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This Software License shall govern the licensing of all software provided to licensee by Bay Networks
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4. Licensee may modify Software (but not firmware), or combine it with other software, subject to the
provision that those portions of the resulting software which incorporate Software are subject to the
restrictions of this license. Licensee shall not make the resulting software available for use by any third
party.

5. Neither title nor ownership to Software passes to licensee.

6. Licensee shall not provide, or otherwise make available, any Software, in whole or in part, in any form, to
any third party. Third parties do not include consultants, subcontractors, or agents of licensee who have
licensee’s permission to use the Software at licensee’s facility, and who have agreed in writing to use the
Software only in accordance with the restrictions of this license.
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7.

10.

11.

12.

Third-party owners from whom Bay Networks has acquired license rights to software that is incorporated
into Bay Networks products shall have the right to enforce the provisions of this license against licensee.

Licensee shall not remove or obscure any copyright, patent, trademark, trade secret, or similar intellectual
property or restricted rights notice within or affixed to any Software and shall reproduce and affix such
notice on any backup copy of Software or copies of software resulting from modification or combination
performed by licensee as permitted by this license.

Licensee shall not reverse assemble, reverse compile, or in any way reverse engineer the Software. [Note:
For licensees in the European Community, the Software Directive dated 14 May 1991 (as may be
amended from time to time) shall apply for interoperability purposes. Licensee must notify Bay Networks
in writing of any such intended examination of the Software and Bay Networks may provide review and
assistance.]

Notwithstanding any foregoing terms to the contrary, if licensee licenses the Bay Networks product “Site
Manager,” licensee may duplicate and install the Site Manager product as specified in the Documentation.
This right is granted solely as necessary for use of Site Manager on hardware installed with licensee’s
network.

This license will automatically terminate upon improper handling of Software, such as by disclosure, or
Bay Networks may terminate this license by written notice to licensee if licensee fails to comply with any
of the material provisions of this license and fails to cure such failure within thirty (30) days after the
receipt of written notice from Bay Networks. Upon termination of this license, licensee shall discontinue
all use of the Software and return the Software and Documentation, including all copies, to Bay Networks.

Licensee’s obligations under this license shall survive expiration or termination of this license.
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About This Guide

This guide describes how to customize a Wellfleet® router software
image using a tool called the Image Builder. You access the Image
Builder via the Wellfleet Site Manager.

You need to use this guide when you receive router software from Bay
Networks and you want to do the following:

g Remove nonessential executable files from the router software
image (or add executable files that you inadvertently removed).

a Reduce the size of a router software image so that it fits on a single
diskette (if you received the image on more than one diskette).




Before You Begin

Before You Begin

Before you use this guide, you must load the Wellfleet Site Manager
application using the instructions provided in Quick-Starting Wellfleet

Routers.

How to Get Help

For additional information or advice, contact the Bay Networks Help

Desk in your area:
United States
Valbonne, France
Sydney, Australia
Tokyo, Japan

Conventions

angle brackets (< >)

arrow character (=)
user entry text

command text

italic text

quotation marks (“”)

1-800-2LAN-WAN
(33) 92-966-968
(61) 2-903-5800
(81) 3-328-0052

Indicate that you choose the text to enter based on
the description inside the brackets. Do not type the
brackets when entering the command. Example: if
command syntax is ping <ip_address>, you enter
ping 192.32.10.12

Separates menu and option names in instructions.
Example: Protocols>AppleTalk identifies the
AppleTalk option in the Protocols menu.

Denotes text that you need to enter. Example: Start
up the Windows environment by entering the
following after the prompt: win

Denotes command names in text. Example: Use the
xmodem command.

Indicates variable values in command syntax
descriptions, new terms, file and directory names,
and book titles.

Indicate the title of a chapter or section within a
book.




About This Guide

Acronyms
ASCII American Standard Code for Information
Interchange
DOS Disk Operating System
PCMCIA Personal Computer Memory Card International
Association

Xi






Chapter 1
Image Builder Overview

Refer to this chapter for information on the following topics:
a  Overview of Router Software Images

a  Using the Image Builder to Modify Router Software Images
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Overview of Router Software Images

Overview of Router Software Images

A router software image is a group of executable files that operate the
protocols on your network with a Wellfleet router. The type of software
image a router uses depends on the particular Wellfleet router.

Table 1-1 shows the router software images for the current router
software. If you are using an earlier version of Wellfleet router
software, refer to the appropriate version of this manual for details of

router software images.

Table 1-1.  Router Software Image Types

Router Router Software | Device that Image
Image Runs On

AFN (Flash) afn.exe Flash card

IN in.exe Flash card

ASN asn.exe Flash card

BLN bn.exe Flash card

BCN bn.exe Flash card

AN an.exe Flash Single
Inline Memory
Modules (SIMMs)

CN, FN, LN (VME) | ace.out Flash card

Appendix A lists all of the executable files that are available from Bay

Networks.
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Image Builder Overview

You can modify a router software image as follows:

m}

o

Remove a protocol that you do not use. For example, you might
want to remove protocols to make more space available on the
medium that contains the router software image.

Add a protocol that you removed inadvertently.

Consolidate the software image. Sometimes Bay Networks supplies
the software image on two diskettes. You might want to consolidate
the two parts into one image.

Replace an existing image with an entirely new one.

To perform these tasks, you use the Image Builder, as the following
section describes.

Using the Image Builder to Modify Router Software Images

The Image Builder tool lets you customize the router software images
that you receive from Bay Networks. You access the Image Builder
from the Tools menu in the main Site Manager window.

To customize a router software image, you must do the following:

1.

Order the new router software from Bay Networks. This software
comes on CD-ROM or on 3 1/2-inch MS-DOS diskettes.

Load the router software onto the local hard drive of your UNIX®
workstation or PC (refer to Chapter 2).

Load the router software into the Image Builder (refer to Chapter
2).

Remove or add executable files as necessary.
Save the customized software image.

Load the customized router software image onto the router’s file
system. You can use the Router Files Manager tool to remotely
transfer the image to the router (refer to Chapter 4).
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Using the Image Builder to Modify Router Software Images

Note: Be sure that you use only executable files from the same router

7.

software version. For example, you cannot mix files from
Version 8.00 with files from Version 8.10.

Boot the router using the customized software image.

In addition to modifying a router software image by removing or
adding executable files, you can use the Image Builder to do the
following:

m)

View information about the components that appear in the Image
Builder window. The Image Builder displays a router software
image as a list of individual components. You can view information
about the components such as

— component name and model number

— router software version

— compressed size of file(s)

— uncompressed size of file(s)

Display all the files that make up a list of components.

Convert an image you created to an equivalent image for a different
type of router (refer to “Converting an Image for Other Types of
Routers” in Chapter 3).

Convert an image you created to an equivalent image for a different
software version (refer to “Converting an Image for Other Software
Versions” in Chapter 3).

Create an entirely new router software image. For example, you
might want to make an entirely new image from several custom
images that you created.
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Chapter 2
Loading Router Software

Refer to this chapter for information on the following topics:
0 Loading Router Software onto a PC or UNIX Workstation

0 Loading Router Software into the Image Builder
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Loading Router Software onto a PC or UNIX Workstation

Loading Router Software onto a PC or UNIX Workstation

Router software is available on the following media:
a MS-DOS diskettes
o CD-ROM

The following sections present information on how to load the Wellfleet
router software.

Loading the Software from MS-DOS Diskettes

Follow these steps to load the router software from MS-DOS diskettes
onto the PC that serves as the Site Manager workstation:

1. Enter the following command to create the directory in which to
store the new router software on the Site Manager workstation:

mkdir \wf\xxx

where xxx is the version of the router software.

Example
For version 8.10, you would type
mkdir \wf\810

2. Insert the first diskette into the diskette drive of the PC, and enter
the following command:

restore <diskette_drive> <drive>:\wf\xxx\*.*

where diskette_drive is the drive containing the router software
diskette, and drive is the hard drive where you created the
directory in which to store the router software.

The operating system extracts the files to the subdirectory you
created in Step 1, and prompts you for the next diskette.

3. Insert the next router software diskette (when prompted), and
press any key to continue.

4. Repeat Step 3 for the remaining diskettes.
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Loading Router Software

5. Start up Site Manager. For instructions, refer to Using Site
Manager Software.

6. You can now load the router software into the Image Builder, as
described in “Loading Router Software into the Image Builder.”

Loading the Software from CD-ROM

PC

The steps that you follow to load the router software from CD depend
on whether you use a PC or a UNIX workstation. The next section
describes how to load the software on a PC. If you use a UNIX
workstation, proceed to the section “UNIX Workstation.”

To load the router software from CD to your PC, follow these steps:
1. Insert the CD into your CD-ROM drive.

2. Bring up Windows.

3. Double-click on the File Manager icon.

4. Click on the CD-ROM drive icon in the File Manager window.

5

Click on the rtr_xxx directory, where xxx is the router software
version. For example, for version 8.10, you would click on the
rtr_810 directory.

You see the following directories in the rir_xxx directory.

afnflash
an

asn

bn

in

vme

6. Click on the directory for the router platform you want.
7. Select File=>Copy.
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Loading Router Software onto a PC or UNIX Workstation

8. Specify the destination directory as follows:
\wif\xxx

where xxx is the version of the router software.

Example
For Version 8.10, you would type
\wf\810

9. Click on OK.

The system then loads the router software for the platform you
selected. When the process is complete, you can load the router
software for any of the other platforms by repeating Steps 6
through 9.

UNIX Workstation

To load the router software from CD to your UNIX workstation, follow
these steps:

1. Insert the CD into your CD-ROM drive.

2. If you have not already created a CD-ROM mountpoint, log in as
root and create a root-level directory.

Example
To create a directory named cdrom, enter
mkdir /cdrom
3. Mount the CD-ROM drive.
a. Ifyou use SunOS on a SPARCstation™ , enter
mount -r -t hsfs /dev/<device> /cdrom
b. If you use Solaris® on a SPARCstation, enter

mount -F hsfs -0 ro /dev/<device> /edrom
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Loading Router Software

Note:

d.

If you use Solaris and you are running the vold daemon, the
CD-ROM will automatically be mounted as /cdrom/
release_xxx_yyy (where xxx is the router software version and
yyy is the Site Manager version), rather than /edrom. For
example, for router software Version 8.10 and Site Manager
Version 2.10, the CD-ROM will automatically be mounted as
/edrom/release_810_210.

If you use an IBM RS/6000, enter
mount -0 ro -v cdrfs /dev/<device> /cdrom
If you use an HP® 9000, enter

mount -r /dev/<device> /ecdrom

4. Change directories by entering

cd /edrom

5. Run the script to load the router software using one of the following
procedures:

a.

On a SPARCstation, enter
JCOPY.SH

On an HP 9000, enter
JCOPY.SH\;1

On an IBM RS/6000, enter
Jcopy.sh

During the load procedure, you must specify the following:

a The directory where you want to load the router software
a The router platform (AFNFLASH, AN, ASN, BN, IN, or VME)

The system then loads the software for the platform(s) you select.
When the process is complete, you can choose to load the router
software for another platform, or you can quit.
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Loading Router Software into the Image Builder

Loading Router Software into the Image Builder

To load the router software into the Image Builder, follow these steps:
1. Select File»Open from the Image Builder window.

The Open window appears (Figure 2-1).

@ohen @
Filter
[ 1der_dir/, |

Directories Files
i/, |

ir/..

s B -
Selection
[/ extra/smgr/builder_dir/ }

| 0K |||Filter| |Cancell

Figure 2-1. Open Window

2. Select the directory and filename of the router software image that
you want to open. Then click on OK.

The directory and filename that you specify depends on the
following:

0 The computer platform (UNIX workstation or PC)

0 The router platform
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Loading Router Software

If you loaded the router software from CD onto a UNIX
workstation, the system stored the image in the directory for the
appropriate router platform. For example, you would find the
image ace.out for the VME platform in the vme directory.

If you loaded the router software on a PC, the system stored the
router software image in the directory you created for the router
software (\wf\xxx).

Once you enter the pathname of the image, the Image Builder
window lists the current components of the image (Figure 2-2).

[® Image Builder
File Edit View Options Help

 Filename:  ace, out
Archive Format: WME Format (ACE, OUT)
Release: rel/ X.XX
Compressed Size: 1,622,144 El. 55["1}

Uncompressed Size: 2,628,128 (2,514
Available Components Current Components
[ 4001x Baseline Router Softwar

4x000 OSPF Router Software
4x001 EGP Router Software
43002 BGP Router Software
43003 IBM Services Router Sof
43004 DECnet Phase IV Router
4x005 ENS Router Software
4x006 Novell IPX Router Softw
4x007 Appletalk Phase 2 Route

¥ 43008 051 Router Software
| ———— ]
U Details {1 Details

Component Information

Figure 2-2. Image Builder Window with Current Components

You can now modify the router software image. For instructions, refer
to “Modifying a Router Software Image” in Chapter 3.
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Chapter 3
How to Use the Image Builder

Refer to this chapter for information on the following tasks:
Modifying a Router Software Image

Saving a Modified Image

Creating a New Image

Converting an Image for Other Types of Routers

Converting an Image for Other Software Versions

o o o o a

Generating a List of Contents for an Image

For specific information about using the windows, buttons, and other
features of Site Manager, refer to Using Site Manager Software; for
information about the Image Builder, refer to Chapter 1.
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Modifying a Router Software Image

Modifying a Router Software Image

When you load your router software image into the Image Builder
(refer to Chapter 2), you see the router software you loaded in the

Current Components list of the Image Builder window (Figure 3-1).

[®] Image Builder i
File Edit View Options Help
. Filename:  ace, out
Archive Format: WME Format (ACE, OUT)
Release: rel/ X.XX
Compressed Size: 1,622,144 E1.55M
Uncompressed Size: 2,628,128 (2,51M

Available Components

B — >

{1 Details

Component Information

— — — — — JI&

Current Components

v

4001x Baseline Router Softwar
4x000 OSPF Router Software
4x001 EGP Router Software
4x002 BGP Router Software
4x003 IBM Services Router Sof
4x004 DECnet Phase IV Router
4x005 XNS Router Software
4x006 Novell IPX Router Softw
43007 8ppletalk Phase 2 Route
4x008 0SI Router Software

- S————— *

0 Details

Figure 3-1. Image Builder Window with Current Components

You can modify the router software image as follows:

o Remove nonessential files from the Current Components list. For

)

example, you might want to make more space available on the
router software medium.

Add components to the Current Components list. For example, you
might have removed files that you decide you want in the router

software image.




How to Use the Image Builder

The following sections describe the Image Builder features that let you
remove and add software components. Refer to the section “Analyzing
Components” to determine which executable files you need in a
software image and how you can track changes.

Removing Software Components

To remove components from the Current Components list, follow these
steps:

1. Double-click on the item in the Current Components list that you
want to remove.

The Remove button appears in the Image Builder window (Figure
3-2).

Note: The Remove button does not appear when you select essential
files. This protects the most important files that make up your
router software image. For example, you cannot remove the
Operating System Kernel file from the Baseline Router
Software component. Also, because the Baseline Router
Software component contains essential files, you cannot remove
it from the list of current components.




Modifying a Router Software Image

[® Image Builder
File Edit WView Options Help
. Filename: ace, out
Archive Format: VME Format (ACE, OUT)
Release: rel/X.XX

Compressed Size: 1,622,144 El. 55[“13

Uncompressed Size: 2,628,128 (2,51
Available Components Current Components

| 4001x Baseline Router Softwar

4x000 OSPF Router Software
4x001 EGP Router Software

4x002 BGP Router Software

4002 TRY Services Router Sof
4z004 DECnet Phase IV Router
4x005 XNS Router Software

43006 Novell IPX Router Softw
4x007 &ppletalk Phase 2 Route

v 4x008 0SI Router Software
P — r P — »
{1 Details 1 Details

Component. Information

Component: 4x003 IBM Services Router Software
Release: rel/7.60
Compressed Size: 115,808 E113K;

155K,

ncompressed Size: 159, 096

Figure 3-2. Remove Button

2. Click on the Remove button.

The Image Builder removes the component from the Current
Components list and adds it to the Available Components list.

You can also select Edit?Remove Component in the Image Builder
window. You can remove all components from the Current Components
list by selecting Edit>Remove All Components. You do not need to
select all the components before you choose this option.

The Edit menu in the Image Builder window also offers Undo and
Redo commands that let you cancel your last action or redo your last
cancelled action.
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How to Use the Image Builder

Adding Software Components

As mentioned in the previous section, when you remove a component
from the Current Components list, the Image Builder adds it to the
Available Components list. If you decide you want to keep that
component in the router software image, you must add it to the
Current Components list. To do so, follow these steps:

1. Double-click on the item in the Available Components list that you

want to add to the current comp

onents.

The Add button appears in the Image Builder window (Figure 3-3).

[®] Inage Builder i
File Edit View Options Help
. Filename: ace, out (EDITED)
rchive Format: WE Format (ACE,OUT)
Release: rel/X.XX
Compressed Size: 1,166,632 El.llmg
Uncompressed Size: 1,987,648 (1, 90M

Available Components

Current Components

4x000 OSPF Router Software
43001 EGP Router Software
4x002 BGP Router Software
43003 IBM Services Router Sof
4x005 ENS Router Software
Sppletalk Phase 2 Routel

B addyy |

43009 Banyan VINES Router Sof
43012 ATM Router Software
4x013 X, 25 Router Software

4001x Baseline Router Softwar
4x004 DECnet Phase IV Router

43006 Novell IPX Router Softw
43008 0SI Router Software

4x014 Frame Relay Router Soft

¥

< ——— ]
{1 Details

Component Information

Release: rel/7, 60
Compressed Size: bl,329 E50Rg
compressed Size: 73,184 (71K

Component: 4x007 Appletalk Phase 2 Router Software

- S——————

{1 Details

Figure 3-3. Add Button
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2. Click on the Add button.

The component moves from the Available Components list to the
Current Components list.

You can also add components by selecting Edit>Add from the Image
Builder window. To add all components that appear in the Available
Components list, select Edit>Add All Components. You do not need to
select all the components before you choose this option.

Note: In the sample Image Builder window (Figure 3-3), the word
EDITED appears in parentheses beside the ace.out filename.
EDITED appears whenever you load a previously modified file
into the Image Builder.

Analyzing Components

The Image Builder window provides several features that you can use
to determine the files you need in a software image and to track
changes. These features include the following:

o A Component Information box that gives details about a selected
component

0 A special symbol (an asterisk) that identifies components from
which you removed a file

a A Details button that you can use to display all the files that make
up a list of components

The following sections provide information on these features.
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Component Information Box

The bottom of the Image Builder window contains a Component
Information box (Figure 3-4). When you select a component from the
Available Components or Current Components list, the following
information appears in the Component Information box:

)

)
a
a

Model number and name of component
Router software version
Compressed size of file(s)

Uncompressed size of file(s)

Component Information

I Component : 43{007}(&1));()%{(3‘5&111« Phase 2 Router Software
G

Te .
onpressed Size: 51,329 5501(3
ncompressed Size: 73,184

Release:

T1K,

Figure 3-4. Component Information Box in the Image Builder Window

Partial Component Asterisk

The Image Builder uses an asterisk (*) to denote a partial component
(Figure 3-5). The asterisk indicates that you removed a file from a
component, and, as a result, both the file and the component are now
partial in nature.




Modifying a Router

Software Image

Details Buttons

A Details button appears below each list of components. You can click
on the Details button to display all the executable files that make up a

[®] Image Builder
File [Edit View Options Help
. Falename: ace,out (EDITED)
Archive Format: WME Format (ACE, OUT)
Release: rel/X.XX
Compressed Size: 1,212,339 El. lSMg
Uncompressed Size: 2, 049,288 (1, 90M

Available Components

Current Components

Component Information

Component :
Release
Compressed Size
ncompressed Size

#4001 Bazeline Router Softwar ¥ Raseline Router Softwar
dmap. exe YME Backplane D demp, out Decompressor Pr
43000 OSPF Router Software krnl_ace, exe Operating Syste
ospf, exe OSPF Protocol & ds2180,exe  MK2180 Dual Syn
43001 EGP Router Software ds218l,exe  MK2181 Dual Syn
62D, eX6 EGP Protocol &p ilace, exe ILACC Ethernet
43002 BGP Router Software lance,exe  LANCE Ethernet
bgp. exe BGP Protocol #p tms380, exe  TMS380 Token Ri
4x003 IBM Services Router Sof hwe, exe Hardware Filter
1lc, exe LLC Protocol p dsde?, exe Dual Sync/Ether
| o—— ] | ———— >
B Details B Details

srel/ X. XX
+ 989, 059 (96BK)
1,738,580 (1, 66M)

#4001z Baseline Router Software

‘% meang Partial Component

Figure 3-5. Partial Components

list of components. To return to the list of components, click on the
Details button again.

For example, suppose you click on the Details button for current
components. All the components in that list open to reveal the

executable files that make up those components (Figure 3-6). Most

protocol components contain only one software file. The Baseline
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Router Software component, however, contains many files, including
the Operating System Kernel.

[®] Inage Builder 1]
File Edit View Options Help

. Filename: ace,out (EDITED)
Brchive Format: WME Format (ACE.OUT)
Release: rel/ X.XX
Compressed Size: 1,217,961 El.lGM}

Uncompressed Size: 2,060,832 (1, 97M
Available Components Current Components
DeEF Router Software - 40ily Baseline Router Soffwar
ospf, exe OSPF Protocol A dcmp, out Decompressor Pr
4x001 EGP Router Software krnl_ace, exe Operating Syste
egp. exe EGP Protocol &p dmap, exe WE Backplane D
4x002 BGP Router Software ds2180.exe  MK2180 Dual Syn
bgp. exe BGP Protocol &p ds218l,exe  MK2181 Dual Syn
4x003 IBM Services Router Sof 1lacc.exe  ILACC Ethernet
1lc. exe LLC Protocol &p lance, exe LANCE Ethernet
dle. exe DLS Protocol Ap tms380,exe  TMS380 Token Ri
1ss, exe LSS Protocol 4pif® hwf, exe Hardware Filter
— = : -

M Details
Component Information

Component.: 4001x Baseline Router Software
. Release: rel/

: rel/ X. XX
ompressed Size: 994,681 (971K)
ncompressed Size: 1,750,124 (1, 67M)

Figure 3-6. Details Buttons

You can also use the options on the View menu to display details about
a list of components.
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Saving a Modified Image

The Image Builder automatically archives router software images in a
directory created during the Site Manager installation process. The
directory is $HOME / .builder_dir. (Refer to Quick-Starting Wellfleet
Routers for information on creating the $HOME / .builder_dir
directory.) The Image Builder archives only individual components in
this directory. We recommend that you archive new router software
images in a different directory. You should also use different image
names for different routers on your network, and keep a record of
which images are running on which routers.

If you loaded the router software onto your Site Manager workstation
using the procedure in the section “Loading Router Software into the
Image Builder” in Chapter 2, you may want to use the directory you
created during that procedure for archiving the image.

1. After you modify a list of current components, select File->Save.

This saves the image to your current directory and archives all
components displayed in the Image Builder window in the Image
Builder directory.

Note: A confirmation window does not appear after you select
File>Save, so make sure you compiled your list correctly before
you select this option.

2. 'To archive an image, select File»Save As from the Image Builder
window.

The Save As window appears (Figure 3-7).
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Save As

Filter

JwE [*

Directories Files

/fwt/. imgbn509
fwE/ ..

Selection

| /s /%

Figure 3-7. Save As Window

3. Select a directory for archiving images and type a filename in the

Selection field. Then click on OK.

Information about the new image replaces the information about
the image you loaded into the Image Builder. The updated
information appears in a box at the top of the Image Builder
window (Figure 3-8). If you are putting the new image on a
diskette, use the image information to check the size of the image

to make sure that it will fit on the diskette.

Filename:

Release:

. ace, out.
Archive Format: VYME Format (ACE, OUT)
rel/ X. XX

Compressed Size: 1,217, 961
Uncompressed Size: 2, 080,832

Figure 3-8. Image Information Box in the Image Builder Window
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Note: The confirmation window (Figure 3-9) appears if you select
File=Exit without saving your changes.

[@] Site Manager FT]

@ “ace.out” has been modified! Discard changes 9

Cancel

Figure 3-9. Confirmation Window

After you save the new image, refer to Chapter 4 for information on
loading the new image on your router.

Creating a New Image

Creating an entirely new image is usually not necessary. However, the
Image Builder provides the option in case you need it. For example,
you might want to completely reconfigure the router software image or
perform a major upgrade (such as from 7.60 to 8.10). To create a new
image, follow these steps:

1. Select File>New from the Image Builder window.

Note: You will be unable to select the New command unless the router
software files are archived in the Image Builder’s directory
($HOME/ .builder_dir).

The New Image window appears (Figure 3-10).
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[® New Image

To Create & New Image:
1) Select the Image Format,
2) Select the Release Version,
3) Select OK to create the lmage,

Inage Format:

4 BN/BNX Format
< WE Format

Release Version:

rel/X.xXX
rel/Y.YY

E

Ok

Cancel |

Figure 3-10. New Image Window

Note: The image formats that appear in the New Image window are
for router images that you loaded into the Image Builder. For
example, in Figure 3-10, only the BN/BNX and VME formats
appear in the New Image Window. In this case, only the router
software images for the BN and VME platforms were loaded
into the Image Builder. Refer to “Proceeding if an Image Format
Is Not Available.”

2. Select the appropriate image format; then click on OK.

An empty Image Builder window appears.

You are now ready to build a new image using the router software on
your workstation. Refer to Chapter 2 for information on loading router
software into the Image Builder.
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Converting an Image for Other Types of Routers

Note:

You can only use this feature to convert to image formats that
you previously loaded into the Image Builder.

If you want to run the same image on different types of Wellfleet
routers in a network, you can create an image for one type of router
and convert the image to run on other types of routers. For example,
you might want to run the same protocols on AN™ and BN™ routers
in a network. You can customize an image for the BN routers and then
convert that image to run on the AN routers.

To convert an image to run on a different type of router:

1. Select File®»Change Format in the Image Builder window.

A list of image formats appears. The possible image formats are

a

o o o o o o

AFN

AN

ASN

BN

IN

VME

One board (AFN Flash for software versions earlier than 8.10)

If the image format you want is gray, you have not loaded that
image into the Image Builder. Refer to “Proceeding if an Image
Format Is Not Available.”

2. Select a format from the list.

The image changes to the format you selected.

3. Save the modified image (refer to “Saving a Modified Image”).
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Proceeding if an Image Format Is Not Available

If you cannot choose the image format you want when you try to create
a new image or convert an image for another type of router, you need to
load the image for that format into the Image Builder.

To load the image:

1. Check that the software image for the format (refer to Table 1-1)
appears in the directory where you loaded the router software.

a. Ifthe image does appear in that directory, load the files into the
Image Builder (refer to “Loading Router Software into the
Image Builder” in Chapter 2).

b. If the image does not appear in the directory where you loaded
the router software, you must load the image onto your
workstation (refer to “Loading Router Software onto a PC or
UNIX Workstation” in Chapter 2) and then load the image in
the Image Builder.

2. Repeat the procedure for creating a new image or converting an
image for another type of router.

Converting an Image for Other Software Versions

Note: You can only use this feature to convert to software versions
that you previously loaded into the Image Builder.

In a network, you may have Wellfleet routers that use different
versions of Wellfleet software. If you want to run the same image on
those routers, you can create an image for a router running one
software version and convert the image for routers running other
software versions. For example, you might want to run the same image
on routers running Version 7.60 software and routers running Version
8.10 software. You can create an image with Version 8.10 files, and
convert the image to use Version 7.60 files.
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To convert an image to a different software version:

1.

3.

Select File®»Change Release.

A list of software versions appears. If you cannot select the version
you want, you need to load that version into the Image Builder.
Refer to “Proceeding if a Software Version Is Not Available.”

Select a version from the list.
The image changes to the software version you selected.

Save the modified image (refer to “Saving a Modified Image”).

Proceeding if a Software Version Is Not Available

If you cannot choose the software version you want when you try to
convert an image for another software version, you need to load the
image with the appropriate format and software release into the Image
Builder.

To load the image:

1.

Check that the software image for the relevant format (refer to
“Overview of Router Software Images” in Chapter 1) appears in the
directory where you loaded the appropriate version of the router
software. For example, if you want to convert an image for an AN
router to software Version 8.10, check that the AN router software
image appears in the directory where you loaded the Version 8.10
software.

a. Ifthe image does appear in that directory, load the files into the
Image Builder (refer to “Loading Router Software into the
Image Builder” in Chapter 2).
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b. If the image does not appear in the directory where you loaded
the router software, you must load the image onto your
workstation (refer to “Loading Router Software onto a PC or
UNIX Workstation” in Chapter 2) and then load the image in
the Image Builder.

2. Repeat the procedure for converting an image for another software
version.

Generating a List of Contents for an Image

You can save to an ASCII file the contents of the Current Components
list in the Image Builder window. To do so, select Options->Generate
CONTENTS.TXT. (By default, the option is already selected.)

When you save an image by selecting File>Save or File>Save As, an
ASCII file named CONTENTS.TXT is created and saved to the same
directory you specified for the image.

The CONTENTS.TXT file lists all the model numbers, components,
filenames, and descriptions shown in the Current Components window.
Figure 3-11 shows a portion of a sample CONTENTS.TXT file.

Note: If you do not specify a directory, by default your image and
CONTENTS.TXT file are saved to the Image Builder's
directory.
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Image File: /extra/smgr/has/image
Created on: Wed Jan 4 16:40:04 1995
Archive Format: VME Format
Release: int/8.10/40
File Size: 2,273,875 (2.17M)

CONTENTS

*4001x Baseline Router Software
dcmp.out Decompressor Program
krnl_ace.exe Operating System Kernel
dmap.exe VME Backplane DMA Processor Driver
arp.exe  ARP Protocol Application
debug.exe DEBUG Protocol Application
ds2180.exe  MK2180 Dual Sync Interface Driver
ds2181.exe  MK2181 Dual Sync Interface Driver
dsde2.exe Dual Sync/Ethernet2 Link Module Driver
dst.exe  Dual Sync Token Link Module Driver
dtok.exe  Dual Token Ring Link Module Driver
dvmrp.exe DVMRP Multicast Protocol Application
el.exe E1 Link Module Driver
enet2.exe Ethernet2 Link Module Driver
fddi.exe  FDDI Link Module Driver
fsiiexe  FDDI SMT Driver
ftp.exe  FTP Protocol Application
hdic.exe HDLC Protocol Application
hfsi.exe HSSI SMT Driver
hssi.exe  HSSI Link Module Driver
hwf.exe = Hardware Filter Driver
igmp.exe  IGMP Multicast Protocol Application
ilacc.exe ILACC Ethernet Interface Driver
ip.exe IP Protocol Application
lance.exe LANCE Ethernet Interface Driver
Im.exe Line Manager Protocol Application
mctiel.exe Multi-Channel T1E1 Link Module Driver
munich.exe Munich Multi-Channel T1E1 Driver
nbip.exe  NetBIOS/IP Protocol Application
pcap.exe Packet Capture Procotol Application
ping.exe  Ping Protocol Application
ppp.exe  PPP Protocol Application

Figure 3-11. CONTENTS.TXT File
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Chapter 4

Loading the Modified Image on a Router

Read this chapter for information on the following topics:

]

)
a
a

Connecting to a Wellfleet Router

Loading a Modified Image on the Router’s File System
Booting the Router with a Modified Image

Verifying that the Router Booted Successfully
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Connecting to a Wellfleet Router

You must specify the router(s) onto which you will load the modified
router software image. You can load an image onto more than one
router at a time.

1. From the Wellfleet Site Manager window, select Options=>Router
Connection.

The Router Connection Options window appears (Figure 4-1).

[®] Router Comnection Options

Node Name/IP Address 2, 32, 156, 68
Identity (Community)

Timeout (seconds) M

Retries (per request) M

Cancel

Figure 4-1. Router Connection Options Window

2. In the Node Name/IP Address field, type the IP address of the
Wellfleet router you want. Then click on OK.

Note: You do not need to change the default values that appear in the
Identity, Timeout, and Retries fields.

Information on the router you specified appears in the Wellfleet
Site Manager window (Figure 4-2).
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[@® Wellfleet Site Manager
File View Options Tools Administration Help
iConnectionl iStatistich ; Traps J f Events I f Files

Well-Known Connections
192, 22, 1e, 107 1o
192,32,18,103  Down

System Name/IP Address: 192,32, 18,107
SNMP ID (Community) : public

R

System Name:

nn

Contact:

ny

Location:
Description: "Image: int/8,10/30 Created on Wed Nov 23 13:06:00
EST 1994,”

MIB Version: %8, 10

Model: Backbone Concentrator Node (BCI)
Power Supply 1: On Line

Power Supply 2: On Line

Power Supply 3: On Line

Power Supply 4: On Line

Fan: On Line

Temperature: Normal

Figure 4-2. Wellfleet Site Manager Window
3. If you want to load the image onto only one router, refer to the next
section.

If you want to load the image onto more than one router, repeat
Steps 1 and 2 for each router.

4. Select Options> Multiple Router Setup. The Multiple Router
Connection window appears (Figure 4-3).
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[@] Multiple Router Connection

Default Routers Current Routers
192, 32, 156, 66
192, 32, 156, 65

192, 32, 156, 68 - Add )

Figure 4-3. Multiple Router Connection Window

The Default Routers window lists the routers to which you are
currently connected. The Current Routers window lists the routers
whose files you want to manage simultaneously.

5. In the Default Routers list, select each router to which you want to

transfer the same image at the same time. Then click on Add. The
selected routers appear in the Current Routers list (Figure 4-4).
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[®] Multiple Router Connection 2|
Default Routers Current Routers
192, 32, 156, 66 192, 32, 156, 66
192, 32, 156, 65 192, 32, 156, 65
192, 32, 156, 68 add 3
[+ [+

Figure 4-4. Adding Routers to the Current Routers List

If you inadvertently add a router to the Current Routers list, you
can remove it from that list. To do so, select the router (in the
Current Routers list) and click on Remove.

6. Click on Save.
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Loading a Modified Image on the Router’s File System

Use the Router Files Manager tool to load an image onto the router’s
file system. To access this tool, select Tools=>Router Files Manager in
the Wellfleet Site Manager window.

The Router Files Manager window appears.

o If space is available, you should keep the old router software image
on the router’s file system until you succeed in booting the router
using the new image. In this case, refer to the next section, “If
Space Is Available.”

0 If space is not available, refer to “If Space Is Not Available.”

If Space Is Available

If space is available, use the Router Files Manager to save the new
image to the router’s file system:

1. In the Router Files Manager window, select the router volume
where you want the image saved.

2. Select File=>TFTP->Put File(s).
The TFTP Put File Selection window appears (Figure 4-5).
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[®] TFTP Put File Selection

Path: l lextra/smer

Files: Files To Put:

oo
Login

. xinitre

. wastebasket

. Rdefaults

. OPENWIN-sm

. Rauthority

. desksetdefaults
. openwin-init

. openwin-menu
.wicfginit ¥

Multiple Routers:

Figure 4-5. TFTP Put File Selection Window

3. In the Path box, enter the pathname of the directory on the Site
Manager workstation that contains the image.

The files in that directory appear in the Files window.

4. In the Files window, click on the image filename; then click on Add.
The selected file appears in the Files to Put window.

If you inadvertently add files that you do not want to transfer to the
router, select those files in the Files to Put window. Then click on
Remove.

5. If you selected multiple routers (refer to “Connecting to a Wellfleet
Router”) and you want to transfer the image to all of the routers
you selected, click on Yes in the Multiple Routers field.
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If you selected only one router, or if you do not want to transfer the
image to all of the routers you set up in the Multiple Router Setup
window, click on No in the Multiple Routers field. In this case, if
you previously set up multiple routers, the Router Files Manager
transfers the image only to the router to which you are currently
connected.

6. Click on OK.

When the transfer (to each of the routers) is complete, the TFTP
Put File Selection window closes and you return to the Router Files
Manager window.

7. Refer to the section “Booting the Router with a Modified Image.”

If Space Is Not Available

If space is not available on the router’s file system, use the Router Files
Manager to remove the old image from the router’s file system before
you save the new image there. The following sections provide
information on how to remove the old image and save the new image.

Removing the Old Image from the Router

To remove the old router software image, proceed as follows:

1. From the Router Files Manager window, select the router volume
and filename of the old software image.

2. Select FileTFTP->Get File(s).
The TFTP Get Files window appears (Figure 4-6).
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[® TFTP Get Files
Proceed with TFTP Get of file(s) ?
ACE, 0UT
v

B — ] >
Destination Directory:
|Hextra/smgr f

Ves

Figure 4-6. TFTP Get File Window

3. In the Destination Directory field, enter the directory on your Site
Manager workstation where you want to store the file.
4. Click on Yes to proceed.

The Router Files Manager transfers the image to the Site Manager
workstation.

If a file with the same name already exists in the destination
directory on the Site Manager workstation, the file you are
“getting” replaces it.

5. Remove the copy of the old image still residing on the router’s file
system. To do so, select the file in the Router Files Manager
window. Then select Commands->Delete.

A window prompts you to confirm your delete request.
6. Click on Yes to delete the file.
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Note: If the old router software image resided on a memory card in
the router, select Commands->Compact after you remove the
old image to reformat the memory card. Compacting typically
takes several minutes.

Saving the Modified Image to the Router
To save the modified image to the router,

1. Follow the directions in “If Space Is Available.”
2. Proceed to the section “Booting the Router with a Modified Image.”

Booting the Router with a Modified Image

1. From the Wellfleet Site Manager window, select
Administration>Boot Router.

The Boot Router window appears (Figure 4-7).

[®] Boot Router ]|
Cancel
Boot Tmage: | ace, out 7

Configuration: | config §

Figure 4-7. Boot Router Window

2. Specify the correct router volume and type the name of the new
router software image. Then specify the configuration file you want
to boot from, and click on Boot.

A confirmation window appears (Figure 4-8).
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[@] Site Manager

@ Proceed with "boot A:ace.out A:config” ?

Figure 4-8. Boot Confirmation Window

3. Click on OK.

4. Proceed to the next section to verify that the router booted
successfully.

Verifying that the Router Booted Successfully

You should verify that the router booted correctly with the modified
software image. From the Wellfleet Site Manager window, select
View=>Refresh Display.

If Site Manager displays system information (such as the system
name, contact, location, description, and MIB version), then the router
booted successfully.

If you did not remove the old router software image from the router’s
file system, use the directions provided in the section “If Space Is Not
Available” to remove the image.

If Site Manager does not display system information in its main
window, the router did not boot successfully. If possible, load the image
back into the Image Builder and call your local Bay Networks help
desk for further assistance.

If you can no longer access the router with Site Manager, refer to Using
Technician Interface Software for instructions on using the xmodem
command to access the router. Call your local Bay Networks help desk
for further assistance.
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Appendix A
Executable Files

This appendix provides a description of the executable files available

from Bay Networks.

Table A-1.  Executable File Descriptions

Executable Files Descriptions

appn_cp.exe APPN Control Point
appn_ls.exe APPN Link Service
arp.exe ARP Protocol
asn_mod.exe ASN Link Module Driver
at.exe AppleTalk® Protocol
atm.exe ATM Level 2
atm_dxi.exe ATM DXI Protocol

atmalc.exe

ATM Link Module Line Driver

atmalcop.exe

Co-processor code for ATM Link Module

bgp.exe

BGP

chipcom.exe

Chipcom® INs Module Driver

dcmp.exe

Decompression Code

continued on the next page




Table A-1. Executable File Descriptions (continued)

Executable Files Descriptions

debug.exe Debug Protocol

dls.exe DLSw Protocol

dmap.exe Direct Memory Access Processor
drs.exe DECnet™ IV Protocol

ds2180.exe T1 Framer Driver

ds2181.exe E1 Framer Driver

dsde2.exe Dual Sync Dual Ethernet Link Module
dst.exe Dual Sync Token Ring Link Module
dtok.exe Dual Token Ring Link Module
el.exe E1 Link Module

efddi.exe Fibermux INs Module Driver
egp.exe EGP Protocol

enet2.exe Ethernet2 Link Module Driver
fddi.exe FDDI Driver

fmpb.exe FastMac Plus (Quad Token Ring)
fr.exe Frame Relay Protocol

fsi.exe FDDI Link Module

ftp.exe FTP Protocol

hdlc.exe SYNC Driver

hfsi.exe HSSI Link Module

hilance.exe Hilance Ethernet Interface Driver
hls_in.exe Hughes INs Module Driver

continued on the next page
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Table A-1.  Executable File Descriptions (continued)

Executable Files Descriptions

hssi.exe HSSI Driver

hwf.exe Hardware Filters

igmp.exe IGMP Multicast Protocol

ilacc.exe ILACC Driver

ip.exe Internet Protocol

ipx.exe Internet Packet Exchange Protocol
isac.exe ISAC Protocol

isdn.exe ISDN Protocol

krnl_ace.exe

Advanced Communications Engine Kernel

krnl_an.exe

Access Node Kernel

krnl_asn.exe

Access Stack Node Kernel

krnl_bn.exe Fast Routing Engine Kernel

krnl_in.exe Integrated Node Kernel

lance.exe LANCE Driver

lapb.exe LAPB Protocol

llc.exe LLC Protocol

Im.exe Line Manager Protocol

Inm.exe LNM Protocol

mctlel.exe Multi-Channel T1E1 Link Module Driver

munich.exe

Munich Multi-Channel T1E1 Interface
Driver

nbase.exe

APPN/SDLC Support Environment

continued on the next page
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Table A-1. Executable File Descriptions (continued)
Executable Files Descriptions
nbip.exe NetBIOS/IP Protocol
netboot.exe NETBOOT Decompression
osi.exe OSI Protocol
ospf.exe OSPF Protocol
pcap.exe Packet Capture
ping.exe Ping Protocol
PpPp.exe Point-to-Point Protocol
genet.exe QUAD Ethernet Link Module
gsync.exe QUAD Sync Link Module

quicsync.exe

Quick Sync Link Module Driver

rarp.exe Reverse Address Resolution Protocol
sdlc.exe SDLC Protocol

snmp.exe SNMP Protocol

tl.exe T1 Link Module

tcp.exe Transmission Control Protocol
tftp.exe TFTP Protocol

tms380.exe Token Ring Driver

tn.exe Telnet Protocol

tnc.exe Telnet Client Protocol

vines.exe VINES® Protocol

vmeboot.exe

Upgrade bootstrap for Flash System Con-
troller

continued on the next page




Executable Files

Table A-1. Executable File Descriptions (continued)

Executable Files Descriptions

wan.exe SMDS Protocol

wcp.exe Wellfleet Compression Protocol
x25.exe X.25 Protocol

Xns.exe XNS Protocol
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A

ace.out, 1-2

Add button, 3-5

adding software components, 3-5
afn.exe, 1-2

an.exe, 1-2

analyzing components
component information box, 3-7
Details buttons, 3-8
partial component asterisk, 3-7

asn.exe, 1-2
asterisk, partial component, 3-7
available components, 3-4

B

bn.exe, 1-2

booting with modified image
booting router, 4-10 to 4-11

loading modified image onto file system,

4-6 to 4-10
overview, 4-1
verifying successful boot, 4-11

buttons
Add, 3-5
Details, 3-8
Remove, 3-3

C

commands
xmodem, 4-11

component information box, 3-7
connecting to a router, 4-2
current components, 3-2

D

Details buttons, 3-8

E

Edit menu options, 3-4
executable files, A-1 to A-5

H

hardware formats, 3-13

Image Builder
directory, 3-10

Index

loading router software into, 2-6

overview, 1-1 to 1-4
saving images, 3-10 to 3-12

in.exe, 1-2
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L

loading
modified image onto file system, 4-6 to
4-10
with available space, 4-6 to 4-8
without available space, 4-8 to 4-10
router software into Image Builder, 2-6

modifying router software images
adding software components, 3-5
analyzing components, 3-6 to 3-9
removing software components, 3-3
saving modified images, 3-10 to 3-12

0]

overview of Image Builder, 1-1 to 1-4

P

partial component asterisk, 3-7

PC
loading router software images on
from CD, 2-3
from diskette, 2-2

protocols, A-1 to A-5

R

Redo command, 3-4
Remove button, 3-3
removing software components, 3-3

router files
executable files, A-1 to A-5

Router Files Manager, 1-3

router software images
adding software components, 3-5
analyzing components, 3-6 to 3-9
copying to a PC, 2-2, 2-3
definition of, 1-2
loading
from CD, 2-3
from MS-DOS diskettes, 2-2
into Image Builder, 2-6
onto router, 4-6 to 4-10
removing software components, 3-3
saving, 3-10 to 3-12
types of, 1-2

S

saving modified images, 3-10 to 3-12

Site Manager
booting router, 4-10 to 4-11

T

Technician Interface, 4-11

U

Undo command, 3-4

UNIX workstation
loading router software images on
from CD, 2-3

v

verifying successful boot, 4-11

Index-2









