
Servant 

A New Shell for the 
Macintosh 

Program by Andy·Hertzfeld 

Documentation by Scott Kronick 



If you wish your name to be placed on the Documentation 

Update' mailing list, please fill out this page and send it to: 

Servant Documentation Update 

1442A Walnut Street. Suite 278 

Berkeley. CA 94709 

You can also use this form to order additional copies of the 

Servant documentation and Scott Kronick's programming 

textbooks. Please enclose a check or money order only, made 

out to "Sco" Kronick." Prices include postage. 

__ Servant: A New Shell for the Macintosh ($10.00) 

__ MPW and Assembly Language Programming ($24.95) 

__ Macintosh Pascal Illustrated: The Fear and Loathing 

Guide ($16.95) 

__ Instant Pascal Illustrated: Fear and Loathing on the 

Apple II ($18.95) 

Name ________________________________ ___ 

Street~ ________________________________ _ 

Ci~ _________________________________ __ 

State and Zip Code _______________ _ 

Did you obtain Servant through a friend, electronic service, 

users group or other? __________________ _ 





Servant 

A New Shell for the 
Macintosh 

,Program by Andy Hertzteld 

Documentation by Scott Kronick 



Copyright © 1987 by Scott Kronick 

All rights reserved. No part of this publication may be 

reproduced, stored in a retrieval system, or transmitted, in any 

form or by any means, electronic, mechanical, photocopying, 

recording, or otherwise, without the prior written permission of 

the author. Printed in the United States of America. 

Products that are known by the author to be claimed as 

trademarks appear in initial caps. This publication is intended 

for informational purposes only and is subject to change without 

notice. The author assumes no liability for any errors or 

inaccuracies that may appear in this text. 



Contents 

1 Introduction to Servant 

How is the manual organized? 

What hardware and system versions does 

Servant require? 

How is Servant being released? 

Where can I send feedback about Servant? 

7 Chapter 1: Exploring the New Desktop 

Starting Servant 

Using the Cursor to Push and Select 

Selecting More than One Icon or Selecting 

None 

Bringing the Entire Desktop into View 

Viewing Size and Information Formats 

21 Chapter 2: Adding Special Touches 

Making Custom Icons and Using Folder Tricks 

Setting the Background and the Startup Application 

Making Servant Talk 

33 Chapter 3: Using the Desktop and Applications 

Together 

Launching an Application 

Switching between an Application and the 

Desktop 

Adding Another Application 

Switching Tips 



45 Chapter 4: Exploring Resources 

Understanding Resources 

Opening a Resource 

Playing with the System and its Desktop 

Icons 

57 Chapter 5: Servant Reference 

Annotated List of Features 

Topic Index to Features 

Graphic Index to Features 



Introduction to Servant 

When you turn on a Macintosh and insert a disk, you expect to 

see a desktop and its icons. This is the starting point for you to 

work with disks and launch applications. 

Servant replaces the old starting point (created by the Finder 

program in the System Folder) with a more powerful desktop 

that Is an accessible part of your work environment at all times. 

As the central application between you and your disks, Servant 

will: 

• Perform desktop tasks faster, more conveniently, and more 

informative Iy. 

• Allow you to keep open numerous applications and disk 

windows at the same time, and to switch from one to another 

instantly by clicking in an application or disk window. 

• Give you the ability to modify an application by directly 

accessing and editing its resources . 

• • • 

On the Impetus for Servant 

Servant is a replacement for Apple's Finder program. A lot of 

programs like spreadsheets, word processors, and database 

programs are constantly improving. Every month there's a 

new one coming out that ups the ante a little bit and forces all 
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the people who have the other ones to improve their product to 

make it better and better and better. That's just the best side 

of capitalism, of a free open market causing products to 

improve. 

Well, I think the Finder is the most important single program in 

the Macintosh environment. It's the one program that 

everyone really has to use. And that one wasn't improving 

enough. The Finder, in the end of 1985, was almost identical 

to the Finder when the Mac first came out. The reason it 

wasn't improving was no one was really challenging it. No one 

was pushing it to evolve in newer and better directions. That's 

what I tried to do with my Servant program . 

• • • 

How Is this manual organized? 

This manual shows you how to use Servant with four tutorial 

chapters and a reference chapter indexed graphically and by 

topic. 

Interspersed through the tutorial chapters (and the introduction) 

are excerpts, shown in italics, of a Servant talk and 

demonstration given by program author Andy Hertzfeld. Even 

without the benefits of a live demonstration, you will find that 

these excerpts are a fun and insightful way to learn about 

Servant. You'll also discover, as I did, that the program author 

often speaks more instructively than the manual writer writes. 

• Chapter 1 shows you how to use the new desktop. 
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• Chapter 2 shows you how to add special touches to the 

desktop. 

• Chapter 3 shows you how to use the desktop and multiple 

applications at the same time. 

• Chapter 4 shows you how to explore and manipulate the 

resources of applications and system files. 

• Chapter 5 contains an annotated list of Servant features 

indexed both graphically and by topic. 

If you want to start using Servant with as little reading as 

possible, or are already familiar with Servant and want to learn 

more about specific features (for instance, what does that eye 

do?), use the graphic index to point you to the annotated list of 

features in Chapter 5. The graphic index uses example 

desktop windows, pull-down menus, and familiar Macintosh 

terms to make the correspondence between what-you-see and 

what-you-need-to-do simple. 

What hardware and system versions does Servant require? 

Servant works on any Macintosh with 128K or 256K ROMs. 

This includes the 512e, Mac Plus, Mac SE, Mac II, and older 

machines that have been upgraded with 128 ROMs and at least 

512K of memory. 

3 



Disks initialized with either HFS (hierarchical file system) or 

MFS (Macintosh file system) are supported. All types of disk 

drives are supported. though the current version of Servant 

does not recognize AppleShare volumes. 

Servant ought to be used with the latest System version 4.1 (or 

version 3.2 for 512e users). 

How Is Servant being released? 

Current versions of Servant are free of charge and can be 

distributed freely. The program is undergoing testing and 

should be used with caution. As with all software, always 

make backup copies of your programs and your documents-in­

progress. Save your work often and on separate disks so that 

a program or disk crash will not cause you undue grief. For 

example. save to disk every fifteen minutes and save to a 

backup disk every hour. 

Servant no longer has a built-in expiration date. If a message 

box appears saying that the version has expired. you should 

obtain a current version. 

• • • 

On Expiration Dates 

I put this little feature into Servant making it self-obsolete 

because my experience with my Switcher program was such 
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that I had, like, Version 2.0 circulating around while I was on 

Version 4.0. And people were giving me bugs that I couldn't 

care less about because it was three months old which, to me, 

seemed like a lifetime. So anyway, the Idea I had was: ·Well, 

why don't I make the versions of Servant self-obsolete 

themselves. • 

I built in an expiration date so that the version released, say, in 

the end of November would expire in the end of January. I 

thought, ·Sure, I'll have a much better one available by then. • 

And, of course, I had to work on other things. It turned out to 

be a bad idea because I wasn't fast enough with my new 

versions. But, I don't know if I'll continue doing that or not. 

* * * 

Where can I send feedback about SeNant? 

When running Servant, the Apple menu offers the item Print 

Bug Report. If you have a printer attached to your Macintosh, 

selecting this item will print a form for sending bug reports and 

comments about Servant and Its documentation. You can 

order additional copies of the documentation with the bug report 

form or the form at the front of this publication. 

Servant Bug Report 

370 Channing Avenue 

Palo Alto, CA 94301 

Servant Documentation 

1442A Walnut Street, Suite 278 

Berkeley, CA 94709 
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Chapter 1: Exploring the New Desktop 

Contents 

• Starting Servant 

• Using the Cursor to Push and Select 

• Selecting More than One Icon or Selecting None 

• Bringing the Entire Desktop into View 

• Viewing Size and Information Formats 

Starting Servant 

To begin using Servant: 

1. Insert a disk containing Servant Into a drive. If you have not 

done so already, you should make backup copies of Servant by 

dragging the Servant application icon onto backup disks. You 

can do this. from the Finder. Servant is not copy-protected. 

2. Double-click on the Servant icon (or select the icon and 

choose Open from the File menu. 

After a few seconds, the disk window reappears in a slightly 

different format. The most noticable difference is that a set of 

small icons has replaced the bottom scroll bar. 
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The following illustration shows a disk window after you have 

started Servant. (The circled codes index the annotated list of 

features in Chapter 5. The more basic of these features are 

discussed the tutorial chapters.) 

II It 
m.~ 

Seruont Disk = 1 B 

5 items 694K in us. 

(!l] ~----I--I-----t 
Syst~m Folc1~r Servant 

BJ '1A\ 
Sup~rPiint Prtfs iiJ_ 

Using the Cursor to Push and Select 

On the Servant desktop, the cursor is usually one of two 

shapes: a hand or an arrow. In the previous illustration, you 

see the hand (1F). When the cursor lies within the white space 

of a disk window, its shape is a hand. 
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When the cursor lies over an icon or outside the disk win~ow, 

its shape is an arrow. You can move the cursor around the 

desktop to see how the cursor automatically changes between 

hand and cursor depending on what it covers. 

Here's how to scroll with the hand: 

1. Move the cursor onto the white space of a disk window so 

that it becomes a hand. 

2. Hold down the mouse button and drag a short distance. 

The hand pushes all the icons in the disk window as if they 

were on a sheet of paper. If you have used a graphics program 

with a hand cursor in order to push around your drawing area, 

you will see that Servant uses the hand in the same way. Most 

of your simple scrolling needs can be performed with the hand. 

Here's how to select and drag (or launch) with the arrow: 

1. Move the cursor over an icon inside a disk window so that it 

becomes an arrow. 

2. Hold down the mouse button and drag a short distance. 

(Double-clicking on an icon will launch the icon's application just 

like the Finder.) 

The icon under the arrow is selected and repositioned just as it 

would have been using the Finder. (Well, not exactly the same. 
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In Servant, the-outline of a dragging icon retains its unique 

shape. In Finders 5.5 and earlier, the outline is always a 

simple rectangle.) 

Dragging icons is the primary method for copying files. Servant 

uses icon animation to show the file copy in progress. When 

copying is initiated-either by dragging or by using the 

Duplicate command from the File menu-the cursor becomes a 

question mark for a moment while Servant determines if the 

copy can be performed. If the copy cannot be performed, a 

dialog box occurs. Otherwise, the copy begins by producing 

the outline of the icon that is being created. As the source file 

is read into memory, the icon outline fills with grey. Finally, as 

the destination file is written to disk, the grey area fills with its 

final shape. 

Servant also allows icons to be selected from the keyboard. 

Pressing the Tab key selects the next consecutive icon, moving 

right to left and top to bottom.· Pressing the Command-Tab key 

combination selects icons in the reverse order. You will find out 

more about this option in the next chapter in a section 

describing Servant's speech option. 

Here's how to scroll continuously with the hand: 

1. Move the cursor back onto the white space so that it 

becomes a hand again. 

2. Hold down the mouse button and, instead of dragging, 

gently push the mouse, letting go of the mouse button as you 

push. 
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You will see that this sets the desktop icons in motion (in the 

direction of and at a speed relative to your push). You can stop 

the rolling scroll by pressing the mouse button or hitting any 

key. 

Note: The command Rearrange ... from the Special menu Is 

not yet implemented. In a later version, this command will 

expand the functionality of the Finder's Clean Up command. 

* * * 

On Scrolling (Part 1) 

The first thing that everyone says when they see Servant is: 

-Hey, where are the scroll bars?-

I got rid of the scroll bars because I believe the scroll bars are 

only effective in one dimension at a time. A scroll bar is 

essentially a one-dimensional input device because it allows 

you to go up or down but not left or right. And there's a 
different scroll bar to go left and right, but not up and down. 

Since viewing in Servant is fundamentally a two-dimensional 

operation, its just as easy for me to go diagonal as it is in any 

other direction. I really felt the hand was a better approach to 

scrolling and I really had to work hard to be able to make it fast 

enough to be able to scroll like that. As you can see, the 

performance is pretty good at scrolling around. 
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"What did I do to replace the scroll bars?" It's subtle when you 

start thinking about it. The scroll bars perform a number of 

different functions, not just incremental scrolling. When I first 

started Servant, I had a picture of a hand and a picture of an 

arrow at the bottom of the window. And the way I conceived of 

it, you click on the hand and, just like in MacPaint, you would 

get in scroll mode. And click on the arrow to get back the 

arrow. 

But I quickly found a problem with that when I implemented it. 

Because what you always wanted to do was scroll an icon into 

view, then immediately click on it. What J came up with is 

obvious in hindsight, but wasn't initially: You make it be the 

hand as long as you're over white, but the arrow as long as 

you're over an icon. You can easily scroll no matter where 

you are. Give it a push and it moves . 

• • • 

Selecting More than One Icon or Selecting None 

The primary function of the cursor in a disk window is the same 

as in the Finder: You select icons by pointing and clicking (and 

can launch applications by pointing and double-clicking). 

Using the cursor when it is a hand gives you an additional 

scrolling function without the inconvenience of scroll bars. But 

perhaps you are wondering how to select more than one icon at 

a time. You can do this with a selection rectangle (for a 

contiguous group of icons) or individually. 
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In the Finder, you click In the white space and drag a selection 

rectangle around the Icons you want selected. In Servant, 

there are two ways to create a selection rectangle starting from 

the white space of the disk window: 

• Double-click and drag. Holding down the button on the 

second click turns the hand cursor Into the arrow cursor. 

• Hold down the Option key and drag. Holding down the 

Option key turns the hand cursor into the arrow. 

To select a group of icons individually, hold down the Shift key 

(this prevents previous selections from becoming unselected) 

as you select each Icon of the group. 

Servant also deselects Icons differently than the Finder. In the 

Finder, clicking in the white space of a disk window will deselect 

all icons (leave no Icon selected). In Servant, clicking 

anywhere inside the disk Information bar (1 C) will deselect all 

icons. The disk information bar is the area In the top of the 

window frame that contains the number of items, amount of 

memory in use, and amount of memory available. 

Bringing the Entire Desktop Into View 

Whenever your active directory window is sized such that some 

icons are hidden, you have four options to bring the hidden 

icons into view. Using the Finder, the only alternative was 

scroll bars. (To see how the latter two features work, hide a 
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few of the icons by pushing them out of view with the hand or 

by making the window smaller.) 

1. Push with the hand cursor (1 F). As you saw in a previous 

section, the cursor is a hand whenever it lies over white space 

in an active directory window. 

2. Hold down the button while pointing in the "eye" iconette 

(1J). The active desktop window is shown in a "Show Page" 

view where all icons, in shrunken form if necessary, are visible. 

Whenever there are hidden icons, a rectangular outline will be 

present to indicate the current window view. 

By holding down the button on the "eye" iconette and dragging 

the mouse into the rectangular outline, you can move the 

current view of the window. The outline can be dragged to any 

position on the desktop to encompass a set of icons. 

3. Hold down the button while pointing in the "arrows" iconette 

(1 K). This scrolls the icons. The icons move in the direction 

that the cursor lies with respect to the center dot of the iconette. 

For instance, if the cursor is bottom-left of the center dot, the 

icons will move to the bottom-left. When the cursor is moved 

farther from the center dot, the speed of scrolling increases. 

In addition to scrolling, the "arrows" iconette changes form to 

indicate the desktop position of icons in relation to the viewing 

window. When the iconette shows a single dot, all icons are 

within view of the current window. When the iconette points 

with one or more little arrows, off-screen icons are present in 

the directions shown. 
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4. Double-click In the ·arrows· Iconette. This automatically 

centers the Icons within the viewing window. The little arrows 

will indicate if Icons remain outside the view of the centered 

window. 

* * 

On Scrolling (Part 2) 

Other scrolling things in Servant are: There's this eye that you 

shows you everything. The hand allows you to incrementally 

scrol" replacing the scroll bar arrows, but it doesn't replace the 

scroll bar thumb because the scroll bar thumb allows you to go 

from the beginning of the document to the end of the 

document without going in-between. 

So what Servant does to replace the thumb: It has this little 

eye-con, so to speak, where when you click on it, it reduces­

no matter how small your window is or no matter how many 

files you have-it down so all the information fits. And just like 

-Show Page- in MaePaint, you can drag a box around to scroll 

to exactly the pOint where you want to scroll. 

These arrows (the -arrows- ieonette) replace the scroll bar 

shading in the sense that they show you, not only that there is 

hidden information, but the direction of the information. When 

only the right arrow is on, it is saying, -Hey, all the information 

is over to the right-. When I make the window real big, there're 
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no arrows at all because I am seeing everything. 

Another tunction at the arrows-the arrows actually have three 

tunctions-is that when you click on the arrows, they act like a 

joystick. By moving a tew pixels, I can change the direction. 

And it goes very tast if you move far away. That replaces all 

tour scroll bar arrows in one little area. 

One of the things I objected to, especially on a large screen, is 

to get trom the top arrow to the bottom arrow, you had to 

traverse the whole scroll bar, which seemed a little silly 

because you always overshoot. So I give you all tour arrows 

within.a tew pixels of each other for tine scrolling control. 

Sometimes you can get lost. 1 can give it a push here and it 

tries to keep aI/ the information on the screen, but you can 

force it off the screen. And 1 hate looking at a blank screen. 

You think, "God, where am I? I'm lost. " 

The solution for that is: If you double-click on the arrows-no 

matter how lost you are-it will always center you where the 

action is. So you can never feel really lost because you can 

double-click on the arrows . 

• • * 

Viewing Size and Information FOl1'l1ats 

Servant allows you to see icons in a variety of size and 

information formats. To switch from one to another format 

requires only that you point and click in an iconette. 
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1. Click on anyone of the six -zoom-jconettes (1 Pl. The 

graphic image of the icons will shrink or expand in scale. The 

iconette's .image reflects the relative size of the desktop icons. 

The currently selected iconette is shown with a thick border. 

The iconette fourth from the left is the default setting. The 

same feature can be implemented by choosing Zoom Out (for 

shrunken icons) or Zoom In (for expanded icons) from the View 

menu. 

2. Click on the -ruler- iconette (1 M). The number of bytes each 

file occupies on disk is listed below the file's name. A file's size 

is measured in K (1024) bytes or, if under 10K, B (single) 

bytes. The same feature is offered by choosing Size from the 

View menu. Be aware that this feature may take a few 

moments when the window contains a large number of 

embedded folders because Servant is determining the size of 

each component file. 

3. Click on the -calendar- iconette (1 N). The date each file 

was last modified is listed below the file's name. The same 

feature is offered by choosing Date from the View menu. 

4. Click on the -abc- iconette (1 L). Only the name of each file 

Is listed below the icon. This is the default setting. The same 

feature is offered by choosing Name Only from the View menu. 

5. Close the disk window by clicking in the Close box. The 

selected disk icon will show whether or not the disk has been 

initialized with HFS, the hierarchical file system. Floppy disks 

formatted with HFS will show the letters HFS embossed on the 
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disk icon. Floppy disks formatted with MFS (Macintosh file 

system) have plain disk icons. 

Two other viewing features of Servant: 

1. When you open a folder, the size of a folder is given in the 

information bar (1 C). This contrasts with the Finder which gives 

you the size of the entire volume in each folder window. 

2. Servant remembers the ieonette settings between sessions. 

Whenever you open a directory window, it displays the window 

icons in the same format as when the window was last closed. 

The default format is Names Only with the same size icons as 

the Finder. 

• • • 

On Viewing 

Another view aid in Servant is zooming. Right now, the 

nominal way to display the icons is just like the Finder: 32 by 

32 pixel icons. But it turns out, when you have a lot of 

information on your disk, you might want to make the icons a 
little smaller. So I have this little construct here called the 

Zoom bar (the "zoom" iconettes). I can click and it makes 

them a little smaller. 

You can make these smaller yet when you have lots of 

information, or smaller yet. Notice, even at these small sizes, 

fonts are surprisingly readable. The reason for that is: They 
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are not shrunken fonts like you'd normally see on the Mac, but 

actually. tiny, teenie-weenie little fonts designed by an artist to 

be as good as they can be at that small size. Teenie-weenie 

little fonts allow you to see more Information at once. 

I fee( the next smaller size is the most useful alternate size and 

other smaller sizes are also useful. But just for fun, I said, 

·Well, what will it look like If you made them a little bigger. So 

the largest size, scaled up twice the size, Is the Sesame Street 

Macintosh. It's actually useful for people who are visually 

impaired to some degree. It's nice to have alternative bigger 

sizes in addition to smaller sizes. Certain people appreciate 

that. It's great for doing a demo. You can really see things 

very clearly. 

Another thing to show you here Is view level. One of the neat 

things Servant will do for you is display the sizes of objects. 

So when you click on the ruler, it shows you under the name 

the sizes of things. So, in a glance, you can see how big 

things are. 

In a similar fashion to the size, if you click on this little 

calendar, /t displays the modification dates. Because you 

often have a few versions of a document and you want to see 

which one /s the latest or whatever. 

* * * 
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Chapter 2: Adding Special Touches 

Contents 

• Making Custom Icons and Using Folder Tricks 

• Setting the Background and the StartUp Application 

• Making Servant Talk 

Making Custom Icons and Using Folder Tricks 

In this section you will see how to make custom icons for 

applications, folders, and disks. You can use existing icons to 

help create custom ones. 

Here's how to draw your own custom icon: 

1. Select a single icon. 

2. Choose Custom Icon from the Special menu. This will 

produce a dialog box containing the selected icon enlarged in 

fat bits. 
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3. Use the cursor (it's a pencil when inside the fat bits square) 

to draw the icon in whatever way you wish. As you are 

drawing, you can see the custom icon in its actual size at the 

bottom-right of the dialog. 

4. If you want to install your customized icon, click in the Okay 

button. This exits the dialog and the icon will retain its new form 

until you wish to change it again. 

5. If you do not want to install your customized icon, click in the 

Cancel button. This exits the dialog without any changes 

made. 

6. If you want the icon in the dialog box to be redrawn the 

same as it was before your current changes, click in the Revert 

button. 
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7. If you want the icon in the dialog box to be redrawn the 

same as it was originally created by the program (before any 

customization), click in the Revert button while holding down 

the Option key. 

In addition to letting you draw custom icons, Servant has a 

feature that allows you to shrink an Icon and stick its image 

onto a plain folder Icon. You will find this is a nice way to create 

a folder that illustrates the folder's contents. 

Here's how to create a custom folder icon with a shrunken icon. 

1. Select the icon you want to appear shrunken on the folder 

icon. 

2. Choose Copy from the Edit menu. This puts the text of the 

icon onto the Clipboard. 

3. Select the folder you want the shrunken image to appear on. 

4. Holding down the Option key, choose Custom Icon from the 

Special menu. 

The Custom Icon dialog box appears with the shrunken icon 

inserted on the folder. At this point, you can click in the Okay 

box to install the folder as you see it or further customize the 

icon with the pencil. 

Servant also allows you to replace a folder icon with an existing 

icon. Use the same four steps for shrinking an icon onto the 

folder except instead of holding down the Option key (in step 4), 

23 



hold down the Command key. The selected icon becomes the 

folder icon. You might find that folders that no longer use the 

folder image are confusing, but Servant gives you the option of 

making any of your icons look any way you wish. 

Another folder feature of Servant [Caution: sometimes buggy] 

allows you to create a new folder with selected files 

automatically inserted inside the folder. Ordinarily, selecting 

New Folder from the File menu creates an empty folder the 

same as it does it in the Finder. 

Here's how to create a new folder that automatically has 

selected files inserted within the folder: 

1. Select the icons you want inserted in the new folder you are 

about to create. 

2. Holding down the Option key, choose New Folder from the 

File menu. 

3. Give the "empty" folder a name. When you open the newly 

created folder, you will find that it is not really empty; inside are 

the selected files. 

* • * 

On Little Touches 

Some of the other little touches... I believe in puning a lot of 

detail into a program. Some people think, "Oh, you shouldn't 

put that feature in; it's too much fun." I get told that al/ the 
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time. "lj3usiness computers shouldn't be fun." Butllike 

making my applications fun because business people are 

people and they enjoy fun things. 

So I'll show you one of the fun little features that are in here. 

Well, I don't know how fun this is: Notice that when I drag 

something, it has the outline that is Identical to the way the 

icon looks. The Finder only has a square outline. But since 

this application Icon is diamond-shaped-it has a diamond­

shaped outline. Or if I drag the Servant icon around, it'l/ have 

the S-shaped outline. That just helps to reinforce the 

metaphor. I can tell at a glance what I am dragging around 

without having to think about it like you do in the Finder. So 

that's kind of a useful thing. 

Here's the other thing I wanted to show you is: When you drag 

something to the trash, the lid pops open. Just another little 

fun thing. That's the one that business people hate. "You 

can't do that; that's stupid." Yeah, it's fun to be stupid. 

* * * 

Setting the Background and the StartUp Application 

Like the Finder, Servant allows you to specify an application 

that is to be automatically launched each subsequent time that 

the Macintosh is started. The specified application remains the 

startup application until you specify another application to be 

the startup. 
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By default, the Finder is the default startup application. Here's 

how you can make Servant (or any other application) the 

startup: 

1. Select the icon of the application that you want to be the 

startup one. 

2. Choose Set StartUp from the Special menu. 

Be careful not to rename the new startup application. This will 

cause the current version of Servant to not recognize the 

application as the startup. 

Servant also give you the ability to make a MacPaint or 

Thunderscan document be the background pattern of your 

desktop. The picture in your document becomes the 

background screen. This feature supplements the Control 

Panel desk accessory that allows you to set the background to 

any 8 by 8 pixel pattern. 

Here's how to set the background to a MacPaint or 

Thunderscan document: 

1. Select the MacPaint or Thunderscan document that you 

want to be set as the background. 

2. Choose Set Background from the Special menu. 

If you select any icon other than a MacPaint or Thunderscan 

document and then choose Set Background, the background 

pattern will be set to the default gray pattern. 
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* * * 

On User Flexibility 

I have been working on this program so long that, and there's 

so many features I always forget to demonstrate them. But I'll 

show one of the other ones that I consider to be a fun feature, 

which Is: You can select any MacPaint document or 

Thunderscan document and say Set Background. So instead 

of the desktop being something grey, it can be one of the your 

heroes, like one of my heroes-Woody Allen. 

Actually, I gave a talk earlier-late last year at Princeton-and 

they don't like Woody Allen so much at Princeton. They like 

this guy more (Einstein). Just click on anything that's not a 
MacPaint document or a Thunderscan document and you get 

back to the boring old desktop. 

This gives you a finer level of control over the machine. /t's 

kind of interesting: different people have different philosophies 

and I'm basically an anarchist-type person. I like giving 

_ everyone the flexibility to do whatever they want. 

Bill Atkinson, who I worked very closely with on developing 

Macintosh, is kind of the opposite. He feels he knows the right 

way and he wants to tell the user because the user will do it a 

worse way than he can think of. And so one of the big fights I 

had with Bill Atkinson was over the Control Panel-one of the 

features in the Control Panel-which allows you to customize 

the desk pattern. 
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I wrote the Control Panel and I put in this feature that allows 

you to put in any pattern you like, and Bill just hated that. He 

thought, "Oh no." He wanted to be in control of the aesthetics 

of his screen. So anyway, since I wrote the Control Panel, I 

kind of won on that. But Bill aced me out because he made it 

that MacPaint is always gray, no matter how you set the 

background. I guess we both had it our own ways. 

Since I like things to be as customizable as possible, the next 

step with Servant was to aI/ow, instead of just a pattern, any 

kind of image you like. 

• • • 

Making Servant Talk 

Servant has an option that will let you hear the name of each 

icon as it is selected and each command as it is chosen. To 

use the speech option, you must have the MacinTalk file (a 

system file that comes on Apple's System disk) in the System 

folder. 

Here's how to make Servant talk: 

1. Make sure the MacinTalk file is in your System folder (or in 

the same directory as Servant). You need this file for speech to 

work. 

2. Choose Options ... from the Special menu. This will produce 

the Options dialog box. 
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3. Click on the Speech On button so that the option is checked. 

4. Click inside the OK button to install the option. If you click 

inside the Cancel button, your Options changes will not be 

installed. 

With the speech option turned on and the MacinTalk file in your 

System folder, your Macintosh will now speak the name of each 

icon as it Is selected and each menu command as it is chosen. 

You may r:Jotice the responsivenss to tasks like dragging is 

slightly slower as the computer is speaking. Heck, they're are 

some people who can't move and speak at the same time. 

Servant provides an adjunct feature that makes speech more 

useful. As an alternative to using the mouse, icons can be 

selected using the Tab key. Pressing the Tab key selects the 

next consecutive icon, moving right to left and top to bottom. 

Pressing the Command-Tab key combination selects icons in 

the reverse order. 

Using keyboard selection and command key menu commands 
\ 

along with Servant speech provides a means of interacting with 

disks without any visual needs. 

• • • 

On Speech 

Believe it or not, Servant will even talk if you want it to. It 

started in 1985. I'm an aficionado of Compuserve and some 
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person put up a very nice note saying he and his wife are both 

Mac fanatics. They both love the Macintosh, but they're 

visually impaired. They had a partial vision problem. They 

said, "Is there any way to enlarge the cursor. We love the 

Macintosh even though we're partially sighted because we can 

use very large fonts. " 

But they felt constrained by the fact that the cursor was really 

tiny and so they put up a message: Ifls it possible to make the 

cursor larger?" 

And another programmer, whose very knowledgeable about 

the Macintosh, answered, "No, I'm sorry. It's impossible to 

make the cursor larger because it's hard-wired in the operating 

system. " 

So I was reading that and I love reading things that are 

impossible. It's not fun to do things that are possible. And so, 

I saw that, and I wrote a big cursor routine that made the 

cursor 32 by 32 pixels. Eventually that got incorporated in the 

Radius full page display. It's one of the features in it. 

But anyway, I put that up on Compuserve, and the people who 

originally requested it, I never heard from. But I got three 

letters from other people saying, "Oh yeah, we're partially 

sighted and having this big cursor made a real difference in us 

enjoying the Mac. " 

So that made me feel good. And when I was doing Servant, I 

thought, "Well gee, what other things can I do to help people 

who are a little visually impaired. One of them is being able to 
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make things big like that. I thought, "But gee, what if you can't 

really see at all. What if I turn off the screen of the Mac." I 

didn't want Servant to be the bottleneck to using your machine 

if you couldn't see very well. So, to that end, I implemented 

this feature where you can turn speech on. 

So basically, you can get it to talk any command that you're 

giving. Even if your screen is off, at least ... the other thing that 

goes along with that is you can use the Tab key to advance 

between the different programs. And Command-Tab makes it 

go backwards. 

So you can go Tab-Tab-Tab, get to the program you want, say 

Command-Open, and being totally blind still will let you run 

your Macintosh. Well, I admit, most people who are blind 

won't really get that much use out of the Mac, but ... 

• • • 
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Chapter 3: Using the Desktop and Applications Together 

Contents 

• launching Applications 

• Switching Between an Application and the Desktop 

• Adding Another Application 

• Switching Tips 

launching an Application 

Servant allows you to keep open numerous applications and 

disk windows at the same time. and to switch from one to 

another instantly by clicking in an application or directory 

window. As a result. desktop management is easily accessible 

even after an application has been started. The Servant 

desktop remains as an inactive window in the background. 

In this chapter you will experiment by opening two different 

applications in addition to the Servant directory window. The 

example applications used in this manual are MacWrite and 

Super Paint (in Andy·s excerpt below. he uses MacWrite and 

MacDraw). yet you could substitute nearly any application that 

uses resizable windows (windows with a size box). 
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For example, WriteNow, Word, FuliPaint, PageMaker, and 

Excel work fine. On the other hand, MacPaint, though it works 

under Servant, doesn't offer the same versatility because it 

lacks a resizable window. 

One of the best ways to see how Servant supports multiple 

applications at the same time is to look at the following screen 

shot. Below the illustration, you will find a series of steps 

necessary for you to create a similar setup. Remember, the 

circled codes 2A-2E serve as an index to the annotated list of 

features in Chapter 5. 

The Grellt AmericlIn Sen/lint /Jocl/mentlltion 
by Scott Kronl ck 

Here's how to open up your first application along side of 

Servant: 
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1. Resize the Servant directory window so that it looks like the 

one in the illustration (wide and short). This will give the screen 

room for the windows of the next two applications you will open. 

2. Click on the MacWrite icon. As the program opens, the 

window will take up the entire screen. 

3. Resize and reposition the MacWrite window so that it looks 

like the one in the previous screen shot. 

Here are some fundamental aspects of Servant that you see: 

• Two windows are open at the same time. One is Servanfs 

directory; the other's MacWrite. The MacWrite window-the 

last one opened-remains the current active window. 

• The menu bar contains MacWrite's (not Servant's) menu 

titles. Since MacWrite is the active application, it controls the 

menu bar. 

• Appended as the last title of the menu bar is the Servant 

application icon (same as 2A). You can use this pull down 

menu to view and switch to the open applications. The active 

application is dimmed. 

• At this pOint, MacWrite will function just as it always should. 

The only significant difference while working in the Servant 

environment is that the inactive directory window remains in the 

background (and easily accessible). 
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Switching Between an Application and the Desktop 

Switching is as easy as clicking in an inactive window. Try it. 

1. Click anywhere in the directory window. The win~ow 

becomes active plus the menu bar changes to the Servant 

menu bar. The previous screen shot was taken with the 

directory window active and the Servant menu bar in control. 

2. Perform any Servant task such as choosing Size from the 

View menu. This reaffirms that Servant's desktop management 

is your active application, while MacWrite remains visible as an 

inactive application. 

3. Pull down the application menu from Servant's menu bar 

(2A) and choose the MacWrite item. MacWrite becomes active. 

The application menu is an alternative method of switching 

among applications. This is particular useful when an 

application's window is hidden. 

Before going any further, you should experiment with your open 

application and the Servant desktop. Try switching between 

the two using both the click-in-the-window method and the 

application menu switcher. 

It takes a little getting used to having multiple applications on 

the screen. By playing around, you will soon convince yourself 

that the active application has complete control of the 

Macintosh, including the menu bar. The inactive, background 

applications simply offer you an exceptionally fast and easy 

way to go from one application to another. 
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Adding Another Application 

Now you should try opening another application along side of 

Servant and MacWrite. In the illustration of this chapter, the 

third open window is a Super Paint document. SuperPaint takes 

good advantage of Servant's abilities because (unlike MacPaint 

2.0) its drawing window can be resized. 

Here are the necessary steps to make your screen look like the 

one in the illustration: 

1. Click in the directory window to make Servant active. 

2. Double-click on the SuperPaint icon (or substitute another 

application that uses reslzable windows). At this point. 

SuperPaint Is the application in control. 

3. Resize the Drawing window so that it looks like the one In 

the illustration. The SuperPalnt drawing palettes still overlap 

the directory and MacWrite windows In the background. 

4. Click In the MacWrite window to switch from SuperPaint to 

MacWrite. Click In the SuperPaint window to switch back to 

SuperPaint. Click In the Servant directory window to make 

Servant active. (If SuperPaint is active yet the palettes are 

missing. try choosing Hide Palettes/Show Palettes from the 

Windows menu.) 

5. Try using the application menu to perform the switching. 

The effect is the same as clicking in a window. 
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6. Finally, use the Edit menu commands to cut, copy, and 

paste between SuperPaint and MacWrite. With the greatest of 

ease, you can draw in SuperPaint, select the drawing, copy it to 

the Clipboard, click in the MacWrite window, and paste the 

Clipboard image into MacWrite. 

Now that you have your screen looking like the illustration 

shown at the beginning of this chapter, you might want to flip to 

the graphic index in Chapter 5 for a summary of its elements . 

• • • 

On Switching and the Wristwatch 

A lot of people think the main thing of Servant is what I'm 

about to show you. I think the main thing is what I've already 

shown you: the second generation Finder. But Apple thinks 

it's this little feature: when I launch a program, instead of the 

desktop ... 

Notice the hands of the wristwatch, by the way, always move. 

Apple copied that from me in the latest release of the Finder. 

And I copied it from a shareware program by Bob Finch. 

Under Servant, it does that in any program you're in, not just 

the Finder. 

When I launch a program, instead of the desktop disappearing, 

the desktop is still there. Servant is underneath it. I can just 

click back so that switching between programs is just as 

simple as that. 
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I'll launch MacWrite here. MacWrite's a good one because it 

leaves the watch up the whole time so, you'll notice, the hands 

of the wristwatch spinning away, even while it's in MacWrite. 

/t's kind of a vel)' subtle psychological thing why its a good 

idea to spin the hands of the wristwatch. If you just leave the 

wristwatch up there, people get frustrated because nothing's 

happening. And they think, -Gee, why's the Mac so slow. It's 

wasting my time and not only is it wasting my time, it has the 

audacity to remind me that its wasting my time by putting up 

this watch. 

But now when they see the hands spin, they kind of think: -Oh 

gee, it's working its little heart out for me. - And you're more 

apt to appreciate it. It's kind of subtle, but it really is true. 

When it's doing something, you think it's not just sitting there. 

Of course, it's doing work all the time, but it's just invisible to 

you. 

So anyway, let's say I want to get an Image from MacDraw into 

MacWrlte. Well, alII have to do Is draw the image into my 

horrible way here--my self portrait-and say Copy and then 

just click on MacWrite. And It's simple as that. Servant knows 

to do the extra work. There's no more of this -always convert 

Clipboard- stuff that Switcher does. Servant just does it 

because it's smarter about that. Just say Paste and its in 

Mac Write. 

Other things to notice: When MacWrite came up there, its 

window was .very large, filling the entire screen practically. 
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You can feel lost. You think, "Uh gee, it's covering something 

else. I know its down there, but where is it?" 

Thai's why there's this little application menu in the upper-right. 

I think of it like a bookend. The apple's al/ the way on the left 

and the application is on the other side. The application menu 

shows you all the applications you're running and where to go. 

So even though I'm in MacWrite here, if I want to go to 

MacDraw, it's as Simple as selecting MacDraw from the 

Application menu. If I'm in MacDraw and I want to get back to 

Servant, it's as simple as selecting Servant from the 

Application menu. 

The desktop knows that MacWrite has created some 

temporary files, so it sticks them up there. When I quit from an 

application-you'll notice that it gives me all the normal 

. confirms-it does the reverse zoom reet, shrinking back down 

into its icon. Just to reinforce the metaphor. 

* * 

Switching Tips 

Here are some tips for working with two or more open 

applications under Servant: 

• Look at the menu bar if you forget which is the current active 

application. You can't always rely on finding an active window. 

For example, close the MacWrite text window by clicking in the 

Close box or choosing Close from the File menu. Though the 
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only open window on the screen is the inactive directory 

window. MacWrite is still the active application and the menu 

bar contains MacWrite's menu titles. Choose New from the File 

menu to reopen a blank text window. 

• After an application has been opened. the subsequent 

opening and closing of its existing documents will not be 

automatically reflected by the dimming and undimming of the 

document icons in the directory window. Document icons will 

be updated only after the application has been exited. 

For example. if you open a MacWrite document by double­

clicking on its icon. the icon is dimmed (the same as the 

Finder). However. cloSing the document will not undim its icon 

in the directory window until MacWrite is quit. 

• Many programs such as MacWrite use internal temporary 

work files. Ordinarily. you would not see Icons for these files. 

(You might have seen these temporary files appearing In the 

Finder if you ever turned off the Macintosh or crashed before 

properly exiting a program.) 

Since Servant is operating visually beneath your application. 

you will see these temporary work files appear on the desktop. 

When an application Is exited. the application will remove the 

temporary files from the desktop just as it does from the Finder. 

At no time are you required to deal with these temporary files; 

the applications take care of them. 

41 



• From the desktop, select an icon then choose Get Info from 

the File menu and examine the resulting dialog box. Every 

application has its own Get Info dialog. Servant provides much 

more information about an application than does the Finder and 

provides a method for the user to allocate memory. 

The Servant application's Get Info box is shown on the next 

page. In addition to the resource information and text input 

area are: 

1. The folder location of the application, nested up to four 

folders deep. In the illustration, Servant is in the folder 

servStuff on the hard disk Silky. 

2. Two check boxes that allow you to change an application's 

Locked and Invisible attributes. 

3. Two input boxes that allow you to specify the memory you 

want allocated to the application. Most applications provide 

preset preferred and minimun memory requirements. Servant 

gives you the opportunity to change those values. 

Memory allocation is particularly important when running 

multiple applications and available memory is scarce. If you 

are having difficulty running a set of applications, you may want 

to reallocate memory to optimize the performance of your 

programs. 

42 



Info obout Seruont 

~ ~D~ ~ 
n,-vStuff Silky 

Kind: ~ppltc~tton 

stu: 123K (125953 bljttS) 

TlJpe: APPL/SERV 
C,-ut.d: 8/4/87 12:24:12 AM 
Modifi.d: 8/7/87 ':17:18 AM 

Pnf.,-,-.d Stu: 1128K I 
Minimum Siu: 1128K I 

Locbd 0 
Invts;bl. 0 

I 
SERV 

The menu item Show Memory from the Special menu produces 

a dialog box that shows graphically the portion of memory 

currently being used by an application (the dark gray region) 

and the additional memory available to the application (the light 

gray region). The number to the right of the bar graph region 

shows the total memory allocated to an application. 
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Chapter 4: Exploring Resources 

Contents 

• Understanding Resources 

• Opening a Resource file 

• Playing with the System and its De~k Accessories 

Understanding Resources 

Applications written for the Macintosh are made up of 

components called resources. An application's resources are 

stored in internal resource files that are intended to be invisible 

to the application user, yet accessible to those who wish to 

modify the application. 

Resource files contain the specifications for such program 

entities as menus, windows, dialog boxes, fonts, icons, and 

program code. By having each of these (and many more) 

entities specified as separate resources, they are more easily 

accessed and modified. 

Servant lets you open resource files and see the resources 

inside. Also implemented are resource duplication and most 

kinds of resource moving (though not fonts and desk 

accessories. yet). Resource copying and moving work just like 

file copying and moving 
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The current version of Servant allows you to edit three types of 

resources: ICN, ICN#, and STA_. In addition, the current 

version lets you browse PICT and snd_ resources. Note: 

Servant will only play sounds if the sound manager is installed. 

The sound manager is always installed on the Mac II and can 

be installed in the System Folder of other Macs (but not by 

Servant). 

Servant represents all resources using icons. (The Custom 

Icon item from the Special menu works with resource icons, 

too.) You can use Servant to explore and manipulate 

resources using the same desktop techniques that you use to 

manipulate disk files. 

The System file makes particularly important use of resources. 

Icons, fonts and desk accessories are examples of System 

resources. Using Servant, you can easily open up the System 

file to look at its resources. 

In the case of desk accessories, you can even move these 

resources out onto the desktop. The icons representing desk 

accessory resources can be opened and run just like 

applications. An upcoming version of Servant will allow you to 

copy fonts and desk accessories among disks in the same 

manner as you copy ordinary application and document files. A 

new kind of box called a bundle with handle fonts and DA's. 

If you are new to the concept of resources, Servant will provide 

your best first glimpse. Up till now, resources have been in the 

domain of the hacker. Servant gives anyone, hackers to the 
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meek, a way to explore resources with methods as simple as 

·opening up an icon to see what's inside.-

You will not find a technical discussion of resources here, but in 

the following steps you will see how an application such as 

MacWrite is made up of a hierarchy of resource files and, 

ultimately, the resource data that helps define its nature. 

When working with resources, you should be extra careful 

about making changes only on backup copies of your disks. 

Both the editing and moving of resources can produce 

unforseen results among even experienced programmers .. 

Opening a Resource File 

Here's how to open up an application to look at its resources: 

1. Select (single-click on) the MacWrite Icon. 

2. Choose Resource Open from the File menu. 

Alternatively, the Resource Open command can performed by 

double-clicking on an icon while holding down the Option key. 
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The following is a snapshot of some MacWrite resource icons: 
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When you open a resource file I the window does not show you 

all its resources, but rather a subset of the common ones as 

determined by the file. However, by holding down the 

Command-Option keys and double-clicking on the file icon (or 

choosing Resource Open from the File menu with the 

Command key down), the window will show all of a file's 

resources. 

The resource icons that are pictured as boxes contain multiple 

resources of the same type. If a file has only one resource of a 
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given type, the resource is shown alone without a box. Also, 

you can" take resources out of their box and drag the box to the 

trash if you wish, but you can't rename Type boxes. 

You can look inside some of MacWrite's resource files by 

double-clicking on their icons. (Or by selecting the icon and 

choosing Open from the File menu.) 

Try the following steps: 

1. Open the resource file named Type ICN# by double-clicking 

on it. Inside you will find a window with three numbered icons. 

2. Double-click on each of the numbered icons. Each of these 

open up with a window that contains one of the desktop icon 

images used by MacWrite. 

You ought to recognize MacWrite's desktop icons as the 

application icon, standard document icon, and text-only 

document icon. They are 32-by-32 bit images that are stored in 

a icon resource file. These images can be editing with the 

cursor that becomes a fat bits pencil when it lies over the icon. 

You can close each layer of windows by Clicking in the 

window's Close box (or selecting Close from the File menu). 

Try opening other MacWrite resource files. If you hear the 

Macintosh tone and nothing else happens, the resource file 

cannot currently be opened to any deeper level. 
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Playing with the System and Its Desk Accessories 

After closing all of MacWrite's resource windows, you should try 

opening the System file's resources. Here's how to do that: 

1. Open the System Folder. (See item 10 in Chapter 5 if you 

want a brief explanation of the S symbol on the System Folder.) 

2. Select (single-click on) the System icon. The System file is 

not an application that can be run by double-clicking on it. 

3. Choose Resource Open from the File menu. The System 

file opens to a window full of its component files. Some of 

these can be opened further. 
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4. Double-click on the resource file Icon named Type DRVR. 

5. Double-click on some these Icons with desk accessory 

names. Now you have an alternative to the Apple menu for 

opening d~sk accessories. 

6. Try dragging one or more of the desk accessory icons out of 

its window and onto the desktop. Now you have the versatility 

to put desk accessories wherever you want them. 

By exploring resource files, you notice that they are identified 

by type, creators, and ID numbers. Resources use three- or 

four-letter namesplus Important punctuaion makes like 

parentheses and single quotation marks. If you want to change 

a resources name or number, you must be careful to follow 

rules such as giving each resource a unique 10 number and 

using the left parenthesis to end a file name. 

You also have available the Get Info box from the File menu to 

examine and change certain resource features. A sample Get 

Info box was shown in the last chapter. 

More information on resource editing will be provided in a 

documentation update . 

• • • 
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On Resource Editing 

So far I've showed you the two aspects of Servant: One of 

which is the second generation Finder with advanced browsing 

capability; another is the second generation Switcher with the 

windows on screen. Well, a third part to Servant is what I call 

"the Resource Editor for the rest of us. " 

What I think has happened over the last one and a half years 

or so is: The Mac System has become more complicated than 

we ever intended it to become. When we were designing Mac, 

we thought, "God, we're making the ultimate computer, the 

perfect computer that will be usable by everyone. The first 

computer that you didn't have to be an expert to use." 

But it turned out, as the System got more complicated, we 

didn't really plan on extending it. Apple began introducing 

products such as the LaserWriter, AppleShare, new System 

files and, all of a sudden, the System became more 

complicated. 

It turns out, there are these installer programs that let the 

Macintosh use the LaserWriter, they add files to your disk, they 

change stuff in your System file. But the disk looks pretty 

much the same to you after the Installer program has run so 

there's some mystery. The normal user doesn't understand 

what's going on beneath the surface of their Macintosh. 

I really think there is a very boldly defined dividing line 

betwl(en the Mac user and the Mac expert. The dividing line is 

a program called ResEdit. If you know how to use ResEdit, 
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you're one of the Mac elite as opposed to just an ordinary 

user. Because ResEdit is an awkward program to use-­

everyone knows it is very dangerous-one of my goals with 

Servant is to turn every Macintosh user Into a Macintosh 

expert by making the resource editing features accessible to 

everyone. 

My approach to doing that was, basically, leveraging the 

Finder metaphor which everyone is already familiar with. 

Everyone already knows that a little disk icon is a picture of a 
disk. When I open it up, there's little icons representing pieces 

of the disk called files. So in Servant, you can open up any file 

by saying Resource Open and you '/I see that the file is made 

of little Icons whose pieces are called resources. 

By saying Resource Open with MacWrite, we have a 
representation of the resources Inside of MacWrite. We're 

now looking at the insides of MacWrite, just like when we 

opened the disk icon we're looking at the inside of the disk. 

There's these little boxes with the resources. In the one called 

Menus al/ the menus Inside MacWrite. You can see the 

Format menu, the Font menu, the Edit menu. So its kind of 

fun. It's almost like you're a voyeur, looking at places you're 

not supposed to be looking at to see the real insides of things. 

For example, you can look at the icons in MacWrite. And we 

can double-click on the icon and it will show you its document 

icon. That one's a custom icon. Where's the MacWrite icon? 

It's probably number 178. Yeah, there it is. That's the 

MacWrite icon. 
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We can drag these resources around just like you can drag 

around any things. But resources really becomes clear when 

you look at the System files stuff. One of the things I didn't 

mention is: Notice on the desktop is a little icon like this little 

calculator icon. Where did that come from? I wonder what 

would happen when I double-click on the calculator icon. Let's 

try it. It opens up into the calculator. It's representing a desk 

accessory. Desk accessories are just resources. 

Here s the scrapbook. Lets click on the scrapbook. It opens 

up into the scrapbook. This one heres the control panel. But 

now, if we look at the Apple menu, we notice that there's the 

alarm clock, and key caps and the notepad and the puzzle. 

Where are those? I don't see the icons for those. 

Well, the reason those are out there are is just because I 

chose to put them there. And I'll show you how to do that. If I 

don't want the control panel to be on the desktop anymore I 

can just take the control panel and drop it into the System file. 

I can open' up the System file, see what's inside there-the 

System file is usually pretty complicated so it might take a little 

while, especially on a floppy disk-but weW notice here we 

have the puzzle. So if I want the puzzle to be on the desktop, 

just drag that to the desktop. 

So basically, what this does is rep/ace the program called 

FontlDA Mover. To me, thats a very non-Macintosh program .. 

It doesn't feel intimate. You're not touching things. Why don't 

you copy desk accessories just like you do files? Well, with 
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SeNant you can. If I want to get rid of the puzzle, I drop it into 

the trash. I don't really want to get rid of it, so bring it out of 

the trash. 

If I w.ant to copy a desk accessory from one disk to another, I 

just copy it like I do In the Finder. So that makes things more 

intimate and more Mac-like which was sort of my goal with this 

thing. As you can see, one of the things we had to do here 

was create a lot of Icons for these different resources to make 

them accessible for everyone. Like, here's the picture 

resource. If we double-click on that we see th~ picture. That 

happens to be a picture used by the alarm clock. /t's really fun 

with SeNant just to go exploring around and see the little 

pieces that the software you use everyday is made up that 

you're not usually aware of. 
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Chapter 5: Servant Reference 

Contents 

• Annotated List of Features 

• Topic Index to Features 

• Graphic Index to Features 

Annotated List of Features 

lA. To see If a floppy disk Is formatted with HFS or MFS ... 

Insert a disk with the Servant program on it Into a drive 

and double-click on the Servant icon. Close the disk window if 

it Is open. 

When Servant has been installed and the disk window Is 

closed. the disk icon will show whether or not the disk has been 

initialized with HFS. the hierarchical file system. Floppy disks 

formatted with HFS will show the letters HFS embossed on the 

disk Icon. Floppy disks formatted with MFS (Macintosh file 

system) have plain disk icons. 

1 B. To quickly resize the desktop to full size and back ... 

Click in the Zoom box in the upper-right corner of the 

window. The first click will resize any single window to the full 

size of the screen. A second click will resize the window to its 

size before the zoom. 
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To close the active window, click in the Close box in the upper­

left corner of the window or chose Close from the File menu. 

Closing a directory window causes the window to zoom back 

into its disk or folder icon. 

1C. To undo the current selection (and find directory 

information) ... 

Click anywhere in the information bar. Any selected icon 

or icons will become unselected. The information bar lies just 

below the window title and contains the item number, directory 

space in use, and disk space available. 

You can also undo the current selection by holding down the 

Option key and clicking an'ywhere in the window other than on 

top of an icon. 

The information bar shows the number of items in the window 

in the left corner, the amount of disk space in use by the 

directory items, expressed in K bytes, in the center, and the 

amount of disk space available for use, expressed in K bytes, in 

the right corner. 

The ruler iconette provides information about the disk space in 

use by individual items. 

10. To find the currently active System Folder. .. 

Look for the folder embossed with the big S symbol. 

Other System Folders will be embossed with a little Mac 

symbol. The little Mac designates an HFS System Folder that 

does not contain the currently active System. 
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Whenever a folder is selected, the Set Startup menu item from 

the Special menu becomes Set System Folder. This command 

can be used to switch the active System. 

1 E. To start Servant... 

Insert a disk with the Servant program on it into a drive 

and double-click on the Servant icon. This installs Servant in 

place of the Finder until you quit Servant or shut down your 

Macintosh. 

You can tell that Servant has been installed if you see a row of 

small icons along the bottom of the directory window. Servant 

does not use scroll bars. Also, the cursor in Servant is a hand 

when it's located over the desktop window's white space and 

the pull-down menu items are different than the Finder's. 

You can copy Servant to one or more or your disks by dragging 

the Servant application Icon onto your new disk. You can do 

this from the Finder, or if Servant is already running, from 

Servant itself. Servant is not copy-protected. 

Servant cannot run under the Switcher, MultiFinder, or itself. 

1F. To scroll along the desktop by pushing ... 

Hold down the mouse button while the cursor is a hand 

and drag. The cursor is a hand whenever it lies over a blank 

area within a window. When the cursor lies over a icon, it is an 

arrow. 

All icons within the window will scroll as a single unit. If you 
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think of a desktop window as a magnifying glass, the hand 

works like your own hand pushing a piece of paper beneath the 

lens. 

By giving the hand cursor a "push", the icons within a window 

will continue to scroll through the window in the direction of, and 

at a speed determined by, the push. A push begins by clicking 

the button and dragging the mouse, then letting up the button 

before the dragging has ended. Clicking the mouse will halt the 

automatic scrolling started by the hand push. 

By holding down the Command key, the hand cursor performs 

"high gear" scrOlling. The "high gear" effect makes scrolling 

more responsive to mouse movement (an equivalent movement 

scrolls a greater distance). 

The "eye" and "arrows" iconettes also serve the purpose of 

positioning icons within the desktop window. 

1G. To select (or drag or copy) an icon ... 

Click on top of the icon. The cursor is an arrow when it 

lies over an icon. Clicking will select the icon. Dragging will 

select and move the icon. 

To select a contiguous group of icons, first make sure the 

cursor is not on top of any icon. Now, double-click and drag the 

mouse (the hand cursor turns into an arrow when the button is 

held down on the second Click). This creates the selection 

rectangle with which to encompass the group of icons. 

Alternatively, you can press the Option key (this turns the hand 
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cursor into an arrow) and drag the mouse to create the 

selection rectangle. 

To select a noncontiguous group of Icons, hold down the Shift 

key (this prevents previous selections from becoming 

unselected) as you select each Icon of the group. 

The applications of selected icons can be opened by choosing 

Open from the File menu. Double-clicking on an icon will also 

open the application. 

The resources of selected icons can be opened by choosing 

Resource Open from the File menu. Double-clicking on an Icon 

with the Option key held down will also open the application's 

resources. 

In Servant, an icon that is being dragged retains the outline 

shape of its icon. This contrasts with the Finder which always 

shows a square outline when dragging. 

Servant displays a file copy in progess with icon animation. 

When copying is initlated-either by dragging or by using the 

Duplicate command from the File menu-the cursor becomes a 

question mark for a moment while Servant determines i.f the 

copy can be performed. If the copy cannot tbe performed, a 

dialog box occurs. Otherwise, the copy begins by producing 

the outline of the icon that is being created. As the source file 

is read into memory, the icon outline fills with grey. Finally, as 

the destination file is written to disk, the grey area fills with its 

final shape. 
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1 H. To resize the desktop ... 

Hold down the mouse button in the Size box in the 

bottom-right corner of the window and drag the mouse. The 

outline of the window shows you what the size of the window 

will be when you let go of the button. Changing the size of a 

window only affects the viewing area, not the window's contents 

or the position of the contents. 

1J. To view all icons on the desktop ... 

Hold down the button on the "eye" iconette. The active 

desktop window is shown in a "show page" view where all 

icons, in shrunken form if necessary, are visible. Also visible, if 

necessary, is a rectangular outline that indicates the portion of 

the desktop that represents the current default view of the 

window. 

By holding down the button on the "eye" iconette and dragging 

the mouse into the rectangular outline, you can move the 

current default view of the window. The outline can be dragged 

to any position on the desktop to encompass a set of icons. 

1K. To scroll the view of icons on the desktop ... 

Hold down the button with the cursor in the "arrows" 

iconette. The arrows ieonette changes form to indicate the 

desktop position of icons in relation to the viewing window. 

When the iconette shows a single dot, all icons are within view 

of the current window. When the ieonette pOints with one or 

more arrows, off-screen icons are present in the directions 

shown. 

62 



Holding down the button within the iconette will move the icons 

as a unit. The icons move in the direction that the cursor lies 

with respect to the center dot of the iconette. For instance. if 

the cursor Is bottom-left of the center dot. the icons will move to 

the bottom-left. 

Double-clicking on the arrows iconette will automatically center 

the icons within the viewing window. The iconette's arrows will 

indicate if icons remain outside the view of the centered 

window. 

The "eye" ieonette provides a method of viewing the entire 

desktop in shrunken form along with an outline of the current 

default window. 

1l. To view icons with name only ... 

Click on the "abc" iconette. This is the default setting. 

The same feature is offered by choosing Name Only from the 

View menu. 

1M. To view icons with name and size ... 

Click on the "ruler" iconette. The size of the file 

represented by each Icon Is displayed below the name. A file's 

size Is a measure of the disk space in K (1024) bytes or. if 

under 10K. B (single) bytes necessary to store the file. The 

same feature is offered by choosing Size from the View menu. 

1N. To view icons with name and date ... 

Click on the "calendar" iconette. The modification day. 

month. and year of the file represented by each icon is 
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displayed below the name. The same feature is offered by 

choosing Date from the View menu. 

1P. To shrink or expand icons in scale ... 

Click on one of the six "zoom" iconettes. The iconette's 

image reflects the relative size of the desktop icons. The 

currently selected iconette is shown with a thick border. 

The iconette fourth from the left is the default setting. The 

default size is 32-by-32 pixel icons, the same as the Finder's. 

The smaller size icons use fonts internal to Servant; they are 

not scaled-down from a larger point size. 

The "zoom" feature can also be implemented by choosing 

Zoom Out (for shrunken icons) or Zoom In (for expanded icons) 

from the View menu. 

2A. To switch among applications using a menu ... 

Choose the application that you want to become active 

from the Application menu. Each application that has been 

opened, yet is not currently active will be listed as an available 

menu item. The current active application will be a dimmed 

item. 

The Application menu is appended as the rightmost menu title 

to all applications running under Servant. Servant, itself, 

contains the Application menu whenever a background 

application exists. As an alternative to switching using the 

Application menu, you can switch among applications by 

clicking in a window of the background application. 
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The Application menu is particularly useful when an application 

is open, yet has no visible window. For instance, you may have 

opened MacWrite, then closed the current MacWrite document. 

MacWrite remains open even though it has no visible document 

window. If you switch to another application, then want to 

return to MacWrite, selecting the MacWrite Item from the 

Application menu will make it the active application (giving you 

the MacWrite menu bar). 

In the simplest case, an inactive application window may be 

completely covered over by other windows. Choosing the 

application name from the Application menu will make the 

application window active and bring its window to the top. 

See feature 2C for more information on switching using a 

window. See feature SA for an example of a pulled·down 

Application menu. 

28. To launch (and exit) one or more applications and their 

documents ... 

Double·click on the application's icon. You can also open 

an aPplication by selecting its icon, then choosing Open from 

the File menu. 

Unlike the Finder, Servant does not close the directory window 

after launching an application. Instead, the directory window 

moves to the background and functions (in most applications) 

like an inactive window. Servant's directory witldow can be 

made the active window by clicking on it or by choosing Servant 

from the Application menu. 
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After an application has been launched, it controls the 

Macintosh the same as if the application had been started from 

the Finder. Servant lies dormant beneath the application. The 

only difference is that, under Servant, an Application menu for 

application switching is appended as the rightmost menu title of 

the application's menu bar (the menu title is represented by the 

generic application icon). Servant should not affect the way the 

application performs. 

Servant allows one or more additional applications to be 

opened without first closing a previous application. The 

previous application remains in the background, usually shown 

as an inactive window. Like Servant, an inactive application 

can be made the active one by clicking on it's window or by 

choosing the application name from the Application menu. 

To launch additional applications, first bring the Servant window 

to the top by clicking on it or by selecting Servant from the 

Application menu. Once the Servant desktop is topmost and 

active, you can launch a new application by double-clicking on 

its icon. 

You can also open more than one application by selecting the 

icons you want opened (drag with the Option key down to make 

a selection rectangle or hold the Shift key down to make 

noncontiguous selections), then choosing Open from the File 

menu. Servant will open each application; the last one to open 

remains active. 
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To quit an application, use whatever method the application 

provides to exit. In most applications, you will choose Quit from 

the application's File menu. 

When you quit an application, the topmost Servant directory 

window becomes the active window and the application title is 

removed from the Application menu. 

In the event that an application Inexplicably ceases to function 

(the application hangs such that you cannot even quit), 

preSSing the four-key combination Command-Shift-Option­

Period will perform an emergency exit to the Servant desktop. 

To close an application's document use whatever method the 

application provides to exit. In most applications, you will click 

on the application's close box or choose Close from the 

application's File menu. 

When an application is running, the application (not Servant) 

controls the opening and closing of its documents. When you 

close a document without quitting its application, the running 

application retains control of the menu bar. 

This can be confusing if the underlying window is the Servant 

desktop or a second application. The Servant desktop or the 

second application's window are inactive even though it may be 

the only window you see on the screen. Yet you can count on 

the menu bar to always reflect the currently running application. 

Since Servant provides the ability to see more than one 

application on the screen I the concept of an active window 
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becomes even more important. An active window still has its 

window frame highlighted, reflects the currently running 

application, and, if one exists, is always the topmost window. 

Under Servant, inactive windows from other applications or the 

desktop window itself remain visible even when the running 

application's active window is closed. To avoid confusion about 

which is the currently running application, remember that any 

active window, as well as the menu bar, belong to the running 

application. But in some circumstances, there will be no active 

window visible-only inactive windows from non-running 

applications or the Servant desktop. 

Finally, when opening and closing documents within an 

application, the Servant desktop is not automatically updated. 

As a result, the document icons might not be appropriately 

dimmed or highlighted until Servant becomes the running 

application. 

2C. To switch among applications using a window ... 

Click on the window of the application you wish to 

become the active application. The window becomes topmost 

and application is ready to use. The menu bar is always set by 

the current active application, though Servant adds the 

Application menu as the rightmost menu title. 

As an alternative to clicking in an inactive window, you can 

switch among applications using the Application menu. The 

Application menu lists the open applications. The current active 

application is a dimmed menu item. 
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The Application menu is particularly useful when an application 

is open, yet has no visible window. If an inactive application 

window is closed or covered over by other windows, choosing 

the application name from the Application menu wi" make the 

application active and bring its window, if any is open, to the 

top. 

See feature 2C for more information on switching using a 

window. See feature SA for an example of a pulled-down 

Application menu. 

3A. To learn about Servant. .. 

Choose About Servant from the Apple menu. A window 

of information about Servant including author, version number, 

and release terms is displayed. Clicking the mouse button will 

close the window. 

3B. To learn quick tips about Servant features ... 

Choose Servant Tips from the Apple menu. A window of 

select instructions and shortcuts is displayed. Clicking the 

mouse button will close the window. 

3C. To send a preformatted bug report to the program author ... 

Choose Print Bug Report ... from the Apple menu. A 

standard print dialog box will appear. Click on the Okay button 

to print the bug report form on your printer. Once printed, follow 

the instructions on the form for documenting bugs and ordering 

documentation. (You should explain how someone else can 

reproduce a bug you have found.) 
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3D. To switch to Servant from another application ... 

Choose Servant from the Apple menu. The Servant 

menu item is appended to the Apple menu only when Servant 

is nQt the currently active application. A Servant menu item is 

also available from the Application menu (BA). 

4A. To open a new empty folder or one filled with selected 

icons ... 

Choose New Folder from the File menu. A folder with the 

name Empty Folder is created in the active window. The empty 

folder can be filled, renamed, and moved like any other folder. 

If the desktop has no active window, the New Folder item is 

dimmed. 

In addition, Servant allows you to create a new folder with 

selected files automatically inserted inside the folder. To create 

a new folder that is automatically filled, first select the icons you 

want inserted, then hold down the Option key and choose New 

Folder from the File menu. Though the newly created folder is 

still given the name Empty Folder, the selected files have been 

put inside. 

4B. To open a new blank file ... 

You will choose New File from the File menu, however 

this feature is not yet implemented. If a resource is the topmost 

window, the menu item is New Resource, also not yet 

implemented. 

4C. To open a selected icon ... 

Choose Open from the File menu. Alternatively, an icon 

can be opened by double-clicking on it. 
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More than one icon can be opened at the same time by 

selected the icons and choosing Open. Servant will open the 

icons in alphabetical order (to the extent memory allows). Each 

application or document will be represented as an item In 

Application menu. The last opened icon will become the 

current application (in control of the menu bar). 

It the icon represents an application, the application will be run. 

It the icon represents a document, the application that created 

the document will be run (a dialog box will indicate if such an 

application cannot be found on diSk), then the document 

opened. It the icon represents a folder, the folder window will 

be opened. 

40. To open the resources of a selected Icon ... 

Choose Resource Open from the File menu. Resources 

will be displayed as resource Icons. Each resource type has a 

unique icon. 

You can also open the resources of a Icon by holding down the 

Option key and double-clicking on the icon. 

The Icon of a resource type can be selected and opened 

(double-clicking on the Icon will also open it) to reveal resource 

file information. Servant's resource editing features are 

discussed in greater length in Chapt~r 4 .. 

4E. To print the contents of a selected document. .. 

Choose Print from the File menu. The application that 

created the selected document must be on the disk. Servant 
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opens the application and printing takes place in the same 

manner as it does from within the application. Most 

applications provide a dialog box before printing for the user to 

select printing options. 

More than one document can be printed at the same time by 

selected the icons and choosing Print. The documents will be 

printed in alphabetical order. 

4F. To close an active window ... 

Choose Close from the File menu. The active window 

closes and the immediately preceding window, if any, becomes 

active. As a window closes, its outline zooms back into the 

selected icon that created it. 

4G. To open an information window about an icon .... 

Choose Get Info from the File menu. The window states 

whether the icon represents an application, an application's 

document, or a folder. The window also states the item's size, 

type, date of creation, date of last modification, and the folder 

location of the item, nested up to four folders deep .. 

A check box allows the user to observe or change the Locked 

and Invisible status of applications and documents. A checked 

Locked box prevents a file from being put in the trash or having 

its name changed. 

Two input boxes allow theuser to specify the amount of memory 

to be allocated to the application. Most applications provide 

preset preferred and minimun memory requirements which can 

be changed to optimize the performance of a set of programs. 

72 



4H. To duplicate a selected icon ... 

Choose Duplicate from the File menu. A copy of the 

items represented by the selected icons Is saved onto the same 

disk. Therfame of each duplicate is prefixed with "Copy of.· 

If a folder is duplicated, a copy is made of the folder and its 

contents, and all items are prefixed with ·Copy of: 

Servant displays a file copy in progess with icon animation. 

When duplication is initiated, the cursor becomes a question 

mark for a moment while Servant determines if the copy can be 

performed. If the copy cannot tbe performed, a dialog box 

occurs. Otherwise, the copy begins by producing the outline of 

the icon that is being created. As the source file is read Into 

memory, the icon outline fills with grey. Finally, as the 

destination file is written to disk, the grey area fills with its final 

shape. 

4J. To set options for printing a disk or folder directory ... 

Choose Page Setup from the File menu. A dialog box 

allows you to determine the page size, orientation, and special 

effects for directories that are printed with the File menu's Print 

Catalog option. 

To set options for printing documents, you must use the Page 

Setup command offered within the document's application. 

Though documents can be printed from Servanrs desktop 

windows, the Page Setup options work only with directories 

printed by the Print Catalog command .. 
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4K. To print a disk or folder directory ... 

You will choose Print Catalog from the File menu, 

however this feature is not yet implemented. The contents of 

the active disk or folder window will be printed using Page 

Setup options in the same view as they appear in the window. 

4L. To quit from Servant. .. 

Choose Quit from the File menu. Quit exits Servant and 

causes the startup program to be installed. 

All open applications must be quit in order to exit Servant. To 

quit an application, make the application active, then choose 

Quit from its File menu. If you attempt to quit Servant while an 

application is open, a dialog box will tell you to first quit the 

application. 

When Quit is chosen, the Macintosh system installs the 

designated shell. By default, the shell is the program named 

Finder. 

The command Restart from the Special menu quits Servant and 

causes the system to reboot (equivalent to turning the 

Macintosh off then on again). The command Shut Down from 

the Special menu quits Servant, ejects floppy disks and 

unmounts hard disks, and produces the Shut Down dialog box. 

(On the Mac II, Shut Down ejects floppies and turns off the 

computer.) The command Eject Disk from the Special menu 

causes the current disk to be ejected. All open applications 

must be quit in order to use these commands. 
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5A. To undo certain desk accessory actions ... 

Choose Undo from the Edit menu. The specific actions 

that can be undone depend on the desk accessory. <?ften, the 

command is limited to text-editing actions. 

59. To cut a selection and make it the Clipboard's current 

contents ... 

Choose Cut from the Edit menu. The command works on 

Icon names, text from the Get Info window, and desk accessory 

text and pictures. However, the files represented by icons are 

not subject to the Cut command; they must be dragged to the 

Trash Can. 

5C. To copy a selection and make it the Clipboard's current 

contents ... 

Choose Copy from the Edit menu. The command works 

on Icon names, text from the Get Info window, and desk 

accessory text and pictures. However, the files represented by 

icons are not subject to the Copy command; they must be 

manipulated by dragging or File menu's Duplicate option. 

50. To paste a copy of the Clipboard's current contents ... 

Choose Paste from the Edit menu. A copy of the contents 

are placed at the Insertion point; the original contents remain 

unchanged. 

5E. To clear a selection without affecting the Clipboard ... 

Choose Clear from the Edit menu. The command works 

the same as the Cut command except the selection is not 

placed o~to the Clipboard. 
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5F. To select all the icons in the active window ... 

Choose Select All from the Edit menu. If no window is 

open, all desktop icons are selected. 

5G. To display the Clipboard window and its contents ... 

Choose Show Clipboard from the Edit menu. The 

Clipboard contains the most recent selection that was used in a 

Cut or Copy command. The Macintosh system creates and 

maintains a clipboard file (represented on the desktop by a 

generic system icon) to handle clipboard activity within and 

among applications. 

6A. To shrink icons in scale ... 

Choose Zoom Out from the View menu. The desktop is 

scaled so that icons are displayed in their next smallest size. 

Servant offers six views. The command has the same effect as 

clicking on the "zoom" iconette to the left of the currently 

selected one. 

68. To expand icons in scale ... 

Choose Zoom In from the View menu. The desktop is 

scaled so that icons are displayed in their next largest size. 

Servant offers six views. The command has the same effect as 

clicking on the "zoom" iconette to the right of the currently 

selected one. 

6C. To view icons with name only ... 

Choose Name Only from the View menu. This is the 

default setting when Servant is started. The same feature is 

offered by clicking on the "abc" iconette. 
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50. To view icons with name and size ... 

Choose Date from the View menu. The size of the file 

represented by each icon is displayed below the name. A file's 

size is a measure of the disk space in K (1024) bytes necessary 

to store the file. The same feature is offered by clicking on the 

-ruler" iconette. 

5E. To view icons with name and date ... 

Choose Date from the View menu. The creation day, 

month, and year of the file represented by each icon is 

displayed below the name. The same feature Is offered by 

clicking on the -calendar- iconette. 

7 A. To erase from disk the contents of the Trash Can ... 

Choose Empty Trash from the Special menu. The files In 

the Trash Can are erased from the disk and their disk space is 

made available. 

The contents of the Trash Can can be viewed in a window by 

clicking on its icon. When Empty Trash is chosen, the icons will 

disappear. Also, the disk information line of the active window 

will be updated. 

Servant will empty the Trash Can automatically whenever a 

new application Is launched or the space is needed. 

7B. To eject a disk from a disk drive ... 

Choose Eject Disk from the Special menu. The command 

ejects the selected disk or disks. If no disk is selected, the 
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command will eject the first disk found among the following: the 

disk that contains a selected item, the startup disk, or another 

inserted disk. Alternatively, a nonstartup disk can be ejected by 

dragging its icon to the Trash Can. 

7C. To initialize a selected disk, thus erasing all previous 

contents ... 

Choose Erase Disk from the Special menu. A dialog box 

will appear asking if you really want to erase the selected disk 

and, if so, should it be initialized as one-sided or two-sided. 

The command will not work on the current startup disk. If you 

have only one disk drive, insert a startup disk, eject the startup 

disk, then insert the disk you want erased. 

Pressing the one-sided button will initialize a disk with MFS 

(Macintosh file system). To initialize a one-sided disk with HFS 

(hierarchical file system) hold down the Option key as you 

press the one-sided button and keep the Option key down until 

the initialization is complete. Pressing the two-sided button will 

always initialize a disk with HFS. 

70. To make a selected application launch immediately upon 

startup (and designate the active System Folder) ... 

Choose Set StartUp from the Special menu. This allows 

you to bypass the Finder or Servant desktop when starting the 

Macintosh. 

To make Servant or the Finder the startup application, select 

the Servant or Finder icon from the directory window, and 

choose Set StartUp. 
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Whenever a folder is selected, the Set Startup menu item from 

the Special menu becomes Set System Folder. This command 

can be used to switch the active System. The currently active 

System Folder Is embossed with the big S symbol. Other 

System Folders are embossed with a little Mac symbol. The 

little Mac designates an HFS System Folder that does not 

contain the currently active System. 

7E. To make a selected MacPalnt or Thunderscan document 

become the background for the desktop ... 

Choose Set Background from the Special menu. The 

picture represented by the selected icon will automatically be 

installed as the background screen. You can use the Control 

Panel desk accessory to return the background to one of the 

standard Macintosh patterns. 

7F. To rearrange the icons In a particular order ... 

You will choose Rearrange from the Special menu. A 

dialog box will ask you to choose an order for arranging the 

icons. This feature is not yet implemented. 

7G. To create a custom icon or special folder Icon ... 

Select an icon (even a disk icon), then choose Custom 

Icon from the Special menu. A dialog box will appear 

containing the selected icon enlarged in fat bits. 

Within the icon Image, you can use the pencil cursor to 

manipulate each dot of the 32-by-32 pixel grid. The lower-right 

corner of the dialog box shows the icon in its actual size. 
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Clicking on the Okay button will return to the desktop with the 

custom icon installed. The custom icon will be used instead of 

the previous one until you change it again. 

Clicking on the Cancel button will return to the desktop without 

the custom icon installed. The icon that was previously used is 

retained. 

Clicking on the Revert button will redraw the icon in the dialog 

box the same as it was before your current changes. This does 

not return you to the desktop, but reverts the fat bits image to 

the last icon that was used. 

Clicking on the Revert button while holding down the Option 

key will redraw the icon in the dialog box the same as it was 

originally created by the program. This does not return you to 

the desktop, but reverts the fat bits image to the original 

program icon before any customization. 

In addition to self-customized icons, Servant can create special 

folder icons that contain a shrunken image (of the image itself) 

of another icon. To create a custom folder icon takes four 

steps: 

First, select the icon you want to appear shrunken on the folder 

icon. Second, choose Copy from the Edit menu. This puts the 

text of the icon onto the Clipboard. Third, select the folder you 

want the shrunken image to appear on. Finally, choose 

Custom Icon from the Special menu while holding down the 

Option key. (If you hold down the Command key instead of the 
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Option key, the selected icon will become the folder Icon rather 

than shrink onto the folder image.) 

The Custom Icon dialog box appears with the shrunken Icon 

inserted. on the folder. At this point, you can click In the Okay 

box to install the folder as you see it or further customize the 

icon with the pencil. 

7H. To install the options ... 

Choose Options ... from the Special menu. A dialog box 

with five check boxes allows you to configure Servant. After 

clicking the OK button, the checked configuration will remain in 

effect for all Servant sessions, including the current one, until 

the Options menu item is reselected and the options 

reconfigured. 

The Switcher On box. when checked. enables the switching 

function between appllcatlohl'.: When unchecked, switching is 
" . 

disabled, thus only one appl'lcation can be opened at a time and 

the Application menu is not appended to the menu bar. By 

default, the Switcher On box Is checked. 

The Show Invisibles box, when checked, will result In the Icons 

of invisible files (for example, the desktop file) to be displayed. 

When unchecked, these icons remain invisible. By default, the 

Show Invisibles box is unchecked. 

The Speech On box, when checked, causes the Macintosh to 

speak the names of files after they're selected and menu items 

after they're chosen. To use the speech option. the MacinTalk 

file must be in the system folder or on the desktop. When the 
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Speech On box is unchecked or the MacinTalk file is not 

available, speech does not occur. By default, the Speech On 

box is unchecked. 

The Save Screens box, when checked, stores the screens 

contents in RAM memory so that switching between 

applications can be performed faster and more smoothly. 

When unchecked, screens will not be stored, slowing switching 

time but saving 22K of RAM memory space (even more on 

large screens and up to 300K on the Mac II). The option has 

effect only when the Switcher On box is checked. By default, 

the Save Screens box is checked. 

The Auto-Center Dialogs box, when checked, centers dialog 

boxes for applications run on large screen displays. Servant 

dialogs are always auto-centered. 

7J. To display memory allocation information· about an 

application ... 

Choose Show Memory Info from the Special menu. The 

graphic display shows the portion of memory currently being 

used by an application (the dark gray region) and the additional 

memory available to the application (the light gray region). The 

number to the right of the bar graph region shows the total 

memory ailocated to an application. 

The Get Info menu item from Servant's File menu offers the 

user the option of allocating preferred and minimum memory to 

an application 
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7K. To reboot the Macintosh ... 

Choose Restart from the Special menu. Rebooting Is 

equivalent to turning the Macintosh off, then on again. The 

default shell is reinstalled. 

All open applications must be quit in order to use Restart. To 

quit an application, make the application active, then choose 

Quit from its File menu. 

To exit Servant and return to the Finder without rebooting the 

Macintosh, choose Quit from the File menu. Quit exits Servant 

and causes the System's startup program to be Installed. 

7L. To turn off the Macintosh ... 

Choose Shut Down from the Special menu. The Shut 

Down dialog box appears stating that the Macintosh can now 

be safely turned off. A Restart button allows you the option of 

rebooting Instead of turning off the Macintosh. On the Mac II, 

. Shut Down ejects floppies and turns off the computer 

All open applications must be quit In order to use Shut Down. 

To quit an application, make the application active, then choose 

Quit from its File menu. 

To install a new startup disk, you can use the Shut Down 

command. However, an alternative method (one that's easier 

on the power supply) is to hold down the Option key and 

double-click on the disk icon you want to be the startup disk. (If 

your disks use different System and Folder versions, use the 

Shut Down command.) 
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SA. To make a background application the active application ... 

Pull down the Application menu and choose from among 

the application items. Each application that has been opened, 

yet is not currently active will be listed as a menu item. The 

Application menu is appended as the rightmost menu title to all 

applications running under Servant. Servant, itself, contains 

the Application menu whenever a background application 

exists. 

You can also make a background application the active 

application by clicking in a window of the background 

application. 
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Topic Index to Features 

The Desktop 

1 A. To see if a floppy disk is formatted with HFS or MFS ... 

1 B. To quickly resize the desktop to full size and back ... 

1 C. To undo the current selection (and find directory 

information) ... 

lD. To find the currently active System Folder ... 

1 E. To start Servant. .. 

IF. To scroll along the desktop by pushing ... 

lG. To select (or drag or copy) an icon ... 

1 H. To resize the desktop ... 

lJ. To view all Icons on the desktop ... 

lK. To scroll the view of Icons on the desktop ... 

lL. To view Icons with name only ... 

1M. To view icons with name and size .. . 

IN. To view Icons with name and date .. . 

lP. To shrink or expand Icons in scale .. . 

The Desktop Running Applications 

2A. To switch among applications using a menu ... 

2B. To launch (and exit) one or more applications and their 

documents ... 

2C. To switch among applications us~ng a window ... 
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The Apple Menu 

3A. To learn about Servant. .. 

38. To learn quick tips about Servant features ... 

3C. To send a preformatted bug report to Andy Hertzfeld ... 

3~. To switch to Servant from another application ... 

The File Menu 

4A. To open a new empty folder ... 

48. To open a new blank script. .. 

4C. To open a selected icon ... 

40. To open the resources of a selected icon ... 

4E. To print the contents of a selected document... 

4F. To close an active window ... 

4G. To open an information window about an icon ... 

4H. To duplicate a selected icon ... 

4J. To set options for printing a disk or folder directory ... 

4K. To print a disk or folder directory ... 

4L. To quit from Servant. .. 

The Edit Menu 

5A. To undo certain desk accessory actions ... 

58. To cut a selection and make it the Clipboard's current 

contents ... 

5C. To copy a selection and make it the Clipboard's current 

contents ... 

50. To paste a copy of the Clipboard's current contents .. . 

5E. To clear a selection without affecting the Clipboard .. . 
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5F. To select all the icons in the active window ... 

5G. To display the Clipboard window and its contents ... 

The View Menu 

6A. To shrink Icons in scale .. . 

68. To expand icons in scale .. . 

6C. To view icons with name only ... 

60. To view icons with name and size .. . 

6E. To view icons with name and date .. . 

The Special Menu 

7A. To erase from disk the contents of the Trash Can ... 

7B. To eject a disk from a disk drive ... 

7C. To initialize a selected disk, thus erasing all previous 

contents ... 

70. To make a selected application launch immediately upon 

startup (and designate the active System Folder) ... 

7E. To make a selected MacPaint or Thunderscan document 

become the background for the desktop ... 

7F. To rearrange the icons In a particular order ... 

7G. To edit a selected Icon .•. 

7H. To install the options ... 

7J. To display memory allocation Information about an 

application ... 

7K. To reboot the Macintosh .. . 

7L. To turn off the Macintosh .. . 
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The Application Menu 

8A. To make a background application the active application ... 
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Graphic Index to Features 
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The 6re6/ AmericIJn Ser'YfJn/ Oocllmen/IJ/ion 
by Scott KronIck 

Rbout Seruant .•• 
Seruant Tips .•. 
Print bug report •.. 

Rlorm Clock 
Calculator 
Chooser 
Control Ponel 
Key Caps 
Note Pad 

Scrapbook 

Seruont 
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Page Setup ••• 
Print Catalog 

Quit 
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XA 
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Custom Icon for "Serllont" 
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Mlu:lntosh Serllant Options 

181 Switcher On 

o Show Inlllsibies 

o Speech On 

181 SCllle Screens 

o Auto-Center Dialogs 

Cancel 
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