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Introducing ResEdit 3.0 1

ResEdit 3.0 is a resource editing application used to create and edit Macintosh 
resources. It is part of the Macintosh suite of development tools, for developing 
Macintosh applications. ResEdit is a standard Macintosh application that runs 
on System 7.1 and later, as well as on Mac OS 8. The current version does not 
run on Motorola 68K-based Macintosh platforms.

This chapter describes ResEdit’s new features and then reviews the concepts 
and terminology you need to work with resources. It then shows you how to 
get started using ResEdit 3.0, complete with steps and sample screen shots.

Introduction 1

New Features 1

ResEdit 3 offers several new features:

■ Drag and drop. ResEdit provides drag-and-drop support for convenient 
resource manipulation.

■ WorldScript support. ResEdit provides support for double-byte, right-to-left 
scripts, allowing you to edit resources in any language or script.

■ Inline editing. ResEdit provides inline editing of resource attributes.

■ Hierarchical views. In the main document (resource type) window, ResEdit 
provides a Finder-like hierarchy, with a right-facing triangle next to each 
resource type. When clicked, the triangle turns down and exposes the 
individual resources in that resource type.

Resources 1

While familiarity with Macintosh programming concepts and terms is 
assumed, this section touches on the basic concepts you should understand 
before you begin to use ResEdit. For more information, see Inside Macintosh: 
More Macintosh Toolbox, for its description of the Resource Manager.

The Macintosh file structure is designed to include a data fork and a resource 
fork. Within the resource fork are stored individual resources, which are a basic 
element of every Macintosh application. Resources typically include data that 
Introduction 1-3
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describes menus, windows, controls, dialog boxes, sounds, fonts, and icons. 
Because such resources are separate from the application’s code, you can easily 
create and manage resources for menu titles, dialog boxes, and other parts of 
your application without recompiling. Resources also simplify the process of 
translating interface elements containing text into other languages.

Resources are classified by type. Each type has its own name, which consists of 
exactly four characters. Any characters in the Macintosh character set can occur 
in resource type names, but typically they consist of lower and uppercase 
letters, numerals, punctuation marks, and the space and Option-space 
characters. There are many types of resources, and you can create your own 
resource types with ResEdit if you don’t find the type you need.

To distinguish individual resources within a resource type, each one is given a 
resource ID number. Within a resource type, these numbers must be unique. The 
resource can also be given a resource name, but whether you provide this 
string is optional.

Resource flags specify how the resource is treated at runtime. See Inside 
Macintosh: More Macintosh Toolbox for more information on resource flags.

The rest of this chapter describes using ResEdit 3.0—how resource information 
is presented to you and how to create and edit resources.

Getting Started 1

Once you’ve installed ResEdit, you’re ready to begin creating or editing 
resources.

Launch ResEdit like any other Macintosh application, by double-clicking its 
icon from within the Finder or by selecting the application and going to the File 
menu in the Finder and choosing the Open command.

After the application has been launched, you can create a new document 
(resource type) or open an existing resource file. You can set numerous 
preferences to affect the behavior of ResEdit. For more information see “The 
File Menu” (page 2-3).
1-4 Getting Started
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The Windows in ResEdit 3.0 1

ResEdit 3.0 has a three-level window hierarchy. The main document window, 
called the resource type window, displays a list of resource types. Associated with 
the main window are two other windows you can open and work with:

■ the resource list window, which displays a list of individual resources of a 
single type

■ the resource editor window, where you can display and edit a single resource

In using ResEdit, most of your time is spent in manipulating and displaying 
data using these three windows. Figure 1-1 shows the three windows.
Getting Started 1-5
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Figure 1-1 The editor’s three windows

The Resource Type Window 1

The resource type window is a visual representation of all the resources found 
within the resource fork of a file. The resources are grouped by resource type 
and are listed alphabetically (Figure 1-2).
1-6 Getting Started
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Figure 1-2 Resource type window for the file MyResources.rsrc

To the left of each resource type is a triangle, which can be flipped downward 
to expand or collapse a sorted list of resources. Clicking the triangle toggles its 
orientation. When the triangle is facing right, individual resources for that type 
are not displayed. When the triangle is facing downward, individual resources 
are displayed.

Resource types within the resource types window are displayed in boldface, 
and individual resources are displayed in plain text. Just below the name of the 
resource types window are labels for the columns of resource attributes.

This information and its default format are presented in Table 1-1.
Getting Started 1-7
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Table 1-1 Displaying information in the resource type window

The Resource List Window 1

The resource list window (Figure 1-3) displays a sorted list of each resource for 
a single given Resource Type. These resources can by sorted by resource ID, 
name, or size. Clicking on a column label selects the sort criteria.

Column name Description

Type Gives the resource type for the class of resources.
ID Gives the resource ID of an individual resource.
Count Gives the number (count) of individual resources contained within a 

particular resource type.
Name Gives the resource name of each resource.
Size For a resource type, gives the total size in bytes of all resources within it. 

Also, the size in bytes for each individual resource.

Flag settings Give the flag settings currently chosen for each resource listed.

Pre Preload. Setting this attribute causes the Resource Manager to load the 
resource into memory immediately after opening the resource file.

Prt Protected. If this attribute is set, the Resource Manager can’t change the 
name or ID number of the resource, modify its contents, or remove the 
resource from the file that contains it.

Lok Locked. If this attribute is set, the resource is locked in place in the heap 
and can’t be moved. Lok overrides the Purgeable attribute.

Prg Purgeable. If this attribute is set, the resource can’t be purged from memory 
if more room is needed.

Sys System heap. If this attribute is set, the resource is placed in the system 
heap unless it is too large to fit. If it is too large, it is placed in the 
application heap, as if the box were not checked. This attribute should not 
be set for an application’s resources.
1-8 Getting Started
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Figure 1-3 A resource list window

A Resource Editor Window 1

A resource editor window (Figure 1-4) allows you to manipulate the data 
contained in a single resource. Each resource type has a specific editor 
associated with it so that the data can be meaningfully presented and edited.
Getting Started 1-9
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Figure 1-4 A resource editor window, open for editing

Managing Files 1

This section tells you how to create, open, and edit files using ResEdit.

Creating a New File 1

Choose New from the File menu to create a new, untitled document, as shown 
in Figure 1-5.
1-10 Getting Started
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Figure 1-5 A new, untitled document

Opening a File 1

You can open a file with ResEdit in several ways:

■ To open an existing file from within ResEdit, choose Open from the File 
menu and select the file you want to open.

■ To open an existing file from within the Finder, drag the file on top of the 
ResEdit application. 

To edit an existing resource, you simply choose Open from the File menu and 
then choose the file you want to open. The example shown here (Figure 1-6) is 
taken from a sample file titled MyResources.rsrc.

Figure 1-6 An open resource file

Saving a File 1

To save the current file, choose Save or Save As from the File menu. Use Save 
As to save your file for the first time or to rename it.
Getting Started 1-11
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Working With Resources 1

This section describes very simply how to create, delete, and select resources.

Creating Resources 1

To create a new resource, choose New Resource from the Resource menu. A 
dialog box appears, allowing you to enter the type of resource you want to 
create. Enter a four-character resource type into the dialog box and click OK to 
bring up a resource editor window. Which editor is invoked depends upon the 
particular resource type you’ve created.

When you have finished editing the resource, you can close the window.

Deleting Resources 1

An individual resource can be deleted by selecting it and either pressing the 
Delete key or choosing Clear from the Edit menu.

Selecting Resources 1

ResEdit supports selection of more than one resource at a time. This design lets 
you perform edit operations (such as Copy or Clear) easily on sets of resources.

The Shift and Command keys provide different behaviors of multiple selection. 
The Shift key lets you select adjacent resources. The Command key lets you 
select and deselect individual resources.

From the resource types window you can select any number of resources or 
types. Selecting a resource type is a simple way of selecting all the resources 
within that type.

Performing a Drag-and-Drop Operation 1

ResEdit supports drag and drop for convenient manipulation of resources. For 
example, you can drag the currently selected resources to copy them to a 
second open resource file. You can also create a Finder Clipping file for future 
access to commonly used resources.
1-12 Getting Started
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Editing Resources 1

In ResEdit you can edit resource attributes and resources. This section shows 
you how.

Editing Resource Attributes 1

Attributes such as resource ID, name, and each of the five flags (Pre, Prt, Lok, 
Prg, and Sys) can be edited in place in both the resource type window and the 
resource list window. To edit an attribute, click once to select a resource.  Then 
click once again on the desired attribute to be edited. A text edit box will 
appear around the attribute, which you can now edit. This is shown in 
Figure 1-7.

Figure 1-7 Editing the resource name for ‘MENU’ 128

Editing a Resource 1

Resources are edited by invoking an editor on them. Editors can be invoked 
from either the resource type window or the resource list window. To invoke 
the editor specific to the chosen resource, either double-click an individual 
resource or select the resource and choose Open Selection from the Resource 
menu. A resource editor window appears. You can manipulate the resource 
data within this box.

Setting Preferences 1

This section to be completed in a future release.
Getting Started 1-13
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In this chapter you’ve learned how to get started using ResEdit so that you can 
port your applications to Mac OS 8. In the next chapter you learn the basic 
menu commands.
1-14 Getting Started
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The Menus 2

This chapter describes the five main menus of ResEdit: File, Edit, Resource, 
Window, and View. Discussion of several of the ResEdit menu items has been 
deferred until later developer releases.

The File Menu 2

The File menu contains the standard commands used in most applications, as 
you can see in Figure 2-1.

Figure 2-1 The File Menu

Here’s how the commands for this menu act:

New Brings up a main document window named “Untitled”.
Open Brings up a dialog box. From it, you select the file you 

want to open.
Close Closes the currently active window.
Save Saves the currently active file. This item is dimmed if no 

changes have been made to it.
Save As… Brings up a dialog box in which you can enter a filename 

to save the current file you’re editing to.
Revert Restores the currently active file, if there is one, to the last 

version you saved. This item is dimmed if no changes have 
been made.
The File Menu 2-3
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Preferences Brings up a dialog box (Figure 2-2) that lets you specify 
how to work with the resource editor. You can choose such 
things as whether the application should confirm certain 
operations with you before carrying them out. You can also 
choose fonts for displaying edit text, static text, and 
hexadecimal notation.

Quit Quits the ResEdit application.

Figure 2-2 The Preferences dialog box

The Edit Menu 2

The Edit menu contains the standard editing commands used in most 
applications, as you can see in Figure 2-3.
2-4 The Edit Menu
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Figure 2-3 The Edit menu

When a resource type window is active, the Edit menu commands have the 
following effects:

Undo/Redo Undoes or redoes your last command.
Cut Removes selection to the Clipboard.
Copy Copies selection to the Clipboard.
Paste Copies the previously cut resources into the resource type 

window.
Clear Removes selection.
Select All Selects all items at the current level.

The Resource Menu 2

The Resource menu (Figure 2-4) provides the commands appropriate for the 
frontmost window.
The Resource Menu 2-5
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Figure 2-4 The Resource menu

The Resource menu commands have the following effects:

New Resource Creates a new resource of a specified type.
Open Selection Where applicable, this command opens the item you have 

selected in the currently active window. If the item you 
have selected can’t be opened, this command is dimmed.

Open Using Hex Editor
Where applicable, this command opens the item you have 
selected in the currently active window and shows the 
information in hexadecimal notation. If this information 
can’t be shown in hexadecimal, this command is dimmed.

Revert Resource(s)
Restores the resources to their last saved state. If you have 
made changes in individual resources of the selected type 
since you last saved the file, you can undo those changes at 
this point.

New List Entry Creates a new entry in the active resource list.
Delete List Entry Deletes selected entry from the active resource list.
Convert TMPL(s) To be described in a later release.
Duplicate (not shown in figure) Copies a selected resource and gives 

it a unique resource ID starting with number 128.
2-6 The Resource Menu
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The View Menu 2

The View menu (Figure 2-5) lets you change the sort order of the resources in 
the resource list window.

Figure 2-5 The View menu and an open resource list window

The menu items have the following effects:
By ID Sorts the resources by ID.
By Name Sorts the resources by name.
By Size Sorts the resources by size.
By Data To be filled in for a later release.

The Window Menu 2

The Window menu lists the windows that are currently open. The active 
window is indicated by a checkmark. 

Figure 2-6 shows a Window menu listing four open windows. The checkmark 
next to the window titled “'ALRT' 1500 from MyResources.rsrc” indicates that 
this window is currently active.

Selecting a window from this menu will activate that window, making it 
frontmost.
The View Menu 2-7
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Figure 2-6 The Window menu and four open files of the resource editor

There is one command in the Window menu:

Rotate Windows Activates the window that follows the currently active 
window.
2-8 The Window Menu
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