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HP E3490A Software Probe—At a Glance

The HP E3490A Software Probe
provides a low-cost way to debug
embedded software for processors
which have on-chip debug features.
The HP E3490A Software Probe
supports the Motorola CPU32 family of
microprocessors, including the
MC6833x, MC68340, and MC68360
microprocessors.  Other processor
families may also be supported by the
time you read this.

The target connection
The HP E3490A Software Probe
connects to your target microprocessor
via a processor family-specific cable.
The cable plugs into a special
connector on the target system.  Flying
leads can also be used to connect the
HP E3490A Software Probe to the
appropriate target signals.

The host computer connection
The HP E3490A Software Probe can
communicate with a host computer via
a LAN connection (10 BASE-T or
10 BASE2).
It can also communicate with a host
computer via an RS-232 serial
connection.

The configuration switches
Use the switches to configure
communication to the host computer.
There is a guide to these switches on
the bottom of the HP E3490A Software
Probe.

The status LEDs
LEDs show the status of the power
supply, the target system, and the
connection to the host computer.

Compatibility with other products
The HP E3490A Software Probe must be
used with host-based software such as
the HP Debugger/ Emulator. The
debugging features available depend on
the microprocessor’s on-chip debug
features and on the host user interface
software being used.

Differences Between an HP Emulator
and the HP E3490A Software Probe
A debugger will behave just as if it is
connected to an emulator, except:

• Trace functions are not
available. You can use an HP logic
analyzer if you need to trace
bus-level activity.

• Emulation memory is not available.
• Like some HP emulators, the

HP E3490A Software Probe has a
built-in terminal interface, but it
should only be used for configuration
or troubleshooting.

• Some emulator features are not
supported, such as supplying a clock
or blocking resets while running in
the monitor.

Because both an emulator and the
HP E3490A Software Probe use BDM
resources, you cannot use both at the
same time.
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Connecting to the Host Computer

To use the HP E3490A Software Probe you need to:

• Connect the HP E3490A Software Probe to a power source

• Connect the HP E3490A Software Probe to the host computer via a
LAN or serial connection

• Set up the host software

• Connect the HP E3490A Software Probe to the target system
(described in the next chapter)

If you plan to use the HP Debugger/Emulator interface on a UNIX
workstation, you must use a LAN connection. 

If you plan to use the HP Real-Time C Debugger interface on a PC,
you can use a LAN or serial connection.  If you use a LAN connection,
you will need to set up a serial connection to set the IP address.

Connecting to the Host Computer 
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Connecting the HP E3490A Software Probe to a
Power Source

The HP E3490A Software Probe does not have an On/Off switch. To
turn the HP E3490A Software Probe on or off, plug or unplug it from
the power supply.

To choose a power cord

The HP E3490A Software Probe is shipped from the factory with a power
supply and cord appropriate for your country.  You should verify that you
have the correct power cable for installation by comparing the power cord
you received with the HP E3490A Software Probe with the drawings under
the "Plug Type" column of the following table.

If the cord you received is not appropriate for your electrical power outlet
type, contact your Hewlett-Packard sales and service office.

W a r n i n g Use only the supplied HP power supply and cord.
Failure to use the proper power supply could result in electric shock.

C a u t i o n Use only the supplied HP power supply and cord.
Failure to use the proper power supply could result in equipment damage.

Connecting to the Host Computer 
To choose a power cord
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Plug Type Cable Part No. Plug Description Length in/cm Color

Opt 903
125V **

8120-1378

8120-1521

Straight
 * NEMA5-15P
90o

90/228

90/228

Jade Gray

Jade Gray

Opt 900
250V

8120-1351

8120-1703

Straight
 * BS136A
90o

90/228

90/228

Gray

Mint Gray

Opt 901
250V

8120-1369

8120-0696

Straight
 * NZSS198/ASC
90o

79/200

87/221

Gray

Mint Gray

Opt 902
250V

812001689

8120-1692

8120-2857

Straight
 * CEE7-Y11
90o

Straight
(Shielded)

79/200

79/200

79/200

Mint Gray

Mint Gray

Coco
Brown

* Part number shown for plug is industry identifier for plug only.
Number shown for cable is HP part number for complete cable including plug.
** These cords are included in the CSA certification approval for the equipment.

Connecting to the Host Computer 
To choose a power cord
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Plug Type Cable Part No. Plug Description Length in/cm Color

Opt 906
250V

8120-2104

8120-2296

Straight
* SEV1011
1959-24507
Type 12
90o

79/20

79/200

Mint Gray

Mint Gray

Opt 912
220V

8120-2957

Straight
*DHCK107
90o

79/200

79/200

Mint Gray

Mint Gray

Opt 917
250V

8120-4600

8120-4211

Straight
SABS164
90o

79/200

79/200

Jade Gray

Opt 918
100V

8120-4753

8120-4754

Straight Miti

90o

90/230

90/230

Dark Gray

* Part number shown for plug is industry identifier for plug only.
Number shown for cable is HP part number for complete cable including plug.
** These cords are included in the CSA certification approval for the equipment.

Connecting to the Host Computer 
To choose a power cord
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To connect the power cord and turn on the HP E3490
Software Probe

1 Connect the power cord to the power supply and to a socket outlet.

2 Connect the 5V power cord to the back of the HP Software Probe.

The power light on the target side of the HP Software Probe will be illuminated.  The HP
Software Probe does not have an On/Off switch.

Connecting to the Host Computer 
To connect the power cord and turn on the HP E3490 Software Probe

8



Setting Up a LAN Connection 

The HP E3490A Software Probe has two LAN connectors:

• A BNC connector that can be directly connected to a IEEE 802.3
Type 10BASE2 cable (ThinLAN). When using this connector, the
HP E3490A Software Probe provides the functional equivalent of a
Medium Attachment Unit (MAU) for ThinLAN.

• An IEEE 802.3 Type 10BASE-T (StarLAN) connector. 

Use either the 10BASE2 or the 10BASE-T connector. Do not use both.
The HP E3490A Software Probe will not work with both connected at
the same time.

You must assign an IP address (Internet address)  to the HP E3490A
Software Probe before it can operate on the LAN. You can also set
other network parameters such as a gateway address. The IP address
and other network parameters are stored in nonvolatile memory
within the HP E3490A Software Probe.

The HP E3490A Software Probe automatically sets a subnet mask
based on the subnet mask used by other devices on the network.

You can configure LAN parameters in any of the following ways:

• Using the built-in terminal interface. This is the most reliable
method.

• Using ipconfig700. The ipconfig700 program is supplied with HP
Debugger/Emulators which run on HP and Sun workstations.

• Using BOOTP.  BOOTP is part of the HP-UX, SunOS, and Solaris
operating systems.

Connecting to the Host Computer 
To connect the power cord and turn on the HP E3490 Software Probe
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To obtain an IP address 

1 Obtain the following information from your local network
administrator or system administrator:

• An IP address for the HP E3490A Software Probe.

• The gateway address. 

The gateway address is an IP address and is entered in integer dot notation.
The default gateway address is  0.0.0.0, which allows all connections on the
local network or subnet.  If connections are to be made to workstations on
other networks or subnets, this address must be set to the address of the
gateway machine. 

2 Find out whether port numbers 6470 and 6471 are already in use on
your network.
The host computer interfaces communicate with the HP E3490A Software
Probe through two TCP service ports. The default base port number is 6470.
The second port has the next higher number (default 6471). 

The default numbers (6470, 6471) can be changed if they conflict with some
other product on your network. TCP service port numbers must be greater
than 1024. If you change the base port, the new value must also be entered in
the /etc/services file on the host computer. For example, you could modify
the line:

hp64700    6470/tcp

To change the port numbers, see page 11. If you have already set the IP
address, you can use a telnet connection instead of a serial connection to
connect to the  HP E3490A Software Probe.

3 Write down the link-level address of the HP E3490A Software Probe.
You will need this address if you use BOOTP or ipconfig700 to set the IP
address.

The link-level address (LLA) is printed on a label above the LAN connectors
on the HP E3490A Software Probe.  This address is configured in each
HP E3490A Software Probe shipped from the factory and cannot be changed.

Connecting to the Host Computer 
To obtain an IP address 
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To configure LAN parameters using the built-in
terminal interface  

1 Set configuration switches S1 through S4 to CLOSED,  and set the
other switches as appropriate for your serial interface.
Switch settings are printed on the bottom of the HP E3490A Software Probe.
If you will use a baud rate of 9600 baud, set the switches like this:

2 Connect an ASCII terminal (or terminal emulator) to the HP E3490A
Software Probe’s RS-232 port with a 9-pin RS-232 cable.
Complete instructions for setting up a serial connection begin on page 20.

3 Plug in the HP E3490A Software Probe’s power cord. Press the
terminal’s <RETURN> key a couple times.  You should see a "p>" or
"R>" prompt.
At this point, you are communicating with the HP E3490A Software Probe’s
built-in terminal interface.

4 Display the current LAN configuration values by entering the lan

command:
R>lan
lan is disabled
lan -i 0.0.0.0
lan -g 0.0.0.0
lan -p 6470
Ethernet Address : 08000903212f

The "lan -i" line shows the current IP address (IP address) of the HP E3490A
Software Probe.

The Ethernet address, also known as the link level address, is preassigned at
the factory, and is printed on a label above the LAN connectors.

5 Enter the following command:

lan -i <internet> [-g <gateway>] [-p <port>]

The lan command parameters are:

-i <internet> The IP address which you obtained from your network administrator.

Connecting to the Host Computer 
To configure LAN parameters using the built-in terminal interface  
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-g <gateway> The gateway address.  Setting the gateway address allows access outside
your local network or subnet.

-p <port> This changes the base TCP service port number. 

The default numbers (6470, 6471) can be changed if they conflict with some
other product on your network. TCP service port numbers must be greater
than 1024. If you change the base port, the new value must also be entered in
the /etc/services file on the host computer. For example, you could modify
the line:

hp64700    6470/tcp

6 Disconnect the power cord from the HP E3490A Software Probe, and
connect the the HP E3490A Software Probe to your network. 
This connection can be made by using either the 10BASE-T connector or the
10BASE2 (BNC) connector on the HP E3490A Software Probe.  Do not use
both connectors at the same time.

7 Set the configuration switches to indicate the type of connection that
is to be made.
Switch S1 must be set to OPEN, indicating that a LAN connection is being
made.

Switch S5 should be 1 if you are connecting to the BNC connector:

Switch S5 should be 0 if you are connecting to the 10BASE-T connector:

Set all other switches to CLOSED.

8 Connect the power cord to the HP E3490A Software Probe.
9 Verify your HP E3490A Software Probe is now active and on the

network. See "To verify LAN communications" on page 19.

Connecting to the Host Computer 
To configure LAN parameters using the built-in terminal interface  
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Once you have set a valid IP address, you can use the telnet utility to connect
to the HP E3490A Software Probe, and use the lan command to change LAN
parameters.

Example For example, to assign an IP address of 192.6.94.2 to the HP E3490A
Software Probe, enter the following command:

R>lan -i  192.6.94.2 

The IP address and any other LAN parameters you change are stored in
nonvolatile memory and will take effect the next time the HP E3490A
Software Probe is powered off and back on again.

See Also "Solving Problems," page 101, if you have problems verifying LAN
communication.

Connecting to the Host Computer 
To configure LAN parameters using the built-in terminal interface  
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To configure LAN parameters using "ipconfig700" 

If you are using an HP 9000 Series 300/400/700 computer or Sun
SPARCsystem computer and you have installed the HP B1471 64700
Operating Environment software, you can configure the HP E3490A Software
Probe’s LAN parameters with the ipconfig700 command.

The ipconfig700 command sets the IP address and gateway address for the
HP E3490A Software Probe.  An IP address must be configured before a
network interface connection can be made.

The ipconfig700 command cannot be used if your workstation is running a
bootp daemon.  If this is the case, use BOOTP to configure LAN parameters.
To determine if BOOTP is enabled on your computer, see "To configure LAN
parameters using BOOTP" in this chapter.

The following steps need to be taken when configuring the network
parameters with ipconfig700.

1 Connect the the HP E3490A Software Probe to your network.  This
connection can be made by using either the 10BASE-T connector or
the 10BASE2 BNC connector on the HP E3490A Software Probe.

2 Set the configuration switches to indicate the type of connection that
is to be made.
Switch S1 must be set to OPEN, indicating that a LAN connection is being
made. Switch S6 must bet set to OPEN, to allow programming of the LAN
parameters. 

Switch S5 should be 1 if you are connecting to the BNC connector:

Switch S5 should be 0 if you are connecting to the 10BASE-T connector:

Set all other switches to CLOSED.

3 Turn ON power to the HP E3490A Software Probe.

Connecting to the Host Computer 
To configure LAN parameters using "ipconfig700" 
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4 Wait at least 20 seconds for the HP E3490A Software Probe to
connect to the LAN.

5 Become the root user on the system from which you wish to
configure the HP E3490A Software Probe.

6 Enter the following command:

ipconfig700 -l <link>  -i  <internet>  [ -g <gateway>]

The ipconfig700 parameters are:

-l <link> The link-level address.  Enter any letters in the address in upper case.

-i <internet> The IP address. 

-g <gateway> The gateway address. 

If the ipconfig700 command is entered without any options, the program
interactively prompts for the necessary information.

7 Set switch S6 back to CLOSED.
8 Verify your HP E3490A Software Probe is now active and on the

network. See "To verify LAN communications" on page 19.

Example If the link-level address on your HP E3490A Software Probe read
08000F090F30, and your system administrator gave you the IP address
192.35.12.6, you could enter the following command:
$ ipconfig700 -l  08000F090B30 -i  192.35.12.6 <RETURN>

Because no gateway address was entered, this value would default to 0.0.0.0.
When the IP address is successfully programmed, ipconfig700 will display the
HP E3490A Software Probe version information.

Limitations of ipconfig700

The ipconfig700 command generally will not work if:

• the workstation and the HP E3490A Software Probe are on different subnets, or

• a BOOTP daemon running elsewhere on your network is configured to
respond to the link-level address of the HP E3490A Software Probe.

Connecting to the Host Computer 
To configure LAN parameters using "ipconfig700" 

15



To configure LAN parameters using BOOTP 

Use this method only if your HP-UX workstation is already running bootpd,
the BOOTP daemon. The ipconfig700 command does the same thing as
BOOTP and is easier to use. 

The BOOTP software is shipped with HP-UX version 8.0 or later.  Your
Hewlett-Packard Sales Engineer can provide the BOOTP software if you have
an earlier version of HP-UX.

1 Make sure that your host computer supports BOOTP.
If the following commands yield the results shown below, your machine
supports the BOOTP protocol.
$ grep bootp /etc/services 
bootps      67/udp
bootpc      68/udp
$ grep bootp /etc/inetd.conf 
bootps  dgram  udp  wait    root  /etc/bootpd   bootpd

If the commands did not yield the results shown, you must either add BOOTP
support to your workstation or use a different method to configure the
HP E3490A Software Probe LAN parameters.

2 Add an entry to the host BOOTP database file, /etc/bootptab.  For
example:

# Global template for options common to all HP 64700
emulators and Software Probes.
# Gateway addresses can be specified differently if
# necessary.

hp64700.global:\
        :gw=0.0.0.0:\
        :vm=auto:\
        :hn:\
        :bs=auto:\
        :ht=ether

# Specific emulator entry specifying hardware address
# (link-level address) and ip address.

hpprobe.div.hp.com:\
        :tc=hp64700.global:\
        :ha=080009090B0E:\

Connecting to the Host Computer 
To configure LAN parameters using BOOTP 
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        :ip=192.6.29.31

In the example above, the "ha=080009090B0E" identifies the link-level
address of the HP E3490A Software Probe. 

The "ip=192.6.29.31" specifies the IP address that is assigned to the
HP E3490A Software Probe. 

The node name is "hpprobe.div.hp.com". 

For additional information about using bootpd, refer to the HP-UX man pages.

3 Connect the the HP E3490A Software Probe to your network. 
This connection can be made by using either LAN connector on the
HP E3490A Software Probe.

4 Set the configuration switches to indicate the type of connection that
is to be made.
Switch S1 must be set to OPEN, indicating that a LAN connection is being
made.

Switch S6 must be set to OPEN to enable BOOTP mode.

Switch S5 should be set to CLOSED if you are connecting to the BNC
connector 

Switch S5 should be set to OPEN if you are connecting to the  10BASE-T
connector.

Set all other switches to CLOSED.

5 Connect the power cord to the HP E3490A Software Probe.
Verify that the power light stays on after 10 seconds. 

The IP address will be stored in EEPROM.

6 Set switch S6 back to CLOSED.  

Connecting to the Host Computer 
To configure LAN parameters using BOOTP 
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Do this so that the HP E3490A Software Probe does not request its IP
address each time power is cycled.  The IP address is stored in EEPROM, so
BOOTP does not need to be run again.  Leaving this switch on will result in
slower performance, increased LAN traffic, and even failure to power up (if
the BOOTP server becomes inactive).

7 Verify your HP E3490A Software Probe is now active and on the
network. See "To verify LAN communications" on page 19.

To set the 10BASE-T configuration switches

Set switches S7 and S8 to CLOSED unless one of the following conditions is
true:

• If the LAN cable exceeds the standard length, set switch S7 to OPEN.
The HP E3490A Software Probe has a switch-selectable, twisted-pair receiver
threshold.  With switch S7 set to OPEN, the twisted-pair receiver threshold is
lowered by 4.5 dB.  This should allow you to use cable lengths of up to about
200 meters.  If you use a long cable, you should consult with your LAN
cabling installer to ensure that:

• The device at the other end of the cable has long cable capability, and

• The cable is high-grade, low-crosstalk cable with crosstalk attenuation
of greater than 27.5 dB.

When switch S7 is set to CLOSED, the LAN port operates at standard
10BASE-T levels. A maximum of 100 meters of UTP cable can be used.

• If your network doesn’t support Link Beat integrity checking or if the
HP E3490A Software Probe is connected to a non 10BASE-T network
(such as StarLAN) set this switch to LINK BEAT OFF (0 or OPEN).
In normal mode (switch S8 set to CLOSED), a link integrity pulse is
transmitted every 15 milliseconds in the absence of transmitted data.  It
expects to receive a similar pulse from the remote MAU.  This is the standard
link integrity test for 10BASE-T networks.  If your network doesn’t support
the Link Beat integrity checking or if the Software Probe is used on a non
10BASE-T network (such as StarLAN) set this switch to LINK BEAT OFF
(OPEN).  

N o t e Setting switch S8 to OPEN when Link Beat integrity checking is required by
your network will cause the remote MAU to disable communications.

Connecting to the Host Computer 
To set the 10BASE-T configuration switches
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To verify LAN communications

1 Verify your HP E3490A Software Probe is now active and on the
network by issuing a telnet to the IP address. 
This connection will give you access to the HP E3490A Software Probe’s
built-in terminal interface.  

2 To view the LAN parameters, enter the lan command at the terminal
interface prompt.

3 To exit from this telnet session, type <CTRL>D at the prompt.
The best way to change the HP E3490A Software Probe’s IP address, once it
has already been set, is to telnet to the HP E3490A Software Probe and use
the terminal interface lan command to make the change. Remember, after
making your changes, you must cycle power or enter a terminal interface
init -p command before the changes take effect.  Doing this will break the
connection and end the telnet session.

If You Have Problems

If you encounter problems, refer to the "Problems" chapter (page 101).

Example $ telnet 192.35.12.6 

R>lan
lan is enabled
lan -i 192.35.12.6
lan -g 0.0.0.0
lan -p 6470
Ethernet Address : 08000F090B30

Connecting to the Host Computer 
To verify LAN communications
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Setting Up a Serial Connection

To set up a serial connection, you will need to:

• Set the serial configuration switches

• Connect the HP E3490A Software Probe to the RS-232 interface

• Connect a serial cable between the host computer and the
HP E3490A Software Probe

• Verify communications

Serial connections on a workstation

You should not use a serial connection on a workstation, except to set
LAN parameters.

If you are using a UNIX workstation as the host computer, you need to
use a serial device file. If a serial device file does not already exist on
your host, you need to create one. Once it exists, you need to ensure
that it has the appropriate permissions so that you can access it. See
the system documentation for your workstation for help with setting
up a serial device.

Serial connections on a PC

Serial connections are supported on PCs. You must use hardware
handshaking if you will use the serial connection for anything other
than setting LAN parameters.

If you are using a PC as the host computer, you do not need to set up
any special files.

Connecting to the Host Computer 
To verify LAN communications
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To set the serial configuration switches 

1 Set switch S1 to CLOSED (RS-232).
2 Set switches S2-S4 to CLOSED.
3 Set switch S5 to CLOSED (HW HANDSHAKE ON) if your serial

interface uses the DSR:CTS/RTS lines for flow control.  Set S5 to
OPEN (HW HANDSHAKE OFF) if your serial interface uses software
flow control (XON/XOFF).
If your serial interface supports hardware handshaking, you should use it (set
switch S5 to CLOSED).  Hardware handshaking will make the serial
connection much more reliable.

4 Set switches S6-S8 for the baud rate you will use. These switch
settings are listed on the bottom of the HP E3490A Software Probe.
The higher baud rates may not work reliably with all hosts and user
interfaces.  Make sure the baud rate you choose is supported by your host
and user interface.

Example To use a baud rate of 9600 baud, set the switches as follows:

To connect a serial cable

C A U T I O N Use a grounded, shielded cable.  If the cable is not shielded, or if the cable is
not grounded at the serial controller, the HP E3490A Software Probe may be
damaged by electrostatic discharge.

1 Connect an RS-232C modem cable from the host computer to the
HP E3490A Software Probe.
The recommended cable is HP part number C2932A.  This is a 9-pin cable
with one-to-one pin connections.

Connecting to the Host Computer 
To set the serial configuration switches 
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If you want to build your own RS-232 cable, follow the pinout shown in the
following figure:

Serial Cable Pinout

Pin
Number

Signal Signal Description

1 DCD Data Carrier Detect (not used)
2 TD Transmit Data (data coming from HP E3490A Software Probe)
3 RD Receive Data (data going to HP E3490A Software Probe)
4 DTR Data Terminal Ready (not used)
5 GND Signal Ground
6 DSR Data Set Ready (Output from HP E3490A Software Probe)
7 RTS Request to Send (Input to HP E3490A Software Probe)
8 CTS Clear to Send (connected to pin 6)
9 RING Ring Indicator (not used)

Connecting to the Host Computer 
To connect a serial cable
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To verify serial communications 

1 Start a terminal emulator program on the host computer.
If you are using a PC, the Terminal application in Microsoft Windows will
work fine.

If you are using a UNIX workstation, you can use a terminal emulator such as
cu or kermit.

2 Plug the power cord into the HP E3490A Software Probe.
When the HP E3490A Software Probe powers up, it sends a message (similar
to the one that follows) to the serial port and then displays a prompt:

                  Copyright (c) Hewlett-Packard Co. 1987
All Rights Reserved.  Reproduction, adaptation, or translation without prior
written permission is prohibited, except as allowed under copyright laws.

  HPE3499A Series Emulation System
    Version:   A.05.00 04Aug94 
    Location:  Generics

 HPE3490A Motorola CPU32 BDM Emulator
    Version:   A.01.00 02Aug94 

R>

The version numbers may be different for your HP E3490A Software Probe.

3 Press the Return or Enter key a few times.
You should see a prompt such as "R>" or "p>".

See Also "Problems with the Serial Interface," page 109.

Connecting to the Host Computer 
To verify serial communications 
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Setting up the Host Software 

The HP E3490A Software Probe requires the use of user interface
software on your host computer. Before you can use this software,
you may need to configure some communication parameters:

• If you will be using an HP Debugger/Emulator on a workstation, you
can set up the 64700tab.net file to give the HP E3490A Software
Probe a "logical name" as you would for an emulator.

• If you are using the HP Real-Time C Debugger on a PC, you do not
need to set up any files.

• If you are using another interface, such as a third-party debugger,
check the interface documentation to see if you need to configure
the LAN address or other communication parameters.

To set up the 64700tab.net file 

This step is optional. When you start a Debugger/Emulator interface, you
need to specify the name or the IP address of the HP E3490A Software Probe
to which it should connect.  If you do not set up the 64700tab.net file, you
will need to type the IP address (or an IP alias set in the /etc/hosts file) every
time you start the Debugger/Emulator.

1 If you have not already installed the HP Debugger/Emulator software
on your workstation, do so now.

2 Make up a logical name for the HP E3490A Software Probe.
You will use this name to identify the HP E3490A Software Probe whenever
you start the user interface software.  This name can be any easy to
remember name, perhaps a unique name for the target or processor. 

3 Find the IP address of the HP E3490A Software Probe.

Connecting to the Host Computer 
To set up the 64700tab.net file 
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This is the address you set in the "Setting Up a LAN Connection" section of
this chapter.

4 Edit the /usr/hp64000/etc/64700tab.net file and add a line with the
following format:

lan: <logical_name> <processor_type> <connection_info> 

<logical_name> The logical name chosen in step 2.
<processor_type> A general classification of the processor type. For the HP E3490A Software

Probe, the processor_type must be "cpu32_bdm" or "*".
<connection_info> The IP address of the HP E3490A Software Probe.

The 64700tab.net file defines the LAN connection to the target. The
64700tab.net file also defines the type of processor which the HP E3490A
Software Probe should present to the Debug Environment.

The 64700tab.net file is located in the directory $HP64000/etc
(/usr/hp64000/etc by default).

Example Here is an example line from /usr/hp64000/etc/64700tab.net for a 68332
processor connected to an HP E3490A Software Probe called "myprobe":
lan:  my332  *    myprobe 

If you did not set up the "myprobe" alias in the /etc/hosts file, you could use
its IP address:
lan:  my332  *    192.35.12.6 

The logical name of this HP E3490A Software Probe is "my332".  You would
use the name "my332" whenever you started a debugger interface.

Connecting to the Host Computer 
To set up the 64700tab.net file 
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Connecting to a Target System

The following cables are provided with the HP E3490A Software
Probe:

• An 8-pin cable (HP part number E3490-61601)

• A 10-pin cable (HP part number E3490-61602)

• A 10-wire flying lead cable (HP part number E3490-61603)

The wide (20-pin) end of the cable plugs into the HP E3490A
Software Probe; the other end connects to  microprocessor signals on
your target system.

A self-test connector (HP part number E3490-61604) is also provided.

To test the HP E3490A Software Probe

1 Check that the self-test connector is plugged into the HP E3490A
Software Probe.

2 Run the performance verification test described on page 115.
3 Remove the self-test connector.

If this is the first time you have used the HP E3490A Software Probe, you
should run the built-in performance verification test before you connect to a
target system. 

Connecting to the Target System 
To test the HP E3490A Software Probe
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To connect to an 8-pin BDM connector

C A U T I O N Be careful to orient the connector as shown below.  If the connector is
rotated, your target system or the HP E3490A Software Probe may be
damaged.

1 Check that the connector on your target system is wired as described
in "Designing a Target System" (page 86).

2 Plug the wide end of the cable into the HP E3490A Software Probe.
3 Plug into the target system with  the cable with the red wire toward

pin 1 of the connector.

To connect to a 10-pin BDM connector

C A U T I O N Be careful to orient the connector as shown below.  If the connector is
rotated, your target system or the HP E3490A Software Probe may be
damaged.

1 Check that the connector on your target system is wired as described
in "Designing a Target System" (page ).86

2 Plug the wide end of the cable into the HP E3490A Software Probe.
3 Plug into the target system with  the cable with the red wire toward

pin 1 of the connector.

If you use the 10-pin cable on an 8-pin connector, pins 1 and 2 of the cable
should be the ones which are not connected. Connect pin 3 of the cable to
pin 1 of the target connector.

Connecting to the Target System 
To connect to an 8-pin BDM connector
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To connect to a CPU32 target using the flying leads

Small SMT-compatible grabbers are included to help connect the flying leads
to the target system.  The ends of the flying leads will also fit onto the
standard 0.025 inch pins on most probing clips.

1 Locate the BDM signals on your target system.
2 Connect the leads as shown in the following table:

CPU32 Flying Lead Connections

Color Signal

Brown DS or not connected
Red BERR or not connected
Orange Ground
Yellow BKPT/DSCLK
Green Ground
Blue FREEZE
Violet RESET
Gray IFETCH/DSI
White VDD

Black IPIPE/DSO

Connect DS and BERR if you want the HP E3490A Software Probe to
terminate "hung" bus cycles.

3 Connect the cable to the HP E3490A Software Probe.

Connecting to the Target System 
To connect to a CPU32 target using the flying leads
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To set the BDM reset clock rate

• If your target system runs at a default clock rate greater than or equal
to 8 MHz, set switch S2 to CLOSED.

• If your target system runs at a default clock rate less than 8 MHz but
greater than 131 kHz, set switch S2 to OPEN.

The target system default clock rate is the rate used when the target comes
out of reset, and before a higher rate is begun by setting clock multiplier or
clock divider values.

See Also "Setting the Processor Clock Rate" on page 46 for more information about
BDM clock rates.

 

Connecting to the Target System 
To set the BDM reset clock rate
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Starting a User Interface

The HP E3490A Software Probe requires that you use a user interface
program, such as a debugger, on your host computer.

You can use one of the following user interfaces:

• On an HP or Sun workstation, you can use the
HP Debugger/Emulator.  

• On a PC, you can use the HP Real-Time C Debugger.

• You can also use third-party (non-HP) interfaces which have been
adapted for use with the HP E3490A Software Probe.

N o t e You must use a host user interface program with the HP E3490A Software
Probe. 

Although built-in commands exist, they are not documented or supported.  A
small set of built-in commands is supplied, however, to help you configure
LAN parameters. 

Starting a User Interface
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Using the HP Debugger/Emulator Interface

The HP Debugger/Emulator interface is a graphical debugger which
runs on HP and Sun workstations.

The HP Debugger/Emulator interface uses menus and dialogs which
make it easy to do things like download code, configure chip selects
and registers, or step through your code.  Using the debugger, you can
view assembly-level instructions, C or C++ statements, and high-level
variables and data structures.

To use the "Getting Started" example

The "Getting Started" example is part of the Debugger/Emulator User’s

Guide.

1 Set up a Motorola BCC demo board.
If you use a Motorola BCC (68332) demo board, you will not need to
recompile the demo files.  If you want to use another target system, you must
recompile the demo files for that processor.

2 Follow the instructions given in the "Getting Started" chapter of the
Debugger/Emulator User’s Guide, with the following exceptions:
Instead of an emulator name, use the name you assigned to the HP E3490A
Software Probe in the hp64000tab.net file (page 24).

Use the demo directory $HP64000/demo/debug_env/hpE3490.

Skip any sections that discuss the "trace" function.

Starting a User Interface
To use the "Getting Started" example
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To start the Debugger/Emulator interface

1 At the operating system prompt, type
db68k -e <logical_name> &

The <logical_name> is the LAN address or logical name you assigned to the
HP E3490A Software Probe in the "Connecting to the Host Computer"
chapter.

When the debugger starts, it will reset the processor then put the processor
into background mode. If the initial stack pointer and program counter point
to memory which is inaccessible, the debugger may take a long time to start
up, or it may not start at all. If this happens, see page 113.

2 Configure the HP E3490A Software Probe as described in the chapter
titled "Configuring the  HP E3490A Software Probe" on page 42.

3 Load an executable file as described in the Debugger/Emulator
User’s Guide.

Starting a User Interface
To start the Debugger/Emulator interface
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Using the HP Real-Time C Debugger Interface

The HP Real-Time C Debugger interface is a graphical debugger which
runs as an MS Windows application on a personal computer.

To use the "Getting Started" example

• Follow the instructions given in the Real-Time C Debugger User’s

Guide for your processor.

To configure the HP Real-Time C Debugger

1 Select Settings→Emulator Config from the menu bar.
2 Configure the processor clock rate.
3 Configure other items as needed.

See Also For more information on using the configuration dialog, see the Real-Time C
Debugger User’s Guide or the on-line help.

Starting a User Interface
To use the "Getting Started" example
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Configuring the HP E3490A Software
Probe Using the Debugger/Emulator
Interface

This chapter tells you how to configure the HP E3490A Software
Probe using the HP Debugger/Emulator interface on a workstation.

The HP E3490A Software Probe supports only those features that are
common on all the processors in the CPU32 family. Additional
processor specific features and capabilities are supported through the
use of user configurable parameters. These parameters may be
customized for specific target systems and saved in configuration files
for future use.

What can be configured

The configurable parameters and their default values are:

• The target processor type. 
Default = 683xx

• The target processor clock rate (determines BDM communication
speed).  

Default: ≥8 MHz if configuration switch #2 is CLOSED.  

Default: ≥131 kHz if configuration switch #2 is OPEN.

• Initial values for memory mapped registers in internal modules
Default: Memory-mapped registers are not defined  

• Simulated I/O setup and activation
Default: off 

Configuring the HP E3490A Software Probe Using the Debugger/Emulator Interface
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What happens when a configuration is applied

When a configuration is applied to HP E3490A Software Probe, the
following events occur:

1 The target is reset.

2 The BDM communication speed is set to the rate based on the
default target processor clock rate.

3 The target processor enters the BDM monitor.

4 The emulation copies of the SIM registers (specified in the
configuration) are loaded into the target SIM.

5 The BDM communication speed is set to the rate based on the value
configured as the target processor clock rate.

Configuring the HP E3490A Software Probe Using the Debugger/Emulator Interface
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To configure the HP E3490A Software Probe

Use one of the following ways to configure the HP E3490A Software
Probe:

• Start a user interface without specifying a configuration file.  
In this case the HP E3490A Software Probe is initialized with a default
configuration.

• Start a user interface, specifying a configuration file.  
In this case, the HP E3490A Software Probe is initialized with the values in
the configuration file. The configuration file must have been created by
saving a configuration in a user interface session.

Example db68k -C My_config -e logical_name

where My_config is a  file saved from a previous debugging session.

• Modify the configuration from within the user interface. 
When a user interface is started, the HP E3490A Software Probe is always
configured from a default file or from user specified configuration file. This
initial configuration can be modified from within the user interface by by
modifying the configuration values or by loading a new configuration file.

To modify the configuration, choose Modify→Emulator Config.... Now
select the various sections, modify the setting, and finally use Apply to

Emulator to apply the new setting to the emulator.

To load a new configuration, select File→Load Config from the menu bar.

The configuration is also applied to the HP E3490A Software Probe when the
target processor is reset while it is running in the BDM monitor.

Configuring the HP E3490A Software Probe Using the Debugger/Emulator Interface
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To set the processor type

1 In the Emulator Configuration dialog box, select  General Items.
2 Position the mouse pointer in the Processor field.
3 Enter the processor type.

To see a list of processor types supported, press the F1 key.

4 Click on the OK button.

N o t e Once you have set the processor type, you cannot change it unless you exit
(Exit Released) and restart the debugger.

If you enter the wrong processor type and have not yet applied the
configuration, you can exit the configuration dialog box and start over with
step 1 above.

The default value for the processor configuration item is 683xx.  With this
value, the HP E3490A Software Probe can provide direct access to all the
registers defined in the CPU32 architecture programming model but will not
have direct access to memory mapped registers in the processor’s internal
modules.

If a processor is specified, the HP E3490A Software Probe will have
knowledge of on-chip peripheral registers and SIM registers and will allow
display and modification from the user interface.  For example, when 68332
is selected as the processor type, the interface will support direct access to
the SIM, the QSM, the TPU, and the TPURAM registers.

The initially supported processor types are 683xx, 68331, 68332, 68336,
68340, and 68360.

The HP E3490A Software Probe does not have explicit support for all CPU32
processors. When using a member of the CPU32 family that is not explicitly
supported it may be possible to select a processor that is a formal subset of
the unsupported processor.  This will provide direct access to all of the
internal memory mapped registers that are common.  Since the registers in
the internal modules are memory mapped, registers in unsupported CPU32
processors are also accessible through the memory commands.  For example,
on a 68332, SIM registers can be accessed at memory locations 7FFA00 to
7FFA7F or FFFA00 to FFFA7F.

Configuring the HP E3490A Software Probe Using the Debugger/Emulator Interface
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Setting the Processor Clock Rate (BDM
Communication Speed)

The HP E3490A Software Probe needs to be configured to
communicate at a rate which is compatible with your target processor
clock rate.  This can be done through your user interface software.

If your target processor runs at less than 8 MHz after power-up, you
will also need to set a configuration switch.

Configuring the HP E3490A Software Probe Using the Debugger/Emulator Interface
Setting the Processor Clock Rate (BDM Communication Speed)
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To set the processor clock rate (BDM communication
speed)

1 In the Emulator Configuration dialog box, select  General Items.
2 Select a Processor Clock Rate.
3 Click on the OK button.

The processor clock rate configuration parameter is used to specify the
maximum rate that the HP E3490A Software Probe can communicate with
the target processor through the BDM port. This maximum communication
rate is based upon the target processor type and the target processor clock
rate.  The maximum communication rate directly impacts the performance of
downloading files through the HP E3490A Software Probe and the intrusion
time when polling for simulated I/O.  Running at a rate slower than the
maximum does not prevent correct operation.  

The default value for the processor clock rate configuration parameter is
determined by the setting of configuration switch S2.  In the Normal
(CLOSED) position this parameter is set to "greater than or equal to 8 MHz".
In the OPEN position  this parameter is set to "greater than or equal to 131
kHz".

Most target systems run with a Processor Clock Rate of 8 MHz or above and
so will function properly using the default value. For correct operation in
target systems that run slower than 8 MHz, the default clock rate must be set
to "greater than or equal to 131 kHz" by setting switch  S2 to OPEN.

The best performance for the HP E3490A Software Probe usually requires
changing the communication rate from the default value.  Set the "Processor
Clock Rate" parameter to the highest rate that is equal to or less than the
target running clock rate.  If using the internal clock synthesizer, set the
EMSYNCR (EMulator copy of the SYNthesizer Control Register, SYNCR) to
the same value as set by the initialization code.  (See "Configuring Internal
Registers" on page 51). 
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To set the default clock rate if the processor clock
rate is less than 8 MHz

• Set switch S2 to OPEN.
If a target system’s processor clock rate is less than 8 MHz following
powerup, the default clock rate must be set to "greater than or equal to 131
kHz" by setting configuration switch 2 OPEN.  

This can occur when the target system has the processor running off of an
external clock source that is less than 8 MHz or is using the clock synthesizer
with a crystal that is lower in frequency that the standard crystal.

The actual processor clock rate should then be communicated to the
HP E3490A Software Probe through the configuration processor clock rate
entry.  The HP E3490A Software Probe will then start communications with
the target processor at the 131 kHz processor clock rate. When the
configuration process is complete, the HP E3490A Software Probe will
change the communication rate to a rate based on the "Processor Clock Rate"
parameter entry.

The HP E3490A Software Probe will not communicate correctly with target
systems that have a processor clock rate slower than 131 kHz.

N o t e The HP E3490A Software Probe does not automatically match the
communication speed to the actual target speed (SYNCR register).
Maintaining consistency is the responsibility of the user. 

To maintain consistency, specify a correct SYNCR register value in the
configuration process and make sure that the target code does not change
the SYNCR register to a value that is slower than what is specified in the
configuration.

N o t e The HP E3490A Software Probe will not run correctly if the actual target
processor clock rate is slower than the rate specified in the configuration.

Configuring the HP E3490A Software Probe Using the Debugger/Emulator Interface
Setting the Processor Clock Rate (BDM Communication Speed)

48



Detailed information about processor clock rates

Most target systems will communicate with the HP E3490A Software Probe
properly and with excellent performance following the basic guidelines given
in the preceding sections. In some target systems, the setting of this
parameter requires greater knowledge of the actual clock generation model.

The CPU32 family has two major use models for the processor clock rate
which can be used to support the majority of target systems. When using the
internal clock synthesizer, the processor will run from reset at a Motorola
defined default clock rate which, when using the Motorola recommended
crystal is usually 8.38 MHz or 1/2 of the maximum clock rate of the processor.
The programmer’s initialization code then programs the clock synthesizer to
run at the desired clock rate which is usually higher than the default. The
second model uses an external clock source to directly control the processor
clock rate.  The HP E3490A Software Probe directly supports both processor
clock rate models.  Users that use a different clock rate model can examine
the support of these models to determine the correct settings for supporting
their processor clock rate.

The HP E3490A Software Probe supports the use model of the target
processor clock rate being increased through the configuration. When
applying the configuration at the start of a user interface or through the
configuration process, the HP E3490A Software Probe communicates with
the target processor at a rate based on the default processor clock rate
(either 8 MHz or 131 kHz).  At this default rate, it copies the EMSYNCR
(EMulator copy of the SYNthesizer Control Register) to the SYNCR
(SYNthesizer Control Register). The HP E3490A Software Probe then
changes its communications rate to the maximum rate that the processor
clock rate specified in the configuration can support.

Resetting the target processor also resets the SYNCR to its default value. If
the target processor is reset while running user code (as opposed to putting
the processor in a reset state from the interface), no communications rate
change takes place within the HP E3490A Software Probe. The initialization
code that runs on the target system from reset is required to set the SYNCR
to the correct value.  If the target processor is reset while in the Background
Debug Monitor, the configuration process is executed by the HP E3490A
Software Probe.

When the target processor clock rate is fixed through the use of an external
clock source, the Processor Clock Rate parameter can be set to the highest
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rate that is equal to or less than the target clock rate.  There are no
dependencies upon any other configuration parameters.

When the target system is using the internal clock synthesizer to increase the
final clock rate but the user leaves the HP E3490A Software Probe at the
default Processor Type (683xx) the EMSYNCR is not available to the
configuration process.  The powerup default clock rate for the target system
can be entered into the "Processor Clock Rate".  This is a failsafe setting but
can limit the HP E3490A Software Probe performance if the target processor
is programmed to run at a significantly faster rate than the powerup default.

If the user desires the higher performance available by setting the "Processor
Clock Rate" configuration parameter to his final value but does not set his
processor type (which means that the configuration process cannot set the
SYNCR) the debugger interface will have a number of failures when invoked
because it cannot communicate accurately with the target processor.  These
will show up as either question marks or bad values in the code, stack, and
monitor windows.  These errors can be cleared up if the target system can
support a "run from reset" with code in the target system that initializes the
target SYNCR register.  Following the target initializing this register, a break
can be requested and the HP E3490A Software Probe will communicate
correctly with the target.  Until the HP E3490A Software Probe and the
target system are running at compatible rates, operations such as "run" "load"
"modify memory/registers" or "display memory/registers" will either fail or
give incorrect information.

If the user loses communication between the HP E3490A Software Probe and
the target system because of incompatible clock rates, control of the target
processor through the HP E3490A Software Probe can be recovered by
applying the configuration to the HP E3490A Software Probe with the target
processor clock rate set to a known good value.

Configuring the HP E3490A Software Probe Using the Debugger/Emulator Interface
Setting the Processor Clock Rate (BDM Communication Speed)

50



Configuring Internal Registers (SIM and
EMSIM Registers)

Internal Registers

The CPU32 family of processors provides a variety of internal
peripheral and memory modules that are directly connected to the
CPU32 core through an internal bus. These modules are configured
through memory mapped register banks. The base address of the
register banks as well as the base address of internal memory modules
are established through Module Configuration Registers (e.g. MCR)
and Base Address Registers (e.g. RAMBAR or MBAR). A common
module throughout the family is a System Integration Module (SIM)
which controls such things as clock speed and external chip selects.

How Internal Register Values are Set

These registers are typically initialized by the CPU32 executing the
reset initialization code.  During development this code may not be
available or may not exist on the target system.  To aid in
development, the most important of these registers can be set directly
by the Software Probe.  This enables such functions as clock speed,
chip selects, and location of internal memory to be established prior to
executing any user code.  Once these registers are set, resources in
the target system can be accessed in the same manner as the
processor would access them after executing the reset initialization
code.  Activities such as downloading code into the target system can
now be performed through the Software Probe.  

When the Software Probe is configured with a specific processor type,
the configuration process within the user interface presents the
internal registers that the Software Probe can initialize.  The
configuration process stores the user entered values as an emulator
copy of these registers.  The emulator copy is identified by the prefix
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"EM" on the register name  (e.g. EMSYNCR is the emulator copy of
the SYNCR register) and are referred to as the EMSIM.  The EMSIM
registers are transferred to the processor registers when the
configuration is applied to the emulator, or when the target processor
is reset while it is running in the BDM monitor.

Based on the previous discussion, it should be clear that the EMSIM
values specified during configuration need to match the intended
programming and of use of your CPU32 target system.  You need to
carefully decide how the processor will be configured and the
corresponding SIM values.

Methods for Configuring EMSIM Register Values

There are two methods you can use to configure EMSIM register
values:

• Copy values from the SIMs into a configuration file, or

• Manually define each of the EMSIM values using a debugger
interface.

N o t e The Software Probe supports configuration of the internal registers in the
System Integration Module (SIM) and other important Module Configuration
Registers and Base Address Registers.  To simplify the interface, all
configurable registers will be referred to as SIM registers even if they are
technically part of another module.

N o t e Some register values can only be written to once after processor reset.  The
user interface for the Software Probe performs a reset prior to writing the
EM registers to the target processor.  If the users code depends upon one of
these values to be the default reset value or needs to write something
different than what the EM copy contains, the user cannot perform a run
directly from the monitor following the application of the configuration.  In
these cases, the user can only perform a "run from reset" operation.  Later
break and run cycles within the same debug session will work correctly.
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To configure EMSIM values by copying SIM values

If you have initialization code that properly defines the SIMs, you can copy
your values of the SIMs into the configuration file. This can be accomplished
by the following sequence:

1 Select Execution→Run from Reset.
This will run your initialization code.

2 Enter a <CTRL>-C to abort the run.
3 Select Modify→Emulator Config...

This will bring up the configuration dialog.

4 Select General Items and enter a processor type, then press OK in
the General Items dialog.

5 Select Modify→Copy SIM to EMSIM to Config.
This will copy the actual  SIM values into the current configuration.

6 Click on Apply to Emulator.
This will load your SIM configuration

7 Select File→Store... in the configuration dialog box.
This will allow you to save the configuration in a file. This will also load your
SIM configuration.
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To manually define EMSIM values

You can manually define all of the appropriate EMSIM values by the following
sequence:

1 Select Modify→ Emulator Config....
This will open the configuration dialog box.

2 Select General Items and enter a processor type.
Press OK in the General Items dialog.

3 Select Reconfigure Internal Registers.
4 Manually enter all of the appropriate values for the registers.

Use F1 with the cursor pointed into a register field to get additional
infromation about that particular register.

5 Click on Apply to Emulator to load your SIM configuration.
Try to access memory as you have defined it.

Make any needed modifications and click on Apply to Emulator again until
you are satisfied with your configuration.

6 Select File→Store....
This allows you to save the configuration in a file.  This will also load your
SIM configuration.

See Also "Using Internal Registers" beginning on page 71.

To use a configuration file

Once you have saved the configuration, every time that you start the
Debugger/Emulator interface you can specify the saved configuration file and
have your EMSIMs set up to the proper values.  You can do this in two ways:

• Specify the configuration on the command line when you start the
debugger interface: 
db68k -C My_Config -e logical_name

• Load the configuration after starting the interface with File→Load→
Emulator Config....
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Configuring Simulated IO

The Simulated IO section defines configuration options to allow your
programs to use the host computer I/O (display, keyboard, files, etc).

Simulated IO is used as a substitute for the target system IO when it has not
been fully developed.

The HP C Cross Compilers provide an environment dependent library (and
source code) that uses Simulated IO for its standard IO routines.  Simulated
IO for MRI compilers is provided in the demo program code. Simulated IO for
other brands of compilers can be readily created from the demo code
provided.  Refer to the demo directory $HP64000/demo/debug_env/hpE3490.

See Also Refer to the Simulated I/O User’s Guide for complete details.
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Configuring the HP E3490A
Software Probe Using the
Real-Time C Debugger
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Configuring the HP E3490A Software
Probe Using the Real-Time C Debugger
Interface

This chapter tells you how to configure the HP E3490A Software
Probe using the HP Real-Time C Debugger interface on a PC.

The HP E3490A Software Probe supports only those features that are
common on all the processors in the CPU32 family. Additional
processor specific features and capabilities are supported through the
use of user configurable parameters and through different interfaces.
The parameters may be customized to suit specific target systems and
saved in configuration files for future use.

What can be configured

The configurable parameters and their default values are:

• The target processor type. 
Default: determined by which Real-Time C Debugger you are using.

• The target processor clock rate (determines BDM communication
speed).  

Default: ≥8 MHz if configuration switch #2 is CLOSED.  

Default: ≥131 kHz if configuration switch #2 is OPEN.

• Initial values for memory mapped registers in internal modules
Default: Memory-mapped registers are not defined
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To configure the HP E3490A Software Probe

1 Set the processor type, processor clock rate, and EMSIM register
values as described in this chapter.

2 Select Execution→Reset.

This will reset the target system. 

3 Select Execution→Break.

When the break occurs the following "configuration process" occurs:

• The target processor enters the BDM monitor.

• The BDM communication speed is set to the default clock rate.

• The emulation copies of the SIM registers (set in step 1) are loaded into
the target SIM.

• The BDM communication speed is set to the rate based on the value
configured as the target processor clock rate.
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To set the processor type

1 In the Hardware Configuration dialog box, select the processor type.
2 Click on the OK button.

If you are using a processor in your target that is not listed as a choice in the
dialog box, the HP E3490A Software Probe can provide direct access to all
the registers defined in the CPU32 architecture programming model but will
not have direct access to memory mapped registers in the processor’s
internal modules.

If you are using a processor that is listed as a choice in the dialog box, the
HP E3490A Software Probe will have knowledge of on-chip peripheral
registers and SIM registers and will allow display and modification from the
user interface.  For example, when 68332 is selected as the processor type,
the interface will support direct access to the SIM, the QSM, the TPU, and
the TPURAM registers.

The supported processor types are listed in the configuration dialog box.

The HP E3490A Software Probe does not have explicit support for all CPU32
processors. When using a member of the CPU32 family that is not explicitly
supported it may be possible to select a processor that is a formal subset of
the unsupported processor.  This will provide direct access to all of the
internal memory mapped registers that are common.  Since the registers in
the internal modules are memory mapped, registers in unsupported CPU32
processors are also accessible through the memory commands.  For example,
on a 68332, SIM registers can be accessed at memory locations 7FFA00 to
7FFA7F or FFFA00 to FFFA7F.
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Setting the Processor Clock Rate (BDM
Communication Speed)

The HP E3490A Software Probe needs to be configured to
communicate at a rate which is compatible with your target processor
clock rate.  This can be done through your user interface software.

If your target processor runs at less than 8 MHz after power-up, you
will also need to set a configuration switch on the HP E3490A
Software Probe.
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To set the processor clock rate (BDM communication
speed)

1 Select Settings→Emulator Config→Hardware....
2 Select a Processor Clock Rate.
3 Click on the OK button.

The processor clock rate configuration parameter is used to specify the
maximum rate that the HP E3490A Software Probe can communicate with
the target processor through the BDM port. This maximum communication
rate is based upon the target processor type and the target processor clock
rate.  The maximum communication rate directly impacts the performance of
downloading files through the HP E3490A Software Probe and the intrusion
time when polling.  Running at a rate slower than the maximum does not
prevent correct operation.  

The default value for the processor clock rate configuration parameter is
determined by the setting of configuration switch S2.  In the Normal
(CLOSED) position this parameter is set to "greater than or equal to 8 MHz".
In the OPEN position  this parameter is set to "greater than or equal to 131
kHz".

Most target systems run with a Processor Clock Rate of 8 MHz or above and
so will function properly using the default value. For correct operation in
target systems that run slower than 8 MHz, the default clock rate must be set
to "greater than or equal to 131 kHz" by setting switch  S2 to OPEN.

The best performance for the HP E3490A Software Probe usually requires
changing the communication rate from the default value.  Set the "Processor
Clock Rate" parameter to the highest rate that is equal to or less than the
target running clock rate.  If using the internal clock synthesizer, set the
EMSYNCR (EMulator copy of the SYNthesizer Control Register, SYNCR) to
the same value as set by the initialization code.  (See "Configuring Internal
Registers" on page 51). 
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To set the default clock rate if the processor clock
rate is less than 8 MHz

• Set switch S2 to OPEN.
If a target system’s processor clock rate is less than 8 MHz following
powerup, the default clock rate must be set to "greater than or equal to 131
kHz" by setting configuration switch 2 OPEN.  

This can occur when the target system has the processor running off of an
external clock source that is less than 8 MHz or is using the clock synthesizer
with a crystal that is lower in frequency that the standard crystal.

The actual processor clock rate should then be communicated to the
HP E3490A Software Probe through the configuration processor clock rate
entry.  The HP E3490A Software Probe will then start communications with
the target processor at the 131 kHz processor clock rate. When the
configuration process is complete, the HP E3490A Software Probe will
change the communication rate to a rate based on the "Processor Clock Rate"
parameter entry.

The HP E3490A Software Probe will not communicate correctly with target
systems that have a processor clock rate slower than 131 kHz.

N o t e The HP E3490A Software Probe does not automatically match the
communication speed to the actual target speed (SYNCR register).
Maintaining consistency is the responsibility of the user. 

To maintain consistency, specify a correct SYNCR register value in the
configuration process and make sure that the target code does not change
the SYNCR register to a value that is slower than what is specified in the
configuration.

N o t e The HP E3490A Software Probe will not run correctly if the actual target
processor clock rate is slower than the rate specified in the configuration.
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Detailed information about processor clock rates

Most target systems will communicate with the HP E3490A Software Probe
properly and with excellent performance following the basic guidelines given
in the preceding sections. In some target systems, the setting of this
parameter requires greater knowledge of the actual clock generation model.

The CPU32 family has two major use models for the processor clock rate
which can be used to support the majority of target systems. When using the
internal clock synthesizer, the processor will run from reset at a Motorola
defined default clock rate which, when using the Motorola recommended
crystal is usually 8.38 MHz or 1/2 of the maximum clock rate of the processor.
The programmer’s initialization code then programs the clock synthesizer to
run at the desired clock rate which is usually higher than the default. The
second model uses an external clock source to directly control the processor
clock rate.  The HP E3490A Software Probe directly supports both processor
clock rate models.  Users that use a different clock rate model can examine
the support of these models to determine the correct settings for supporting
their processor clock rate.

The HP E3490A Software Probe supports the use model of the target
processor clock rate being increased through the configuration. When
applying the configuration at the start of a user interface or through the
configuration process, the HP E3490A Software Probe communicates with
the target processor at a rate based on the default processor clock rate
(either 8 MHz or 131 kHz).  At this default rate, it copies the EMSYNCR
(EMulator copy of the SYNthesizer Control Register) to the SYNCR
(SYNthesizer Control Register). The HP E3490A Software Probe then
changes its communications rate to the maximum rate that the processor
clock rate specified in the configuration can support.

Resetting the target processor also resets the SYNCR to its default value. If
the target processor is reset while running user code (as opposed to putting
the processor in a reset state from the interface), no communications rate
change takes place within the HP E3490A Software Probe. The initialization
code that runs on the target system from reset is required to set the SYNCR
to the correct value.

When the target processor clock rate is fixed through the use of an external
clock source, the Processor Clock Rate parameter can be set to the highest
rate that is equal to or less than the target clock rate.  There are no
dependencies upon any other configuration parameters.
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For the 6833x interface, when the target system is using the internal clock
synthesizer to increase the final clock rate but the user leaves the HP E3490A
Software Probe at the default processor type (683xx) the EMSYNCR is not
available to the configuration process.  The powerup default clock rate for
the target system can be entered into the "Processor Clock Rate".  This is a
failsafe setting but can limit the HP E3490A Software Probe performance if
the target processor is programmed to run at a significantly faster rate than
the powerup default.

If the user desires the higher performance available by setting the "Processor
Clock Rate" configuration parameter to his final value but does not set his
processor type (which means that the configuration process cannot set the
SYNCR) the debugger interface will have a number of failures when invoked
because it cannot communicate accurately with the target processor.  These
will show up as either dashes or bad values in the source, backtrace, and
memory windows.  These errors can be cleared up if the target system can
support a "run from reset" with code in the target system that initializes the
target SYNCR register.  Following the target initializing this register, a break
can be requested and the HP E3490A Software Probe will communicate
correctly with the target.  Until the HP E3490A Software Probe and the
target system are running at compatible rates, operations such as "run,"
"load," "modify memory/registers," or "display memory/registers" will either
fail or give incorrect information.

If the user loses communication between the HP E3490A Software Probe and
the target system because of incompatible clock rates, control of the target
processor through the HP E3490A Software Probe can be recovered by
applying the configuration to the HP E3490A Software Probe with the target
processor clock rate set to a known good value.
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Configuring Internal Registers (SIM and
EMSIM Registers)

Internal Registers

The CPU32 family of processors provides a variety of internal
peripheral and memory modules that are directly connected to the
CPU32 core through an internal bus. These modules are configured
through memory mapped register banks. The base address of the
register banks as well as the base address of internal memory modules
are established through Module Configuration Registers (e.g. MCR)
and Base Address Registers (e.g. RAMBAR or MBAR). A common
module throughout the family is a System Integration Module (SIM)
which controls such things as clock speed and external chip selects.

How Internal Register Values are Set

These registers are typically initialized by the CPU32 executing the
reset initialization code.  During development this code may not be
available or may not exist on the target system.  To aid in
development, the most important of these registers can be set directly
by the HP E3490A Software Probe.  This enables such functions as
clock speed, chip selects, and location of internal memory to be
established prior to executing any user code.  Once these registers are
set, resources in the target system can be accessed in the same
manner as the processor would access them after executing the reset
initialization code.  Activities such as downloading code into the target
system can now be performed through the HP E3490A Software
Probe.

The emulator copy is identified by the prefix "EM" on the register
name  (e.g. EMSYNCR is the emulator copy of the SYNCR register)
and are referred to as the EMSIM.  The EMSIM registers are
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transferred to the processor registers when the target processor is
reset while it is running in the BDM monitor.

The names and values of the EMSIM registers are displayed in the
Emulator SIM Registers window.

Based on the previous discussion, it should be clear that the EMSIM
values specified during configuration need to match the intended
programming and of use of your CPU32 target system.  You need to
carefully decide how the processor will be configured and the
corresponding SIM values.

Methods for Configuring EMSIM Register Values

There are two methods you can use to configure EMSIM register
values:

• Copy values from the SIMs into the EMSIM registers, or

• Manually define each of the EMSIM values using a debugger
interface.

N o t e The HP E3490A Software Probe supports configuration of the internal
registers in the System Integration Module (SIM) and other important
Module Configuration Registers and Base Address Registers.  To simplify the
interface, all configurable registers will be referred to as SIM registers even
if they are technically part of another module.
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To copy EMSIM values to the SIM registers

You can copy values from the EMSIM registers into the SIM registers in two
ways:

• Using the Configuration Information dialog. 
a Select Settings→Emulator Config→Information.
b Select Synchronize from emsim regs, copy to processor regs

in the Synchronize SIM Registers box.
c Click on Apply/Results.

• Resetting the target system.
a Select Execution→Reset.
b Select Execution→Break.

N o t e Some registers can only be written once after processor reset. 

If you set the EMSIM values, then reset and break, the EMSIM values will be
written to the SIM registers. If your initialization code then attempts to write
to one of the "write once after reset" registers, the writes will fail. In this case,
you must use the  Execution→Run...From Reset command to correctly
execute the initialization code.

To configure EMSIM values by copying SIM values

If you have initialization code that properly defines the SIMs, you can copy
your values of the SIMs into the configuration file. This can be accomplished
by the following sequence:

1 Select Execution→Run....
2 Select User Reset and then Run.

This will run your initialization code.

3 Select  Execution→Break to stop the execution.
4 Select Settings→Emulator Config→Information.

This will bring up the Configuration Information dialog.

5 Select Synchronize from processor sim regs, copy to emsim

regs in the Synchronize SIM Registers box.
6 Click on Apply/Results.

This will copy your SIM configuration into the EMSIM registers.
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7 Select File→Save Emulator Config from the menu bar.
This will allow you to save the configuration in a file. 

To manually define EMSIM values

1 Open the SIM/MEMC Registers window.
2 Double-click on the VALUE field for the register you want to define.

This will open the Register Bit Fields window.

This will not change the value of the SIM register.  To apply the new value to
the corresponding SIM register, see "To copy EMSIM values to the SIM
registers."

To load EMSIM values from a configuration file

Once you have saved the configuration,  you can specify the saved
configuration file and have your EMSIMs set up to the proper values. 

• Select File→Load Configuration.
This will not change the SIM registers.  To apply the new values to the
corresponding SIM registers, see "To copy EMSIM values to the SIM
registers."
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Using Internal Registers  (EMSIM
registers)

The purpose of EMSIM registers

Software Probe maintains a set of pseudo registers known as EMSIM
registers.  There is a one to one correspondence between the the
EMSIM registers and the target SIM registers.  The purpose of the
EMSIM registers is to provide a stable, known set of registers that can
be copied into the SIM to establish an initial SIM state or re-establish a
previous known state.  This is useful because it allows Software Probe
to communicate with a target without first running initialization code
to set up the chip select registers. 

N o t e The Software Probe supports configuration of the internal registers in the
System Integration Module (SIM) and other important Module Configuration
Registers and Base Address Registers.  To simplify the interface, all
configurable registers will be referred to as SIM registers even if they are
technically part of another module.
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Using EMSIM Registers with the
Debugger/Emultor Interface

The effect of processor type on the EMSIM registers

EMSIM registers only exist if the HP E3490A Software Probe has been
configured with a target processor name other than 683xx.  If the
processor is 683xx, the HP E3490A Software Probe does not know
what type of SIM exist in the target and will have no knowledge of SIM
registers.

To copy EMSIM registers to target SIM registers

EMSIM registers can be copied to the target SIM in several ways.

• In a Debugger Emulator interface, EMSIMs are copied to target SIMs
each time  a configuration is applied to Software Probe.  This
happens automatically when a user interface is started.
Configurations may also be applied manually from within the user
interface by choosing Modify→Emulator Config...  and then Apply

to Emulator

• In a Debugger/Emulator interface choose Modify→SIM

registers→Copy emulator SIM to processor SIM.
In addition, EMSIMs are copied to target SIMs when the target processor is
reset while it is running in the BDM monitor

To copy target SIM registers to EMSIM registers

Target SIM registers may be copied to the EMSIM in several ways.
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• In a Debugger Emulator interface choose Modify→Emulator

Config...  Then issue the command Modify→Copy SIM to

EMSIM to Config

• In a Debugger Emulator interface choose Modify→SIM

registers→Copy SIM to Emulator SIM

To compare SIM and EMSIM registers

Target SIM registers may compared to the the EMSIM to determine if
they have changed.

• In a Debugger Emulator interface choose Display→SIM Register

Differences.
When displaying differences between SIMs and EMSIMs, register
names will not be show.  Registers will be identified by a memory
offset from their base address in the target system.
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Using EMSIM Registers with the Real-Time C
Debugger Interface

The effect of processor type on the EMSIM registers

If you are using the 6833x Real-Time C Debugger interface, EMSIM
registers are valid only  if the HP E3490A Software Probe has been
configured with a target processor name other than 683xx.  If the
processor is 683xx, the HP E3490A Software Probe does not know
what type of SIM exist in the target and will not display correct values
for the SIM registers.

To copy EMSIM registers to target SIM registers

You can copy values from the EMSIM registers into the SIM registers in two
ways:

• Using the Configuration Information dialog. 
a Select Settings→Emulator Config→Information.
b Select Synchronize from emsim regs, copy to processor regs

in the Synchronize SIM Registers box.
c Click on Apply/Results.

• Resetting the target system.
a Select Execution→Reset.
b Select Execution→Break.

N o t e Some registers can only be written once after processor reset. 

If you set the EMSIM values, then reset and break, the EMSIM values will be
written to the SIM registers. If your initialization code then attempts to write
to one of the "write once after reset" registers, the writes will fail. In this case,
you must use the  Execution→Run...From Reset command to correctly
execute the initialization code.
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To copy target SIM registers to EMSIM registers

If you have initialization code that properly defines the SIMs, you can copy
your values of the SIMs into the configuration file. This can be accomplished
by the following sequence:

11 Select Settings→Emulator Config→Information.
This will bring up the Configuration Information dialog.

2 Select Synchronize from processor sim regs, copy to emsim

regs in the Synchronize SIM Registers box.
3 Click on Apply/Results.

This will copy your SIM configuration into the EMSIM registers.

To compare SIM and EMSIM registers

Target SIM registers may compared to the the EMSIM to determine if
they have changed.

1 Select Settings→Emulator Config→Information.
This will bring up the Configuration Information dialog.

2 Select Show differences for processor and emsim regs in the
Synchronize SIM Registers box.

3 Click on Apply/Results.

This will display the differences between the SIM and EMSIM register
sets.

N o t e The HP E3490A Software Probe, when comparing SIM and EMSIM registers,
will not compare EMSIM registers that have not been set.

When you first turn on the HP E3490A Software Probe and the target system
and start the Real-Time C Debugger, the  Show differences for processor

and emsim regs command will not find any differences.  If one register is
modified, just that one register may show differences. A complete check of
the register differences will occur only if a complete configuration is loaded
or the SIM registers are copied to the EMSIM registers. Once written, any
EMSIM register will be considered valid until you cycle power on the
HP E3490A Software Probe.
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Internal Representation of SIM and EMSIM
Registers

Internal to the HP E3490A Software Probe the EMSIM and SIM
memory spaces are accessed using memory suffixes of the form
offset@emsim and offset@reg.  All memory mapped registers in the
683xx family are contained within a contiguous 4k block of memory
(8k for the 68360).  The base address is determined by the SIM MCR
MM bit in the 6833x or the MBAR in the 68340 and 68360 processors.
The internal representation within the HP E3490A Software Probe of
these registers is maintained as an offset to the memory mapped
register base.  Referencing memory as offset@emsim will access a SIM
copy value in the EMSIM. Referencing offset@reg will access a
register within the processor.  For example the memory address
0a00@reg within a 68332 will access the SIM MCR.  The memory
address 0@reg within a 68340 will access its SIM MCR.

Typically these internal representations of offset@emsim and
offset@reg will not be seen by the user of the HP E3490A Software
Probe via the workstation debugger or the the PC RTC interfaces.
Currently though, a command used to compare the values with the
EMSIM and SIM will result in memory references using this notation.
For example suppose the command is given to compare the SIM and
EMSIM within the 68332.  Further suppose that the the values in the
Clock Synthesizer Control differ.  This is the SIM register SYNCR.  The
resulting display may look as follows:

0a04@emsim=000, 0a04@reg=03f
0a05@emsim=000, 0a05@reg=008

At this point the user must refer to the 68332 data book to understand
which SIM register is differing.  In future versions of the HP E3490A
Software Probe interface the register names will be displayed,
completely hiding the use of the offset@ syntax.
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See Also Page 51 in the "Configuring the HP E3490A Software Probe" chapter  for
additional information on EMSIM registers.
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Programming Target Flash Memory

You can use the HP E3490A Software Probe to program flash memory
on your target system.

Target system configuration

Prior to erasing or programming parts through the HP E3490A
Software Probe, you must to establish any necessary options on the
target system.  This can include enabling the programming voltage
(VPP), disabling write protection, or properly setting the chip selects
in the SIM.  The chip selects in the SIM can be set through the
configuration process.  The documentation on the target system can
provide information on such things as establishing the VPP and
disabling any target based write protection.  The HP E3490A Software
Probe accomplishes the FLASH ROM erasure and programming
through standard target bus writes and reads.

Supported Parts

The HP E3490A Software Probe can program standard Intel and AMD
parts, and equivalent parts from other manufacturers. Supported
algorithms include the Intel quick-pulse (or the identical AMD
Flashrite), Intel Auto, AMD 5V embedded, and AMD 12V embedded
algorithms.

Since the list of supported parts may change frequently, refer to the
on-line help in your user interface software.

Programming Target Flash Memory

80



Supported File Sizes

There is no file size limit. 

Supported User Interfaces

The following user interfaces support flash programming:

• On an HP or Sun workstation, you can use the
HP Debugger/Emulator.  

• On a PC, you can use the HP Real-Time C Debugger.
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To program or erase a part using the HP
Debugger/Emulator 

1 Create a file which contains the data to be flashed.
2 Set the necessary options (if any) on your target system to allow

flash programming.
3 Open the FLASH Operations dialog box by selecting

Modify→FLASH Erase... or File→Load→FLASH From File from
the menu bar.

4 Program the part by clicking on OK or Apply in the dialog box.
The dialog box supports erasure of parts and programming from different
binary files. You must select the programming algorithm to use, the base
address and size of the FLASH ROM, and the configuration of the FLASH
ROM. Sector erasable parts can be erased a sector at a time if desired.

Currently supported parts and algorithms can be identified through the F1
help function in the dialog box.

To program or erase  a part using the HP Real-Time C
debugger 

1 Create a file which contains the data to be flashed.
2 Set the necessary options (if any) on your target system to allow

flash programming.
3 Open the FLASH dialog box by selecting File→Flash

Programming... from the menu bar.
4 Select the appropriate options to program your flash memory.
5 Program the part by clicking on OK or Apply in the dialog box.

Programming Target Flash Memory
To program or erase a part using the HP Debugger/Emulator 
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Designing a Target System

This chapter will help you design a target system that will work with
the HP E3490A Software Probe.

Wiring the BDM Port

Some of the signals  at the BDM port share the same lines, as shown in
the diagrams on the following pages.

When deciding whether to use an 8-pin or a 10-pin BDM port,
consider how often you are likely to encounter "hung" bus cycles. If
you are using an 8-pin BDM port, and a target bus cycle fails to
terminate, you will need to reset the target system. If you use a 10-pin
BDM port, the HP E3490A Software Probe will detect and terminate
the "hung" cycle.

Therefore if your target system does not have a good bus monitor, or
if you are not using the built-in bus monitor, you should use a 10-pin
BDM port to take advantage of the DS and BERR signals.
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The following signals should be available at the BDM port:

BDM signal definitions

Mnemonic Name Direction Signal Description

GND Ground

BKPT Breakpoint Input 
(to target)

Signals a hardware breakpoint. 
Also used to place the CPU32 in background debug
mode. Active low

DSCLK Development system
clock

Input Serial input clock

FREEZE Freeze Output Indicates BDM mode

QUOT Quotient out Output Quotient bit of the polynomial divider. Not used in BDM
mode.

RESET Reset Output Indicates system reset

IFETCH Instruction fetch Output Indicates when the CPU is performing an instruction
word prefetch and when the instruction pipeline has
been flushed (active low)

DSI Development serial in Input BDM data input

VDD Output Target power (+5 V or +3.3 V)

IPIPE Instruction pipe Output Used to track the movement of words through the
instruction pipeline (active low)

DSO Development serial out Output BDM data output

DS Data strobe Output During read, indicates ready to receive valid data;
during write, indicates that valid data is on the bus; used
by the HP E3490A Software Probe to indicate that a bus
cycle is in progress (optional)

BERR Bus error Input Used to terminate target memory cycles (optional)
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8-pin BDM port

If you plan to use the provided 8-pin cable, the BDM port should be a
dual row header strip ("Berg connector"), 4 pins per row, 10 pins per
inch, with 25 mil pins. If you plan to use the 10-pin cable, use a header
with 2 rows of 5 pins.

If you plan to use the provided 8-pin cable, you should use the
following pin assignments for the BDM port:

10-pin BDM port

If you plan to use the provided 10-pin cable, you should use the
following pin assignments for the BDM port:

Target VDD
The HP E3490A Software Probe may draw up to 10 mA from target
VDD.

Read the specifications on page 92 for more information on current
and voltage requirements.

CONFIG2 pin

The CONFIG2 pin on CPU32+ processors shares a pin with the
processor FREEZE output.  The HP E3490A Software Probe can pull

Designing a Target System

88



this line down and cause the CPU32+ to power up in Slave Mode with
the internal CPU disabled.  To ensure that CONFIG2 is high at reset,
the target should supply sufficient pullup current to drive the
FREEZE input on the HP E3490A Software Probe.  Loading for the
FREEZE pin (and all BDM pins) is described in the "Specifications"
chapter.

Enabling BDM

Your target system does not need to enable background debug mode.

If the HP E3490A Software Probe is connected and turned on before
you turn on the target system, the HP E3490A Software Probe will
enable BDM.

If you connect the HP E3490A Software Probe after you turn on the
target system, the HP E3490A Software Probe will enable BDM when
the target is reset. 

If you turn on the HP E3490A Software Probe while it is connected to
a running target system, the HP E3490A Software Probe will reset the
target system.
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Processor Compatibility

The HP E3490A Software Probe supports the Motorola MC68331, MC68332,
MC68333, MC68334, MC68335, MC68336, MC68340, and MC68360
microprocessors operating at clock speeds up to 25 MHz. (Other processors
and clock speeds may be supported.  Contact HP for a complete list.)

The HP E3490A Software Probe supports both 5V and 3.3V operation.

Electrical Specifications

BNC, labeled TRIGGER OUT 

Output Drive Logic high level with 50-ohm load >= 2.0 V when in BDM
monitor. Logic low level with 50-ohm load <= 0.4 V when running user
code or when in reset.

BNC, labeled BREAK IN

Input Edge-triggered TTL level input (active high), 20 pf, with 2K ohms
to ground in parallel. Maximum input: 5 V above VCC; 5 V below ground.
When this input is driven, the target system is forced into background
mode.

Communications  

Serial Port 9-pin female type “D” subminiature connector. RS-232 DCE
to 115.2 kbaud.

10BASE-T LAN Port RJ-45 connector. IEEE 802.3  10BASE-T
(StarLAN).

10BASE 2 LAN Port 50-ohm BNC connector. IEEE 802.3  10BASE2
(ThinLAN). When using this connector, the HP E3490A Software Probe
provides the  functional equivalent of a Medium Attachment Unit (MAU)
for ThinLAN.

Power Supply

Input 100-240 V, 9.75 A, 50/60 Hz, IEC 320 connector.

Output 5 V, 1.0 A 

Accessory Output 100-240 V, 9.50 A, 50/60 Hz
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Maximum Ratings

Characteristic Symbol Value Unit

Supply Voltage from Target VDD –0.3 to +5.5 V

Characteristic Symbol
VDD = 5 Volts VDD = 3.3 Volts

Unit
Min Max Min Max

Input Current (VDD) Iil 10 6 mA

Input Voltage Vin VSS-0.5 VDD+0.5 VSS-0.5 VDD+0.5 V

Input High Voltage Vih 2 VDD+0.5 2 VDD+0.5 V

Input Low Voltage Vil VSS-0.5 0.8 VSS-0.5 0.8 V

Input High Current Iih -20 -15 µA

Input Low Current Iil 0.6 0.35 mA

Input Capacitance Cin 40 40 pF

Output High Voltage (BKPT_L, IFETCH_L/DSI) Voh 3.86 3 V

Output High Current (BKPT_L, IFETCH_L/DSI) Ioh -4 -2 mA

Output Low Voltage (BKPT_L, IFETCH_L/DSI) Vol 0.4 0.4 V

Output Low Current (BKPT_L, IFETCH_L/DSI) Iol 3.4 3.4 mA

Output Low Voltage (BERR_L, RESET_L), 
Iol = 12 mA*

Vol 0.4 0.4 V

Output Low Voltage (BERR_L, RESET_L), 
Iol = 24 mA*

Vol 0.5 0.5 V

*The Voh specification for BERR_L and RESET_L is not applicable because
they are OPEN-collector outputs.

Input-only pins: VDD, DS_L, FREEZE, I_PIPE_L/DSO

Output-only pins: BKPT_L

Input/output pins: IFETCH_L/DSI, BERR_L, RESET_L
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Environmental Specifications

Temperature

Operating, 0 to +40 °C (+32 to +104 °F); nonoperating, -40 to +60 °C (-40 to
+140 °F). 

Altitude

Operating/nonoperating 4600 m (15 000 ft). 

Relative Humidity

15% to 95%. 
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Updating Firmware

Hewlett-Packard formally supports only configurations that include
the latest revisions of all software and firmware. Software updates can
be ordered to get the latest firmware revisions.

You can update the firmware in the HP E3490A Software Probe by
running the progflash utility program.  Progflash downloads code from
files on the host computer into Flash EPROM memory which is
built-in to the HP E3490A Software Probe.

This chapter describes how to:

• Order the software updates.

• Update firmware with the "progflash" command.

• Display current firmware version information.
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To order the software updates

1 Order the HP BasicLine software support service for the products
that are to be kept up to date.  The Software Update Materials will
include files for updating firmware as well as the host-resident user
interface software.

2 Order Software Materials Subscription (SMS) subscriptions for the
products that contain the progflash program and the flashware.
If you’re using the HP E3490A Software Probe with an HP 9000 computer or
a Sun SPARCsystem computer:

The HP B1471 64700 Operating Environment product contains the
progflash program.

The graphical Debugger/Emulator interface product contains
flashware.

If you’re using an IBM PC AT compatible computer:

The HP 64700BX Option 006 product contains the progflash program.

The Real-Time C Debugger product contains flashware for the
HP E3490A Software Probe.

Updating Firmware
To order the software updates

97



To update firmware with "progflash"

1 Make sure your HP E3490A Software Probe is listed in the
64700tab.net file.

2 Install the update software on your computer.
The following table describes the files that are used when updating firmware.

Files Used During Firmware Updates

File Description
Location on HP 9000 or Sun
SPARCsystem computers

Location on IBM PC
AT compatible
computers

progflash Executable program. $HP64000/bin \hp64700\bin

<product>.cfg
<product>.X

Product configuration file.
Product code file.

$HP64000/inst/update \hp64700\update

3 Enter the progflash  command.
4 Answer the questions asked by the progflash command.

The progflash command downloads code from files on the host computer into
Flash EPROM memory in the HP E3490A Software Probe.

Instead of running progflash interactively, you may use options to the
progflash command:
progflash [-v] [emul_name] [products_to_update ...]

The -v option means "verbose".  It causes progress status messages to be
displayed during operation.

The emulname option is the logical emulator name as specified in the
64700tab or 64700tab.net file.

The products_to_update option names the products whose firmware is to be
updated.  For the HP E3490A Software Probe, the product name is "E3490".

If you enter the progflash command without options, it becomes interactive.
If you don’t include the "emulname" option, it displays the logical names in
the 64700tab or 64700tab.net file and asks you to choose one.  If you don’t
include the "products_to_update" option, it displays the products which have
firmware update files on the system and asks you to choose one.  (In the
interactive mode, only one product at a time can be updated.)  You can abort
the interactive progflash command by pressing <CTRL>c.
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Progflash will print "Flash programming SUCCEEDED" and return 0 if it is
successful; otherwise, it will print "Flash programming FAILED" and return a
nonzero (error).

You can verify the update by displaying the firmware version information.

Example To use update the firmware in "myprobe", you could enter the following
command:
progflash -v myprobe E3490

To display current firmware version information

• Use telnet or a terminal emulator to access the built-in "terminal
interface" and use the ver command to view the version information
for firmware currently in the HP E3490A Software Probe.

Updating Firmware
To display current firmware version information
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If the firmware doesn’t appear to be updated

Though Flash EPROM is very reliable, it can fail.  If the HP E3490A Software
Probe determines the Flash EPROM is not working, it will try to use the boot
code in its Flash EPROMs.  The only useful operation the boot code allows is
running progflash.

Make sure the current version information is incorrect by comparing it
with the version numbers of the update software.

Try updating the firmware again.

If none of these steps solves the problem, contact your local HP
Representative.

If there is a power failure during a firmware update

If there is a power glitch during a firmware update, some bits may be lost
during the download process, possibly resulting in an HP E3490A Software
Probe that will not boot up.

Set switch S4 to OPEN, then cycle power. This tells the HP E3490A
Software Probe to ignore everything in the Flash EPROM except the
boot code.

Repeat the firmware update process.

Set switch S4 to CLOSED, then cycle power. This restores the
HP E3490A Software Probe to its normal mode.

See Also "If the data in ROM is corrupt" on page 120.
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Solving Problems

If you have problems with the HP E3490A Software Probe, your first
task is to determine the source of the problem.  Problems may
originate in any of the following places: 

• The HP E3490A Software Probe itself

• The connection between the HP E3490A Software Probe and your
host computer

• The software on the host computer

• The connection between the HP E3490A Software Probe and the
target system

• The target system

You can use several means to determine the source of the problem:

• The status lights on the HP E3490A Software Probe

• Error messages displayed on the host computer

• Diagnostic tests performed using the host computer

• The HP E3490A Software Probe "performance verification" tests
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Status lights

The following illustration shows the status lights on both sides of the
HP E3490A Software Probe and what they mean:

Lit when the power
supply is properly
connected

Lit when the target system is in a
reset state

Lit when the target processor is
running in background debug mode

Lit when the target processor is running in
normal (user program) mode

Lit when LAN data is being transmitted

Lit when 10BASE-T
connection has a
good link; not used
for 10BASE2 

Lit when the polarity on
the receive twisted pair
is reversed for a
10BASE-T connection

Lit when LAN data is being received
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Status Lights

The HP E3490A Software Probe communicates various modes and
error conditions via the status lights.  The meanings of the status
lights are shown on the previous page.

The following table gives more information about the meaning of the
power and target status lights.

❍ = LED is off 
● = LED is on 
✳ = Not applicable (LED is off or on)

Power/Target Status Lights

Pwr/Target
LEDs Meaning
❍❍❍❍ HP E3490A Software Probe is not connected to power supply 
●❍❍❍ No target system power, or HP E3490A Software Probe is not connected

to the target system
●●❍❍ Target system is in a reset state
●❍●● Only boot firmware is good (other firmware has been corrupted)
●❍●❍ Target system is executing in Background Debug Mode
●❍❍● Target system is executing user code
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Problems with the LAN Interface

If you cannot verify LAN communication

Use the "telnet" command on the host computer to verify LAN
communication.  After powering up the HP E3490A Software Probe, it takes
up to a minute before the HP E3490A Software Probe can be recognized on
the network. After a minute, try the "telnet <internet address>" command.

If "telnet" does not make the connection:

Make sure that you have connected the HP E3490A Software Probe to
the proper power source and that the power light is lit.

Make sure that the LAN cable is connected.  Refer to your LAN
documentation for testing connectivity.

Make sure that only one of the LAN ports is connected.

Make sure the HP E3490A Software Probe communication configuration
switches are set correctly.  Unplug the HP E3490A Software Probe
power cord, then plug it in again to make sure the switch settings are
read correctly by the HP E3490A Software Probe.

Make sure that the HP E3490A Software Probe’s IP address is set up
correctly.  Use the RS-232 port to verify this that the IP address is set up
correctly.  When you are connected to the RS-232 port, run performance
verification on the HP E3490A Software Probe’s LAN interface with the
"pv" command.

If "telnet" makes the connection, but no prompt (for example, R>, M>, U>,
etc.) is supplied:
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It’s possible that the host software is in the process of running a
command. You can use <CTRL>c to interrupt and get the Terminal
Interface prompt.

It’s also possible for there to be a problem with the HP E3490A Software
Probe firmware while the LAN interface is still up and running.  In this
case, you must reboot the HP E3490A Software Probe by disconnecting
power to the HP E3490A Software Probe and reconnecting it again.

If you have LAN connection problems

Try to "ping" the HP E3490A Software Probe.  At your operating system
prompt, type:

ping <hostname or IP address>

If it does not respond:

1. Check that switch S1 is "0" (attached to LAN, not RS-232).

2. Check that switch S5 is in the correct position for your LAN interface
(either 10BASE2 or 10BASE-T).

(Remember: if you change any switch settings, the changes do not take effect
until you cycle power.)

If the HP E3490A Software Probe still does not respond to a "ping", you
need to verify the IP address and gateway mask of the HP E3490A
Software Probe.  To do this, connect the HP E3490A Software Probe to a
terminal or terminal emulator (see page 20), change the switch settings
so it is connected to RS-232, and enter the "lan" command.  The output
looks something like this:

lan -i 15.5.24.116 
lan -g 15.5.23.1 
lan -p 6470 
Ethernet Address : 08000909BAC1

"lan -i" shows the internet address is 15.5.24.116 in this case.  If the Internet
address (IP) is not what you expect, you can change it with the ’lan -i <new
IP>’ command.

"lan -g" shows the gateway address.  Make sure it is the address of your
gateway if you are connecting from another subnet, 0.0.0.0 if you are
connecting from the local subnet.
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"lan -p" shows the port is 6470.  If the port is not 6470, you must change it
with the "lan -p 6470" command (unless you have deliberately set the port
number to a different value because of a conflict).

If you have LAN DLL errors

On a PC, the various LAN transport selections require the following DLLs:

• HP-ARPA

• WSOCKETS.DLL.

• Novell-WP

• WLIBSOCK.DLL.

• W4WG-TCP

• WSOCKETS.DLL.  (Windows for Workgroups)

• WINSOCK1.1

• WINSOCK.DLL.

These DLLs are included with LAN software.  The required DLL must be in
your search path.  This will be the case if your network software is installed.

If the "POL" LED is lit

The "POL" LED indicates that the polarity is reversed on the receive pair if
you are using a 10BASE-T connection.  The HP E3490A Software Probe
should still work properly in this situation, but other LAN devices may not
work.
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If it takes a long time to connect to the network

Check the subnet masks on the other LAN devices connected to your
network.  All of the devices should be configured to use the same subnet
mask.

Subnet mask error messages do not indicate a major problem.  You can
continue using the HP E3490A Software Probe. 

The HP E3490A Software Probe automatically sets its subnet mask based on
the first subnet mask it detects on the network.  If it then detects other
subnet masks, it will generate error messages.

If there are many subnet masks in use on the local subnet, the HP E3490A
Software Probe may take a very long time to connect to the network after it is
turned on.

To "clean up" the network, connect a terminal to the HP E3490A Software
Probe.  You can then see error messages which will help you identify which
devices on the network are using the wrong subnet masks.
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Problems with the Serial Interface

If you cannot verify RS-232 communication

If the HP E3490A Software Probe prompt does not appear in the terminal
emulator window:

Make sure that you have connected the HP E3490A Software Probe to
the proper power source and that the power light is lit.

Make sure that you have properly configured the data communications
switches on the HP E3490A Software Probe and the data
communications parameters on the host computer.  You should also
verify that you are using the correct cable.

The most common type of data communications configuration problem
involves the configuration of the HP E3490A Software Probe as a DTE device
instead of as a DCE device.  If you are using the wrong type of cable, no
prompt will be displayed.

A cable with one-to-one connections will work with a PC or an HP Series 700
workstation.

If you have RS-232 connection problems with the MS
Windows Terminal program

Remember that Windows 3.1 only allows two active RS-232 connections
at a time.  To be warned when you violate this restriction, choose
Always Warn in the Device Contention group box under 386 Enhanced
in the Control Panel.

Use the "Terminal" program (usually found in the Accessories windows
program group) and set up the "Communications..." settings as follows:
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Baud Rate: 19200 (or whatever you have chosen for the
emulator) 
Data Bits: 8 
Parity: None 
Flow Control: hardware 
Stop Bits: 1

When you are connected, hit the Enter key.  You should get a prompt back.
If nothing echos back, check the switch settings on the HP E3490A Software
Probe.

If the switches are in the correct position and you still do not get a
prompt when you hit return, try turning OFF the power to the
HP E3490A Software Probe and turning it ON again.

If you still don’t get a prompt, make sure the RS-232 cable is connected
to the correct port on your PC, and that the cable is appropriate for
connecting the PC to a DCE device.  

With certain RS-232 cards, connecting to an RS-232 port where the
HP E3490A Software Probe is turned OFF (or is not connected) will hang the
PC.  The only way to get control back is to reboot the PC.  Therefore, we
recommend that you always turn ON the HP E3490A Software Probe before
attempting to connect via RS-232.
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Problems with the N-Wire Connection

If a user interface behaves erratically

Check the orientation of the cable connecting the HP E3490A Software
Probe to your target system.  If the cable is offset or rotated, the
HP E3490A Software Probe will try to interpret the "random" signals
with unpredictable results.  If the cable is rotated, the HP E3490A
Software Probe or target system may also be damaged.

Check that the processor clock speed has been properly configured. See
page 46.

If your target system uses a 68360, check that the FREEZE and
CONFIG2  lines have sufficient pull-up current.  See page 88 for more
information.
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Problems with Configuration

If you have problems displaying some registers

If your user interface can read or write "generic" registers, but cannot
access registers that are unique to your target microprocessor, check
that the target microprocessor matches the processor type you have
selected for your user interface.  Use the configuration dialog in your
user interface software to set the target processor type.

If the value of the SP and PC are displayed as ???, see "If boot area
accesses fail" on page 113.

If you have problems initializing some registers

Some registers can only be written once after processor reset. 

If you set the EMSIM values, then reset and break, the EMSIM values will be
written to the SIM registers. If your initialization code then attempts to write
to one of the "write once after reset" registers, the writes will fail.

If you are using the Real-Time C Debugger interface, use the
Execution→Run...From Reset command to correctly execute the
initialization code.

If you are using the Debugger/Emulator interface on a workstation, use the
Execution→Run→From Reset command to correctly execute the
initialization code.
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Problems with the Target System

If boot area accesses fail

When you start a debugger interface or attempt to run from reset, the
HP E3490A Software Probe makes four accesses to the target system boot
area to find reset values for the SP and PC. It then attempts to read the
values on the stack and the code at the PC.

This problem can result in unknown values for the SP and PC (displayed as
???) and can make the debugger interface respond very slowly.

To avoid this problem, you can do several things:

Use the 10-pin connector.  The extra two pins on this connector allow
the HP E3490A Software Probe to complete unterminated memory
cycles.

In your boot-up code, set the initial PC and stack pointer to memory
which will be accessible at reset.  Be sure to set the chip selects
appropriately.

If the target system does not run

Check that the CONFIG2 line is not floating. See page 88 (the "CONFIG2
pin" section in the "Designing a Target System" chapter) for more
information.
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Problems with the HP E3490A Software Probe
Itself

To run the power up self test

1 Unpug the HP E3490A Software Probe, then plug it in.
2 Watch the status lights.  They should show the following pattern:

❍ = LED is off 
● = LED is on 
✳ = Not applicable (LED is off or on)

Normal sequence during power up self test 

Pwr/Target
LEDs Meaning

1 ●●●● Initial power up, system reset 
2 ●❍❍❍ XILINX array initialized successfully
3 ●❍❍● XILINX array tested successfully
4 ●❍●❍ BOOT ROM space tested successfully
5 ●❍❍● GENERIC ROM space tested successfully
6 ●❍●❍ DRIVER ROM space tested successfully
7 ●❍❍● RESERVED ROM space tested successfully
8 ●❍●❍ RAM tested successfully
9 ●❍●● LAN internal feedback tested successfully
10 ●❍●● Start system, load drivers, initialize LAN

If the power up self test fails, the RESET LED will flash the number of the
test, then stay lit.

If any of the LEDs fail to change, or all of them remain on, there is a system
failure.

Following power up, the LEDs will enter one of the following states:
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●❍❍❍ No target system power, or HP E3490A Software Probe is not connected
to the target system, or

●●❍❍ Target system is in a reset state
●❍●● Only the boot ROM was used; other firmware in the Flash EPROM has

been corrupted

Starting a user interface will change the pattern to the one requested
by the interface.

If the power up self tests fail, try the following:

Check and reset the LAN address as shown in the "Connecting to the
Host Computer" chapter. LAN powerup failures will occur if the
HP E3490A Software Probe does not have a valid Link Level Address
and IP Address. 

Disconnect all external connections, including the LAN, serial (RS-232),
and BNC Break and Trigger cables, then cycle power. 

To ensure that the firmware is working as it should, reprogram the
firmware, then cycle power.

To execute the built-in performance verification test

In addition to the powerup tests, there are additional tests available through
the built-in "terminal interface."  Three of these tests can be invoked through
either a telnet session to the HP E3490A Software Probe or through a
terminal emulator on the RS-232 port.  The LAN tests can only be executed
through the RS-232 port.

The remainder of this section assumes that the tests are being run from a
terminal emulator connected to the RS-232 port.  

1 Set all of the switches to OPEN.
This is standard RS-232 at 9600 baud which can be connected directly to a 9
pin RS-232 interface that conforms to the IBM PC-AT 9 pin standard.

2 Use a terminal emulator to connect to the HP E3490A Software Probe.
3 Enter the pv command.
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Options available for the "pv" are explained in the help screen displayed by
typing "help pv" or "?  pv" at the prompt. The help screen output will appear
similar to the screen shown below:

R>? pv 

  pv - Execute the system performance verification diagnostics. 

  USAGE: pv <-l> <-t*|x[-y]> <-f> <-vverbose_level> <repeat_count> 
    pv                - display pv warning message 
    pv <-l>           - list pv test#s and descriptions only (do not execute) 
    pv <-t*|x[-y]>    - select pv test number x or  tests x thru y only 
                        * selects all emulation tests 
    pv <-f>           - for factory use only 
    pv <-vverbose>    - set verbose level;  valid levels: 1-9. 
    pv <repeat_count> - execute diagnostics (repeat_count> number of times. 
                        repeat_count of 0 repeats until keyboard break 
  SETUP: 
    10BASE2 FEEDBACK TEST: 
                  Disconnect 10Base2 Connector From the Network 
                  Terminate With Two 50 Ohm Terminators on a TEE 
    10BASET FEEDBACK TEST: 
                  Connect 10BaseT Connector To Active Port 
    BREAK IN, TRIGGER OUT BNC FEEDBACK TEST: 
                  Connect Coaxial Cable Between BREAK IN and TRIGGER OUT 
    TARGET PROBE FEEDBACK TEST: 
                  Replace Target Cable With Feedback Connector E3490-61604 

  WARNING*** This command performs a system initialization after 
             all pv execution is completed. 
R>

Examples: To execute all tests one time:

pv 1

To execute test 2 with maximum debug output repeatedly until a ^C is
entered:
pv -t2 -v9 0

To execute tests 3, 4, and 5 only for 2 cycles:
pv -t3-5 2
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The tests available through this command can be displayed as follows:
R>pv -l 
  Tests Available in Performance Verification; 
    Test # 1: Powerup PV Results 
    Test # 2: LAN 10Base2 Feedback Test 
    Test # 3: LAN 10BaseT Feedback Test 
    Test # 4: Break In and Trigger Out BNC Feedback Test 
    Test # 5: Target Probe Feedback Test 
R>

On a good system, when the E3490-61604 feedback connector is plugged into
the 20 pin target connector, the RESET LED will light and the BKG and
USER LEDs will be out.

The results on a good system are as follows: 
R>pv 1 

  Testing: HPE3499A Series Emulation System 
    Test # 1: Powerup PV Results                            passed! 
    Test # 2: LAN 10Base2 Feedback Test                     passed! 
    Test # 3: LAN 10BaseT Feedback Test                     passed! 
    Test # 4: Break In and Trigger Out BNC Feedback Test    passed! 
    Test # 5: Target Probe Feedback Test                    passed! 
  PASSED  Number of tests: 1           Number of failures: 0 

                  Copyright (c) Hewlett-Packard Co. 1987 
All Rights Reserved.  Reproduction, adaptation, or translation without prior 
written permission is prohibited, except as allowed under copyright laws. 

  HPE3499A Series Emulation System 
    Version:   A.05.00 29Aug94 15:53 Proto 
    Location:  Generics 

  HPE3490A Motorola CPU32 BDM Emulator 
    Version:   A.01.00 30Aug94 13:07 Proto 

R>

There are some things you can do if a failure is found on one of these tests.
Details of Failure can be obtained through using a verbose level of 2 or more.  

TEST 2: LAN 10BASE2 Feedback Test

For LAN 10BASE2 test, the following is an example of a failure which is not

caused by a broken HP E3490A Software Probe.

Solving Problems
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R>pv -t2 -v2 1 

  Testing: HPE3499A Series Emulation System 
    Test # 2: LAN 10Base2 Feedback Test                     failed! 
      FAILED - no lan connection (LAN probably not terminated) 
  FAILED  Number of tests: 1           Number of failures: 1

Check to see that the port under test has a good cable connected to it and
that the cable is properly terminated with a 50 ohm terminator on each end
of the overall cable.

R>pv -t2 -v2 1 

  Testing: HPE3499A Series Emulation System 
    Test # 2: LAN 10Base2 Feedback Test                     failed! 
      FAILED due to excessive collisions 
  FAILED  Number of tests: 1           Number of failures: 1

The most common cause of this problem is poor termination of the cable or
failure to remove the port under test from the LAN before performing the
test.  Check to see that the terminators are good (50 Ohms) and that you are
isolated from any traffic on a system LAN.

R>pv -t2 -v2 1 

  Testing: HPE3499A Series Emulation System 
    Test # 2: LAN 10Base2 Feedback Test                     failed! 
      FAILED - invalid Ethernet address in EEPROM 
  FAILED  Number of tests: 1           Number of failures: 1

First check to see that a correct LLA and IP address have been set in the
virtual EEPROM through the "lan" command. If the "lan" command shows bad
information for the LLA and IP, then try to set them to correct values.  If you
are unable to set them to correct values, their is a failure in the FLASH ROM
which requires service from HP.

Test 3: 10BaseT Feedback Test

R>pv -t3 -v2 1

  Testing: HPE3499A Series Emulation System 
    Test # 3: LAN 10BaseT Feedback Test                     passed!
  PASSED  Number of tests: 1           Number of failures: 0

In addition to the internal checks performed in Test 2, this test also checks
for shorts on the cable connected to the network.  If this test fails, disconnect
the cable and run the test again.  If it then passes, the cable is faulty.  If it still
fails, it requires service from HP.

Solving Problems
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If the HP E3490A Software Probe passes this "pv" test, additional testing can
be performed through exercising the connection to the network.  To run this
test, set configuration switch 1 and switch 5 to OPEN, all other configuration
switches CLOSED (this enables LAN using 10BaseT).  Cycle power and wait
for 15 to 30 seconds.  Then "ping" the HP E3490A Software Probe from your
host computer or PC.  See the LAN documentation for your host computer
for the location and action of the "ping" utility.  If the HP E3490A Software
Probe fails to respond to the "ping" request, verify that the lan parameters (IP
address and gateway address) are set correctly and that your host computer
recognizes the IP address of the HP E3490A Software Probe.  If all else is
good, then failure to respond to ping indicates a faulty HP E3490A Software
Probe.

TEST 4:   Break In and Trigger Out BNC Feedback Test 

R>pv -t4 -v2 1 

  Testing: HPE3499A Series Emulation System 
    Test # 4: Break In and Trigger Out BNC Feedback Test    failed! 
      Break In not receiving Break Out HIGH 
  FAILED  Number of tests: 1           Number of failures: 1

Before returning to HP, check to ensure that you have connected a good
Coaxial cable between the two BNCs.  If the cable is good, the E3490A is bad. 

TEST 5: Target Probe Feedback Test 

A verbose output on this test can be extensive.  For example, the following is
the output of this test if you forget to plug in the E3490-61604 connector.

p>pv -t5 -v2 1 

  Testing: HPE3499A Series Emulation System 
    Test # 5: Target Probe Feedback Test                    failed! 
      Bad 20 Pin Status Read when unconnected = 0x7fb7 
                               Expected Value = 0xffb7 
      Bad 20 Pin Status Read when connected= 7fb7 
                             Expected Value = 0x7fb7 
      Output 19 Low not received on Input 11 
      Output 11 Low not received on Input 19 
      Output 13 Low not received on Input 1 
      Output 12 High not received on Input 6 
      Output 12 and Input 6 not pulled high on release 
      Output 8 Low not received on Input 10 
      Output 7 Low not received on Input 20 

Solving Problems
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      Output 4 Low not received on Input 14 
      Output 2 Low not received on Input 18 
  FAILED  Number of tests: 1           Number of failures: 1

If the you get a verbose output like this, check to make sure that the self test
loopback connector was connected properly.

If the data in ROM is corrupt

Sometimes the data in the FLASH ROM can be corrupt.  This can be caused
while programming of the FLASH ROM if one of the following things happens:

• A system fault

• A loss of power to the HP E3490A Software Probe or host computer

• A break in the communications channel

If this happens, try the following steps:

1 Cycle power on the HP E3490A Software Probe and try the flash
programming utility (progflash) again.
If this doesn’t work, continue with the next step:

2 Set switch S3 to OPEN and switch S4 to CLOSED, then cycle power.
This will force the HP E3490A Software Probe to use only the boot ROM.  Try
running the programming utility again.  If this is successful, return the
switches to their normal configuration (S3  and S4 OPEN) and cycle power.

Solving Problems
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Returning the HP E3490A Software Probe to
Hewlett-Packard for Service

To return the HP E3490A Software Probe to
Hewlett-Packard

1 Follow the procedures in this chapter to make sure that the problem
is caused by a failure in the HP E3490A Software Probe or power
supply, not by configuration or communication problems.

2 Call your nearest HP sales office.  Ask them for the address of the
nearest HP service center.
A list of HP sales offices is included at the back of this binder.

3 Package the HP E3490A Software Probe or the power supply and
send it to the HP service center.
If only the HP E3490A Software Probe is broken, keep the power supply and
cables .  If only the power supply is broken, keep the HP E3490A Software
Probe and cables.

4 When the HP E3490A Software Probe or the power supply has been
replaced, it will be sent back to you.
The unit returned to you will have the same serial number as the unit you
sent to HP.

Solving Problems
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To obtain replacement cables

• Order one of the following parts from your HP sales office:

Cable part numbers

Part number Description
E3490-61601 8-pin BDM cable
E3490-61602 10-pin BDM cable
E3490-61603 10-pin flying lead assembly

A list of HP sales offices is included at the back of this manual.

Solving Problems
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Glossary

BDM Background Debug Mode. An
alternate operating mode of
Motorola CPU32 microprocessors.
BDM allows various debugging func-
tions under external control.

configuration A set of parameters
which control the operating modes
and behavior of the HP E3490A Soft-
ware Probe.  Using your user
interface software, you can create,
modify, and save configurations as
configuration files. A configuration
must be applied to the HP E3490A
Software Probe before it has any ef-
fect.

IP address Internet Protocol ad-
dress. A 32-bit network address.  It
is usually represented as decimal
numbers separated by periods; for
example, 192.35.12.6.  You must as-
sign this address to the HP E3490A
Software Probe.

logical name A name you make
up for an HP E3490A Software
Probe. You will use this name to iden-
tify the HP E3490A Software Probe
whenever you start the user inter-
face software. This name can be any
easy to remember name, perhaps a
unique name for the target or proces-
sor.

user interface software A pro-
gram, such as a debugger, which
runs on a host computer and which

allows you to communicate with the
HP E3490A Software Probe.
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Index

64700tab.net file, 24–26

A

address, IP
See IP address

algorithms, flash memory, 80
altitude specifications, 94
AUI connector on LAN interface, 9

B

BKG light, 103
BNC, LAN, 9, 92
BOOTP, 16–17
bus cycle termination, 86

C

cable
BDM, 29
LAN, 18
power, 8–9
replacing, 122
serial, 21–22

clock rate
reset, 31–32

clocks
specifications, 92–93

CONFIG2 line, 89
configuration

using Debugger/Emulato, 41–56
using RTC interface, 57–70

connecting to the host workstation, 3–26
connecting to the target system, 27–32
connection problems, LAN, 106
connection problems, RS-232, 109–110
connector

10BASE-T, 92
10BASE2, 92
BDM, 29
serial, 92

D

data communications
specifications, 92

DCE or DTE selection and RS-232 cable,
109
DLL errors, 107

E

EMSIM registers, 51–56, 66–70
eratic behavior, 111
ethernet address, 11

F

files
64700tab.net, 24–26
workstation setup, 24

firmware version, 99
firmware, corrupt, 120
firmware, updating, 96
Flash EPROM, 96
flash memory

programming, 80, 82
supported parts, 80

G

gateway, 106
gateway address, 12, 14–15

H

HP 64700 LAN port number, 106
HP 64700 switch settings, 

LAN, 106
RS-232, 109–110

HP-ARPA LAN transport DLL, 107
humidity specifications, 94

I

IEEE 802.3, 9
interfaces, 36
internet address

See IP address
IP address, 9–11, 14–15, 105–106
ipconfig700, 14–15

L

LAN connection problems, 106, 117–118
LAN interface, 9
LAN parameters, configuring, 9

BOOTP, 16–17
ipconfig700, 14–15
terminal interface, 11–13

lights

See status lights
link beat, 18
link level address, 11, 15, 17
LINK light, 103

M

mask, subnet, 108
MAU, 9, 92

N

Novell LAN transport DLL, 107

O

order
update, 97

P

performance verification test, 115–119
ping command, 106
POL light, 103, 107
port number, 12
power cord, 5, 8–9
power failure during firmware update, 100
power up self test, 114
probe, testing, 119
processor type, setting, 45, 60
progflash, 96

R

registers
EMSIM, 51–56, 66–70
initializing, 112
problems displaying, 112–113
unknown values, 113

RESET light, 103
restriction on number of RS-232
connections, 109–110
RS-232

See serial connection
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S

search path, 107
self test, 114
serial connection

DCE or DTE selection, 109
number of connections, 109–110
problems, 109–110
setting up, 20
verifying, 23

service ports, TCP, 12
service, how to obtain, 121
software material subscription (SMS), 97
software updates, 97
specifications

altitude, 94
clock, 92–93
data communications, 92
humidity, 94
temperature, 94
trigger in/out, 92

StarLAN, 9, 18
status lights, 104, 114
subnet mask, 9, 106, 108
switches

bootp, 17
serial configuration, 21

T

target system
connecting to, 28

telnet, 19, 105
temperature specifications, 94
terminal (MS Windows program), 109–110
terminal interface, 19

LAN parameters, setting, 11–13
not supported, 36

ThickLAN, 9
ThinLAN, 9, 92
trigger

in/out specifications, 92
turning on power, 8–9
TX light, 103

U

update
firmware, procedure, 98

update, firmware, 96
USER light, 103

V

version, firmware, 99
voltage

processor, 92

W

Windows for Workgroups LAN transport
DLL, 107
WINSOCK LAN transport DLL, 107
WINSOCK.DLL, 107
WLIBSOCK.DLL, 107
workstation files, 24
WSOCKETS.DLL, 107

Index
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DECLARATION OF CONFORMITY
according to ISO/IEC Guide 22 and EN 45014

Manufacturer’s Name: Hewlett-Packard Company

Manufacturer’s Address: Colorado Springs Division
1900 Garden of the Gods Road
Colorado Springs, CO 80907 U.S.A.

declares, that the product

Product Name: Software Probe

Model Number(s): E3490A

Product Option(s): All

conforms to the following Product Specifications:

Safety: IEC 1010-1:1990+AMD 1 :1992
UL 3111

EMC: CISPR 11:1990 / EN 55011:1991 Group 1 Class A
IEC 801-2:1991 / EN 50082-1:1992 4 kV CD, 8 kV AD
IEC 801-3:1984 / EN 50082-1:1992 3 V/m, {1kHz 80% AM, 27-1000 MHz}
IEC 801-4:1988 / EN 50082-1:1992 0.5 kV Sig. Lines, 1 kV Power Lines

Supplementary Information:

The product herewith complies with the requirements of the Low Voltage Directive
73/23/EEC and the EMC Directive 89/336/EEC.

Colorado Springs, 6/15/94

European Contact: Your local Hewlett-Packard Sales and Service Office or Hewlett-Packard GmbH, Department ZQ /
Standards Europe, Herrenberger Strasse 130, D-71034 Böblingen Germany (FAX: +49-7031-14-3143)

John Strathman, Quality Manager



Product Regulations

Safety IEC 1010-1:1990+AMD 1:1992
UL 3111

EMC This product meets the requirement of the European
Communities (EC) EMC Directive 89/336/EEC.

Emissions EN55011/CISPR 11 (ISM, Group 1, Class A equipment)
SABS RAA Act No. 24 (1990)

Immunity EN50082-1 Code1 Notes2

 IEC 801-2 (ESD) 4kV CD, 8kV AD
 IEC 801-3 (Rad.) 3 V/m
 IEC 801-4 (EFT) 1kV

 3
 1
 1

 
 
 

1 Performance Codes:
 1 PASS - Normal operation, no effect.
 2 PASS - Temporary degradation, self recoverable.
 3 PASS - Temporary degradation, operator
          intervention required.
 4 FAIL - Not recoverable, component damage.

2 Notes:
  (none)



© Copyright Hewlett-
Packard Company 1994, 1995
All Rights Reserved.

Reproduction, adaptation, or
translation without prior
written permission is
prohibited, except as allowed
under the copyright laws.

Restricted Rights Legend

Use, duplication, or
disclosure by the U.S.
Government is subject to
restrictions set forth in
subparagraph (C) (1) (ii) 
of the Rights in Technical
Data and Computer Software
Clause in DFARS
252.227-7013.
Hewlett-Packard Company,
3000 Hanover Street, Palo
Alto, CA 94304 U.S.A.
Rights for non-DOD U.S.
Government Departments
and Agencies are set forth in
FAR 52.227-19(c)(1,2).

Document Warranty

The information contained in
this document is subject to
change without notice.
Hewlett-Packard makes

no warranty of any kind

with regard to this

material, including, but

not limited to, the implied

warranties of

merchantability or fitness

for a particular purpose.

Hewlett-Packard shall not be
liable for errors contained
herein or for damages in
connection with the
furnishing, performance, or
use of this material.

Safety

This apparatus has been
designed and tested in
accordance with IEC
Publication 348, Safety
Requirements for Measuring
Apparatus, and has been
supplied in a safe condition.
This is a Safety Class I
instrument (provided with
terminal for protective
earthing).  Before applying
power, verify that the correct
safety precautions are taken
(see the following warnings).
In addition, note the external
markings on the instrument
that are described under
"Safety Symbols."

Warning

• Before turning on the
instrument, you must connect
the protective earth terminal
of the instrument to the
protective conductor of the
(mains) power cord. The
mains plug shall only be
inserted in a socket outlet
provided with a protective
earth contact. You must not
negate the protective action
by using an extension cord
(power cable) without a
protective conductor
(grounding).  Grounding one
conductor of a two-conductor
outlet is not sufficient
protection.

• Only fuses with the
required rated current,
voltage, and specified type
(normal blow, time delay,
etc.) should be used.  Do not
use repaired fuses or
short-circuited fuseholders.
To do so could cause a shock
of fire hazard.

• Service instructions are for
trained service personnel. To
avoid dangerous electric
shock, do not perform any
service unless qualified to do
so.  Do not attempt internal
service or adjustment unless
another person, capable of
rendering first aid and
resuscitation, is present.

• If you energize this
instrument by an auto
transformer (for voltage
reduction), make sure the
common terminal is
connected to the earth
terminal of the power source.

• Whenever it is likely that
the ground protection is
impaired, you must make the
instrument inoperative and
secure it against any
unintended operation.

• Do not operate the
instrument in the presence of
flammable gasses or fumes.
Operation of any electrical
instrument in such an
environment constitutes a
definite safety hazard.

• Do not install substitute
parts or perform any
unauthorized modification to
the instrument.

• Capacitors inside the
instrument may retain a
charge even if the instrument
is disconnected from its
source of supply.

Safety Symbols

Instruction manual symbol:
the product is marked with
this symbol when it is
necessary for you to refer to
the instruction manual in
order to protect against
damage to the product.

Hazardous voltage symbol.

Earth terminal symbol: Used
to indicate a circuit common
connected to grounded
chassis.

W A R N I N G

The Warning sign denotes a
hazard.  It calls attention to a
procedure, practice, or the
like, which, if not correctly
performed or adhered to,
could result in personal
injury.  Do not proceed
beyond a Warning sign until
the indicated conditions are
fully understood and met.

C A U T I O N

The Caution sign denotes a
hazard.  It calls attention to
an operating procedure,
practice, or the like, which, if
not correctly performed or
adhered to, could result in
damage to or destruction of
part or all of the product.  Do
not proceed beyond a
Caution symbol until the
indicated conditions are fully
understood or met.

Hewlett-Packard
P.O. Box 2197
1900 Garden of the Gods Road
Colorado Springs, CO 80901-2197, U.S.A



Product Warranty

This Hewlett-Packard
product has a warranty
against defects in material
and workmanship for a period
of one year from date of
shipment.  During the
warranty period,
Hewlett-Packard Company
will, at its option, either
repair or replace products
that prove to be defective.
For warranty service or
repair, this product must be
returned to a service facility
designated by
Hewlett-Packard.
For products returned to
Hewlett-Packard for warranty
service, the Buyer shall
prepay shipping charges to
Hewlett-Packard and
Hewlett-Packard shall pay
shipping charges to return
the product to the Buyer.
However, the Buyer shall pay
all shipping charges, duties,
and taxes for products
returned to Hewlett-Packard
from another country.
Hewlett-Packard warrants
that its software and firmware
designated by
Hewlett-Packard for use with
an instrument will execute its
programming instructions
when properly installed on
that instrument.
Hewlett-Packard does not
warrant that the operation of
the instrument software, or
firmware will be
uninterrupted or error free.

Limitation of Warranty

The foregoing warranty shall
not apply to defects resulting
from improper or inadequate
maintenance by the Buyer,
Buyer-supplied software or
interfacing, unauthorized
modification or misuse,
operation outside of the
environmental specifications
for the product, or improper
site preparation or
maintenance.

No other warranty is

expressed or implied.

Hewlett-Packard

specifically disclaims the

implied warranties of

merchantability or fitness

for a particular purpose.

Exclusive Remedies

The remedies provided herein
are the buyer’s sole and
exclusive remedies.
Hewlett-Packard shall not be
liable for any direct, indirect,
special, incidental, or
consequential damages,
whether based on contract,
tort, or any other legal theory.

Assistance

Product maintenance
agreements and other
customer assistance
agreements are available for
Hewlett-Packard products.
For any assistance, contact
your nearest Hewlett-Packard
Sales Office.

Certification

Hewlett-Packard Company
certifies that this product met
its published specifications at
the time of shipment from the
factory.  Hewlett-Packard
further certifies that its
calibration measurements are
traceable to the United States
National Institute of
Standards and Technology, to
the extent allowed by the
Institute’s calibration facility,
and to the calibration
facilities of other
International Standards
Organization members.

About this edition

This is the second edition of
the HP E3490A Software

Probe User’s Guide.

Publication number
E3490-97002
Printed in USA.
Edition dates are as follows:
First edition, Oct 1994
Second edition, Nov 1994
Third edition, July 1995

New editions are complete
revisions of the manual.
Many product updates do not
require manual changes, and
manual corrections may be
done without accompanying
product changes.  Therefore,
do not expect a one-to-one
correspondence between
product updates and manual
updates.

UNIX is a registered
trademark in the United
States and other countries,
licensed exclusively through
X/Open Company Limited.
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