4400 and 6400 Series Printers

Printer Management Utility
User’s Manual



First Edition (September 2001)

This edition of the Printer Management Utility is to be used with the IBM 6400 Series Line Matrix
Printers and 4400 Series Thermal Printers.

The following paragraph does not apply to the United Kingdom or any country where such
provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES
CORPORATION PROVIDES THIS MANUAL “AS IS” WITHOUT WARRANTY OF ANY KIND,
EITHER EXPRESSED OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. Some
states do not allow disclaimer of express or implied warranties in certain transactions. Therefore,
this may not apply to you.

IBM does not warrant that the contents of this publication or the accompanying source code
examples, whether individually or as one or more groups, will meet your requirements or that the
publication or the source code is error-free.

Requests for copies of this publication and for technical information about IBM products should be
made to your IBM authorized Dealer, your IBM Marketing Representative, or your IBM Software
Solutions Representative.

IBM Printing Systems welcomes your comments. For your convenience, a form for reader’s
comments is provided at the back of this publication. You may send your comments by fax to
1-800-524-1519 within the U.S., by fax to 1-303-924-6873 outside the U.S., by e-mail to
printpub @ us.ibm.com, or mail your comments to:

INFORMATION DEVELOPMENT

IBM PRINTING SYSTEMS
DEPARTMENT 583E BUILDING 003G
PO BOX 1900

BOULDER CO 80301-9191

Note: Visit our home page at http://www.ibm.com/printers

When you send information to IBM, you grant IBM a nonexclusive right to use or distribute the
information in any way it believes appropriate without incurring any obligation to you.

However, the following copyright notice protects this documentation under the Copyright laws of
the United States and other countries which prohibit such actions as, but not limited to, copying,
distributing, modifying, and making derivative works.

© Copyright International Business Machines Corporation 2001. All rights reserved.
US Government Users Restricted Rights - Use, duplication or disclosure restricted by GSA ADP
Schedule Contract with IBM Corp.



Notices

References in this publication to IBM products, programs, or services do not imply that IBM
intends to make these available in all countries in which IBM operates. Any reference to an IBM
licensed product, program, or setrvice is not intended to state or imply that only IBM’s product,
program, or service may be used. Any functionally equivalent product, program, or service that
does not infringe any of IBM’s intellectual property rights may be used instead of the IBM product.
Evaluation and verification of operation in conjunction with other products, except those expressly
designated by IBM, is the user’s responsibility.

Any performance data contained in this document was obtained in a controlled environment based
on the use of specific data. The results that may be obtained in other operating environments may
vary significantly. Users of this document should verify the applicable data in their specific
environment. Therefore, such data does not constitute a performance guarantee or warranty.

IBM may have patents or pending patent applications covering subject matter in this document.
The furnishing of this document does not give you any license to these patents. You can send
license inquiries, in writing, to the IBM Corporation, IBM Director of Licensing, 208 Harbor Drive,
Stamford, Connecticut, United States, 06904.

Trademarks and Service Marks

The following terms, denoted by an asterisk (*) in this publication, are trademarks of IBM
Corporation in the United States or other countries or both:

AIX
IBM

The following terms, denoted by a double asterisk (**) in this publication, are service marks,
trademarks, or registered trademarks of other companies:

Ethernet Xerox Corporation
Java Sun Microsystems, Inc.
Linux Linus Torvalds
Microsoft Microsoft Corporation
Pentium Intel Corporation
Solaris Sun Microsystems, Inc.
Sun Sun Microsystems, Inc.
Windows Microsoft Corporation

UNIX Unix System Laboratories, Inc.






4400 and 6400 Series Printers

Printer Management Utility
User’s Manual

© Copyright IBM Corp., 2001






Table of Contents

OVEIVIEW ..t 9
The Printer Management Utility ... 9
ReqUIrEMENTS ...coiiiiieie e 9
Installing the PMU ... ..o e 9
Printer SEIUP ...eeeiiee e 10
6400 Series Line Matrix Printers ..., 10
4400 Series Thermal Printers........cccooeieiiiiiiiiei e 10
St PaSSWOIA .. .eeiiiiiiiiie e 11
Check POrt NUMDET......coiiiiiii e 11
Getting Started .......c.ovv i 12
Printer Database ..........ccoiiiiiiiiiiiiieee 19
OVEIVIEW ...ttt ettt st e e e sttt e e e st e e e e e anbeeeeeeaaaee 19
The MENU Bar........ooeeeeee e 20
The File MENU ... 20
The Edit MENU ... 24
THEe VIEW MENU ... 26
The Applications MenU..........cc.uuiiiiiiiiiiiie e 29
The Status MENU ....cooiiiiiii e 30
The Utlities MeNU ......cocooiiiiiii e 41
The Help MENU.......ooiiiiee e 44
THE TOOIDAN ... 45
Managing the Database ... 47
Database ItemS ........ooviiiiiii e 47
Defining Printer Properties ... 48
Downloading Files ......coooiiiiiiiie e 53
Applications and Web Access........ccoevvvveevinnnnnnne. 59
OPperator PANEl .........ccooiiiiiiiiiiie e 59
Primary/Secondary Operator Keys.........cccoeueeriieiiieeniiiee e 61
Message DiSPlay .........cccoiueeiiiiiiiiiiie e 61
Status INAICATON .....eiiieiieee s 61
Disabled INAICALON .........coeiiiiiiiiiiie e 61
IN Progress INdiCAtOr ..........ooii e 61
Information Capture..........ooouiiiiiii e 62
Il e 63
Configuration Printout .........cccciiiiiii e 63
=g o] gl oo IR TP UU PRSPPI 63

DIFECIONY .o 63



Table of Contents

Configuration Editor........cooouiiiiiii e 64
MENU TTE .. ettt 64
Creating Configurations .........ccccccoiiiiiinii e 65
Changing Configurations............cccvreeir e 65
Saving Configuration Files ..o 68
Opening Configuration Files...........ocooeiiieiiien e 68
Downloading Configurations ............ccocueeiiiiiiiieniiee e 68
Uploading Configurations...........ccccorueeiiieeiiiee e 69
REVEI . .. 69

Flash File Manager............ocueiiiiiiiiee e 70

Configuration Download/File Download ............cccocoevenieiiiieeineeeieeeens 70

Data Validation ..........ccceviiiiii e 71

ODV Quality WIZard .........coceeeiiieieiieee ettt 72

Configure Print SEIVEIS ........oiiiiiiiiee e 73

SPEEA KBYS ...ttt 74

WED ACCESS ..ottt 75
The PMU Web Site URL ADAress .......coovveieiiiiiieeeeiee e 75
Login To The PMU Web Site .........ccoeiiiiriieee e 76
Changing The User Password ..........cccovueeiieieniien e 76
The Printer List Page .....ccoooiiiiiiiiieeee e 77

Changing User Settings, IP Addresses, and IP Address Ranges....78



1 Overview

The Printer Management Utility

The IBM* printer management utility (PMU) allows you to organize all of the
printers in your office remotely in a single database, download software and
printer settings from a host computer with a single mouse click, and use a
virtual operator’s panel to configure printers in the same room or on the other
side of the world.

Requirements

Running the PMU requires:
+ an IBM 6400 Series Line Matrix or 4400 Series Thermal Printer

* ahost computer running the Microsoft** Windows** (95, 98, Me, NT, or
2000) or UNIX** (such as AIX*, Linux**, or Solaris**) operating system

+ the host computer must be running a Java** Virtual Machine (JVM) that is
fully 1.3 compliant. Sun** Microsystems provides a Solaris, Linux, and
Windows 1.3 compliant JVM known as the Java 2 Runtime Environment,
Standard Edition (JRE) at:
http://java.sun.com/j2se/

+ for Windows 98, a minimum hardware configuration of a 450MHz
Pentium** with 64 MB of RAM

The printer must be attached to the host system via an Ethernet** Interface.
Refer to your printer User’s Manual for information on connecting interfaces.

To install and edit the database, it is not necessary to have the printers
connected. When starting a session with a printer, the printer must be
connected and turned on.

Installing the PMU

The PMU software is only available on CD. Follow the on-screen instructions
to install the software.
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Your printer uses the diagnostic port to communicate with the PMU. The
diagnostic port must be configured to interact with the Ethernet Interface.

Follow the instructions below for your printer model to check the diagnostic
port setting.

6400 Series Line Matrix Printers

On the printer control panel, press the Stop key to take the printer offline.

Press the Scroll T and Scroll | keys at the same time to unlock the Enter
switch.

Press the Scroll T, Scroll |, Enter, and Return keys at the same time to
enter the Service menu.

Press Scroll T until the PRINTER MGMT menu appears.
Press the Enter key until the DIAGNOSTIC PORT option displays.

Press the Enter key again to see the current selection. If the DEBUG
ETHERNET option is already marked with an * (asterisk), continue with
step 9.

Press the Scroll T key until the DEBUG ETHERNET option appears.
Press the Enter key to select it.

Press the Scroll T and Scroll | keys at the same time to lock the Enter
switch.

10. Press the Start key to put the printer back online.

4400 Series Thermal Printers

1.

On the printer control panel, press the PAUSE key to take the printer
offline.

Press the | and ! keys at the same time to unlock the ! switch.

Press the +, -, |, and T keys at the same time to enter the Factory
menu.

Press | to enter the Diagnostic Port menu.

Press the + key until the Debug Ethernet option displays. If the Debug
Ethernet option is already marked with an * (asterisk), continue with
step 7.

Press the . key to select it.
Press the | and . keys at the same time to lock the I switch.
Press the PAUSE key twice to put the printer back online.
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Set Password

See page 41 to learn how to set passwords.

If the password is unknown you must clear it first. Go into the PRINTER MGMT
menu (6400 Series) or Factory menu (4400 Series), then into the
Diagnostic Port menu. Move forward until you reach Clear Password.
Unlock the keyboard, then press ENTER () to clear both passwords.

Under the Security tab in Printer Properties, delete any passwords that
already exist. Now you may set the new passwords as mentioned above.

Check Port Number

Make sure your printer port number has the same setting as the Ethernet
Interface. To check the port number using the PMU, see page 15. To check
the port number on the printer, check the PMU Port Number in the
PRINTER MGMT menu (6400 Series) or Factory menu (4400 Series). The
default port number is 3001.

11
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This section provides a short tutorial on how to set up and access a printer
using the PMU.

1. This tutorial assumes the host computer running the PMU and the printer
you want to access are connected by a network. You must know the
printer’s IP Address and Port Number.

2. From your operating system, launch the PMU. Click the splash screen to
see the main window of the Printer Database more clearly. See Figure 1.

File Edit View Applications Status Utilities Help

= B et ot o B2 @ & o) ] @ X | | == B B <l < ) @ ] | W )
‘=] default.pdb
& E New_Printer (A template)

Status and Error Log:

Figure 1. Printer Database Main Window



Getting Started

Printer Properties

| Identification | Security rCunnectiuns |/Infurmatiun |

Hame (Unigue):  (Mew_Printer

Printer Description: |A tomplate

Onby use characters 4.7, a..z, 0..9 for printer hame and description.

oK

Cancel

Figure 2. Printer Properties: Identification Tab

3. Double-click New_Printer (A template). The Printer Properties dialog
box opens. See Figure 2.

4. Assign a name to your printer. Delete the words “New_Printer” in the
Name (Unique) field, and then type Tutorial.

5. Assign a description to this printer. Delete the words “A template” in the

Printer Description field, and then type My First Connection.

13
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Printer Properties E3 |

fldentiﬁcatiun Securitﬂ Connections |/Infurmatiun |

User Passwaori:

Supervisor Password

[_] Supervisor Mode

Only use characters A..Z, a..z, 0.9 for passworis.

OK Cancel

Figure 3. Printer Properties: Security Tab
Click the Security tab. See Figure 3.

If you are using the PMU for the first time, it is likely that no passwords are
assigned to this printer. If you are unsure, contact your system
administrator.

* If no password is assigned, leave both password boxes empty.

» Ifa User password is necessary to access this printer, type the password
in the User Password field.

« If a Supervisor password is necessary to access this printer, type the
password in the Supervisor Password field, and check the Supervisor
Mode check box.

In either case, an asterisk (*) character appears in the field after each
letter you type to preserve password secrecy.

For more details on setting up and changing passwords, see page 41.

14
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Pinter Propetis (|
fldentiﬁcatiun rSEt:urilyr Connections | Information |

rn[:cess Method rﬂetwurk |

IP Address: [|127.0.0.1

Port Humber: (3001 Default

Time Out (5..300 seconds): 15

OK Cancel

Figure 4. Printer Properties: Connections — Network Tab
Click the Connections tab. By default, the Network tab displays.

Click the IP Address field and then type the IP Address of the printer you
want to access. Follow the format shown in Figure 4.

The Port Number field must be set to the same port as the printer. Leave
it set at 3001. Leave the Time Out (5..300 seconds) field set at 15
seconds.

15
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Pinter Propetis (|
fldentiﬁcatiun rSEt:urilyr Connections | Information |

rn[:cess Method rﬂetwurk |

Access Method: | Ethernet -

Download Mode: | Access Method

Download Timeout: | 4 minute -

OK Cancel

Figure 5. Connections: Connections — Access Method Tab
10. Click the Access Method tab. See Figure 5.

The Access Method tells the PMU how the host computer communicates
with the printer. Make sure it is set to Ethernet. Ignore “Download Mode”
and “Download Timeout” for now. These options are covered in “Access
Method Tab” on page 51.

16
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11. Click OK. The Printer Properties dialog box closes and you return to the
Printer Database main window. Your printer is now set up in the PMU
database.

File Edit “iew Applications Status Utilities Help

=E el aal P | &nae x| |=ddd ¢ = =2eeg w =
¥y default.pdb
@E Tutorial vy First Connection)

Status and Error Log:

Figure 6. Printer Database Main Window

12. Try to access the printer’s virtual operator panel as a test to see if the
information you input is accurate. Follow this procedure:

a. “Tutorial (My First Connection)” should be highlighted in blue, as
shown in Figure 6. If it is not highlighted, click it to select it.

b. Select Applications » Operator Panel. The printer’s virtual operator
panel appears (see page 59). If not, an error message appears in the
Status and Error Log pane. Check your password to make sure it is
correct. If the error continues, contact your system administrator.

17
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2 Printer Database

Overview

When you start the PMU, the Printer Database window appears first. The
Printer Database tool organizes and controls printers, configuration files, and
download files. Figure 7 shows how the database looks when the PMU
launches for the first time.

Menu bar Toolbar Database pane

File Edit “iew Applications Status Utilities Help,

|8 oo o el 0] 0| 3 oo @] &) x| o= B @ <6 &l =2 = 6y ] W[ |

= default.pdb
5 E Mew_Printar (& ternglate)

Status and Errar Log:

\

Status and Error Log pane
Figure 7. Printer Database Main Window

The menu bar contains all the menus used to control the functions of the
program. The menus are described later in this chapter.

The toolbar contains buttons for the most commonly used menu functions.
See page 45 for descriptions of the Toolbar buttons.

Use the Database pane to access and control your printers in a tree format.
The first line of the database tree displays the database file name. In Figure 7,
the default file name for this database is default .pdb. From there, your
database tree branches out to include printers, folders, configuration files, and
download files, which you can organize into groups. With a single mouse
click, you can download a file to several printers at once. In addition, you can

19



Chapter

2

The Menu Bar

use as many databases with the PMU as you wish. Databases save as .pdb
files on your local hard drive.

NOTE: You can open only one printer database at a time.

The Status and Error Log scrolls status and error messages as you work
through the program. If the PMU does not function properly, look at this pane
for error messages. Use the scroll bar on the side of the pane to reference
previous status and error messages. The status and error messages relate to
the current PMU session, not to the specific database. When you quit the
PMU, these messages will be deleted.

The Menu Bar

20

The Printer Database menu bar is located at the top of the window (see
Figure 7). Use the menu bar to access all the functions of the PMU.

The following are descriptions of each of the options located on the menu bar.

The File Menu

Eile| Edit \iew Applications Status LHilities Help

%
)

New t:tn-n@l;')@ & (Bl BB X =

Open Ctrl-0

Save cti-s Bt Connection
Save As

Preferences

Exit

Figure 8. File Menu

New: Creates a new database file. Since the PMU allows only one database
file to be open at a time, it asks if you want to save your changes to the
current database before it creates a new one.

Open: Opens a database file. Since the PMU allows only one database file to
be open at a time, it asks if you want to save your changes to the current
database before it opens a different one.

Save: Saves the active database file using its current name.

Save As: Prompts you to enter a name for the current database file before
the PMU saves it. Use Save As if you do not wish to overwrite the current
database file.

Preferences: Opens the Preferences dialog box. See Figure 9.
Exit: Exits the PMU.
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Preferences

(Printer Database rCunﬁguratinn Editor rSewers |

Datahase File Hame

|default.p|:|t:| ‘ | Browse |

Lease Time on Printer Connection: (3 E

Security

[_] Show message when the printer is not protected

OK || Cancel |

Figure 9. Preferences: Printer Database Tab

The Preferences dialog box has three tabs: Printer Database, Configuration
Editor, and Servers.

The Printer Database tab controls database features.

Database File Name: Enter the name of the default database file. The PMU
opens this database file when the program starts. To select a new default
database file, type it into the Database File Name field, or click Browse to
locate a file on your network.

Lease Time on Printer Connection: Enter an amount (in seconds) to set the
maximum amount of time a printer connection can remain open without any
communication. The default is three seconds.

Security: Check the Show message when the printer is not protected
check box to enable a warning message that informs you when a selected
printer does not have an assigned password.

21
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0

Preferences E

([Printer Database |Configuration Editor | Senvers |

Editor keys
Hide Key: Unhide Key: Dec. Key: Inc. Kew:
TR | TR | PP | R

Maximum rexisions: @E

ok | ‘ cancel

Figure 10. Preferences: Configuration Editor Tab

The Configuration Editor tab controls features of the Configuration Editor
utility.

Hide Key/Unhide Key: Assigns which keys hide and unhide menu items in
the Configuration Editor menu tree (see page 64). The default for Hide is
“H h”. The default for Unhide is “U u”.

Dec./Inc. Key: Assigns which keys will decrement and increment menu items
in the Configuration Editor menu tree (see page 64). The default for
decrement is “<,”. The default for increment is “> .”.

Maximum revisions: Sets the maximum allowed number of reverted
Configuration Editor sessions to be saved by the PMU. For detailed
information on the Revert feature, see page 69. The Maximum revisions
setting ranges from 1 to 20. The default setting is 10.
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Preferences E3

rPrinter Database rCunﬁguratinn Editor | Servers

SHMP Trap Server
Port: | 48152 [_] Service Enabled
Wieh Server

Port: | 8080 [_] Service Enabled

¥ml Server

Port; | 30581 [_] Service Enabled

Mote: Restart program to use new settings.

OK | | Cancel

Figure 11. Preferences: Servers Tab

The Servers tab allows you to assign port values for the SNMP Trap Server,
the Web Server, and the Xml Server. Click Service Enabled next to the
corresponding server to turn it on.

NOTE: You must restart the PMU to use the new settings and enable the
servers.

SNMP Trap Server: The service that enables the PMU to receive alerts from
the printer when its status changes. Once the PMU receives the alert, the
PMU creates an instant status poll to reflect the change in the database pane.
For instance, if you turn the printer offline, the printer sends an alert to the
PMU causing it to change the printer status instantly. In the database pane,
the printer status changes to offline.

NOTE: The SNMP Trap Server works only if the printer's Ethernet Interface
is configured correctly. See your Ethernet Interface User’s Manual.

Web Server: Allows you to view the active PMU using a web browser. See
“Web Access” on page 75.

NOTE: If you wish to use the Web Server service, you must also enable the
Xml Server service.

Xml Server: The PMU uses XML to communicate with its web server.

23
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The Edit Menu

File Edit| View Applications Status LUtilities Help

= Insert * | Folder ﬂ B3| D

=4 d Cut Cirl-%, Printer

g Copy Etrl-C Configuration File

Paste Etrl-f Download File
Delete Paste Buffer
Include / Exclude

Figure 12. Edit Menu

Use the Edit option on the menu bar to build your database. The options in the
Edit menu are described below.

Insert

Adds a folder, printer, configuration file, or download file into your database.
You must select an existing database item to create a folder, printer, or file.
You can also paste the contents of the paste buffer (the last item that was
copied or cut) into the database. The new icon appears one level below the
selected database item. If there are items below the selected database item,
the new item appears at the end.

Inserting an item involves three steps:

1. Select a database item. (The new icon will appear below the item you
select.)

2. Define which type of icon you wish to add. Select Edit » Insert » and then
select the item you wish to add. A new icon appears in the database.

3. Define what printer, folder, or file this icon represents.
a. To define a printer, see “Defining Printer Properties” on page 48.

b. To define a folder, double-click New Folder. The Folder Name dialog
box opens. Type the name of the folder and click OK.

c. To define a configuration or download file, double-click New Config
File or New Download File. The Open dialog box opens. Locate the
configuration or download file, select it, then click Open. The
database displays the path and name of the configuration or
download file.
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Cut

Removes a selected folder, printer, or file from the database and places it in
the paste buffer.

Copy

Copies a selected folder, printer, or file from the database to the paste buffer,
leaving the original intact.

NOTE: The PMU cuts or copies only one database item at a time. If you
select multiple database items using the SHIFT key and then cut or
copy, only the first selected database item copies to the paste buffer.

Paste

Places the item in the paste buffer on the database tree. To paste, you must
select a database item. The pasted item appears on the same level as the
selected database item.

NOTE: If you select Edit » Paste, the pasted item appears on the same level
as the selected database item. However, if you select Edit » Insert »
Paste Buffer, the pasted item appears one level below the selected
database item.

Delete

Permanently removes a selected folder, printer, or file from the database.

Include/Exclude

Deactivates a selected folder, printer, or file. Inactive database items display a
red circle with a slash through it on top of the item’s icon.

You cannot send information to or receive information from excluded
database items using the following Applications and Status menu options:
Flash File Manager, CST Manager, File Download, Configuration Download,
Configure Printer Servers, and Update Status.

To activate a database item, select the inactive item and then select
Edit » Include/Exclude.

25
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The View Menu

File Edit \_ﬁEW| Applications Status Liilities Help

= | [EF ﬂ Collapse Tree ol % ES
Edefault_ Expand Tree i

it
™

ET Ste » | ® Angled Lines
Toolbar ) Horizontal Lines
'No Lines

Figure 13. View Menu

Collapse Tree

Collapses all folders on the database menu tree. Only folders display.

Expand Tree

Expands all folders and printers on the database menu tree. All folders,
printers, printer configuration files, and download files display.

Style

Angled Lines: Shows the links between database items using angled lines.

File Edit YWiew Application Status Liilities Helf
=B o o @ a [ 2] | % =]
= Cisample.pdb
@ 5 Building A
@ S5 Manufacturing
(D] C:\Printer Software A prg
CAConference Configs.cfy
@ Area 1 (north end of building
53 Area 2 fwest end of building)
@ &5 Administration Cffice
(D] CPrinter Software B prg
CAOffice Configs.cfy
£ vending Room §
§ & Conference Roorm
CAConference Confins.cfo
@ =3 Special Fonts
(D] CFonts.int
@ Area 1 (north end of building
£ vending Room §
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Horizontal Lines: Shows the links between folders using horizontal lines.

File Edit Wiew Application Status Liilities Helg

=B |cH o & a2 @ % | B
=) Clsample.pdb
@ = Building A
@ =3 Manufacturing
(D] C\Printer Software A prg
CAConference Configs.cfy
@ Area 1 {north end of building)
£ Area 2 fwest end of building)
@ = Adrministration Cffice
(D] C\Printer Software B.prg
CAOffice Configs.cfy
£ vending Room §
§ & Conference Roorm §
CiConference Configs.cfy
@ =3 Special Fonts
(D] CFonts.int
@ Area 1 {north end of building)
£ Yending Room §
(£ Building B

No Lines: Shows no links between database items.

File Edit Wiew Application Status Liilities Helg

=B |cH o & a2 @ % | B
=) Clsample.pdb
@ = Building A
@ =3 Manufacturing
(D] C\Printer Software A prg
CAConference Configs.cfy
@ Area 1 {north end of building)
£ Area 2 fwest end of building)
@ = Adrministration Cffice
(D] C\Printer Software B.prg
CAOffice Configs.cfy
£ Yending Room §
§ & Conference Roorm
CiConference Configs.cfy
@ =3 Special Fonts
(D] CFonts.int
@ Area 1 {north end of building)
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Toolbar

Allows you to select which buttons display on the toolbar.

Customizo Toalbar |
¥l @ Open |
vl B Save

[V £¥ Folder

[vi g Printer

[l @ Configuration File

Clear all

Set All

Default

[vl @ Download File
[vi B2 Edit
[¥] & Include | Exclude

vl & Cut

[v] Bz Copy

[v] B Paste

[v] @ Paste Buffer

[¥] ¥ Delete

[v] =" Operator Panel

[v] &F) Information Capture
[ 8 configuration Editor

[vi &g Configuration Download
[vi &g File Download

/] B Data Validation

[v] B 0DV Quality Wizard

] B# Configure Print Servers
[v] BEE Speed Keys

[ &5 Flash File Manager

[vi Y Update Status

[¥] =2 Discover Printers

1 8 Help

oK Cancel

28



The Menu Bar

The Applications Menu

File Edit “iew

Applications | Status Lhilities Help

=B ok &

=] default.pdb
&84 B New_Pri

Configuration Editor
Flash File Manager
File Download

1@ x| =@ ]«

Operator Panel
Information Capture
Configuration Download
Data Walidation

0DV Quality Wizard
Configure Print Servers
Speed Keys

Figure 14. Applications Menu

For an explanation of the Applications menu options, find the menu option in
Table 1 and go to the corresponding page.

Any applications listed below “File Download” connect to the printer when

executed.

Table 1. Applications Menu Options

Menu Option Page #
Configuration Editor page 64
Flash File Manager page 70
File Download page 53
Operator Panel page 59
Information Capture page 62
Configuration Download page 53
Data Validation page 71
ODV Quality Wizard page 72
Configure Print Servers page 73
Speed Keys page 74

29
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The Status Menu

File Edit View Applications |Status| Utilities Help

|| o o | i I0 - Discover Priners ] |e=
default pdb Update Status
55 5 Mew_Printer (Aternplaty  Properties

@<

Figure 15. Status Menu

Discover Printers

Discover Printers starts the printer discovery process (see “Properties” on
page 32). If Polled Discovery is enabled (see page 33), a progress dialog box
appears while the PMU discovers printers. See Figure 16.

File Edit View Applications Status Utilities Help
EEEIE I e N A T RN =1 Il EIE=TEE R SE

‘= default.pdb
B3 ] Mew_Printer (4 template)

Ega Progress._. E
[} Discovery
il

= Polling 10.22.1.112
L

Epo

Status and Error Log

Figure 16. Discovery Polling in Progress
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Update Status

Figure 17 shows an updated status for a printer.

File Edit Yiew Applications 5Status LUilities Help
=| B | of || o | |32 @] | & | BB &) X| |B=

= new.pdh
@E Meswy_Printer (4 template) ORLINE.POWER SAVER MODE

7
[

Figure 17. Update Status

Update Status shows the condition of the printer at the time the status is
checked. To update the status of a printer, select Status » Update Status, or
click the T__‘II (green flag) button at the right of the toolbar.

When the printer status updates, the Eﬁ (printer) icon may change color:
* Red indicates the printer is not functioning properly and cannot print
* Yellow indicates a warning, but the printer can print

» Green indicates the printer is functioning properly and can print

The message to the right of the printer icon is identical to the message on the
front panel of the printer.

If you enable status polling, the printer status updates automatically.

The E (stacked bar) icon indicates the amount of ribbon available on the
printer. If the icon is gray, the ribbon availability feature is not supported on
the printer.
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Properties

Select Status » Properties to open the Status Monitoring Properties dialog
box. The dialog box contains three tabs: Discovery, Polling, and Alert

Delivery.
Eg’,g Status Monitoning Properties _ O] %]

[Discovery [Polling | Alert Delivery |

[¢| Enable Printer Discovery

fF'rirlt Server Discovery rPuIIed Discovery rh'nuwn Printers Discovery |

[¥| Enable Print Server Discovery Response Wait (Seconds) (3

Broadcast IP | Subnet Mask | Return Gateway
255.255.255.255 0.0.0.0 0.0.0.0
Add
Remove
Apphy Cancel

Figure 18. Status Monitoring Properties:
Discovery — Print Server Discovery Tab

Discovery

You can discover printers on a network in three ways:

1. Print Server Discovery: This option allows you to discover all
IBM 4400/6400 Series Ethernet Interface-equipped Printers on a subnet.
To enable the option, check the Enable Print Server Discovery check
box in the Status Monitoring Properties dialog box (see Figure 18), then
click Apply. The results of the search display in the database pane.

32



The Menu Bar

E%Slalus Monitoning Properties

(Discovery |Polling | Alert Delivery |

[¥] Enable Printer Discovery

rF'rirrt Server Discovery rPuIIed Discovery rKnuwn Printers Discovery

[+ Enable Polled Discovery

First IP Address | LastIP Address
Add
Remove
Apphy Cancel

Figure 19. Status Monitoring Properties:
Discovery — Polled Discovery Tab

2. Polled Discovery: This option allows you to select a range of IP
addresses to poll. To enable the option, click the Polled Discovery tab
and check the Enable Polled Discovery check box, then click Add (see
Figure 19). In the First IP Address field, enter the beginning IP address
range. In the Last IP Address field, enter the last IP address range. Click
Apply. The PMU polls the printers within your specified range and
displays the results in the database pane.
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E%Slalus Monitoning Properties

(Discovery |Polling | Alert Delivery |
[¥] Enable Printer Discovery

rF'rirrt Server Discovery rPuIIed Discovery WKnuwn Printers Discovery |

[+ Enable Known Printer Discovery

Clear all Delete

Apphy Cancel

Figure 20. Status Monitoring Properties:
Discovery — Known Printers Discovery Tab

3. Known Printers Discovery: This option records and logs previously
discovered printer IP addresses. From this log, you can select and delete
previously polled discoveries to create a new polling list to target your
printer search. To enable the option, click the Known Printers Discovery
tab and check the Enable Known Printer Discovery check box (see
Figure 20). From the polled list of IP addresses, narrow your search by
keeping or deleting found IP addresses. Click Apply to start a new poll
based on your specification.

NOTE: You cannot manually add an IP address to this list. If you delete an IP
address, it is lost until the polling process rediscovers it.
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Polling

Eg_;gﬁtalus Monitoring Properties

[Discovery |[Polling | Alert Delivery |

[¥] Enable Status Monitoring

Snmp Pacing (MS) (100
PrinterFolder | FirstlP | LastiP | Enable | Initial del
Discovery; frue il
Folder: root true 60
Add
Remove

4 |

Apphy Cancel

Figure 21. Status Monitoring Properties: Polling Tab

The Polling option allows you to control the way the PMU polls printers on the
network. For instance, you can create a timed interval for the PMU to poll
every 30 seconds or every two minutes. You can also specify a range of IP
addresses.

To enable the option, check the Enable Status Monitoring check box in the
Polling tab (see Figure 21). The Snmp Pacing (MS) value places a delay
between each snmp request. This feature minimizes the network load. By
default, the value is set at 100 milliseconds (.1 second).

NOTE: If Discovery is enabled, then a discovery also occurs, based upon the
settings in the Discovery tab (see “Discovery” on page 32).

Now you can set parameters to a new task. The parameters include:

Printer/Folder: To select which printer or folder you want the PMU to poll.
Click the field to select options from a drop-down menu.

First IP: To set the beginning IP address in a polling range. Use this option if
you select Range: as the Printer/Folder option.

Last IP: To set the last IP address in a polling range. Use this option if you
select Range: as the Printer/Folder option.
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Enable: To select whether or not you want to enable polling of a specific task.
If you want the PMU to poll the printers according to the specifications of your
first task, select true. Otherwise, select false.

Initial Delay (S): To specify the time delay from when the PMU starts to when
the PMU polls printers. The time delay is calculated in seconds.

Polled Interval (S): To poll printers automatically with timed intervals
calculated in seconds. Use this option to periodically poll for new printers
every few seconds.

Response Wait (MS): To specify the time delay the PMU waits between
SNMP responses. By default, the value is set at 300 milliseconds
(.3 seconds).

NOTE: If you enter a low value for slow networks, you may receive no
response. In this case, increase the Response Wait (MS) value.
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Alert Delivery

Eg’,i'ﬁtatus Monitoring Properties

(Discovery | Polling | Alert Delivery |
vl Enable Notification

[ Alert Loy [Email Merts | Syslog Posting |
[v| Enable Log File

LogFile | Size | Device | First

Last

i Falder: root

Eng

Add

Remove

Browse

A |

[ >

Clear

Apphy

Cancel

Figure 22. Status Monitoring Properties: Alert Delivery — Alert Log Tab

Select Status » Properties to open the Status Monitoring Properties dialog

box. Click the Alert Delivery tab. Check the Enable Notification check box
to enable the option. The Alert Delivery properties allow you to customize the
way the PMU notifies you of potential printer errors. Descriptions of the three
alert types follows:

1. Alert Log: Allows the PMU to log alerts to a file located in the PMU
directory. To log alerts, check the Enable Log File check box, then click
Add (see Figure 22). A task item adds to the log list. In the task item,
specify the following as applicable, then click Apply.

Log File: To name the log file.

Size: To set the maximum file size.

Device: To choose a device item you want the PMU to monitor, such
as a folder, specific printer, or a range of IP addresses.

First: To set the beginning IP address in a polling range. Use this
option if you select Range: as the Device option.

Last: To set the last IP address in a polling range. Use this option if
you select Range: as the Device option.
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NOTE: In the remaining alert option fields, select enable or disable as
desired.

Offline, Warning, Media Input, Media Output, Media Path, Cutter,
Barcode, Scanner, Label, Intervention Needed, and
Consumables: For a description of the alert groups and printer
events, refer to the Alert Groups table in chapter three of the Ethernet
Interface User’s Manual. All options are enabled by default.

Comment: Enter comments as needed.

E%Status Monitoring Properties

(Discovery [Polling || Alert Delivery

[¥| Enable Motification

(Alert Log | Email Alerts |Syslog Posting |
[v] Enable Email

Outgoing Mail (SMTP) Server |

Email Subject |F'rinter Status |

Email Sender |printermanager@wurwmpanv.cum |
SMTP Email Server Port |25

Email Address | Device | First | Last | Offling

Add

Remove

[ »

Apphy Cancel

Figure 23. Status Monitoring Properties: Alert Delivery — Email Alerts
Tab

2. Email Alerts: The PMU sends you an alert e-mail if a printer error occurs.
To set up Email Alerts, check the Enable Email check box. Enter
information in the following fields:

Outgoing Mail (SMTP) Server: See your system administrator.
Email Subject: Enter the subject of e-mail.
Email Sender: Enter your e-mail address.

SMTP Email Server Port: See your system administrator.
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Next, click Add to define a new task (see Figure 23). In the new task item,
specify the following information, then click Apply.

NOTE:

gaﬁtatus Monitoring Properties

Email Address: Enter the e-mail address where you want the PMU
to send the alert messages.

Device: To choose a device item you want the PMU to monitor, such
as a folder, specific printer, or a range of IP addresses.

First: To set the beginning IP address in a polling range. Use this
option if you select Range: as the Device option.

Last: To set the last IP address in a polling range. Use this option if
you select Range: as the Device option.

In the remaining alert option fields, select enable or disable as
desired.

Offline, Warning, Media Input, Media Output, Media Path, Cutter,
Barcode, Scanner, Label, Intervention Needed, and
Consumables: Refer to Table 4 in chapter three of the Ethernet
Interface User’s Manual. All options are enabled by default.

Comment: Enter comments as needed.

[Discovery |Polling | Alert Delivery |
[v| Enable Notification

(Alert Log | Email Alerts | Sysloy Posting |
[¥] Enable Syslog

Machine Address | Fort Device First Last

514 Folder: raot

Add

Remove

Apphy Cancel

Figure 24. Status Monitoring Properties:
Alert Delivery — Syslog Posting Tab
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3. Syslog Posting: Used in a Unix operating system, it allows the PMU to
log alerts to a file located in the PMU directory. To log alerts, check the
Enable Syslog check box, then click Add (see Figure 24). A task item
adds to the log list. In the task item, specify the following as applicable,
then click Apply.

NOTE:

Machine Address: The Unix IP Address.
Port: See your system administrator.

Device: To choose a device item that you want the PMU to monitor,
such as a folder, specific printer, or a range of IP addresses.

First: To set the beginning IP address in a polling range. Use this
option if you select Range: as the Device option.

Last: To set the last IP address in a polling range. Use this option if
you select Range: as the Device option.

In the remaining alert option fields, select enable or disable as
desired.

Offline, Warning, Media Input, Media Output, Media Path, Cutter,
Barcode, Scanner, Label, Intervention Needed, and
Consumables: For a description of the alert groups and printer
events, refer to Table 4 in chapter three of the Ethernet Interface
User’s Manual. All options are enabled by default.

Comment: Enter comments as needed.
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The Utilities Menu

File Edit Yiew Applications Status | Liilities | Help

=B | o e | | @ B2 & @ Reboot Printer ﬂﬂ
=5 default pdb Set Printer Password [
&5 B Mew_Printer (A template) SNMP Browser
Assign IP Address

Figure 25. Utilities Menu

Reboot Printer

Reboots the selected printer.

Set Printer Password

The PMU does not allow passwords to change unless the supervisor
password matches the password in the Printer Properties.
See “Security Tab” on page 50.

To set the printer password:

1.

o M D

Double-click the printer name. The Printer Properties dialog box opens.
Click the Security tab.

Type the User Password and Supervisor Password.

Check the Supervisor Mode check box.

Click OK.
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To change the printer password:

1. Click the printer name to select it.

2. Select Utilities » Set Printer Password. The Change Password dialog

box opens.

Eéf’,% Change Paszword

Enter new password:

[_| Supervisor Password

Cancel

Delete

Set

Type the new password.

For a new supervisor password, check the Supervisor Password check

box. For a new user password, leave this box unchecked.

Click Set.

If you entered a new supervisor password, double-click the printer name.
The Printer Properties dialog box opens.

Click the Security tab.

Type the same password you entered in step 3 in the Supervisor

Password field.
9. Click OK.
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SNMP Browser
E%SNHP Browser =] E3
File

IP: [0.0.0.0 | om: |1.381.21.25 | community: |public

| Get || wak || clear |

-

The SNMP (Simple Network Management Protocol) Browser enables you to
view attribute values in the Printer MIB managed by the Ethernet Interface.
You can retrieve an attribute value of a specific MIB Object ID (OID), or you
can “walk” or traverse the MIB. Three inputs are required before you can use
the SNMP Browser. They are: IP, OID, Community.

In the IP field, enter the IP address of the target printer. The OID field defines
either the specific MIB object ID you want to view, or the starting location for
the MIB walk. The Community field defines the access Community defined in
the Ethernet Interface. The default is public.

The Get button retrieves the attribute and attribute value for the specific OID
entered. If the OID entered is invalid, you will receive the “Error: SNMP error”
message. The Walk button traverses the MIB starting with the OID entered.
The display is in the format: OID=Attribute_Value. The Clear button clears the
current display.

The File menu allows you to open a previously saved SNMP Browser
session, save the current session to file, or send the current session to a
printer.
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IMPORTANT

Assign IP Address

Allows you to assign IP addresses remotely to Ethernet Interfaces that have
not been used before.

This utility requires expert network knowledge. If you assign incorrect
network parameters to the printer, then other devices on the network
may operate improperly, possibly causing the whole network to be
unusable.

The Assign IP Address utility has five fields:

* Reply IP Address: To enter a subnet broadcast number or a direct IP
address to find the printer.

» Hardware Address: To enter the MAC (Machine Access Code) on the
Ethernet Interface.

* New IP Address: To assign the printer its new IP address. Make sure
this address is correct and do not enter an already existing IP address.

* New Mask: To enter the new mask address, if necessary. If you need the
same mask, type the mask number.

* New Gateway: To enter the gateway number the new printer uses.
Once you click Assign, a BOOTP packet is sent to the Reply IP Address.

IP assignment will work only once, and then only if another BOOTP/DHCP
has not already set the IP address.

The Help Menu

File Edit View Applications Status [|Hilities ﬂelp|
=) & | cf| ¢ | e | 5P| @) | 4 Bz @) About

= default.pdb
53 B New_Printer (A template)

B
£

Figure 26. Help Menu

About: Displays the PMU About dialog box. The About dialog box shows the
program’s part number and version information.
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The Toolbar

The PMU toolbar contains buttons that perform functions. See below for a
description of each button. Refer to the specified page for a more detailed
description.

You can select which buttons display on the toolbar. See page 28.

Button Description

Open: Opens a new printer database.

Save: Saves the current printer database.

Folder: Inserts a new folder into the printer database
(page 24).

Printer: Inserts a new printer into the database
(page 24).

Configuration File: Inserts a new Configuration file into
the database (page 24).

Download File: Inserts a new Download file into the
database (page 24).

Edit: Defines the properties of the selected item
(page 48).

Include/Exclude: Deactivates a selected folder, printer,
or file (page 25).

Cut: Removes a selected folder, printer, or file from the
database and places it in the paste buffer (page 25).

Copy: Copies a selected folder, printer, or file to the
paste buffer (page 25).

Paste After: Pastes the item in the paste buffer after the
selected item (page 25).

Paste Into: Pastes the item in the paste buffer into the
selected item (page 25).

Delete: Removes the selected item (page 25).
Operator Panel: Virtual control panel that allows you to

make selections via the PMU as if you are using the
actual printer control panel (page 59).

|l x® 8 F>~0€ 8 Be&l 8O

Information Capture: Allows the PMU to capture
information sent between the computer and the printer
(page 62).

i

45



Chapter

2

The Toolbar

46

Button

ex o Al @ rEdd

Description

Configuration Editor: Allows you to edit the data sent
from the computer to the printer before the printer
receives it (page 64).

Configuration Download: Allows you to download a
configuration to the printer (page 53).

File Download: Adds a download file to your printer
database (page 53).

Data Validation: Opens the Data Validation window
(page 71).

ODV Quality Wizard: Opens the ODV Quality Wizard
window (page 72).

Configure Print Servers: Opens the Configure Print
Servers window (page 73).

Speed Keys: Opens the Speed Keys window (page 74).
Flash File Manager: Opens the Flash File Manager
window (page 70).

Update Status: Marks a printer or printers for status
updates (page 31).

Discover Printers: Searches for new printers
(page 30).

Help: Opens the Help window (page 44).
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Managing the Database

To organize your databases easily and effectively, use the Edit option on the
Printer Database menu bar. You can add, delete, and assign printers,
configuration files, and download files to your database tree. You can also
organize them using folders. All Edit menu functions have buttons on the
toolbar (see page 45).

Database Iltems

E‘F Folder: Use folders to group the elements of your database.
@{' Printer: See “Defining Printer Properties” on page 48.

= Configuration file: A file created in the Configuration Editor (see
page 64) and stored on your host computer. A configuration file
contains user-defined printer configurations that you can download to
your printer using either the Printer Database or the Configuration
Editor.

ﬂi' Download file: A file stored on your host computer (i.e., software)
that you can download to the flash SIMM memory of a printer or group
of printers.
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Defining Printer Properties

File Edit \iew Applications Status LUtilities Help

=& oo o | PO | # e @) @) | =)
= defaultpdb
&3 & New_Printer (4 ternplate)

Identification | Security rConnections rlnformation |

Mame {Unigue): |New_Printer |

=
@

Aa/< = = &/e¢ wx

Printer Description: |A template |

Only use characters A..Z, a..z, 0..9 for printer name and description.

Status and Error Log:

Figure 27. Defining Printer Properties

Before you can use any of the PMU applications, you must define the printer’s
properties. You must identify the printer and configure how the printer
communicates with the PMU. To define a printer, double-click the printer’s
name or click the w (edit database entry) button. The first time you run the
PMU, double-click New_Printer (A template). The Printer Properties dialog
box opens. See Figure 27.

The Printer Properties dialog box contains four tabs: Identification, Security,
Connections, and Information, described in the next sections.
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Identification Tab

Printer Properties |
| ldentification | Security |/Cunnec’tiuns rlnfurmatiun |

Hame (Unigue):  [Mew_Printer

Printer Description: (A tamplate

Only use characters A..F, a..z, 0.9 for printer hame and description.

OK Cancel

Figure 28. Printer Properties: Identification Tab

Name (Unique)/Printer Description: Assigns a name to your printer to
identify it in the Printer Database. You can also assign a printer description,
which appears in parentheses to the right of the printer name in the database.

When you assign a printer name and description, use only the alphanumeric
characters A-Z, a-z, and 0-9. Underscores and spaces may be used to
separate words.
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Security Tab

Printer Properties |

|/Identiﬁ[:atiun | Securit].r| Connections rlnfurmatiun |

User Password:

Supenvisor Password

[_| Supervisor Mode

Only use characters 4.7, a..z, 0.9 for passwords.

OK Cancel

Figure 29. Printer Properties: Security Tab

User/Supervisor Password: Enter the printer’'s password, if appropriate.
The password feature restricts access to certain functions of the PMU. In
User mode, the PMU does not allow the following functions: downloading
files, configurations, or configuration names to the printer; clearing the error
log; and setting passwords. Supervisor mode allows unrestricted access to all
functions of the PMU.

Passwords are only recognized up to 9 characters, and are displayed as *****,
one * for each character typed. Use only the alphanumeric characters A-Z, a-
z, and 0-9 for passwords. Underscores and spaces may be used to separate
words. To set up a password, see page 41.
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Connections Tab

Printer Properties |

|/Identiﬁ[:atiun rﬂecurﬂy ]Cunnec’tiuns | Information |

fn[:t:ess Method rﬂetwurk |

Access Method: | Ethernet

Download Mode: | Access Method

Download Timeout: | 4 minute -

OK Cancel

Figure 30. Printer Properties: Connections — Access Method Tab

The Connections tab contains two sub-tabs: Access Method and Network.

Access Method Tab

Access Method: Identifies how the PMU accesses the printer. “Ethernet” is
the only option available. See the Ethernet Interface User's Manual to set up
the Ethernet Interface for your printer.

Download Mode: Identifies how the PMU downloads files and configurations
to the printer. “Access Method” is the only option available. All downloads will
use the Ethernet Interface.

Download Timeout: Specifies the number of minutes the printer waits for
data while downloading a file from the host computer. If a stall lasts for more
than the specified time, the printer times out and the download terminates. If
you have a slow connection between the PMU and the printer, you may need
to define a longer Download Timeout period. Define the Download Timeout
between 1 and 60 minutes (the default is 1 minute).
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Network Tab

Printer Properties |

fldentiﬁt:atiun rSEcurity ]Cunnectiuns | Information |

rnt:cess Method rﬂetwurk |

IP Address: [127.0.01

Port Humber: (3001 Default

Time Out {5..300 seconds): |, 5

0K Cancel

Figure 31. Printer Properties: Connections — Network Tab

Enter the printer's IP Address and Port Number. (Click Default to reset the
Port Number to 3001.) The Time Out option sets the amount of time, in
seconds, the PMU waits for a response from the printer after sending a
command. If there is no response in the specified amount of time, an error
message appears in the Status and Error Log pane. If you have a slow
connection between the PMU and the printer, you may need to define a
longer Time Out period. Define the Time Out between 5 and 300 seconds (the
default is 15 seconds).

NOTE: The Network settings must match the settings in the printer’s front
panel menu. See the “ETHERNET PARAMS” section in the User’s
Manual.

Information Tab

Printer Properties |

fldentiﬁcatiun |/Securityr rCunnemiuns Information
Hardware Address: 00:80:72:09:C9.FY

IF Mask 0.0.0.0

Gateway: 10.22.1.254

Print Server Mame: M_09C9FY

ShB Workoroup: WORKGROUP

Location: null

Serial Mumber: 51703

OK Cancel

Contains information about your printer.
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Downloading Files

NOTE: The terms “download” and “upload” as used here and in the software
indicate the printer’s point of view. Therefore, when you download a
file using the PMU, you are sending information to the printer (the
printer downloads). When you upload a file, you are receiving
information from the printer (the printer uploads).

The PMU allows you to download Configuration and Download files to either a
single printer or to a group of printers. To download a Configuration or
Download file to a single printer, place the ﬂﬁ (Configuration file) or

[if (Download file) icon below the printer (one level lower than the printer).
To download a Configuration or Download file to a group of printers, insert the
proper icon on the same level as the printers (in the same folder containing
the printers). Insert additional Configuration or Download file icons if you wish

to download multiple files or configurations.

Once you define Configuration and Download files on your database, you
must download them to your printer in order for them to affect the active print
state. Use the Printer Database to download as many files to as many printers
as you want.

NOTE: Each emulation used by the printer has its own list of valid flash files it
can use. Refer to the appropriate Programmer’s Reference Manual
for details about valid flash files.

To download a ﬂi Configuration file that is on the same level or one level
lower than the target printer on your database tree, select the printer to
receive the download and select Applications » Configuration Download.
To download a ﬂi Download file that is on the same level or one level lower
than the target printer on your database tree, select the printer to receive the
download and select Applications » File Download.

Once you choose your download option, a dialog box opens that shows all the
files that will download to each printer. Confirm that the correct files will be
sent to the appropriate printers. Click Upgrade to begin the download. Click
Cancel to cancel the download and start over.

You can also download a series of files to several printers at once using
folders. Select a folder and select either Applications »

Configuration Download or Applications » File Download. All of the
appropriate files inside the selected folder download to all of the printers
inside that folder.

NOTE: Downloading a Configuration file does not immediately update the
printer’s active configuration. You must activate a downloaded
configuration using the “Load Config.” setting in the printer’s operator
panel. See your printer's User’s Manual for details.

See page 54 for examples of using the Printer Database to download files.
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Downloading Files Examples

Figure 32 shows a sample database.

File Edit View Applications Status Utilities Help

=@ g o x| ] @] | 4| @) @) %] o= @ ) @

= Cleamplepdb
@ =3 Building A
@ =3 Manufacturing
(D] CPrinter Software A prg
Camanufacturing Configs.cfg
@ Area 1 (north end of building
£ Area 2 (west end of building)
@ =3 Administration Office
(D] CaPrinter Software B.pro
CAOffice Configs.cfyg
&3 vending Roorn
9 A Conference Room ()
CACanference Configs.cfg
@ = Special Fonts
(D] CFonts it
@ Area 1 (north end of building
g5 vending Roorn
[ Building B

Status and Error Log:

Figure 32. Sample Database

In the sample database, the printers are organized according to different parts
of the building. Each area contains its own printers, Configuration files, and
Download files.
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Example 1

In the following example, the user selected the Conference Room printer,
then selected Applications » Configuration Download or clicked the

ﬁ (configuration download) button. The Configuration Download dialog box
opens.

E;‘,g Configuration Download
Double Click on an entry to change its settings
Printer | Lpgrade File | Progress | Configurati...
Canference Room § | CiCanference Configs.cfy | [dle F 2 4
Upgrade | | Cancel

Figure 33. Configuration Download: Conference Room Printer

The Configuration Download dialog box displays the printer receiving the file,
the name of the file being sent, the progress of the download, and the
configurations contained within the file. If the user clicks Upgrade, the
Conference Configs.cfgfileis senttothe Conference Room printer. The
dialog box indicates the progress of the file as it downloads.
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Example 2

In the following example, the user selected the Manufacturing folder, then
selected Applications » Configuration Download or clicked the

(configuration download) button. The Configuration Download dialog box
opens.

EE’,% Configuration Download

Double Click on an entry to change its settings

Printer | Ungrade File |Progress] Configurati...
Area 1 (north end of huilding) | SA\Conference Confins.cfiy | ldle F 24
Area 2 fwest end of building) | CA\Conference Configs.cfy | ldle F 24

Upgrade || Cancel

Figure 34. Configuration Download: Manufacturing

The PMU sends all configuration files inside the Manufacturing folder to all
printers inside the Manufacturing folder. If the user clicks Upgrade, the
Manufacturing Configs.cfg file is sent to printers Area 1 and Area 2.

You can also specify which configurations within the file you wish to
download. Double-click the name of the printer you want to make adjustments
to, and a dialog box opens that allows you to select or deselect specific
configurations. Only the selected configurations download.

Notice that the Printer Software A.prg file, located inside the
Manufacturing folder, is not on the download list. The PMU downloads
Configuration and Download files separately. To download the Printer
Software A.prg file to these printers, select the Manufacturing folder, then
select Applications » File Download.
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Example 3

In the following example, the user selected the Building A folder, then
selected Applications » File Download or clicked the Eﬁ (flash file
download) button. The File Download dialog box opens.

E%File Download [_ O] x|
Double Click on an entry to change the download mode
Printer | DownloadMode | Progress | Upgrade File
Area 1 (north end ofb... | Download wiCaonfigur... | Idle CAPrinter Software Aprg
Area 2 (westend of bu... | Dowwnload wiCanfigur... | I1dle CAPrinter Software Aprd
Wending Room Dawnload wiCaonfigur... | Idle CAPrinter Software B.prg
Conference Room Download wiConfigur... | ldle CAPrinter Software B.prg
Area 1 (north end of b... |Download w/Configur... |Idle CAFonts.fnt
Wending Room () Download wiConfigur... |ldle CAFonts.fnt
| Upgrade | | Cancel |

Figure 35. File Download Window

The PMU downloads files from the selected folder, as well as its sub-folders.
If the user clicks Upgrade, the Printer Software A.prg fileis sentto
printers Area 1 and Area 2, the Printer Software B.prgfileis sentto the
Vending Room and Conference Room printers, and the Fonts . £nt file is
sent to the Area 1 and Vending Room printers.
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The options in the Download Mode column can be changed. Double-click the
printer you wish to change, and the File Download — Download Mode window

appears. See Figure 36.

File Download |
Download Mode
‘@) Download without preserving configurations or flash files
) Download preserving configurations onhy
) Download preserving flash files onky
) Download preserving configurations and flash files

{_) SKip this entry

0K Cancel

Figure 36. The File Download — Download Mode Window

Download without preserving configurations or flash files: When the
firmware file downloads, all configurations are reset to their original, factory
settings.

Download preserving configurations only: When the firmware file
downloads, the configurations saved in the printer are preserved.

Download preserving flash files only: When the firmware file downloads,
the flash files are preserved.

Download preserving configurations and flash files: When the firmware
file downloads, the configurations and flash files are preserved.

Skip this entry: As the PMU moves through the download queue, any files
marked “Skip this entry” do not download.



3 Applications and
Web Access

Operator Panel

The PMU includes a virtual operator panel that simulates all the functions of
the actual operator panel on your printer. Figure 37 shows the operator panel

for a 6400 Series Line Matrix Printer, and Figure 38 for a 4400 Series Thermal
Printer.

The layout of the operator panel changes to visually simulate the printer being
used (line matrix, thermal, or laser), but the keys and indicators function as
described on page 61, regardless of the type of printer used.

To access the operator panel, select the appropriate printer from the Printer
Database and then select Applications » Operator Panel or click the
[EI==] (operator panel) button.
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Operator Panel Window
Message Display

Operator Keys

[E3 Dperator Panel [Conferpnce Room]

P.:T-:r ‘RERDY ' TWIHAX/ASCII
E|
Ready
-
Processing | |
Lire Farm
Mok Seroll f Eriter hofizro + Feed Feed Start
| N DNNNNNNN (NN DN B
- Con- Set Top
ﬁmi{mnn figuration Scroll W | Retumn hicro W | Wlew of Foarm Stop
I DN DN (N D 0

Dizabled [ Busy N ——
X

Status Indicator Disabled/In Progress Indicators

Figure 37. 6400 Series Line Matrix Printer Operator Panel

[2: Operator Panel [Thermal P... &l E3
Message Display l

a0

DHLINE
ETHERHET fPGL fLP+

FRENE

Operator Keys

Disabled/In Progress
Indicators

Enable

Figure 38. 4400 Series Thermal Printer Operator Panel
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Primary/Secondary Operator Keys

Clicking the primary and secondary operator keys in the operator panel
causes the printer to perform the same actions as if you were physically
pressing the keys on the printer’s operator panel. For example, when the
printer is online, click the Stop key (the PAUSE key on thermal models) to
take the printer offline. Click the Start key to place the printer back online.

Some functions require pressing multiple keys at the same time. To simulate
this, hold down the SHIFT key on your host keyboard as you select each key.
Release the SHIFT key, and the selected keys on the operator panel activate
as if they were pressed simultaneously.

For example, to unlock the Enter key on your printer, hold down the SHIFT
key on your keyboard, then click Scroll T and Scroll |. Release the SHIFT
key, and the ENTER key unlocks.

NOTE: For an explanation of the functions of each primary and secondary
operator key, see your User’s Manual.

Message Display

The message display shows what is displayed on the printer's LCD. Use the
message display to configure menu options and read error messages.

Status Indicator

The status indicator displays the current operating mode:
Online mode: The indicator displays bright green.
Offline mode: The indicator displays black.

Fault mode: The indicator flashes.

Disabled Indicator

Normally, when you control the printer via the operator’s panel, the Disabled
light is off, and the Enable button underneath the status indicator is grayed
out. While the PMU has control of the printer, the message CAUTION
PRINTER MANAGER HAS REMOTE CONTROL appears on the printer's LCD
display to alert others that the printer is being controlled remotely.

However, if someone presses a key on the printer, the virtual operator panel
disables. The Disabled indicator lights up, and the Enable button activates.
Click the Enable button to give control of the printer back to the virtual
operator panel.

In Progress Indicator

This light flashes when the printer is working on a job or moving paper.
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Information Capture

Egilnfmmalion Capture [New_Printer]

File Configuration Printout Error Log Directory

FOWER ON CONFIGURATION - FACTORY CONFIGURATION
IEM Printer Configuration
File Part Nuwnber XXXXXXX
Beference Nuwber 333066
Date 09-Jul-01
Program File Version 3.11G¢ Part No. 3358217
IGP Version 3.10C

[»

LinePrinter+ Version 3.10C

DC V3.10C 09-TJul-01 #338213
EC Vi.03H 03-TJul-01 #338238
EBOOT,/ CMI v1.05W 11-Dec-00 #337196
SHUTTLE TYFPE 2000

FLASH 4 ME

DEAM 4 ME

SECURITY PAL 154140-017
CONFIGURATICON CODE FFO1GF

1]

Figure 39. Information Capture Window

To access the Information Capture application, select a printer from the
Printer Database and select Applications » Information Capture or click the
(information capture) button. The Information Capture application allows
you to view the configurations or error logs saved in the printer’'s memory and
save them as a text file to your local hard drive.

Loading a configuration into the Information Capture does NOT change the
active configuration — this is a view only application. If you wish to change
the active configuration, use the Configuration Editor (see page 64) or the
operator panel.
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The following are descriptions of the Information Capture menus.

File

Save As: Saves the configuration or error log displayed in the Information
Capture window as a . txt text file on your local hard drive. This . txt file
can be opened in any word processing program.

Print: Prints the text of the information captured to the host computer’s
default printer.

Clear Window: Clears the Information Capture window of any displayed
configurations or error logs.

Close: Closes the Information Capture window.

Configuration Printout

Current/Factory/Power-Up/All/1-8: Choose which configuration you wish to
view. If you choose more than one configuration without clearing the window,
each additional configuration adds to the end of the display.

Error Log

All Errors: Displays the printer’s error log.
Clear: Clears all errors from the printer's memory.

NOTE: The printer’s error log and the Status and Error Log at the bottom of
the main printer database window of the PMU are separate. Clearing
the printer’s error log does not clear the Status and Error Log.

Directory

Flash File System: Displays the file system information for your printer.

63



Chapter

3

Configuration Editor

Configuration Editor
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E’i[ﬁonﬁgutalion Editor - T4000.cfg

File Edit Wiew Hide Download Upload

EEIEE]

OFFLINE
Protect Configs.: Disahle
ACTIVE IGP EMUL: IGPIPGL
= EMULATION
D= MAINT I MISC
@ HOST INTERFACE: Centronics
@ PRINTER CONTROL
@ FOMNT MEMORY

Displayed Language Displayed Configuration Power-Up Configuration
| English ~ | |Factory ~ | |Existing |

Figure 40. Configuration Editor Window

To access the Configuration Editor application, select a printer from the
Printer Database and select Applications » Configuration Editor or click the
ﬂ (configuration editor) button. Select Upload » All to upload configurations
from the printer. The active configuration uploads from the printer and
displays in the Configuration Editor window. See Figure 40.

The Configuration Editor supports offline editing, allowing the editing of stored
configurations. If you start the Configuration Editor without connecting to a
printer, the screen will be blank. A configuration will not display until you load
a configuration file from a disk or computer.

The Configuration Editor allows you to upload, modify, and download eight
user-defined configurations and the factory default configuration (only if
modification of the factory configuration has been enabled; see the Note on
page 65). You may also save sets of configurations to your local hard drive so
that they can be easily downloaded to the printer at any time.

The Configuration Editor does not change the current configuration or the
active printer status until the configurations are downloaded to the printer.

Menu Tree

The Configuration Editor displays the printer configurations in a tree format
(see Figure 40). The top level of the tree is the OFFLINE menu. From this
level, the tree branches into the printer's submenus. Menu items that have a
ﬁl or & (handle) next to them have further submenus below them. Click the
handle to expand or collapse the submenus below. (You may also use the
Expand Tree/Collapse Tree options in the View menu to expand or collapse
submenus.)

The Configuration Editor has three drop-down menus at the bottom. The
Displayed Language option allows you to select from five different languages
to display the configuration information. The Displayed Configuration option
lets you choose between the available configurations to display. The
Power-Up Configuration allows you to assign which configuration loads
whenever the printer turns on.
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Creating Configurations

Along with the factory configuration, your printer allows up to 8 user-defined
configurations that can be downloaded to your printer's memory. You may
create configurations using the printer’'s operator panel, or by using the
Configuration Editor.

To create a configuration using the Configuration Editor:

1. Select Edit » Copy From:. A list of configurations appears. Undefined
configurations appear gray. Choose one of the configurations.

2. Click Edit. (Notice that the configuration you chose in step 1 now appears
next to the Copy From: menu item.) Move your mouse down to Copy To.
A list of configurations appears. Choose the number of the configuration
you wish to create. This new configuration is created with the settings
from the configuration you chose in step 1.

NOTE: If you choose to Copy To a configuration which already exists, that
configuration will be erased.

3. You may now edit the configuration settings. See the next section,
“Changing Configurations.”

Changing Configurations

Configuration settings in the Configuration Editor can be changed two ways:
* make the changes directly on the menu tree
+ use the Menu Editor

NOTE: Normally, the factory default configuration cannot be changed.
However, you can enable modification of the factory configuration.
Select Edit » Enable Factory Edit. It is strongly recommended that
you do not modify the factory default configuration. If you choose to
modify the factory configuration, you should first upload it from the
printer, and then save it. This way, you will have a backup copy of the
factory configuration. To disable modification of the factory
configuration, select Edit » Disable Factory Edit.

Making Changes on Menu Tree

1. Using the Displayed Configuration menu at the bottom of the window,
click the drop-down arrow to choose the configuration to change.

2. Expand the submenus until the configuration setting you wish to change
displays.

3. Select the menu item you wish to change. A selection box surrounds your
choice.

@ LinePrinter+
& Printer Protocaol: P-Series
Qrientation: Portrait
@ CPIILPI Select
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4. Use the < and > keys to toggle through the available options. (You may
change these keys in the Printer Database window: select
File » Preferences, then click the Configuration Editor tab.
See page 22.)

@ LinePrinter+
& Printer Protocaol: Epson Fi
Crientation: Porrait
& CPILFI Select

Menu Editor

E%‘:Henu Editor: Printer Protocol

—Factory {0) Edit On —Configuration 1 —Configuration 2
|P-Series - ‘ ‘P-Series -
i Hidden (" Hidden Hidden
—Configuration 3 —Configuration 4 —Configuration 5
Hidden Hidden Hidden
—Configuration 6 —Configuration 7 —Configuration 8
Hidden Hidden Hidden
HideAll || cCopyFact || ok || cancel | appy

Figure 41. Menu Editor

Double-click any menu item to open the Menu Editor window. Figure 41
shows the screen you see when you double-click the Printer Protocol option.
By using the Menu Editor, you may view and adjust the settings of all nine of
the printer configurations at once. To change a setting, click the drop-down
arrow underneath the corresponding configuration and choose an option.
Grayed out configuration names and settings do not exist; you must create
the configuration before you can edit it (see page 65).

To hide a menu item in the operator panel, select Hidden under a
configuration. Click Hide All to hide this menu item in all configurations. (For
more information on hiding, see page 67.)

Select Copy Fact (1-8) to set all configurations to the same value as the
factory or user-defined configuration currently selected under the
Edit » Copy From: menu in the Configuration Editor (see page 65).

Click Cancel to exit the Menu Editor without saving your changes.
Click Apply to save your changes without exiting the Menu Editor.
Click OK to save your changes and exit the Menu Editor.
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Deleting Configurations

To delete any of the configurations (except the Factory Configuration), select
Edit » Delete » and choose the number of the configuration to be deleted.

Naming Configurations

You may give a 15-character, alpha-numeric name to any of the 8
user-defined configurations. Select Edit » Names to open the Edit
Configuration Names window.

Choose the configuration you want to name, then click OK to assign the name
change, Cancel to exit this window without saving your changes, or Reset to
restore the original configuration numbers.

Hiding/Unhiding Menu ltems

Eg’,% Configuration Editor - T4000_cfg
File Edit Wiew Hide Download Upload

EEETE

CFFLINE
Frotect Configs.: Disakle
ACTIVE IGP EMUL: IGPIPGL

@ EMULATION
2 LinePrinter+

@ Printer Protocol: P-Series
& P-Series
& P-Series X
&= Searial Matrix
& Proprintar XL
& Epson Fx
Crientation: Porrait

@ CPILPI Select

Select CPI:10.0 CPI
Displayed Language Displayed Configuration Power-Up Co

English ~ | |Factory ~ | |Existing

Figure 42. Hiding a Menu Item

The Configuration Editor allows you to hide menus to make the operator
panel menus easier to use, or to restrict printer operators from accessing
certain printer configuration menu items. If you choose to hide a menu item in
the Configuration Editor, the hidden menu item still loads into the printer when
the configuration downloads to it. However, the hidden menu item does not
appear on the printer’s front panel.

The Configuration Editor displays hidden menus in gray on the menu tree.
When a menu item is hidden, all of its sub-menus are hidden as well. In
Figure 42, the Printer Protocol menu item is hidden. The Printer Protocol
menu item, as well as its sub-menus (P-Series, P-Series XQ, etc.) cannot be
changed from the printer’s operator panel.

You can still change hidden menu items using the Menu Editor.
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You can hide or unhide menu items in three ways:

1. Using the keyboard. From the menu tree, select a menu item. A selection
box appears around the selected menu item. Press H to hide the menu
item or U to unhide the menu item. (To change these keys, select
File » Preferences in the Printer Database window. See Figure 10 on
page 22.)

Using the Menu Editor. See page 67.

Using the Hide option on the Configuration Editor menu bar. With this
menu option, you may hide or unhide individual items, sub-menus or the
entire configuration.

Saving Configuration Files

Normally, your printer can save only nine configurations in its memory. You
change these configurations through the printer’'s operator panel. However,
using the PMU, you can store a nearly unlimited number of configurations on
your host computer.

Once you have made your changes, you can save your configurations as a
.ctg file on your local hard drive. This way, you can open any set of
configurations from your host computer and download them into your printer
quickly and easily.

To save configurations to your local hard drive, select File » Save As. Be sure
to save your configuration as a filename. cfg file.

Opening Configuration Files

To open a configuration file, select File » Open. The Configuration Editor
loads the settings from the file you choose.

Remember, these settings do not affect the current configuration or the active
printer status until the configurations are downloaded to the printer.

NOTE: The Configuration Editor displays only one configuration file at a time.
Be sure to save any changes before opening another configuration
file.

Downloading Configurations

You may use the Configuration Editor to download into your printer any
configurations you have created. Open the configuration file you wish to use,
then use the options under the Download menu to send individual
configurations, all configurations, or just the configuration names.

Downloading a configuration deletes the corresponding configuration
currently stored in the printer. If you wish to save the configurations currently
stored in the printer before overwriting them, upload them into the
Configuration Editor first, and then save them as a . c£fg file on your local
hard drive.
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Uploading Configurations

The Configuration Editor can upload configurations from a printer. Once the
configurations upload, you can save them to a file. Now you can select
another printer from the database and upload its configurations. The PMU
prompts you to save the previously uploaded configuration before the new
configuration uploads.

Revert

The Configuration Editor allows you to revert to a previously uploaded printer
configuration.

Each time you start the Configuration Editor, the current configuration settings
upload from your printer's memory. The Configuration Editor saves this
information, and assigns a date and time to it.

Select File » Revert, and a list of previous Configuration Editor sessions
appears. Choose the date/time stamp of any session to restore the
configuration settings that were uploaded from the printer at that time.

To set the maximum number of revert sessions allowed, select
File » Preferences in the Printer Database window. The default is 10.

NOTE: Revert only works when editing online. When editing offline, you do
not need to select a printer.
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Flash File Manager

EE% Flash File Manager P[=] B3
Printer List File List
Mew_Printer | Upload

l Idie

Figure 43. Flash File Manager Window

The Flash File Manager is a tool that allows you to upload all unprotected files
from the flash memory of a selected printer. Select Applications » Flash File
Manager or click the @ (flash file manager) button.

The Printer List pane displays a list of printers. Depending on what is
selected, different printers appear. If you select one printer, it appears alone
in the list. If you select a folder, all active printers in the folder appear.

If you select another printer or folder, click Update in the lower-left corner to
update the Flash File Manager and display the newly selected printer(s).

NOTE: Cloned printers or different folders that link to the same printer do not
display. Only the original printer displays.

Click Upload to upload unprotected files from the printer's flash memory.

Progress displays on the status bar at the bottom of the window.

After the file uploads, it appears in the File List pane. You can save all files
together as one downloadabile file. Click Clear to clear the file list.

Configuration Download/File Download
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Data Validation

Eg’,; Data Yalidation Telemetry Viewer [New_Printer]

Seq | Failure | ) Deviation ¢+ | Data

B1.1 Pass | [STIO0O[ST]

L1.1 Pass (Label)

B2.1 Pass | [STI001[ST]

L21 Pass (Lahel) =
B3.1 Pass | [STIO0Z[ST]

L3.1 Pass (Label)

B4.1 Pass | [STIO03[ST]

L4.1 Pass (Label)

BA.1 Pass | [STIO04[ST]

L5.1 Pass (Label)

BE.1 Pass | [STIO0S[ST]

6.1 Pass (Label)

B7 .1 Pass | [STIQOG[ST]

L7.1 Pass (Label)

Ba.1 Pass | [STIO0F[ST]

L8.1 Pass (Label)

Ba.1 Pass | [STIO0E[ST] |
LN 1 1

Connection Status: collecting [] Labels Only [_] Auto Scroll

Figure 44. Data Validation Window

Use the Data Validation application for printers equipped with a barcode
validator. Validation data transmits over an Ethernet connection to the PMU,
which interprets the data and displays statistical information based on the
data received.

To access the Data Validation application, first select a printer from the Printer
Database that has a barcode validator. Then select Applications » Data
Validation or click the E Data Validation button.

Figure 44 shows an exarr;ple of the Data Validation screen after a print job
runs. The printer sends the barcode report to the PMU.

The “Failure” column indicates if each barcode passes validation standards. If
one does not, the reason for the failure appears. The “Deviation” column
gives a graphic representation of the barcode deviation. The “Data” column
indicates the barcode data.
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ODV Quality Wizard

For more information, click a bar code and select View »
Barcode Details. Figure 45 shows the details for barcode number 12 from

Figure 44.

NOTE: You cannot save validation data to a file.

E-"g’,j'Details for Barcode 1 M=l E3
Farameter Walue

Type 3

Count B1.1

CaptureDate Wied Aug 01 111813 POT 2001

Frinter Mame Mew_Printer [

Frinter Address 10224231

Failure Code 0

Deviation -18

Symbology Code 349

Decoded Data 2Bo00ze

Ref Decode true

Decodeability Avg g9

Modulation Awvg aa

Defects Avg 14 =

ODV Quality Wizard

Figure 45. Barcode Details Window
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Ega 0DY Quality Wizard [New_FPrinter]

Print Intensity -3 EE
Print Speed 6 ips EE

Settings Recommendation:
Barcode Code 39 Status:

| OK || Cancel |

Figure 46. ODV Quality Wizard Window

The ODV (Online Data Validation) Quality Wizard is a function that helps you
select the best combination of print speed and print intensity that will produce
optimal bar code output. It displays controls that allow you to select a print
speed and a print intensity.

Click the Test Print button to print and validate a test bar code pattern. Based
on the validation results, the ODV Quality Wizard changes settings to
optimize the bar code quality.

Click OK to save these changes in Configuration 1. Configuration 1 then
becomes the Power-Up configuration (see page 64). Click Cancel to not save
the changes.
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Configure Print Servers

Eg_;’%[:onﬁgule Print Servers

Login: | Password: [v] Automatic

Frinter | Status | Trap Port | Warning | Offline | Media Input | hed
Mew_Printer Ready Set [l [l [

[ »

Press {Start) to configure the Print Servers | Start | | Cancel |

Figure 47. Configure Print Servers Window

To access the Configure Print Servers application, select one or several
printers from the printer database then select Applications » Configure
Print Servers or click the @ Configure Print Servers button. The Configure
Print Servers window appears (see Figure 47).

The Configure Print Servers application allows you to select alert groups. To
select an alert group, click the check box(es) of the corresponding option(s).
The alert group options include:

*  Warning

« Offline

¢ Media Input

*  Media Output

* Media Path
e Marker

o Cutter

« Barcode

* Scanner

* Intervention
« Consumable
e Label

Click Start to configure the print servers. When your printer encounters a
problem that falls within the parameters of the selected alert options, the
corresponding alert message appears. Refer to the Alert Groups Table in
chapter three of the Ethernet Interface User's Manual for descriptions of the
alert message options.

NOTE: To check the print servers configuration, go to the Ethernet Interface
web page as discussed in chapter three of the Ethernet Interface
User’s Manual.
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Speed Keys
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The Speed Keys are single buttons that allow you to perform a specific
operation without having to traverse the printer’s front panel menu structure.
The Speed Keys assist you in performing repetitive functions associated with
printer configuration or maintenance.

To access Speed Keys, select a printer then select Applications »
Speed Keys or click the JEST] Speed Keys button.See Figure 48.

Changes made using Speed Keys are changed in the printer and saved in
Configuration 1. Configuration 1 then becomes the Power-Up configuration
(see page 64).

NOTE: Speed Keys are printer specific, and not all printer models have
Speed Key support. Printers without Speed Key support return the
error message:

Operation not allowed on this type of printer.

[E3 Speed Keys [M_09COF7] [_[O]
Physical Unit Setup | Media Sensor Calibration rPrirmJut Quality Settings r\;‘alidatur Settings |

i@ Use Inches
) Use Millimeters

Figure 48. The Speed Keys Window
The Speed Keys are grouped according to their use:
»  Physical Unit Setup
* Media Sensor Calibration
*  Printout Quality Settings
» Validator Settings

NOTE: For an explanation of the functions the Speed Keys perform, see your
User’s Manual.
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Web Access

You can access your printers using a web browser. You can monitor the
status, open an operator panel, check the configurations, access Speed
Keys, open the ODV Quality Wizard, and access the printer web page.

NOTE: To access your printer using a web browser, you must enable the
Web Server and Xml Server services (see page 23). Remember to
exit and restart the PMU to enable the service.

The PMU Web Site URL Address

Open a web browser. In the URL address field, type http://, followed by
the host name (computer name, not case-sensitive) or the host IP address of
the workstation running the PMU, followed by a : (colon), and then the port
number.

For example:
http://1ab21042:8080

or:
http://10.224.5.121:8080

NOTE: Make sure the port number does not conflict with another port number
designated for a different purpose.

Press Enter, and the web page for your designated printer appears. See
Figure 50.

(To find the host name using Windows, right-click Network Neighborhood
on your desktop and select Properties. The Network dialog box opens, and
the computer name appears in the Identification tab. See Figure 49.)

Metwork [viewing mode) HE

Services | Protocols | Adapters |

WWindows uses the following information to identify this
| computer oh the network.

Computer Mame: ||_A|321 04z

Domair: [MISIRYINE

Close I [Fatice] |

Figure 49. Finding Your Host Name In Windows
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Login To The PMU Web Site

User: |
—

Figure 50. The PMU Web Site

By default, three categories of login privileges are available. See Table 2 for a
list of categories and their corresponding user names and passwords.

Table 2. User Login Options

Login Category User name Password
Standard standard standard
Supervisor super super
Administrator admin admin

Type admin for the user name and password, then click Login. The Select
Desired Page web page appears. See Figure 51.

admin is Logged in - Please Select Desived Page

Frinter List Page

Change Password Page

Figure 51. The Select Desired Page Web Page

Changing The User Password

You can change the default password. Click Change Password Page, and
the Change Password web page appears. See Figure 52.

Change Password

New Password: —
Retype Password: [N

Change Password

Figure 52. The Change Password Web Page

Enter a new password in the New Password and Retype Password fields,
then Click Change Password. Your password changes and you return to the
Select Desired Page web page.
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The Printer List Page

Click Printer List Page. The Printer List web page appears and lists the same
printers found in the database pane. See Figure 53.

This page will refresh once a minute. Time: 15:11

Sort Printers by | Status (Errors) jﬂl
. ODY [Printer
Frinter Address | Status Message Configuration Operator|Speed Quality| Web
m Panel Keys .
Wizard Page
Thermal (Building 43
Thermal|10.224 2 35EEROR OFFLINEPOWER SAVEE  [Current Open  |OpenCpen (Open
MODE
Line Line Matriz (Building B)
Matrix| > 22229 PK o INEETRERNET/PGLLP+CUTENt  [Open  CpenCpen Open

Figure 53. The Printer List Web Page

By default, printers are sorted by Status (Errors). You can also sort printers by
Status (Warnings), Status (Online), Address (Ascending), and
Address (Descending).

In the above example, the thermal printer displays an error because it is
offline. Any printer not ready to print displays an error status.

For an explanation of the Printer List Page options, find the option in Table 3
and follow the corresponding reference.

Table 3. Printer List Page Options

Web Page Option

Referen

ce

Configuration

displays the printer’s current configuration

Operator Panel page 59
Speed Keys page 74
ODV Quality Wizard page 72

Printer Web Page

Manual

opens the IBM network adapter home page; refer
to chapter three of the Ethernet Interface User’s

NOTE: Administrators and Supervisors can access all five options. Standard
users can access only Configuration and Printer Web Page.
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Web Access

IMPORTANT

Changing User Settings, IP Addresses,
and IP Address Ranges

The PpmLogin.xml file, located in the PMU program directory, contains user
settings and the included/excluded IP addresses and IP address ranges.
Open this file with any standard text editor. See Figure 54.

The PpmLogin.xml file should only be modified by expert users.
Incorrect entries in this file could render the Web Server service

unusable.

<?xml wversion="1.0" encoding="UTF-5"2>
< |DOCTYPE ppmXML [
< !ELEMENT ppmXML (LoginDatabase):>
< !ELEMENT LoginDatakhase [(UserDatahase,
< !ELEMENT UserDatabase [(userid#®):»
<!ELEMENT userid (#PCDATA)>
<!ATTLIST userid password CDATA #IMPLIED>
<IATTLI3ZT userid privilege (admin|standard|=super) "standard"” >
< !ELEMENT MachineDatsbhasze (iplddressIncluded?® , iplddressExcluded?,
<!ELEMENT ipiddressIncluded (§PCDALTA) >
< !ELEMENT ipiddressExcluded (#PCDATA) >
< !ELEMENT iphddressIncludeRange (#PCDATA) >
<!ATTLIST ipiddressIncludeRange start CDATA #IMPLIED>
<!ATTLIST ipiddressIncludeRange end CDATAL H#IMPLIED>
< !ELEMENT iphddressExcludeRange (#PCDATL) >
<!ATTLIST ipiddressExcludeRange start CDATA HIMPLIED>
<!ATTLIST ipiddressExcludeRange end CDATA #IMPLIED>

MachineDatabase)] >

iphddres=sIncludeRange®,

1=
<ppmEML >
<LoginDatabase:
< !—— For some user to access the printer information,
<!-— The IF address of their machine also needs to be
<UserDatabase>
<!—— A1l the user names, their privilege type (standard, super, admwin)
<userid password="standard" privilege="standard":rstandard</userids>
<userid password="super" privilege="super"srsuper</userids>
<userid password="admin" privilege="admin">admin</userid>
</UserDatshase>
<Nachinebatabasex
<!—— Indiwvidual address can be included or excluded from accessing the printer information.
2l iphddressIncluded and iplddressExcluded are used for individual addresses. ——»
<iphddressIncluded»10.22.1.121</ipiddressInc luded>
<iphddressExcluded»100.100.100. 100</ ipiddressExcludeds

they need to be added by userid.
authorized. —->

-

iphddressExcludeRange ) >

needs to be added here ——»

-

< !—— Use ipiddressIncludeRange and its

<iplddressIncludeRange starc="00.00.00.

<!—— Tze ipAddressExcludeRange and its

<ipdddressExcludeRange start="00.00.00.

start and end attributes to define the access range.
00" end="zZ55.255.255.255"> </ iphiddressInc ludeRange>

-

start and end attributes to define the inwvalid access range.

0a" end="00,00.00.1"></iphddressExcludeRangs>

</MachineDatabase>
</Loginlatabhase>
</ ppmEML>

Figure 54. The PpmLogin.xml File
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User Settings

The user name, password, and privilege category are defined in the
<UserDatabase> section of the file.

Password Privilege category User name

<Userlatabase> l l

<!'—— All the user nawmey, their privilegey type (standyrd, super, admin
<uzerid password="standard"” privilege="standard">standard</userid:>
<uzerid password="super™ privilege="superTrsuper</userid>
<userid password="admin™ privilege="admin"radmin</useridx>

</ UserDatabasex

Figure 55. User Login Parameters

Password: Defines the password for the designated user name. When you
change the password using the Change Password web page, this information
updates.

Privilege Category: Defines the privilege for the designated user name. The
available options are: standard, super, and admin.

User name: Defines the user name. You can only change the user name by
modifying this attribute.

You can add additional users by duplicating the following line in the
<UserDatabase> section

<userid password="standard" privilege="standard">
standard</userids>
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IP Addresses and IP Address Ranges

You can define which IP addresses are available to the PMU for access. Any
IP address not included or defined in the included range will be unavailable to
the PMU. In addition, any IP address excluded or defined in the excluded
range will also be unavailable. The included and excluded IP addresses are
defined in the <MachineDatabase> section of the file.

Included IP Address Included IP Address Range
<MachineDatabhase>
“l=— Individual address |(an hbe included or exgluded from accessing thu
<!'—— iplddressIncluded agd iphddressExcluded are used for individual :

<iphddressIncluded>10.22.1.121</ipiddressInc lideds
<iphddressExcluded>100.100.100.100</ ipiddressExcluded:>

“l—— TUse iphddressIncluddBancgs and ﬂts Start and end atTributes to de:
<iphddressIncludeRange start="00.00.00.00" end="255.2585.255. 288>/ 1ip.
“l=— TUze iphddreszsExcludegRange and its start and end attrilbutes to de:

<iphddressExcludeRange sStlart="00.00.00.00" end="00.00.00.1"></ ipiddre:
</ MachineDatabaser [ | I

Excluded IP Address Excluded IP Address Range

Figure 56. Include/Exclude IP Address Options
Address Included: Defines which IP address to include.
Address Excluded: Defines which IP address to exclude.
Address Include Range: Defines the range of IP addresses to include.
Address Exclude Range: Defines the range of IP addresses to exclude.

You can add additional included/excluded IP addresses or IP address ranges
by duplicating the corresponding lines in the <MachineDatabase> section:

<ipAddressIncluded>10.22.1.121</ipAddressIncluded>
<ipAddressExcluded>100.100.100.100</ipAddressExcluded>

<ipAddressIncludeRange start="00.00.00.00"
end="255.255.255.255"></ipAddressIncludeRange>

<ipAddressExcludeRange start="00.00.00.00"
end="00.00.00.1"></ipAddressExcludeRange>
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Alert Delivery, 37
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Applications
barcode verification, 71
Configuration Download, 53
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Configure Print Servers, 73
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File Download, 53
Flash File Manager, 70
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ODV Quality Wizard, 72
Operator Panel, 59
Speed Keys, 74

Applications menu, Printer Database, 29

Assign IP Address, 44

B

Barcode verification, 71

C

Changing
configurations, 65
IP addresses, web access, 78
user password, web access, 76
user settings, 78
Collapse database tree, 26
Configuration Download, using Printer Database, 53
Configuration Editor, 64
changing configurations, 65
creating configurations, 65
Menu Editor, 66
menu tree, 64
Configuration Editor tab, 22

Configuration files
opening, 68
saving, 68
Configuration Printout, 63
Configurations
downloading, 68
uploading, 69
Configure Print Servers, 73
Connections tab, 51
Copy item in database, 25
Create new database file, 20
Creating configurations, 65
Cut item from database, 25

D

Data Validation, 71
Database File Name, 21
Database tree, 19
Dec./Inc. Key, 22
Defining printer properties, 48
Deleting configurations, 67
Deleting item from database, 25
Directory, 63
Discover Printers, 30
Discovery
Known Printers, 34
Polled, 33
Print Server, 32
Download
file examples, 54
preserving configurations and flash files, 58
preserving configurations only, 58
preserving flash files only, 58
without preserving configurations
or flash files, 58
Download Mode, 51
Download Timeout, 51
Downloading configurations, 68
Downloading files, 53

81



E

Edit menu, Printer Database, 24
Email Alerts, 38
Error Logs

printer, 63

printer management utility, 20
Excluding item in database, 25
Expand database tree, 26

F

File Download, 53

File menu, Printer Database, 20
Flash file download, 53

Flash File Manager, 70

G

Getting started, 12

H

Hardware Address, 44

Hardware requirements, 9

Help menu, Printer Database, 44
Hide Key/Unhide Key, 22

Hiding menu items, 67

Identification tab, 49
Including item in database, 25
Information Capture, 62
Configuration Printout, 63
Directory, 63
File, 63
Insert item in database, 24
Installation, 9
Interfaces, 9
IP addresses, web access, changing, 78

K

Known Printers Discovery, 34
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Lease Time on Printer Connection, 21
Login to the printer management utility web site, 76

M

Making changes on the menu tree, 65
Maximum revisions, 22
Menu bar, Printer Database
Applications, 29
Edit, 24
File, 20
Help, 44
Status, 30
Utilities, 41
View, 26
Menu Editor, 66
Menu tree, 64

N

Naming configurations, 67
Network tab, 52

New Gateway, 44

New IP Address, 44

New Mask, 44

o)
ODV Quality Wizard, 72
Open database file, 20
Opening Configuration files, 68
Operator Panel, 59
4400 Series Thermal Printer, 60
6400 Series Line Matrix Printer, 60
Disabled indicator, 61
in progress indicator, 61
message display, 61
primary operator keys, 61
secondary operator keys, 61
status indicator, 61



Password, printer
setting, 41
Supervisor Mode, 50
User Mode, 50
Paste item into database, 25
Polled Discovery, 33
Polling, 35
Preferences, 20
Primary operator keys, 61
Print Server Discovery, 32
Printer Database
items, 47
main window, 19
menu tree, 19
toolbar, 45
Printer discovery, 30
Printer list page, 77
Printer Properties
Access Method, 51
Connections, 51
defining, 48
Download Mode, 51
Download Timeout, 51
Identification, 49
password, 50
printer description, 49
printer name, 49
Security, 50
Printer setup, 10

Reboot Printer, 41

Reply IP Address, 44

Requirements, 9

Revert to a previously uploaded printer
configuration, 69

S
Save As, 20
Save database file, 20
Saving Configuration files, 68
Secondary operator keys, 61
Security, 21
Security tab, 50
Set Printer Password, 41
Skip this entry, 58
SNMP Browser, 43
SNMP Trap Server, 23

Software requirements, 9

Speed Keys, 74

Status and Error Log, 20

Status menu, Printer Database, 30
Status Monitoring Properties, 32
Status update, 31

Style of database tree, 26
Supervisor Mode, 50

Syslog Posting, 40

Toolbar, 28, 45
Tutorial, 12

U

Unhiding menu items, 67
Update Status, 31
Uploading configurations, 69
User mode, 50
User settings, changing, 78
Utilities
Assign IP Address, 44
Reboot Printer, 41
Set Printer Password, 41
SNMP Browser, 43
Utilities menu, Printer Database, 41

\'}

View menu, Printer Database, 26
Viewing configurations,
using Information Capture, 62
Viewing Error logs, 63
Virtual Operator Panel

See Operator Panel

w

Web access
changing IP addresses, 78
changing user settings, 78

Web Server, 23

Web site
changing the user password, 76
login, 76
printer list page, 77
URL address, 75

X
XML Server, 23
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