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In this book
This book documents the Agilent 89600-Series installation and service procedures. 
It provides the following:

• software installation instructions

• hardware installation instructions

• PCI card and PCMCIA cardbus installation instructions

• hardware configuration information

• licensing information

• diagnostics, troubleshooting, and replaceable parts information for VXI 
hardware

This book does not contain operating information. All operating information is 
contained in the 89600 online help.

Other documentation
In addition to the Installation Guide (this book), the following documentation also 
comes with your software:

• 89600 Online Help is available after you install the software on your computer. 
The help includes reference information, tutorials on making several kinds of 
measurements, and a video overview of the analyzer. Separate online help is 
available for the 89600 WLAN Test and 89604 Distortion Suite applications.

• An online version of this Installation Guide (install.pdf) is available at 
C:\Program Files\Agilent\89600 VSA\Help after you install the software on 
your computer.

•  If the analyzer includes VXI measurement hardware, the printed VXI 
mainframe User and Service Manual is shipped with your analyzer. (You can 
put the mainframe manual in the 89600-series binder.)

• The complete documentation (PDF files) for the Agilent IO libraries is located 
in C:\Program Files\Agilent\IO Libraries Suite\Manuals (if you install the IO 
libraries).

• Agilent E1438 and Agilent E1439 operating information is documented in PDF 
files located in C:Program Files\Visa\Winnt\age1438\help and C:\Program 
Files\Visa\Winnt\age1439\help (only for VXI measurement hardware).

• Technical Specifications are available from the 89600 web page: 
http://www.agilent.com/find/89600.
  9
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Independent operation of the Agilent 89605, 89606, E2730, and E2731 modules is 
not supported at this time.

To read the PDF files, you must have Acrobat® Reader installed on your computer. 
You can install this application from the 89600 Installation CD.

We have provided room in this binder so that you can put the VXI mainframe 
documentation in this binder. This way all the documentation you may need for 
troubleshooting or replacing parts will be in one location.

Safety Summary

IMPORTANT Note that this manual contains only the safety information pertaining to installing 
VXI modules in the VXI mainframe and for installing the IEEE 1394 PCI interface 
card in your computer. For information on operating your VXI hardware and your 
computer safely, please refer to the user or service manuals for your VXI 
mainframe and computer.

The following general safety precautions must be observed during all phases of 
operation of this instrument. Failure to comply with these precautions or with 
specific warnings elsewhere in this manual violates safety standards of design, 
manufacture, and intended use of the instrument. Agilent Technologies Inc. 
assumes no liability for the customer's failure to comply with these requirements.

GENERAL

This product is a Safety Class 1 instrument (provided with a protective earth 
terminal). The protective features of this product may be impaired if it is used in a 
manner not specified in the operation instructions.

BEFORE APPLYING POWER

Verify that the product is set to match the available line voltage, the correct fuse is 
installed, and all safety precautions are taken. Note the instrument's external 
markings described under Safety Symbols.

GROUND THE PRODUCT

To minimize shock hazard, the instrument chassis and cover must be connected to 
an electrical protective earth ground. The instrument must be connected to the ac 
power mains through a grounded power cable, with the ground wire firmly 
connected to an electrical ground (safety ground) at the power outlet. Any 
interruption of the protective (grounding) conductor or disconnection of the 
protective earth terminal will cause a potential shock hazard that could result in 
personal injury.

FUSES

Only fuses with the required rated current, voltage, and specified type (normal 
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blow, time delay, etc.) should be used. Do not use repaired fuses or short-circuited 
fuse holders. To do so could cause a shock or fire hazard.

DO NOT OPERATE IN AN EXPLOSIVE ATMOSPHERE

Do not operate the instrument in the presence of flammable gases or fumes.

DO NOT REMOVE THE PRODUCT COVER

Operating personnel must not remove instrument covers. Component replacement 
and internal adjustments must be made only by qualified service personnel.

Instruments that appear damaged or defective should be made inoperative and 
secured against unintended operation until they can be repaired by qualified 
service personnel.

Front and Rear Panel Symbols
The CE mark is a registered trademark of the European 
Community.

The C-Tick mark is a registered trademark of the Australian 
Spectrum Management Agency.

This is a marking of an Industrial Scientific and Medical Group 1 
Class A product, and to indicate product compliance with the 
Canadian Interference-Causing Equipment Standard (ICES-001).

The CSA mark is a registered trademark of the Canadian 
Standards Association.

Caution, refer to 
accompanying documents Alternating current

Earth (ground) terminal Direct current

Frame or chassis terminal Warning, risk of electric shock

Terminal is at earth potential.

Used for measurement and control circuits designed to be operated with one 
terminal at earth potential.
  11



This is a marking of the WEEE Directive (2002/96/EC) 
requirements.  The affixed label indicates that you must not 
discard this electrical/ electronic product in domestic household 
waste. 

Do not dispose in domestic household waste. 

To return unwanted products, contact your local Agilent 
office or for more information, see 
http://www.agilent.com/environment/product/. 

Warranty
This Agilent Technologies instrument product is warranted against defects in 
material and workmanship for a period of one year from date of shipment. During 
the warranty period, Agilent Technologies will, at its option, either repair or 
replace products that prove to be defective.

For warranty service or repair, this product must be returned to a service facility 
designated by Agilent Technologies. Buyer shall prepay shipping charges to 
Agilent Technologies and Agilent Technologies shall pay shipping charges to 
return the product to Buyer. However, Buyer shall pay all shipping charges, duties, 
and taxes for products returned to Agilent Technologies from another country.

Agilent Technologies warrants its software and firmware designated by Agilent 
Technologies for use with an instrument will execute its programming instructions 
when properly installed on that instrument. Agilent Technologies does not warrant 
that the operation of the instrument, or software, or firmware will be uninterrupted 
or error-free.
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89600 Series Software
89600 Series Software
The 89600 Series Software CD-ROM includes software for the following 
applications:

• 89600 Vector Signal Analyzer (89601 VSA software)

• 89600 Spectrum Analyzer (89601 VSA software)

• 89604 Distortion Suite

• 89607 WLAN Test
 14 Chapter 1 
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Before you start installation
The information in this section prepares you for installation.

IMPORTANT If you are installing only a floating license server, skip the rest of this chapter and 
go directly to Chapter 14 , “Setting Up a Floating License Server,” on page 197

To prepare for installation:

1. Be sure you have the documentation and media listed below:

• Agilent 89600 Series Software installation CD.

• Installation and Service Guide for Agilent 89600 Series.

• If your analyzer requires LAN, GPIB, or IEEE 1394 interfaces, you need 
your computer’s documentation for installation of PCI adapters, PCMCIA 
cards, or GPIB cards.

• VXI Measurement Hardware - If the VXI measurement hardware includes 
an 89605, E2730, or E2731 module, you may need the Calibration disks for 
the module.

• Installation and setup information for a source or non-VXI measurement 
hardware you will be using with 89600 software.

2. Be sure your desktop or laptop PC satisfies the following minimum 
requirements.

racteristic
Microsoft® Windows® 
XP Professional

Microsoft Windows 
Vista Business, Enterprise, or 
Ultimate

Microsoft Windows 7  
Professional, Enterprise, or 
Ultimate

600 MHz Pentium or 
AMD-K6 
(≥ 2 GHz recommended)

1 GHz 32-bit (x86) 
(≥ 2 GHz recommended)

1 GHz or faster 32-bit (x286) or 
64-bit (x64) processor

ty slots 
top)

1PCI-bus slot  
(2 recommended- VXI 
hardware only)

1PCI-bus slot  
(2 recommended- VXI hardware 
only)

1PCI-bus slot  
(2 recommended- VXI hardware 
only)

ty slots 
op)

1 CardBus TypeII slot 
(integrated FireWire® 
recommended - XI hardware 
only)

1 CardBus TypeII slot 
(integrated FireWire 
recommended - XI hardware 
only)

1 CardBus TypeII slot 
(integrated FireWire 
recommended - XI hardware 
only)

512 MB 
(1 GB recommended)

1 GB Rcmd’d 2 GB Rcmd’d (32bit) / 4 GB 
Rcmd’d (64-bit)

o RAM 4MB 
(16 MB recommended)

128 MB  
(512 MB recommended)

128 MB  
(512 MB recommended)
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3. Setup your computer and connect peripherals if required.

4. Determine what kind of interface is required for your measurement hardware, 
using the following table. Note that you may need to install and configure more 
than one interface. For example, if your measurement hardware includes VXI 
measurement hardware and an Agilent ESG source, you must configure both an 
IEEE-1394 interface and a GPIB interface.

 disk 1 GB available 1 GB available 1 GB available

tional drives CD-ROM to load software; 
license transfer requires a 3.5 
inch floppy disk drive, 
network access, or USB 
memory stick

CD-ROM to load software; 
license transfer requires a 3.5 
inch floppy disk drive, network 
access, or USB memory stick

CD-ROM to load software; 
license transfer requires a 3.5 
inch floppy disk drive, network 
access, or USB memory stick

face support LAN, GPIB, USB or 
FireWirea interface (VXI 
HW only)

LAN, GPIB, USB or FireWire 
interface (VXI HW only)

LAN, GPIB, USB or FireWire 
interface (VXI HW only)

a. For a list of supported IEEE 1394 (FireWire) interfaces, visit www.agilent.com/find/89600 and 
search the FAQs for information on “What type of IEEE-1394 interface can I use in my computer to 
connect to the 89600S VXI hardware?”

racteristic
Microsoft® Windows® 
XP Professional

Microsoft Windows 
Vista Business, Enterprise, or 
Ultimate

Microsoft Windows 7  
Professional, Enterprise, or 
Ultimate

Measurement 
Hardware

Computer Type Interface

VXI (Agilent 89610, 
89611, 89640, 89641)

Laptop or desktop PC IEEE-1394 VXI to PC

Agilent ESA Laptop or desktop PC GPIB, LAN/GPIB Gateway 
(portal), USB/GPIB adapter

Agilent ESA-E Series 
Analyzer

Laptop or desktop PC GPIB or LAN/GPIB 
Gateway (portal), 
USB/GPIB

Agilent InfiniiVision 
6000/7000 Series 
Oscilloscope

Laptop or desktop PC LAN, GPIB, LAN/GPIB 
Gateway (portal), 
USB/GPIB

Agilent Infiniium 
Oscilloscope

Laptop or desktop PC or 
embedded Windows XP 
scope

LAN, GPIB, LAN/GPIB 
Gateway (portal), 
USB/GPIB, or internal

Agilent Logic Analyzer Laptop, desktop PC, or 
embedded PC

LAN or internal

Agilent X-Series Signal 
Analyzer

Laptop or desktop PC or 
embedded PC

LAN or internal**
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* To use GPIB with the PSA, your PSA firmware must be version A.4.0 or 
later. With earlier firmware versions, you must use the LAN connection.

** The Agilent X-Series Signal Analyzer embedded PC configuration (89600 
analyzer running in the analyzer) only supports a LAN interface between the 
analyzer and an Agilent Source; GPIB is not supported.

Agilent N4010 Wireless 
Connectivity Test Set

Laptop or desktop PC USB, LAN, GPIB, 
LAN/GPIB, USB/GPIB

Agilent PSA (used as 
ADC)*

Laptop or desktop PC LAN, GPIB, USB, 
LAN/GPIB Gateway 
(portal), USB/GPIB*

Agilent PSA (used as a 
down- converter with 
89611)*

Laptop, desktop, or VXI 
embedded PC

LAN, GPIB, USB, 
LAN/GPIB Gateway 
(portal), USB/GPIB

Agilent SI Spectrum 
Analyzer

(N8201, N8221)

Laptop or desktop PC LAN

Agilent Acqiris 
Waveform Digitizer

Laptop, desktop, or 
embedded Acqiris PC

LAN

Agilent Sources:  
ESG-D, ESG-DP, 
E4438C, PSG, and MXG 
sources

Laptop, desktop, 
measurement hardware 
with embedded PC, or 
embedded VXI PC

LAN, GPIB, LAN/GPIB 
Gateway (portal), 
USB/GPIB**

Measurement 
Hardware

Computer Type Interface
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89600-Series Analyzer Installation and Setup

IMPORTANT If you are installing only a floating license server, skip the rest of this chapter and 
go directly to Chapter 14 , “Setting Up a Floating License Server,” on page 197.

This chapter provides the instructions necessary to install and configure all the 
various 89600-series analyzer system configurations. It is very important to begin 
with this procedure and use it as the primary procedure unless noted or directed 
otherwise. This general procedure will direct you to other chapters and procedures 
for software and hardware specific installation and setup information.

The 89600-series analyzer installation and setup process consists of 6 basic steps:

1. Install the software

2. Set up the measurement hardware

3. Install I/O cards in your computer

4. Configure I/O interfaces

5. License the software. 

6. Calibrate the analyzer

Not all 89600-series analyzer system configurations require all steps to be 
performed. The details for each of these steps vary, depending on what kind of 
computer you are using, what type of interface connects your measurement 
hardware to the computer, and what operating system your computer uses. System 
hardware and configuration specific procedures are provided in various chapters in 
this book. You will not need to read and use every chapter, instead you will be 
directed to the appropriate chapter and procedure when required. 

NOTE Read all steps completely before doing the task. Most steps contain exceptions.

Perform each step in sequence unless specifically directly otherwise:

• Pre-installed systems: 
VXI measurement hardware with embedded VXI computer or laptop PC 
configuration: If your 89600 system includes VXI measurement hardware 
with either an embedded VXI computer or a laptop PC, all installation and 
licensing may have been completed at the factory. If this is true, you only need 
to connect the VXI hardware to the computer and start the analyzer.

• Software only installations:  
For 89600-series analyzer configurations that do not include measurement 
hardware, you only need to install and license the software. Do the “Install 
89600-series software” Step 1. and “License the software” Step 5.

Step 1. Install 89600-series software
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For all PC based hardware except the following, go to “Installing 89600 Software” 
on page 24 and install the 89600-software:

• Agilent Infiniium scope: If you are installing 89600 software in an Agilent 
Infiniium scope with a Windows XP operating system, go directly to Chapter 
8 , “Installing 89601 Software in Agilent Infiniium XP Scopes,” on page 125.

• Agilent X-Series Signal Analyzer: If you are installing 89600 software in an 
Agilent X-Series Signal Analyzer, go directly to Chapter 9 , “Installing Agilent 
89600 Software in Agilent X-Series Signal Analyzers,” on page 131

• Agilent Logic Analyzer: If you are installing the 89600 software in an Agilent 
Logic Analyzer, go directly to Logic Analyzer "Software Installation" (page 
143).

If your analyzer is a software only installation that does not include measurement 
hardware, go to “License the software” Step 5.

Step 2. Set up your measurement hardware

a. For VXI measurement hardware, see: “Introduction” on page 32. If the VXI 
modules are already installed in the mainframe and you are not using a laptop 
PC, skip this step and continue with step b.

b. Set up and configure the LAN, USB, and/or GPIB interface in the instruments 
you plan to connect to the computer, referring to the instrument’s user’s guide 
for documentation on configuring I/O. (Look in the instrument user guide index 
under “GPIB” or “I/O configuration.”)

You probably can use the instrument default settings. Make sure that each 
instrument on the GPIB has a unique GPIB address; two instruments cannot 
use the same address.

Step 3. Install the necessary I/O interface cards in the computer

a. For VXI measurement hardware, install the Agilent IEEE 1394 Host Adapter in 
your computer.

For desktop computer details, see: “Installing the IEEE 1394 host adapter in 
your computer” on page 79. Use the instructions in this book rather than any 
installation instructions that came with the adapter. For laptop computer details, 
see: “Installing the IEEE 1394 PCMCIA cardbus” on page 82.

b. If you require communication via GPIB, LAN, or USB and the interface has 
not been installed in your computer, install the interface card, following the 
instructions that came with the card. For details, see: “Introduction” on 
page 86.

c. Connect all measurement hardware to the appropriate interface on your 
computer or to the LAN. Plug in and turn on all measurement hardware and 
your computer (if they are not already on).

Step 4. Configure the I/O hardware interfaces
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Find your measurement hardware or interface type from the following list and go 
to the referred procedure.

a. Infiniium scope: If your measurement hardware is an Infiniium scope, see: 
Chapter 7 , “Configuring Infiniium Windows XP Scopes,” on page 111.

b. Agilent Logic Analyzer: If your measurement hardware is an Agilent Logic 
Analyzer follow the instructions in the "Connecting to a Network" (page 145) 
and "89600 I/O Connections" (page 146) in Chapter 10 , “Linking Logic 
Analyzers to the Agilent 89600 VSA,” on page 137.

c. VXI: If your analyzer includes VXI measurement hardware, configure 
IEEE-1394. See: “Configuring the VXI interface” on page 95 for details.

d. LAN interface: If you will be communicating with hardware via LAN, 
configure LAN. See: “Configuring the LAN interface” on page 97 for details.

e. LAN/GPIB Gateway interface: If you will be communicating with hardware 
via a LAN/GPIB Gateway, configure LAN-to-GPIB. See: “Configuring the 
Agilent E5810 LAN/GPIB Gateway interface” on page 102 for details.

f. USB/GPIB interface: If you will be communicating with hardware via a 
USB/GPIB interface, configure USB-to-GPIB. See: “Configuring the 
USB/GPIB Interface” on page 105 for details.

g. GPIB interface: If you will be communicating with hardware via GPIB, 
configure GPIB. See: “Configuring the GPIB interface” on page 107 for 
details.

h. USB interface: If you will be communicating with hardware via USB, 
configure USB. See: “Configuring the USB Interface” on page 109 for details.

Step 5. License the software (obtain authorization to use the software). There 
are four types of licenses: trial (step a.), node-locked (step b.), 
floating (step c.), or demo (step d.).

a. Trial license: 
A trial license lets you to run the software for 14 days. During this 14-day 
period, all options are enabled. This lets you to try all the optional software and 
to use your analyzer while you obtain and install permanent authorization 
(license). To use the trial license, start the 89600 software. When you are asked 
if you want to obtain authorization, click Yes, then click the Trial tab and click 
Accept Trial.

b. Node-locked license: 
For a node-locked license, follow these instructions:

1. Start the software as follows:

For an 89600 analyzer, double click the appropriate icon, or click Start > 
(All) Programs > Agilent 89600 VSA > Vector Signal Analyzer or 
Spectrum Analyzer. 

2. Follow the instructions for obtaining and installing a site key. If you 
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encounter problems or need more information, see “Installing a 
Node-Locked License,” page 187.

NOTE A site key will have to be obtained for each installed software application: 89600 
VSA, 89604 Distortion Suite and/or 89607 WLAN Test.

3. Continue with Calibrate your analyzer, Step 6.

c. Floating or Network license: 
For a floating or network license, perform these steps:

1. Set up the license server as instructed in Chapter 14 , “Setting Up a Floating 
License Server,” on page 197.

2. Set up the license client as instructed in Chapter 15 , “Setting Up a Floating 
License Client,” on page 215.

d. Demo: 
For a demo license, perform these steps:

1. Start the analyzer by double clicking the Vector Signal Analyzer icon, or 
clicking Start > (All) Programs > Agilent 89600 VSA > Vector Signal 
Analyzer.

2. Follow the instructions for accepting a Demo License.

NOTE Unlike other licenses, you must accept a Demo License each time you start the 
software. There is no limit to the number of times you can use a Demo License, but 
analyzer functionality is limited.

Step 6. Calibrate your analyzer

Before making measurements, you should calibrate (or align) your analyzer to 
optimize measurement accuracy. Refer to the 89600 online help for details on 
calibration for your analyzer configuration.

• In the Agilent 89600 VSA (or Spectrum Analyzer) window, click Utilities. 
Position the pointer on Calibration, and press F1 on the keyboard.

• In 89604 Distortion Suite, open help and look for Calibration in the Utilities 
menu or in the index.

• In 89607 WLAN Test, open help and look for Calibration in the Utilities menu 
or in the index.

NOTE For 2-RF-channel VXI measurement hardware, you can use the fixed equalization 
feature to better match the channels. See fixed equalization in the 89600 online 
help index.
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Installing 89600 Software
Installing 89600 Software
The Agilent 89600 Installation Manager program guides you through software 
installation. If you have problems installing your software, see Chapter 16 , 
“Diagnostics,” on page 221 for assistance.

There are several types of Agilent 89600 software installation (each described in 
the following sections):

• ew installation is a first-time installation. (No previous versions of the 
Agilent 89600 software have been installed.)

• Modify installation adds or removes features or adds hardware support 
components to an existing version of Agilent 89600 software.

• Repair installation repairs corrupted files on the hard drive for an existing 
version of Agilent 89600 software.

• Remove will removed the existing version of the Agilent 89600 software.

• Update installation replaces an existing version of Agilent 89600 software 
with a newer version.

ew Installation

If you are installing the Agilent 89600 software for the first time:

1. Turn on the computer. If the computer is already on, close any applications you 
have open.

NOTE To install the Agilent 89600 VSA software, you must have administrator privileges 
on the computer you are installing the Agilent 89600 VSA software on.

2. Insert the Agilent 89600 Series Vector Signal Analysis Software installation 
CD-ROM.

3. If the installation utility does not start automatically, click Start > Run, and 
type:

drive:\autoplay.exe

...where drive represents the drive containing the installation CD-ROM. Click 
OK.
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4. When the Agilent 89600 Installation Manager window opens, please read the 
Readme information.

5. After you read the ReadMe file, close it and click Install 89600 Series 
Software. Continue through the InstallShield Wizard to complete the 
installation.

6. After the 89600 Series software is installed, you will have the choice to install 
hardware support. If you do not choose to install any hardware support at this 
time, all hardware support components are available for installation at a later 
time. See “Add Hardware Support” on page 27.

7. The installation program preconfigures your system environment for 89600. 
The installation process may ask you to reboot your computer. Click OK.

IMPORTANT After rebooting you will need to be logged on with administrative privileges to 
complete the installation.

NOTE If you are installing from a remotely mounted CD-ROM drive, the remote drive 
must be configured to reconnect at logon so that the installation files can be found 
after the reboot.
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Modify Installation 

If you want to add or remove a feature or add hardware support to an existing 
version of 89600 software:

Add or remove a feature

1. Turn on the computer. If the computer is already on, close any applications you 
have open.

NOTE To modify the Agilent 89600 VSA software installation, you must have 
administrator privileges on the computer you are modifying the Agilent 89600 
VSA software installation on.

2. Insert the Agilent 89600 Series Vector Signal Analysis Software installation 
CD-ROM.

3. If the installation utility does not start automatically, click Start > Run, and 
type:

drive:\autoplay.exe

...where drive represents the drive containing the installation CD-ROM. Click 
OK.

4. When the Agilent 89600 Installation Manager window opens, click Install 
89600 Series Software. 

5. The Modify, Repair or Remove window will open. Select Modify and continue 
through the InstallShield Wizard. 
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Add Hardware Support

1. Turn on the computer. If the computer is already on, close any applications you 
have open.

NOTE To install the Agilent 89600 VSA software, you must have administrator privileges 
on the computer you are installing the Agilent 89600 VSA software on.

2. Insert the Agilent 89600 Series Software installation CD-ROM.

3. If the installation utility does not start automatically, click Start > Run, and 
type:

drive:\autoplay.exe

...where drive represents the drive containing the installation CD-ROM. Click 
OK.

4. When the Agilent 89600 Installation Manager window opens, click More 
Installation Choices. 

5. In the More Installation Choices window, click Hardware Support Menu.

6. The Hardware Support window will open. Select the components to add and 
continue through the Installation Manager. 
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Repair Installation

If you need to repair corrupt files on your hard drive affecting an existing version 
of 89600 Software:

1. Turn on the computer. If the computer is already on, close any applications you 
have open.

NOTE To install the Agilent 89600 VSA software, you must have administrator privileges 
on the computer you are repairing the Agilent 89600 VSA software on.

2. Insert the Agilent 89600 Series Vector Signal Analysis Software installation 
CD-ROM.

3. If the installation utility does not start automatically, click Start > Run, and 
type:

drive:\autoplay.exe

...where drive represents the drive containing the installation CD-ROM. Click 
OK.

4. When the Agilent 89600 Installation Manager window opens, click Install 
89600 Series Software. 

5. The Modify, Repair or Remove window will open. Select Repair and continue 
through the InstallShield Wizard. 
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Remove

If you need to remove an existing version of 89600 Software:

1. Turn on the computer. If the computer is already on, close any applications you 
have open.

NOTE To uninstall the Agilent 89600 VSA software, you must have administrator 
privileges on the computer you are uninstalling the Agilent 89600 VSA software 
from.

2. For Windows XP: Click Start > Control Panel > Add or Remove Programs.

For Windows Vista: Click Start > Control Panel > Programs and Features

3. Scroll down and select Agilent 89600 Series Software.

4. For Windows XP: Click Remove.

For Windows Vista: Click Uninstall.

5. A dialog named Remove All Agilent 89600 Series Software will pop up. Click 
Yes to uninstall the software.
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Update Installation

IMPORTANT You must uninstall any 89600 Software that is Version 7.2 or less before you install 
Version 8.0 or greater. For a Windows XP system, click Start > Control Panel > 
Add or Remove Programs. For a Windows Vista system, click Start > Control 
Panel > Programs and Features.

Each new version of the 89600 Software is shipped with an Update Installation 
Note. Use the Update Installation Note for the current version being installed.
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Introduction
Introduction
This chapter includes instructions on configuring your VXI measurement 
hardware, installing the VXI hardware modules into the VXI mainframe, 
connecting front-panel cables, and connecting the EMC grounding cable to the 
VXI chassis and laptop PC. See: Chapter 1 , “Installation Overview,” on page 13 
to learn which procedures you must perform to install your Agilent 89600-series 
product.

NOTE If you purchased an Agilent 89610, 89611, 89640, or 89641, everything in this 
chapter was done at the factory except connecting the cables for an external down 
converter or EMC grounding cable. If your analyzer uses an external down 
converter, see the appropriate illustration at the end of the chapter. If your system 
includes a laptop PC, see “Connecting EMC grounding cable” on page 74. 
Otherwise, continue with Step 2., part b, in “Set up your measurement hardware” 
on page 19.

For information on configuring other measurement hardware, see 89600 online 
help under Installation and Licensing > Hardware Setup.
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Inspecting Agilent 89600-series VXI modules
The Agilent 89600-series VXI modules were carefully inspected both 
mechanically and electrically before shipment. They should be free of marks or 
scratches upon receipt.

If a module was damaged in transit, do the following:

• Save all packing materials.

• File a claim with the carrier

• Call your Agilent Technologies sales and service office (phone numbers 
available at www.agilent.com/find/89600).

NOTE If you ordered a 2-channel analyzer, the two E1438 or E1439 modules must have 
the same amount of memory.
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Setting up Agilent 89600 series VXI mainframe and 
modules

CAUTION To protect circuits from static discharge, observe anti-static techniques whenever 
handling the Agilent 89600-series VXI modules.

IMPORTANT For safety, environment, regulatory, and mains power specifications, see the user 
or service manual for your VXI mainframe.

Set logical addresses

This section includes information on setting logical addresses.

To set logical addresses:

1. Check the logical address switches for each VXI module. (See Figure 3-1 
through Figure 3-5 on the following pages.) Except for the E2730 and E2731 
modules, each module in the system must have a unique logical address. The 
following table lists the factory default settings (the addresses for 
second-channel 89605, E1438, and E1439 modules must be different). 

 For 2-channel systems, the addresses must be different for the two modules

2. If you need to change the address setting for a module, use a small screwdriver 
or similar tool to move the switches to the correct position. The figures on the 
following pages show the location and default setting of the logical address 
switches for each module.

VXI module Default address Figure showing address switch 
location

Agilent 89605 14 (0000 1110) Figure 3-1 on page 35

Agilent E2730 or E2731 255 (1111 1111) Figure 3-2 on page 35

Agilent E1439 194 (1100 0010) Figure 3-3 on page 36

Agilent 89606 15 (0000 1111) Figure 3-4 on page 37

Agilent E1438 192 (1100 0000) Figure 3-5 on page 38
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Setting up Agilent 89600 series VXI mainframe and modules
Figure 3-1 89605 Input module -- address 14 (000 1110)

Figure 3-2 E2730 or E2731 RF Tuner module -- address 255 (1111 1111) (This setting 
enables dynamic addressing, so that the address is automatically assigned.)

For 2-channel systems, the addresses must be different for the two E1439 modules.

0
1

Logical Address

1 2 3 4 5 6 7 8

1 2 3 4 5 6 7 8

ON

1 2 3 4 5 6 7 8

0
1

Logical Address
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Setting up Agilent 89600 series VXI mainframe and modules
Figure 3-3 E1439 ADC module -- address 194 (1100 0010)

0
1

Logical Address
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Setting up Agilent 89600 series VXI mainframe and modules
Figure 3-4 89606 module -- address 15 (0000 1111)

0
1

Logical Address
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Setting up Agilent 89600 series VXI mainframe and modules
For 2-channel systems, the addresses must be different for the two E1438 modules.

Figure 3-5 E1438 ADC module -- address 192 (1100 0000)

0
1

Logical Address
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Installing modules in the mainframe
Installing modules in the mainframe
Refer to Figure 3-6 for installing modules in the mainframe.

To install modules in the mainframe:

1. Unpack your VXI mainframe.

IMPORTANT For safety, environment, regulatory, and mains power specifications, see the user 
or service manual for your VXI mainframe.

2. Set the mainframe’s power switch to off (0).

CAUTION Be sure the power is off before installing modules in the mainframe. Installing or 
removing a module with power on may damage components in the module.

3. Be sure to put each module in the correct slot, see "Configuring your VXI 
hardware" (page 40).

4. Place the module’s card edges (top and bottom) into the module guides in the 
slot.

5. Install the module into the mainframe. (Note: the E2730 module does not have 
insertion/extraction levers.)

Figure 3-6 Installing a VXI module in the mainframe

1

2

3

Tighten the two
retaining screws

Extraction
levers

Slide the module into the
mainframe until it plugs into
the backplane connectors

Seat the module by
pushing in the
extraction levers
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Installing modules in the mainframe
Configuring your VXI hardware

Your Agilent 89600 series VXI modules must be installed in a specified order in 
the VXI mainframe. There are eight possible configurations:

• Agilent 89610 Single-channel DC-40 MHz analyzer (page 41)

• Agilent 89610 Two-channel DC-40 MHz analyzer (page 42)

• Agilent 89611 70 MHz IF analyzer (page 43)

• Agilent 89611 Two-channel 70 MHz IF analyzer (page 44)

• Agilent 89640 DC-2.7 GHz analyzer (page 45)

• Agilent 89640 DC-2.7 GHz analyzer with second IF/baseband channel 
(page 46)

• Agilent 89640 DC-2.7 GHz analyzer with second RF channel (page 47)

• Agilent 89641 DC-6 GHz analyzer (page 48)

• Agilent 89641 DC-6 GHz analyzer with second IF/baseband channel (page 49)

• Agilent 89641 DC-6 GHz analyzer with second RF channel (page 50)

NOTE If you are using a VXI mainframe with more than 4 slots, the Agilent E8491 
module or VXI imbedded PC must be installed in slot 0. The other 89600 series 
modules are not required to be installed in slots 1 through 3. However, the modules 
must be installed relative to each other in the order described in Figure 3-7 through 
Figure 3-16.
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Installing modules in the mainframe
89610 Single-channel DC-40 MHz analyzer

This configuration includes 3 modules (Figure 3-7), which must be installed in this 
order:

Note that this illustration shows an 89606B input module. Your analyzer might 
include an 89606A input; the configuration is the same for both modules.

Figure 3-7 89610 DC-40 MHz analyzer

Mainframe slot VXI module

0 Agilent E8491 Interconnect 

1 Agilent 89606 Baseband Input

2 Agilent E1438 ADC

E8491 89606 E1438
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Installing modules in the mainframe
89610 Two-channel DC-40 MHz analyzer

This configuration includes 4 modules (Figure 3-8), which must be installed in this 
order:

Note that this illustration shows an 89606B input module. Your analyzer might 
include an 89606A input module. The configuration is the same for both modules.

Figure 3-8 89610 Two-channel DC-40 MHz analyzer

Mainframe slot VXI module

0 Agilent E8491 Interconnect 

1 Agilent 89606 Baseband Input

2 Agilent E1438 ADC

3 Agilent E1438 ADC

E8491 89606 E1438 E1438
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Installing modules in the mainframe
89611 70 MHz IF analyzer

This configuration includes 3 modules (Figure 3-9), which must be installed in this 
order:

Note that this illustration shows an 89605B input module. Your analyzer might 
include an 89605A input. The configuration is the same for both modules.

Figure 3-9 89611 analyzer

Mainframe slot VXI module

0 Agilent E8491 Interconnect 

1 Agilent 89605 RF Input

2 Agilent E1439 RF ADC

E8491 89605 E1439
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Installing modules in the mainframe
89611 Two-channel 70 MHz IF analyzer

This configuration includes 5 modules (Figure 3-10), which must be installed in 
this order:

NOTE The 2-channel 89611 requires an 89605B module for the second channel (slot 3 in 
Figure 3-10). The module for channel 1 can be either an 89605B or A.

Figure 3-10 2-channel 89611 analyzer

Mainframe slot VXI module

0 Agilent E8491 Interconnect 

1 Agilent 89605 RF Input

2 Agilent E1439 RF ADC

3 Agilent 89605B RF Input

4 Agilent E1439 RF ADC

E8491 89605 E1439 89605B E1439
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Installing modules in the mainframe
89640 DC-2.7 GHz analyzer

This configuration includes 4 modules (Figure 3-11), which must be installed in 
this order:

Figure 3-11 89640 DC-2.7 GHz analyzer

Mainframe slot VXI module

0 Agilent E8491 Interconnect 

1 Agilent 89605 RF Input

2 Agilent E2730 RF Tuner

3 Agilent E1439 RF ADC

E8491 89605 E2730 E1439
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Installing modules in the mainframe
89640 DC-2.7 GHz analyzer with second IF/baseband channel

This configuration includes 6 modules (Figure 3-12), which must be installed in 
this order:

NOTE The 2-channel 89640 requires an 89605B module for the second channel (slot 4 in 
Figure 3-12). The module for channel 1 can be either an 89605B or A.

Figure 3-12 89640 DC-2.7 GHz analyzer with second IF/baseband channel

Mainframe slot VXI module

0 Agilent E8491 Interconnect 

1 Agilent 89605 RF Input

2 Agilent E2730 RF Tuner

3 Agilent E1439 RF ADC

4 Agilent 89605B RF Input

5 Agilent E1439 RF ADC

E8491 89605 E2730 E1439 89605B E1439
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Installing modules in the mainframe
89640 DC-2.7 GHz analyzer with second RF channel

This configuration includes 7 modules (Figure 3-13), which must be installed in 
this order:

NOTE The 2-channel 89640 requires E2730B modules for both channels and an 89605B 
module for the second channel (slot 4 in Figure 3-13). The module for channel 1 
can be either an 89605B or A.

Figure 3-13 89640 DC-2.7 GHz analyzer with second RF channel

Mainframe slot VXI module

0 Agilent E8491 Interconnect 

1 Agilent 89605 RF Input

2 Agilent E2730 RF Tuner

3 Agilent E1439 RF ADC

4 Agilent 89605B RF Input

5 Agilent E2730 RF Tuner

6 Agilent E1439 RF ADC

E8491 89605 E2730B E1439 89605B E2730B E1439
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Installing modules in the mainframe
89641 DC-6 GHz analyzer

This configuration includes 4 modules (Figure 3-14), which must be installed in 
this order:

Figure 3-14 89641 DC-6 GHz analyzer

Mainframe slot VXI module

0 Agilent E8491 Interconnect 

1 Agilent 89605 RF Input

2 Agilent E2731 RF Tuner

3 Agilent E1439 RF ADC

E8491 89605 E1439E2731
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Installing modules in the mainframe
89641 DC-6 GHz analyzer with second IF/baseband channel

This configuration includes 6 modules (Figure 3-15), which must be installed in 
this order:

NOTE The 2-channel 89641 requires an 89605B module for the second channel (slot 4 in 
Figure 3-15). The module for channel 1 can be either an 89605 B or A.

Figure 3-15 89641 DC-6 GHz analyzer with second IF/baseband channel

Mainframe slot VXI module

0 Agilent E8491 Interconnect 

1 Agilent 89605 RF Input

2 Agilent E2731 RF Tuner

3 Agilent E1439 RF ADC

4 Agilent 89605B RF Input

5 Agilent E1439 RF ADC

E8491 89605 E1439E2731 89605B E1439
Chapter 3  49



Setting Up VXI Hardware
Installing modules in the mainframe
89641 DC-6 GHz analyzer with second RF channel

This configuration includes 7 modules (Figure 3-16), which must be installed in 
this order:

NOTE The 2-channel 89641 requires E2731B modules for both channels and an 89605B 
module for the second channel (slot 4 in Figure 3-16). The module for channel 1 
can be either an 89605B or A.

Figure 3-16 89641 DC-6 GHz analyzer with second RF channel

Mainframe slot VXI module

0 Agilent E8491 Interconnect 

1 Agilent 89605 RF Input

2 Agilent E2731 RF Tuner

3 Agilent E1439 RF ADC

4 Agilent 89605B RF Input

5 Agilent E2731 RF Tuner

6 Agilent E1439 RF ADC

E8491 89605 E1439E2731B 89605B E1439E2731B
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Connecting front panel cables
Connecting front panel cables
The illustrations on the following pages show the cable connections for 11 
configurations of Agilent 89600 series analyzers. Below each illustration is a table 
listing each cable, termination, and adapter with a description and part number.

For a single-channel 89610A, see page 52.

For a two-channel 89610A, see page 53.

For an 89610A with external down converter, see page 54.

For a single-channel 89611A, see page 55.

For an 89611A with PSA option H70, see page 56

For a two-channel 89611A, see page 59.

For a single-channel 89640A, see page 61.

For an 89640A with second IF/baseband channel, see page 62.

For an 89640A with second RF channel, see page 64.

For an 89640A with external down converter, see page 66.

For a single-channel 89641A, see page 67.

For an 89641A with second IF/baseband channel, see page 68.

For an 89641A with second RF channel, see page 70.

For an 89641A with external down converter, see page 72.

NOTE If you change or replace any cables, be sure to do a calibration to compensate for 
variance in cable characteristics before you make measurements.
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Connecting front panel cables
Cable connections, 89610

 

After you have installed and configured the IEEE-1394 interface in your PC, you 
must connect the IEEE 1394 interface cable between the PC and one of the E8491 
module IEEE ports. If you are using a laptop PC, you must also connect the EMC 
grounding cable. See “Connecting EMC grounding cable” on page 74.

Continue with Step 2., part b, in “Set up your measurement hardware” on page 19.

Description Connection Part number

1 black BNC-BNC cable (172 
mm)

89606 10 MHz Ref Out to E1438A Ext Clock/Ref 8120-6237

2 black BNC-BNC cable 
(267mm)

89606 To ADC Analog In to E1438 Analog In 8121-0133

E143889606B

1

2
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Connecting front panel cables
Cable connections, two-channel 89610

The following cable connections for the 2-channel 89610 are especially important:

• You must connect one set of 
Clock connectors and one set 
of Sync connectors between 
the two E1438 modules. The 
two cables used for these 
connections must be exactly 
the same length to avoid 
timing and synchronization 
problems.

• You must connect the 10 MHz 
Ref Out from the 89606 
module to the Ext Clock/Ref 
connector on the E1438 
module adjacent to the 89606 
module.

• If you use external trigger, you must connect the trigger signal to the channel 1 
ADC (E1438) trigger input.

After you have installed and configured the IEEE-1394 interface in your PC, you 
must connect the IEEE 1394 interface cable between the PC and one of the E8491 
module IEEE ports. If you are using a laptop PC, you must also connect the EMC 
grounding cable. See “Connecting EMC grounding cable” on page 74.

Continue with Step 2., part b, in “Set up your measurement hardware” on page 19.

Description Connection Part number

1 orange SMB-SMB cable 
(100 mm)

E1438 #1 Clock to E1438 #2 Clock 03585-61603

2 orange SMB-SMB cable 
(100 mm)

E1438 #1 Sync to E1438 #2 Sync 03585-61603

3 50 ohm SMB term (Qty 4) Unused E1438 Clock & Sync connectors 1250-0676

4 black BNC-BNC cable (172 mm) 89606 10 MHz Ref Out to E1438A #1 Ext 
Clock/Ref

8120-6237

5 black BNC-BNC cable (215 mm) 89606 To ADC 2 Analog In to E1438A #2 
Analog In

8121-0132

6 black BNC-BNC cable (267 mm) 89606 To ADC 1 Analog In to E1438A #1 
Analog In

8121-0133

3

6

5

1

3

2

4

89606B E1438 E1438
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Connecting front panel cables
Cable connections, 89610 with external down converter

After you have installed and configured the IEEE-1394 interface in your PC, you 
must connect the IEEE 1394 interface cable between the PC and one of the E8491 
module IEEE ports. If you are using a laptop PC, you must also connect the EMC 
grounding cable. See “Connecting EMC grounding cable” on page 74.

Continue with Step 2., part b, in “Set up your measurement hardware” on page 19.

Description Connection Part number

1 orange SMB-SMB cable (100 mm) 1438 #1 to E1438 #2 Clock 03585-61603

2 orange SMB-SMB cable (100 mm) E1438 #1 to E1438 #2 Sync 03585-61603

3 50 ohm SMB term (Qty 4) Unused E1438 Clock & Sync connectors 1250-0676

4 black BNC-BNC cable (172 mm) 89606 to E1438 Ext Clock/Ref 8120-6237

5 black BNC-BNC cable (215 mm) 89606 to E1438 #2 Analog In 8121-0132

6 black BNC-BNC cable (267mm) 89606 to E1438 #1 Analog In 8121-0133

7 varies down converter I Out to 89606 Ch1 In user supplied

8 varies down converter Q Out to 89606 Ch2 In user supplied

9 BNC 89606 10 MHz Ref Out to down converter 
Ext Ref In

user supplied

10 varies down converter RF input user supplied

3

6

5

1

3

2

4

89606B E1438 E1438External I/ Q Quadrature
     Down converter

(Agilent 71910
   with 70911)

RF In

7

8

9

10

I out

Q out

Ext Ref In
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Connecting front panel cables
Cable connections, 89611

After you have installed and configured the IEEE-1394 interface in your PC, you 
must connect the IEEE 1394 interface cable between the PC and one of the E8491 
module IEEE ports. If you are using a laptop PC, you must also connect the EMC 
grounding cable. See “Connecting EMC grounding cable” on page 74.

Continue with Step 2., part b, in “Set up your measurement hardware” on page 19.

Description Connection Part number

1 SMA-SMA cable (requires a type 
N-SMA adapter)

from external tuner IF output to 89605 
Ch 1 Input

8121-0790 (cable) 
1250-1250 (adapter)

2 black BNC-BNC cable (215 mm) from 89605 To ADC Analog In to 
E1439 Analog In

8121-0132

3 black BNC-BNC cable (215 mm) from 89605 10 MHz Ref Out to E1439 
Ext Clock/Ref

8121-0132

4 BNC-BNC cable from 89605 10 MHz Ref Out to 
external tuner Ext Ref In 
(or from external tuner10 MHz Ref Out 
to 89605 Ext Ref In)

user supplied

5 varied input to down converter user supplied

External down converter

70 MHz
IF Out

Ext
Ref
In

Input

4

51

2

3

89605B E1439
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Connecting front panel cables
Cable connections, 89611 with PSA Option H70

This configuration replaces the VXI tuner module with an Agilent PSA option 
H70.

After you have installed and configured the IEEE-1394 interface in your PC, you 
must connect the IEEE 1394 interface cable between the PC and one of the E8491 
module IEEE ports. If you are using a laptop PC, you must also connect the EMC 
grounding cable. See “Connecting EMC grounding cable” on page 74.

Continue with Step 2., part b, in “Set up your measurement hardware” on page 19.

Agilent PSA option H70

10 MHz Out 70 MHz
 IF Out

Agilent 89611A

1

4

5

6

connect either LAN or GPIB,
not both

2

3

89605B E1439

CONTROL

MEASURE

SYSTEM

LOCAL

Description Connection Part number

1 SMA-SMA cable with 
a type N-SMA adapter

from PSA 70 MHz IF output to 89605 Ch 1 Input 8121-0790 (cable) 
1250-1250 (adapter)

2 black BNC-BNC 
cable (215 mm)

from 89605 To ADC Analog In to E1439 Analog In 8121-0132

3 black BNC-BNC 
cable (215 mm)

from 89605 10 MHz Ref Out to E1439 Ext Clock/Ref 8121-0132

4 BNC-BNC cable from 89605 10 MHz Ref Out to PSA Ext Ref In 
(or from PSA 10 MHz Ref Out to 89605 Ext Ref In)

user supplied

5 varies PSA RF input user supplied

6 LAN or GPIB cable LAN or GPIB connector to PC (not both) varies
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Connecting front panel cables
Cable connections, 89611 with ESA Option H70

This configuration replaces the VXI tuner module with an Agilent ESA option 
H70.

Note that the cards may be installed in a different order in the slots, so the GPIB 
connector and the 70 MHz Out connector may be in different locations on the rear 
panel.

After you have installed and configured the IEEE-1394 interface in your PC, you 
must connect the IEEE 1394 interface cable between the PC and one of the E8491 
module IEEE ports. If you are using a laptop PC, you must also connect the EMC 

Agilent ESA option H70

Agilent 89611A

1

4

5

6

2

3

89605B E1439

Description Connection Part number

1 SMA-SMA cable with 
a type N-SMA adapter

from ESA 70 MHz IF output to 89605 Ch 1 Input 8121-0790 (cable) 
1250-1250 
(adapter)

2 black BNC-BNC cable 
(215 mm)

from 89605 To ADC Analog In to E1439 Analog In 8121-0132

3 black BNC-BNC cable 
(215 mm)

from 89605 10 MHz Ref Out to E1439 Ext Clock/Ref 8121-0132

4 BNC-BNC cable from 89605 10 MHz Ref Out to ESA Ext Ref In 
(or from ESA 10 MHz Ref Out to 89605 Ext Ref In)

user supplied

5 varies ESA RF input user supplied

6 GPIB cable ESA GPIB connector to PC varies
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Connecting front panel cables
grounding cable. See “Connecting EMC grounding cable” on page 74.

Continue with Step 2., part b, in “Set up your measurement hardware” on page 19.
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Connecting front panel cables
Cable connections, two-channel 89611

NOTE If you use external trigger, you must connect the trigger signal to the channel 1 
ADC (E1439) trigger input.

The interconnections for the 10 MHz reference signals can be different, but you 
must ensure that all the hardware is referenced to one signal.

1

2
3

4

5

3

5

4
6

External down converter 1

70 MHz
IF Out

  Ext Ref In

Input

External down converter 2

70 MHz
IF Out

  Ext Ref In

Input

89605B 89605BE1439 E1439C

7

8

89611A

  Ext Ref Out

10

9

Description Connection Part number

1 orange SMB-SMB 
cable (100 mm)

E1439 #1 Clock to E1439 #2 Clock 03585-61603

2 orange SMB-SMB 
cable (100 mm)

E1439 #1 Sync to E1439 #2 Sync 03585-61603

3 50 ohm SMB term (Qty 
4)

Unused E1438 Clock & Sync connectors 1250-0676

4 black BNC-BNC cable 
(215 mm)

89605 To ADC Analog In to E1439 Analog In 8121-0132

5 black BNC-BNC cable 
(215 mm)

from 89605 10 MHz Ref Out to E1439 Ext Clock/Ref 8121-0132

6 black BNC-BNC cable 
(215 mm)

from 89605 1 10 MHz Ref Out to89605 2 Ext Ref In 8121-0132

7 varies external down converter 70 MHz IF Out to 89605 Ch 1 
Input

user supplied

8 varies input to down converter user supplied

9 varies from 89605 #2 10 MHz Ref Out to external down converter 
#1 Ext Ref In

user supplied
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Connecting front panel cables
After you have installed and configured the IEEE-1394 interface in your PC, you 
must connect the IEEE 1394 interface cable between the PC and one of the E8491 
module IEEE ports. If you are using a laptop PC, you must also connect the EMC 
grounding cable. See “Connecting EMC grounding cable” on page 74.

Continue with Step 2., part b, in “Set up your measurement hardware” on page 19.

10 varies from external down converter #1 10 MHz Ref Out to 
external down converter #2 Ext Ref In

user supplied

Description Connection Part number
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Connecting front panel cables
Cable connections, 89640

NOTE It is important that you use the semi-rigid SMA cables shipped with the analyzer. 
Using other cables could degrade measurement accuracy.

After you have installed and configured the IEEE-1394 interface in your PC, you 
must connect the IEEE 1394 interface cable between the PC and one of the E8491 
module IEEE ports. If you are using a laptop PC, you must also connect the EMC 
grounding cable. See “Connecting EMC grounding cable” on page 74.

Continue with Step 2., part b, in “Set up your measurement hardware” on page 19.

Description Connection Part number

1 semi-rigid SMA cable 89605 10 MHz Ext Ref Out to E2730 10 MHz 
Ext Ref

for 89605B, 89605-61693 
for 89605A, 89605-61691

2 semi-rigid SMA cable E2730 70 MHz IF Out to 89605 From 70 MHz 
IF Out

89605-61691

3 semi-rigid SMA cable 89605 To RF In to E2730 RF In 89605-61692

4 N-to-BNC adapter 89605 Ch 1 Input (user signal) 1250-0780

5 black BNC-BNC cable 
(215 mm)

89605 10 MHz Ref Out to E1439 Ext Clock/Ref 8121-0132

6 black BNC-BNC cable 
(215 mm)

89605 To ADC Analog In to E1439 Analog In 8121-0132

7 coax SMA cap E2730 1st LO In/Out and 2nd LO In/Out 1250-0590

3

6
2
1
5

4

7
89605B E1439
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Connecting front panel cables
Cable connections, 89640 with second IF/baseband channel

NOTE If you use external trigger, you must connect the trigger signal to the channel 1 
ADC (E1439) trigger input. 
 
It is important that you use the semi-rigid SMA cables shipped with the analyzer. 
Using other cables could degrade measurement accuracy.

1

9

3
4
5
6
7

8
9

10

6

3

2
2

11

Description Connection Part number

1 semi-rigid SMA cable 89605 To RF In to E2730 RF In 89605-61692

2 N-to-BNC adapter 89605 Ch 1 Input (user signal) 1250-0780

3 black BNC-BNC cable 
(215 mm)

89605 To ADC Analog In to E1439 Analog 
In

8121-0132

4 semi-rigid SMA cable E2730 70 MHz IF Out to 89605 From 70 
MHz IF Out

89605-61691

5 semi-rigid SMA cable 89605 10 MHz Ext Ref Out to E2730 10 MHz 
Ext Ref

for 89605B, 89605-61693 
for 89605A, 89605-61691

6 black BNC-BNC cable 
(215 mm)

89605 10 MHz Ref Out to E1439 Ext 
Clock/Ref

8121-0132

7 black BNC-BNC cable 
(215 mm)

89605-1 10 MHz Ext Ref Out to 89605-2 Ext 
Ref In

8121-0132

8 orange SMB-SMB cable 
(100 mm)

E1439 #1 Clock to E1439 #2 Clock 03585-61603

9 50 ohm SMB term (Qty 
4)

Unused E1438 Clock & Sync connectors 1250-0676

10 orange SMB-SMB cable 
(100 mm)

E1439 #1 Sync to E1439 #2 Sync 03585-61603

11 coax SMA cap E2730 1st LO In/Out and 2nd LO In/Out 1250-0590
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Connecting front panel cables
After you have installed and configured the IEEE-1394 interface in your PC, you 
must connect the IEEE 1394 interface cable between the PC and one of the E8491 
module IEEE ports. If you are using a laptop PC, you must also connect the EMC 
grounding cable. See “Connecting EMC grounding cable” on page 74.

Continue with Step 2., part b, in “Set up your measurement hardware” on page 19.
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Connecting front panel cables
Cable connections, 89640 with second RF channel

NOTE If you use external trigger, you must connect the trigger signal to the channel 1 
ADC (E1439) trigger input. It is important that you use the semi-rigid SMA cables 
shipped with the analyzer; using other cables could degrade measurement 
accuracy.

1

9

3
4
5
6
7

2 8
9

10

6

3

2

4
5

1

11

12

Description Connection Part number

1 semi-rigid SMA cable 89605 To RF In to E2730 RF In 89605-61692

2 N-to-BNC adapter 89605 Ch 1 Input (user signal) 1250-0780

3 black BNC-BNC cable 
(215 mm)

89605 To ADC Analog In to E1439 Analog In 8121-0132

4 semi-rigid SMA cable E2730 70 MHz IF Out to 89605 From 70 
MHz IF Out

89605-61691

5 semi-rigid SMA cable 89605 10 MHz Ext Ref Out to E2730 10 MHz 
Ext Ref

for 89605B, 89605-61693 
for 89605A, 89605-61691

6 black BNC-BNC cable 
(215 mm)

89605 10 MHz Ref Out to E1439 Ext 
Clock/Ref

8121-0132

7 black BNC-BNC cable 
(215 mm)

89605-1 10 MHz Ext Ref Out to 89605-2 Ext 
Ref In

8121-0132

8 orange SMB-SMB cable 
(100 mm)

E1439 #1 Clock to E1439 #2 Clock 03585-61603

9 50 ohm SMB term (Qty 
4)

Unused E1438 Clock & Sync connectors 1250-0676

10 orange SMB-SMB cable 
(100 mm)

E1439 #1 Sync to E1439 #2 Sync 03585-61603

11 semi-rigid SMA cable E2730 #1 2nd LO In/Out to E2730 #2 2nd 
LO In/Out

89605-61696

12 semi-rigid SMA cable E2730 #1 1st LO In/Out to E2730 #2 1st LO 
In/Out

89605-61696
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After you install and configure the IEEE-1394 interface in your PC, you must 
connect an IEEE 1394 cable between the PC and an E8491 module IEEE ports. If 
you are using a laptop PC, you must also connect the EMC grounding cable. See 
“Connecting EMC grounding cable” on page 74.

CAUTION If you reconfigure a 2-RF-channel 89640 to a single-channel, you must connect 
coax SMA caps (Agilent part number 1250-0590) to the LO connectors on the 
E7230 module.

Continue with Step 2., part b, in “Set up your measurement hardware” on page 19.
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Cable connections, 89640 with external down converter

NOTE It is important that you use the semi-rigid SMA cables shipped with the analyzer. 
Using other cables could degrade measurement accuracy.

After you have installed and configured the IEEE-1394 interface in your PC, you 
must connect the IEEE 1394 interface cable between the PC and one of the E8491 
module IEEE ports. If you are using a laptop PC, you must also connect the EMC 
grounding cable. See “Connecting EMC grounding cable” on page 74.

Continue with Step 2., part b, in “Set up your measurement hardware” on page 19.

Description Connection Part number

1 semi-rigid SMA cable 89605 10 MHz Ext Ref Out to E2730 10 MHz 
Ext Ref

for 89605A, 89605-61691

for 89605B, 89605-61693

2 semi-rigid SMA cable E2730 70 MHz IF Out to 89605 From 70 
MHz IF Out

89605-61691

3 semi-rigid SMA cable 89605 To RF In to E2730 RF In 89605-61692

4 varies external down converter IF Out to 89605 
Ch1 Input 

varies

5 black BNC-BNC cable 
(215 mm)

89605 10 MHz Ref Out to E1439 Ext 
Clock/Ref

8121-0132

6 black BNC-BNC cable 
(215 mm)

89605 To ADC Analog In to E1439 Analog 
In

8121-0132

7 varies input to external down converter varies

8 BNC-BNC cable 89605 10 MHz Ext Ref Out to external down 
converter Ext Ref In

varies

9 coax SMA cap E2730 1st LO In/Out and 2nd LO In/Out 1250-0590

Ext Ref In

IF Out

External Down Converter

Input

89640A

7

8

3

6
2
1
5

4

9
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Cable connections, 89641

NOTE It is important that you use the semi-rigid SMA cables shipped with the analyzer. 
Using other cables could degrade measurement accuracy.

After you have installed and configured the IEEE-1394 interface in your PC, you 
must connect the IEEE 1394 interface cable between the PC and one of the E8491 
module IEEE ports. If you are using a laptop PC, you must also connect the EMC 
grounding cable. See “Connecting EMC grounding cable” on page 74.

Continue with Step 2., part b, in “Set up your measurement hardware” on page 19.

1
2

4
5
6
7

3

8

Description Connection Part number

1 semi-rigid SMA cable E2731 FE RF Out to E2731 2.7GHz RF In E2731-61601

2 semi-rigid SMA cable 89605 To RF In to E2731 6 GHz In 89605-61694

3 N-to-BNC adapter 89605 Ch 1 Input (user signal) 1250-0780

4 black BNC-BNC cable 
(215 mm)

89605 To ADC Analog In to E1439 Analog 
In

8121-0132

5 semi-rigid SMA cable E2731 70 MHz IF Out to 89605 From 70 
MHz IF Out

89605-61691

6 semi-rigid SMA cable 89605B 10 MHz Ext Ref Out to E2731 10 
MHz Ext Ref

for 89605B, 89605-61693 
for 89605A, 89605-61691

7 black BNC-BNC cable 
(215 mm)

89605 10 MHz Ref Out to E1439 Ext 
Clock/Ref

8121-0132

8 coax SMA cap E2731 1st LO In/Out and 2nd LO In/Out 1250-0590
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Cable connections, 89641 with second IF/baseband channel

NOTE If you use external trigger, you must connect the trigger signal to the channel 1 
ADC (E1439) trigger input. 
 
It is important that you use the semi-rigid SMA cables shipped with the analyzer. 
Using other cables could degrade measurement accuracy.

After you have installed and configured the IEEE-1394 interface in your PC, you 

1
2

4 4

5
6
7
8
9

10

11

8
5

3
3

12

Description Connection Part number

1 semi-rigid SMA cable E2731 FE RF Out to E2731 2.7GHz RF 
In

E2731-61601

2 semi-rigid SMA cable 89605 To RF In to E2731 6 GHz In 89605-61694

3 N-to-BNC adapter 89605 Ch 1 Input (user signal) 1250-0780

4 50 ohm SMB term (Qty 4) Unused E1439 Clock & Sync connectors 1250-0676

5 black BNC-BNC cable (215 
mm)

89605 To ADC Analog In to E1439 
Analog In

8121-0132

6 semi-rigid SMA cable E2731 70 MHz IF Out to 89605 From 70 
MHz IF Out

89605-61691

7 semi-rigid SMA cable 89605 10 MHz Ext Ref Out to E2731 10 
MHz Ext Ref

for 89605B, 89605-61693 
for 89605A, 89605-61691

8 black BNC-BNC cable (215 
mm)

89605 10 MHz Ref Out to E1439 Ext 
Clock/Ref

8121-0132

9 black BNC-BNC cable (215 
mm)

89605 #1 10 MHz Ref Out to 89605 #2 
Ext Ref In

8121-0132

10 orange SMB-SMB cable 
(100 mm)

E1438 #1 Clock to E1438 #2 Clock 03585-61603

11 orange SMB-SMB cable 
(100 mm)

E1438 #1 Sync to E1438 #2 Sync 03585-61603

12 coax SMA cap E2731 1st LO In/Out and 2nd LO In/Out 1250-0590
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must connect the IEEE 1394 interface cable between the PC and one of the E8491 
module IEEE ports. If you are using a laptop PC, you must also connect the EMC 
grounding cable. See “Connecting EMC grounding cable” on page 74.

Continue with Step 2., part b, in “Set up your measurement hardware” on page 19.
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Cable connections, 89641 with second RF channel

NOTE If you use external trigger, you must connect the trigger signal to the channel 1 
ADC (E1439) trigger input. 
 
It is important that you use the semi-rigid SMA cables shipped with the analyzer. 
Using other cables could degrade measurement accuracy.

1
2

4

5
6
7
8

9

3

4
10

11

8

5

3

6
7

12

13

1
2

Description Connection Part number

1 semi-rigid SMA cable E2731 FE RF Out to E2731 2.7GHz RF In E2731-61601

2 semi-rigid SMA cable 89605 To RF In to E2731 6 GHz In 89605-61694

3 N-to-BNC adapter 89605 Ch 1 Input (user signal) 1250-0780

4 50 ohm SMB term (Qty 
4)

Unused E1439 Clock & Sync connectors 1250-0676

5 black BNC-BNC cable 
(215 mm)

89605 To ADC Analog In to E1439 Analog In 8121-0132

6 semi-rigid SMA cable E2731 70 MHz IF Out to 89605 From 70 
MHz IF Out

89605-61691

7 semi-rigid SMA cable 89605 10 MHz Ext Ref Out to E2731 10 MHz 
Ext Ref

for 89605B, 89605-61693 
for 89605A, 89605-61691

8 black BNC-BNC cable 
(215 mm)

89605 10 MHz Ref Out to E1439 Ext 
Clock/Ref

8121-0132

9 black BNC-BNC cable 
(215 mm)

89605 #1 10 MHz Ref Out to 89605 #2 Ext 
Ref In

8121-0132

10 orange SMB-SMB cable 
(100 mm)

E1438 #1 Clock to E1438 #2 Clock 03585-61603

11 orange SMB-SMB cable 
(100 mm)

E1438 #1 Sync to E1438 #2 Sync 03585-61603

12 semi-rigid SMA cable E2731 #1 2nd LO In/Out to E2731 #2 2nd 
LO In/Out

89605-61696
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After you have installed and configured the IEEE-1394 interface in your PC, you 
must connect the IEEE 1394 interface cable between the PC and one of the E8491 
module IEEE ports. If you are using a laptop PC, you must also connect the EMC 
grounding cable. See “Connecting EMC grounding cable” on page 74.

CAUTION If you reconfigure a 2-RF-channel 89641 to a single-channel configuration, you 
must connect coax SMA caps (Agilent part number 1250-0590) to the LO 
connectors on the E7231 module.

Continue with Step 2., part b, in “Set up your measurement hardware” on page 19.

13 semi-rigid SMA cable E2731 #1 1st LO In/Out to E2731 #2 1st LO 
In/Out

89605-61696

Description Connection Part number
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Cable connections, 89641 with external down converter

NOTE It is important that you use the semi-rigid SMA cables shipped with the analyzer. 
Using other cables could degrade measurement accuracy.

After you have installed and configured the IEEE-1394 interface in your PC, you 
must connect the IEEE 1394 interface cable between the PC and one of the E8491 
module IEEE ports. If you are using a laptop PC, you must also connect the EMC 
grounding cable. See “Connecting EMC grounding cable” on page 74.

Description Connection Part number

1 semi-rigid SMA cable E2731 FE RF Out to E2731 2.7 GHz In E2731-61601

2 semi-rigid SMA cable 89605 To RF In to E2731 RF In 89605-61692

3 varies external down converter IF Out to 89605 Ch1 
Input

varies

4 black BNC-BNC cable 
(215 mm)

89605 To ADC Analog In to E1439 Analog In 8121-0132

5 semi-rigid SMA cable E2731 70 MHz IF Out to 89605 From 70 MHz 
IF Out

89605-61691

6 semi-rigid SMA cable 89605 10 MHz Ext Ref Out to E2731 10 MHz 
Ext Ref

for 89605A, 89605-61691

for 89605B, 89605-61693

7 black BNC-BNC cable 
(215 mm)

89605 10 MHz Ref Out to E1439 Ext Clock/Ref 8121-0132

8 varies input to external down converter varies

9 BNC-BNC cable 89605 10 MHz Ext Ref Out to external down 
converter Ext Ref In

varies

9 coax SMA cap E2731 1st LO In/Out and 2nd LO In/Out 1250-0590

Ext Ref In

IF Out

External Down Converter

Input

89641A

8

9

1
2

4
5
6
7

3
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Continue with Step 2., part b, in “Set up your measurement hardware” on page 19.
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Connecting EMC grounding cable
When the 89600S is operating and configured with a laptop PC, the EMC 
grounding cable (Agilent part number 89600-60006) must be installed as described 
below. This cable is necessary to ensure conformity to European EMC immunity 
requirements according to IEC 61326-1. The EMC grounding cable is used in 
addition to the IEEE-1394 (Firewire) cable (Agilent part number 8121-1944).

The EMC grounding cable is provided with the 89600S when option 201 
(IEEE-1394 cable and VXI interface for use with user-supplied laptop PC) or 
option 204 (Laptop PC w/VSA SW, IEEE-1394 I/F; 90 day warranty only) are 
purchased.

1. Attach the terminal lug of the EMC grounding cable (Agilent part number 
89600-60006) to chassis grounding location on rear panel of VXI main frame 
with a M4 x 10mm screw as shown below.

Figure 3-17 EMC grounding cable attached to VXI main frame chassis

2. Insert the USB connector of the EMC grounding cable into any available USB 
port on the laptop computer as shown in the following figure.

NOTE The EMC grounding cable establishes an electrical connection to the shield of the 
laptop computer's USB connector.  That is, it makes no connection to the USB 
signal or voltage terminals.
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Connecting EMC grounding cable
Figure 3-18 IEEE-1394 cable connected to laptop PC (left side of image). EMC grounding 
cable connected to laptop PC (right side of image).
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Connecting EMC grounding cable
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Installing IEEE 1394 Interfaces in Computers
Introduction to installing IEEE 1394 interfaces
Introduction to installing IEEE 1394 interfaces
This chapter includes instructions on installing the IEEE 1394 to VXI interface 
card in your computer. See: “89600-Series Analyzer Installation and Setup” on 
page 18 to learn which procedures you must perform to install your Agilent 
89600-series product.

For instructions on installing the IEEE 1394 Host Adapter in your desktop 
computer, go to "Installing the IEEE 1394 host adapter in your computer" (page 
79).

For instructions on installing the IEEE 1394 PCMCIA Cardbus in your laptop 
computer, go to "Installing the IEEE 1394 PCMCIA cardbus" (page 82).

Otherwise, continue with Step 3., part b, in “Set up your measurement hardware” 
on page 19.
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Installing the IEEE 1394 host adapter in your computer
Installing the IEEE 1394 host adapter in your computer
The IEEE 1394 adapter shipped as Option 001 to the E8491 is an 
OHCI-compatible PCI-to-IEEE 1394 Host Adapter. You must install the following 
components:

• Host adapter card (step 1. through step 6. starting on page 79).

• Gray 4.5 meter interface cable between the computer and the VXI mainframe.

CAUTION Refer to your computer’s documentation for specific instructions about the 
installation of PCI adapters.

NOTE If your personal computer (PC) currently has a PCI-to-IEEE 1394 host adapter or a 
built-in IEEE 1394 port, continue with Step 3., part b, in “Install the necessary I/O 
interface cards in the computer” on page 19.

WARNING Shut down, turn off and disconnect the power to your computer and to any 
peripheral devices before installing the host adapter.

CAUTION To protect circuits from static discharge, observe anti-static techniques whenever 
handling the Agilent 89600-series VXI modules.

To install the IEEE 1394 host adapter in your computer:

1. Remove the computer chassis cover to expose the expansion slots and external 
access covers.

2. Locate an unused, unobstructed PCI bus expansion slot (Figure 4-1) that 
supports bus mastering. (PCI slots are usually white or ivory.) See your 
computer documentation to determine if the PCI slot supports bus mastering.

CAUTION It is very important that the slot supports bus mastering. If it does not, you will be 
unable to install the IO libraries that are necessary for communication between the 
computer and the VXI hardware.
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Installing the IEEE 1394 host adapter in your computer
Figure 4-1 Locating a PCI bus Expansion Slot.

NOTE Many computer PCI systems have one pair of ISA and PCI slots close to each 
other. This saves space and enables you to install either an ISA card or a PCI card 
in the slot pair.

3. Remove the corresponding expansion slot cover (Figure 4-2) from the 
computer chassis.

Figure 4-2 Removing the PC Expansion Slot Cover.

PCI slots
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Installing the IEEE 1394 host adapter in your computer
4. Align the bus contacts on the bottom of the host adapter with the PCI bus slot. 
Carefully, but firmly, press the adapter into the slot (Figure 4-3).

Figure 4-3  Installing the Host Adapter.

5. Secure the host adapter bracket to the computer chassis with the screw from the 
expansion slot cover removed in step 4..

6. If you need to install a GPIB or LAN interface in your PC, continue with Step 
3., part b, in “Set up your measurement hardware” on page 19.

Otherwise, replace the computer cover. Reconnect the power cord and any 
other accessories you disconnected, then continue with Step 3., part b, in “Set 
up your measurement hardware” on page 19.

If you encounter problems installing the driver, examine the files on the 
Installation CD-ROM in the iolibs\readme directory for troubleshooting 
information.

Host
Adapter
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Installing the IEEE 1394 PCMCIA cardbus
Installing the IEEE 1394 PCMCIA cardbus

NOTE For a list of supported IEEE 1394 interfaces, see the Frequently Asked Question 
“What type of IEEE-1394 interface can I use in my computer to connect to the 
89600S VXI hardware” at:  http://www.agilent.com/find/89600 or contact your 
local Test and Measurement Call Center or sales office.

You must have installed the 89600 VSA application software (“Installing 89600 
Software” on page 24), and setup your VXI measurement hardware 
(“Introduction” on page 32) before installing the IEEE 1394 card. 

To install IEEE 1394 PCMCIA cardbus in your computer:

1. Shut down or turn off the computer.

2. Plug in the IEEE 1394 card, following the instructions that came with the card.

3. Continue to the next page.
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Installing drivers for IEEE 1394 and E8491
Installing drivers for IEEE 1394 and E8491
Before following these steps, be sure that your VXI hardware is installed, the 
mainframe is connected to your computer, and the mainframe is on.

To install drivers for IEEE 1394 and E8491:

1. If the Found New Hardware Wizard appears and prompts you to install the 
driver for an OHCI Compliant IEEE 1394 Host Controller, you must get and 
install the drivers for this card from the Windows XP CD that came with your 
computer (or from the CD that came with the IEEE Host Controller).

NOTE These drivers may already be installed on your computer, and in that case, the 
Found New Hardware Wizard for this device will not appear.

2. If the Found New Hardware Wizard does not prompt you to install a driver for 
the E8491, click Start > Settings > Control Panel > Add/Remove Programs. 
If the E8491 is listed, the driver has already been installed.

3. If the Found New Hardware Wizard prompts you to install a driver for the 
E8491, you can install this driver from the 89600 Installation CD. Click ext.

4. In the next dialog box, select Search for suitable driver. Click ext.

5. In the next dialog box, select CD-ROM. Insert the 89600 Installation CD in the 
CD drive. Click ext. The wizard searches for the driver and configures the 
hardware.

6. If the 89600 Installation Manager window appears, close it. Return to the 
Found New Hardware Wizard and Click Finish.

If you encounter problems installing the driver, examine the files on the 
Installation CD-ROM in the iolibs\readme directory for troubleshooting 
information.

Continue with Step 3., part b, in “Install the necessary I/O interface cards in the 
computer” on page 19.
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Installing drivers for IEEE 1394 and E8491
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Installing GPIB, LAN, and USB Interface Cards
Introduction
Introduction
This chapter includes general instructions for installing GPIB and LAN interface 
cards in your computer and connecting instruments to your computer.

Desktop computers require a PCI High-Performance GPIB card. Laptop 
computers require a GPIB Interface for PCMCIA. For a list of supported IEEE 
1394 interfaces, see the Frequently Asked Question “What type of IEEE-1394 
interface can I use in my computer to connect to the 89600S VXI hardware” at: 
http://www.agilent.com/find/89600 or contact your local Test and Measurement 
Call Center or sales office.

For a GPIB interface on a desktop computer, see to "Configuring GPIB on a 
desktop PC" (page 87).

For a GPIB interface on a laptop computer, see to "Configuring GPIB on a laptop 
PC" (page 88).

For a LAN interface, see to "Installing a LAN Interface" (page 89).

For a USB interface, see to "Installing a USB interface" (page 90).

For a LAN-to-GPIB gateway, see to "Configuring a LAN-to-GPIB gateway" (page 
91).
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Configuring GPIB on a desktop PC
Configuring GPIB on a desktop PC
If the GPIB interface card has not been installed in your PC, install it now, 
following the instructions that came with the card. If you need to install other 
interface cards, do not put the cover back on your computer until you have 
installed those cards.

NOTE If you control other GPIB instruments or devices from this computer, see 
“Troubleshooting interference with other devices or instruments” on page 233 for 
information on excluding those devices from the 89600 identification process.

If you will also be communicating with instruments via LAN, continue to 
"Installing a LAN Interface" (page 89). Otherwise, continue with Step 3., part c, in 
“Install the necessary I/O interface cards in the computer” on page 19.
Chapter 5  87



Installing GPIB, LAN, and USB Interface Cards
Configuring GPIB on a laptop PC
Configuring GPIB on a laptop PC
If the GPIB PCMCIA interface card has not been installed in your PC, install it 
now, following the instructions that came with the card. For a National Instruments 
GPIB card, be sure to install the NI 488.2 software first, then reboot your computer 
and install the interface card.

NOTE After a National Instruments GPIB card installation is complete, you must reinstall 
the Agilent IO libraries. Insert the Agilent 89600 Series Software installation 
CD-ROM. When the Agilent 89600 Installation Manager window opens, click 
Install Agilent 89600 VSA. Select Custom Installation and select and install IO 
libraries.

If you control other GPIB instruments or devices from this computer, see page 233 
for information on excluding those devices from the 89600 identification process.

If you will also be communicating with instruments via LAN, continue on page 89. 
Otherwise, continue with Step 3., part c, in “Install the necessary I/O interface 
cards in the computer” on page 19.
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Installing a LA  Interface
Installing a LA  Interface
If the LAN interface is not already installed in your computer, install it now, 
following the instructions that came with the interface.

NOTE If your computer and the instrument are connected to a building LAN, you may 
need to check with your network administrator to verify that the IP addresses for 
your computer and the instrument satisfy requirements.

Continue with Step 3., part c, in “Install the necessary I/O interface cards in the 
computer” on page 19.
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Installing a USB interface
Installing a USB interface
If the USB interface is not already installed in your computer, install it now, 
following the instructions that came with the interface.

Continue with Step 3., part c, in “Install the necessary I/O interface cards in the 
computer” on page 19.
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Configuring a LA -to-GPIB gateway
This section provides information on the LAN-to-GPIB gateway.

To make the LA -to-GPIB gateway connection:

1. Connect the LAN cable to the E5810A LAN/GPIB Gateway and a GPIB cable 
from the E5810A LAN/GPIB Gateway to your GPIB instrument. Connect 
power to the E5810A LAN/GPIB Gateway.

2. Do not configure the E5810. You will be instructed to do this later.

Continue with Step 3., part c, in “Install the necessary I/O interface cards in the 
computer” on page 19
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Configuring IO Interfaces
Introduction
Introduction
This chapter provides instructions for configuring your computer to communicate 
with hardware via IEEE-1394, LAN, or GPIB interfaces. See “89600-Series 
Analyzer Installation and Setup” on page 18 to learn which procedures you must 
perform to install your Agilent 89600 series product.

NOTE Do not configure more than one interface to point to a single instrument, either 
from a single computer or from multiple computers. For example, if your 
instrument is on a LAN, do not point to it from two computers simultaneously.

Perform the procedures for each interface type as directed below:

• Agilent Infiniium oscilloscope: If your measurement hardware is an Agilent 
Infiniium oscilloscope, skip this chapter and follow the instructions in 
“Configuring Infiniium Windows XP Scopes” on page 111.

• Agilent Logic Analyzer: If your measurement hardware is an Agilent Logic 
Analyzer, skip this chapter and follow the instructions in the "Connecting to a 
Network" (page 145) and "89600 I/O Connections" (page 146).

• IEEE-1394 to VXI interface: For IEEE-1394 to VXI interface, start on 
"Configuring the VXI interface" (page 95).

• LA : For LAN interface, start on "Configuring the LAN interface" (page 97).

• LA /GPIB: For LAN/GPIB gateway (portal) interface, start on "Configuring 
the Agilent E5810 LAN/GPIB Gateway interface" (page 102).

• USB/GPIB: For USB/GPIB interface, start on "Configuring the USB/GPIB 
Interface" (page 105).

• GPIB: For GPIB interface, start on "Configuring the GPIB interface" (page 
107).

• USB: For USB interface, start on "Configuring the USB Interface" (page 109).
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Configuring the VXI interface
Configuring the VXI interface

To configure the VXI interface:

1. Connect the IEEE 1394 interface card from the computer to the E8491 VXI 
module in the mainframe. 

2. If using a laptop PC, connect the EMC grounding cable from the VXI 
mainframe chassis to a USB port on the laptop. See “Connecting EMC 
grounding cable” on page 74.

3. Power on the computer and the VXI mainframe.

NOTE If the Found New Hardware Wizard opens, click ext and when it is finished, 
click Finish. 

4. Run Connection Expert: 

Click the IO Control icon in the task bar, then click Agilent Connection 
Expert. (Or click Start > (All) Programs > Agilent IO Libraries Suite > 
Agilent Connection Expert.)

Connection Expert will automatically detect and configure most interfaces and 
instruments and will assign names and other default configuration settings. 

If the VXIO interface does not show up, check cable connections and power 
cord connections. Also, check another port on the E8491 VXI Interconnect 
Module. Click Refresh All to update.

Interfaces or instruments can also be added manually to the test system 
configuration. See Agilent IO Libraries Suite Online Help for more 
information.

5. To verify that the computer recognized all the modules in your VXI mainframe, 
expand VXI0 in the Instrument I/O on this PC section. Connection Expert will 
list all the modules and their addresses. A green checkmark is shown to verify 
the VXI mainframe and modules are on and connected properly.
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Configuring the VXI interface
Agilent IO Libraries Suite also provides a VXI Resource Manager. that 
initializes and prepares a VXI system for use. The VXI Resource Manager runs 
when any of the following conditions occur:

• You start it from the Connection Expert’s Tools menu (select Tools > VXI 
Resource Manager > Edit Resources, then click Run in the resulting 
Resource Manager dialog box)

• You start it from the Agilent IO Control

• You apply or cycle VXI mainframe power

• You press the E8491 Reset button

• You reboot your PC

In VXI systems with multiple E8491 interfaces, you can turn off individual 
VXI mainframes without affecting other mainframes in the system. When a 
mainframe is turned on, the VXI Resource Manager reconfigures that 
mainframe.

For more information about VXI interfaces, see Connectivity in the Agilent IO 
Libraries Suite Documentation. Click on the IO Control icon in the task bar and 
then select Documentation. (Or click Start > (All) Programs > Agilent IO 
Libraries Suite > Documentation.)

If you will also be communicating with measurement hardware via LAN, continue 
to "Configuring the LAN interface" (page 97).

If you will also be communicating with measurement hardware via a 
LAN-to-GPIB portal, continue to "Configuring the Agilent E5810 LAN/GPIB 
Gateway interface" (page 102).

If you will also be communicating with measurement hardware via GPIB, continue 
to "Configuring the GPIB interface" (page 107).

If you will not be using any other measurement hardware, continue with Step 5 
(Page 20).
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Configuring the LA  interface
This procedure is used to configure the LAN interface except as directed for the 
following measurement hardware:

• Agilent Infiniium oscilloscope: If your measurement hardware is an Agilent 
Infiniium oscilloscope, skip this chapter and follow the instructions in Chapter 
7 , “Configuring Infiniium Windows XP Scopes,” on page 111.

• Agilent Synthetic Instrument (SI) Spectrum Analyzer: If your measurement 
hardware is an Agilent Synthetic Instrument (SI) Spectrum Analyzer, skip this 
chapter and follow the instructions in Chapter 11 , “Linking a Synthetic 
Instrument (SI) Spectrum Analyzer to the Agilent 89600 VSA,” on page 161.

For more information about LAN interfaces, see Connectivity in the 
Documentation section of the Agilent IO Libraries Suite. You can find this when 
you click on the IO Control icon in the task bar and then select Documentation. 
(Or click Start > (All) Programs > Agilent IO Libraries Suite > 
Documentation.)

You must ensure that the IP addresses for your computer and measurement 
hardware are compatible, then configure the LAN interface. The IP address 
consists of 4 groups of numbers separated by periods (for example, 
192.192.192.25).

To configure your LA  interface:

1. Set the IP address on the instrument, using the appropriate set of instructions:

— instrument IP address for a computer on Local Area network or IP address 
for computer cable (see: "Instrument IP address for a Local Area Network 
configuration" (page 97)).

or

— instrument IP address for a computer with a crossover cable (see: 
"Instrument IP address for a crossover cable configuration" (page 98)).

2. Run Connection Expert ("Run Connection Expert" (page 100)).

Instrument IP address for a Local Area etwork configuration

This section provides information on setting the instrument IP address when your 
computer is on a Local Area Network.

To set the instrument IP address for a LA  configuration:

1. If your computer is connected to a Local Area Network, have your network 
administrator assign an IP address for your instrument hardware that will work 
with your computer. (The network administrator can also tell you if you need to 
set Subnet Masks.)
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a. Set the IP address on the measurement hardware.

• E4406: On the E4406, press System > Config IO > IP address, type the 
new address using the number keypad, and press Enter.

• PSA: On the PSA, press System > Config IO > IP address, type the 
new address using the number keypad, and press Enter.

• X-Series Signal Analyzer: On the analyzer, press System > Show > 
System to find the IP address. To change the IP address, refer to the 
LAN Interface configuration documentation provided with the analyzer.

• Series 6000/7000 Oscilloscopes: On the Series 6000A/7000A 
Oscilloscopes, verify the I/O Controller is set to LAN. If it is not set to 
LAN, press Utility > I/O > Controller XX (where XX is either GPIB, 
LAN or USB), use the Entry knob labelled with a circular arrow to point 
the screen arrow to LAN, and press the Controller button. For the Series 
6000L Oscilloscopes, see scope documentation.

b. Click in the Subnet Mask box.

For the E4406 only, if the IP address begins with “10.”, set the subnet mask 
to “255.0.0.0.” If the E4406 IP address begins with anything other than 
“10.”, set the subnet mask to “255.255.0.0.” (Press System > Config I/O > 
Subnet Mask, type the new address using the number keypad, and press 
Enter.)

For all other instruments, accept the default numbers that appear for the 
subnet mask.

Click OK and close all dialog boxes.

c. If you are prompted to reboot your computer, do so now.

2. Be sure that both the instrument and your computer are connected to the LAN.

3. Cycle power on the measurement hardware (such as the E4406 or PSA).

4. Continue with "Run Connection Expert" (page 100).

Instrument IP address for a crossover cable configuration

This section provides information on setting the instrument IP address when your 
computer is connected to the instrument using a crossover cable.

To set the instrument IP address for a crossover cable configuration:

1. If your computer is connected to a Local Area Network and you will be 
connecting directly to the hardware using a crossover cable, perform these 
steps:

a. Determine the IP address for your computer. Click Start > Run. Type cmd 
and click OK. At the DOS prompt, type ipconfig and press Enter. If an 
IP address is not listed, or if the address is 0.0.0.0, go to step d. If a non-zero 
IP address is listed, leave it and continue with step b.
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b. Set the IP address on the instrument so that the first 3 sections of the IP 
address are the same as the computer’s IP address and the last section is 
different than the computer’s. (For example, if the computer IP address is 
192.192.192.25, set the hardware IP address to 192.192.192.26.)

To change the E4406A or PSA IP address, press System > Config I/O > IP 
address, type the new address using the number keypad, and press Enter.

c. Continue with step e.

d. Find the IP address for the hardware (for the E4406 or PSA, press System > 
Config I/O > IP address). Set the IP address for the computer so that the 
first 3 sections are the same as the instrument and the last section is different 
than the instrument. (For example, if the hardware IP address is 
10.10.10.10, set the computer address to 10.10.10.9.)

For Windows XP, click Start > 
right click My etwork Places 
> Properties > right click 
Local Area Connection > 
Properties > Internet Protocol 
(TCP/IP) > Properties > Use 
the following IP address. 

-or-

For Windows Vista, 
click Start > right click 

etwork > Properties 
> View Status in Local 
Area Connection > 
Properties > Internet 
Protocol Ver. 4 >  
Properties > Use the  
following IP address.

Enter the IP address in the box, 
using the periods (.) to separate the sections.

e. Click in the Subnet Mask box.

For the E4406 only, if the IP address begins with “10.”, set the subnet mask 
to “255.0.0.0”. If the E4406 IP address begins with anything other than 
“10.”, set the subnet mask to “255.255.0.0”. (Press System > Config I/O > 
Subnet Mask, type the new address using the number keypad, and press 
Enter.)

For all other instruments, accept the default numbers that appear for the 
subnet mask.

Click OK and close all dialog boxes.

f. If you are prompted to reboot your computer, do so now.

2. Connect the crossover cable between the computer and the instrument.
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3. Cycle power on the measurement hardware (such as the E4406 or PSA).

4. Continue with Run Connection Expert below.

Run Connection Expert

1. Run the Agilent IO Libraries Suite Connection Expert tool.

Click the IO Control icon in the Windows application task bar, then click 
Agilent Connection Expert. (Or click Start > (All) Programs > Agilent IO 
Libraries Suite > Agilent Connection Expert.)

2. Add an instrument.

Auto discover cannot be done on LAN devices so you must manually add the 
instrument.

a. Click on LA  in the Instrument I/O on this PC section.

b. Click Add an instrument in the Task Guide section. The Add LAN 
Instrument window will open. 

You can browse for the instrument to be added and select the check box. 

If the instrument is not listed, click Add Address. Enter the hostname or 
select IP address and enter the IP address of the instrument. 

c. Click OK.

Connection Expert will automatically configure the interface and instruments 
and will assign names and other default configuration settings.

3. To verify that the computer recognized the instrument, expand LA  in the 
Instrument I/O on this PC section. Connection Expert will list all instruments 
and their addresses. A green checkmark is shown to verify the instrument is on 
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and connected properly.

NOTE If you setup a LAN connection, then turn off or disconnect the hardware, the 
89600 looks for the hardware when started. This slows down startup. To speed up 
startup, use Connection Expert to remove the LAN setup or choose to ignore the 
instrument.

NOTE When the 89601 software locates an instrument, it locks onto the instrument so 
only the 89601 software can communicate with it. This will prevent Agilent IO 
Libraries from any communication with these instruments and cause the green 
checkmark to become a red X in Connection Expert. You can disconnect the 
instrument by selecting Control > Disconnect in the 89601 software. Select 
Refresh in Connection Expert and the green checkmark will be shown.

If you will also be communicating with measurement hardware via a 
LAN-to-GPIB portal, continue on "Configuring the Agilent E5810 LAN/GPIB 
Gateway interface" (page 102).

If you will also be communicating with measurement hardware via GPIB, continue 
on "Configuring the GPIB interface" (page 107).

If you will not be using any other measurement hardware, continue with Step 5 
(Page 20).
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Configuring the Agilent E5810 LA /GPIB Gateway 
interface
This procedure is used to configure the E5810 LAN/GPIB interface except as 
directed for the following measurement hardware:

• Agilent Infiniium oscilloscope: If your measurement hardware is an Agilent 
Infiniium oscilloscope, skip this chapter and follow the instructions in Chapter 
7 , “Configuring Infiniium Windows XP Scopes,” on page 111.

To setup and use the E5810 with Microsoft Windows, you must have Internet 
Explorer 4.0 or higher or Netscape 4.7 or higher.

For details on setting up the E5810, see the E5810 Users Guide in the Agilent IO 
Libraries Suite Documentation. Click the Agilent IO Control icon in the task bar. 
Click Documentation and then select E5810 LA  GPIB Users Guide. (Or click 
Start > (All) Programs > Agilent IO Libraries Suite > Documentation > E5810 
LA  GPIB Users Guide.)

IMPORTANT Before making network connections, contact your Information Technology (IT) 
department for policies concerning user connections, IP address, etc.

To configure the Agilent E5810 LA /GPIB Gateway interface:

1. Connect the E5810 to the network and to instruments.

2. Plug in and power on the E5810 and any GPIB instruments. 

• E5810: The IP address should be displayed in the display of the E5810. If 
the address does not appear, see Troubleshooting Information in the E5810 
Getting Started Guide.

• Series 6000/7000 Oscilloscopes: On the Series 6000A/7000A 
Oscilloscopes, verify the I/O Controller is set to GPIB. If it is not set to 
GPIB, press Utility > I/O > Controller XX (where XX is either GPIB, LAN, 
or USB), use the Entry knob labelled with a circular arrow to point the 
screen arrow to LAN, and press the Controller button. For the Series 6000L 
Oscilloscopes, see scope documentation.

3. Configure the E5810

a. Display the E5810 Welcome Page. In your Web browser, type 
 ‘http://<IP address>’ 
 where <IP address> is the current E5830A IP address (such as 
169.254.58.10) shown on the E5810 display. Press Enter.

b. Take note of the GPIB SICL Interface Name (something like gpib0). You 
will need to use this name in a later step.

c. If you need to change any configuration information, such as the IP address, 
click View & Modify Configuration. (The default password is E5810.) After 
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making changes, click Save and then Reboot E5810 to make changes 
effective.

4. Verify communication from the E5810.

a. From the E5810 Welcome page, click Find & Query Instruments. (The 
default password is E5810.)

b. Click Find.

c. In the list of SICL Addresses, highlight the instrument you want to query.

d. Click ID ? The identification information for the instrument appears in the 
right pane.

Run Connection Expert

1. Run the Agilent IO Libraries Suite Connection Expert tool.

Click the IO Control icon in the Windows application task bar, then click 
Agilent Connection Expert. (Or click Start > (All) Programs > Agilent IO 
Libraries Suite > Agilent Connection Expert.)

2. Add an interface. 

For more information about LAN Client interfaces, see Connectivity in the 
Documentation section of the Agilent IO Libraries Suite. You can find this 
when you click on the IO Control icon in the task bar and then select 
Documentation. (Or click Start > (All) Programs > Agilent IO Libraries 
Suite > Documentation > Connectivity.)

a. Click Add an interface on the Connection Expert task bar.

b. Select Remote GPIB interface and click Add. 

c. Select IP address and enter IP address from the E5810A (see step 3B). 

d. Click OK.

Connection Expert will automatically configure the interface and instruments 
and will assign names and other default configuration settings.

3. To verify that the computer recognized the instrument, expand Remote 
(GPIB1) in the Instrument I/O on this PC section. Connection Expert will list 
all instruments and their addresses. A green checkmark is shown to verify that 
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the instrument is on and connected properly.

NOTE When the 89601 software locates an instrument, it locks onto the instrument so 
only the 89601 software can communicate with it. This will prevent Agilent IO 
Libraries from any communication with these instruments and cause the green 
checkmark to become a red X in Connection Expert. You can disconnect the 
instrument by selecting Control > Disconnect in the 89601 software. Select 
Refresh in Connection Expert and the green checkmark will be shown.

If you will not be using any other measurement hardware, continue with Step 5 
(Page 20).
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Configuring the USB/GPIB Interface
This procedure is used to configure the USB/GPIB interface except as directed for 
the following measurement hardware:

• Agilent Infiniium oscilloscope: If your measurement hardware is an Agilent 
Infiniium oscilloscope, skip this chapter and follow the instructions in Chapter 
7 , “Configuring Infiniium Windows XP Scopes,” on page 111.

For details on setting up the 82357 USB/GPIB Interface, see the 82357 USB/GPIB 
User’s Guide in the Agilent IO Libraries Suite Documentation. Click the Agilent 
IO Control icon in the task bar. Click Documentation and then select 82357 USB 
GPIB Users Guide. (Or click Start > (All) Programs > Agilent IO Libraries 
Suite > Documentation > 82357 USB GPIB Users Guide.)

To configure the USB/GPIB interface:

1. Plug the 82357 USB cable into a USB port on your PC. Do not connect to your 
GPIB instrument at this time.

2. Observe the 3 LEDs on the E8237A. Initially, only the red FAIL LED should be 
on. After the Found New Hardware Wizard runs, all 3 LEDs should be ON. If 
any LED is off after 20 seconds, stop and refer to the 82357 USB/GPIB User’s 
Guide in the Agilent IO Libraries Suite Documentation for information.

3. If the Agilent 82357 USB/GPIB Interface Detected dialog box appears, click 
OK or Accept. (If you want to change any of the settings, refer to the 82357 
documentation for instructions.) (The graphic below is a sample from a 
Windows XP system.)

4. Connect one or more instruments to the GPIB connector on the 82357.

• Series 6000/7000 Oscilloscopes: On the Series 6000A/7000A 
Oscilloscopes, verify the I/O Controller is set to GPIB. If it is not set to 
GPIB, press Utility > I/O > Controller XX (where XX is either GPIB, LAN, 
or USB), use the Entry knob labelled with a circular arrow to point the 
screen arrow to LAN, and press the Controller button. For the Series 6000L 
Oscilloscopes, see scope documentation.

Run Connection Expert

1. Run Connection Expert.

a. Click the IO Control icon in the task bar or click Start > (All) Programs > 
Agilent IO Libraries Suite > Agilent Connection Expert. 

Connection Expert will automatically detect and configure the interface and 
instruments. It will also assign names and other default configuration 
settings.

2. To verify that the computer recognized the instrument, expand USB/GPIB 
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(GPIB1) in the Instrument I/O on this PC section. Connection Expert lists all 
instruments and their addresses. A green checkmark is shown to verify the 
instruments are on and connected properly. To troubleshoot problems, refer to 
the Troubleshooting chapter in the 82357 User’s Guide.

NOTE When the 89601 software locates an instrument, it locks onto the instrument so 
only the 89601 software can communicate with it. This will prevent Agilent IO 
Libraries from any communication with these instruments and cause the green 
checkmark to become a red X in Connection Expert. You can disconnect the 
instrument by selecting Control > Disconnect in the 89601 software. Select 
Refresh in Connection Expert and the green checkmark will be shown.

If you will not be using any other measurement hardware, continue with Step 5 
(Page 20).
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Configuring the GPIB interface
This procedure is used to configure the GPIB interface except as directed for the 
following measurement hardware:

• Agilent Infiniium oscilloscope: If your measurement hardware is an Agilent 
Infiniium oscilloscope, skip this chapter and follow the instructions in Chapter 
7 , “Configuring Infiniium Windows XP Scopes,” on page 111.

NOTE The purpose of this chapter is to guide you through the specific setup required to 
get your computer and instrument configured properly. For more detailed 
information on IO configuration, refer to the documentation for the IO Libraries 
Suite (click the IO Control icon, then select Documentation).

For more information about GPIB interfaces, see Connectivity in the 
Documentation section of the Agilent IO Libraries Suite. You can find this when 
you click on the IO Control icon in the task bar and then select Documentation. 
(Or click Start > (All) Programs > Agilent IO Libraries Suite > 
Documentation.)

To configure the GPIB interface:

1. If you are configuring a GPIB connection for measurement hardware that is 
currently configured as a LAN connection on this computer, you must first 
remove the LAN configuration. Then cycle power on the hardware before 
continuing with the GPIB configuration.

2. Connect your GPIB instruments to the computer’s GPIB interface. Power on 
the PC and the instruments.

• Series 6000/7000 Oscilloscopes: On the Series 6000A/7000A 
Oscilloscopes, verify the I/O Controller is set to GPIB. If it is not set to 
GPIB, press Utility > I/O > Controller XX (where XX is either GPIB, LAN, 
or USB), use the Entry knob labelled with a circular arrow to point the 
screen arrow to LAN, and press the Controller button. For the Series 6000L 
Oscilloscopes, see scope documentation.

Run Connection Expert

1. Run Connection Expert.

Click the IO Control icon in the task bar, then click Agilent Connection 
Expert, or click Start > (All) Programs > Agilent IO Libraries Suite > 
Agilent Connection Expert.

Connection Expert will automatically detect and configure the interface and 
instruments and will assign names and other default configuration settings.

2. To verify that the computer recognized the instrument, expand GPIB0 in the 
Instrument I/O on this PC section. Connection Expert will list all instruments 
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and their addresses. A green checkmark will be shown to verify that the 
instrument is on and connected properly.

NOTE When the 89601 software locates an instrument, it locks onto the instrument so 
only the 89601 software can communicate with it. This will prevent Agilent IO 
Libraries from any communication with these instruments and cause the green 
checkmark to become a red X in Connection Expert. You can disconnect the 
instrument by selecting Control > Disconnect in the 89601 software. Select 
Refresh in Connection Expert and the green checkmark will be shown.

If you will not be using any other measurement hardware, continue with Step 5 
(Page 20).
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Configuring the USB Interface
This procedure is used to configure the USB interface except as directed for the 
following measurement hardware:

• Agilent 82357 USB/GPIB Interface: If you are using a Agilent 82357 
USB/GPIB Interface, go to "Configuring the USB/GPIB Interface" (page 105). 
The instructions in this chapter assume that the USB interface is installed in 
your PC and is working.

NOTE The purpose of this chapter is to guide you through the specific setup required to 
get your computer and instrument configured properly. For more detailed 
information on GPIB IO configuration, refer to the documentation for the IO 
Libraries Suite (click the IO Control icon, then select Documentation > 
Connectivity).

To configure the USB interface:

Connect your USB instruments to the USB interface in the computer. Power on the 
PC and the instruments.

On the Series 6000A/7000A Oscilloscopes, verify the I/O Controller is set to USB. 
If it is not set to USB, press Utility > I/O > Controller XX (where XX is either 
GPIB, LAN or USB), use the Entry knob labelled with a circular arrow to point the 
screen arrow to USB and press the Controller button. For the Series 6000L 
Oscilloscopes, see scope documentation.

Run Connection Expert

1. Run Connection Expert. 

Click the IO Control icon in the task bar, then click Agilent Connection 
Expert, or click Start > (All) Programs > Agilent IO Libraries Suite > 
Agilent Connection Expert.

Connection Expert will automatically detect and configure the interface and 
instruments and will assign names and other default configuration settings

2. To verify that the computer recognized the instrument, expand USB0 in the 
Instrument I/O on this PC section. Connection Expert will list all instruments 
and their addresses. A green checkmark will be shown to verify that the 
instrument is on and connected properly.
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NOTE When the 89601 software locates an instrument, it locks onto the instrument so 
only the 89601 software can communicate with it. This will prevent Agilent IO 
Libraries from any communication with these instruments and cause the green 
checkmark to become a red X in Connection Expert. You can disconnect the 
instrument by selecting Control > Disconnect in the 89601 software. Select 
Refresh in Connection Expert and the green checkmark will be shown.

If you will not be using any other measurement hardware, continue with Step 5 
(Page 20).
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Introduction
This chapter includes networking information for configuring Agilent Infiniium 
scopes, running the Windows XP operating system, and a corresponding PC 
running the 89601 software.

The table below lists the supported Agilent Infiniium scopes.

NOTE Refer to Application Note 5988-4096EN (Agilent Infiniium Oscilloscopes 
Performance Guide Using the 89601A VSA Software) for the required infiniium 
firmware revisions.

NOTE If you are installing the 89601 software directly in the Agilent Infiniium scope 
(Windows XP only), see: Chapter 8 , “Installing 89601 Software in Agilent 
Infiniium XP Scopes,” on page 125.

Before configuring your Infiniium scope, be sure you have installed the 89601 
software on the PC you are using with the scope.

For any connection type, there are up to three possible steps:

1. Configure Infiniium Networking

— "Configuring Windows XP Infiniium Networking for non-DHCP Network" 
(page 114)

— "Configuring Windows Infiniium Networking for DHCP Network" (page 
115)

— "Configuring Windows XP Infiniium Networking for a Crossover Cable 
Network" (page 116)

2. Configure PC Networking

Model # Bandwidth Model # Bandwidth

8064 600 MHz 9104 1 GHz

8104 1 GHz 9254 2.5 GHz

80204 2 GHz 9404 4 GHz

80304 3 GHz 90254 2.5 GHz

80404 4 GHz 90404 4 GHz

80604 6 GHz 90604 6 GHz

80804 8 GHz 90804 8 GHz

81004 10 GHz 91204 12 GHz

81204 12 GHz 91304 13 GHz

81304 13 GHz
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— "Configuring PC Networking for a Crossover Cable Configuration" (page 
117)

3. Configure Agilent IO Config Software for GPIB and LAN

— "Configuring PC Agilent IO Config for GPIB connection" (page 118)

— "Configuring PC Agilent IO Config for LAN connection" (page 119)

See table below for additional information in determining the sections you need to 
complete based on your connection type. Check with your network administrator 
to determine your network type.

Table 7-1 Summary of Connection Types 

Connection Type Infiniium etworking PC etworking PC Agilent IO Config Software

GPIB to GPIB N/A N/A “Configuring PC Agilent IO Config for GPIB 
connection” on page 118

USB to GPIB N/A N/A “Configuring the USB/GPIB Interface” on 
page 123

LAN/GPIB Gateway N/A N/A “Configuring the Agilent E5810 LAN/GPIB 
Gateway Interface” on page 121

LAN using a crossover 
cable

“Configuring Windows XP 
Infiniium Networking for a 
Crossover Cable Network” on 
page 116

“Configuring PC 
Networking for a 
Crossover Cable 
Configuration” on 
page 117

“Configuring PC Agilent IO Config for LAN 
connection” on page 119

LAN with DHCP “Configuring Windows 
Infiniium Networking for 
DHCP Network” on page 115

N/A “Configuring PC Agilent IO Config for LAN 
connection” on page 119

LAN without DHCP “Configuring Windows XP 
Infiniium Networking for 
non-DHCP Network” on 
page 114

N/A “Configuring PC Agilent IO Config for LAN 
connection” on page 119
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Configuring Windows XP Infiniium etworking for 
non-DHCP etwork
Complete the following procedure to configure your Windows XP Infiniium scope 
for networking via a non-DHCP (Dynamic Host Configuration Protocol) network.

To configure Windows XP Infiniium networking for a non-DHCP 
network:

1. You will need an IP Address, Gateway Address and a Subnet Mask from your 
Network Administrator.

2. On your Infiniium, quit the Scope application if it is running.

3. Open the Control Panel (Start > Control Panel). Open etwork 
Connections. (If you are in Category view, click Network and Internet 
Connections and then select Network Connections.) 

4. Click Local Area Connection and then Properties to display the Local Area 
Connection Properties dialog box. 

5. Select Internet Protocol (TCP/IP) on the connection list and click Properties 
to display the Internet Protocol (TCP/IP) Properties dialog box.

6. Select Use the following IP address and enter the IP Address, Subnet mask, 
and Default gateway address provided by your Network Administrator. 

7. Click OK in the Internet Protocol (TCP/IP) Properties dialog box.

8. Click OK in the Local Area Connection Properties dialog box. If Windows 
prompts you to reboot your Infiniium, click Yes. If not, close all open dialog 
boxes.

9. After the Infiniium reboots, the instrument is ready for LAN control over the 
LAN interface. Go to “Configuring PC Agilent IO Config for LAN 
connection” on page 119.
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Configuring Windows Infiniium etworking for DHCP 
etwork

If your network provider uses DHCP, Windows XP will automatically retrieve a 
dynamic IP Address from the DHCP server. No configuration for the Infiniium is 
necessary. Continue to "Configuring PC Agilent IO Config for LAN connection" 
(page 119).
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Configuring Windows XP Infiniium etworking for a 
Crossover Cable etwork
Complete the following procedure to configure Windows XP Infiniium 
Networking for a Crossover Cable.

To configure Windows XP Infiniium networking for a crossover 
cable:

1. You need to create IP Addresses for both the Infiniium and your PC. Both 
addresses must have the first 3 sections the same and the last one different. For 
example, the PC IP address can be 192.168.0.2 and the Infiniium IP address 
192.168.0.1.

2. On your Infiniium, quit the Scope application if it is running.

3. Open the Control Panel (Start > Control Panel). Open etwork 
Connections. (If you are in Category view, click etwork and Internet 
Connections and then select etwork Connection.)

4. Click Local Area Connection and then Properties to display the Local Area 
Connection Properties dialog box.

5. Select Internet Protocol (TCP/IP) from the connection list and click 
Properties to display the Internet Protocol (TCP/IP) Properties dialog screen.

6. Select Use the following IP address and enter the IP Address for the Infiniium 
you created in step 1 (192.168.0.1 in this example), and type a subnet mask of 
255.255.255.0.

7. Click OK in the Internet Protocol (TCP/IP) Properties dialog box.

8. Click OK in the Local Area Connection Properties dialog box. If Windows 
prompts you to reboot your Infiniium, click Yes. If not, close all open dialog 
boxes.

9.  After the Infiniium reboots, the instrument is ready for LAN control over the 
LAN interface. Continue to "Configuring PC Networking for a Crossover 
Cable Configuration" (page 117).
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Configuring PC etworking for a Crossover Cable 
Configuration
Complete the following procedure to configure a PC for a Crossover Cable 
configuration.

To configure PC networking for a crossover cable configuration:

1. On your PC, open the Control Panel (Start > Control Panel). 

2. For Windows XP, click etwork Connections >  Local Area Connections > 
Properties.

For Windows Vista, click View network status and tasks in etwork and 
Internet >  View status in Local Area Connection > Properties.

This will display the Local Area Connection Properties dialog box. 

3. For Windows XP, select Internet Protocol (TCP/IP) and click Properties.

For Windows Vista, select Internet Protocol Version 4 and click Properties.

This will display the Internet Protocol (TCP/IP or Version 4) Properties dialog 
screen.

4. Select Use the following IP address and enter the IP Address for the PC you 
created in step 1 of "Configuring Windows XP Infiniium Networking for a 
Crossover Cable Network" (page 116) (this example uses 192.168.0.2.), and 
enter a subnet mask of 255.255.255.0. 

5. Click OK in the Internet Protocol (TCP/IP or Version 4) Properties dialog box.

6. Click OK or Close in the Local Area Connection Properties dialog box. If 
Windows prompts you to reboot your PC, click Yes. If not, close any open 
dialog boxes.

7.  After your PC reboots, the PC is ready for setting up the Agilent IO Config 
software. Go to "Configuring PC Agilent IO Config for LAN connection" 
(page 119).
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Configuring PC Agilent IO Config for GPIB connection
The 89601A Software will automatically install the Agilent IO Libraries Suite on 
your PC if they are not already installed. These instructions assume that your 
computer has a GPIB card installed and operable.

To configure PC Agilent IP Config for a GPIB connection:

1. On the PC with the 89600A software, select: Start > Programs > Agilent IO 
Libraries Suite > Agilent Connection Expert

Connection Expert will automatically detect and configure the interface and 
instruments. It will also assign names and other default configuration settings.

2. To verify that the computer recognized the instrument, expand GPIB0 in the 
Instrument I/O on this PC section. Connection Expert will list all instruments 
and their addresses. 

NOTE Agilent Connection Expert will not find the Infiniium scope if the scope 
application is not running.

NOTE When the 89601 software locates an instrument, it locks onto the instrument so 
only the 89601 software can communicate with it. This will prevent Agilent IO 
Libraries from any communication with these instruments and cause the green 
checkmark to become a red X in Connection Expert. You can disconnect the 
instrument by selecting Control > Disconnect in the 89601 software. Select 
Refresh in Connection Expert and the green checkmark will be shown.
 118 Chapter 7 



Configuring Infiniium Windows XP Scopes
Configuring PC Agilent IO Config for LA  connection
Configuring PC Agilent IO Config for LA  connection
The 89601A Software automatically installs the Agilent IO Libraries Suite on your 
PC if they are not already installed.

To configure PC Agilent IO Config for a LA  connection:

1. On the PC with the 89601A software, select: Start > Programs > Agilent IO 
Libraries Suite > Agilent Connection Expert.

2. Add an instrument.

Auto discover cannot be done on LAN devices so you must manually add the 
instrument.

a. Click on LA  in the Instrument I/O on this PC section.

b. Click Add an instrument in the Task Guide section. The LAN selection 
should be highlighted but if not, highlight it.

c. Click OK.

d. Select IP address in the LAN instrument dialog box and enter the IP 
address of the instrument. You can also use Hostname if it is known. 

e. Click OK. 

3. To verify that the computer recognized the instrument, expand LA  in the 
Instrument I/O on this PC section. Connection Expert lists all instruments and 
their addresses.

NOTE Agilent Connection Expert can not find the Infiniium scope if the scope 
application is not running.

NOTE When the 89601 software locates an instrument, it locks onto the instrument so 
only the 89600 software can communicate with it. This will prevent Agilent IO 
Libraries from any communication with these instruments and cause the green 
checkmark to become a red X in Connection Expert. You can disconnect the 
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instrument by selecting Control > Disconnect in the 89601 software. Select 
Refresh in Connection Expert and the green checkmark will be shown.
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Configuring the Agilent E5810 LA /GPIB Gateway 
Interface
To setup and use the E5810 with Microsoft Windows, you must have Internet 
Explorer 4.0 or higher or Netscape 4.7 or higher.

For details on setting up the E5810, see the E5810 User’s Guide in the Agilent IO 
Libraries Suite Documentation. Click the Agilent IO Control icon in the task bar. 
Click Documentation > Interface Manuals > E5810 LA  GPIB Users Guide. 
(Or click Start > (All) Programs > Agilent IO Libraries Suite > Documentation 
> E5810 LA  GPIB Users Guide.)

IMPORTANT Before making network connections, contact your Information Technology (IT) 
department for policies concerning user connections, IP address, etc.

To configure the E5810 LA /GPIB Gateway interface:

1. Connect the E5810 to the network and to instruments.

2. Plug in and power on the E5810 and any GPIB instruments. The IP address 
should be displayed in the display. If the address does not appear, see 
Troubleshooting Information in the E5810 Getting Started Guide.

3. Configure the E5810

a. Display the E5810 Welcome Page. In your Web browser, type 
 ‘http://<IP address>’ 
 where <IP address> is the current E5830A IP address (such as 
169.254.58.10) shown on the E5810 display. Press Enter.

b. Take note of the GPIB SICL Interface Name (something like gpib0). You 
will need to use this name in a later step.

c. If you need to change any configuration information, such as the IP address, 
click View & Modify Configuration. (The default password is E5810.) 
After making changes, click Save and then Reboot E5810 to make changes 
effective.

4. Verify communication from the E5810.

a. From the E5810 Welcome page, click Find & Query Instruments. (The 
default password is E5810.)

b. Click Find.

c. In the list of SICL Addresses, highlight the instrument you want to query.

d. Click ID ? The identification information for the information appears in 
the right pane.

5. Run the Agilent IO Libraries Suite Connection Expert tool.
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Click the IO Control icon in the task bar, then click Agilent Connection 
Expert, or click Start > (All) Programs > Agilent IO Libraries Suite > 
Agilent Connection Expert.

6. Add an interface. 

For more information about LAN Client interfaces, see Connectivity Guide in 
the Documentation section of the Agilent IO Libraries Suite. You can find this 
when you click on the IO Control icon in the task bar and then select 
Documentation > Connectivity Guide. (Or click Start > (All) Programs > 
Agilent IO Libraries Suite > Documentation > Connectivity Guide.)

a. Click Add an interface on the Connection Expert Task Guide panel.

b. Select Remote GPIB interface and click Add.

c. Select IP address and enter IP address from the E5810A (see step 3b). 

d. Click OK.

Connection Expert will automatically configure the interface and instruments 
and will assign names and other default configuration settings.

7. To verify that the computer recognized the instrument, expand Remote 
(GPIB1) in the Instrument I/O on this PC section. Connection Expert will list 
all instruments and their addresses.

NOTE Agilent Connection Expert will not find the Infiniium scope if the scope 
application is not running.

NOTE When the 89601 software locates an instrument, it locks onto the instrument so 
only the 89601 software can communicate with it. This will prevent Agilent IO 
Libraries from any communication with these instruments and cause the green 
checkmark to become a red X in Connection Expert. You can disconnect the 
instrument by selecting Control > Disconnect in the 89601 software. Select 
Refresh in Connection Expert and the green checkmark will be shown.
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Configuring the USB/GPIB Interface
For details on setting up the 82357 USB/GPIB Interface, see the 82357 USB/GPIB 
User’s Guide in the Agilent IO Libraries Suite Documentation. Click the Agilent 
IO Control icon in the task bar and select Documentation > Interface Manuals 
> 82357 USB GPIB Users Guide. (Or click Start > (All) Programs > Agilent IO 
Libraries Suite > Documentation > 82357 USB GPIB Users Guide.)

To configure the USB/GPIB interface:

1. Plug the 82357 USB cable into a USB port on your PC. Do not connect to your 
GPIB instrument at this time.

2. Observe the 3 LEDs on the E8237A. Initially, only the red FAIL LED should be 
on. After the Found New Hardware Wizard runs, all 3 LEDs should be ON. If 
any LED is off after 20 seconds, stop and refer to the 82357 USB/GPIB User’s 
Guide in the Agilent IO Libraries Suite Documentation for information.

3. If the Agilent 82357 USB/GPIB Interface Detected dialog box appears, click 
OK or Accept. (If you want to change any of the settings, refer to the 82357 
documentation for instructions.))

4. Connect one or more instruments to the GPIB connector on the 82357.

5. Run Connection Expert.

a. Click the IO Control icon in the task bar or click Start > (All) Programs > 
Agilent IO Libraries Suite > Agilent Connection Expert. 

Connection Expert will automatically detect and configure the interface and 
instruments. It will also assign names and other default configuration 
settings.

6. To verify that the computer recognized the instrument, expand USB/GPIB 
(GPIB1) in the Instrument I/O on this PC section. Connection Expert will list 
all instruments and their addresses. To troubleshoot problems, refer to the 
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Troubleshooting chapter in the 82357A User’s Guide.

NOTE Agilent Connection Expert will not find the Infiniium scope if the scope 
application is not running.

NOTE When the 89601 software locates an instrument, it locks onto the instrument so 
only the 89601 software can communicate with it. This will prevent Agilent IO 
Libraries from any communication with these instruments and cause the green 
checkmark to become a red X in Connection Expert. You can disconnect the 
instrument by selecting Control > Disconnect in the 89601 software. Select 
Refresh in Connection Expert and the green checkmark will be shown.
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Installing 89601 Software in Agilent Infiniium XP Scopes
Introduction
Introduction
This chapter includes information for installing 89601 software in Agilent 
Infiniium scopes running Windows XP.

Many Infiniium oscilloscopes provide an open Microsoft Windows XP Pro 
operating system that enables you to install other applications. You can install and 
operate the 89601A Vector Signal Analyzer software on these scopes.

If you are installing 89600 software on a PC connected to your Infiniium scope, 
skip this chapter and see: Chapter 7 , “Configuring Infiniium Windows XP 
Scopes,” on page 111
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Installing the 89600 software
This section provides information on installing the 89600 software in your scope.

To install the 89600 software embedded in your scope:

1. Increase the scope's virtual memory to at least 1 GByte as follows:

a. Minimize the scope application.

b. Navigate to: Start > Control Panel > Administrative Tools (double-click) 
> Computer Management (double-click) > Computer Management 
(Local) (right-click) > Properties > Advanced (tab)> Performance 
Settings (button) > Virtual Memory - Change (button) to display the 
Virtual Memory dialog screen.

c. Set Initial Size (MB) and Maximum Size (MB) to 1000 MB (or more if 
you have sufficient Space Available), then click Set > OK > OK (reboot 
message) > OK (reboot message - no) > OK and close remaining screens. 
Remember, this change does not take effect until you reboot.

2. Install the 89600 VSA software as follows:

a. Insert the Agilent Technologies 89600 Series Software CD into the scope's 
CD drive. If your scope does not have a CD drive, use the USB procedure 
described in steps 1 - 7 of Chapter 9 , “Installing Agilent 89600 Software in 
Agilent X-Series Signal Analyzers,” on page 131.

b. When the Agilent 89600 Installation Manager window opens, select Install 
89600 Series Software. Continue through the InstallShield Wizard to 
complete the installation.

c. In the Select Products and Features window, select Agilent 89600 VSA. 
Click ext.

NOTE Only the 89600 VSA software is currently supported in your Infiniium scope.

d. When the installation is complete, exit the Installation Manager.

NOTE When installing the 89600 VSA in an Infiniium scope, Hardware support is 
disabled. This prevents using disk space for unnecessary components that are not 
needed when the 89600 VSA software is installed in a logic analyzer.
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3. Start the 89600 VSA. Click Start > Programs > Agilent 89600 VSA > Vector 
Signal Analyzer.
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Verifying correct operation
If a Simulated Hardware watermark does not appear in the trace area of the VSA, 
the installation is complete and the VSA is operating properly. If the watermark 

 does appear in the 89600 display, follow these steps to solve the 
problem.

To verify correct operation:

1. Exit the 89600 VSA application.

2. If the Infiniium application is not running, start the Infiniium application and 
restart the 89600 VSA application (click Start > Programs > Agilent 89600 
VSA > Vector Signal Analyzer).

3. If the Simulated Hardware water mark still appears, check the hardware 
configuration as follows:

a. in the 89600 VSA window click Utilities > Hardware.

b. Check the Default Hardware check box and click OK.

4. If the Infiniium application is running, then there is a VISA configuration 
problem, which you can fix as follows:

a. Stop the VSA application.

b. Minimize the Infiniium application.

c. Start the Connection Expert application by clicking Start > All Programs > 
Agilent IO Libraries > Agilent Connection Expert.

d. Make sure that the GPIB0 (VISA Name), hipb7 (SICL Name) interface 
appears in the Configured Interfaces list.

e. If it does not appear then highlight Internal Instrument in the Available 
Interface Type list and click Configure then OK until the configuration is 
complete.

f. Restart the VSA application.

Continue with Step 5 (Page 20).
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Installing Agilent 89600 Software in Agilent X-Series Signal Analyzers
Introduction
Introduction
This chapter contains information for installing the Agilent 89600 VSA software 
into an Agilent X-Series Signal Analyzer. 

NOTE Verify that the Instrument software revision (System hardkey > Show softkey > 
System softkey) is A.01.40 or greater.

If you have an Internet connection to the X-series analyzer, you can download the 
Agilent 89600 VSA software from the Agilent 89600 VSA Analysis software 
home page (www.agilent.com/find/89600). 

You can also install the software from the Agilent 89600 software product CD. 
Since the Agilent X-Series Signal Analyzers do not have a CD drive you can use a 
USB Flash drive. The first step is to copy the contents of the Agilent 89600 VSA 
Software CD onto the USB Flash Drive. The Agilent 89600 VSA software CD is 
not protected or encrypted. The copy will be identical to the original CD.

NOTE This procedure assumes that a USB Flash Drive is being used. Other USB storage 
devices, such as a USB hard drive or USB CD/DVD drive, could also be used. 
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Installing the 89600 software in an Agilent X-Series 
Signal Analyzer
This section provides the instructions for installing the 89600 software in an 
Agilent X-Series Signal Analyzer using a USB Flash drive.

1. Insert the Agilent 89600 VSA Software CD into a PC’s CD drive. If the Agilent 
89600 Installation Manager window opens, close the installer program (click 
Exit).

2. Insert a USB Flash Drive into a USB port on the same PC that the Agilent 
89600 VSA Software CD is in.

3. Copy the contents of the Agilent 89600 VSA Software CD onto the USB Flash 
Drive.

4. Connect a USB keyboard and mouse to the analyzer.

NOTE To install the Agilent 89600 VSA software on the analyzer, you need to have 
administrator privileges. Press Ctrl - Alt - Delete, then click Log Off.... Log back 
in as the Administrator. The default password is agilent4u.

5. Insert the USB Flash Drive into an available USB port.

6. Open Windows Explorer and navigate to the USB drive.

7. Double-click autoplay.EXE to bring up the Agilent 89600 Installation 
Manager.

8. When the Agilent Installation Manager window opens, click Install 89600 
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Series Software. Continue through the InstallShield Wizard to complete the 
installation.

NOTE In the Select Products and Features window of the InstallShield Wizard, select 
Agilent 89600 VSA. Only the 89600 VSA software is currently supported in your 
Agilent X-Series Signal Analyzer.

9. When the installation is complete, exit the Installation Manager.

NOTE When installing the 89600 VSA in a logic analyzer mainframe, Hardware 
support is disabled. This prevents using disk space for unnecessary components 
that are not needed when the 89600 VSA software is installed in a logic analyzer.
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Verifying correct operation

To verify correct operation:

1. Start tht X-Series analyzer application: Double-click the LaunchXSA icon on 
the Windows desktop.

2. After the X-Series analyzer finishes booting up, start the Agilent 89600 VSA 
analyzer (press the Mode hardkey and the 89601 VSA softkey to launch the 
89600 VSA software).

Continue with Step 5 (Page 20).
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Linking Logic Analyzers to the Agilent 89600 VSA
Introduction
Introduction
This chapter includes information related to the Agilent 89600 series Vector Signal 
Analyzer’s link to selected Agilent Logic Analyzers. This capability is available 
with 89601A VSA software revision 6.00 and higher.

The 89600 VSA can capture and analyze time series data on a digital bus using 
either an Agilent 1680, 1690, 16800, or 16900 series Logic Analyzer as a data 
source. The Agilent 1680, 1690, 16800, and 16900 series Logic Analyzers all use 
the same Logic Analyzer software. The Logic Analyzer link to the 89600 VSA is 
available with Logic Analyzer software revision 3.20 and higher.

The Distortion Suite application (89604A) supports the Logic Analyzer as 
acquisition hardware as long as Use 89600 VSA Application and Show 89600 
VSA are selected. To select Use 89600 VSA Application and Show 89600 VSA, 
start the Distortion Suite application and click MeasSetup > Connection and 
select Use 89600 VSA Application and select Show 89600 VSA.

The 89607A Wireless LAN Test application does not support the Logic Analyzer 
as acquisition hardware.

The 89601A software’s Swept Spectrum Analyzer application does not support the 
Logic Analyzer Link.
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Configurations

16900 Series Logic Analyzers

The 16900 series Logic Analyzer application runs on any PC running Windows 
XP Professional. The PC can be embedded in the 16900 series Logic Analyzer 
mainframe, or the PC can be connected to the Logic Analyzer mainframe via a 
LAN.

NOTE The Logic Analyzer application version 3.20 or higher supports both Windows XP 
Professional Service Pack 1 and Windows XP Professional Service Pack 2.

The 16900 series Logic Analyzer application can be configured to run online or 
offline. The online configuration acquires data from a digital device using the 
measurement hardware in the Logic Analyzer mainframe. The offline 
configuration uses data previously recorded and saved by the Logic Analyzer. 
Offline analysis does not require a connection to the Logic Analyzer mainframe.

The 89600 VSA application runs on any PC running Window Vista or Windows 
XP Professional. The 89600 VSA application runs on either the 16900 series Logic 
Analyzer mainframe or on a separate PC. The 89600 VSA works with the 16900 
series Logic Analyzer whether the 16900 series Logic Analyzer is online or 
offline.

Configurations for linking the Agilent 16900 series Logic Analyzer to the Agilent 
89600 VSA are:

• Logic Analyzer application and VSA application both running on the Logic 
Analyzer mainframe. From a speed standpoint, this is generally the highest 
performance configuration.

• Logic Analyzer application running on the Logic Analyzer mainframe. VSA 
application running on a separate PC. The VSA application communicates with 
the Logic Analyzer via the LAN interface.

NOTE The PC and the Logic Analyzer mainframe must both be members of the same 
domain or workgroup. If the PC and the Logic Analyzer are members of the same 
workgroup, you must log on to both the PC and the Logic Analyzer using the same 
user name. If the Logic Analyzer is a member of a workgroup, and uses Windows 
XP Professional, make sure that it does not use simple file sharing. Click Start > 
My Computer > Tools > Folder Options > View and clear Use simple file 
sharing (Recommended) if currently selected.

• Logic Analyzer application and VSA application both running on the same PC. 
The Logic Analyzer application communicates with the Logic Analyzer 
mainframe via the LAN interface. 
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Logic Analyzer Measurement Module Support

The 89600 VSA application supports the 16900 series Logic Analyzer mainframes 
and the following Logic Analyzer measurement modules. See table below.

In addition to the measurement modules listed above, the 89600 VSA application 
supports 16900 series Logic Analyzer integrated software tools. Examples of 
Logic Analyzer software tools include tools that provide flexible de-serialization 
of serial data, and tools that serialize several parallel busses into one bus. The 
software tools are integrated with the Logic Analyzer application, and the output 
of these software tools look like parallel bus data to the 89600 VSA.

The 89600 VSA reads the collection of tools, identifies those that can be used as 
input, and adds them to the collection of module names available for analysis.

Table 10-1 Supported Logic Analyzer Measurement Modules

State/Timing Cards Maximum Clock 
Speed (MHz)

Maximum State 
Acquisition Rate 

(Mb/s)

Maximum Memory 
(MB)

16950A 600 800 64

16910A/11A 450 500 32

16740A/41A/42A 200 200 2/8/32

16750B/51B/52B 400 400 2/8/32/128

16753A/54A/55A/56A 600 600 2/8/32/128

16760A 800 1500 128
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1680 and 16800 Series Logic Analyzers

The 1680 and 16800 series Logic Analyzer application runs on any PC running 
Windows XP Professional. The PC can be embedded in the 1680 or 16800 series 
Logic Analyzer mainframe, or the PC can be connected to the Logic Analyzer 
mainframe via a LAN.

NOTE The Logic Analyzer application version 3.20 or higher supports both Windows XP 
Professional Service Pack 1 and Windows XP Professional Service Pack 2.

The 1680 and 16800 series Logic Analyzer application can be configured to run 
online or offline. The online configuration acquires data from a digital device 
using the measurement hardware in the Logic Analyzer mainframe. The offline 
configuration uses data previously recorded and saved by the Logic Analyzer. 
Offline analysis does not require a connection to the Logic Analyzer mainframe.

The 89600 VSA application runs on any PC running Windows Vista or Windows 
XP Professional. The 89600 VSA application runs on either the 1680 or 16800 
series Logic Analyzer mainframe or on a separate PC. The 89600 VSA works with 
the 1680 or 16800 series Logic Analyzer whether the 1680 or 16800 series Logic 
Analyzer is online or offline.

Configurations for linking the Agilent 1680 or 16800 series Logic Analyzer to the 
Agilent 89600 VSA are:

• Logic Analyzer application and VSA application both running on the Logic 
Analyzer mainframe. From a speed standpoint, this is generally the highest 
performance configuration.

• Logic Analyzer application running on the Logic Analyzer mainframe. VSA 
application running on a separate PC. The VSA application communicates with 
the Logic Analyzer via a LAN interface.

NOTE The PC and the Logic Analyzer mainframe must both be members of the same 
domain or workgroup. If the PC and the Logic Analyzer are members of the same 
workgroup, you must log on to both the PC and the Logic Analyzer using the same 
user name. If the Logic Analyzer is a member of a workgroup, and uses Windows 
XP Professional, make sure that it does not use simple file sharing. Click Start > 
My Computer > Tools > Folder Options > View and clear Use simple file 
sharing (Recommended) if currently selected.

• Logic Analyzer application and VSA application both running on the same PC. 
The Logic Analyzer application communicates with the Logic Analyzer 
mainframe via a LAN interface.

1690 Series Logic Analyzers

The 1690 series Logic Analyzer application runs on any PC running Windows XP 
Professional.
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NOTE The Logic Analyzer application version 3.20 or higher supports both Windows XP 
Professional Service Pack 1 and Windows XP Professional Service Pack 2. 

NOTE Unlike the 1680, 16800, and 16900 series Logic Analyzers, the 1690 series Logic 
Analyzer does not have an embedded PC in the Logic Analyzer mainframe.

The 1690 series Logic Analyzer mainframe must be connected to a PC via an IEEE 
1394 Firewire interface. Refer to the instructions that came with the IEEE 1394 
Connection Kit for IEEE 1394 installation help.

The 1690 series Logic Analyzer application can be configured to run online or 
offline. The online configuration acquires data from a digital device using the 
measurement hardware in the Logic Analyzer mainframe. The offline 
configuration uses data previously recorded and saved by the Logic Analyzer. 
Offline analysis does not require a connection to the Logic Analyzer mainframe.

The 89600 VSA application runs on any PC running Windows Vista or Windows 
XP Professional. The 89600 VSA application works with the 1690 series Logic 
Analyzer whether it is online or offline. 

Configurations for linking an Agilent 1690 series Logic Analyzer to an Agilent 
89600 VSA are:

• Logic Analyzer application and VSA application both running on the same PC. 
The Logic Analyzer application communicates with the Logic Analyzer 
mainframe via the IEEE 1394 interface. From a speed standpoint, this is 
generally the highest performance configuration.

• Logic Analyzer application and VSA application running on separate PCs. The 
Logic Analyzer application communicates with the Logic Analyzer mainframe 
via the IEEE 1394 interface. The VSA application communicates with the 
Logic Analyzer application via the LAN interface.

NOTE The two PC’s must be members of the same domain or workgroup. If the PC’s are 
members of the same workgroup, you must log on to both PC’s using the same 
user name.
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Software Installation
The first step is to decide where you want to install the Logic Analyzer software 
and the 89600 Vector Signal Analyzer software. See “Configurations” on page 139 
for information on configurations.

Logic Analyzer Software Installation

The Logic Analyzer software comes installed on the Agilent 1680, 16800, and 
16900 series Logic Analyzer mainframes. The 1690 series Logic Analyzers 
require the Logic Analyzer software to be installed on a PC. The Logic Analyzer 
software is available as a free download at http://www.agilent.com/find/logic. For 
Logic Analyzer software installation assistance, refer to the Logic Analyzer 
Installation Guide.

89600 Vector Signal Analyzer Software Installation

NOTE It is useful to have an external keyboard and mouse connected to the Logic 
Analyzer mainframe on which you intend to install and run the VSA software.

To install the 89600 Vector Signal Analyzer software on a PC, follow the 
instructions in “Installing 89600 Software” on page 24.

To install the 89600 Vector Signal Analyzer software in an Agilent 1680 or 16900 
series Logic Analyzer mainframe with a built in CD drive, be sure to log on with 
administrator privileges.

To install the 89600 software:

a. Insert the Agilent Technologies 89600 Series Software CD into the logic 
analyzer’s CD drive.

NOTE The 16901 and the 16800 Series Logic Analyzers do not have built in CD drives. 
To install the 89600 VSA software in a Logic Analyzer mainframe without a built 
in CD drive, copy the contents of the 89600 VSA software onto a USB device, 
such as a USB Flash Drive. Log on to the Logic Analyzer with administrator 
privileges, insert the USB Flash Drive with the Agilent 89600 VSA software on it, 
browse to and double-click on autoplay.exe.

b. When the Agilent 89600 Installation Manager window opens, select Install 
89600 Series Software. Continue through the InstallShield Wizard to complete 
the installation.

c. In the Select Products and Features window, select Agilent 89600 VSA. 

NOTE Only the 89600 VSA software is currently supported in your Logic Analyzer.

d. When the installation is complete, exit the Installation Manager.
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NOTE When installing the 89600 VSA in a logic analyzer mainframe, Hardware 
support is disabled. This prevents using disk space for unnecessary components 
that are not needed when the 89600 VSA software is installed in a logic analyzer.
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Connecting to a etwork
If either the Logic Analyzer application or the Vector Signal Analyzer application 
requires access to the Logic Analyzer mainframe via a LAN, you must:

• Configure the Logic Analyzer mainframe firewall to enable applications to 
access it.

• Set up a direct LAN connection between the host computer and the Logic 
Analyzer mainframe using a CAT5 crossover LAN cable or set up the Logic 
Analyzer mainframe to communicate via your intranet using a standard CAT5 
LAN cable.

• Install the Logic Analyzer COM Automation client software on your remote 
computer.

NOTE The PC and the Logic Analyzer mainframe must both be members of the same 
domain or workgroup. If the PC and the Logic Analyzer are members of the same 
workgroup, you must log on to both the PC and the Logic Analyzer using the same 
user name. If the Logic Analyzer is a member of a workgroup and uses Windows 
XP Professional, make sure that it does not use simple file sharing. Click Start > 
My Computer > Tools > Folder Options > View and clear Use simple file 
sharing (Recommended) if currently selected

Follow the instructions in the Logic Analyzer help topic Setting Up for COM 
Automation to properly set up your network connection and configure the 
firewall. To access the Setting Up for COM Automation information, start the 
Logic Analyzer application and click Help > Help Topics > COM Automation > 
Setting Up for COM Automation.

The preferred method for installing the Logic Analyzer COM Automation client 
software is to install the Logic Analyzer software on the remote computer. 
Installing the Logic Analyzer software automatically installs the COM Automation 
client. This gives you the benefit of having Logic Analyzer offline analysis 
capability and the COM Automation client set up on each computer you use to link 
to the Logic Analyzer. For a free copy of the latest Logic Analyzer software, go to 
http://www.agilent.com/find/logic.

If you would prefer to not install the Logic Analyzer software on your remote 
computer, you can install just the Logic Analyzer COM Automation client 
software. The Logic Analyzer COM Automation client software is available on 
any system that has the Logic Analyzer software installed. The file name is 
SetupLACOM.exe. The file is located at C:\Program Files\Agilent 
Technologies\Logic Analyzer\SetupLACOM.exe. For additional information on 
installing the Logic Analyzer COM Automation client software, refer to Setting 
Up for COM Automation in the Logic Analyzer online help.

For information on configuring the 89600 VSA LAN interface, see “Configuring 
the LAN interface” on page 97.
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Overview

Agilent 89600 I/O Connections is a software utility that helps you to quickly 
connect and configure your LAN-connected Logic Analyzer instruments, verify 
operation, and troubleshoot connectivity problems. The 89600 I/O Connections 
software is installed with the 89600 Vector Signal Analyzer software. To start the 
89600 I/O Connections utility, click Start > (All) Programs > Agilent 89600 
VSA > Logic Analyzer > IO Connections. 

An explorer pane appears when you start the 89600 I/O Connections utility. The 
explorer pane is a graphical representation of your test system and its status. The 
following screen shot is of an 89600 I/O Connections explorer pane. 

Adding an Instrument

You can use the Agilent 89600 I/O Connections utility to add an instrument in any 
of the following ways.

• Click Add Instrument on the toolbar.

• Right-click anywhere in the Explorer Pane, then click Add Instrument.

• From the menu bar, click I/O Configuration > Add Instrument.

When the Add Instrument dialog box appears, select Agilent Logic Analyzer and 
click OK.

When the Add LA  Instrument dialog box appears, configure your Logic Analyzer 
in one of the following ways.

• If you know the hostname of the Logic Analyzer, select Hostname and enter 
the Logic Analyzer hostname.

• If you know the IP address of the Logic analyzer, select IP address and enter 
the IP address of the Logic analyzer.

Click Test Connection, verify the connection works and click OK.

For additional information on the Agilent 89600 I/O Connections utility, refer to 
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the 89600 Vector Signal Analyzer online help. To get access to the online help, 
start the 89600 VSA application, then click Help > Contents. Information about 
the Agilent 89600 IO Connections is located under Product Overview > 
Measurement Hardware > Agilent 89600 IO Connections.
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Logic Analyzer application and 89600 VSA application running 
on the same PC

This example guides you through the 89600 VSA and Logic Analyzer setups 
required to display a North American Digital Cellular (NADC) signal acquired by 
the Logic Analyzer. This example is valid when both the Logic Analyzer 
application and the VSA application are running on the same PC.

Step 1. Close the 89600 Vector Signal Analyzer application.

Step 2. Start the Logic Analyzer application.

Step 3. Select Open File when the following dialog box appears. 

Step 4. When the Open dialog box appears, click the Look in drop down menu and open 
C:\Program Files\Agilent\89600 VSA\LogicAnalyzer\demo nadc statedata.ala. 
The file demo nadc statedata.ala is a configuration and data file of an NADC 
signal that was installed with the 89601A software. 

Step 5. Click Start > (All) Programs > Agilent 89600 VSA > Logic Analyzer > IO 
Connections. When the Agilent 89600 I/O Connections dialog box appears, click 
Add Instrument. When the Add Instrument dialog box appears, select Agilent 
Logic Analyzer and click OK. Type localhost in the Hostname text box. Click 
Test Connection to make sure the connection works. Click OK.

Step 6. Start the 89600 Vector Signal Analyzer application.

Step 7. Click Utilities > Hardware. Clear Default Hardware if currently selected. Clear 
Simulate Hardware if currently selected. Select TCPIP::localhost as ADC 1 and 
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click OK.

NOTE Selecting TCPIP::localhost as ADC 1 can create a hardware configuration that is 
not supported. A red X on a hardware tab in the Select Hardware dialog box 
indicates a hardware configuration that is not supported. Click hardware tabs that 
have a red X and clear the current hardware selection. Refer to the ADC Tab 
section of the 89600 VSA online help for more information on hardware 
configurations.

Step 8. Click Input > Digital. Type 97.2 kSa/Sec in the Frequency Sample Rate text box. 
Your Input Properties dialog box Digital settings should now be the same as the 
settings in the following Input Properties dialog box. 

Step 9. Click Close.

Step 10. If the 89600 VSA is paused, click the Restart button.
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Your 89600 VSA display should look similar to the following screenshot. 

NOTE If your 89600 VSA does not have option AYA, Vector Modulation Analysis, this is 
the end of the example. If your 89600 VSA does have option AYA, you can now 
digitally demodulate this signal.

Step 11. Click MeasSetup > Demodulator > Digital Demod.

Step 12. Click MeasSetup > Demod Properties. In the Format Tab dialog box, click 
Preset to Standard > Cellular > ADC. In the Search Tab dialog box, clear the 
Pulse Search selection. Click Close.

Your 89600 VSA display should now look similar to the following screenshot. 
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Logic Analyzer application and 89600 VSA application 
running on the Logic Analyzer mainframe

This example guides you through the 89600 VSA and Logic Analyzer setups 
required to display a North American Digital Cellular (NADC) signal acquired by 
the Logic Analyzer. This example is valid when both the Logic Analyzer 
application and the VSA application are running on the Logic Analyzer 
mainframe.

Step 1. Close the 89600 Vector Signal Analyzer application.

Step 2. Start the Logic Analyzer application.

Step 3. Click File > Open.

Step 4. When the Open dialog box appears, click the Look in drop down menu and open 
C:\Program Files\Agilent\89600 VSA\LogicAnalyzer\demo nadc statedata.ala. 
The file demo nadc statedata.ala is a configuration and data file of an NADC 
signal that was installed with the 89601A software.

Step 5. If the Module Mapping dialog box appears, select Switch to ‘Offline’ mode and 
load the configuration as-is.  
 
If the dialog box does not appear, click File > Go Offline. Click Ok in the 
Information dialog box.

Step 6. Click Start > (All) Programs > Agilent 89600 VSA > Logic Analyzer > IO 
Connections. When the Agilent 89600 I/O Connections dialog box appears, click 
Add Instrument. When the Add Instrument dialog box appears, select Agilent 
Logic Analyzer and click OK. Type localhost in the Hostname text box. Click 
Test Connection to make sure the connection works. Click OK.

Step 7. Start the 89600 Vector Signal Analyzer application.

Step 8. Click Utilities > Hardware. Clear Default Configuration if currently selected. 
Clear Simulate Hardware if currently selected. Select TCPIP::localhost as ADC 
1 and click OK.

NOTE Selecting TCPIP::localhost as ADC 1 can create a hardware configuration that is 
not supported. A red X on a hardware tab in the Select Hardware dialog box 
indicates a hardware configuration that is not supported. Click hardware tabs that 
have a red X and clear the current hardware selection. Refer to the ADC Tab 
section of the 89600 VSA online help for more information on hardware 
configurations.

Step 9. Click Input > Digital. Type 97.2 kSa/Sec in the Frequency Sample Rate text box. 
Your Input Properties dialog box Digital settings should now be the same as the 
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settings in the following Input Properties dialog box. 

Step 10. Click Close.

Step 11. Click the Play button on the 89600 VSA.
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The 89600 VSA display on the Logic Analyzer should look similar to the 
following screen shot. 

NOTE If your 89600 VSA does not have option AYA, Vector Modulation Analysis, this is 
the end of the example. If your 89600 VSA does have option AYA, you can now 
digitally demodulate this signal.

Step 12. Click MeasSetup > Demodulator > Digital Demod.

Step 13. Click MeasSetup > Demod Properties. In the Format Tab dialog box, click 
Preset to Standard > Cellular > ADC. In the Search Tab dialog box, clear the 
Pulse Search selection. Click Close.

Your 89600 VSA display should now look similar to the following screen shot. 
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Logic Analyzer application running on the Logic Analyzer 
mainframe and 89600 VSA application running on a separate PC

This example guides you through the 89600 VSA and Logic Analyzer setups 
required to display a North American Digital Cellular (NADC) signal acquired by 
the Logic Analyzer. This example is valid when the Logic Analyzer application is 
running in the Logic Analyzer mainframe and the VSA application is running on a 
separate PC.

The connection from the PC to the Logic Analyzer mainframe is made with a LAN 
cable. The PC and the Logic Analyzer mainframe can be connected to your 
intranet, or you can connect a crossover LAN cable directly between the PC and 
the Logic Analyzer mainframe. 

NOTE The PC and the Logic Analyzer mainframe must both be members of the same 
domain or workgroup. If the PC and the Logic Analyzer are members of the same 
workgroup, you must log on to both the PC and the Logic Analyzer using the same 
user name. If the Logic Analyzer is a member of a workgroup, and uses Windows 
XP Professional, make sure that it does not use simple file sharing. Click start > 
My Computer > Tools > Folder Options > View and clear Use simple file 
sharing (Recommended) if currently selected.

Step 1. Locate the file demo nadc statedata.ala on the PC that has the 89600 Vector Signal 
Analyzer application installed on it. The file is located at C:\Program 
Files\Agilent\89600 VSA\LogicAnalyzer\demo nadc statedata.ala. The file demo 
nadc statedata.ala is a configuration and data file of an NADC signal that was 
installed with the 89601A software. You need to copy this file onto your Logic 
Analyzer mainframe.

Step 2. Close the 89600 Vector Signal Analyzer application.

Step 3. Start the Logic Analyzer application on the Logic Analyzer mainframe.

Step 4. Click File > Open.

Step 5. When the Open dialog box appears, click the Look in drop down menu and browse 
to the location where you copied the demo nadc statedata.ala file in step 1 and 
open the file.

Step 6. If the Module Mapping dialog box appears, select Switch to ‘Offline’ mode and 
load the configuration as-is. 
 
If the dialog box does not appear, click File > Go Offline. Click Ok in the 
Information dialog box.

NOTE The remaining steps are performed on the PC that has the 89600 Vector Signal 
Analyzer application installed on it.

Step 7. Click Start > (All) Programs > Agilent 89600 VSA > Logic Analyzer > IO 
Connections. When the Agilent 89600 I/O Connections dialog box appears, click 
Add Instrument. When the Add Instrument dialog box appears, select Agilent 
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Logic Analyzer and click OK. Type localhost in the Hostname text box. Click 
Test Connection to make sure the connection works. Click OK.

NOTE The Host ame of your Logic Analyzer mainframe can be found by clicking Start 
> My Computer > View System Information > Computer ame. The Full 
computer name is the Host ame.

Step 8. Start the 89600 Vector Signal Analyzer application.

Step 9. Click Utilities > Hardware. Clear Default Configuration if currently selected. 
Clear Simulate Hardware if currently selected. Select TCPIP::<Host ame> or 
TCPIP::<IP address> as ADC 1 and click OK.

NOTE Selecting TCPIP::<Host ame> or TCPIP::<IP address> as ADC 1 can create 
a hardware configuration that is not supported. A red X on a hardware tab in the 
Select Hardware dialog box indicates a hardware configuration that is not 
supported. Click hardware tabs that have a red X and clear the current hardware 
selection. Refer to the ADC Tab section of the 89600 VSA online help for more 
information on hardware configurations.
Chapter 10  157



Linking Logic Analyzers to the Agilent 89600 VSA
Logic Analyzer Link Examples
Step 10. Click Input > Digital. Type 97.2 kSa/Sec in the Frequency Sample Rate text box. 
Your Input Properties dialog box Digital settings should now be the same as the 
settings in the following Input Properties dialog box.

Step 11. Click Close.

Step 12. Click the Play button on the 89600 VSA.

Your 89600 VSA display should now look similar to the following screenshot.
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NOTE If your 89600 VSA does not have option AYA, Vector Modulation Analysis, this is 
the end of the example. If your 89600 VSA does have option AYA, you can now 
digitally demodulate this signal.

Step 13. Click MeasSetup > Demodulator > Digital Demod.

Step 14. Click MeasSetup > Demod Properties. In the Format Tab dialog box, click 
Preset to Standard > Cellular > ADC. In the Search Tab dialog box, clear the 
Pulse Search selection. Click Close.

Your 89600 VSA display should now look similar to the following screenshot.
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Introduction
This chapter includes information related to the Agilent 89600 series Vector Signal 
Analyzer’s link to the Synthetic Instrument (SI) Spectrum Analyzer. This 
capability is available with 89600 VSA software revision 6.20 and higher.

The following Agilent Technologies LXI (LAN eXtensions for Instrumentation) 
models are supported by the 89600 VSA software.

• N8201 26.5 GHz Performance Downconverter Synthetic Instrument Module

• N8221 30 MS/s IF Digitizer Synthetic Instrument Module

The 89600 VSA Software supports the N8201 and the N8221 when they are used 
together to make a Synthetic Instrument (SI) Spectrum Analyzer. 

The 89600 VSA Software also supports the N8201 with option 526 (frequency 
range from 3 Hz to 26.5 GHz), option B7J (1 dB step attenuator from 3 Hz to 3 
GHz), and option H01 or H02 (30 MSa/s internal digitizer) as a stand alone 
spectrum analyzer. All three options, 526, B7J, and H01 or H02 must be installed. 
In this configuration, the N8201 operates exactly like an E4440 PSA in 
narrowband mode. Refer to the 89600 VSA Software Agilent PSA online help for 
stand alone N8201 hardware specific information.

89600 VSA software control of the Agilent SI Spectrum Analyzer requires the use 
of an underlying application program interface (API) called an SI Physics Server. 
You must install and create the SI Physics Server. After the SI Physics Server is 
created, you must configure it to connect to the N8221 and N8201 to create the 
Agilent Synthetic Instrument (SI) Spectrum Analyzer. Only after this process has 
been completed can you proceed to connect the 89600 VSA software to the 
Agilent SI Spectrum Analyzer. Refer to the documentation that came with your 
N8221 and N8201 for information on installing and configuring the SI Physics 
Server.

After the SI Physics Server has successfully established the link to the SI Spectrum 
Analyzer, the Agilent 89600 IO Connections software utility will be used to 
connect the SI Spectrum Analyzer to the 89600 VSA software. The Agilent 89600 
IO Connections software is installed when you install the 89600 VSA software. 
The information in this chapter is intended to step you through the process of using 
the 89600 IO Connections utility to link an SI Spectrum Analyzer to the Agilent 
89600 VSA software. Detailed information on the 89600 IO Connections utility is 
located in the 89600 VSA online help.

The Distortion Suite application (89604A) enables the SI Spectrum Analyzer as 
acquisition hardware. Performance is unspecified.

The Wireless LAN test application (option B7R or 89607A) does not support the 
SI Spectrum Analyzer as acquisition hardware.

The 89600 software’s Swept Spectrum Analyzer application does not support the 
SI Spectrum Analyzer Link.
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89600 VSA software control of the Agilent SI Spectrum Analyzer requires that the 
SI Physics Server has been installed and is connected to the SI Spectrum Analyzer. 
Only after this process has been completed can you proceed to connect the 89600 
VSA software to the Agilent SI Spectrum Analyzer. Please refer to the 
documentation that came with your N8201 and N8221 for information on 
configuring the SI Physics server and connecting the SI Physics Server to the SI 
Spectrum Analyzer.

After the SI Physics Server has been configured and successfully connected to the 
Agilent SI Spectrum Analyzer, follow these steps to connect the 89600 VSA 
software to the Agilent SI Spectrum Analyzer.

NOTE The SI Physics Server can operate in a computer other than the computer the 
89600 VSA software is operating in, however, the SI Physics Server software must 
also be installed in the computer that the 89600 VSA software is operating in. If 
the SI Physics Server is not installed in the same computer that the 89600 VSA 
software is installed in, start with Step 1. If the SI Physics Server is already 
installed in the same computer that the 89600 VSA software is installed in, start 
with Step 6.

Step 1. On the computer that the 89600 VSA software is installed in, insert the SI Physics 
Server software CD and begin the SI Physics software installation process. This 
will bring up the SI Physics Setup Wizard as shown below. Click ext. 

Step 2. Select I agree in the License Agreement window and click ext. 

Step 3. Select an installation folder and select who can access the SI Physics Server. Click 
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ext.

Step 4. Click ext to start the installation.
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Step 5. Click Close after the following Installation Complete window comes up. The SI 
Physics Server software is now installed in the same computer that the 89600 VSA 
software is installed in.

Step 6. Click Start > All Programs > Agilent 89600 VSA > SI Spectrum Analyzer > IO 
Connections. The Agilent 89600 I/O Connections explorer pane will come up. 
Click LA  (TCPIP) then click Add instrument in the toolbar.
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Step 7. The Add Instrument dialog box will come up. Select Agilent Spectrum Analyzer 
and click OK

Step 8. The Configurable Properties dialog box will come up. If the SI Physics Server and 
the 89600 VSA software are running on the same PC, type localhost as the 
Hostname. Type the Physics Server Port number that is shown in the Physics 
Server Settings of the Agilent SI Profile Editor dialog box. If the SI Physics server 
and the 89600 VSA software are running on different computers, enter the IP 
address and Port number where the SI Physics server operates. Click Test 
Connection and verify that the instrument is connected. Click OK to close this 
window after verifying the connection

Step 9. Click Start > All Programs > Agilent 89600 VSA > Vector Signal Analyzer to 
start the 89600 VSA. In the 89600 VSA application, click Utilities > Hardware to 
bring up the Select Hardware window. Clear Simulate Hardware or Default 
Configuration if selected. Select the Agilent SI Spectrum Analyzer for ADC 1. 
The Agilent SI Spectrum Analyzer has the address you entered in the previous 
step. Click OK. The 89600 VSA is now controlling the Agilent SI Spectrum 
Analyzer configured from the N8221 Digitizer and the N8201 Down Converter.
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For additional information about the SI Spectrum Analyzer, such as hardware 
configuration parameters and measurement setup parameters, refer to the 89600 
VSA online help. To get access to the online help, start the 89600 VSA 
application, then click Help > Contents. Information about the SI Spectrum 
Analyzer is located under Product Overview > Measurement Hardware > 
Agilent SI Spectrum Analyzer. Additional information about the Agilent 89600 
IO Connections is located under Product Overview > Measurement Hardware 
> Agilent 89600 IO Connections.
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Connecting Acqiris Waveform Digitizers to the Agilent 89600 VSA
Introduction
Introduction

Overview

This chapter includes information related to the Agilent 89600 Vector Signal 
Analyzer’s link to selected Agilent U1065A and U1066A Acqiris Broadband 
High-Speed Digitizers. This capability is available with 89601A VSA software 
revision 8.00 and higher.

The 89600 VSA can be used to capture and analyze time series data on a digital 
bus by using either an Agilent Acqiris DC222, DC252, DC282, DC438 or DC440 
as a data source. The Acqiris digitizers can be configured with the 89600 VSA 
Software in two different modes:

• Standard Operation - Acqiris Waveform Digitizers are linked to the 89601A 
VSA software running on a PC using the IC414 interface.

• Embedded Operation - Acqiris Waveform Digitizers are linked to the 89601A 
VSA software running on an embedded controller (PC505).

For additional information see the “Acqiris Broadband High-Speed Digitizers 
Using 89601A Vector Signal Analyzer Software” Application Note which can be 
found in the Library > Application Notes section of the Agilent 89600 Series VSA 
website (http://www.agilent.com/find/89600).
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Agilent Acqiris High-Speed Digitizers

The Agilent Acqiris High-Speed Digitizer application runs on any PC running 
Windows XP Professional.

NOTE This application requires the following versions:

• Version 3.2 or later of the Acqiris Digitizer.

• Version 8.00 or later of the 89600 VSA Software (version 9.00 or later for the 
DC440 HF Input).

Configurations for linking the Agilent Acqiris Digitizers to the Agilent 89600 
VSA Software are:

• Standard Operation - Acqiris Waveform Digitizers are linked to the 89600 VSA 
Software running on a PC using the U1056A-101 interface.

• Embedded Operation - Acqiris Waveform Digitizers are linked to the 89600 
VSA Software running on an embedded controller (U1056A-300 Embedded 
CompactPCI Processor).

Acqiris Digitizers Supported

The 89600 VSA application supports the Agilent U1065A and U1066A Acqiris 
Digitizers consisting of the following options:
Table 12-1 Supported Acqiris Digitizers

Model ame 1 Channel 
Bandwidth

2 Channel 
Bandwidth

U1066A - 001 (DC440) 100 MHz 100 MHz

U1066A-001 (DC440) HF Input 164 MHz 164 MHz

U1066A - 002 (DC438) 78.125 MHz 78.125 MHz

U1065A - 001 (DC222) 2 GHz n/a

U1065A - 002 (DC252) 2 GHz 1.5625 GHz

U1065A - 004 (DC282)* 2 GHz 1.5625 GHz

* only supported in 1 channel or 2 channel mode
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Installation for Standard Operation
In Standard Operation mode, the Acqiris Waveform Digitizers are linked to the 
89600 VSA Software running on a PC using the U1056A-101 interface.

The procedure for installing this mode is:

1. Install and configure the ADLINK PCI/PXI-8570 Extension Card in your PC 
using the instructions provided with the card.

2. Setup and configure the crate with the ADLINK PXI 8570 module and Agilent 
Acqiris Digitizers following the instructions provided with the equipment. 
Connect the U1056A-101 interface cable.

3. The installation process may ask you to reboot your computer. Click OK for a 
reboot.

NOTE The digitizer crate must be turned on before the computer reboot for the new 
hardware to be found. Also, whenever the digitizer crate is powered down, your 
computer will need to be rebooted to find the new hardware again.

4. Install the Agilent 89600 VSA Software:

a. Turn on the computer. If the computer is already on, close any applications 
you have open.

NOTE To install the Agilent 89600 VSA Software, you must have administrator 
privileges on the computer you are installing the Agilent 89600 VSA Software on.

b. Insert the Agilent 89600 Series Software installation CD-ROM.

c. If the installation utility does not start automatically, click Start > Run and 
type:

drive:\autoplay.exe

...where drive represents the drive containing the installation CD-ROM. 

Click OK.
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d. When the Agilent 89600 Installation Manager window opens, it is 
recommended that you read the Readme information.

e. To start the 89600 VSA Software installation, click Install 89600 Series 
Software. The Agilent 89600 Series Software - InstallShield Wizard 
window opens. Click ext.

f. Read the license agreement and warranty terms. Click to accept the terms 
and continue installation. If you do not accept the terms, you will not be 
able to install the software. Click ext.
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g. In the Choose Destination Location window of the InstallShield Wizard, 
verify where you want the 89600 Series Software to install. The default, a 
folder named Program Files located off the root of the drive where 
Windows is installed, is recommended. If you want to install the software in 
a different directory, click Change, enter the new directory, and click OK. 
Click ext.

h. In the Select Products and Features window of the InstallShield Wizard, 
select the products and features you want to install. Clear any selections you 
do not want. For example, if you do not want desktop shortcuts (icons) 
created, clear the check box to disable that option.

NOTE Selecting a check box will install that product or feature and clearing a check box 
will uninstall the product or feature.

If you want the Floating License Support, see Chapter 14 , “Setting Up a 
Floating License Server,” on page 197 and Chapter 15 , “Setting Up a 
Floating License Client,” on page 215. 

NOTE Do not select Floating License Support unless you have a product with a Floating 
License.
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Click ext.

i. If Floating License Support is selected in the Select Products and Features 
window, a warning message opens verifying that you do want to install 
floating license support. If you do not, click o.

j. In the Setup Status window of the InstallShield Wizard, click Install.

k. After the software has installed, you will get an attention message 
explaining the 14-day trial license and reminding you to install a permanent 
license prior to the expiration of the 14-day trial license. Click OK.

l. In the InstallShield Wizard Complete window, click Finish.
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m. After the 89600 Series software is installed, the Select Hardware Support 
window opens. To install the Acqiris software, select Hardware Support 
Menu and click ext. 

5. Install the Acqiris VSA Server Software:

a. To start the Acqiris software installation, select Acqiris VSA Server and 
click Install Hardware Support.

NOTE If you do not want to install the Agilent IO Libraries or the VXI-based VSA 
libraries, you will need to clear these check boxes.
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b. When the Agilent Acqiris VSA Server Welcome window opens, click ext.

c. In the Select Installation Folder window, select where you want the Agilent 
Acqiris VSA Server to install. The default folder of C:\Program 
Files\Agilent\Agilent Acqiris VSA Server is recommended. Click ext.

d. In the Confirm Installation window, click ext.

e. When the software has installed, the Installation Complete window will 
open. Click Close.

f. The installation process may ask you to reboot your computer. Click OK for 
a reboot.

6. Run and configure the Acqiris VSA Server.

a. Click Start > All Programs > Agilent Acqiris VSA > Acqiris VSA 
Server. The Agilent Acqiris VSA Configuration window will open. Click 
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ew to configure the Acqiris Digitizer.

b. In the Agilent Acqiris VSA Profile Editor window, after you name and 
configure your digitizer, click Save. If you have more than one digitizer, 
continue to configure and save each one.

NOTE You can configure several server profiles but only one server can be launched at a 
time.
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c. Click Start in the Agilent Acqiris VSA Configuration window to run the 
server. The digitizer software will run its alignment. When it is complete, 
the status will say OK. You may set an appropriate name for each digitizer 
profile.

IMPORTANT The Agilent Acqiris VSA Server window must stay open for the Acqiris digitizer to 
remain connected to the 89600 VSA Software.

7. Run the 89600 VSA Software.

a. Click on the Vector Signal Analyzer icon on your computer or click Start > 
All Programs > Agilent 89600 VSA > Vector Signal Analyzer.

b. Verify the 89600 VSA Software is connected to the digitizer by clicking 
Utilities > Hardware > ADC 1.
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Installation for Embedded Operation
In the Embedded Operation mode, the Acqiris Waveform Digitizers are linked to 
the 89600 VSA Software running on an embedded controller (U1056A-300 
Embedded CompactPCI Processor).

1. Setup and configure the crate with the U1056A-300 controller module and 
Agilent Acqiris Digitizers following the instructions provided with the 
equipment. Connect to the monitor.

2. Install the Agilent 89600 VSA Software:

Since the U1056A-300 Embedded Controller does not have a CD driver, the 
first step is to copy the contents of the Agilent 89600 Series Software 
installation CD-ROM onto a USB Flash Drive. The Agilent 89600 VSA 
Software is not protected or encrypted. The copy you make will be identical to 
the original CD.

NOTE This procedure assumes that a USB Flash Drive is being used. Other USB storage 
devices, such as a USB hard drive or USB CD/DVD drive, could also be used.

a. Insert the Agilent 89600 Series Software installation CD-ROM into a PC’s 
CD drive. If the Agilent 89600 Installation Manager window opens, click 
Exit.

b. Insert a USB Flash Drive into a USB port on the same PC that the Agilent 
89600 Series Software CD-ROM is in.

c. Copy the contents of the Agilent 89600 Series Software CD-ROM into the 
USB Flash Drive.
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d. Insert the USB Flash Drive into the USB port in the U1056A-300 
Embedded Controller.

NOTE To install the Agilent 89600 VSA Software on the controller, you need to have 
administrator privileges. If not, press Ctrl - Alt - Delete, then click Log Off.... Log 
back in as the Administrator.

e. Open Windows Explorer and navigate to the USB drive.

f. Double-click autoplay.EXE to bring up the Agilent 89600 Installation 
Manager.

g. When the Agilent Installation Manager window opens, click Install 89600 
Series Software. The Agilent 89600 Series Software - InstallShield Wizard 
window will open. Click ext.

h. Read the licensing information in the Software License and Warranty 
message window. Click to accept the terms and continue installation. Click 

ext.

i. In the Choose Destination Location window of the InstallShield Wizard, 
verify where you want the 89600 Series Software to install. The default, a 
folder named Program Files located off the root of the drive where 
Windows is installed, is recommended. If you want to install the software in 
a different directory, click Change, enter the new directory, and click OK. 
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Click ext.

j. In the Select Products and Features window of the InstallShield Wizard, 
select Agilent 89600 VSA.

k. In the Setup Status window of the InstallShield Wizard, click Install.

l. After the software has installed, you will get an attention message 
explaining the 14-day trial license and reminding you to install a permanent 
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license prior to the expiration of the 14-day trial license. Click OK.

m. In the InstallShield Wizard Complete window, click Finish.

n. After the 89600 Series software is installed, the Select Hardware Support 
window opens. To install the Acqiris software, select Hardware Support 
Menu and click ext. 

3. Install the Acqiris VSA Server Software:

a. To start the Acqiris software installation, select Acqiris VSA Server and 
click Install Hardware Support.

NOTE If you do not want to install the Agilent IO Libraries or the VXI-based VSA 
libraries, you will need to clear these check boxes.
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b. When the Agilent Acqiris VSA Server Welcome window opens, click ext.

c. In the Select Installation Folder window, select where you want the Agilent 
Acqiris VSA Server to install. The default folder of C:\Program 
Files\Agilent\Agilent Acqiris VSA Server is recommended. Click ext.

d. In the Confirm Installation window, click ext.

e. When the software has installed, the Installation Complete window will 
open. Click Close.

f. The installation process may ask you to reboot your computer. Click OK for 
a reboot.

4. Run and configure the Acqiris VSA Server.

a. Click Start > All Programs > Agilent Acqiris VSA > Acqiris VSA 
Server. The Agilent Acqiris VSA Configuration window will open. Click 
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ew to configure the Acqiris Digitizer.

b. In the Agilent Acqiris VSA Profile Editor window, after you name and 
configure your digitizer, click Save. If you have more than one digitizer, 
continue to configure and save each one.

NOTE You can configure several server profiles but only one server can be launched at a 
time.
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c. Click Start in the Agilent Acqiris VSA Configuration window to run the 
server. The digitizer software will run its alignment. When it is complete, 
the status will say OK. You may set an appropriate name for each digitizer 
profile.

IMPORTANT The Agilent Acqiris VSA Server window must stay open for the Acqiris digitizer 
to remain connected to the 89600 VSA Software.

5. Run the 89600 VSA Software.

a. Click on the Vector Signal Analyzer icon on your computer or click Start > 
All Programs > Agilent 89600 VSA > Vector Signal Analyzer.

b. Verify the 89600 VSA Software is connected to the digitizer by clicking 
Utilities > Hardware > ADC 1.
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Introduction
Introduction
This chapter documents installing and setting up a node-locked license for your 
89601 analyzer. This enables you to run the 89600 VSA software only on this PC. 
You can move the license to another PC, but then you cannot run the software on 
the PC you removed the license from.

NOTE The term PC also refers to products such as analyzers and oscilloscopes running 
the 89600 VSA software.

If you purchased a floating license for your 89600 software, see installation 
instructions in Chapter 14 , “Setting Up a Floating License Server,” on page 197 
and Chapter 15 , “Setting Up a Floating License Client,” on page 215. 

If you are using a demo license, start the 89600 software and follow the 
instructions for accepting a demo license.
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Starting the analyzer
Start the analyzer by double-clicking the appropriate icon on your desktop or by 
clicking:

Start > Programs > Agilent 89600 VSA > Spectrum Analyzer

Start > Programs > Agilent 89600 VSA > Vector Signal Analyzer, 

Start > Programs > Agilent Distortion Suite > Distortion Suite

Start > Programs > Agilent WLA  Test > WLA  Test

You must accept a trial or demo license, or install a permanent license 
(authorization) before you can run the applications. See instructions that follow. 
You can also transfer a license from another computer ("Transferring a license 
from another computer" (page 195)).

NOTE If your analyzer includes measurement hardware and the analyzer does not find it, 
see: “Troubleshooting a VXI IO configuration problem” on page 227.
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When you first run your application, you are prompted to license (or authorize) 
your software. You must obtain and install a valid software Site Key (a unique 
hexadecimal code) to permanently enable the 89600-series software on your 
computer. The licenses required depends on the applications that were purchased:

• The license for the 89600 software enables both the Vector Signal Analyzer and 
the Spectrum Analyzer applications.

• The 89604 Distortion Suite application must be licensed separately. The license 
for the 89604 only enables the Distortion Suite application. If you did not 
purchase the 89600 software, you cannot access the Vector Signal Analyzer or 
Spectrum Analyzer applications independent of Distortion Suite.

• The 89607 WLAN Test application must be licensed separately unless the 
89600 Option B7R was purchased. The license for 89607 only enables the 
WLAN Test application. If you did not purchase the 89600 software, you 
cannot access the Vector Signal Analyzer or Spectrum Analyzer applications 
independent of WLAN Test.

The Trial License enables all software options for the analyzer for fourteen days. 
When you install the permanent Site Key (license), only the options you purchased 
will be enabled.

The Demo License lets you run the software with limited functionality. You cannot 
use measurement hardware, and you can analyze only the recordings provided 
with the software. You must accept a demo license each time you start the 89600 
software, but there is no limit to the number of times you can use a demo license.

NOTE When you accept the trial license, you can run your analyzer without the Site Key 
for fourteen days. You must install the Site Key before the trial license expires, or 
you will have to obtain a new Site Key and the analyzer will stop working. 
 
You do not need to accept the trial license if you will be transferring in a license 
from another computer rather than obtaining a new license. For instructions on 
transferring in a license, see "Transferring a license from another computer" (page 
195).

Continue with "Obtaining a site key (license)" (page 191).
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Obtaining a site key (license)

Follow these steps to obtain your software Site Key:

To find the materials and information you need:

1. Locate the Site Key Request Form in one of these ways:

a. (Preferred) Go to the 89600 webpage at www.agilent.com/find/89600 and 
click Request Site Key. You can paste or type in your Site Code, complete 
the rest of the form, and submit your request.

b. Locate the printed Site Key Request Form. This sheet of paper is in the 
Installation Materials envelope shipped with your analyzer. You can fill in 
the requested information and return the form by fax to (707) 577-5043.

2. Collect the License Certificates for all copies of the 89600 software and each 
software option that you purchased. The License Certificates are printed on 
gray parchment and are shipped in the Installation Materials envelope.

NOTE If you are installing a software update, you need an Update Certificate rather than a 
License Certificate. One Upgrade Certificate covers all the software and options 
installed on one computer.

3. Obtain the site code for your computer. The site code is a 30-character 
hexadecimal code created by the 89600 installation process to identify your 
computer. Each computer has a different site code. There are two ways to find 
the site code:

If you are starting the analyzer for the first time and have not already accepted a 
trial license, follow these steps:

a. Start the application by double clicking the icon or by clicking:

Start > (All) Programs > Agilent 89600 VSA > Spectrum Analyzer | 
Vector Signal Analyzer

-or-

Start > (All) Programs > Agilent Distortion Suite > Distortion Suite

-or-

Start > (All) Programs > Agilent WLA  Test > WLA  Test

If you get an error message saying that the analyzer cannot find VXI 
hardware, see: Chapter 16 , “Diagnostics,” on page 221.

b. When a dialog box asks if you want to obtain authorization, click Yes.

c. Click the ew License tab in the Authorization dialog box.

d. Click Generate Site Code. The Site Code appears in the Site Code box. 
This also accepts a trial license, so that you can operate the analyzer for 14 
days while you obtain and install your permanent license.
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Be sure to obtain and install your Site Key within 14 days. At the end of the 
14-day trial period, the trial license expires, and your Site Code changes. If 
you have not installed your Site Key before this happens, you must obtain a 
new Site Key.

If you previously accepted a trial license, follow these steps:

a. Start the analyzer by double clicking the icon or by clicking Start > (All) 
Programs > Agilent 89600 VSA > Spectrum Analyzer or Vector Signal 
Analyzer or Start > (All) Programs > Agilent Distortion Suite > 
Distortion Suite or Start > (All) Programs > Agilent WLA  Test > 
WLA  Test.

b. Click Utilities > License > Modify. 
The Site Code is displayed in the Site Code box.

CAUTION Be sure to obtain and install your Site Key within 14 days. At the end of the 14-day 
trial period, the trial license expires, and your Site Code changes. If you have not 
installed your Site Key before this happens, you must obtain a new Site Key. When 
the trial license expires, you cannot run the software until you install the correct 
Site Key.
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To complete the Site Key Request Form:

1. Copy the site code onto the Site Key Request Form. The site code contains 30 
hexadecimal characters (digits 0 through 9 and letters A through F). The code is 
not case sensitive, and spaces are optional. (You can copy and paste the site 
code into the Web or ASCII text version of the Site Key Request Form.)

2. (optional) Fill in the Customer’s Computer ID. This is the name or code that 
you use to identify the computer. It might be the name of the person who uses 
the computer (such as John Doe’s PC), or it might be an identifier that your 
company has assigned to the computer (such as lab214).

The Customer’s Computer Name is optional and is included for your 
convenience. If you provide the information, we include it in any 
correspondence we send to you. This is useful for you if you are installing 
licenses on more than one computer, so you can identify which license file goes 
on which computer.

3. Below the Site Code, list the License Certificate Number for each piece of 
software and software option you installed on that computer. You can get this 
number from the gray parchment License Certificate that was shipped with the 
analyzer.

If you are installing a software update, list one Update Certificate Number. It 
covers all software options enabled on the computer.

4. If you ordered software for more than one computer, use separate tables to list 
the site code and license certificate numbers for each computer. You can 
photocopy the form or copy the e-mail form.

5. Fill in the customer name and address information on the Site Key Request 
Form. The fields marked with an asterisk (*) must be completed.

6. Return the Site Key Request Form to Agilent Technologies using one of these 
methods:

a. Submit the form from the Web page.

b. Send the Site Key Request Form via fax to (707) 577-5043. Your Site Key 
will be returned by fax to the number you provided on the form.

7. Close the Authorization or License window.
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Installing a site key

When you receive your Site Key, install it on the computer.

CAUTION Be sure to install your Site Key before your trial license expires. If the trial license 
expires, the Site Code for your computer changes and you must obtain a new Site 
Key.

To install a site key (if your Trial License is still active):

1. Start the analyzer by double-clicking the desktop icon or by clicking:

Start > (All) Programs > Agilent 89600 VSA > Spectrum Analyzer | Vector 
Signal Analyzer

-or-

Start > (All) Programs > Agilent Distortion Suite > Distortion Suite.

-or-

Start > (All) Programs > Agilent WLA  Test > WLA  Test

2. Click Utilities > License > Modify.

3. Copy and paste the Site Key in the space provided and click Update. (The Site 
Key is a hexadecimal number, containing only the numerals 0 through 9 and 
letters A through F. The Site Key is not case sensitive, and spaces are optional.) 
If you received your Site Key via fax, you must type the 26-character Site Key 
in the space.

CAUTION If your trial license has expired, the Site Code for your computer has changed and 
you must obtain a new Site Key. The Site Key you just received will not work.

You can now run your Agilent 89600-series software permanently on this 
computer only. If you want to move the software to another computer, see 
“Transferring a license from another computer” on page 195.

When you install the Site Key, the site code for your computer changes. In addition 
to identifying your computer, the site code also identifies which Agilent 
89600-series software is installed and enabled on your computer.
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Transferring a license from another computer

The Transfer In and Transfer Out tabs of the License dialog box provide the 
mechanism to transfer a single license from one computer to another using a 
license imprint file. To begin such a transfer, the software must be installed on two 
different computers, and there must be at least one valid license installed. Once 
these preconditions exist, take the following steps to transfer the license.

To transfer a license from another computer:

1. Perform the following steps on the target computer (the computer to which you 
want to move the license):

a. Start the analyzer by double clicking on the icon or by clicking  
Start > (All) Programs > Agilent 89600 VSA > Spectrum Analyzer or 
Vector Signal Analyzer 
or Start > (All) Programs > Agilent Distortion Suite > Distortion Suite. 
or Start > (All) Programs > Agilent WLA  Test > WLA  Test.

b. During startup, no license is detected, so the software asks if you wish to 
obtain a license. Click Yes.

c. In the Authorization dialog box, click Transfer In and Register Transfer.

d. Enter the path where you want the license imprint file stored and click OK. 

2. Transfer the license request file to the source computer (the computer that 
currently has the license) using an available transfer medium such as a floppy 
disk, flash drive, or network location.

3. Perform the following steps at the source computer:

a. Start the analyzer.

b. Click Utilities > License > Transfer Out.

c. Provide the path to the location of the license request file, and click OK. 
The licensing software moves the license to the specified location. At this 
time, the license on the source computer is discontinued, or decremented by 
one in the case of multiple licenses.

CAUTION Do not lose the license file--it is now your license for the 89600 analyzer. If you 
lose it, you lose your license.

4. Perform the following steps at the target computer:

a. If the Authorization dialog box is still open, go to the next step. Otherwise, 
start the analyzer. In the Invalid Authorization question box, click Yes.

b. In the Authorization dialog box, click the Transfer In tab, then the 
Transfer In button.

c. Provide the path to the location of the license file, and click OK.

5. The software is now enabled on the target computer.
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Via network drive

A license can never be shared - that is, it must always be assigned to a particular 
computer. In those rare cases when two computers on the same network need to 
run the software sequentially or alternately, the Direct Out license transfer can 
provide a kind of sharing without the need to carry a portable drive from one 
system to another.

To share a license:

1. Install the software on both computers

2. Obtain a license for one of the computers in the usual way and install the 
license.

3. When you want to run the application on the other computer, click  
Utilities > License on the licensed (source) computer and click Direct Out.

4. A dialog box will open asking you for the path to the license destination 
directory on shared network drive. Type or browse to it and click OK. This 
transfers the license to the destination computer and disables the license on the 
source computer.

Now when you open the application on the destination computer, the licensing 
software recognizes that the license has been transferred. The application will no 
longer open on the source computer.
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Introduction
Introduction
This chapter documents installing and setting up a floating license server for your 
89600 analyzer. If you purchased a node-locked license for your 89600 software, 
installation instructions are in Chapter 13 , “Installing a Node-Locked License,” on 
page 187. If you are using a demo license, start the software and follow the 
instructions for accepting a demo license.
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Floating License Overview
Use the information in this chapter to set up a floating license server for the 89600 
software. You must set up the license server and your 89600 license (.lic) file 
before you can run any of the 89600 Series Software that require floating licenses. 
FLEXnet Licensing (floating licenses) require a server computer (to manage 
license control) and client computers (to obtain a license from the server computer) 
for running the 89600-series software. Note that the server computer and client 
computer can be the same PC.

The following operating systems are supported for use as 89600 license servers. 

• Windows 2000

• Windows XP Professional

• Windows Vista Business, Enterprise, or Ultimate (32 bit only)

• Windows 2000 Server

• Windows Server 2003

• Windows Server 2008

NOTE If you are currently using Sun Solaris 8.0 as a FlexLM license server for other 
products and are familiar with configuring the license server, the agilevsa and 
agilevsa2 vendor daemons are available on the 89600 installation CD in 
\unsupported\LicenseDaemon\SunSolaris

NOTE If you will not be running 89600 application software on this PC, install only the 
89600 License Support and no other part of the 89600 software.

These are the basic steps for setting up your FLEXnet Licensing server, which are 
described in the rest of this chapter.

1. "Installing Floating License Support" (page 201).

2. "Obtaining your Floating License File" (page 204)

a. Read Host ID

b. Submit request form

3. "Installing your Floating License File" (page 206)

a. Place Floating License File

b. Enter hostname (optional)

4. "Starting Your License Server" (page 207)
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Redundant license servers

If you will be setting up redundant license servers, see: "Setting up Redundant 
License Servers" (page 209).

Setting up client PCs

To set up FLEXnet Licensing on your client PC (the computer where you will run 
the 89600 software), see: Chapter 15 , “Setting Up a Floating License Client,” on 
page 215.

Adding license files

If you are adding licenses to an existing server, see: "Adding License (.lic) Files" 
(page 211).
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Installing Floating License Support
The 89600 Series Software uses Macrovision’s Flexible License Manager 
(FLEXnet Licensing) software for all floating software security configurations. 
The 89600 setup program installs the FLEXnet Licensing software at 
%SystemRoot%\vsa\licenses\bin, where %SystemRoot% is typically 
C:\WINDOWS.

Installing floating license support does the following:

• Creates the %SystemRoot%\vsa\licenses folder to contain your License File(s).

• Installs the FLEXnet Licensing libraries in the %SystemRoot%\vsa\licenses\bin 
folder.

• Installs the license daemons in the %SystemRoot%\vsa\licenses\vendors folder.

NOTE Agilent 89600 Version 7.0 and greater installs 2 daemons: agilevsa for versions 
less than 7.0 and agilevsa2 for Version 7.0 and greater.

• Installs help files in the <TARGETDIR>\89600 VSA\Help

where <TARGETDIR> is typically C:\Program Files\Agilent

• Installs tools and batch files in the %SystemRoot%\vsa\licenses\help folder

To install floating license support:

NOTE If the 89600 License Support software currently installed on your server computer 
is from an Agilent 89600 CD with version lower than Version 7.0, you will need to 
uninstall and remove the current license support. 

If the 89600 License Support software currently installed on your server computer 
is from an Agilent 89600 CD with Version 7.0 or higher, skip to step 3.

1. If you need to uninstall the current license server, click Start > (All) Programs 
> Agilent 89600 License Support > Server > License Server Uninstall. This 
will not remove your current licenses.

2. To remove the current license support, click Start > Control Panel > Add or 
Remove Programs > Agilent 89600 License Support > Remove. This will 
not remove your current licenses.

3. If you have not installed the 89600 Series Software, insert the Agilent 89600 
Series Software CD into the PC’s CD drive and click autoplay.EXE.

If you have installed the 89600 Series Software:

For a Windows XP system, click Start > Control Panel > Add or Remove 
Programs > Agilent 89600 Series Software > Change.

For a Windows Vista system, click Start > Control Panel > Uninstall a 
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program in Programs > highlight Agilent 89600 Series Software > Change 
in the toolbar. 

The Agilent 89600 Series Software InstallShield Wizard opens. Select Modify 
and click ext.

4. In the Select Products and Features window, select Floating License Support.
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NOTE
Do not clear any of the selected products. Clearing any selected check boxes will 
uninstall that product.

Click ext

5. A warning message opens verifying that you do want to install floating license 
support. Click Yes.

6. Click Finish in the Maintenance Complete window.

7. If you see any errors in the command window, you may need to refresh the 
license support. Click Start > All Programs > Agilent 89600 License 
Support > Server > License Server Refresh.

8. Continue to: "Obtaining your Floating License File" (page 204).
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Obtaining your Floating License File
Before performing these steps, you must have installed the 89600 License Support 
as described in "Installing Floating License Support" (page 201).

CAUTION The new floating license file will NOT support client PCs with less than Version 
7.0 versions of the 89600 VSA Software.

Find the materials and information you need:

1. Locate the Floating License File Request Form in one of these ways:

a. (Preferred) Go to the 89600 Web page at www.agilent.com/find/89600 and 
click Request Floating License File. You can paste or type in your Host 
ID, complete the rest of the form, and submit your request.

b. Locate the printed Floating License File Request Form. This sheet of paper 
is in the Read Me First envelope shipped with your software. You can fill in 
the requested information and return the form by fax to (707) 577-5043.

2. Collect the License Certificates for all copies of the 89600 software and each 
software option that you purchased. The License Certificates are printed on 
gray parchment and are shipped in the Read Me First envelope.

NOTE If you are installing a software update, you need Update Certificates rather than 
License Certificates.

3. Obtain the Host ID for your computer. 

a. Click Start > (All) Programs > Agilent 89600 License Support > Server 
> Host ID.

NOTE If more than one Host ID is listed, use the first one from the list.

b. Copy the line displayed in the Notepad window or print the file. This is the 
Host ID that you will need to obtain a License File.

c. Paste or write the Host ID in the space provided in the License File Request 
Form.

d. Close the Notepad window.
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To complete the License File Request Form:

1. Copy the Host ID (from step 3 on the previous page) onto the Floating License 
File Request Form. (You can copy and paste the Host ID into the Web version 
of the License File Request Form.)

2. (optional) Fill in the Customer’s Computer Name. This is the name or code that 
you use to identify the computer. It might be the name of the person who uses 
the computer (such as John Doe’s PC), or it might be an identifier that your 
company has assigned to the computer (such as lab214).

The Customer’s Computer Name is optional and is included for your 
convenience. If you provide the information, we include it in any 
correspondence we send to you. This is useful for you if you are installing 
licenses on more than one computer, so you can identify which license file goes 
on which computer.

3. Below the Host ID, list the License Certificate Number for each piece of 
software you installed on that computer. You can get this number from the gray 
parchment License Certificate that was shipped with the software.

If you are installing a software update, list your Update Certificate Numbers 
rather than your License Certificate Numbers.

NOTE If you are running 89600 software using several independent license servers, 
submit a separate License File Request for each license server. Each License 
Certificate can only be used once, and is intended to provide a license file for a 
single server. If you need to allocate the licenses within a License Certificate 
across multiple servers, please make a special note of this in your request.

4. Fill in the customer name and address information on the Floating License File 
Request Form.

5. Return the Floating License File Request Form to Agilent Technologies using 
one of the following methods. Your License File will be sent to you by e-mail 
or fax, depending on whether you provided a fax number or e-mail address on 
the request form.

a. Submit the form from the Web page (www.agilent.com/find/89600).

b. Send the Floating License File Request Form via fax to (707) 577-5043.

NOTE The floating license files issued for 89601AN and 89604AN contain license keys 
(codewords) that Agilent will automatically renew every 18 months. To facilitate 
this, please keep the contact information you send to us current. If your software 
notifies you that a renewal is needed, and you have not received a renewal from 
Agilent Technologies, please contact us immediately using one of the methods 
outlined above. Failure to do so will lead to loss of access to the software until the 
license keys are renewed.
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Installing your Floating License File
When you receive your license (.lic) file, you must install it on the server PC. If 
your licenses will be served by a central server, have your system administrator 
install the license (.lic) file on the license server computer.

To install your floating license file:

1.  If you receive your license file via e-mail, open the message in e-mail.

a. Click Start > (All) Programs > Agilent 89600 License Support > Server 
> License Files Directory. This opens an Explorer window in the 
%SystemRoot%\vsa\licenses directory.

b. Drag the license file from the e-mail message and drop it in the licenses 
directory.

2. If you receive your license file via fax, you must type the file and save it under 
the name specified in the fax. The file must go in the directory described in the 
previous step.

3. If you are adding a license file to a previously-installed license server, go to: 
"Adding License (.lic) Files" (page 211).

If you are setting up a redundant license server, go to: "Setting up Redundant 
License Servers" (page 209).

Otherwise, continue to: "Starting Your License Server" (page 207).
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Starting Your License Server
The information in this section shows you how to start your license server.

To start your license server:

1. Start FLEXnet Licensing by clicking Start > (All) Programs > Agilent 89600 
License Support > Server > License Server Install.

a. When the Install License Server window appears, press any key on the 
keyboard.

b. When the installation is finished and reads Finished. Press any key to 
continue . . ., press any key on the keyboard.

2. Verify that the license server is working. Click Start > (All) Programs > 
Agilent 89600 License Support > Server > License Server Status.

When you install the server for Version 7.0 and greater, two files are installed 
(empty_license_file _for _agilevsa2.lic and empty_license_file _for 
_agilevsa.lic) to ensure that the licenses directory has at least one license for 
each of the two daemon names.

3. Inform your clients of the computer name or names and port number (if 
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required) for the server PC.

To find the computer name, click Start > (All) Programs > Agilent 89600 
License Support > LMTOOLS > System Settings. The computer name is 
listed in the Computer/Hostname box.

Clients must add an environment variable called 
AGILEVSA2_LICENSE_FILE. The value for the variable is the computer 
name and, optionally, the port number in this form:

@mike  (if the computer name is mike and no port number is required).

2110@mike (if the computer name is mike and a port number of 2110 is 
required).

You need to specify a port only if it is specified on the SERVER line of the 
license file or files and it is not in the range of 27000 to 27009. The following 
table shows the possible formats for the variable value.

NOTE You must install the 89600 Series Software on each client PC. Rather than 
installing the software from individual CDs, you can copy the CD to a shared 
drive. Then clients can run autoplay.exe from the shared drive to install the 
software on their PCs.

Single server - no port number 
assigned

@mike

Single server - port number assigned 2100@mike

Redundant server - no port number 
assigned

@mike;@mike2;@mike3

Redundant server - port number 
assigned

2100@mike2110;@mike2;2120@mike3
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Setting up Redundant License Servers
FLEXnet lets you set up a redundant license server configuration. This involves 
configuring three license servers with one of the three servers functioning as the 
master server. If the master server goes down, one of the other two servers 
becomes the new master server, and the licenses remain available on the network.

NOTE Setting up redundant servers requires extra system administration and is not 
recommended unless you absolutely need it.

To set up redundant license servers, use the same FLEXnet procedures on all three 
servers. All three servers must be up and running before your licenses are 
available.

To setup redundant license servers:

1. Install the 89600 License Support on all three computers (see: "Installing 
Floating License Support" (page 201)).

2. Obtain your floating license file (see: "Obtaining your Floating License File" 
(page 204)). You must provide the host ID for all three computers.

3.  Install your license file (see: "Installing your Floating License File" (page 
206)) with the following exceptions:

a. Using an ASCII editor, change the default hostname settings in your license 
(.lic) file to the actual hostnames of your license servers. The license servers 
are the machines that will serve the licenses on the network, and whose 
ethernet addresses appear on the SERVER lines:

SERVER <hostname1> <hostid1> <tcp_port> 
SERVER <hostname2> <hostid2> <tcp_port> 
SERVER <hostname3> <hostid3> <tcp_port>

To find the hostname and hostid, click Start > (All) Programs > Agilent 
89600 License Support > LMTOOLS > System Settings. The computer 
name is listed in the Computer/Hostname box. The hostid is listed in the 
Ethernet Address box.

<tcp_port> is the port number for the server, such as 2100

For these examples, one SERVER line would read: 
SERVER mike1 0060b05768ee 2100
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IMPORTANT
Be sure the hostname and hostid in the same line (such as “hostname1” and 
“hostid1”) are for the same computer. 
 
You must also specify a TCP port number for license requests. The license file 
includes a default port number. If this conflicts with other FLEXnet licenses 
on your server, change the port number.

b. Save the license file to <windir>\VSA\licenses.

c. Copy empty license files from <windir>\VSA\licenses\util to 
<windir>\VSA\licenses.

d. Replace the SERVER line in the empty license files with the 3 lines created 
in step a and save to <windir>\VSA\licenses.

e. Copy the 3 license files to the licenses directory on each of the other two 
server PCs.

4. Start the license server on each of the PCs. See: "Starting Your License Server" 
(page 207).

5. Verify that the license servers are installed properly. Click Start > (All) 
Programs > Agilent 89600 License Support > LMTOOLS > Server Status 
> Perform Status Enquiry.

The status should include 3 lines similar to these:

In this example, the hostnames of the three servers are vsa, vsa2, and vsaxp. All 
three servers should be listed as UP, and only one server should be indicated as 
MASTER.
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Adding License (.lic) Files
If you have been running Flexlm and receive updated License Files from Agilent, 
you can add the new licenses to the FLEXnet Licensing environment as below.

To add license (.lic) files:

1. Install the new file from Agilent to the License Files Directory, following the 
instructions in "Installing your Floating License File" (page 206).

2. On the server, click Start > (All) Programs > Agilent 89600 License Support 
> Server > License Server Refresh. This causes the lmgrd on the primary 
server to re-read the license (.lic) files and update all of the other lmgrd 
processes on the network.

IMPORTANT If you are using the LM_LICENSE_FILE for other products, you may see an 
invalid error on the old daemon name when you refresh. You may safely ignore the 
error as the refresh was successful. To verify this, run the status in the next step.

3. After you have done this, you can verify that the license servers have received 
the new license information by clicking Start > (All) Programs > Agilent 
89600 License Support > Server > License Server Status.

If this does not work, you may need to stop and restart the license servers on your 
network.

To stop and restart the license servers:

IMPORTANT This can cause a disruption to your clients using this license server. A warning will 
show on the client computers and after 15 minutes the clients will be terminated if 
the license server is not restarted.

1. Click Start > (All) Programs > Agilent 89600 License Support > Server > 
License Server Uninstall.

2. When instructed to Press any key to continue, do so.

3. Click Start > (All) Programs > Agilent 89600 License Support > Server > 
License Server Install.

4. When instructed to Press any key to continue, do so.
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Managing Multiple Application License Servers on One 
Computer
When you are running multiple FLEXnet Licensing applications, the 
recommended configuration is to run multiple license servers, each running one 
lmgrd and accessing one or more license (.lic) files. This enables you to keep the 
other application’s licensing separate from the 89600 licensing.

To manage multiple application license servers on one computer:

1. Each lmgrd uses a different TCP/IP port. If you specify port numbers in your 
License File(s), then each license server (lmgrd) must use a different port 
number as specified on the SERVER lines of the license (.lic) files. You can use 
a standard text editor to change the port number in each license (.lic) file.

2. You must make sure that you are using a compatible version of lmgrd when you 
start it up for a particular license (.lic) file.

When you have license (.lic) files for two different FLEXnet-licensed products, 
the products may ship with the different versions of FLEXnet Licensing. 
FLEXnet Licensing is designed to handle this situation.

If you install an application that provides a newer version of FLEXnet 
Licensing than was installed for your 89600 program, the easiest way to ensure 
compatibility is to copy  three files from the newer version into the directory 
%SystemRoot%\vsa\licenses\bin. The files you should copy are lmgrd.exe, 
lmtools.exe, and lmutil.exe.

To determine the version of FLEXnet currently in use by the 89600 license, 
click Start > (All) Programs > Agilent 89600 License Support > Server > 
FLEXnet Version.

If the version of FLEXnet Licensing you install with your 89600 program is 
newer than FLEXnet Licensing versions installed for other applications, see the 
documentation for those applications to determine what you need to do.
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Removing 89600 License Support
If you have a node-locked 89600 license installed or have accepted a trial 89600 
license, then you install 89600 License Support on that PC, you hide the other 
licenses. To use either the trial license or node-locked license, you must uninstall 
and remove 89600 License Support.

To uninstall and remove 89600 license support:

1. Click Start > (All) Programs > Agilent 89600 License Support > Server > 
License Server Uninstall. This will not remove your current licenses.

2. Click Start > Control Panel > Add or Remove Programs.

3. Select Agilent 89600 Series Software and click Change. 

4. Select Modify in the Modify, repair or remove Agilent 89600 Series Software 
dialog box and click ext. Clear the Floating License Support checkbox and 
click ext. This will not remove your current licenses.

5. Click Finish.

6. When the removal is finished, close all the Control Panel dialog boxes and 
windows.

You can now run your 89600 software with the node-locked or trial license. When 
your trial license expires, you must reinstall 89600 License Support and install 
your license file before you can run the 89600 software.
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Tools and Batch Files
The FLEXnet support includes several batch files to simplify setting up and 
checking your licenses. You can run these batch files by clicking Start > (All) 
Programs > Agilent 89600 License Support and either Server or LMTOOLS.

FLEXnet Version Run this file to check which versions of FLEXnet and 89600 License Support are 
used for the 89600 license manager.

Host ID Run this file to display the host ID of this computer. If the list includes more than 
one line, use the host ID from the first line.

If you are setting up redundant servers (see page 209), you must provide the host 
ID of all three servers. If more than one host ID is listed for a server, use the first 
host ID listed.

License Files 
Directory

Run this file to open an explorer window in the licenses directory.

License Server 
Install

Run this file to install FLEXnet Licensing as a service and start FLEXnet 
Licensing.

License Server 
Refresh

Run this file after you have installed a new license file or modified an existing 
license file. This forces a currently running FLEXnet Licensing server to reread 
the license files.

License Server 
Status

Run this file to display the number of licenses available and used.

License Server 
Uninstall

Run this file to shut down FLEXnet Licensing and remove FLEXnet Licensing as 
a service.

LMTOOLS This file provides a shortcut to the LMTOOLS utility. LMTOOLS is a graphical 
user interface to the FLEXnet license manager tools. For details on using the tools, 
see the FLEXnet end user document, click Start > (All) Programs > Agilent 
89600 License Support > Help > FLEXnet End User Guide.
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Introduction
Introduction
This chapter documents installing and setting up a floating license client for your 
89600 analyzer. If you purchased a node-locked license for your 89600 software, 
see: Chapter 13 , “Installing a Node-Locked License,” on page 187. If you are 
using a demo license, start the software and follow the instructions for accepting a 
demo license.
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Floating License Overview
The 89600 Series Software uses Macrovision’s FLEXnet Licensing software for 
floating (network) software security configurations. When you run the 89600 
Series Software setup program, the FLEXnet Licensing software is installed at 
%SystemRoot%\vsa\licenses\bin where %SystemRoot% is typically 
C:\WINDOWS.

The FLEXnet Licensing floating licenses require a server computer, to manage 
license control, and client computers, those on which you obtain a license from the 
server and run the 89600 series software.

These are the basic steps to set up FLEXnet Licensing on a client PC:

1. Install 89600 Series Software on your client PC as instructed in Chapter 2 , 
“Installing 89600 Software,” on page 23.

2. Install 89600 license support on your client PC as instructed in Chapter 14 , 
“Setting Up a Floating License Server,” on page 197 

3. Set system environment variables: "Setting the System Environment Variables" 
(page 218).

4. Start the 89600 software: "Starting the 89600 software" (page 220).

NOTE If you install 89600 License Support on a PC that also has a node-locked or trial 
license, you will not be able to use the node-locked or trial license unless you use 
Add/Remove Programs to remove 89600 License Support.
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Setting the System Environment Variables
To run 89600 Series Software and check out a license from the license server, you 
must set the AGILEVSA2_LICENSE_FILE environment variable. 

The environment variable specifies the name of the license server computer (or 
computers) from which you will get a license to run 89600 software. You specify a 
name for the environment variable (AGILEVSA2_LICENSE_FILE) and assign a 
value. The value is the license computer name and, optionally, the TCP port 
number assigned. Your license administrator will provide you with the computer 
name and, if required, the port number.

To set the system environment variables:

1. Get the name of the server computer (or computers) from your license 
administrator.

2. For Windows XP, click Start > Control Panel > System > Advanced > 
Environment Variables.

For Windows Vista, click Start > Control Panel > System and Maintenance 
> System > Advanced system settings in the side panel > Environment 
Variables.

3. Add a new variable named AGILEVSA2_LICE SE_FILE that points to the 
license server computer.

a. Click ew under the User variables or System variables list.

NOTE You can enter the AGILEVSA2_LICENSE_FILE environment variable either as 
a user variable or as a system variable. The user variable affects only the currently 
logged-in user; the system variable affects all users.

b. In the Variable name box, type AGILEVSA2_LICENSE_FILE

c. In the Variable value box, type @ and the name of the server computer 
(mike, in this example). Your license administrator can provide you with 
this information.

d. Click OK, OK, OK, and close the Control Panel window.
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IMPORTANT The AGILEVSA2_LICENSE_FILE environment variable takes precedence over 
any LM_LICENSE_FILE settings you might have set up for other applications 
that use FLEXnet Licensing. AGILEVSA2_LICENSE_FILE is searched first for a 
valid license before LM_LICENSE_FILE. As a result, using the 
AGILEVSA2_LICENSE_FILE variable will isolate your 89600 Series Software 
license configurations from other applications that use the LM_LICENSE_FILE 
variable.
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Starting the 89600 software
Start the application by double-clicking the appropriate icon on your desktop or by 
using the Start menu:

Start > (All) Programs > Agilent 89600 VSA > Spectrum Analyzer | Vector 
Signal Analyzer

Start > (All) Programs > Agilent Distortion Suite > Distortion Suite

Start > (All) Programs > Agilent WLA  Test > WLA  Test.

NOTE If two to three minutes after starting the 89600 VSA software, a License Warning 
message window appears that says Lost connection to network license server for 
the following, you may have a firewall incompatibility. Every two to three minutes, 
the 89600 VSA software will connect to the license server to check the floating 
license status. Some third party firewall applications treat this as a port scan attack 
and will lock out the client. This problem can be fixed by turning off any third 
party firewall software that resides on the server. This is not an issue with the 
Windows firewall.
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Introduction to Diagnostics
This chapter includes procedures for troubleshooting and isolating hardware 
problems.

NOTE For additional troubleshooting information, in the Agilent 89600 window, click 
Help > Roadmap > Troubleshooting.

Before you run diagnostics on VXI analyzers, check the front-panel cable 
connections described in Chapter 3  (see table below).

Refer to table below for a summary of diagnostic procedures in this chapter.

Table 16-1 Front-Panel Cable Connections for VXI Analyzers

Analyzer configuration Cable connections

1-channel 89610A "Cable connections, 89610" (page 52)

2-channel 89610A "Cable connections, two-channel 89610" (page 53)

1-channel 89611A "Cable connections, 89611" (page 55)

2-channel 89611A "Cable connections, two-channel 89611" (page 59)

1-channel 89640A "Cable connections, 89640" (page 61)

89640A, second IF/BB channel "Cable connections, 89640 with second IF/baseband channel" (page 62)

2-RF-channel 89640A "Cable connections, 89640 with second RF channel" (page 64)

1-channel 89641A "Cable connections, 89641" (page 67)

89641A second IF/BB channel "Cable connections, 89641 with second IF/baseband channel" (page 68)

2-RF-channel 89641A "Cable connections, 89641 with second RF channel" (page 70)

Table 16-2 Summary of Diagnostic Issues and Procedures 

Issue Discussion

Your analyzer includes VXI hardware and 
when you start the 89600 software you get a 
message saying the hardware wasn’t found 
(or Simulated Hardware is displayed on the 
trace grid)

Troubleshoot Installation problems: "Troubleshooting a VXI 
installation problem" (page 226).

Troubleshoot a VXI IO problem: "Troubleshooting a VXI IO 
configuration problem" (page 227).

Troubleshoot an IEEE-1394 interface problem: "Troubleshooting 
an IEEE-1394 interface failure" (page 228).

Problem is VXI hardware and you suspect a 
defective module

E1438 ADC module: "Troubleshooting an E1438 ADC module" 
(page 237)

E1439 ADC module: "Troubleshooting an E1439 ADC module" 
(page 238)

E2730 or E2731 RF Tuner module: "Troubleshooting the 
E2730/E2731 module" (page 239)
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Problem is in signal path and you suspect a 
defective module

2.7 GHz RF signal path: "Troubleshooting the 2.7 GHz RF signal 
path" (page 240)

6.0 GHz RF signal path: "Troubleshooting the 6.0 GHz RF signal 
path" (page 243)

0 to 36 MHz baseband signal path: "Troubleshooting the 0 to 36 
MHz baseband signal path" (page 246)

70 MHz IF signal path: "Troubleshooting the 70 MHz IF signal 
path" (page 247)

0 to 40 MHz signal path: "Troubleshooting the 0-to-40 MHz 
baseband signal path" (page 248)

Your analyzer uses non-VXI measurement 
hardware and when you start the 89600 
software you get a message saying the 
hardware wasn’t found (or Simulated 
Hardware appears on the trace grid)

"Troubleshooting a LAN interface problem" (page 230)

Other instruments or devices connected to 
the same computer reset or experience 
errors when you start an 89600 analyzer

"Troubleshooting interference with other devices or instruments" 
(page 233)

The trace data constellation symbol location 
shape, such as dots, is not properly 
displayed.

"Troubleshooting the Display Driver" (page 252)

Table 16-2 Summary of Diagnostic Issues and Procedures 

Issue Discussion
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Recommended Test Equipment
The table below shows you the recommended test equipment.
Table 16-3 Recommended Test Equipment

Instrument Specifications (50 Ω In/Out Impedance) Model

Digital Signal 
Generator

Frequency: 500 kHz to 3 GHz 
Amplitude range: -40 to +16 dBm 
Amplitude resolution: 0.1 dB 
Harmonic level: <-30 dBc 
Spurious: <-90 dBc, <40 MHz 
Spurious: <-78 dBc, <2.56 GHz 
SWR: <1.5 
Frequency Reference Out: 10 MHz 
   Amplitude: ~7 dBm 
   SSB Phase Noise: <-140 dBc/Hz at 100,1 k, 10MHz offsets 
RF: 1 GHz SSB Phase Noise:  
   ≤-109 dBc/Hz at 20 kHz 
   ≤-122 dBc/Hz at 100 kHz offset 
External Reference Input

E4433B

Spectrum Analyzer Frequency 3 to 7 GHz 
Amplitude Range −20 to +15 dBm

E4407B

Power Meter Dual Channel 
Absolute Accuracy: ±0.5% 
Power Reference Accuracy: ±0.9%

E4419B

Alternate: 
E4419A

Power Sensor (2) Frequency Range: 10 MHz to 6 GHz 
Amplitude Range: -30 to +20 dBm 
SWR (varies): ≤1.1 10 MHz to 2 GHz 
      ≤1.15 2GHz to 6 GHz

E9301A
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Troubleshooting a VXI mainframe failure
Using the mainframe service guide, verify that all power supplies and fan(s) are 
operational.
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Troubleshooting a VXI installation problem
If you get a message saying that the analyzer cannot find VXI hardware when you 
start either the Vector Signal Analyzer or the Spectrum Analyzer application, there 
may have been a problem during the installation of the PCI card in your computer.

To troubleshoot a VXI installation problem:

1. It is very important that you upgrade the PC BIOS to the latest version your PC 
manufacturer provides whether your PC is new or old. Upgrading to the latest 
version of BIOS will eliminate those bugs fixed by the new BIOS. A BIOS 
upgrade and a video driver upgrade may be required to fix PCI-related 
problems even on a new PC.

2. You may also need to upgrade the drivers for other PCI devices in the PC 
(video, IDE, LAN, SCSI, sound, modem, etc.).

3. Verify that the power supply splitter cable is connected between the PC power 
supply and the PCI card.

4. The E8491B requires installation of the PCI-to-IEEE 1394 host adapter in a 
bus-mastering PCI slot. Consult your PC’s user manual to determine which 
slots are bus-mastering (it is possible that all slots are bus-mastering).

5. In addition to the above, you may need to move the PCI-to-IEEE 1394 host 
adapter to a separate IRQ line in the PC. PCI enables up to four devices sharing 
an IRQ line. However, this doesn’t always work, and you may need to have one 
IRQ per card. Moving the IRQ is not easy, and whether it can be done will 
depend on the details of the BIOS implementation of your PC.

6. Go to Control Panel, Devices and change the Startup mode for the wn1394 to 
System. This starts the 1394 PCI card driver sooner and prevent problems.

If you suspect such a problem, refer to PDF: Agilent E8491B IEEE 1394 PC 
Link to VXI Configuration and User’s Guide located at 
http://www.home.agilent.com/upload/cmc_upload/All/E8491-90001_users.pdf
.
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Troubleshooting a VXI IO configuration problem
The information in this section shows you how to troubleshoot a VXI IO 
configuration problem when the 89600 software cannot find VXI measurement 
hardware.

If you replace the E8491 card in the mainframe or connect a different VXI 
mainframe to your computer, the 89600 software will not be able to find the 
hardware. The PCI interface in the computer looks for the specific E8491 card that 
was previously connected and cannot find it.

To troubleshoot a VXI IO configuration problem:

1. If you are running Vector Signal Analyzer or Spectrum Analyzer, close the 
application.

2. Click Start > (All) Programs > Agilent IO Libraries Suite> Agilent 
Connection Expert.

3. In the right column, select VXI in list and click Delete.

4. Click Add Interface and then select VXI: Agilent E8491 IEEE 1394 to VXI 
Controller, then click Add.

5. If E8491 IEEE to VXI is not listed, you may need to install a driver for the 
E8491. See instructions on the next page. The 89600 software should find the 
hardware. If not, you can find E8491 troubleshooting information in E8491B 
Configuration and User’s Guide located at 
http://www.home.agilent.com/upload/cmc_upload/All/EPSG084330.pdf.

You can also find E8491B Configuration and User’s Guide by searching: Go to 
http://www.agilent.com. Click on Technical Support > Manuals and Search for 
E8491B. 
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Troubleshooting an IEEE-1394 interface failure
If you are running Vector Signal Analyzer or Spectrum Analyzer, close the 
application before troubleshooting this problem.

To troubleshoot an IEEE-1394 interface failure:

1. Verify that Agilent IO Libraries Suite Control is running.

If this program is running, the icon shown to the right will appear in the 
task bar. If the icon is there, go to step 2.

If the icon is not there, reinstall the IO Libraries Suite from the 89600 
Installation CD as follows:

a. Insert the 89600 Installation CD ROM.

b. If the installation utility does not start automatically, click Start > Run, and 
type:

drive:\setup.exe

...where drive represents the drive containing the setup CD-ROM.

c. When the Installation Manager window opens, select Install Agilent 89600 
VSA.

d. Click ext in the Welcome window and Yes in the Software License and 
Warranty window.

e. In the Installation Options window, select Custom Installation  and click 
ext.

f. In the Custom Installation window, select IO Libraries Suite 14.0 from the 
list. Click ext.

g. In the Installation Settings window, click Install.

2. If the Agilent IO Libraries Suite Control is running, verify that the version is 
14.0 or greater.

a. Click the IO Control icon (shown above).

b. Click About Agilent IO Control.

If the version is lower than 14.0, reinstall the IO Libraries Suite 14.0 as 
instructed in step 1.

3. Verify that the IEEE-1394 drivers are loaded and running.

a. Click Start > Settings > Control Panel > System > Hardware > Device 
Manager.

b. If IEEE 1394 Bus host controllers is not present then the IEEE-1394 drivers 
were not loaded properly. Reload the IO Libraries Suite as instructed in step 
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1.

If IEEE 1394 Bus host controllers is on the list, then the PCI interface card 
is most likely faulty.

4. Verify the E8491B slot zero VXI controller card.

a. Click on the Agilent IO Control icon and click VXI Resource Manager > 
Edit Resources, then click the Run button.

b. If an error is reported, click Start > (All) Programs > Agilent IO 
Libraries Suite > Agilent Connection Expert.

If Connection Expert is unable to find the E8491B, then the E8491B is most 
likely faulty.
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Troubleshooting a LA  interface problem
If the 89600 software cannot find your measurement hardware, the problem may 
be in the LAN interface.

To verify the correct ADC.

1. Click Utilities > Hardware.

2. If your measurement hardware is not included in the list for ADC1, continue 
with “To troubleshoot the LAN interface.”

3. If your measurement hardware is included in the list for ADC1, click to 
highlight it.

4. Make sure that the Default Hardware and Simulate Hardware checkboxes are 
cleared.

5. Click OK.

6. If the analyzer still does not use your hardware, continue with “To troubleshoot 
the LAN interface.”

To troubleshoot the LA  interface:

1. Close all 89600 applications. To verify that all applications are closed, run Task 
Manager.

a. Right click an empty space in the task bar or press Alt-Ctrl-Delete.

b. Click Task Manager … > Applications.

c. If there are any AgtVSAVector or AgtVSAScalar applications listed, 
highlight them and click End Task.

d. Click the Processes tab.

e. If there are any VSAVEC*.EXE or VSASCA*.EXE processes in the list, 
highlight them and click End Task.

2. Confirm that your PC can communicate with the instrument.

a. Open a Command Prompt window: for Windows XP, click Start > All 
Programs > Accessories > Command Prompt.

b. Type ping hostname and press Enter, where hostname is the IP address or 
hostname for the instrument. (For instructions on finding the IP address or 
hostname, see “Instrument IP address for a crossover cable configuration” 
on page 98.)

If you are successful, continue with step 3. If you are not successful, 
continue with the next sub-step.

c. Make sure that the PC is on and the LAN cable is connected to the PC and 
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the instrument.

d. If you are connecting directly from the PC to the instrument, verify that you 
are using a crossover LAN cable.

e. Cycle power on the instrument.

f. Verify that the subnet mask is set appropriately. For detailed instructions, 
see: “Instrument IP address for a crossover cable configuration” on page 98.

3. Confirm that VISA Assistant can find and communicate with the LAN 
instrument. Follow the instructions in: step 3. in “Configuring the Agilent 
E5810 LAN/GPIB Gateway interface” on page 102.

4. After you have confirmed that Interactive IO can find the instrument, verify 
that Interactive IO can send a SCPI query (if the instrument supports SCPI).

a. Restart Interactive IO if necessary.

b. Click Connect and check the resource name.

c. Click Send & Read.

d. If there is an error or an incorrect response, try sending a device clear first. 
Click Device Clear. If this does not help, cycle power on the instrument and 
try step c. again.

5. Start an 89600 application. Look for any error dialog boxes at startup stating 
that the instrument does not have the proper options or firmware.

6. Verify that the instrument is in the ADC 1 list under Utilities > Hardware.

LA  interface problem with an Infiniium Oscilloscope:

If you are having trouble communicating directly over the LAN with an Infiniium 
Oscilloscope, check that the M libraries on the scope are configured correctly 
(Click Start > All Programs > Agilent IO Libraries > Connection Expert). 
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To configure the M libraries (Win XP firewall must be off):

1. On the Infiniium scope, minimize the scope application. Click Start > All 
Programs > Agilent I/O Libraries > Connection Expert.

2. Select Internal Instrument in the Available Interfaces and click the Configure 
button. Set the following parameters: SICL Interface Name - hpib7, VISA 
Interface Name - GPIB0, and Logical Unit - 7. Press OK.

3. Select Internal Instrument in the Available Interfaces and click the Configure 
button again. Set the following parameters: SICL Interface Name - inst0, VISA 
Interface Name - GPIB1, and Logical Unit - 8. Press OK.

4. Select TCPIP in the Available Interfaces and click the Configure button. Set the 
following parameters: SICL Interface Name - lan, VISA Interface Name - 
TCPIP0, Logical Unit - 30 and Default Protocol - Auto. Press OK.

5. Select n/a LAN Server in the Available Interfaces and click the Configure 
button. Click the Defaults button and press OK.

6. Close the Connection Expert dialog box.

You must reboot the scope after closing the Connection Expert dialog box.

Table 16-4 M libraries configuration

VISA ame SICL ame

GPIB0 hpib7

GPIB1 inst0

TCPIP0 lan
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Troubleshooting interference with other devices or 
instruments
When you start an 89600 analyzer, the software attempts to identify other 
instruments and devices connected to the computer. This can cause the following 
problems:

• Instruments and devices get reset when you start the 89600 analyzer even if the 
instrument/device is not controlled by 89600.

• Errors occur on instruments or devices not controlled by 89600 when you start 
the 89600 analyzer.

To eliminate these problems, you can instruct the 89600 software to exclude 
specific devices from the identification process. To do this, edit the file:

C:/Program Files/Agilent/89600 VSA/VsaVisaTemplate.txt

List the addresses of the devices you want to exclude, then save the file as:

C:/Program Files/Agilent/89600 VSA/VsaVisaConfig.txt
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Troubleshooting licensing errors
The licensing errors include:

• license initialization errors

• lost licenses

License Initialization Errors

When starting up any 89600 software application, the following error messages 
may be generated by the Crypkey licensing software.

89600 software Version 7.20 or lower:

License initialization error 
Reply from network driver is bad 
Re-install product

License initialization error 
etwork driver appears to not be serving this directory 

Re-install product

Use this procedure to uninstall and re-install the licensing software.

1. Stop the CrypKey service via the Windows Services tool.

For Windows 2000, click Start > Settings > Control Panel > Administrative 
> Services. 

For Windows XP, click Start > Control Panel > Performance and 
Maintenance > Administrative Tools > Services. 

2. Delete the following files in <WINNT>/system32:

— Ckldrv.sys

— Crypserv.exe

— esnecil.ind

3. Execute <WINNT>/vsa/setupex.exe.

4. Start 89600 software. Once the software is able to start, you may need to 
request a new site key.
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89600 software Version 8.00 or greater:

Update OT successful 
Reply from network driver is bad 
Re-install product

License initialization error 
Could not start ngn. 
Re-install product

Use this procedure to uninstall and re-install the licensing software.

1. Start a command prompt window. Click Start > Run > cmd > OK.

2. Enter the command “ \Documents and Settings\All Users\Application 
Data\Agilent\Vsa\8.0\setupex /U ” and then press Enter.

3. Delete the file \system32\esnecil.ind.

4. Reboot your PC.

5. Run \Documents and Settings\All Users\Application 
Data\Agilent\Vsa\8.0\setupex.

Lost License Error

If you have antivirus software on your PC, it can cause your 89600 software 
license to be lost. To avoid this problem, configure your antivirus software to 
exclude the following files:

• *.rst

• *.ent

• *.key

• *.41s

• *.ind

• cks*.tmp
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Troubleshooting a lost connection to the network license 
server
This information only applies to systems that use a floating license server and a 
floating license client.

If two to three minutes after starting the 89600 VSA software, a License Warning 
message window appears that says Lost connection to network license server for 
the following, you may have a firewall incompatibility. Every two to three minutes, 
the 89600 VSA software will connect to the license server to check the floating 
license status. Some third party firewall applications treat this as a port scan attack 
and will lock out the client. This problem can be fixed by turning off any third 
party firewall software that resides on the server. This is not an issue with the 
Windows firewall.
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Troubleshooting an E1438 ADC module
This section provides information on troubleshooting an E1438 ADC module.

To verify the E1438 module using the self test:

1. If you have either the Vector Signal Analyzer or Spectrum Analyzer running, 
close the application.

2. Click Start > (All) Programs > Vxipnp > Age1438 > E1438 Front Panel.

3. If the factory default address has been changed you must enter it into the dialog 
box that will be presented.

There are two ways to find the E1438 address:

a. Click on the Agilent IO Libraries Suite Control icon and click VXI 
Resource Manager > Edit Resources, highlight Add/delete symbolic 
names of VXI devices, and click RM Output. The LADD column in the 
VXI device table lists the logical address for each module.

b. Open the Vector Signal Analyzer or Spectrum Analyzer, click Utilities > 
Hardware and the ADC tab for the module. The logical address is listed in 
the first column with the VXI mainframe number.

4. On the menu bar of the front panel program select Control > Self Test.

If errors are reported, then the E1438 module is faulty.

5. Repeat this procedure for a second E1438 if necessary.

The E1438 front panel test always looks for a module at logical address 192. If 
it finds one, it automatically opens the soft front panel for that module. To test 
another E1438 module, power-off the mainframe and pull the module with 
address 192 out of the mainframe (you don’t have to remove the module 
completely--just slide it forward an inch or so). Repeat steps 1-4 above.
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Troubleshooting an E1439 ADC module
This section provides troubleshooting information for an E1439 ADC module.

To verify the E1439 module using the self test:

1. If you have either the Vector Signal Analyzer or Spectrum Analyzer running, 
close the application.

2. Click Start > (All) Programs > Vxipnp > Age1439 > E1439 Front Panel.

3. If the factory default address has been changed you must enter it into the dialog 
box that will be presented.

There are two ways to find the E1439 address:

a. Click on the Agilent IO Libraries Suite Control icon and click VXI 
Resource Manager > Edit Resources, highlight Add/delete symbolic 
names of VXI devices, and click RM Output. The LADD column in the 
VXI device table lists the logical address for each module.

b. Open the Vector Signal Analyzer or Spectrum Analyzer, click Utilities, 
Hardware and the ADC tab for the module. The logical address is listed in 
the first column with the VXI mainframe number.

4. On the menu bar of the front panel program select Control > Self Test.

If errors are reported, then the E1439 module is faulty.

5. Repeat this procedure for a second E1439 if necessary.

The E1439 front panel test always looks for a module at logical address 194. If 
it finds one, it automatically opens the soft front panel for that module. To test 
another E1439 module, power-off the mainframe and pull the module with 
address 194 out of the mainframe (you don’t have to remove the module 
completely--just slide it forward an inch or so). Repeat steps 1-4 above.
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Troubleshooting the E2730/E2731 module
You can use VISA Assistant to isolate problems to the E2730/E2731 module.

To troubleshoot the E2730/E2731 module:

1. Start Agilent Connection Expert by clicking Start > (All) Programs > Agilent 
IO Libraries Suite > Agilent Connection Expert.

2. Under VXIO, highlight the E273xA module. 

3. Click Interactive IO. 

a. If the red LED on the E273xA front panel is lit, type CDE? in the command 
box and click Send & Read. (CDE? reads the module’s current device 
Error Register contents.) If the response ends in 32768, the 10 MHz 
Reference signal is probably not connected properly. Check the semi-rigid 
cable from the 10 MHz Ref Out connector on the 89605 module to the 10 
MHz Ext Ref connector on the E273xA module. Tighten the connectors, 
and the red LED should turn off. If the query returns any number other than 
32768 or 00000, the E273xA module is most likely faulty.

b. If the red LED on the E273xA front panel flickers or turns on and off, type 
DDE? in the command box and click Send & Read. (DDE? reads the 
module’s latched error status. Reading this register clears it until the fault 
reoccurs.) If the query returns 32768, check the 10 MHz Ref connections as 
described in the previous paragraph. If the query returns any number other 
than 32768 or 00000, the E273xA module is most likely faulty.

4. Repeat for a second E2730/E2731 module if necessary.
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Troubleshooting the 2.7 GHz RF signal path
The following procedures direct you through inserting a signal at various points in 
the analyzer’s signal path to isolate problems to a specific module. Perform the 
steps in the order listed.

This test requires a signal generator. See, "Recommended Test Equipment" (page 
224).

To troubleshoot the 2.7 GHz RF signal path:

1. Set up the analyzer as follows:

a. If it is not already running, start the Vector Signal Analyzer by double 
clicking the icon or clicking Start > (All) Programs > Agilent 89600 VSA 
> Vector Signal Analyzer.

b. Click File > Preset > Preset Setup.

c. Click Utilities > Calibration, and clear the Apply Corrections to Data 
checkbox.

d. Click MeasSetup > Frequency Bands > 36 MHz – 2.7 GHz.

e. Disconnect the BNC cable from the E1439 Analog In connector and 
connect a signal generator to E1439 Analog Input.

f. Set the signal generator for 70 MHz, –10 dBm output.

g. Set the analyzer’s marker to peak by right clicking on the spectrum trace 
and clicking ↑Peak.

The marker reading should be 20 dBm ± 1.5 dB.

h. Verify the other settings in the following table.

If any of the readings are incorrect, the E1439 module is most likely faulty.

2. Reconnect the BNC cable to the E1439 Analog In and disconnect the SMA 
cable from the 89605 From 70 MHz IF Out connector. Connect the signal 
generator output to 89605 From 70 MHz IF Out.

a. Set the marker to peak by right clicking on the spectrum trace and clicking 
↑Peak.

Input Range Signal Generator Level Marker Level

+20 dBm –10 dBm +20 dBm ± 1.5 dB

–35 dBm –20 dBm –40 dBm ± 1.5 dB

–40 dBm –20 dBm –40 dBm ± 1.5 dB

–45 dBm –20 dBm –40 dBm ± 1.5 dB
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b. The marker reading should be –40 dBm ± 1.5 dB. If this reading is 
incorrect, the 89605 module is most likely faulty.

3. Set the signal generator to 1 GHz, –40 dBm.

a. Reconnect the SMA cable to the 89605 From 70 MHz IF Out connector. 
Disconnect the SMA cable from the E2730 RF I  connector. Connect the 
signal generator output to the E2730 RF In connector.

b. Set the marker to peak by right clicking on the spectrum trace and clicking 
↑Peak.

c. The marker reading should be –40 dBm ± 3.5 dB

d. Change the signal generator and 89600 center frequency to 950 MHz.

e. Set the marker to peak by right clicking on the spectrum trace and clicking 
↑Peak.

f. The marker reading should be –40 dBm ± 3.5 dB.

If either reading is incorrect, the E2730 module is most likely faulty. If this 
module is channel 2 in a 2-channel analyzer, see “Verifying Channel 1 LO 
outputs in a 2-channel RF system” on page 250.

4. Set the signal generator to 1 GHz, –30 dBm. Set the 89600 center frequency to 
16 Hz.

a. Reconnect the SMA cable to E2730 RF In connector. Connect the signal 
generator output to the 89605 Ch1 Input connector.

b. Set the marker to peak by right clicking on the spectrum trace and clicking 
↑Peak.
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c. Change the analyzer input range and the signal generator output level in 5 
dB steps, verifying the marker readings in the following table.

If any of these readings are incorrect, the 89605 module is most likely 
faulty.

5. Repeat steps 1 through 4 for a second channel if required.

Input Range Signal Generator Level Marker Level

–30 dBm –30 dBm –30 dBm ± 3.5 dB

–25 dBm –25 dBm –25 dBm ± 3.5 dB

–20 dBm –20 dBm –20 dBm ± 3.5 dB

–15 dBm –15 dBm –15 dBm ± 3.5 dB

–10 dBm –10 dBm –10 dBm ± 3.5 dB

–5 dBm –5 dBm –5 dBm ± 3.5 dB

0 dBm 0 dBm 0 dBm ± 3.5 dB

+5 dBm +5 dBm +5 dBm ± 3.5 dB

+10 dBm +10 dBm +10 dBm ± 3.5 dB

+15 dBm +15 dBm +15 dBm ± 3.5 dB

+20 dBm +20 dBm +20 dBm ± 3.5 dB
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Troubleshooting the 6.0 GHz RF signal path
The following procedures direct you through inserting a signal at various points in 
the analyzer’s signal path to isolate problems to a specific module. Perform the 
steps in the order listed. This test requires a signal generator. See "Recommended 
Test Equipment" (page 224).

To troubleshoot the 6.0 GHz RF signal path:

1. Set up the analyzer as follows:

a. If it is not already running, start the Vector Signal Analyzer by double 
clicking the icon or clicking Start > (All) Programs > Agilent 89600 VSA 
> Vector Signal Analyzer.

b. Click File > Preset > Preset Setup.

c. Click Utilities > Calibration, and clear the Apply Corrections to Data 
checkbox.

d. Click MeasSetup > Frequency Bands > 36 MHz – 6 GHz.

e. Disconnect the BNC cable from the E1439 Analog In connector and 
connect a signal generator to E1439 Analog Input.

f. Set the signal generator for 70 MHz, –10 dBm output.

g. Set the analyzer’s marker to peak by right clicking on the spectrum trace 
and clicking ↑Peak. The marker reading should be 20 dBm ± 1.5 dB

h. Verify the other settings in the following table.

If any of the readings are incorrect, the E1439 module is most likely faulty.

2. Reconnect the BNC cable to the E1439 Analog In and disconnect the SMA 
cable from the 89605 From 70 MHz IF Out connector. Connect the signal 
generator output to 89605 From 70 MHz IF Out.

a. Set the marker to peak by right clicking on the spectrum trace and clicking 
↑Peak.

b. The marker reading should be –40 dBm ± 1.5 dB.

If this reading is incorrect, the 89605 module is most likely faulty.

Input Range Signal Generator Level Marker Level

+20 dBm –10 dBm +20 dBm ± 1.5 dB

–35 dBm –20 dBm –40 dBm ± 1.5 dB

–40 dBm –20 dBm –40 dBm ± 1.5 dB

–45 dBm –20 dBm –40 dBm ± 1.5 dB
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3. Set the signal generator to 1 GHz, –40 dBm.

a. Reconnect the SMA cable to the 89605 From 70 MHz IF Out connector. 
Disconnect the SMA cable from the E2731 6 GHz I  connector. Connect 
the signal generator output to the E2731 6 GHz I  connector.

b. Set the marker to peak by right clicking on the spectrum trace and clicking 
↑Peak.

c. The marker reading should be –40 dBm ± 4.5 dB

d. Change the signal generator and 89600 center frequency to the frequencies 
in the table and repeat steps b and c.

If any of these readings are incorrect, the E2731 module is most likely 
faulty. If this module is channel 2 in a 2-channel analyzer, see “Verifying 
Channel 1 LO outputs in a 2-channel RF system” on page 250.

4. Set the signal generator to 1 GHz, –30 dBm. Set the 89600 center frequency to 
16 Hz.

a. Reconnect the SMA cable to E2731 6 GHz In connector. Connect the signal 
generator output to the 89605 Ch1 Input connector.

b. Set the marker to peak by right clicking on the spectrum trace and clicking 
↑Peak.

c. Change the analyzer input range and the signal generator output level in 5 
dB steps, verifying the marker readings in the following table.

Frequency

950 MHz

3.5 GHz

4.0 Ghz

4.5 Ghz

5.5 Ghz

Input Range Signal Generator Level Marker Level

–30 dBm –30 dBm –30 dBm ± 5 dB

–25 dBm –25 dBm –25 dBm ± 5 dB

–20 dBm –20 dBm –20 dBm ± 5 dB

–15 dBm –15 dBm –15 dBm ± 5 dB

–10 dBm –10 dBm –10 dBm ± 5 dB

–5 dBm –5 dBm –5 dBm ± 5 dB

0 dBm 0 dBm 0 dBm ± 5 dB

+5 dBm +5 dBm +5 dBm ± 5 dB

+10 dBm +10 dBm +10 dBm ± 5 dB
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If any of these readings are incorrect, the 89605 module is most likely 
faulty.

5. Repeat steps 1-4 for channel 2 if required.

+15 dBm +15 dBm +15 dBm ± 5 dB

+20 dBm +20 dBm +20 dBm ± 5 dB

Input Range Signal Generator Level Marker Level
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Troubleshooting the 0 to 36 MHz baseband signal path
Perform the following procedures in the order listed to troubleshoot the 89640 
baseband signal path.

This test requires a signal generator. See "Recommended Test Equipment" (page 
224).

1. Set up the 896xxA as follows:

a. If it is not already running, start the Vector Signal Analyzer by double 
clicking the icon or clicking Start > (All) Programs > Agilent 89600 VSA 
> Vector Signal Analyzer.

b. Click File > Preset > Preset Setup.

c. Click Utilities > Calibration, and clear the Apply Corrections to Data 
checkbox.

d. Click MeasSetup > Frequency Bands > 0 - 36 MHz.

e. Disconnect the BNC cable from the E1439 Analog In connector and 
connect a signal generator to E1439 Analog In.

f. Set the signal generator for 20 MHz, -30 dBm output.

g. Set the marker to peak by right clicking on the spectrum trace and clicking 
↑Peak.

h. The marker reading should be 20 dBm ± 1.7 dB.

If this reading is incorrect, the E1439 module is most likely faulty.

2. Connect the signal generator output to 89605 Ch 1 Input.

a. Reconnect the BNC cable from 89605 To ADC to E1439 Analog In.

b. Set the center frequency to 20 MHz and the frequency span to 100 kHz.

c. Set the marker to peak by right clicking on the spectrum trace and clicking 
↑Peak.

d. The marker reading should be -30 dBm ± 3.5 dB.

e. Change the 89640A input range in 5 dB steps while verifying that the 
marker reading at each step is -30 dBm ± 3.5 dB.

If any of these readings are incorrect, the 89605 module is most likely 
faulty.

3. Repeat steps 1 and 2 for a second channel if required.
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Troubleshooting the 70 MHz IF signal path
The following procedures direct you through inserting a signal at various points in 
the analyzer’s signal path to isolate problems to a specific module. Perform the 
steps in the order listed. This test requires a signal generator. See "Recommended 
Test Equipment" (page 224).

1. Set up the analyzer as follows:

a. If it is not already running, start the Vector Signal Analyzer by double 
clicking the icon or clicking Start > (All) Programs > Agilent 89600 VSA 
> Vector Signal Analyzer.

b. Click File > Preset > Preset Setup.

c. Click Utilities > Calibration, and clear the Apply Corrections to Data 
checkbox.

d. Click MeasSetup > Frequency Bands > 52 MHz – 88 MHz.

e. Click MeasSetup > Freq > Span, and enter 100 kHz.

f. Click Input > Range, and enter -45 dBm.

g. Click Control > Restart.

h. Disconnect the BNC cable from the E1439 Analog In connector and 
connect a signal generator to E1439 Analog Input.

i. Set the signal generator for 70 MHz, –45 dBm output.

j. Set the 89600 marker to peak: right click on the spectrum trace and click 
↑Peak. The marker reading should be -39 dBm ± 1.5 dB

k. Click Markers > Copy Marker to > Move Offset to Mkr.

l. Change the Input Range in 5 dB increments from -45 dBm to -25 dBm. The 
Marker Level for all ranges should read 0 dB ± 0.5 dB.

If any of the readings are incorrect, the E1439 module is most likely faulty.

2. Reconnect the BNC cable to the E1439 Analog In. Connect the signal generator 
output to 89605 Ch 1 Input.

a. Set the marker to peak: right click on the spectrum trace and click ↑Peak.

b. Click Input > Range, and enter -25 dBm.

c. Click Markers > Copy Marker to > Move Offset to Mkr.

d. Change the Input Range in 5 dB increments from -25 dBm to +20 dBm. The 
Marker Level for all ranges should read 0 dB ± 0.5 dB.

If any of these readings is incorrect, the 89605 module is most likely faulty.

3. For a two-channel IF analyzer, repeat this procedure for the second channel.
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Troubleshooting the 0-to-40 MHz baseband signal path
Perform the following procedures in the order listed to troubleshoot the 89610A 
signal path. This test requires a signal generator. See "Recommended Test 
Equipment" (page 224).

To troubleshoot the 0-to-40MHz baseband signal path:

1. Set up the analyzer as follows:

a. If it is not already running, start the Vector Signal Analyzer by double 
clicking the icon or clicking Start > (All) Programs > Agilent 89600 VSA 
> Vector Signal Analyzer.

b. Click File > Preset > Preset Setup.

c. Click Utilities > Calibration, and clear the Apply Corrections to Data 
checkbox.

d. Disconnect the BNC cable from the E1438 Analog In connector and 
connect a signal generator to E1438 Analog In.

e. Set the signal generator for 20 MHz, -31 dBm output.

f. Set the analyzer input range to -31 dBm.

g. Set the marker to peak by right clicking on the spectrum trace and clicking 
↑Peak.

h. The marker reading should be -31 dBm ± 1.7 dB.

If this reading is incorrect, the E1438 module is most likely faulty.
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i. Change the analyzer input range and the signal generator output level in 3 
dB steps, verifying the marker readings in the following table.

If any readings are incorrect, the E1438 module is most likely faulty.

2. For a two-channel 89610A, repeat this procedure for the second E1438.

3. Connect the signal generator output to 89606/B Ch 1 Input.

a. Reconnect the BNC cable from 89606/B To ADC to E1438 Analog In.

b. Set the signal generator to -31 dBm output level.

c. Set the analyzer center frequency to 20 MHz, frequency span to 100 kHz, 
and input range to -31 dBm.

d. Set the marker to peak by right clicking on the spectrum trace and clicking 
↑Peak.

e. The marker reading should be -31 dBm ± 1.7 dB.

f. Change the analyzer input range and the signal generator output level in 3 
dB steps, verifying the marker readings in the table in above.

If any of these readings are incorrect the 89606/B module is most likely 
faulty.

Input Range Signal Generator Level Marker Level

–31 dBm –31 dBm –31 dBm ± 1.7 dB 

–28 dBm –28 dBm –28 dBm ± 1.7 dB

–25 dBm –25 dBm –25 dBm ± 1.7 dB

–22 dBm –22 dBm –22 dBm ± 1.7 dB

–19 dBm –19 dBm –19 dBm ± 1.7 dB

–16 dBm –16 dBm –16 dBm ± 1.7 dB

–13 dBm –13 dBm –13 dBm ± 1.7 dB

–10 dBm –10 dBm –10 dBm ± 1.7 dB

–7 dBm –7 dBm –7 dBm ± 1.7 dB

–4 dBm –4 dBm –4 dBm ± 1.7 dB

–1 dBm –1 dBm –1 dBm ± 1.7 dB

+ 2 dBm + 2 dBm + 2 dBm ± 1.7 dB

+5 dBm +5 dBm +5 dBm ± 1.7 dB

+8 dBm +8 dBm +8 dBm ± 1.7 dB

+11 dBm +11 dBm +11 dBm ± 1.7 dB

+14 dBm +14 dBm +14 dBm ± 1.7 dB

+17 dBm +17 dBm +17 dBm ± 1.7 dB

+20 dBm +20 dBm +20 dBm ± 1.7 dB
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Verifying Channel 1 LO outputs in a 2-channel RF 
system
Perform the following procedures to verify the channel 1 LO output on an E2730 
or E2731 module in a 2-channel analyzer. This test requires a spectrum analyzer 
and a power meter. See "Recommended Test Equipment" (page 224).

To verify Channel 1 LO outputs in a 2-channel RF system, 1st 
LO:

1. Disconnect the cable connected to E273x 1st LO In/Out.

2. Connect Channel 1 1st LO In/Out to the spectrum analyzer RF Input.

3. If it is not already running, start the Vector Signal Analyzer by double clicking 
the icon or clicking Start > (All) Programs > Agilent 89600 VSA > Vector 
Signal Analyzer.

4. Set up the 89600 Vector Signal Analyzer:

a. Click File > Preset > Preset Setup.

b. Click Input > Channels > 2 Channels.

5. Set up the spectrum analyzer:

a. Preset.

b. Set the reference level to 12 dBm.

c. Set the span to 100 MHz.

6. For each frequency listed below verify that the amplitude is < 6.5 dBm. If the 
signal level is marginal, verify with a power meter. 

If any reading is incorrect then the E273x is most likely faulty.

89600 center frequency Spectrum analyzer center frequency

36 MHz 3.8175 GHz

1 GHz 4.7825 GHz

2.7 GHz 6.4825 GHz
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To verify Channel 1 LO outputs in a 2-channel RF system, 2nd 
LO

1. Disconnect the cable connected to E273x 2nd LO In/Out.

2. Connect Channel 1 2nd LO In/Out to the spectrum analyzer RF Input.

3. If it is not already running, start the Vector Signal Analyzer by double clicking 
the icon or clicking Start > (All) Programs > Agilent 89600 VSA > Vector 
Signal Analyzer.

4. Set up the 89600 Vector Signal Analyzer:

a. Click File > Preset > Preset Setup.

b. Click Input > Channels > 2 Channels.

5. Set up the spectrum analyzer:

a. Preset.

b. Set the reference level to 15 dBm.

c. Set the center frequency to 3.711 GHz.

d. Set the span to 5 MHz.

6. For each frequency listed below verify that the amplitude is < 10.0 dBm. If the 
signal level is marginal, verify with a power meter.

If any reading is incorrect then the E273x is most likely faulty.

89600 center frequency Spectrum analyzer center frequency

252.4 MHz 3710 MHz

252.5 MHz 3712.5 MHz

254 MHz 3711 MHz
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Troubleshooting the Display Driver
This section provides display driver troubleshooting information.

Problem

The symbol location shape, such as the dots, on the constellation trace displays do 
not show properly.

Possible Cause

The display driver may not be functioning properly.

Solution

Use this procedure to correct the display driver:

1. Update the display driver: 
Contact your PC manufacturer to see if a newer version of the display driver is 
available. If there is, update the driver and verify if the problem is fixed.

2. Reconfigure the display driver settings: 
If the latest display driver does not fix the problem, try decreasing the hardware 
acceleration.

— (Windows XP Instructions) Click Start > Control Panel > Display > 
Settings > Advanced > Troubleshoot, then decrease the hardware 
acceleration value, click OK > OK.
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Introduction
Introduction
This chapter contains block diagrams and circuit descriptions of the 89600 series 
VXI measurement hardware. This information is provided to help you understand 
system operation and identify and isolate problems to a specific module.

These products consist of VXI measurement hardware and Vector Signal Analysis 
(VSA) software running on a standard Windows XP workstation. The 89600 series 
includes three analyzer configurations with VXI measurement hardware:

• 89611 70 MHz IF Analyzer, see: "Agilent 89611 70 MHz IF Analyzer circuit 
description" (page 263)

• 89610 DC - 40 MHz Analyzer (with optional second input channel), see: 
"Agilent 89610 circuit description" (page 255)

• 89640 DC - 2.7 GHz Analyzer and 89641 DC - 6.0GHz Analyzer, see: "Agilent 
89640/89641 circuit description" (page 259)
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Agilent 89610 circuit description
The Agilent 89610 Vector Signal Analyzer VXI hardware includes the following 
VXI modules:

• Agilent E8491 Option 001 IEEE 1394 PC Link to VXI (Firewire)

• Agilent 89606 Input module

• Agilent E1438 ADC module

• Option 002, 102, 145, and 289 include a second E1438 module

For module descriptions in this section, refer to Figure 17-1 on page 256.

E8491 PC Link to VXI

The E8491 module provides the link between the computer and the VXI 
measurement hardware. No signal acquisition or processing happens in this 
module. For detailed information on this module and the IEEE 1394 interface, 
refer to the PDF document Agilent E8491B IEEE 1394 PC Link to VXI 
Configuration and User’s Guide located at 
http://www.home.agilent.com/upload/cmc_upload/All/E8491-90001_users.pdf.

89606/B Input Module

The 89606 Input module accepts the input signal and passes it to the E1438 ADC 
module. During calibration, the input signal path is interrupted. The calibrator in 
the 89606 module inserts a calibration signal into the signal path to the E1438 
ADC module. The calibration signal is taken from the 10 MHz reference and 
multiplied by 10 to match the E1438 sampling rate of 100 MSa per second. The 
E1438 ADC uses the same 10 MHz reference, so the calibration source is phase 
locked to the sample clock.

The 89606 also provides a 10 MHz reference signal to the Agilent E1438 module. 
An additional 10 MHz Ref output is available on the module front panel to connect 
to other instruments in your measurement setup. For the 89606B only, you can 
connect a 10 MHz or 13 MHz reference signal to the Ext Reference In connector.

Use of this module outside the 89600-series of analyzers is not supported.
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E1438 ADC Module

All signal processing happens in the Agilent E1438A 100 MSa/s ADC + Filter + 
FIFO (attenuation, anti-alias filtering, etc.). Detailed information about this 
module is available in a PDF file: Agilent E1438 VXI 100 MSa/s ADC with filters 
and memory User’s Guide. This guide is installed on your computer, however, you 
may have to use the Search function to find the exact location. Typical locations 
include the following:

C:/Vxi/Vxipnp/Winnt/age1438/help/e1438_Users_Guide.pdf

C:/Program Files/Visa/Winnt/age1438\help/e1438_Users_Guide.pdf

Triggering

For external trigger mode, a trigger signal must be supplied at the Ext Trigger 
connector on the front panel. This input is AC coupled with an impedance of 1 K 
ohm so any signal with a sharp rising or falling transition greater than 100 mV (for 
example, TTL or ECL logic) can be used as an external trigger source. Minimum 
pulse width is 300 ns.

If your system includes two E1438 modules, you can use the external trigger 
connector on either module. The bi-directional Intermodule Sync connectors on 
the module front panels connect the trigger signal between the modules. This 
synchronizes the two modules so that they receive the trigger signal 
simultaneously.

Coupling

The input can be either AC or DC coupled. AC coupling enables the system to 
measure low level AC signals in the presence of a large DC offset.

Ranging

Attenuation is the first step in the E1438 module. The module provides 0 to 51 dB 
of attenuation in 3 dB steps, resulting in analyzer input ranges between -31 dBm 
and 20 dBm in 3 dB steps.

Anti-alias filtering

Since the normal ADC sample rate is 100 MHz, a complete representation of the 
input signal can be achieved only for bandwidths up to 50 MHz. Frequency 
components above 50 MHz can cause ambiguous results (aliasing).

The anti-alias filter attenuates these high frequency components to reduce aliasing. 
The anti-alias filter in the Agilent E1438 is flat to 40 MHz and rejects signals 
above 60 MHz by at least 90 dB. Thus the 0-40 MHz frequency range of the 
sampled signal is −90 dB alias free. The filter’s transition band from 40 MHz to 60 
MHz affects flatness and enable some aliasing in the sampled signal frequency 
range of 40 MHz to 50 MHz.

Analog-to-digital (ADC) signal conversion

The central part of the E1438 is a precision sampling ADC. The ADC samples the 
Chapter 17  257



Circuit Descriptions
Agilent 89610 circuit description
signal at a rates up to 100 MSa/sec and converts the analog signal to a digital 
signal.

Zoom and decimation filtering

This section uses digital circuitry to enable programmable changes in the center 
frequency and signal bandwidth of the 89610 analyzer (zoom). Bandwidth is 
controlled by a chain of digital low-pass filters. Each of the filters reduces the 
bandwidth by a factor of 2 (decimation).

Memory

Digitized data is stored in memory in the E1438 module and read out after a block 
of data has been taken. The digitized data passes through the E8491 interface to the 
measurement software in the computer.

For information on how the signal is processed by the measurement software, see 
the 89600 online help for “System Block Diagram” under Tutorial, Theory of 
Operation. Typically, this help file is in location:

C:/Program Files/Agilent/89600 VSA/Help/tasks.hlp
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Agilent 89640/89641 circuit description
The Agilent 89640 Vector Signal Analyzer VXI hardware includes the following 
VXI modules:

• Agilent E8491 Option 001 IEEE 1394 PC Link to VXI

• Agilent 89605 Input module

• Agilent E1439 ADC module

• Agilent E2730 RF Tuner module

• optional second IF/baseband channel, including an additional E1439 and 
E2730 modules

The Agilent 89641 Vector Signal Analyzer VXI hardware includes the following 
VXI modules:

• Agilent E8491 Option 001 IEEE 1394 PC Link to VXI

• Agilent 89605 Input module

• Agilent E1439 ADC module

• Agilent E2731 RF Tuner module

• optional second IF/baseband channel, including an additional E1439 and 
E2731 modules

The module descriptions in this section apply to the 89640/89641 block diagram: 
"89640/89641 block diagram" (page 260). Your analyzer may include a second 
IF/baseband channel, which is not shown in the block diagram.

E8491 PC Link to VXI

The E8491 module provides the link between the computer and the VXI 
measurement hardware. No signal acquisition or processing happens in this 
module. For detailed information on this module and the IEEE 1394 interface, 
refer to the PDF document Agilent E8491B IEEE 1394 PC Link to VXI 
Configuration and User’s Guide located at 
http://www.home.agilent.com/upload/cmc_upload/All/E8491-90001_users.pdf.
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Figure 17-2 89640/89641 block diagram
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89605 Input Module

The 89605 Input module accepts the input signal and passes it through a 
0-to-50 dB attenuator (5 dB steps). In baseband mode (0 to 36 MHz), the signal is 
routed directly to the E1439 module, by-passing the E2730/E2731 module. In RF 
mode (36 MHz to 2.7 GHz or 6 GHz), the signal is routed to the E2730/E2731 RF 
Tuner. The down-converted signal from the E2730/E2731 comes back to the 
89605 and is routed to the E1439 module.

During calibration, the input signal path is interrupted. The calibrator in the 89605 
module inserts a calibration signal into the signal path to the E1439 ADC module. 
The calibration signal is taken from the 10 MHz reference and multiplied by 19/2 
to match the E1439 sampling rate of 95 MSa per second. The E1439 ADC uses the 
same 10 MHz reference, so the calibration source is phase locked to the sample 
clock.

The 89605 also provides a 10 MHz reference signal to the E2730/E2731 and 
E1439 modules. An additional 10 MHz Ref output is available on the module front 
panel to connect to other instruments in your measurement setup. For the 89605B 
only, you can connect a 10MHz or 13 MHz reference signal to the Ext Reference 
In connector.

Use of this module outside the 89600-series of analyzers is not supported.

E2730/E2731 RF Tuner module

The E2730 RF Tuner has a frequency tuning range of 20 to 2700 MHz in 1 kHz 
steps. The E2731 RF Tuner has a frequency tuning range of 20 to 6000 MHz. Each 
tuner converts the input signal in multiple stages of local oscillators, amplifiers, 
attenuators, and filters. The 70 MHz output has a bandwidth of 36 MHz, resulting 
in an output signal to the ADC between 52 MHz and 88 MHz.

Use of this module outside the 89600-series of analyzers is not supported.

E1439 ADC module

The input signal passes to the E1439 ADC module in one of two ways. If the input 
frequency band is 0 Hz to 36 MHz, the signal goes directly to the E1439 module. If 
the input frequency band is 36 MHz to 2.7 GHz or 6 GHz, the signal goes to the 
RF Tuner module to be down converted. From the RF Tuner module, the signal 
goes back through the 89605 module to the Agilent E1439 95 MSa/s ADC + Filter 
+ FIFO + 70 MHz IF Input module.

Detailed information about this module is available in a PDF file: Agilent E1439 
VXI 70 MHz IF ADC with filters and memory User’s Guide. This guide is installed 
on your computer, however, you may have to use the Search function to find the 
exact location. Typical locations include the following:

C:/Vxi/Vxipnp/Winnt/age1439/help/e1439_Users_Guide.pdf

C:/Program Files/Visa/Winnt/age1439/help/e1439_Users_Guide.pdf
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Triggering

For external trigger mode, a trigger signal must be supplied at the Ext Trigger 
connector on the front panel. This input is AC-coupled with an impedance of 1K 
ohm so any signal with a sharp rising or falling transition greater than 100 mV (for 
example, TTL or ECL logic) can be used as an external trigger source. Minimum 
pulse width is 300 ns.

Coupling

The input can be either AC or DC coupled. AC coupling enables the system to 
measure low level AC signals in the presence of a large DC offset.

Signal conditioning

In 0-36 MHz mode, the input signal goes through the lower path in the block 
diagram. In this mode, no attenuation occurs in the E1439 module.

In 36 MHz-2.7 GHz (or 6 GHz) mode, the input signal goes through the upper path 
in the block diagram. This path includes 0 to 32 dB of attenuation in 1 dB steps. 
The signal is band-pass filtered, mixed with 95 MHz, and low-pass filtered. This 
inverts and translates the frequency spectrum from 52-88 MHz at the input to 
43-7 MHz at the ADC. The ADC samples the signal at a 95 MHz sample rate.

Analog-to-digital (ADC) signal conversion

The central part of the E1439 is a precision sampling ADC. The ADC samples the 
signal at a rate of up to 95 MSa/sec and converts the analog signal to a digital 
signal.

Memory

Digitized data is stored in memory in the E1439 module and read out after a block 
of data has been taken. The digitized data passes through the E8491 interface to the 
measurement software in the computer.

For information on how the signal is processed by the measurement software, see 
the 89600 online help for “System Block Diagram” under Tutorial, Theory of 
Operation. Typically, this help file is in location:

C:/Program Files/Agilent/89600 VSA/Help/tasks.hlp
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Agilent 89611 70 MHz IF Analyzer circuit description
The Agilent 89610 Vector Signal Analyzer VXI hardware includes the following 
VXI modules:

• Agilent E8491 Option 001 IEEE 1394 PC Link to VXI

• Agilent 89605 Input module

• Agilent E1439 ADC module

• an optional second channel, including an additional 89605 and E1439 module

In addition, the 89611 requires an external down converter that provides a 70 MHz 
IF out signal. If you use an Agilent PSA option H70 as the down converter, the 
89600 software controls the down converter. Otherwise, you must control the 
down converter separately from the 89600 interface.

The module descriptions in this section apply to: "89611 block diagram" (page 
264). This block diagram does not include the optional second channel.

E8491 PC Link to VXI

The E8491 module provides the link between the computer and the VXI 
measurement hardware. No signal acquisition or processing happens in this 
module. For detailed information on this module and the IEEE 1394 interface, 
refer to the PDF document Agilent E8491B IEEE 1394 PC Link to VXI 
Configuration and User’s Guide located at 
http://www.home.agilent.com/upload/cmc_upload/All/E8491-90001_users.pdf.
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Figure 17-3 89611 block diagram
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89605 Input Module

The 89605 Input module accepts the baseband input signal and passes it through a 
0-to-50 dB attenuator (5 dB steps). In baseband mode (0 to 36 MHz), the signal 
from the Ch 1 Input connector is routed to the E1439 module. For the upper 
frequency band (frequencies determined by the down converter used), the signal is 
routed from the From 70 MHz IF Out connector to the E1439 module (via the To 
ADC Analog In connector).

During calibration, the input signal path is interrupted. The calibrator in the 89605 
module inserts a calibration signal into the signal path to the E1439 ADC module. 
The calibration signal is taken from the 10 MHz reference and multiplied by 19/2 
to match the E1439 sampling rate of 95 MSa per second. The E1439 ADC uses the 
same 10 MHz reference, so the calibration source is phase locked to the sample 
clock.

The 89605 also provides a 10 MHz reference signal to the E1439 module. An 
additional 10 MHz Ref output is available on the module front panel to connect to 
other instruments in your measurement setup. For the 89605B only, you can 
connect a 10 MHz or 13 MHz reference signal to the Ext Reference In connector.

Use of this module outside the 89600 series analyzers is not supported.

E1439 ADC Module

The input signal passes to the E1439 ADC module in one of two ways. If the input 
frequency band is 0 Hz to 36 MHz, the signal at the 89605 input is passed directly 
to the E1439 module. If the input frequency band is 20 MHz to 2.7 GHz, the signal 
comes from the external down converter through the 89605 module to the E1439 
95 MSa/s ADC + Filter + FIFO + 70 MHz IF Input module.

Detailed information about this module is available in a PDF file: Agilent E1439 
VXI 70 MHz IF ADC with filters and memory User’s Guide. This guide is installed 
on your computer, however, you may have to use the Search function to find the 
exact location. Typical locations include the following:

C:/Vxi/Vxipnp/Winnt/age1439/help/e1439_Users_Guide.pdf

C:/Program Files/Visa/Winnt/age1439/help/e1439_Users_Guide.pdf

Triggering

For external trigger mode, a trigger signal must be supplied at the Ext Trigger 
connector on the front panel. This input is AC coupled with an impedance of 1 K 
ohm so any signal with a sharp rising or falling transition greater than 100 mV (for 
example, TTL or ECL logic) can be used as an external trigger source. Minimum 
pulse width is 300 ns.

Coupling

The input can be either AC or DC coupled. AC coupling enables the system to 
measure low level AC signals in the presence of a large DC offset.
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Signal conditioning

In 0-36 MHz mode, the input signal goes through the lower path in the block 
diagram. In this mode, no attenuation occurs in the E1439 module.

In 36 MHz-2.7 GHz mode, the input signal goes through the upper path in the 
block diagram. This path includes 0 to 32 dB of attenuation in 1 dB steps. The 
signal is band-pass filtered, mixed with 95 MHz, and low-pass filtered. This 
inverts and translates the frequency spectrum from 52-88 MHz at the input to 
43-7 MHz at the ADC. The ADC samples the signal at a 95 MHz sample rate.

Analog-to-digital (ADC) signal conversion

The central part of the E1439 is a precision sampling ADC. The ADC samples the 
signal at a rate of up to 95 MSa/sec and converts the analog signal to a digital 
signal.

Memory

Digitized data is stored in memory in the E1439 module and read out after a block 
of data has been taken. The digitized data passes through the E8491 interface to the 
measurement software in the computer.

For information on how the signal is processed by the measurement software, see 
the 89600 online help for “System Block Diagram” under Tutorial, Theory of 
Operation. Typically, this help file is in location:

C:/Program Files/Agilent/89600 VSA/Help/tasks.hlp
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This section provides information on obtaining replaceable parts for the Agilent 
89600-series VXI modules.
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Replaceable parts for VXI hardware

NOTE This chapter contains information only for VXI measurement hardware modules. 
If your analyzer uses other measurement hardware, such as an Agilent E4406 or 
Agilent E4440, refer to the service document shipped with that product. 
 
For VXI mainframes, refer to the mainframe documentation on replaceable parts.

For information on upgrading your analyzer or replacing parts, contact your local 
Agilent Technologies sales and service office. See the list of office locations and 
addresses in the back of this manual.

Ordering Information

To order Agilent parts in the U.S., call Agilent Technologies Support Parts at (877) 
447-7278. Outside the U.S., please contact your local Agilent Technologies parts 
center.

See the following pages for replaceable parts lists:

System cables and connectors

• "Agilent 89610A parts" (page 269)

• "Agilent 89611A parts" (page 269)

• "Agilent 89640A parts" (page 270)

• "Agilent 89641A parts" (page 271)

Modules

• "89605 parts" (page 272)

• "89606 parts" (page 272)

• "E1438 parts" (page 272)

• "E1439 parts" (page 272)

• "E2730 parts" (page 273)

• "E2731 parts" (page 273)

• "E8491B parts" (page 273)
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Agilent 89610A parts

Cables, connectors, and terminations. References for illustrations showing cable 
connections:

• “Cable connections, 89610” on page 52

• “Cable connections, two-channel 89610” on page 53

Additional cables and connectors for second input channel 

Agilent 89611A parts

Cables, connectors, and terminations (double the quantities for 2-channel 
configurations). References for illustrations showing cable connections:

• “Cable connections, 89611” on page 55

• “Cable connections, 89611 with PSA Option H70” on page 56

• “Cable connections, two-channel 89611” on page 59

Additional cables and connectors for second input channel:

Part umber Description Qty

8121-0133 flex BNC (m) to BNC (m) cable 267 mm, black 1

8120-6237 flex BNC (m) to BNC (m) cable 172 mm, black 1

Part umber Description Qty

8121-0132 BNC (m) to BNC (m) cable 215 mm, black 1

03585-61603 SMB (f) to SMB (f) cable, 100 mm, orange 2

1250-0676 50 ohm SMB termination 4

Part umber Description Qty

8121-0132 flex BNC (m) to BNC (m) cable 215 mm, black 2

1250-0780 N (m) to BNC (f) Adapter 1

8121-0790 SMA(m) to SMA(m) cable 1,219 mm 1

1250-1250 Type N(m) to SMA(f) adapter 1

1250-1700 BNC(m) to SMA(f) adapter 1

1250-0590 coax SMA cap 2

Part umber Description Qty

03585-61603 SMB (f) to SMB (f) cable, 100 mm, orange 2

8121-0132 flex BNC (m) to BNC (m) cable 215 mm, black 1

1250-0676 50 ohm SMB termination 4
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Agilent 89640A parts

Cables, connectors, and terminations. (Double the quantities for 2-channel 
configurations.) References for illustrations showing cable connections:

• “Cable connections, 89640” on page 61

• “Cable connections, 89640 with second IF/baseband channel” on page 62

• “Cable connections, 89640 with second RF channel” on page 64

• “Cable connections, 89640 with external down converter” on page 66

* With an 89605A, you need two 89605-61691 cables. With an 89605B, you need 
one 89605-61691 cable and one 89605-61693 cable.

Additional cables and connectors for second IF channel:

Additional cables and connectors for second RF channel: 

1250-0590 coax SMA cap 2

Part umber Description Qty

8121-0132 flex BNC (m) to BNC (m) cable 215 mm, black 2

1250-0780 N (m) to BNC (f) Adapter 1

89605-61691 SMA (m) to SMA (m) Semi-rigid cable 1-2*

89605-61692 SMA (m) to SMA (m) Semi-rigid cable with toroid 1

89605-61693 SMA (m) to SMA (m) Semi-rigid cable 0-1*

1250-0590 coax SMA cap 2

Part umber Description Qty

03585-61603 SMB (f) to SMB (f) cable, 100 mm, orange 2

1250-0676 50 ohm SMB termination 4

8121-0132 flex BNC (m) to BNC (m) cable 215 mm, black 1

Part umber Description Qty

03585-61603 SMB (f) to SMB (f) cable, 100 mm, orange 2

1250-0676 50 ohm SMB termination 4

8121-0132 flex BNC (m) to BNC (m) cable 215 mm, black 1

89605-61696 semi-rigid SMA cable 2

1250-0590 coax SMA cap 2

Part umber Description Qty
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Agilent 89641A parts

Cables, connectors, and terminations. References for illustrations showing cable 
connections:

• “Cable connections, 89641” on page 67

• “Cable connections, 89641 with second IF/baseband channel” on page 68

• “Cable connections, 89641 with second RF channel” on page 70

• “Cable connections, 89641 with external down converter” on page 72

* With an 89605A, you need two 89605-61691 cables; with an 89605B, you need 
one 89605-61691 cable and one 89605-61693 cable.

Additional cables and connectors for second IF channel:

Additional cables and connectors for second RF channel: 

Part umber Description Qty

8121-0132 flex BNC (m) to BNC (m) cable 215 mm, black 2

1250-0780 N (m) to BNC (f) Adapter 1

89605-61691 SMA (m) to SMA (m) Semi-rigid cable 1-2*

89605-61694 SMA (m) to SMA (m) Semi-rigid cable with toroid 1

89605-61693 SMA (m) to SMA (m) Semi-rigid cable 0-1*

1250-0590 coax SMA cap 2

Part umber Description Qty

03585-61603 SMB (f) to SMB (f) cable, 100 mm, orange 2

1250-0676 50 ohm SMB termination 4

8121-0132 flex BNC (m) to BNC (m) cable 215 mm, black 1

Part umber Description Qty

03585-61603 SMB (f) to SMB (f) cable, 100 mm, orange 2

1250-0676 50 ohm SMB termination 4

8121-0132 flex BNC (m) to BNC (m) cable 215 mm, black 1

89605-61696 semi-rigid SMA cable 2

1250-0590 coax SMA cap 2
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89605 parts

The following lists 89605 parts.

89606 parts

The following lists 89606 parts.

E1438 parts

For information in installing SDRAM, see the Replacing Assemblies chapter in the 
Agilent E1438 VXI 100 MSa/s ADC with filters and memory User’s Guide. This 
guide is installed in your computer, however, you may have to use the Search 
function to find the exact location. Typical locations include the following:

C:/Vxi/Vxipnp/Winnt/age1438/help/e1438_Users_Guide.pdf

C:/Program Files/Visa/Winnt/age1438/help/e1438_Users_Guide.pdf

E1439 parts

For information in installing SDRAM, see the Replacing Assemblies chapter in the 
Agilent E1439 VXI 70 MHz IF ADC with filters and memory User’s Guide. This 
guide is installed in your computer, however, you may have to use the Search 
function to find the exact location. Typical locations include the following:

C:/Vxi/Vxipnp/Winnt/age1439/help/e1439_Users_Guide.pdf

C:/Program Files/Visa/Winnt/age1439/help/e1439_Users_Guide.pdf

Part umber Description Qty

89605-69201 Exchange 89605A module 1

89605-69211 Exchange 89605B module 1

Part umber Description Qty

89606-69201 Exchange 89606A module 1

89606-69211 Exchange 89606B module 1

Part umber Description Qty

E1438-69202 Exchange E1438 module 1-2

1818-7901 ICM SDRAM 128 MB 0-2

1818-7889 ICM SDIMM 16 MB 0-2

1818-8606 IC SDRAM 64MX7 0-2

Part umber Description Qty

E1439-69202 Exchange E1439 module 1-2
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E2730 parts

The following lists E2730 parts.

E2731 parts

The followings lists E2731 parts.

E8491B parts

See E8941B service manual for installation instructions. You can also find this 
PDF guide using: http://www.agilent.com. Click on Technical Support and Search 
for E8491B. Select E8491B Configuration and User’s Guide from the results. You 
can also view this guide as a PDF using the link:

http://www.home.agilent.com/upload/cmc_upload/All/EPSG084330.pdf

1818-7901 ICM SDRAM 128 MB 0-2

1818-8606 IC SDRAM 64MX7 0-2

1818-7889 IC SDIMM 16 MB 0-2

Part umber Description Qty

E2730-69201 Exchange E2730A module 1

E2730-69211 Exchange E2730B module 1-2

1250-0590 coax SMA cap 2

Part umber Description Qty

E2731-69201 Exchange E2731A module 1

E2731-69211 Exchange E2731B module 1

 E2731-61601 SMA (m) to SMA (m) Semi-rigid cable 1

1250-0590 coax SMA cap 2

Part umber Description Qty

E8491-66202 Module, Service Replaceable E8491B 1

8121-0078 E8491B to IEEE-1394/PCI card cable 1

E8491-61613 IEEE-1394/PCI card power adapter cable 1

E8491-66204 IEEE-1394/PCI Card 1

Part umber Description Qty
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Transporting VXI modules

CAUTION The VXI modules are static sensitive; use appropriate precautions when removing, 
handling, and installing to avoid damage.

• Package the module using the original factory packaging or packaging identical 
to the factory packaging.

• If returning the module to Agilent Technologies for service, attach a tag 
describing the following:

• Type of service required

• Return address

• Model number

• Full serial number

In any correspondence, refer to the module by model number and full serial 
number.

• Mark the container FRAGILE to ensure careful handling.

• If necessary to package the module in a container other than original 
packaging, observe the following (use of other packaging is not 
recommended):

• Wrap the module in heavy paper or anti-static plastic.

• Protect the front panel with cardboard.

• Use a double-wall carton made of at least 200-pound test (32 ECT) 
material.

• Cushion the module to prevent damage. For example, several layers of 
plastic bubble wrap is usually sufficient.

CAUTION Do not use pellets in any shape as packing material for the module. The pellets do 
not adequately cushion the module and do not prevent the module from shifting in 
the carton. In addition, some pellets create static electricity which can damage 
electronic components.
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Storing VXI modules
Store modules in a clean, dry, and static free environment.
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