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Installation 
Preparing your emulation system for use.  

System Requirements 
Your computer must be running Windows XP/2000/9x or better and have one USB 
2.0 port available. USB 1.1 ports are not recommended because of slow speed. 

The shipping package should contain the following: 

1. ADM-51 in-circuit debugger (emulator). 

2. USB 2.0 (type A/B) cable. 

3. 20-pin target cable 

4. Signum Systems Development Tools CD-ROM. 

5. Software activation key. 

6. Printed User Guide (this document). 
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Installation Procedure 
1. Insert the Signum Systems Development Tools for Microsoft Windows CD into your CD-

ROM drive. From the Master Setup window, select Chameleon Debugger and 
double-click on ADM51 Emulator, as shown in Figure 1. 

 
FIGURE 1  Chameleon Master Setup window. 

2. Follow the online instructions and complete the installation process. 

3. Attach the ADM51 emulator to a USB communication port. If the USB driver for 
the emulator has not yet been installed, the Found New Hardware Wizard appears. 
Please follow the wizard’s instructions. When asked to provide the location of the 
driver, select Install from a List or Specific Location and point to the SigUSB.inf 
file located in the Drivers\USB subdirectory of the main installation directory. The 
default location is C:\Program Files\Signum Systems\Wemu51\Drivers\USB. 
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For more USB driver installation details, please refer to the USB 2.0 Driver for 
JTAGjet and ADM-51: Installation Instructions PDF file. 

4. 
ulator. Optionally, turn the 

5. 
 an existing one (Figure 2). Click the Create New button to 

Connect the ADM51 emulator to the 20-pin male emulation connector on your 
target board using the flex cable provided with the em
target power on now. 

Start Chameleon WEMU51 Debugger. A dialog box prompts you to create a new 
debug project or open
build a brand new project. 

 
FIGURE 2   Creating new project on debugger startup. 
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6. The Create Project Wizard appears (Figure 3). Click Next. 

 
FIGURE 3   Create Project Wizard guides you through the project creation process. 
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7. When asked to provide the name and optional comment for your project, enter 
them and click Next. Browse for, or type, the name of the project directory for all 
project-specific files. Be careful not to use the debugger installation directory as the 
project directory. Click Next. A list of available targets appear. Select ADM51 
Emulator (Figure 4) and press the Next button. 

 
FIGURE 4   Target selection list. 
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8. Depending on your system, the wizard displays the available communication device 
or a list of such devices. Select the USB ADM51 device with the serial number of 
the ADM51 emulator used in your project (Figure 5). Click Next.  

 
FIGURE 5   Choosing the communication device for a project. 
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9. Select the emulated target processor from the list (Figure 6). Click Next.  

 
FIGURE 6   Choosing the emulation processor. 
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10. In its last dialog box, the Create Project Wizard displays all the selections you 
made. To correct the entries, click Back and modify the settings. If you are satisfied 
with the setting, make sure that the Open New Project after it is Created check box 
is checked (Figure 7) and click the Finish button. 

 
FIGURE 7   Verifying the project settings. 
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11. The debugger closes the Create Project Wizard and opens the project you have just 
created and establishes communication with the ADM51 emulator. The Select 
Clock Frequency dialog box appears (Figure 8). Enter the frequency of your target 
clock. The value is used by the Trace window to convert processor cycles into time 
units (microseconds, milliseconds, etc.) when displaying trace data. 

 
FIGURE 8   Selecting the target clock frequency. 
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12. Press the Select button. The initial debugger screen should look as shown in Figure 
9. 

 
FIGURE 9   Chameleon WEMU51 opening screen. 
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13. If you have not turned the target power on, the Status window displays the NoPwr 
state in, and the Command the “No Target Power” message appears in the 
Command window (Figure 10). If this is the case, turn power the emulator now. 
Chameleon acknowledges the power-on state in the Status window by displaying 
STOP as the processor state (Figure 11). It is recommended to keep the Status 
window opened permanently for monitoring the status of the processor and 
important processor registers. 

 
FIGURE 10   Chameleon WEMU51 detects the No Target Power condition. 
 

 
FIGURE 11   Target Power On and CPU Stopped condition acknowledgement. 
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14. Verify that your ADM51 emulator is equipped with the optional Trace Buffer 
hardware by executing the VERSION command in the debugger’s Command 
window. In addition to displaying the serial numbers of the debugger’s hardware, 
firmware, software and the serial number of the emulator unit itself, it detects the 
presence of Trace Buffer. If Trace Buffer is installed, then the debugger’s toolbar 
contains the Trace button, while the Trace option appears in the View menu. 

15. Since the trace option is turned off by default, emulators with Trace Buffer require 
activating the feature from within the debugger. Select Project > Preferences > 
Trace. Make sure that the Enable Trace check box in the Open Trace Preferences 
dialog box is checked (Figure 12). Click OK. 

 
FIGURE 12   Enabling the Trace Buffer option. 
 

The Trace setting is stored in your project configuration file Wemu51.cnf located 
in the project directory. On project startup, the setting is restored. 
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Before you continue with your project, please familiarize yourself with the 
documentation available through the Contents option of the (Figure 13). Chapter 6.2 of 
the text contains information specific to the ADM51 emulator. To obtain HELP 
information about a specific debugger window, make the window active and then press 
the F1 key. To obtain information on Chameleon commands, right-click in the 
Command window and from the popup menu select either the Help on Available 
Commands or Help on Expression Syntax option.  

 
FIGURE 13   Accessing the Chameleon documentation. 
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Emulator Features 
Getting familiar with your emulator. 

External Characteristics 

  

USB 2.0 
interface 

Status 
LED

Host activity 
LED 

TargetAd
apter a
Cable

nd 
 

Target activity 
LED 

 
FIGURE 14   ADM-51  emulator.
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The ADM-15 emulator is shown in Figure 14.  Their USB connectors are located on 
the unit’s back side. On the front of the ADM-51, there is a 20-pin high-density 
connector. The emulator has LED indicators for monitoring various aspects of the 
units’ operations, as specified in Table 1. 

L E D  
I N D I C A T O R  

D E S C R I P T I O N  

Target Monitors the target connection lines. 
• Stable ON: target powered, no data transfer on target 

connection lines. 
• Stable OFF: target not powered. 
• Blinking: data transmission on target connection lines. 

Status 1. Monitors the CPU status when the debugger has 
established communication with the emulator. 
• ON: CPU is running 
• OFF: CPU in HALT state. 

2. Monitors the emulator’s power when the debugger is 
disconnected form the emulator. 

Host Monitors the link to the host computer. 
• ON: debugger established connection. 
• OFF: no debugger-emulator connection. 
• Blinking: data transfer between PC and emulator in 

progress. 
 

TABLE 1  ADM-51 LED functionality. 

Note: Chameleon Debugger polls the CPU status approximately 
every 1 sec. Accordingly, this data transfer is indicated by the 
TARGET and HOST LEDs as a steady blinking occurring every 
1 sec. (even when the CPU is not running). 
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Reset and Power-Up Conditions 

Software 
You can quit the debugger and leave the target board running at any time. Re-entering 
Chameleon Debugger will neither reset the running CPU nor stop it. However, it may 
be necessary to reset the CPU at times in order to enable debugging. 

Emulator 
As a rule, the emulator should be always turned on first. When disconnect from the 
host USB port while the debugger is running, the system displays the Communication 
Error dialog box In such an event, reconnect the emulator and press the Settings 
button in the Communication Error dialog box to resume normal operation. 

Target Board 
Chameleon does not report any error when the target board is disconnected from 
power. The loss of power is indicated in the Status window, however. The content of 
target volatile memory is lost when power is disconnected. Therefore, after power has 
been turned on, it may be necessary to both reload the application program and execute 
an initialization macrocommand file. 

Reset 
Clicking the RES toolbar button resets the CPU, making it stop on the fetch of the 
first instruction at the reset vector address. 
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Troubleshooting 
When things go wrong. 

Communicating with the Emulator 
Encountering a communication error message when Chameleon starts, or during a 
debug session, indicates either that the debugger cannot connect to the emulator, or 
that the connection has been lost (Figure 15). 

 
FIGURE 15   Run-time communication error message. 

Try this 
• Check if the emulator is connected to host computer USB port. 

• Check if the emulator’s HOST LED is on. 

18 
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• Try to use different USB port on your computer. 

CPU NoPwr Status (No Power) 
The NoPwr CPU state displayed in the topmost row of the Status window indicates 
that Chameleon could not detect power the target board. 

Try this 
• Check if target power is turned on. 

• Check if the emulator’s TARGET LED is on. 

• Check if the emulator is connected to the target board CCTC connector using a flex 
cable. 

Trace Window Menu Not Available 
You are not able to find the Trace option on the View menu or the Trace button on the 
toolbar. 

Try this 
• Check whether your ADM51 emulator has Trace Buffer installed. Run the VERSION 

command in the Command window and verify the Trace installation status. 

• Verify the processor type. With the TDK 71M6511 and 71M6511H processors, which 
do not generate trace data, the Trace window is disabled. 

• Disconnect the emulator from the USB port, the target power supply and the external 
power supply. Reconnect and check the Trace option status again. 
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Trace window does not display any data 
The Trace window does not display any data after program execution is stopped. 

Try this 
• Select Project >Preferences > Trace to verify that Trace Buffer is enabled: the Enable 

Trace check box in the Trace Preferences dialog box should be checked. 

No Source Code in the Source Window 
The debugger’s Source window does not display the source code of your application. 

Try this 
• Select File > Load to display the Load dialog box. Verify that your application is loaded 

with the Load Code, Load Lines and Load Symbols options selected. 

• In the Symbol Explorer window, verify that the loaded application contains debug 
information about source code lines. 

• Review the compilation/linking options applied when building your application. Rebuild 
the entire application, reload it, and check again. 

• Verify that the display mode of the Source window is set to “Source.” On the toolbar, 
press the Reset button (or run the RESET command in the Command window). Check 
the source code display again. 
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Emulator specification  •  Target connector  •  Technical support 

Emulator Specification 
P A R A M E T E R  A D M - 5 1  
Size (W × L × H) 2.5 × 5.5 × 1.0 inches 
Power supply 100 – 240 VAC input 

5 VDC @ 1 A output 
Compatible voltage 3.3V – 5V 
Target cable length 10 in. flex ribbon cable 
Storage 
temperature 

0 to 40 C 
Operating humidity 0 to 90% 
Breakpoints • Unlimited number of software 

breakpoints 
• Two independent hardware 

breakpoints 
• Hardware based single step 

Communication 
interface 

USB 2.0 High-Speed  mode 
480Mbps 

Section 

4 

21 



S I G N U M  S Y S T E M S  
6 9 0  

22 

P A R A M E T E R  A D M - 5 1  
File download 
format 

HEX, AOMF51 (Intel, Keil, 
Franklin, Archimedes, Raisonance), 
UBROF (IAR, Archimedes), COFF 
(Tasking), IEEE695 (PLC), FST 
(Signum) 

TABLE 2  ADM-51 emulator specifications. 

Target Connector 
Trough Hole Part Number AMP/Tyco #104068-1 
Type Male header, through hole, 

20-pin, dual-row, with 
keying shroud 

Surface Mount Part Number AMP/Tyco # 104549-2 
Type Male header, 20-pin, dual-

row, with keying shroud 
TABLE 3  Target connector specifications. 

T A R G E T  
S I G N A L  

P I N  T A R G E T  
S I G N A L  

3.3 V PD 20 19 GND 
ISYNC 18 17 GND 

TB0 16 15 GND 
TB1 14 13 GND 
TB2 12 11 GND 
TB3 10 9 GND 

RXTX 8 7 GND 
TCLK  6 5 GND 

RST  4 3 GND 
 2 1 GND 

TABLE 4  Pinout of the target connector. 
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Target Board Layout 

Pin 1 m
board’

Pin 1 must be on 
board’s bottom. 

Through hole male 
header mounted 
astride edge. 

FIGURE 16  Target board layout guidelines 

 

  
Through hole or 
surface mount 
male header with 
shroud mounted 
straight-up. 
23 

ust face 
s edge. 
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Signum Technical Support  
Contact Signum Systems Technical Support by dialing 
(805) 523-9774, Monday through Friday between 9 A.M. 
and 5 P.M. Pacific Time. In order to enable our technical 
support engineers to process your request efficiently, we 
strongly recommend submitting the Technical Support 
Request form available at signum.com/support.htm. 

 

℡
 
A Friendly Reminder We will be able to serve you better 
if, when contacting our Tech Support, you are at your 
computer, have your documentation at hand and are 
prepared to provide: 

1. 

2. 

3. 

4. 

Fo

 

C O N T A C T  I N F O  

 11992  Challenger Court  

Moorpark , California 93021 

 805.523.9774 

 805.523.9776 

 www.signum.com 

 signum.com/support.htm 
 signum.com/sales.htm 
 

The version of your Signum Systems software, hardware or firmware that you are 
using and the serial number of your emulator. 

The wording of any messages and prompts that appear on your screen. 

The environment, in which your software is running, including the type of 
hardware and operating system. 

A description of what happened and what you were doing when the problem 
occurred. 

r more information, please visit our home page on the World Wide Web. 
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