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Purpose

This document describes the process of installing the Signum Chameleon

WEMUS51 debugger for use with the Signum Systems USP-51 emulator for the
8051 family of microcontrollers.

Installation

Insert the Development Tools for Microsoft Windows CD into your CD-ROM

drive. In the Master Setup dialog box, select Chameleon Debugger and
double-click USP-51 ICE, as shown in Figure 1.
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FIGURE1 Chameleon Master Setup dialog box.
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2.

On Windows XP/2000/NT, the dialog box shown in Figure 2 appears.
If you intend to use the parallel with your emulator, click the Yes button.

Question <]
@ Concern: USPAIDS units with activated parallel port:

Tainztall the ICE's parallel port driver
the cunent account should be azzigned
the administrator privilege lewvel.

Thig iz neceszany for the setup pragram ta add

a reqistry entry required by the ICE parallel port driver.
If pou install the debugger from an account

without the adminiztrator privileges

the debugger will nat work with the ICE parallel port.

wiould you like to install the parallel port driver now?

FIGURE 2 Installing the parallel driver.

Complete the Chameleon WEMUS51 debugger installation process.

Connect the USP-51 emulator to your computer through either a serial
port (e.g, COM1) or parallel port (e.g., LPT1), then connect it to the
power supply. Plug the power supply cord into an outlet. Attach the
POD to the emulator using the two white flexible cables that extend
from the emulator’s front panel. Turn the emulator on. Do not connect
the POD to the user target yet—please complete the installation
procedures described below first.

Start WEMUS1 Dby selecting the Windows Start menu and clicking
Programs | Signum Systems WEMU-51. If you installed Chameleon
WEMUSL1 for the first time, the WEMUbS1 Project Manager dialog box
appears (Figure 3).
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B WEMUS1 Project Manager

Mo information about recent projects was found in the master project
configuration file.

If pou would like to create new project now [recommended), click Create
Mew.

Click Open to browse for already existing project file and open the project.
If pou click Cancel pou may create new project or open existing project
later from PROJECT menu,

i Create Mew. . | Open... | Cancel |

FIGURE3 WEMUS1 Project Manager dialog box..

Create a new debug project to start working with your emulator. The fastest
way to do so is to click the Create Nlew button in the dialog box in Figure 3.
This launches the Project Creation Wizard.

Clicking the Cancel button dismisses the Project Manager dialog box and
enables the debugger menus. Note that some of Help and Project
submenus are available regardless of your project status. This allows you to
read the program documentation (Help | Contents), obtain the program
version number (Help | About) or create a new project (Project | Create
New).

If you reinstalled the debugger, but earlier had created a project with a
previous Chameleon WEMUSL1 version, then click the Open button. This
brings up the standard Windows Open dialog box. Browse for the project
configuration file Wemu51.CNF located in the project directoryan select it.
This opens the corresponding project.
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You can create a brand new project using the Project Creation Wizard
accessible from the WEMUS1 Project Manager dialog box. Press the
Create New button or select Create New from the File menu (Figure 4).

Project Creation Wizard

Welcome to the Create Project
Wizard

This wizard helps you create project that will be
uzed by the Chameleon debugger to save and
manage all pour programs, data and settings.

To continue, click Next.

< Back

Cancel |

FIGURE 4 Project Creation Wizard—opening dialog box.
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Click Next to begin creating a new project. Enter the project name along
with optional comments (Figure 5).

Project Creation Wizard [ %]

Fleaze zelect name and optional comment far
wour project.

The project name may consist up to 32 chars and
iz displayed on debugger's title bar when a project
iz opened.

The comment is optional and usually iz a brief (up
to 256 chars] description of project features. It
may be left blank now and set later fram
FROJECT-:INFORMATION metnu.

M arne:
ITest Project

Comment [optional):

Thiz is a test project ;I

% Back I Mext» I Cancel |

FIGURE5 Naming the project.
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Click Next. The wi

zard prompts you to select the project folder (Figure 6).
The folder will contain your application executable file, source code files, the
project command startup file Wemu51.INI, definitions of custom toolbar

buttons and other project specific files.

Project Creation Wizard

Pleaze select project directary for your project.

Project directory is a folder for files and subfalders
where all project files will be stored.

Iain project settings will be stored in the project
configuration file "WERMUST.CMF" located in the
project directony.

Other files stored in the project directory will be:

- project command startup fle "WEMUSTINIY,

- program executable and source code files,

- defiritions of custom toolbar buttons,

- wariouz project related data files.

Mate, that project directary has to have file create
and write rightz.

e strongly recommend to avoid use of
debugger's installation directary "'C:\Pragram
FilezSignum Systemsziw'emubl" az a project
directony |

F:A\Signumiwemudl Projects\T est Project 1

Browse ... |

< Back I Mext » I Cancel |

FIGURE 6 Selecting the project library.
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Click Next. Select USP-51 In-Circuit Emulator as the target for your project,
as shown in Figure 7.

Project Creation Wizard

Pleaze select target pou want ko uze in
yaur project from the following list of
available targets.

uit E mulator

< Back I Mest » I Cancel

FIGURE 7 Selecting the emulator.
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Click Next. In the dialog box that appears, choose the communication
device, such as one of the host computer communication ports, to connect
the selected target device (the USP-51) with the host. From he Detected
Devices list, select the same port you chose in step 4 above. However, if you
connected the emulator to the network, you should select IceServer. Set the
remaining parameters. For best performance with the serial port or IceServer,
set the highest baud rate, 57600 bps. When using the parallel port under
Windows ME, 98 or 95, it is necessary to select the base LPT port address.
This address can be found in the Device Manager available from the
Windows Control Panel. Windows XP, 2000 and NT provide the base LPT
port address automatically; its value cannot be modified and is grayed out
(Figure 8).

Project Creation Wizard

Pleaze select communication device for your
project from the following list of detected devices.

Detected Devices: LPT Port &ddress:

04378
S COM1
¥ cOM2
2 lceServer

| EeSEnen st

Hameion B addiess: I
TEEIF part: I

< Back I Mext » I Cancel |

FIGURE 8

Click Next. In this step, you select the processor for your project. From the
list of available devices, select the processor whose name corresponds to the
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processor chip located on the POD connected to the USP-51 emulator via
two wide flexible cables (Figure 9).

Project Creation Wizard

Pleaze select processar you want ta uge in your
project from the following list of processors.

If you cannot find exact processor name please
select processor manufactured by the same
company which haz features most alke to your
processar ar contact Signun Systems Technical
Support far an azsistance.

Atmel Wil 83CHIIC2 ;l

Atrnel W 23CH1RB2
Atmel Wil SICHIRC2
i A EUC SOCR1RD S

Dalas DEAOCH 0
Dallas D580C320 =l

CPU with 32/481/0 lines, High-5peed
rchitecture, Clock =2 function, Dual DFTR,
DT. PC& with P'M, Compare/Capture and
H50, 3 Timers/Counters, 7 Intermupts with 4
priovity levels, B4K Flash, 2566 Bytes IRAM,
additional configurable 1K an-chip <Rak, 25
EEPROM used as ¥DATA

< Back I Mest » I Cancel |

FIGURE9 Selecting the emulator.

Clicking on the Next button brings up the last wizard dialog box. It
summarizes the choices you have made. If you want to modify some of these
settings, press Back to go to the appriopriate wizard dialog box. Make the
desired changes and return to the last dialog box. Verify that the Open new
project after it is created check box is checked. Finally, press the Finish
button to create the new project.

Chameleon WEMU5S1 debugger opens the project you have created and
establishes communication with the USP-51 emulator as the target. The
Select Clock and Power Settings dialog box appears. Please select the
processor power source as external (i.e., from your target board) if the
emulator’s POD is plugged into your target board. If the POD is in the
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standalone mode, that is, not connected to any target board, the source

should be internal (i.e., from the emulator).

Select the processor clock source as external
or internal (from the POD) if the emulator’s
POD is plugged into your target board. When
the POD is unplugged from your target board,
then select internal. Choose the appropriate
clock frequency and clock speed rate: x2 for
new chips from Atmel W&uC, Philips or
another brand if you plan to use the x2 speed.
Otherwise, select x1. The effective processor

frequency is calculated as the selected
frequency times the speed rate.
[ Select Clock and Power Settings
Processor Power Proceszsor Clock [MHz]————
" Internal % Intemal |30.0
s 5 |1
|VF Extemnal —‘ |7f" External |16.0 spesdate HI_

Cancel |

FIGURE 10 Power and clock selection.

Note: The clock
frequency selected in
the dialog box does
not set the
frequency of the
processor clock
located on the POD
or on your target
board. This value is
simply used by the
debugger when
timing data have to
be calculated.

Upon opening the project, the debugger main window contains the
Status, Source, Symbol Explorer and Command windows. Note the
names of the selected target (Emulator) and project (Test Project) displayed

on the debugger’s title bar (Figure 11).
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|
FIGURE 11 Typical project initial screen.

The File menu can be used to select and load your application and to open
or save various data from/into files.

The View menu provides access to various debugger windows, such as
Status or Command.

The Debug menu allows you to start, stop and step through a loaded
application and trigger breakpoints.
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The Project menu facilitates project management tasks. Use it to create
new projects, list and open existing ones, close the current project and
modify its settings.

The Options serves the purpose of modifying the project target and
communication device as well as customizing the toolbars.

The Help menu allows you to open the debugger documentation (Help
| Contents), display the debugger version information (Help | About),
open Signum web pages (to check for the latest software upgrades, for
instance, or send a message to the Signum Systems support personnel.

Turn the entire system off
and connect the POD to the Note: If you would like to explore the

target board. program before connecting to the target
board, proceed as outlined below.

In the Command window on the right side of your screen, you should
see a record of the WEMUS1. ini file commands that were executed
when the project was opened. This project startup command file contains
the commands run automatically by the debugger when the project
opens. Note that the memory mapping is such that the memory on the
target board is used and the POD is ready for target board development
and debugging. However, if you choose to work with the program before
it connects to the target board, you need to remap the memory so that
the emulator's memory is used instead. To accomplish that, type “map
P all 1”7 (map the entire program memory to the emulator) in the
Command window and hit the Enter key. Then type “map X all
1”. This places the external memory data in the emulator’'s memory
(Figure 12).
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FIGURE 12 Remapping the memory.
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Technical Support

CONTACT INFO

< 1211 Flynn Road , Unit 104

Camarillo , California 93012

(805) 583-3682

(805) 583-3685

WWW.SIgnum.com

signum.com/support.htm

OB |

signum.com/saleshtm

provide:

L

Contact Signum Systems Technical Support by
dialing (805) 523-9774, Monday through Friday
between 9 am. and 5 p.m. Pacific Time. In order
to enable our technical support engineers to
process your request efficiently, we strongly
recommend submitting the Technical Support
Request form available at
signum.com/support.htm.

A Friendly Reminder WWe will be able to serve you
better if, when contacting our Tech Support,
you are at your computer, have your
documentation at hand and are prepared to

The version of your Signum Systems software, hardware or firmware that

you are using and the serial number of your emulator.

2. The exact wording of any messages and prompts that appear on your screen.

3. The environment, in which your software is running, including the type of
hardware and operating system.

4. A description of what happened and what you were doing when the

problem occurred.

For more information, please visit our home page on the World Wide Web.

a

SWII-ChamUSP-51 11.5.04.16.50 480
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