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about this 
guide

About this Guide
About this Guide

This user guide provides information to help you:

■ Install and configure Fabric Manager

■ Use Fabric Manager to manage your fabric and switches

■ Contact technical support for additional assistance

“About this Guide” topics include:

■ Overview, page 12

■ Conventions, page 13

■ Rack Stability, page 16

■ Getting Help, page 17
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Overview
This section covers the following topics:

■ Intended Audience

■ Related Documentation

Intended Audience
This book is intended for use by system administrators who are experienced with 
the following:

■ HP StorageWorks Fibre Channel SAN switches

■ Fabric Operating System (FOS) V3.0.x or later

Related Documentation
For a list of related documents included with this product, see the Related 
Documents section of the Release Notes that came with your switch.

For the latest information, documentation, and firmware releases, please visit the 
following StorageWorks website:

http://www.compaq.com/storage/productindexdisk.html

For information about Fibre Channel standards, visit the Fibre Channel 
Association website, located at http://www.fibrechannel.com.
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Conventions
Conventions consist of the following:

■ Document Conventions

■ Text Symbols

■ Equipment Symbols

Document Conventions
The document conventions included in Table 1 apply in most cases.

Text Symbols
The following symbols may be found in the text of this guide. They have the 
following meanings.

WARNING:  Text set off in this manner indicates that failure to follow 
directions in the warning could result in bodily harm or death.

Caution:  Text set off in this manner indicates that failure to follow directions 
could result in damage to equipment or data.

Table 1:  Document Conventions

Element Convention
Cross-reference links Blue text: Figure 1
Key and field names, menu items, 
buttons, and dialog box titles

Bold

File names, application names, and text 
emphasis

Italics

User input, command and directory 
names, and system responses (output 
and messages)

Monospace font

COMMAND NAMES are uppercase 
monospace font unless they are case 
sensitive

Variables <monospace, italic font>

Website addresses Blue, underlined sans serif font text: 
http://www.hp.com
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Note:  Text set off in this manner presents commentary, sidelights, or interesting points 
of information.

Equipment Symbols
The following equipment symbols may be found on hardware for which this guide 
pertains. They have the following meanings.

Any enclosed surface or area of the equipment marked with these 
symbols indicates the presence of electrical shock hazards. Enclosed 
area contains no operator serviceable parts. 

WARNING: To reduce the risk of personal safety from electrical shock 
hazards, do not open this enclosure.

Any RJ-45 receptacle marked with these symbols indicates a network 
interface connection.

WARNING: To reduce the risk of electrical shock, fire, or damage to the 
equipment, do not plug telephone or telecommunications connectors 
into this receptacle.

Any surface or area of the equipment marked with these symbols 
indicates the presence of a hot surface or hot component. Contact with 
this surface could result in injury. 

WARNING: To reduce the risk of personal safety from a hot 
component, allow the surface to cool before touching.
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Power supplies or systems marked with these symbols indicate the 
presence of multiple sources of power. 

WARNING: To reduce the risk of personal safety from electrical 
shock, remove all power cords to completely disconnect power 
from the power supplies and systems.

Any product or assembly marked with these symbols indicates that the 
component exceeds the recommended weight for one individual to 
handle safely.

WARNING: To reduce the risk of personal safety or damage to the 
equipment, observe local occupational health and safety requirements 
and guidelines for manually handling material.
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Rack Stability
Rack stability protects personnel and equipment.

WARNING:  To reduce the risk of personal safety or damage to the 
equipment, be sure that:
■ The leveling jacks are extended to the floor.
■ The full weight of the rack rests on the leveling jacks.
■ In single rack installations, the stabilizing feet are attached to the rack.
■ In multiple rack installations, the racks are coupled.
■ Only one rack component is extended at any time. A rack may become 

unstable if more than one rack component is extended for any reason.

Stephen Pomfret


Stephen Pomfret
Fabric Manager has nothing to do with racks. Fabric Manager is a CD not hardware. Delete the above section.
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Getting Help
If you still have a question after reading this guide, contact an HP authorized 
service provider or access our website: http://www.hp.com.

HP Technical Support
In North America, call technical support at 1-800-652-6672, available 24 hours a 
day, 7 days a week.

Note:  For continuous quality improvement, calls may be recorded or monitored.

Outside North Americas, call technical support at the nearest location. Telephone 
numbers for worldwide technical support are listed on the HP website under 
support: http://thenew.hp.com/country/us/eng/support.html.
Be sure to have the following information available before calling:

■ Technical support registration number (if applicable)

■ Product serial numbers

■ Product model names and numbers

■ Applicable error messages

■ Operating system type and revision level

■ Detailed, specific questions

HP Storage Website
The HP website has the latest information on this product, as well as the latest 
drivers. Access storage at: http://www.hp.com/country/us/eng/prodserv/
storage.html. From this website, select the appropriate product or solution.

http://www.hp.com/support/
http://www.hp.com
http://www.hp.com/country/us/eng/prodserv/storage.html
http://www.hp.com/country/us/eng/prodserv/storage.html
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HP Authorized Reseller
For the name of your nearest HP authorized reseller:

■ In the United States, call 1-800-345-1518

■ In Canada, call 1-800-263-5868

■ Elsewhere, see the HP website for locations and telephone numbers: 
http://www.hp.com.

http://www.hp.com
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1Introducing Fabric Manager

This chapter provides the following information:

■ Overview on page 20

■ Features on page 22

■ Fabric OS Integration on page 26

■ Concepts on page 27
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Overview
Fabric Manager provides a graphical interface that allows the administrator to 
monitor and manage an entire fabric from a standard workstation. Fabric Manager 
can be used to manage fabrics containing integrated fabrics, in addition to 
individual switches. 

Fabric Manager provides high-level information about all switches in the fabric, 
launching the Web Tools application when more detailed information is required. 
The launching of Web Tools is transparent, providing a seamless user interface. In 
addition to the ability to view the switches as a group, Fabric Manager provides 
improved efficiencies in the management of SANs over Web Tools alone. 

Fabric Manager is installed on the workstation, and can be used to manage any 
switches that have Fabric OS V2.2 or later and Web Tools V2.2 or later installed. 

Advantages 
Fabric Manager is the complete SAN management power tool for SANs, and 
provides the following advantages to administrators:

■ Provides a highly scalable Java-based application that manages multiple 
switches and multiple fabrics (up to 8) in real-time. 

■ Assists SAN administrators with the configuration, monitoring, dynamic 
provisioning and daily management of Storage Area Networks. 

■ Lowers the cost of SAN ownership by intuitively facilitating SAN 
management tasks. 

■ Saves time by enabling the global integration and execution of processes 
across multiple fabrics, through its single-point SAN management platform. 

■ Allows more effective management by providing rapid access to critical SAN 
information across both Fabric OS SANs and enhanced Fabric OS SANs. 

Capabilities 
In cooperation with Web Tools, Fabric Manager provides the following 
information and capabilities: 

■ Configure and manage the fabric on multiple efficient levels. 

■ Intelligently group multiple SAN objects and SAN management functions to 
provide ease and time-efficiency in administering tasks.

Stephen Pomfret
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■ Identify, isolate, and manage SAN events across multiple switches and 
fabrics. 

■ Provide drill-down capability to individual SAN components through tightly 
coupled Web Tools and Fabric Watch integration.

■ Discover all SAN components and view the real-time state of all fabrics. 

■ Execute multi-fabric administration of Secure Fabric OS SANs through a 
single encrypted console.

■ Implement scalable SAN management tasks through functionality and tools 
that intelligently span 8 fabrics and 200 switches. 

■ Monitor Interswitch Links (ISLs).

■ Manage switch licenses.

■ Perform fabric stamping.
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Features
This section describes Fabric Manager’s core and advanced management features.

Core Features
Fabric Manager delivers enhanced levels of efficiency to administrators that are 
immersed in multiple HP SANs. It has the unique ability to provide real-time 
information and facilitate rapid SAN management. 

Improved Scalability
Fabric Manager is highly scalable and can manage up to eight fabrics and 200 
switches in real-time. 

A Single Console Global SAN Management Platform
Fabric Manager has the intelligence to manage multiple SAN objects spanning up 
to 8 fabrics. It dynamically collects (in real time) all SAN fabric elements and 
portrays them within the single console, allowing intuitive iconic and explorer tree 
operations. 

For more information, see “Accessing Fabric Manager View” on page 42.

Enhanced SAN Visibility
Fabric Manager can globally capture and present reliable statuses across all SAN 
objects. These are projected throughout the entire SAN management environment. 
This context-sensitive feature allows the status of all SAN components to be 
dynamically discovered and controlled by Fabric Manager. 

For more information, see “Events” on page 86 or “Fabric Manager Log” on 
page 74.

Intuitive and Functional Object Management Platform
Fabric Manager’s visual display is tailored to facilitate a high degree of efficiency 
when working with multiple storage area networks (SANs), medium to large 
SANs and up to 200 fabric switches. Fabric Manager provides object status of 
critical fabric elements such as fabric events, capturing this information in 
real-time across multiple fabrics. 

For more information, see “Events” on page 86.
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Advanced Management Features
Fabric Manager provides unique and intuitive advanced methods for managing 
storage area networks (SANs).

User-Controllable SAN Object Grouping
Fabric Manager enables the SAN manager with the power to group fabric 
switches in any logical user-defined group. These groups are dynamically and 
intelligently propagated throughout Fabric Manager. User-defined groups can be 
utilized at any time and ultimately lower the cost of SAN management. 

For more information, see “Logical Groups” on page 27.

ISL Monitoring
Fabric Manager enables you to monitor the physical connections (known as 
Interswitch Links, or ISLs) between switches and ports. Specific alarm settings 
may be chosen, and changes in the ISL topology, such as moves and disconnects 
can be monitored in the Events dialog box as well as by the status color of the 
switch icon. 

For more information, see “ISL Status Tab” on page 68 and “Setting ISL Status 
Parameters” on page 69.

Fully Controllable Sequenced and Timed Reboot
For SAN administrators immersed in the complexities of hardware and firmware 
management, Fabric Manager provides a totally flexible environment for 
controlling the availability of fabric switches. The ability to control switch 
availability is tightly controlled using logical groupings and global password 
control. 

For more information, see “Reboot” on page 102.

Global Password Control
Fabric Manager provides the advanced ability to manage a user-definable set of 
fabric switch passwords. Secure and encrypted objects can be utilized across all 
secure features within the platform and across logical groups. 

For more information, see “Telnet” on page 90.
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Highly Flexible Firmware Download
The Firmware Download feature is dynamically configurable and scalable across 
logical groups, password controls, and multiple fabrics. When utilized with the 
Sequenced Reboot functionality, it provides a fully configurable environment to 
SAN administrators for controlling the Fabric OS firmware download process. 

For more information, see “Download Firmware” on page 99.

Advanced License Key Management
Fabric Manager provides a powerful environment to manage license keys across 
all SAN fabrics under its control. Fabric Manager can receive licenses from 
support (via e-mail), enabling you to perform pre and post installation 
cross-checking of License keys. License management is fully integrated to all 
advanced features, particularly Groups and Password Control. 

For more information, see “Licensing” on page 106.

Configuration Control through Intelligent Baseline Profiling
This function allows SAN managers to capture a detailed, customizable profile of 
a switch within any fabric. Once the snapshot has been acquired, it can optionally 
be stored in any user-definable location, external Configuration Control Database, 
or Management Framework. At any point in time, a static profile can be reviewed 
and analyzed against an active fabric or switch within a SAN. 

For more information, see “Comparing or Downloading a Switch Configuration 
from a File” on page 105.

Enhanced Merge Control
Storage Area Network Administrators can easily control the merging details of 
SAN management through the Fabric Manager multi-fabric platform. When 
merging fabrics and zones within fabrics, Fabric Manager does most of the work 
for the administrator. Fabric Manager delivers a detailed transaction report of the 
proposed zone merge operation that identifies any inconsistencies or underlying 
issues that may exist within the topology or operation. 

For more information, see “Fabric Merge” on page 108.
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Tight Integration of Management Products 
Fabric Manager is tightly integrated with HP’s entire SAN management family of 
products. It has the native ability to work with: 

■ Web Tools for a rapid drill-down to individual SAN elements within a fabric. 

■ Fabric Watch for advanced fabric wide status reporting, threshold gathering 
and information analysis. Provides rapid access to Fabric Watch allows 
reporting of conditions across multiple fabrics. 

Fabric Manager’s ability to work easily with all Management tools is unique and 
highly functional, effectively reducing the time and costs of managing your SAN.
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Fabric OS Integration
The Fabric OS version running on the switch determines what functionality is 
supported by Fabric Manager. A matrix that outlines the features and what version 
of the Fabric OS they are supported on is shown in Table 2. 

The cell contents indicate the access method being used by Fabric Manager to 
implement the features:

Note:  Cells in Table 1–1 that are shaded indicate that the feature is supported.

 

Table 2:  Outline of Feature Support in Fabric OS Versions

Feature V2.2 - 2.5 V2.6
Firmware Download
Sequenced Reboot
Fabric Merge
License Management
Configuration Handling
Multi-fabric Support
Logical Groups
ISL Monitoring
Switch Status Detail (Starts V2.5)
Set Time FA 2.0 FA 2.0
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Concepts

Logical Groups
A “logical” group can be created to monitor the status of their component 
switches and propagate actions over the chosen group of switches. A SAN 
administrator can also use this feature to quickly determine the status of a large 
number of switches without looking through each one. A logical group differs 
from a physical group in that they do not necessarily represent a physically 
grouped set of switches. 

For information on creating a logical group, see “Groups” on page 64.

Local Files
Fabric Manager persists groups and other information to “local” files. Fabric 
Manager stores these files in your home directory. Log files are under your 
home/Fabric Manager/log. 

Import/Export
Logical groups and other configuration information can be saved to local files and 
shared between hosts through the Import and Export options. Additionally, 
configuration information can be imported from files. 

For more information about Import/Export, see “Groups” on page 64 or “Config” 
on page 105.

ISL Checking
ISL checking is done by stamping or taking a “snapshot” of a topology. When you 
turn on ISL checking for a fabric, a stamp is taken of the topology of the ISLs. 
Then when a change occurs in these ISLs, the status of the switch changes and the 
detailed information is shown on the Events page, as well as causing the status 
color of the switch to change during an event. 

For information about setting up ISL checking, see “ISL” on page 93 and 
“Monitor ISLs” on page 149.
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2Installing Fabric Manager

This chapter provides the following information:

■ Requirements on page 30

■ Installing Fabric Manager on page 31

■ Launching Fabric Manager through Windows on page 38

■ Adding the Browser Pathname to the Properties File on page 39

■ Uninstalling Fabric Manager on page 40
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Requirements
The computer workstation and the switch must both meet specific requirements 
for the correct installation and operation of Fabric Manager.

Switch Requirements
Fabric Manager can be used to manage HP StorageWorks switches that meet the 
following requirement:

■ Fabric OS V2.2 or greater is installed. Fabric Manager can be used to manage 
switches with earlier versions of Fabric OS, but status and event information 
is not available. 

Workstation Requirements
The following items are required for the correct installation and operation of 
Fabric Manager on the computer workstation: 

■ One of the following operating systems:

— Windows 2000

— Windows NT 4.0

■ Adequate RAM:

— 128 MB for fabrics of 21 switches or less

— 256 MB for fabrics containing more than 21 switches

■ 30 MB of free disk space

■ One of the following web browsers: 

— Netscape Communicator 4.51 or later

— Internet Explorer 4.01 or later

Note:  The browser must be specifically configured to work with Fabric Manager. For 
information about how to do this, see “Configuring the Web Browser” on page 2–32.

■ Java Plug-in Version 1.2.2-005 or better

Stephen Pomfret
Internet Explorer 6 preferred.
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Installing Fabric Manager
Preparing to use Fabric Manager to manage your fabric requires the following:

■ Installation of one of the supported web browsers on the workstation, if not 
already installed.

■ Configuration of the web browser for use with Fabric Manager.

■ Installation of the required Java Plug-in on the workstation, if not already 
installed.

■ Installation of Fabric Manager on the computer to be used as a workstation.

■ Exit and re-launch the browser.

Installing the Java Plug-in on the Workstation
A Java Plug-in must be installed on the workstation for the Fabric Manager 
installer to function. Note that the Java Plug-in is also required for the correct 
operation of Fabric Manager and Web Tools. Windows 2000 and NT workstations 
require Java Plug-in Version 1.2.2-005 or later. The SAN Appliance requires Java 
Plug-in Version 1.3.1 or later.

To determine the version of the Java Plug-in installed on Windows 2000 or NT, 
and install the plug-in if necessary:

1. Choose Start > Programs > Java Plug-in Control Panel and turn on the 
Java Console.

2. Launch the web browser, enter the name or IP address of a switch running 
Fabric OS V2.2 or later, and press Enter. 

The switch launches the Java Plug-in console, which displays the Java Plug-in 
version currently installed.

3. Determine whether the correct Java Plug-in version is installed, and install if 
necessary:

■ If the correct version is installed, Fabric Manager is ready for use. 

■ If no Java Plug-in is installed, point the browser toward a switch running 
Fabric OS V2.2 or later, follow the link to the Sun Microsystems website, 
and download the correct Java Plug-in, then double-click the downloaded 
file to install the plug-in.

■ If an outdated version is currently installed, uninstall it, re-launch the 
browser, enter the address of a switch running Fabric OS V2.2 or later, 
follow the link to the Sun website, and download the new Java Plug-in.
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Installing a Web Browser
Install one of the following browsers, if not already installed:

■ Netscape Communicator 4.51 or later (available at http://www.netscape.com).

■ Internet Explorer 4.01 or later (available at http://www.microsoft.com).

Configuring the Web Browser
Specific browser settings are required for the correct operation of Fabric Manager 
with either Netscape Communicator or Internet Explorer.

Configuring Netscape Communicator
The web browser cache must be cleared after the installation of Fabric OS. The 
browser may use local cache copies of jar files and/or image files to improve 
performance (depending on options selected in the browser), which can cause 
incorrect display.

To remove cached files from Netscape Communicator:

1. Choose Edit > Preferences. 

2. Click Advanced in the left text box to expand it, then click Cache.

3. Click Clear Memory Cache.

4. Click Clear Disk Cache.

5. Click OK.

Configuring Internet Explorer
Correct operation of Fabric Manager with Internet Explorer requires clearing the 
web browser cache after installation and specifying the appropriate settings for the 
browser refresh frequency and process model.

The browser cache must be cleared after the installation of Fabric OS. The 
browser may use local cache copies of jar files and/or image files to improve 
performance (depending on options selected in the browser), which can cause 
incorrect display.

To remove cached files from Internet Explorer:

1. Choose Internet Options from the View menu if using Internet Explorer 4.x, 
or from the Tools menu if using 5.x.

2. Choose the General tab.

http://www.netscape.com
http://www.microsoft.com
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3. Click Delete Files... (under Temporary Internet Files). 

4. Click OK.

5. Exit and re-launch the browser.

Browser pages must be refreshed at every visit to ensure the correct operation of 
the Switch Admin feature.

To set the refresh frequency:

1. Choose Internet Options from the View menu if using Internet Explorer 4.x, 
or from the Tools menu if using 5.x.

2. Choose the General tab and click Settings (under Temporary Internet 
Files). 

3. Under Check for newer versions of stored pages, choose Every visit to the 
page.

The correct Browser Process Model must be selected.

To choose the Browser Process Model (only required for Windows NT):

1. Choose View > Internet Options if using Internet Explorer 4.x, or Tools > 
Internet Options if using Internet Explorer 5.x.

2. Choose the Advanced tab and click to expand the Browsing category.

3. Under Browsing, choose Browse in a new process if using Internet Explorer 
4.x, or Launch browser windows in a separate process if using Internet 
Explorer 5.x.

Installing Fabric Manager on the Windows Workstation
The Fabric Manager 3.0 installation package includes the following items:

■ ReadMe.txt file, providing product name, version, and late-breaking news.

■ Java Plug-in.

■ FabricManager.Jar file, containing the required Java classes.

■ FabricManager.properties file, containing configuration information.

To install Fabric Manager 3.0:

1. Insert the Fabric Manager CD-ROM in the CD drive of the computer 
workstation. 

If Fabric Manager is already installed on the computer, a dialog box displays. 
If this dialog box displays, you must exit the installer and uninstall the 
existing version.
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The installer searches the local system for the correct version of the Java 
Plug-in. If this version is not installed, a dialog box displays warning that the 
correct version of the plug-in is missing. If the installer warns that the plug-in 
is missing, perform step 3 before continuing. Otherwise, continue with step 4.

The Welcome dialog box displays, providing product information and 
version.

2. Click Next.

3. If the installer warns that the Java plug-in is missing:

a. Click Exit to close the Fabric Manager installer, then click Exit Install 
in the warning dialog that displays.

b. View the local drives, right-click on the icon for the Fabric Manager 
CD-ROM, and choose Explore.

c. Click to open the JRE folder, then click on the file jre-1_3_1-win.exe. The 
plug-in installer launches.

d. Read the license agreement, and click Next if you accept the agreement. 
A dialog box displays to allow selection of the installation location.

e. Click Next to accept the default installation location, or browse for a 
custom location and then click Next. The installation completes and the 
Plug-in Installer dialog box closes.

f. Re-launch the Fabric Manager installer by double-clicking the icon for 
your CD-ROM drive. The Welcome dialog box displays.

g. Click Next to close the Welcome dialog box.

Once the Java plug-in has been successfully located, a dialog box listing 
Fabric Manager’s web browser requirements displays.

4. Determine whether a compatible browser is installed. If a compatible browser 
is not installed, exit the Fabric Manager installation, install the browser, and 
then re-launch the Fabric Manager installation. 

Note:  The browser should be installed before Fabric Manager is installed so that the 
pathname for the browser can be written to the Fabric Manager properties file.

5. Click Next to continue. A dialog box that allows selection of the installation 
location displays.
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6. Click Install to accept the default installation location, or browse for a custom 
location and then click Install. A dialog box showing the progress of the 
installation displays, with the name of the file currently being installed in the 
lower portion of the dialog box. 

The installer searches the registry for the web browser and adds the complete 
pathname to the FabricManager.properties file. If the installer is unable to 
locate a web browser, a dialog box displays warning that no browser was 
found. If this dialog box displays, exit the Fabric Manager installation, install 
the browser, and then re-launch the Fabric Manager installation. 

Note:  If the browser is installed or moved after Fabric Manager is installed, see 
“Adding the Browser Pathname to the Properties File” on page 2–39.

7. Choose the check box if you want to view the ReadMe file, then click Done to 
close the installer.

Note:  Clicking Exit at this point does not undo the installation, but does prevent the 
ReadMe.txt file from being displayed.

Configuring a Browser for Secure Telnet
Once you have Secure Telnet software installed, you can configure a browser to 
use Secure Telnet.

Netscape Navigator 3.0 

1. Choose Options > General Preferences.

2. Click Applications or Apps tab. Look for the space for entering a Telnet 
application. 

3. Click Browse to choose your Telnet application, or enter the full path and file 
name of the Telnet application on your computer. 

Netscape Communicator (Navigator 4.03 and above) 

1. Choose Edit > Preferences. 

2. Click Navigator: Applications. Scroll down the list at the right. 

3. Click URL: Telnet Protocol, then click Edit. 
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In the Handled by: area, make sure Application is selected.

4. Click Browse to choose your Telnet application, or enter the full path and file 
name of the Telnet application on your computer. 

5. After the full path and file name has been added, place the cursor at the end of 
the path and type a space and %1.Example:

C:\Program Files\CRT\Crt.exe %1 

Microsoft Internet Explorer 3.0 

Note:  When you first install Internet Explorer, it should already be able to open a 
Telnet application (called RUNDLL.32). Follow these instructions if you wish to change 
the default Telnet application, or if a default Telnet application is not set. 

1. Choose View > Options. The Options dialog box displays.

2. Click Programs tab.

3. Click on the File Types button to scroll down the list of registered file types. 

4. Click URL: Telnet Protocol, then click on the Edit button. The Edit File 
Type dialog box displays.

5. Click Open from the Actions box by clicking on it, then click Edit. 

6. Click Browse to choose your Telnet application, or enter the full path and file 
name of the Telnet application on your computer. 

Microsoft Internet Explorer 4.0 or higher (PC) 

Note:  When you first install Internet Explorer, it should already be able to open a 
Telnet application (called RUNDLL.32). Follow these instructions if you wish to change 
the default Telnet application, or if a default Telnet application is not set. 

1. Go to your Desktop. 

2. Double-click My Computer. 

3. Choose View > Option.

4. Click File Types tab then scroll down list of registered file types. 

5. Click URL: Telnet Protocol and then click Edit. 
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6. Click Edit from the Edit File Type dialog box.

7. Click Browse to choose your Telnet application, or enter the full path and file 
name of the Telnet application on your computer. Your Telnet application 
displays in the Application used to perform action dialog box. 
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Launching Fabric Manager through Windows
You can launch Fabric Manager once Fabric Manager and the Java Plug-in are 
both installed on the workstation.

To launch Fabric Manager:

1. Choose Start >Programs > Fabric Manager > Fabric Manager. The 
Address dialog box displays.

2. Enter the switch name or IP address in the Switch URL field. 

Note:  This switch is assumed to be the local domain. If you want information specific to 
QuickLoop to be available, the QuickLoop switch must be the local domain.

3. Press Enter to submit the address.

Note:  If an incorrect address or format is used, an error message displays, listing the 
formats that can be used. If this message displays, determine and enter the correct 
address.

Once a correct address is entered, Fabric Manager launches, displaying the 
Fabric View. 
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Adding the Browser Pathname to the Properties File
This is an optional step, and usually not necessary. However, if your browser is not 
working, you may need to edit the properties file to show the correct path for the 
browser. 

Note:  Editing any information other than the browser pathname in the properties file is 
not recommended.

To add the browser pathname to the properties file:

1. Open the directory where Fabric Manager is installed. The default directory 
is:

c:\Program Files\Fabric Manager\

where c is the local drive.

2. Double-click on the FabricManager.Properties file, and choose a text editor 
(such as Notepad) as the application for this file.

3. Enter a new line starting with BrowserPath=, followed by the correct 
pathname for the browser, in quotes. Example: 

BrowserPath=”C:\\Program Files\\Internet Explorer\iexplore.exe”

This line can be added anywhere in the file, provided it does not interrupt another 
line.
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Uninstalling Fabric Manager

Note:  The uninstaller can only access the most recent installation. To uninstall an 
additional installation, open the corresponding installation folder, open the 
subdirectory UninstallerData, and double-click Uninstall FabricManager.exe to launch 
the uninstaller.

To uninstall Fabric Manager:

1. Choose Start > Settings > Control Panel.

2. Double-click the Add/Remove control panel.

3. On the Install/Uninstall tab of the control panel, choose Fabric Manager 
application and click Add/Remove. A dialog box displays warning that you 
are about to uninstall Fabric Manager.

4. Click Uninstall to continue. A dialog box showing the progress of the 
uninstallation displays. When the uninstallation is complete, the Uninstall 
Complete dialog box displays.

5. Click Exit.
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3Fabric Manager View

This chapter provides the following information:

■ Overview on page 42

■ Options available in the Fabric Manager View on page 45
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Overview
Fabric Manager detail view is the first view that displays when you launch Fabric 
Manager, and it provides access to specific information about the fabric and 
switches through a panel representing each switch. Every switch in the fabric is 
represented by a switch panel in Fabric View.

Accessing Fabric Manager View
Launch Fabric Manager and access the Fabric Manager View. For information 
about launching Fabric Manager, see “Launching Fabric Manager through 
Windows” on page 38.

Fabric Manager launches, displaying the Fabric View (default), as shown in 
Figure 1.
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Figure 1:  Fabric Manager View 

Figure 2 shows the Fabric Manager View with the Fabric Icon selected. 
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Figure 2:  Fabric Manager View with the Fabric icon selected 

For more information, see “SAN Elements Tab Icons” on page 49.
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Options available in the Fabric Manager View 
The following section provides an overview of the options available through the 
Fabric View area of Fabric Manager. 

Menus
The Menus portion of the Fabric Manager View is shown in Figure 3.

Figure 3:  Fabric Manager View menus

Table 3 lists the options available in the Fabric Manager View:

Table 3:  Available Options on the Fabric Manager View

View Options
File > The File drop-down list provides the following options:

■ New 
■ Close
■ Fabric Login
■ Groups

— Create
— Import 
— Export

■ Options...
■ Log...
■ Print...
■ Exit 
For more information, see “File Menu” on page 57.

View > The View drop-down list provides the following options:
■ Detail
■ Summary
■ Table
For more information, see “View Menu” on page 79.
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Actions > The Actions drop-down list provides the following options:

■ Switch View
■ Events
■ Admin
■ Fabric Watch
■ Telnet
■ Zone Admin
■ Name Server
■ ISL

— ISL Checking
— Restamp

■ Set Time
■ Fabric Checking
For more information, see “Actions Menu” on page 83.

Tools > The Tools drop-down list provides the following options:
■ Download Firmware
■ Reboot 

— Create Reboot Sequence
— Sequence Reboot

■ Config
— Save Baseline
— Compare/Download from File
— Compare/Download from Switch

■ Licensing

— Import from File
— Load from Switch

■ Fabric Merge
For more information, see “Tools Menu” on page 97.

Table 3:  Available Options on the Fabric Manager View (Continued)
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Tool Bar
Table 4 lists a brief description of the options available in the Fabric View Tools 
bar.

Help > The Help drop-down list provides the following options:
■ Help
■ Context Help
■ Status Legend
■ About
For more information, see “Help Menu” on page 111.

Table 3:  Available Options on the Fabric Manager View (Continued)

Table 4:  Available Options on the Fabric View Tools Bar

Option Description

Address dialog box Enter the IP address, name, or WWN 
of the switch that you want to manage 
or monitor. Once the switch information 
has been entered, the address can be 
chosen automatically from the 
drop-down list. 

Fabric Login Icon Click the switches that you want to login 
to. For more information about this 
option, see “Fabric Login Icon” on 
page 121.

Open FM Log Icon Click to open the Fabric Manager Log. 
For more information about this option, 
see “Fabric Manager Log” on page 74.

Print Table Icon Click to print a table report. For more 
information, see “Print Table Icon” on 
page 126 or “Print” on page 73.
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For more information about the Tool Bar options available in Fabric Manager, see 
“Tool Bar” on page 119.

SAN Elements Panel
Use the SAN Elements Panel to view, choose, and search for the elements of a 
SAN (fabrics and/or groups) by their IP address, Name, or WWN. 

SAN Elements Tab
The SAN Elements tab of the Fabric Manager View is shown in the default view 
in Figure 4.

Download Firmware Icon Click to set up firmware downloads for 
multiple switches at once. For more 
information about this option, see 
“Download Firmware” on page 99.

Sequenced Reboot Icon Click to set up switches to reboot in a 
chosen order. For more information, 
see “Sequenced Reboot” on page 103 
or “Set up a Sequenced Reboot” on 
page 151.

Context Sensitive Help Icon Click to view Context Sensitive Help. For 
more information about this options, 
see “Context Sensitive Help Icon” on 
page 132.

Help Icon Click to view the Help section. For more 
information, see “Help” on page 134 
or “Help” on page 112.

Table 4:  Available Options on the Fabric View Tools Bar (Continued)
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Figure 4:  SAN Elements dialog box

The Navigation Tree control of the SAN Elements Panel displays various nodes, 
such as fabrics, groups, reboot groups, devices, switches, ports, etc. Some views 
in Fabric Manager may show only some nodes, but not others. A filter tab may be 
displayed on some views so that you can search for switches by their properties. 

SAN Elements Tab Icons
Table 5 lists a brief description of the options available in the SAN Elements tab:
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Table 5:  SAN Elements Tab Options

Options Descriptions

Fabric Icon Click the Fabric Icon from the SAN 
Elements column to view a fabric 
view of the entire fabric, rather than 
individual switches. See “Switch 
and Fabric Icons Available in Fabric 
View” on page 52.

ISL Checking

A—

B—

C—

D—

Displays the status of ISL Checking. 
A—Displays by default when ISL 
Checking is OFF and fabric checking 
is OFF.
B—Displays when ISL Checking is 
ON, but fabric checking is OFF.
C—Displays when ISL Checking is 
OFF, but fabric checking is ON.
D—Displays when ISL Checking is On, 
and fabric checking is ON.

Clicking on the word “Fabrics” in the navigation tree causes the following icons to 
display in the right-hand dialog box:

Fabric Events Click to open Fabric Events View.

Zone Admin Click to open the Zone Admin View. 

Name Server Click to open the Name Server. 

Fabric Topology Click to open the Fabric Topology 
view. For information, refer to the HP 
StorageWorks Web Tools Version 
3.0.x/4.0.x User Guide. 
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Filter tab
Use the Filter tab of the SAN Elements dialog box to search for switches by IP 
Address, Name, Type, Version (FOS), WWN, or Domain ID. The Filter tab is 
shown in Figure 5.

Figure 5:  Filter tab of the SAN Elements dialog box

Clicking on the word “Groups” in the navigation tree causes the following icons 
display in the right-hand dialog box:

Group Events Click to open Fabric Events View. For 
information about this view, see 
“Events” on page 86.

Group Creation Click to open the Group Creation 
dialog box. 

Group Exportation Click to open the Group Exportation 
dialog box.

Table 5:  SAN Elements Tab Options (Continued)



Fabric Manager View

52 Fabric Manager Version 3.0.x User Guide

Switch View
Use the Switch View portion of the Fabric View to manage individual switches. 
Launching the Switch View in Fabric Manager actually launches a partner 
management tool called Web Tools. The Switch View is shown in Figure 6.

Figure 6:  Switch View

Switch and Fabric Icons Available in Fabric View
Table 6 lists the available switch and fabric options in Fabric View:
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Table 6:  Available Switch and Fabric Options

Options Descriptions

Fabric and Group Select Icon Click this icon in either fabric or group 
to view the associated fabric or group. 
The fabric or group is selected in the 
navigation tree. 

Individual Switch Panel The Switch Panel representing an 
individual switch in the fabric. A Switch 
Panel displays for each individual 
switch in the fabric.

 Integrated Fabric Panel The Switch Panel representing a 
integrated fabric. 
The components of the control panel 
are described in the following rows.

Individual Switch Icon Click to open Switch View for the 
switch. Each switch type is represented 
by a different icon. The background 
color around the icon indicates the 
status of the switch.

Stephen Pomfret
The picture is of a core switch not a SAN Integrated Switch.
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Table 7 lists the Switch view fields and their descriptions:

Fabric Events Button Click to open Fabric Events View.

Events Click to open Switch Events View to 
display the Switch Events log.

Admin Click to open Switch Administration 
View.

Telnet Click to launch the Telnet Interface for 
the switch.

Table 7:  Switch View Field Descriptions

Switch View  Field Descriptions
Type Displays a picture of the switch 

configuration.
polled at
(or unreachable since:)

Displays the time of the last status check. 
If the switch is unavailable, this shows 
the time of the last successful status 
check.

Name Displays the name of the switch.
Fabric OS version Displays the version of Fabric OS 

installed on the switch.
Domain ID Displays a number that uniquely 

identifies the switch within the fabric.
Ethernet IP Displays the Ethernet IP address.
Ethernet Mask Displays the Ethernet subnetmask.
FCnet IP Displays the Fibre channel IP address.

Table 6:  Available Switch and Fabric Options (Continued)
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FCnet Mask Displays the Fibre channel subnetmask.
Gateway IP Displays the Gateway IP address.
WWN Displays the unique numeric identifier 

for the switch; assigned by 
manufacturer.

Table 7:  Switch View Field Descriptions (Continued)

Switch View  Field Descriptions
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4File Menu

This chapter provides information on the options available through the drop-down 
lists of Fabric Manager. The File menu, as shown in Figure 7, provides the 
following options:

■ New on page 58

■ Close on page 59

■ Fabric Login on page 60

■ Groups on page 64

■ Options on page 66

■ Print on page 73

■ Fabric Manager Log on page 74

■ Exit on page 78

Figure 7:  File menu 
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New 
Use the New option in the File menu to open a new dialog box to view fabric 
information. Any dialog boxes that are currently active remain open. 
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Close
Use the Close option in the File menu to close the dialog box you are currently 
viewing. Any other dialog boxes that are currently active remain open. 
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Fabric Login
Use the Fabric Login option in the File menu to choose and set up a switch, or 
group of switches, to login to. Table 8 lists the fields available in the Fabric Login 
dialog box:

Table 8:  Available Fields in the Fabric Login Dialog Box

Field Description
User Id Enter the User Id for a selected switch.
Password Enter the Password for a selected switch.
IP, Name, WWN Click the appropriate radio button to display a selected 

group of switches by IP address, name, or World Wide 
Name. 

SAN Elements Displays the fabrics or groups that belong to the Storage 
Area Network that the Admin is logged into. 

Filter Allows you to search for switches by IP address, Name, 
Type, FOS Version, WWN, or Domain ID. 

Selected Switches:

IP Address Displays the IP address of the selected switch.
Switch Name Displays the name of the selected switch. 
Firmware Version Displays the version of Fabric OS that is installed on the 

switch. 
User Id Displays the User Id of the individual who is logged into 

the switch. 
Status Displays the status of the switch login. Possible status 

reports are: Ready, Success, or Authorization Failed.
When Success is displayed, the background is green and 
User Id and Password are saved for performing admin 
operations until the session is terminated. 
When Authorization Failed is displayed, the background 
is red and the User Id and Password are not saved in 
memory. 

Test & Apply Click to check User Id and Password login on the listed 
switches. 
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Setting up a Login for Multiple Switches
1. Choose File > Fabric Login. The Fabric Login dialog box displays, as 

shown in Figure 8. 

OK Click to save configuration and exit dialog box. 
Cancel Click to cancel all changes made since changes were last 

applied, and to exit Fabric Login. Changes cannot be 
cancelled once they are applied.

Apply Click to save configuration but leave dialog box open.

Table 8:  Available Fields in the Fabric Login Dialog Box (Continued)
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Figure 8:  Fabric Login dialog box

2. Click SAN Elements tab to list the available elements by IP, Name, or WWN.

3. Choose a switch to set up and click on it to highlight.

4. Hold down the Ctrl key and choose any additional switches by clicking on 
them. 
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5. Click the  button. The switch moves to the Selected Switches area.

6. Enter User ID and Password at the top of the dialog box.

7. Click Test & Apply to determine if login is accepted.
or
Click OK to save configuration and exit dialog box.
or
Click Apply to save configuration and keep dialog box open.
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Groups
Use the Groups option in the File menu to create, import, and export groups of 
SAN elements.

Creating Logical Groups
To create a group of controllable SAN objects:

1. Choose File > Group > Create. The Create Groups dialog box displays, as 
shown in Figure 9.

Figure 9:  Create Groups dialog box
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2. Highlight the word Groups (that you want to create a new group in) from the 
navigation tree. 

3. Click Create from the bottom of the navigation tree dialog box. The Create 
Groups dialog box displays.

4. Enter a name for the group and press OK. The name of your group displays in 
the navigation tree.

5. Highlight the name of your group from the navigation tree by clicking on it. 

6. Click switches from the left navigation tree to be added to the Group. To 
choose multiple switches, use Shift/Click.

7. Add selected switches to your group by clicking on the right-arrow button, or 
by dragging and dropping selections from the navigation tree to the Group. 

Importing a Group
To import a group of controllable SAN objects:

1. Choose File > Group.

2. Click Import. A browser dialog box displays.

3. Browse to the XML file that was previously exported and choose it. The 
imported groups display in the navigation tree under Groups.

Exporting a Group
To export a group of controllable SAN objects:

1. Choose File > Group. 

2. Click Export. The Export dialog box displays.

3. Click Browse to locate and choose the file to export. The name of the file 
should display in the File field. 

4. Choose the groups that you want to export from the navigation tree.

5. Move the selected groups to the Export table by using the left-arrow or by 
dragging and dropping.

6. Click OK. The file is created. 



File Menu

66 Fabric Manager Version 3.0.x User Guide

Options
Use the Options function under the File menu to do:

■ File Transfers 

■ Check Logging Parameters

■ Check ISL Status

■ Fabric Change

File Transfer Tab
The File Transfer tab of the Options dialog box is used to transfer files from a 
Host IP to a Remote IP.

Transferring Files
To transfer files from a host IP to a remote IP by either Remote Shell or FTP:

1. Choose File > Options menu. The Options dialog box displays.

2. Click File Transfer tab. The File Transfer tab displays, as shown in 
Figure 10.

Figure 10:  File Transfer tab of the Options dialog box

3. Enter the Remote Host IP that ftp or rsh daemon is running on.
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4. Enter the Remote User name of the rsh or ftp program.

5. Enter the Remote Path that the rsh or ftp program used for the file.

6. Choose either Remote Shell or FTP protocol from Select Protocol 
drop-down list.

Note:  If FTP is the desired protocol, enter a password in the Password Required for FTP 
field. 

7. Click OK. 

Log Parameters Tab
Use the Log Parameters tab of the Options dialog box to set the path and priority 
levels for events in the fabric.

Setting Log Parameters
To set log parameters 

1. Choose File > Options menu. The Options dialog box displays.

2. Click Log Parameters tab. The Log Parameters tab displays, as shown in 
Figure 11.
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Figure 11:  Log Parameters tab of the Options dialog box

3. Browse to locate and choose the Logging path that is used to create a log 
sub-directory.

4. Choose a priority for the FabricManager Log Level from the drop-down list.

5. Choose a priority for the Console Log Level from the drop-down list.

6. Choose a priority for the File Log Level from the drop-down list.

7. Click OK to apply the settings.

ISL Status Tab
Use the ISL Status tab in the Options dialog box to set various ISL status 
parameters. Table 9 lists the fields available in the ISL Status tab:
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Setting ISL Status Parameters
To set ISL status levels to be reported in ISL checking:

1. Choose File > Options. The Options dialog box displays.

Table 9:  Available Fields on the ISL Status Tab

Field Description
Incorporate Adds 
into Stamp

Check box if:
You want the ISL Stamp to change when additions are 
made to the fabric. 

Uncheck box if:
You do not want the ISL Stamp to change when 
additions are made to the fabric.

Add Conflict Status Choose Yellow or Red, depending on which color you 
want to display when Fabric Manager detects that one or 
more ISLs cannot be monitored due to conflicting ISL Add 
events.
An Add Conflict occurs when two valid ISLs are set to be 
monitored for the same port in the stamp. 

Add Status Choose Yellow or Red, depending on which color you 
want to display when an ISL connection has been added. 

Remove Status Choose Yellow or Red, depending on which color you 
want to display when an ISL connection is removed. 
Because Remove Direct Connection Status is considered a 
high priority, the Remove Status priority cannot be set 
higher than the Remove Direct Connection Status. 

Remove Direct 
Connection Status

Choose Yellow or Red, depending on which color you 
want to display when a Fabric Manager detects that a 
direct physical connection has been removed. 
A Remove Direct Connection occurs when no direct path 
exists, although there is still an indirect path between 
switches.

Move Status Choose Yellow or Red, depending on which color you 
want to display when a Move event occurs. 
A Move event occurs when one end of an ISL is moved 
from one port to another, but is still connecting the same 
switches and one end of the connection has not moved.

OK Click to save ISL status parameters.
Cancel Click to exit without saving changes. 
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2. Click ISL Status tab. The ISL Status tab displays, as shown in Figure 12.

Figure 12:  ISL Status tab in the Options dialog box

3. Click the Yellow or Red radio buttons to choose the desired color to display 
when Add, Remove, or Move events occur (fabric and switch events display 
in the Fabric Events dialog box).

4. Click OK to apply the settings.

Fabric Change Tab
Use the Fabric Change tab in the Options dialog box to enable or disable 
automatic fabric checking. Table 10 lists the available fields and descriptions in 
the Fabric Change tab:

Table 10:  Available Fields on the Fabric Change Tab

Field Description
Automatically check 
fabrics

Check box to automatically check for new fabrics that 
are discovered.

Fabric Change Handling:
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Enabling Automatic Fabric Checking
To enable automatic Fabric Checking and to set Fabric Change handling:

1. Choose File > Options. The Options dialog box displays.

2. Click Fabric Change tab. The Fabric Change tab displays, as shown in 
Figure 13.

Figure 13:  Fabric Change tab in the Options dialog box

3. Choose Automatically Check Fabrics to automatically check new fabrics 
that are discovered. 

Allow Adds Click if you want switches to be added to the Fabric 
View when the fabric is checked. 

No Changes Click if you do not want the fabric to change (due to 
additions) after the fabric is checked. 

OK Click to save changes to Fabric Change Handling. 
Cancel Click to exit dialog box without saving changes. 

Table 10:  Available Fields on the Fabric Change Tab
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4. Choose Allow Adds from the drop-down list if you want additions in the 
fabric to cause a change in the Fabric View.
or
Choose No Changes if you do not want additions in the fabric to cause a 
change in the Fabric View.

5. Click OK to save and apply changes.
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Print
Use the Print option in the File menu to print table reports for review. 

Printing Reports
To print a report:

1. Choose View > Table. The Fabric View changes from an icon view to a table 
format. 

Note:  You can only print reports from the Table View.

2. Choose File > Print.
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Fabric Manager Log
Use the Fabric Manager Log in the File menu to view events occurring within the 
fabric. Table 11 lists the available fields and descriptions in Fabric Manager Log:

Viewing the Fabric Manager Log
Choose File > Fabric Manager Log to view the Fabric Manager Log. The Fabric 
Manager Log displays, as shown in Figure 14.

Table 11:  Available Fields on the Fabric Manager Log

Field Description
Severity Displays the log levels, such as Debug, Info (information), 

Warning, or Error.
Time Displays the time an event occurred. 
Module Displays which sub-module (or service), such as Discovery, 

or License generated the log entry. 
Message Displays messages regarding events occurring within the 

fabric, such as switch removal and discovery.
Search Click to launch the Search dialog box and search for 

particular data, such as specific messages, severities, 
modules, and time ranges. The Search dialog box is shown 
in Figure 15.

Filter Click to choose which aspects you want to have shown in 
the FM Log. This keeps the log from getting crowded with 
unwanted information. The Filter dialog box is shown in 
Figure 16.

Close Click to close the dialog box. 
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Figure 14:  Fabric Manager Log dialog box

Searching the Fabric Manager Log
Use the Search dialog box to locate specific events.

Searching for Fabric Data
To locate specific events, messages, or time ranges within the fabric:

1. Choose File > Fabric Manager Log. The Fabric Manager Log dialog box 
displays, as shown in Figure 14.
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2. Click Search at the bottom of the dialog box. The Search Dialog box 
displays, as shown in Figure 15.

Figure 15:  Search dialog box 

3. Enter a message to search the fabric for (specifying Case Sensitive or Whole 
Word, if desired).

4. Choose a severity from the Severity drop-down list.

5. Enter a Module to search the fabric for.

6. Choose a time range from both Time Range drop-down lists.

7. Click Search to begin a search using the assigned parameters.
or
Click Next to choose the next switch in the Fabric Manager Log list. 
or
Click Prev to choose the previous switch in the Fabric Manager Log list.

Filtering the Fabric Manager Log
Use the Filter dialog box to determine which events you want to display in Fabric 
Events. This prevents the Fabric Events dialog box from becoming cluttered with 
unnecessary information.

Filtering Fabric Events
To filter specific events such as messages, and time ranges within the fabric:

1. Choose File > Fabric Manager Log. The Fabric Manager Log dialog box 
displays, as shown in Figure 14.
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2. Click Filter at the bottom of the dialog box. The Filter Dialog box displays, 
as shown in Figure 16.

Figure 16:  Filter dialog box 

3. Enter a message to filter the fabric for (specifying Case Sensitive or Whole 
Word, if desired).

4. Choose a severity from the Severity drop-down list.

5. Enter a Module to filter within the fabric for.

6. Choose a time range from both Time Range drop-down lists.

7. Click Filter to begin filtering the assigned parameters.



File Menu

78 Fabric Manager Version 3.0.x User Guide

Exit
Use the Exit option in the File menu to close the Fabric Manager application. 
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5View Menu

This chapter provides information on the options available through the View 
drop-down list of Fabric Manager.

The View option of the drop-down list provides the following options:

■ Detail on page 80

■ Summary on page 81

■ Table on page 82

The View Menu is shown in Figure 17.

Figure 17:  View menu
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Detail 
Use the Detail option in the View Menu to see a Fabric View of the switches that 
includes information such as the Domain ID and the IP Address. The Detailed 
option of the View menu is shown in Figure 18.

Figure 18:  Detailed option of the View menu
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Summary 
Use the Summary option in the View Menu to see a Fabric View that provides a 
brief overview of the fabric information, rather than more detailed information. 
The Summary dialog box is shown in Figure 19.

Figure 19:  Summary option of the View menu
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Table
Use the Table option in the View menu to view and sort switch information in a 
table-form, rather than in a graphic-form. The Table option of the View menu is 
shown in Figure 20.

Figure 20:  Table dialog box of the View menu

Printing Table Reports
The Table View is the only view that allows you to use the Print option. For more 
information, see “Print” on page 73.
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6Actions Menu

This chapter provides information on the options available through the Actions 
drop-down list of Fabric Manager.

The Actions drop-down list provides the following options:

■ Switch View on page 85

■ Events on page 86

■ Admin on page 88

■ Fabric Watch (Optional) on page 89

■ Telnet on page 90

■ Zone Admin on page 91

■ Zone Admin on page 91

■ Name Server on page 92

■ ISL on page 93

■ Set Time on page 95

■ Fabric Checking on page 96

Note:  The options that are available in the Actions menu vary depending on what has 
been selected on the tree control.

The Action Menu is seen in Figure 21.
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Figure 21:  Actions menu
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Switch View
Use the Switch View option of the Actions Menu to open a Web Tools dialog box. 
For more information, look for the Switch View topic in the HP StorageWorks 
Web Tools Version 3.0.x/4.0.x User Guide.
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Events
Use the Events option of the Actions Menu to view a log of events for all switches 
in the fabric. The Events dialog box is shown in Figure 22.

Figure 22:  Events dialog box

Note:  To sort the events by a particular column, click the column header. To resize a 
column, drag the column divider.
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Table 12 lists the available fields and descriptions in the Events option:

Table 12:  Available Fields on the Events Option

Field Description
Status Reason Section: The upper area of the Events dialog box describes 

events that have changed the status of a switch. Entries 
in this area no longer display once the issue has been 
resolved. Some of the events are generated by Fabric 
Manager, and not by the switch. 

Print Click to print the Fabric Events dialog box. 
Status Displays the status this event caused.
Switch Displays the name of the switch that has had a change 

in status.
Status Reason Displays the reason that the switch has had a change in 

status. 
Event Log Section: The lower area of the Events dialog box is a log of all 

the events that have been detected by the switch. 
Status Displays the status this event caused.

Switch Displays the name of switch.

Status Reason Displays the reason for a noted event.

Num... (number) Displays the event number for affected switch.

Time Displays the time of the event.

Count Displays the number of consecutive occurrences of 
the same event.

Level Displays the severity level of the event:
■ 0 panic (switch reboots)
■ 1 Critical
■ 2 error
■ 3 warning
■ 4 information
■ 5 debug

Message Displays a description of the event.
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Admin
When using the Admin option, you are actually accessing Web Tools.

For more detailed information regarding Web Tools, refer to the appropriate 
version of the HP StorageWorks Web Tools Version 3.0.x/4.0.x User Guide. 
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Fabric Watch (Optional)
When using the Fabric Watch option, you are actually accessing Fabric Watch 
through Web Tools.

For more detailed information regarding Web Tools, refer to the appropriate 
version of the HP StorageWorks Web Tools Version 3.0.x/4.0.x User Guide or the 
HP StorageWorks Fabric Watch Version 3.0.x/4.0.x User Guide.
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Telnet
When using the Telnet option, you are actually accessing Telnet through Web 
Tools.

For more detailed information regarding Web Tools, refer to the appropriate 
version of the HP StorageWorks Web Tools Version 3.0.x/4.0.x User Guide or the 
HP StorageWorks Fabric OS Version 3.0.x/4.0.x Reference Guide.
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Zone Admin
When using the Zone Admin option, you are actually accessing Web Tools.

For more detailed information regarding Web Tools, refer to the appropriate 
version of the HP StorageWorks Web Tools Version 3.0.x/4.0.x User Guide or the 
HP StorageWorks Zoning Version 3.0.x/4.0.x User Guide.
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Name Server
When using the Name Server option, you are actually accessing Web Tools.

For more detailed information regarding Web Tools, refer to the appropriate 
version of the HP StorageWorks Web Tools Version 3.0.x/4.0.x User Guide.
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ISL
Use the ISL option to record and monitor the ISL configuration for a fabric. There 
are two separate actions that can be taken when using the ISL option:

■ ISL Checking

■ Restamp (available only when ISL Checking is enabled)

Note:  ISL Checking requires FOS 26 or later. The ISL feature is grayed out if the launch 
switch is running a version of FOS prior to 26 (even if switches under the launch switch 
are running versions of FOS).

Enabling and Disabling ISL Checking
When ISL Checking is enabled, a snapshot (or stamp) is taken of the topology. 
When a change occurs in the ISLs, the detailed information is shown on the Status 
Reason section of the Events page. For more information about Events, see 
“Events” on page 86.

To enable ISL checking:

1. Choose Actions > ISL > ISL Checking. A check mark displays, showing that 
ISL checking is enabled and the node icon changes. When ISL checking is 
turned on, the following changes take place:

■ If an event occurs, the Status Legend color changes to represent the 
appropriate Event. 

■ Any events are shown in the Fabric Events dialog box. 

To disable ISL checking:

Choose Actions > ISL > ISL Checking. A check mark displays, showing that 
ISL checking is disabled and the node icon changes.

Note:  For more information, refer to the “SAN Elements Panel” on page 48.
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Using Restamp
To restamp the fabric topology, and have the most current topology information 
noted in Fabric Events, use the Restamp option. This option is only available 
when ISL Checking has already been enabled. 

1. Ensure that ISL Checking is enabled. See “Enabling and Disabling ISL 
Checking” on page 93 and the follow the instructions to enable.

2. Choose Actions > ISL > Restamp. A snapshot is taken of the fabric.

3. Choose Actions > Fabric Events. View the latest changes within the fabric in 
the top of the Fabric Events dialog box.
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Set Time
Use the Set Time option set and change the time on a fabric or an individual 
switch. The Set Time dialog box is shown in Figure 23.

Figure 23:  Set Time dialog box
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Fabric Checking
Use the Fabric Checking option of the Actions menu to determine what changes 
or updates display in the Fabric View.

Enabling and Disabling Fabric Checking
To enable Fabric Checking, choose Actions > Fabric Checking. A check mark 
displays.

To disable Fabric Checking, choose Actions > Fabric Checking. The check mark 
disappears.
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7Tools Menu

This chapter provides information on the options available through the Tools 
drop-down list of Fabric Manager. The Tools drop-down list provides the 
following options:

■ Download Firmware on page 99

■ Reboot on page 102

■ Config on page 105

■ Licensing on page 106

■ Fabric Merge on page 108

The Tools Menu is shown in Figure 24, Figure 25, and Figure 26.

Figure 24:  Tools menu with Reboot options
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Figure 25:  Tools menu with Config options

Figure 26:  Tools menu with Licensing options



Tools Menu

99Fabric Manager Version 3.0.x User Guide

Download Firmware
Use the Download Firmware option of the Tools menu to download new firmware 
to the fabric. The Download Firmware dialog box is shown in Figure 27. The 
Download Firmware dialog box can also be displayed by selecting the Download 
Firmware icon located in the Tool Bar.
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Figure 27:  Download Firmware dialog box 
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Downloading Firmware to Multiple Switches
For instructions on downloading firmware, see “Downloading Firmware to 
Multiple Switches” on page 129.
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Reboot
Use the Reboot option of the Tools menu to manage switch reboots and minimize 
interruption of switch access. The Reboot option provides the following detailed 
options:

■ Create Reboot Sequence

■ Sequence Reboot

Create Reboot Sequence
Use the Create Reboot Sequence option to create a reboot group and sequence. 
The Create or Change Reboot Groups and Sequence dialog box displays, as 
shown in Figure 28.
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Figure 28:  Create or Change Reboot Groups and Sequence dialog box

Sequenced Reboot
Use the Sequence Reboot option to set up a group of switches to be rebooted in a 
chosen sequence. The Sequence Reboot dialog box is shown in Figure 29.
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Figure 29:  Sequence Reboot dialog box of the Reboot menu
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Config
Use the Config option of the Tools menu to create and apply “Baseline” 
configurations across multiple switches. The Config option provides the following 
submenus:

■ Save Baseline

■ Compare/Download from File

■ Compare/Download from Switch

Creating a Baseline Switch Configuration
For information on creating a Baseline Switch Configuration, see “Save a 
Baseline Configuration” on page 145.

Comparing or Downloading a Switch Configuration from a File
For information, see “Download and Apply a Baseline Configuration” on 
page 146.

Comparing or Downloading a Switch Configuration from a Switch
For information, see “Download and Apply a Baseline Configuration” on 
page 146.
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Licensing
Use the Licensing option of the Tools menu to administer and manage licensing 
information. The Licensing option provides the following submenus:

■ Import from File

■ Load from Switch

Importing a License from a File
To import a license from a local file:

1. Choose Tools > Licensing > Import From File. A browser dialog box 
displays.

2. Browse to choose the file that contains the license to be imported. 

3. Click OK.

Loading a License from a Switch
To view and change licensing information on a switch or fabric, use the License 
Admin dialog box:

1. Choose Tools > Licensing > Load From Switch. The License Admin - 
Switch Selection dialog box displays.

2. Choose the switch from which you want to load a license.

3. Click Login and log in to switch (if you have not already done so).

4. Click OK. The License Admin dialog box displays, as shown in Figure 30.

5. Click Switch tab.

6. Click Load From Switch.
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Figure 30:  License Admin dialog box of the License menu
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Fabric Merge
Use the Fabric Merge option of the Tools menu to facilitate the process of merging 
two fabrics. 

Performing a Fabric Merge
To choose two fabrics as merge candidates:

1. Choose Tools > Fabric Merge. The Fabric Merge Check dialog box 
displays, as shown in Figure 31

.

Figure 31:  Fabric Merge Check dialog box

2. Choose two fabrics to merge from the drop-down lists.

3. Click Check. Testing is initiated to compare configurations that are currently 
active. Results are displayed in the Merge Check Results dialog box, as 
shown in Figure 32.
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Figure 32:  Merge Check Results dialog box

If incompatibilities are found between fabrics, the Zone Merge dialog box 
displays, as shown in Figure 33.
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Figure 33:  Zone Merge dialog box

4. Click Options to remove conflicts.

Note:  For more information about merging fabrics, see “Validate Merging of Two 
Fabrics” on page 148.
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8Help Menu

This chapter provides the following information:

■ Help on page 112

■ Context Sensitive Help on page 114

■ Status Legend on page 116

The Help menu is shown in Figure 34.

Figure 34:  Help menu
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Help
Use the Help option to view selected information about Fabric Manager features. 

Using Help
To use Help:

1. Choose Help > Help. The Help dialog box displays, as shown in Figure 35.

Figure 35:  Sample Help dialog box of the Help menu
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2. Choose a folder from the navigation tree in the left column. Information 
displays in the right-hand dialog box.

3. Open a folder and choose a file to view sub-topics.
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Context Sensitive Help
Use the Context Help option to view context-sensitive information about Fabric 
Manager features. 

Using Context Sensitive Help
To use Context Sensitive Help:

1. Click Context Sensitive Help. A question mark displays on screen.

2. Use your mouse to click on an object of interest on screen. A Help dialog box 
displays, as shown in Figure 36.
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Figure 36:  Sample Context Sensitive Help dialog box
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Status Legend
The Status Legend defines the meaning of colors visible in the background of the 
switch icons. Each color indicates a different operational state:

■ Blue—Unknown

■ Green—Healthy

■ Yellow—Marginal (mix of good and faulty readings)

■ Red—Down (more than two faulty readings)

■ Gray—Unmonitored

— If the status of the switch is Unmonitored, the status does not change 
during that Fabric Manager session.

If no data is available from a switch, the most recent background color remains 
displayed.

Note:  For all statuses that are based on errors per time interval, any errors cause the 
status to show faulty until the entire sample interval has passed.

The Status Legend is shown in Figure 37.

Figure 37:  Status Legend

Using the Status Legend
A sample of an individual switch icon is shown in Figure 38.
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Figure 38:  Individual switch

The background color of the switch indicates that the status of the switch is down. 
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9Tool Bar

This chapter provides information regarding options that are available through the 
Tool Bar of the Fabric View. The following icons and dialog boxes are available 
through the Fabric Manager Tool Bar:

■ Address Dialog Box on page 120

■ Fabric Login Icon on page 121

■ Open FM Log on page 124

■ Print Table Icon on page 126

■ Download Firmware Icon on page 127

■ Sequenced Reboot Icon on page 130

■ Context Sensitive Help Icon on page 132

■ Help on page 134

The Tool Bar is shown in Figure 39.

Figure 39:  Tool Bar in Fabric view



Tool Bar

120 Fabric Manager Version 3.0.x User Guide

Address Dialog Box
Use the Address dialog box to enter the IP address, name, or WWN of the switch 
that you want to manage or monitor. Once the switch information has been 
entered, the address can be chosen automatically from the drop-down list. The 
Address dialog box is available through the Fabric View. For more information, 
see “Accessing Fabric Manager View” on page 42. 

The Address dialog box is shown in Figure 40.

Figure 40:  Address dialog box in Fabric view
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Fabric Login Icon
Use the Fabric Login icon to access the Fabric Login dialog box, which allows 
you to choose a group of switches to log in to. The Fabric Login icon is available 
through the Fabric View. For more information, see “Accessing Fabric Manager 
View” on page 42.

The Login Setup dialog box is shown in Figure 41.

Figure 41:  Fabric Login icon

When the Fabric Login Setup icon is selected, the Login Setup dialog box 
displays. 

Login Setup Dialog Box
Use the Login Setup dialog box to choose a group of switches to log in to 
simultaneously. The Login Setup dialog box is shown in Figure 42.



Tool Bar

122 Fabric Manager Version 3.0.x User Guide

Figure 42:  Login Setup dialog box 
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Logging into Multiple Switches
To log in to multiple switches simultaneously:

1. Launch the Login Setup dialog box through one of the following options:

■ Click Multiple Switches Login Setup, as shown in Figure 41.

■ Click Login Setup from the Firmware Download dialog box, as shown 
in Figure 47.

■ Click Login Setup from the Sequenced Reboot dialog box, as shown in 
Figure 49.

2. Highlight switches or groups of switches to be selected. Use mouse clicks in 
combination with Shift/Control to highlight multiple switches.

3. Click Add/Delete arrows in the middle column to choose the switches. The 
selected switches are applied in a table with all their details. 

4. Enter the User Name and Password that apply to the switches you selected.

5. Click Test and Apply to check your login and apply the login.
or
Click Apply to login to the selected switches.
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Open FM Log
Use the FM Log icon to view events occurring within the fabric. 

The FM Log icon is shown in Figure 43.

Figure 43:  Open FM Log icon

Fabric Manager Log Dialog Box
The Fabric Manager Log dialog box is shown in Figure 44.
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Figure 44:  FM Log dialog box
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Print Table Icon
Use the Print Table Icon to print table reports for review. The Print Table Icon is 
available through the Fabric View. 

The Print Table icon is shown in Figure 45.

Figure 45:  Print Table icon
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Download Firmware Icon
Use the Download Firmware icon to access the Download Firmware dialog box, 
and choose multiple switches to be upgraded simultaneously. The Download 
Firmware Icon is available through the Fabric View.

The Download Firmware Icon is shown in Figure 46.

Figure 46:  Download Firmware icon

Download Firmware Dialog Box
Use the Download Firmware dialog box to upgrade the firmware of multiple 
switches simultaneously. The Download Firmware dialog box is shown in 
Figure 47.
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Figure 47:  Download Firmware dialog box 
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Downloading Firmware to Multiple Switches
Use the Download Firmware dialog box to upgrade the firmware to multiple 
switches:

1. Click Download Firmware, as discussed in “Open FM Log” on page 124.

2. Highlight switches or groups of switches to be selected for firmware upgrade. 
Use mouse clicks in combination with Shift/Control to highlight multiple 
switches.

3. Click Add/Delete arrows in the middle column to choose the switches or drag 
and drop from the navigation dialog box to the table.

The selected switches are applied in a table with all their details. 

4. Enter the Host Name or Host IP address.

5. Enter the Remote User Name.

6. Use Browse to choose a firmware file from the local host, or if the firmware is 
located on the remote host, then type the full path to the firmware on the 
remote host.

7. Click download protocol (RSHD or FTP).

Note:  If FTP is the chosen protocol, enter FTP password.

8. Click Download to begin firmware download. 
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Sequenced Reboot Icon
The Sequenced Reboot icon is shown in Figure 48.

Figure 48:  Sequenced Reboot icon

Sequenced Reboot Dialog Box
Use the Sequenced Reboot dialog box to configure switches to reboot in a 
specified order. This prevents unexpected lapses in fabric availability. The 
Sequenced Reboot dialog box is shown in Figure 49. 

Rebooting Switches
To reboot switches without creating a Reboot Group:

1. Choose Tools > Reboot.

2. Click Sequence Reboot. The Sequence Reboot dialog box displays, as 
shown in Figure 49.
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Figure 49:  Sequenced Reboot dialog box

3. Choose the switches to be rebooted from the navigation tree. Move switches 
to the right-hand table by using the right-arrow, or by dragging and dropping. 
Use Shift/Click to choose multiple switches.

4. Click Fastboot to reboot selected switches without performing a POST test.
or
Click Reboot to reboot selected switches with POST test. 
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Context Sensitive Help Icon
Use the Context Sensitive Help icon to access help on the Fabric Manager screen. 
The Context Sensitive Help icon is shown in Figure 50.

Figure 50:  Context Sensitive Help icon

Using Context Sensitive Help
To use Context Sensitive Help:

1. Click Context Sensitive Help. A question mark displays on screen.

2. Use your mouse to click on an object of interest on screen. A dialog box 
displays, as shown in Figure 51.
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Figure 51:  Sample Context Sensitive Help dialog box
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Help
Use the Help icon to view the following areas:

■ Help

■ Context Help

■ Status Legend 

■ About

The Help icon is shown in Figure 52.
 

Figure 52:  Help icon 
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10 Switch View

This chapter briefly describes the options and interfaces available through the 
Switch View, which consist of the following:

■ Port icons on page 137

■ Status on page 138

■ Events on page 138

■ Fabric Watch on page 138

■ Fan on page 138

■ Admin on page 138

■ Telnet on page 138

■ Performance Monitor on page 138

■ Beacon on page 139

■ Temp on page 139

■ Info on page 139

Note:  The options available in the Switch View vary depending on the version of Web 
Tools that is installed on the individual switch. 
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Web Tools
When using the Switch View, you are actually accessing Web Tools.

Note:  For more information on Web Tools, refer to the appropriate version of the HP 
StorageWorks Web Tools Version 3.0.x/4.0.x User Guide.

Access
To access Web Tools:

1. Click Fabric Manager. The Switch View displays as part of the main Fabric 
View. 

2. Click an individual switch. Web Tools launches and the Switch View 
displays, as shown in Figure 53.

Capabilities
The Switch View, or Web Tools, provides a graphical interface that allows the 
administrator to monitor individual switches and ports from a standard 
workstation. The Switch View displays as shown in Figure 53.
.

Figure 53:  Switch view

Table 13 lists the options available in the Switch View:
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Table 13:  Available Options on the Switch View

Option Description

Port icons The letters in the Port icon indicate the SFP (Small 
Form Factor Pluggable) type, as follows:

blank—No SFP present
SW—Short wave SFP
LW—Long wave SFP
CU—Copper SFP
SWID—Short wave serial ID SFP
LWID—Long wave serial ID SFP
CUID—Copper serial ID SFP

A yellow outline around a port icon indicates port 
failure. For detailed port information, click the Port 
icon to see the Port Information View.

Port numbers 
(on the top of each port)

The number of the port.

LED Status Indicators
(round light next to each 
port)

The color indicates the status of the port:
No light—No device attached.
Steady yellow—Receiving light, but not online; 
check cable connections.
Slowly flashing yellow—Disabled (diagnostics or 
portDisable command).
Rapidly flashing yellow—Error, fault with port.
Steady green—Online (connected with device by 
cable).
Slowly flashing green—Online but segmented 
(loopback cable or incompatible switch).
Rapidly flashing green—Internal loopback 
(diagnostic)
Flickering green—Online and transmitting/ 
receiving frames.

Power supply a. Removable power assemblies are updated to 
show presence/absence and status of each:

a. Green—Power supply present and 
operational.

a. Red X—Power supply present but not 
operational.

a. Cover plate—Power supply absent or not 
fully plugged in.
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Status Click to view the switch’s health status. 

Events Click to access Switch Events View.

Telnet Click to launch a Telnet session.

Fabric Watch

(optional software)

Click to access Fabric Watch, if a license is installed.

Fan The background color of the button indicates the 
overall status of the fans: 

Green—Healthy
Yellow—Marginal (mix of good and faulty 
readings)
Red—Down (more than two faulty readings)
Gray—Unknown or unmonitored

Admin Click to display the Administrative Interface where 
you can perform switch management functions.

Performance Monitor Click to display the Performance Monitor where you 
can monitor switch performance.

Table 13:  Available Options on the Switch View (Continued)
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Note:  For more information on Web Tools, refer to the appropriate version of the HP 
StorageWorks Web Tools Version 3.0.x/4.0.x User Guide.

Beacon Click to turn on the beaconing function. If on, this icon 
shows beams of light. The beaconing function helps to 
physically locate a switch by sending a signal to the 
specified switch, resulting in an LED light pattern 
flashing from side to side on the switch.

Temp Click to display temperature readings from all switch 
thermal sensors. The background color of the button 
indicates the overall temperature status: 

Green—Healthy
Yellow—Marginal (mix of good and faulty 
readings)
Red—Down (more than two faulty readings)
Gray—Unknown or unmonitored

Info Click to display the switch information.

Table 13:  Available Options on the Switch View (Continued)
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11Administrative Task Examples

This chapter provides examples of the following administrative tasks that can be 
performed:

■ Create a Logical Group on page 142

■ Share a Group with Another Host on page 143

■ Filter a Fabric on page 144

■ Share a Group with Another Host on page 143

■ Save a Baseline Configuration on page 145

■ Download and Apply a Baseline Configuration on page 146

■ Validate Merging of Two Fabrics on page 148

■ Monitor ISLs on page 149

■ Create a Reboot Group on page 150

■ Set up a Sequenced Reboot on page 151
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Create a Logical Group 
To create a group of controllable SAN objects:

1. Choose File > Group > Create. The Create Group dialog box displays.

2. Highlight the word Groups (that you want to create a new group in) from the 
navigation tree. 

3. Click Create from the bottom of the navigation tree dialog box. The Create 
Groups dialog box displays.

4. Type in a name for the group and press OK. The name of your group displays 
in the navigation tree.

5. Highlight the name of your group from the navigation tree by clicking on it. 

6. Choose switches from the left navigation tree to be added to the Group. To 
choose multiple switches, use Shift/Click.

7. Add selected switches to your group by clicking on the right-arrow button, or 
by dragging and dropping selections from the navigation tree to the Group. 
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Share a Group with Another Host
To share a logical group with another host:

1. Choose File > Groups.

2. Click Export.

3. Use Browse to choose a file to Export a Group to. 

4. Type a name for your group file. 

5. Highlight the name of the group(s) to be exported from the navigation tree. 

6. Add the group to be exported by clicking on the arrow button, or by dragging 
and dropping selections from the navigation tree to the table. 

7. Click OK.

8. Go to a host on a separate machine.

9. Choose File > Groups.

10. Click Import.

11. Browse to choose the file you previously exported to.
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Filter a Fabric 
To filter a fabric, using specific parameters:

1. Click Filter tab from the SAN Elements Panel.

2. Choose the filter parameters from the drop-down list.

3. Type in the IP address, Name, or other search parameter in the dialog box 
beside the drop-down list.

4. Press the Enter key. Any switches that match the criteria are displayed in the 
panel below the text box.
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Save a Baseline Configuration
To create a baseline configuration:

1. Choose Tools > Config. 

2. Click Save Baseline.

3. Choose a template as a base for your configuration or browse to choose an 
XML template file. 

4. Click Next. The Pick a Baseline Target Switch dialog box displays.

5. Highlight a switch to use as a baseline configuration from the navigation tree.

Note:  You must highlight one switch only, not a fabric. 

6. Choose the highlighted switch by clicking on the left-arrow button, or by 
dragging and dropping selections from the navigation tree to the table. 

7. Click Login and log in to the switch (if you have not previously done so).

8. Set up File Transfer properties if you have not previously done so. The Base 
Configuration dialog box displays.

Note:  You can set up File Transfer properties anytime by selecting File > Options and 
selecting the File Transfer tab.

9. Check the configuration properties that you would like to save to your 
template from the Base Configuration dialog box.

10. Click Save. The Save Base dialog box displays.

11. Enter a file name for your configuration template.

It is recommended that you name your file so that you can easily recognize 
selected configuration parameters. Example: 

SNMP_Baseline.txt

12. Click Save.
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Download and Apply a Baseline Configuration
A baseline configuration can be downloaded from a file or switch.

Download and Apply a Baseline Configuration from a File
To download and apply a baseline configuration from a switch:

1. Create a Reboot Group if you intend to apply a Baseline Configuration to an 
entire fabric. This is an optional step, however, it is recommended to maintain 
the stability of a fabric. 

2. Choose Tools > Config. 

3. Click Compare/Download from File.

4. Browse to choose a baseline configuration file and click Open. The Target 
Switches dialog box displays.

5. Highlight switches that you want to compare to the baseline configuration 
from the navigation tree.

6. Choose the highlighted switch by clicking on the left-arrow button, or by 
dragging and dropping selections from the navigation tree to the table. 

7. Click Login and log in to the switch (if you have not previously done so).

8. Set up File Transfer properties, if you are prompted to do so. 

Note:  You can set up File Transfer properties anytime by selecting File > Options and 
selecting the File Transfer tab.

9. Click OK. The Configure Compare/Download dialog box displays.

10. Click Apply to apply baseline configuration to switches.
or
Click Print a Report to print a report of switch configuration comparisons.

Download and Apply Baseline Configuration from a Switch
To download and apply a baseline configuration from a switch:

1. Create a Reboot Group if you intend to apply a Baseline Configuration to an 
entire fabric. This is an optional step, however, it is recommended to maintain 
the stability of a fabric as switches are rebooted. 
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2. Choose Tools > Config.

3. Click Compare/Download from Switch.

4. Highlight a switch from the navigation tree to use as a baseline configuration.

Note:  You must choose one switch only, not a whole fabric. 

5. Highlight switches that you want to compare to the baseline configuration 
from the navigation tree.

6. Choose the highlighted switch by clicking on the left-arrow button, or by 
dragging and dropping selections from the navigation tree to the table. 

7. Click Login and log in to the switch (if you have not previously done so).

8. Set up File Transfer properties, if you are prompted to do so. 

Note:  You can set up File Transfer properties anytime by selecting File > Options and 
selecting the File Transfer tab.

9. Click OK. The Configure Compare/Download dialog box displays.

10. Click Apply to apply baseline configuration to switches.
or
Click Print a Report to print a report of switch configuration comparisons.



Administrative Task Examples

148 Fabric Manager Version 3.0.x User Guide

Validate Merging of Two Fabrics
To validate the merging of two fabrics:

1. Choose File > Options.

2. Click File Transfer tab.

3. Click Tools > Fabric Merge.

4. Choose two fabrics to be merge-tested by using the drop-down lists.

5. Click Check at the bottom of the dialog box. The Login Setup dialog box 
displays, if you have not already logged into the switch. Enter the User Name 
and Password at the top of the dialog box. 

6. Highlight switches from the right-hand table to be tested. To choose multiple 
switches, use Shift/Click.

7. Add selected switches to be tested by clicking on the right-arrow button, or by 
dragging and dropping selections from the table to the navigation tree.

8. Click Test. Check the status of your test in the Status column of the table. 
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Monitor ISLs
To monitor ISLs and Fabric Configurations:

1. Choose File > Options. The Options dialog box displays with three tab 
choices. 

2. Click ISL Status tab.

3. Choose the status parameters to be propagated in the Fabric Events.

4. Click OK.

5. Choose Actions > ISL > ISL Checking to turn on ISL checking. A 
checkmark displays, showing that ISL checking is active. 

6. Choose Actions > Restamp any time you want to restamp the fabric topology.

Note:  There is a ten second time spacing in stamping. When ISL checking is turned on, 
the stamp is set to the results of the last poll, which is at most ten seconds behind. 

7. Choose Actions > Events to view changes to fabric topology. 
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Create a Reboot Group
To create a reboot group:

1. Choose Tools > Reboot.

2. Click Create Reboot Sequence. The Create or Change Reboot Groups 
dialog box displays.

3. Choose a fabric from the drop-down list at the top of the dialog box.

4. Click Create from the bottom of the navigation tree. The Create Reboot 
Group dialog box displays.

5. Type in a name for the reboot group.

6. Enter Fabric Stabilization time-out information and choose the action to take 
if time-out occurs.

7. Enter delay time after stabilization.

8. Enter Fabric Stabilization information and press OK. The name of your group 
displays in the navigation tree.

9. Click OK.

10. Choose switches from the table to be added to the reboot group. Use 
shift/click to choose multiple switches.

11. Click the left arrow, or use drag and drop to move switches from the table to 
the reboot group. 

Note:  Delete switches or reboot groups by pressing the delete button; this moves the 
related switches to the table of unassigned switches. 

Two reboot groups can be merged by dragging one group and dropping it on 
another group.

The switch reboot sequence can be changed by selecting one or more groups 
and pressing the up/down arrow button to move the selected groups up/down 
in the order of reboot.

12. Click Apply or OK to save reboot group. The Sequenced Reboot dialog box 
displays. For instructions on proceeding with reboot, see “Set up a Sequenced 
Reboot” on page 151.
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Set up a Sequenced Reboot
To set up a sequenced reboot:

1. Choose Tools > Reboot > Sequence Reboot. The Sequenced Reboot dialog 
box displays.

2. Choose a fabric from the drop-down list at the top of the dialog box.

3. Highlight the name of your group from the navigation tree by clicking on it. 

4. Choose switches from the right-hand table to be added to the reboot group.

5. Click Login Setup (if you have not previously logged into the switches).

6. Click OK to proceed when the confirmation dialog box displays.

7. Click Reboot to administer sequenced reboot. 

8. Login to switch if you are prompted.

9. Press Abort to abort the sequenced reboot at any time. If you have set up a 
delay on the reboot group, a delay timer displays. Press Play-Pause-Skip on 
the delay timer at runtime. 

10. View message at the end of sequenced reboot. A message displays the success 
or failure of the operation.



Administrative Task Examples

152 Fabric Manager Version 3.0.x User Guide



153Fabric Manager Version 3.0.x User Guide

glossary

Glossary
Glossary

This glossary defines terms used in this guide or related to this product and is not 
a comprehensive glossary of computer terms.

16-port card
The Fibre Channel port card provided with the StorageWorks Core switch. Contains 16 Fibre 
Channel ports and the corresponding LEDs indicating port status and speed. 

See also port card.

8b/10b Encoding
An encoding scheme that converts each 8-bit byte into 10 bits. Used to balance ones and zeros 
in high-speed transports.

Access Control List
Enables an organization to bind a specific WWN to a specific switch port or set of ports, 
preventing a port in another physical location from assuming the identity of a real WWN. May 
also refer to a list of the Read/Write access of a particular community string. 

See also device connection controls. 

Account Level Switches
Refers to switches that have four login accounts into the operating system (in descending 
order): root, factory, admin, and user. 

See also root account, factory account, admin account, and user account.

Address Identifier
A 24-bit or 8-bit value used to identify the source or destination of a frame.

Admin Account
A login account intended for use by the customer to control switch operation.

See also account level switches.

AL_PA
Arbitrated Loop Physical Address. A unique 8-bit value assigned during loop initialization to a 
port in an arbitrated loop.
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Alias
An alternate name for an element or group of elements in the fabric. Aliases can be used to 
simplify the entry of port numbers and WWNs when creating zones.

Alias Address Identifier
An address identifier recognized by a port in addition to its standard identifier. An alias 
address identifier may be shared by multiple ports. 

See also alias.

Alias AL_PA
An AL_PA value recognized by an L_Port in addition to the AL_PA assigned to the port. 

See also AL_PA.

Alias Server
A fabric software facility that supports multicast group management.

ANSI
American National Standards Institute. The governing body for Fibre Channel standards in the 
U.S.A.

API
Application Programming Interface. Defined protocol that allows applications to interface 
with a set of services.

Arbitrated Loop
A shared 100 or 200 MBps Fibre Channel transport structured as a loop. Can support up to 126 
devices and one fabric attachment. 

See also topology.

Arbitrating State
The state in which a port has become the loop master. This state is only available from the 
Open state.

Area Number
A number assigned to each potential port location in the StorageWorks Core switch. Used to 
distinguish StorageWorks Core switch ports that have the same port number but are on 
different port Blades.

ASIC
Application Specific Integrated Circuit.
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ATM
Asynchronous Transfer Mode. A transport used for transmitting data over LANs or WANs that 
transmit fixed-length units of data. Provides any-to-any connectivity, and allows nodes to 
transmit simultaneously.

Auto-negotiate Speed
Process that allows two devices at either end of a link segment to negotiate common features, 
speed (e.g., 1 or 2 Gbps) and functions.

Autosense
Process during which a network device automatically senses the speed of another device.

AW_TOV
Arbitration Wait Time-out Value. The minimum time an arbitrating L_Port waits for a 
response before beginning loop initialization.

Backup FCS Switch
Backup fabric configuration server switch. The switch or switches assigned as backup in case 
the primary FCS switch fails. 

See also FCS switch, primary FCS switch.

Bandwidth
The total transmission capacity of a cable, link, or system. Usually measured in bps (bits per 
second). May also refer to the range of transmission frequencies available to a network. 

See also throughput.

BB_Credit
Buffer-to-buffer credit. The number of frames that can be transmitted to a directly connected 
recipient or within an arbitrated loop. Determined by the number of receive buffers available. 

See also Buffer-to-buffer Flow Control, EE_Credit.

Beacon
When all the port LEDs on a switch are set to flash from one side of the switch to the other, to 
enable identification of an individual switch in a large fabric. A switch can be set to beacon by 
telnet command or through Web Tools.

Beaconing
The state of the switches LEDs when the switch is set to Beacon. 

See also Beacon.
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Beginning Running Disparity
The disparity at the transmitter or receiver when the special character associated with an 
ordered set is encoded or decoded. 

See also disparity.

BER
Bit Error Rate. The rate at which bits are expected to be received in error. Expressed as the 
ratio of error bits to total bits transmitted. 

See also error.

Bit Synchronization
See BER.

Blade
See 16-port card.

Blind-mate Connector
A two-way connector used in some switches to provide a connection between the motherboard 
and the power supply.

Block
As applies to Fibre Channel, upper-level application data that is transferred in a single 
sequence.

Blower Assembly
A fan that prevents a switch (or individual elements within a switch) from overheating.

Boot Flash
Flash memory that stores the boot code and boot parameters. The processor executes its first 
instructions from boot flash. Data is cached in RAM.

Boot Monitor
Code used to initialize the CP (control processor) environment after powering on. Identifies 
the amount of memory available and how to access it, and retrieves information about system 
buses.

Broadcast
The transmission of data from a single source to all devices in the fabric, regardless of zoning. 

See also multicast, unicast.
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Buffer-to-buffer Flow Control
Management of the frame transmission rate in either a point-to-point topology or in an 
arbitrated loop. 

See also BB_Credit.

Cascade
Two or more interconnected Fibre Channel switches. StorageWorks 1 Gb SAN switches 
(running Fabric OS V2) and later can be cascaded up to 239 switches, with a recommended 
maximum of seven interswitch links (no path longer than eight switches). 

See also fabric, ISL.

Chassis
The metal frame in which the switch and switch components are mounted. 

Circuit
An established communication path between two ports. Consists of two virtual circuits 
capable of transmitting in opposite directions. 

See also link.

Class 1
Service that provides a dedicated connection between two ports (also called 
connection-oriented service), with notification of delivery or non-delivery.

Class 2
Service that provides multiplex and connectionless frame switching service between two ports, 
with notification of delivery or non-delivery. 

Class 3
Service that provides a connectionless frame switching service between two ports, without 
notification of delivery or non-delivery of data. This service can also be used to provide a 
multicast connection between the originator and recipients, with notification of delivery or 
non-delivery.

Class F
Connectionless service for control traffic between switches, with notification of delivery or 
non-delivery of data between the E_Ports.

Class of Service
A specified set of delivery characteristics and attributes for frame delivery.

CLI
Command line interface. Interface that depends entirely on the use of commands, such as 
through telnet or SNMP, and does not involve a Graphic User Interface (GUI).
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CLS
Close Primitive Signal. Only in an Arbitrated Loop; sent by an L_Port that is currently 
communicating on the loop, to close communication to an other L_Port.

Comma
A unique pattern (either 1100000 or 0011111) used in 8b/10b encoding to specify character 
alignment within a data stream. 

See also K28.5.

Community (SNMP)
A relationship between a group of SNMP managers and an SNMP agent, in which 
authentication, access control, and proxy characteristics are defined. 

See also SNMP.

Compact Flash
Flash memory that stores the run-time operating system and is used like hard disk storage. Not 
visible within the processor's memory space. Data is stored in file system format.

Configuration
How a system is set up. May refer to hardware or software.

■ Hardware: The number, type, and arrangement of components that make up a system or 
network. 

■ Software: The set of parameters that guide switch operation. May include general system 
parameters, IP address information, domain ID, and other information. Modifiable by any 
login with administrative privileges. 

May also refer to a set of zones. 

See also zone configuration.

Connection Initiator
A port that has originated a Class 1 dedicated connection and received a response from the 
recipient.

Connection Recipient
A port that has received a Class 1 dedicated connection request and transmitted a response to 
the originator.

Control Panel
Refers to the left-side panel of Web Tools, which accesses fabric-wide functions such as 
Zoning and Events.
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Core Switch
A switch whose main task is to interconnect other switches. 

See also SAN switch.

CP Card
Control Processor Card. The central processing unit of the StorageWorks Core switch, which 
contains two CP Card slots to provide redundancy. Provides Ethernet, serial, and modem ports 
with the corresponding LEDs.

CRC
Cyclic Redundancy Check. A check for transmission errors included in every data frame.

Credit
As applies to Fibre Channel, the number of receive buffers available for transmission of frames 
between ports. 

See also BB_Credit, EE_Credit.

CT_HDR
Common Transport Header. A header that conforms to the Fibre Channel Common Transport 
(FC_CT) protocol.

CT_IU
Common Transport Information Unit. An information unit that conforms to the Fibre Channel 
Common Transport (FC_CT) protocol.

Current Fill Word
The fill word currently selected by the LPSM. 

See also fill word, LPSM.

Cut-through
A switching technique that allows the route for a frame to be selected as soon as the 
destination address is received. 

See also route.

Data Word
Type of transmission word that occurs within frames. The frame header, data field, and CRC 
all consist of data words. 

See also frame, ordered set, transmission word.
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DB-9 connector
A 9-pin version of the RS-232C port interface. May be either the male of female interface. 

See also RS-232 port.

dBm
Logarithmic unit of power used in electronics. Indicates signal strength in decibels above the 
reference level, which is 1 milliwatt for dBm. An increase of 10 dBm or represents a 10-fold 
increase in power.

DCE port
A data communications equipment port capable of interfacing between a DTE (data terminal 
equipment) port and a transmission circuit. DTE devices with an RS-232 (or EIA-232) port 
interface transmit on pin 3, and receive on pin 2. 

See also DTE port, RS-232 port.

Defined Zone Configuration
The set of all zone objects defined in the fabric. May include multiple zone configurations. 

See also enabled zone configuration, zone configuration.

Device Connection Controls
Enables organizations to bind an individual device port to a set of one or more switch ports. 
Device ports are specified by a WWN and typically represent HBAs (servers). 

See also access control lists.

Device
A disk, a RAID, or an HBA.

Disparity
The relationship of ones and zeros in an encoded character. “Neutral disparity” means an equal 
number of each, “positive disparity” means a majority of ones, and “negative disparity” means 
a majority of zeros.

DLS
Dynamic Load Sharing. Dynamic distribution of traffic over available paths. Allows for 
recomputing of routes when an Fx_Port or E_Port changes status.

Domain ID
As applies to HP StorageWorks switches, a unique number between 1 and 239 that identifies 
the switch to the fabric and is used in routing frames. Usually automatically assigned by the 
switch, but can be manually assigned.
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DTE port
A data terminal equipment port capable of interfacing to a transmission circuit through a 
connection to a DCE (data communications equipment) port. DTE devices with an RS-232 (or 
EIA-232) port interface transmit on pin 3, and receive on pin 2 in a 9-pin connector (reversed 
in 25-pin connectors). 

See also DCE port, RS-232 port.

DWDM
Dense Wavelength Multiplexing. A means to concurrently transmit more than one stream of 
data through a single fiber by modulating each stream of data onto a different wavelength of 
light.

E_D_TOV
Error Detect Time-out Value. The minimum amount of time a target waits for a sequence to 
complete before initiating recovery. Can also be defined as the maximum time allowed for a 
round-trip transmission before an error condition is declared. 

See also R_A_TOV, RR_TOV.

E_Port
Expansion Port. A type of switch port that can be connected to an E_Port on another switch to 
create an ISL. 

See also ISL.

EE_Credit
End-to-end Credit. The number of receive buffers allocated by a recipient port to an 
originating port. Used by Class 1 and 2 services to manage the exchange of frames across the 
fabric between source and destination. 

See also End-to-end Flow Control, BB_Credit.

EIA Rack
A storage rack that meets the standards set by the Electronics Industry Association.

ELWL
Extra Long Wave Length. Laser light with a periodic length greater than 1300 nm (e.g., 1420 
or 1550). ELWL lasers are used to transmit Fibre Channel data over distances greater than 10 
km. 

Also known as XLWL.

Enabled Zone Configuration
The currently enabled zone configuration. Only one configuration can be enabled at a time. 

See also defined zone configuration, zone configuration.
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End-to-end Flow Control
Governs flow of class 1 and 2 frames between N_Ports. 

See also EE_Credit.

Entry Fabric
Basic HP license that allows one E_Port per switch. Not supported by StorageWorks Core 
switches.

Error
As applies to Fibre Channel, a missing or corrupted frame, time-out, loss of synchronization, 
or loss of signal (link errors). 

See also loop failure.

ESD
Electrostatic Discharge.

Exchange
The highest level Fibre Channel mechanism used for communication between N_Ports. 
Composed of one or more related sequences, and can work in either one or both directions.

Extended Fabric
An HP product that runs on Fabric OS and allows creation of a Fibre Channel fabric 
interconnected over distances of up to 100 kilometers.

Extended Fabric is a means of allowing the implementation and management of SANs over 
extended distances. This is achieved by adjusting the Buffer-to-Buffer Credits to guaranteed 
allocation of buffers to specific ports.

F_Port
Fabric Port. A port that is able to transmit under fabric protocol and interface over links. Can 
be used to connect an N_Port to a switch. 

See also FL_Port, Fx_Port.

Fabric
A Fibre Channel network containing two or more interconnected switches in addition to hosts 
and devices. May also be referred to as a switched fabric. 

See also topology, SAN, cascade.
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Fabric Access
An HP product that consists of a set of APIs that allow third party applications to interface 
with Fabric OS. 

Fabric Access allows the application to control the fabric directly for functions such as 
discovery, access (zoning), management, performance, and switch control. Consists of a 
host-based library that interfaces the application to switches in the fabric over an out-of-band 
TCP/IP connection or in-band using an IP-capable Host Bus Adapter (HBA).

Fabric Assist
An HP feature that enables private and public hosts to access public targets anywhere on the 
fabric, provided they are in the same Fabric Assist zone. This feature is available only when 
both QuickLoop and Zoning are installed on the switch. 

Fabric Assist is a means of allowing private hosts to communicate with public targets across a 
switched fabric. Fabric Assist also allows private hosts to communicate with private targets 
that are not resident on the same switch across a switched fabric. 

See also QuickLoop.

Fabric Configuration Server
One or more designated HP switches that store and manage the configuration parameters for 
all other switches in the fabric. These switches are designated by WWN, and the list of 
designated switches is known fabric-wide.

Fabric Manager
An HP product that works in conjunction with Web Tools to provide a graphical user interface 
for managing switch groups (such as the SAN Switch Integrated/32) as a single unit, instead of 
as separate switches. Fabric Manager is installed on and run from a computer workstation. 

Fabric Name
The unique identifier assigned to a fabric and communicated during login and port discovery.

Fabric OS
The proprietary operating system on HP StorageWorks switches.
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Fabric Watch
An HP product that runs on Fabric OS and allows monitoring and configuration of fabric and 
switch elements. 

Allows the SAN manager to monitor key fabric and switch elements, making it easy to quickly 
identify and escalate potential problems. It monitors each element for out-of-boundary values 
or counters and provides notification when defined boundaries are exceeded. The SAN 
manager can configure which elements, such as error, status, and performance counters, are 
monitored within an HP switch. 

See also Fabric Manager.

Factory Account
A login used during manufacturing to initialize and test a switch and is not intended for 
customer use. 

See also account level switches.

Failover
The act that causes control to pass from one redundant unit to another. In the StorageWorks 
Core switch one may failover from the currently Active Control Processor (CP) to the Standby 
CP. 

FAN
Fabric access notification. Retains the AL_PA and fabric address when loop re-initializes (if 
the switch supports FAN).

FC-AL-3
The Fibre Channel Arbitrated Loop standard defined by ANSI. Defined on top of the FC-PH 
standards.

FC-FLA
The Fibre Channel Fabric Loop Attach standard defined by ANSI.

FCIA
Fibre Channel Industry Association. An international organization of Fibre Channel industry 
professionals. Among other things, provides oversight of ANSI and industry developed 
standards.

FCP
Fibre Channel Protocol. Mapping of protocols onto the Fibre Channel standard protocols. For 
example, SCSI FCP maps SCSI-3 onto Fibre Channel.

FC-PH-1, 2, 3
The Fibre Channel Physical and Signaling Interface standards defined by ANSI.
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FC-PI
The Fibre Channel Physical Interface standard defined by ANSI.

FC-PLDA
The Fibre Channel Private Loop Direct Attach standard defined by ANSI. Applies to the 
operation of peripheral devices on a private loop.

FCS switch
Fabric configuration server switch. One or more designated HP switches that store and manage 
the configuration parameters for all switches in the fabric. FCS switches are designated by 
WWN, and the list of designated switches is communicated fabric-wide. 

See also backup FCS switch, primary FCS switch.

FC-SW-2
The second generation of the Fibre Channel Switch Fabric standard defined by ANSI. 
Specifies tools and algorithms for the interconnection and initialization of Fibre Channel 
switches in order to create a multi-switch Fibre Channel fabric. 

Fibre Channel Transport
A protocol service that supports communication between Fibre Channel service providers. 

See also FSP.

FIFO
First In, First Out. May also refer to a data buffer that follows the first in, first out rule.

Fill Word
An IDLE or ARB ordered set that is transmitted during breaks between data frames to keep the 
Fibre Channel link active. 

Firmware Download
Loading firmware down from a server into a switch.

Firmware
The basic operating system provided with the hardware.

FL_Port
Fabric Loop Port. A port that is able to transmit under fabric protocol and also has arbitrated 
loop capabilities. Can be used to connect an NL_Port to a switch. 

See also F_Port, Fx_Port.

Flash Partition
Two redundant usable areas, called “partitions,” into which firmware can be downloaded in the 
StorageWorks Core switch.
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Flash
Programmable NVRAM memory that maintains its contents.

FLOGI
Fabric Login. The process by which an N_Port determines whether a fabric is present, and if 
so, exchanges service parameters with it. 

See also PLOGI.

Frame
The Fibre Channel structure used to transmit data between ports. Consists of a start-of-frame 
delimiter, header, any optional headers, the data payload, a cyclic redundancy check (CRC), 
and an end-of-frame delimiter. There are two types of frames: Link control frames 
(transmission acknowledgements, etc.) and data frames. 

See also Data Word.

FRU
Field Replaceable Unit. A component that can be replaced on site.

FS_ACC
Fibre Channel Services Accept. The information unit used to indicate acceptance of a request 
for a Fibre Channel service.

FS_IU
Fibre Channel Services Information Unit. An information unit that has been defined by a Fibre 
Channel service.

FS_REQ
Fibre Channel Services Request. A request for a Fibre Channel services function, or 
notification of a fabric condition or event.

FS_RJT
Fibre Channel Services Reject. An indication that a request for Fibre Channel services could 
not be processed.

FS
Fibre Channel Service. A service that is defined by Fibre Channel standards and exists at a 
well-known address. For example, the Simple Name Server is a Fibre Channel service. 

See also FSP.

FSPF
Fabric Shortest Path First. HP routing protocol for Fibre Channel switches.
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FSP
Fibre Channel Service Protocol. The common protocol for all fabric services, transparent to 
the fabric type or topology. 

See also FS.

Full Fabric
The HP license that allows multiple E_Ports on a switch, making it possible to create multiple 
ISL links.

Full-duplex
A mode of communication that allows the same port to simultaneously transmit and receive 
frames. 

See also half-duplex.

Fx_Port
A fabric port that can operate as either an F_Port or FL_Port. 

See also F_Port, FL_Port.

G_Port
Generic Port. A port that can operate as either an E_Port or F_Port. A port is defined as a 
G_Port when it is not yet connected or has not yet assumed a specific function in the fabric.

Gateway
Hardware that connects incompatible networks by providing translation for both hardware and 
software. For example, an ATM gateway can be used to connect a Fibre Channel link to an 
ATM connection.

GBIC
Gigabit interface converter. A removable serial transceiver module that allows gigabaud 
physical-level transport for Fibre Channel and gigabit Ethernet. Typically refers only to the 
SC-form factor transceivers. 

See also SFP.

Gbps
Gigabits per second (1,062,500,000 bits/second).

GBps
Gigabytes per second (1,062,500,000 bytes/second).
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Half-duplex
A mode of communication that allows a port to either transmit or receive frames at any time, 
but not simultaneously (with the exception of link control frames, which can be transmitted at 
any time). 

See also full-duplex.

Hard Address
The AL_PA that an NL_Port attempts to acquire during loop initialization.

Hardware Translative Mode
A method for achieving address translation. The following two hardware translative modes are 
available to a QuickLoop-enabled switch:

■ Standard Translative Mode: Allows public devices to communicate with private devices 
that are directly connected to the fabric.

■ QuickLoop Mode: Allows initiator devices to communicate with private or public devices 
that are not in the same loop.

HBA
Host Bus Adapter. The interface card between a server or workstation bus and the Fibre 
Channel network.

High Availability
An attribute of equipment that identifies it as being capable of conducting customer operations 
well in excess of 99% of the time. Typically High Availability is identified by the number of 
nines in that percentage. “Five Nines” means the equipment is rated as being capable of 
conducting customer operations 99.999% of the time without failure.

Host
A computer that accesses storage devices over the fabric. May also be referred to as a server. 

See also workstation. 

Hot Pluggable
A FRU capability that indicates it may be extracted or installed while customer data is 
otherwise flowing in the chassis.

Hub
A Fibre Channel wiring concentrator that collapses a loop topology into a physical star 
topology. Nodes are automatically added to the loop when active and removed when inactive.
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IBTA
The InfiniBand Trade Association (IBTA). The IBTA is an industry consortium of more than 
200 companies working together to develop a new common I/O specification designed to bring 
greater scalability and performance to server I/O. InfiniBand defines a new channel based, 
switched-fabric technology for server-to-server and server-to-I/O interconnection that is 
expected to improve scalability and performance over existing PCI Bus technologies. 

Idle
Continuous transmission of an ordered set over a Fibre Channel link when no data is being 
transmitted, to keep the link active and maintain bit, byte, and word synchronization.

InfiniBand
See IBTA.

Initiator
A server or workstation on a Fibre Channel network that initiates communications with 
storage devices. 

See also Target.

Integrated Fabric
The fabric created by a SAN Switch Integrated/32 and SAN Switch Integrated/64, consisting 
of six SAN Switch 16-EL switches cabled together and configured to handle traffic as a 
seamless group.

IOD
In-order Delivery. A parameter that, when set, guarantees that frames are either delivered in 
order or dropped.

IPA
Initial Process Associator. An identifier associated with a process at an N_Port.

Isolated E_Port
An E_Port that is online but not operational due to overlapping domain IDs or nonidentical 
parameters (such as E_D_TOVs). 

See also E_Port.

ISL
Interswitch Link. a Fibre Channel link from the E_Port of one switch to the E_Port of another. 

See also E_Port, cascade, ISL trunking.
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ISL Trunking
An HP feature that enables distribution of traffic over the combined bandwidth of up to four 
ISLs (between adjacent switches), while preserving in-order delivery. A set of trunked ISLs is 
called a trunking group; each port employed in a trunking group is called a trunking port. 

See also Master Port.

IU
Information Unit. A set of information as defined by either upper-level process protocol 
definition or upper-level protocol mapping.

JBOD
Just a Bunch Of Disks. Indicates a number of disks connected in a single chassis to one or 
more controllers. 

See also RAID.

K28.5
A special 10-bit character used to indicate the beginning of a transmission word that performs 
Fibre Channel control and signaling functions. The first seven bits of the character are the 
comma pattern. 

See also comma.

Kernel Flash
lash memory that stores the bootable kernel code and is visible within the processor's memory 
space. Data is stored as raw bits.

Key Pair
In public key cryptography, a pair of keys consisting of an entity's public and private key. The 
public key can be publicized, but the private key must be kept secret. 

L_Port
Loop Port. A node port (NL_Port) or fabric port (FL_Port) that has arbitrated loop capabilities. 
An L_Port can be in one of two modes:

■ Fabric mode: Connected to a port that is not loop capable, and using fabric protocol.

■ Loop mode: In an arbitrated loop and using loop protocol. An L_Port in loop mode can 
also be in participating mode or non-participating mode. 

See also Non-participating Mode, Participating Mode.

Latency
The period of time required to transmit a frame, from the time it is sent until it arrives. 
Together, latency and bandwidth define the speed and capacity of a link or system.
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LED
Light Emitting Diode. Used on HP switches to indicate the status of various switch elements.

Link Services
A protocol for link-related actions.

Link
As applies to Fibre Channel, a physical connection between two ports, consisting of both 
transmit and receive fibers. 

See also Circuit.

LIP
Loop Initialization Primitive. The signal used to begin initialization in a loop. Indicates either 
loop failure or resetting of a node.

LIS_HOLD_TIME
Loop Initialization Sequence Hold Time. The maximum period of time for a node to forward a 
loop initialization sequence.

LM_TOV
Loop Master Time-out Value. The minimum time that the loop master waits for a loop 
initialization sequence to return.

Login BB_Credit
The number of receive buffers a receiving L_Port has available when a circuit is first 
established. 

See also BB_Credit.

Loop Circuit
A temporary bidirectional communication path established between L_Ports.

Loop Failure
Loss of signal within a loop for any period of time, or loss of synchronization for longer than 
the time-out value. 

See also error.

Loop Initialization
The logical procedure used by an L_Port to discover its environment. Can be used to assign 
AL_PA addresses, detect loop failure, or reset a node.

Loop_ID
A hex value representing one of the 127 possible AL_PA values in an arbitrated loop. 
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Looplet
A set of devices connected in a loop to a port that is a member of another loop.

LPSM
Loop Port State Machine. The logical entity that performs arbitrated loop protocols and 
defines the behavior of L_Ports when they require access to an arbitrated loop.

LWL
Long Wavelength. A type of fiber optic cabling that is based on 1300-mm lasers and supports 
link speeds of 1.0625 Gbps. May also refer to the type of GBIC or SFP. 

See also SWL.

Master Port
As relates to trunking, the port that determines the routing paths for all traffic flowing through 
the trunking group. One of the ports in the first ISL in the trunking group is designated as the 
master port for that group. 

See also ISL Trunking.

Media
See transceiver.

MIB
Management Information Base. An SNMP structure to help with device management, 
providing configuration and device information.

Modem Serial Port 
The upper serial port on the CP Card of the StorageWorks Core switch. Can be used to connect 
the CP Card to a modem with a standard 9-pin modem cable. Consists of a DB-9 connector 
wired as a RS-232 device, and can be connected by serial cable to a DCE device. A 
Hayes-compatible modem or Hayes-emulation is required. The device name is ttyS1. 

See also DB-9 connector, DCE port, terminal serial port.

Monitoring State
The state in which a port is monitoring the flow of information for data relevant to the port.

Multicast
The transmission of data from a single source to multiple specified N_Ports (as opposed to all 
the ports on the network). 

See also broadcast, unicast.
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Multimode
A fiber optic cabling specification that allows up to 500 meters between devices for 1 Gb, or 
300 meters between devices for 2 Gb.

N_Port
Node Port. A port on a node that can connect to a Fibre Channel port or to another N_Port in a 
point-to-point connection. 

See also NL_Port, Nx_Port.

NAA
Network Address Authority. An identifier that indicates the format of a network address.

Name Server
Frequently used to indicate Simple Name Server. 

See also SNS.

Native Address Identifier
A unique, 64-bit address is assigned to each port, and is referred to as its World-Wide Name 
(WWN). If a port connects to an arbitrated loop, it will also be assigned a dynamic 8-bit 
address, referred to as its arbitrated loop physical address, or AL_PA. If it connects to a fabric, 
it will be assigned a dynamic 24-bit address, referred to as its Native Address Identifier. 

Negotiate
See auto-negotiate speed and autosense. 

NL_Port
Node Loop Port. A node port that has arbitrated loop capabilities. Used to connect an 
equipment port to the fabric in a loop configuration through an FL_Port. 

See also N_Port, Nx_Port.

Node Name
The unique identifier for a node, communicated during login and port discovery.

Node
A Fibre Channel device that contains an N_Port or NL_Port.

Non-participating Mode
A mode in which an L_Port in a loop is inactive and cannot arbitrate or send frames, but can 
retransmit any received transmissions. This mode is entered if there are more than 127 devices 
in a loop and an AL_PA cannot be acquired. 

See also L_Port, Participating Mode.
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Nx_Port
A node port that can operate as either an N_Port or NL_Port.

Open Originator
The L_Port that wins arbitration in an arbitrated loop and sends an OPN ordered set to the 
destination port, then enters the Open state.

Open Recipient
The L_Port that receives the OPN ordered set from the open originator, and then enters the 
Open state.

Open State
The state in which a port can establish a circuit with another port. A port must be in the Open 
state before it can arbitrate.

OPN
Open Primitive Signal. 

Ordered Set
A transmission word that uses 8B/10B mapping and begins with the K28.5 character. Ordered 
sets occur outside of frames, and include the following items:

■ Frame delimiters: Mark frame boundaries and describe frame contents.

■ Primitive signals: Indicate events.

■ Primitive sequences: Indicate or initiate port states.

Ordered sets are used to differentiate Fibre Channel control information from data frames and 
to manage the transport of frames.

Packet
A set of information transmitted across a network. 

See also Frame.

Participating Mode
A mode in which an L_Port in a loop has a valid AL_PA and can arbitrate, send frames, and 
retransmit received transmissions. 

See also L_Port, Non-participating Mode.

Path Selection
The selection of a transmission path through the fabric. HP StorageWorks switches use the 
FSPF protocol.
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Performance Monitor
Comprehensive HP tool for monitoring the performance of networked storage resources.

Performance Monitoring
An HP product that provides error and performance information to the administrator and end 
user for use in storage management.

Phantom Address
An AL_PA value that is assigned to an device that is not physically in the loop. 

Also known as phantom AL_PA.

Phantom Device
A device that is not physically in an arbitrated loop, but is logically included through the use of 
a phantom address.

PLOGI
Port Login. The port-to-port login process by which initiators establish sessions with targets. 

See also FLOGI.

Point-to-point
A Fibre Channel topology that employs direct links between each pair of communicating 
entities. 

See also topology.

Port Cage
The metal casing extending out of the optical port on the switch, and in which the SFP can be 
inserted.

Port Card
A Fibre Channel card that contains optical or copper port interfaces, and acts like a switch 
module. 

See also 16-port card.

Port Module
A collection of ports in a switch.

Port_Name
The unique identifier assigned to a Fibre Channel port. Communicated during login and port 
discovery.

POST
Power On Self-Test. A series of tests run by a switch after it is turned on.
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Primary FCS Switch
Primary fabric configuration server switch. The switch that actively manages the configuration 
parameters for all switches in the fabric. 

See also backup FCS switch, FCS switch.

Private Device
A device that supports arbitrated loop protocol and can interpret 8-bit addresses, but cannot log 
into the fabric.

Private Loop
An arbitrated loop that does not include a participating FL_Port.

Private NL_Port
An NL_Port that communicates only with other private NL_Ports in the same loop and does 
not log into the fabric.

Protocol
A defined method and a set of standards for communication.

PSU
Power Supply Unit.

Public Device
A device that supports arbitrated loop protocol, can interpret 8-bit addresses, and can log into 
the fabric.

Public Loop
An arbitrated loop that includes a participating FL_Port, and may contain both public and 
private NL_Ports.

Public NL_Port
An NL_Port that logs into the fabric, can function within either a public or a private loop, and 
can communicate with either private or public NL_Ports.

Quad
A group of four adjacent ports that share a common pool of frame buffers.
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QuickLoop
An HP StorageWorks product that makes it possible to allow private devices within loops to 
communicate with public and private devices across the fabric through the creation of a larger 
loop.

May also refer to the arbitrated loop created using this software. A QuickLoop can contain a 
number of devices or looplets; all devices in the same QuickLoop share a single AL_PA space.

A means of allowing private hosts to communicate with private targets across a switched 
fabric. 

The QuickLoop/Fabric Assist feature also allows:

■ Private hosts to communicate with public targets across a switched fabric

■ Private hosts to communicate with private targets that are not resident on the same switch 
across a switched fabric

See also Fabric Access, fabric assist, and translative mode.

QuickLoop Zoning
Protects devices from disruption by unrelated devices during critical processes; for example, 
during a tape backup session.

R_A_TOV
Resource Allocation Time-out Value. The maximum time a frame can be delayed in the fabric 
and still be delivered. 

See also E_D_TOV, RR_TOV.

R_RDY
Receiver ready. A primitive signal indicating that the port is ready to receive a frame.

RAID
Redundant Array of Independent Disks. A collection of disk drives that appear as a single 
volume to the server and are fault tolerant through mirroring or parity checking. 

See also JBOD.

Remote Fabric
A fabric that spans across WANs by using protocol translation (a process also known as 
tunneling) such as Fibre Channel over ATM or Fibre Channel over IP.

Remote Switch
Bridges two switches into a SAN as large as 3000KM or more through protocol encapsulation 
in ATM networks via the Computer Network Technologies (CNT) UltraNet Open Systems 
Gateway.
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Request Rate
The rate at which requests arrive at a servicing entity. 

See also service rate.

RLS Probing
Read link status of the AL_PAs.

Root Account
A login used for debugging purposes by HP engineers and is not intended for customer use. 

See also account level switches.

Route
As applies to a fabric, the communication path between two switches. May also apply to the 
specific path taken by an individual frame, from source to destination. 

See also FSPF.

Routing
The assignment of frames to specific switch ports, according to frame destination.

RR_TOV
Resource Recovery Time-out Value. The minimum time a target device in a loop waits after a 
LIP before logging out a SCSI initiator. 

See also E_D_TOV, R_A_TOV.

RS-232 port
A port that conforms to a set of Electrical Industries Association (EIA) standards. Used to 
connect DTE and DCE devices for communication between computers, terminals, and 
modems. 

See also DCE port, DTE port.

RSCN
Registered State Change Notification. A switch function that allows notification of fabric 
changes to be sent from the switch to specified nodes.

RX_ID
Responder Exchange Identifier. A 2-byte field in the frame header used by the responder of the 
Exchange to identify frames as being part of a particular exchange.
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SAN
Storage Area Network. A network of systems and storage devices that communicate using 
Fibre Channel protocols. 

See also fabric.

SAN Switch
A switch whose main task is to connect nodes into the fabric. 

See also core switch.

SCSI
Small Computer Systems Interface. A parallel bus architecture and protocol for transmitting 
large data blocks to a distance of 15 - 25 meters.

SDRAM
Synchronous Dynamic Random Access Memory. The main memory for the switch. Used for 
volatile storage during switch operation. 

See also flash.

Sequence
A group of related frames transmitted in the same direction between two N_Ports.

Service Rate
The rate at which an entity can service requests. 

See also request rate.

SFF
Small Form Factor.

SFP Cable
The latest innovation in high-speed copper cabling for Fibre Channel and InfiniBand. It 
incorporates the SFP module directly onto the cable assembly, eliminating the need for a 
separate SFP copper module and an HSSDC2 cable assembly. 

SFP
Small form factor pluggable. A transceiver used on 2 Gbps switches that replaces the GBIC. 
Refers to the LC-form factor transceiver. 

See also GBIC.

SID/DID
Source identifier/Destination identifier. S_ID is a 3-byte field in the frame header that is used 
to indicate the address identifier of the N_Port from which the frame was sent.
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Single Mode
The fiber optic cabling standard that, when used in conjunction with a 1300 nm laser light, can 
transfer data up to 10 km between devices. When used in conjunction with a 1550 nm laser 
light, single mode cabling can transfer data over 10 km. 

See also multimode, LWL, ELWL, and XLWL.

SI
Sequence Initiative.

SNMP
Simple Network Management Protocol. An internet management protocol that uses either IP 
for network-level functions and UDP for transport-level functions, or TCP/IP for both. Can be 
made available over other protocols, such as UDP/IP, because it does not rely on the 
underlying communication protocols. 

See also Community (SNMP).

SNMPv1
The original SNMP, now labeled v1.

SNS
Simple Name Server. A switch service that stores names, addresses, and attributes for up to 15 
minutes, and provides them as required to other devices in the fabric. SNS is defined by Fibre 
Channel standards and exists at a well-known address. May also be referred to as directory 
service. 

See also FS.

StorageWorks SAN switch
The brand name for the HP family of switches.

Switch Name
The arbitrary name assigned to a switch.

Switch Port
A port on a switch. Switch ports can be E_Ports, F_Ports, or FL_Ports.

Switch
Hardware that routes frames according to Fibre Channel protocol and is controlled by 
software.
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SWL
Short Wavelength. A type of fiber optic cabling that is based on 850-mm lasers and supports 
1.0625-Gbps link speeds. May also refer to the type of GBIC or SFP. 

See also LWL.

Tachyon
A chip developed by Hewlett-Packard, and used in various devices. This chip has FC-0 
through FC-2 on one chip.

Target
A storage device on a Fibre Channel network. 

See also Initiator.

Tenancy
The time from when a port wins arbitration in a loop until the same port returns to the 
monitoring state. Also referred to as loop tenancy.

Terminal Serial Port
May also be referred to as the console port. The lower serial port on the CP Card of the 
StorageWorks Core switch. This port sends switch information messages and can receive 
commands. Can be used to connect the CP Card to a computer terminal. Has an RS-232 
connector wired as a DTE device, and can be connected by serial cable to a DCE device. The 
connector pins two and three are swapped so that a straight-through cable can be used to 
connect to a terminal. The device name is ttyS0. 

See also DCE port, modem serial port.

Throughput
The rate of data flow achieved within a cable, link, or system. Usually measured in bps (bits 
per second). 

See also bandwidth.

Topology
As applies to Fibre Channel, the configuration of the Fibre Channel network and the resulting 
communication paths allowed. There are three possible topologies:

■ Point to point: A direct link between two communication ports.

■ Switched fabric: Multiple N_Ports linked to a switch by F_Ports.

■ Arbitrated loop: Multiple NL_Ports connected in a loop.



Glossary

182 Fabric Manager Version 3.0.x User Guide

Transceiver
Device that converts one form of signaling to another for transmission and reception; in fiber 
optics, it refers to optical and electrical.

Transfer State
The state in which a port can establish circuits with multiple ports without reentering the 
arbitration cycle for each circuit. This state can only be accessed by an L_Port in the Open 
state.

Translative Mode
A mode in which private devices can communicate with public devices across the fabric.

Transmission Character
A 10-bit character encoded according to the rules of the 8B/10B algorithm.

Transmission Word
A group of four transmission characters. 

See also data word.

Trap (SNMP)
The message sent by an SNMP agent to inform the SNMP management station of a critical 
error. 

See also SNMP.

Trunking
See ISL Trunking.

Tunneling
A technique for enabling two networks to communicate when the source and destination hosts 
are both on the same type of network, but are connected by a different type of network.

U_Port
Universal Port. A switch port that can operate as a G_Port, E_Port, F_Port, or FL_Port. A port 
is defined as a U_Port when it is not connected or has not yet assumed a specific function in 
the fabric.

UDP
User Datagram Protocol. A protocol that runs on top of IP and provides port multiplexing for 
upper-level protocols.

ULP_TOV
Upper-level Time-out Value. The minimum time that a SCSI ULP process waits for SCSI 
status before initiating ULP recovery.
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ULP
Upper-level Protocol. The protocol that runs on top of Fibre Channel. Typical upper-level 
protocols are SCSI, IP, HIPPI, and IPI.

Unicast
The transmission of data from a single source to a single destination. 

See also broadcast, multicast.

user account
A login intended for use by the customer to monitor, but not control, switch operation. 

See also account level switches.

VC
Virtual circuit. A one-way path between N_Ports that allows fractional bandwidth.

Web Tools
An HP product that runs on Fabric OS and provides a graphical interface to allow monitoring 
and management of individual switches or entire fabrics from a standard workstation running a 
browser.

Well-known Address
As pertaining to Fibre Channel, a logical address defined by the Fibre Channel standards as 
assigned to a specific function, and stored on the switch.

Workstation
A computer used to access and manage the fabric. May also be referred to as a management 
station or host.

WWN
World-Wide Name. An identifier that is unique worldwide. Each entity in a fabric has a 
separate WWN.

XLWL
Xtra Long Wave Length. Laser light with a periodic length greater than 1300 nm (e.g., 1420 or 
1550). XLWL lasers are used to transmit Fibre Channel data over distances greater than 10 
Km. 

Also known as ELWL.

Xmitted Close State
The state in which an L_Port cannot send messages, but can retransmit messages within the 
loop. A port in the XMITTED CLOSE state cannot attempt to arbitrate.
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Zone
A set of devices and hosts attached to the same fabric and configured as being in the same 
zone. Devices and hosts within the same zone have access permission to others in the zone, but 
are not visible to any outside the zone. 

See also Zoning.

Zone Alias
A name assigned to a device or group of devices in a zone. Aliases can greatly simplify the 
zone administrative process. 

See also alias.

Zone Configuration
A specified set of zones. Enabling a configuration enables all zones in that configuration. 

See also defined zone configuration, enabled zone configuration.

Zone Member
A port, node, WWN, or alias, which is part of a zone.

Zone Schemes
The level of zoning granularity selected. For example, zoning may be done by switch/port, 
WWN, AL_PA, or a mixture. 

See also zone configuration.

Zone Set
See zone configuration.

Zoning
An HP product that runs on Fabric OS and allows partitioning of the fabric into logical 
groupings of devices. Devices in a zone can only access and be accessed by devices in the 
same zone. 

See also zone.
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