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About This Guide

Use this guide to install and configure Compaq StorageWorks Command Console (SWCC). This guide 
is designed to be used as step-by-step instructions for installation and as a reference for operation, 
troubleshooting, and future upgrades.

IMPORTANT:  Some of the software described in this guide may not be in your release. To determine which 
software is included, see Chapter 1, About StorageWorks Command Console and readme.txt. 

Intended Audience
This guide is intended for storage administrators. Before you install SWCC, you should have a basic 
understanding of the following:

■ Your hub, switch, and/or tape controller

■ The TCP/IP network

■ The Storage Area Network (SAN)

In This Guide
This guide contains the following chapters and appendixes:

Chapter 1 — About StorageWorks Command Console provides a brief overview on the software, its 
components, and its features. It also provides an installation and configuration table, in addition to 
information about integrating SWCC with a third-party storage management program.

Chapter 2 — Using the Command Console Client provides information about using the Command 
Console Client and its components. 
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Chapter 3 — Installing and Removing the Client provides instructions on how to install the Client 
software on Microsoft Windows NT (Intel) version 4.0 and Windows 2000. It also provides information 
on how to remove the Command Console Client. 

Chapter 4 — Troubleshooting Connection Problems and the Command Console Client describes 
troubleshooting information for connection problems and the Command Console Client.

Appendix A — Network Connections for Hubs, Switches, and Tape Controllers describes the network 
connections for hubs, switches, and tape controllers. 

Appendix B — Installing the Hub Management Utilities Software describes the software required for 
you to manage your Compaq Storage Hub 12. 

Appendix C — Installing, Configuring, and Removing the Fibre Channel Interconnect Agent describes 
how to install, configure, and remove the Fibre Channel Interconnect Agent. This section describes how 
to add and remove client system entries, in addition to changing the polling interval of the Agent.

Appendix D — Managing Hubs, Switches, and Tape Controllers provides information on managing 
hubs, switches, and tape controllers by using the Web-based software.

Appendix E — Configuring the Web Browser for the Compaq StorageWorks FC-AL Switch describes 
how to configure your Web browser so you can view the configuration pages for the Compaq 
StorageWorks FC-AL Switch.

Text Conventions
This document uses the following conventions to distinguish elements of text:

Keys Keys appear in boldface. A plus sign (+) between two 
keys indicates that they should be pressed 
simultaneously.

USER INPUT User input appears in a different typeface and in 
uppercase

FILENAMES File names appear in uppercase italics.

Menu Options, 
Command Names, 
Dialog Box Names

These elements appear in initial capital letters.
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Online Help
Most of the information about using the Client is provided in the online Help. Online Help is provided 
in two places:

■ Navigation Window - Provides information on pager notification and a tour of the Command 
Console Client, in addition to information on how to add a system to the Navigation Tree. 

■ Fabric Window - Provides information about adding and removing the fabrics and elements. 

Release Notes
The release notes are in several files:

■ Readme.txt - Provides information on software components, installation, and Adobe Acrobat 
Reader. 

■ ccclient.txt - Provides information relating to the Command Console Client, such as the Navigation 
Tree. 

■ fcinter.txt - Provides information relating to the Fibre Channel Interconnect Agent and Fibre 
Channel Interconnect Client. 

Symbols in Text
These symbols may be found in the text of this guide. They have the following meanings.

WARNING:  Text set off in this manner indicates that failure to follow directions in the warning could 
result in bodily harm or loss of life.

COMMANDS, 
DIRECTORY NAMES, 
and DRIVE NAMES

These elements appear in upper case.

NOTE:  UNIX commands are case sensitive and will not 
appear in uppercase.

Type When you are instructed to type information, type the 
information without pressing the Enter key.

Enter When you are instructed to enter information, type the 
information and then press the Enter key.
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CAUTION:  Text set off in this manner indicates that failure to follow directions could result in damage 
to equipment or loss of information.

IMPORTANT:  Text set off in this manner presents clarifying information or specific instructions.

NOTE:  Text set off in this manner presents commentary, sidelights, or interesting points of information.

Symbols on Equipment
These icons may be located on equipment in areas where hazardous conditions may exist.

Any surface or area of the equipment marked with these symbols indicates the presence of 
electrical shock hazards. Enclosed area contains no operator serviceable parts. 

WARNING: To reduce the risk of injury from electrical shock hazards, do not open this 
enclosure.

Any RJ-45 receptacle marked with these symbols indicates a Network Interface Connection.

WARNING: To reduce the risk of electrical shock, fire, or damage to the equipment, do not 
plug telephone or telecommunications connectors into this receptacle.

Any surface or area of the equipment marked with these symbols indicates the presence of a 
hot surface or hot component. If this surface is contacted, the potential for injury exists. 

WARNING: To reduce the risk of injury from a hot component, allow the surface to cool 
before touching.

Power Supplies or Systems marked with these symbols indicate the equipment is 
supplied by multiple sources of power. 

WARNING: To reduce the risk of injury from electrical shock, remove all power 
cords to completely disconnect power from the system.
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Any product or assembly marked with these symbols indicates that the component exceeds 
the recommended weight for one individual to handle safely.

WARNING: To reduce the risk of personal INJURY or damage to the equipment, observe local 
occupational health and safety requirements and guidelines for manual material handling.

Rack Stability

WARNING:  To reduce the risk of personal injury or damage to the equipment, be sure that:

■ The leveling jacks are extended to the floor.

■ The full weight of the rack rests on the leveling jacks.

■ The stabilizing feet are attached to the rack if it is a single rack installations.

■ The racks are coupled together in multiple rack installations.

■ A rack may become unstable if more than one component is extended for any reason. Extend only 
one component at a time.
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Getting Help
If you have a problem and have exhausted the information in this guide, you can get further information 
and other help in the following locations.

Compaq Technical Support

In North America, call the Compaq Technical Phone Support Center at 1-800-OK-COMPAQ. This 
service is available 24 hours a day, 7 days a week.

NOTE:  For continuous quality improvement, calls may be recorded or monitored.

Outside North America, call the nearest Compaq Technical Support Phone Center. Telephone numbers 
for world wide Technical Support Centers are listed on the Compaq website. Access the Compaq 
website by logging on to the Internet at http://www.compaq.com.

Be sure to have the following information available before you call Compaq:

■ Technical support registration number (if applicable)

■ Product serial numbers

■ Product model names and numbers

■ Applicable error messages

■ Add-on boards or hardware

■ Third-party hardware or software

■ Operating system type and revision level

■ Detailed, specific questions

Compaq Website

The Compaq website has latest information on this product as well as the latest drivers. You can access 
the Compaq website by logging on to the Internet at http://www.compaq.com/storage.

http://www.compaq.com
http://www.compaq.com/storage
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Compaq Authorized Reseller
For the name of your nearest Compaq Authorized Reseller:

■ In the United States, call 1-800-345-1518.

■ In Canada, call 1-800-263-5868.

■ Elsewhere, see the Compaq website for locations and telephone numbers.





Chapter 1

About StorageWorks Command Console

This chapter includes: 

■ Installation and Configuration Overview Table

■ SWCC Overview 

■ Components of SWCC

■ Using SWCC with a Third-Party Storage Management Program

Table 1–1:  Installation and Configuration Overview
Step Procedure

1 Verify that the hardware is configured properly. Refer to your hardware 
documentation.

2 Verify that the hardware is connected to a TCP/IP network. See Appendix A, 
Network Connections for Hubs, Switches, and Tape Controllers.

3 To understand SWCC, read Chapter 1, About StorageWorks Command 
Console and Chapter 2, Using the Command Console Client.
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SWCC Overview
To monitor and configure your hubs, switches, and/or tape controllers, you can:

■ Use the Web-based software that is installed with the Fibre Channel Interconnect 
Agent for managing switches and tape controllers (http://youragentsystem:2301)

■ Use the Windows-based Client software (Start > Programs > Command Console > 
StorageWorks Command Console) for hubs, switches, and tape controllers

4 If you have a Compaq Storage Hub 12, install the HMU software on the same client 
system you plan to install the Command Console Client and Fibre Channel 
Interconnect Client. See Appendix B, Installing the Hub Management 
Utilities Software. The HMU software can be ordered from Compaq.

5 Install the Command Console Client and the Fibre Channel Interconnect Client. See 
Chapter 3, Installing and Removing the Client.

6 Install the Fibre Channel Interconnect Agent. See Appendix C, Installing, 
Configuring, and Removing the Fibre Channel Interconnect Agent.

7 Add the name of the client system to the Agent’s list of client system entries. 
See Appendix C, Installing, Configuring, and Removing the Fibre 
Channel Interconnect Agent.

8 Add the name of the agent system to the Navigation Tree of each client system. For 
more information, refer to the Command Console Client Help. 

9 Add fabrics and elements to the Fabric Page and/or to the Fabric Window. For 
information about the Fabric Window, see Appendix D, Managing Hubs, 
Switches, and Tape Controllers and the online Help in the Fabric Window. For 
more information about the Fabric Page, see Appendix D, Managing Hubs, 
Switches, and Tape Controllers and the Fabric Page’s online Help.

10 For troubleshooting information, see Chapter 4, Troubleshooting Connection 
Problems and the Command Console Client and Appendix E, 
Configuring the Web Browser for the Compaq StorageWorks FC-AL 
Switch. 

11 To receive pager notification, add the agent system to the Navigation Tree and set 
up pager notification. For information on pager notification, see Setting Up 
Pager Notification in Chapter 2. 

Table 1–1:  Installation and Configuration Overview (Continued)
Step Procedure
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You can set up pager notification in the Navigation Window to page you when a problem 
occurs. When you are away from your office, you can learn about the details of a problem 
with the hub, switch, or tape controller from any computer that has the following:

■ A supported Web browser 

■ Network access to the computer running the Agent software

■ For more information on pager notification, see Chapter 2, Using the Command 
Console Client. 

■ Figure 1–1, A brief overview of the software provides a graphical view of the 
connections for the software.

Figure 1–1:  A brief overview of the software

1 Computer running the 
Windows-based software 
(client system)

2 Computer using a  browser to access 
multiple tape controllers

3 TCP/IP network connection 4 Computer running the Agent software

5 Fibre cable (Optional) 6 Tape controller  
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Components of SWCC
In this release, SWCC includes: the Command Console Client, the Fibre Channel 
Interconnect Client, and the Fibre Channel Interconnect Agent. If you are planning to use 
SWCC to manage your hub, you must install the Compaq Storage Hub 12 Management 
Utilities.

NOTE:  SWCC does not support the dynamic host configuration protocol (DHCP) or the Windows 
Internet Name Service (WINS); however, you can still use these protocols on systems that do not 
run Command Console.

About the Command Console Client

The Command Console Client provides the Navigation Window you see when you click 
Start > Programs > Command Console > StorageWorks Command Console. The 
Command Console Client contains the following:

■ Navigation Tree

■ Navigation Window

■ Asynchronous Event Service

■ Pager Notification

Table 1–2:  Components of StorageWorks Command Console
Software Operating System Components

Command Console Client Windows-based AES, Pager Notification, Navigation 
Tree, and Navigation Window

Fibre Channel Interconnect 
Client

Windows-based Fabric Window, configuration windows 
for hubs, switches, and tape 
controllers.

Hub Management Utilities 
(HMU)

(Purchased separately)

Windows-based (Intel), 
add-in to Fibre Channel 
Interconnect Client

Configuration software for the Compaq 
Storage Hub 12.

Fibre Channel Interconnect 
Agent (SAN Interconnect 
Management)

Windows 2000 and Windows 
NT (Intel) 4.0 with Service 
Pack 4 or later

Agent service, Agent configuration 
utility, and  pages that allow you to view 
the status of your fabrics.
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About the Fibre Channel Interconnect Client

The Fibre Channel Interconnect Client works with the Command Console Client to 
provide information about your subsystems. The Fibre Channel Interconnect Client 
provides a Fabric Window, which displays detailed information on a particular fabric. 

About the Fibre Channel Interconnect Agent

The Fibre Channel Interconnect Agent:

■ Obtains the status of the hubs, switches, and tape controllers

■ Passes the status of the hubs, switches, and tape controllers to the Fabric Page

■ Passes the status of the hubs, switches, and tape controllers to the Navigation Tree

For more information on the Fabric Page, see Appendix D, Managing Hubs, Switches, and 
Tape Controllers.

About the Compaq Storage Hub 12 Management Utilities 
(Intel Only)

If you want to use SWCC to manage your Compaq Storage Hub 12, you must install the 
Storage Hub 12 Management Utilities (HMU) on the same client system you plan to 
install the Command Console Client and the Fibre Channel Interconnect Client. This 
software allows you to manage your hubs from your client system. 

For the HMU software to work, you must insert the Compaq Storage Hub 12 Management 
Module (HMM) into a slave Storage Hub 12 and configure the HMM. When the HMM is 
inserted into a slave hub, the hub becomes the master hub. HMM provides TCP/IP 
network connectivity to SWCC. 

NOTE:  For more information on the HMU software, see Appendix B, Installing the Hub 
Management Utilities Software.
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Using SWCC with a Third-Party Storage 
Management Program

You can use SWCC with a third-party storage management program by adding the name 
of the computer that has the third-party storage management program to the Agent’s list of 
client system entries. The Agent sends SNMP traps to client systems that are on its list of 
client system entries. For more information on how to add client systems, see Appendix B, 
Installing the Hub Management Utilities Software.

NOTE:  Depending on your third-party software, you may need to complete additional steps. 
Refer to the documentation that came with your third-party storage management program. 



Chapter 2

Using the Command Console Client

This chapter includes the following:

■ Using the Navigation Tree 

■ About the Asynchronous Event Service

■ Setting Up Pager Notification 

For a complete list of hardware that SWCC supports, refer to the software product 
description (SPD) on the StorageWorks Command Console website:

http://www.compaq.com/products/storageworks/Storage-Management-Software/
command_console.html

The features of Command Console differ according to your software release. For example, 
SWCC for an HS-Series controller provides a Storage Window, while SWCC for a Fibre 
Channel switch provides a Fabric Page. 

To determine which software is offered in your release, refer to the readme.txt file that is on 
the SWCC CD-ROM or if you downloaded the software from the website, refer to the 
readme.txt file on the website.
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Using the Navigation Tree
The Navigation Window provides the Navigation Tree. The Navigation Tree provides a 
way for you to view the status of all your storage at once, as shown in Figure 2–1. It also 
lets you manage your subsystem over a network. Some of the items shown in the 
Navigation Tree may not represent the software in your release.

Figure 2–1:  An example of the Navigation Tree
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Managing Storage Subsystems from the Navigation Tree

You can manage a storage subsystem from the Navigation Tree by double-checking the 
subsystem’s management window, icon. The name of this management window will 
change according to your software release. It may be called a Storage Window, a Fabric 
Window, or a Web page. The following steps tell you how to access a subsystem’s 
management window: 

1. Double-click the folder for the storage subsystem. An icon appears underneath the 
folder. 

NOTE:  If you have two KZPCC controllers connected to the agent system and you have installed 
the KZPCC Client and KZPCC Agent, you may see two icons. 

2. Double-click the subsystem’s management window, icon,. Depending on your 
software release, one of the following will appear:

❏ A Storage Window or Fabric Window – The window’s name varies according to 
your release.

❏ A Web page – The page’s name varies according to your release.

❏ A CLI Window – It applies to only HS-Series controllers. It provides a command 
line interface that allows you to change the configuration of your subsystem. 

Organizing Your Storage in the Navigation Tree

After you have added systems to the Navigation Tree, you can use folders to organize your 
storage, as follows:

■ You can place folders under the Command Console root or under another general 
folder in the Navigation Window.

■ You can use folders to group systems and other general folders, but they cannot be 
used to group controllers.

For example, in Figure 2–1, the general folder Storage on the First floor was created and 
two agent systems were placed in the folder. If one of the systems in the folder is at a 
critical state, the status of the folder displays the same critical state. 

NOTE:  For a description of the Navigation Window, refer to the “Quick Tour” in the introduction 
of the Command Console Client Help.
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About the Asynchronous Event Service
The Asynchronous Event Service (AES) is a component of the Command Console Client. 
AES does the following:

■ Runs in the background as a service that provides status updates of the subsystems to 
its client system. For a client system to receive updates, it needs to be running AES. 

■ Passes the trap (message) to the Navigation Tree. The Navigation Tree, in turn, passes 
the trap to the appropriate Storage Window or Fabric Window. When a trap provides 
information about a status change in a subsystem, one or more of the icons in the 
Navigation Tree change color.

■ Sends traps to pagers. To activate this feature, you must predefine each pager number 
in the User Profile section of the Event Notification menu in the Navigation Window. 

NOTE:  Refer to Command Console’s Help for the latest information on how to diagnose 
problems that could occur when sending pages. Help provides instructions on how to put AES 
into a debug mode.

You can change whether AES starts at boot time. You can also stop or start AES manually. 
However, you need AES running to receive pages notifying you of faults and to provide 
updates to the Navigation Tree, Storage Windows, Fabric Windows, and Event Viewer. 
When you stop AES, you are telling the Client software to stop the following:

■ Providing updates to the Navigation Tree, Storage Windows, and Fabric Windows.

■ Displaying updates obtained from the Asynchronous Event Service in the Application 
Log of the Event Viewer.

■ Paging when a fault occurs.

Stopping or Starting AES:

From Windows NT

To stop or start AES manually:  

1. Double-click Services in Start > Settings > Control Panel.

2. Click the AsyncEventSvc entry. 

3. Click Stop or Start, then click Close.
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To disable the automatic start of AES when your system boots, change the startup option 
to manual in the Services window, as described below:

1. Double-click Services in Start > Settings > Control Panel.

2. Double-click the AsyncEventSvc entry. The Service window appears.

3. Select Manual under Startup Type, and click OK.

From Windows 2000

To stop or start AES manually:  

1. Click Start > Settings > Control Panel > Administrative Tools > Component Services.

2. Under Console Root, select Services (Local).

3. Under Services (Local), right-click AsyncEventSvc. 

4. Click Stop or Start.

To disable the automatic start of AES when your system boots, change the startup option 
to manual, as described below:

1. Click Start > Settings > Control Panel > Administrative Tools > Component Services.

2. Under Console Root, select Services (Local).

3. Under Services (Local), right-click AsyncEventSvc. 

4. From the drop-down menu, select Properties. The AsyncEventSvc Properties (Local 
Computer) window appears.

5. Under the General tab, select Manual from the Startup Type drop-down menu.

6. Click OK.

Setting Up Pager Notification
You can set up Command Console to notify you by pager when a critical event occurs. 
This feature works with alphanumeric and numeric pagers. You can configure this feature 
so it sends pages to numerous people at different times. 

For example, if several people monitor the network in shifts, you can configure this feature 
so the software only pages the person currently working. 

To receive pages, the following must occur:
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■ The Asynchronous Event Service (AES) must be running on the client system on 
which you set up the pager notification. 

■ The Agent must be running.

■ The client system must be added to the Agent’s list of client system entries.

■ In the Agent’s list of client system entries, you must select the TCP/IP notification 
scheme for your client system. 

■ The agent system must be added to the Navigation Tree of the client system on which 
you set up pager notification.

NOTE:  Pager notification uses the Telocator Alphanumeric Protocol (TAP) adopted in 1988 by 
the Personal Communications Industry Association (PCIA). Verify your paging company uses this 
protocol.

Setting Up Pager Codes

Numeric pager support lets you receive notification about critical events. A numeric pager 
usually has three fields separated by hyphens. The first field signifies the area code, the 
second field signifies the exchange, and the third field signifies the four-digit extension. 
When you receive a page from Command Console, the first field signifies a three-digit 
number for the host system, the second field is a three-digit number for the subsystem, and 
the last field is a four-digit code for the critical event. 

Table 2–1:  Setting Up Pager Notification
Step Description

1 Numeric Pagers only - Assign pager codes to host systems and controllers. See 
Setting Up Pager Codes.

2 Set up user profiles. See Setting Up User Profiles.

3 Set up notification lists. See Setting Up Notification Lists.

4 Set up modem and polling intervals. See Setting Up Modem and Polling 
Preferences.

5 Associate systems and controllers with notification list. See Associating 
Systems and Subsystems with Notification Lists.

6 For information on troubleshooting pager notification, refer to the Command 
Console Client online Help.
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Set up pager codes by assigning a three-digit code for each host system. Then assign 
another three-digit code for each subsystem controller connected to that host. The last four 
digits are pre-assigned (but you can change them).

Assigning a Pager Code to a Host System

1. Click a host system in the Navigation Window. 

2. Click File > Properties. 

3. Click the Event Notification tab.

4. Enter a three-digit number in the Pager identification number field. Avoid entering a 
number that could be mistaken for an area code.

Assigning a Pager Code to a Subsystem 

1. Click a subsystem controller in the Navigation Window.  

2. Click File > Properties. 

3. Click the Event Notification tab.

4. Enter a three-digit number in the Pager identification number field.

Viewing or Changing a Pager Code for a Critical Event

1. Click Options > Event Notification > Pager Codes. 

2. Click the code you want to edit, then click Edit.

3. Type the new pager code in the edit field.

Table 2–2:  Pager Codes
*Critical Event Code Notes

Disk Fault 1000 Physical device failure

Power Supply Fault 1002

Fan Fault 1003

Battery Fault 1004

Temperature Fault 1005

Controller Fault 1006 The controller has detected an internal 
fault
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NOTE:  *Some of the critical events listed may not apply to your hardware. System codes, 
subsystem controller codes, and event codes are numeric-only codes. Alphanumeric pager 
codes are not supported.

Setting Up User Profiles
1. Click Options > Event Notification > User Profiles. 

2. Click New.

3. Enter a name. If you want, you can also enter a description. 

4. Click the Pager tab.

5. Select Enabled.

6. Enter the phone number for your pager in the pager number field. 

7. Select Alphanumeric for alphanumeric paging.

8. Enter the pager identification number (required for alphanumeric pagers). If your 
numeric pager does not require a pager identification number (PIN), leave this field 
blank. For example: This field must be left blank for numeric pagers that are assigned 
their own unique telephone number.

9. Enter the start and end times in HH:MM, 24-hour format. For example: 08:00 as start, 
and 17:00 as end. Leave both fields set to 00:00 if you want to be notified 24 hours a 
day.

Keep the following in mind:

■ If you need to dial a code to access an outside number, the code must precede the 
phone number in the pager number field.

■ Do not use commas with alphanumeric pagers, except if required to access an outside 
line.

Communication Fault 1007 Agent cannot talk to the subsystem.

Other Controller Fault 1008 One controller is reporting a fault on the 
other.

External Fault 1009

LUN Fault 1010 Virtual disk failure

Table 2–2:  Pager Codes (Continued)
*Critical Event Code Notes
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■ If you are configuring an alphanumeric pager, you must supply the paging service 
provider’s TAP service modem number in the pager number field.

■ When you enter a numeric pager number, you can optionally use one or more commas 
to specify a two-second wait interval. Each comma causes the pager dialer to wait two 
seconds before sending the pager identification number to the paging company. You 
may need to add additional commas by using the trial and error method so that 
Command Console will pause long enough for the pager company greetings to 
complete.

■ Not every paging company requires a pager identification number. If your pager is 
assigned a unique phone number to call the paging company, do not enter a pager 
identification number.

■ Alphanumeric pagers require a pager identification number.

■ Refer to your pager documentation to determine which special characters are 
supported.

Figure 2–2:  Sample user profile – alphanumeric paging
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Figure 2–3:  Sample user profile – numeric paging

NOTE:  The commas in  represent two-second wait intervals.

Setting Up Notification Lists
1. Click Options > Event Notification > Notification List. 

2. Click New and enter a name for the new notification list.

3. Write a brief description of the list (optional).

4. Add members to the list by clicking the check box next to each name. 

NOTE:  Use notification lists to notify groups of people of critical events. You cannot add a user 
to a list until a user profile has been created for the user.  Be sure you have created the user 
profiles first before creating a notification list. Use the property pages to associate notification 
lists with systems and subsystem critical events.
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Setting Up Modem and Polling Preferences
1. Click Options > Preferences. 

2. Enter the number of hours or minutes in the subsystem polling interval field.

3. Select the COM port that your modem uses in your computer.

4. For alphanumeric pagers select the baud rate of your paging service provider’s TAP 
modem. This is typically 1200 baud.

NOTE:  The subsystem-polling interval is the frequency at which the Client pings an Agent to 
determine if the Agent is running.

NOTE:  The default-polling interval is 30 minutes.

NOTE:  If Command Console loses a connection to an Agent, an X will appear on the system 
folder in the Navigation Window and Command Console will immediately send a communication 
loss message.

Associating Systems and Subsystems with Notification 
Lists

To associate a host system or a subsystem with a notification list for the purpose of paging 
a group of people when a critical event occurs: 

1. Click a host system or a subsystem in the Navigation Window.

2. Click File > Properties. 

3. Click the Event Notification tab.

4. Select a notification list from the drop-down menu.

NOTE:  You must first create a notification list before you can associate a system or controller 
with a notification list.





Chapter 3

Installing and Removing the Client

This chapter contains information about installing the Client, troubleshooting the Client 
installation, and removing the Command Console Client.

Installing the Client
Depending on your software release, you can install the Client from a CD-ROM or from a 
file downloaded from the Compaq StorageWorks website. The readme.txt file provides 
guidance on which way is suitable.

Before You Install the Client
1. Verify that you are logged into an account that is a member of the administrator group. 

2. Check the SPD on the Compaq StorageWorks website for a list of supported hardware. 
For the URL, see Chapter 2, Using the Command Console Client.
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3. Verify that you have the SNMP service installed on your computer. You must have 
SNMP installed on your computer for this software to work properly. The Client 
software uses SNMP to receive traps from the Agent. The SNMP service is available 
on your Windows NT or Windows 2000 installation CD-ROM. To verify that you have 
the SNMP service:

❏ For Windows NT, double-click Services in Start > Settings > Control Panel. The 
entry for SNMP is shown in this window. If you install the SNMP service and you 
already have a Windows NT service pack on your computer, reinstall the service 
pack after installing the SNMP service.

❏ For Windows 2000, click Start > Settings > Control Panel > Administrative Tools > 
Component Services. The entry for SNMP is shown in the Component Services 
window. 

4. Read the release notes in the ccclient.txt file for the Command Console Client.

5. Read the release notes for your device-specific Client. The readme.txt file will have 
information on where you can find the release notes for the device-specific Client.

6. Read section Troubleshooting the Client Installation, in this chapter.

7. If you have the Command Console Client open, exit the Command Console Client. 

8. If you have Command Console Client version 1.1b or earlier, remove the program by 
going into Add/Remove Programs.

9. If you have a previous version of Command Console, you can save your Navigation 
Tree configuration by copying the swcc2.mdb file to another directory. After you have 
installed the product, move swcc2.mdb to the directory to which you installed SWCC. 

10. During the installation you will be given the option to install certain components. To 
determine which software is required, refer to the readme.txt file.

Installing from the SWCC CD-ROM
1. Insert the CD-ROM into a computer running Windows 2000 or Windows NT 4.0 

(Intel) with Service Pack 4 or later.

2. Using Microsoft Windows Explorer, go to the top-level directory on the CD-ROM, and 
double-click setup.exe. 

3. Select the required Client components and click Next. To determine which software is 
required, refer to readme.txt.

4. Follow the instructions on the screen. After you install the software, the Asynchronous 
Event Service (AES) starts.
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For more information on AES, see section About the Asynchronous Event Service, in 
Chapter 2.

5. For information on how to install the Agent, see Appendix B, Installing the Hub 
Management Utilities Software. 

Installing from the StorageWorks Website

This procedure assumes you have downloaded the file that contains the Client from the 
StorageWorks website to a computer running Windows 2000 or Windows NT 4.0 (Intel) 
with Service Pack 4 or later: 

1. Open Windows Explorer and double-click the file you downloaded.

The file self-extracts.

2. Go to the top-level directory created from the self-extracted zip file and double-click 
setup.exe. 

3. Select the required Client components and click Next. To determine which software is 
required, refer to readme.txt.

4. Follow the instructions on the screen. After you install the software, the Asynchronous 
Event Service (AES) starts.

For more information on AES, see section About the Asynchronous Event Service, in 
Chapter 2.

5. For information on how to install the Agent, see Appendix B, Installing the Hub 
Management Utilities Software. 

Troubleshooting the Client Installation
This section provides the following information on how to resolve some of the problems 
that may appear when you install the Client software: 

■ Invalid Network Port Assignments During Installation

■  “There is no disk in the drive” Message
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Invalid Network Port Assignments During Installation

SWCC Clients and Agents communicate by using sockets. The SWCC installation 
attempts to add entries into each system list of services (services file or for UCX, the local 
services database). If the SWCC installation finds an entry in the local services file with 
the same name as the one it wants to add, it assumes the one in the file is correct.

The SWCC installation may display a message, stating that it cannot upgrade the services 
file. This happens if it finds an entry in the local services file with the same number as the 
one it wants to add, but with a different name. In that case, appropriate port numbers must 
be obtained for the network and added manually to the services file. 

There are two default port numbers, one for Command Console (4998) and the other for 
the device-specific Agent and Client software, such as the Fibre Channel Interconnect 
Client and Agent (4989). There are two exceptions. The following software has two 
default port numbers: 

■ The KZPCC Agent and Client, (4991 and 4985) 

■ The RA200 Agent and Client, (4997 and 4995)

If the Network Information Services (NIS) are being used to provide named port lookup 
services, contact the network administrator to add the correct ports. 

The following shows how the network port assignments appear in the services file:

spgui 4998/tcp #Command Console

ccdevmgt 4993/tcp #Device Management Client and Agent

kzpccconnectport 4991/tcp #KZPCC Client and Agent

kzpccdiscoveryport 4985/tcp #KZPCC Client and Agent

ccfabric 4989/tcp #Fibre Channel Interconnect Agent

spagent 4999/tcp #HS-Series Client and Agent

spagent3 4994/tcp #HSZ22 Client and Agent

ccagent 4997/tcp #RA200 Client and Agent

spagent2 4995/tcp #RA200 Client and Agent
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“There is no disk in the drive” Message

When you install the Command Console Client, the software checks the shortcuts on the 
desktop and in the Start menu. The installation will check the shortcuts of all users for that 
computer, even if they are not currently logged on. You may receive an error message if 
any of these shortcuts point to empty floppy drives, empty CD-ROM drives, or missing 
removable disks. Do one of the following:

■ Ignore the error message by clicking Ignore.

■ Replace the removable disks, and place a disk in the floppy drive and a CD-ROM in 
the CD-ROM drive. Then click Retry.

Removing the Command Console Client
Before you remove the Command Console Client from your computer, remove AES. This 
will prevent the system from reporting that a service failed to start every time the system is 
booted. Steps 2 through 5 tell you how to remove the Command Console Client.

NOTE:  When you remove the Command Console Client, the swcc2.mdb file is deleted. This file 
contains the Navigation Tree configuration. If you want to save this information, move the file to 
another directory.

1. Click Start > Programs > Command Prompt and change to the directory to which you 
installed the Command Console Client. 

2. Enter the following command:

C:\Program Files\Compaq\SWCC>   AsyncEventService -remove

3. Do one of the following:

❏ On Windows NT 4.0, click Start > Settings > Control Panel, and then double-click 
the Add/Remove Programs icon in the Control Panel. The Add/Remove Program 
Properties window appears.

❏ On Windows 2000, click Start > Settings > Control Panel > Add/Remove 
Programs. The Add/Remove Program window appears.

4. Select Command Console located in the window.

5. Do one of the following:

❏ On Windows NT 4.0, click Add/Remove. 

❏ On Windows 2000, click Change/Remove.

6. Follow the instructions on the screen. 
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NOTE:  This procedure removes only the Command Console Client. You can remove a 
device-specific Client (such as the KZPCC Client) by using the Add/Remove program.



Chapter 4

Troubleshooting Connection Problems and the
Command Console Client

This chapter provides general usage notes for troubleshooting connection problems and 
the Command Console Client. 

Troubleshooting the Command Console 
Client

■ Authorization Error When Adding an Agent System

■ Increasing Screen Space for the Fabric Windows and Storage Windows

■ Invalid or Missing Fault Displays and Event Logs

■ Pager Notification and Event Logging Continues After Exiting the Command Console 
Client

■ Some Graphics Do Not Scale Well with Large Fonts

■ Starting Client from the Command Prompt
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Authorization Error When Adding an Agent System

If you receive an authorization error when you add an agent system to the Navigation Tree, 
your client system may be missing from the Agent’s list of client system entries. If you 
have more than one type of Agent installed on that agent system, the name of your client 
system must be on each Agent’s list of client system entries. 

Increasing Screen Space for the Fabric Windows and 
Storage Windows

Run the Client on a monitor that has a minimum super VGA (SVGA) (800X600) display 
resolution. The Fabric Windows and Storage Windows require a certain amount of screen 
space to properly display their contents. When you use a VGA display resolution, screen 
space becomes more limited. If you must use a VGA resolution, select the Auto Hide 
check box in the Taskbar Properties window to increase screen space for the Fabric 
Windows and Storage Windows.

Invalid or Missing Fault Displays and Event Logs

Invalid or lost notifications may occur when the client system’s connection with a 
subsystem is broken. The client system receives notification for most changing subsystem 
faults at monitored intervals. This means that if the client system is no longer notified of 
subsystem faults, then changes to that subsystem will not be displayed in the client 
system’s Navigation Tree, Storage Window (if applicable), Fabric Window (if applicable), 
and Event Viewer.

For example, while client system’s connection with a subsystem is broken, you will not 
receive event logs pertaining to that subsystem, except to notify you that the connection is 
severed.

The following list provides the reasons for broken connections. After you have fixed the 
physical and/or software problem that is listed below, you will need to close and reopen 
the Storage Window pertaining to that subsystem to obtain its latest status. 

■ RAS connections -  Remote Access Service (RAS) connections are not full time. 
When there is no RAS connection, events are not logged to the Application Log of 
Event Viewer.

■ Serial controller connections - There may be a bad or missing serial cable. To repair 
this situation, replace or plug in the cable.

■ Network connections - Agent may be missing or not running. 
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■ Network connections - There may be network discontinuity. 

■ The Agent may not be properly configured for a client system.

■ If your setup includes a controller, the controller may have halted, reset or hung. To 
repair the situation, restart or replace the controller.

■ If your setup includes virtual disks, the virtual disk being used for communicating with 
the subsystem is no longer available.

Pager Notification Continues After Exiting the Command 
Console Client

You may have noticed continuous pager notification in response to subsystem faults, even 
though you have exited Command Console Client. This behavior is normal. 

AES runs under Windows NT and Windows 2000 as a service. It continues to run even 
after you have exited the Command Console Client. AES communicates with Agents, and 
activates paging when a subsystem event occurs. 

To stop pager notification, stop AES. For information on how to stop AES, see section 
About the Asynchronous Event Service, in Chapter 2.

Some Graphics Do Not Scale Well with Large Fonts

Display small fonts when using Client.  Some of the graphics do not scale as well when 
large fonts are used.

Starting Client from the Command Prompt

To start the Client with network connections from the command prompt, enter the 
following at the command prompt on the client system:

\path_to_client_directory\swcc.exe -d your_host_system your_host_subsystem

where -d your_host_system your_host_subsystem  is an optional set of parameters that 
enables you to specify a system and a subsystem to start Client. 

For example: 

C:\>\Program Files\Compaq\SWCC\swcc.exe –d hostsystem subsystem
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If you specify these parameters, Client opens with the system selected and the subsystem 
displayed in the Storage Window, in the Fabric Window, or in a Web browser. If Client is 
not already aware of the system and the subsystem, it adds them to the Navigation Tree.

Troubleshooting Connection Problems
SWCC is a TCP/IP socket-based application. As a result, SWCC requires that each node 
running a SWCC Client or Agent must have access to a valid hosts file or Domain Name 
Service (DNS) server. The valid hosts file must include at least the system itself and any 
other systems running a SWCC Client or Agent that it will connect to.

IMPORTANT:  SWCC does not support the dynamic host configuration protocol (DHCP) or the 
Windows Internet Name Service (WINS); however, you can still use these protocols on systems 
that do not run Command Console. To determine whether you system is using DHCP or WINS on 
Windows 2000 or Windows NT 4.0:
Right-click Network Neighborhood on the desktop.
Select Properties.
Click the Protocols tab.
Select TCP/IP, then click Properties. You see the Microsoft TCP/IP Properties window. 

This section includes the following topics:

■ “Access Denied” Message

■ Adding New System by Using Internet Protocol Address May Cause Client to Stop 
Responding

■ “No Agent Running” Message When Adding System to the Navigation Tree

NOTE:  First verify that your network is running. 

NOTE:  For Windows NT or Windows 2000, run netstat at the command prompt on the Agent 
and check the TCP/IP active connections. 

NOTE:  For UNIX, run netstat with the correct options (Reference netstat man pages in UNIX help 
information).

NOTE:  For other operating systems, refer to the operating system documentation.

“Access Denied” Message

This section covers some of the most common reasons for a Client to receive an “Access 
Denied” message when it attempts to add an agent system to the Navigation Tree.
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Aliases Not Checked

When SWCC Agents scan the Client authorization list, they do not check aliases. The 
entry in the Client authorization list must match that returned by a gethostbyaddr call in 
the hostent h_name field. SWCC will not scan the hostent alias list to verify if an alias 
may match the Client authorization list.

Client System Not on Agent's List

The client system may not be on the authorized client system list for the Agent. To verify 
that the client system is included, view the list of client system entries in the Agent 
Configuration utility. 

Entry in the Client Authorization List Does Not Match

You may see an “access denied” message if the name of the client system that you entered 
in the Agent configuration utility does not match that for DNS or in the agent system’s 
hosts file. The hosts file on Windows NT and Windows 2000 is at 
\winnt\system32\drivers\etc.

Your system may be configured to do one the following:

■ Check its local hosts file first, then go to DNS. (most common setup for Windows NT 
and Windows 2000) 

■ Go to DNS first, then check its local hosts file. 

■ Ignore DNS even if configured.

■ Ignore the local hosts file.

To determine how your system is configured (Windows NT and Windows 2000):

1. Right-click Network Neighborhood on the desktop.

2. Select Properties. 

3. Click the Protocols tab.

4. Select TCP/IP, then click Properties. You see the Microsoft TCP/IP Properties 
window. 

5. Click the WINS Address tab. If your computer uses DNS, the option, Enable DNS for 
Windows resolution, is selected. You do not need the option, Enable LMHOSTS 
Lookup, selected. If WINS servers are available on the network, LMHOST file can be 
used. SWCC does not support WINS.
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6. To determine the IP address of the system, click the IP Address tab in the Microsoft 
TCP/IP Properties window.

7. To determine the full name of the system, click the DNS tab.

Multiple Agents

If the agent system is running multiple SWCC Agents (for example, to support different 
controller types) then the client system must be authorized for all Agents. If the client 
system is missing from any authorized Client list of an Agent, then that Agent cannot be 
added to the Navigation Tree.

Adding New System by Using Internet Protocol Address 
May Cause Client to Stop Responding

The SWCC Client may stop responding when you attempt to add a system by using the 
agent system's IP address rather than the agent system's node name. This occurs when the 
client system does not have a DNS server configured that knows the agent system, and the 
agent system is not in the client system's hosts file. To correct this situation, add the agent 
system to the hosts file on the client system.

If you receive an “Invalid host” or “Host not known” message when you attempt to 
connect to an agent system, do not enter the IP address. Correct your DNS server 
configuration. If it is correct, confirm the DNS server knows the agent system. If you are 
not using DNS, verify the agent system is in the client system's hosts file. 

“No Agent Running” Message When Adding System to the 
Navigation Tree

When trying to add a new system to the Navigation Tree, you may see a message, stating 
“No Agent running on specified system.” This message can appear for several reasons. 
The error most likely occurred as a result of one of the following: 

■ The wrong system name was entered. 

■ The Agent was not installed on the entered system.

■ The Agent was installed on a system that stopped functioning. 

■ Port names and numbers in the services file may be missing or may not match between 
Client and Agent. This may occur if the default value for an SWCC port was already in 
use. 
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■ The specific Client required to support an Agent was not installed. For example, if the 
agent system only has a KZPCC Agent and the client system has only an HSZ22 
Client, the “No Agent Running” message will appear.

To verify that Client support for an Agent had been installed, look at the following registry 
key:

HKEY_LOCAL_MACHINE\Software\DigitalEquipmentCorporation\
Command Console\AppletManager

You should see a series of keys for supported products.





Appendix A

Network Connections for Hubs, Switches, and Tape
Controllers

This appendix provides an overview on connecting your hardware to use Command 
Console to manage your hubs, switches, and/or tape controllers over the network. You 
need a TCP/IP network connection to link the Fibre Channel Interconnect Client to your 
Agent through the network.

IMPORTANT:  SWCC does not support the dynamic host configuration protocol (DHCP) or the 
Windows Internet Name Service (WINS); however, you can still use these protocols on systems 
that do not run Command Console. To determine whether you system is using DHCP or WINS on 
Windows 2000 or Windows NT 4.0:
Right-click Network Neighborhood on the desktop.
Select Properties.
Click the Protocols tab.
Select TCP/IP, then click Properties. You see the Microsoft TCP/IP Properties window.
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Network Connection with a Switch
A switch with an Ethernet connection to a TCP/IP network can be used to manage other 
switches that are connected to it by Fibre Channel cable.

Figure A–1:  An example of a network connection with a switch

1 Client system, which must be TCP/IP 
network-accessible to the agent 
system.

2 TCP/IP Network.
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3 Agent system with a terminal. It must 
be TCP/IP network-accessible to the 
client systems. It must have access to 
the hubs, switches, and/or tape 
controllers through a TCP/IP network. It 
can be a part of the SAN (Storage Area 
Network).

4 It is a switch.

5 Hardware connected by Fibre Channel 
cables to the switch. 

For a network connection, the SAN 
switch needs to be on the same TCP/IP 
network as the agent system.

6 Fibre Channel cable (optional).
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Network Connection with a Tape Controller

Figure A–2:  An example of a network connection with a tape controller

1 Agent system (server) with a monitor 
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systems and the tape controller. It can 
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3 Client system, which must be TCP/IP 
network-accessible to the agent 
system.

4 Tape controller that is connected to the 
agent system (host) by a TCP/IP 
network. 

5 Tape libraries and/or tape drives. 6 Fibre Channel cable (optional for the 
agent system).

7  Hardware connected to the SAN, such 
as RAID arrays and servers.

8 SAN 
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Network Connection with Master and 
Slave Hubs

Figure A–3:  An example of a network connection with master and slave hubs

1 Client system, which must be TCP/IP 
network-accessible to the agent system.

2 Agent system with a terminal. It must 
have access to the hubs, switches, 
and/or tape controllers through a 
TCP/IP network. It can be a part of the 
SAN.
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3 TCP/IP Network 4 Master hub. This hub must have the 
Compaq Storage Hub 12 Management 
Module (HMM) installed and 
configured. The hub must also have a 
network address.

5 Slave hubs that are connected to the 
master hub by Fibre Channel cables. The 
master hub has the HMM.

6 Fibre channel cable (optional for a 
TCP/IP network connection). If the tape 
controller is not connected to the 
TCP/IP network, the fibre channel 
cable is required.





Appendix B

Installing the Hub Management Utilities Software

Installing the Software
If you plan to use Command Console to manage a Compaq Storage Hub 12, you must 
install Compaq Storage Hub 12 Management Utilities (HMU) software. This software acts 
as a plug-in that allows you to manage your hub from your client system by using the 
Windows-based software. You can order the HMU software from Compaq. 

For the HMU software to work, you must insert the Compaq Storage Hub 12 Management 
Module (HMM) into a slave Storage Hub 12 and configure the HMM. When the HMM is 
inserted and configured, the hub becomes a master hub. HMM provides TCP/IP network 
connectivity to SWCC. For more information on how to install the HMU, refer to the User 
Manual for the Compaq Storage Hub 12 Management Utilities. This manual is shipped 
with the HMU software. 

CAUTION:  You can only install the HMU software on Intel computers running Windows 
NT 4.0 (Intel).
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You will be able to access this software by double clicking on the element ID entry for a 
hub in the Fabric Window. However, you will not be able to access this software right 
away. After you install HMU software, you must do the following to access the HMU 
software: 

1. Install the Client software. If this is a new installation, you must install the Command 
Console Client and the Fibre Channel Interconnect Client. See Chapter 3, Installing 
and Removing the Client.

2. Install the Fibre Channel Interconnect Agent. See Appendix C, Installing, Configuring, 
and Removing the Fibre Channel Interconnect Agent.

3. Add the name of your client system to the Agent’s list of client system entries. See 
Appendix C, Installing, Configuring, and Removing the Fibre Channel Interconnect 
Agent.

4. Add the name of your agent system to the Navigation Tree on your client system (Start 
> Programs > Command Console > StorageWorks Command Console). For more 
information, refer to the Command Console Client online Help.

5. Add a fabric and then add an element to the Fabric Window. For more information, 
refer to the Fabric Window online Help. 



Appendix C

Installing, Configuring, and Removing the Fibre
Channel Interconnect Agent

This appendix contains instructions for installing and removing the Fibre Channel 
Interconnect Agent (SAN Agent) for Windows NT 4.0 (Intel) and for Windows 2000. 
When you install the Fibre Channel Interconnect Client to operate over a network, you 
must also install the Fibre Channel Interconnect Agent. 

The Agent is responsible for establishing communication with the Client and its 
subsystems on the network. The Agent runs in the background as a service on the host 
system. The Fibre Channel Interconnect Agent also provides Web pages, which show the 
status of your hub, switch, and/or tape controller. 

Before You Install the Fibre Channel 
Interconnect Agent

1. Install the Command Console Client and Fibre Channel Interconnect Client. See 
Chapter 3, Installing and Removing the Client.
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2. Verify that you have the SNMP service installed on your computer. You need SNMP 
installed on your computer for this software to work properly. If this service is not 
installed, the Fibre Channel Interconnect Agent is unable to monitor your hubs, 
switches, and/or tape controllers. The SNMP service is available on your Windows NT 
or Windows 2000 installation CD-ROM. To verify that you have the SNMP service:

❏ For Windows NT, double-click Services in Start > Settings > Control Panel. The 
entry for SNMP is shown in this window. If you install the SNMP service and you 
already have a Windows NT service pack on your computer, reinstall the service 
pack after installing the SNMP service.

❏ For Windows 2000, go to Start > Settings > Control Panel > Administrative Tools > 
Component Services. The entry for SNMP is shown in the Component Services 
window. 

3. For Intel computers running Windows NT, verify that you have Windows NT Service 
Pack 4 or 5 (My Computer > Help > About).

4. Verify that you are logged into an account that is a member of the administrator group. 
Perform all installations on Windows NT locally. Do not attempt to install the Agent 
over the network.

5. Read the release notes in the fcinter.txt file for more information on the installation.

Installing the Fibre Channel Interconnect 
Agent

This section describes how to install your Fibre Channel Interconnect Agent from the 
SWCC CD-ROM and from the Web. Install the Fibre Channel Interconnect Agent on only 
one system. You can install the Fibre Channel Interconnect Agent on multiple systems if 
you intend to manage separate collections of Fibre Channel hubs, switches, and tape 
controllers.

Install the Fibre Channel Interconnect Agent on a host that has the following:

■ TCP/IP network connection  to the client systems

■ TCP/IP network connection to the bridges, hubs, and/or tape controllers

1. Do one of the following:

❏ Insert the SWCC CD-ROM into a computer running Windows 2000 or Windows 
NT 4.0 (Intel) with Service Pack 4 or later.
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❏ Download the file that contains the SAN Interconnect Agent from the 
StorageWorks website to a computer running Windows 2000 or Windows NT 4.0 
(Intel) with Service Pack 4 or later. 

2. If you downloaded the file that contains the SAN Interconnect Agent, open Windows 
Explorer and double-click the file you downloaded.

The file self-extracts.

3. Using Microsoft Windows Explorer, double-click Setup.exe in one of the following 
directories:

❏ Top-level directory of the SWCC CD-ROM. 

❏ Top-level directory created from the self-extracted zip file. 

4. Select SAN Interconnect Management under Agent Applications and click Next. 
When you install the Fibre Channel Interconnect Agent (SAN Interconnect 
Management), WebAgent installs automatically, unless you have a previous version of 
WebAgent. The Welcome window appears.

5. Click Next. The software license appears.

6. Click Yes. The default directory is shown: 

C:\program files\Compaq\Swcc\Fibre Agent

7. Click Next. You see a window displaying the polling interval.

8. Type an interval for the Agent to poll each element in the fabric. An element is a hub, 
switch, or tape controller. The default is five minutes; however, you can enter an 
interval from 1 to 60 minutes.

IMPORTANT:  If you want to use the Windows-based software to manage your hubs, switches, 
and tape controllers, you must complete the following steps. If you want to use the Web-based 
software, you must complete another set of steps. Those steps are described in Appendix D, 
Managing Hubs, Switches, and Tape Controllers.

NOTE:  If the installation detects previous configuration files, it displays the StorageWorks 
Command Console Fibre Agent configuration Utility. If necessary, make changes to the 
configuration. To save your changes, click OK. Click Finish to exit the installation.

9. Click Next. The Client List window appears.

10. Type the client system name and select the monitor mode: TCP/IP and/or SNMP or 
none. The notification scheme defines the network protocol that the Agent will use 
when notifying the selected client system of a change in the state in a subsystem. The 
following table lists the client system notification options.
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11. Click Add to add the Client. 

12. Click Finish if satisfied or Back for changes. The program prompts you with the 
message: 

Changes have been made to the Fibre Agent Configuration. The Agent is not currently running. Start the 
Agent now? 

13. Click Yes to run Agent. The Agent is started and the program finishes loading. 

IMPORTANT:  You need the Agent service running to receive status updates on your hubs, 
switches, and/or tape controllers.

14. Click Finish.

15. If you plan to use the Window-based Client, add this system to the Navigation Tree of 
each client system you added to the Agent’s list (File > Add System in the Command 
Console Client). Refer to the Command Console Client online Help.

Using the Agent Configuration Utility
You must use the Fibre Channel Interconnect Agent’s configuration utility to not only 
change the polling interval and enable/disable the Agent startup at system boot, but also to 
stop, start, and restart the Agent. If you want to use the Windows-based Client, you also 
must use the configuration utility to add, modify, and remove client system entries. For 
more information on how to use the Web-based software, see Appendix D, Managing 
Hubs, Switches, and Tape Controllers. Topics in this section include: 

■ Client System Notification Options (Windows-based Client Only)

Table C–1:  Client System Notification Options for Fibre Channel Interconnect 
Client (Windows-Based Software)

Options SWCC Function

Transmission Control 
Protocol/ Internet Protocol

(TCP/IP)

■ Automatically updates the Fabric Window of subsystem changes

■ Required for event logging and pager notification

■ If you do not select TCP/IP, you must refresh the Fabric Window to 
obtain the latest status of a subsystem.

Simple Network 
Management Protocol 
(SNMP)

■ Requires you to use an SNMP-monitoring program to view SNMP 
traps
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■ Adding a Client System Entry (Windows-based Client Only)

■ Modifying a Client System Entry (Windows-based Client Only)

■ Removing a Client System Entry (Windows-based Client Only)

■ Restarting the Agent (Windows-based Client and Web-based software)

■ Changing the Polling Interval (Windows-based Client and Web-based software)

■ Starting and Stopping Agent (Windows-based Client and Web-based software)

■ Disabling and Enabling the Agent Startup at System Boot 
(Windows-based Client and Web-based software)

■ Viewing the SNMP Traps (Windows-based Client and Web-based software)

Adding a Client System Entry (Windows-Based Client Only)

For a client system to receive updates from the Agent, you must add it to the Agent’s list 
of client system entries. The Agent will only send information to client system entries that 
are on this list. 

NOTE:  Put your most important client systems at the top of this list and the client systems that 
are connected infrequently to the network at the bottom. The Agent first contacts the client 
systems that are located at the top of the list.

1. Click Start > Programs > StorageWorks > Fibre Agent Configure. The StorageWorks 
Command Console Fibre Agent Configuration window appears.

2. Click the Clients tab. The Clients window appears.

3. Type the client system’s name. For example, tree.wat.ran.com. 

4. Select the notification scheme:  TCP/IP and/or SNMP or none.

For definitions of the notification options, see Table C–1, Client System Notification 
Options for Fibre Channel Interconnect Client (Windows-Based Software). 

5. Click Add Client to add the client system entry to the Client list.

6. To save your changes: 

❏ If you click Apply, you stay in the configuration program. 

❏ If you click OK, you leave the configuration program.

IMPORTANT:  You must restart the Agent for your changes to take effect.
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Modifying a Client System Entry (Windows-Based Client 
Only)

1. Click Start > Programs > StorageWorks > Fibre Agent Configure. The StorageWorks 
Command Console Fibre Agent Configuration window appears.

2. Click the Clients tab. The Clients window appears.

3. Select the client system entry you want to modify in the Client list.

4. Change the notification scheme to one of the following: TCP/IP and/or SNMP or none.

For a definition of the notification options, see Table C–1, Client System Notification 
Options for Fibre Channel Interconnect Client (Windows-Based Software). 

5. Click Modify Client. 

6. To save your changes: 

❏ If you click Apply, you stay in the configuration program. 

❏ If you click OK, you leave the configuration program.

IMPORTANT:  You must restart the Agent for your changes to take effect.

Deleting a Client System Entry (Windows-Based Client 
Only)

When you delete a client system entry from the Agent’s list, you are instructing the Agent 
to stop sending updates to that client system. 

1. Click Start > Programs > StorageWorks > Fibre Agent Configure. The StorageWorks 
Command Console Fibre Agent Configuration window appears.

2. Click the Clients tab. The Clients window appears.

3. Select the client system entry to delete in the list.

4. Click Delete Client. The client system entry is deleted.

5. To save your changes: 

❏ If you click Apply, you stay in the configuration program. 

❏ If you click OK, you leave the configuration program.

IMPORTANT:  You must restart the Agent for your changes to take effect.
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Changing the Polling Interval

IMPORTANT:  When you change the polling interval of the Agent, the Windows-based Client and 
the Web-based software is affected.

1. Click Start > Programs > StorageWorks > Fibre Agent Configure. The StorageWorks 
Command Console Fibre Agent Configuration window appears.

2. Type an interval for the Agent to poll each element in the fabric. The default is 5 
minutes; however, you can enter an interval from 1 to 60 minutes.

3. To save your change: 

❏ If you click Apply, you stay in the configuration program. 

❏ If you click OK, you leave the configuration program.

IMPORTANT:  You must restart the Agent for your changes to take effect.

Stopping and Starting Agent

The Agent runs as a service in the background. When you stop the Agent, you are 
instructing the software to stop monitoring the hubs, switches, and/or tape controllers that 
were added as elements to the agent system’s Fabric Page and/or Fabric Window. 

1. Verify that the Fabric Windows, pertaining to this agent system, are closed on all of 
your client systems.

2. Click Start > Programs > StorageWorks > Fibre Agent Configure. The StorageWorks 
Command Console Fibre Agent Configuration window appears with the Agent tab on 
top.

3. Click Stop to stop the Agent or click Start to start the Agent.

Disabling and Enabling the Agent Startup at System Boot

By default, the Agent starts at system boot; however, you may want to change this option. 
For example, if you want to check your system, you may not want the Agent to start at 
system boot. 

NOTE:  If you want to disable the Fibre Channel Interconnect Agent startup at system boot, 
change the startup type to manual.
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From Windows NT 4.0

1. Double-click Services in Start > Settings > Control Panel.

2. Double-click SWCC SAN Agent. The Service window appears.

3. Select Manual under Startup Type, and click OK.

From Windows 2000

1. Click Start > Settings > Control Panel > Administrative Tools > Component Services.

2. Under Console Root, select Services (Local).

3. Under Services (Local), right-click SWCC SAN Agent. 

4. From the drop-down menu, select Properties. The SWCC SAN Agent (Local 
Computer) window appears.

5. Under the General tab, select Manual from the Startup Type drop-down menu.

6. Click OK.

Viewing the SNMP Traps

The Fibre Channel Interconnect Agent gathers the SNMP traps and puts them in the 
Application Log of Event Viewer, which resides on its computer and on the client systems 
that it notifies. The events that the Fibre Channel Interconnect Agent collected from Data 
Director and Tape Controller II will be listed under the sources: AsyncEventSvc and 
SWCC SAN Agent. To access Event Viewer:

■ Windows NT 4.0– (Start > Programs > Administrative Tools > Event Viewer) To 
access the Application Log, select Application from the Log menu.

■ Windows 2000 – (Settings > Control Panel > Administrative Tools > Event Viewer) To 
access the Application Log, select Application Log in the Tree panel.

For your client system to receive traps, the Asynchronous Event Service (AES) needs to 
be running on that computer and the agent system must be added to the Navigation Tree. 
For information on how to start AES, see section Stopping or Starting AES:, in Chapter 2.

Removing the Fibre Channel Interconnect 
Agent 

1. Do one of the following: 



Installing, Configuring, and Removing the Fibre Channel Interconnect Agent C–9

❏ On Windows NT 4.0, click Start > Settings > Control Panel, and then double-click 
the Add/Remove Programs icon in the Control Panel. The Add/Remove Program 
Properties window appears.

❏ On Windows 2000, click Start > Settings > Control Panel > Add/Remove 
Programs. The Add/Remove Program window appears.

2. Select StorageWorks SAN Management located in the window.

3. Do one of the following:

❏ On Windows NT 4.0, click Add/Remove. 

❏ On Windows 2000, click Change/Remove.

4. Follow the instructions on the screen. The Agent is removed, but several files are left 
behind.

5. To remove the files left behind, go to the directory that contained the Fibre Channel 
Interconnect Agent, and delete the files listed in the following table. The default is 
C:\Program Files\Compaq\Swcc\Fibre Agent. If you delete these files, you must 
reconfigure the Agent during reinstallation. For a list of the files, see Table C–2, 
Program Files.

CAUTION:  Other Agents use the client.ini and storage.ini file names, but their files are 
in different directories. If you cannot determine which files are for the Fibre Channel 
Interconnect Agent, find the FibreAgent.cfg file. The storage.ini file for the Fibre 
Channel Interconnect Agent is located in the directory referenced by the second line in 
the FibreAgent.cfg file.

Table C–2:  Program Files
File Name File Type

FibreAgent.cfg Contains information on the fabrics and elements

client.ini Contains the list of client system entries

storage.ini Contains the polling interval

fibreagent.db Contains the names and the IP addresses of the hubs, switches, and/or 
tape controllers that have been added to the Fabric Page

sysinfo.agt Contains information about the agent system





Appendix D

Managing Hubs, Switches, and Tape Controllers

This appendix describes how to use SWCC to manage hubs, switches, and tape 
controllers. It includes the following topics:

■ Using the Web-Based Software

■ Using the Windows-Based Client

■ Configuring the Hubs, Switches, and Tape Controllers

The Fabric Page is the Web-based version of the Fabric Window. You add fabrics and 
elements to the Fabric Page, just as you would add them to the Fabric Window. Any 
changes you make in the Fabric Page are reflected in the Fabric Window and vice-versa. 
Table D–1, Comparison Between the Fabric Page and the Fabric Window provides a 
comparison.
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NOTE:  You can use the Fabric Page to monitor your hubs, but you cannot manage them from 
the Fabric Page. You must use the HMU to manage your hubs.

Using the Web-Based Software
The following sections tells you how to use the Web-based software. You can use the 
Web-based software to manage your switches and tape controllers. Use one of the 
supported browsers when accessing the Fabric Page:

❏ Microsoft Internet Explorer version 4.01 or 5 that runs on Intel computers

❏ Netscape Communicator version 4.6 that runs on Tru64 UNIX version 4 or 5

How User Accounts Work

To access the Fabric Page, enter a user name and a password. In this software release you 
are given three predefined user names and passwords. You cannot add, delete, or modify 
the user names. However, you can as administrator, change the passwords of the user 
names. Table D–2, Available User Accounts shows the available accounts.

Table D–1:  Comparison Between the Fabric Page and the Fabric Window
Software Setup Manage Configuration Pages

Fabric Page Web-Based Switches, and 
Tape Controllers

Access configuration pages by clicking 
the element entry

Fabric Window Windows-Based Hubs, Switches, 
and Tape 
Controllers

Access configuration pages by double 
clicking the element entry
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Changing the Password of a User Account

If you have administrative privileges, you can change the password of a user account. To 
change the password, you must access the Account Login page. For more information on 
how to access the Account Login page, see section Accessing the Fabric Page, in this 
appendix.

Accessing the Fabric Page
1. Verify you have installed a supported Web browser. 

2. Open your Web browser, type “http://”, and then the name of the system on which you 
installed the Agent software followed by “:2301”, as shown here:

http://agentsystem.compaqxx.com:2301

Table D–2:  Available User Accounts
Account User Name Password Privileges

User user public ■ Cannot make changes to the Fabric 
Page

■ Can make changes to the 
configuration pages of the 
elements

■ Cannot add, rename, or delete 
fabrics and elements

Operator operator operator ■ Cannot make changes to the Fabric 
Page

■ Can make changes to the 
configuration pages of the 
elements

■ Cannot add, rename, or delete 
fabrics and elements

Administrator administrator administrator ■ Can make changes to the Fabric 
Page and to the configuration 
pages of the elements

■ Can change the password of an 
account

■ Can add, rename, or delete fabrics 
and elements
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You see the Device Home Page.

3. Click Compaq SAN Interconnect Management, as displayed in Figure D–1, Hot link 
for SAN Interconnect Management.

Figure D–1:  Hot link for SAN Interconnect Management

4. You are asked to enter your user name and password on the Account Login page. For 
more information on your user name and password, see section, How User Accounts 
Work, in this appendix.

5. Type your user name and password. Click OK. 

6. The Fabric Page appears.

Viewing the Latest Version of the Fabric Page

Some Web browsers are configured to view an earlier version of a Web page, stored in its 
cache, rather than view the latest version, posted to the Web. To verify your Web browser 
is configured to view the latest version of the Fabric Page:

In Internet Explorer 5.0:

1. Click Tools > Internet Options. The Internet Options window appears.

2. Click Settings on the General tab in the Internet Options window.

3. Select Every visit to the page, and click OK. When the Web browser goes to a Web 
page, the Web browser compares the version of the Web page in its cache with the 
version on the Web and displays the latest version. 

In Netscape Communicator 4.6:

1. Click Edit > Preferences. The Preferences window appears.

2. In the Category field, double-click Advanced. The options expand under Advanced.

3. In the Category field, click cache. The preferences for the cache display.
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4. Select Every time, and click OK. When the Web browser goes to a Web page, the Web 
browser compares the version of the Web page in its cache with the version on the Web 
and displays the latest version. 

Java Disabled in Some Versions of Netscape Communicator

Java must be enabled to view the configuration pages. In some versions of Netscape 
Communicator, Java is disabled. To enable it, select the Enable Java and Enable Java 
Script options in the Advanced Preferences menu of Netscape Communicator (Edit > 
Preference > Advanced). 

Adding Fabrics and Elements

This section describes how to add hubs, switches, and tape controllers to fabrics by using 
the Web-based software. In the software, hubs, switches, and tape controllers are referred 
to as elements. The method of adding fabrics and elements to your Fabric Page is similar 
to adding fabrics and elements to the Fabric Window by using the Windows-based Client 
software. Before you can add an element, you must create a fabric. A fabric is a collection 
of interconnected hubs, switches, and/or tape controllers in the same SAN. 

IMPORTANT:  You must have administrative privileges to add hubs, switches, and tape 
controllers. For more information, see section How User Accounts Work, in this appendix. 
Before you add your hubs, switches, and/or tape controllers by using the Web-based software, 
you must create an IP address for them. You can add a hub to the fabric for monitoring 
purposes; however, you will not be able to manage it by using the Web-based software.

1. Access the Fabric Page. For more information, see section Accessing the Fabric Page, 
in this appendix.

2. Select Add Fabric from the drop-down menu on the left, and click OK.

3. Type a name for your fabric. It can have 1 to 32 characters, but it cannot have spaces 
nor can it have the vertical line. Click Add. 

IMPORTANT:  When you add fabrics and elements to a Fabric Page or to a Fabric Window, 
others who are accessing the same agent system see the fabrics and elements you added in 
their Fabric Page and in their Fabric Window. When you delete or rename a fabric or an element, 
that change also appears in their Fabric Page and in their Fabric Window that corresponds to the 
same agent system.

4. Repeat steps 2 and 3 for each fabric you want to add.
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5. Select Add Element from the drop-down menu on the right, and click OK.

6. Type a name for your element. It can have 1 to 32 characters, but it cannot have spaces 
nor can it have the vertical bar. The name does not have to be its host name; however, it 
is suggested you choose a name that will help you to distinguish it from the other 
elements.  

7. Enter the TCP/IP address of the element you want to add.

8. Click OK.

The element is added to SAN Interconnect Manager. 

9. Repeat steps 5 through 8 for each element you want to add. 

IMPORTANT:  Elements in the same fabric must belong to the same SAN.

NOTE:  You can access the configuration menus for the switches and tape controllers by clicking 
the name of the element, which is hot-spotted.

Renaming Fabrics and Elements

You can rename fabrics and elements within Fabric Page by using the drop-down menus. 

IMPORTANT:  You must have administrative privileges to rename fabrics and elements. For 
more information, see section How User Accounts Work, in this appendix. When you 
rename a fabric or an element, that change will also appear in other Fabric Pages and in other 
Fabric Windows that correspond to the same agent system.

1. Access the Fabric Page. For more information, see section Accessing the Fabric Page, 
in this appendix.

2. Select the Rename option on the drop-down menu that corresponds to the fabric or 
element you want to rename, and click OK.

The software displays a window that tells you to enter a new name.

3. Enter the new name of the element or the fabric. It can have 1 to 32 characters, but it 
cannot have spaces nor can it have the vertical bar. Click OK.

The software displays a window that tells you that the fabric or element has been renamed.

4. Click OK.
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Deleting Fabrics and Elements

You can delete fabrics and elements within the Fabric Page by using 
the drop-down menus. 

IMPORTANT:  When you delete a fabric or an element:
You must have administrative privileges to delete fabrics and elements. For more information, 
see section How User Accounts Work, in this appendix.
That change will also appear in other Fabric Pages and in other Fabric Windows, corresponding 
to the same agent system.
You are instructing the software to stop monitoring the fabric or the element for the 
Windows-based and Web-based version of the software.
When you delete a fabric, you will automatically delete the elements contained in that fabric.

1. Access the Fabric Page. For more information, see section Accessing the Fabric Page, 
in this appendix.

2. Select the Delete option on the drop-down menu that corresponds to the fabric or 
element you want to rename, and click OK.

You are asked if you want to delete the fabric or the element. 

3. If you are certain you want to delete the element or fabric, click OK. You are told that 
the element or fabric has been deleted.

4. Click OK.

Using the Windows-Based Client
The following sections tell you how to use the Windows-based Client software. You can 
use the Windows-based Client software to manage your hubs, switches, and/or tape 
controllers. For more information, refer to the online Help in the Fabric Window.

Accessing the Fabric Window
1. Add the agent system to the Navigation Tree. Click File > Add System in the menu bar 

of the Command Console Client, and follow the instructions on the screen. After you 
add the agent system, an icon for a Fabric Window will be displayed under the folder 
for the agent system. 
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NOTE:  You may receive an error message if you have not added the name of your computer to 
the Agent’s list of client system entries. For more information on how to add a client system 
entry, see Appendix C, Installing, Configuring, and Removing the Fibre Channel 
Interconnect Agent. For more information on troubleshooting, see Chapter 4, 
Troubleshooting Connection Problems and the Command Console Client.

2. Double-click the icon for the Fabric Window.

The Fabric Window appears.

Adding Fabrics and Elements

In this section you will learn how to add hubs, switches, and tape controllers to a fabric by 
using the Windows-based software. In the software, hubs, switches, and tape controllers 
are referred to as elements. Before you can add an element, you must create a fabric. A 
fabric is a collection of interconnected hubs, switches, and/or tape controllers in the same 
SAN. 

IMPORTANT:  You must have administrative privileges to add hubs, switches, and tape 
controllers. For more information, see section How User Accounts Work, in this appendix. 
Before you add your hubs, switches, and/or tape controllers by using the Windows-based 
software, you must create an IP address for them.

1. Access the Fabric Window. For more information, see section Accessing the Fabric 
Page, in this appendix.

2. Click Fabric > Add in the menu bar.

3. Type a name for your fabric. It can have 1 to 32 characters, but it cannot have spaces 
nor can it have the vertical bar. Click OK. If you want to add more than one fabric, 
click Apply.

IMPORTANT:  When you add fabrics and elements to a Fabric Window, others who are 
accessing the same agent system see the fabrics and elements you added in their Fabric 
Window and in their Fabric Page. When you delete or rename a fabric or an element, that 
change also appears in their Fabric Window and Fabric Page that corresponds to the same 
agent system.

4. Repeat steps 2 and 3 for each fabric you want to add.

5. Click Element > Add from the menu bar.
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6. Type a name for your element. It can have 1 to 32 characters, but it cannot have spaces 
nor can it have the vertical bar. The name does not have to be its host name; however, it 
is suggested you choose a name that will help you to distinguish it from the other 
elements.  

7. Enter the TCP/IP address of the element you want to add.

8. Click OK. If you want to add more than one fabric, click Apply.

The element is added to SAN Interconnect Manager. 

9. Repeat steps 5 through 8 for each element you want to add. 

IMPORTANT:  Elements in the same fabric must belong to the same SAN.

NOTE:  You can access the configuration menus for the hubs, switches, and tape controllers by 
double clicking the name of the element.

Renaming Fabrics and Elements

IMPORTANT:  When you rename a fabric or an element, that change also appears in other 
Fabric Pages and in other Fabric Windows that correspond to the same agent system.

1. Access the Fabric Window. For more information, see section Accessing the Fabric 
Page, in this appendix.

2. Do the following:

❏ To rename a fabric, click Fabric > Rename in the menu toolbar. 

❏ To rename an element, click Element > Rename in the menu toolbar. 

3. Enter the new name of the element or the fabric. It can have 1 to 32 characters, but it 
cannot have spaces nor can it have the vertical bar. Click OK.
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Deleting Fabrics and Elements

IMPORTANT:  When you delete a fabric or an element:
That change will also appear in other Fabric Pages and in other Fabric Windows, corresponding 
to the same agent system.
You are instructing the software to stop monitoring the fabric or the element for the 
Windows-based and Web-based version of the software.
When you delete a fabric, you will automatically delete the elements contained in that fabric.

1. Access the Fabric Window. For more information, see section Accessing the Fabric 
Page, in this appendix.

2. Do the following:

❏ To delete a fabric, select Fabric > Delete in the menu toolbar. 

❏ To delete an element, select Element > Delete in the menu toolbar. 

3. If you are certain you want to delete the element or fabric, click Yes. 

4. Click OK.

Configuring the Hubs, Switches, and Tape 
Controllers

You can configure your hubs, switches, and tape controllers from SWCC by accessing 
their configuration pages. These pages can be accessed by:

■ Double clicking the element entry in the Fabric Window 
(Windows-based Client)

■ Clicking the element entry in the Fabric Page 
(This does not apply to the hub.)

Using SWCC to Configure Fibre Channel Tape Controller II

You can access the configuration of Fibre Channel Tape Controller II (FCTC-II) by 
clicking its element ID entry in the Fabric Page or by double clicking its element ID entry 
in the Fabric Window. You can obtain information, such as the following, when you access 
the tape controller’s configuration: 

■ Baud rate of the serial port

■ Fibre Channel address
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■ SCSI initiator and target IDs

■ Ethernet IP and MAC addresses

■ Fibre Channel-to-SCSI mapping

■ SCSI-to-Fibre Channel mapping

■  Trace level settings

CAUTION:  If you change the tape controller’s IP address and you have already added 
the tape controller to a fabric, you must delete the old entry and then add the tape 
controller with the new IP address to the fabric. You must do this because SWCC 
contacts the tape controller by its IP address. If you change the tape controller’s IP 
address, SWCC will be unable to find the tape controller. You should also alert others, 
who have this tape controller added to a fabric, of its new IP address.

NOTE:  For more information on how to configure FCTC-II, refer to its documentation.

Using SWCC to Configure the Hub

You can access the hub’s configuration by double clicking its element ID entry in the 
Fabric Window. You can obtain information, such as the following, when you access the 
hub’s configuration: 

■ Device Description

■ Device Model Number

■ Device Serial Number

■ HMM Board Identifier

■ Agent Board Serial number

■ Hub Board Serial Number

■ Device Location

■ Contact Name

For more information, refer to the online Help in the Fabric Window.
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Using SWCC to Configure the Switch

You can access the SAN switch’s configuration by clicking its element ID entry in the 
Fabric Page or by double clicking its element ID entry in the Fabric Window. You can 
obtain information, such as the following, when you access the switch’s configuration: 

■ LED Status Information

■ Port Information

■ Switch Information

■ Administration

■ Performance View

■ Temperature

■ Fans

For more information, refer to the online Help in the Fabric Window.

IMPORTANT:  Before you can access the configuration pages for the Compaq StorageWorks 
FC-AL Switch, you must configure your Web browser. For more information, see Appendix E, 
Configuring the Web Browser for the Compaq StorageWorks FC-AL Switch.



Appendix E

Configuring the Web Browser for the Compaq
StorageWorks FC-AL Switch

This appendix describes how to configure your Web browser so you can view the 
configuration pages for the Compaq StorageWorks FC-AL Switch.

IMPORTANT:  Before you configure your browser, the Compaq StorageWorks FC-AL Switch 
must have the following:
An IP address
A subnet mask
Default gateway address
Its IP address mapped to a Fully Qualified Domain Name (FQDN) (Recommended)
For more information, see section Configuring the Compaq StorageWorks FC-AL 
Switch for the Web Interface, in this chapter.
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Configuring the Compaq StorageWorks 
FC-AL Switch for the Web Interface

This section tells you how to configure setup your Compaq StorageWorks FC-AL Switch 
for the Web interface. The following topics are covered:

■ Assigning an IP address

■ Assigning a subnet mask

■ Assigning a gateway for access to the Web interface

■ About Mapping the Switch’s IP Address to an FQDN

First connect to the serial interface of the switch by using a program, such as 
HyperTerminal on Windows. The default terminal settings are the following:

■ 38400 baud rate 

■ Data bits 8

■ No parity

■ Stop bits 1

■ No flow control  
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When you connect, the following appears (Press <CR> for the Boot Menu.):

Powering up switch...

Press <CR> for Boot Menu, Agent Code within 5 seconds

Boot Menu Version 01.00-G01

1. Switch IP address [current = 127.0.0.1]

2. Switch subnetworking mask [current = 0.0.0.0]

3. Switch default gateway address [current = 0.0.0.0]

4. TFTP server IP address [current = 0.0.0.0]

5. TFTP filename [current = ]

6. TFTP initial number of retries [current = 5]

7. TFTP initial timeout [current = 5000ms]

8. TFTP data transfer number of retries [current = 5]

9. TFTP data transfer timeout [current = 5000ms]

T. TFTP force download [current = no]

B. Boot filename [current = ]

D. load Default system parameters

E. Exit menu and continue operation

command>

Assigning an IP Address
1. Connect to the switch by using a program, such as HyperTerminal on Windows. Press 

<CR> for the Boot Menu. 

2. Enter 1.

3. Enter the switch’s new IP address.

Assigning a Subnet Mask
1. Connect to the switch by using a program, such as HyperTerminal on Windows. Press 

<CR> for the Boot Menu. 

2. Enter 2.
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3. Enter the switch’s new subnetworking mask.

Assigning a Gateway for Access to the Web Interface from a 
Different Network

1. Connect to the switch by using a program, such as HyperTerminal on Windows. Press 
<CR> for the Boot Menu. 

2. Enter 3.

3. Enter the switch’s new default gateway address.

About Mapping the Switch’s IP Address to an FQDN

Map the switch’s IP address to a valid Fully Qualified Domain Name (FQDN) in the DNS 
server used by the Web browser host. This is needed to work around a bug that appears in 
some older versions of Microsoft Internet Explorer Java Virtual Machine. Contact your 
network administrator to set this up. 

For example: 192.168.13.13 should resolve to myswitch.mycompanyxxxx.com 

Where 191.168.13.13 is the switch’s IP address, and myswitch.mycompanyxxxx.com is 
the FQDN. 

Configuring Netscape Communicator
1. Verify that the Java support is enabled by selecting Edit > Preferences. 

2. Click the Advanced Section and select Enable Java and Enable Java Script.

3. If you have problems viewing the configuration pages, use the Java Console to 
troubleshoot your problem. To view the Java Console, click Communicator > Tools > 
Java Console 

Configuring Microsoft Internet Explorer
Before you can use Microsoft Internet Explorer to view the configuration pages, you must 
configure it.
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How to Verify Whether JVM Is Installed

Microsoft  JVM is an optional component of Microsoft Internet Explorer version 5.x, 
unlike version 4.x, which had it installed by default.

1. Open Microsoft Internet Explorer.

2. Select Tools > Internet Options. You see the Internet Options window.

3. Click the Advanced tab.

4. Scroll down to find the “Java VM” section as shown in the following figure.

Table E–1:  Configuring Microsoft Internet Explorer for the Compaq 
StorageWorks FC-AL Switch

Step Description

1 Verify that the switch IP address maps to an FQDN on DNS. See section About 
Mapping the Switch’s IP Address to an FQDN, in this appendix.

2 Verify that Java Virtual Machine (JVM) is installed. See section How to Verify 
Whether JVM Is Installed, in this appendix.

3 If JVM is not installed, install it. See section Installing JVM, in this appendix.

4 Add the switch IP address/host name to trusted sites on Microsoft Internet Explorer. 
See section Adding the Switch’s IP Address/Host Name to Trusted 
Sites, in this appendix.

5 Verify that unsigned applets are able to access the network. See section Enabling 
Unsigned Apples to Access the Network, in this appendix.

6 Enable Java Console and Logging. See section Enabling Java Console and 
Logging, in this appendix.
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Figure E–1:  Verifying whether you have Java VM

NOTE:  If Java VM is missing, JVM is not installed. See section Installing JVM, in this 
appendix. 

Installing JVM
1. Go to the Microsoft Windows Update website:

http://www.microsoft.com/windowsupdate

2. Click the link, Product Updates. You are asked if you want to install and run Microsoft 
Active Setup.
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3. Click Yes. Microsoft Active Setup scans your hard drive to determine the software 
updates available.

After Microsoft Active Setup scans your hard drive, you see a list of software updates that 
are available for your version of windows. 

4. Select Microsoft virtual machine.

5. Click Start Download. JVM is installed on your computer.

6. Restart the computer.

NOTE:  If you have problems with the Windows update, contact your system administrator or go 
to http://www.microsoft.com.

Adding the Switch’s IP Address/Host Name to Trusted Sites
1. Open Microsoft Internet Explorer.

2. Select Tools > Internet Options. You see the Internet Options window.

3. Click the Security tab. 

4. Click the Trusted Sites icon, 

5. Click Sites. You see the Trusted Sites window.

6. Add the switch’s hostname (FQDN) to the trusted sites list.

Enabling Unsigned Apples to Access the Network
1. Open Microsoft Internet Explorer.

2. Select Tools > Internet Options. You see the Internet Options window.

3. Click the Security tab. 

4. Click the Trusted Sites icon, .

5. Click Custom Level. You see the Security Settings window.

6.  Scroll down to find the “Java VM” section.

7. Set the Java permissions to custom, as shown in the following figure. When you select 
custom, the software displays the Java Custom Settings button.
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Figure E–2:  Setting Java permissions to custom

8. Click Java Custom Settings. You see the Trusted Sites window. 

9. Click the Edit Permissions tab.

10. Ensure “Run in sandbox” is selected under “Run Unsigned content.”

11. Under “Unsigned Content” scroll down to the “Access to all Network Addresses” 
section and set it to “Enable.” 
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Figure E–3:  Setting the permissions

12. Click OK.

13. Restart Microsoft Internet Explorer before accessing the SAN Interconnect software.

Enabling Java Console and Logging
1. Open Microsoft Internet Explorer.

2. Select Tools > Internet Options. You see the Internet Options window.

3. Click the Advance tab.

4. Select the following:

❏ Java console enabled
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❏ Java logging enabled

❏ JIT compiler for virtual machine enabled (requires restart)

5. Click OK.

6. To view the Java console, click View > Java Console.

Logging into the Configuration Pages for 
the Compaq StorageWorks FC-AL Switch

When you click the element entry for the Compaq StorageWorks FC-AL Switch, you are 
asked to enter a user name and password. Enter the user name and password that you 
would use for console/telnet. 

After you enter your username and password, the software asks for the SNMP read/write 
community strings to access the switch. If you only want to view the configuration and 
passively monitor the switch, the read community string is all you need. If you intend to 
change the switch configuration, the read and the write community strings are required.

If you had started the configuration pages for the Compaq StorageWorks FC-AL Switch 
with only the read community string, but want to be able to change the switch’s 
configuration:

1. Click the Chassis tab, then click the Network Settings tab.  

2. Enter the write community string and click the Set button. Use the same procedure for 
correcting an incorrect write community string.

If you entered a wrong read community string, close and then reopen the Web browser.

Accessing the Configuration Pages for the 
Compaq StorageWorks FC-AL Switch 
Through Firewalls

The network administrator should configure your firewall to allow access to the following 
ports of the switch’s IP address:

■ 80/TCP (HTTP)

■ 161/UDP (SNMP)



Glossary

This glossary defines terms used in this guide or related to this product and is not a 
comprehensive glossary of computer terms.

agent system

Computer that has the Fibre Channel Interconnect Agent installed

Asynchronous Event Service (AES)

AES, which runs in the background as a service, collects and passes all traps from the 
subsystems to the appropriate Navigation Trees and individual pagers. AES needs to be 
running for your client system to receive updates.

client system

A computer that has one of the following:

■ The Windows-based Client software installed

■ A Web browser that can view the status of the fibre channel devices

StorageWorks Command Console (SWCC) refers to the overall program

Command Console Client

Provides event notification and the Navigation Tree

Compaq Storage Hub 12 Management Utilities (HMU) 

Add-in for SWCC. This software allows you to manage your hubs from your client 
system. It can only be installed on Intel computers. You can obtain this software by 
ordering it separately.
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Compaq Storage Hub 12 Management Module (HMM)

A hub with HMM is called a master hub, and a hub without HMM is called a slave hub. 
HMM provides TCP/IP network connectivity to SWCC.

device

Refers to a hub, switch, or tape controller.

element

An element is hardware that makes up a fabric. It can be a hub, switch, or tape controller.

fabric

A collection of interconnected hubs, switches, and/or tape controllers that are in the same 
SAN.

Fabric Page

Displays the status of your fabrics in the Web-based software. Used to monitor your hubs,  
switches, and tape controllers; however, you can use it to manage your switches and tape 
controllers.

Fabric Window

Displays the status of your fabrics in the Windows-based Client software. Used to manage 
your hubs, switches, and tape controllers.

Fibre Channel Interconnect Agent (SAN Interconnect Agent) 

■ Collects data from the hubs, switches, and tape controllers. It then passes the 
information along to the Windows-based Client software and to the  pages.

■ Enables the Client to communicate with your hubs, switches, and tape controllers.

Fibre Channel Interconnect Client

■ Works with the Command Console Client 

■ Provides the Fabric Window
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Navigation Tree

■ Provides access to the Fabric Window

■ Shows the status of your storage systems. It displays your systems in a hierarchical 
order.

Navigation Window

Contains the Navigation Tree

subsystem for Fibre Channel Interconnect 

A list of fabrics in a SAN. It is comprised of hubs, switches, and/or tape controllers.
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