
Installation Guide
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Intel® Server Control
Order Number: 747116-007

This guide explains how to install and launch the Intel® Server Control (ISC) software.  ISC is a
server management tool that provides real time monitoring and alerting for server hardware,
emergency remote management, and remote server setup.  It is implemented using a client-server
architecture.
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System Requirements

ISC contains two parts:

• ISC Console Software
• ISC Server Instrumentation Software

ISC Console Software allows interaction with the managed server.  It can be installed on these
system configurations:

• Windows NT† 4.0 server or workstation, Enterprise Edition
• Windows† 98 Second Edition workstation
• Windows 2000 workstation

ISC Server Instrumentation Software, when installed, creates a managed server that can be
managed from the system running ISC Console Software.  It can be installed on these systems:

• Windows NT 4.0 server
• Windows 2000 server
• NetWare† server
• UnixWare† server
• Linux† 6.2 server

Managed Server Requirements
ISC supports several Intel® motherboards.  For a complete list of supported server motherboards
and qualified BIOS revision levels, see the ISC release note files (ENUREADME.TXT and
ENUERRATA.TXT).  The following requirements must be met for a managed server.

Windows 2000/NT Requirements
• Windows 2000, NT Server 4.0 (SP 5), or Enterprise Edition
• 64 MB of RAM
• 60 MB of available disk space
• Windows NT SNMP or SNMP service installed (required only for connectivity to an SNMP

management console)

NetWare Requirements
• NetWare 4.2 or 5.0 symmetric multiprocessing (SMP)
• At least 32 MB of RAM
• At least 60 MB of available disk space
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Red Hat Linux Requirements

If you intend to manage a Linux file server, it must meet the following minimum requirements:

• Red Hat Linux 6.2 running in multiple-processor kernel
• 32 MB of RAM
• 60 MB of available disk space

SCO† UnixWare Requirements

If you intend to manage a UnixWare file server, you must have an account with root privileges
available to you.  The server must also meet the following minimum requirements:

• SCO UnixWare 7.1
• 32 MB of RAM
• 60 MB of available disk space

Additional Requirements for DMI-SNMP Translation

Simple Network Management Protocol (SNMP) support must be installed if you want to integrate
ISC with an SNMP-based management framework.  For SNMP installation information, see your
Windows NT, NetWare, or UnixWare documentation.

On the managed server, you should consider the following issues when configuring SNMP:

• Community string names for SNMP Get and Set operations
• Community string names for sending traps
• The destination address for the management console receiving the traps

On the management console, you should consider the following issues when configuring SNMP:

• Compiling the MIBs into the SNMP management consoles
• Integration of ISC traps into SNMP management consoles

Console Requirements
Console System requirements may change when snapping into one of the supported management
applications.  Please refer to their installation requirements for additional information.

ISC Console Software integrates into an Enterprise System Management Console or it can be
installed on a stand-alone console.  The required Enterprise System Management Consoles are:

1. Intel® LANDesk® Server Management 6.xx
2. HP OpenView† Network Node Manager 6 for Windows NT
3. CA UnicenterTNG† 2.2 for Windows NT

A stand-alone console manages ISC-enabled servers without Enterprise System Management.  It is
implemented as an ActiveX† control that runs within its own container or third party container
application (e.g., Microsoft† Management Console, Internet Explorer† v3.02 or later, or Netscape
Navigator† v3.0 or later with ActiveX snap-in). You can choose the stand-alone environment
during setup.  If you do not choose the stand-alone environment and no management console is
present, the ISC software will not install.
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Windows 98 Second Edition
• Intel® Pentium® microprocessor or higher.
• At least 32 MB of RAM.
• At least 10 MB of available disk space.
• Microsoft Windows compatible modem must be used for if you connect to the server by

modem.

Windows 2000/NT
• Windows 2000/NT Server, or Workstation 4.0 (SP 5), or Enterprise Edition.
• Intel Pentium microprocessor or higher.
• At least 64 MB of RAM.
• At least 10 MB of available disk space.
• For Windows NT, Remote Access Service must also be installed. If it is not installed the Direct

Platform Control (DPC) component will not install.
• Microsoft Windows compatible modem must be used for if you connect to the server by

modem.
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Installing ISC

Managed Server Preparation
ISC uses the event-logging feature of the BIOS for system management status and information.  To
enable this feature for each server to be managed with ISC, you must boot the server(s) using the
System Configuration Utility (SCU) or System Setup Utility (SSU) and set the appropriate options
under System Management Options.  For motherboard-specific settings and values, see the ISC
release note files (ENUREADME.TXT and ENUERRATA.TXT).

✏ NOTE

It is possible to configure temperature and voltage thresholds on the server
system using the SCU or SSU.  However, the thresholds set with the SCU or
SSU are in effect only for a short time during the system boot process.  PIC
overwrites these thresholds when the OS loads.  It is recommended that all
threshold changes be made using Platform Instrumentation Control (PIC).

Compatibility and Upgrade Issues
The following paragraphs describe compatibility and upgrade issues for:

• LSC and LDSM
• Networks
• Windows NT
• Window 98 Second Edition
• Red Hat Linux

LSC and LDSM

If you have earlier versions of LSC or LDSM on your network, be aware of the following:

• Versions of LSC integrated with LDSM (e.g., LDSM with LSC55) are not supported
under ISC.

• The ISC-managed server installation will not upgrade the DMI service provider or any DMI
database that is already installed on the managed server.  However, if a service provider is not
found, ISC installs a DMI 2.0 service provider.

• The ISC server installation process installs the remote procedure call (RPC) transports (DCE
and ONC) if they are not available on the managed server.

• ISC ships with the DMI 2.0s Service Provider for Windows NT.  The 2.0s version is an
extension of the Service Provider that supports security.  ISC does not use those features, but
they are available under Windows NT for possible use by other DMI 2.0s-compliant software.
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NetWare

For installation on systems using NetWare, be aware of the following:

• Connect as a user with supervisor rights when installing ISC to a NetWare server.
• All NetWare servers require two manual reboots following the ISC installation.
• The TiRPC runtime library for ONC RPC or a substitute file set for NetWare5x must be

running.

Windows NT

For installation on systems using Windows NT, be aware of the following:

• Connect as a user with supervisor rights when installing ISC to a Windows NT server.
• The ISC installation program automatically reboots both remote and local servers as necessary.
• Remote Access Service (RAS) must be previously be installed on the console for if you are

installing the ISC Direct Platform Control (DPC) and/or Client System Setup Utility (SSU)
component.

Windows 98 Second Edition

For installation on systems using Windows 98 Second Edition, be aware of the following:

• A manual reboot is required following the ISC installation.
• Remote Registry must be previously installed on the console.

UnixWare

For installation on systems using UnixWare, be aware of the following:

• Connect as root user when installing ISC to a UnixWare server.
• A plain text password must be enabled in the registry.  If the password is not enabled, an extra

reboot following ISC installation will be required on each UnixWare server.
• Vision FS must be installed, configured, and running.
• A manual reboot is required for each server following the ISC installation.
• The server automatically reboots following ISC installation.

Red Hat Linux

For installation on systems using Red Hat Linux, be aware of the following:

• Remote ISC installation is not available.
• Additional steps are required to configure the Linux DMI service provider.
• Additional steps are required to configure the SNMP-DMI mapper.
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LSC, LDSM, Windows, NetWare, and UnixWare
Installation

The ISC package contains both the console and instrumentation software.  To install, launch
ISCsetup.exe if it is downloaded from the web or Launch Binaries\Setup.exe if it is from a
CD-ROM.  Remote installation for server instrumentation software is supported for
Windows 2000/NT or Novel server.  The console software installation can only be installed
locally.  Select all the server(s) to be installed and follow the instruction on the screen to continue.
After the installation is completed, reboot the server to complete the installation:
• Each Windows 2000/NT server automatically reboots.
• Each NetWare or UnixWare server requires manual reboot.

1. Login with system administrator access.
2. Verify the HP OpenView is not running.
3. Do steps 4 and 5 then skip step 6 if you are installing from the Software Kit CD.  Skip to step 6

if you are installing from a download from the web.
4. At the console, insert the Software Kit CD into the CD ROM reader.
5. Run the program x:\binaries\setup.exe, where x in the drive letter of your CD ROM reader.
6. Run the program ISCsetup.exe from the ISC download directory.
7. Note this installation may require multiple server reboots.

When installation is complete, view the file logfile in the install directory of each server and
console to verify that ISC installed correctly.

Red Hat Linux Installation
There are three steps to Red Hat Linux installation process:

• Installing Linux DMI server provider
• Installing ISC
• Configuring the SNMP_DMI mapper

Installing Linux DMI Service Provider
1. Insert the Software Kit CD into the console CD ROM reader.
2. Connect to the directory \isc\LinuxDMI.
3. Open an ftp session to the Linux server.
4. Change the mode to binary.
5. Copy the file dmisp-1.0-4.i386.rpm to a temporary directory on the server.
6. Close the ftp session.
7. Login as root on the server.
8. Uninstall ucd-snmp if it has been installed previously.  Also remove all related snmp packages

and all related dmi packages.  Remove the packages in a suitable order to eliminate error
messages about dependencies.  If a dependency error messages appears, remove the dependent
package.  Continue removing the dependent package until error messages stop.

9. Enter the command <temp directory>/rpm –i dmisp-1.0-4.i386.rpm  and press
<Enter>.

10. Follow the instruction on your screen.
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11. Reboot the Linux server when the command completes.
12. Repeat steps 5 through 9 for the files:

ucd-snmp-4.1.1-13smux.i386.rpm
ucd-snmp-utils-4.1.1-13smux.i386.rpm
dmi2snmp-1.0-13.i386.rpm

Installing ISC Server Instrumentation
1. Insert the Software Kit CD into the console CD ROM reader.
2. Connect to the directory \isc\Linux.
3. Open an ftp session to the Linux server.
4. Change the mode to binary.
5. Copy the file ISC-2.4-1.i386.rpm to a temporary directory on the server.
6. Close the ftp session.
7. Login as root on the server.
8. Enter the command <temp directory>/rpm –I <temp directory>/ISC-2.4-1.i386  and

press <Enter>.
9. Following the instructions on your screen.
10. Reboot the Linux server when the command completes.

Configuring the SNMP–DMI Mapper

These steps must be completed if any SNMP management console (HP OpenView, CA UniCenter)
will manage the Linux server.

1. Verify that the dmi2snmp-1.0-13.i386.rpm and ucd-snmp-4.0.1-13smux.i386.rpm are installed.
2. Open the file /etc/snmp/snmpd.conf.
3. Add a trapsink line at the end of the file for each management console that receives traps from

the managed server.  The trapsink line syntax is:
trapsink <myhost-name.domain.com>.
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Customizing NetWare Servers After Setup

While installing PIC, the configuration and Setup program installs Adaptec and LSI (Symbios)
SCSI, and Intel® LAN Adapter instrumentation on the NetWare server but does not enable the
instrumentation support.

To enable support for any or all instrumentation, you must edit the AUTOEXEC.NCF file in the
SYS:SYSTEM directory as follows:

Add the line:

rpsstart.ncf

before the line:

isc_on.ncf

To enable the Adaptec SCSI instrumentation, remove the word REM from these lines:

REM load simcinw.nlm

REM load simcinw.nlm

To enable the Intel LAN Adapter instrumentation, remove the word REM from this line:

REM load e100bdmi.nlm /auto

To enable the LSI (Symbios) SCSI instrumentation, remove the word REM from this line:

REM load simcinw.nlm
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Launching ISC

ISC can be launched from and can manage your server from one of these enterprise management
environments:
• LANDesk Server Manager (LDSM)
• HP Network Node Manager
• CA-Unicenter TNG

Once the ISC application is launched from an enterprise management console, the management
console application can terminate, and ISC will continue to operate normally.

ISC can be launched from and can manage your server from a stand-alone ISC Console.  The ISC
Console can run as an executable program, as an ActiveX control within an Internet browser, or
within Microsoft Management Console.

LANDesk® Server Manager
The LANDesk Server Manager (LDSM) console dynamically builds its feature set when
communication is established with a managed server.  If the managed server is running the ISC, the
LDSM console adds an option for “Intel Server Control” in the Tools branch of the LDSM
navigation tree.  Select this option to launch ISC.

HP Network Node Manager
The HP Network Node Manager Console autodetects servers running the ISC Server
Instrumentation software.  The Console updates the server bitmap with an ISC server icon for those
servers.

To launch the ISC applet, select an ISC-enabled server on the HP Console network map, and then
select the "Intel Server Control Applet" option from the Tools Menu.  Alternatively, you can launch
ISC by selecting an ISC-enabled server on the HP console network map, clicking the right mouse
button, and then selecting the "Intel Server Control" option from the popup menu.

CA-Unicenter TNG
The CA-Unicenter TNG Console autodetects servers running the ISC Server Instrumentation
software if you have enabled the ISC to CA discovery service.  To enable discovery, you must start
the "Intel Tng-ISC AutoDiscovery" service.  You can start this service from either the TNG
Unicenter "Auto Discovery" dialog or from the Windows NT "Services" applet.

The "Intel Tng-ISC AutoDiscovery" service creates a new "Intel Server Control" TNG object for
each server having the ISC Server Instrumentation software.  That TNG object displays on the map
as a child of the "ISC World View" and as a child of the ISC-enabled server.  You can view all
ISC-enabled servers under the "ISC World View."

To launch ISC, right-click on a "Intel Server Control" icon, and select the “Launch ISC" option
from the popup menu.
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Stand-alone ISC Console
Use the stand-alone ISC Console to manage ISC-enabled servers without installing an enterprise
management console application.  The environment is implemented as an executable program; as
an application within Microsoft Management Console; or as an ActiveX control that runs within a
“container” application, such as Microsoft Internet Explorer, versions 4.0 or 5.0, or Netscape
Navigator, version 3.0 or 4.0.

To launch the stand-alone ISC Console in its own container, do the following:

1. Click Start, and then point to Programs.
2. Point to Intel Server Control Tool, and then point to Intel Server Control.
3. From the Start Menu in Windows, select Start->Programs->Intel Server Control Tools->Intel

Server Control.

Launching the ISC Console with Internet Browsers

To launch the stand-alone ISC Console within a Web browser, do the following:

1. Run the Internet Browser to be used as a “container” for the ISC Console
2. Within the browser, choose File->Open.
3. Enter the ISC Console filename, specifying the full path to the file:

%ISCPATH%\MI\EMC\IC\ISC.HTM

The stand-alone ISC Console will be started as the active application within the default Web
browser.

Once the ISC Console is loaded, the location can be saved as a “Bookmark” (Netscape) or a
“Favorite” (Internet Explorer) for easy access in later sessions.

You may also:

1. Locate the file using Windows Explorer, specifying the path:
%ISCPATH%\MI\EMC\IC\ISC.HTM

2. Double-click on the filename to launch the control within the default Web browser

✏ NOTE

Netscape Navigator requires a plug-in for viewing ActiveX applications.
One that is known to work is ScriptActive†, which available from Ncompass
Labs, Inc. (see http://www.ncompasslabs.com).
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Launching the ISC Console with Microsoft Management Console

To launch the stand-alone ISC Console within Microsoft Management Console (MMC), do the
following:

1. From a Start Menu in Windows or from the Start->Run selection, run MMC.
2. Within MMC, choose File->Open.
3. Enter the ISC Console filename, specifying the full path to the file:

%ISCPATH%\MI\EMC\IC\ISC.MSC

The ISC stand-alone application will be started as the active application within MMC.  You may
also:

1. Locate the file using Windows Explorer, specifying the path:
%ISCPATH%\MI\EMC\IC\ISC.MSC

2. Double-click on the filename to launch the control within MMC.

✏ NOTE

If you have not installed MMC on your console system, you can obtain it from Microsoft at
http://www.microsoft.com/management/mmc/
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