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Chapter 1. Getting Started

This chapter describes the documents you received with your RAID Controllers and how 
to use them.

About this User’s Handbook

This User’s Handbook provides the information necessary to set up, monitor, tune, and 
repair your RAID Controllers using the storage management software. It is divided into 7 
chapters and an appendix.

• "Chapter 1. Getting Started" provides an overview of the chapters contained in this 
book as well as descriptions of other companion documentation.

• "Chapter 2. Storage Management Software Overview" describes the storage 
management software, defines key terms used throughout this book, describes the 
different hardware configurations supported by the software, describes the types of 
component failures that may occur, and lists the routine tasks you need to perform to 
manage the RAID Controllers.

• "Chapter 3. Common Application Features" describes the software features common to 
all applications.

• "Chapter 4. Configuring RAID Controllers" describes how to configure the drives in 
the RAID Controllers into logical units (LUNs) and hot spares.

• "Chapter 5. Checking Status" describes how to check the status and performance of the 
RAID Controllers.

• "Chapter 6. Recovery" describes how to recover after device failures. These failures 
may involve drives, controllers, fans, and power supplies. In some cases, you also need 
the information found in the hardware manuals accompanying the RAID Controllers 
for specifics on how to do the physical tasks required in the recovery process.

• "Chapter 7. Maintenance and Tuning" describes the routine maintenance and tuning 
RAID Controllers.

• "Appendix A. Command Line Interface" describes the command line interface to the 
RAID Controllers.

• "Appendix B. Notices" lists warranty provisions and legal notices.
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About the Installation and User’s Handbook

In addition to this book, you also received an Installation and User’s Handbook for the 
particular operating system you are using to access the RAID Controllers. 

The Installation and User’s Handbook contains:

• The installation procedure for installing the storage management software on that 
operating system.

• Special restrictions on the use of the storage management software on that operating 
system.

• Troubleshooting information for the storage management software.

• Other notes on how the storage management software runs in that specific operating 
system environment.

You must refer to the Installation and User’s Handbook for installation instructions before 
doing anything else on the RAID Controllers as described in this book.

About the Hardware Handbook

Along with your RAID Controllers, you received one or more hardware books describing 
how to install the RAID hardware and replace hardware components. These hardware 
handbooks also contain information on troubleshooting the modules and determining 
which components have failed.

You may need these hardware handbooks to supplement the recovery information given 
here. They cover the physical replacement of the hardware components. The software 
procedures given in this User’s Handbook work hand in hand with the hardware 
procedures given in the hardware books.

Always follow the software recovery procedures given in this User’s Handbook, if any, 
when replacing a hardware component. Use the hardware books, if necessary, at the 
appropriate time to find how the physical replacement is performed.

About Software Installation

The software installation procedure is given in the Installation and User’s Handbook that 
you received along with this book. This Handbook is specific to the operating system you 
are using. Refer to the Installation and User’s Handbook for complete information on 
installation, then return to this User’s Handbook for information on how to run the 
installed software.
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What to Do Next

To set up and run the storage management software and the RAID Controllers, you need to 
perform the following steps:

1. Install the RAID Controller hardware, using the information given in the hardware 
handbooks.

2. Install the storage management software, using the information in the Installation and 
User’s Handbook.

3. If necessary, read "Chapter 2. Storage Management Software Overview" to become 
acquainted with the storage management software. Be sure to read the task summary 
list in that chapter for a description of the routine tasks you need to perform to manage 
the RAID Controllers.

4. If necessary, read "Chapter 3. Common Application Features" to familiarize yourself 
with the common program features.

5. Go to "Chapter 4. Configuring RAID Controllers" to configure the RAID Controllers 
into logical units and hot spares, according to your system needs.
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Chapter 2. Storage Management Software Overview

This chapter defines the terms used by the storage management software, describes 
supported hardware configurations, describes component failures, and lists the tasks you 
must perform to maintain the RAID Controllers.

Common Definitions

This section describes the concepts used by the storage management software. You will 
need to understand these concepts to use your RAID Controllers effectively.

Cache Memory

Cache memory is memory on the controller used for intermediate storage of read and write 
data. By using cache, you can increase system performance because the data for a read 
from the host may already be in the cache from a previous operation (thus eliminating the 
need to access the drive itself), and a write operation is completed once it is written to the 
cache, rather than to the drives.

When you create a logical unit, you can specify various caching parameters for the LUNs. 
If you need to change any caching parameters after LUN creation, use the Maintenance 
and Tuning Application (see "Changing Cache Parameters" on page 121).

The following cache options are available through the storage management software. You 
can enable these options when creating LUNs using the Configuration Application or later 
using the Maintenance and Tuning Application.

• Write Caching — Allows write operations from the host to be stored in the controller’s 
cache memory. The use of write caching increases overall performance because a write 
operation from the host is completed when data is put in the cache, instead of when the 
data is actually written to the drive itself.

• Write Cache Mirroring — Allows cached data to be mirrored across two redundant 
controllers with the same cache size. The data written to the cache memory of one 
controller is also written to the cache memory of the other controller. Therefore, if one 
controller fails, the other can complete all outstanding write operations.

• Cache Without Batteries — Allows write caching to continue even if the batteries are 
discharged completely, not fully charged, or if there are no batteries present. If you 
select this option without a UPS for protection, you could lose data if power fails.
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You can change other cache options using the rdacutil utility. See "Appendix A. Command 
Line Interface." 

Device Name

The storage management software uses device names to identify the controllers and 
logical units in the RAID Controller. You use these names in the storage management 
software applications to access the logical units and controllers. In some operating 
systems, you can assign a name to these items.

Device names are determined by the location of the subsystem hardware and vary 
according to the operating system you are using. For example, most UNIX operating 
systems use a cXtXdXsX scheme, the Windows NT operating system uses a driveX 
scheme, and the Networked version uses an eight character scheme defined during 
installation. 

See your Installation and User’s Handbook for more information on the device names 
used by your operating system.

Drive Group

A drive group is a physical set of drives in the RAID Controller. There are three types of 
drive groups:

• Unassigned drive group — the drives in the RAID Controller that have not been 
configured into logical units or hot spares. This drive group is only displayed in the 
Configuration Application.

• Hot spare drive group — drives that have been assigned as hot spares. This drive group 
is only displayed in the Configuration Application.

• Configured drive group — drives that have been configured into one or more logical 
units with the same RAID Level. A configured drive group is created the first time you 
create a logical unit on the selected drives. Each configured drive group is designated 
with a number. These drive groups are displayed by number in all applications. See the 
next section for a discussion of how drive groups are numbered.
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Figure 1 shows a 10-drive tray organized into drive groups and LUNs.

Figure 1.  Drive Groups and Logical Units (LUNs)

Drive Group Numbering

Each drive group in a RAID Controller has a number from 1 to 32 (depending on how 
many logical units you can create on your system and on how you have configured them). 
These numbers may change as you create and delete logical units. Drive group numbering 
is based on the specific logical unit numbers associated with each drive group. Drive 
group numbering starts with the lowest numbered logical unit. 

IMPORTANT Keep in mind that the drive group numbering can change when you are 
creating and deleting logical units (LUNs).

For example, the drive group containing LUN 0 will always be drive group 1. When you 
delete LUNs and then add new LUNs, the drive group numbers may change to reflect the 
new logical unit numbers associated with it.

Configured Drive Group 
of 3 drives containing 
three LUNs

Unassigned Drive Group 
containing two drives

Hot Spare Drive Group 
containing two drives

Configured Drive Group 
of 3 drives containing 
one LUN
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For example, suppose you had the following drive groups:

Now, you delete LUN 1. In this case, renumbering would not occur. The drive groups 
would be as follows:

Next, you create a new drive group. The new drive group will use the first available LUN, 
which in this case is 1. The drive groups would be renumbered as follows:

As you can see, LUN 1 is now part of drive group 2. The old drive group 2 has been 
renumbered to 3, and the old drive group 3 has been renumbered to 4.

Drive Names

Drives are identified by a channel number and a SCSI ID. For example, a drive may be 
listed in a storage management software display as [1,3], indicating that it is channel 1, 
SCSI ID 3.

Drive Group # LUN #

1 0, 1

2 2

3 3, 4, 5

Drive Group # LUN #

1 0

2 2

3 3, 4, 5

Drive Group # LUN #

1 0

2 1

3 2

4 3, 4, 5
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See your hardware documentation for a description of the drive numbering used on your 
drive modules.

Hot Spare

A hot spare is a drive containing no data that acts as a standby in case a drive fails in a 
RAID 1, 3, or 5 logical unit.

The hot spare drive adds another level of redundancy to your RAID Controller. If a drive 
fails, the hot spare takes over for the failed drive until you replace it. Once you replace the 
failed drive, the hot spare returns to a Standby status.

A hot spare drive is not dedicated to a specific drive group/LUN, but instead can be used 
for any failed drive in the RAID Controller with the same or smaller capacity. 

The hot spare drive group is displayed only in the Configuration Application. 

See "Creating Hot Spares" on page 66 for information on how to create a hot spare. See 
"Protecting Yourself From Component Failures" on page 19 for more information on the 
advantages of hot spares.

Logical Unit (LUN)

A logical unit (called a “LUN” for logical unit number) is the basic structure you create to 
retrieve and store your data. A LUN is a set of physical drives (that is, a drive group), that 
have been configured into either RAID Level 0, 1, 3, or 5. 

Each logical unit (not the drive group) is seen by the operating system as one drive. The 
operating system accesses each logical unit in the same way it accesses a new disk drive, 
and you must follow the same procedures on the LUN (creating file systems, volumes, and 
so on) that you would use to access a standard disk drive.

One or more LUNs make up a configured drive group. See Figure 1 on page 7 for an 
example of the relationship between drive groups and LUNs.

Each LUN has several properties:

• A LUN number — this is a number (from 0 to 32, depending on your system) assigned 
to the LUN by the controller when you create the LUN.

• A RAID level — this determines how data is written to the drives and determines 
whether or not the LUN has data redundancy (RAID level 1, 3, and 5 have data 
redundancy; RAID 0 does not.)
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• A set number of drives — Each logical unit is made up of a set number of drives. The 
number of drives is determined when you create the logical unit and is dependent on 
the RAID level selection. For example, all RAID 1 LUNs must have an even number 
of drives. You can add drives to an existing drive group/LUN, but you can’t decrease 
the number of drives in a drive group/LUN without deleting and recreating it.

• A capacity — Each logical unit has a fixed amount of space. The capacity is set when 
you create the logical unit. The capacity depends both on the size of the drives and the 
selected RAID level. For example, a 6 drive RAID 0 LUN has twice the capacity of a 6 
drive RAID 1 LUN, even if both LUNs use the same size drive. 

• A set of parameters — These parameters include segment size, cache options, 
reconstruction rate, and so on. Some of these parameters can be changed for individual 
LUNs, while others apply to a whole drive group (one or more LUNs occupying the 
same drives).

Parity

Parity is additional information stored along with the data that allows the controller to 
reconstruct lost data. Only RAID 3 and 5 have parity. RAID 1 uses mirroring, not parity, 
although you can run parity check and repair on a RAID 1 logical unit; in this case, parity 
check compares the data on the mirrored drives.

Parity Check/Repair

Parity check is the process of scanning the blocks in a logical unit and checking the parity 
for each block. RAID 1 does not use parity, but parity check can still be performed on a 
RAID 1 unit; in this case, parity check compares the data on the mirrored drives.

Parity repair is the process of correcting any parity inconsistencies found during parity 
check. However, this process corrects only parity errors. If the errors were caused by 
corrupted data, the data is still corrupted.

You can set a time to run an automatic parity check/repair by using Options → Auto Parity 
Settings in the Maintenance/Tuning Application. You can also initiate a manual check/
repair using the Recovery Application. See "Running Parity Check" on page 110 for more 
information.

RAID Level

The RAID level determines how the controller reads and writes data and parity on the 
drives. The storage management software supports 4 RAID levels:

• RAID 0 — In RAID 0, data is striped across the drives in segments. There is no parity 
data, so RAID 0 uses the full capacity of the drives. However, there is no redundancy, 
so if a single drive fails, all data in the LUN is lost.
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• RAID 1 — In RAID 1, data is mirrored. Each data drive has a corresponding mirrored 
drive with identical data. If one drive in the mirrored pair fails, the data from the other 
drive is used. In fact, a RAID 1 logical unit can suffer multiple drive failures without 
losing data, so long as none of the failed drives are mirrored pairs. Because RAID 1 
mirrors data, a RAID 1 logical unit has only half the capacity of the assigned drives 
(for example, if you create a 4-drive RAID 1 logical unit with 18 MB drives, the 
resulting data capacity is 36 MB).

• RAID 3 — In this version of the storage management software, RAID 3 is identical 
to RAID 5. However, RAID 3 is better suited to larger record performance. RAID 5 is 
better suited to small records, such as those used in transaction processing.

• RAID 5 — In RAID 5, data is striped across the drives in the logical unit in segments, 
with parity information being striped across the drives as well. Because of this parity, if 
a single drive fails, data can still be recovered from the remaining good drives. Two 
drive failures cause all data to be lost. A RAID 5 logical unit has data capacity of all 
the drives in the logical unit less one (for example, a 5-drive RAID 5 logical unit with 
18 GB drives has a data capacity of 72 GB).

RDAC Driver

The Redundant Disk Array Controller (RDAC) driver is part of the storage management 
software package and manages the I/O data connection for RAID Controller Units with 
redundant controllers running under Windows NT. If a component (cable, controller, host 
adapter, etc.) fails along the connection, causing the host to lose communication with a 
controller, the RDAC driver automatically reroutes all I/O operations to the other 
controller.

Consult the Installation and User’s Handbook for your operating system for specific 
information. 

RAID Controller Unit

This is the physical unit, which contains one or two controllers and associated power 
supplies, fans and battery. This Handbook sometimes refers to the RAID Controller Unit 
as “RAID Controller.”

RAID Controller Module

When the RAID Controller Unit is physically connected with one or more drive modules, 
it becomes a Raid Controller Module. You select a RAID Controller Module to perform 
the various RAID tasks (such as configuring, obtaining status, recovering, and so on). This 
Handbook sometimes refers to the RAID Controller Module as “RAID Controller.”
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Reconstruction

Reconstruction is the process of using data and parity on all operational drives within a 
drive group to regenerate the data on a replacement drive or a hot spare drive. Only data 
on a RAID 1, 3, or 5 logical unit can be reconstructed.

Reconstruction occurs when you replace a failed drive in a degraded RAID 1, 3, or 5 
logical unit (a degraded logical unit has suffered a drive failure but is still operable). 

The rate of reconstruction is determined by the Reconstruction Rate settings. The settings 
define how much processing time is allocated for reconstruction and for system 
performance. The faster the rate, the faster reconstruction occurs, but the slower system 
I/O is serviced.

Redundant Controllers

When you have two controllers, these controllers are set up as redundant controllers. That 
is, if one controller fails, the other controller in the pair takes over the failed controller’s 
functions, and the RAID Controller Unit continues to operate. You can then replace the 
failed controller, often without shutting down the RAID Controller Unit, to resume normal 
operation.

This feature involves more than just the controller. It concerns the entire data connection, 
the route data takes from the host system to the RAID Controller controller. If any part of 
the connection fails (for example, if the cable connecting the two units fails), the controller 
redundancy feature reroutes I/O to the remaining good connection.

The redundant controller feature is managed by the RDAC software, which controls data 
flow to the controller pairs independent of the operating system. This software keeps track 
of the current status of the connections and can perform the switch-over without any 
changes in the operating system.

Whether or not your RAID Controller Unit has the redundant controller feature depends 
on the following:

• Whether your operating system supports RDAC. Currently, RDAC runs on Windows 
NT Version 4.

• How the RAID controllers are connected. See "Controller Configurations" on page 13 
for information on the possible configurations and their effect on redundant controller 
support.

Redundant controllers can be configured in two ways:

• Active/passive — in this configuration, one controller handles all the I/O from the host, 
and the other controller is held as a spare, taking over if the first controller fails.
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• Active/active — in this configuration, both controllers handle I/O from the host. Each 
controller is assigned specific LUNs to service. If one controller fails, the other takes 
over the failed controller’s assigned LUNs. This is the recommended configuration, 
because using two controllers for I/O is usually faster than using a single controller.

Segment Size

A segment is the amount of data the controller writes on a single drive in a logical unit 
before writing data on the next drive. Segment size is given in blocks of 512 bytes. For 
example, if the segment size is 128 blocks, the controller will write 128 blocks of data on 
drive 1, then 128 blocks of data on drive 2, and so on.

When you create a logical unit, the default segment size is the optimal size for that RAID 
level. You can change this default segment size when you create a logical unit using the 
Options selection. You can also change it later using the Modify LUN option in the 
Configuration application.

SNMP

The Simple Network Management Protocol (SNMP) notification is an option that you 
may enable while installing this software. It allows this software to send remote 
notification of RAID events to a designated network management station (NMS) using 
SNMP traps.

See the Installation and User’s Handbook for your operating system for details on 
enabling this notification option.

Controller Configurations

The storage management software supports three main configurations from the host 
systems to the RAID Controller. Be sure to consult the Installation and User’s Handbook 
specific to your operating system for details on hardware requirements required to use this 
software with that operating system.

CAUTION No configurations or combinations are supported beyond those described 
in this section. Furthermore, the software’s operation cannot be 
guaranteed to work as intended/described in the operating-system specific 
Installation and User’s Handbook, this User Handbook, or the on-line 
help if other configurations are used.

Most RAID Controller Units supported by this software use active/active redundant 
controllers. Each drive group/LUN is owned by only one of the active controllers in a 
RAID Controller Unit. Furthermore, the combined total of LUNs configured for both 
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controllers cannot exceed the maximum number of LUNs that the module can handle (that 
is, 8, 16, or 32) regardless of which configuration is used. For information on LUN limits 
per module, see your operating-system specific Installation and User’s Handbook.

Single-Host Configuration

In a single host configuration, one host machine with two host adapters is connected by 
separate connections to each controller in the RAID Controller. The two connections are 
required for maximum RDAC failover support for redundant controllers (see Figure 2 on 
page 15). 

Note: This is the recommended configuration with the storage management software 
installed on the host for fullest functionality and complete RDAC failover support 
with dual controllers. 

IMPORTANT Although this configuration also supports RAID Controller Units that 
have a single-controller or dual controllers on the same connection, you 
do not have complete RDAC data path protection with either of these 
configurations. The host adapter and cable become a single-point of 
failure and any data path failure could result in the operating system 
hanging. For the greatest level of I/O protection, provide each controller 
in a RAID Controller Unit with its own connection to a separate host 
adapter in the host system.
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Figure 2.  Single-Host To RAID Controller Configuration

Multi-Host Configuration

In a Multi-host configuration, two host machines are each connected by two 
connections to both of the controllers in a RAID Controller Unit (see Figure 3 on page 
16).

CAUTION Not every operating system supports this configuration. Be sure to consult 
the restrictions in the Installation and User’s Handbook specific to your 
operating system for more information. Also, the host machines and 
operating systems must be able to handle the multi-host configuration. 
Refer to the appropriate hardware documentation.

With the storage management software installed on each host machine, both hosts have 
complete visibility of both controllers, all data paths, and all configured drive groups/
logical units(LUNs) in a RAID Controller, plus RDAC failover support for the redundant 
controllers. However, in this configuration, you must use caution when performing storage 
management tasks (especially creation and deletion of LUNs) to ensure the two hosts do 
not send conflicting commands to the controllers in the RAID Controller.

Host system with two Fibre channel 
host adapters

RAID Controller Unit with two 
Fibre channel controllers

Fibre channel connection 
(may be through one or two hubs)
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The following items are unique to this configuration:

• Both hosts must have the same operating system and storage management software 
versions installed.

• Both host machines should have the same LUNs-per-host adapter capacity (that is, 
either both are limited to eight LUNs or both can have 16-32 LUNs). This is important 
for RDAC failover situations so that each controller can take over for the other and 
display all configured drive groups/LUNs.

• If the operating system on the host machine is capable of creating reservations (many 
UNIX systems can), the storage management software will honor them. This means 
that each host could have reservations to specified drive groups/logical units (LUNs) 
and only that host’s software can perform operations on the reserved drive group/LUN. 
Without reservations, the software on either host machine is able to begin any 
operation. Therefore, you must use caution when performing certain tasks that need 
exclusive access. Especially when creating and deleting LUNs, you should be sure to 
have only one configuration session open at a time (from only one host) or the 
operations could fail.

• This software does not provide failover protection at the host level. That feature 
requires third-party software. 

Figure 3.  Multi-Host To RAID Controller Unit Configuration

Host Adapters Host Adapters

Interlink

Hub Hub

RAID Controller
Unit

RAID Controller
Unit Controller

Two Host systems, each with two 
Fibre channel host adapters

Fibre channel connections with two 
hubs (may contain different hub 
configurations) 

RAID Controller Unit with two 
controllers

Fibre Channel Connection
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Independent Controller Configuration

In the Independent controller configuration, two host machines are connected to a dual-
controller RAID Controller. One host machine is connected to one RAID Controller 
controller, and a second host machine is connected to the other controller (see Figure 4 on 
page 18.) Each host machine and its storage management software see the controller and 
the drive groups/LUNs that it owns as independent of the other (alternate) controller. That 
is, each host machine acts as if it is connected to a single-controller RAID Controller. 

Also, when an independent controller is selected with Select Module, the storage 
management software has knowledge of the alternate controller and displays all 
configured drive groups/LUNs. It only reports real-time status for the host-controller data 
path on which it is installed, but displays and reports an “Inaccessible” status for drive 
groups/LUNs owned by the alternate controller. 

IMPORTANT Because it is possible to open a Configuration application from both 
hosts, be sure that you have only one configuration session open at a time 
(from only one host) when creating and deleting LUNs or the operation 
will fail for one of the hosts.

The following items are unique to this configuration:

• Both hosts must have the same operating system and the same storage management 
software versions installed.

• Both host machines should have the same LUNs-per-host adapter capacity (that is, 
either both are limited to eight LUNs or both can have 16-32 LUNs). 

• This configuration is indicated by a special setting in Select Module (the “Indep. 
Cntrls?” column says Yes).

• The controllers in the RAID Controller Unit do not have RDAC failover protection.

• The storage management software reports the alternate controller and its drive group/
LUNs as “Inaccessible.”

• Recovery Guru/Health Check (Recovery Application) detects data path-related failures 
only for the controller that is connected to the host machine running the storage 
management software. For example, if host 1 has a controller failure, host 1 reports the 
failure, but host 2 will not report a controller failure using its Health Check. Also, these 
applications detect drive-related failures only for configured drive groups/LUNs that 
are owned by the controller (connected to the host machine running the storage 
management software) or for any unassigned or hot spare drive. 
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• Hot spares are always available to LUNs owned by either controller.

Figure 4.  Independent Controller Configuration

Special Network Considerations

The Networked version of the storage management software always sees both controllers 
in a dual-controller RAID Controller Unit regardless of which configuration you have. 
However, the Networked version will be able to tell if the currently selected RAID 
Controller has an independent controller configuration if independent controllers was 
selected using the Select Module option.

If you are using the Networked version of this software, the following restrictions apply to 
any of the host-RAID Controller Unit configurations:

• Your RAID Controller Unit does not have RDAC failover protection unless there is 
failover protection installed on the host connected to the unit through the Fibre 
Channel connection.

• This software does not provide I/O connection failure detection or recovery. However, 
any problems with a loop connection to the controllers or a problem with the 
controllers themselves are shown as a data path failure. Recovery Guru/Health Check 
provides assistance for these problems.

• This software has no way to recognize any exclusive access operations that may be 
performed by other software installed on the host machine (not even another storage 
management package). This requires you to use caution before starting certain 
operations that need exclusive access because without it file systems are not detected 
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and multiple operations could be launched without logical units being protected. 
Furthermore, because it is possible to open a Configuration application from any 
networked station, be sure that you have only one configuration session open at a time 
when creating and deleting LUNs or the operation will fail for all but one station.

CAUTION Drive groups/LUNs and their data could be lost if more than one 
“destructive” operation is launched. No other operations should be 
attempted on the same drive group/LUN if one of these operations is still 
being completed. Operations requiring exclusive access to the LUNs 
include Delete for LUNs and File → Reset Configuration 
(Configuration); formatting a LUN with Options → Manual Recovery → 
Logical Units (Recovery); and Firmware Upgrade → Offline method 
(Maintenance/Tuning).

Component Failures

The RAID Controller Units serviced by the storage management software are designed to 
be fault tolerant. All units provide drive redundancy, so that if a drive fails, the data 
contained on the drive is still available. The units also feature redundant controllers, fans, 
and power supplies as well, so that the RAID Controller Unit can keep functioning even if 
a single component fails. The controllers also feature caching, to both speed up I/O 
operations and to preserve data in the event of a controller failure, and battery backup, to 
prevent data loss in the event of a power failure. See the hardware books accompanying 
your RAID Controller Unit for complete information on the redundant features of your 
hardware.

The storage management software provides notification of most component failures. 
When you do replace the component, follow the instructions given in Recovery Guru. For 
more information on component failures, see "Chapter 6. Recovery."

In some cases, you may need to consult the hardware books for information on how to 
identify and replace the failed component. This usually does not involve the software. For 
example, there is no procedure for replacing a failed power supply given in this book.

Protecting Yourself From Component Failures

Using the features of the storage management software, you can take steps to further 
increase your protection against component failures.

• Use RAID levels 1, 3, or 5. These RAID levels offer data redundancy and can survive a 
single drive failure without losing data. RAID 0 does not have redundancy, and a 
RAID 0 logical unit will lose all data if a single drive fails.
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• Use sufficient hot spares. A hot spare automatically replaces a failed drive in a RAID 
1, 3, or 5 logical unit (assuming sufficient time between failures). Therefore, a hot 
spare protects your data from two drive failures instead of one. Two hot spares protect 
your data from three drive failures, and so on.

• Use write cache mirroring. This feature is available only with active/active controller 
pairs. Cache mirroring stores cache information for a controller on both controllers in 
the pair, so if a single controller in the pair fails, the cache information is still present in 
the other controller.

• When creating LUNs, try and assign drives on different drive channels, if possible. 
This prevents a channel failure from preventing access to multiple drives. This may 
require you to use the Options selection when creating LUNs. Note that this may not be 
possible if you create LUNs with more drives than you have channels.

Application Summary Charts

The storage manager software consists of four separate applications, Configuration, 
Recovery, Status, and Maintenance and Tuning. These applications can be run 
independently of each other or concurrently.
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Figure 5.  Configuration Application Summary
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Figure 6.  Status Application Summary

Open Log

Save Log As
Save Module Profile
Save Performance Data
Exit

Find
Add

Controllers
Locate

Default Log

Copy to Clipboard

Log Size Threshold

Select All

Checking Frequency

Remove

Drives

Edit

LUNs

Message Log
LUN Reconstruct
Performance Monitor

Options

Edit

Help
RAID Selection Box

Log Settings

Profile

Refresh All

Select All
All

Parity
General

Hardware ASC/ASCQ code

Message
Log

Show Details

File

Module Select 

Status
Application

(See Chapter 5)

List Type



Chapter 2. Storage Management Software Overview 23

Figure 7.  Recovery Application Summary
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Figure 8.  Maintenance And Tuning Application Summary
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Task List

The table below lists the tasks you must perform to manage and support the RAID 
Controllers, and indicates when they need to be performed.

Table 1: Storage Management Task List

Task When to Perform Reference

Informational Tasks (Locating Raid Controllers, Checking Configurations)

Locate a RAID 
Controller Module

When you want to physically locate a RAID 
Controller Module. Perform this task when you 
first install the module and mark the module for 
future reference.

"Locating a Module" on 
page 35

Locate A Logical Unit 
or Specific Drives

When you want to physically locate a drive or a 
logical unit.

"Locating Drives" on 
page 36

Assign Names to 
Modules and 
Controllers

To make the RAID Controller Module components 
easily identifiable. Only the networked version 
allows you to name controllers.

"Selecting a Module" 
on page 33

View RAID controller 
Configuration 
Information

When you need information on your RAID 
Controllers, such as current firmware version or 
drive information.

"Viewing A Module 
Profile" on page 37

Check the Status Log When you want to see if any errors have occurred 
on the RAID Controller Module.

"Viewing The Log" on 
page 72

Run the Performance 
Monitor

To gather information on the performance of the 
RAID controller unit, with the goal of discovering 
any changes that could be made to speed 
performance.

"Using The 
Performance Monitor" 
on page 78

Configuration Tasks (Creating and Modifying Logical Units)

Create Logical Units 
(LUNs) After you install a RAID Controller Module. "Creating Logical Units 

(LUNs)" on page 47

Create a Hot Spare
When you configure a RAID Controller Module. 
You should always have at least one hot spare on 
your system to protect against failures.

"Creating Hot Spares" 
on page 66

Add Drives to an 
Existing Drive Group When you want to add capacity in a Drive Group

"Modifying Drive 
Groups and LUNs" on 
page 57

Change RAID Level of 
an Existing Drive 
Group/Logical Unit

If you want a different configuration in your RAID 
Controller after you have created a LUN.

"Modifying Drive 
Groups and LUNs" on 
page 57
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Change the Segment 
Size of Existing 
Logical Units

To change the striping on all the logical units in a 
drive group. This may improve performance.

"Modifying Drive 
Groups and LUNs" on 
page 57

Delete a Logical Unit
If you want to make some drives available to 
reconfigure your system. Note that this deletes all 
data from the logical unit.

"Deleting LUNs" on 
page 64

Delete a Hot Spare If you need the hot spare drive for a new LUN. "Deleting A Hot Spare" 
on page 68

Maintenance Tasks (Loading new firmware, changing parameters)

Download Controller 
Firmware

• When you receive new firmware.

• When adding RAID controllers with new 
firmware into an existing site (you will need to 
upgrade the existing controllers).

"Upgrading Controller 
Firmware" on page 101

Download NVSRAM

• When you receive new firmware.

• When adding RAID controllers with new 
firmware into an existing site (you will need to 
upgrade the existing controllers).

"Upgrading Controller 
Firmware" on page 101

Reset the Configuration

If all attempts to use the RAID controller unit have 
failed. This is a last resort option that will delete all 
data and configuration information from your 
RAID Controller.

"Resetting the 
Configuration" on page 
69

Change Controller 
Modes

If the controllers in a RAID Controller are 
currently active/passive and you want to change 
them to active/active.

"Changing Controller 
Mode" on page 118

Balance Logical Units 
across controllers

• If you have changed controller mode from 
active/passive to active/active and didn’t balance 
the LUNs at that time.

• If you want to reassign logical units to 
controllers.

"Balancing LUNs" on 
page 115

Change Cache 
Parameters

To turn cache on and off after you have created a 
logical unit.

"Changing Cache 
Parameters" on page 
121

Change the 
Reconstruction Rate

To change the speed at which data is reconstructed 
after a drive replacement.

"Changing The LUN 
Reconstruction Rate" 
on page 113

Table 1: Storage Management Task List (continued)

Task When to Perform Reference
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Set the Time for 
Automatic Parity 
Check/Repair

If you want to change the default time automatic 
parity check is performed. You might want to do 
this if the current time is interfering with system 
operations.

"Setting Automatic 
Parity Time" on page 
110

View the Results of 
Automatic Parity 
Check/Repair

If you want to see if automatic parity check/repair 
detected any parity errors.

"Viewing The Log" on 
page 72

Recovery and Repair Tasks (recovering from failures, checking data)

Perform a Health 
Check

If you have indications that a component failure or 
other error has occurred. The Health Check will 
locate the problem and give information on how to 
correct it.

"Running Recovery 
Guru/Health Check" on 
page 90

Replace a Failed 
Component

If Health Check has detected a failed component. 
Do not replace a failed component unless the 
Recovery Guru recommends it. If necessary, see 
the manuals accompanying your hardware for 
information on how to replace a failed component.

"Chapter 6. Recovery."

Check Data Parity
If Recovery Guru tells you to run parity check after 
a component failure, or you have indications that 
I/O errors have occurred.

"Running Parity 
Check" on page 110

Table 1: Storage Management Task List (continued)

Task When to Perform Reference
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Chapter 3. Common Application Features

This chapter describes the software features common to all applications, including how to 
display and save RAID Controller configuration information.

Navigation

This software requires that you use a mouse for fullest functionality; however, you can 
also use your keyboard to access the task options. Table 2 describes how to use the mouse 
and keyboard.

Table 2: Using A Mouse And Keyboard

When using a 
mouse...

• To select an option, place the pointer over the desired option and single-click.

• To receive information about a top menu option, click on the option and hold 
down the left-mouse button.

• To receive information about a particular button option, move the mouse over the 
appropriate button and read the description near the bottom of the screen.

• To highlight items, do one of the following:

• Single-click to highlight a single item.

• Press <Shift> + click to highlight a series of items. For example, single-click to 
highlight the top item in a list, then press <Shift> + click on the last item in the 
list to highlight all the items in that list.

• Press <Control> + click to highlight items not in a series. For example, single-
click to highlight one item in a list, then press <Control> + click on another 
item to highlight it as well. Do this for every item you want to highlight.

When using a 
keyboard...

• To select an option using the keyboard (such as Locate Module), press <Alt> and 
the key for the underlined letter that appears on the screen. 

• If you select a task button, the associated screen is launched. For example, <Alt> 
+ <L> brings up the Locate Module screen.

• If you select from the top-menu items, a drop-down menu displays the second-
level menu options that are available. To select a second-level menu item, press 
the key for the underlined letter in that option. For example, to select Save 
Module Profile from the File menu, press <Alt> + <F>, then either press <S>, or 
use the arrow key to highlight Save Module Profile and press <Enter>. 
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Starting and Exiting An Application

The following sections explain how to start and exit an application.

Starting An Application

Select the application (Figure 9) you want to start.

• The first screen you see will prompt you to select the RAID Controller you want to 
access (see "Selecting a Module" on page 33).

• If the message log file is currently over its maximum size limit, you will be 
prompted to rewrite the file (see "Clearing The Message File" on page 77).

Figure 9.  Application Icons

Exiting An Application

To exit any application, select File → Exit from the top menu. You are returned to the 
Application Icons. 

Using Online Help

A powerful, hypertext online help system is available with this software. This help has 
information on features common to all the applications as well as topics that are specific to 
each application (Configuration, Status, Recovery, and Maintenance/Tuning). 

You can access all of the help topics from any application. However, in situations where a 
new screen is overlaid on top of the main application screen, you cannot access help from 
within that specific application. Fortunately, it is still possible to obtain help by selecting 
Help from another application.
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In many cases, the online help offers more specific information than is given in this User 
Handbook. If you have questions concerning a specific procedure, check the online help 
before coming back to this manual.

When you select Help from the top menu of any application, you see a screen similar to 
Figure 10. Table 3 on page 32 details the features common to Online Help.

Figure 10.  Main Online Help Screen
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Table 3: Online Help Screen Elements

Selection Description

File

Allows you to do the following:

• Print the currently displayed topic to a file or printer.

• Set up your printer (landscape/portrait, margins, etc.).

• Exit Online Help.

Edit
Copies text to a clipboard. 

From the top menu, select Edit → Copy to Clipboard to copy the topic in the 
window you are viewing.

Home
Returns you to the Home Page. 

This screen appears whenever you select Help from the top menu in an application.

Contents

Displays all the help topics organized by hierarchy and appearance on the Home 
Page.

Press a letter to quickly advance through the list of topics. For example, pressing 
<M> will take you to the first topic that begins with M. You can also use the 
<Home> and <End> keys on your keyboard to move through this list. 

Index

Lists key words or phrases in alphabetical order in the top of the Index window. The 
bottom of the window displays the topics in which the highlighted index term 
appears.

Press a letter to quickly advance through this alphabetical list. For example, pressing 
<M> will take you to the first word that begins with M. You can also use the 
<Home> and <End> keys on your keyboard to move through this list. To view one of 
these topics, you can either double-click the topic or simply highlight the topic and 
select <Go To>. 

Back Takes you back (one topic at a time) through the topics you have viewed since 
selecting Help. 

History

Creates a list of all topics you view in the order you have selected them. 

This feature begins a new list each time you enter Help. To return to one of these 
topics, either double-click the topic or simply highlight the topic and select <Go To>. 
You can also use the <Home> and <End> keys on your keyboard to move through 
this list.

Glossary

Displays an alphabetical list of defined terms.

Press a letter to quickly advance through this alphabetical list. For example, pressing 
<M> will take you to the first word that begins with M. To view a definition, click 
and hold the mouse button while pointing to the glossary term. You can use the 
<Home> and <End> keys on your keyboard to quickly move to the beginning and 
end of the glossary. 
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Selecting a Module

All storage management operations require you to first select the module you want to 
work on. Once you select the module, you can perform an operation, such as configuration 
or recovery, on it. 

Instead of selecting a single module, you can select All Modules if you want to perform an 
operation on all of the modules. Note, however, that certain operations (such as 
configuration) can not be performed on all the RAID Controller Modules simultaneously.

RAID Controller Modules are identified either by a device name, assigned by the 
operating system, or by a user-specified name. You can name the module through the 
Module Selection screen (see the next section).

There are several ways to select a RAID Controller Module:

• If the correct parameter is turned on in your rmparams file (it is turned on by default), 
you are given the chance to select a RAID Controller Module when you first start an 
application (see Figure 11 on page 34). Either highlight a module and select OK or 
double-click on the module you want.

• Once in an application, you can:

• Select the RAID Controller Module you want from the RAID Controller Module 
drop-down list box next to the tool bar.

• Click on the Module Select button.

• Select Module → Select from the drop-down menus.

Same level 
topics

Displays topics of the same level using the << and >> keys to move forward or 
backward. 

You can also select Same Level Topics → All Topics from the drop-down menu to 
make the arrow buttons move you through every topic in help. 

<< and >>

• If you are in Same Level Topics, these buttons move you to the previous/next 
topic within the level you are currently viewing.

• If you are in All Topics, these buttons move you to the previous/next topic across 
all levels.

Up Moves you to the next higher level of topics.

Table 3: Online Help Screen Elements (continued)

Selection Description
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• Right click on any item in the Module Information tree (in the Configuration 
application only).

In all cases except when selecting a module from the Module drop-down list box, the 
RAID Controller Module selection screen is displayed. See "RAID Controller Module 
Selection Screen" on page 34 for details on that screen.

RAID Controller Module Selection Screen

Figure 11.  RAID Controller Module Selection Screen

Notes:

• The display gives the module name, the names of the controllers in the module, 
indicates whether the controllers have an independent controller configuration (see 
"Independent Controller Configuration" on page 17), and displays any comments you 
may have entered with the Edit option.

• Table 4 on page 35 gives more information on the buttons you can select.

Click here to search for a specific 
RAID Controller. This option is 
useful if you have a large number 
of modules.

This display shows all the RAID Controllers connected to your system. In any application other than Configuration, 
you can also select All RAID Controllers. You can double-click on an individual module to select that module, or you 
can highlight the module and click on OK.

Click here to exit this screen.

Click here to assign a name to the 
module and controllers and enter 
any comments. Only the 
networked version allows you to 
change the controller names.

Click here to add a new module. 
This option is available only in a 
network environment.

Click here to select the current 
highlighted module.

Click here to remove the 
highlighted RAID Controller.
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Locating a Module

The storage management software allows you to physically locate a RAID Controller 
Module. This is useful in trying to physically locate the unit you are accessing.

Table 4: Select Module Screen Elements

Screen Element Description

Find

Allows you to quickly locate a RAID Controller. It will be most useful 
when you have many modules. 

At the pop-up screen enter the search term you want to use. Remember that 
the search item must be contained in one of the fields on this screen.

Add

Applicable for the Networked version only. Allows you to add new 
modules to your system so that this software can access and monitor it. 

See the Installation and User’s Handbook specific to your operating system 
for details on adding new modules to your system.

Remove

Allows you to remove RAID Controllers from your system. 

You can only remove one module at a time. This option will be grayed out 
if All RAID Controllers is selected.

IMPORTANT

• Before you use this option, first physically remove the module from the 
system. Otherwise, the module will be added again when this software 
detects it.

• If you physically remove RAID Controllers from your system, but do not 
use this Remove option, the storage management software will continue 
trying to contact the controllers in that module. This is especially 
important in the networked environment because missing modules could 
cause the software to have long delays or even system hangs while trying 
to contact the removed module.

Edit

Allows you to assign a name to the RAID Controllers and to enter 
comments about it. Use the comments area to provide detailed information 
about the RAID Controller (such as location information, independent 
controllers, etc.) to help you identify it.

On Networked versions, you can also assign names to the RAID Controller 
controllers.

You can only edit information for one module at a time. This option will be 
grayed out if All RAID Controllers is selected. 
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Once you locate a module, it is a good idea to label it, so that you will not need to use the 
software to locate the module again.

If you need to locate individual drive groups/logical units or individual drives, use the 
List/Locate Drives option in the Configuration application (see "Locating Drives" on page 
36).

Note: For best results, shut down all I/O activity to the module you want to locate, so that 
you won’t be distracted by the activity light’s normal blinking during I/O activity.

To locate a RAID Controller Module, do the following.

1. Start the application you want to perform.

2. Select the Module you want to locate. Do not select All Modules, because this will 
gray out the Locate Module option.

3. Click on the Locate Module button or select Module → Locate from the drop-down 
menus.

4. Click Start on the Locate Module screen. The activity lights on the selected module 
begin to blink. 

5. After you have physically located the module, click Stop and return to the current 
application. This is a good time to label the module for future reference.

Locating Drives

The Configuration application allows you to physically locate individual drive groups/
logical units and drives. Drives are identified by channel number and SCSI ID. See your 
hardware documentation for more information on drive numbering.

To locate a drive group or individual drives, do the following.

1. Start the Configuration application.

2. Select the RAID Controller Module containing the logical units or drives you want to 
locate.

3. Click on the drive group or drives you want to locate in the directory tree.

4. Click on the List/Locate Drives button or select Options → List/Locate Drives from 
the drop-down menus.

5. A screen like Figure 12 appears. Select the drives you want to locate (click Select All if 
you want to locate all the drives in the group), then select Locate.

6. Press Start on the Locate Group screen. The activity lights on the selected drives begin 
to blink. 
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7. After you have physically located the drives, click Stop and return to the Configuration 
application.

Figure 12.  List/Locate Drives Screen

Viewing A Module Profile

You can view configuration information on a RAID Module by selecting Module Profile. 
The Module Profile option displays complete information on the controllers, drives, and 
logical units on the selected RAID Controllers.

To display a module profile, do the following:

1. Start any application (Configuration is the recommended application).

2. Select the module you want information on. Do not select All Modules (the Module 
Profile option is grayed out if All Modules is selected).

3. Click on the Module Profile button or select Module → Profile from the drop-down 
menus. The Module Profile screen is displayed (see Figure 13).

4. After you have viewed all the profile information you want, click OK to return to the 
application.

5. After exiting Module Profile, you can save the profile information to a file. See 
"Saving A Module Profile" on page 43.

This display shows all the drives in the 
selected drive group, along with individual 
drive capacity and status. The first number 
given in Drive Location is the channel 
number of the drive; the second number is 
the SCSI ID. Highlight the drives you want 
to locate.

Click here to locate all the drives listed. 
This locates the entire drive group.

Click here to locate the selected drives.

Click here exit this screen without locating 
any drives.
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Figure 13.  Module Profile Screen

Table 5: Module Profile Screen Contents

Screen Element Explanation

Name
Identifies the controllers in the selected RAID Controller Module as A or B 
and, where applicable, includes a system device name. The A and B 
correspond to the hardware controller IDs.

Serial Number Identifies the controller by a number assigned by the manufacturer.

Mode

Identifies the operating state of the controller. Possible modes are Active, 
Passive, or Offline. You could also see Inaccessible with these statuses if the 
RAID Controller Module has an independent controller configuration.

IMPORTANT If you do not see Mode information or other information in this 
screen is incomplete, there may be a connection problem. Select Recovery 
Guru and correct any problems indicated.

Number of LUNs Indicates how many logical units are owned by the particular controller.

Disk Drives Indicates how many drives make up the selected RAID Controller Module.

Click here to view detailed 
information on the module 
controllers (see "The Controller 
Profile Screen" on page 39).

Click here to view detailed 
information on the module drives 
(see Figure 15 on page 41).

Click here to view detailed 
information on the module 
logical units (see Figure 16 on 
page 42).

Click here to exit this screen.

See Table 5 for an explanation of the items in this 
display.
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The Controller Profile Screen

This section describes the Fiber Channel Controller Profile screen.

Fibre Channel Controller Profile

Figure 14.  Controller Profile Screen

Table 6: Controller Profile Screen Contents (Fibre Channel)

Screen Element Explanation

Board Name Controller type designation. 

Board ID Controller model number (4766). 

Board Serial Number Unique identification for the controller assigned by the manufacturer.

Product ID Controller manufacturer’s product code.

Product Serial Number Usually the same as Board Serial Number.

See Table 6 for an 
explanation of the 
items in this 
display.

Click here to exit this screen.
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Vendor ID Controller manufacturer’s name. 

Date of Manufacture Date controller was assembled.

Product Revision A manufacturer’s code giving the revision number of the controller.

Host Interface The type of connection used by the host (Fibre Channel).

Topology The physical or logical layout of nodes on the Fibre Channel network. There 
are two topologies, Arbitrated Loop (Public or Private) and Point-to-Point.

Controller ID - 
NL_Port (hex)

The Fibre Channel Controller’s ID in a hexadecimal value.

• For Arbitrated Loop, this is a one-byte Arbitrated Loop Physical Address. 

• For Fabric and Point-to-Point, this is a three-byte hexadecimal value.

Preferred Address - 
AL_PA (hex)

The hard address (AL_PA format) that Fibre Channel controllers attempt to 
acquire. Displayed only for controllers using the Arbitrated Loop topology. If 
the hard address is not available, the controller automatically obtains the first 
address available after the other ports on the loop have obtained their hard 
addresses. 

Preferred Loop ID 
(dec)

The Fibre Channel Loop ID in NVSRAM used to determine the Preferred 
AL_PA (hard address). Displayed only for controllers attached using the 
Arbitrated Loop topology.

This ID is NOT the AL_PA, but an index into an table of valid AL_PA values 
(see Annex K of the FC-AL standard). Loop IDs are assigned an arbitration 
priority with (host-side IDs) 0 being the lowest and 126 being the highest. 

Host-Side ID
A number used to identify the controller connection between the controller and 
the host (host-side bus). This number is set on the back of the controller using 
the Host ID switch.

Worldwide Port Name 
(hex)

An 8-byte hexadecimal value used to uniquely identify Fibre Channel 
controllers. It consists of fields identifying the naming convention, the node, 
and its ports.

Physical Connection The type of fibre channel connection (optical).

Link Speed (MB/sec) The speed in megabytes per second (MB/sec) of the Fibre Channel connection.

Boot Level Number indicating the release version of controller bootware. 

Firmware Level Number indicating the release version of controller firmware (also referred to 
as appware).

Table 6: Controller Profile Screen Contents (Fibre Channel) (continued)

Screen Element Explanation
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The Drive Profile Screen

Figure 15 shows the Drive Profile screen.

Figure 15.  Drive Profile Screen

Fibre Channel Level Number indicating the release version of Fibre Channel controller firmware.

Cache/Processor Size Amount (in megabytes — MB) of total available cache and processor 
memories on the controller. 

“Unknown” in a column means that the software can not return the indicated value. This is not 
necessarily an error; it is usually a limitation on the fibre channel firmware.

Table 6: Controller Profile Screen Contents (Fibre Channel) (continued)

Screen Element Explanation

See Table 7 on page 42 
for an explanation of the 
items in this display.

Click here to exit this screen.
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The LUN Profile Screen

Figure 16 shows the LUN Profile screen.

Figure 16.  LUN Profile Screen

Table 7: Drive Profile Screen Contents

Screen Element Explanation

Location

Designation indicating the unique location of the drive in the selected RAID 
Controller Module. This information is displayed as [x,y] on screen where the 
channel number is always listed first. For example, [2,1] corresponds to the 
drive at SCSI Channel 2 and SCSI ID 1.

Capacity (MB) Amount of storage space on the drive (in megabytes).

Status
Operating condition of the drive. If a status other than Optimal appears here, 
run Recovery Guru to determine what the problem is, and, if necessary, what 
action to take.

Vendor Drive manufacturer’s name.

Product ID Drive manufacturer’s product code.

Firmware Version Number indicating the release of drive firmware.

Serial Number Drive manufacturer’s serial number.

Date Code Date of manufacture.

See Table 8 on page 
43 for an explanation 
of the items in this 
display.

Click here to exit this 
screen.
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Saving A Module Profile

You can save module profile information for future reference. The module information is 
stored in a text file. It can not be used to restore module settings, but it can be used as a 
reference if you need to recreate the module using the standard configuration procedures.

To save a module profile, perform the following steps:

1. Start any storage management application.

2. Select the RAID Controller you want to save profile information for. Do not select All 
RAID Controllers (this option is grayed out if All RAID Controllers is selected).

Table 8: LUN Profile Screen Contents

Screen Element Explanation

LUN Identifies the number of the logical unit (LUN).

Controller Identifies the controller that owns the logical unit.

Capacity (MB) Shows the amount of storage space (in megabytes).

RAID Level
Indicates the way the controller reads and writes both data and parity on the 
drives. 

Possible RAID Levels are 0, 1, 3, and 5.

Segment Size (Blocks) Indicates the amount of data (in blocks) that the controller writes on one drive 
in a logical unit before writing data on the next drive.

Write Cache Indicates whether the write caching option has been enabled for a particular 
LUN.

Cache Mirroring Indicates whether the cache mirroring option has been enabled for a particular 
LUN.

Cache Without 
Batteries

Indicates whether the cache without batteries option has been enabled for a 
particular LUN.

Status
Indicates the operating condition of the logical unit. If a status other than 
Optimal appears here, run Recovery Guru to determine what the problem is, 
and, if necessary, what action to take.

NOTE: You might see an asterisk next to the caching parameters column. This indicates that the 
parameter is enabled, but is currently not active. The controller has disabled the parameter for some 
reason (such as low batteries). If you see this condition, use Recovery Guru to determine the correct 
action to take, if any.
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3. Select File → Save Module Profile from the drop-down menus. A screen like Figure 
17 is displayed.

Figure 17.  Save Module Profile Screen

4. Click on the information you want to save (or click on All to save all information), then 
click OK.

5. You must then assign a name and location to the file. Enter the name and click OK.

Click here to print all module information. 

Click here to specify exactly what module information you 
want to save. The Controller, Drive, and Logical unit 
information selections are the same as the Profile screens. 
Configuration information gives information on the drive 
groups and logical units that you see in the Configuration 
display.

Click here to save the information selected. You 
then must assign a name to the file to save it.

Click here to exit this screen without saving any information.
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Chapter 4. Configuring RAID Controllers

This chapter describes how to configure RAID Controllers and assign hot spares.

Configuration Overview

IMPORTANT Before you attempt to configure a RAID Controller, make sure you 
understand the concepts of RAID Controller, Drive Group, Logical Unit, 
and RAID Level. See  "Common Definitions" on page 5 for information 
on these important concepts, which will be needed to perform the tasks in 
this section.

Before you can use the RAID Controllers on your system, you must create logical units 
(LUNs) on the RAID Controller. In general, you need to do the following to create and use 
the RAID Controllers:

1. Configure the logical units using the procedures given in this chapter.

2. Perform whatever operating system procedures on the logical unit you need to do to 
bring a new drive on line. For example you may need to restart the system, create file 
systems and volumes, create mount points, and so on.

Types Of Logical Unit (LUN) Creation

There are two types of LUN creation:

• Creating a new LUN from the unassigned drives in the RAID Controller. This also 
creates a new drive group. When you create a LUN from unassigned drives, you assign 
the RAID level and number of drives. See "Creating A Logical Unit From Unassigned 
Drives" on page 48.

• Creating a new LUN from remaining capacity in a drive group. In this configuration 
mode, you cannot assign a new RAID level or new drives, as all the LUNs in a drive 
group must use the same RAID level and drives. See "Creating A LUN From 
Remaining Capacity" on page 50.

Types Of Logical Unit (LUN)/Drive Group Modification

After a LUN is created, you can modify it in the following ways:



46 IBM Netfinity SYMplicity Storage Manager User’s Handbook

• You change the RAID level of the LUNs in the drive group. This change applies to all 
LUNs in the drive group. See "Changing RAID Level" on page 60.

• You can modify LUN parameters (such as segment size, caching, reconstruction rate 
and so on). See:

• "Modifying Segment Size" on page 63

• "Changing Cache Parameters" on page 121

• "Changing The LUN Reconstruction Rate" on page 113

After a Drive Group is created, you can modify it in the following way:

• You can increase Drive Group capacity by adding new drives to the drive group. This 
does not increase the size of the LUNs in the drive group. See "Adding Drives" on page 
61.

• You can change the controller assignment of the LUN/drive group. See "Balancing 
LUNs" on page 115.

The Module Information Display

The Configuration application displays module information as shown in Figure 18 

Figure 18.  Configuration Application Module Information Display

This is the currently 
selected RAID Controller.

This shows the RAID Controller as a directory tree structure. At the top is the RAID 
Controller, then the controllers, then the drive groups owned by the controller, then the 
logical units and drives in that drive group. At the bottom of the display (not shown 
here) are the hot spares and unassigned drives. Clicking on the different structures 
changes the display on the right of the screen.

This gives information on 
the drive groups and 
logical units in the RAID 
Controller. The items 
displayed here depend on 
what is selected in the 
directory tree display to the 
left.
The display shown here is 
the master display, shown 
when the RAID Controller 
itself is selected.
See Table 9 on page 47 for 
a description of the 
elements in the display.

These buttons are active or grayed out depending 
on what RAID Controller structure is currently 
selected in the directory tree.
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Notes:

• Click on the “+” or “-” signs to expand or collapse the tree.

• Clicking on an element in the tree display changes the information displayed in the 
right half of the screen. For example, if you click on a drive group, only information on 
that drive group is displayed on the right. If you click on the unassigned drive group, 
information on the drives in the unassigned group (drive ID and capacity) is displayed 
on the right.

• You cannot click on items in the right-hand display.

Creating Logical Units (LUNs)

Table 9: Configuration Display Columns

Column Heading Explanation

Group/Ctl The controller (A or B) or drive group.

Drives The number of drives in the drive group.

Total (MB) The total capacity of the drive group, after accounting for RAID level.

Remaining (MB) The total capacity remaining in the drive group.

LUN The logical units (LUNs) in the drive group.

Name/ID

The name or ID of the controller, logical unit, or drive, depending on the 
display. 

• Controller and logical unit names are usually assigned by the operating 
system, although in the networked version of the storage management 
software you can assign names to them with the Edit function of the Module 
Selection screen (see "RAID Controller Module Selection Screen" on page 
34).

• Drive IDs are the channel number and SCSI ID of the drives. See "Drive 
Names" on page 8 for more information.

RAID Level The RAID level of the logical unit.

Capacity (MB) The capacity of the logical unit.

Status
The current status of the logical unit. If a status other than Optimal appears 
here, run Recovery Guru to determine what the problem is, and, if necessary, 
what action to take.
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You can create a new LUN in two ways:

• By creating a new LUN from unassigned drives (see "Creating A Logical Unit From 
Unassigned Drives").

• By creating a new LUN from capacity remaining in a drive group (see "Creating A 
LUN From Remaining Capacity" on page 50).

Creating A Logical Unit From Unassigned Drives

To create a new LUN from unassigned drives, you must have drives remaining in the 
Unassigned drive group. If there is no Unassigned drive group, this option will be grayed 
out. Creating a new LUN from unassigned drives creates a new drive group.

Use the following steps to create a LUN from unassigned drives.

1. Start the Configuration application.

2. Select the RAID Controller on which you want to create the new LUNs.

3. Select the RAID Controller or the Unassigned Drive group and click on the Create 
LUN button. A screen like Figure 19 on page 49 is displayed.

4. Set the RAID level you want to assign to the new LUN. The RAID level might change 
the Number of Drives setting, or may be limited by the number of drives available. For 
example, you need at least 3 unassigned drives to create a RAID 3 or 5 logical unit, and 
you must have an even number of drives for a RAID 1.

5. Set the number of drives you want to include in the new LUN. The drives are 
automatically assigned unless you change the value by selecting Options. Changing the 
number of drives here may change the RAID level setting. For example, if you select 
RAID 1 and then specify an odd number of drives here, the RAID level will change.

6. Set the number of LUNs you want to create on the new drive group. This may be 
limited by the total number of LUNs you can create on your RAID Controller. Each 
LUN created gets an equal amount of the displayed capacity. For example, if you 
specify two LUNs, each LUN gets half the displayed capacity. You can change the 
capacity value by selecting Options.

7. The new drive group will automatically be assigned to a controller if the RAID 
Controller has redundant controllers. The first drive group you create in a configuration 
session will be assigned to controller A, the second to controller B, the third to 
controller A again and so on. If you repeatedly create one drive group per session, 
therefore, all the created drive groups will be assigned to the same controller. You can 
change controller assignment by selecting Options. To balance LUNs after you create 
them, see "Balancing LUNs" on page 115.
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8. If you want to view or change the default settings for drives, capacity, segment size, 
caching, or LUN assignment, click on Options. See "Using the Options Screens" on 
page 52 for a description of those screens.

IMPORTANT If your RAID Controller contains drives of different sizes, you should use 
the Options → Drive Selection option to make sure that all the drives 
assigned to the new LUN are of the same size. Otherwise, LUN capacity 
will be based on the smallest drive size in the LUN, and capacity will be 
wasted.

Figure 19.  Create LUN Main Screen (Unassigned Drives)

Select one of these RAID buttons to assign 
a RAID level to the new LUN. RAID level 
helps determine the possible capacity and 
Number Of Drives settings.

Specify the number of drives in the new 
LUN here. The number of drives you may 
assign depends on the RAID level selected 
and on the number of unassigned drives 
available. Changing this value may change 
the selected RAID level.

Information describing the currently 
selected RAID level is displayed here. 
Available Group Capacity gives the 
capacity of the group after considering the 
RAID level selected.

Click here to start LUN creation with the current parameters.

Select the number of new LUNs to create 
here. This value may be limited by the 
number of LUNs available on your system.

This part of the screen gives help 
information Click here to exit without creating a LUN.

Click here to view or change LUN options (capacity, drives, caching, 
segment size, and controller assignment). See Figure 21 through Figure 
25 for examples of those options.
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9. After you have set all the LUN parameters you want, start LUN creation by clicking 
Create in the Create LUN screen.

IMPORTANT If you change any parameters in the Create LUN screen after making 
changes in the Options screens, any Options changes are negated.

10.The new LUNs are created. 

Note: If you are creating the first LUN on the module, wait for the create/format to finish 
before creating any LUNs on other drive groups. In addition, Module Profile 
information may not be displayed correctly until the first LUN is created.

11.After the LUNs are created, you need to do whatever is necessary on your operating 
system to make the LUNs available for use. This might involve restarting the system, 
creating file systems and volumes, and so on. Check your operating system 
documentation and the Installation and User’s Handbook for your operating system for 
more information.

Creating A LUN From Remaining Capacity

To create a new LUN from remaining capacity in an existing drive group, you must have 
drive groups with unused capacity. The new LUN will have the same RAID level, drives, 
and controller assignment as the current drive group.

Use the following steps to create a LUN from the remaining capacity in a drive group.

1. Start the Configuration application.

2. Select the RAID Controller on which you want to create the new LUNs.

3. Select the Drive Group in the Module directory tree and click on the Create LUN 
button. A screen like Figure 20 on page 51 is displayed.

4. Set the number of LUNs you want to create from the unassigned capacity. This may be 
limited by the total number of LUNs you can create on the RAID Controller. By 
default, each LUN created gets an equal amount of the displayed capacity. 

5. If you want to change the default settings for capacity, segment size, or caching, click 
on Options (see "Using the Options Screens" on page 52).

6. After you have set all the LUN parameters you want, start LUN creation by clicking 
Create in the Create LUN screen.

IMPORTANT If you change any parameters in the Create LUN screen after making 
changes in the Options screens, any Options changes are negated.
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7. The new LUNs are created. 

8. After the LUNs are created, you need to do whatever is necessary on your operating 
system to make the LUNs available for use. This might involve restarting the system, 
creating file systems and volumes, and so on. Check your operating system 
documentation and the Installation and User’s Handbook for your operating system for 
more information.

Figure 20.  Create LUN Main Screen (Existing Drive Group)

Notes:

• You cannot change the RAID level or drives in the LUN. 

• The new drive group will automatically be assigned the controller that currently owns 
the drive group.

This area displays the RAID level, number of drives, 
and available group capacity for the drive group. You 
cannot change any of these parameters.

Set the number of LUNs you want to create here. This 
may be limited by the total number of LUNs available 
on your system.

Click here to create the 
LUNs specified.

Click here to exit this 
screen without creating a 
new LUN.

Click here to view or 
change the LUN capacity, 
cache parameters, and 
segment size. You cannot 
change drives or controller 
assignment. See "Using the 
Options Screens" on page 
52 for more information on 
changing options.

This part of the screen gives 
help information.

Click here to exit this 
screen without creating a 
new LUN.
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Using the Options Screens

The Options screens allow you to view or change:

• The capacity of the LUNs to be created (see Figure 21 on page 53).

• The drives in the LUN (see Figure 22 on page 54).

• The caching parameters (see Figure 23 on page 55).

• The segment size (see Figure 24 on page 56).

• The controller that “owns” the new LUN. This option is allowed only if your RAID 
Controller has active/active redundant controllers (see Figure 25 on page 57).

Note: When you move from screen to screen, you automatically save the values displayed 
in the current screen.
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LUN Capacity Option

Use the LUN Capacity option to set the capacity of the new LUNs. By default, the new 
LUNs are assigned an equal proportion of the total capacity of the drive group. For 
example, if you create 2 logical units, each is assigned half the total capacity.

Figure 21.  LUN Capacity Screen

Notes:

• Normally, you will want to use the maximum capacity setting.

Drive Selection Option

Use the Drive Selection option to specify the drives assigned to the new LUN/drive group. 
In particular, you should make sure that all the drives in the new LUN/drive group have 
the same capacity. You should also attempt to make sure that all drives are on different 
channels (the first number in the drive ID), although this is not always possible. Assigning 
drives on different channels prevents a channel failure from disabling multiple drives.

This box displays the capacity 
remaining in the drive group.

Click here to go back to the 
Create LUN screen using the new 
values.

Click here to return to the Create 
LUN screen without changing the 
capacity. Values set in other 
options screens are retained.

Click here to return to 
the original settings.

See Figure 23 on page 55. See Figure 24 on page 56. See Figure 25 on 
page 57.

See Figure 22 on page 54.

Click here to set the 
capacity for the specified 
LUN or enter a value 
manually. The value in 
the Remaining Group 
Capacity box is updated 
to reflect the new setting. 
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Figure 22.  Drive Selection Screen

Note: You cannot exit this screen if you have specified more drives than you entered in the 
Create LUN Main screen (Figure 19 on page 49).

See Figure 23 on page 55. See Figure 24 on page 56. See Figure 25 on 
page 57.

See Figure 21 on page 53.

Click here to return to the 
original values.

This box displays the drives 
available for assignment and their 
capacities. To assign a drive, 
highlight it and click the Move 
button.

Click here to return to the Create 
LUN screen using the new values. 

This box displays the drives 
currently assigned and their 
capacities. If the RAID level 
is RAID 1, this box also 
shows the mirrored pairing. 
To move a drive from this box 
to the unassigned box, 
highlight the drive and click 
on the Move button.

Click here to return to the Create 
LUN screen assigning any drives. 
Values set in other options 
screens are retained.
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Cache Parameters Option

Use the Cache Parameters option to change the cache parameters assigned to the new 
LUNs. Parameters are assigned on a LUN basis. See "Cache Memory" on page 5 and 
"Changing Cache Parameters" on page 121 for more information on the cache parameters.

Figure 23.  Cache Parameters Screen

Note: See Table 18 on page 122 for a description of cache parameter interdependencies.

See Figure 22 on 
page 54.

See Figure 24 on 
page 56.

See Figure 25 on 
page 57.

See Figure 21 on 
page 53.

Information on the cache without 
batteries parameter is displayed 
here.

Click here to return to the Create 
LUN screen using the new values.

The cache parameters are 
listed here by LUN. Click the 
parameters you want to assign 
to the LUN. Note that setting 
or deleting certain values will 
set and delete other related 
values.

Click here to return to the 
original values.

Click here to return to the Create 
LUN screen without changing the 
cache parameters. Values entered 
in other options screens are 
retained.
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Segment Size Option

This option changes the segment size used by the new LUNs.

Figure 24.  Segment Size Screen

Notes:

• You can set the segment size for individual LUNs; LUNs in a drive group do not need 
to have the same segment size value.

• You can change the segment size of a LUN after you create it; see "Modifying Segment 
Size" on page 63.

See Figure 22 on 
page 54.

See Figure 23 on 
page 55.

See Figure 25 on 
page 57.

See Figure 21 on 
page 53.

Click here to 
return to the 
original 
values.

The current segment size for each 
LUN is displayed here. Use the 
spinner to increase or decrease 
this size.

Click here to return to the Create 
LUN screen without changing 
segment sizes. Values entered in 
other options screens are retained.

Click here to return to the Create 
LUN screen using the new values. 
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LUN Assignment Option

Use this option to change the controller assignment of the new LUN.

Figure 25.  Set LUN Assignment Screen

Modifying Drive Groups and LUNs

Once a drive group/logical unit is created, you can modify it in the following ways:

• Change the RAID level — you can dynamically change the RAID level of all the 
logical units in a drive group. All logical units in the drive group must still have the 
same RAID level. You may be limited in the new RAID level by the number of drives 
in the drive group; for example, you cannot change a 5-drive RAID 5 to RAID 1 
because RAID 1 must have an even number of drives. See "Changing RAID Level" on 
page 60.

• Add Capacity — you can increase the capacity of a drive group by adding drives. This 
does not increase the capacity of the LUNs in the drive group. The amount of increase 
depends on the number of drives added and the RAID level (see Table 10 on page 61). 
See "Adding Drives" on page 61.

See Figure 22 on 
page 54.

See Figure 23 on 
page 55.

See Figure 24 on 
page 56.

See Figure 21 on 
page 53.

Click here to return to the 
original values.

This button shows the current 
controller assignment for the new 
drive group. Click the controller 
you want to own the new drive 
group.

This display shows the 
current drive group and 
LUN assignment for the 
two controllers.

Click here to return to the Create 
LUN screen using the new values.

Click here to return to the Create 
LUN screen without reassigning 
the drive group. Values entered in 
other options screens are retained.
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• Modify the segment size — you can change the segment size of individual logical units 
(you don’t have to change all the logical units in the drive group). This may improve 
performance. See "Modifying Segment Size" on page 63.

• Defragment the logical units on the drive group — this may increase total available 
capacity. See "The Defragment Option" on page 58 for a description of defragmenting 
and when it applies.

• Change the cache parameters — you can change the write caching, write cache 
mirroring, and cache without batteries parameters using the Maintenance and Tuning 
application. See "Changing Cache Parameters" on page 121. You can change other 
cache parameters using the rdacutil utility. See the rdacutil entry on page 134.

• Change the reconstruction rate — you can change the reconstruction rate assigned to 
individual logical units. See "Changing The LUN Reconstruction Rate" on page 113.

You cannot make the following changes without deleting a logical unit and recreating it.

• Change the LUN capacity.

• Decrease the number of drives in the drive group.

The Defragment Option

The Defragment option is used to reclaim space on your drive group that might be 
inaccessible after LUN deletion. This is a result of the way data is written to the logical 
units.

For example, Figure 26 shows a three-drive logical unit. Each logical unit has a capacity 
of 600 MB, with 200 MB written on each disk (ignore RAID level effects on capacity for 
purposes of this example). Remaining capacity in the drive group is 900 MB.

Figure 26.  Defragment Logical Units #1

Now assume LUN 2 (the middle LUN) is deleted. This is shown in Figure 27.
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MB
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MB
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MB
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MB

LUN 2 -- 200 
MB

Empty -- 300 
MB

LUN 1 -- 200 
MB

LUN 3 -- 200 
MB

LUN 2 -- 200 
MB

Empty -- 300 
MB

Drive 1 Drive 3Drive 2
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Figure 27.  Defragment Logical Units #2

Even though there is actually 1500 MB of empty space in this drive group, for purposes of 
actual logical unit creation, the largest logical unit that can be created is 900 MB, because 
a logical unit must be created in a contiguous area. The Configuration application will 
show the remaining capacity as 900 MB, ignoring the additional 600 MB. 

Assume you create a new LUN 2 of 200 MB. The new logical unit will be written in the 
300 MB remaining capacity, as shown in Figure 28 on page 59.

Figure 28.  Defragment Logical Units #3

Total remaining capacity is 900 MB, but the configuration utility will show a capacity of 
600, because that is the biggest single area in which a logical unit can be created. The 
remaining 300 MB is unavailable until you create a LUN larger than 300 MB in the free 
area. Configuration always shows the largest contiguous area available.

The Defragment option rewrites the data on the drive group so that all the free space is 
contiguous. For example, if the Defragment option is performed on the drive group in 
Figure 28, the resulting drive group will look like Figure 29.
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Figure 29.  Defragment Logical Units #4

Note that the logical units have been “moved down” to fill in the gap left by the deletion of 
the logical unit. The remaining capacity for this drive group is shown as 900 MB again, 
because all the free space is now contiguous.

You may need to run the Defragment option after deleting a logical unit from a drive 
group if there is more than one logical unit on that drive group. The option will tell you if 
there is any space that needs to be reclaimed on the drive group. See "Defragmenting The 
Drive Group" on page 64 for procedural information.

Changing RAID Level

Use this procedure to change the RAID level of all the logical units in a drive group. 

1. Start the Configuration application.

2. Select the RAID Controller containing the logical units you want to modify.

3. Select the Drive Group you want to modify in the Module directory tree.

4. Click on the Modify Group/LUNs button, then select Modify RAID Level, or select the 
option from the drop-down menus. A screen like Figure 30 is displayed.

5. Select the RAID level you want for the drive group. Keep in mind that you may be 
limited by the number of drives in the group. For example, if the drive group has an 
odd number of drives, you will not be able to select RAID 1.

6. After you have selected the new RAID level, click OK to make the change.

7. As the controller changes the RAID level, the configuration display will show a status 
of “Modifying” for the drive group and for the individual logical units. The status will 
give a percentage, indicating the percentage of the individual logical unit modified and 
the percentage of the overall drive group modified. When the status of all elements 
changes to Optimal, the operation is complete.
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LUN 1 -- 200 
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LUN 2 -- 200 
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LUN 3 -- 200 
MB

Empty -- 300 
MB

LUN 1 -- 200 
MB

LUN 2 -- 200 
MB

LUN 3 -- 200 
MB

Empty -- 300 
MB

Drive 1 Drive 3Drive 2



Chapter 4. Configuring RAID Controllers 61

Figure 30.  Modify RAID Level Screen

Adding Drives

Use this procedure to increase the capacity of a drive group by adding drives to the group. 
Table 10 gives the formulae for calculating how much space is added to the drive group. 

NOTE Adding drives does not increase the size of the LUNs in the drive group. The 
LUNs are spread out over the added drives. However, after adding drives, the 
drive group will have capacity for new LUN creation.

Table 10: Adding Capacity Formulas

RAID Level The Drive Group Capacity Is Increased By:

RAID 1 1/2 the Number of Drives Added x Capacity of Drives

RAID 0, 3, or 5  Number of Drives Added x Capacity of Drives

For example, assume a 5-drive drive group containing RAID 5 logical units. Each drive is 18 GB, giving 
a current group capacity of 72 GB (one drive’s worth of capacity is required for parity). Adding two 
drives to the drive group would increase the capacity of the drive group by 2 x 18 or 36 GB. The drive 
group would then have a capacity of 72 + 36 or 108 GB. 

This shows the current RAID level, number of drives, and logical units in 
the drive group.

Select the new RAID level here. If the 
RAID level is grayed out, you cannot 
change the drive group to that RAID 
level. This is usually due to the 
number of drives in the current group.

Click here to change the RAID level.

Click here to exit without changing the 
RAID level.
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Perform the following procedure.

1. Start the Configuration application.

2. Select the RAID Controller containing the logical units you want to modify.

3. Select the Drive Group you want to modify in the Module directory tree.

4. Click on the Modify Group/LUNs button, then select Group Capacity, or select the 
option from the drop-down menus. A screen like Figure 31 is displayed.

5. Select the drives you want to add to the drive group. You should pick drives of the 
same size as the current drives in the group.

6. After you have selected the drives, click OK to make the change.

7. As the controller adds the drives, the configuration display will show a status of 
“Modifying” for the drive group and for the individual logical units. The status will 
give a percentage, indicating the percentage of the individual logical unit modified and 
the percentage of the overall drive group modified. When the status of all elements 
changes to Optimal, the operation is complete.

Figure 31.  Modify Group Capacity Screen

This shows the current RAID level, number of drives, and logical units in the 
drive group.

This shows the unassigned drives 
available to be added to the drive 
group. You can select more than 
one drive (for a RAID 1 logical 
unit, you must select an even 
number of drives).

Click here to add the selected drives to the drive group.

Click here to exit without adding 
drives to the drive group.
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Modifying Segment Size

Use this procedure to modify the segment size of individual logical units. You do not have 
to change all the logical units in a drive group. Perform the following procedure.

1. Start the Configuration application.

2. Select the RAID Controller containing the logical units you want to modify.

3. Select the Drive Group or LUN you want to modify in the Module directory tree.

4. Click on the Modify Group/LUNs button, then select Modify Segment Size, or select 
the option from the drop-down menus. A screen like Figure 32 is displayed.

5. One at a time, select the logical units you want to modify, then pick the new segment 
size.

6. After you have changed the segment size, click OK to make the change.

7. As the controller changes the segment size, the configuration display will show a status 
of “Modifying” for the drive group and for the individual logical units. The status will 
give a percentage, indicating the percentage of the individual logical unit modified and 
the percentage of the overall drive group modified. When the status of all elements 
changes to Optimal, the operation is complete.

Figure 32.  Modify Segment Size Screen

Select the logical units you want to modify here. 

When you select a logical unit, the current 
segment size setting is displayed here.

Select the new size here.

Click here to change the segment size as specified.

Click here to exit without changing the 
segment size.
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Defragmenting The Drive Group

Defragmenting the drive group can free up space after the deletion of a logical unit from 
the drive group. See "The Defragment Option" on page 58 for more information.

To defragment the drive group, perform the following procedure.

1. Start the Configuration application.

2. Select the RAID Controller containing the logical units you want to modify.

3. Select the Drive Group you want to modify in the Module directory tree.

4. Click on the Modify LUNs button, then select Defragment, or select the option from 
the drop-down menus. 

5. A message is displayed, stating:

• That there is no space to recover in the drive group you selected. Click OK to return 
to the Main Configuration screen. You are finished with this procedure.

• That there is space to be recovered on the selected drive group. The message 
indicates how much space can be recovered. Click OK to recover the space or click 
Cancel to return to the Main Configuration screen.

6. If there is space to recover and you clicked OK, the software begins to defragment the 
drive group. As the controller defragments the drive group, the configuration display 
will show a status of “Modifying” for the drive group and for the individual logical 
units. The status will give a percentage, indicating the percentage of the individual 
logical unit modified and the percentage of the overall drive group modified. When the 
status of all elements changes to Optimal, the operation is complete.

Deleting LUNs

When you delete a LUN, any data in the LUN is lost. If you delete all the LUNs in a drive 
group, the drives in the drive group return to the unassigned drive group.

CAUTION Do not delete all the LUNs in the RAID Controller and exit configuration 
without creating at least 1 LUN. Doing so could prevent you from 
accessing the RAID Controller. 

Before you delete a LUN, check your Installation and User’s Handbook 
to see if there are any special restrictions or special requirements on LUN 
deletion. For example, you may be required to first delete partitions, 
deassign drives, or unmount file systems before deleting. After you delete 
a LUN, you may need to perform procedures on your operating system 
before it recognizes that the LUN is gone. For example, you may need to 
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restart your system before the operating system records the LUN deletion. 
Also see the special consideration "Deleting LUNs In The Network 
Configuration" on page 66.

To delete a LUN, perform the following steps:

1. Perform whatever steps are necessary on your operating system to prepare for LUN 
deletion. See your operating system documentation and the Installation and User’s 
Handbook for information.

2. Start the Configuration application.

3. Select the RAID Controller containing the LUN you want to delete.

4. Select the drive group containing the LUN you want to delete in the Module directory 
tree.

5. Press the Delete key, select Options → Delete from the drop-down menus, or right 
click on the drive group containing the LUN, then select Delete. A screen like Figure 
33 on page 66 appears.

6. Select the LUNs you want to delete, or click Select All to delete all the LUNs in them 
drive group.

7. When the LUNs you want to delete are highlighted, click Delete.

8. After the LUNs are deleted, you need to do whatever is necessary on your operating 
system to delete a drive. This might involve restarting the system, clearing file tables, 
and so on. See your operating system documentation and the Installation and User’s 
Handbook for your operating system for more information.
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Figure 33.  Delete LUNs Screen

Deleting LUNs In The Network Configuration

If you are using the Networked version or a host-RAID Controller configuration with 
more than one host (see "Controller Configurations" on page 13), it is possible to open a 
Configuration Application and begin Delete from more than one host/station. However, 
you must be sure that you are using only one configuration session at a time or the drive 
group/LUN you delete could be in use and cause problems for one of the hosts.

Creating Hot Spares

Hot spares add another level of protection to the data on your RAID Controllers. Hot 
spares automatically replace failed drives in your logical units. You can only create hot 
spares if you have unassigned drives.

IMPORTANT A hot spare cannot replace a drive with a larger capacity. If you have 
drives of two different capacities in your RAID Controllers, you should 
select a drive of the larger capacity as your hot spare drives.

To create a hot spare drive, do the following.

1. Start the Configuration application.

2. Select the RAID Controller you want to create hot spares for.

3. Highlight the Unassigned drive group or the Hot Spare drive group.

Select the individual LUNs you want to delete.

Click here to exit this screen without deleting any LUNs.

Click here after you have selected the LUNs you want to 
delete.

Click here to select all the LUNs displayed.
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4. Click on the Hot Spare button or select Options → Create Hot Spare from the drop-
down menus. A screen like Figure 34 is displayed. 

5. Enter the number of hot spares you want to create. You can create as many hot spares 
as there are drive channels on your RAID Controller (this can be further limited by the 
number of unassigned drives remaining in the RAID Controller).

.

Figure 34.  Create Hot Spare Screen

6. If you want, select Options to physically select the drive you want to assign as a hot 
spare. In most cases, you should just take the default choice and not use this option. It 
may be necessary to use this option if you have unassigned drives of more than one 
size and need to make sure that you have selected the highest capacity drive as the hot 
spare.

7. Click OK to create the hot spare drives.

Click here to create the hot spare.

Click here to select the drives to use 
for the hot spare. Use this option if 
you have drives of more than one size 
to make sure you assign a drive of the 
largest capacity as a hot spare. A 
screen like Figure 35 on page 68 
appears.

Click here to exit this screen without 
creating a new hot spare.

Set the number of hot spares you want to create here. You may be limited by the number of channels on your 
RAID Controller, by the number of hot spares already created, and by the number of unassigned drives available.
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Figure 35.  Select Hot Spare Screen

Notes:

• You can create as many hot spares on the RAID Controller as there are drive channels.

• Always use the largest capacity drives for hot spares.

Deleting A Hot Spare

When you delete a hot spare, the drive returns to the unassigned drive group. To delete a 
hot spare, perform the following steps.

1. Start the Configuration application.

2. Select the RAID Controller containing the hot spare you want to delete.

3. Select the Hot Spare drive group.

4. Press the Delete key or select Options → Delete from the drop-down menus. A screen 
like Figure 36 is displayed, listing all the drives currently assigned as hot spares. 

5. Select the hot spares you want to delete, then click Delete.

6. The selected hot spares are deleted and returned to the Unassigned drive group.

This box shows the unassigned drives available to be assigned 
as hot spares. Highlight a drive and click the Move button to 
assign them as hot spares.

Click here to exit this screen without creating any hot 
spares.

Use this button to move drives between the two 
boxes.

This box shows the drives to be made into hot spares. 
Highlight a drive and click on the Move button to 
move the drive back to the unassigned group.

Click here to return to the Create Hot Spares screen.
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Figure 36.  Delete Hot Spares Screen

Resetting the Configuration

CAUTION Use this option only as a last resort if your configuration is totally 
inaccessible or you want to completely redo your configuration.

When you reset the configuration, the selected RAID Controller (all drive groups and their 
logical units) is reset back to a default configuration based on NVSRAM settings specified 
in the controller. 

• Because deleting LUNs causes data loss, back up data on all the drive group/LUNs in 
the RAID Controller. This operation also deletes any filesystems mounted on the 
LUNs.

• You must first stop I/Os to the affected RAID Controller and you should ensure no 
other users are on the system.

• You cannot reset the configuration on a RAID Controller with an independent 
controller configuration. For a description of this configuration, see "Independent 
Controller Configuration" on page 17.

• This operation could also fail if the storage management software cannot gain 
exclusive access to the drive groups/LUNs, such as if filesystems are mounted. 

Highlight the hot spare drives you want to 
delete in this display or click Select All to 
select all the hot spares.

After you have selected the hot spares you want to delete, click 
here to delete them and return the drives to the unassigned drive 
group.

Click here to exit without deleting any hot 
spares.
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To reset the configuration on the RAID Controller, perform the following steps.

1. From the top menu, select File → Reset Configuration.

2. Select OK to confirm that you want to reset your configuration.

CAUTION Resetting the configuration will destroy all data on all the logical units in 
your RAID Controller! Step 3 is your last chance to Cancel! 

3. Select OK to confirm again that you want to reset your configuration.

A default configuration appears in the main Configuration screen.

Note: This does not necessarily mean that you have all unassigned drives; you may have a 
small LUN configured.

4. Select OK at the “Reset Was Successful” confirmation screen.

5. You will have to redefine all of your logical units and drive groups using Create LUN.

Note: Your operating system may have additional requirements to complete the 
configuration process so that it can recognize the new LUNs, including adding 
drives and possibly restarting the operating system. Refer to the Installation and 
User’s Handbook specific to your operating system (restrictions and troubleshooting 
sections) and to the appropriate system documentation for specific details.
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Chapter 5. Checking Status

This chapter describes how to check RAID Controller status and performance.

Status Overview

The storage management software monitors the status of the RAID Controllers in the 
background and logs any status changes, or “events,” in a log file. These events may be 
component failures, parity check/repair operations, or configuration changes. You use the 
Status application to view and maintain this log file. 

Background Polling

The storage management software polls all RAID Controllers periodically to find any 
status changes or other “events.” When a status change is found, the software writes 
detailed information on the event into the log file. 

You can set the polling interval for this background check (see "Changing Log File 
Settings" on page 76). The default time is 5 minutes. You can set any time from 1 to 59 
minutes. However, setting too small a time may slow system performance because of the 
time required to poll, and setting too large a time may delay notification of serious 
failures.

The Message Log File

The message log is the file the application uses to store event messages. The default file is 
defined by your operating system (see the Installation and User’s Handbook), but can be 
changed to any file (see "Changing Log File Settings" on page 76).

The log file has a maximum size limit, which is set by default to 40K (this limit can be 
changed; see "Changing Log File Settings" on page 76). When you open any storage 
management application after this limit has been reached, the log file is automatically 
copied to a backup file and all messages are erased (see"Clearing The Message File" on 
page 77 for a description of this procedure). Until you open an application and reset the 
log file, however, messages will continue to be written to the file, even after the limit has 
been reached.

You can save the contents of the log file by selecting File → Save Log As from the drop-
down menus. This does not delete the original file or change the default file. Saving the 
log saves the entire contents of the log file, regardless of which RAID Controller or 
message types are currently selected.
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You can open a saved file later by selecting File → Open Log from the drop-down menus. 
This does not change the default log file.

Message Types

The software has three categories of events as shown in Table 11:

The Status Log And Health Check

Note that in some cases, you may discover a problem when running Recovery Guru/
Health Check that is not in the Message Log. This is due to the delay in the polling 
interval. If the error occurred after the last polling cycle, but before the current one, Health 
Check will find the error even though it is not yet in the log.

Event Notification

Depending on the operating system, you can set up SNMP or other scriptable notification 
to perform some other action when an event is found. See the Installation and User’s 
Handbook for your operating system for details.

Viewing The Log

To view the status log, perform the following steps.

1. Open the Status Application.

Table 11: Message Types

Type Description

Parity
Messages related to parity check/repair (either manual or automatic). The message details 
give the location of any bad blocks found, the affected logical unit, and the number of 
blocks repaired.

Hardware

Messages related to component failures. The message details give the affected component, 
the affected logical unit (if any), the probable cause, and the action to take (usually you will 
be advised to run Recovery Guru/Health Check).

The message may also give ASC (Additional Sense Code) and ASCQ (ASC Qualifier) 
information. This is SCSI information providing further details about the failure. This 
information is most useful for troubleshooting by Customer Services personnel.

General
Messages related to log file backups, I/O errors, configuration changes, and other event 
types. The message details will try and give a further description of the event. In many 
cases, they will require no action.
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2. Select the RAID Controller you want to view status information for (or select All 
RAID Controllers).

3. Click on the Message Log button or select Options → Message Log from the drop-
down menus. 

The contents of the currently selected message log is displayed (if you didn’t select 
another message log file, this is the default message log). Figure 38 on page 74 shows 
an example of the screen displayed.

4. If you want to view a log other than the current default message log, go to File → Open 
Log and specify the log file you want to view.

5. If desired, click on List Type to filter the types of messages displayed (Figure 37). 

6. Continue with Step 7 on page 75.

Figure 37.  Selecting Message Type

Select the types of message you want displayed by 
clicking in the appropriate box. After you have 
selected the message types you want, click OK. See 
Table 11 on page 72 for a description of message types.

If you select Hardware messages, you can further filter 
the messages by entering the ASC/ASCQ codes you 
want to view.

Click here to display the selected 
message types.

Click here to exit this screen without 
changing the messages displayed.
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Figure 38.  Message Log Screen

Table 12: Message Log Explanation

Column Heading Explanation

Date & Time

Indicates when the detected event was logged.

• If the event is a component failure detected by the background monitor, this is 
the time the error was detected, not necessarily when it occurred.

• If the event is a parity error, this is the time the error was detected and corrected 
by Parity Check/Repair.

• If the event is a general status change, this is the time the change was detected.

RAID Moduler The RAID Module where the event occurred. 

Type The type of RAID Controller event; either Hardware, Parity, or General (see 
"Message Types" on page 72).

Code The ASC/ASCQ code for the hardware message, if any. Help has a summary of 
these codes.

Controller The system device name of the affected controller.

The messages shown in the display are for the selected RAID Controller.

This display gives summary 
information on the messages in the 
currently selected message log. 
Table 12 explains the entries shown.
Highlight the messages you want to 
view, then click Show Details.

Click here for Help.

Click here to select all 
the messages, then click 
Show Details.

Click here to specify the 
types of messages you 
want to display (see 
Figure 37 on page 73).

Click here to display 
detailed information on 
the selected messages 
(see Figure 39 on page 
75).

This bar shows the selected 
message log, the number of 
messages in the log, and the number 
of messages selected.
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7. Highlight a displayed message or messages and click Show Details to get more 
information on the message. A screen like Figure 39 is displayed.

Figure 39.  Message Details Screen

8. View the details and take the appropriate action.

9. You can also perform the following actions:

• Save the message log file to another file — select File Save → Log As from the 
drop-down menus. See "The Message Log File" on page 71.

• Open another, previously saved, log file — select File → Open Log from the drop-
down menus.

• Copy message text to the clipboard — highlight text in the Message Details screen 
and select Edit → Copy To Clipboard. You can only perform this option from the 
Details screen (Figure 39).

• Refresh the screen — select Options → Refresh All from the drop-down menus. 
This updates the message log with any events that occurred since you opened the 
log. You can only perform this option from the Summary screen (Figure 38 on page 
74).

10.When you are finished viewing the messages, close the Status application or select 
another option.

This displays detailed information 
on a selected message. The 
message includes information on 
the affected component, the 
probable cause, and the action to 
take. Usually, you should run 
Recovery Guru for a complete 
description of the action to take.

This shows the message you are 
viewing and the total number of 
messages selected.

Click here to return to the message 
summary screen (see Figure 38 on 
page 74).

Click here for help.If you have selected more than one 
message, click Next or Previous to 
move through the selected messages.



76 IBM Netfinity SYMplicity Storage Manager User’s Handbook

Changing Log File Settings

You can change the following log settings (see "The Message Log File" on page 71):

• Default log file — this is the file where RAID events are written to.

• Maximum Message Log Size — This is the file size that must be exceeded before the 
file is backed-up and cleared (see "Clearing The Message File" on page 77). Note that 
setting a size does not limit the size of the file. The file will to grow beyond this limit 
until you open a storage management application and reset it.

• Polling interval — This is the frequency in minutes that the background monitor 
checks the RAID Controllers. Setting too small a value may affect system 
performance. Setting too large a value may delay notification of serious errors.

Use the following procedure to change log file settings.

1. Start the Status Application.

2. Select any RAID Controller (this change affects all RAID Controllers).

3. Select Options → Log Settings from the drop-down menus. A screen like Figure  is 
displayed.

4. Enter the values you want, then click Save (or view the current values and click cancel 
to exit without changing values).

Figure 40.  Log Settings Screen

Enter the file name of the new 
default log file here.

Enter the maximum size limit 
here.

Enter the polling interval here. 
Entering too small a value may 
slow system performance; 
entering too large a value may 
delay notification of serious 
failures.

Click here to save the new values. Click here to exit without 
changing any values.
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Clearing The Message File

If you open a storage management application and the message log file currently exceeds 
the defined maximum size limit (see "Changing Log File Settings" on page 76), the 
message log file is saved and cleared. The following sequence occurs:

1. When you open the storage management application, a warning message like Figure 41 
is displayed.

2. Click OK.

• If the file rmlog.<hostname>_1 does not exist, the message file is backed up to the 
rmlog.<hostname>_1 file and cleared. 

• If the file rmlog.<hostname>_1 already exists, a screen like Figure 42 on page 78 is 
displayed.

3. Click Yes if you want to write over the current rmlog.<hostname>_1 file. Click No if 
you want to create the next file in the sequence (_2, _3, _4, and so on). 

4. The first message in the new log file will notify you that this backup occurred. 
Highlight the message and click Show Details to find the name of the backup file used.

Figure 41.  Message Limit Warning Message

This screen indicates that the default 
message file has reached or exceeded its 
defined maximum size limit. 

This is the name of the backup file to 
be created. The default save name is 
always rmlog.<hostname>_1. 

Click OK to continue. If the rmlog.<hostname>_1 file does not exist, the 
current contents of the file is written to the backup file and the message log 
file is cleared. If the rmlog.<hostname>_1 file already exists, a screen like 
Figure 42 on page 78 is displayed when you click OK.
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Figure 42.  Message Log Save Message

Using The Performance Monitor

IMPORTANT Before you start the Performance Monitor, make sure you have I/O going 
to the RAID Controllers you want to monitor.

To run the Performance Monitor, perform the following steps:

1. Start the Status application.

2. Select the RAID Controller you want to monitor. 
(Do not select All RAID Controllers.)

This screen tells you that a file 
named rmlog.<hostname>_1 already 
exists. 

Click Yes to write over the current 
rmlog.<hostname>_1 file.

If you click No, the next file in the 
sequence, given here, will be 
created.

t 

Click No to copy the message log to 
a new file.
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3. Click on the Performance Monitor button or select Options → Performance Monitor 
from the drop-down menus. A screen like Figure 43 is displayed.

Figure 43.  Performance Monitor Settings Screen

4. Select the Controllers/LUNs you want to monitor and click OK. A screen like Figure 
44 is displayed.

5. Click Start to start the Performance Monitor. A screen like Figure 45 on page 80 is 
displayed.

Select the controllers or LUNs you want to 
monitor here. Click Select All to highlight 
all the elements in the RAID Controller.

Set the Polling interval here. This is the 
frequency which the Performance Monitor uses 
to check I/O activity on the RAID Controller.

Click here to start the Performance Monitor using the current 
settings.

Click here to exit without starting the 
Performance Monitor.

Set the Polling interval here. This is the 
frequency which the Performance Monitor uses 
to check I/O activity on the RAID Controller.

Click here to start the Performance Monitor using the current 
settings.

Click here to exit without starting the 
Performance Monitor.
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Figure 44.  Performance Monitor Start-Up Screen

Figure 45.  Performance Monitor Data Screen

Click here to start the Performance 
Monitor.

Click here to change the 
Performance Monitor settings (see 
Figure 43 on page 79).

Click here for help.

This screen shows the performance 
data collected by the Performance 
Monitor. It is updated at the interval 
specified in the Polling Interval 
setting (see Figure 43 on page 79). 
See Table 13 for a description of the 
screen contents.

This bar gives start and stop times 
and the total time monitored.

Click here to stop the 
Performance Monitor.

Click here to update the screen. 
This forces an immediate poll of 
the RAID Controllers.

Click here to change the polling 
setting (see Figure 43 on page 
79).

This bar gives the totals for the 
selected controllers.

Click here for help.
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6. You can save the displayed performance data as a text file by selecting File → Save 
Performance Data from the drop-down menus.

7. After you have gathered all the data you want, click Stop to end performance 
monitoring.

Using Performance Monitor Data

The following considerations apply in analyzing the data gathered by the Performance 
Monitor.

Table 13: Performance Monitor Screen Contents

Column Explanation

Devices Controller name listed as Controller A or B; or LUNs listed as LUN 0, LUN 1, etc. 
The LUNs are listed in numerical order following the controller that owns them.

Total IOs

The number of total I/Os performed by this device since the “Start” button of the 
performance monitor was last clicked. When this number exceeds 99,999, it will be 
displayed as 100K until the number reaches 9999K, at which time it will be 
displayed as “M” units. For amounts less than 100M, the value will be displayed in 
tenths (for example, 12.3M).

Read % The percentage of Total I/Os (previous column) that are read operations for this 
device. Write percentage can be calculated as 100 minus this value.

Cache Hit % The percentage of reads that are fulfilled by data from the cache rather than 
requiring an actual read from disk.

Current KB/sec
The current KB per second. Current means the number of KB/second since the last 
time the polling interval elapsed, causing an update to occur, or since the update 
button was pressed.

Max KB/sec The highest value achieved by the current KB/sec column for this polling session 
(since the “Start” button was pressed).

Current IO/sec
The current I/Os per second. Current means the number of I/Os/second since the last 
time the polling interval elapsed, causing an update to occur, or since the update 
button was pressed.

Max IO/sec The highest value achieved by the current I/Os/second column for this polling 
session (since the “Start” button was last pressed).

Controller values represent the totals for all LUNs owned by the controller, not just the LUNs presently 
selected for monitoring. Module totals represent totals for both controllers in the controller pair, 
regardless if one, both, or neither are selected for monitoring.
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Total I/Os — This field is useful for monitoring the I/O traffic to a specific controller and 
a specific LUN. This is needed to identify possible I/O “hot spots.” It is also useful to be 
able to identify actual I/O patterns to the individual LUNs and compare those with the 
expectations based on the application. If a particular LUN has considerably more I/O 
activity, consider moving the LUN to the other controller in the RAID Controller. If a 
particular array controller has considerably more I/O activity, consider moving the LUN to 
another SCSI bus or system bus. The system administrator should also consider moving 
the storage set to another array controller or distributing the storage set across multiple 
arrays and LUNs.

Read% — Knowing the read/write ratio of an application gives more insight into the 
actual application behavior. With redundant RAID levels, write performance is typically 
slower than read performance, and RAID 5 is slower than RAID 1. If a high amount of 
write activity is occurring, the user might want to consider changing the RAID level from 
RAID 5 to RAID 1.

Cache Hit% — Indicates the percentage of read operations that were satisfied from the 
array cache (did not require a disk access). A higher percentage is better. Increasing the 
amount of installed cache will increase the possibility of a cache hit, but there is no 
guarantee that more cache will improve cache hit percentage. This field can also be used 
to determine the effectiveness of read request prefetch. By default, the controller does not 
perform any read prefetching. If read prefetch is enabled, you can measure the 
effectiveness by noticing changes in the cache hit percentage.

KB/Sec Rates — The I/O size and the I/O rate determine the transfer rates of the 
controller. In general, a small host I/O request size will result in lower throughput rates 
(but will provide faster I/O rates and shorter response times). With larger host I/O request 
sizes, higher throughput rates are possible. Wide Ultra SCSI supports sustained data 
transfer rates of up to 40MB/second with large host I/O sizes. The maximum transfer rates 
with relatively small I/O sizes, 4096 bytes, is approximately 17MB/second. So, if transfer 
rate is low, it may not be a problem. 

IO/Sec Rates — Indicates current and maximum I/O rates. This can be useful in 
determining if the array is performing up to expectations based on access pattern, I/O size, 
RAID level, and number of drives in the array. Sequential access to the array will result in 
higher I/O rates. Higher write I/O rates will be experienced with write-back caching 
enabled compared to disabled. The higher the cache hit rate, the higher I/O rates will be.
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Chapter 6. Recovery

This chapter describes how to recover from component failures.

Recovery Overview

Recovery involves replacing a failed RAID component, such as a drive, controller, fan, or 
power supply. Because most RAID ControllerRAID Controllers have redundancy built 
into them, a single failure will not stop the RAID Controller from operating. For example, 
if a single drive in a RAID 5 logical unit fails, the controller uses the data and parity 
information from the remaining good drives to continue delivering data.

Check the hardware manuals accompanying your RAID Controller for the redundant 
features on that module. In most cases, the module has redundant controllers, fans, and 
power supplies. 

IMPORTANT You may need to refer to the hardware manuals accompanying your 
RAID Controllers for information on how to physically replace failed 
components. The information in this User Handbook provides 
information on what you must do with the software to enable component 
replacement.

If the failed component has redundancy, in most cases you can replace it without shutting 
down the RAID Controller or stopping I/O to it. For example, if your RAID Controller has 
redundant fans or power supplies, you can replace one of these components if they fail 
without shutting down the RAID Controller. 

Recovery Procedures

You can view the recovery procedures in the Recovery Guru by selecting Help → 
Recovery Guru Procedures in the Recovery Application.
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General Recovery Steps

The recovery process involves these general steps:

1. You are notified of a component failure. This notification could be via:

• Software error messages

• An error message in the Message Log

• Fault lights or audible alarms on your RAID Controller

• SNMP notification

• Console messages from your operating system

• Results of a Recovery Guru/Health Check

• A non-optimal status appearing for any RAID Controller component in the 
Configuration screen or in Module Profile

2. You run Recovery Guru/Health Check to get information on the failure (see "Running 
Recovery Guru/Health Check" on page 90).

3. You should view the recommended procedure in Recovery Guru/Health Check for 
detailed information on the steps you need to take to recover from the failure (see 
Figure 47 on page 91).

4. You take the steps indicated, which often involve replacing the failed component. In 
some cases, you may need to refer to your hardware documentation for information on 
how to physically replace failed components. You may also need to perform the 
functions given in "Manual Recovery Options" on page 92, but do not do so unless 
instructed by Recovery Guru.

5. You perform whatever functions are necessary on your operating system to recover 
from the failure (see your Operating System documentation and the Installation and 
User’s Handbook).

Recovering From Drive Failures

CAUTION This section gives the general principles involved in replacing failed 
drives. However, you should always start with the information given in 
the procedure screen of Recovery Guru. The information given there is 
specific to the type of failure that occurred, and should be followed as 
much as possible.
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Degraded And Dead Modes

Drive failures leave the logical unit in one of two general states, degraded or dead.

• Degraded Mode — Degraded mode occurs when a RAID 1, 3, or 5 logical unit suffers 
a single drive failure (or when multiple drives in a RAID 1 logical unit fail, but none of 
the drives is a mirrored pair). In degraded mode, the logical units continue to operate 
normally.

It is important to note that your operating system will not tell you when logical units 
enter degraded mode. This is because to the operating system the drive is still 
functioning normally.

• Dead Mode — Dead mode occurs when any drives in a RAID 0 logical unit fail, or 
when multiple drives in a RAID 1, 3, or 5 logical unit fail. Your operating system 
handles a dead logical unit in the same way that it handles any failed drive. You will 
see the same error messages, for example, that you would see if a standard hard drive 
failed, and will need to follow the same procedures that you take if a standard drive 
fails. See the documentation accompanying your operating system for information on 
how to handle logical unit failures at the operating system level.

Recovery And RAID Level

The recovery procedure you need to perform depends on the RAID level of the logical 
units on that drive and on the number of drive failures. Table 14 summarizes the recovery 
procedures required. Note that in the case of single drive failures on RAID 1, 3, or 5 
logical units, you will not need to shut down the RAID Controller to recover from the 
failure. Table 14 gives general information only; always run Recovery Guru/Health Check 
before attempting to replace drives.
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Multiple Drive Failures And Channel Failures

If multiple drives on the same drive channel fail simultaneously, the problem may be a 
channel failure rather than a series of drive failures. For example, if drives [0,1], [0,3], and 
[0,7] fail at the same time, the problem may be in channel 0 rather than in the three drives. 

Table 14: Drive Failures And Recovery (Summary)

RAID 
Level

Number of 
Failed 
Drives

Explanation

0 1 or more

A single drive failure in a RAID 0 logical unit results in the loss of all data on 
the logical unit, because RAID 0 does not provide data redundancy. To recover 
from a drive failure in a RAID 0 logical unit, you need to replace the failed 
drive, reformat the logical unit, and restore data from backup.

1, 3, or 
5 1

A single drive failure in a RAID 1, 3, or 5 logical unit does not result in the loss 
of data. The logical unit will continue to operate in degraded mode. To recover 
from a single drive failure in a RAID 1, 3, or 5 logical unit, you need to replace 
the failed drive. The controller will then reconstruct the data on the replaced 
drive, and the logical unit will return to optimal status. 

1 2 or more

In a RAID 1 logical unit, multiple drives can fail without data loss so long as 
none of the failed drives make up a mirrored pair.

• If two mirrored drives fail, all data in the logical unit is lost. To recover from 
this kind of multiple failure, you need to replace the drives, reformat the 
logical unit, and restore data from backup.

• If none of the failed drives are in the same mirrored pair, data is not lost. To 
recover, you need to replace the failed drives. The controller will then 
reconstruct the data on the replaced drives, and the logical unit will return to 
optimal status.

3 or 5 2 or more

Two or more drive failures in a RAID 3 or 5 logical unit results in the loss of all 
data on the logical unit. To recover from multiple drive failures in a RAID 3 or 
5 logical unit, you need to replace the failed drives, reformat the logical unit, 
and restore data from backup.

NOTE The information in this table ignores the effect of hot spare drives. Hot spare drives increase the 
number of drives that must fail in a RAID 1, 3, or 5 logical unit before data is lost. They do this by 
automatically replacing the failed drive. For example, if your RAID Controller has 1 hot spare drive, three 
drives must fail before data is lost in a RAID 5 logical unit. See "Hot Spare" on page 9 and "Protecting 
Yourself From Component Failures" on page 19 for more information.
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To prevent channel failures from causing multiple drive failures, you should try and create 
logical units so that drives are not on the same channel, although this is not always 
possible.

If the drives fail as the result of a channel failure, data on the drives may not be lost. You 
need to fix the channel and then try and revive the logical unit using manual recovery (see 
"Manual Recovery Options" on page 92). As always, however, follow the steps given in 
the Recovery Guru procedure screen before attempting any kind of manual recovery.

Reviving Drives

Under limited circumstances, you can “revive” a failed drive and return it to an optimal 
status using the Revive Drive function in Manual Recovery. In general, you can only 
revive a drive if you accidentally removed it or failed it, not if the controller failed it. See 
"Manual Recovery/Drives" on page 93 for a description of the Revive Drive procedure.

Revive a drive only if:

• You are instructed to by Recovery Guru.

• You accidentally failed an optimal drive in an optimal RAID 0 LUN (with Manual 
Recovery → Fail Drive) and have not performed any writes to the LUN in the 
meantime. In this case, the LUN should return to an optimal status after you revive it 
and the data is not affected. 

• You accidentally failed an optimal drive in an optimal RAID 1, 3, or 5 LUN (with 
Manual Recovery → Fail Drive) and have not performed any writes to the LUN in the 
meantime. In this case, the LUN should return to an optimal status after you revive it 
and the data is not affected. If you are not sure whether any writes occurred, 
reconstruct the drive instead of reviving it.

• You accidentally removed or failed an optimal drive in an optimal RAID 0 LUN and 
you were writing to it at the time (the LUN status will change to Dead, and the 
operating system will send you messages indicating the failure). In this case, reviving 
the drive may allow you to recover some of your data intact (any files that were not 
being written when you removed or failed the drive are probably OK).

• You accidentally removed or failed an optimal drive in an degraded RAID 1, 3, or 5 
LUN and you were writing to it at the time (the LUN status will change to Dead, and 
the operating system will send you messages indicating the failure). In this case, 
reviving the drive may allow you to recover some of your data intact (any files that 
were not being written when you removed or failed the drive are probably OK).

You do not need to revive a drive if:

• You accidentally remove an optimal drive from an optimal LUN and the LUN status 
remains optimal (that is, you were not writing to the LUN at the time you removed it). 
The drive will automatically be returned to an optimal status after you reinsert it.
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• You accidentally remove an optimal drive from an optimal RAID 1, 3, or 5 LUN and 
the LUN status changes to degraded (that is, you were writing to the LUN at the time 
you removed it). The drive will automatically be reconstructed after you reinsert it.

Do not revive a drive if:

• The controller failed the drive.

Monitoring Reconstruction Progress

After you replace a single drive in a RAID 1, 3, or 5 logical unit, the controller starts 
reconstruction to rebuild the data on the replaced drive. See "Reconstruction" on page 12 
for more information on reconstruction.

You can monitor the progress of reconstruction, and change the reconstruction rate, by 
using the Status Application. See "Monitoring/Changing Reconstruction" on page 98 for 
more information.

Using Configured Drives As Spares

If you want to use configured drives as spares, always delete the LUNs on them before 
removing them.

If this is not possible, you can use the configured drives as spares, but you should insert 
them into the new module one at a time. When the drive status goes to Offline, you must 
then revive the drive using the procedure in "Reviving Drives" on page 87 before inserting 
the next drive. Note that this procedure is possible only if the drives were part of a LUN 
that contained at least two drives.

Recovering From Controller/Connection Failures

CAUTION This section gives the general principles involved in replacing failed 
controllers and recovering from connection failures. However, you should 
always start with the information given in the procedure screen of 
Recovery Guru. The information given there is specific to the type of 
failure that occurred, and should be followed as much as possible.

A failure in a controller or along the connection from the host to the controller will usually 
not result in the loss of data. However, it will result in the RAID Controller becoming 
unusable unless all of the following conditions are met:

• The RAID Controller Unit has redundant controllers (see "Redundant Controllers" on 
page 12).

• The RAID Controller Unit is configured in the single host configuration using two host 
busses (see "Controller Configurations" on page 13).
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• The RAID Controller has RDAC protection (see "RDAC Driver" on page 11).

Always consult your hardware documentation for instructions on how to physically 
replace the controller, as well as any possible instructions on additional steps you must 
take.

Recovery And Fail-Over Protection

Table 15 summarizes the steps you need to take to recover from a failed controller 
depending on whether or not your RAID Controller has fail-over protection.

Recovering From Fan/Power Supply Failures

CAUTION This section gives the general principles involved in replacing failed 
RAID Controller fans and power supplies. However, you should always 
start with the information given in the procedure screen of Recovery 
Guru. The information given there is specific to the type of failure that 
occurred, and should be followed as much as possible.

The RAID Controller Unit contains redundant fans and power supplies. A single failure, 
therefore, will not shut down the RAID Controller Unit. You can then replace the failed 
component while the RAID Controller Unit is running. The replaced component will 
automatically be returned to service in the RAID Controller Unit.

Table 15: Recovering From Failed Controllers (Summary)

Fail-Over 
Protection? Recovery Procedure

Yes

If a controller fails, the other controller in the pair will take over for it. LUNs assigned 
to the failed controller will be automatically assigned to the remaining good controller. 
Data will continue to flow along the connection. If you are using write caching but not 
write cache mirroring, any data in the cache of the failed controller is lost. 

Recovery: You will probably be able to replace the failed controller without shutting 
down the RAID Controller Unit. Follow the instructions on the Recovery Guru 
procedure screen. 

No

If the RAID Controller Unit does not have fail-over protection, data will not flow along 
the failed connection, and any data currently in the cache of the failed controller is lost. 
Data on the drives is not necessarily destroyed, but is inaccessible.

Recovery: You will need to shut down the RAID Controller Unit to replace the 
controller. Follow the instructions on the procedure screen.
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If necessary, see your hardware documentation for information on how to physically 
replace failed fans and power supplies, as well as information on how to locate the 
particular fan or power supply that has failed.

Running Recovery Guru/Health Check

Run Recovery Guru/Health Check when you have some indication that there is a failure in 
some array component or if you want to check the status of your modules. This Health 
Check locates the failure and gives detailed information on the steps you need to take to 
correct it.

Use the following procedure to run Recovery Guru/Health Check. 

1. Start the Recovery application.

2. Select the RAID Controllers you want to check, or select All RAID Controllers to 
check all the modules on your system. A screen like Figure 46 is displayed.

Figure 46.  Recovery Main Screen

Click here to start the Health Check 
on the selected modules. You can 
also start the Health Check by 
selecting Options → Recovery 
Guru.

You can view the various recovery procedures by selecting Help → Recovery 
Guru Procedures.
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3. Click on the Recovery Guru/Health Check button or select Options → Recovery Guru 
from the drop-down menus.

The software checks all the selected modules for non-optimal statuses. If a non-optimal 
status is found, a screen like Figure 47 is displayed.

Figure 47.  Recovery Screen/Exceptions Found

4. If exceptions are found, highlight the exception and click on Show Procedures for 
recommendations on how to fix the problem (see Figure 48).

5. Print out the procedure, if desired, using File → Print Topic. 

6. Follow the procedure given to recover from the component failure. You may need to 
use the procedures given in "Manual Recovery Options" on page 92.

Click here to display information on the highlighted failure. This information 
will include recovery information. See Figure 48 on page 92 for a sample 
screen.

This area displays the results of the 
check. If a non-optimal status is 
found, highlight the line and click 
Show Procedure for recovery 
information.

Click here for help.
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Figure 48.  Recovery Procedure Screen

Manual Recovery Options

CAUTION Take care when using any of these options. In general, do not use these 
options unless specifically directed by the procedure screen of Recovery 
Guru or by a Customer Services representative. Doing so could result in 
the loss or corruption of data. Do not attempt to manually recover without 
understanding the circumstances of the failure.

The manually recovery options provide a means to perform operations on drives, logical 
units, and controllers. You may need to perform these procedures if instructed by 
Recovery Guru.

Use the Manual Recovery options if:

• Instructed to in the procedure screen of Recovery Guru.

• You need to format a logical unit after replacing the drives in a dead logical unit.

• You accidentally remove a good drive from a logical unit and no write operation was 
performed on the logical unit while the drive was removed (see "Reviving Drives" on 
page 87).

The first part of this area gives detailed status 
information on the failure. In this case, the 
message indicates that drive [1,0] has failed. 
A hot spare drive has taken over for the failed 
drive and is currently reconstructing. LUNs 0 
and 3 are affected by this failure.

Select File here to print the information displayed in the 
procedure screen, or to set up the printer before printing. 
Select Edit to copy text to the clipboard.

The rest of this area gives information on the 
cause of the failure and on how to recover 
from it. Read the instructions carefully. If 
necessary, print them out by selecting File → 
Print Topic from the drop-down menus.
In this case, there is no action to take until the 
reconstruction is finished. Then you should 
run Health Check again for information on 
how to replace the failed drive.

Although this looks like a standard Help screen, 
these buttons are grayed out.
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• You want to force a drive failure rather than wait for the controller to fail it.

• You want to remove a controller from the RAID Controller.

• A channel failure caused multiple drives in a logical unit to fail.

There are three Manual recovery options:

• Manual recovery of drives — See "Manual Recovery/Drives" on page 93.

• Manual recovery of logical units — See "Manual Recovery/Logical Units" on page 95.

• Manual recovery of controllers — See "Manual Recovery/Controllers" on page 97.

Manual Recovery/Drives

CAUTION Take care when using manual recovery. In general, do not use these 
options unless specifically directed by the procedure screen of Recovery 
Guru or by a Customer Services representative. Doing so could result in 
the loss or corruption of data. Do not attempt to manually recover without 
understanding the circumstances of the failure.

Using manual recovery on drives, you can:

• Fail a drive — you may need to do this if the drive is causing problems but the 
controller won’t fail it.

• Reconstruct data on a drive — you may need to do this if reconstruction doesn’t occur 
automatically when you replace a failed drive.

• Revive a drive — you may need to do this if you accidentally fail or remove a drive. 
See "Reviving Drives" on page 87 for a description of when to use this option.

To perform manual recovery of drives, do the following:

1. Start the Recovery application.

2. Select the RAID Controller containing the drives you want to recover.

3. Select Options → Manual Recovery → Drives from the drop-down menus. A screen 
like Figure 49 on page 94 is displayed.

4. Select the individual drive you want to fail, reconstruct, or revive, then click on the 
appropriate button to perform the operation. 
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Figure 49.  Manual Recovery/Drives Screen

Notes:

• Failing a drive in a RAID 0 logical unit will result in the loss of data on the logical unit.

• Failing a drive in a Degraded RAID 3 or 5 logical unit will result in the loss of data.

• Failing a drive in a degraded RAID 1 logical unit will result in the loss of data if the 
drive you fail is the mirror drive of a failed drive.

• Reconstruction should only be performed on a drive after you have replaced it.

• Reviving a drive should be done only under the circumstances described in "Reviving 
Drives" on page 87.

Select the RAID Controller containing the drives you want to recover.

Information on the drives in the 
module is displayed here. Highlight 
the drive you want to fail, 
reconstruct, or revive. 

Click here for help.

Click here to Fail the currently 
highlighted drive. This button will 
be grayed out if the selected drive is 
already failed. Note that failing a 
drive could result in the loss of data, 
especially in a RAID 0 logical unit.

Click here to Revive the drive. This 
option works only if the drive status 
is Failed. See "Reviving Drives" on 
page 87 for a description of when to 
use this option.

Click here to 
reconstruct data on the selected 
drive. You can only perform this 
option on a drive with a status of 
Replaced or Failed in a RAID 1, 3, 
or 5 logical unit. The logical unit 
status must be Degraded or 
Optimal.
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Manual Recovery/Logical Units

CAUTION Take care when using manual recovery. In general, do not use these 
options unless specifically directed by the procedure screen of Recovery 
Guru or by a Customer Services representative. Doing so could result in 
the loss or corruption of data. Do not attempt to manually recover without 
understanding the circumstances of the failure.

Using manual recovery on logical units, you can:

• Format the logical unit — you need to do this to recover from a dead logical unit after 
you have replaced the failed drives.

• Revive a logical unit — you may need to do this if a logical unit failed because of a 
channel failure. A channel failure can fail multiple drives in the logical unit but not 
cause the data on those drives to be lost. Do not use this option unless instructed to by 
Recovery Guru.

To perform manual recovery of logical units, do the following:

1. Start the Recovery application.

2. Select the module containing the logical units you want to format or revive.

3. Select Options → Manual Recovery → Logical Units from the drop-down menus. A 
screen like Figure 50 on page 96 is displayed.

4. Select the logical units you want to format or revive, then click on the appropriate 
button to perform the operation.
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Figure 50.  Manual Recovery/Logical Units Screen

Notes:

• Do not format a logical unit until you have replaced any failed drives that caused the 
failure.

• Formatting deletes all data on the logical unit (it is probably already lost anyway, 
assuming the logical unit status is Dead).

• Reviving a logical unit should be performed only if the logical unit failure was caused 
by a channel failure. Do not attempt to revive a logical unit unless instructed to by 
Recovery Guru. Doing otherwise can result in corrupted data or another failure. See 
"Multiple Drive Failures And Channel Failures" on page 86 for more information.

Select the RAID Controller containing the logical units you want to recover.

This display shows the logical units 
on the selected RAID Controller 
and the current status of those 
units. Highlight the logical units 
you want to format or revive and 
click on the appropriate button 

Click here for help

Click here to format the selected logical units. 
You must first replace any drives that caused the 
failure. Formatting deletes all data on the logical 
unit.

Click here to revive the selected logical units. You should only 
revive a logical unit if the logical unit failure was caused by a 
channel failure. Use the Recovery Guru to determine the cause 
of the failure. Reviving a logical unit under other 
circumstances will most often result in corrupted data or more 
failures.
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Manual Recovery/Controllers

CAUTION Take care when using manual recovery. In general, do not use these 
options unless specifically directed by the procedure screen of Recovery 
Guru or by a Customer Services representative. Doing so could result in 
the loss or corruption of data. Do not attempt to manually recover without 
understanding the circumstances of the failure.

Using manual recovery on controllers, you can:

• Place a controller offline — use this option if you want to remove the controller in 
order to replace it. 

• Place a controller online — use this option if you have replaced a failed controller and 
it was not put back online automatically.

To perform manual recovery of controllers, do the following:

1. Start the Recovery application.

2. Select the module containing the controllers you want to place online or offline.

3. Select Options → Manual Recovery → Controller Pairs from the drop-down menus. A 
screen like Figure 51 on page 98 is displayed.

4. Select the controller you want to place online or offline and then click on the 
appropriate button to perform the operation. 
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Figure 51.  Manual Recovery/Controllers Screen

Notes:

• You can only place a controller offline if it is one of a redundant pair of controllers. The 
other controller takes over for the offline controller (see "Redundant Controllers" on 
page 12).

• If you place an offline controller online, you may need to go into the Maintenance and 
Tuning application to reset the controller modes and assign LUNs to the online 
controller (see "Changing Controller Mode" on page 118).

Monitoring/Changing Reconstruction

After you replace a failed drive in a degraded RAID 1, 3, or 5 logical unit, the controller 
begins rebuilding data on the replaced drive. You can use this option to view the progress 
of this reconstruction, and to change the reconstruction rate. 

You can only change the rate for logical units currently being reconstructed. To change the 
reconstruction rate of logical units that are not currently being reconstructed, see 
"Changing The LUN Reconstruction Rate" on page 113.

Select the RAID Controller containing the controllers you want to recover.

Click here to put the selected controller 
Offline. This option is only available if 
the selected controller is currently 
online. 

Click here for help.

Click here to put the selected controller Online. This option is only 
available if the selected controller is currently offline. After you 
put the controller online, you may need to change controller mode 
(see "Changing Controller Mode" on page 118 for more 
information).

This display shows the controllers in 
the selected RAID Controller Unit 
and their current status. Highlight the 
controller you want to put online or 
offline and click on the appropriate 
button below.
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To view reconstruction progress and change the rate of reconstruction, perform the 
following steps:

1. Start the Status Application.

2. Select the RAID Controller containing the logical units currently being reconstructed. 
Do not select All RAID Controllers.

3. Click on the LUN Reconstruction button or select Options → LUN Reconstruction 
from the drop-down menus. A screen like Figure 52 on page 100 is displayed.

4. The display shows the progress of reconstruction on each logical unit. If you want to 
change the reconstruction rate, move the slider bar for that logical unit. 

IMPORTANT Reconstruction can take a long time (several hours or longer) if the logical 
units involved are very large and there is a lot of I/O going to the LUNs 
being reconstructed. To some extent, you can speed up this process by 
adjusting the speed with the slider bars. 

In addition, if you replace a failed drive while the hot spare that replaced 
the failed drive is being reconstructed, reconstruction will be completed 
on the hot spare before it begins on the replaced drive. This may increase 
the time required to complete the recovery procedure.
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Figure 52.  Viewing/Changing Reconstruction Screen

Notes:

• If you exit this screen and then return to it, any logical units that have completed 
reconstruction will no longer be displayed.

• The reconstruction rate is changed immediately when you move the slider bar, 
although you may notice a slight delay if you have many or large logical units 
reconstructing.

• From left to right, the points on the Slider bar indicate the following reconstruction 
rates (blocks/seconds delay). Note that each 1024 block = 512 KB.

• Slow — 1024 blocks/0.8 second delay

• Medium slow — 1024 blocks/0.4 second delay

• Medium — 1024 blocks/0.2 second delay

• Medium fast — 1024 blocks/0.1 second delay

• Fast — reconstruct with no delays.

These columns show the drive 
group and LUNs currently 
being reconstructed.

This histogram shows 
the amount of reconstruction accomplished as a 
percentage. If you exit this screen and then return, 
any LUNs that have completed reconstruction will 
no longer be displayed.

Move the slider bar here to change 
the reconstruction rate. Moving to 
the left slows reconstruction but 
increases system performance. 
Moving to the right speeds 
reconstruction at the expense of 
system performance.

This must be a module containing logical units currently being reconstructed.

Each row displays information on a 
single logical unit.
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Chapter 7. Maintenance and Tuning

This chapter describes the maintenance and tuning procedures needed to maintain the 
RAID ControllerRAID Controllers.

Maintenance and Tuning Overview

The Maintenance and Tuning application performs functions needed to maintain and tune 
your RAID Controllers. With the Maintenance and Tuning application, you can:

• Download new controller firmware and NVSRAM files (see "Upgrading Controller 
Firmware" on page 101).

• Manually run Parity Check (see "Running Parity Check" on page 110).

• Set the time for Automatic Parity Check (see "Running Parity Check" on page 110).

• Change the Reconstruction Rate for logical units (see "Changing The LUN 
Reconstruction Rate" on page 113).

• Balance drive groups/logical units across active/active redundant controller pairs (see 
"Balancing LUNs" on page 115).

• Swap active/passive controllers or change them to active/active (see "Changing 
Controller Mode" on page 118).

• Change the write cache, write cache mirroring, and cache without batteries parameters 
for logical units (see "Changing Cache Parameters" on page 121).

Upgrading Controller Firmware

Controller firmware resides on the array controller in the RAID Controller. It contains the 
commands necessary to operate the RAID Controllers. Normally, you do not need to load 
new firmware when you install a RAID Controller. You may need to perform this function 
as part of an upgrade. You will receive new firmware files from your Customer Services 
representative.

IMPORTANT Controller firmware is different from the drive firmware. Use this option 
only to upgrade controller firmware.
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Controller Firmware Files

Downloading controller firmware involves up to five files:

• The NVSRAM file — The NVSRAM file specifies default settings for the controller. 
You must download this file, if present, before loading the other firmware files.

• The Boot Level (also called bootware) file — this is a firmware file that controls 
controller operation.

• The Firmware Level (also called appware) file — this is a firmware file that controls 
controller operation.

• The Fibre Channel firmware — this file contains firmware to operate the RAID 
Controller in a fibre channel environment. The fibre channel information is combined 
in the firmware (appware) file and is not a separate file.

• The fwcompat.def file — this file enables the software to compare the firmware files 
for compatibility during the upgrade process, providing you with a list of compatible 
files to select for downloading.

You can determine current Boot, Firmware, and Fibre Channel version levels through the 
Controller Profile screen; see "The Controller Profile Screen" on page 39.

General Procedure

In general, use the following steps to download new controller firmware.

1. Determine whether you can download the new firmware files using the Online or 
Offline method, and take any necessary steps required (see the next section).

2. Copy the new NVSRAM file, the firmware files, and the fwcompat.def file to the 
default subdirectory in the installation directory of your system (see the Installation 
and User’s Handbook for information on which directory to use).

IMPORTANT If you do not copy the fwcompat.def file to the correct subdirectory, the 
software is unable to check the files for compatibility. Although you can 
still enter firmware filenames, the software is unable to check the 
firmware files for compatibility or to provide you with a list of compatible 
files to select for downloading.

3. Download the new NVSRAM file using the Firmware Upgrade option in the 
Maintenance and Tuning application.

4. Run nvutil -vf from the command line to ensure that NVSRAM settings are set-up 
correctly for the storage management software.
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5. Reset the controller or turn the power to the RAID Controller off and then on again, to 
establish the new NVSRAM settings.

6. Download the new firmware files to your system.

Read through the following sections, then go to the complete download procedure on page 
104.

Online And Offline Method

You can download controller firmware using one of two methods, Online and Offline, 
depending on your controllers and configuration. 

IMPORTANT Note that because you must turn the RAID Controller off and then on 
again, or reset the controller, after upgrading NVSRAM, you must use the 
Offline method if a new NVSRAM file must be downloaded.

• Select Online to upgrade firmware while the selected RAID Controller receives I/O. 
You may only use the Online method if:

• The controllers have the RDAC driver installed for redundant controller support. 

• All LUNs on the RAID Controllers have a status of Optimal.

• Select Offline to upgrade firmware when the selected RAID Controller is not receiving 
I/O. You must use the offline method if:

• You need to download a new NVSRAM file (you can load an NVSRAM file using 
the Online method, but the changes in the file will not take effect until after you turn 
the RAID Controller off and then on again).

• The RAID Controller has an independent controller configuration (in this case, you 
must download the firmware to each controller from its host).

• The RAID Controllers have single controllers.

• The Offline option also requires exclusive access to the logical units in the selected 
RAID Controllers; that is, no other operations can be running on the RAID 
Controller.

The software will notify you if you can perform a firmware upgrade using the selected 
method.

Selecting Controllers

Whether or not you can select specific controllers for downloading NVSRAM or 
upgrading controller firmware depends on the RAID Controller you select:
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• When you select All RAID Modules → Firmware Upgrade, or one RAID module and 
the Online method, you will be downloading NVSRAM files or upgrading controller 
firmware files to every controller in those modules. You cannot select individual 
controllers in this case.

• If you select one RAID Module that has only one controller, you must use the Offline 
method. The controller is automatically selected in this case. 

• If you select a RAID Module with an independent controller configuration, you must 
use the Offline method. In addition, you must download the firmware to each 
controller from each host.

• If you select one RAID Module that has a pair of redundant controllers and the Offline 
method, you need to select the controllers on which you want to upgrade firmware in 
addition to highlighting the version level you want to download. 

CAUTION Remember that both controllers in a redundant pair must have the same 
version of controller firmware installed. You should therefore select both 
controllers to ensure that they have compatible versions of NVSRAM/
controller firmware unless you are replacing a failed controller and the 
replacement controller has an earlier firmware version than the original 
pair was using.

Download Procedure

Perform the following steps to download new controller firmware.

1. Copy the NVSRAM file, firmware files, and the fwcompat.def file to the correct 
subdirectory in the installation directory of your system (see your Installation and 
User’s Handbook).

2. Determine whether you can upgrade the firmware using the Online or Offline method. 
If you must use the Offline method, make sure that you stop all I/O to the RAID 
Controllers you are going to upgrade. 

3. Start the Maintenance and Tuning application.

4. Select the RAID Module containing the controllers you want to upgrade. Select All 
RAID Controllers to download firmware to all controllers in all RAID Controllers.

5. Click on the Firmware Upgrade button or select Options → Firmware upgrade from 
the drop-down menus. 

6. Read the Important Notes screen and click OK.

7. A screen appears asking you to select the online or offline procedure. Select either: 
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• Online to upgrade firmware while the selected RAID Controller receives I/O.

• Offline to upgrade firmware when the selected RAID Controller is not receiving I/
O.

8. After selecting Online or Offline, the screen displays “Verifying the controller state” 
while the software checks the selected RAID Controllers for restrictions based on the 
type of firmware upgrade you selected. If there are no restrictions, a screen like Figure 
53 on page 106 is displayed. 

9. Depending on whether you are downloading NVSRAM files or upgrading controller 
firmware, do one of the following:

IMPORTANT Remember, you need to download any NVSRAM files first, before 
downloading any new firmware files.

• To download an NVSRAM files, type its complete path information in the path box 
and select OK. Continue with Step 11 on page 106.

• To select controller firmware, highlight the version level you want to download. 
Continue with Step 10.

10.Select OK with the correct version level highlighted. 

You either receive notification that a problem occurred, or you have a final 
confirmation that the upgrade process is about to begin.



106 IBM Netfinity SYMplicity Storage Manager User’s Handbook

Figure 53.   Firmware Upgrade Screen

IMPORTANT Once you click OK at the “Firmware is about to start” prompt in Step 11, 
do not select any other options or exit the Maintenance/ Tuning 
Application until the upgrade process is completed. You can, however, 
monitor the upgrade progress.

11.Select OK and follow the upgrade progress.

A histogram for the selected RAID module indicates the download progress of the 
NVSRAM or firmware files. This graphic shows the amount of progress as a 
percentage and starts over at 0% for each file if you have more than one. If you selected 
All RAID Modules, the module number is updated as each module begins its upgrade 
process.

When the NVSRAM download or the firmware upgrade is finished, you see a 
summary report indicating whether the upgrade is Successful or Failed. Table 16 on 
page 107 shows the information this screen displays.

Click here to begin the download after you 
have selected the firmware files to load or 
entered the name of the NVSRAM file in 
the path box. 

Click here to cancel 
without downloading any new 
files.

This screen displays the 
compatible firmware files found 
by fwcompat.def. That program 
checks the default subdirectory 
for files. Highlight the version 
level you want to download. 

Note that for firmware versions 
3.0 or higher, the firmware 
(appware) file contains the fibre 
channel firmware, so no fibre 
channel file is listed here.

The path is updated to show the 
files currently selected in the 
Compatibility display. You can 
also enter a file name here to 
download that file (this is how to 
download an NVSRAM file).

This display shows the controllers in the selected RAID modules and their current 
firmware levels. Make sure both controllers are highlighted here if you want to 
download new firmware to both controllers. Note that for firmware levels 3.0 and 
higher, the fibre channel level is the same as the firmware level because the fibre 
channel firmware is contained in the firmware file.
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Note: If you selected All RAID Modules, it is possible that the upgrade was successful for 
some modules, but not for others. The final summary report should indicate which 
modules were not successful and give an appropriate cause. For more information, 
see "Confirming The Download" on page 108.

12.After the download is completed, select OK to return to the Maintenance/ Tuning 
screen.

13.Depending on whether you are downloading NVSRAM files or upgrading controller 
firmware, do one of the following:

• If you have successfully downloaded NVSRAM files, continue with Step 14.

• If you have successfully upgraded controller firmware, you are finished with this 
procedure.

14.At the command line, type: 

nvutil -vf

This utility checks and corrects any settings on all controllers in your RAID 
Controllers to ensure that certain settings in the NVSRAM are set-up correctly for this 
software. Consult the help text file or man page specific to your operating system for a 
description of the nvutil utility.

15.Turn the power to the RAID Controller Unit off and then on again to establish the new 
settings.

16.Go back to Step 9 and download any new firmware files.

Table 16: Firmware Confirmation Screen Elements

Screen Element Description

Summary Report for Files
Lists the files used to upgrade the firmware. These are the files loaded in the 
Path line when you selected files at the Compatible Files/Versions screen 
(Figure 53 on page 106).

RAID Controller Identifies the specific RAID Controller.

Download Status

Indicates whether the download process was completed successfully. 

You see either “Successful” or “Failed” with a reason why the upgrade was 
unsuccessful. See Table 17 on page 108 if you see any Failed download 
statuses.
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Confirming The Download

At the final summary report of the NVSRAM or firmware download procedure, you will 
see if the upgrade was Successful or Failed for each of the selected RAID Controllers.

• If you see that the upgrade was Successful, you should still verify that all the logical 
units (LUNs) are not assigned to only one controller. See "Balancing LUNs" on page 
115 for the procedures to balance the LUNs across both controllers.

• If you see “Failed” for any module, you should fix the specified failure and try the 
firmware upgrade procedure again. See Table 17 for possible actions to take to correct 
a failed upgrade.

Table 17: Controller Firmware Upgrade: Failed Statuses

Reasons for Failed Status Actions

The selected module had I/O activity 
occurring or filesystems mounted 
(Offline download).

Stop I/O to that module and be sure filesystems are unmounted, 
then try to upgrade the firmware again.

At least one of the selected firmware 
files had bad file contents. 

Copy the firmware files to the correct subdirectory in the 
installation directory again. If you see this message a second 
time, one or more of your files are most likely corrupt. Obtain a 
new copy of the firmware upgrade files.

The SCSI command write buffer 
failed. 

Try to perform the upgrade again for this module. If it fails a 
second time, call your Customer Services representative.

The software was unable to reset the 
controller. Try to upgrade the firmware again.

One or more logical units for the 
selected module were not Optimal. 

Use Recovery Guru/Health Check in the Recovery Application 
to restore the LUNs to an Optimal status, then try to upgrade 
the firmware again. See "Chapter 6. Recovery."

Upgrading to the selected firmware 
version requires that you use the 
Offline method.

Try to upgrade the firmware again and this time be sure to 
select Offline.

The current firmware version is unable 
to upgrade to the files you selected. 

Most likely, you need to upgrade to an intermediate version of 
firmware. Try to upgrade to a version earlier than the one you 
selected. If that upgrade is successful, perform a second 
upgrade for this latest firmware version.
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The files you selected are not 
compatible with the current firmware 
version on the selected module’s 
controllers. 

Most likely, the current directory does not contain all the 
necessary firmware files. Copy the firmware files and the 
fwcompat.def file to the correct subdirectory in the installation 
directory and try again. Be sure the version you select has both 
Firmware Level and Bootware Level versions specified. If the 
upgrade fails a second time, obtain a new copy of the firmware 
upgrade files.

The software was unable to access the 
controllers during the upgrade process. 

Use Recovery Guru/Health Check in the Recovery Application 
to determine if the module has a failure. See "Chapter 6. 
Recovery." 

• If a failure is indicated, fix it and try to upgrade the firmware 
again.

• If Recovery Guru/Health Check does not indicate a failure, 
try to upgrade the firmware again. 

You tried to load a pre-2.04 firmware 
version, which is not supported by this 
software or the redundant controller 
configuration.

Do not try to load this firmware version again.

The selected firmware files are not 
compatible with your controller 
model.

Use Module Profile → Controller details to check your 
controller type and model (see Figure 13 on page 38), and 
obtain the correct firmware version files.

The online upgrade cannot be 
performed because either the selected 
module has only one controller or one 
of the controllers in the pair is not 
accessible.

Use Module Profile → Controller details to determine how 
many controllers the module has (see Figure 13 on page 38).

• If there is only one controller, try to upgrade the firmware 
again and be sure to select Offline.

• If you have two controllers, use the Recovery application to 
select Recovery Guru/Health Check and follow the 
recommended procedure to fix the controller problem before 
attempting to upgrade the firmware again (see "Chapter 6. 
Recovery").

An unknown failure occurred. Use the Status Application to select Message Log for 
component information (see "Viewing The Log" on page 72).

Table 17: Controller Firmware Upgrade: Failed Statuses (continued)

Reasons for Failed Status Actions
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Running Parity Check

The RAID Controllers use parity information in RAID 3 and 5 logical units to enable data 
redundancy. When a single drive fails in a RAID 3 or 5 logical unit, the controller can 
reconstruct the data on the missing drive by using the parity information stored on the 
drives. RAID 1 logical units do not use parity, but you can still run Parity Check repair on 
RAID 1 logical units. In this case, the check compares the data on the mirrored drives. 

RAID 0 logical units do not have parity and therefore can not be checked. A non-optimal 
RAID 1, 3, or 5 logical unit (such as a degraded units) also can not be checked.

If a parity error is found, the Parity Check/Repair application fixes the parity. If the error is 
found on a RAID 3 or 5 logical unit, the controller changes the parity information so that 
the parity is correct. If an error is found on a RAID 1 logical unit, the controller changes 
the data stored on the mirrored drive so that it is the same as that on the other drive.

Note that Parity Check/Repair only guarantees that the parity information, not the data, is 
correct. The data in the logical units may be corrupted even though the parity information 
is correct. If you get a parity error, you may need to locate the file containing the error and 
restore the file from back-up.

To ensure that a redundant logical unit will be able to recover, you should set your RAID 
Controllers to perform Automatic Parity Check/Repair on a regular basis. You can set it to 
run either daily or once a week. At times, you may need to run Parity Check/Repair 
manually as part of the recovery process. 

Setting Automatic Parity Time

To ensure data integrity on your RAID Controllers, you should set your software to run 
Automatic Parity Check/Repair on a regular basis (either daily or once a week).

Note: If you have very large RAID Controllers, it may take longer than 24 hours to run 
automatic Parity Check/Repair. This can result in multiple parity checks running at 
the same time. If this occurs, set Parity Check/Repair to run once a week.

To set the time for Automatic Parity Check/Repair, do the following:

1. Start the Maintenance and Tuning application.

2. Select any RAID Controller or All RAID Controllers. The automatic time always 
applies to all RAID 1, 3, and 5 logical units on all the RAID Controllers on your 
system, even if you select an individual module.

3. Select Option → Auto Parity Settings from the drop-down menus. A screen like Figure 
54 is displayed.

4. Enter the settings you want, then click Save to make the settings effective, or press 
Cancel to return to the application without changing the settings.
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Figure 54.   Setting The Time For Automatic Parity Check/Repair

Running Manual Parity Check

Normally, you should set your RAID Controllers so that Parity Check is run automatically 
on a regular basis (see "Setting Automatic Parity Time" on page 110 for information on 
how to set the time for Automatic Parity Check). However, during recovery, or if you 
suspect a problem, you may need to run manual Parity Check/Repair to find and correct 
parity errors immediately.

1. Use the following procedure to run Parity Check/Repair manually.

2. Start the Recovery application.

3. Select the RAID Module containing the LUNs you want to check (or select ALL RAID 
Controllers).

4. Click the Manual Parity Check/Repair button or select Options → Manual Parity 
Check/Repair from the drop-down menus. A screen like Figure 55 on page 112 is 
displayed.

5. After you have selected the LUNs you want to check, click Start Parity Check/Repair. 
Click any of the other buttons to exit this screen without performing the check.

6. As each LUN is checked, a histogram bar appears on the screen indicating the Parity 
Check/Repair progress on that LUN.

Click here to enable or disable Automatic Parity Check/Repair.

Click here to go back to the application without 
changing the current settings.

Click here to save the values currently displayed.

Set the time for automatic check/
repair here. Pick a time of low 
system usage. The current setting 
is displayed.

Select the day of the week you 
want automatic parity check to 
run, or select Daily to run it every 
day.
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7. When Parity Check/Repair is completed, you will see a message indicating if any 
errors were found.

Figure 55.   Manual Parity Check Repair Screen

Notes:

• You can not run Parity Check/Repair on a RAID 0 logical unit or a non-optimal RAID 
1, 3, or 5 logical unit.

• Parity repair fixes parity, not data. If the parity inconsistencies were caused by 
corrupted data, the data is still corrupted, even though the parity is correct.

• While parity check/repair is in progress, you can not perform other Recovery tasks.

Select the logical units you want to check here. You can 
not select a RAID 0 logical unit, or a logical unit with a 
status other than Optimal.

Click here to start the Parity Check/Repair 
operation. This box is grayed out if you 
select a RAID 0 or a non-Optimal logical 
unit.

Click here to view the help.

Click any button here to leave this 
screen without performing a check.

A histogram appears here to show 
the progress of Parity Check/Repair 
on each LUN as it is checked.

Click here to cancel Manual Parity 
Check.
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Changing The LUN Reconstruction Rate

The Reconstruction Rate is the rate at which the controller rebuilds data on a replaced 
drive. The faster the reconstruction rate, the more time the controller spends rebuilding 
data and the less time it spends servicing I/O requests from the host. The slower the rate, 
the faster system I/O occurs, but the longer reconstruction takes to finish. See 
"Reconstruction" on page 12 for more information.

Use this option to change the LUN Reconstruction Rate of logical units that are not 
currently being reconstructed. To change the rate of logical units that are currently being 
reconstructed, see "Monitoring/Changing Reconstruction" on page 98.

To change the LUN reconstruction, perform the following steps.

1. Start the Maintenance and Tuning application.

2. Select the RAID module you want to change reconstructions rates on. Do not select All 
RAID Controllers.

3. Click on the LUN Reconstruction button or select Options → LUN Reconstruction 
from the drop-down menus. A screen like Figure 56 on page 114 is displayed.

4. For each logical unit, move the tab in the slider bar to the rate you want. 

• Moving the tab to the left increases system performance during reconstruction, but 
slows reconstruction

• Moving the tab to the right decreases the amount of time reconstruction will take, 
but slows system performance.

5. After you have made all the changes you want, click Save to implement the changes.
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Figure 56.   Changing The Reconstruction Rate Screen

Notes:

• You can not perform this option if you select All RAID Controllers.

• The new reconstruction rate will go into effect the next time the selected logical units 
are reconstructed.

• You can use this option to change the reconstruction rate of LUN currently being 
reconstruction; however, it is best to use the procedure given in "Monitoring/Changing 
Reconstruction" on page 98.

• From left to right the points on the Slider bar indicate the following reconstruction 
rates (blocks/seconds delay). Note that each 1024 block = 512 KB.

• Slow — 1024 blocks/0.8 second delay

• Medium slow — 1024 blocks/0.4 second delay

• Medium — 1024 blocks/0.2 second delay

• Medium fast — 1024 blocks/0.1 second delay

• Fast — reconstruct with no delays.

Click here to implement the 
changes.

Click here for help.

This display shows all the logical 
units in the selected RAID 
Controller and the current 
reconstruction rate settings for 
them. 
This setting is shown as a slider 
bar. If you move the tab to the left, 
reconstruction will be slower, but 
system performance will be faster. 
If you move the tab to the right, 
reconstruction will occur at a faster 
rate, at the expense of system 
performance.

You must have an individual RAID Controller selected 
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Balancing LUNs

Balancing LUNs involves assigning drive groups/LUNs to controllers in an active/active 
redundant controller pair (see "Redundant Controllers" on page 12 for a definition of 
redundant controllers). Some LUN balancing occurs when you create drive groups/LUNs. 
The first drive group you create in a configuration session is assigned to controller A, the 
second to controller B, the third to controller A again, and so on. However, if you 
repeatedly create one drive group per session, you will end up with all drive groups 
assigned to controller A. You can manually balance the logical units to change this default 
balancing, or if you need to reassign logical units after a controller failure.

Logical units are balanced by drive group. That is, all the LUNs in a drive group must be 
assigned to the same controller. This may result in more actual logical units assigned to 
one controller than to the other, even if each controller is assigned the same number of 
drive groups. For example, if drive groups 1 and 2 have 1 logical unit each and drive group 
3 has 4 logical units, relying on automatic balancing will result in one controller servicing 
5 logical units while the other controller services only one. 

Using the LUN balancing option, you can either:

• Automatically balance drive groups/logical units (see "Automatic LUN Balancing" on 
page 115).

• Manually balance the logical units in one RAID Controller (see "Manual LUN 
Balancing" on page 117).

Automatic LUN Balancing

IMPORTANT If a RAID Controller does not have RDAC protection, it will not be 
balanced unless all I/O to that module is stopped. If none of the displayed 
RAID Controllers are eligible for balancing, the Balance button is grayed 
out.

To automatically balance drive groups/logical units in RAID Controllers, use the 
following procedure.

1. Start the Maintenance and Tuning application.

2. Select All RAID Controllers. (If you select a single RAID Controller, you can only 
balance the logical units manually; see"Manual LUN Balancing" on page 117).

3. Click on the LUN Balancing button or select Options→ LUN Balancing. A screen like 
Figure 57 on page 116 is displayed.

4. Select the RAID Controllers you want to balance, then click Balance to automatically 
balance them. 
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Figure 57.   Automatic LUN Balancing Screen

Notes:

• You can only select RAID Controllers with active/active controller pairs.

• You can not select controllers in an independent configuration (you must use 
manual LUN balancing to reassign LUNs in this configuration; see "Manual LUN 
Balancing" on page 117).

• Remember that balancing is done by drive group, so the number of LUNs assigned 
to each controller will not necessarily be the same after the LUNs are balanced. 

• Odd-numbered drive groups are assigned to one controller and even numbered 
drive groups are assigned to the second controller.

• Logical units/drive groups will not be balanced on RAID Controllers without 
RDAC protection unless all I/O to that module is stopped. 

• If none of the displayed RAID Controllers are eligible for balancing, the Balance 
button is grayed out.

You must have All RAID Controllers selected here. If you have selected a 
specific RAID Controller, see "Manual LUN Balancing" on page 117.

This display shows all the RAID 
Controllers on your system and the 
current LUN assignments on them. 
Select the RAID Controllers you 
want to balance and click on the 
Balance button.

Remember that balancing is by 
drive group, so the number of LUNs 
assigned to each controller will not 
necessarily be the same after the 
LUNs are balanced. 

Click here to automatically balance the LUNs 
on the selected RAID Controllers.

Click here for help.



Chapter 7. Maintenance and Tuning 117

Manual LUN Balancing

To manually balance the logical units/drive groups in a single RAID Controller, perform 
the following steps.

CAUTION If the RAID Controller does not have RDAC fail-over protection, you 
must stop all I/O to that module before balancing the LUNs.

1. Start the Maintenance and Tuning application.

2. Select the individual RAID Controller containing the logical units/drive groups you 
want to reassign. (If you select All RAID Controllers, you can only automatically 
balance all the drive groups in all your RAID Controllers; see"Automatic LUN 
Balancing" on page 115).

3. Click on the LUN Balancing button or select Options→ LUN Balancing. A screen like 
Figure 58 on page 118 is displayed.

4. Make the re-assignments you want by highlighting the drive groups and then clicking 
on the Move button.

5. After you have made all the changes you want to make, click Save to make the 
changes.
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Figure 58.   Manual LUN Balancing Screen

Notes:

• You can only select RAID Controllers with active/active controller pairs.

• If the RAID Controller does not have RDAC protection, you must stop all I/O to the 
module before balancing the LUNs.

• In an independent controller configuration, you can only reassign LUNs from the 
inaccessible controller to the accessible controller (the controller connected to the 
host system you are using). You can not assign LUNs from the accessible controller 
to the inaccessible controller.

Changing Controller Mode

IMPORTANT You can use this option only if the redundant controllers in the RAID 
Controller are active/passive.

These two windows show the current logical unit/drive 
group assignments. To move a drive group from one 
controller to the other, highlight the drive group and use 
the Move button.

Use the Move button to move 
drive groups between screens. 
Highlight a drive group and then 
click on the button to move the 
selected drive group to the other 
window.

Click here to make the changes 
you’ve entered. The drive groups 
are then reassigned according to 
the current display.

Click here to exit without 
changing drive group assignment.

Click here for help.

You must have a specific RAID Controller selected 
here. If you have selected ALL RAID Controllers, see 
"Automatic LUN Balancing" on page 115.
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Use this option to:

• Swap the active/passive controllers in a RAID Controller so that the active controller 
becomes passive and the passive controller becomes active. 

• Change the active/passive status to active/active.

Note that you can not use this option to change controllers from active/active to active/
passive. This can only be done with the rdacutil utility. See the rdacutil entry on page 134 
for information on this utility.

To change the controller mode of your controllers, perform the following steps:

CAUTION If the RAID Controller does not have RDAC protection on the selected 
RAID Controller, you must stop all I/O to that module before changing 
controller modes.

1. Start the Maintenance and Tuning application.

2. Select the RAID Controller with the controllers you want to change or select All RAID 
Controllers to change controller mode in more than one RAID Controller.

IMPORTANT You will not be able to select this option unless the selected RAID 
Controller contains an active/passive controller pair, or, if you selected 
All RAID Controllers, at least one controller pair is active/passive.

3. Click on the Controller Mode button or select Option → Controller Mode from the 
drop-down menu. A screen like Figure 59 on page 120 is displayed.

4. Either:

• Swap the controllers, making the active one passive and the passive one active. 

• Change the controller mode to active/active. A confirmation message will appear, 
giving you the chance to automatically balance the drive groups/logical units across 
the two controllers during the mode change.
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Figure 59.   Change Controller Mode Screen

Notes:

• If the RAID Controller does not have RDAC protection, you must stop all I/O to the 
module before changing controller mode.

• You will not be able to select this option unless the selected RAID Controller contains 
an active/passive controller pair, or, if you selected All RAID Controllers, at least one 
controller pair is active/passive.

• You can not change active/active controllers to active/passive using this application. 
See the rdacutil entry on page 134.

• When you swap active/passive controllers, the logical units are automatically switched 
to the other controller.

The selected module must contain a pair of redundant controllers in active/
passive mode. If you selected All RAID Controllers, at least one controller pair 
must be active/passive.

This displays shows the current 
active/passive status of the 
controllers in the selected RAID 
Controllers.
If you selected All RAID 
Controllers, you must highlight the 
controller pair you want to change.

Click here to change the controllers to active/active 
mode. A confirmation message will allow you to 
specify whether you want to automatically balance 
the drive groups/LUNs across the controllers.

Click here to make the active controller passive 
and the passive controller active. All LUNs will be 
re-assigned to the active controller.

Click here for help.

These buttons will be grayed out if 
the currently selected controllers are 
not active/passive.
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Changing Cache Parameters

Cache is a memory area on the controller that stores read/write data from the host. Using 
cache memory can speed up I/O operations. See "Cache Memory" on page 5 for more 
information on cache memory.

You can set three cache memory parameters with this option: write caching, write cache 
mirroring, and caching without batteries. You can change other cache options using the 
raidutil utility. See the raidutil entry on page 134 for information on this utility.

You can only change cache parameters if:

• Both controllers in the RAID Controller (if there are two) have the same size cache 
memory (at least 128 MB).

• Write cache mirroring can be assigned to a single controller, but this has no effect.

You can check the cache capacity of the controllers through the Module Profile controller 
information screen (see "The Controller Profile Screen" on page 39).

Use the following procedure to change the cache parameters.

1. Start the Maintenance and Tuning application.

2. Select the RAID Controller containing the logical units you want to set cache 
parameters for.

3. Click on the Cache Parameters button or select Option → Cache Parameters from the 
drop-down menus. A screen like Figure 60 on page 122 is displayed.

Note: You might see an asterisk next to the caching parameters column. This indicates that 
the parameter is enabled, but is not currently active. The controller has disabled the 
parameter for some reason (such as low batteries). If you see this condition, use 
Message Log (Status Application) to determine the correct action to take.

4. Click in the boxes to select or deselect individual cache parameters for the logical 
units. The parameters are interdependent; clicking on some will automatically select or 
deselect others. See Table 18 on page 122.

5. After you have made all the changes you want, click Save to apply the changes.



122 IBM Netfinity SYMplicity Storage Manager User’s Handbook

Figure 60.   Cache Parameters Screen

Table 18: Cache Parameter Interdependencies

If You Select: The Following Parameters Are 
Enabled:

Write Caching Write Cache Mirroring1

Write Cache Mirroring1 Write Caching

Cache Without Batteries Write Caching

If You Deselect: The Following Parameters Are 
Disabled:

Write Caching
Write Cache Mirroring

Cache Without Batteries

1 Write Cache Mirroring is only effective for modules with redundant controller pairs 
(active/active or active/passive) that have the same size cache. Use Module Profile → 
Controllers to determine if both controllers in the pair have the same cache size before 
enabling this parameter. Note that the parameter can be assigned to any controller, even 
single controllers.

Select an individual RAID Controller here. You can not set cache parameters if 
All RAID Controllers is selected.

This display shows the cache 
parameter settings for each logical 
unit in the selected RAID Controller. 
If an option is grayed out, it is 
because the controllers in the RAID 
Controller do not support that 
parameter.

Click in the boxes to select or deselect 
parameters. These parameters are 
interdependent. Clicking on one may 
cause others to be enabled or disabled 
(see Table 18).

Click here to save the current cache 
parameter settings.

Click here to exit this screen without 
making any changes.

Click here for help.
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Chapter 8. Getting Help, Service, and Information

If you need help, service, technical assistance, or just want more information about IBM products, 
you will find a wide variety of sources available from IBM to assist you. 

For example, IBM maintains pages on the World Wide Web where you can get information about 
IBM products and services, find the latest technical information, and download device drivers and 
updates. Some of these pages are:

You can select a country-specific Web site from these pages.

Help is also available from bulletin boards and online services, as well as by fax and telephone. 
This section provides information about these sources.

Services available and telephone numbers listed are subject to change without notice.

Service Support

With the original purchase of an IBM hardware product, you have access to extensive support 
coverage. During the IBM hardware product warranty period, you may call the IBM Personal 
Computer HelpCenter (1-800-772-2227 in the U.S.) for hardware product assistance covered 
under the terms of the IBM Statement of Limited Warranty.

The following services are available during the warranty period:

• Problem Determination - Trained personnel are available to assist you with 
determining if you have a hardware problem and deciding what action is necessary to 
fix the problem.

http://www.ibm.com Main IBM home page

http://www.pc.ibm.com IBM Personal Computing

http://www.pc.ibm.com/support IBM Personal Computing Support

http://www.pc.ibm.com/us/desktop/ IBM Commercial Desktop (U.S.)

http://www.pc.ibm.com/us/intellistation/ IBM IntelliStation (U.S.)

http://www.pc.ibm.com/us/netfinity/ IBM Netfinity and PC Servers (U.S.)

http://www.pc.ibm.com/us/options/ IBM Options (U.S.)
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• IBM Hardware Repair - If the problem is determined to be caused by IBM hardware 
under warranty, trained service personnel are available to provide the applicable level 
of service.

• Engineering Change Management - Occasionally, there might be changes that are 
required after a product has been sold. IBM or your reseller, if authorized by IBM, will 
make Engineering Changes (ECs) available that apply to your hardware.

Be sure to retain your proof of purchase to obtain warranty service.

Please have the following information ready when you call:

• Machine Type and Model 

• Serial numbers of your IBM hardware products

• Description of the problem

• Exact wording of any error messages

• Hardware and software configuration information

If possible, be at your computer when you call.

The following items are not covered:

• Replacement or use of non-IBM parts or nonwarranted IBM parts

• All warranted parts contain a 7-character identification in the format IBM FRU 
XXXXXXX.

• Identification of software problem sources

• Configuration of BIOS as part of an installation or upgrade

• Changes, modifications, or upgrades to device drivers

• Installation and maintenance of network operating systems (NOS)

• Installation and maintenance of application programs

Refer to the IBM Statement of Limited Warranty for a full explanation of IBM’s warranty terms.

Before You Call for Service

Many computer problems can be solved without outside assistance, by using the online help or by 
looking in the online or printed documentation that comes with your computer or software. Also, 
be sure to read the information in any README files that come with your software.
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Most computers, operating systems, and application programs come with documentation that 
contains troubleshooting procedures and explanations of error messages. The documentation that 
comes with your computer also contains information about the diagnostic tests you can perform.

If you receive a POST error code when you turn on your computer, refer to the POST error-
message charts in your hardware documentation. If you do not receive a POST error code, but 
suspect a hardware problem, refer to the troubleshooting information in your hardware 
documentation or run the diagnostic tests.

If you suspect a software problem, consult the documentation (including README files) for the 
operating system or application program.

Getting Customer Support and Service

Purchasing an IBM PC hardware product entitles you to standard help and support during the 
warranty period. If you need additional support and services, a wide variety of extended services 
are available for purchase that address almost any need.

Using Electronic Support Services

If you have a modem, you can get help from several popular services. Bulletin boards and online 
information services provide assistance through question-and-answer message areas, live chat 
rooms, searchable databases, and more.

Technical information is available on a wide range of topics, such as:

• Hardware setup and configuration

• Preinstalled software

• OS/2, DOS, and Windows

• Networking

• Communications

• Multimedia

In addition, the latest device driver updates are available.

The IBM Bulletin Board System (BBS) can be reached 24 hours a day, 7 days a week.  Modem 
speeds of up to 14,400 baud are supported. Long distance telephone charges might apply. To 
access the IBM BBS:

• In the U.S., call 1-919-517-0001.

• In Canada:
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–In Montreal, call 514-938-3022.
–In Toronto, call 905-316-4255 or 416-956-7877.
–In Vancouver, call 604-664-6464.

• In the U.K., call 01256 336655.

Commercial online services that contain information about IBM products include:

• CompuServe

Use the following GO words:  APTIVA, IBMPS2, ThinkPad, PowerPC, ValuePoint, 
IBMSVR, or IBMOBI.

• PRODIGY

Use the Jump command; type IBM and select PC Product Support.

• America Online

Use the “Go to” keyword IBM Connect.

Using the World Wide Web

On the World Wide Web, the IBM Personal Computing Web site has up-to-date information about 
IBM Personal Computer products and support. The address for the IBM Personal Computing 
home page is:

http://www.pc.ibm.com

You can find support information for your IBM products, including supported options, on the IBM 
Personal Computing Support page at: 

http://www.pc.ibm.com/support

If you select Profile from the support page, you can create a customized support page that is 
specific to your hardware, complete with Frequently Asked Questions, Parts Information, 
Technical Hints and Tips, and Downloadable Files. You will have the information you need, all in 
one place.

In addition, you can choose to receive e-mail notifications whenever new information becomes 
available about your registered products. You also can access online support forums, which are 
community sites monitored by IBM support staff.

For information about specific Personal Computer products, visit the following pages:

http://www.pc.ibm.com/us/intellistation/

http://www.pc.ibm.com/us/desktop/
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http://www.pc.ibm.com/us/netfinity/

http://www.pc.ibm.com/us/thinkpad/

http://www.pc.ibm.com/us/options/

http://www.pc.ibm.com/us/aptiva/

You can select a country-specific Web site from these pages.

Getting Information by Fax

If you have a touch-tone telephone and access to a fax machine, in the U.S. and Canada you can 
receive by fax marketing and technical information on many topics, including hardware, operating 
systems, and local area networks (LANs). You can call the IBM Automated Fax System 24 hours a 
day, 7 days a week. Follow the recorded instructions, and the requested information will be sent to 
your fax machine.

To access the IBM Automated Fax System, do the following:

• In the U.S., call 1-800-426-3395.

• In Canada, call 1-800-465-3299.

Getting Help Online

Online Housecall is a remote communication tool that allows an IBM technical-support 
representative to access your PC by modem. Many problems can be remotely diagnosed and 
corrected quickly and easily. In addition to a modem, a remote-access application program is 
required. This service is not available for servers. There might be a charge for this service, 
depending on the request.

For more information about configuring your PC for Online Housecall:

• In the U.S., call 1-800-772-2227.

• In Canada, call 1-800-565-3344.

• In all other countries, contact your IBM reseller or IBM marketing representative.

Getting Help by Telephone

During the warranty period, you can get help and information by telephone through the IBM PC 
HelpCenter. Expert technical-support representatives are available to assist you with questions you 
might have on the following:

• Setting up your computer and IBM monitor
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• Installing and setting up IBM options purchased from IBM or an IBM reseller

• 30-day, preinstalled-operating-system support

• Arranging for service (on-site or carry-in)

• Arranging for overnight shipment of customer-replaceable parts

In addition, if you purchased an IBM PC Server or IBM Netfinity Server, you are eligible for IBM 
Start Up Support for 90 days after installation. This service provides assistance for:

• Setting up your network operating system

• Installing and configuring interface cards

• Installing and configuring network adapters

Please have the following information ready when you call:

• Machine Type and Model

• Serial numbers of your computer, monitor, and other components, or your proof of 
purchase

• Description of the problem

• Exact wording of any error messages

• Hardware and software configuration information for your system

If possible, be at your computer when you call.

In the U.S. and Canada, these services are available 24 hours a day, 7 days a week. In the U.K., 
these services are available Monday through Friday, from 9:00 a.m. to 6:00 p.m.*

Country Telephone number

Austria 1-546 585 075

Belgium - Dutch 02-717-2504

Belgium - French 02-717-2503

Canada 1-800-565-3344

Denmark 3-525-6905

Finland 9-22-931805

France 01-69-32-40-03
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*Response time will vary depending on the number and complexity of incoming 
calls.

In all other countries, contact your IBM reseller or IBM marketing representative.

Getting Help Around the World

If you travel with your computer or need to move it to another country, you can register for 
International Warranty Service. When you register with the International Warranty Service Office, 
you will receive an International Warranty Service Certificate that is honored virtually worldwide, 
wherever IBM or IBM resellers sell and service IBM PC products.

For more information or to register for International Warranty Service:

• In the U.S. or Canada, call 1-800-497-7426.

• In Europe, call 44-1475-893638 (Greenock, U.K.).

• In Australia and New Zealand, call 61-2-9354-4171.

In all other countries, contact your IBM reseller or IBM marketing representative.

Germany 069-6654-9003

Ireland 01-815-9207

Italy 02-4827-5003

Luxembourg 298-977-5060

Netherlands 020-504-0531

Norway 2-305-3203

Portugal 01-791-5147

Spain 091-662-4270

Sweden 08-632-0063

Switzerland - German 01-212-1810

Switzerland - French 022-310-0418

Switzerland - Italian 091-971-0523

United Kingdom 01475-555555

U.S.A. and Puerto Rico 1-800-772-2227
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Purchasing Additional Services

During and after the warranty period, you can purchase additional services, such as support for 
IBM and non-IBM hardware, operating systems, and application programs; network setup and 
configuration; upgraded or extended hardware repair services; and custom installations. Service 
availability and name might vary by country.

Enhanced PC Support Line

Enhanced PC Support is available for desktop and mobile IBM computers that are not connected 
to a network. Technical support is provided for IBM computers and IBM or non-IBM options, 
operating systems, and application programs on the Supported Products list.

This service includes technical support for:

• Installing and configuring your out-of-warranty IBM computer

• Installing and configuring non-IBM options in IBM computers

• Using IBM operating systems in IBM and non-IBM computers

• Using application programs and games

• Tuning performance

• Installing device drivers remotely

• Setting up and using multimedia devices

• Identifying system problems

• Interpreting documentation

You can purchase this service on a per-call basis, as a multiple-incident package, or as an annual 
contract with a 10-incident limit. For more information about purchasing Enhanced PC Support, 
see "900-Number Operating System and Hardware Support".

900-Number Operating System and Hardware Support

In the U.S., if you prefer to obtain technical support on a pay-as-you go basis, you can use the 900-
number support line. The 900-number support line provides support for IBM PC products that are 
out of the warranty period. 

To access this support, call 1-900-555-CLUB (2582). You will be notified of the charge per 
minute.
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Network and Server Support Line

Network and Server Support is available for simple or complex networks made up of IBM servers 
and workstations using major network operating systems. In addition, many popular non-IBM 
adapters and network interface cards are supported.

This service includes all of the features of the Enhanced PC Support Line, plus:

• Installing and configuring client workstations and servers

• Identifying system problems and correcting problems on the client or the server

• Using IBM and non-IBM network operating systems

• Interpreting documentation

You can purchase this service on a per-call basis, as a multiple-incident package, or as an annual 
contract with a 10-incident limit. 

Ordering Support Line Services

Enhanced PC Support Line and Network and Server Support Line services are available for 
products on the Supported Products list. To receive a Supported Products list:

In the U.S.:

1. Call 1-800-426-3395.

2. Select document number 11683 for Network and Server support.

3. Select document number 11682 for Enhanced PC support.

In Canada, contact IBM Direct at 1-800-465-7999, or:

1. Call 1-800-465-3299.

2. Select the HelpWare catalog.

3. In all other countries, contact your IBM reseller or IBM marketing representative. 

For more information or to purchase these services:

• In the U.S., call 1-800-772-2227.

• In Canada, call 1-800-465-7999.

• In all other countries, contact your HelpCenter.
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Warranty and Repair Services

You can upgrade your standard hardware warranty service or extend the service beyond the 
warranty period.

Warranty upgrades in the U.S. include:

• Carry-in service to on-site service

If your warranty provides carry-in repair service, you can upgrade to on-site repair service, 
either standard or premium. The standard upgrade provides a trained servicer within the 
next business day (9 a.m. to 5 p.m., local time, Monday though Friday). The premium 
upgrade provides 4-hour average response, 24 hours a day, 7 days a week.

• On-site service to premium on-site service

If your warranty provides for on-site service, you can upgrade to premium on-site service 
(4-hour average on-site response, 24 hours a day, 7 days a week).

You also can extend your warranty. Warranty and Repair Services offers a variety of post-warranty 
maintenance options, including ThinkPad EasyServ Maintenance Agreements. Availability of the 
services varies by product.

For more information about warranty upgrades and extensions:

• In the U.S., call 1-800-426-4968.

• In Canada, call 1-800-465-7999.

• In all other countries, contact your IBM reseller or IBM marketing representative.

Ordering Publications

Additional publications are available for purchase from IBM.  For a list of publications available 
in your country:

• In the U.S., Canada, and Puerto Rico, call 1-800-879-2755.

• In other countries, contact your IBM reseller or IBM marketing representative.
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Appendix A. Command Line Interface

This Appendix describes the command line interface to the storage management software.

Command Line Utilities

Table 19 summarizes the Command Line utilities, scripts, and background processes 
available in the storage management software. All of these items have associated Help 
files available as man pages (UNIX) or as Help Text files (Windows NT). The utilities are 
fully explained in these Help files.

Most of these utilities duplicate operations in the GUI, and therefore need to be performed 
only as a last resort.

Table 19: Command Line Utilities And Program Description

Option Description

Informational

symsm
Gives an overview of the software’s graphical user interface (GUI), command 
line programs, background process programs and driver modules, and 
customizable elements.

rdac Describes the software’s support for rdac (Redundant Disk Array Controller), 
including details on any applicable drivers and daemons.

rmevent
The RAID Event File Format. This is the file format used by the applications to 
dispatch an event to the rmscript notification script. It also is the format for 
Message Log’s log file (the default is rmlog.log).

raidcode.txt A text file containing information about the various RAID events and error 
codes.

Command Line Utility

 drivutil
The drive/LUN utility. This program helps manage drives/LUNs. It allows you 
to obtain drive/LUN information, revive a LUN, fail/revive a drive, and obtain 
LUN reconstruction progress.

fwutil The controller firmware download utility. This program downloads appware, 
bootware, fibre channel code, or an NVSRAM file to a specified controller.
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healthck The health check utility. This program performs a health check on the indicated 
RAID Module(s) and displays a report to standard output.

lad The list array devices utility. This program identifies what RAID controllers and 
logical units are connected to the system.

logutil The log format utility. This program formats the error log file and displays a 
formatted version to the standard output.

nvutil

The NVSRAM display/modification utility. This program permits the viewing 
and changing of RAID controller non-volatile RAM settings, allowing for some 
customization of controller behavior. It verifies and fixes any NVSRAM settings 
that are not compatible with the storage management software.

parityck
The parity check/repair utility. This program checks, and if necessary, repairs the 
parity information stored on the array. (While correct parity is vital to the 
operation of the array, the possibility of damage to parity is extremely unlikely.)

raidutil

The RAID configuration utility. This program is the command line counterpart 
to the graphical configuration application. It permits RAID logical unit and hot 
spare creation and deletion to be performed from a command line or script. It 
also allows certain battery management functions to be performed on one 
controller at a time.

rdacutil

The redundant disk array controller management utility. This program permits 
certain redundant controller operations such as LUN load balancing and 
controller failover and restoration to be performed from a command line or 
script.

storutil

(Networked version 
only)

The host store utility. This program performs certain operations on a region of 
the controller called host store. You can use this utility to set an independent 
controller configuration, change RAID Module’s names, and clear information 
in the host store region.

symping

The network connection verification utility. This program verifies that the 
network connection between the Networked storage management software’s 
host and a RAID Module's controllers is operational. If a failure occurs, the 
symping utility will display possible reasons.

Background Process Programs and Driver Modules 

arraymon
The array monitor background process. The primary function of the array 
monitor is to watch for the occurrence of exception conditions in the array and 
provide administrator notification when they happen.

Table 19: Command Line Utilities And Program Description (continued)

Option Description
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Customizable Elements

rmparams

This software’s parameter file. This ASCII file has a number of parameter 
settings, such as the array monitor poll interval, what time to perform the daily 
array parity check, etc. The applications read this file on startup or at select times 
during their execution. A subset of the parameters in rmparams are changeable 
under the graphical interface.

For more information on this file, see the Installation and Support Handbook.

rmscript

The notification script. A program that is called by the array monitor and other 
programs whenever an important event is reported. The file has certain standard 
actions, including posting the event to the message log (rmlog.log), sending e-
mail to the superuser/administrator, and, in some cases, sending an SNMP trap. 
Although you can edit rmscript, make certain that you do not disturb any of the 
standard actions.

For more information on this file, see the Installation and Support Handbook.

Table 19: Command Line Utilities And Program Description (continued)

Option Description
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Appendix B. Notices

Notices

References in this publication to IBM products, programs, or services do not imply that 
IBM intends to make these available in all countries in which IBM operates. Any 
reference to an IBM product, program, or service is not intended to state or imply that only 
that IBM product, program, or service may be used. Subject to IBM’s valid intellectual 
property or other legally protectable rights, any functionally equivalent product, program, 
or service may be used instead of the IBM product, program, or service. The evaluation 
and verification of operation in conjunction with other products, except those expressly 
designated by IBM, are the responsibility of the user.

IBM may have patents or pending patent applications covering subject matter in this 
document. The furnishing of this document does not give you any license to these patents. 
You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
N. Castle Drive
Armonk, NY 10504-1785
U.S.A.

Licensees of this program who wish to have information about it for the purpose of 
enabling: (1) the exchange of information between independently created programs and 
other programs (including this one) and (ii) the mutual use of the information which has 
been exchanged, should contact IBM Corporation, Department 80D, P.O. Box 12195, 
3039 Cornwallis, Research Triangle Park, NC 27709, U.S.A. Such information may be 
available, subject to appropriate terms and conditions, including in some cases, payment 
of a fee.

Trademarks

The following terms are trademarks of the IBM Corporation in the United States or other 
countries or both:
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IBM
Netfinity
IntelliStation
HelpCenter
OS/2
ThinkPad
HelpWare

Microsoft is a trademark of Microsoft Corporation.

Intel is a registered trademark of Intel.

Other company, product, and service names may be trademarks or service marks of others.
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Index

A
Active/active controllers 13

balancing 115, 118
changing to active/passive 120

Active/passive controllers 12
changing mode 26, 118
LUN ownership after swap 120

Add (module) 35
Appware 102

see also Firmware
arraymon utility 134
ASC/ASCQ codes 72, 74
Automatic LUN balancing 115

see also Balancing Logical units
Automatic parity check/repair

see Parity check/repair
B
Balancing logical units 26, 50, 115

LUN creation and 48, 57
restrictions 116

Batteries
caching and 5
see also Cache without batteries

Board ID 39
Board name 39
Board serial number 39
Boot level 40
Bootware 102

see also Firmware
C
Cache memory

cache options and 121
defined 5
performance monitor and 81, 82
see also Cache options

Cache options
asterisks in display 121
cache without batteries 5, 43, 121

changing 26
interdependencies 122
other 121
rdacutil utility and 58
selecting 50, 55, 121

restrictions 121
selections for 43
write cache mirroring 5, 20, 43, 121

restrictions 121
write caching 5, 43, 121

Cache parameters option 55
Cache size 41, 121
Cache without batteries 121

defined 5
setting 43, 121
see also Cache options

Channel ID
drives 9, 36

Channels
creating LUNs and 20, 53
drive 20
failures on 20, 86, 95
hot spares and 67
see also Channel ID

Command line interface 133
see also Command line utilities 133

Command line utilities
drivutil 133
fwutil 133
healthck 134
lad 134
logutil 134
nvutil 102, 107, 134
parityck 134
raidutil 121, 134
rdacutil 6, 58, 119, 120
storutil 134
symping 134

Component failures
see Failures

Configuration
fibre channel 13
independent controller 17
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downloading firmware 103
multi-host 15
network 18
overview 45
recommended 14
resetting 26, 69
single-host 14

Configuration application 48, 65
description of 21
module information display 46

Configured drives
as spares 88

Controller firmware download utility
(fwutil) 133
Controller ID 40
Controllers

active/active 13, 115, 119
active/passive 12, 118
assigning 57
automatic LUN assignment 48, 51, 

115
balancing 26, 115
changing mode 26, 118
firmware 101

downloading 104
inaccessible status 17
manual LUN assignment 115
manual recovery options 97
names of 6, 25
naming 35
placing offline 97
placing online 97
same host bus

restrictions 14
selecting for download 103
unknown status 41
see also Redundant Controllers

Creating logical units
see Logical units, creating

D
Daemon processes

arraymon 134
Data connection

failures 12, 88
see also Redundant controllers

Data path
see Data connection

Date code 42
Date of manufacture 40
Dead logical unit 85
Dead mode 85
Defragment option

defined 58
procedure 64

Degraded logical unit 85
defined 12
parity check and 110

Degraded mode 85
failing drives and 94

Deleting logical units 64
network configuration 66
restrictions 64

Device names
controllers 6
drives 8
logical units 6
user defined 6

Drive groups
adding drives to 25, 61

capacity added 61
balancing 115
configured drives 6
creating 48, 50
defined 6
defragmenting 58, 64
hot spare 6
locating 36
modifying 46, 61
numbering 7
selecting drives 53

restrictions 53
space allocation on 58
unassigned 6, 64
viewing 46

Drive selection option 53
Drive/LUN utility (drivutil) 133
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Drives
adding to drive group 61
channel number 9, 36
channels 20, 86
different sizes 49, 53, 66
drive groups 6

numbering 7
failing 93
failures on 84
firmware 42, 101
hot spares 9, 20
locating 36
manual recovery options 93
names 8
numbering 36
profile information 41
reconstructing 93
replacing 86
reviving 87, 93
SCSI ID 8, 36
serial number 42
status 42
using configured drives as spares 88

drivutil utility 133
E
Edit (module) 35
Exiting the software 30
F
Failing drives 93
Failures

accidental 87
channel 20, 53, 86, 95
controllers 12, 88
data connection 12
drives 84
fans 89
general information 19
message log and 72
power supplies 89
preventing 19
recovering from 83
recovery guru/health check and 19
recovery information for 91

redundant controllers 12
replacing components 27

Fibre channel
configuration 13
controller ID 40
firmware 3.0 and 102, 106
firmware file 102
host-side ID 40
independent controller configuration 

17, 18
link speed 40
multi-host configuration 15, 16
NL_Port 40
physical connection 40
preferred address 40
preferred loop ID 40
restarting after firmware download 

107
single-host configuration 15
topology 40
version 41
worldwide port name 40

Fibre channel level 41
Find (module) 35
Firmware

boot level 102
controller 101
downloading 26

confirming download 108
general steps 102
online/offline method 103
procedure 104
progress of 106

drives 101
fibre channel 102, 106
firmware level 40, 102
fwcompat.def file 102
redundant controller requirements 

104
versions 104

Firmware level 40
drives 42

Formatting logical units 95
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fwcompat.def file 102, 104
fwutil utility 133
G
GUI

navigating in 29
online help 30
overview 133

H
Hardware guides

when to use 2, 83, 89
Health Check

see Recovery guru/health check
Health check utility (healthck) 134
Host bus

caution with dual controllers 14
see also SCSI bus, Fibre Channel

Host interface 40
Host store utility (storutil) 134
Host-side ID 40
Hot spares 20

creating 66
defined 9
deleting 26, 68
drive group 6
drive sizes to use 66
independent controllers and 18
LUN assignment 9
number allowed 67, 68
recovery and 86
restrictions on creating 66
viewing 46

I
Inaccessible status 17
Independent controller configuration 17,
18

hot spares and 18
inaccessible status and 17
rdac support for 17
recovery and 17
see also RAID Modules, 

configuration
Installation and support guide

description of 2

software installation and 2
troubleshooting information in 2

K
Keyboard 29
L
lad utility 134
Link speed 40
List array devices utility (lad) 134
Locating

drive groups 36
drives 36
logical units 36
RAID modules 35

Log format utility (logutil) 134
Logical units

adding drives to 61
cache options

selecting 50, 55, 121
capacity

defaults 53
setting 50, 53

changing RAID level 60
checking parity on 110
controller ownership 13, 26

changing 115
creating 25, 45

controller assignment 57
drive group numbering 7
from unassigned drives 48
in existing drive group 50
operating system and 45, 50, 51
overview 45
RAID level 48
segment size 50, 56
selecting drives 53
space avaliable for 59

dead 85
defined 9
degraded 12, 85
deleting 26, 64

drive group numbering 7
operating system and 64

drive groups 6
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formatting 95
locating 25, 36
manual recovery options 95
modifying 45
names of 6
number allowed 14, 17
profile information 42
reconstruction rate of 98, 113
recovering 85
reviving 95

when 96
segment size 56

changing 63
status 43
viewing 46

logutil utility 134
LUN

see Logical units
LUN assignment option 57
LUN capacity option 53
LUN creation and 50
M
Maintenance and Tuning application 104,
121

description of 24
overview 101

Manual LUN balancing 117
see also Balancing Logical units

Manual parity check/repair
see Parity check/repair

Manual recovery options 92
controllers 97
drives 93
logical units 95
when to use 84

Maximum size limit
effects when exceeded 30, 77
message file and 71, 76
resetting file 77
warning message 77

Message log file 71, 84
backup file names 77
changing settings 76

clearing 30, 77
copying 75
default 72
maximum size limit 30, 71, 76, 77
message types 72
recovery guru and 72
saving 75
viewing 72

Module information display 46
Module profile

drives 41
logical units 42
saving 43
viewing 37
see also RAID modules

Mouse 29
Multi-host configuration 15, 16

number of LUNs on 16
operations on 15
rdac support for 15
reservations and 16
see also RAID Modules, 

configuration
Multiple drive failures 85
N
Navigation 29

keyboard 29
mouse 29
online help 31

Network configuration 18
adding modules 35
deleting logical units 66
exclusive access and 19
naming controllers 35
RDAC and 18
storutil utility 134
symping utility 134
see also RAID Modules, 

configuration
Network connection verification utility
(symping) 134
Network management station 13
NL_Port 40
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NMS 13
Number of drives

setting 48
Number of LUNs

setting 48, 50
NVSRAM 104

defined 102
downloading 26, 103, 104
nvutil utility 134
resetting 69
restart after downloading 103, 107

NVSRAM utility (nvutil) 134
nvutil utility 102, 107, 134
O
Offline controller 97
Offline method (firmware download) 103
Online controller 97
Online help 30
Online method (firmware download) 103
Operating system

dead mode and 85
degraded mode and 85
deleting logical units and 64
device names on 6
installation and support guide 2
logical unit creation and 45, 50, 51
logical unit deletion and 65
messages from 84
RDAC on 11, 12
recovery and 84

P
Parity 110

defined 10
how used 110
RAID 1 and 10, 110
RAID 3 10, 11, 110
RAID 5 10, 11, 110
reconstruction and 12
see also Parity Check/Repair

Parity check/repair
automatic 110

current setting 111
disabling 111

setting time 27, 110
corrupted data and 110
defined 10
eligible LUNs 112
manual 110

restrictions 112
running 111
when to run 27, 111

parityck utility 134
RAID 1 and 10
RAID 3 10
RAID 5 10
restrictions 110, 112
running 110
viewing results of 27, 72
what is repaired 110

Parity check/repair utility (parityck) 134
Performance monitor 78

polling interval 79
saving data from 81
screen elements 81
starting 78
using data from 81
when to run 25

Physical connection 40
Polling interval

performance monitor 79
status 71

changing 76
Preferred address 40
Preferred loop ID 40
Processor size 41
Product ID 39
Product revision 40
Product serial number 39
R
RAID 0

dead mode 85
defined 10
failing drives and 94
parity check and 110
recovery on 85
reviving drives and 87
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see also RAID level
RAID 1

dead mode 85
defined 11
degraded mode 85
failing drives and 94
parity and 10
parity check/repair and 10, 110
recovery on 85
reviving drives and 87
when to use 19
see also RAID level

RAID 3
dead mode 85
defined 11
degraded mode 85
failing drives and 94
parity 10
parity check/repair 10, 110
recovery on 85
reviving drives and 87
when to use 19
see also RAID level

RAID 5
dead mode 85
defined 11
degraded mode 85
failing drives and 94
parity 10
parity check/repair 10, 110
recovery on 85
reviving drives and 87
when to use 19
see also RAID level

RAID configuration utility (raidutil) 134
RAID level

changing 25, 60
RAID 0 10
RAID 1 11
RAID 3 11
RAID 5 11
setting 48
when to use 19

see also individual RAID level entries
RAID modules

adding 35
configuration

independent 17
multi-host 15
network 18
overview 45
single-host 14

failure recovery 83
finding 35
identifying 33
locating 35
module information display 46
naming 25, 35
profile information 25, 37

saving 43
removing 35
selecting 33
tasks 25

raidcode.txt file 133
raidutil utility 121, 134
RDAC

controller failures and 88
controller mode changes and 120
defined 11
failover conditions 89
firmware download and 103
independent configuration and 17
LUN balancing and 115, 116, 117, 

118
multi-host configuration and 15
overview 133
redundant controllers and 12
single-host configuration and 14

rdac text file 133
rdacutil utility 6, 58, 119, 120
Reconstructing drives 93
Reconstruction 93, 94

defined 12
monitoring 88, 98
rate of 12

Reconstruction rate
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changing 26, 88, 98, 113
restrictions 114

defined 12
settings 100, 114

Recovery
component failures and 19
failed controllers 88
failed drives 84
failed fans 89
failed power supplies 89
independent controllers and 17
instructions for 91
manual recovery options 92
overview 83
reconstruction rate 98
tasks 27

Recovery application 90, 93
description of 23
overview 83

Recovery guru/health check 19
independent configuration and 17
message log and 72
show procedures 91
starting 90
viewing procedures 83
when to use 27, 84

Redundant controller management utility
(raidutil) 134
Redundant controllers

active/active 13, 119
active/passive 12, 119
changing mode of 118
changing status of 98
described 12
failover support 15, 17, 18
firmware requirements 104
LUN ownership and 115
recommended configuration 13
see also Controllers
see also RDAC

Remove (module) 35
Reservations 16
Resetting configuration 69

Reviving drives 87, 93
Reviving logical units 95
rmevent file 133
rmparams file 135
rmscript

description 133
file 135

S
SCSI bus

independent controller configuration 
17, 18

multi-host configuration 15, 16
single-host configuration 14
see also Host Bus

SCSI ID
drives 8, 36
see also Host-side ID

Segment size
changing 26, 63
defined 13
selecting 50, 56

Segment size option 56
Serial number

board 39
controller 38
drives 42
product 39

Show procedures 91
see also Recovery guru/health check

Simple Network Management Protocol
see SNMP

Single drive failures 85
Single-host configuration 14

rdac support for 14
see also RAID Modules, 

configuration
SNMP 72, 84

defined 13
Software

exiting 30
installing 2
online help for 30
starting 30
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Starting the software 30
Status 71, 84

dead mode 85
degraded mode 85
drives 42
inaccessible 17
logical units 43
message file 25, 71, 84

backup file name 77
changing settings 76
clearing 30, 77
copying 75
default 72
maximum size limit 30, 71, 77
message types 72
opening 75
viewing 72

polling 71, 76
unknown 41

Status application 78
description of 22

Status log 25, 71
clearing 30, 77
see also Message log file

Stopping the software 30
storutil utility 134
symping utility 134
symsm file 133
T
Tasks 25
Topology 40
Troubleshooting 2

see also Installation and Support 
Guide

U
Unassigned drive group 6, 64

creating LUNs from 48
viewing 46

Unknown status 41
User guide

description of 1
V
Vendor

drives 42
Vendor ID

fibre channel controllers 40
W
Worldwide port name 40
Write cache mirroring 121

defined 5
failures and 89
restrictions 121
setting 43, 121
when to use 20
see also Cache options

Write caching 121
defined 5
failures and 89
setting 43, 121
see also Cache options
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