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Preface
Preface

The UM Services User’s Guide provides you with basic information for 
installing and using Universal Manageability (UM) Services on your 
system. It also provides information for installing and using UM 
Services Upward Integration Modules (UIMs) on systems running 
supported system-management applications.

Who Should Read This Guide
This guide is intended for the individuals responsible for installing and 
using UM Services (on their systems or on remote client systems in a 
network environment) and Upward Integration Modules (on supported 
system-management platforms). This guide assumes that you have 
extensive knowledge of server, mobile, and desktop system hardware; 
operating systems; Windows networking; desktop environments; 
system-management tasks; and the features and functionality provided 
by the supported system-management platforms.

What This Guide Contains
This guide contains the following chapters:

■ Chapter 1 on page 11 provides an overview of UM Services.

■ Chapter 2 on page 15 provides directions for installing and starting 
UM Services on your IBM system.

■ Chapter 3 on page 27 provides an overview of the UM Service 
console and includes brief descriptions of UM Services 
Information and Task functions.

■ Chapter 4 on page 89 provides information on installing and using 
UIMs with supported system management applications.

Getting Help
UM Services includes an online troubleshooting guide that contains 
solutions for many common installation and usage issues. This 
troubleshooting guide is installed when you install UM Services and can 
UM Services  
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be accessed from the UM Services Troubleshooting option in your 
Start menu.

Additional information and UM Services product updates, when 
available, can be obtained from the IBM Web site at:

http://www.ibm.com/pc/ww/software/sysmgmt/products/ums
x
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1.About UM Services

IBM® Universal Manageability (UM) Services is a lightweight client 
that resides on managed computer systems. It provides a suite of 
graphical user interfaces (GUIs) that enhance the local or remote 
administration, monitoring, and maintenance of IBM systems, such as 
ThinkPad® computers, IntelliStation® computers, and Netfinity® 
servers. 

With UM Services, a client-system user or remote system administrator 
can use a Web browser or the Microsoft® Management Console (MMC) 
and the UM Services Web console support to inventory, monitor, and 
troubleshoot IBM systems on which UM Services is installed. 

This “point-to-point” system-management approach enhances support 
and enables a system administrator to effectively maintain IBM systems 
without having to install additional system-management software on the 
administrator console.

UM Services also includes support for Upward Integration Modules 
(UIMs). A system administrator who uses any supported 
system-management platform (such as Tivoli® Enterprise, CA 
Unicenter TNG Framework, or Microsoft Systems Management Server) 
can use UIMs to integrate portions of UM Services into the 
administrator console. Because it is designed to use industry-standard 
information gathering technologies and messaging protocols (such as 
Common Information Model, Desktop Management Interface, and 
Simple Network Management Protocol), UM Services adds value to any 
of these supported workgroup or enterprise system-management 
platforms.
UM Services  User’s Guide  11



The following describes the available components (services) that you 
can install on local UM Services client systems. 

Basic Services
Basic Services includes a Java Virtual Machine, a Common 
Information Model (CIM) repository, a Desktop Management 
Interface (DMI) 2.0 compliant service provider, and basic 
instrumentation for gathering hardware inventory data. The 
inventory information provided by Basic Services can be 
viewed through a CIM browser such as Microsoft 
WBEMTEST. The IBM Managed Information Format (MIF) 
generator program (CIM2MIF) can also be used to generate 
inventory files that can be exported to system-management 
applications, such as Tivoli Enterprise, Microsoft Systems 
Management Server (SMS), or CA Unicenter TNG Framework. 
Basic Services must be installed on all UM Services clients in 
the network.

Netfinity Director Support
IBM Netfinity Director is an advanced Intel® processor-based 
workgroup hardware manager with centralized client- and 
group-management console and server services. It was 
developed with object-oriented tools to provide flexibility and 
extendability, including Life Cycle Tools for added 
management over the entire life cycle of the asset. Installing this 
feature will enable the client system to be a part of this Universal 
Manageability process.

Web Based Access
Web Based Access offers a convenient Java-based tool for 
managing a client system and for viewing the CIM-based 
inventory data. If you install Web Based Access, a hypertext 
transfer protocol (HTTP) DAEMON will be installed and will 
require a user name and password to be typed during the 
installation. The user name and password will be used to limit 
access to the HTTP DAEMON. With Web Based Access 
installed on the client system, the client can be managed from 
any remote computer with a supported Web browser. No 
software other than a Web browser is needed on the remote 
computer.
12
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Note: This component is selected for installation by default.

Web Based Remote Control
Using Web Based Remote Control, a system administrator can 
remotely take control of the client system desktop through a 
Web browser or MMC, enhancing the administrator’s ability to 
diagnose system problems and troubleshoot the client system.

Note: You must install the Web Based Access component to 
install the Web Based Remote Control component.

System Health Monitoring
System Health Monitoring provides active monitoring of 
critical system functions, such as available disk space, system 
temperature, fan functionality, power supply voltage, and 
system cover removal. System Health Monitoring also provides 
software for enabling Alert on LAN functionality on systems 
that support this feature. With System Health Monitoring, you 
can detect system problems early, before system failures occur. 
The system administrator will be notified of a system problem 
by a CIM event, simple network management protocol (SNMP) 
trap (SNMP traps are available only if SNMP access and trap 
forwarding are also enabled), or SMS status message (Microsoft 
SMS 2.0 only). A critical problem also results in a message 
displayed on the monitor of the client system.

LANDesk Management Suite Integration
LANDesk Management Suite Integration installs the Intel 
Common Base Agent on the client system. This enables the 
system administrator to use UM Services with LANDesk 
Management Suite.

Tivoli Management Agent
Tivoli Management Agent provides support on the client system 
that enables it to be managed by the Tivoli Enterprise 
system-management platform.

SNMP Access and Trap Forwarding
This feature enables CIM information to be accessed from a 
client system using the Simple Network Management Protocol 
(SNMP). If System Health Monitoring is enabled, this option 
also enables System Health to forward CIM events as SNMP 
UM Services  User’s Guide  13



traps. This component requires that you have the SNMP service 
(provided with your operating system) installed on the endpoint. 
If the SNMP service is not installed, you will be prompted to 
insert your operating system installation media and install 
SNMP during the UM Services installation.

DMI Support When enabled, this feature maps Common Information 
Model (CIM) data and events from a managed client system to 
a Desktop Management Interface (DMI).
14
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2.Installing UM Services

This section contains instructions for installing Universal Manageability 
Services (UM Services) on the client systems. Depending on your 
system-management environment, you can choose to install all of UM 
Services, or you can choose to install only selected portions of UM 
Services. 

The UM Services installation program also includes support for 
installing Workgroup/Enterprise Integration on client systems running 
supported system-management platforms. Workgroup/Enterprise 
Integration adds an Upward Integration Module (UIM) to a supported 
system-management platform, such as CA Unicenter TNG Framework 
or Microsoft SMS. With UIMs, you can use your system-management 
software to manage clients running the UM Services client software. 
Workgroup/Enterprise Integration installation procedures are explained 
in “Chapter 4. Upward Integration Modules,” on page 89.

Before You Begin
As noted in the previous chapter, UM Services includes a number of 
optional components that add value in a variety of system-management 
environments. Before you begin your installation, determine whether 
you will be using UM Services as a stand-alone client-based 
system-management solution, or whether you will be using UM 
Services to gather data for a supported system-management platform. 

Also, UM Services require certain hardware and software minimums for 
installation. These requirements are found on page 18.
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Supported Systems-Management Environments
The UM Services components that you choose to install are largely 
determined by the system-management environment in which you are 
installing UM Services. Some components are of use to most 
system-management platforms, while others are of use only to specific 
platforms. The following sections offer example component selections 
based on the system-management platforms used to manage systems in 
the network.

UM Services Console

If you will be using a Web browser or MMC to manage UM Services 
clients, install the following UM Services components on the client 
systems:

■ Web Based Access

■ System Health Monitoring

■ Web Based Remote Control

Note: Systems using a Web browser or MMC to access UM Services 
locally require 64 MB of RAM to function properly.

Tivoli Enterprise

If you use Tivoli Enterprise to manage the client systems in your 
network, install the following UM Services components on the client 
systems:

■ Web Based Access

■ System Health Monitoring

■ Tivoli Management Agent

■ SNMP Access and Trap Forwarding

Tivoli NetView

If you use Tivoli NetView to manage the client systems in your network, 
install the following UM Services components on the client systems:

■ Web Based Access

■ System Health Monitoring
16
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■ Web Based Remote Control

■ SNMP Access and Trap Forwarding

Microsoft SMS 1.2 or 2.0

If you use Microsoft SMS 1.2 or 2.0 to manage the client systems in your 
network, install the following UM Services components on the client 
systems:

■ Web Based Access

■ System Health Monitoring

■ SNMP Access and Trap Forwarding

Note: For SMS 1.2, the Upward Integration Module (UIM) needs to 
be installed on all primary site servers and management 
consoles.  It does not need to be installed on the secondary 
servers.

For SMS 2.0, the UIM needs to be installed on all site servers 
and all management consoles.

CA Unicenter TNG Framework

If you use CA Unicenter TNG Framework to manage the client systems 
in your network, install the following UM Services components on the 
client systems:

■ Web Based Access

■ System Health Monitoring

■ SNMP Access and Trap Forwarding

LANDesk Management Suite

If you use LANDesk Management Suite to manage the client systems in 
your network, install the following UM Services components on the 
client systems:

■ Web Based Access

■ System Health Monitoring

■ LANDesk Management Suite Integration
UM Services  User’s Guide  17



Installation Requirements
Before you install UM Services, consider the following installation 
requirements:

■ Supported Systems by Component

■ Hardware Requirements

■ Workgroup/Enterprise Integration

Hardware Requirements

The UM Services Client in a Windows operating system requires the 
hardware, memory, and disk space:

■ An IBM Netfinity server, IBM Desktops, IBM IntelliStation 
computer, or IBM ThinkPad mobile computer.

Note: Client systems must support SMBIOS version 2.0 or 
higher.

■ An Intel Pentium 200 MHz or faster processor.

■ 75 MB of hard disk space on the client systems.

■ A minimum of 32 MB random access memory (RAM), or the 
recommended minimum for the operating system. 

Supported Operating Systems

The UM Services Client is supported on the following operating 
systems:

■ Windows® 2000—Server or Advanced Server

■ Windows 2000 Professional

■ Windows NT® Server 4.0 (with Service Pack 4 or later)

■ Windows NT Workstation 4 (with Service Pack 4 or later)

■ Windows 98®

■ Windows 95® (with OEM Service Release 2 (OSR2) or later)
18
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Supported Browsers

A World Wide Web browser is needed on the system from which you 
plan to manage remote UM Services clients, and is required only if you 
are planning to install the UM Services Web Based Access or Web 
Based Remote Control options.

The UM Services console is supported only on the following browsers.

■ Microsoft Internet Explorer 4.01 or later.

Notes:

• If you are using Internet Explorer 5.x, you must install the 
optional Java Virtual Machine (VM) support to access a 
client system running UM Services.

• If you are using Internet Explorer and you reinstall 
Internet Explorer after installing UM Services, you must 
reapply the Microsoft VM update. The UM Services client 
requires the Microsoft VM Build 3165 or later. The latest 
Microsoft VM can be downloaded from
http://www.microsoft.com/java

■ Microsoft Management Console (MMC) 1.1 or later.

If you install UM Services before you install MMC, a Microsoft 
Management Console icon will not appear in the IBM Universal 
Manageability Services programs section of your Start menu. 

■ Netscape Navigator or Netscape Communicator 4.51 or later.

Additional Installation Guidelines
Before you install UM Services, consider these additional restrictions, 
requirements, and installation options:

■ Windows 95 Installations
DCOM95 must be installed before you install UM Services on 
systems running Windows 95. DCOM95 is included with Internet 
Explorer 4.0 or later and NetScape Navigator 4.5 or later. 
However, if one of these browsers is not installed on the system on 
which you are installing UM Services, you must install DCOM95 
first. 
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To install DCOM95 and the Microsoft Virtual Machine (both of 
which are required by UM Services), run the program named 
MSJAVX86.EXEfound in the directory to which you downloaded 
and decompressed the UM Services installation files. When this 
program finishes running, restart your system, delete (or rename) 
MSJAVX86.EXE from the installation directory, and then install 
UM Services.

If you are distributing UM Services remotely to systems running 
Windows 95, be sure to distribute and run the MSJAVX86.EXE 
program first. When running MSJAVX86.EXE remotely, use the 
following command:
MSJAVX86 /Q /R:N

Then, restart the remote system.

■ Default Directory 
By default, the UM Services installation program installs the UM 
Services program files in C:\Program Files\IBM\UMS. If you do 
not want to install the program files in the default location, be 
prepared to provide an alternative installation drive and directory.

■ Microsoft Management Console (MMC) 1.1 or later

■ You can use UM Services after installing MMC on Windows 95, 
Windows 98, or Windows NT systems.

■ Running an Unattended Installation
UM Services supports unattended installation. If you want to use 
your software distribution facility to install UM Services, you can 
set up an unattended installation for UM Services. UM Services 
can then be installed across your network from one central 
location. The format of the UM Services response file, named 
SETUP.ISS, is described in “Modifying the SETUP.ISS File 
Manually” in the Netfinity Director User’s Guide on the Netfinity 
Director with UM Services CD.

Installing UM Services
This section will step you through the installation process for installing 
UM Services on supported operating systems.

To install UM Services, do the following. 
20
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1. Place the Netfinity Director with UM Services CD–ROM in the 

CD-ROM drive of the machine to which you will be installing.

2. Click Start→Run.

3. In the Open: field, type X:\win32\install\Ibmsetup.exe

where X is the location of the CD-ROM drive.

4. Click through the Welcome window and accept the License 
Agreement.

The Select Components window opens.

There are four different installation choices from the Select 
Components window:

Server Install the files for the Server, Console, and Client for 
Netfinity Director.

Console Install the remote user interface for Netfinity Director 
Servers.

Client Install the Client files on Microsoft operating systems 
only.
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Workgroup/Enterprise Integration
Install UM Services integration for management 
environments.  See “Chapter 4. Upward Integration 
Modules,” on page 89, for complete information.

5. Select Client.

The UM Services Client Configuration window opens.

6. Check the checkbox beside any of the components you want to 
install on the client system. 

Note: The first component listed, Basic Services, is selected by 
default and cannot be deselected. Basic Services installs a 
Java Virtual Machine, a Common Information Model 
(CIM) repository, and basic instrumentation for gathering 
hardware inventory data. The inventory information 
provided by Basic Services can be viewed through a CIM 
browser such as Microsoft WBEMTEST. Basic Services 
must be installed on all Netfinity Director managed UM 
Services clients.

The following optional components are available. The components 
that are selected by default are indicated as such:
22
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Netfinity Director Support (Default)

Netfinity Director support is an additional configuration 
option for the client installation only. IBM Netfinity 
Director is an advanced Intel processor-based workgroup 
hardware manager, with centralized client and group 
management console and server services. Selecting this 
feature enables the system to be managed in a Netfinity 
Director environment by installing UM Services on this 
system.

Web Based Access (Default)
Web Based Access offers a convenient Java-based tool for 
managing a client system and for viewing the CIM-based 
inventory data. If you install Web Based Access, a 
hypertext transport protocol (HTTP) daemon is installed 
and requires that a user name and password be entered 
during the installation. The user name and password are 
used to limit access to the HTTP daemon. With 
Web-based Access that is installed on the client system, 
the client can be managed from any remote computer with 
a supported Web browser. No software other than a Web 
browser is needed on the remote system.

System Health Monitoring (Default)
System Health Monitoring provides active monitoring of 
critical system functions, such as disk space available, 
SMART Drive alerts, system temperature, fan 
functionality, power supply voltage, and system cover 
removal (dependent upon the hardware options of a 
selected managed system) . System Health Monitoring 
enables you to detect system problems early, before 
system failures occur. System administrators are notified 
of a system problem by a CIM event, SNMP trap (SNMP 
traps are available only if SNMP access and trap 
forwarding is also selected), or SMS Status Message 
(Microsoft SMS 2.0 only). Critical problems also result in 
a pop-up message by appearing on the display of the client 
system.
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Web Based Remote Control
Web Based Remote Control enables a remote systems 
administrator using a Web browser or MMC console to 
take control of the client system desktop, enhancing the 
administrator’s ability to diagnose system problems and 
troubleshoot the system.

Note: You must install the Web Based Access 
component to install the Web Based Remote 
Control component.

LANDesk Management Suite Integration
LANDesk Management Suite Integration installs the Intel 
Common Base Agent on the client system. This enables 
the systems administrator to use UM Services with 
LANDesk Management Suite.

Tivoli Management Agent
Tivoli Management Agent installs support on the client 
system that enables it to be managed by the Tivoli 
Enterprise systems-management platform.

SNMP access and trap forwarding  
This feature enables CIM information to be accessed from 
a system that use the Simple Network Management 
Protocol (SNMP). If System Health Monitoring is 
enabled, this option also enables System Health to forward 
CIM events as SNMP traps. This component requires that 
you have the SNMP service (provided with the operating 
system) installed on the endpoint. If the SNMP service is 
not installed, the system prompts you to insert the 
operating system installation media and install SNMP 
during the UM Services installation.

DMI Support 
Selecting this component installs the Desktop 
Management Interface (DMI) 2.0 compliant Service 
Provider.  When enabled, this feature maps a managed 
system CIM data and events to DMI.  

7. Click Next to continue.

The Choose Destination Location window opens.
24
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8. Click Next to accept the default directory (C:\Program 

Files\IBM\UMS\), or click Browse to choose a different directory.

9. If you selected DMI Support from the UM Services Client 
Configuration menu, the DMI Platform window opens.  

Select the type of platform you are installing the DMI support to.  
Click Next to continue.

The User ID window opens.

10. Use this window to set the user ID and password for the client 
system and to specify the TCP/IP port that is used to access the 
client.

You must provide a unique user ID and password for the client 
system. To use the UM Services console to manage this system, 
you must first provide a valid user ID and password before being 
allowed access to the system. Type in the User ID field the user ID. 
Then type the password in the Password field, and type the 
password again in the Confirm Password field. 

Note: The user ID and password are case sensitive.

Then, select a TCP/IP port that is used to access the UM Services 
console. The default port is 411. If this port is not available, you 
can select port number 6411, 6500, 6600, or 6611. Make sure that 
other TCP/IP applications do not use the selected port.

11. Click Next to continue.
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12. If you selected SNMP access and trap forwarding from the UM 
Services Client Configuration menu and do not have the SNMP 
network service installed, UM Services installation will prompt 
you with an SNMP installation query.

■ Click No to continue with the UM Services installation 
without installing the SNMP network service.

■ Click Yes to install the SNMP network service on the server.  
The Installing SNMP window and your Network window 
opens.  Follow the directions for installing SNMP.  When the 
Windows operating system prompts for a restart, click No.  In 
the Installing SNMP window, click Next to return to the UM 
Services installation program.

13. The system asks you if you want to place an UM Services icon on 
the start menu. Select Yes or No.

14. The system asks you if you want to install files for remote control. 
Select Yes or No.

15. The system asks you if you require user authorization for remote 
control window access. Select Yes or No.

The system begins installing the necessary files. The Setup is 
Complete window opens.

16. Restart the computer now or later. If you choose Restart Now, the 
system shuts down and restarts immediately. If you choose 
Restart Later, the UM Services installation program closes. 
However, you must restart and log in to the system to begin using 
Um Services.

Starting the UM Services Console
If the Web Based Access or Web Based Remote Control optional 
component is installed on a client, you can use a Web browser or MMC 
to access and manage the client locally or remotely.

Note: IBM provides two Java class libraries (Swing/JFC and XML) 
with UM Services. These libraries must be installed on the Web 
browser before you access UM Services data. The first time you 
use a Web browser for UM Services, you will be asked to 
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download the installation programs for these files. Click each 
HTML link to begin installation of each library. You will have 
to restart your UM Services Web browser for these Java 
libraries to take effect.

Starting the UM Services Console on Your Local 
System

During installation, if you clickedYes to create icons on the Start menu, 
you can start UM Services locally from this menu.

Note: Systems using a Web browser or MMC to access UM Services 
locally require 64 MB of RAM to function properly.

From the local system, click Start → Programs → IBM Universal 
Manageability Services → UM Services Browser.

The system starts the default Web browser and opens it to the Web 
address 

http://localhost:tcpip_port

where tcpip_port is the TCPIP port you selected during installation. You 
must type your user ID and password in the UM Services User ID and 
Password window.

Starting UM Services Remotely
You can start UM Services remotely using a supported Web browser. In 
the Universal Resource Locator (URL) field of your browser, type

http://systemname:tcpip_port

where systemname is the TCP/IP address or the IP address of the client 
and tcpip_port is the port number assigned for use by the UM Services 
console during UM Services client installation. Port number 411 is the 
default, but if this port is being used by another application, UM 
Services could also have been configured to use port number 6411, 
6500, 6600, or 6611.
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Starting UM Services from Microsoft Management 
Console

If you install Microsoft Management Console (MMC) 1.1 and then 
install UM Services on the client, the system creates an icon on the Start 
menu from which you can start UM Services in the MMC.

■ Click Start → Programs → IBM Universal Manageability 
Services → Microsoft Management Console.

The Microsoft Management Console is available as part of the Windows 
NT Option Pack 4 or from

http://www.microsoft.com/MANAGEMENT/MMC

Starting UM Services from a UIM Management 
Console

 If UM Services is integrated into Tivoli Enterprise 3.6, Tivoli NetView 
5.1.1, SMS 1.2, SMS 2.0, or CA Unicenter TNG 2.2 (Windows 95, 98 
and NT only), you can start UM Services directly from the management 
console. The management console starts either the default Web browser 
or the Microsoft Management Console (whichever is appropriate for the 
workgroup or enterprise environment). For more information, see 
“Chapter 4. Upward Integration Modules,” on page 89.

Uninstalling UM Services
You can uninstall UM Services through the Add/Remove Programs 
feature in the Windows Control Panel.

To uninstall UM Services:

1. Click Start → Settings → Control Panel. The Control Panel 
opens.

2. Click the Add/Remove Programs icon. The Add/Remove 
Programs Properties window opens.

3. From the Install/Uninstall  list, select IBM Universal 
Manageability Services, and then click Add/Remove.

4. When prompted, click Yes to remove UM Services.
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The uninstallation process might take a while to complete.
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3.Using UM Services

When you have connected to a client system, the UM Services console 
opens in your Web browser or MMC, and is divided into two panes. 

The Services pane is on the left side of the UM Services console and 
contains two tabs, each containing a list of UM Services that are 
available on the client system. The tabs available from the Services pane 
are:
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■ Information — This tab contains a tree view of the UM Services 
used to gather hardware and software information from the client 
system.

■ Tasks — This tab contains a tree view of the UM Services used to 
perform system-management and system-configuration tasks on 
the client system.

The Display pane is on the right side of the UM Services console and is 
a dynamic view that displays the interfaces and data associated with the 
service selected from the Information  or Tasks  tabs. 

The following field and command icons also appear in the Display pane 
of the UM Services console:

Next 
System 
field

You can use the same browser window or MMC to 
access multiple UM Services clients. In this field, type 
the TCP/IP address of another client running UM 
Services, and then press Enter to access another client 
without opening another Web browser. This field is not 
available on MMCs.

Export 
icon

With UM Services, you can create comma-separated-
value (CSV) data files from the hardware and software 
data collected by many of the UM Services interfaces. 
These CSV files can be imported into many database 
programs, so that you can create a centralized 
repository for data collected by UM Services. To create 
a CSV file, select a service from the Services pane. 
When UM Services has completed loading data, click 
the Export  icon. If a CSV file can be created from the 
data that was collected, a new browser window opens, 
containing the CSV file data. You can then save this 
data by selecting Save from the File menu.

Help 
icon

Online help is available for all UM Services. To access 
online help for a service, select the service from the 
Services pane and, when it has completed loading, 
click the Help icon.
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Information Tab
The services available from the Information tab gather hardware and 
software information from the client system. This data is gathered 
directly from the client and represents the physical components of the 
system or the current, monitored state of the client as reported by 
monitoring hardware and software in the client. The data presented in 
the Information service interfaces is static and cannot be changed or 
configured by the UM Services user.

The Information services are divided into two categories:

■ Inventory 

■ Monitors

The sections that follow describe each of the services available from the 
Information tab.

Inventory Services
Inventory services gather information about the physical devices that 
make up the client system (such as disk drives, multimedia adapters, 
video adapters, and memory) or the operating system of the client 
system. The available Inventory services are:

■ Basic system

■ Drives
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■ Memory

■ Multimedia

■ Operating system

■ Ports

Descriptions of each of the Inventory services that you can select from 
the Information tab follow.

Basic System

The Basic System service gathers and displays general information 
about the client system hardware and operating system.

Note: Not all client systems have all of the items that can be displayed 
in the Basic System interface. If a client does not have a 
particular item, the field associated with that item will not 
appear in the Basic System interface.

To start the Basic System service, click Information→ Inventory → 
Basic system in the Services pane. The following interface opens in the 
Display pane.
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The Basic System interface provides information about the items 
described in the following table.

Item Description

System unit The manufacturer and model of the client 
system.

Serial number The serial number of the client system.

System UUID The universally unique identification (UUID) 
number assigned to the client system. UUIDs are 
assigned to systems for system management 
purposes, and are stored in EEPROM on the 
system board. This item is available only on 
client systems that use SMBIOS 2.3 or later.

Operating system The name, version number, and service pack 
level (if applicable) of the operating system that 
is running on the client system.

BIOS The version and completion date of the basic 
input/output system (BIOS) of the client system.

Processor The type (for example, Pentium, Pentium II, or 
Pentium III) and clock speed of the 
microprocessor that is installed on the system 
board of the client system.

Memory The amount of random access memory (RAM) 
installed in the client system, in kilobytes (KB).

Cache The amount of microprocessor memory cache 
that is available to the microprocessor of the 
client system.

Expansion slots The number and type (for example, PCMCIA or 
PCI) of expansion slots in the client system. 

Storage The type and size, in megabytes (MB), of storage 
devices installed in the client system, such as 
hard disk drives, CD-ROM drives, or CD-RW 
(read/write) drives.
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Drives

The Drives service gathers and displays information about the physical 
and logical disk drives installed in the client system. To start the Drives 
service, click Information → Inventory → Drives in the Services 
pane. The following interface opens in the Display pane.

Video The type of video adapter installed in the client 
system.

Monitor Manufacturer The company that manufactured the monitor in 
use on the client system. This item appears only 
for clients running Windows 95 or Windows 98.

Monitor Type The type of monitor in use on the client system 
(for example, laptop display pane). This item 
appears only for clients running Windows 95 or 
Windows 98.

Audio The type of audio adapter installed in the client 
system.

Communications The network interface adapter or modem that is 
installed in the client system, the media access 
control (MAC) address of the adapter, and the IP 
address of the client system.

Keyboard The type of keyboard attached to the computer.

Pointing device The type of pointing device, for example, mouse, 
trackball, or TrackPoint® attached to the client 
system.

Item Description
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The Drives interface contains two interfaces:

Logical Drives
Click the Logical Drives tab to display information about the 
logical drives configured on the client system.

Physical Drives
Click the Physical Drives tab to display information about the 
physical drives installed in the client system.

The Logical Drives interface is displayed by default. For additional 
information about each entry on the Logical Drives interface, click any 
disk row. The interface is updated to display a pie graph that shows used 
space and free space on the selected logical drive. Used space contains 
the applications and files that are on the disk, and free space is available 
for adding files or applications.

The Logical Drives interface provides information about the items 
described in the following table.
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Click the Physical Drives tab to display the Physical Drives interface. 

The Physical Drives interface shows the type; capacity; unassigned 
space; and self-monitoring, analysis, and reporting technology 
(SMART) of each physical drive installed in the client system. To see if 
a physical hard disk has partitions, click any disk row. If the selected 

Item Description

Name The drive letter assigned to the 
logical drive, partition, or network 
drive.

Type The type of logical drive, such as 
removable drive or network drive.

Capacity The total amount of data that can be 
held by each logical drive, measured 
in megabytes (MB) or gigabytes 
(GB).

Free Space The amount of disk space available 
on the logical drive.
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disk has partitions, information about the partitions is displayed in the 
Partition Information section of the Physical Drives interface. 

The partition information is displayed as a pie graph, showing the 
portion of the total physical disk that is used by each partition.

The Physical Drives interface provides information about the items 
described in the following table.

Item Description

Physical Drives

Type The type of physical drive such as 
hard disk, diskette, or CD-ROM.

Total capacity The total amount of data that can be 
stored by each physical drive, 
measured in KB, MB, or GB.

Unassigned space The amount of space on a hard disk 
drive that is not used by logical 
partitions.

SMART Health alerts, generated by a status 
monitor, for a physical drive if 
potential failure exists.

Partition Information

Partition The drive letter mapped to the 
partition. 

Capacity The total amount of data that can be 
stored by each partition, measured in 
MB or GB.

File System The file system in use by the 
partition, such as file allocation table 
(FAT) or NT file system (NTFS).

Volume Label The name of the partition, if any. 

Free space The amount of space that is available 
on the partition for applications or 
files. 
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Memory

The Memory service gathers information about the physical memory 
that is installed in the client system and provides information about 
memory upgrade options that are available for the client system. To start 
the Memory service, click Information → Inventory → Memory in 
the Services pane. The following interface opens in the Display pane.

The Memory interface contains two interfaces:

Physical Memory
Click the Physical Memory tab to display information about 
the physical memory that is installed in the client system.

Upgrade Options
Click the Upgrade Options tab to display information about 
memory upgrade options for the client system.

The Physical Memory interface is displayed by default and provides 
information about the items described in the following table.
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Click the Upgrade Options tab to display the Upgrade Options 
interface.

The Upgrade Options interface shows the current physical RAM 
installed in the computer, and the maximum capacity of the client 
system, which refers to the total RAM that can be installed in the 

Item Description

Total physical 
memory

The amount of total physical random access memory 
(RAM) installed on the system board.

Socket designation The number of the socket and the type of memory 
memory module the socket can hold. For example, 
DIMM-2 refers to a dual inline memory module 
(DIMM) in socket 2, and SIMM-3 refers to a single 
inline memory module (SIMM) in socket 3.

Size The size (in MB) of the memory module currently 
installed in each socket.

Characteristics Details regarding the type of memory module 
installed in the socket, such as SIMM or DIMM.
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computer. If you want to install additional memory in the client system, 
select the amount of memory you want to install to display additional 
information on proper memory configuration.

Multimedia

The Multimedia service gathers information about the multimedia 
adapter installed in the client system. To start the Multimedia service, 
click Information → Inventory → Multimedia in the services pane. 
The following interface opens in the Display pane.

The Multimedia service has one interface that provides information 
about the system audio and video, described in the following table.

If an audio or video adapter is not installed in the client system or if 
information from the adapter is unavailable, the field associated with the 
missing data will not be shown in the interface.
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Operating System

The Operating System service gathers information about the operating 
system that is installed and running on the client system. To start the 
Operating System service, click Information → Inventory → 
Operating System in the Services pane. The following interface opens 
in the Display pane.

Item Description

Adapter name The name of the audio adapter installed in the client.

Adapter 
description

The name of the video adapter installed in the client.

Chip type The type of video chip used by the video adapter.

RAM The amount of random access memory (RAM) 
available for use by the video subsystem.

Color bits/pixel The number of color bits per picture element (pixel) 
that can be displayed by the video adapter.

Resolution The picture element (pixel) resolution currently 
displayed by the video adapter (for example, 640 by 
480 or 800 by 600).

Refresh rate The frequency, in megahertz (Mhz), with which the 
monitor screen is cleared and redrawn. This item 
appears only for clients running Windows NT.
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The Operating System interface contains the following interfaces (the 
Services interface is displayed only for clients running Windows NT):

Operating System
Click the Operating System tab to display general information 
about the operating system including name, version, and service 
pack level. 

Process Click the Process tab to display information about the 
processes or tasks that are currently running on the client 
system.

Environment Click the Environment tab to display information about 
the environment variables used by the client operating system.

Drivers Click the Drivers tab to display information about the device 
drivers that are being used by the client system.

Services Click the Services tab to display information about the current 
state and start mode of services that are installed on the client 
system. This interface is available only for client systems 
running Windows NT.

The Operating System interface is displayed by default and provides 
information about the items described in the following table.
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Click the Process tab to display the Process interface.

Item Description

Name The name of the operating system.

Version The version number of the operating system.

Service pack The operating system service pack level installed on 
the system, if any.

License key The license key number or code entered when the 
operating system was installed. Depending on the 
screen resolution, you might need to move the 
horizontal scroll bar to the right to view this item 
completely.

Build type The operating system build type. Build type can refer 
to the processor configuration the operating system 
is designed to run on (uniprocessor or 
multiprocessor), or to whether the build is a retail (or 
“Free”) version or debug (or “Checked”) version. 
Depending on the screen resolution, you might need 
to move the horizontal scroll bar to the right to view 
this item completely. 
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The Process interface provides information about the items described in 
the following table.

Click the Drivers tab to display the Drivers interface.

Item Description

Name The name of the executable process.

Path The complete path to the executable file.

Kernel mode time The amount of time the computer processor spends 
in kernel mode because of this process. Depending 
on the screen resolution, you might need to move the 
horizontal scroll bar to the right to view this item 
completely. This item appears only for clients 
running Windows NT.

Process ID The identifying number assigned to the process by 
the system according to startup sequence. Depending 
on the screen resolution, you might need to move the 
horizontal scroll bar to the right to view this item 
completely.
46



3.
  U

sing U
M

 S
ervices
The Drivers interface provides information about the items described in 
the following table.

Item Description

Name The name of each device driver in the operating 
system directory.

Start mode The start mode assigned to each device driver. 
Depending on which mode is selected, a device 
driver is incorporated or not incorporated into the 
operating environment. Disabled means that the 
device driver is not added to the operating 
environment. Auto means that the device driver is 
automatically started when the operating system is 
started. Boot means that the device driver is 
initialized during the operating system startup (boot) 
sequence.

State The current run state of each device driver (Running 
or Stopped). This item applies only to clients running 
Windows NT. State values are not displayed on 
clients running Windows 95 or Windows 98 .
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Click the Services tab to display the Services interface.

The Services interface provides information about the items described in 
the following table.

Command line The complete path to the device driver, such as 
C:\System Root \System32\adapti.sys. To view the 
complete Command line, move the horizontal scroll 
bar to the right.

Item Description

Name The name of the service (for example, EventLog or 
Remote Control Service).

Start mode The start mode of the service. For each service, the 
start mode can be Auto for automatic, Manual for 
manual start, or Disabled when the service is turned 
off or is unavailable.

Item Description
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Ports

The Ports service gathers information about the input and output ports 
and connectors on the client system. To start the Ports service, click 
Information → Inventory → Ports in the Services pane. The following 
interface opens in the Display pane.

The Ports service provides information about the items described in the 
following table.

State The current run state of each service (Running or 
Stopped). 

Command line The complete path to the device driver, such as 
C:\System Root \System32\adapti.sys. To view the 
complete Command line, move the horizontal scroll 
bar to the right.

Item Description
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Monitor Services
Monitor services use system monitoring hardware and software 
included with the UM Services client to gather data about the current 
operational state of the client system, such as temperature, battery time 
remaining, and contents of the Windows NT Event Log on the client 
system. The three Monitor services are:

■ Event Viewer

■ Notebook (available only if you are using UM Services on an IBM 
ThinkPad model 560, 570, 600, or 770)

■ System Health

Event Viewer

The Event Viewer shows the contents of the Windows NT Event Log. 
To start the Event Viewer service, click Information → Monitors → 
Event Viewer in the Services pane. The following interface opens in the 
Display pane.

Item Description

Port name The name of the input or output port (for example, 
LPT1, Keyboard, or Ethernet).

Connector type The type of connector for each port (for example, 
DB-9 or DB-25 Female).

Port type Type of port (for example, serial, parallel, or 
Universal Serial Bus).
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The Event Viewer interface provides information about the items 
described in the following table.

Item Description

Type The log category (information, 
warning, error, success audit, or 
failure audit).

Date The date when the event took place, 
in mm/dd/yy format.

Time The time when the event occurred, 
in hh:mm:ss format for a.m. or p.m.
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The NT Event Log can contain a large number of entries. With the Event 
Viewer service, you can filter the contents of the NT Event Log before 
viewing the entries. Before Event Viewer loads the contents of the Event 
Log, you must select a log category. These broad categories help limit 
the number of Event Log entries that will be loaded into the Event 
Viewer. From the Log menu, select an Event Log category that 
corresponds to the Event Log entries you want to view, or click the Load 
All Events button to display all log entries. 

Note: The NT Event Log can contain thousands of individual entries. 
Choosing Load All Events can result in significant delays while 
the contents are loaded into the Event Viewer.

The available selections are:

Application Displays the 30 most recent log entries that result from 
application or software issues, faults, and problems.

Event The identification number that is 
automatically given to an event, 
with related events getting the same 
number. For example, Service 
Control Manager has 7001 and 7002 
event numbers, regardless of the 
time of the event.

Source The program, application, system, or 
security that led to the event(for 
example, WinMgmt, DCOM, 
SNMP, AOLAgent, or some other 
program).

Category A number that identifies the 
category that the event falls into. 
This is used to organize the events. 
To view this field, slide the scroll bar 
to the right.

User The ID of the user. To view this 
field, move the horizontal scroll bar 
to the right.

Item Description
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System Displays the 30 most recent log entries that result from system 
or hardware issues, faults, and problems.

Security Displays the 30 most recent log entries that result from security 
problems, such as invalid user ID or password entries and other 
attempted security violations. 

Use the check boxes at the bottom of the Event Viewer window to filter 
the contents of the Event Viewer by event type. The event type provides 
a general description of the severity of the event. Available event-type 
check boxes are: 

Information Displays rows of informational entries that are related to 
the Application, System, or Security Event Log category you 
selected.

Warning Displays rows of warning entries that indicate a severe 
problem to resolve for an Application, System, or Security 
problem.

Error Displays logs that result from security issues, such as password 
or user ID failures or other access problems, or attempted 
security violations. 

Success Audit
Displays event information on successful events.

Failure Audit
Displays event information on unsuccessful events.

Only entries that correspond to a selected check box will be displayed in 
the Event Viewer. For example, if you want to view only entries that are 
the results of a system error, select the Error check box and leave the 
other selections unselected. If you select an event-type check box and no 
information is displayed, it means that there are no Event Log entries 
that correspond to the selected event type. 

You can use Event Viewer to display additional information about any 
entry that appears in the window. To display additional information 
about any entry, click the entry to highlight it, and then double-click the 
entry. A window opens, containing additional information about the 
event.
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Notebook

The Notebook service is available only if UM Services is running on an 
IBM ThinkPad model 560, 570, 600, or 770 system. If the client system 
is not one of these supported models, this service is not displayed in the 
Monitors section of the Information tab.

The Notebook service gathers and displays information about ThinkPad 
computers. To start the Notebook service, click Information → 
Monitors → Notebook in the Services pane. The following interface 
opens in the Display pane.
54



3.
  U

sing U
M

 S
ervices
The Notebook service interface contains two categories. The Battery 
interface is displayed by default.

Battery Click the Battery tab to display information about the 
ThinkPad battery power supply.

Enclosure status
Click the Enclosure status tab to display information about the 
power supply currently being used by the computer and for 
information about whether the computer is currently docked in 
a docking station.

The Battery interface provides information about the items described in 
the following table.

Item Description

Battery The battery that is being used by the 
ThinkPad computer (Main or 
Backup).
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Click the Enclosure status tab to display the Enclosure Status interface. 
The Enclosure Status interface provides information about the items 
described in the following table.

Status The charge status of the battery 
(Fully Charged, Partial, High, Low, 
Critical, Charging, Charging High, 
Charging Low, Charging Critical, 
Unknown).

Estimated Run Time (minutes) The number of minutes of run time 
left on the battery.

If the ThinkPad computer is plugged 
into an electrical outlet using an 
adapter, the Estimated Run Time 
will show N/A.

Remaining Charge (%) The approximate percentage of 
battery charge remaining, running 
from 100% downward. 

If the ThinkPad computer is plugged 
into an electrical outlet using an 
adapter, the Remaining Charge will 
continue to show the percentage of 
battery life that remained at the time 
the system was plugged in.

Full Charge Time (minutes) The amount of time needed to charge 
the battery to full capacity. If the 
battery is fully charged, the Full 
Charge Time will show N/A.

Battery Type The type of battery. The ThinkPad 
computer uses a Lithium-Ion battery.

Item Description
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System Health

UM Services automatically monitors the client systems for changes in a 
variety of system-environment factors, including temperature and 
voltage. Each monitored value has a System Health normal range. If the 
monitored value stays within normal range, the assumption is that the 
System Health is normal. However, if any of these monitored values 
falls outside of acceptable System Health parameters, UM Services can 
automatically generate five forms of output to alert the system 
administrator of this state change. The alert output generated by UM 
Services can include:

■ System Health graphical user interface (GUI ) window in UM 
Services

■ Alert messages

■ Alert messages sent as simple network management protocol 
(SNMP) traps

■ Alert messages sent as System Management Server (SMS) status 
messages

■ Common Information Model (CIM) events

You can use the System Health service to check the status of all health 
monitors supported by the client system. To start the System Health 
service, click Information → Monitors → System Health in the 
Services pane. The following interface opens in the Display pane.

Item Description

Power Source The current power source being used 
by the ThinkPad computer (battery 
or On-Line).

Docking Station The current docking status of the 
ThinkPad computer (Docked or Not 
Docked).
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The System Health interface provides information about the items 
described in the following table.

Health reports are gathered from a variety of system devices. The health 
reports available on a client system are dependent on the availability of 
components that contribute to health reports. The following are some 
examples of potential System Health event messages and the 
circumstances that cause them:

Item Description

Health The current state of the monitored 
device (Normal, Warning, or 
Critical).

Description A description of the monitored 
device.

Time The date and time stamp applied to 
for the health event. The format is 
MM/DD/YYYY hh:mm:ss.
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Chassis Intrusion
 If the system chassis has been opened, a warning System Health 
event is generated, regardless of the reason.

Fan Failure If the system cooling fan fails, a Critical System Health 
event is generated. This might be the only prediction of a 
temperature-related event.

LAN Leash LAN Leash detects if a client system is disconnected from 
the LAN, even when the computer is off. If a client system is 
disconnected from the LAN, a Critical System Health event is 
generated.

Low Disk Space
 If free disk space is low, a Warning System Health event is 
generated.

Processor removed
If the microprocessor is removed from the client system, a 
Warning System Health event is generated.

Temperature out of specification
If the microprocessor temperature is out of the specified range, 
a Warning System Health event is generated.

Voltage out of specification
If there is a dramatic change in the voltage of the power supplied 
to any part of the client system, a Warning or Critical System 
Health event is generated.

Predicted Failure Alert (PFA)
SMART-drive enabled systems generate events if operational 
thresholds on the hard drive are exceeded.

Tasks Tab
The services available from theTasks tab help the system administrator 
manage the client systems. Users with less than system-administrator 
authority can view the available screens, but only system administrators 
can change or update system configurations and use the available tools. 
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UM Services displays only the tasks associated with what is installed on 
a client system. For example, if the Remote Control feature is not 
installed on a client system, the task Remote Control (under Tools) is not 
displayed for that system. Requirements and optional installations are 
noted under each task heading. Certain security levels are required for 
users to view or edit selected features in the UM Services program. See 
“User Security” on page 78 for additional information.

The Tasks services are divided into three main categories:

■ Configuration

■ Tools (beginning on page 84)

■ Web Links (beginning on page 87)

The sections that follow describe each of the services available from the 
Tasks tab.

Configuration
There are six setup options associated with the Configuration task.

■ Alert on LAN

■ Asset ID

■ Date and Time 

■ Network
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■ SNMP

■ User Security

Alert on LAN

Note: Alert on LAN is displayed in the task list only for IBM PC 
300PL and IntelliStation computers on which Alert on LAN 
hardware is installed. 

A user with administrative security status can use the Alert on LAN task 
to set the options related to network system alerts.

To start the Alert on LAN service, click Tasks → Configuration → 
Alert on LAN . The following interface opens in the Display pane.

The Alert on LAN interface provides information about the items 
described in the following table.Each section in the Table denotes a 
tabbed window within the Alert on LAN Configuration Task.
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Item Description

General Tab

System UUID A Universally Unique ID (UUID) is 
assigned to each system board for 
system-management purposes. 

The UUID is stored in the BIOS on 
the system board.

 Enable Alert on LAN hardware This option determines whether the 
system alerts are on or off. Select 
the check box to enable system 
alerts.

Configuration Tab

Proxy server (IP address Port) The internet protocol address for the 
server you use to communicate with 
the client systems. The IP address is 
assigned by the system 
administrator. (Default Port is 
5500.)

Heartbeat timer period The Alert on LAN proxy computer 
verifies that the client system is 
running. This is the number of 
seconds between system checks. 
The default value is 32.

The enabled heartbeat timer period 
values range from 43 to 5461 
seconds and can be set in intervals 
of 43 seconds.
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Watchdog Timer Period If the watchdog timer indicates that 
a client system has stopped, the 
watchdog timer automatically sends 
a message to the proxy computer. 
This is the period between polls for 
the watchdog timer (measured in 
seconds). The default value is 43.

The watchdog timer period values 
range from 86 to 5461 seconds and 
can be set in intervals of 86 seconds.

Transmission attempts The number of retries for 
transmission after the client stops. 
The default value is 30.

Event Polling Period The polling period for software 
problems. The default value is 30.

Events Tab

Cover Tamper If the cover of the managed system 
has been opened or removed, an 
event message is generated.

LAN Leash Tamper LAN Leash detects if a client 
system is disconnected from the 
LAN, even when the computer is 
off. If a client system is 
disconnected from the LAN, an 
event message is generated.

Temperature Out of Specification If the microprocessor 
temperature is out of the 
specified range, an event 
message is generated.

Watchdog If the operating system of the 
managed system is not functioning, 
or is in a “hung” state, an event 
message is generated.

Item Description
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If you make changes to any of the Alert on LAN default user options, 
click Apply to save the changes and return to the UM Services main 
window.

Asset ID

The Asset ID service contains the hardware information for the client 
system. To start the Asset ID service, click Asset ID in the 

Voltage Out Specification If there is a dramatic change in 
the voltage of the power supplied 
to any part of the client system, 
an event message is generated.

Auto-clear events If this option is enabled, the client 
system sends an alert each time the 
condition is present (multiple 
alerts). If this option is disabled, the 
system sends an alert for a condition 
only once (no reminder alerts).

Events Enabled Selecting this option enables all 
events to be monitored. To select an 
individual event, check the 
particular event in the Enable row.

Clear All Events Select this option and click Apply, 
to clear the events log.

Control Functions Tab

Power Down Receives this message as a system 
state report.

Power Up Receives this message as a system 
state report.

Reboot Receives this message as a system 
state report.

Presence Ping Returns the message that the system 
is not on but is still connected to the 
network.

Item Description
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Configuration pane. The Asset ID interface contains the following 
interfaces:

Serialization
Click the Serialization tab to display serial numbers for the 
client system hardware.

System  Click the System tab to display the current client system 
characteristics: system name, MAC address, user login name, 
operating system, UUID address, IBM LAN Client Control 
Manager (LCCM) Profile.

User Click the User tab to display the user profile: user name, phone 
number, work location, department, and professional position.

Lease Click the Lease tab to display the information on the lease 
agreement for the client system hardware.

Asset Click the Asset tab to display the inventory factors related to the 
client system.

Personalization
Click the Personalization tab to display the free-form screen 
where you can add information on your systems, users, or 
computers.
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Warranty Click the Warranty tab to display the information on the 
warranty agreement for the client system hardware.

When you click Asset ID from the UM Services task list, the system 
displays the Serialization screen. To access any of the other Asset ID 
screens, click the appropriate tab.

Serialization

Click the Serialization tab to display the Serialization interface. The 
Serialization interface displays the serial numbers for the various 
components in the client system. 

The Serialization interface provides information about the items 
described in the following table.

System

Click the System tab to display the System interface. The System 
interface displays information about the client system.

Item Description

Name The hardware component name.

Serial Number The serial number for the hardware 
component.

Information Descriptive information for the 
hardware component.
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The System interface provides information about the items described in 
the following table.

Item Description

System Name The NetBEUI name of the client 
system (the computer name as it 
appears under Network Properties).

NetBEUI is NetBIOS extended user 
interface, and NetBIOS is network 
basic input/output system. 

MAC Address The unique hexadecimal character 
string that identifies the network 
adapter in the client system.

Login Name The user ID that the system 
administrator assigned at 
installation.
UM Services  User’s Guide  67



User

Click the User tab to display the User interface. The User interface 
displays information about the logged-in user. 

The User interface provides information about the items described in the 
following table.

Operating System The operating system (for the 
management server or for the 
computer where UM Services 
resides).

System UUID The client system Universally 
Unique Identifier (UUID). This is 
your BIOS unique ID number.

LCCM Profile The profile name of the IBM LAN 
Client Control Manager (LCCM), if 
applicable.

Item Description
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Lease

Click the Lease tab to display the Lease interface. The Lease interface 
displays lease information for the client system. 

The Lease interface provides information about the items described in 
the following table.

Item Description

Name The user login name.

Phone The user phone number.

Location The user office location.

Department The user department name or 
number.

Position The user job title.
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Asset

Click the Asset tab to display the Asset interface. The Asset interface 
displays inventory information about the client system. 

The Asset interface provides information about the items described in 
the following table.

Item Description

Lease Start Date (mm/dd/yy) The date that the lease agreement 
began.

Lease End Date (mm/dd/yy) The date that the lease agreement 
ends.

Lease Term (months) The number of months for which the 
client system is leased.

Lease Amount The total price of the lease 
agreement.

Lessor The name of the company that leased 
the client system.
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Personalization

Click the Personalization tab to display the Personalization interface.

The Personalization interface is a free-form window where you can 
enter information about your users, system, or computer. There is a 32-
character maximum for each of these fields.

Item Description

Purchase Date (mm/dd/yy) The date the client system was 
purchased.

Last Inventoried (mm/dd/yy) The date of the last inventory check.

Asset Number A unique number that is assigned to 
the client system for inventory 
purposes.

RF-ID The radio-frequency identification 
(RF-ID) number encoded in the 
client system by the manufacturer. 
Not all computers have RF-ID 
capabilities. This is a fixed field and 
cannot be changed. 
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Warranty

Click the Warranty tab to display the Warranty interface. The Warranty 
interface displays information about the warranty on the client system. 

The Warranty interface provides information about the items described 
in the following table.

Date and Time

Use the Date and Time service to set the date and time that are displayed 
on the client system. For the date, you have separate fields for month, 
day, and year. For the time, you have a field for the local time.

Item Description

Duration (months) The duration of the warranty 
agreement.

Cost The total cost of the warranty.

End Date (mm/dd/yy) The date that the warranty ends.
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To start the Date and Time service, click Tasks → Configuration → 
Date and Time in the Services pane. The following interface opens in 
the Display pane.

Network

The Network service provides information about your network. The 
following tabs are available under Network:

IP Address Provides routing information for your network.

DNS Provides information on the distributed database system used to 
map domain names to IP addresses.

Modem Provides information on and characteristics of the modem 
attached to the client system.

When you click Network from the UM Services Tasks tab, the system 
automatically displays the screen associated with the IP Address tab. 
Select the DNS or Modem tab to view those screens.

IP Address Tab

The IP Address interface provides routing information for your network.

Click Tasks → Configuration → Network → IP Address to display 
the IP Address interface.
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The following items are displayed on the IP Address screen.

Item Description

Network Adapter Choose the appropriate network 
adapter from the drop-down list.

IP Address The IP address of the client system. 

Subnet Mask A bit mask used to identify which 
bits in an IP address correspond to 
the network address and which bits 
correspond to the subnet portions of 
the address.

The address mask has ones in 
positions corresponding to the 
network and subnet numbers and 
zeros in the host-number positions. 

Default Gateway The IP address for the default 
gateway server you are using to 
communicate with other networks.
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DNS Tab

Domain Name System (DNS) is the distributed database system used to 
map domain names to IP addresses.

From the UM Services task list, click Tasks → Configuration → 
Network → DNS tab to display the screen.

The following items are displayed on the DNS screen.

MAC Address The unique hexadecimal number 
that identifies the network adapter in 
the client system.

Item Description

Item Description

Host Name The alphabetic identifier for your 
Netfinity server.

Domain The domain name of the server or a 
network domain (IP address).
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Modem Tab

Note: The Modem tab appears only if a modem is connected to the 
client system or installed in the client system.

The Modem tab, which is located within the Network task if a modem is 
present, displays the characteristics of the modem.

Click the Tasks → Configuration → Network → Modem to display 
the Modem screen.

The following items are available from the modem screen.

DNS Service A list of IP addresses for the DNS 
server that is related to your 
Netfinity server.

Item Description

Item Description

Description A description of the type of modem 
attached to the client system. 
Select the appropriate item from the 
drop-down list.
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SNMP

Note: The SNMP task appears on the task list only if the SNMP 
service is installed on the operating system.

The SNMP task provides the ability to work with community strings that 
are used in network communication and to set trap destination addresses.

Click Tasks → Configuration → Network → SNMP to display the 
SNMP screen.

The following items are displayed on the SNMP screen.

COM Port The port to which the modem is 
connected (for example, COM 1).

Max Baud Rate The maximum baud rate for the 
modem (for example, 28800).

Device type Displays whether the modem is 
internal or external.

Item Description
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User Security

The User Security option displays user names, provides the ability to 
add and remove user names, and sets the security level and password 
options for each user name.

Security Levels

The security level assigned to a user affects that user’s ability to access 
the UM Services program, the ability to view, manipulate, and access 
selected features in the program. The following describes the security 
levels associated with UM Services. 

Item Description

Community name A unique character string that 
identifies the community. The 
community name enables your 
network-management system 
(NMS) to verify that a server is 
authorized to take a specific action. 
If the server community name 
matches the community name 
assigned to the requested 
information or action, the NMS 
provides the information or action to 
the server. You can add or remove a 
unique community name.

Trap Destination A list of network management 
system IP addresses to which the 
server can send alerts. You can add, 
remove or edit a trap destination. To 
modify a trap destination, select an 
IP address and click Edit.
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Disabled A disabled user is not permitted to log in (usually a temporary 
state). The disabled state is not technically a security level, but 
is included here because users with Administrator privileges can 
use it to override other security levels and temporarily prevent 
access to the UM Services program.

Browse, User, and Power User
Users with Browse, User, or Power User privileges can access 
much of the UM Services program. They cannot change settings 
or save entered information. In this release of the UM Services 
program, there are no practical differences between the Browse, 
User, and Power User privileges.

Administrator
Users with Administrator privileges have full control over the 
UM Services program. In addition to having full read and write 
access to the UM Services program, they can add new users, 
assign and change passwords, and assign security levels.

Click Tasks → Configuration → Network → User Security to display 
the following screen.
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The following items are displayed on the User Security interface.

Item Description

User Name A unique name to identify the user. 
The user name is assigned when the 
new user is added (see “Adding a 
New User” on page 81).

Description Information about the user, such as 
title, department, or reason for 
granting access to the UM Services 
program. This information is entered 
when the new user is added. This is 
a free-form field, with a 32-
character maximum.
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Adding a New User

Use the Add New User interface to add UM Services new users with the 
appropriate security levels and password options.

To display the Add New User interface, from the User Security screen, 
click Add New User.

The Add New User interface contains the following fields.

Item Description

User Name A unique character string that 
identifies the end user (32 characters 
maximum).

Security Level The level of system access authority 
the user is granted. From the drop-
down list, select the security level 
that is appropriate for the user you 
are adding.

Description Type Information about the user, such as 
title, department, or reason for 
granting access to the UM Services 
program (32 character maximum). 
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The following table lists the user security levels.

Password Type The user password (32 character 
maximum, case sensitive). There are 
no restrictions on the characters that 
can be used in passwords. 

Confirm Password Type This field must contain the same 
character string as the Password 
field (32 character maximum, case 
sensitive). 

User Must Change Password at Next 
Logon

Select this check box if you want to 
force the user to change the 
password the next time the user 
accesses the UM Services program. 

User Cannot Change Password Select this check box if you want to 
prevent the user from changing the 
password. If this check box is 
selected, only someone with 
Administrator privileges can change 
the password.

Password Never Expires Select this check box if you do not 
require the password to be changed 
at regularly scheduled intervals. 

Account Disabled Select this check box if you want to 
temporarily disable this user’s 
access to the UM Services program. 
As a system administrator, you 
cannot disable your own account. 
This ensures that at least one 
account with Administrator 
privileges remains active.

Security Level Description

Disabled No access (temporary)

Browse Limited read/write

Item Description
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Notes:

• Disabled users can not access the UM Services program. 
Administrators can use the disabled state to override other 
security levels and temporarily prevent access to the UM 
services programs.

• Users with Browse, User, or Power User have similar privileges 
in this release of the product. Though these users can access 
much of the UM Services program, they cannot change settings 
or save entered information.

• Users with Administrator privileges have the highest degree of 
control over the UM Services program. In addition to having 
full read and write access to the UM Services program, they can 
add new users, assign and change passwords, lock and unlock 
selected features, and assign security levels.

Removing a User

 You can use the User Security interface to remove a user from UM 
Services. To remove a user, do the following:

1. From the User Security screen, highlight the user you want to 
remove.

2. Click Remove User. The following message is displayed: 

Are you sure you want to remove user?

3. Click Yes. The user is removed.

User Limited read/write

Power User Limited read/write

Administrator Read/write, lock/unlock, assign 
security levels, add new users and 
passwords

Security Level Description
UM Services  User’s Guide  83



Viewing User Properties

You can use the User Security interface to review or edit user properties 
such as description, security level, and password options. To view or 
edit user properties, do the following: 

1. From the User Security interface, highlight the user that you want 
to view or edit. 

2. Click Properties. The User Properties interface is displayed. 

You can view or edit the properties listed in this interface.

Tools
There are two UM Services tools listed on the UM Services task list:

■ Remote Control —Provides a way to control one computer to 
from another computer.

■ Shutdown — Provides three shutdown options.

Remote Control

Notes:

• The Remote Control service appears on the task list only if the 
Remote Control option is installed on the client system. If you 
did not select Remote Control during the UM Services 
installation, the Remote Control option is not displayed.

• Remote Control is not supported when you use a Web browser 
or MMC to manage the client systems.

You can use the Remote Control interface to set configuration options 
for remote-control sessions.

Click Tasks → Tools → Remote Control to display the Remote 
Control interface.
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The following items are displayed on the Remote Control screen. 

Item Description

Access type The access type (Monitor or Active 
) determines whether you will 
monitor the client system or 
actively control it.

Grace period Number of seconds before the 
management server takes active 
control of the client system. This is 
the number of seconds between the 
warning and the actual active 
control. If you are having trouble 
with the management server timing 
out, increase the grace period.

Proceed if timeout  This timeout option is associated 
with the grace period. If you select 
Yes, the management server 
automatically takes control of the 
client system if the grace period 
times out before you get a response 
from the client system.
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Shutdown

The Shutdown service provides three options for shutting down your 
system:

■ Shutdown and Power Off — Shut down and turn off the 
computer.

Note: Shutdown and Power Off is available only on systems that 
support and have enabled Advanced Power Management. 

■ Restart — Shut down and restart your computer without turning it 
off.

Change state on Target  If you select Yes, the client system 
can take back control from the 
remote computer.

Desktop optimization If you select Yes, you can disable 
the background wallpaper of the 
client system for faster transmission 
between computers.

Color reduction For faster transmission between 
computers, you can compress the 
display on the client system. This 
number (16, 256, or Nothing) 
represents the number of pixels to 
which the display will be 
compressed.

Enable compression If you select Yes, the system 
compresses data for faster 
transmission between computers, 
but the user must wait for the 
compressed data to decompress 
after the transfer. If you are having 
difficulty transferring the data, 
enable compression.

Refresh rate A numeric value that represents the 
delay time between the controlling 
computer and the client system. The 
default is 100 milliseconds.

Item Description
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■ Log Off — Log off your operating system without shutting down 
the computer.

Click Tasks → Tools → Shutdown from the UM Services task list to 
display the following screen.

Web Links
Use the System Updatesoption to connect to an IBM Internet site that 
provides updated information for your specific system. This option 
works only if you have the ability to connect to the Internet.

Click Tasks → Tools → System Updates from the UM Services task 
list. The System Updates screen opens.
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The following items are available from the System Updates screen.

Item Description

Table of machine information The client system model number, 
serial number, operating system, and 
version number.

Get the latest drivers and news about 
your system

Immediate access to the latest device 
drivers, technical information, and 
news about the client system.

Build a custom online profile with 
IBM for your system

Be notified automatically when 
there is new information about the 
client system.
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4.Upward Integration Modules

This chapter provides information on installing and using Upward 
Integration Modules (UIMs) on supported system-management 
platforms. 

UIMs enable workgroup- and enterprise-level system-management 
products to interpret and display data provided by clients running UM 
Services. The modules provide enhancements on the management server 
that enable the system administrator to start UM Services from within 
the system-management platform, collect UM Services inventory data, 
and view UM Services alerts. UIMs are provided for the following 
system-management platforms:

■ Tivoli Enterprise, including Tivoli Framework 3.6, Tivoli 
Software Distribution 3.6, and Tivoli Enterprise Console 3.6

■ Tivoli NetView 5.1.1 and 6.0 for Windows NT

■ CA Unicenter TNG Framework for WIN32 Version 2.2, AIM IT 
Version 3.0, Asset Management Option 3.0, SHIP IT Version 2.0, 
Software Distribution Option 2.0

■ Intel LANDesk Management Suite 6.3

■ Microsoft SMS 1.2; Microsoft SMS 2.0

The UM Services installation program enables you to install the Alert on 
LAN Proxy agent on your system-management platform. The Alert on 
LAN Proxy is not a UM Services UIM, but this proxy agent must be 
installed on your system-management platform to receive Alert on LAN 
messages from Alert on LAN-enabled client systems.
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Installing Upward Integration Modules
The method used to install an Upward Integration Module depends on 
the system-management platform for which you are installing support.

■ If you are installing the Tivoli Enterprise Plus Module, see 
“Installing the Tivoli Enterprise Plus Module” on page 91.

■ If you are installing Intel LANDesk Management suite integration, 
see “Intel LANDesk Management Suite Integration” on page 115.

■ If you are installing an Upward Integration Module for any other 
supported system-management platform or are installing the Alert 
on LAN Proxy agent, use the UM Services installation program to 
install the UIM on the system-management platform. Copy the 
UM Services installation files to a directory on the 
system-management system and then go to the same 
platform-specific section of this chapter for additional installation 
instructions and usage information.

■ If you are installing the Intel Alert on LAN Proxy on your 
system-management platform, see “Installing Intel Alert on LAN 
Proxy” on page 126.

Tivoli Enterprise Plus Module Integration
Tivoli Enterprise is part of Tivoli Management Environment (TME)10. 
The Tivoli Enterprise UIM adds a module that enables a system 
administrator using Tivoli Enterprise to manage client systems that have 

Systems 
Management 

Platform
Additional Information

Tivoli NetView “Tivoli NetView 5.1.1 and 6.0 Integration” 
on page 99

CA Unicenter TNG “CA Unicenter TNG Framework 
Integration” on page 108

Microsoft SMS “Microsoft SMS Integration” on page 117
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UM Services installed. For example, the system administrator can shut 
down, restart (shut down and restart), and wake up any selected client 
system that has UM Services installed.

Installing the Tivoli Enterprise Plus Module
Notes:

• The TMR Gateway in Netfinity Director is not a true Tivoli 
Enterprise Framework gateway. You cannot:

■ Migrate endpoints to Netfinity Director

■ Assign the gateway to the endpoint using the 
lcs.login_interfaces setting

■ Use any of the w commands.  

The Netfinity Director TMR Gateway is designed to only listen 
for the login broadcast requests from the endpoint and will make 
one downcall at that time, the Director client installation. An 
endpoint usually attempts to contact known gateways. The 
endpoint can be configured to broadcast in an attempt to find a 
TMR, if a known gateway cannot be reached.  

To enable communication between the endpoint and the 
Netfinity Director TMR Gateway, you must configure the 
endpoint broadcasting feature. Set the bcast_disable parameter 
in the lasg.cfg file of the endpoint to 0 (the default). For best 
results, shutdown any true TMR Gateways that may be running 
in the broadcast space of the Tivoli Management Agent 
endpoint. See the UM Services deployment instructions on page 
97 for more information.

• The ID that you configure on the Director TMR Gateway 
discovery preferences dialog is just a placeholder.  If you do not 
pass one to the endpoint during its login, login recognition does 
not occur.  The ID has no preferred or set value and can be set 
to any set of alphanumeric characters.

• The Netfinity Director TMR Gateway does not interact with 
other Tivoli TMR gateways.
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• Currently, Netfinity Director does not support the distribution 
of unique RSP files for installations using the TMR Gateway 
method.

Follow these steps to install the Tivoli Enterprise Plus Module:

1. Copy the Tivoli Enterprise Plus Module to a temporary directory 
on the system that is running Tivoli Enterprise. 

You can download the Tivoli Enterprise Plus Module from 

http://www.ibm.com/pc/ww/software/sysmgmt/products/ums

The downloaded file is named UM_Services.tar

2. Use a file decompression program that supports the TAR file 
compression format to extract the contents of the file to a 
temporary directory, for this example, UM Services Plus for 
Tivoli.

3. Use the Tivoli Desktop to install the Tivoli Enterprise Plus 
Module. 

a. From the Tivoli Desktop menu, click Install → Install 
Product.

b. Select your host and directory. Choose the temporary directory 
UM Services Plus for Tivoli, which contains the Tivoli 
Enterprise Plus Module files.

c. Click Set Media → Close.

d. Install the Plus Module Support link binaries first, and then 
install the UM Services Plus module for Tivoli. You must 
install the Plus Module on the Tivoli Management Region 
(TMR) and on any other managed nodes from which the Plus 
Module will be used. 

Notes:

• Because of a limitation in Tivoli Enterprise 3.6, the 
only administrator roles that can install the Plus 
Module are root (for systems running UNIX) and 
administrators (for systems running Windows NT).
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• When installing the Tivoli Enterprise Plus Module, 
the administrator must use a fully qualified Tivoli 
login name (in name@domain format).

Enabling Additional Functions
After you install the Tivoli Enterprise Plus Module, use the following 
information to enable additional functionality.

■ Enabling Wake on LAN® support

To use the Wake on LAN component, you must have a Java Virtual 
Machine installed on the computer on which the Plus Module is 
installed. Also, you must install the Inventory module and collect 
inventory from the client endpoints, before you attempt a wake up.

■ Enabling Software Distribution support

To enable Software Distribution support, install the Software 
Distribution Gateway from the Software Distribution CD onto a 
managed node before installing the UM Services Plus Module so 
that Tivoli endpoints can be targeted. Additionally, you must 
install the Software Distribution product on any managed node 
where the Plus Module is installed.

Note: The source path of the UM Services

1. Before you can distribute UM Services software, you need a 
source computer and a source directory that contains the UM 
Services installation files. This is your staging location for 
distributing software.You also need a destination drive and 
location (for example, C:\temp) on the target systems where 
the installation files will be copied. This destination drive and 
directory must exist on all client systems before you 
distribute the software.

Notes:

• The source path of the UM Services FilePack profile 
designates the root directory as the beginning of the 
installation. If you have changed or added to the 
installation file path 

/Win32/Install/en
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then you must edit the correct path in the file 
ums_fp_after.bat. 

For example, if you mount the Netfinity Director 
with UM Services CD on a system running Unix 
with a mount point of /cdrom, then you add the 
change directory command of 

CD CDROM

before the other change directory commands. The 
edited section of the batch file will look like this:

REM Next line is Unix CDROM mount

CD CDROM 

CD Win32

CD Install

CD en

• This destination differs from the final destination for 
the UM Services software (for example, 
C:\program files\ibm\ums, which must be 
configured with the SETUP.ISS file. For more 
information on editing the SETUP.ISS file, see 
“Modifying the SETUP.ISS File Manually” on page 
121.

2. Before doing any software distribution, run the Prepare for 
UM Services Install service to configure a UM Services file 
package. Take the following steps:

a. Double-click on the icon, Prepare for UM Services 
Install.

b. In the Source Host field, type the machine name of the 
system where the installation files are located.

c. In the Source Path field, type the directory path where 
the installation files are located.

d. In the Destination Path, type the directory path of the 
managed system where the files are to be distributed.

e. Click Set and Close.
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f. Right-click on the icon, Install UM Services. In the 
pop-up menu, select Distribute.

3. You can distribute UM Services to any supported Windows 
operating system (Windows 95,Windows 98, or Windows 
NT 4.0 or later). A log file (named umsinst.log) records the 
results of the software distribution. The file is located in 
%DBDIR%\..\tmp.

Note: DCOM95 must be installed before you install UM 
Services on systems running Windows 95. DCOM95 is 
included with Internet Explorer 4.0 or later and NetScape 
Navigator 4.5 or later. However, if one of these browsers 
is not installed on the system on which you are installing 
UM Services, you must install DCOM95 first.

To install DCOM95 and the Microsoft Virtual Machine 
(both of which are used by UM Services), run the program 
named msjavx86.exe, included in the UM Services 
installation files. When this program finishes running, 
restart the system, delete (or rename) msjavx86.exe from 
the installation directory, and then install UM Services.

If you are distributing UM Services remotely to systems 
running Windows 95, be sure to distribute and install the 
msjavx86.exe program first. When running msjavx86.exe 
remotely, use the following command:

MSJAVX86 /Q /R:N

Then, restart the client system, delete (or rename) 
msjavx86.exe from the installation directory, and install 
UM Services.

■ Installing the Inventory Gateway product

 Install the Inventory Gateway product from theTivoli Enterprise 
Inventory CD onto a managed node before you install the Plus 
Module. The Inventory Gateway product must be installed on a 
managed node where the Plus Module is installed.

■ Enabling distributed monitors

Distributed monitors are not supported on Windows 95 or 
Windows 98 endpoints. To enable distributed monitors on systems 
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running Windows NT, install the distributed monitor package on a 
managed node where the Plus Module is installed.

UM Services monitors the UM Services HTTP DAEMON and the 
SNMP subagent processes.

■ Activating Tivoli Enterprise Console (TEC) integration

To activate TEC integration, run the Setup TEC Event Server for 
the UM Services task on the TEC server.

• TEC events from UM Services Monitors

The UM Services SNMPCheck and HTTPCheck monitors 
send TEC events when the UM Services SNMP subagent or 
HTTP DAEMON processes stop. The events register, with the 
corresponding TEC indicator, changes its temperature icon 
depending on the severity of the event. Additionally, the 
events appear in the TEC console as members of the 
UM_Services_Plus Event Group.

Note: The default configuration for each monitor is for 
critical responses only.

To change the default settings in the Edit Monitor 
window, you first must select the critical response 
level. Otherwise, you will create a new configuration 
rather than change the existing one.

• Automated actions in response to events sent by UM Services 
Monitors

When the httpserv.exe and snmp.exe processes stop, the TEC 
server responds by restarting them automatically.

■ Launching UM Services

UM Services provides a Web browser-based console that you can 
use on any system that supports Netscape 4.5 or higher, Internet 
Explorer 4.01 or higher, and Java 1.1.7b or higher. This includes 
UNIX-based Tier 1 nodes. However, because the Tivoli 
application does not import system-wide environment variables on 
UNIX platforms, such as CLASSPATH, that are needed by UM 
Services, you must add the CLASSPATH environment variable to 
the Tivoli setup_env.sh or setup_env.csh scripts to enable UM 
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Services startup support. Also, under AIX, the MOZILLA_HOME 
variable that Netscape uses must be included in the setup_env.sh 
or setup_env.csh scripts. After you set these variables, run 
setup_env.sh to enable the launch support for UM Services in the 
Plus Module.

■ Adding Plus Module icons

The Plus Module installation automatically places launch icons in 
the collection window for every managed node in the TMR that has 
the Plus Module installed. The launch functionality for a specific 
managed node works only when you double-click the launch icon 
for that managed node (for example, Launch UM 
Services@<hostname>.)

■ Managing large numbers of managed nodes

For TMRs with a large number of managed nodes running the Plus 
Module, the number of launch icons in the Plus Module collection 
window can become excessive. You can remove some of these 
icons from the collection window by clicking an icon to highlight 
it and choosing Remove from the Edit menu. Alternatively, you 
can create a separate collection just for the launch icons by 
choosing Create → Collection, and then dragging and dropping 
the individual icons into the new collection. 

Note: In this case, the icons still must be removed from the 
original view.

■ Deploying endpoints with UM Services

Tivoli recommends deploying endpoints with a preconfigured 
gateway to help ensure their successful initial login. You can 
specify the gateway for a particular endpoint in the silent 
installation script tmasetup.iss that is included in the UM Services 
installation package. Open the file and scroll to:

[SdShowDlgEdit3-0]

szEdit1=9494

szEdit2=9494

szEdit3=-d1

Result=1
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The key 

szEdit1

 specifies the port through which the gateway communicates. It is 
9494 by default. The key 

szEdit2

specifies the port through which the endpoint communicates, also 
9494 by default. The key 

szEdit3

specifies any command lines to pass to the install action program. 
Use this key with the following flags to specify a gateway:

szEdit3=-d1 -g gateway host+ gateway 
listening port

Using the Tivoli Enterprise Plus Module 
Tivoli Enterprise Plus Module enables you to perform the following 
additional system-management tasks from the system where UM 
Services is installed:

■ Configure UM Services for all platforms

■ Conduct UM Services queries

■ Obtain UM Services inventory on a client computer

■ Use the UM Services indicators for monitors

You can also select a remote system and perform any of the following 
tasks remotely:

■ Restart (shut down and restart) a UM Services client system.

■ Shut down a UM Services client system.

■ Wake up a UM Services client system.

To use the Plus Module to manage client systems:

1. From the Tivoli Management Framework window, double-click 
the Plus Module icon (found in the upper-right corner of the 
window). The Plus Module window opens.
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Note: The items that appear on the Plus Module window depend 
on what you have installed on the computer that you are 
managing.

2. To be able to restart, shut down, or wake up a client computer, you 
must first select the client computer from a list of subscribers. 
Click the UMS Subscribers icon on the Plus Module window.

Tivoli NetView 5.1.1 and 6.0 Integration
Tivoli NetView can be used to manage clients running UM Services. To 
enable this functionality, you must use the UM Services installation 
program to install the UM Services NetView Upward Integration 
Module on the system that is running NetView Server.

Installing the Tivoli NetView Upward Integration 
Module

To install the Tivoli NetView UIM:

1. Establish an appropriate remote access policy. 

The NetView system administrator must have access privileges on 
every remote client system so that UM Services inventory data can 
be obtained for each client system. The easiest way to do this is to 
create a Windows NT domain in which every client is a member. 
The system administrator should be a member of the Domain 
Admins group. This enables the system administrator to access all 
the computers in the domain (and any trusted domains) without 
requiring further authentication.

2. Install UM Services on the client computers. 

Note that you must install the Web Based Access component on 
UM Services client computers to classify client systems as UM 
Services-capable. It is important to do this before installing the 
NetView UIM on the NetView server. For more information on 
installing UM Services on client systems, see “Chapter 2. 
Installing UM Services,” on page 15.

3. Use dcomcnfg.exe to enable DCOM connections on client 
systems running Windows 95 and Windows 98.
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You can download dcomcnfg.exe from 

http://www.microsoft.com/com/tech/DCOM.asp

Ensure that CONNECT level authentication and 
IMPERSONATE level impersonation are selected.

4. Start the UM Services installation program on the NetView server.

To start UM Services installation, click Start → Run, and then 
type in the Run field:

drive letter:\directory\setup.exe 

where drive letter and directory are the drive letter and directory 
where you have decompressed the UM Services files that you 
downloaded from the Internet. 

5. Click OK.

The installation program displays the Welcome window, which 
advises you to exit from all Windows programs before you begin 
to install UM Services and notifies you of the copyright laws 
associated with UM Services.

6. Click Next.

The installation program displays the Select Language window. 
Select the language to be used for this UM Services installation.

7. Click Next.

The installation program displays the License Agreement 
window. Click I Agree to proceed.

Note: You must agree to the terms of the License Agreement to 
install UM Services. If you click I Disagree, the 
installation program will close.

The Setup Options window opens.
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8. From the Setup Options window, click the 
Workgroup/Enterprise Integration — Installs UM Services 
integration for management environments button.

The Select Components window opens.

9. Click Tivoli NetView Upward Integration, and then click Next.

The installation program adds the UM Services SmartSet, loads 
UM Services MIB files, adds trap filters for UM Services SNMP 
traps, and adds menu items for starting and inventory collection 
into the NetView Tools menu. 

10. When the installation is finished, restart the server.

The integration setup program configures nvsniffer.exe to run 
after the system is restarted and has populated the UM Services 
SmartSet.
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Starting UM Services on NetView Clients
NetView clients with the UM Services Web Based Access component 
installed can be targets for starting UM Services. To start UM Services 
on NetView clients:

1. Open the UM Services SmartSet and then select a client system.

2. From the Tools menu, click Universal Manageability Services.

This selection will be disabled and unavailable if the client system 
you selected does not have the Web Based Access component 
installed.

UM Services starts on the selected client, using the management system 
default Web browser. A valid UM Services user ID and password are 
required to use UM Services to manage a remote client system. 

Using Tivoli NetView 5.1.1 and 6.0 to Obtain 
Inventory Data 

NetView clients with the UMSCIM Object capability can be targets for 
collecting UM Services WBEM-based inventory. Inventory data from 
UM Services clients can be collected in one of the following ways: 

■ From the command prompt.

1. Create a new NetView sniffer configuration file.

Open the file nvsniffer.conf.

2. Replace the line, wbem_discovery.conf, with 
ums_wbem.conf.

3. Save the file as ums_wbem_discovery.conf.

4. While logged into the NetView server host with an account 
that is a member of the Domain Admins group, run 
nvsniffer.exe interactively from the command prompt:

nvsniffer.exe -c 
/usr/ov/conf/ums_wbem_discovery.conf

■ From the NT Schedule service. 

Use the NT Schedule service to run nvsniffer.exe. 
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By default, NetView configures the Schedule service to run 
nvsniffer.exe daily at 1:00 a.m. However, because UM Services 
inventory collection relies on a remote DCOM connection to the 
client computer to access its WBEM repository, you must 
reconfigure the Schedule service to log in as a user with remote 
access privileges on the client system. 

To reconfigure the NT Schedule service, do the following:

1. Select the Control Panel → Services.

2. Select the Schedule service.

3. Click Startup and configure the service to Log On As a user 
to join the Domain Admins group.

■ From the NetView Console.

1. Open the NetView console.

2. Open the SmartSets submap.

3. Open the UM Services SmartSet.

4. Select a system in the submap for which to collect inventory 
information. 

5. Open the Tools menu and select the UM Services Inventory 
item.

A pop-up menu displays the different categories of 
WBEM-based inventory information provided by UM 
Services on the client. 

6. Select Demand Poll from the pop-up menu to have the data 
collected from each client in the Netview database. 

7. To see the database logged UM Services inventory data from 
a particular system, from the command prompt type:

ovobjprint -s <hostname>

Note: If the client you selected does not have a UMSCIM 
Object capability (there is no remote access policy to 
the computer from the NetView server), the UM 
Services Inventory item will be disabled.
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Viewing UM Services SNMP Data from NetView
During the installation of UM Services NetView integration support, 
trap filters for UM Services SNMP traps are added to the NetView 
trapd.conf file. Thus, when an SNMP trap is sent from a UM Services 
client, it can be viewed in the NetView Event Browser. Only traps of 
critical severity are filtered, and the default action is to change the icon 
color of the source computer from green to red. Traps indicate an 
abnormal environment condition on the UM Services client, such as 
chassis intrusion, a removed processor, or temperature out of range.

To configure the NetView console to display advanced menu items do 
the following:

1. Click Options → Advanced to configure the NetView console to 
display advanced menu items and query this data. 

2. Shut down and reopen the NetView console.

3. Open the UM Services SmartSet and select a system from which 
to view SNMP data.

4. To start the NetView SNMP browser, open the Tools menu and 
click MIB → Browser. Ensure that the selected system node name 
is displayed in the Node Name or Address field, and click Get 
Values.

Note: To view specific Alert on LAN SNMP traps, you must use 
the SNMP V2 browser. Click MIB → SNMP V2 → 
Browser.

5. The NetView SNMP collection DAEMON will contact the UM 
Services SNMP subagent on the client system and query it for the 
data published in the UM Services MIB files. 

Because SNMP support is an optional component of UM Services, and 
not a required component, not all systems in the UM Services SmartSet 
will have the UM Services SNMP subagent installed. Those that have 
the subagent installed will have UMSSnmp Object capability. The is 
UMSSnmp test is not enabled by default in nvsniffer.conf, but can be 
enabled by opening the nvsniffer.conf and removing the comment 
symbol from the line that begins with is UMSSnmp.
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Forwarding SNMP Trap Information
UM Services forwards SNMP trap alerts to the NetView administrator 
for critical IBM sytem environmental conditions, low disk space, a 
failing hard drive, and a system being removed from a LAN. During the 
installation of the UM Services upward integration support for NetView, 
these traps are added to NetView’s trapd.conf file with their Trap 
Properties configured using the addtrap.exe utility. 

UM Services forwards the following SNMP traps to the NetView server 
workstation: 

■ iBMPSG_TemperatureEvent

■ iBMPSG_VoltageEvent

■ iBMPSG_ChassisEvent

■ iBMPSG_FanEvent

■ iBMPSG_StorageEvent

■ iBMPSG_SMARTEvent

■ iBMPSG_LANLeashEvent

The following list describes the default properties configured for UM 
Services SNMP traps:

Enterprise: ibm

Trap-Type: Specific <Last field of NOTIFICATION-TYPE OID>

Trap Name: <Label of NOTIFICATION-TYPE>

Display the Trap Category as:
Status Events

With Severity:
Critical

From this Source:
Load MIB

Object Status for Specific Traps:
Critical/Down

Event Description:
<Event> condition critical
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Run this command when the trap is received:
“”

Run as: Hidden Application

The MIB file describing the traps is named umsevent.mib and is 
installed in the 

%NV_DRIVE%\usr\ov\snmp_mibs

directory.  Client systems must have SNMP support installed and the 
UMSSnmp Object Property before they can forward UM Services 
SNMP traps.

Additionally, the installation program adds placeholders for the 
following traps, which will be implemented by UM Services in the 
future:

■ iBMPSG_ProcessorEvent

■ iBMPSG_AssetEvent

■ iBMPSG_POSTEvent

■ iBMPSG_ConfigChangeEvent

■ iBMPSG_LeaseExpiration

■ iBMPSG_WarrantyExpiration

Alert on LAN 2.0 Traps

The Alert on LAN 2.0 networking hardware that is present on certain 
IBM systems, such as the IBM 300 PL, also has the ability to send alerts 
when it detects abnormal environmental conditions or system 
tampering. These alerts are sent to the AOL 2 Proxy tool that can be 
installed from the UM Services install program by selecting 
Workgroup/Enterprise Integration and then AOL Proxy. (For more 
information, see “Installing Intel Alert on LAN Proxy” on page 126.) 

Once the tool is installed, the administrator can configure AOL 2 clients 
to forward their alerts to the system with the AOL 2 Proxy tool. Once the 
alerts reach the AOL 2 Proxy system, they are converted to SNMP traps 
and can be forwarded to the NetView Event Browser

The traps forwarded by AOL 2 Proxy are defined in the aolntrap.mib 
and aolnpet.mib files. The files are loaded into NetViw's SNMP MIB 
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loader when the UM Services upward integration support for NetView 
is installed. Both MIB files describe the same traps except in different 
formats. Therefore, it is recommended that one of the MIB files should 
be unloaded. Specifically, aolntrap.mib defines traps whose packets are 
formatted in the traditional way and aolnpet.mib defines traps whose 
packets are formatted in a way that complies with the newer Intel pET 
standard.

The traps defined in both MIB files are added to trapd.conf. To view the 
traps, do the following.

1. From the NetView console, click on Trap Settings. 

2. For aolntrap.mib traps, select Enterprise Intel, ID 
1.3.6.1.4.1.343.

For aolnpet.mib traps, select Enterprise Intel, ID 
1.3.6.1.4.1.3183.

3. Open Event Details.

Netfinity Director Traps

During the installation of the UM Services upward integration support 
for NetView, a trap filter for Netfinity Director is added to trapd.conf. 
This filter allows Administrators to view SNMP traps forwarded from 
the Netfinity Director Management Server received from a Netfinity 
Director agent. Netfinity Director only supports one trap type.

To view the details of the trap, including the description, severity, and 
origin, do the following.

1. From the NetView console, click on Trap Settings. 

2. Select Enterprise IBM, ID 1.3.6.1.4.1.2.6.146.

3. Open Event Details.

MIB Browsing

By default, the UM Services upward integration support for NetView 
installation program loads the UM Services MIBs using the 
loadmib.exe utility. These MIBs comply with the SMIv1 standard, and 
therefore the SNMP MIB Browser must be used when browsing UM 
Services systems. In addition, target systems must be installed with the 
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UM Services SNMP Support install option. See the “Installing UM 
Services” on page 20 for more information.

CA Unicenter TNG Framework Integration
You can use CA Unicenter TNG Framework to manage client 
computers that have UM Services. The UM Services integration for 
Unicenter TNG Framework supports the generation of custom MIF files 
for the AimIT or Asset Management Option repositories. You can also 
discover IBM client systems running UM Services, launch IBM UM 
Services, and create an IBM UM Services software distribution package 
for installing on client computers.

Configuring CA Unicenter TNG Framework
To receive SNMP traps from UM Services, you first must configure the 
SNMP trap server to receive UMS Service alerts (critical only) from 
IBM computers that have UM Services installed. To activate the SNMP 
trap service, perform the following steps:

1. Click Start → Programs → Unicenter TNG Enterprise 
Management (or Unicenter TNG Framework). Then click 
Enterprise Managers. A window with a Windows NT computer 
icon opens .

2. Double-click the Windows NT icon. A window with three 
options: Calendar, Configuration, and Event opens.

3. Double-click the Configuration icon. The Settings window 
opens.

4. Double-click the Settings icon. The Settings window with tabs, a 
table and a list of items opens.

5. Select the Component Activation Flag at the bottom and the 
Client Preferences tab on the right, and then scroll to the row with 
SNMP Trap Server Activated in the Description field.

6. In the Settings column, the value should be YES. If it is not, 
double-click the Setting box. Click the YES option.

7. Click the Server Preferences tab, and scroll to the row with 
SNMP Trap Server Activated in the Description column.
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8. In the Settings column, the value should be YES. If it is not, 
double-click the Setting box. Click the YES option.

9. Set the Windows NT SNMP Trap service to manual by doing the 
following:

a. Click Start → Settings → Control Panel.

b. Double-click Services.

c. Double-click SNMP Trap Service .

d. Set the Startup type to Manual.

10. Start all CA Unicenter TNG Enterprise Management services. 
Open a command prompt window and type:

UNICNTRL START ALL

11. Exit from any Unicenter TNG Framework applications that are 
running.

12. If you have not restarted the computer since the CA Unicenter 
TNG Framework was installed, do so now.

Installing the CA Unicenter TNG Framework Upward 
Integration Module

To install the CA Unicenter Upward Integration Module:

1. Start the UM Services installation program on the CA Unicenter 
server.

To start UM Services installation, click Start → Run, and in the 
Run field, type:

x:\directory\setup.exe

where x is the drive letter and directory is the directory where the 
UM Services installation program is located. 

2. Click OK.

The installation program displays the Welcome window, which 
advises you to exit from all Windows programs before you begin 
to install UM Services and notifies you of the copyright laws 
associated with UM Services.
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3. Click Next.

The installation program displays the Select Language window. 
Select the language to be used for this UM Services installation.

4. Click Next.

The installation program displays the License Agreement 
window. Click I Agree to proceed.

Note: You must agree to the terms of the License Agreement to 
install UM Services. If you click I Disagree, the 
installation program will close.

The Setup Options window opens.

5. From the Setup Options window, click the 
Workgroup/Enterprise Integration — Installs UM Services 
integration for management environments button.

The Select Components window opens.

6.  Click CA Unicenter Upward Integration, and then click Next.

The installation program adds the UM Services UIM for CA 
Unicenter to the Unicenter server. 

7. Click Next. A Unicenter TNG Framework window opens, 
prompting you to select a repository. Use the down-arrow or the 
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Find button to locate a repository, and then click OK. You are 
prompted for a user ID and a password. If a Unicenter TNG 
Framework session has been initiated before you installed UIM, 
use that logon procedure. 

8. A command prompt window appears, and after a few moments CA 
Unicenter TNG Framework UIM installation completes. A 
notification is displayed and informs you that the installation is 
complete. Click OK to close this notification window.

9. You must restart the system to activate the CA Unicenter TNG 
Framework UIM. A window is displayed and prompts you to 
restart the system. Click Restart to restart the system immediately, 
or click Cancel to exit from the installation program without 
restarting the system.

Reclassifying Existing Devices
After installation, the Unicenter TNG Framework discovery process 
runs automatically and identifies IBM systems running UM Services, 
reclassifying them in Unicenter TNG Framework. However, there can 
be many existing computers that need to be reclassified. To reclassify 
existing devices:

1. Run the Reclassify utility by clicking Start → Programs  → IBM 
Integration with Unicenter TNG → Reclassify Systems in 
Unicenter TNG.

A Unicenter TNG Framework window opens, prompting you to 
select a repository. 

2. Select the repository that you defined during setup. Click OK to 
start the Reclassify utility. A command prompt window opens and 
displays a message showing that it is finding existing Windows 95, 
Windows 98, or Windows NT computers that might have UM 
Services installed on them. 

The process reclassifies existing objects into IBM UM Services 
objects. These computers can receive UM Services inventory 
requests and can send SNMP traps.

If there are many systems to reclassify, the reclassification process 
can take several minutes to complete. When the reclassification 
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process is finished, the command prompt window closes. You 
should have to run the Reclassify utility only once.

Using CA Unicenter TNG Framework UIM
The CA Unicenter TNG Framework UIM enables you to:

■ Launch UM Services from the CA Unicenter TNG Framework 2D 
or 3D Map

■ View UM Services inventory from the 2D Map

■ Use AimIT to obtain inventory data from client systems

■ View SNMP alerts sent by UM Services clients

■ Use ShipIT to create a UM Services software package

Launching UM Services with CA Unicenter TNG 
Framework UIM

To launch UM Services from the CA Unicenter 2D or 3D map:

1. Click Start → Programs → Unicenter TNG Framework → 2D 
Map (or 3D Map). Select the respository defined in setup. The 
Unicenter TNG Framework Map opens with the Managed 
Objects window opened.

2. In the Managed Objectswindow, double-click the IBM icon. The 
Computers window opens.

3. Right-click the computer of your choice, and then select IBM UM 
Services from the pop-up menu. The UM Services console opens. 

Viewing UM Services Inventory from the 2D Map

When AimIT is integrated with CA Unicenter, it enables you to obtain 
inventory information on CA Unicenter clients. To use AimIT from the 
2D Map to view inventory data on UM Services client inventory data:

1. From the Managed Objectswindow, double-click the IBM icon.

2. Double-click the client system for which you want information.

3. Right-click the Inventory icon, and then select View from the 
menu to open the AimIT Domain window.
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4. Click the Additional bar at the bottom of the window. An 
additional inventory list window opens.

5. Click UM Services Inventory, and then select any inventory 
option. The inventory information appears on the right side of the 
window.

Using AimIT to View Inventory

AimIT can be used to view inventory. To start AimIT, do the following:

1. Click Start → Programs → AimIt Workgroup Edition → 
Admin Console. After you type the CA Unicenter password, the 
AimIT Domain window opens.

2. Double-clickDomain. A window that contains a list of available 
domains and computers opens.

3. Click the Computer icon, and then double-click on a single 
computer for which you want to display the inventory. The 
inventory for the selected computer is displayed.

4. Scroll to the Inventory icon in the list, and click it to display 
primary inventory.

5. Click the Inventory Browser icon in the toolbar. The 
Inventorywindow opens.

6. Click the Additional bar at the bottom of the window. To open the 
window that displays the complete inventory list. You can view the 
inventory of UM Services by selecting an item under this category 
in the inventory directory.

Viewing UM Services SNMP Alerts

When an SNMP alert occurs, a banner scrolls at the top of the screen to 
notify you of the alert. To view all UM Services SNMP Alerts that have 
been received by the CA Unicenter Framework:

1. Click Start → Programs → Unicenter TNG Enterprise 
Management (or Unicenter TNG Framework). Then click 
Enterprise Managers to open a window with a Windows 
NTcomputer icon.
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2. Double-click the Windows NT icon. A window with three 
options: Calendar, Configuration, and Event opens.

3. Double-click the Event icon. A window with three options: 
Console Logs, Messages, and Messages Action opens.

4. Double-click the Console Logs icon.

The Console Log window opens. The top of the window shows held 
messages. Held messages are deleted from the Console Log window 
after you reply to them.

Using ShipIT to Create a UM Services Software 
Package

You can use ShipIT to create a UM Services installation package, which 
can then be used to install UM Services onto CA Unicenter TNG 
Framework client systems.

Note: DCOM95 must be installed before you install UM Services on 
systems running Windows 95. DCOM95 is included with 
Internet Explorer 4.0 or later and NetScape Navigator 4.5 or 
later. However, if one of these browsers is not installed on the 
system on which you are installing UM Services, you must 
install DCOM95 first.

To install DCOM95 and the Microsoft Virtual Machine (both of 
which are used by UM Services), run the program named 
msjavx86.exe, included in theUM Services installation files. 
When this program finishes running, restart the system, delete 
(or rename) msjavx86.exe from your installation directory, and 
then install UM Services.

If you are distributing UM Services remotely to the system 
runningWindows 95, be sure to distribute and install the 
msjavx86.exe program first. When running msjavx86.exe 
remotely, use the following command:

MSJAVX86 /Q /R:N

Then, restart the client system, delete (or rename) msjavx86.exe 
from the installation directory, and install UM Services.

 To create and distribute an installation package:
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1. Set up a software package to distribute UM Services from the 
server to client computers by manually copying all of the UM 
Services installation files into the directory: 
c:\TNGFW\IBM\SW_Distribution

2. Manually run rr_swdistrib.bat, to set up the UM Services 
package into ShipIT Enterprise ED, WkgpEd, or Software 
Delivery Option (SDO), so that you can install it onto remote 
clients.

3. To use this ShipIT software, click Start → Programs → ShipIt 
→ SD Explorer.

4. Using SDO, drag and drop the package onto the client systems.

Uninstalling the CA Unicenter TNG Framework 
Upward Integration Module

To remove the UM Services UIM from the Unicenter TNG Framework 
server, click Start → Programs → IBM Integration with Unicenter 
TNG → IBM Integration with Unicenter TNG → Uninstall IBM 
Integration with Unicenter TNG. After the uninstallation program 
finishes uninstalling the UIM, remove the modifications made to 
umclient.bat.

Intel LANDesk Management Suite Integration
Unlike other UM Services Upward Integration Modules, LANDesk 
Management Suite integration requires that an additional component be 
installed on each UM Services client. When installing UM Services on 
your client systems, be sure to select the LANDesk Management Suite 
Integration component from the Select Components window.

Remember: Do not select Web Based Remote Control when installing 
UM Services on clients that you will manage using LANDesk 
Management Suite. LANDesk Management Suite includes a remote 
control service that is not compatible with the Remote Control service 
included with UM Services.

 For more information, see “Supported Systems-Management 
Environments” on page 16 and “Installing UM Services” on page 20.
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Note: You can install UM Services on clients with the LANDesk 
integration option enabled, even if you have not yet installed 
LANDesk Management Suite on your network.

Integrating UM Services Clients into LANDesk 
Management Suite

You do not need to install additional software to your LANDesk 
Management Suite administration system to manage UM Services 
clients that have the LANDesk Management Suite component installed. 
To integrate UM Services clients into your LANDesk Management 
Suite environment, configure the batch file ldinv.bat to run periodically 
on each UM Services client. ldinv.bat generates custom MIF files that 
can be used by the LANDesk Management Suite inventory functions. Be 
sure to run ldinv.bat before ldiscn32.exe inventory collection. One 
method you can use to accomplish this task is described in the following 
procedure:

1. From a login script, run ldinv.bat, and then runldiscn32.exe .

2. Create a login script that connects the system to the \LDLOGON 
share of the LDMS server.

3. Copy the contents of the %UMS_HOME%\inventory\ldinv.bat 
file into the script.

4. Remove the comment symbols from the command line for 
ldiscn32.exe that is included in the batch file and configure it with 
the name of the inventory server and its network address and any 
other desired settings. With this line active, whenever a user logs 
in, the login script generates a MIF file, output it to c:\dmi\dos\mifs 
(by default), and trigger an inventory scan that will update the 
LDMS inventory database.

5. Use the LANDesk scheduler to run ldinv.bat on each client at a 
predefined time.

6. Run ldinv.bat from the Startup folder of each client system. 
Ensure that ldiscn32.exe runs from ldinv.bat and that no other 
copies of ldiscn32.exe are run from the Startup folder.
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Microsoft SMS Integration
Microsoft SMS can be used to manage clients running UM Services. To 
enable it, use the UM Services installation program to install the UM 
Services Microsoft SMS Upward Integration Module on the Microsoft 
SMS server.

Notes:

• After you have installed the Microsoft SMS UIM on the 
Microsoft SMS 1.2 or Microsoft SMS 2.0 Server or Console, 
you can use the SMS Software Distribution function to 
distribute UM Services to your SMS 1.2 or 2.0 client systems. 
A special installation program designed to facilitate this 
process, named umsw32un.exe, can be downloaded from the 
Web at:

http://www.ibm.com/pc/ww/software/sysmgmt/products/u
ms

• DCOM95 must be installed before you install UM Services on 
systems running Windows 95. DCOM95 is included with 
Internet Explorer 4.0 or later and NetScape Navigator 4.5 or 
later. However, if one of these browsers is not installed on the 
system on which you are installing UM Services, you must 
install DCOM95 first.

To install DCOM95 and the Microsoft Virtual Machine (both of 
which are used by UM Services), run the program named 
msjavx86.exe, included in the UM Services installation files. 
When this program finishes running, restart the system, delete 
(or rename) msjavx86.exe from your installation directory, and 
then install UM Services.

If you are distributing UM Services remotely to systems running 
Windows 95, be sure to distribute and install the msjavx86.exe 
program first. When running msjavx86.exe remotely, use the 
following command:

MSJAVX86 /Q /R:N

Then, restart the client system, delete (or rename) msjavx86.exe 
from the installation directory, and install UM Services.
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Installing the Microsoft SMS Upward Integration 
Module

Installing UIM on the SMS 1.2 server adds a resource file 
(ibmsmsresdll) and bitmaps for IBM features, and provides a *.atd file 
that is used by smsaddin.exe to add features to the Tools menu of the 
SMS console.

During installation of the UIM on the SMS 2.0 server, the SMS console 
is configured with the queries, collections, and tools specific to UMS. 
Also, the installation provides a Microsoft Management Console 
(MMC) snap-in module that adds a context to the client systems. The 
UMS-specific menu items appear only on systems that have UMS 
installed.

1. Start the UM Services installation program on the Microsoft SMS 
Console or Server.

To start UM Services installation, click Start → Run, and in the 
Run field type:

drive letter:\directory\setup.exe 

where drive letter and directory are the drive letter and directory 
where you have decompressed the UM Services files that you 
downloaded from the Worl Wide Web.

2. Click OK.

The installation program displays the Welcome window, which 
advises you to exit from all Windows programs before you begin 
to install UM Services and notifies you of the copyright laws 
associated with UM Services.

3. Click Next.

Select the language to be used for this UM Services installation. 
The installation program displays the Select Language window.

4. Click Next.

The installation program displays the License Agreement 
window. Click I Agree to proceed.
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Note: You must agree to the terms of the License Agreement to 
install UM Services. If you click I Disagree, the 
installation program will close.

The Setup Options window opens.

5. From the Setup Options window, click Workgroup/Enterprise 
Integration — Installs UM Services integration for 
management environments.

The Select Components window opens.

6.  Click Microsoft SMS Upward Integration and then click Next.

7. Select the version of Microsoft SMS for which you are installing 
support and then click Next. The installation program adds the UM 
Services UIM to your Microsoft SMS system.

Customizing the SMS Installation
Use the following procedure to modify the UM Services installation 
routine and to create a new UM Services installation executable file. 
This procedure requires a compatible compression utility program, such 
as WinZip, to decompress the original file and to create a new 
executable file with preset command-line instructions.
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Note: In order to customize the UM Services installation file 
(UMSW32UN.EXE) properly, the compression utility must 
meet the following basic requirements:

■ Has the ability to extract files into a temporary directory

■ Allow user to edit and delete compressed files

■ Contains a self-extracting process that creates a user 
defined installation executable file, with the ability to set 
up specific start-up commands

To create a new UM Services installation file, do the following:

1. Use Windows Explorer to locate the file UMSW32UN.EXE.

2. Using the compatible compression utility program, extract the 
components files of UMSW32UN.EXE into a temporary 
directory.

3. Edit the extracted file, SETUP.ISS, to select the installation 
components to install for your particular configuration.

See “Modifying the SETUP.ISS File Manually” on page 121 for 
more information.

4. To reduce the size of the new package, delete Tivoli.z or Netfin.z 
from the temporary directory if they are not required for 
downloads.

5. Select all the extracted files, including SETUP.ISS, and create a 
new compressed file with the filename UMSW32UN.

6. Open your self-extracting executable file program using the 
compressed UMSW32UN file. 

7. Label the new file, UMSW32UN.EXE.

8. In the Command To Issue field (after the self-extraction operation 
completes), type:

en/um_setup.exe -S -SMS.

Note: To have the client system reboot after installation type: 

en/um_setup.exe REBOOT -S -SMS

9. In the Wait For field, type

_ISDEL
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10. Click OK to save the new file. 

A customized UM Services installation executable file is created.

Modifying the SETUP.ISS File Manually

This section describes the contents of the UM Services response file, 
SETUP.ISS, which can be used for the silent installation of UM Services 
on client systems. You can use this response file for software 
distribution from the Upward Integration Module environments and 
other silent installation scenarios.

Note:  You must install the UIM before using this process.

The response file is a text file that includes a number of variables that 
specify installation selections, such as which components are installed 
or the drive and directory to which the program files will be copied, that 
would ordinarily be selected during an attended installation. Some 
portions of the response file must not be changed by the user; making 
changes to these sections will cause the installation program to fail. All 
portions of the SETUP.ISS file, including sections that the user should 
not change, are described in the following pages.

This first four sections of the SETUP.ISS response file provide 
information about the installation process to the installation program. 
These entries must not be changed by the user:

[InstallShield Silent]

Version=v3.00.000

File=Response File

[Application]

Name=UMS

Version=2.0

Company=IBM

[DlgOrder]

Dlg0=SdOptionsButtons-0
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Dlg1=SdAskOptions-0

Dlg2=AskDestPath-0

Dlg3=AskSecurInfo-0

Dlg4=SdFinishReboot-0

Dlg5=MessageBox-0

Count=6

[SdOptionsButtons-0]

Result=101

The next section of the SETUP.ISS response file can be customized by 
the user. This section determines the UM Services components that will 
be installed on the client system.

To change these options, change the value of Component-count to the 
total number of components that you want to install, and list the 
components in sequential order, starting at Component-0.

[SdAskOptions-0]

Component-type=string

Component-count=x

where x is the total number of components to be installed.

The following is the list of components you can install. If your 
SETUP.ISS file contains all of these examples as shown, all selectable 
UM Services components will be installed on the client system. Include 
only the components that you want to install.

Component-0=Basic Services

Component-1=&Web Based Access

Component-2=System Health &Monitoring

Component-3=Web Based &Remote Control

Component-4=&LANDesk(TM) Management Suite 
Integration

Component-5=&Tivoli Management Agent
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Component-6=&SNMP access and trap forwarding

Result=1

The next section of the response file displays the path where you want 
to install UM Services. The default path is shown. You can change the 
installation path if necessary.

[AskDestPath-0]

szPath="C:\Program Files\IBM\UMS"

Result=1

The next section of the response file configures the security information. 
In this section of the file, type your user ID and password; both items are 
case-sensitive. Type your password again in the svConfirm line. You 
can also use this section to specify the TCPIP port number that will be 
used by UM Services.

[AskSecurInfo-0]

svUser=uniqueID

svPassword=uniquePassword

svConfirm=passwordConfirm

svPort=portnumber

Result=1

where uniqueID is your user ID, uniquePassword is your password, 
passwordConfirm is your unique password typed a second time, and 
portnumber is the TCPIP port number that will be used by UM Services. 
The default port number is 411. You can change this default port if 
necessary. Other valid port numbers are 6411, 6500, 6600, and 6611.

The last two sections of the SETUP.ISS response file provide 
information about the installation process to the installation program. 
These entries must notbe changed by the user.

[SdFinishReboot-0]

Result=1

BootOption=0
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[MessageBox-0]

Result=1

Uninstalling the Microsoft SMS Upward Integration 
Module

To remove UM Services from a SMS 1.2 server:

1. Delete the files from the %UMS_HOME% directory and remove 
the directory.

2. Remove the environment variable UMS_HOME

3. Remove the Registry 
keyHKEY_LOCAL_MACHINE\SOFTWARE\IBM\UMS 

4. Remove the Registry 
keyHKEY_CURRENT_USER\Software\Microsoft\SMS\Appl
ications\IBM - PCCo

To remove UM Services from a SMS 2.0 Server or Console, do the 
following:

1. Run REGSVR32 - U UMSCONS.DLL

2. Run REGSVR32 - U UMSSMSE1.DLL

3. Run REGSVR32 - U UMSSMSE2.DLL

4. Run UMSCOLL . \UMSCOLL.INI YourSMSSiteServer -D 
where YOURSMSSiteServer is the name of the SMS server. 

5. Delete the files from the %UMS_HOME% directory and remove 
the directory.

6. Remove the environment variable UMS_HOME

7. Remove the Registry key: HKLM\SOFTWARE\IBM\UMS

Using Microsoft SMS to View Client Computer 
Inventory

You can use Microsoft SMS 1.2 or 2.0 to view UM Services client 
inventory data.
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Microsoft SMS 1.2

To view UM Services inventory data or start the UM Services console 
from the Microsoft SMS 1.2 Console, do one of the following:

■ Start the SMS Console, and then double-click a client machine to 
open the Personal Computer Properties window.

■ Start the SMS Console, and then click Issue Wake on Lan 
Request → UM Services Help → UM Services Management 
Tools → Update UM Services Client Inventory.

SMS 1.2 UIM uses a static MIF file to provide inventory data to the SMS 
server. A MIF file is created for each inventory query file in the UM 
Services inventory directory. To refresh the client inventory data, select 
Update Client Inventory from the SMS Tools menu for the currently 
selected client computer.

The Microsoft SMS 1.2 UIM also enables the SMS server to receive UM 
Services alerts (such as System Health messages) as SNMP traps.

Microsoft SMS 2.0

The Microsoft SMS 2.0 UIM enables the SMS server to gather inventory 
data directly from the CIM agent on Windows 95, Windows 98, or 
Windows NT clients. It also enables SMS to gather inventory data using 
the static MIF file method used by Microsoft SMS 1.2.

The Microsoft SMS 2.0 UIM extends the SMS 2.0 Collections tree in the 
SMS 2.0 console to include UM Services clients. The SMS 2.0 UIM also 
extends the Queries tree, so that it can retrieve UM Services-specific 
inventory data. The Tools tree is extended as well, so that you can start 
the UM Services console on a client system.

SMS 2.0 does not support SNMP trap listening. However, the Microsoft 
SMS 2.0 UIM translates CIM notifications generated by UM Services 
into SMS 2.0 status messages.

To view the UM Services inventory data from the SMS 2.0 Console, 
click the Collections tree and then do the following:

1. Click All Systems with UM Services Agent

2. Right-click a client system in thewindow on the right side.

3. Click All Tasks → Start Resource Explorer.
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4. Click the Hardware node. The UM Services inventory data is 
under IBM UM Services.

Installing Intel Alert on LAN Proxy 
To install the Intel Alert on LAN Proxy on your system-management 
system, do the following:

1. Start the UM Services installation program on the 
system-management system that will receive Alert on LAN 
messages.

To start UM Services installation, click Start → Run, and then in 
the Run field type:

drive letter:\directory\setup.exe

where drive letter and directory are the drive letter and directory 
where you have decompressed the UM Services files that you 
downloaded from the World Wide Web.

2. Click OK.

The installation program displays the Welcome window, which 
advises you to exit from all Windows programs before you begin 
to install UM Services and notifies you of the copyright laws 
associated with UM Services.

3. Click Next.

Select the language to be used for this UM Services installation. 
The installation program displays the Select Language window.

4. Click Next.

The installation program displays the License Agreement 
window. Click I Agree to proceed.

Note: You must agree to the terms of the License Agreement to 
install UM Services. If you click I Disagree, the 
installation program closes.

The Setup Options window opens.
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5. From the Setup Options window, click the 
Workgroup/Enterprise Integration — Installs UM Services 
integration for management environments button.

The Select Components window opens.

6.  Click Intel Alert on LAN Proxy and then click Next.

7. Select a TCPIP port for use by the Alert on LAN Proxy. Then, click 
Next to finish the installation process.
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