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About this book

This book provides information about installing, setting up, and working with IBM® 
Netfinity® FAStT Storage Manager Version 7.02 in a Microsoft® Windows NT® 
operating system environment. This Installation and Support Guide is written for 
system administrators. Use this guide to:

• Determine the hardware and software that are required to install the storage-
management software.

• Integrate the necessary hardware components into your network.

• Install the storage-management software.

• Upgrade controller firmware, if necessary.

• Identify storage-management features that are unique to Windows NT.

How this book is organized
Chapter 1, “Introduction,” on page 1 provides an overview of IBM Netfinity FAStT 
Storage Manager Version 7.02 and describes storage-subsystem management 
methods, configuration types, types of installations, and installation requirements.

Chapter 2, “Preparing for installation,” on page 15 discusses preparing for a network 
installation, including setting up a Microsoft DHCP server or a UNIX BOOTP server, 
and describes other setup tasks.

Chapter 3, “Installing software in a standard configuration,” on page 29 gives the 
procedure for installing the software in a standard (noncluster) environment.

Chapter 4, “Installing software in a cluster server environment,” on page 39 gives the 
procedure for installing the software in a cluster server environment and upgrading 
from a previous version of the storage-management software.

Chapter 5, “Completing the installation,” on page 55 describes Enterprise 
Management and Subsystem Management, changing NVSRAM configuration 
settings, and completing the installation tasks.

Chapter 6, “Migration process,” on page 61 provides the procedure for upgrading 
storage-management software version 6.22 to IBM Netfinity FAStT Storage Manager 
Version 7.01, updating RDAC on the host computer, installing MSVM and SM7agent 
on the host computer, and migrating from firmware 3.x to 4.x on the RAID controllers.

Chapter 7, “Operating-system support,” on page 73 discusses Windows NT 
restrictions and using the Hot Add utility, SM7devices utility, and other software 
features.

Appendix A, “Notices,” on page 77 provides product notices and trademark 
information.

Appendix B, “Storage subsystem/controller information record,” on page 79 provides 
a data sheet that you can copy and record information about your hardware devices. 
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Notices used in this book
This book contains notices to highlight information or provide safety information:

• Notes

These notices provide important tips, guidance, or advice.

• Important

These notices provide information that might help you avoid inconvenient or 
problem situations.

• Attention

These notices indicate possible damage to programs, devices, or data. An 
attention notice is placed just before the instruction or situation in which damage 
could occur.

Related publications
The following publications are available in Adobe Acrobat Portable Document Format 
(PDF) on the IBM Netfinity FAStT Storage Manager CD and on the World Wide Web 
at http://www.ibm.com/pc/support/

Note: The items that are denoted by an asterisk (*) in the list indicate publications 
that are printed and come with the IBM FAStT200 and FAStT200 High 
Availability (HA) Storage Servers.

• IBM Netfinity FAStT Storage Manager Version 7.02 for Windows NT Installation 
and Support Guide (this book)

• IBM Netfinity FAStT Storage Manager Version 7.02 for Windows 2000 Installation 
and Support Guide

• IBM FAStT200 and FAStT200 HA Storage Servers Installation and User’s Guide*

• IBM Netfinity FAStT500 RAID Controller Enclosure Unit Installation Guide

• IBM Netfinity FAStT500 RAID Controller Enclosure Unit User’s Reference

• IBM Netfinity Fibre Channel Storage Manager Concepts Guide

• IBM Netfinity Fibre Channel RAID Controller Unit User’s Handbook

When you complete the tasks in this Installation and Support Guide, refer to the 
following online Help systems.

• IBM Netfinity FAStT Storage Manager Version 7.02 Enterprise Management 
online Help. Use this help system for more information about working with the 
management domain.

• IBM Netfinity FAStT Storage Manager Version 7.02 Subsystem Management 
online Help. Use this help system for more information about managing storage 
subsystems.

You can access the help systems from the Enterprise Management and Subsystem 
Management windows in Netfinity FAStT Storage Manager Version 7.02. Click Help 
on the toolbar or press F1.

The help systems contain operating information that is common to all operating 
environments. Refer to this Installation and Support Guide for information that is 
specific to Windows NT.
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Additional publications are available for purchase from IBM. For a list of publications 
available in your country:

• In the U.S. and Puerto Rico, call 1-800-426-7282.

• In the United Kingdom, call 01705-565000 or 0161-9056001.

• In Canada, call 1-800-465-1234.

• In other countries, contact the IBM support organization that services your area, 
your IBM marketing representative, or your IBM reseller.
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Chapter 1.  Introduction

IBM Netfinity FAStT Storage Manager Version 7.02 for Windows NT is a Java-based 
tool that simplifies the management of the Netfinity Fibre Array Storage Technology 
(FAStT)200 and FAStT200 HA Storage Servers, Netfinity FAStT500 RAID Controller 
Enclosure Unit, and Netfinity Fibre Channel RAID Controller Unit. Netfinity FAStT 
Storage Manager Version 7.02 was formerly known as Netfinity Fibre Channel 
Storage Manager 7.

The Netfinity FAStT Storage Manager Version 7.02 software presents an interface for 
storage management based on information supplied by the storage subsystem 
controllers. You can install the storage-management software on a management 
station, which is the system that is responsible for managing all, or a portion of, a 
network. The management station communicates with network management agents 
that reside in the managed node by means of a network management protocol, such 
as Simple Network Management Protocol (SNMP). When you manage a storage 
subsystem using the client software that is installed on a management station, 
commands are sent to the storage subsystem controllers. The controller firmware 
contains the necessary information to carry out the storage-management commands. 
The controller is responsible for validating and running the commands and providing 
status and configuration information back to the client software.

Throughout this book, the terms storage-management software and Storage Manager 
7.02 refer to the IBM Netfinity FAStT Storage Manager Version 7.02 for Windows NT 
software. Individual components of the storage-management software are identified 
by name.

Terms to know
If you are upgrading from a previous version of the storage-management software, 
you will find that some of the terms you are familiar with have changed. It is important 
that you familiarize yourself with the new terminology. Table 1 on page 2 provides a 
list of some of the old and new terms. For more information, refer to the IBM Netfinity 
Fibre Channel Storage Manager Concepts Guide.

Product name

Product 
release 

firmware 
version

Released storage-
management 

software version

Machine 
type Model

IBM FAStT200 4.x 7.02 3542 1RU

IBM FAStT200 HA 4.x 7.02 3542 2RU

Netfinity Fibre Channel RAID Controller Unit 3.x, 4.x 6.22, 7.0, 7.01, 7.02 3526 1RU

Netfinity FAStT500 RAID Controller Enclosure Unit 4.x 7.01, 7.02 3552 1RU
 © Copyright IBM Corp. 2000  1



It is important to understand the distinction between the following two terms when 
reading this document.

Management station
A system that is used to manage the storage subsystem. This system does not need 
to be attached to the storage subsystem through the Fiber Channel I/O path.

Host/Host computer
The terms host and host computer are used interchangeably throughout this 
document. Both terms refer to a system that is directly attached to the storage 
subsystem through a Fibre Channel I/O path. This system is used to serve data 
(normally in the form of files) from the storage subsystem.

Note: A system can be both a management station and a host server at the same 
time.

Software components
Storage Manager 7.02 contains the following software components:

• Client software

• Host-agent

• RDAC package

• Migrate utility

Client software
The Storage Manager 7.02 client (SM7client) component provides the graphical user 
interface for managing storage subsystems through the Ethernet network or from the 
host. The SM7client contains two main components:

• Enterprise Management for adding, removing, and monitoring storage 
subsystems within the management domain.

• Subsystem Management for managing the components of an individual storage 
subsystem.

Host-agent package
The Storage Manager 7.02 Agent (SM7agent) consists of two software components:

• Host-agent software. You can use the host-agent software to manage storage 
subsystems through the host Ethernet connection. The host-agent software takes 
requests from a management station that is connected to the host through an 
Ethernet connection and passes the requests to the storage subsystem 
controllers through the Fibre Channel I/O path. For more information about 
managing storage subsystems through the host-agent, see “Host-agent managed 
method” on page 4.

Table 1. Old and new terminology 

Term used in previous versions New term

RAID module Storage subsystem

Drive group Array

Logical Unit (LUN)1 Logical drive

1 In Storage Manager 7.02, the term Logical Unit Number (LUN) designates a logical address used by the host to 
access a particular logical drive.
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• SM7device utility. You can use the SM7devices utility to associate storage 
subsystem logical drives with operating system device names. For more 
information about using SM7devices, see “Using the SM7devices utility” on page 
76.

RDAC package
The Redundant Disk Array Controller (RDAC) package contains two software 
components:

• RDAC multipath device driver. The RDAC multipath device driver provides 
failover support to the other controller if a component along the Fibre Channel I/O 
path fails.

• Hot Add utility. You can use the Hot Add utility to register newly created logical 
drives with the operating system. For information on using the Hot Add utility, see 
“Using the Hot Add utility” on page 75. 

Migration package
You can use the Storage Manager 7.02 migrate utility (SM7migrate) to upgrade 
controller firmware for model 3526 and download default configuration settings to 
NVSRAM so you can manage existing storage subsystems with Storage Manager 
7.02.

Important: Storage Manager 7.02 operates with only controllers using firmware 
version 4.x. If you want to manage controllers with Storage Manager 7.02, 
you must upgrade the firmware to version 4.x. You must use version 6.22 
of the storage-management software to manage storage subsystems with 
controllers using firmware version 3.x. For more information, see 
“Installation types” on page 10.

You can use the migration procedure to perform the following tasks:

• Migrate from storage-management software version 6.22 to Netfinity FAStT 
Storage Manager Version 7.02 on one or more management stations.

• Update RDAC on one or more host computers.

• Install Microsoft Virtual Machine (MSVM) and SM7agent on one or more host 
computers.

• Migrate from firmware 3.x to 4.x on the Redundant Array of Independent Disks 
(RAID) controllers in an IBM Netfinity Fibre Channel RAID Controller Unit, model 
3526-1RU.

For more information, see Chapter 6, “Migration process,” on page 61. 

Storage subsystem management methods
The storage-management software provides two methods for managing storage 
subsystems — the host-agent managed method and the directly managed method. 
Depending on your specific storage subsystem configurations, you can use either or 
both methods.
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Host-agent managed method
When you use this method, you manage the storage subsystems through the Fibre 
Channel I/O path to the host. The storage subsystem can be managed from the host 
computer or management station that is attached to the host through an Ethernet 
connection.

The advantages of managing storage subsystems through the host-agent include:

• You do not have to run Ethernet cables to the controllers.

• You do not need a BOOTP server to connect to the network.

• You do not need to perform the controller network configuration tasks that are 
described in Chapter 2, “Preparing for installation,” on page 15.

• When adding devices, you have to specify a host name or IP address only for the 
host instead of for the individual controllers in a storage subsystem. Storage 
subsystems that are attached to the host are automatically discovered.

The disadvantage of using the host-agent method include: 

• You are limited to configuring one less Logical Unit Number (LUN) than the 
maximum number that is allowed by the operating system and the host adapter 
that you are using.

• The host-agent requires a special logical drive, called an access volume, to 
communicate with the controllers in the storage subsystem.

Note: The access volume uses one of the logical unit numbers (LUNs). Windows NT 
allows a maximum number of LUNs depending on which Service Pack is 
installed and which host adapter you are using. For more information, see 
“Number of supported logical drives” on page 74.

If you are upgrading controllers from firmware version 3.x to version 4.x and your host 
system has already configured its maximum number of LUNs, you must give up a 
LUN to be used as an access volume.
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Figure 1 shows a system in which storage subsystems are managed through the 
host-agent.

Figure 1. Host-agent managed storage subsystems

Directly managed method
When you use this method, you manage storage subsystems directly over the 
network through the Ethernet connection to each controller. To manage the storage 
subsystem through these Ethernet connections, you must define the IP address and 
host name for each controller and attach a cable to the Ethernet connectors on the 
storage subsystem controllers.

Ethernet

Host computer

Controller

Controller

Controller

Controller

Fibre Channel
I/O path

Management station
(one or more)

Running the
host-agent software

Storage subsystems

Note: The host can act as a
management station also.
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The advantages of managing storage subsystems directly include:

• The Ethernet connections to the controllers enable a management station running 
Windows NT to manage storage subsystems that are connected to a host with an 
operating system other than those that are supported by Storage Manager 7.02.

• You do not need to use an access volume to communicate with the controllers as 
you do if you are running the host-agent software. You can configure the 
maximum number of LUNs that are supported by the operating system and the 
host adapter that you are using.

The disadvantages of managing storage subsystems directly include:

• It requires two Ethernet cables to connect both storage subsystem controllers to a 
network.

• When adding devices, you must specify an IP address or host name for each 
controller.

Note: Controller machine type 3526 requires an attachment unit interface (AUI) 
transceiver to attach to an RJ-45 connector.

• A BOOTP server and network preparation tasks are required. For a summary of 
the preparation tasks, see Table 8 on page 16.

Figure 2 shows a system in which storage subsystems are managed directly.

Figure 2. Directly managed storage subsystems
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Management station
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Configuration types
You can install Storage Manager 7.02 in either of two configurations:

• Standard (noncluster) configuration

• Cluster server configuration

Standard (noncluster) configuration
Table 2 describes where the storage-management software components are installed 
in a standard configuration (not a cluster server configuration).

Table 2. Where to install software components in a standard (noncluster) configuration 

Software component Where installed Notes

Storage Manager 7.02 client 
(SM7client)

You can install the SM7client package 
on either of the following:

• Management station (for direct or 
host-agent management)

• Host computer (for a non-
network configuration similar to 
previous versions of the storage-
management software)

• Management stations 
If you install the SM7client software on one o
more management stations, you can choose
to manage storage subsystems directly 
through Ethernet connections to the 
controllers, over the network through the hos
agent, or a combination of both methods.

• Host computer
If you install the SM7client software on the 
host computer, the host computer does not 
need to be connected to a network as long a
the host-agent software is installed. Howeve
the host computer must have the TCP/IP 
software installed and you must assign a 
static IP address to the host.

RDAC Host computer The RDAC component is required for controller 
failover support and for installing and using the 
host-agent software. Make sure that you install 
RDAC on each host connected to the storage 
subsystem.

Microsoft Virtual Machine 
(MSVM)

Host computer The Microsoft Virtual Machine is a required 
component for installing and using the software 
that is contained in the host-agent package.

Storage Manager 7.02 agent 
(SM7agent)

Host server You must install the SM7agent software even if 
you choose not to manage storage subsystems 
with the host-agent software. The host-agent 
contains important utilities that are necessary for
operating the storage-management software.
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The following figure shows an example of a standard (noncluster) configuration, 
including a management station. You can install the SM7client on a stand-alone host 
computer if that host has the Transmission Control Protocol/Internet Protocol 
(TCP/IP) software installed and the host has a static IP address. If you want to 
manage storage subsystems with the host-agent software, you must also install the 
Microsoft Virtual Machine (MSVM) on the host.

Figure 3. Sample standard (noncluster) configurations

Cluster server configuration
Table 3 on page 9 describes the storage-management software components that you 
can install in a cluster server environment.

Important: Be sure to install all storage-management software components on each 
server in your cluster.

Ethernet

Host computer

Controller

Controller

Controller

Controller

Fibre Channel
I/O path

Management station

RDAC, Microsoft
VM, and host-agent

The client software is
installed on one or more

management systems,
or on the host computer.

Storage subsystems
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Table 3. Where to install software components in a cluster server configuration 

Software component Where installed Notes

Storage Manager 7.02 client 
(SM7client)

You can install the SM7client package 
on either of the following:

• Management station (for direct or 
host-agent management)

• Nodes A and B (for direct or host-
agent management)

• Management stations 
If you install the SM7client software on 
one or more management stations, you 
can choose to manage storage 
subsystems directly through Ethernet 
connections to the controllers, over the 
network through the host-agent, or a 
combination of both methods.

• Nodes A and B
If you install the SM7client on the 
cluster servers (nodes A and B), the 
server does not need to be connected 
to a network as long as the host-agent 
software is installed. However, the host 
computer must have the TCP/IP 
software installed, and you must assign 
a static IP address to the cluster server.

RDAC Nodes A and B The RDAC component is required for 
controller failover support and for installing 
and using the host-agent software. Make 
sure that you install RDAC on each host 
connected to the storage subsystem.

Microsoft Virtual Machine 
(MSVM)

Nodes A and B The Microsoft Virtual Machine is a required 
component for installing and using the 
software that is contained in the host-agent 
package.

Storage Manager 7.02 agent 
(SM7agent)

Nodes A and B You must install the host-agent even if you 
choose not to manage storage subsystems 
with the host-agent software. The host-
agent contains important utilities that are 
necessary for operating the storage-
management software.
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The following figure shows an example of a cluster server configuration.

Figure 4. Sample cluster server configuration (single loop)

Installation types
To install Storage Manager 7.02, choose the installation type in the following list that 
represents the setup of your enterprise.

• New storage subsystem environment. You do not have existing storage 
subsystems. In this case, you are installing new storage subsystems with 
machine type 3526, 3552, or 3542 controllers using firmware version 4.x and 
intend to manage these new storage subsystems using Storage Manager 7.02. 
To proceed with this installation, go to “System requirements” on page 13.

• Existing storage subsystem environment. You have existing storage 
subsystems. Table 4 on page 11 explains your options for managing these 
existing storage subsystems.

Ethernet

Fibre Channel
I/O path

Management station
(one or more)

Cluster server
node A

Cluster server
node B

RDAC, Microsoft
VM, and SM7agent

Controller

Controller

Storage subsystems

Managed hub or
switch

The SM7client software
is installed on one or more
management stations, or
on the cluster servers.
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Managing new and existing storage subsystems attached to the same 
host

When installing Storage Manager 7.02, you must determine how you will use any 
existing storage subsystems. Existing storage subsystems are coexisting storage 
subsystems when they are attached to the same host as storage subsystems 
managed with Storage Manager 7.02, and when the conditions in Table 5 are met.

Table 4. Configurations for existing storage subsystems 

Existing storage subsystems 
with: Options

Machine type 3526 controllers 
running firmware version 3.x

Option 1 —Upgrade the controller firmware to version 4.x and manage the 
storage subsystems with Storage Manager 7.02. Go to “System 
requirements” on page 13. 

Option 2 —Install new storage subsystems and attach them to the same 
host as the existing storage subsystems. These existing and new storage 
subsystems are referred to as coexisting storage subsystems. See 
“Managing new and existing storage subsystems attached to the same 
host” for more information.

Option 3 —Continue to use version 6.22 of the storage-management 
software to manage these storage subsystems if they are attached to 
separate hosts from those that are attached to storage subsystems 
managed with Storage Manager 7.02. Go to “System requirements” on 
page 13.

Machine type 3526 and 3552 
controllers running firmware 
versions from 4.00.00 through 
4.00.01

Option 1 — Uninstall the previous version of the storage-management 
software; then, install Storage Manager 7.02. After you install Storage 
Manager 7.02, upgrade the controller firmware from versions 4.00.00 
through 4.00.01 to version 4.00.02 and manage these existing storage 
subsystems with Storage Manager 7.02. Go to “System requirements” on 
page 13.

Option 2 — Continue using your existing version 4.00.00 through 4.00.01 
controller firmware. Uninstall the previous version of the storage-
management software; then, install Storage Manager 7.02. You can 
manage these existing storage subsystems through Storage Manager 7.02, 
which includes components that are compatible with these older firmware 
versions. The functional differences between your existing controller 
firmware and controller firmware 4.00.02 are provided on the installation 
CD. For more information, refer to the README file located in the \NT\ 
directory on the installation CD. Go to “System requirements” on page 13.

Table 5. Coexisting storage subsystems requirements 

Existing storage subsystems New or upgraded storage subsystems

• Use 3.01.x firmware

• Are managed with version 6.22 of the 
storage-management software

Note: Firmware and software levels are the 
minimum levels required for machine 
type 3526 controllers to coexist with 
new or upgraded storage 
subsystems.

• Use 4.x firmware

• Are managed with Storage Manager 
7.02
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Figure 5 shows an example of an environment that includes coexisting storage 
subsystems.

Important: The RDAC software packaged with Storage Manager 7.02 overwrites the 
RDAC driver associated with version 6.22 of the storage-management 
software. Figure 5 shows an example of coexisting storage subsystems 
(new and previously installed storage subsystems attached to the same 
host); the two versions of the storage-management software that are 
installed will use the newly installed RDAC driver. 

Figure 5. Sample coexistence installation
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I/O path

Management station
(one or more)

Management station
(one or more)
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and host-agent
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Important:
Both versions of the storage-
management software share a
common RDAC - the one you
install with Storage Manager 7.02.
This new RDAC overwrites any
previous version of RDAC.

Version 6.22 of the storage-management
software must be installed on either a
management station (network version)
or on the host.

Firnware version
3.01.x (minimum)

Firmware version 4.x
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System requirements
This section provides detailed information about the hardware, software, and 
operating requirements for Storage Manager 7.02.

Hardware requirements
The following table lists the hardware required for installing Storage Manager 7.02.

Table 6. Hardware requirements for the storage-management software 

Hardware component Requirements

A BOOTP server 
(for directly managed 
storage subsystems only).

• Microsoft BOOTP-compatible DHCP server for 
Windows NT

• UNIX® BOOTP server

Storage subsystems 
(one or more).

Storage subsystems with controllers running firmware version 
4.00.00 through 4.00.02

Note: Make sure that you read “Installation types” on page 10 
for information on managing these storage subsystems 
when existing storage subsystems are physically 
connected to the same host that you will connect to the 
new storage subsystems.

Fibre Channel (FC) host 
adapters.

The following Fibre Channel host adapters were tested with the 
storage-management software:

• IBM Netfinity FAStT Host Adapter 
(part number: 00N6881)

For information on specific host adapter requirements:

• Refer to the README file in the \NT\Host_Adapter 
directory on the installation CD.

• Read the host adapter documentation.

• Refer to the IBM Web site, http://www.ibm.com/pc/support

Fibre Channel (FC) fabric 
switches (if needed for the 
desired configuration).

The following Fibre Channel fabric switches were tested with 
the storage-management software:

• IBM 8-port Fibre Channel switch 
(machine type: 2109-S08)

• IBM 16-port Fibre Channel switch 
(machine type: 2109-S16)

For specific Fibre Channel switch setup requirements:

• Read the switch documentation.

• Refer to the IBM Web site, http://www.ibm.com/products

Fibre Channel (FC) 
managed hub (if needed for 
the desired configuration).

The following managed hub was tested with the storage-
management software:

• IBM Fibre Channel managed hub 
(machine type: 3534)

For specific Fibre Channel managed hub setup requirements:

• Read the managed hub documentation.

• Refer to the IBM Web site, http://www.ibm.com/products
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Firmware requirements
Storage Manager 7.02 operates only with controller machine type 3526, 3552 or 3542 
and firmware version 4.00 or later. If you want to manage controllers with Storage 
Manager 7.02, you must upgrade the firmware to version 4.00 or later. You must use 
version 6.22 of the storage-management software to manage storage subsystems 
with controllers using firmware version 3.x.

Software requirements
The following table contains the installation requirements for each of the software 
packages.

Operating system requirements
For management stations, install one of the following operating systems:

• Windows NT Server 4.0 with Service Pack 5 or greater

• Windows NT Workstation 4.0 with Service Pack 5 or greater

For hosts, install one of the following operating systems:

• Windows NT Server 4.0 with Service Pack 5 or greater

• Windows NT 4.0 Enterprise Edition with Service Pack 5 or greater

For cluster servers, install Windows NT 4.0 Enterprise Edition with Service Pack 5 or 
greater.

Table 7. Installation requirements by software package 

Requirement Software

SM7client RDAC Microsoft VM SM7agent SM7 migrate

Available disk 
space

20 MB 1 MB 1 MB 1 MB 10 MB

Administrator 
privileges

Not required Required Required Required Required

Minimum 
display settings

800 x 600 pixels, 
256 colors

640 x 480 pixels, 
256 colors1

640 x 480 pixels, 
256 colors1

640 x 480 pixels, 
256 colors1

640 x 480 pixels, 
256 colors1

1 These settings are for the Install Shield installation of the software.
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Chapter 2.  Preparing for installation

This chapter helps you plan and prepare for installing the storage-management 
software.

Deciding how to manage storage subsystems
If you have not already done so, see Chapter 1, “Introduction,” on page 1 for 
information about the following two methods for managing storage subsystems:

• Direct management through an Ethernet connection to each controller on the 
storage subsystem

• Host-agent management through the host-agent software that is installed on the 
host computer that is connected to the storage subsystem

You can use one or both methods. However, because many of the preparation tasks 
for installation depend on which method you use, before you begin, decide how you 
want to manage the storage subsystems on your network

Reviewing a sample network
Figure 6 on page 16 shows an example of a directly managed storage subsystem 
network setup (see network A). This network contains the following components:

• BOOTP server

• Management station for Simple Network Management Protocol (SNMP) traps

• Host that is connected to a storage subsystem through a Fibre Channel I/O path

• Management station connected by Ethernet cable to the storage subsystem 
controllers

Figure 6 on page 16 shows an example of a host-agent managed storage subsystem 
network setup (see network B). This network contains the following components:

• A host that is connected to a storage subsystem through a Fibre Channel I/O path

• A management station that is connected by Ethernet cable to the host
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Figure 6. Sample network

Preparing for a network installation 
Before you install the storage-management software, make sure that the network 
components are set up and operating properly, and that you have all the host and 
controller information that is needed for the software to operate correctly. To do this, 
perform the tasks that are summarized in Table 8 (referring to the appropriate 
procedures). Use Table 14 on page 79 as a data sheet to record storage subsystem 
and controller information.

Controller

Controller

Controller

Controller

Storage
subsystem

finance

Storage
subsystem
engineering

Fibre Channel
I/O path

Fibre Channel
I/O path

Network A
TCP/IP

Network B
TCP/IP

Ethernet

Router

Network
management

station
(for SNMP traps)

Management
station

(one or more)

Management
station

(one or more)

Host computer
Denver

(IP address
153.79.144.12)

Host computer
Atlanta

(IP address
153.79.144.22)

BOOTP server

Host name: Denver_a
(IP address 153.79.144.13)

hardware address 00.a0.b8.02.04.20
Host name: Denver_b

(IP address 153.79.144.14)
hardware address 00.a0.b8.00.00.d8

Table 8. Network preparation task summary 

Task to perform For direct or host-
agent? Why perform this task? For instructions, see

Step 1- Install all hardware 
components (host 
computers, storage 
subsystems, cables, and 
so on) that you want to 
connect to the network.

Both To ensure that the network 
hardware is present.

The installation guide that is 
specific to the hardware 
components.

Step 2 - Establish and 
record a naming 
convention for the storage 
subsystems that are 
connected to the network.

Both To add the storage subsystems 
to the management domain after 
installing the software.

“Deciding how to name the 
storage subsystems” on page 
18.
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Step 3 - Determine the 
hardware Ethernet address 
for each controller in all 
storage subsystems that 
are connected to the 
network.

Direct To set up the BOOTP server to 
provide network configuration 
information to the controllers.

“Identifying the hardware 
Ethernet address for each 
controller” on page 19.

Step 4 - Obtain IP 
addresses and host names 
from the network 
administrator.

Both For host-agent management, 
you need the IP addresses and 
host names of the host on which 
the host-agent software will run.

For direct management, you 
need the IP addresses of each 
controller in the storage 
subsystems. The IP addresses 
are used to configure the 
BOOTP server so that it can 
provide network configuration 
information to the controllers. 
Also, you use the IP addresses 
of the controllers to set up the 
host or Domain Name System 
(DNS) table.

“Obtaining IP addresses for 
hosts and controllers” on 
page 20.

Step 5 - Set up the BOOTP 
server to provide network 
configuration information 
for a specific controller.

Direct To provide network configuration 
information to the controllers, 
using the BOOTP server.

“Setting up the BOOTP 
server” on page 21.

Step 6 - Verify that the 
TCP/IP software is 
installed, and set up the 
host or DNS table.

Direct Installing the client software on a 
management station ensures 
that the management station is 
configured to reach the 
controllers over the network. If 
the client software is installed on 
the host, the TCP/IP software is 
still necessary for successful 
communication between the 
client software and the 
controllers.

“Verify the TCP/IP software 
and set up the host or DNS 
table” on page 26.

Step 7 - Power on the 
devices that are connected 
to the network.

Both To ensure that all devices and 
links are operational.

The installation guide that is 
specific to the hardware 
components.

Table 8. Network preparation task summary 

Task to perform For direct or host-
agent? Why perform this task? For instructions, see
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Table 9 shows a sample information record with entries for a directly managed 
storage subsystem and a host-agent managed storage subsystem. 

Table 14 on page 79 provides a data sheet on which you can record storage 
subsystem names, management types, hardware Ethernet addresses, and IP 
addresses. Make a copy of this table and complete the information for your storage 
subsystems and controllers. Use the information that is recorded in Table 14 on page 
79 to set up the BOOTP table for the network server and the host or Domain Name 
System (DNS) table. The information in Table 14 on page 79 helps you add storage 
subsystems after initial installation. The column headings show a page reference for 
detailed instructions about obtaining the information. For a sample information record, 
see Table 9.

Deciding how to name the storage subsystems
As you set up your network, decide on the naming convention for the storage 
subsystems. After you install the storage-management software and start it for the 
first time, all storage subsystems in the management domain display as <unnamed>. 
Use the Subsystem Management window to rename the individual storage 
subsystems.

The following list provides tips for naming storage subsystems:

• There is a 30-character limit. All leading and trailing spaces are deleted from the 
name.

• Use a unique, meaningful naming scheme that is easy to understand and 
remember.

• Avoid arbitrary names or names that would quickly lose their meaning in the 
future.

• The software displays storage-subsystem names with the prefix Storage 
Subsystem. Therefore, if you rename a storage subsystem to Engineering, it 
displays as Storage Subsystem Engineering.

After you decide on a naming scheme, record the storage subsystem names in the 
information record (Table 14 on page 79).

If you are directly managing your storage subsystem, go to “Identifying the hardware 
Ethernet address for each controller” on page 19. If you are going to manage your 

Table 9. Sample information record 

Storage subsystem 
name

(see page 18)

Management type 
(see page 15)

Controllers—Ethernet and IP addresses, 
and host name

(see pages 19 and 20)

Host—IP address 
and host name
(see page 20)

Storage Subsystem 
Finance

Direct Hardware Ethernet 
address = 
00a0b8020420

Hardware Ethernet 
address = 
00a0b80000d8

IP address = 
153.79.144.13

IP address = 
153.79.144.14

Host = Denver_a Host = Denver_b

Storage Subsystem 
Engineering

Host-agent IP address = 
153.79.144.22

Host = Atlanta
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storage subsystem through the host-agent, go to “Obtaining IP addresses for hosts 
and controllers” on page 20.

Identifying the hardware Ethernet address for each controller
Use the following procedure if you plan to directly manage storage subsystems 
through Ethernet connections to each controller. If you plan to manage storage 
subsystems using the host-agent software, skip this procedure and go to “Obtaining 
IP addresses for hosts and controllers” on page 20.

1. Remove the front bezel (machine types 3526 and 3552), from the controller unit, 
as shown in Figure 7. Carefully pull the bottom of the bezel out to release the pins 
�1�; then slide the bezel down �2�.

Figure 7. Removing the controller-unit bezel (machine types 3526 and 3552)

2. Unlock and open the levers on the RAID controllers, models 3526 and 3552.

Figure 8. Location of the hardware Ethernet address (machine types 3526 and 3552)

Hardware Ethernet
address label
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Figure 9. Location of the hardware Ethernet address (machine type 3542)

3. The controller hardware Ethernet address labels are located on the front of each 
controller, as shown in Figure 8 on page 19 and Figure 9.

The number will be in the form xx.xx.xx.xx.xx.xx (for example, 00.a0.b8.00.00.d8).

4. Record each Ethernet address in the information record (Table 14 on page 79).

5. To replace the bezel (machine types 3526 and 3552), slide the top edge under the 
lip on the chassis �1�; then push the bezel bottom until the pins snap into the 
mounting holes �2�, as shown in Figure 10.

Figure 10. Replacing the controller-unit bezel on models 3526 and 3552

6. Continue with “Obtaining IP addresses for hosts and controllers”.

Obtaining IP addresses for hosts and controllers

Hardware Ethernet
address label

If you want to Go to

Manage storage subsystems directly Step 1

Manage storage subsystems with the host-agent Step 2

Note: If you intend to manage some storage subsystems directly and others with the host-
agent software, complete both of the following steps.
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1. Assign (or obtain from your network administrator) a unique IP address and 
associated host name for each controller in every storage subsystem on the 
network. Record the IP address and host name for each controller in the 
information record (Table 14 on page 79). Then, go to “Setting up the BOOTP 
server”.

2. Contact your network administrator to obtain the IP address and host name for 
each host on which you plan to install the host-agent software for managing 
storage subsystems. Record the IP address and host name for the host in the 
information record (Table 14 on page 79). Then, go to “Verify the TCP/IP software 
and set up the host or DNS table” on page 26.

Setting up the BOOTP server
If you plan to directly manage storage subsystems through the Ethernet connection to 
each controller, select the procedure you plan to use for setting up the BOOTP server: 

• When using a Microsoft BOOTP-compatible DHCP server, go to “Using Microsoft 
DHCP as a BOOTP-compatible server”.

• When using a UNIX BOOTP server, go to “Using a UNIX BOOTP server” on page 
25.

If you plan to manage storage subsystems using the host-agent software, go to “Verify 
the TCP/IP software and set up the host or DNS table” on page 26. 

Using Microsoft DHCP as a BOOTP-compatible server
You must use a version of DHCP that supports BOOTP static addressing. To use a 
DHCP server, you must have a DHCP Manager installed. If a DHCP Manager is 
installed on the system, go to “Setting up a DHCP server”. If a DHCP Manager is not 
installed, use the following installation procedure.

Installing the DHCP manager
Use the following procedure to install the DHCP Manager:

1. Click Start → Settings → Control Panel.

2. Double-click the Network icon.

3. In the Network window that opens, click the Services tab.

4. Click DHCP Server Network Services → Add.

5. Reinstall Windows NT Service Pack 5 or greater to get new DHCP settings or 
information that is associated with the respective service pack.

6. Continue with “Setting up a DHCP server”.

Setting up a DHCP server
Use the following procedure, along with Table 14 on page 79, to set up the DHCP 
server. 

Note: The following steps and window examples assume that you are configuring a 
Windows NT DHCP server using its DHCP Manager.

1. Click Start → Programs → Administrative Tools → DHCP Manager.

The DHCP Manager window opens.

2. Create a scope. A scope defines a group of controllers that you want to configure 
using the DHCP server. 

a. Click Local Machine.

b. Click Scope → Create.

The Create Scope window opens.
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Figure 11. Create scope - (Local) window

c. Type the starting and ending IP addresses of the controllers that you are 
configuring on the network.

For example, if you are configuring 50 controllers on a 153.79.144.0 subnet, 
set the starting address to 153.79.144.1, and set the ending address to 
153.79.144.50. 

Note: If each field does not contain at least three characters, press the 
period (.) key to advance to the next field. If you have only one 
controller, type its address for both the starting and ending addresses.

d. Type the subnet mask (obtained from your network administrator).

e. Set the Lease Duration to Unlimited. This makes the DHCP connection 
permanent.

f. Type a scope name and comment.

g. Click OK.

h. When the scope has successfully completed, click Yes to activate it.

You return to the DHCP Manager window.

3. Use the following procedure to configure global scope options. You can use the 
scope options to configure settings that are applicable to all controllers. To 
determine which parameters to apply to the entire group, see Table 8 on page 16.

Note: You can apply options to specific controllers later using step 5 on page 24.

a. Click DHCP Options → Global.

The DHCP Options: Global window opens.
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Figure 12. DCHP options window

b. Select an item in the Unused Options list, and click Add to move it to the 
Active options list. Each option is preceded by its tag number.

c. Click Value to assign a value to the active option.

If Value is not selectable, the Edit Array option window opens in the lower 
part of the window.

d. If you need to add an IP address, click Edit Array.

The IP Address Array Editor window opens.

Figure 13. IP address array editor window

Figure 13 shows an example of adding the IP address for a management 
station.

If you do not need to add an IP address, go to step 3g.

e. Type the unique IP address for the option that you added.

f. Click Add to move the New IP Address to the IP Addresses list.

g. Click OK.

You return to the DHCP Options: Global window.

h. Repeat step 3b through step 3g until all global options are added.

i. When you finish adding the Global Scope Options, click OK at the DHCP 
Options: Global window. 

You return to the DHCP Manager window. 
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4. Use the following procedure to create a reservation for each controller. Use the 
data sheet that you created from Table 14 on page 79 to make sure that you 
include all of the controllers for every storage subsystem on the network.

a. Click Scope → Add Reservations.

b. In the IP Address field, type the IP address for the first controller on your data 
sheet.

c. In the Unique Identifier field, type the controller hardware Ethernet address.

d. In the Client Name field, type the controller eight-character name.

e. Click Add.

f. Repeat step 4b through step 4e for each controller that is listed in your data 
sheet. See Table 14 on page 79.

g. When you finish typing the information for all of the controllers, click Close. 

You return to the DHCP Manager window.

5. Use the following procedure to configure controller-specific options. By creating a 
controller-specific option, you can associate a controller configuration entry with a 
specific controller that you added in step 4.

Note: If you set an option as Global Scope, it applies to every controller in this 
group and does not need to be added again.

a. Click Scope → Active Leases.

The Active Leases window opens.

Figure 14. Active Leases window

b. Select a controller in the list.

c. Click Properties.

The Add Option Type window opens. The Unique Identifier is the hardware 
Ethernet address that you added in step 4c.
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Figure 15. Add option type window

d. Click Options.

The DHCP Options: Reservations window opens.

e. Select an entry in the Unused Options list, and click Add to move it to the 
Active Options list.

f. Click Value to assign a value to the active option.

g. Type the information for the value of the option.

For example, for Host Name, type the host name for the controller (from your 
data sheet, see Table 14 on page 79) in the String field. Click Edit if the value 
that you need to add is an IP address for a router.

h. Repeat step 5e through step 5g until you finish adding specific options for this 
controller.

i. Click OK. 

 You return to the Add Option Type window.

j. Click OK.

You return to the Active Leases window.

k. Repeat step 5b on page 24 through step 5j until you finish adding controller-
specific options for every controller.

l. When you finish adding specific options for all controllers, click OK at the 
Active Leases window. You return to the DHCP Manager window.

6. Continue with “Verify the TCP/IP software and set up the host or DNS table” on 
page 26.

Using a UNIX BOOTP server
Table 10 and Table 14 on page 79 provide information for setting up the BOOTP table 
and making the required entries to support the controllers in the storage subsystems. 
Use a text editor to edit the bootptab file in the /etc directory.

Table 10. Required entries for setting up the UNIX BOOTP server 

Entry Description Sample format in 
BOOTP server

Subnet mask Mask that is used to route packets to defined 
subnets.

dot notation 
(sm=255.255.248.0)

Router IP address of the host computer that routes 
packets to networks.

dot notation 
(gw=153.79.144.2)
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Note: The RMS and NMS entries used in previous versions of storage-management 
software version 6.22, are not required when using Storage Manager 7.02 to 
manage storage subsystems with controllers running firmware version 4.x.

Example for editing a UNIX BOOTP table
The following example of a BOOTP table assumes that you are configuring a UNIX 
BOOTP server, such as a server on Network A, as shown in Figure 6 on page 16. The 
s4.default:\ entry denotes settings that are common to all controllers. The 
tc=s4.default:\ entry associates this common setting group to a specific controller.

s4.default:\ (common settings)

ht=ether:\

sm=255.255.248.0:\

gw=153.79.144.2:\

hn:

denver_a:\

tc=s4.default:\ (refers to common settings)

ip=153.79.144.13:\

ha=00a0b8020420:

denver_b:\

tc=s4.default:\

ip=153.79.144.14:\

ha=00a0b80000d8:

When you finish setting up the BOOTP table, do the following:

1. Turn on power to the storage subsystems so that the parameters in the BOOTP 
table take effect.

2. After you finish setting up the BOOTP table, go to “Verify the TCP/IP software and 
set up the host or DNS table”.

Verify the TCP/IP software and set up the host or DNS table
Make sure that the host names for the controllers correspond to the appropriate 
internet protocol addresses for the controllers. Use the following procedure to verify 

Host name for 
the controller

Host name that is associated with the controller 
(see Table 14 on page 79).

host name
(Denver_a)

IP address IP address of the controller (see Table 14 on page 
79).

dot notation 
(ip=153.79.144.13)

Ethernet 
address

The Ethernet address of the controller hardware 
(see Table 14 on page 79).

hexadecimal notation 
(ha=00a0b8020420)

Table 10. Required entries for setting up the UNIX BOOTP server 

Entry Description Sample format in 
BOOTP server
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that the TCP/IP software is installed on the management station and to set up the host 
or Domain Name System (DNS) table.

Note: You might choose to use the Windows Internet Name Service (WINS) rather 
than DNS.

1. Click Start → Settings → Control Panel → Network → Protocols to verify that 
the TCP/IP software is installed and configured property.

Note: If the TCP/IP software did not install properly, install it from the 
Windows NT 4.0 installation CD. Click Start → Settings → 
Control Panel → Network → Protocols → Add → Have Disk.

2. Update either the host or DNS table to specify a host name to associate with an 
IP address. If you do not have a DNS, edit the two host tables that are found in 
the following directories.

c:\winnt\system32\drivers\etc\hosts

c:\winnt\system32\drivers\etc\imhosts

For example, to set up the host tables for the controllers that are connected to 
Network A (Figure 6 on page 16), use a text editor to create the following IP 
address and controller-name entries. 

3. If you want to manage storage subsystems through a firewall, continue with 
“Enabling ports for operation through a firewall”. Otherwise, go to “Preparing to 
install the storage-management software”

Enabling ports for operation through a firewall
If you plan to manage storage subsystems through a packet-filtering firewall, 
configure the firewall to open port 2463 to TCP data.

Preparing to install the storage-management software
You have completed the preparation tasks and are now ready to install the storage-
management software. The installation process that you follow depends on how you 
want to configure the system.

IP Address Host name for the controller

127.0.0.01 localhost

153.79.144.13 denver_a

153.79.144.14 denver_b

If you want to Go to

Install the software in a standard (non-
cluster) configuration

Chapter 3, “Installing software in a standard 
configuration,” on page 29.

Install the software in a cluster server 
environment

Chapter 4, “Installing software in a cluster 
server environment,” on page 39.
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Chapter 3.  Installing software in a standard configuration

This chapter describes how to install the storage-management software in a standard 
(noncluster) configuration.

Important: Always check for a README file on any installation media. This README 
file might contain important information that was not available when this 
Installation and Support Guide was prepared.

Pre-installation process
There are two configurations in which you can install the storage-management 
software:

• You do not have existing storage subsystems. In this situation, you are installing 
new storage subsystems with machine type 3526, 3542, or 3552 controllers using 
firmware version 4.x and will manage these new storage subsystems using 
Storage Manager 7.02. If this is your situation, go to “New installation process” on 
page 30.

• You do have existing storage subsystems with machine type 3526, 3552, or 3542 
controllers. In this situation, you can do one of the following:

— Upgrade the controller firmware on the existing storage subsystems to 
version 4.x and manage them with Storage Manager 7.02.

— Continue to manage the storage subsystems with version 6.22 of the storage-
management software. You might manage these storage subsystems in 
coexistence with new storage subsystems that you are managing with 
Storage Manager 7.02. To determine if you have coexisting storage 
subsystems, see “Managing new and existing storage subsystems attached 
to the same host” on page 11.

Use Table 11 to determine your installation process. 

Table 11. Determining your installation process in a standard (noncluster) configuration 

Current environment Planned environment Action

No existing storage 
subsystems

New storage subsystems with controllers 
that will use version 4.00.02 firmware and 
will be managed with Storage Manager 
7.02.

Go to “New installation process” on page 
30.

Existing storage subsystems 
with controllers that have 
firmware version 3.x 
(machine type 3526) and 
storage-management 
software version 6.22

Upgrade storage subsystems with 
controllers that will use version 4.00.02 
firmware and will be managed with Storage 
Manager 7.02.

Go to Chapter 6, “Migration process,” on 
page 61.
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New installation process
Begin the installation of the storage-management software with “Installing the 
SM7client package” on page 32. Continue the process until you have completed 
“Installing the SM7agent package” on page 37. You do not need to install or use the 
migrate utility. 

Existing storage subsystems 
with controllers that have 
firmware versions 4.00.00 
through 4.00.01 and storage- 
management software 
version 7.00 or 7.01 (machine 
types 3526 and 3552)

Upgrade storage subsystems with 
controllers that will use version 4.00.02 
firmware and will be managed with Storage 
Manager 7.02.

1. Uninstall storage-management 
software version 7.0 or 7.01 using 
the procedures in the Installation 
Guide for the previous version of the 
storage-management software.

2. Go to “New installation process”.

3. Update the NVSRAM and firmware 
to version 4.00.02 using the 
storage-management software 
online help. 

Continue to use your existing versions 
4.00.00 through 4.00.01 controller firmware. 
Be sure to uninstall previous versions of the 
storage-management software before 
installing version 7.02. You can manage 
these existing storage subsystems through 
Storage Manager 7.02, which includes 
components that are compatible with these 
older firmware versions. The functional 
differences between your existing controller 
firmware and controller firmware 4.00.02 is 
provided on the installation CD. Refer to the 
README file located in the \NT\ directory 
on the installation CD for more information.

1. Uninstall storage-management 
software version 7.0 or 7.01 using 
the procedures in the Installation 
Guide for the previous version of the 
storage-management software.

2. Go to “New installation process”.

Table 11. Determining your installation process in a standard (noncluster) configuration 

Current environment Planned environment Action
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Figure 16 shows a flowchart of the installation process. 

Figure 16. Installation process

Installation with existing storage subsystems
Begin this installation with “Installing the SM7client package” on page 32. Continue 
the process until you have completed “Installing the SM7agent package” on page 37. 
Then, if you are upgrading the controller firmware on the existing storage subsystems 
to version 4.x, go to “Installing SM7migrate” on page 66.
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Figure 17 shows a flowchart of the process for an installation with existing storage 
subsystems. 

Figure 17. Installation process for existing storage subsystems

Installing the SM7client package
Use the following procedure to install the SM7client on a management station that is 
configured with one of the following:

• Windows NT Server 4.0 with Service Pack 5 or greater

• Windows NT Workstation 4.0 with Service Pack 5 or greater

Any previously
installed machine type

3526 controllers you want to
manage with Storage

Manager 7?

Any storage
subsystems you want to
migrate at firmware level

3.x or 3.01.03 ?

Yes

No

Yes
3.x

Install the client package

Complete the installation

Use migrate utility to upgrade
firmware on these storage
subsystems from version

3.01.x to 3.01.03

Install the migrate utility

Use migrate utility to download
NVSRAM file

Use migrate utility to upgrade
firmware from version 3.01.03

to 4.00x

Complete the installation

Install the RDAC package

Install the Microsoft Virtual Machine

Install the host-agent package

If the host physically attached to the
storage subsystem is not running the
Windows NT operating system, you will
install only the client package. You also
will install the migrate utility if you want
to use Storage Manager 7 to manage
existing storage subsystems with
machine type 3526 controllers.
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Important notes: 

• If you are configuring only a networked management station, you need to install 
only the SM7client.

• If you want to install SM7client on a stand-alone host and manage storage 
subsystems through the Fibre Channel I/O path rather than over the network, you 
must install the TCP/IP software on the host and assign a static IP address to the 
host. The host operating system must be Windows NT Server 4.0 or Windows NT 
Workstation 4.0.

Installation instructions
Before you install the software, make sure that:

• The management station has at least 20 MB of available disk space.

• The display properties are set to a minimum screen resolution of 800 x 600 pixels 
and a palette of 256 colors or more.

• You close all other programs.

To install the SM7client package:

1. Insert the IBM Netfinity FAStT Storage Manager CD into the CD-ROM drive.

2. Click Start → Settings → Control Panel → Add/Remove Programs. 

The Add/Remove Programs Properties window opens.

3. Click Install, and follow the instructions on the screen.

4. Click Browse.

 The Browse window opens.

5. Select the CD-ROM drive.

6. Select the \NT\SM7client directory.

7. Select the setup.exe file, and then click Open.

8. Click Finish.

The setup program Welcome window opens.

9. Click Next to begin the installation. 

The Choose Destination Location window opens.

10. Click Browse if you want to change the destination location.

11. Click Next.

12. When the installation is complete, click Finish.

Verifying the SM7client installation
Use the following procedure to verify that the installation was successful:

1. Click Start → Programs.

2. Verify that the “Netfinity Fibre Channel Storage Manager client” appears in the list 
of programs.

3. If you are installing SM7client on only a management station, go to Chapter 5, 
“Completing the installation,” on page 55; otherwise, go to “Installing the RDAC 
package” on page 34.
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Installing the RDAC package
Use the following procedure to install the RDAC package on a host computer that is 
connected to one or more storage subsystems.

The RDAC package contains the following components:

• The multipath device driver that is necessary for controller failover support

• The Hot Add utility for dynamically adding logical drives to the operating system 
(see “Using the Hot Add utility” on page 75)

Important: You must install RDAC before installing the SM7agent package.

Assigning drive letters
Note: If you are installing the RDAC software on an existing configuration, go to 

“Installation instructions” on page 35.

The installation procedure installs the RDAC device driver before the native Windows 
NT class device driver. This is necessary to enable the RDAC. However, this means 
that the system recognizes the storage subsystem logical drives before it recognizes 
any local drives, and assigns drive letters accordingly.

Note: Before you install this software, you must have static drive letters assigned to 
the existing local drives.

Use the following procedure to determine if you need to assign static drive letters and 
to assign them, if necessary:

1. Power off the storage subsystem to prevent Disk Administrator (WINDISK) from 
locking up while you are assigning drive letters and installing the RDAC device 
driver.

2. Click Start → Programs → Administrative Tools → Disk Administrator to view 
the disk configuration and check the number of partitions.

• If you have only one partition, go to step 4.

• If you have two partitions, go to step 3.

3. If you have at least two partitions (the boot partition and one other partition) and 
both of the following conditions apply, go to “Installation instructions” on page 35. 

• The last partition that you created was created with Disk Administrator.

• The partition has a drive letter assigned and has a status of Unknown or has 
a file system on it (that is, it has a status other than Unformatted).

4. Use the following procedure to create a new partition.

a. Select a drive containing free disk space.

b. Click Partition → Create. The partition is created (a drive letter is assigned, 
and the partition status is Unformatted).

c. Click Partition → Commit Changes Now. The partition status changes to 
Unknown, and static drive letters are assigned to all existing partitions.

5. Continue with “Installation instructions” on page 35. 
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Installation instructions
Before you install the software, make sure that:

• You have Administrator privileges on the host computer.

• The host computer is configured with Windows NT 4.0 and Service Pack 5 or 
greater.

• The host computer has at least 1 MB of available disk space.

• The display properties are set to a minimum screen resolution of 640 x 480 pixels 
and a palette of 256 colors or more.

• You close all other programs.

Install the RDAC software:

1. Insert the IBM Netfinity FAStT Storage Manager CD into the CD-ROM drive.

2. Click Start → Settings → Control Panel → Add/Remove Programs. 

The Remove Programs Properties window opens.

3. Click Install, and follow the instructions on the screen.

4. Click Browse.

The Browse window opens.

5. Select the CD-ROM drive.

6. Select the \NT\RDAC directory.

7. Select the setup.exe file, and then click Open.

8. Click Finish.

The setup program Welcome window opens. 

9. Click Next to begin the installation.

When RDAC is installed, the Setup Complete window opens. 

10. Click No, I will restart my computer later; then, click Finish.

11. Click Start → Shutdown.

The Shut Down Windows window opens. 

12. Click Shutdown to shut down the server.

13. Power on the storage subsystem.

14. After the storage subsystem is powered on completely, power on the host to 
ensure that the changes take effect.

Verifying the RDAC installation
Use the following procedure to verify that the installation was successful.

1. Click Start → Settings → Control Panel → Devices.

The Devices window opens. 

2. Scroll through the list of devices, and then select symarray.

3. Make sure that the status of the symarray device is Started.

4. Continue with “Installing Microsoft Virtual Machine (MSVM)” on page 36.
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Installing Microsoft Virtual Machine (MSVM)
Use the following procedure to install Microsoft Virtual Machine (MSVM) on a host 
computer that is connected to one or more storage subsystems.

Important: You must install the Microsoft Virtual Machine (MSVM) before installing 
SM7agent. The Netfinity FAStT Storage Manager 7.02 installation CD 
contains a version of Microsoft VM that was tested with the storage-
management software. Before you install this version, go to the Web site 
at http://www.ibm.com/pc/support to see if a newer version of the software 
is available. Also, check the Web site for the latest support information.

Installation instructions
Before you install the software, make sure that:

• You have Administrator privileges on the host computer. 

• The host computer is configured with Windows NT 4.0 and Service Pack 5 or 
greater.

• The host computer has at least 1 MB of available disk space.

• The display properties is set to a minimum screen resolution of 640 x 480 pixels 
and a palette of 256 colors or more.

• You close all other programs.

Install Microsoft Virtual Machine (MSVM) on a host computer:

1. Insert the IBM Netfinity FAStT Storage Manager CD into the CD-ROM drive.

2. Click Start → Settings → Control Panel → Add/Remove Programs. 

The Add/Remove Programs Properties window opens.

3. Click Install, and follow the instructions on the screen.

4. Click Browse. 

The Browse window opens 

5. Select the CD-ROM drive.

6. Select the \NT\SM7agent directory.

7. Select the msjavx86.exe file, and then click Open.

8. Click Finish, and follow the instructions on the screen.

If the program detects newer files, you will be prompted to overwrite the older 
files, click Yes. When the software is installed, the Setup Complete window 
opens. 

If Service Pack 6a is installed, you will be prompted to reboot. Click Yes to restart 
the host. 

Note: You must restart the host to ensure that all changes take effect.

9. After installing SM7agent and restarting the host, reinstall Service Pack 6a. 
Failure to do so will result in the agent service not starting properly.

10. Click Yes to restart the host.

11. Continue with “Installing the SM7agent package” on page 37.
 36 IBM® Netfinity® FAStT Storage Manager Version 7.02 for Windows NT®  Installation and Support Guide  



Installing the SM7agent package
Use the following procedure to install SM7agent on a host computer connected to one 
or more storage subsystems. The SM7agent consists of the following components:

• The host-agent software that is necessary for host-agent management of the 
storage subsystems.

• The SM7devices utility that is used to display the relationship of logical drives to 
operating system device names. For more information, see “Using the 
SM7devices utility” on page 76.

Important: You cannot install SM7agent unless RDAC is installed. The Microsoft 
Virtual Machine is also a required component for installing and using 
SM7agent.

You must install SM7agent even if you do not intend to manage storage 
subsystems through the host-agent software.

Installation instructions
Before you install the software, make sure that:

• You have Administrator privileges on the host computer.

• The host computer is configured with Windows NT 4.0 and Service Pack 5 or 
greater.

• The host computer has at least 1 MB of available disk space.

• The display properties are set to a minimum screen resolution of 640 x 480 pixels 
and a palette of 256 or more.

• You installed RDAC and the Microsoft Virtual Machine (MSVM).

• You close all other programs

Install the SM7agent:

1. Insert the IBM Netfinity FAStT Storage Manager CD into the CD-ROM drive.

2. Click Start → Settings → Control Panel → Add/Remove Programs. 

The Add/Remove Programs Properties window opens.

3. Click Install, and follow the instructions on the screen.

4. Click Browse. 

The Browse window opens.

5. Select the CD-ROM drive.

6. Select the \NT\SM7agent directory.

7. Select the setup.exe file, and then click Open.

8. Click Finish. 

The setup program Welcome window opens.

9. Click Next to begin the installation. 

When SM7agent is installed, the Setup Complete window opens.

Note: You must restart the host to ensure that all changes take effect.

10. Click Finish to restart the host.
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Verifying the SM7agent installation
Use the following procedure to verify that the installation was successful:

1. Click Start → Settings → Control Panel → Services. The Services window 
opens.

2. Scroll through the list of services until you find the “Netfinity Fibre Channel 
Storage Manager 7 agent”.

3. Make sure that the status of the agent service is Started.

Note: If you are not using the host-agent software to manage storage 
subsystems, you can stop the host-agent service. Click Start → 
Settings → Control Panel → Services. Select the host-agent from the list 
of displayed services, and click Startup. Under Startup Type, click 
Manual, and then click OK.

4. Go to Chapter 5, “Completing the installation,” on page 55.
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Chapter 4.  Installing software in a cluster server environment 

This chapter describes how to install the hardware components and storage-
management software in the multi-host configuration, using cluster server software.

Important: Always check for a README file on any installation media. This README 
file might contain important information that was not available when this Installation 
and Support Guide was prepared.

Pre-installation process
There are two configurations in which you can install the storage-management 
software:

• You do not have existing storage subsystems.

• You do have existing storage subsystems.

Before you begin the installation of Storage Manager 7.02, read “Installing the 
hardware” on page 40 to make sure that all hardware components are installed 
correctly for the cluster server configuration. Then, use Table 12 to determine your 
installation process. 

Table 12. Determining your installation process in a cluster server environment 

Current environment Planned environment Action

No existing storage 
subsystems

New storage subsystems with controllers 
that will use version 4.00.02 firmware and 
will be managed with Storage Manager 
7.02.

Go to “New installation” on page 40.

Existing storage subsystems 
with controllers that have 
firmware version 3.x 
(machine type 3526) and 
storage-management 
software version 6.22

Upgrade storage subsystems with 
controllers that will use version 4.00.02 
firmware and will be managed with Storage 
Manager 7.02.

Go to “Migration process for a Windows 
NT cluster configuration” on page 52.

Existing storage subsystems 
with controllers that have 
firmware versions 4.00.00 
through 4.00.01 and storage-
management software 
versions 7.00 or 7.01 
(machine types 3526 and 
3552)

Upgrade storage subsystems with 
controllers that will use version 4.00.02 
firmware and will be managed with Storage 
Manager 7.02.

Go to “Upgrading from a previous 
version of the storage-management 
software in a cluster server 
configuration” on page 50.

Continue to use your existing versions 
4.00.00 through 4.00.01 controller firmware. 
Be sure to uninstall previous versions of the 
storage-management software before 
installing version 7.02. You can manage 
these existing storage subsystems through 
Storage Manager 7.02, which includes 
components that are compatible with these 
older firmware versions. The functional 
differences between your existing controller 
firmware and the controller firmware 
4.00.02 is provided on the installation CD. 
Refer to the README file located in the 
\NT\ directory on the installation CD for 
more information.

Go to “Upgrading from a previous 
version of the storage-management 
software in a cluster server 
configuration” on page 50.

Note: When using this procedure, if 
you want to continue to use 
controller firmware versions 
4.00.00 through 4.00.01, do not 
update the NVSRAM and 
controller firmware to version 
4.00.02.
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New installation
Before you begin the new installation, read “Installing the hardware” to make sure that 
all hardware components are installed correctly for the cluster server environment. 
Then, begin the software installation process with “Installing the SM7client package” 
on page 43. Continue the process until you have completed “Installing the cluster 
server software” on page 49. You do not need to install or use the migrate utility. 

Important: After connecting the storage subsystems to both nodes, do not start 
Windows NT on both nodes at the same time until you install the cluster software on 
at least one node. To suspend Windows NT startup on node B, press the spacebar at 
the operating system (OS) startup. Do not install the cluster software until instructed 
to do so.

Figure 18 shows a flowchart of the process for installing the storage-management 
software for a new installation.

Figure 18. Process for a new installation

Installing the hardware
The hardware installation involves installing host adapters and storage subsystems.

Host adapters
Refer to the appropriate host-adapter documentation for specific installation 
requirements and procedures. The following considerations apply:

• You can install two host adapters in each node to run two cables from each node 
to both controllers in a storage subsystem. For example, if you are using single-
channel host adapters and want the dual-path configuration, you must install two 
host adapters in each node. Figure 19 on page 42 shows Fibre Channel single- 
and dual-path connection examples.

• In a multinode system, be sure to set each host adapter with a unique hard loop 
ID for diagnostic purposes. Refer to the host adapter documentation for setting 
the hard loop ID.
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• Install the correct device driver for the host adapter. Refer to the README file in 
the \NT\Host_Adapter directory on the IBM Netfinity FAStT Storage Manager CD 
for information on supported host adapters and device drivers.

Storage subsystems
Refer to the appropriate hardware documentation to install the storage subsystems. 
The following considerations apply:

• If you are managing storage subsystems directly, you must install Ethernet cables 
to both controllers in each storage subsystem.

• Unless you are using dual-channel host adapters, you need two host adapters per 
node to use the dual-path configuration.

Note: Use the dual-path configuration for the maximum RDAC protection, in the 
event that there is a problem with the connection.

The following figure shows Fibre Channel connections using single-path and dual-
path configurations for fully redundant, partially-redundant, and non-redundancy. For 
more information, refer to the hardware documentation that comes with your controller 
unit or storage server.

Note: The interlink is used as the clustering heartbeat path.
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Figure 19. Installing the storage subsystem on a Fibre Channel network

Note: Other managed hub configurations are possible.

Continue with “Installing the SM7client package” on page 43. 
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 42 IBM® Netfinity® FAStT Storage Manager Version 7.02 for Windows NT®  Installation and Support Guide  



Installing the SM7client package
Install the SM7client package on each management station. You can install the 
package on host node A or node B configured with one of the following operating 
systems:

• Windows NT Server 4.0

• Windows NT Workstation 4.0

• Windows 98

• Windows 98 Second Edition

Important notes: 

• If you are configuring only a networked management station, you need to install 
only the SM7client.

• After connecting the storage subsystems to both nodes, do not start Windows NT 
on both nodes at the same time until you install the cluster software on at least 
one node. To suspend the Windows NT startup on node B, press the spacebar at 
the operating system (OS) startup. Do not install the cluster software until 
instructed to do so.

• If you want to install SM7client on a stand-alone host and manage storage 
subsystems through the Fibre Channel I/O path rather than over the network, you 
must install the TCP/IP software on the host and assign a static IP address to the 
host. The host operating system must be Windows NT Server 4.0 or Windows NT 
Workstation 4.0.

Installation Instructions
Before you install the software, make sure that:

• The management station has at least 20 MB of available disk space.

• The display properties are set to a minimum screen resolution of 800 x 600 pixels 
and a palette of 256 colors or more.

• You close all other programs.

Install the SM7client:

1. Insert the IBM Netfinity FAStT Storage Manager installation CD into the CD-ROM 
drive.

2. Click Start → Settings → Control Panel → Add/Remove Programs.

The Add//Remove Programs Properties window opens.

3. Click Install, and follow the instructions on the screen.

4. Click Browse.

The Browse window opens.

5. Select the CD-ROM drive.

6. Select the \NT\SM7client directory.

7. Select the setup.exe file, and then click Open.

8. Click Finish.

The setup program Welcome window opens.

9. Click Next to begin the installation. 

The Choose Destination Location window opens.

10. Click Browse if you want to change the destination location.
 Chapter 4.  Installing software in a cluster server environment  43



11. Click Next.

12. When the installation is complete, click Finish.

Verifying the SM7client installation
Use the following procedure to verify that the installation was successful:

1. Click Start → Programs.

2. Verify that Netfinity FAStT Storage Manager 7 client appears in the list of 
programs.

3. If you are installing SM7client on only a management station, go to “Continuing 
the installation” on page 48; otherwise, go to “Installing the RDAC package”.

Installing the RDAC package
Use the following procedure to install the RDAC package on a host computer that is 
connected to one or more storage subsystems.

The RDAC package consists of the following components:

• The multipath device driver that is necessary for controller failover support.

• The Hot Add utility for dynamically adding logical drives to the operating system 
(see “Using the Hot Add utility” on page 75).

Important: You must install the RDAC package before installing the SM7agent 
package.

Assigning drive letters
The installation procedure loads the RDAC device driver before the native Windows 
NT class device driver. This is necessary to enable the RDAC. However, this means 
that the system recognizes the storage subsystem logical drives before it recognizes 
any local drives, and assigns drive letters accordingly.

Note: Before you install this software, you must have static drive letters assigned to 
the existing local drives.

Use the following procedure to determine if you need to assign static drive letters and 
to assign them, if necessary.

1. Power off the storage subsystem to prevent Disk Administrator (WINDISK) from 
locking up while you are assigning drive letters or installing the RDAC device 
driver.

2. Click Start → Programs → Administrative Tools → Disk Administrator to view 
the disk configuration and to check the number of partitions.

• If you have two or more partitions, go to Step 3.

• If you have only one partition, go to Step 4.

3. If you have at least two partitions (the boot partition and one other partition) and 
both of the following conditions apply, go to “Installation instructions” on page 45. 
Otherwise, go to Step 4 on page 45.

• The last partition you created was created with Disk Administrator.

• The partition has a drive letter assigned and has a status of Unknown or has 
a file system on it (that is, it has a status other than Unformatted).
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4. Use the following procedure to create a new partition.

a. Select a drive containing free disk space.

b. Click Partition → Create. The partition is created (a drive letter is assigned 
and the partition status is Unformatted).

c. Click Partition → Commit Changes Now. The partition status changes to 
Unknown, and static drive letters are assigned to all existing partitions.

5. Continue with “Installation instructions”.

Installation instructions
Before you install the RDAC package, make sure that:

• You have Administrator privileges on the host computer.

• The host computer is configured with Windows NT 4.0 and Service Pack 5 or 
greater.

• The host computer has at least 1 MB of available disk space.

• The display properties are set to a minimum screen resolution of 640 x 480 pixels 
and a palette of 256 colors or more.

• You close all other programs.

Installing RDAC:

1. Insert the IBM Netfinity FAStT Storage Manager installation CD into the CD-ROM 
drive.

2. Click Start → Settings → Control Panel → Add/Remove Programs.

The Add/Remove Programs Properties window opens.

3. Click Install and follow the instructions on the screen.

4. Click Browse.

The Browse window opens.

5. Select the CD-ROM drive.

6. Select the \NT\RDAC directory.

7. Select the setup.exe file, and then click Open.

8. Click Finish.

The setup program Welcome window opens. 

9. Click Next to begin the installation.

When RDAC is installed, the Setup Complete window opens. 

10. Click No, I will restart my computer later; then, click Finish.

11. Click Start → Shutdown.

The Shut Down Windows window opens. 

12. Click Shutdown to shut down the server.

13. Power on the storage subsystem.

14. After the storage subsystem is powered on completely, power on the host to 
ensure that the changes take effect.
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Verifying the RDAC installation
Use the following procedure to verify that the installation was successful.

1. Click Start → Settings → Control Panel → Devices.

The Devices window opens.

2. Select symarray from the list of devices.

3. Make sure that the status of the symarray device is Started.

4. Continue with “Installing Microsoft Virtual Machine (MSVM)”.

Installing Microsoft Virtual Machine (MSVM)
Use the following procedure to install Microsoft Virtual Machine (VM) on a host 
machine connected to one or more storage subsystems.

Important: You must install the Microsoft Virtual Machine (VM) before installing 
SM7agent. The Netfinity FAStT Storage Manager 7.02 installation CD contains a 
version of Microsoft VM that was tested with the storage-management software. 
Before you install this version, go to the Web site at http://www.ibm.com/pc/support to 
see if a newer version of the software is available. Also, check the Web site for the 
latest support information.

Installation instructions
Before you install the software, make sure that:

• You have Administrator privileges on the host machine.

• The host machine is configured with Windows NT 4.0 and Service Pack 5 or 
greater.

• The host machine has at least 1 MB of available disk space.

• The display properties are set to a minimum screen resolution of 640 x 480 pixels 
and a palette of 256 colors or more.

• You close all other programs.

Install Microsoft Virtual Machine:

1. Insert the IBM Netfinity FAStT Storage Manager installation CD into the CD-ROM 
drive.

2. Click Start → Settings → Control Panel → Add/Remove Programs.

The Add/Remove Programs Properties window opens.

3. Click Install and follow the instructions on the screen.

4. Click Browse.

The Browse window opens.

5. Select the CD-ROM drive.

6. Select the NT\SM7agent directory.

7. Select the msjavx86.exe file. and click Open.

8. Click Finish, and follow the instructions on the screen.

When the software is installed, the Setup Complete window opens.

Note: You must restart the host to ensure that all changes take effect.

9. Click Yes to restart the host.

10. Continue with “Installing the SM7agent package” on page 47.
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Installing the SM7agent package
Use the following procedure to install the SM7agent package on a host machine 
connected to one or more storage subsystems.

The SM7agent package consists of the following components:

• The host-agent software necessary for host-agent management of the storage 
subsystems.

• The SM7devices utility necessary for relating logical drives to operating system 
device names. For more information, see “Using the SM7devices utility” on page 
76.

Important notes:

• You cannot install the SM7agent package unless the RDAC package is installed. 
The Microsoft Virtual Machine is also a required component for installing and 
using the SM7agent package.

• You must install SM7agent even if you do not intend to manage storage 
subsystems through the host-agent software.

Installation instructions
Before you install the software, make sure that:

• You have Administrator privileges on the host machine.

• The host machine is configured with Windows NT 4.0 and Service Pack 5 or 
greater.

• The host machine has at least 1 MB of available disk space.

• The display properties are set to a minimum screen resolution of 640 x 480 pixels 
and a palette of 256 or more.

• You installed RDAC and the Microsoft Virtual Machine (VM).

• You close all other programs.

Install the SM7agent package:

1. Insert the IBM Netfinity FAStT Storage Manager installation CD into the CD-ROM 
drive.

2. Click Start → Settings → Control Panel → Add/Remove Programs.

The Add/Remove Programs Properties window opens.

3. Click Install and follow the instructions on the screen.

4. Click Browse.

The Browse window opens.

5. Select the CD-ROM drive.

6. Select the \NT\SM7agent directory.

7. Select the setup.exe file, and then click Open.

8. Click Finish. 

The setup program Welcome window opens.

9. Click Next to begin the installation. 

10. After SM7agent is installed, the Setup Complete window opens.

11. You must restart the host to ensure that all changes take effect. Click Finish to 
restart the host.
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Verifying the SM7agent installation
Use the following procedure to verify that the installation was successful.

1. Click Start → Settings → Control Panel → Services.

The services window opens.

2. Scroll through the list of services until you find the Netfinity Fibre Channel Storage 
Manager 7 agent.

3. Make sure that the status of the host-agent service is started.

Note: If you are not using the host-agent software to manage storage 
subsystems, you can stop the host-agent service. Click Start → 
Settings → Control Panel → Services. Select the host-agent from the list 
of displayed services and click Startup. Under Startup Type, click Manual, 
and then click OK.

Continuing the installation
If you installed the storage-management software on Node A, go to “Setting up the 
storage subsystems”. If you installed the storage-management software on Node B, 
go to “Verifying drive letters” on page 49. 

Setting up the storage subsystems
Use the procedures in Chapter 5, “Completing the installation,” on page 55 to perform 
the following tasks:

1. Start Enterprise Management and perform an Initial Automatic Discovery of 
storage subsystems on the local subnetwork. (See “Starting Enterprise 
Management” on page 55.)

2. Add other devices to the management domain as necessary. (See “Adding 
devices” on page 57.)

3. Create all of your planned arrays and logical drives on each storage subsystem 
connected to your cluster. (See “Creating arrays and logical drives” on page 57.)

4. Modify configuration settings in NVSRAM by running the appropriate scripts 
required for your configuration. (See “Modifying configuration settings in 
NVSRAM” on page 60.)

5. Open a Subsystem Management window for each storage subsystem and 
configure the storage subsystem as much as possible. You do not have to 
completely configure the storage subsystems. However, any changes you make 
later must be made known to Node B. (See “Starting Subsystem Management” on 
page 58.)

6. After you complete the procedures in Chapter 5, “Completing the installation,” on 
page 55, continue with step 7.

7. If you installed the storage-management software on Node A, go to “Shutting 
down node A” on page 49, If you installed the storage-management software on 
Node B, go to “Verifying drive letters” on page 49. 
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Shutting down node A
After installing the storage-management software on node A:

1. Shut down Windows NT, but leave Node A running (do not turn off the node).

2. Return to “Installing the SM7client package” on page 43 and repeat the 
installation procedures to install the necessary software components on Node B.

Verifying drive letters
After installing the storage-management software on node B:

1. Use the Windows NT Disk Administrator to verify that the drive letters that are 
assigned to the configured logical drives are the same as those that are assigned 
to Node A.

2. Continue with “Shutting down node B”.

Shutting down node B
1. Shut down Windows NT, but leave Node B running (do not turn off the node).

2. Continue with the next section, “Installing the cluster server software”.

Installing the cluster server software
Use the following procedure to install the cluster server software on Nodes A and B.

Important: Before you install the cluster server software, make sure that you have 
installed the storage-management software on both nodes of the cluster server.

1. Install the cluster server software on Node A, as follows:

a. Refer to the appropriate Microsoft Cluster Server (MSCS) documentation for 
the correct procedure to install the cluster server software. 

Note: During installation, specify that you want to Form A New Cluster. 

b. After the system restarts, leave Node A up and running.

2. Install the Cluster Server software on Node B, as follows:

a. Refer to the appropriate MSCS documentation for the correct procedure to 
install the Cluster Server software. 

Note: During installation, specify that you want to Join The Existing Cluster. 

b. After the system restarts, leave Node B up and running.

Important: When the installation of the MSCS is complete, be sure to reinstall the 
latest supported Service Pack.
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3. Verify the software installation, as follows:

a. On either node (A or B), click Start → Programs → Administrative Tools 
(Common).

b. Click Cluster Administrator.

c. In the Cluster or Server Name field, type either the name of the cluster or the 
name or IP address of one of the nodes.

d. If the installation is successful, the computer names of both nodes appear on 
the left side of the Cluster Administrator window.

4. If both node names appear, go to “Completing final tasks” on page 60. Otherwise, 
reinstall the cluster server software. 

Upgrading from a previous version of the storage-management software 
in a cluster server configuration

Be sure that you are familiar with the steps required in “New installation” on page 40, 
before you continue with the following upgrade procedures.

You can choose from one of the following procedures to upgrade your existing 
storage subsystem to Storage Manager 7.02 and to controller firmware version 
4.00.02:

• Performing a scheduled upgrade. A scheduled upgrade means scheduling 
down time on your cluster server to upgrade the controller firmware and the 
storage-management software. The scheduled upgrade is the preferred 
procedure for upgrading a cluster server configuration.

• Performing a rolling upgrade. A rolling upgrade means upgrading the controller 
firmware and storage-management software so that the services and resources 
offered by the cluster are available, while the node that is being upgraded is not 
available.

Important: After the storage subsystem controller firmware has been upgraded to 
4.00.02, you will not be able to communicate with the controller until you have 
upgraded to Storage Manager 7.02 software on your management station and host. 
Previously installed versions of the storage-management client and host-agent 
software will not recognize controllers running version 4.00.02 firmware. 

Performing a scheduled upgrade from storage-management software 
version 7.0 or 7.01 to Storage Manager 7.02

Complete the following steps to upgrade from storage-management software version 
7.0 or 7.01 to Storage Manager 7.02.

1.  Before installing the storage-management software, do the following:

a. Click Start → Settings → Control Panel → Services.

The Services window opens.

b. Select Cluster Server from the list of displayed services and then, click 
Startup. The Service window opens.

c. In the Startup Type group box, click Manual; then, click OK.

d. Stop Cluster Server on all nodes in the cluster configuration.

2. Shutdown all but node A in the cluster configuration.

3. From node A, to uninstall the components from the previous version of the 
storage-management software, use the uninstall procedure that came with the 
version of the storage-management software that you are running.
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4. Verify that the IBM Host Bus Adapter driver versions are current. If they are not at 
the current versions, refer to the README file in \NT\Host_Adapter directory on 
the installation CD to upgrade the driver versions before continuing.

5. Install the Storage Manager 7.02 SM7client package using the procedure in 
“Installing the SM7client package” on page 43.

6. Install the Storage Manager 7.02 RDAC package using the procedure in 
“Installing the RDAC package” on page 44.

7. Install the Storage Manager 7.02 SM7agent package using the procedure in 
“Installing the SM7agent package” on page 47.

8. Upgrade the controller NVSRAM and controller firmware to version 4.00.02. 
Then, modify the appropriate configuration settings in NVSRAM using the 
procedure in “Modifying configuration settings in NVSRAM” on page 60. 

Note: You can continue to use your existing controller firmware versions 4.00.00 
through 4.00.01. You can manage these existing storage subsystems 
through Storage Manager 7.02.

9. Shutdown this node.

10. On node B, repeat step 3 on page 50 through step 7; then, repeat step 9.

11.  All nodes should be shut down. Start up one node at a time, using the following 
procedure:

a. Click Start → Settings → Control Panel → Services.

The Services window opens.

b. Select Cluster Server from the list of displayed services; then, click Startup. 
The Service window opens.

c. In the Startup Type group box, click Automatic; then, click OK.

d. Start the cluster server on node B.

Performing a rolling upgrade from storage-management software 
version 7.0 or 7.01 to Storage Manager 7.02

Note: To avoid losing access to a cluster, you need to perform a rolling upgrade. A 
rolling upgrade means upgrading so that the services and resources offered by 
the cluster are always available, even though the node being upgraded is not 
available.

If you have applications installed in the cluster server environment that do not support 
a rolling upgrade, then you will have to do either of the following:

• Put those resources offline before the upgrade; then, put them back online after 
the upgrade, or

• Use a different upgrade method

Complete the following steps to perform a rolling upgrade from storage-management 
software version 7.0 or 7.01 to Storage Manager 7.02:

1. On node A, open Cluster Administrator.

2. Select node A, then pause the node (File → Pause Node)

3. Double-click on the Active Groups folder in the right window of Cluster 
Administrator.

4. Select each group listed, and move your selection to node B.

5. On node A, to uninstall the components from the previous version of the storage-
management software, use the uninstall procedure that came with the version of 
the storage-management software you are running.
 Chapter 4.  Installing software in a cluster server environment  51



6. Verify that the IBM Host Bus Adapter driver versions are current. If they are not at 
the current versions, refer to the README file in \NT\Host_Adapter directory on 
the installation CD to upgrade the driver versions before continuing.

7. Install the Storage Manager 7.02 SM7client package using the procedure in 
“Installing the SM7client package” on page 43.

8. Install the Storage Manager 7.02 RDAC package using the procedure in 
“Installing the RDAC package” on page 44.

9. Install the Storage Manager 7.02 SM7agent package using the procedure in 
“Installing the SM7agent package” on page 47.

10. Upgrade the controller NVSRAM and controller firmware to version 4.00.02. 
Then, modify the appropriate configuration settings in NVSRAM using the 
procedure in “Modifying configuration settings in NVSRAM” on page 60.

Note: You can continue to use your existing controller firmware versions 4.00.00 
through 4.00.01. You can manage these existing storage subsystems 
through Storage Manager 7.02.

11. Run Cluster Administrator, and resume the node (File → Resume Node)

12. On node B, repeat step 1 on page 51 through step 9; then, repeat step 11.

Migration process for a Windows NT cluster configuration
Complete the following steps to migrate controller firmware from version 3.x to 4.x and 
to upgrade the storage-management software to Storage Manager 7.02.

1. Before installing the storage-management software, do the following:

a. Click Start → Settings → Control Panel → Services.

The Services window opens.

b. Select Cluster Server from the list of displayed services and then, click 
Startup. The Service window opens.

c. In the Startup Type group box, click Manual; then, click OK.

d. Stop cluster server on all nodes in the cluster configuration.

2. Shutdown all but node A in the cluster configuration.

3. To complete the migration process on node A, go to Chapter 6, “Migration 
process,” on page 61.

Note: The migration process will upgrade the controller firmware from version 3.x 
to 4.x and upgrade the storage-management software from version 6.22 to 
7.01.

4.  From the one remaining node, to uninstall the components from the previous 
version of the storage-management software, use the uninstall procedure that 
came with the version of the storage-management software that you are using.

5. Verify that the IBM Host Bus Adapter driver versions are correct. If they are not 
the correct versions, use the README file in \NT\Host_Adapter directory on the 
installation CD to upgrade the driver versions before continuing.

6. Install the Storage Manager 7.02 SM7client package using the procedure in 
“Installing the SM7client package” on page 43.

7. Install the Storage Manager 7.02 RDAC package using the procedure in 
“Installing the RDAC package” on page 44.

8. Install the Storage Manager 7.02 SM7agent package using the procedure in 
“Installing the SM7agent package” on page 47.
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9. Upgrade the controller NVSRAM and controller firmware to version 4.00.02. 
Then, modify the appropriate configuration settings in NVSRAM using the 
procedure in “Modifying configuration settings in NVSRAM” on page 60. 

10.  Shutdown this one node.

11. On node B, repeat step 4 on page 52 through step 8 on page 52; then, repeat 
step 10.

12.  All nodes should be shut down. Start up one node at a time, using the following 
procedure:

a. Click Start → Settings → Control Panel → Services.

The Services window opens.

b. Select Cluster Server from the list of displayed services and then, click 
Startup. The Service window opens.

c. In the Startup Type group box, click Automatic; then, click OK.

d. Start cluster server on the node.
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Chapter 5.  Completing the installation

This chapter contains procedures for starting Enterprise Management and Subsystem 
Management and for completing the installation tasks.

Starting Enterprise Management
The Enterprise Management window is the first window to open when you start the 
software. Use the Enterprise Management window to:

• Add and discover the storage subsystems that you want to manage.

• Provide a comprehensive view of all storage subsystems in your management 
domain.

• Perform batch storage subsystem management tasks using the Script Editor.

Use the following procedure to start the Enterprise Management window:

1. Click Start → Programs.

2. Click Netfinity Fibre Channel Storage Manager 7 client.

The client software starts, and the Enterprise Management window and the 
Confirm Initial Automatic Discovery window open, as shown in Figure 20.

Figure 20. Confirm Initial Automatic Discovery window

Note: The Enterprise Management window can take several minutes to open. No 
wait cursor (such as an hourglass) is displayed.

If you do not want to perform the initial automatic discovery, click No. You 
can use the Edit → Add Device menu option to add hosts and storage 
subsystems. For more information, see “Adding devices” on page 57. 

3. Click Yes to begin an initial automatic discovery of hosts and storage subsystems 
that are attached to the local subnetwork on which the management station is 
installed.
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The software sends a broadcast message across the local subnetwork where the 
management station is installed. It discovers host-agent managed storage 
subsystems if the hosts that provide network management connections to the 
storage subsystems respond to the broadcast. The software discovers directly 
managed storage subsystems if the controllers in those storage subsystems 
respond to the broadcast message.

Note: It can take up to a minute for the Enterprise Management window to refresh 
after an initial automatic discovery. 

If you need to stop the automatic discovery operation, close the Enterprise 
Management window.

When the initial automatic discovery is complete, you can see all hosts and storage 
subsystems that are attached to the local subnetwork, as shown in Figure 21. 

Figure 21. Enterprise Management window

If you do not see all hosts and storage subsystems, do the following: 

• Check the hardware and connections for possible problems (refer to the hardware 
documentation for specific procedures).

• Refer to the Enterprise Management Help topic about discovering storage 
subsystems.

• Make sure that the device is on the local subnetwork. If it is not, you must use the 
Add Device option.

Note: If any device shows a status of Unresponsive, use the software to remove the 
device from the management domain and then add it again. Refer to the 
Enterprise Management online Help for instructions on removing and adding 
devices.

A storage subsystem might be duplicated in the device tree after an automatic 
discovery, if the storage subsystem is directly managed but is attached to a host with 
the host-agent software installed and running. In this case, you can remove the 
duplicate storage management icon from the device tree using the remove device 
option in the Enterprise Management window.

Continue with “Adding devices” on page 57.
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Adding devices
You can add more hosts or storage subsystems outside the local subnetwork. For 
more information about this option, refer to the Enterprise Management window online 
Help.

Important:   If you are managing storage subsystems through the host-agent 
software and you physically add new storage subsystems, you must stop and restart 
the host-agent service so that it can recognize the new storage subsystems (see 
“Stopping the host-agent service” on page 60). Then, go to the Enterprise 
Management window and click Tools → Rescan to add the new storage subsystems 
to the management domain.

Continue with “Creating arrays and logical drives”.

Creating arrays and logical drives
Use the following procedure to create an array or logical drive:

1. Highlight a storage subsystem in the Enterprise Management window and select 
Tools → Manage Device to start a Subsystem Management window for that 
storage subsystem.

2. Create all of your planned arrays and logical drives on this storage subsystem 
using the Configure → Create Array/Logical Drive option.

3. Repeat the arrays/logical drive configuration for each storage subsystem 
connected to your cluster.

Note: If you make any other logical drive additions or deletions, you must make 
them known to node B.

4. Go to “Setting up alert notifications”.

Setting up alert notifications
After you add devices to the management domain, set up alert notification options to 
report critical events on the storage subsystems. The following options are available 
for alert notification:

• Notification to a designated network management station (NMS) using Simple 
Network Management Protocol (SNMP) traps (see “Setting up the NMS for SNMP 
notification” for more information)

• Notification to designated e-mail addresses

• Notification to designated alphanumeric pagers (when a third-party software 
package is used to convert e-mail messages)

Note: The Enterprise Management Window must remain open if you want to monitor 
the condition of storage subsystems included in your management domain. 
You may want to minimize the window. If you close this window, you will not 
receive alert notifications. Refer to the Enterprise Management online Help for 
more information on alert notification options.

Setting up the NMS for SNMP notification
If you choose to set up alert notification using SNMP traps, you must first copy a 
management information base (MIB) file to the designated network management 
station. Use this procedure to set up the MIB file on the network management station.
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Important: You need to set up your designated NMS only one time.

1. From the \NT\SM7mib directory on the Netfinity FAStT Storage Manager 
Installation CD, copy the Arrayman.mib file to the network management station.

2. Follow the steps that are required by your specific network management station to 
compile the MIB file.

Note: For details on the required steps, consult your network administrator or the 
documentation that is specific to the NMS product that you are using.

Configuring alert destinations
Configure SNMP trap destinations and e-mail destinations for alert notifications using 
Enterprise Management. Refer to the Enterprise Management online Help for specific 
procedures.

Starting Subsystem Management
The Subsystem Management window enables you to manage selected subsystems.

Use the following procedure to open a Subsystem Management window for a 
selected storage subsystem:

1. In the Enterprise Management window, select a storage subsystem.

2. Click Tools → Manage Device.

The software displays the Subsystem Management window for the selected 
storage subsystem, as shown in Figure 22.

Note: Using the open Subsystem Management window, you can manage only 
the selected storage subsystem. However, you can open multiple 
Subsystem Management windows to manage other storage subsystems.

Figure 22. Subsystem Management window (models 3526 and 3552)
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Figure 23. Subsystem Management window (model 3542)

Renaming storage subsystems
When starting Storage Manager 7.02 for the first time, the storage subsystems are 
unnamed. You must use the Subsystem Management window to rename each 
storage subsystem from <unnamed> to the name that you want. Refer to the names 
that you entered in the information record that you created using Table 14 on page 79. 
Then, refer to the topic about renaming storage subsystems in the Subsystem 
Management online Help. The Help topic provides detailed instructions for renaming 
storage subsystems.

Performing other storage-subsystem management tasks
You can perform the following storage-subsystem management tasks:

• Downloading controller firmware

• Downloading controller NVSRAM

• Locating a storage subsystem

• Viewing a storage subsystem profile

• Typing or changing a storage subsystem password

• Creating and managing logical drives and arrays

• Using the Performance Monitor

• Creating storage partitions (if applicable)

Note: To create storage partitions, you must obtain the worldwide name or port name 
of each host adapter in each host connected to the storage subsystem.

For more information about these and other storage-subsystem management tasks, 
refer to the appropriate topics in the Subsystem Management online Help.

Go to “Modifying configuration settings in NVSRAM” on page 60.
 Chapter 5.  Completing the installation  59



Modifying configuration settings in NVSRAM
Depending on the operating system, management method (host-agent or direct) and 
configuration (cluster or noncluster) that you selected, you might need to run scripts to 
modify configuration settings stored in NVSRAM on each storage subsystem you are 
managing with Storage Manager 7.02.

Use the following procedure to modify the configuration settings.

1. Insert the Netfinity FAStT Storage Management Installation CD into the CD-ROM 
drive on the management station.

2. Go to the NT\Scripts directory and read the README file in that directory.

3. In the Enterprise Management window, select a storage subsystem; then, click 
Tools → Execute Script. 

4. Run the scripts for your configuration using steps 6 through 8.

Note: In a cluster configuration, if you are managing storage subsystems with 
only the host-agent, run the script to disable networking.

5. To run a script file, click File → Load Script. 

The Load Script window opens.

6. Select the appropriate script from the NT\Scripts directory on the 
installation CD.

7. Click Open to load the script.

8. Click Tools → Execute Only. Wait until the Script Execution Complete 
message displays.

9. Repeat the procedures in steps 3 through 8 for each storage subsystem that you 
are managing with the storage-management software. 

Completing final tasks
If you want to manage storage subsystems using only the direct method, go to 
“Stopping the host-agent service”. Otherwise, go to Chapter 7, “Operating-system 
support,” on page 73.

Note: You can manage the storage subsystems using both the direct and host-agent 
management methods.

Stopping the host-agent service
Use the following procedure to stop the host-agent service:

1. Click Start → Settings → Control Panel → Services.

2. Click Netfinity Fibre Channel Storage Manager 7 Agent.

3. Click Stop.

4. Click Startup.

The Service window opens.

5. Under Startup Type, click Manual.

6. Click OK.

7. Click Close to close the Services window, and then close the Control Panel.

8. Go to Chapter 7, “Operating-system support,” on page 73.
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Chapter 6.  Migration process 

If you have a previous installation of storage subsystems containing controller model 
3526 that you are managing with version 6.22 of the storage-management software, 
and you want to manage those storage subsystems with Storage Manager 7.01, 
continue with “Installation prerequisites”. Otherwise, Go to Chapter 5, “Completing the 
installation,” on page 55.

Use the migration procedure to perform the following tasks:

• Upgrading from storage-management software version 6.22 to Storage Manager 
Version 7.01 on the management station

• Upgrading RDAC on the host computer

• Installing MSVM and SM7agent on the host computer

• Migrating from firmware 3.x to 4.x on the RAID controllers in an IBM Netfinity 
Fibre Channel RAID Controller Unit model 3526-1RU.

Notes:

1. Perform the installation of SM7client on each management station.

2. Perform the installation of SM7rdac, MSVM, and SM7agent on each host.

3. Perform the migration process from one host for each storage subsystem.

Installation prerequisites
Before starting the migration process, make sure that:

1. The host computer and management station are running Windows NT Service 
Pack 5 or greater.

Note: You cannot migrate the controller firmware if the host agent and 
management station are running Windows 2000. Windows 2000 can 
communicate with controllers at firmware level 4.x.

2. Fibre Channel RAID controllers to be migrated must be at bootware 03.01.00.02 
and appware 03.01.02.22.

3. Make sure that 32 LUN support is enabled.

(The ’LargeLuns’ setting in the registry for the Fibre Channel Host Bus Adapters 
(HBA) must be set to ’1’ and the ’Luns per target’ setting in the ALT-Q FC HBA 
utility must be set to’0’.)

4. Storage-management software version 6.22 must be uninstalled before beginning 
the migration process.

5. Download the software files from the IBM web site, 
http://www.ibm.com/pc/netfinity

a. Click Downloads→Netfinity and PC Server Drivers.

b. Select your product and click Servers → Fibre Channel Solutions → 
3526 → All → Fibre; then, link and download the following software:

• 06p4929A IBM Netfinity FAStT Storage Manager 7 for Windows NT version 
7.01.

• IBM Netfinity FAStT Storage Manager 7.01 migration from Storage Manager 
version 6.22 (for Windows NT only).

Before you install the software, make sure that:

• You have Administrator privileges on the host computer.
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• The host computer is configured with Window NT 4.0 and Service Pack 5 or 
greater.

• The host computer has at least 10 MB of available disk space and the display 
properties are set to a minimum screen resolution of 640 x 480 pixels and a 
palette of 256 colors.

• The management station has at least 20 MB of available disk space and the 
display properties are set to a minimum screen resolution of 800 x 600 pixels and 
a palette of 256 colors.

• You close all other programs. You cannot update the controller if there is an active 
lock on the logical disk(s). This includes IBM Netfinity Manager, Netfinity Director, 
Diskeeper, or Microsoft Cluster Server.

Installation preparation
Use the following procedure to prepare for the migration process:

1. Run 06P4929A.exe. Choose a directory to extract the files to and click Unzip. 
This will create the following directory structure under the target extraction 
directory:

2. Run migrate701.exe. Choose the same directory as the one selected in the 
previous step to extract the files to and click Unzip. This will create the following 
directory structure under the target extraction directory:

Directory of

<target directory>\temp\AGENT701 SM7agent-NT-07012501.exe

<target directory>\temp\CLIENT701 SM7client-NT-07012503.exe

<target directory>\temp\FW04000100 FW_04000100_04000100.dlp

<target directory>\temp\MIB arrayman.mib

<target directory>\temp\MSVM MSJavx86-5_00_3186.exe

<target directory>\temp\NVSRAM NV4766WNT856004.dlp

NV4774WNT856003.dlp

<target directory>\temp\RDAC SM7rdac-07002507.exe

<target directory>\temp\SCRIPTS SM7Scripts.exe

<target directory>\temp READM701.txt

Directory of 

<target directory>\temp\FW03010300 firmware_03010300.dlp

<target directory>\temp\MIB arrayman.mib

<target directory>\temp\migrate701 sm7migrate-nt-07012500.exe

• Migrate.txt

• Migrate.cmd

• NVutil.exe

• SetNVSRAM.cmd
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Installing SM7client
Use the following procedure to install the SM7client package on a management 
station or file server that is configured with one of the following operating systems.

• Windows NT Server 4.0

• Windows NT Workstation 4.0

• Windows 98

• Windows 98 Second Edition

Note: If you want to install SM7client on a host and manage storage subsystems 
through the Fibre Channel I/O path rather than over the network, you must 
install the TCP/IP software on the host and assign a static IP address to the 
host. The host operating system must be Windows based.

Installation Instructions
1. Go to the <target directory>\temp\client701 directory.

2. Run the SM7client-NT-07012503.exe file.

This self-extracting executable file will expand out its files to the c:\storage 
directory. If prompted to overwrite files, click Yes to All.

Note: Your directory path might be identified differently.

3. From the c:\storage directory, select the setup.exe file, and then click Open.

4. Click Next.

The setup program Welcome window opens.

5. Click OK to begin the installation.

The Choose Destination Location window opens.

6. Click Browse if you want to change the destination location.

7. Click Next to begin the installation.

8. When the installation is complete, click Finish.

Verifying the SM7client installation
Use the following procedure to verify that the installation was successful:

1. Click Start → Programs.

2. Verify that Netfinity Fibre Channel Storage Manager 7 client appears in the list of 
programs.

3. Go to “Installing SM7rdac”.

Installing SM7rdac
Use the following procedure to install the RDAC package on a host computer that is 
connected to one or more storage subsystems.

The RDAC package consists of the following components:

• The multipath device driver that is necessary for controller failover support.

• The Hot Add utility for dynamically adding logical drives to the operating system 
(see “Using the Hot Add utility” on page 75).

Important: You must install the RDAC package before installing the SM7agent 
package.
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Installation instructions
1. Select the <target directory>\temp\RDAC\ directory.

2. Run the SM7rdac-07002507.exe file.

Set the overwrite files setting to ’Always’. This self-extracting executable file will 
expand out its files to the c:\storage directory.

3. From the c:\storage directory, run the setup.exe file.

4. Click Next.

The setup program Welcome window opens.

5. Click OK to begin the installation.

After RDAC is installed, the Setup Complete window opens.

6. You must restart the host to ensure that all changes take effect. Click Finish to 
restart the host computer.

Verifying the SM7rdac installation
Use the following procedure to verify that the installation was successful.

1. Click Start → Settings → Control Panel → Devices.

The Devices window opens.

2. Select symarray from the list of devices.

3. Make sure that the status of the symarray device is Started.

4. Continue with “Installing Microsoft Virtual Machine (MSVM)”.

Installing Microsoft Virtual Machine (MSVM)
Use the following procedure to install Microsoft Virtual Machine (MSVM) on a host 
computer connected to one or more storage subsystems.

Important: You must install the Microsoft Virtual Machine (MSVM) before installing 
SM7agent. The Netfinity FAStT Storage Manager 7.01 installation CD contains a 
version of Microsoft VM that was tested with the storage-management software. 
Before you install this version, go to the IBM Web site, http://www.ibm.com/pc/support 
to see if a newer version of the software is available. Also, check the Web site for the 
latest support information.

Installation instructions
1. Go to the <target directory>\temp\MSVM directory.

2. Run the MSJavx86-5_00_3186.exe file.

If prompted, choose not to overwrite newer files. This self-extracting executable 
file will expand out its files to the c:\storage directory.

3. Click Next and follow the instructions.

After the software is installed, the Setup Complete window opens.

Note: You must restart the host to ensure that all changes take effect.

4. Select Yes to restart the host computer.

Installing the SM7agent package
Use the following procedure to install the SM7agent package on a host machine 
connected to one or more storage subsystems.
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The SM7agent package consists of the following components:

• The host-agent software necessary for host-agent management of the storage 
subsystems.

• The SM7devices utility necessary for relating logical drives to operating system 
device names. For more information, see “Using the SM7devices utility” on page 
76.

Important: You cannot install the SM7agent package unless the RDAC package is 
installed. The Microsoft Virtual Machine is also a required component for installing 
and using the SM7agent package.

You must install SM7agent even if you do not intend to manage storage subsystems 
through the host-agent software.

Installation instructions
1. Select the <target directory>\temp\AGENT701 directory.

2. Run the SM7agent-NT-07012501.exe file.

If prompted to overwrite files, select Yes to All. This self-extracting executable file 
will expand out its files to the c:\storage directory.

3. From the c:\storage directory, run the setup.exe file.

4. Click Next.

The setup Welcome window opens.

5. Click OK to begin the installation.

When the SM7agent package is installed, the Setup Complete window opens.

6. You must restart the host to ensure that all changes take effect. Click Finish to 
restart the host.

Verifying the SM7agent installation
Use the following procedure to verify that the installation was successful.

1. Click Start → Settings → Control Panel → Services.

The services window opens.

2. To ensure that the service is installed, scroll through the list of services until you 
locate the Netfinity Fibre Channel Storage Manager 7 agent.

Notes:

a. If the host-agent does not find controllers connected that have firmware 
version 4.x installed, the following Service Control Manager message 
appears:

At least one service or driver failed during system startup. Use 
Event Viewer to examine the event log for details.

b. An entry similar to the following will be present in the NT system event log 
regarding the fact that the storage management agent did not start:
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At this point this error is expected and can safely be ignored. When the host is 
connected to a storage subsystem with firmware version 4.x installed, the 
host-agent will start automatically after the system is restarted.

Note: If you are not using the host-agent software to manage storage 
systems, you can stop the host-agent service. Select the agent from 
the list of displayed services, an then select Stop.

Installing SM7migrate
Use the following procedure to install SM7migrate on a host computer connected to 
one or more storage subsystems. SM7migrate is necessary for downloading 
NVSRAM files and for upgrading controller firmware.

Installation instructions
1. Insert the IBM Netfinity FAStT Storage Manager installation CD into the CD-ROM 

drive.

2. Click Start → Settings → Control Panel → Add/Remove Programs.

The Add/Remove Programs Properties window opens.

3. Click Install and follow the instructions on the screen.

4. Click Browse.

The Browse window opens.

5. Select the CD-ROM drive.

6. Select the <target directory>\temp\MIGRATE701 directory.

7. Run the SM7migrate-NT-07012500.exe file.

If prompted to overwrite files, select Yes to All. This self-extracting executable file 
will expand out its files to the c:\storage directory.

8. From the c:\storage directory, run setup.exe. 

9. Select Next.

The setup program’s Welcome window opens.

10. Select OK.

The Choose Destination Location window opens. 

11. Click Browse if you want to change the destination location.

12. Click Next to begin the installation.

13. You must restart the host to ensure that all changes take effect. Click Finish to 
restart the host.

Date: 6/14/00 Event ID: 7024
Time: 7:00:38 PM Source: Service Control Manager
User: N/A Type: Error
Computer: FC-PD Category: None
Description:
The Netfinity Fibre Channel Storage Manager 7 Agent service 
terminated with service-specific error 100.
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Downloading firmware, NVSRAM, and batch files
If you are upgrading previously installed storage subsystems for management with 
Netfinity FAStT Storage Manager 7.x, you must use SM7migrate to download a 
default NVSRAM file. The default settings enable the network bit and the bit for 
creation of an access volume.

1. Copy the NV4766WNT856004.dlp file from the <target directory>\Temp\NVSRAM 
directory to the \Program Files\SM7migrate\native directory.

2. Copy the firmware_03010300.dlp file from the <target 
directory>\temp\FW03010300 to the \Program Files\SM7migrate\native directory.

3. Copy the FW_04000100_04000100.dlp file from the <target 
directory>\temp\FW04000100 directory to the \Program Files\SM7migrate\native 
directory.

4. Copy the migrate.cmd batch file to the \Program Files\SM7migrate\native 
directory.

5. Copy the NVutil.exe file to the \Program Files\SM7migrate\native directory.

6. Copy the SetNVSRAM.cmd batch file to the \Program Files\SM7migrate\native 
directory.

Running the SetNVSRAM.cmd batch file
Before you can upgrade the NVSRAM, the storage subsystems need to be set to 
report all LUNs (the older version of the NVSRAM limited the storage subsystems to 
only reporting eight LUNs each). Run the SetNVSRAM batch file to prepare the 
storage subsystems. This will need to be performed for each storage subsystem on 
which the NVSRAM will be updated.

Important: You must run the setNVSRAM.cmd batch file. If this step is not performed 
before you upgrade the NVSRAM, the NVSRAM update could fail.

Note: The batch file performs step 1 and 2.

1. nvutil -o 34=30

This will set offset 34 in the NVSRAM to 30 so that the storage subsystem reports 
all LUNs.

2. nvutil -o 34

This will read back the setting of offset 34 in the NVSRAM of the storage 
subsystem. This should show ’30’.

3. Power down the host system.

4. Power cycle the storage Raid controllers.

5. Power up the host computer.

6. Confirm that you are ready to proceed with upgrading the NVSRAM.

7. Select Start → Settings → Control Panel → SCSI Adapters applet.

Count the number of devices listed for the FC HBAs that are attached to the RAID 
controllers in the storage subsystems. There should be 32 devices listed for each 
RAID controller that each FC HBA can communicate with.

Running the Migrate.cmd batch file
To facilitate the installation of the NVRAMs and firmware files, a batch file has been 
developed. When this file is run, the procedure steps in “Installing NVSRAM files” on 
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page 68 and “Upgrading firmware from version 3.x to version 4.x” on page 68 are 
performed automatically. The batch file steps that correlate to the manual actions are 
shown next to the commands in “Installing NVSRAM files” on page 68 and “Upgrading 
firmware from version 3.x to version 4.x” on page 68.

Note: Be sure to use the Migrate.cmd batch file.

Installing NVSRAM files
1. From a DOS command prompt, change to the \Program Files\SM7migrate\native 

directory.

2. Type:

SM7migrate NV4766WNT856004.dlp (batch file steps 1 and 2)

The software displays information on each storage subsystem (see product table 
on page 1) connected to the host computer on which you are running 
SM7migrate. For example, you might see:

• JASON_001:Drive0 Drive8

• MAGGIE_01:Drive16 Drive32

• FRED_001:Drive1 Drive9

Note: The first part of the displayed information refers to the storage subsystem 
name (for example, JASON_001). The second part of the displayed 
information refers to the controllers in the storage subsystem (for example, 
Drive0 Drive8).

The software displays the following options:

Make Selection: (A)ll Modules, E(x)it, or Module Index Number

3. Type a number corresponding to one of the Module Index Numbers.

Important: Do not type A to update all modules, this might result in the NVSRAM 
not being updated properly on all storage subsystem.

The message Download to controller drive <n> was successful is displayed.

4. Run the ClearLocks.bat file located in the \Program Files\SM7migrate\native 
directory to clean up unnecessary files generated by the firmware migration.

5. Repeat steps 2 to 4 above, making sure that the same Module Index Number is 
entered as before, to update the NVSRAM on the storage subsystem twice.

Note: This is batch file step 2.

Important: This second update of the NVSRAM must be performed due to a 
timing window that exists that might prevent the NVSRAM from being updated 
properly the first time. The second update ensures that the NVSRAM is updated 
correctly.

If the message Download to controller Drive <n> was successful is not 
displayed, stop the migration process and contact IBM service.

6. Repeat steps 2 through 5 above for each storage subsystem that you wish to 
manage with Storage Manager 7.01.

Upgrading firmware from version 3.x to version 4.x
Storage Manager 7.01 only manages storage subsystems with controllers using 
firmware version 4.x. If you want to manage controllers with Storage Manager 7.01, 
use SM7migrate to upgrade the firmware on those controllers from version 3.x to 
version 4.x. Depending on the version of the firmware currently installed on the 
controllers, this might be a two-part process:
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• Upgrading from version 3.x to 3.1.3 (the “stepping stone” for upgrading to version 
4.x)

• Upgrading from version 3.1.3 to version 4.x

Use the following procedure to use the SM7migrate utility to upgrade controller 
firmware from version 3.x to version 3.1.3. (This is the “stepping stone” for upgrading 
to version 4.x.)

Attention: Do not use SM7migrate to upgrade firmware directly from version 3.01.x to 
version 4.x because you might lose communication with the controllers in the storage 
subsystem.

1. From the DOS command prompt, change to the
\Program Files\SM7migrate\native directory.

2. Type:

SM7migrate firmware_03010300.dlp (batch file step 3)

The software displays information on each storage subsystem connected to the 
host computer on which you are running SM7migrate. For example, you might 
see:

• JASON_001:Drive0 Drive8

• MAGGIE_01:Drive16 Drive32

• FRED_001:Drive1 Drive9

Note: The first part of the displayed information refers to the storage 
subsystem name (for example, JASON_001). The second part of the 
displayed information refers to the controllers in the storage subsystem 
(for example, Drive0 Drive8).

The software displays the following options:

Make Selection: (A)ll Modules, E(x)it, or Module Index Number. 

3. Type a number corresponding to one of the Module index numbers.

Notes:

a. Do not type A to update all modules, this might result in the NVSRAM not

 being updated properly on all storage subsystems.

Download to controller Drive <n> was successful is displayed.

b. If you receive an error message that the filename you typed is not a 
downloadable file, check to make sure that the .dlp file is in the \Program 
Files\SM7migrate\native directory. If you placed the file in another directory, 
move it to the \Program Files\SM7migrate\native directory and try the 
migration procedure again.

c. If the message Download successful is not displayed, stop the migration 
process and contact IBM service.

4. Run the ClearLocks script located in the \SM7migrate\native directory to clean up 
unnecessary files generated by the firmware migration.

5. Repeat steps b through d above for each storage subsystem that you wish to 
manage with Storage Manager 7.01.
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6. Restart the system.

7. Complete the following procedure to use the SM7migrate utility to upgrade 
controller firmware from version 3.1.3 to version 4.x: 

a. From a DOS command prompt, change to the 
\Program Files\SM7migrate\native directory.

b. Type:

SM7migrate FW_04000100_04000100.dlp (batch file step 4)

The software displays information on each storage subsystem connected to 
the host machine on which you are running SM7migrate. For example, you 
might see:

• JASON_001:Drive0 Drive8

• MAGGIE_01:Drive16 Drive32

• FRED_001:Drive1 Drive9

Note: The first part of the displayed information refers to the storage 
subsystem name (for example, JASON_001). The second part of the 
displayed information refers to the controllers in the storage subsystem 
(for example, Drive0 Drive8).

The software displays the following options:

Make Selection: (A)ll Modules, E(x)it, or Module Index Number

c. Type a number corresponding to one of the Module index numbers.

Important notes:

• Do not type A to update all modules, this may result in the NVSRAM not 
being updated properly on all storage subsystems. 

The message Download to controller Drive <n> was successful is 
displayed.

•  If you receive an error message that the filename you typed is not a 
downloadable file, check to make sure that the .dlp file is in the \Program 
Files\SM7migrate\native directory. If you placed the file in another 
directory, move it to the \Program Files\SM7migrate\native directory and 
try the migration procedure again.

• If the message Download successful is not displayed, stop the migration 
process and contact IBM service.

d. Run the ClearLocks script located in the \SM7migrate\native directory to 
clean up unnecessary files generated by the firmware migration.

e. Repeat steps b through d above for each storage subsystem that you wish to 
manage with Storage Manager 7.01.

f. Restart the system.

Applying NVSRAM configuration scripts
After the system has restarted, three NVSRAM configuration scripts must be run to 
configure the storage subsystem for use with Windows NT 4.0 hosts in a non-
clustered environment. Use the following procedure to apply these scripts: 

1. Run <target directory>\Temp\SCRIPTS\SM7Scripts.exe. This self-extracting file 
will extract the NVSRAM configuration script files. Select a target directory and 
click Unzip.
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• This will create the following directory structure under the target extraction 
directory:

2. Select Start → Programs → Netfinity Fibre Channel Storage Manager 7.

3. After the Netfinity Fibre Channel Storage Manager 7 program starts, you will be 
prompted with the following message:

Select Yes.

If you select No, you can still use the Edit → Add Device option to manually add 
the devices.

The storage subsystems that are at firmware level 4.x will be automatically 
discovered.

4. In the right hand pane of the Netfinity Fibre Channel Storage Manager 7 
(Enterprise Management) window, right-click on a storage subsystem, and select 
Execute Script in the resulting pop-up menu.

The Script Editor window opens.

Directory of <target directory>
04/25/00  05:25p 321 clusteringoff.scr
04/25/00  05:22p 423 clusteringon.scr
Comment: Executed to enable the proper operation of MS Clustering
04/21/00  03:48p 246 lun0off.scr
04/21/00  03:48p 245 lun0on.scr
Comment: Executed to manage the default creation of LUN 0
04/21/00  03:53p 248 networkoff.scr
04/21/00  03:54p 248 networkon.scr
Comment: Executed to enable\disable the Network capabilities of the 
controllers
04/21/00  03:56p 248 propresetoff.scr
04/25/00  05:21p 248 propreseton.scr
Comment: Executed to enable\disable the "Propagated Reset" between controllers
04/21/00  03:52p 252 softresetoff.scr
04/21/00  03:51p 253 softreseton.scr
Comment: Executed to set the interpretation of a Target Reset to either soft of 
hard resets either soft of hard resets.
04/25/00  05:39p 398 UnixWare.scr
03/31/00  12:01p 317 Novell.scr
04/25/00  05:42p 654 FactoryDefaults.scr
05/02/00  11:47a 405 Windows2000.scr
05/02/00  11:47a 402 WinNT4.scr
Comment: Executed to set the controllers to the Factory defaults and to set the 
Inquiry data to conform to the OS requirements.

Confirm Initial Automatic Discovery

The Enterprise Management Window is not configured to 
monitor any devices.

Select Yes to be in an automatic discover on the local 
sub-network; this may take several minutes. Select No to 
bypass the automatic discover process.

<Yes> <No> <Help>
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5. From the Script Editor window menu select File → Load Script.

If prompted to save changes to newscript.scr, select No.

6. In Load Script window, select the <target directory>\FactoryDefaults.scr file and 
select Open.

7. From the Script Editor window menu, select Tools → Verify and Execute.

Script execution complete will be displayed in the lower pane of the Script 
Editor window.

8. From the Script Editor window, select File → Load Script.

If prompted to save changes to newscript.scr, select No.

9. In the Load Script window, select the <target directory>\WinNT4.scr file and then, 
select Open.

10. From the Script Editor window, select Tools → Verify and Execute.

Script execution complete will be displayed in the lower pane of the Script 
Editor window.

11. From the Script Editor window, select File → Load Script.

If prompted to save changes to newscript.scr, select No.

12. In Load Script window, select the <target directory>\softreseton.scr file and then, 
select Open.

13. From the Script Editor window, select Tools → Verify and Execute.

Script execution complete will be displayed in the lower pane of the Script 
Editor window.

Cleaning up
1. Uninstall SM7migrate.

2. The migration is complete. You can begin using Storage Manager 7.01 to manage 
the storage subsystems that are at firmware level 4.x.
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Chapter 7.  Operating-system support

This chapter contains information that is related to operating the storage-
management software with Windows NT.

Windows NT restrictions
Important: Always check for a README file on any installation media. This README 

file might contain important information that was not available when this 
Installation and Support Guide was prepared.

Table 13 explains the restrictions that apply when you use the Netfinity FAStT Storage 
Manager Version 7.02 with Windows NT.

Table 13. Windows NT restrictions and notes 

Restriction Workaround

Clicking a vertical scroll arrow (either up or 
down) causes the scroll box to move all the 
way to the opposite end of the scroll bar.

This is a known defect in the Java Runtime 
Environment.

Click the scroll box and slide it until you reach 
the desired position in the Help window.

Logical drive migration (removing a set of 
drives configured with logical drives from one 
storage subsystem to insert in another 
storage subsystem) is not supported because 
it could cause loss of configuration.

Call for service.

If you manage storage subsystems through 
the host-agent software and use the storage 
management software to download controller 
firmware, the download process can take up 
to 10 minutes to complete.

None.

If you configure a new storage subsystem 
with a single controller, you must place the 
controller in (slot A). The controller firmware 
cannot recognize or communicate with a 
single controller until slot A is populated. This 
restriction does not apply to storage 
subsystems that were originally configured 
with two controllers.

None.

A public loop configuration (managed hubs 
attached to switches) is not supported.

None.

If you remove a fan or power supply (CRU) 
from a storage subsystem while the system is 
running, the storage-management software 
does not report an error message, and the 
component is not reported as missing.

Note: Fan and power supply CRU failures 
are reported.

Replace the missing fan or power supply 
CRUs immediately to ensure redundancy. 
Make sure that the fan or power supply CRU 
is properly seated in the controller unit.
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Number of supported logical drives
The supported logical drive limits are as follows:

• Windows NT with Service Pack 5 or greater will support up to 8 logical drives per 
storage subsystem (LUNs 0–7).

• Windows NT with Service Pack 5 supports up to 32 logical drives per storage 
subsystem (LUNs 0–31) if the host adapter also supports large LUNs and is 
configured correctly.

• Host adapters support a maximum number of logical drives. Refer to the host-
adapter documentation for specific information.

• The host-agent management method uses a special logical drive, called an 
access volume, to communicate with the controllers on the storage subsystem. 
The access volume uses one of the allowable logical drives. Therefore, managing 
storage subsystems with the host-agent software limits you to one fewer LUN 
than the maximum number that is supported by Windows NT and the host 
adapter.

Creating logical drives
A logical drive is a logical object that is the basic structure that you create to store 
data on the storage subsystem. A logical drive is configured across an array with a 
specific RAID level to meet application needs for data availability and Fibre Channel 
I/O performance. A logical drive is recognized by the operating system as one drive. 

You can add or delete logical drives in a standard (noncluster) configuration and in a 
cluster server environment.

Standard configuration
When you create new logical drives with the storage-management software, you must 
add the new logical drives to Windows NT. Refer to the Windows NT documentation 
for details about adding a drive. Remember that each logical drive (not array) is 
recognized by Windows NT as one drive. After creating logical drives, run the Hot Add 
and SM7devices utilities that are provided with the storage-management software. 
The Hot Add utility adds newly created logical drives to the operating system, and the 
SM7devices utility identifies logical drives by their associated operating system device 
names. For information about using these utilities, see “Using the Hot Add utility” on 
page 75 and “Using the SM7devices utility” on page 76.

Before either deleting logical drives with the storage-management software or using 
Configure → Reset Configuration, stop all input and output activity to the affected 
storage subsystem. Then use Disk Administrator to delete any partitions and to 
unassign drive letters that are associated with the logical drives.

Attention: If you do not use Disk Administrator first, registry information will be 
damaged.

Cluster server environment
When you create logical drives on one node in a cluster server environment, you must 
assign the same drive letter on the other node as well. After creating logical drives, 
run the Hot Add and SM7devices utilities that are provided with the storage-
management software. The Hot Add utility adds newly created logical drives to the 
operating system, and the SM7devices utility identifies logical drives by their 
associated operating system device names. For information about using these 
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utilities, see “Using the Hot Add utility” on page 75 and “Using the SM7devices utility” 
on page 76.

Use the following procedure to add logical drives in a cluster server environment:

1. Use the storage-management software to create a new logical drive. For specific 
instructions, refer to the Subsystem Management online Help.

2. Use the Hot Add utility to add the logical drive on Node A.

3. Use Disk Administrator on Node A to format the new logical drive.

4. Use the Hot Add utility to add the logical drive on Node B.

5. Use Disk Administrator on Node B to assign the same drive letter to the new 
logical drive as the one it has on Node A.

6. Start the Cluster Administrator on Node B, and use it to stop the cluster service.

7. Click Node B → File Stop → Cluster Service.

8. In Cluster Administrator, click Node B, and then click File → Evict Cluster Node.

9. Restart Node A.

10. On Node A, use Cluster Administrator either to create a new array or select an 
existing array to which you can add the new logical drive.

11. Select the array, and click File → New → Resource.

12. Name the new resource and click Physical Disk as the resource type.

13. Click Next.

14. Click Node A as the disk resource owner, and then click Next.

15. Specify any dependencies (other resources that Cluster Administrator must bring 
online) before this new disk resource is brought online.

16. Select the new disk from the drive parameter list, and then click Finish.

17. Uninstall the Cluster Server software from Node B.

18. Reinstall the Cluster Server software on Node B, and join the existing cluster that 
includes Node A.

Important: Edit the properties of the new disk to enable Node B to be a possible 
owner of the resource. You can redistribute the cluster resources between 
Nodes A and B and edit the properties of all cluster resources to include 
Node B. Move any cluster resources that belong to Node B from Node A 
back to Node B.

Using the Hot Add utility
The RDAC software includes a utility called Hot Add that you can use to add new 
logical drives dynamically without restarting the system. The utility registers the new 
logical drives with the operating system so that you can use Disk Administrator to 
create partitions, add device names, and so on. The Hot Add utility is installed as part 
of the RDAC package.

After you finish creating the logical drives on a particular storage subsystem, go to the 
host that is attached to that storage subsystem, and perform the following steps to 
use the hot add utility:

1. From a DOS command prompt, type:

hot_add

2. Press Enter.

The new logical drives are available through the Disk Administrator.
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Using the SM7devices utility
The SM7agent software includes a utility called SM7devices that you can use to view 
the storage subsystem logical drive that is associated with a particular operating 
system device name. This capability is helpful when you want to create drive letters or 
partitions for the logical drive using Disk Administrator.

After you finish creating the logical drives on a particular storage subsystem, go to the 
host that is attached to that storage subsystem, and perform the following steps to 
use SM7devices:

1. From a DOS command prompt, change to the \Program Files\SM7agent 
directory. 

2. Type:

SM7devices

3. Press Enter.

The software displays device identification information. For example, you might 
see:

\\.\PHYSICALDRIVE0 [Storage Subsystem Finance, Logical Drive DEBIT, LUN 
0, WWN <600a0b800006028600000000382060eb>]
\\.\PHYSICALDRIVE1 [Storage Subsystem Finance, Logical Drive CREDIT, LUN 
1, WWN <600a0b70006028600000000392060eb>]

Where PHYSICALDRIVEx = Diskx in Disk Administrator
Storage Subsystemx = the storage subsystem name
Logical Drivex= the logical drive name
LUNx = the logical unit number associated with the logical drive
WWNx = the worldwide name for the logical drive

Uninstalling storage-management software components
Use the following procedure if you need to uninstall one or more of the components of 
Storage Manager 7.02.

Attention:  Do not uninstall the RDAC component unless instructed to do so by IBM 
service personnel. The host-agent package requires RDAC to function properly. If you 
uninstall RDAC in a coexistence environment, you will loose Fibre Channel I/O path 
failover support for both Storage Manager 7.02 and storage-management software 
version 6.22.

1. Click Start → Settings → Control Panel → Add/Remove Programs.

The Add/Remove Programs Properties window opens.

2. From the list of programs, select the component that you want to uninstall.

For example, select Fibre Channel Storage Manager 7 Client.

3. Click Add/Remove.

The Confirm File Deletion window opens.

4. Click Yes to start the uninstallation process.

5. When the uninstallation is completed, click OK.
 76 IBM® Netfinity® FAStT Storage Manager Version 7.02 for Windows NT®  Installation and Support Guide  



Appendix A.   Notices

References in this publication to IBM products, programs, or services do not imply 
that IBM intends to make these available in all countries in which IBM operates. Any 
reference to an IBM product, program, or service is not intended to state or imply that 
only that IBM product, program, or service may be used. Subject to IBM’s valid 
intellectual property or other legally protectable rights, any functionally equivalent 
product, program, or service may be used instead of the IBM product, program, or 
service. The evaluation and verification of operation in conjunction with other 
products, except those expressly designated by IBM, are the responsibility of the 
user.

IBM may have patents or pending patent applications covering subject matter in this 
document. The furnishing of this document does not give you any license to these 
patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

This section contains trademarks and other important information.

Any references in this publication to non-IBM Web sites are provided for convenience 
only and do not in any manner serve as an endorsement of those Web sites. The 
materials at those Web sites are not part of the materials for this IBM product and use 
of those Web sites is at your own risk.

Edition Notice
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS 
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS 
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES 
OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some juris-
dictions do not allow disclaimer of express or implied warranties in certain transac-
tions, therefore, this statement may not apply to you. 

This publication could include technical inaccuracies or typographical errors. Changes 
are periodically made to the information herein; these changes will be incorporated in 
new editions of the publication. IBM may make improvements and/or changes in the 
product(s) and/or the program(s) described in this publication at any time.

This publication was developed for products and services offered in the United States 
of America and the United Kingdom. It is possible that this publication may contain 
reference to, or information about, IBM products (machines and programs), 
programming, or services that are not announced in your country. Such references or 
information must not be construed to mean that IBM intends to announce such IBM 
products, programming, or services in your country.

Requests for technical information about IBM products should be made to your IBM 
reseller or IBM marketing representative. No part of this publication may be 
reproduced or distributed in any form or by any means without prior permission in 
writing from the International Business Machines Corporation.
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Note to U.S. Government Users — Documentation related to restricted rights — Use, 
duplication or disclosure is subject to restrictions set forth in GSA ADP Schedule 
Contract with IBM Corp.

Trademarks
The following terms are trademarks of International Business Machines Corporation 
in the United States, other countries, or both:

IBM

Netfinity

JavaHelp is a trademark of Sun Microsystems, Inc. in the United States, other 
countries, or both.

Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation in the 
United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other 
countries.

Other company, product, and service names may be trademarks or service marks of 
others.
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Appendix B.   Storage subsystem/controller information record

Table 14 provides a data sheet on which you can record storage subsystem names, 
management types, hardware Ethernet addresses, and IP addresses. Make a copy of 
this table and complete the information for your storage subsystems and controllers. 
Use the information that is recorded in Table 14 to set up the BOOTP table for the 
network server and the host or Domain Name System (DNS) table. The information in 
Table 14 helps you add storage subsystems after initial installation. The column 
headings show a page reference for detailed instructions about obtaining the 
information. For a sample information record, see Table 9 on page 18.

Table 14. Storage subsystem and controller information record 

Storage 
subsystem 

name
(see page 18)

Management type 
(see page 15)

Controllers—Ethernet and IP 
addresses, and host name

(see pages 19 and 20 )

Host—IP 
address and 
host name

(see page 20)

Storage 
subsystem 
name:

Storage 
subsystem 
name:

Storage 
subsystem 
name:

Storage 
subsystem 
name:

Storage 
subsystem 
name:

Storage 
subsystem 
name:

Storage 
subsystem 
name:

Storage 
subsystem 
name:
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