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About this book

This book provides information about installing, setting up, and working with IBM® 
Netfinity® FAStT Storage Manager Version 7.02 in a Microsoft® Windows® 2000 
operating system environment. This Installation and Support Guide is written for 
system administrators. Use this guide to:

• Determine the hardware and software required to install the storage-management 
software.

• Integrate the necessary hardware components into your network.

• Install the storage-management software.

• Upgrade controller firmware, if necessary.

• Identify storage-management features unique to Windows 2000.

How this book is organized
Chapter 1, “Introduction,” on page 1 provides an overview of IBM Netfinity FAStT 
Storage Manager Version 7.02 and describes storage-subsystem management 
methods, configuration types, types of installations, and installation requirements.

Chapter 2, “Preparing for installation,” on page 13 discusses preparing for a network 
installation including setting up a Microsoft DHCP server or a UNIX BOOTP server, 
and describes other setup tasks.

Chapter 3, “Installing software in a standard configuration,” on page 27 gives the 
procedure for installing the software in a standard (noncluster) environment.

Chapter 4, “Installing software in a cluster server environment,” on page 35 gives the 
procedure for installing the software in a cluster server environment.

Chapter 5, “Completing the installation,” on page 47 describes Enterprise 
Management and Subsystem Management, changing NVSRAM configuration 
settings, and completing the installation tasks.

Chapter 6, “Operating system support,” on page 55 discusses Windows 2000 
restrictions, using the SM7devices utility, and other software features.

 Appendix A, “Notices,” on page 61 provides product notices and trademark 
information.

Appendix B, “Storage subsystem/controller information record,” on page 63 provides 
a data sheet template that you use to create a controller information record.

Notices used in this book
This book contains notices to highlight information or provide safety information:

• Note: These notices provide important tips, guidance, or advice.

• Attention: These notices indicate possible damage to programs, devices, or 
data. An attention notice is placed just before the instruction or situation in which 
damage could occur.

• Important: These notices provide information that might help you avoid 
inconvenient or problem situations.
© Copyright IBM Corp. 2000  xi



Related publications
The following publications are available in Adobe Acrobat Portable Document Format 
(PDF) on the IBM Netfinity FAStT Storage Manager Version 7.02 CD and on the 
World Wide Web at http://www.ibm.com/pc/support/

Note: The items denoted by an asterisk (*) in the list indicate publications that are 
printed and come with the IBM FAStT200 and FAStT200 High Availability (HA) 
Storage Servers.

• IBM Netfinity FAStT Storage Manager Version 7.02 for Windows 2000 Installation 
and Support Guide (this book)

• IBM Netfinity FAStT Storage Manager Version 7.02 for Windows NT Installation 
and Support Guide

• IBM FAStT200 and FAStT200 HA Storage Servers Installation and User’s Guide*

• IBM Netfinity Fibre Channel Storage Manager Concepts Guide

When you complete the tasks in this Installation and Support Guide, refer to the 
following online Help.

• IBM Netfinity FAStT Storage Manager Version 7.02 Enterprise Management 
Online Help. Use this help system for more information about working with the 
management domain.

• IBM Netfinity FAStT Storage Manager Version 7.02 Subsystem Management 
Online Help. Use this help system for more information about managing storage 
subsystems.

You can access the help systems from the Enterprise Management and Subsystem 
Management windows in Netfinity FAStT Storage Manager 7.02. Click the Help menu 
on the toolbar or press F1.

The help systems contain operating information common to all operating 
environments. Refer to this Installation and Support Guide for information specific to 
Windows 2000.

Additional publications are available for purchase from IBM. For a list of publications 
available in your country:

• In the U.S. and Puerto Rico, call 1-800-426-7282.

• In the United Kingdom, call 01705-565000 or 0161-9056001.

• In Canada, call 1-800-465-1234.

• In other countries, contact the IBM support organization that services your area, 
your IBM marketing representative, or your IBM reseller.
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Chapter 1.  Introduction

This installation and support guide provides information on preparation, installation, 
configuration, and starting the IBM Netfinity FAStT Storage Manager Version 7.02 in a 
Windows 2000 environment. This book applies to system administrators. Before you 
begin the installation of this product, consult the following documentation: 

• Readme.txt file - Read this text file first. It is located in the root directory on the 
CD, and contains the latest installation and user information about the storage-
management software and hardware components.

• IBM Netfinity Fibre Channel Concepts Guide - Use this reference document to 
become familiar with terminology and features of the storage-management 
software.

When you have finished the entire installation process, refer to the following online 
Help systems, which contain information common to all operating system 
environments. For installation information specific to Windows 2000, refer to this 
book.

• Enterprise Management window Help - Use this online Help system to learn more 
about working with the entire management domain.

• Subsystem Management window Help - Use this online Help system to learn 
more about managing individual storage subsystems.

Terminology
Throughout this book, the term storage-management software and Storage Manager 
7.02 refer to IBM Netfinity FAStT Storage Manager Version 7.02 as a whole. This 
book identifies by name the individual components of the storage-management 
software. Refer to the following table for product information status at the time of the 
Storage Manager 7.02 release.

Note: Product firmware must be at version 4.x to be compatible with Storage 
Manager 7.02.

It is important that you become familiar with the new terminology. For a complete list 
of the new terms, refer to IBM Netfinity Fibre Channel Storage Manager Concepts 
Guide. 

Product name

Product 
release 

firmware 
version

Released 
storage-

management 
software 
version

Machine 
type Model

Netfinity FAStT200 4.x 7.02 3542 1RU

Netfinity FAStT200 HA 4.x 7.02 3542 2RU

Netfinity Fibre Channel RAID Controller Unit 3.x, 4x 7.01, 7.02 3526 1RU

Netfinity FAStT500 RAID Controller Enclosure Unit 4.x 7.01, 7.02 3552 1RU
© Copyright IBM Corp. 2000  1



Installation process overview
The installation involves the following main process:

• Reading the entire contents of this chapter.

• Chapter 2, “Preparing for installation,” on page 13.

• Chapter 3, “Installing software in a standard configuration,” on page 27 or 
Chapter 4, “Installing software in a cluster server environment,” on page 35.

• Chapter 5, “Completing the installation,” on page 47.

About the storage-management software
The storage-management software contains the following components:

• Client software

• Host-agent package

• RDAC package

Client software
The Storage Manager 7.02 client software provides the graphical user interface (GUI) 
for managing storage subsystems. It features two main components:

• Enterprise Management window. Use this window to add, remove, and monitor all 
storage subsystems within the management domain.

• Subsystem Management window. Use this window to manage individual storage 
subsystem components.

Host-agent package
The Storage Manager 7.02 host-agent package consists of two software components:

• Host-agent software. You can use the host-agent software to manage storage 
subsystems through the host Ethernet connection. The host-agent software takes 
requests from a management station that is connected to the host through an 
Ethernet connection and passes the requests to the storage subsystem 
controllers through the Fibre Channel I/O path. For more information about 
managing storage subsystems through the host-agent, see “Host-agent managed 
method” on page 3.

• SM7devices utility. You can use the SM7devices utility to associate storage 
subsystem logical drives with operating system device names. For more 
information about using SM7devices, see “Using the SM7devices utility” on page 
58.

RDAC package
The Redundant Disk Array Controller (RDAC) package consists of the following 
software component:

RDAC multi-path device driver. The RDAC multi-path device driver provides 
failover support to the other controller if a component along the Fibre Channel I/O 
path fails.
 2 IBM® Netfinity® FAStT Storage Manager Version 7.02 for Windows® 2000 Installation and Support Guide  



Storage subsystem management methods
The storage-management software provides two methods for managing storage 
subsystems — the host-agent managed method and the directly managed method. 
Depending upon your specific storage subsystem configurations, you can use either 
or both methods.

Host-agent managed method
When you use this method, you manage the storage subsystems through the Fibre 
Channel I/O path to the host. The storage subsystem can be managed from the host 
computer or management station that is attached to the host through an Ethernet 
connection.

The advantages of managing storage subsystems through the host-agent include:

• You do not have to run Ethernet cables to the controllers.

• You do not need a BOOTP server to connect to the network.

• You do not need to perform the controller network configuration tasks that are 
described in Chapter 2, “Preparing for installation,” on page 13.

• When adding devices, you have to specify a host name or IP address only for the 
host instead of for the individual controllers in a storage subsystem. Storage 
subsystems that are attached to the host are automatically discovered.

The disadvantage of using the host-agent method include: 

• You are limited to configuring one less Logical Unit Number (LUN) than the 
maximum number that is allowed by the operating system and the host adapter 
that you are using.

• The host-agent requires a special logical drive, called an access volume, to 
communicate with the controllers in the storage subsystem.

Note: The access volume uses one of the logical unit numbers (LUNs). Windows NT 
allows a maximum number of LUNs depending on which Service Pack is 
installed and which host adapter you are using. For more information, see 
“Number of logical drives supported” on page 56.

If you are upgrading controllers from firmware version 3.x to version 4.x and your host 
system has already configured its maximum number of LUNs, you must give up a 
LUN to be used as an access volume.

Important: Windows 2000 allows a maximum number of LUNs, depending on your 
host adapter. If your host already has the maximum number of LUNs 
configured, either use the directly managed method or give up a LUN for 
use as the access volume. For information on your specific configuration, 
see “Number of logical drives supported” on page 56. Contact IBM 
support for additional assistance.
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Figure 1. Host-agent managed storage subsystems

Directly managed method
In this method, you use storage management client software to manage the storage 
subsystem directly over the network through each controller’s Ethernet connection, 
see Figure 2 on page 5. To do so, you must attach a cable to each Ethernet 
connection on the controller tray and define each controller’s IP address and host 
name.

The advantages of using the directly managed method include:

• You can use a Windows 2000 management station to manage storage 
subsystems connected to a host that is using an operating system not supported 
by the storage-management software. Contact IBM support for more information.

• You can configure the maximum number of LUNs (logical unit numbers) 
supported by your operating system and host adapters. The directly managed 
method does not require an access volume and does not require the use a LUN.

The disadvantages of using this method directly include:

• Two Ethernet cables are required to connect both storage subsystem controllers 
to a network.

• You must specify an IP address or host name for each controller when you add 
storage subsystems.

Ethernet

Host computer

Controller

Controller

Controller

Controller

Fibre Channel
I/O path

Management station
(one or more)

Running the
host-agent software

Storage subsystems

Note: The host can act as a
management station also.
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Figure 2 shows a system in which storage subsystems are managed directly.

Figure 2. Directly managed storage subsystem

Configuration types
You can install Storage Manager 7.02 in one of two configurations:

• Standard (noncluster) configuration. Refer to Table 1 on page 6.

• Cluster server configuration. Refer to Table 2 on page 8.

Standard (noncluster) configuration
Table 1 on page 6 indicates where the storage-management software components 
are installed in a standard (noncluster) configuration. Figure 3 on page 7 shows a 
sample standard (noncluster) configuration.
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Fibre Channel
I/O path

Management station
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Controller

Controller

Controller

Controller
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Table 1. Where to install software components in a standard (noncluster) configuration 

Software component Where installed Notes

Storage Manager 7.x client 
(SM7client)

You can install the client 
package on either of the 
following:

• Management station (for 
direct or host-agent 
management)

• Host computer (for a non-
network configuration 
similar to previous 
versions of the storage-
management software)

• Management stations 
If you install the SM7client software on one or more 
management stations, you can choose to manage 
storage subsystems directly through Ethernet 
connections to the controllers, over the network 
through the host-agent, or a combination of both 
methods.

• Host computer
If you install the SM7client software on the host 
computer, the host computer does not need to be 
connected to a network as long as the host-agent 
software is installed. However, the host computer 
must have the TCP/IP software installed and you 
must assign a static IP address to the host.

RDAC Host The RDAC component is required for controller failover 
support and for installing and using the host-agent 
software. Make sure you install RDAC on each host 
connected to the storage subsystem.

Storage Manager 7.02 
Agent (SM7agent)

Host You must install the SM7agent software even if you 
choose not to manage storage subsystems with the host-
agent software. The host-agent contains important 
utilities that are necessary for operating the storage-
management software.
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The following figure shows an example of a standard (noncluster) configuration.

Figure 3. Sample standard (noncluster) configurations

Cluster server configuration
The following table describes the storage-management software components that are 
installed in a cluster server environment. Refer to Figure 4 on page 9 for a sample 
cluster configuration.

Important: Be sure to install all storage-management software components on each 
server in your cluster.

Ethernet

Host computer

Controller

Controller

Controller

Controller

Fibre Channel
I/O path

Management station

RDAC and
host-agent

The client software is
installed on one or more

management systems,
or on the host computer.

Storage subsystems
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Table 2. Where to install software components in a cluster server configuration 

Software component Where installed Notes

Storage Manager 7.02 client 
(SM7client)

You can install the SM7client 
package on either of the 
following:

• Management station 
(for direct or host-agent 
management)

• Nodes A and B 
(for direct or host-agent 
management)

• Management stations 
If you install the SM7client software on one or 
more management stations, you can choose to 
manage storage subsystems directly through 
Ethernet connections to the controllers, over the 
network through the host-agent, or a combination 
of both methods.

• Nodes A and B
If you install the SM7client on the cluster servers 
(nodes A and B), the server does not need to be 
connected to a network as long as the host-agent 
software is installed. However, the host computer 
must have the TCP/IP software installed, and you 
must assign a static IP address to the cluster 
server.

RDAC Nodes A and B RDAC is required for controller failover support and for 
installing and using the host-agent software. Make sure 
that you install RDAC on each host connected to the 
storage subsystem.

Storage Manager 7.02 agent 
(SM7agent)

Nodes A and B You must install the host-agent even if you choose not 
to manage storage subsystems with the host-agent 
software. The host-agent contains important utilities 
that are necessary for operating the storage-
management software.
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Figure 4 shows an example of a cluster server configuration.

Figure 4. Sample cluster server configuration

Installation types 
You can install the storage-management software in two types of hardware 
environments:

• New storage subsystem environment. You are installing new storage 
subsystems with controllers that are using firmware version 4.00.02, and that you 
will manage with Storage Manager 7.02. Go to “System requirements” on page 
10.

• Existing storage subsystem environment. You are installing the storage-
management software in an environment with existing storage subsystems. Refer 
to Table 3 on page 10 for your installation options in an environment with existing 
storage subsystems.

Ethernet

Fibre Channel
I/O path

Management station
(one or more)

Cluster server
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Cluster server
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RDAC, and SM7agent

Controller

Controller

Storage subsystems

Managed hub or
switch

The SM7client software
is installed on one or more
management stations, or
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System requirements
This section provides detailed information about the hardware, software, and 
operating requirements for Storage Manager 7.02.

Hardware requirements
Table 4 lists the hardware required for installing Storage Manager 7.02.

Table 3. Configurations for existing storage subsystems 

Existing storage 
subsystems with: Options

Controllers (machine types: 
3526 and 3552) running 
firmware versions from 
4.00.00 through 4.00.01

Option 1 — Be sure to uninstall the previous version of the storage-management 
software before installing version 7.02. Then, install Storage Manager 7.02 and 
upgrade the controller firmware from versions 4.00.00 through 4.00.01 to version 
4.00.02. You will manage the existing storage subsystems with Storage Manager 7.02. 
Go to “System requirements”.

Option 2 — Continue using your existing version 4.00.00 through 4.00.01 controller 
firmware. Be sure to uninstall the previous version of the storage-management 
software before installing version 7.02. You can manage these existing storage 
subsystems through Storage Manager 7.02, which includes components that are 
compatible with these older firmware versions. The functional differences between 
your existing controller firmware and the controller firmware (4.00.02) is provided on 
the installation CD. Refer to the README file located in the \W2K\ directory on the 
installation CD for more information. Go to “System requirements”.

Controller (machine type: 
3526) running firmware 
version 3.x

Option 1 — If upgrading from Windows NT 4.0 to Windows 2000, use the Windows 
NT migration process to upgrade the controllers to firmware version 4.00.02; then, 
upgrade your operating system from Windows NT to Windows 2000. For more 
information refer to Table 9 on page 27. 

Table 4. Hardware requirements for the storage-management software 

Hardware component Requirements

A BOOTP server 
(for directly managed 
storage subsystems only).

• Microsoft BOOTP-compatible DHCP server for Windows®

• UNIX® BOOTP server

Storage subsystems 
(one or more).

Storage subsystems with controllers running firmware version 
4.00.00 through 4.00.02

Note: Make sure that you read “Installation types” on page 9 
for information on managing these storage subsystems 
when existing storage subsystems are physically 
connected to the same host that you will connect to the 
new storage subsystems.

Fibre Channel (FC) host 
adapters.

The following Fibre Channel host adapters were tested with the 
storage-management software:

• IBM Netfinity FAStT host adapter 
(part number: 00N6881)

For information on specific host adapter requirements:

• Refer to \W2K\Host_Adapter directory on the installation 
CD.

• Read the host adapter documentation.

• Refer to the IBM Web site, http://www.ibm.com/pc/support
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Disk space and administrators privilege requirements
Table 5 lists the disk space and administrator privileges required for installing the new 
version of the storage-management software.

Operating system requirements
Each management station, host computer, or cluster server requires one of the 
following operating systems:

Management stations and host computers. Install one of the following operating 
systems:

• Windows 2000 Server

• Windows 2000 Professional

• Windows 2000 Advanced Server (required for a cluster environment).

Cluster servers. Install the Windows 2000 Advanced Server operating system.

If you are upgrading from Windows NT 4.0 to Windows 2000 in a standard 
(noncluster) configuration, go to “Upgrading from Windows NT 4.0 to Windows 2000 
in a standard configuration” on page 13.

Fibre Channel (FC) fabric 
switches (if needed for the 
desired configuration).

The following Fibre Channel fabric switches were tested with 
the storage-management software:

• IBM 8-port Fibre Channel switch 
(machine type: 2109-S08)

• IBM 16-port Fibre Channel switch 
(machine type: 2109-S16)

For specific Fibre Channel switch setup requirements:

• Read the switch documentation.

• Refer to the IBM Web site, http://www.ibm.com/products

Fibre Channel (FC) 
managed hub (if needed for 
the desired configuration).

The following managed hub was tested with the storage-
management software:

• IBM Fibre Channel managed hub 
(machine type: 3534)

For specific Fibre Channel managed hub setup requirements:

• Read the managed hub documentation.

• Refer to the IBM Web site, http://www.ibm.com/products

Table 4. Hardware requirements for the storage-management software 

Hardware component Requirements

Table 5. Disk space and administrator privileges requirements 

Package Disk space requirement Administrator privilege

Client 35 MB Not required

RDAC 1 MB Required

Host-agent 1 MB Required
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If you are upgrading from Windows NT 4.0 to Windows 2000 in a cluster 
configuration, go to “Upgrading from Windows NT 4.0 to Windows 2000 in a cluster 
configuration” on page 13.

If you are not upgrading from Windows NT to Windows 2000, go to “Deciding how to 
manage storage subsystems” on page 14.
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Chapter 2.  Preparing for installation

This chapter helps you plan and prepare for installing the storage-management 
software.

Upgrading from Windows NT 4.0 to Windows 2000 in a standard 
configuration

If you already have Windows 2000 installed as your operating system, go to “Deciding 
how to manage storage subsystems” on page 14.

Important: To avoid possible data loss, you must follow the instructions to uninstall 
any previous versions of the storage-management software, including 
RDAC, before upgrading from Windows NT 4.0 to Windows 2000.

You cannot upgrade from Windows NT to Windows 2000 if your storage subsystem is 
the boot device.

Note: Controllers must be running firmware 4.x prior to upgrade.

Follow these steps to upgrade from Windows NT 4.0 to Windows 2000:

1. Be sure that the storage subsystem contains no system-dependent files or 
directories, such as paging files.

Note: All configuration information is deleted during the uninstall process. You 
will need to install the storage-management software as if it is a first time 
installation.

2. Uninstall the storage-management software using the uninstall procedure that 
came with the version of the storage-management software that you are currently 
using. Do not use the procedure given in this book.

3. Use Microsoft’s instructions to upgrade to Windows 2000.

4. Install Storage Manager 7.02 as a new installation by following the instructions 
beginning at “Deciding how to manage storage subsystems” on page 14.

Upgrading from Windows NT 4.0 to Windows 2000 in a cluster 
configuration

If you already have Windows 2000 installed as your operating system, go to “Deciding 
how to manage storage subsystems” on page 14.

Note: To avoid losing access to a cluster, you need to do a rolling upgrade. A rolling 
upgrade means upgrading so that the services and resources offered by the 
cluster are always available, even though the nodes being upgraded are not 
available. 

If you have applications installed in the cluster environment that do not support 
a rolling upgrade, then you will have to either:

• Put those resources offline before the upgrade, and then put them back 
online afterwards, or

• Use a different upgrade method
© Copyright IBM Corp. 2000  13



Follow these steps to upgrade from Windows NT 4.0, Enterprise Edition, to Windows 
2000 Advanced Server:

1. After you install the cluster server, reinstall the latest Service Pack for NT 4.0 
(Service Pack 5.0 or greater).

2. On node A, open Cluster Administrator.

3. Highlight node A, then pause the node (File → Pause Node).

4. Double-click on the Active Groups folder in the right window of Cluster 
Administrator.

5. Select each group listed, and move it to node B.

6. Uninstall all storage-management software components from node A. Do not use 
the procedure given in this book. Uninstall the storage-management software 
using the uninstall procedure that came with the version of the storage-
management software that you are currently using.

7. Follow Microsoft’s instructions to upgrade node A from Windows NT to Windows 
2000 Advanced Servers.

Note: During the upgrade, the existing cluster server installation will be detected, 
and clustering for Windows 2000 Advanced Server will be installed. After 
the upgrade is finished, node A will rejoin the cluster, but it will still be 
paused.

8. Verify that the Host Bus Adapter (HBA) driver versions are correct. If they are not 
the certified version, use the README file in \W2K\Host_Adapter directory on the 
installation CD to upgrade the driver versions before continuing.

9. Verify that node A was successfully upgraded to Windows 2000 Advanced 
Server.

10. Install RDAC for Windows 2000 onto node A.

11. Install Storage Manager 7.02 for Windows 2000 components (SM7client and 
SM7agent)

12. Run Cluster Administrator, and resume the node (File → Resume Node).

13. Repeat steps 1 through 12 on node B.

14. Install Storage Manager 7.02 as a new installation by following the instructions 
beginning at “Deciding how to manage storage subsystems”. 

Deciding how to manage storage subsystems
If you have not already done so, see Chapter 1, “Introduction,” on page 1 for 
information about the following two methods for managing storage subsystems:

• Direct management through an Ethernet connection to each controller on the 
storage subsystem

• Host-agent management through the host-agent software that is installed on the 
host computer that is connected to the storage subsystem

You can use one or both methods. However, because many of the preparation tasks 
for installation depend on which method you use, before you begin, decide how you 
want to manage the storage subsystems on your network.

Reviewing a sample network
Figure 5 on page 15 shows an example of a directly managed storage subsystem 
network setup (see network A). This network contains the following components:

• BOOTP server
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• Management station (NMS) for Simple Network Management Protocol (SNMP) 
traps

• Host that is connected to a storage subsystem through a Fibre Channel I/O path

• Management station connected by Ethernet cable to the storage subsystem 
controllers

Figure 5 shows an example of a host-agent managed storage subsystem network 
setup (see network B). This network contains the following components:

• A host that is connected to a storage subsystem through a Fibre Channel I/O path

• A management station that is connected by Ethernet cable to the host

Figure 5. Sample network using directly and host-agent managed storage subsystems

Go to “Preparing for a network installation”.

Preparing for a network installation 
Before you install the storage-management software, make sure that the network 
components are set up and operating properly, and that you have all the host and 
controller information needed for the software to operate correctly. To do this, perform 
the tasks summarized in Table 6 on page 16 (referring to the appropriate procedures). 
Use Table 12 on page 63 as a data sheet to record storage subsystem and controller 
information. An example of a completed information record is shown in Table 7 on 
page 17.
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Table 6. Network preparation task summary 

Task o perform For direct or 
host-agent? Why perform this task? For instructions, see:

Step 1 - Install all hardware 
components (host computers, 
storage subsystems, cables, and 
so on) that you want to connect 
to the network.

Direct and host-
agent

To ensure that the network 
hardware is present.

The installation guide specific to 
the hardware components.

Step 2 - Establish and record a 
naming convention for the 
storage subsystems connected 
to the network.

Direct and host-
agent

To add the storage 
subsystems to the 
management domain after 
installing the software.

“Deciding how to name the 
storage subsystems” on page 
17.

Step 3 - Determine the hardware 
Ethernet address for each 
controller in all storage 
subsystems connected to the 
network.

Direct To set up the BOOTP server 
to provide network 
configuration information to 
the controllers.

“Identifying the hardware 
Ethernet address for each 
controller” on page 18.

Step 4 - Obtain IP addresses 
and host names from the 
network administrator.

Direct and host-
agent

For host-agent management, 
you need the IP addresses 
and host names of the host 
on which the host-agent 
software will run.

For direct management, you 
need the IP addresses of 
each controller in the storage 
subsystems to configure the 
BOOTP server. The BOOTP 
server can then provide 
network configuration 
information to the controllers. 
Also, you use the IP 
addresses of the controllers 
to set up the host or DNS 
table.

“Obtaining IP addresses for 
hosts and controllers” on page 
20

Step 5 - Set up the BOOTP 
server to provide network 
configuration information for a 
specific controller.

Direct To provide network 
configuration information to 
the controllers using the 
BOOTP server.

“Setting up the BOOTP server” 
on page 20.

Step 6 - Verify that the TCP/IP 
software is installed and set up 
the host or DNS table.

Direct Installing the client software 
on a management station 
ensures that the 
management station is 
configured to reach the 
controllers over the network. 

“Verify the TCP/IP protocol and 
set up the host or DNS table” on 
page 24.

Step 7 - Power on the devices 
connected to the network.

Direct and host-
agent

To ensure that all devices and 
links are operational.

The installation guide specific to 
the hardware components.
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The following table shows a sample information record with entries for a directly 
managed storage subsystem and a host-agent managed storage subsystem.

Table 12 on page 63 provides a data sheet on which you can record storage 
subsystem names, management types, hardware Ethernet addresses, and IP 
addresses. Make a copy of this table and complete the information for your storage 
subsystems and controllers. Use the information recorded in Table 12 to set up the 
BOOTP table for the network server and the host or DNS (Domain Name System) 
table. The information in Table 12 helps you add storage subsystems after initial 
installation. The column headings show a page reference for detailed instructions 
about obtaining the information. For a sample information record, see Table 7.

Completing the preparation tasks
In addition to the task information outlined in Table 6 on page 16, the following list 
contains tasks that you might need to perform before you are ready to install Storage 
Manager 7.02. 

• “Deciding how to manage storage subsystems” on page 14.

• “Identifying the hardware Ethernet address for each controller” on page 18.

• “Obtaining IP addresses for hosts and controllers” on page 20.

• “Setting up the BOOTP server” on page 20.

• “Verify the TCP/IP protocol and set up the host or DNS table” on page 24.

• “Enabling ports for operation through a firewall” on page 24.

Deciding how to name the storage subsystems
As you set up your network, decide on the naming convention for the storage 
subsystems. After you install the storage-management software and start it for the 
first time, all storage subsystems in the management domain display as <unnamed>. 
Use the Subsystem Management window to rename the individual storage 
subsystems.

Table 7. Sample information record 

Storage 
subsystem 

name
(see page 17)

Management 
type 

(see page 14)

Controllers—Ethernet and IP 
addresses, and host name

(see pages 18 and 20)

Host—IP 
address 

and host name
(see page 20)

Controller A Controller B

Storage 
subsystem 
name: Finance

Direct Hardware 
Ethernet 
address = 
00a0b8020420

Hardware 
Ethernet 
address = 
00a0b80000d8

IP address = 
192.168.1.13

IP address = 
192.168.1.14

Host = Denver_a Host = Denver_b

Storage 
subsystem 
name: 
Engineering

Host-agent IP address = 
192.168.2.22

Host = Atlanta
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The following list provides tips for naming storage subsystems:

• There is a 30-character limit. All leading and trailing spaces are deleted from the 
name.

• Use a unique, meaningful naming scheme that is easy to understand and 
remember.

• Avoid arbitrary names or names that would quickly lose their meaning in the 
future.

• The software displays storage-subsystem names with the prefix Storage 
Subsystem. Therefore, if you rename a storage subsystem Engineering it 
displays as Storage Subsystem Engineering.

When you have decided on a naming scheme, record the storage subsystem names 
in the information record (Table 12 on page 63).

If you are directly managing your storage subsystem, go to “Identifying the hardware 
Ethernet address for each controller”. If you are going to manage your storage 
subsystem through the host-agent, go to “Obtaining IP addresses for hosts and 
controllers” on page 20.

Identifying the hardware Ethernet address for each controller
Use the following procedure if you plan to directly manage storage subsystems 
through Ethernet connections to each controller. If you plan to manage storage 
subsystems using the host-agent software, skip this procedure and go to “Obtaining 
IP addresses for hosts and controllers” on page 20.

1. Remove the front bezel from the controller unit (machine types 3526 and 3552), 
as shown in Figure 6. Carefully pull the bottom of the bezel out to release the pins 
�1�; then slide the bezel down �2�.

Figure 6. Removing the controller-unit bezel from machine types 3526 and 3552
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2. Unlock and open the levers on the RAID controllers (models 3526 and 3552).

Figure 7. Location of the hardware Ethernet address on machine types 3526 and 3552

3. The hardware Ethernet address labels are located on the front of each controller, 
as shown in Figure 7 and Figure 8.

The number will be in the form xx.xx.xx.xx.xx.xx (for example, 00.a0.b8.00.00.d8).

Figure 8. Location of the hardware Ethernet address on machine type 3542

4. Record each Ethernet address in the information record (Table 12 on page 63).

5. To replace the bezel on machine types 3526 and 3552, slide the top edge under 
the lip on the chassis �1�; then push the bezel bottom until the pins snap into the 
mounting holes �2�, as shown in Figure 9 on page 20. 

Hardware Ethernet
address label

Hardware Ethernet
address label
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Figure 9. Replacing the controller-unit bezel on models 3526 and 3552

6. Continue with “Obtaining IP addresses for hosts and controllers”.

Obtaining IP addresses for hosts and controllers

1. Assign (or obtain from your network administrator) a unique IP address and the 
associated host name for each controller in every storage subsystem on the 
network. Record the IP address and host name for each controller in the 
information record (Table 12 on page 63). Then, go to “Setting up the BOOTP 
server”.

2. Contact your network administrator to obtain the IP address and host name for 
each host on which you plan to install the host-agent software for managing 
storage subsystems. Record the IP address and host name for the host in the 
information record (Table 12 on page 63). Then, go to “Verify the TCP/IP protocol 
and set up the host or DNS table” on page 24.

Setting up the BOOTP server
If you plan to directly manage storage subsystems through the Ethernet connection to 
each controller, select the procedure you plan to use for setting up the BOOTP server: 

Select the appropriate procedure for setting up the BOOTP server.

• When using a Microsoft BOOTP-compatible DHCP server, go to “Using Microsoft 
DHCP as a BOOTP-compatible server” on page 21.

• When using a UNIX BOOTP server, go to “Using a UNIX BOOTP server” on page 
22.

If you plan to manage storage subsystems using the host-agent software, go to “Verify 
the TCP/IP protocol and set up the host or DNS table” on page 24.

If you Go to

Manage storage subsystems directly Step 1

Manage storage subsystems with the host-agent Step 2

Note: If you intend to manage some storage subsystems directly and others with the host-
agent software, complete both of the following steps.
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Using Microsoft DHCP as a BOOTP-compatible server
You must use a version of Dynamic Host Configuration Protocol (DHCP) that supports 
BOOTP static addressing. To use a DHCP server, you must have a DHCP Manager 
installed. If a DHCP Manager is installed on the system, go to “Setting up a DHCP 
server”. If a DHCP Manager is not installed, use the following installation procedure.

Use the following procedure to install the DHCP Manager:

1. Click Start → Settings → Control Panel → Add/Remove Programs

2. In the Network window that opens, scroll to and click the Networking Services → 
Details.

3. Under Subcomponents of Networking Services, check the box next to Dynamic 
Host Configuration Protocol, and click OK.

4. If prompted, type the full path to the Windows 2000 distribution files and click 
Continue.

The required files will be copied to your hard drive. The server software can be 
used after restarting the system.

5. Continue with “Setting up a DHCP server”.

Note: After installing the DHCP Manager, you can refer to its online help for 
additional information.

Setting up a DHCP server
Use the following procedure to create a scope and to set up the DHCP server. A 
scope defines a group of controllers by their IP addresses. You must create and 
configure a scope so that dynamic IP addresses can be assigned to controllers on 
your network. Refer to the information that you provided in Table 12 on page 63. 
Before you begin, read through the instructions to determine what information is 
required, and then, request the information from your network administrator.

Note: The following steps and window example assume that you are configuring a 
Windows 2000 DHCP server using its DHCP Manager.

1. Click Start → Programs → Administrative Tools → DHCP Manager.

The DHCP Manager window opens.

2. Highlight the server you want to configure.

The add a scope window opens. Use the following instructions. 

a. Enter a scope name and description.

Figure 10. Create scope - (Local) window
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b. Type the starting and ending IP addresses of the controllers that you are 
configuring on the network.

For example, if you are configuring 50 controllers on a 192.168.1.0 subnet, 
set the starting address to 192.168.1.1, and set the ending address to 
192.168.1.50. 

Note: If each field does not contain at least three characters, press the 
period (.) key to advance to the next field. If you have only one 
controller, type its address for both the starting and ending addresses.

c. Type the subnet mask (obtained from your network administrator).

d. Using the Add Exclusions screen, enter IP addresses that need to be 
excluded from the beginning and ending addresses that you just entered in 
step b, then click Add.

e. Set the Lease Duration (obtained from your network administrator).

f. Configure the DHCP options:

Note: Be sure that you configure the DHCP options now. If you want to 
configure the options later, go to the DHCP screen and open the 
directory structure for the Scope that you created in step 2. Right-click 
Scope Options → Configure Options and follow the instructions. 

(1) To configure the DHCP options, begin by adding an IP address for a 
router.

(2) Add the domain name and DNS servers.

(3) Enter the server name and IP address in the WINS Servers window.

(4) When the scope has successfully completed, click Yes to activate it.

You return to the DHCP Manager window.

3. Open the directory structure below the scope you created in step a on page 21.

4. Right-click on Reservation, select New Reservation and follow the instructions.

Important: At the bottom of the New Reservations window, make a selection 
under Supported Type. Be sure that you select both.

a. Click General Tab. Scroll through the list and select Host Name.

b. Type a specific host name for each controller. Be sure that you use the same 
name assigned as the reservation name.

c. Repeat step 4 until you have added the host names for all of the controllers.

d. When you finish typing the information for all of the controllers, click Close.

5. When you have finished setting up the DHCP server, you must recycle the power 
before any modifications in the DHCP will take effect.

If the storage subsystem is powered up, to recycle the power, power down the 
storage subsystems. Then, power up the storage subsystems 

6. Continue with “Verify the TCP/IP protocol and set up the host or DNS table” on 
page 24.

Using a UNIX BOOTP server
Table 8 and Table 12 on page 63 provide information for setting up the BOOTP table 
and making the required entries to support the controllers in the storage subsystems. 
Use a text editor to edit the bootptab file in the /etc directory.
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Note: The RMS and NMS entries used in previous versions of the storage-
management software version 6.22, are not required when using Storage 
Manager 7.02 to manage storage subsystems with controllers running 
firmware version 4.x.

Example for editing a UNIX BOOTP table
The following example of a BOOTP table assumes that you are configuring a UNIX 
BOOTP server, such as a server on Network A, as shown in Figure 5 on page 15. The 
s4.default:\ entry denotes settings that are common to all controllers. The 
tc=s4.default:\ entry associates this common setting group to a specific controller.

s4.default:\ (common settings)

ht=ether:\

sm=255.255.248.0:\

gw=192.168.1.1:\

hn:

denver_a:\

tc=s4.default:\ (refers to common settings)

ip=192.168.1.13:\

ha=00a0b8020420:

denver_b:\

tc=s4.default:\

ip=192.168.1.14:\

ha=00a0b80000d8:

Table 8. Required entries for setting up the UNIX BOOTP server 

Entry Description Sample format in 
BOOTP server

Subnet mask Mask that is used to route packets to defined 
subnets.

dot notation
(sm=255.255.255.0)

Router IP address of the host computer that routes 
packets to networks.

dot notation
(gw=192.168.1.1)

Host name for 
the controller

Host name that is associated with the controller 
(see Table 12 on page 63).

host name
(Denver_a)

IP address IP address of the controller (see Table 12 on 
page 63).

dot notation
(ip=192.168.1.13)

Ethernet 
address

The Ethernet address of the controller hardware 
(see Table 12 on page 63).

hexadecimal notation
(ha=00a0b8020420)
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When you finish setting up the BOOTP table, perform the following:

1. If the storage subsystem power is on, power down the subsystem, then, power up 
the storage subsystems.

You must cycle the power to the storage subsystems for the parameters in the 
BOOTP table to take affect.

2. Go to “Verify the TCP/IP protocol and set up the host or DNS table”. 

Verify the TCP/IP protocol and set up the host or DNS table
Make sure that the host names for the controller correspond to the appropriate IP 
addresses for the controllers. Use the following procedure to verify that the TCP/IP-
protocol software is installed on the management station and to set up the host or 
DNS (Domain Name System) table.

Note: You might choose to use the Windows Internet Name Service (WINS) rather 
than DNS.

1. Click Start → Settings → Control Panel → Network → Properties to verify that 
the TCP/IP software is installed and configured property.

Note: If the TCP/IP software is not installed, install it from the Windows 2000 
Installation CD. Click Start → Settings → Control Panel → Network → 
Properties → Install → Protocols → Add. 

2. Update either the host or DNS table to specify a host name to associate with an
IP address. If you do not have a DNS (or WNS), edit the two host tables found in 
the following directories.

c:\winnt\system32\drivers\etc\hosts

c:\winnt\system32\drivers\etc\imhosts

For example, to set up the host tables for the controllers connected to Network A 
(Figure 5 on page 15), use a text editor to create the following IP address and 
controller name entries.

Important: Potential security risks occur when you open ports to your network.

3. If you want to manage storage subsystems through a firewall, continue with 
“Enabling ports for operation through a firewall”.

Enabling ports for operation through a firewall
If you plan to manage storage subsystems through a packet-filtering firewall, 
configure the firewall to open port 2463 to TCP data.

IP Address Host name for the controller

127.0.0.01 localhost

192.168.1.13 denver_a

192.168.1.14 denver_b
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Preparing to install the storage-management software
You have completed the preparations tasks and are now ready to install the storage-
management software. The installation process you follow depends on how you want 
to configure the system.

If you Go to

Install the software in a standard (non-
cluster) configuration

Chapter 3, “Installing software in a standard 
configuration,” on page 27.

Install the software in a cluster server 
environment

Chapter 4, “Installing software in a cluster 
server environment,” on page 35.
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Chapter 3.  Installing software in a standard configuration

This chapter describes how to install the storage-management software in a standard 
(noncluster) configuration.

Important: Always check for a README file on any installation media. This README 
file might contain important information that was not available when this 
Installation and Support Guide was prepared.

Pre-installation process
There are two configurations in which you can install the storage-management 
software:

• You do not have existing storage subsystems.

• You do have existing storage subsystems.

Use Table 9 to determine an installation process.

Table 9. Determining your installation process in a standard (noncluster) configuration 

Current environment Planned environment Action

No existing storage subsystems New storage subsystems with 
controllers that will use version 
4.00.02 firmware and will be managed 
with Storage Manager 7.02.

Go to “New installation process” on 
page 28.

(machine type 3526)
Existing storage subsystems with 
controllers that have firmware version 
3.x, and Storage Manager version 
6.22 Running on a Windows NT 4.0 
operating system.

Upgrade from Windows NT to 
Windows 2000. Upgrade storage 
subsystems with controllers that will 
use version 4.00.02 firmware and will 
be managed with Storage Manager 
7.02 for Windows 2000.

To upgrade controller firmware from 
3.x to 4.00.02, use the migration 
process defined in Netfinity FAStT 
Storage Manager Version 7.02 for 
Windows NT Installation and Support 
Guide.

Note: You must upgrade controller 
firmware from version 3.x to 
4.00.02 before upgrading the 
operating system from 
Windows NT to Windows 
2000.

To upgrade Windows NT to Windows 
2000, go to “Upgrading from Windows 
NT 4.0 to Windows 2000 in a standard 
configuration” on page 13.

(machine types 3526 and 3552)
Existing storage subsystems with 
controllers that have firmware 
versions 4.00.00 through 4.00.01. 
running Windows NT 4.0 operating 
system.

Upgrade from Windows NT to 
Windows 2000 with storage 
subsystems that will be managed with 
Storage Manager 7.02.

Go to “Upgrading from Windows NT 
4.0 to Windows 2000 in a standard 
configuration” on page 13.
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New installation process
Begin the installation of the storage-management software with “Installing the 
SM7client package”. Continue the process until you have completed “Installing the 
SM7agent package” on page 31. 

Figure 11 shows a flowchart of the installation process. 

Figure 11. New installation process

Installing the SM7client package
Use the following procedure to install the SM7client on each management station that 
is configured with one of the following:

• Windows 2000 Server

• Windows 2000 Professional

• Windows 2000 Advanced Server (required for a cluster environment)

Important: If you want to install SM7client on a stand-alone host and manage storage 
subsystems through the Fibre Channel I/O path rather than over the network, you 
must install the TCP/IP software on the host and assign a static IP address to the 
host. The host operating system must be running Windows 2000 Server, Windows 
2000 Professional, or Windows 2000 Advanced Server (required for a cluster 
environment).

(machine types 3526 and 3552) 
Existing storage subsystems with 
controllers that have firmware 
versions 4.00.00 through 4.00.01.

Upgrade storage subsystems with 
controllers that will use version 
4.00.02 firmware and will be managed 
with Storage Manager 7.02.

1. Uninstall Storage Manager 
version 7.0 or 7.01.

2. Go to “New installation process”.

3. Update the NVSRAM and 
controller firmware to version 
4.00.02 using the storage-
management software online 
help. 

Table 9. Determining your installation process in a standard (noncluster) configuration 

Current environment Planned environment Action

Install the client package

Install the RDAC package

Install the host agent package

Complete the installation
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Installation instructions
Before you install the software, make sure that:

• The management station has at least 35 MB of available disk space.

• The display properties are set to a minimum screen resolution of 800 x 600 pixels 
and a palette of 256 colors or more.

• You close all other programs.

To install the SM7client package:

1. Insert the IBM Netfinity FAStT Storage Manager CD into the CD-ROM drive.

2. Click Start → Settings → Control Panel → Add/Remove Programs. 

The Add/Remove Programs Properties window opens.

3. Click Install, and follow the instructions on the screen.

4. Click Browse.

5. Select the CD-ROM drive.

6. Select the \W2K\SM7client directory.

7. Select the setup.exe file, and then click Open.

8. Click Next.

The setup program Welcome window opens.

9. Click Next to begin the installation. 

The Choose Destination Location window opens.

10. Click Browse if you want to change the destination location.

11. Click Next.

12. When the installation is complete, click Finish.

Verifying the SM7client installation
Use the following procedure to verify that the installation was successful:

1. Click Start → Programs.

2. Verify that the Netfinity Fibre Channel Storage Manager 7 client appears in the list 
of programs.

3. If you are installing SM7client on only a management station. Go to Chapter 5, 
“Completing the installation,” on page 47. Otherwise, go to “Installing the RDAC 
package”.

Installing the RDAC package
Use the following procedure to install the RDAC package on a host computer that is 
connected to one or more storage subsystems.

RDAC contains the multipath device driver that is necessary for controller failover 
support.

Important: You must install RDAC before installing the SM7agent package.

Use the following procedure to install RDAC on each host computer that has at least 
1 MB of available disk space and is configured with one of the following:

• Windows 2000 Server

• Windows 2000 Professional
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• Windows 2000 Advanced Server (required for a cluster environment)

Assigning drive letters
Note: If you are installing the RDAC software on an existing configuration, go to 

“Installation instructions”.

The installation procedure installs the RDAC device driver before the Windows 2000 
device driver. This is necessary to enable the RDAC. However, this means that the 
system recognizes the storage subsystem logical drives before it recognizes any local 
drives, and assigns drive letters accordingly.

Note: Before you install this software, you must have static drive letters assigned to 
the existing local drives.

Use the following procedure to determine if you need to assign static drive letters and 
to assign them, if necessary:

1. Power off the storage subsystem to prevent Disk Administrator (WINDISK) from 
locking up while you are assigning drive letters and installing the RDAC device 
driver.

2. Click Start → Programs → Administrative Tools → Computer Management 
→ Storage →Disk Management to view the disk configuration and check the 
number of partitions.

• If you have only one partition, go the step 4.

• If you have two partitions, go to step 3.

3. If you have at least two partitions (the boot partition and one other partition) and 
both of the following conditions apply, go to “Installation instructions”. 

• The last partition that you created was created with Disk Management.

• The partition has a drive letter assigned and has a status of Unknown or has 
a file system on it (that is, it has a status other than Unformatted).

4. Use the following procedure to create a new partition.

a. Select a drive containing free disk space, and then, right-click on that drive.

The Write Signature and upgrade disk window opens.

b. Click Partition → Create. The partition is created (a drive letter is assigned, 
and the partition status is unformatted).

c. Click Partition → Commit Changes Now. The partition status changes to 
Unknown, and static drive letters are assigned to all existing partitions.

5. Continue with “Installation instructions”. 

Installation instructions
Before you install the software, make sure that:

• You have Administrator privileges on the host computer.

• The host computer is configured with Windows 2000 Server, Windows 2000 
Professional or Windows 2000 Advanced Server.

• The host computer has at least 1 MB of available disk space.

• The display properties are set to a minimum screen resolution of 640 x 480 pixels 
and a palette of 256 colors or more.

• You close all other programs.
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Install the RDAC package:

1. Insert the IBM Netfinity FAStT Storage Manager CD into the CD-ROM drive.

2. Click Start → Settings → Control Panel → Add/Remove Programs. 

The Remove Programs Properties window opens.

3. Click Install, and follow the instructions on the screen.

4. Click Browse.

The Browse window opens.

5. Select the CD-ROM drive.

6. Select the \W2K\RDAC directory.

7. Select the setup.exe file, and then click Open.

8. Click Next.

The setup program Welcome window opens. 

9. Click Next to begin the installation.

When RDAC is installed, the Setup Complete window opens. 

10. Click No, I will restart my computer later; then, click Finish.

11. Go to “Installing the SM7agent package”.

Installing the SM7agent package
Use the following procedure to install SM7agent on each host computer connected to 
one or more storage subsystems. The SM7agent consists of the following 
components:

• The host-agent software that is necessary for host-agent management of the 
storage subsystems.

• The SM7devices utility that is used to display the relationship of logical drives to 
operating system device names. For more information, see “Using the 
SM7devices utility” on page 58.

Important: You cannot install SM7agent unless RDAC is installed. 

You must install SM7agent even if you do not intend to manage storage subsystems 
through the SM7agent software.

Installation instructions
Before you install the software, make sure that:

• You have Administrator privileges on the host computer.

• The host computer is configured with Windows 2000 Server, Windows 2000 
Professional or Windows 2000 Advanced Server (required for a cluster 
environment).

• The host computer has at least 1 MB of available disk space.

• The display properties are set to a minimum screen resolution of 640 x 480 pixels 
and a palette of 256 or more.

• You installed RDAC.

• You close all other programs.
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Install the SM7agent:

1. Insert the IBM Netfinity FAStT Storage Manager CD into the CD-ROM drive.

2. Click Start → Settings → Control Panel → Add/Remove Programs. 

The Add/Remove Programs Properties window opens.

3. Click Install, and follow the instructions on the screen.

4. Click Browse. 

The Browse window opens.

5. Select the CD-ROM drive.

6. Select the \W2K\SM7agent directory.

7. Select the setup.exe file, and then click Open.

8. Click Next. 

The setup program Welcome window opens.

9. Click Next to begin the installation. 

When SM7agent is installed, the Setup Complete window opens.

10. You must restart the host to ensure that all changes take effect. Click Finish to 
restart the host.

Verifying the RDAC installation
Use the following procedure to verify that the RDAC package installation was 
successful:

Note: Make sure that all storage subsystems are connected to the host and powered 
on.

1. Right-click on My Computer.

2. Click Manage → System Tools → System Information → Software 
Environment → Drivers. The Services window opens.

3. Scroll through the list of drivers until you find rdacfltr.

4. Rdacfltr must be displayed with the state type Running and status OK. Otherwise, 
reinstall RDAC.

Verifying the SM7agent installation
Use the following procedure to verify that the SM7agent installation was successful:

Note: Make sure that all storage subsystems are connected to the host and powered 
on.

1. Click Start → Programs → Administrative Tools → Services. The Services 
window opens.

2. Scroll through the list of services until you find the Netfinity Fibre Channel Storage 
Manager 7 agent.

3. SM7agent must be displayed with the startup type Automatic and status Started. 
Otherwise, reinstall SM7agent. 

4. If you are upgrading from an earlier version of the storage-management software, 
use the procedure in the storage-management software online help for 
downloading the latest version of NVSRAM and controller firmware. Otherwise, 
go to step 5.

5. If you plan to use the host-agent software to manage one or more storage 
subsystems, go to Chapter 5, “Completing the installation,” on page 47.
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6. If you do not plan to use the host-agent software to manage one or more storage 
subsystems, disable the host-agent service in the following procedure.

a. Select Start → Programs → Administrative Tools → Services.

b. From the list of displayed services, right-click on the host-agent.

c. Select Properties → Startup Type → select Manual from the drop-down 
menu.

d. Select OK.

7. Go to Chapter 5, “Completing the installation,” on page 47.
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Chapter 4.  Installing software in a cluster server environment 

This chapter describes how to install the storage-management software in the multi-
host configuration, using cluster server software. The installation process you will use 
depends on your storage subsystem environment. Refer to Table 10.

Important: Always check for a README file on any installation media. This README 
file might contain important information that was not available when this Installation 
and Support Guide was prepared. To ensure proper installation, make sure you have 
read the entire contents of chapter 1, including all supporting documentation listed in 
Chapter 1, “Introduction,” on page 1. You must complete all preparation tasks 
described in Chapter 2, “Preparing for installation,” on page 13.

Pre-installation process
There are two configurations in which you can install the storage-management 
software:

• You do not have existing storage subsystems.

• You do have existing storage subsystems.

Use Table 10 to determine an installation process.

Table 10. Determining your installation process in a cluster server configuration 

Current environment Planned environment Action

No existing storage subsystems New storage subsystems with 
controllers that will use version 
4.00.02 firmware and will be managed 
with Storage Manager Version 7.02.

Go to “New installation process” on 
page 28.

Existing storage subsystems with 
controllers that have firmware version 
3.x, and storage-management 
software version 6.22 running on a 
Windows NT 4.0 operating system.
(machine type 3526)

Upgrade from Windows NT to 
Windows 2000. Upgrade storage 
subsystems with controllers that will 
use version 4.00.02 firmware and will 
be managed with Storage Manager 
Version 7.02 for Windows 2000.

To upgrade controller firmware from 
3.x to 4.00.02, use the migration 
process for cluster configuration 
defined in Netfinity FAStT Storage 
Manager Version 7.02 for Windows 
NT Installation and Support Guide.

Note: You must upgrade controller 
firmware from version 3.x to 
4.00.02 before upgrading the 
operating system from 
Windows NT to Windows 
2000.

To upgrade Windows NT to Windows 
2000, go to “Upgrading from Windows 
NT 4.0 to Windows 2000 in a standard 
configuration” on page 13.
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New installation
Before you begin an installation with existing storage subsystems, refer to your 
hardware installation documentation for the specific configuration required for your 
hardware to support operating the storage-management software in a cluster 
configuration.

If you have a management station connected to an Ethernet network, install the 
SM7client and complete the install for a host installation. Refer to Figure 12 for the 
new installation process. 

Important: After connecting the storage subsystems to both nodes, do not start 
Windows 2000 on both nodes at the same time until you install the cluster software on 
at least one node. To suspend Windows 2000 startup on node B, press the spacebar 
at the operating system (OS) startup. Do not install the cluster software until 
instructed to do so.

Figure 12. Process for a new installation

Existing storage subsystems with 
controllers that have firmware 
versions 4.00.00 through 4.00.01.
(machine types 3526 and 3552)

Upgrade from Windows NT to 
Windows 2000 with storage 
subsystems that will be managed with 
Storage Manager Version 7.02.

Go to “Upgrading from Windows NT 
4.0 to Windows 2000 in a cluster 
configuration” on page 13.

Upgraded storage subsystems with 
controllers that will use version 
4.00.02 firmware and will be managed 
with Storage Manager Version 7.02.

1. Uninstall Storage Manager 
version 7.0 or 7.01.

2. Go to “New installation process” 
on page 28.

3. Update the NVSRAM and 
firmware to version 4.00.02 using 
the storage-management 
software online help. 

Table 10. Determining your installation process in a cluster server configuration 

Current environment Planned environment Action

Install the client package

Install the RDAC package

Install the host agent package

Complete the installation
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Installing the SM7client package
Install the SM7client package on each management station. The package can be 
installed on a host, node A or node B, or on both node A and node B configured with 
Windows 2000 Advanced Server.

Install the TCP/IP software on the host computer and assign a static IP address. Be 
sure that the SM7client is installed on each management station that is configured 
with one of the following:

• Windows 2000 Server

• Windows 2000 Professional

• Windows 2000 Advanced Server (required for a cluster environment)

Important: If you want to install SM7client on a stand-alone host and manage storage 
subsystems through the Fibre Channel I/O path rather than over the network, you 
must install the TCP/IP software on the host and assign a static IP address to the 
host. The host operating system must be running Windows 2000 Advanced Server, 
Windows 2000 Professional, or Windows 2000 Advanced Server (required for a 
cluster environment).

If you are installing SM7client on only a management station go to Go Chapter 5, 
“Completing the installation,” on page 47.

Installation Instructions
Before you install the software, make sure that:

• Each management station has at least 35 MB of available disk space.

• The display properties are set to a minimum screen resolution of 800 x 600 pixels 
and a palette of 256 colors or more.

• You close all other programs.

Install the SM7client:

1. Insert the IBM Netfinity FAStT Storage Manager installation CD into the CD-ROM 
drive.

2. Click Start → Settings → Control Panel → Add/Remove Programs.

The Add//Remove Programs Properties window opens.

3. Click Install, and follow the instructions on the screen.

4. Click Browse.

The Browse window opens.

5. Select the CD-ROM drive.

6. Select the \W2K\SM7client directory.

7. Select the setup.exe file, and then click Open.

8. Click Next.

The setup program Welcome window opens.

9. Click Next to begin the installation.

The Choose Destination Location window opens.

10. Click Browse if you want to change the destination location.

11. Click Next to begin the installation.

12. When the installation is complete, click Finish.
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Verifying the SM7client installation
Use the following procedure to verify that the installation was successful:

1. Click Start → Programs.

2. Verify that Netfinity Fibre Channel Storage Manager 7 client appears in the list of 
programs.

3. If you are installing SM7client on only a management station go to Go Chapter 5, 
“Completing the installation,” on page 47.

Installing the RDAC package
Use the procedures in the following sections to install the RDAC package on each 
host computer that is connected to one or more storage subsystems. Make sure that 
each host computer has at least 1 MB of available disk space and is configured with 
Windows 2000 Advanced Server (required for a cluster environment. 

RDAC contains the multipath device driver that is necessary for controller failover 
support.

Assigning drive letters
The installation procedure installs the RDAC device driver before the Windows 2000 
device driver. This is necessary to enable the RDAC. However, this means that the 
system recognizes the storage subsystem logical drives before it recognizes any local 
drives, and assigns drive letters accordingly.

Note: Before you install this software, you must have static drive letters assigned to 
the existing local drives.

Use the following procedure to determine if you need to assign static drive letters and 
to assign them, if necessary:

1. Power off the storage subsystem to prevent Disk Administrator (WINDISK) from 
locking up while you are assigning drive letters and installing the RDAC device 
driver.

2. Click Start → Programs → Administrative Tools → Computer Management 
→ Storage →Disk Management to view the disk configuration and check the 
number of partitions.

• If you have only one partition, go the step 4.

• If you have two partitions, go to step 3.

3. If you have at least two partitions (the boot partition and one other partition) and 
both of the following conditions apply, go to “Installation instructions” on page 39. 

• The last partition that you created was created with Disk Management, and

• The partition has a drive letter assigned and has a status of Unknown or has 
a file system on it (that is, it has a status other than Unformatted).

4. Use the following procedure to create a new partition.

a. Select a drive containing free disk space; then, right-click on that drive.

The Write Signature and Upgrade Disk window opens.

b. Click Partition → Create. The partition is created (a drive letter is assigned, 
and the partition status is Unformatted).

c. Click Partition → Commit Changes Now. The partition status changes to 
Unknown, and static drive letters are assigned to all existing partitions.

5. Continue with “Installation instructions” on page 39. 
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Installation instructions
Before you install the software, make sure that:

• You have Administrator privileges on the host computer.

• The host computer is configured with Windows 2000 Advanced Server.

• The host computer has at least 1 MB of available disk space.

• The display properties are set to a minimum screen resolution of 640 x 480 pixels 
and a palette of 256 colors or more.

• You close all other programs.

Install the RDAC package:

1. Insert the IBM Netfinity FAStT Storage Manager CD into the CD-ROM drive.

2. Click Start → Settings → Control Panel → Add/Remove Programs. 

The Remove Programs Properties window opens.

3. Click Install, and follow the instructions on the screen.

4. Click Browse.

The Browse window opens.

5. Select the CD-ROM drive.

6. Select the \W2K\RDAC directory.

7. Select the setup.exe file, and then click Open.

8. Click Next.

The setup program Welcome window opens. 

9. Click Next to begin the installation.

When RDAC is installed, the Setup Complete window opens. 

10. If you are installing the host-agent package, go to “Installing the SM7agent 
package”.

11. Click No, I will restart my computer later; then, click Finish. 

12. Go to “Installing the SM7agent package”.

Installing the SM7agent package
Use the following procedure to install SM7agent on each host computer in your 
planned cluster that is connected to one or more storage subsystems. The SM7agent 
consists of the following components:

• The Storage Manager 7 Agent software that is necessary for host-agent 
management of the storage subsystems.

• The SM7devices utility that is necessary for relating logical drives to operating 
system device names. For more information, see “Using the SM7devices utility” 
on page 58.

Important: You cannot install SM7agent unless RDAC is installed. 

You must install SM7agent even if you do not intend to manage storage subsystems 
through the SM7agent software.
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Installation instructions
Before you install the software, make sure that:

• You have Administrator privileges on the host computer.

• The host computer is configured with Windows 2000 Advanced Server (required 
for a cluster environment).

• The host computer has at least 1 MB of available disk space.

• The display properties are set to a minimum screen resolution of 640 x 480 pixels 
and a palette of 256 or more.

• You installed RDAC.

• You close all other programs

Install the SM7agent:

1. Insert the IBM Netfinity FAStT Storage Manager CD into the CD-ROM drive.

2. Click Start → Settings → Control Panel → Add/Remove Programs. 

The Add/Remove Programs Properties window opens.

3. Click Install, and follow the instructions on the screen.

4. Click Browse. 

The Browse window opens.

5. Select the CD-ROM drive.

6. Select the \W2K\SM7agent directory.

7. Select the setup.exe file, and then click Open.

8. Click Next. 

The setup program Welcome window opens.

9. Click Next to begin the installation. 

When SM7agent is installed, the Setup Complete window opens.

10. You must restart the host to ensure that all changes take effect. Click Finish to 
restart the host.

Verifying the RDAC installation
Use the following procedure to verify that the RDAC package installation was 
successful:

Note: Make sure that all storage subsystems are connected to the host and powered 
on.

1. Right-click on My Computer.

2. Click Manage → System Tools → System Information → Software 
Environment → Drivers. The Services window opens.

3. Scroll through the list of drivers until you find rdacfltr.

4. Rdacfltr must be displayed with the state type Running and status OK. Otherwise, 
reinstall RDAC.

5. Go to “Verifying the SM7agent installation”.

Verifying the SM7agent installation
Use the following procedure to verify that the SM7agent installation was successful:

Note: Make sure that all storage subsystems are connected to the host and are 
powered on.
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1. Click Start → Programs → Administrative Tools → Services. The Services 
window opens.

2. Scroll through the list of services until you find the Netfinity Fibre Channel Storage 
Manager 7 agent.

3. SM7agent must be displayed and have the startup type Automatic and status 
Started. Otherwise, reinstall SM7agent.

4. If you are upgrading from an earlier version of storage-management software, 
Use the procedure in the storage-management software online help for 
downloading the latest version of NVSRAM and controller firmware. Otherwise, 
go to step 5.

5. If you plan to use the host-agent software to manage one or more storage 
subsystems, go to “Continuing the installation”. Otherwise, you can disable the 
host-agent service by using the following procedure:

a. Select Start → Programs → Administrative Tools → Services.

b. From the list of displayed services, right-click on the host-agent.

c. Select Properties → Startup Type → select Manual from the drop-down 
menu.

d. Select OK.

Continuing the installation
If you installed the storage-management software on node A, go to “Setting up the 
storage subsystems”. If you installed the storage-management software on node B, 
go to “Verifying drive letters” on page 42.

Setting up the storage subsystems
Use the procedures in Chapter 5, “Completing the installation,” on page 47 to perform 
the following tasks:

1. Start Enterprise Management and perform an Initial Automatic Discovery of 
storage subsystems on the local subnetwork. See “Starting Enterprise 
Management” on page 47.

2. Add other devices to the management domain as necessary. For more 
information, see “Adding devices” on page 48.

3. Create all of your planned arrays and logical drives on each storage subsystem 
connected to your cluster, see “Creating arrays and logical drives” on page 49

4. Open a Subsystem Management window for each storage subsystem and 
configure the storage subsystem as much as possible. You do not have to 
completely configure the storage subsystems. However, any changes you make 
later must be made known to Node B, see “Performing other storage subsystem 
management tasks” on page 51.

5. Modify configuration settings in NVSRAM by running the appropriate scripts 
required for your configuration, see “Modifying configuration settings in NVSRAM” 
on page 51

6. After you complete the procedure in Chapter 5, “Completing the installation,” on 
page 47, continue with step 7.

7. If you installed the storage-management software on node A, go to “Shutting 
down node A” on page 42. If you installed the storage-management on node B, 
go to “Verifying drive letters” on page 42. 
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Verifying drive letters
Important: Do not perform this procedure until you have installed the necessary 
storage-management software components on both node A and node B.

1. Select Start → Programs → Administrator Tools → Computer Management 
→ Storage → Disk Management to verify that the drive letters that are assigned 
to the configured logical drives are the same as those that are assigned to 
node A. 

2. Continue with “Shutting down node B”.

Shutting down node A
1. Shut down Windows 2000, but leave node A running (do not turn off the node).

2. Return to “Installing the SM7client package” on page 37 and repeat the 
installation procedures to install the necessary software components on node B.

Shutting down node B
1. Shut down Windows 2000, but leave node B running (do not turn off the node).

2. Continue with the next section, “Installing the cluster server software”.

Installing the cluster server software
Use the following procedure to install the cluster server software on nodes A and B.

Important: Before you install the cluster server software, make sure that you have 
installed the storage-management software on both nodes of the cluster server.

1. Install the cluster server software on node A, as follows:

a. Refer to the appropriate Microsoft Cluster Server (MSCS) documentation for 
the correct procedure to install the cluster server software. 

Note: During installation, specify that you want to Form a New Cluster. 

b. Install the cluster on node A. After the system restarts, leave node A running.

2. Install the cluster server software on node B. After the system restarts, leave 
node B running.

a. Refer to the appropriate MSCS documentation for the correct procedure to 
install the Cluster Server software. 

Note: During installation, specify that you want to Join The Existing Cluster. 

b. After the system restarts, leave node B up and running.

Important: When the installation of the MSCS is complete, be sure to reinstall the 
latest supported Service Pack.

3. Verify the software installation, as follows:

a. On either node (A or B), click Start → Programs → Administrative Tools 
(Common).

b. Click Cluster Administrator.

c. In the Cluster or Server Name field, type either the name of the cluster or the 
name or IP address of one of the nodes.

d. If the installation is successful, the computer names of both nodes appear on 
the left side of the Cluster Administrator window.
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4. If both node names appear, go to “Completing final tasks” on page 52. Otherwise, 
reinstall the cluster server software. 

Upgrading from a previous version of the storage-management software 
in a cluster server configuration

Be sure that you are familiar with the steps required in a new installation process 
before you continue with the following upgrade procedures.

You may choose from one of the following two procedures to upgrade your existing 
storage subsystem to Storage Manager 7.02 and your controller firmware to version 
4.00.02.

• Performing a scheduled upgrade: A scheduled upgrade means scheduling 
down time on your cluster server to upgrade the controller firmware and storage-
management software. The scheduled upgrade is the preferred procedure for 
upgrading a cluster server configuration.

• Performing a rolling upgrade: A rolling upgrade means upgrading the controller 
firmware and storage-management software so that the services and resources 
offered by the cluster are available, while the node that is being upgraded is not 
available.

Important: After the storage subsystem controller firmware has been upgraded to 
4.00.02, you will not be able to communicate with the controller until you have 
upgraded to Storage Manager 7.02 software on your management station and host. 
Previously installed versions of the storage-management client or host-agent software 
will not recognize controllers running version 4.00.02 firmware.

Performing a scheduled upgrade from storage-management software 
version 7.0 or 7.01 to Storage Manager 7.02

Complete the following steps to upgrade from storage-management software version 
7.0 or 7.01 to Storage Manager 7.02.

1. Before installing the storage-management software, do the following:

a. Click Start → Programs → Administrative Tools  → Services. The 
services window opens.

b. From the list of displayed services, right-click on the Cluster Server. Then, 
click Manual.

c. Stop cluster server on all nodes in the cluster configuration.

2. Shutdown all but node A in the cluster configuration.

3. From node A, to uninstall the components from the previous version of the 
storage-management software, use the uninstall procedure that came with the 
version of the storage-management software that you are running.

4. Verify that the IBM host bus adapter driver versions are current. If they are not 
current, refer to the README file located in the \W2K\Host_Adapter directory on 
the installation CD to upgrade the driver versions before continuing.

5. To install the Storage Manager 7.02 SM7client package, refer to the procedure in 
“Installing the SM7client package” on page 37.

6. To install the Storage Manager 7.02 RDAC package, refer to the procedure in 
“Installing the RDAC package” on page 38.

7. To install the Storage Manager 7.02 SM7agent package, refer to the procedure in 
“Installing the SM7agent package” on page 39.
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8. Upgrade the controller NVSRAM and controller firmware to version 4.00.02. 
Then, modify the appropriate configuration settings in NVSRAM using the 
procedure in “Modifying configuration settings in NVSRAM” on page 51.

Note: You can continue to use your existing versions 4.00.00 through version 
4.00.01 controller firmware. You can manage the existing storage 
subsystems through the Storage Manager 7.02.

9. Shutdown the node.

10. On node B, repeat step 3 on page 43 through step 7 on page 43; then, repeat 
step 9.

11. All nodes should be shutdown. Start up one node at a time and complete the 
following:

a. Click Start → Programs  → Administrative Tools  → Services. The 
services window opens.

b. From the list of displayed services, right-click on the Cluster Server. Click 
Automatic to change the cluster server startup option.

c. Start the cluster server on node B.

Performing a rolling upgrade from storage-management software 
version 7.0 or 7.01 to Storage Manager 7.02.

Note: To avoid losing access to a cluster, you need to perform a rolling upgrade. A 
rolling upgrade means upgrading so that the services and resources offered by 
the cluster are always available, even though the node being upgraded is not 
available. 

If you have applications installed in the cluster server environment that do not 
support a rolling upgrade, then you will have to either of the following:

• Put those resources offline before the upgrade; then put them back online 
after the upgrade or,

• Use a different upgrade method

Complete the following steps to perform a rolling upgrade from storage-management 
software version 7.0 or 7.01 to Storage Manager 7.02. 

1. From node A, open cluster administrator.

2. Select node A, and select File → Pause Node to pause the node.

3. Double-click on the Active Groups folder in the right window of cluster 
administrator.

4. Select each group listed and move your selection to node B.

5. From node A, to uninstall the components from the previous version of the 
storage-management software, use the uninstall procedure that came with the 
version of the storage-management software that you are running.

6. Verify that the IBM host bus adapter driver versions are current. If they are not at 
the current versions, refer to the README file located in the \W2K\Host_Adapter 
directory on the installation CD to upgrade the driver versions before continuing.

7. To install the Storage Manager 7.02 SM7client package, refer to the procedure in 
“Installing the SM7client package” on page 37.

8. To install the Storage Manager 7.02 RDAC package, refer to the procedure in 
“Installing the RDAC package” on page 38.

9. To install the Storage Manager 7.02 SM7agent package, refer to the procedure in 
“Installing the SM7agent package” on page 39.
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10. Upgrade the controller firmware to version 4.00.02. Then, modify the appropriate 
configuration settings in NVSRAM. Refer to the procedure in “Modifying 
configuration settings in NVSRAM” on page 51.

Note: You can continue to use your existing versions 4.00.00 through version 
4.00.01 controller firmware. You can manage the existing storage 
subsystems through the Storage Manager 7.02.

11. Run Cluster Administrator, and resume the node by selecting File → Resume 
Node.

12. On node B, repeat step 1 on page 44 through step 9 on page 44; then, repeat 
step 11.
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Chapter 5.  Completing the installation

This chapter contains procedures for starting Enterprise Management and Subsystem 
Management and for completing the installation tasks.

Starting Enterprise Management
The Enterprise Management window is the first window to open when you start the 
software. Use the Enterprise Management window to:

• Add and discover the storage subsystems you want to manage.

• Provide a comprehensive view of all storage subsystems in your management 
domain.

• Perform batch storage subsystem management tasks using the Script Editor.

Use the following procedure to start the Enterprise Management window:

1. Click Start → Programs.

2. Click Netfinity Fibre Channel Storage Manager 7 client.

The client software starts, displaying the Enterprise Management window and the 
Confirm Initial Automatic Discovery window, as shown in Figure 13.

Figure 13. Confirm Initial Automatic Discovery window

Note: The Enterprise Management window can take several minutes to open. No 
wait cursor (such as an hourglass) is displayed.

If you do not want to perform the initial automatic discovery, click No. You 
can use the Edit → Add Device pull-down menu option to add hosts and 
storage subsystems. For more information, see “Adding devices” on page 
48. 

3. Click Yes to begin an initial automatic discovery of hosts and storage subsystems 
attached to the local subnetwork on which the management station is installed.

The software sends a broadcast message across the local subnetwork where the 
management station is installed. It discovers host-agent managed storage 
subsystems if the hosts that provide network management connections to the 
storage subsystems respond to the broadcast. The software discovers directly 
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managed storage subsystems if the controllers in those storage subsystems 
respond to the broadcast message.

Important: It can take up to a minute for the Enterprise Management window to 
refresh after an initial automatic discovery.

If you need to stop the automatic discovery operation, close the Enterprise 
Management window.

When the initial automatic discovery is complete, you can see all hosts and storage 
subsystems attached to the local subnetwork, as shown in Figure 14. 

Figure 14. Enterprise Management window

If you do not see all hosts and storage subsystems, do the following: 

• Check the hardware and connections for possible problems (refer to the hardware 
documentation for specific procedures).

• Refer to the Enterprise Management online Help topic about discovering storage 
subsystems.

• Make sure that the device is on the local subnetwork. If it is not, you must use the 
Add Device option.

Note: If any device shows a status of Unresponsive, use the software to remove the 
device from the management domain and then add it again. Refer to the 
Enterprise Management online Help for instructions on removing and adding 
devices.

A storage subsystem might be duplicated in the device tree after an automatic 
discovery, if the storage subsystem is directly managed but is attached to a host with 
the host-agent software installed and running. In this case, you can remove the 
duplicate storage management icon from the device tree using the remove device 
option in the Enterprise Management window.

Continue with “Adding devices”.

Adding devices
You can add more hosts or storage subsystems outside the local subnetwork. For 
more information about this option, refer to the Enterprise Management window online 
Help.
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Important: If you are managing storage subsystems through the host-agent software 
and you physically add new storage subsystems, you must stop and 
restart the host-agent service so it can recognize the new storage 
subsystems (see “Stopping the host-agent service” on page 52). Then, go 
to the Enterprise Management window and click Tools → Rescan to add 
the new storage subsystems to the management domain.

Continue with “Creating arrays and logical drives”.

Creating arrays and logical drives
To create an array or logical drive, perform the following procedure:

1. Highlight a storage subsystem in the Enterprise Management window and select 
Tools → Manage Device to start a Subsystem Management window for that 
storage subsystem.

2. Create all of your planned arrays and logical drives on this storage subsystem 
using the Configure → Create Array/Logical Drive option.

3. Repeat the arrays/logical drive configuration for each storage subsystem 
connected to your cluster.

Note: If you make any other logical drive additions or deletions, you must make 
them known to node B in a cluster configuration.

4. Go to “Setting up alert notifications”.

Setting up alert notifications
After you add devices to the management domain, set up alert notification options to 
report critical events on the storage subsystems. The following options are available 
for alert notification:

• Notification to a designated network management station (NMS) using Simple 
Network Management Protocol (SNMP) traps (see “Setting up the NMS for SNMP 
notification” for more information).

• Notification to designated e-mail addresses. 

• Notification to designated alphanumeric pagers (when a third party software 
package is used to convert e-mail messages).

Note: The Enterprise Management Window must remain open if you want to monitor 
the condition of storage subsystems included in your management domain. 
You may want to minimize the window. If you close this window, you will not 
receive alert notifications. Refer to the Enterprise Management window online 
Help for more information on alert notification options.

Setting up the NMS for SNMP notification
If you choose to set up alert notification using SNMP traps, you must first copy a 
management information base (MIB) file to the designated network management 
station. Use this procedure to set up the MIB on the network management station.

Important: You only need to set up your designated NMS one time.

1. Copy the Arrayman.mib file from the \W2K\SM7mib directory on the Installation 
CD to the network management station.

2. Follow the steps required by your specific network management station to 
compile the MIB.

Note: For details on the required steps, consult your network administrator or the 
documentation specific to the NMS product you are using.
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Configuring alert destinations
Configure SNMP trap destinations and e-mail destinations for alert notifications using 
the Enterprise Management window. Refer to the Enterprise Management online Help 
for specific procedures.

Go to “Starting the subsystem management”.

Starting Subsystem Management
The Subsystem Management window enables you to manage selected subsystems.

Use the following procedure to open a Subsystem Management window for a 
selected storage subsystem:

1. In the Enterprise Management window, select a storage subsystem.

2. Click Tools → Manage Device.

The software displays the Subsystem Management window for the selected 
storage subsystem, as shown in Figure 15.

Note: Using the open Subsystem Management window, you can manage only 
the selected storage subsystem. However, you can open multiple 
Subsystem Management windows to manage other storage subsystems.

3. Go to “Renaming storage subsystems”.

Figure 15. Subsystem Management window

Renaming storage subsystems
When you start Storage Manager 7.02 for the first time, the storage subsystems are 
unnamed. You must use the Subsystem Management window to rename each 
storage subsystem from <unnamed> to the name you want. Refer to the names you 
entered in the information record you created using Table 12 on page 63. Then, refer 
to the renaming storage subsystems topic in the Subsystem Management online 
Help. The Help topic provides detailed instructions for renaming storage subsystems.
 50 IBM® Netfinity® FAStT Storage Manager Version 7.02 for Windows® 2000 Installation and Support Guide  



Performing other storage subsystem management tasks
The storage subsystem management tasks you can perform include the following:

• Downloading controller firmware

• Downloading controller NVSRAM

• Locating a storage subsystem

• Viewing a storage subsystem profile

• Entering or changing a storage subsystem password

• Creating and managing logical drives and subsystems

• Using the Performance Monitor

• Creating storage partitions (if applicable)

Note: To create storage partitions, you must obtain the worldwide name or port name 
of each host adapter in each host connected to the storage subsystem.

For more information about these and other storage subsystem management tasks, 
refer to the appropriate topics in the Subsystem Management online Help.

Go to “Modifying configuration settings in NVSRAM”.

Modifying configuration settings in NVSRAM
Depending on the operating system, management method (host-agent or direct) and 
configuration (cluster or noncluster) that you are using, you might need to run scripts 
to modify configuration settings stored in NVSRAM on each storage subsystem you 
are managing with Storage Manager 7.02.

Use the following procedure to modify the appropriate configuration settings.

1. Insert the IBM Netfinity FAStT Storage Manager installation CD into the CD-ROM 
drive on the management station.

2. Go to the \W2K\Scripts directory and read the README file in that directory.

3. Highlight a storage subsystem in the Enterprise Management window and 
click Tools → Execute Script.

4. Did you install the storage-management software in a standard (noncluster) 
configuration? Refer to the following table.
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5. Repeat the procedures in step 3 on page 51 through step 4 on page 51 for each 
storage subsystem that you are managing with the storage-management 
software.

6. If you have a standard configuration, go to “Completing final tasks”. Otherwise, go 
to step 7.

7. If you have a cluster configuration, go to step 6 in “Setting up the storage 
subsystems” on page 41. 

Completing final tasks
If you want to manage storage subsystems using the direct method only, go to 
“Stopping the host-agent service”. Otherwise, go to Chapter 6, “Operating system 
support,” on page 55.

Note: You can manage storage subsystems using both the direct and host-agent 
management methods.

Stopping the host-agent service
Use the following procedure to stop the host-agent service:

1. Click Start → Programs → Administrative Tools → Services.

2. Click Netfinity Fibre Channel Storage Manager 7 Agent service.

3. Click Stop.

4. Click Startup.

The Service window opens.

Yes No

Run the scripts to enable the Windows 2000 operating 
system.

1. To install and run the Windows 2000 script:

a. Select File → Load Script. The Load Script 
window opens.

b. Select the appropriate script from the 
\W2K\Scripts directory on the installation CD.

c. Select Open to install the script.

d. Select Tools → Execute Only.
Wait until the Script Execution Complete 
message displays.

Go to step 5 on page 52. 

Run the scripts to enable the Windows 2000 operating 
system and clustering. If you are not managing storage 
subsystems directly, run the script to disable networking.

1. To install and run the Windows 2000 script:

a. Select File → Load Script. The Load Script 
window opens.

b. Select the appropriate script from the 
\W2K\Scripts directory on the installation CD.

c. Select Open to install the script.

d. Select Tools → Execute Only.
Wait until the Script Execution Complete 
message displays.

2. To install and run the disable networking script:

a. Click File → Load Script. The Load Script 
window opens.

b. To disable networking, select the appropriate 
script from the \W2K\Scripts directory on the 
installation CD.

c. Click Open to install the script.

d. Click Tools → Execute Only. Wait until the 
Script Execution Complete message displays.

e. Go to step 5 on page 52.

Note: The default NVSRAM has clustering enabled. After 
you run the Clustering Off script, you must run the 
Clustering On script to enable clustering.
 52 IBM® Netfinity® FAStT Storage Manager Version 7.02 for Windows® 2000 Installation and Support Guide  



5. Under Startup Type, click Manual.

6. Click OK.

7. Click Close to close the Services window, and then close the Control Panel.

8. Go to Chapter 6, “Operating system support,” on page 55.
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Chapter 6.  Operating system support

This chapter contains information related to operating the storage-management 
software in a Windows 2000 environment.

Understanding the Windows 2000 restrictions
Important: Always check for a README file on any installation media. This README 

file might contain important information that was not available at the time 
this Installation and Support Guide was prepared.

Table 11 explains the restrictions that apply when using Storage Manager 7.02 with 
Windows 2000.

Table 11. Windows 2000 restrictions and notes 

Restriction Workaround

In the online help, clicking on the vertical scroll arrows 
(either up or down) causes the scroll box to move all the 
way to the opposite end of the scroll bar.

This is a known defect in the JavaHelp runtime 
environment. 

Click the scroll box and slide it until you reach the desired 
position in the Help window.

After trying to add a host device to the management 
domain of more than five clients, the host-agent managed 
storage subsystems attached to that host become 
unresponsive.

A single instance of the host-agent software can only 
communicate with five or fewer clients.

There are limits to how much drive space capacity you can 
have in a single logical drive group. For example, with 73.4 
GB drives, the maximum number of drives that can be 
configured in a single logical drive group is 29.

None.

Password information is stored on a reserved area of each 
drive on the storage subsystem. Each drive stores a 
mirrored copy of the password data. With no drives in the 
storage subsystem, the storage-management software 
does not find the password data when you attempt 
password protected operations. Add one of the drives to 
the storage subsystem and try the operation again.

Password information is stored on a reserved area of each 
drive on the storage subsystem. Each drive stores a 
mirrored copy of the password data. With no drives in the 
storage subsystem, the storage-management software 
does not find the password data when you attempt 
password protected operations. Add one of the drives to 
the storage subsystem and reattempt the operation.

Array migration is not supported because it could cause 
loss of configuration. 

Array migration is when you remove a set of drives 
configured with arrays from one storage subsystem and 
insert them into another storage subsystem.

Call IBM service for assistance.

A stand-alone (non-networked) configuration, in which the 
Windows 2000 host does not have the TCP/IP software 
installed, is not supported.

Install the TCP/IP software on the Windows 2000 host and 
assign the host a static IP address.

If you configure a new storage subsystem with a single 
controller, you must place the controller in the top slot (slot 
A) for machine types 3552 and 3526 or in the left slot for 
machine type 3542. The controller firmware cannot 
recognize or communicate to a single controller until slot A 
is populated. This restriction does not apply to storage 
subsystems that were originally configured with two 
controllers.

None.
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Number of logical drives supported
There are limits on how many logical unit numbers (LUNs) you can use to access the 
logical drives on a single storage subsystem. Supported logical drive limits are as 
follows:

• Windows 2000 supports up to 8 logical drives per storage subsystem (LUNs 0–7).

• Windows 2000 supports up to 32 logical drives per storage subsystem 
(LUNs 0–31) if the host adapter also supports large LUNs and is configured 
correctly.

• Host adapters support a maximum number of logical drives. Refer to the host 
adapter documentation for specific information.

• The host-agent management method uses a special logical drive, called an 
access volume, to communicate with the controllers on the storage subsystem. 
The access volume uses one of the allowable logical drives. Therefore, managing 
storage subsystems with the host-agent software limits you to one less LUN than 
the maximum number supported by Windows 2000 and the host adapter.

A controller failover occurs in an active/active controller 
pair and ownership of arrays transfer from the failed 
preferred owner to the other controller of the pair. The 
failed controller is replaced and brought online, until array 
ownership is transferred back to the preferred controller 
owner.

Immediately after replacing the controller, select the 
storage subsystem → Redistribute Arrays option in the 
Subsystem Management window to redistribute Arrays 
back to their preferred controller owners.

For more information, see the Subsystem Management 
window online Help.

After installing the host-agent software, you see an error 
message with “Service Error 100” on the host.

Causes include:

The host-agent software does not find any controllers with 
firmware version 4.x.

Controllers with firmware version 4.x have the access 
volume disabled with NVSRAM configuration settings.

The NVSRAM on controllers in a storage subsystem you 
are attempting to manage contains an access volume 
logical unit number that is already in use by another logical 
drive.

The NVSRAM on controllers in a storage subsystem you 
are attempting to manage contains an access volume 
logical unit number that is not supported by the operating 
system and installed patches. For example, the access 
volume is configured at LUN 32, but the operating system 
and service packs only support 8 LUNs.

A possibility of file system corruption exists when 
resources are moved back and forth multiple times 
between cluster nodes using Microsoft Cluster Server 
running under Windows 2000 Advanced Server.

When the cluster resource is moved, the owning node 
flushes cache and then releases the reservation to one or 
more logical drives. The other node then reserves one or 
more logical drives. In some instances, file system reads 
and writes do not finish before the release. This results in 
a reservation conflict and file system corruption. Trying to 
recover using the chkdsk command causes the file 
system information to be corrected in such a way that 
some files are no longer accessible.

None. The problem is highly unlikely to occur during 
normal failover situations.

Table 11. Windows 2000 restrictions and notes 

Restriction Workaround
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Creating logical drives
A logical drive is a logical object that is the basic structure you create to store data on 
the storage subsystem. A logical drive is configured across a subsystem with a 
specific RAID level to meet application needs for data availability and Fibre Channel 
I/O performance. A logical drive is recognized by the operating system as one drive. 

You can add or delete logical drives in a standard (noncluster) configuration and in a 
cluster server environment.

Standard (noncluster) configuration
When you create new logical drives with the storage-management software, you must 
add the new logical drives to the Windows 2000 operating system. Remember that 
each logical drive (not array) is recognized by Windows 2000 as one drive.

You can use the SM7devices utility to identify logical drives by their associated 
operating system device names. For more information refer to “Cluster server 
environment”.

1. Use the storage-management software to create a new logical drive. For specific 
instructions, refer to the Subsystem Management online Help.

2. To add logical drives to node A: 

a. Select Start →Programs → Administrator Tools →
Computer Management Storage → Disk Management.

b. In System Tools click Device Manager.

c. Right click Disk Drives to scan for hardware changes.

3. Select Start →Programs → Administrator Tools → Computer Management
→ Storage → Disk Management (local) to format the new logical drive on 
node A.

Attention: Before either deleting logical drives with the storage-management 
software or using Configure → Reset Configuration, stop all input and output 
activity to the affected storage subsystem. Then, use Disk Management to delete any 
partitions and to unassign drive letters associated with the logical drives. If you do not 
use Disk Management first, registry information will be damaged. Restart the system 
to remove configuration information.

Cluster server environment
When you create logical drives on one node in a cluster server environment, you must 
assign the same drive letter on the other node as well.

You can use the SM7devices utility to identify logical drives by their associated 
operating system device names.

1. Use the storage-management software to create a new logical drive. For specific 
instructions, refer to the Subsystem Management online Help.

2. To add logical drives to node A: 

a. Select Start →Programs → Administrator Tools →
Computer Management Storage → Disk Management.

b. In System Tools click Device Manager.

c. Right click Disk Drives to scan for hardware changes.

3. Select Start →Programs → Administrator Tools → Computer Management
→ Storage → Disk Management (local) to format the new logical drive on 
node A.
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Use the following procedure to add logical drives in a cluster server environment:

1. Use the storage-management software to create a new logical drive. For specific 
instructions, refer to the Subsystem Management online Help.

2. To add logical drives to node B:

a. Select Start →Programs → Administrator Tools → 
Computer Management Storage → Disk Management.

b. In System Tools click Device Manager.

c. Right click Disk Drives to scan for hardware changes.

3. To format the new logical drive on node B:

a. Select Start →Programs → Administrator Tools → Computer 
Management → Storage →Disk Management to format the new logical 
drive on node B.

4. Start the Cluster Administrator on node B and use it to stop the cluster service.

5. Click Node B → File Stop → Cluster Service.

6. In Cluster Administrator, click Node B, and then click File → Evict Cluster Node.

7. Restart node A.

8. On node A, use Cluster Administrator either to create a new subsystem or select 
an existing subsystem to which you can add the new logical drive.

9. Highlight the logical drive group and click File → New → Resource.

10. Name the new resource and click Physical Disk as the resource type.

11. Click Next.

12. Click node A as the disk resource owner, and then click Next.

13. Specify any dependencies (other resources that Cluster Administrator must bring 
online) before this new disk resource is brought online.

14. Select the new disk from the drive parameter list, and then click Finish.

15. Uninstall the Cluster Server software from node B.

16. Re-install the Cluster Server software on node B and join the existing cluster that 
includes node A.

Important: Edit the properties of the new disk to allow node B to be a possible owner 
of the resource. You can redistribute the cluster resources between nodes A and B 
and edit the properties of all cluster resources to include node B. Move any cluster 
resources belonging to node B from node A back to node B.

Using the SM7devices utility
The SM7agent software includes a utility called SM7devices that enables you to view 
the storage subsystem logical drive that is associated with a particular operating 
system device name. This capability is helpful when you want to create drive letters or 
partitions for the logical drive using Disk Administrator.

After you finish creating the logical drives on a particular storage subsystem, go to the 
host attached to that storage subsystem and perform the following steps to use 
SM7devices:

1. From a DOS command prompt, change to the \Program Files\SM7agent 
directory. 

2. Type:

SM7devices
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3. Press Enter.

The software displays device identification information. For example, you might 
see:

\\.\PHYSICALDRIVE0 [Storage Subsystem Finance, Logical Drive DEBIT, LUN 
0, WWN <600a0b800006028600000000382060eb>]
\\.\PHYSICALDRIVE1 [Storage Subsystem Finance, Logical Drive CREDIT, LUN 
1, WWN <600a0b70006028600000000392060eb>]

where PHYSICALDRIVE x = Diskx in Disk Management
Storage Subsystem = the storage subsystem name
logical drive = the logical drive name
LUN = the logical unit number associated with the logical drive
WWN = the world wide name for the logical drive

Stopping and starting the host-agent
Use the procedure in the following sections to stop and start the host-agent software 
installed on the host.

Note: If an access volume is not detected after a restart, then the host-agent software 
will automatically stop running. Restart the host so that new host-agent 
managed storage subsystems can be discovered.

Stopping the host-agent
You must stop the host-agent software if you want to add storage subsystems. When 
you restart the service, the host-agent discovers the new storage subsystems and 
adds them to the management domain. To stop the host-agent:

1. Select Start → Settings → Control Panel → Services.

The Services dialog box appears

2. Select Netfinity Fibre Channel Storage Manager 7 Agent.

3. Select Stop.

Starting the host-agent
The host-agent software automatically starts after you restart the host. However, you 
must start the software manually if you stop it to add storage subsystems.

To start the host-agent:

1. Select Start → Settings → Control Panel → Services.

The Services dialog box appears

2. Select Netfinity Fibre Channel Storage Manager 7 Agent.

3. Select Start.
 Chapter 6.  Operating system support  59



Uninstalling storage-management software components
Use the following procedure if you need to uninstall one or more of the components of 
Storage Manager 7.02.

Important: Do not uninstall the RDAC component unless instructed by a service 
representative. The host-agent package requires RDAC to function 
properly. If you uninstall RDAC in a coexistence environment, you will 
loose Fibre Channel I/O path failover support for both the version 7.02 
and version 6.22 systems.

1. Click Start → Settings → Control Panel → Add/Remove Programs.

The Add/Remove Programs Properties window opens.

2. Select the component you want to uninstall from the list of programs.

For example, Netfinity Fibre Channel Storage Manager 7 Client.

3. Select Add/Remove.

The Confirm File Deletion window opens.

4. Click Yes to start the uninstallation process.

5. When the uninstallation is completed, click OK.
 60 IBM® Netfinity® FAStT Storage Manager Version 7.02 for Windows® 2000 Installation and Support Guide  



Appendix A.   Notices

References in this publication to IBM products, programs, or services do not imply 
that IBM intends to make these available in all countries in which IBM operates. Any 
reference to an IBM product, program, or service is not intended to state or imply that 
only that IBM product, program, or service may be used. Subject to IBM’s valid 
intellectual property or other legally protectable rights, any functionally equivalent 
product, program, or service may be used instead of the IBM product, program, or 
service. The evaluation and verification of operation in conjunction with other 
products, except those expressly designated by IBM, are the responsibility of the 
user.

IBM may have patents or pending patent applications covering subject matter in this 
document. The furnishing of this document does not give you any license to these 
patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

This section contains trademarks and other important information.

Any references in this publication to non-IBM Web sites are provided for convenience 
only and do not in any manner serve as an endorsement of those Web sites. The 
materials at those Web sites are not part of the materials for this IBM product and use 
of those Web sites is at your own risk.

Edition Notice
INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS 
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS 
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES 
OF MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some juris-
dictions do not allow disclaimer of express or implied warranties in certain transac-
tions, therefore, this statement may not apply to you. 

This publication could include technical inaccuracies or typographical errors. Changes 
are periodically made to the information herein; these changes will be incorporated in 
new editions of the publication. IBM may make improvements and/or changes in the 
product(s) and/or the program(s) described in this publication at any time.

This publication was developed for products and services offered in the United States 
of America and the United Kingdom. It is possible that this publication may contain 
reference to, or information about, IBM products (machines and programs), 
programming, or services that are not announced in your country. Such references or 
information must not be construed to mean that IBM intends to announce such IBM 
products, programming, or services in your country.

Requests for technical information about IBM products should be made to your IBM 
reseller or IBM marketing representative. No part of this publication may be 
reproduced or distributed in any form or by any means without prior permission in 
writing from the International Business Machines Corporation.
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Note to U.S. Government Users — Documentation related to restricted rights — Use, 
duplication or disclosure is subject to restrictions set forth in GSA ADP Schedule 
Contract with IBM Corp.

Trademarks
The following terms are trademarks of International Business Machines Corporation 
in the United States, other countries, or both:

IBM

Netfinity

JavaHelp is a trademark of Sun Microsystems, Inc. in the United States, other 
countries, or both.

Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation in the 
United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other 
countries.

Other company, product, and service names may be trademarks or service marks of 
others.
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Appendix B.   Storage subsystem/controller information record

Table 12 provides a data sheet on which you can record storage subsystem names, 
management types, hardware Ethernet addresses, and IP addresses. Make a copy of 
this table and complete the information for your storage subsystems and controllers. 
Use the information that is recorded in Table 12 to set up the BOOTP table for the 
network server and the host or Domain Name System (DNS) table. The information in 
Table 12 helps you add storage subsystems after initial installation. The column 
headings show a page reference for detailed instructions about obtaining the 
information. For a sample information record, see Table 7 on page 17.

Table 12. Storage subsystem and controller information record 

Storage 
subsystem 

name
(see page 17)

Management type 
(see page 14)

Controllers—Ethernet and IP 
addresses, and host name

(see pages 17)

Host—IP 
address and 
host name

(see page 20)

Storage 
subsystem 
name:

Storage 
subsystem 
name:

Storage 
subsystem 
name:

Storage 
subsystem 
name:

Storage 
subsystem 
name:

Storage 
subsystem 
name:

Storage 
subsystem 
name:

Storage 
subsystem 
name:
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