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Preface

About this book
This book provides information about setting up, installing, configuring, and working 
with IBM® FAStT Storage Manager Version 7.02 in a Novell NetWare operating 
system environment. This Installation and Support Guide is for system administrators. 
Use this guide to:

• Determine the hardware and software that are required to install the storage-
management software.

• Integrate the necessary hardware components into your network.

• Install the storage-management software.

• Upgrade controller firmware, if necessary.

• Identify storage-management features that are unique to NetWare.

How this book is organized
Chapter 1, “Introduction,” on page 1 provides an overview of IBM FAStT Storage 
Manager Version 7.02 and describes storage-subsystem management methods, 
configuration types, types of installations, and installation requirements.

Chapter 2, “Preparing for installation,” on page 13 discusses preparing for a network 
installation, including setting up a Microsoft® DHCP server or a UNIX BOOTP server, 
and describes other setup tasks.

Chapter 3, “Installing software in a standard configuration,” on page 27 describes the 
procedure for installing the software in a standard environment.

Chapter 4, “Completing the installation,” on page 33 describes Enterprise 
Management and Subsystem Management, changing NVSRAM configuration 
settings, and completing the installation tasks.

Chapter 5, “Operating system support,” on page 41 contains information that is 
related to operating the storage-management software with Novell NetWare.

Appendix A, “Storage subsystem/controller information record,” on page 47 provides 
a data sheet that you can copy and use to record information about your hardware 
devices.

Appendix B, “Notices,” on page 49 provides product notices and trademark 
information. 
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Notices used in this book
This book contains notices to highlight information or provide safety information:

• Notes

These notices provide important tips, guidance, or advice.

• Important

These notices provide information that might help you avoid inconvenient or 
problem situations.

• Attention

These notices indicate possible damage to programs, devices, or data. An 
attention notice is placed just before the instruction or situation in which damage 
could occur.

• Caution

These notices indicate situations that can be potentially hazardous to you. A 
caution notice is placed just before a description of a potentially hazardous 
procedure step or situation. 

Related publications
The following publications are available in Adobe Acrobat Portable Document Format 
(PDF) on the IBM FAStT Storage Manager CD and on the World Wide Web at 
http://www.ibm.com/pc/support/.

Note: The items that are denoted by an asterisk (*) in the list are publications that are 
printed and come with the IBM FAStT200 and FAStT200 High Availability (HA) 
Storage Servers.

• IBM FAStT Storage Manager Version 7.02 for Novell NetWare Installation and 
Support Guide (this book)

• IBM Netfinity FAStT Storage Manager Version 7.02 for Windows 2000 Installation 
and Support Guide

• IBM Netfinity FAStT Storage Manager Version 7.02 for Windows NT Installation 
and Support Guide

• IBM Netfinity FAStT Host Adapter Installation and User’s Handbook

• IBM FAStT200 and FAStT200 HA Storage Servers Installation and User’s Guide*

• IBM Netfinity FAStT500 RAID Controller Enclosure Unit Installation Guide

• IBM Netfinity FAStT500 RAID Controller Enclosure Unit User’s Reference

• IBM Netfinity Fibre Channel Storage Manager Concepts Guide

• IBM Netfinity Fibre Channel RAID Controller Unit User’s Handbook

When you complete the tasks in this Installation and Support Guide, refer to the 
following online Help systems:

• IBM FAStT Storage Manager Version 7.02 Enterprise Management online Help. 
Use this help system for more information about working with the management 
domain.

• IBM FAStT Storage Manager Version 7.02 Subsystem Management online Help. 
Use this help system for more information about managing storage subsystems.
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You can access the help systems from the Enterprise Management and Subsystem 
Management windows in IBM Netfinity Fibre Channel Storage Manager. Click Help on 
the toolbar or press F1.

The help systems contain operating information that is common to all operating 
environments. Refer to this Installation and Support Guide for information that is 
specific to Novell NetWare.

Additional publications are available for purchase from IBM. For a list of publications 
that are available in your country:

• In the U.S. and Puerto Rico, call 1-800-426-7282.

• In the United Kingdom, call 01705-565000 or 0161-9056001.

• In Canada, call 1-800-465-1234.

• In other countries, contact the IBM support organization that services your area, 
your IBM marketing representative, or your IBM reseller.
 Preface  xi



 

 xii Book Title



 

Chapter 1.  Introduction

IBM FAStT Storage Manager Version 7.02 for Novell NetWare is a Java™-based tool 
that simplifies the management of the IBM Fibre Array Storage Technology 
(FAStT)200 and FAStT200 HA Storage Servers, Netfinity FAStT500 RAID Controller 
Enclosure Unit, and Netfinity Fibre Channel RAID Controller Unit. Previous versions of 
IBM FAStT Storage Manager Version 7.02 were known as Netfinity Fibre Channel 
Storage Manager 7.

The FAStT Storage Manager Version 7.02 software presents an interface for storage 
management that is based on information that is supplied by the storage subsystem 
controllers. You can install the storage-management software on a management 
station, which is the system that is responsible for managing all, or a portion of, a 
network. The management station communicates with network management agents 
that reside in the managed node by means of a network management protocol, such 
as Simple Network Management Protocol (SNMP). When you manage a storage 
subsystem that uses the client software that is installed on a management station, 
commands are sent to the storage subsystem controllers. The controller firmware 
contains the necessary information to carry out the storage-management commands. 
The controller is responsible for validating and running the commands and providing 
status and configuration information back to the client software.

Throughout this book, the terms storage-management software and Storage Manager 
7.02 refer to the IBM FAStT Storage Manager Version 7.02 for Novell NetWare 
software. Individual components of the storage-management software are identified 
by name.

Terms to know
If you are upgrading from a previous version of the storage-management software, 
you will find that some of the terms you are familiar with have changed. It is important 
that you familiarize yourself with the new terminology. Table 1 provides a list of 
machine type and storage-management software requirements. Table 2 on page 2 
provides a list of some of the old and new terms. For more information, refer to the 
IBM Netfinity Fibre Channel Storage Manager Concepts Guide.

Table 1. Machine type and storage-management software requirements 

Product name Machine 
type Model

Product 
release and 

firmware 
version

Released storage-
management 

software version

IBM FAStT200 3542 1RU 4.x 7.02

IBM FAStT200 HA 3542 2RU 4.x 7.02

Netfinity Fibre Channel RAID Controller Unit 3526 1RU 3.x, 4.x 6.22, 7.02

Netfinity FAStT500 RAID Controller Enclosure Unit 3552 1RU 4.x 7.02
  1



 

It is important to understand the distinction between the following two terms when 
reading this document.

Management station
A management station is a system that is used to manage the storage 
subsystem. This system does not need to be attached to the storage 
subsystem through the Fibre Channel I/O path.

Host and host computer
The terms host and host computer are used interchangeably throughout this 
book. Both terms refer to a system that is directly attached to the storage 
subsystem through a Fibre Channel I/O path. This system is used to serve 
data (typically in the form of files) from the storage subsystem.

Note: A system can be both a management station and a host computer at the same 
time.

Software components
Storage Manager 7.02 contains the following software components:

• Client software

• Host-agent package

Client software
The Storage Manager 7.02 client (SM7client) component provides the graphical user 
interface for managing storage subsystems through the Ethernet network or from the 
host. The SM7client contains two main components:

• Enterprise Management. You can use the Enterprise Management component 
for adding, removing, and monitoring storage subsystems within the management 
domain.

• Subsystem Management. You can use the Subsystem Management component 
for managing the components of an individual storage subsystem.

Host-agent package
The Storage Manager 7.02 agent (SM7agent) package consists of three software 
components:

• Host-agent software. You can use the host-agent software to manage storage 
subsystems through the host Ethernet connection. The host-agent software takes 
requests from a management station that is connected to the host through an 
Ethernet connection and passes the requests to the storage subsystem 
controllers through the Fibre Channel I/O path. For more information about 
managing storage subsystems through the host-agent, see “Host-agent managed 
method” on page 3.

Table 2. Old and new terminology

Term used in previous versions New term

RAID module Storage subsystem

Drive group Array

Logical unit number (LUN)1 Logical drive

1 In Storage Manager 7.02, the term logical unit number (LUN) refers to a logical address that is used by the host to 
access a particular logical drive.
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• SM7devices utility. You can use the SM7devices utility to associate storage 
subsystem logical drives with operating system device names. For more 
information about using SM7devices, see “Using the SM7devices utility” on page 
45.

• Hot Add utility. You can use the hot add utility to register newly created logical 
drives without restarting the operating system. For information on using the hot 
add utility, see “Using the Hot Add utility” on page 45.

Storage subsystem management methods
The storage-management software provides two methods for managing storage 
subsystems — the host-agent managed method and the directly managed method. 
Depending on your specific storage subsystem configurations, you can use either or 
both methods.

Host-agent managed method
When you use this method, you manage the storage subsystems through the Fibre 
Channel I/O path to the host. The storage subsystem is managed from the host 
computer or management station that is attached to the host through an Ethernet 
connection.

Managing storage subsystems through the host-agent has these advantages:

• You do not have to run Ethernet cables to the controllers.

• You do not need a BOOTP server to connect to the network.

• You do not need to perform the controller network configuration tasks that are 
described in Chapter 2, “Preparing for installation,” on page 13.

• When adding devices, you have to specify a host name or IP address only for the 
host instead of for the individual controllers in a storage subsystem. Storage 
subsystems that are attached to the host are automatically discovered.

Managing storage subsystems through the host-agent method has these 
disadvantages: 

• You are limited to configuring one less logical unit number (LUN) than the 
maximum number that is allowed by the operating system and the host adapter 
that you are using.

• The host-agent requires a special logical drive, called an access volume, to 
communicate with the controllers in the storage subsystem.

Note: The access volume uses one of the LUNs. NetWare allows a maximum 
number of LUNs depending on which Service Pack is installed and which host 
adapter you are using. For more information, see “Number of supported logical 
drives” on page 42.

Important:  If your host system is configured with the maximum number of LUNs, you 
must give up a LUN to be used as an access volume.
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Figure 1 shows a system in which storage subsystems are managed through the 
host-agent.

Figure 1. Host-agent managed storage subsystems

Directly managed method
When you use the directly managed method, you manage storage subsystems 
directly over the network through the Ethernet connection to each controller. To 
manage the storage subsystem through these Ethernet connections, you must define 
the IP address and host name for each controller and attach a cable to the Ethernet 
connectors on the storage subsystem controllers.

Managing storage subsystems directly has these advantages:

• The Ethernet connections to the controllers enable a management station running 
SM7client to manage storage subsystems that are connected to a host running 
NetWare or other operating systems that are supported by Storage Manager 
7.02.

• You do not need to use an access volume to communicate with the controllers as 
you do if you are running the host-agent software. You can configure the 
maximum number of LUNs that are supported by the operating system and the 
host adapter that you are using.

Managing storage subsystems directly has these disadvantages:

• It requires two Ethernet cables to connect both storage subsystem controllers to a 
network.

• When adding devices, you must specify an IP address or host name for each 
controller.

• A BOOTP server and network preparation tasks are required. For a summary of 
the preparation tasks, see Table 8 on page 14.

Ethernet

Host computer

Controller

Controller

Controller

Controller

Fibre Channel
I/O path

Management station
(one or more)

Running the
host-agent software

Storage subsystems

Note: The host can act as a
management station also.
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Figure 2 shows a system in which storage subsystems are managed directly.

Figure 2. Directly managed storage subsystems

Installation types
To install Storage Manager 7.02, choose the installation type in the following list that 
represents the setup of your enterprise.

• New storage subsystem environment. You do not have existing storage 
subsystems. In this case, you are installing new storage subsystems with 
machine type 3526, 3542, or 3552 controllers using firmware version 4.00.0x and 
intend to manage these new storage subsystems using Storage Manager 7.02. To 
proceed with this installation, go to “System requirements” on page 10.

• Existing storage subsystem environment. You have existing storage 
subsystems. Table 3 on page 6 explains your options for managing these existing 
storage subsystems.

Ethernet

Host computer

Fibre Channel
I/O path

Management station
(one or more)

Controller

Controller

Controller

Controller

Storage subsystems
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Managing new and existing storage subsystems attached to the same 
host

When installing Storage Manager 7.02, you must determine how you will use any 
existing storage subsystems. Existing storage subsystems are coexisting storage 
subsystems when they are attached to the same host as storage subsystems 
managed with Storage Manager 7.02, and when the conditions in Table 4 are met.

Table 3. Configurations for existing storage subsystems 

Existing storage subsystems 
with: Options

Machine type 3526 controllers 
running firmware version 3.x

Option 1 —Upgrade the controller firmware to version 4.x and manage the 
storage subsystems with Storage Manager 7.02. Go to “System 
requirements” on page 10. 

Option 2 —Install new storage subsystems and attach them to the same 
host as the existing storage subsystems. These existing and new storage 
subsystems are referred to as coexisting storage subsystems. See 
“Managing new and existing storage subsystems attached to the same 
host” for more information.

Option 3 —Continue to use version 6.22 of the storage-management 
software to manage these storage subsystems if they are attached to 
separate hosts from those that are attached to storage subsystems 
managed with Storage Manager 7.02. Go to “System requirements” on 
page 10.

Table 4. Coexisting storage subsystems requirements 

Existing storage subsystems New or upgraded storage subsystems

• Use 3.01.x firmware

• Are managed with version 6.22 of the 
storage-management software

Note: Firmware and software levels are the 
minimum levels required for machine 
type 3526 controllers to coexist with 
new or upgraded storage 
subsystems.

• Use 4.00.0x firmware

• Are managed with Storage Manager 
7.02
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Figure 3 shows an example of an environment that includes coexisting storage 
subsystems.

Figure 3. Sample coexistence installation
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Version 6.22 of the storage-management
software must be installed on a
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Firnware version
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storage-management
software must be installed on either
a management station or host.
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Standard configuration
You can install Storage Manager 7.02 in a standard configuration. Table 5 describes 
where the storage-management software components are installed in a standard 
configuration (not a cluster server configuration).

Table 5. Where to install software components in a standard configuration 

Software component Where installed Notes

Storage Manager 7.02 client 
(SM7client)

You can install the SM7client package 
on either of the following:

• Management station (for direct or 
host-agent management)

• Host computer (for direct or host-
agent management)

• Management stations 
If you install the SM7client software on 
one or more management stations, you 
can choose to manage storage 
subsystems directly through Ethernet 
connections to the controllers, over the 
network through the host-agent, or a 
combination of both methods.

• Host computer in a networked 
controller configuration
If you install the SM7client software on 
the host computer, you can use the 
directly managed method, the host-
agent managed method or a 
combination of both. The host computer 
does not need to be connected to a 
network if the host-agent software is 
installed. However, the host computer 
must have the TCP/IP software installed 
and you must assign a static IP address 
to the host.

• Host computer in a non-networked 
controller configuration
If you install the SM7client software in an 
alternative, non-networked controller  
configuration, you can manage the 
storage subsystems that are connected 
to the host computer through the Fibre 
Channel I/O path.

To set up a non-networks configuration, 
perform the following steps:

1. Install the host-agent package.

2. Install the TCP/IP software on the host 
computer. 

3. Assign a static IP address to the host 
computer.

Storage Manager 7.02 agent 
(SM7agent)

Host server You must install the SM7agent software even 
if you choose not to manage storage 
subsystems with the host-agent software. 
The host-agent package contains important 
utilities that are necessary for operating the 
storage-management software.
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The following figure shows an example of a standard configuration, including a 
management station. You can install the SM7client on a stand-alone host computer if 
that host has the TCP/IP software installed and the host has a static IP address.

Figure 4. Sample standard configuration
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System requirements
This section provides detailed information about the hardware, software, and 
operating requirements for Storage Manager 7.02.

Hardware requirements
The following table lists the hardware that is required for installing Storage Manager 
7.02. For the latest information about host adapters and host adapter drivers, see the 
README file on the IBM FAStT Storage Manager Version 7.02 for Novell NetWare 
installation CD or on the IBM web site at: http://www.ibm.com/pc/support.

Table 6. Hardware requirements for the storage-management software 

Hardware component Requirements

A BOOTP server 
(for only directly managed 
storage subsystems)

• UNIX® BOOTP server or

• Novell DNS/DHCP services for NetWare 5 or greater

• Microsoft BOOTP-compatible DHCP2 server for 
Windows NT® Server 4.0 with Service Pack 5 or later

Storage subsystems 
(one or more)

Storage subsystems with controllers running firmware version 
4.00.0x.

Note: Before you begin, make sure that you read “Storage 
subsystem management methods” on page 3 for 
information on managing these storage subsystems 
when existing storage subsystems are physically 
connected to the same host that you will connect to the 
new storage subsystems.

Fibre Channel host adapters The IBM FAStT Host Adapter (part number: 00N6881) has been 
tested with the storage-management software.

For information on specific host adapter requirements:

• Refer to the README file in the \Netware51\Host_Adapter 
directory on the installation CD.

• Read the documentation that comes with your host 
adapter.

• Refer to the IBM support Web page at 
http://www.ibm.com/pc/support

Fibre Channel fabric 
switches (if needed for the 
desired configuration)

The following Fibre Channel fabric switches were tested with 
the storage-management software:

• IBM 8-port Fibre Channel switch 
(machine type 2109-S08)

• IBM 16-port Fibre Channel switch 
(machine type 2109-S16)

For specific Fibre Channel switch setup requirements:

• Read the documentation that comes with your switch.

• Refer to the IBM products Web page at 
http://www.ibm.com/products

Fibre Channel managed 
hub (if needed for the 
desired configuration)

The IBM Fibre Channel managed hub (machine type: 3534) has 
been tested with the storage-management software.

For specific Fibre Channel managed hub setup requirements:

• Read the documentation that comes with your managed 
hub.

• Refer to the IBM Web site, http://www.ibm.com/products
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Management station or host 
(for client software)

Your management station or host computer will require:

• Intel® Pentium® or Pentium-equivalent microprocessor 
(133 MHz or faster)

• CD-ROM drive

• Mouse or similar pointing device.

• A minimum of 64 MB system memory (128 MB preferred).

• AGP or PCI video card (AGP preferred), ISA cards are not 
supported.

• Monitor setting of 1024 x 768 pixels with 64 000 colors. The 
minimum display setting that is allowed is 800 x 600 pixels 
with 256 colors.

If you are using a monitor setting of 256 colors, you might 
experience display problems when scrolling up or down in 
the online help windows. Use the Page Up and Page Down 
keys or click in the scroll area above or below the scroll bar.

Do not use the Up Arrow or Down Arrow keys or click on 
the scroll bar to move it for scrolling the online help 
windows.

• Hardware-based Windows® acceleration

• 60 MB of free hard disk space

• Ethernet network interface card

Note: Desktop computers that use system memory for 
video memory are not preferred for use with the 
storage-management software.

Important:  Many PC-based servers are not designed to 
run graphic intensive software. If your server has difficulty 
running the storage-management software smoothly 
without video artifacts, you might need to upgrade the 
server’s video card.

The following microprocessors are preferred for the optimal use 
of laptop computers as management stations: 

• Intel, 366 MHz or faster

• AMD, 400 MHz or faster

Table 6. Hardware requirements for the storage-management software 

Hardware component Requirements
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Firmware requirements
Storage Manager 7.02 operates with only controller machine type 3526, 3542, and 
3552 and firmware version 4.00.0x.

Software requirements
The following table contains the installation requirements for each of the software 
packages.

Operating system requirements
For management stations, install one of the following operating systems:

• Windows NT Server 4.0 with Service Pack 5 or later

• Windows NT Workstation 4.0 with Service Pack 5 or later

• Windows NT 4.0 Enterprise Edition with Service Pack 5 or later

• Windows 2000 Server

• Windows 2000 Professional

• Windows 2000 Advanced Server

For hosts, install Novell NetWare version 5.1 operating system with Service Pack 1.

Table 7. Installation requirements by software package 

Requirement Software

SM7client SM7agent

Available disk space 60 MB 1 MB

Administrator privileges Not required Required

Minimum display settings 800 x 600 pixels, 256 colors 640 x 480 pixels, 256 colors1

1 These settings are for the InstallShield installation of the software.
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Chapter 2.  Preparing for installation

This chapter provides information to help you plan and prepare for installing the 
storage-management software.

Deciding how to manage storage subsystems
If you have not already done so, see Chapter 1, “Introduction,” on page 1 for 
information about the following two methods for managing storage subsystems:

• Direct management through an Ethernet connection to each controller on the 
storage subsystem

• Host-agent management through the host-agent software that is installed on the 
host computer that is connected to the storage subsystem

You can use one or both methods. However, because many of the preparation tasks 
for installation depend on which method you use, before you begin, decide how you 
want to manage the storage subsystems on your network.

Figure 5 on page 14 shows an example of a directly managed storage subsystem 
network setup (see network A). This network contains the following components:

• BOOTP server

• Management station for Simple Network Management Protocol (SNMP) traps

• Host that is connected to a storage subsystem through a Fibre Channel I/O path

• Management station connected by Ethernet cable to the storage subsystem 
controllers

Figure 5 on page 14 shows an example of a host-agent managed storage subsystem 
network setup (see network B). This network contains the following components:

• A host that is connected to a storage subsystem through a Fibre Channel I/O path

• A management station that is connected by Ethernet cable to the host
© Copyright IBM Corp.  2001  13



 

Figure 5. Sample network

Preparing for a network installation 
Before you install the storage-management software, make sure that the network 
components are set up and operating properly, and that you have all the host and 
controller information that is needed for the software to operate correctly. To do this, 
perform the tasks that are summarized in Table 8 (referring to the appropriate 
procedures). Use Table 13 on page 47 as a data sheet to record storage subsystem 
and controller information.

Controller

Controller

Controller

Controller

Storage
subsystem

finance

Storage
subsystem
engineering

Fibre Channel
I/O path

Fibre Channel
I/O path

Network A
TCP/IP

Network B
TCP/IP

Ethernet

Router

Network
management

station
(for SNMP traps)

Management
station

(one or more)

Management
station

(one or more)

Host computer
Denver

(IP address
153.79.144.12)

Host computer
Atlanta

(IP address
153.79.144.22)

BOOTP server

Host name: Denver_a
(IP address 153.79.144.13)

hardware address 00.a0.b8.02.04.20
Host name: Denver_b

(IP address 153.79.144.14)
hardware address 00.a0.b8.00.00.d8

Table 8. Network preparation task summary 

Task to perform For direct or host-
agent? Why perform this task? For instructions, 

see

Step 1- Install all 
hardware 
components (host 
computers, storage 
subsystems, cables, 
and so on) that you 
want to connect to 
the network.

Both To ensure that the 
network hardware is 
present.

The installation 
guide that is specific 
to the hardware 
components.

Step 2 - Establish 
and record a naming 
convention for the 
storage subsystems 
that are connected to 
the network.

Both To add the storage 
subsystems to the 
management domain 
after installing the 
software.

“Deciding how to 
name the storage 
subsystems” on 
page 16.
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Step 3 - Determine 
the hardware 
Ethernet address for 
each controller in all 
storage subsystems 
that are connected to 
the network.

Direct To set up the BOOTP 
server to provide network 
configuration information 
to the controllers.

“Identifying the 
hardware Ethernet 
address for each 
controller” on page 
17.

Step 4 - Obtain IP 
addresses and host 
names from the 
network 
administrator.

Both For host-agent 
management, you need 
the IP addresses and 
host names of the host 
on which the host-agent 
software will run.

For direct management, 
you need the IP 
addresses of each 
controller in the storage 
subsystems. The IP 
addresses are used to 
configure the BOOTP 
server so that it can 
provide network 
configuration information 
to the controllers. Also, 
you use the IP addresses 
of the controllers to set 
up the host or Domain 
Name System (DNS) 
table.

“Obtaining IP 
addresses for hosts 
and controllers” on 
page 18.

Step 5 - Set up the 
BOOTP server to 
provide network 
configuration 
information for a 
specific controller.

Direct To provide network 
configuration information 
to the controllers, using 
the BOOTP server.

“Setting up the 
BOOTP server” on 
page 19.

Step 6 - Verify that 
the TCP/IP software 
is installed and set 
up the host or DNS 
table.

Direct Installing the client 
software on a 
management station 
ensures that the 
management station is 
configured to reach the 
controllers over the 
network. If the client 
software is installed on 
the host, the TCP/IP 
software is still 
necessary for successful 
communication between 
the client software and 
the controllers.

“Verifying the 
TCP/IP software and 
setting up the host 
or DNS table” on 
page 27.

Step 7 - Power on 
the devices that are 
connected to the 
network.

Both To ensure that all devices 
and links are operational.

The installation 
guide that is specific 
to the hardware 
components.

Table 8. Network preparation task summary 

Task to perform For direct or host-
agent? Why perform this task? For instructions, 

see
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Table 9 shows an example of an information record with entries for a directly managed 
storage subsystem and a host-agent managed storage subsystem. 

Table 13 on page 47 provides a data sheet on which you can record storage 
subsystem names, management types, hardware Ethernet addresses, and IP 
addresses. Make a copy of this table and complete the information for your storage 
subsystems and controllers. Use the information that is recorded in Table 13 on page 
47 to set up the BOOTP table for the network server and the host or Domain Name 
System (DNS) table. The information in Table 13 on page 47 helps you add storage 
subsystems after initial installation. The column headings show a page reference for 
detailed instructions about obtaining the information. For an example of an information 
record, see Table 9.

Deciding how to name the storage subsystems
As you set up your network, decide on the naming convention for the storage 
subsystems. After you install the storage-management software and start it for the 
first time, all storage subsystems in the management domain are displayed as 
<unnamed>. Use the Subsystem Management window to rename the individual storage 
subsystems.

The following list provides tips for naming storage subsystems:

• There is a 30-character limit. All leading and trailing spaces are deleted from the 
name.

• Use a unique, meaningful naming scheme that is easy to understand and 
remember.

• Avoid arbitrary names or names that would quickly lose their meanings in the 
future.

• The software displays storage-subsystem names with the prefix Storage 
Subsystem. Therefore, if you rename a storage subsystem to Engineering, it is 
displayed as: 

Storage Subsystem Engineering

After you decide on a naming scheme, record the storage subsystem names in the 
information record (Table 13 on page 47).

Table 9. Sample information record 

Storage 
subsystem 

name
(see page 16)

Management 
type (see page 

13)

Controllers—Ethernet and IP 
addresses, and host name

(see pages 17 and 18)

Host—IP 
address 

and host name
(see page 18)

Storage 
Subsystem 
Finance

Direct Hardware 
Ethernet 
address = 
00a0b8020420

Hardware 
Ethernet 
address = 
00a0b80000d8

IP address = 
153.79.144.13

IP address = 
153.79.144.14

Host = Denver_a Host = Denver_b

Storage 
Subsystem 
Engineering

Host-agent IP address = 
153.79.111.22

Host = Atlanta
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If you are directly managing your storage subsystem, go to “Identifying the hardware 
Ethernet address for each controller”. If you are going to manage your storage 
subsystem through the host-agent, go to “Obtaining IP addresses for hosts and 
controllers” on page 18.

Identifying the hardware Ethernet address for each controller
Use the following procedure if you plan to directly manage storage subsystems 
through Ethernet connections to each controller. If you plan to manage storage 
subsystems using the host-agent software, skip this procedure and go to “Obtaining 
IP addresses for hosts and controllers” on page 18.

1. Remove the front bezel (machine types 3526 and 3552), from the controller unit, 
as shown in Figure 6. Carefully pull the bottom of the bezel out to release the pins 
c1d; then slide the bezel down c2d.

Figure 6. Removing the controller-unit bezel (machine types 3526 and 3552)

2. Unlock and open the levers on the RAID controllers, models 3526 and 3552.

Figure 7. Location of the hardware Ethernet address (machine types 3526 and 3552)

Hardware Ethernet
address label
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Figure 8. Location of the hardware Ethernet address (machine type 3542)

3. The controller hardware Ethernet address labels are located on the front of each 
controller, as shown in Figure 7 on page 17 and Figure 8.

The number is in the form xx.xx.xx.xx.xx.xx (for example, 00.a0.b8.00.00.d8).

4. Record each Ethernet address in the information record (Table 13 on page 47).

5. To replace the bezel (machine types 3526 and 3552), slide the top edge under the 
lip on the chassis c1d; then, push the bezel bottom until the pins snap into the 
mounting holes c2d, as shown in Figure 9.

Figure 9. Replacing the controller-unit bezel (machine types 3526 and 3552)

6. Continue with “Obtaining IP addresses for hosts and controllers”. 

Obtaining IP addresses for hosts and controllers
If you plan to manage your storage subsystems directly, assign (or obtain from your 
network administrator) a unique IP address and associated host name for each 
controller in every storage subsystem on the network. Record the IP address and host 
name for each controller in the information record (Table 13 on page 47). Then, go to 
“Setting up the BOOTP server” on page 19.

Hardware Ethernet
address label
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Setting up the BOOTP server
If you plan to directly manage storage subsystems through the Ethernet connection to 
each controller, select the procedure that you plan to use for setting up the BOOTP 
server: 

• If you are using a NetWare BOOTP-compatible DHCP server, go to “Using 
NetWare DHCP as a BOOTP-compatible server”.

• If you are using a Microsoft BOOTP-compatible DHCP server, go to “Using 
Microsoft DHCP as a BOOTP-compatible server” on page 21.

• If you are using a UNIX BOOTP server, go to “Using a UNIX BOOTP server” on 
page 27.

If you plan to manage storage subsystems using the host-agent software, go to 
“Verifying the TCP/IP software and setting up the host or DNS table” on page 27. 

Using NetWare DHCP as a BOOTP-compatible server
To use a DHCP server, you must have a DHCP Manager installed.

Before you begin:
Yo must complete the following steps before setting up DHCP:

1. Install NetWare version 5.1 on the selected server or servers.

2. Install the Novell Client software delivered with NetWare version 5.1 on client 
computers that you will use to administer DNS and DHCP.

3. Install the DNS/DHCP Management Console on client computers that you will use 
to administer DNS and DHCP.

Installing DHCP services during the NetWare 5.1 server 
installation
Use the following procedure to install DHCP services:

1. From the Installation Options window, select Custom.

2. From the Components window, select the Novell DNS/DHCP Services check box.

3. Follow the on-screen instructions to complete the NetWare version 5.1 server 
installation.

Launching the DHCP management console
To launch the DNS/DHCP Management Console, double-click its icon. You can install 
the DNS/DHCP Management Console on a client workstation, or you can access it 
from the Tools menu of the NetWare Administrator utility.

After the DNS/DHCP Management Console is installed, you are prompted to enter the 
DNS Tree Name where you want to set up DHCP.

Creating a DHCP server object
Use the DHCP Management Console to create and set up a DHCP server

object. A DHCP server object is created or located under any of the following

objects: 

Organization (O) 
Organization Unit (OU) 
Country (C) 
Locality (L)
 Chapter 2.  Preparing for installation  19



 

Complete the following steps to create and set up a DHCP server object:

1. Click the DHCP Service tab of the DHCP Management Console.

The Our Network object is the only object displayed on the DHCP Management 
Console’s left pane.

2. Click Create on the tool bar. 

The Create New DHCP Object window opens, enabling you to create a DHCP 
server object, a subnet object, or a subnet pool object. 

3. Select DHCP Server and click OK.

The Create DHCP Server window opens, prompting you to select a server object. 

4. Use the browse button to select a server, then click Create.

This creates the DHCP server object in NDS, called DHCP_servername.

In the DHCP Management Console, locate the icon for the DHCP server at the 
bottom of the DHCP Service tab. The server object will display with a red line 
through it. The red line indicates that DHCP server NLM and related NLMs have 
not been installed.

Creating a subnet object
You use the DNS/DHCP Management Console to create and set up a DHCP subnet

object for each of the subnets to which you will assign addresses.

You must complete the following steps to create and set up a subnet object:

1. Click the DHCP Service tab of the DNS/DHCP Management Console.

The Our Network object is the only object displayed on the DNS/DHCP 
Management Console’s left pane.

2. Click Create on the tool bar.

The Create New DHCP Object window opens enabling you to create a DHCP 
server, a subnet, or a subnet pool object.

3. Select Subnet and click OK.

The Create Subnet window opens. For each subnet you create, enter the 
following information in the fields provided: subnet name, NDS context, subnet 
address, and subnet mask. If you have setup a default DHCP server, its name is 
displayed and can be changed.

Click the Define Additional Properties check box to provide more detailed 
configuration, including DHCP options specific to each subnet. 

4. Enter the required information, then click Create.

The DHCP subnet object is created and displayed in the left pane of the 
DNS/DHCP Management Console.

Creating subnet address ranges
You use the DNS/DHCP Management Console to create and set up subnet address

range objects for each pool of addresses you want to be dynamically assigned by 
DHCP.

To create and set up a subnet address range object, complete the following steps: 

1. Click the DHCP Service tab from the DNS/DHCP Management Console.

2. Select the subnet object under which you want to create the subnet address 
range object, then click Create.
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The Create New DHCP Record window opens.

3.  Select Subnet Address Range and click OK.

The Create New Subnet Address Range window opens.

4. Enter a name for the subnet address range, specify the range’s starting and 
ending address, then click Create. 

If you click the Define Additional Properties check box, the range’s detailed 
information window is displayed, enabling you to provide more detailed 
configuration information.

Creating IP address objects
You use the DNS/DHCP Management Console to create and set up any IP address

objects to be assigned to specific devices or to be excluded from dynamic 
assignment. Create an IP address object for each such device or address. Assigning 
a specific address to a client requires you to specify the client’s media-access control 
(MAC) address or Client ID. 

If you have set up subnets and subnet address ranges, you are not required to set up 
individual IP addresses unless you want to perform manual address assignment or 
exclude addresses from assignment.

To create and set up an IP address object, complete the following steps:

1. Click the DHCP Service tab of the DNS/DHCP Management Console.

2. Select the subnet object of the target IP address, then click Create on the tool bar. 

The Create New DHCP Object window opens.

3. Select IP Address and click OK. 

The Create IP Address window opens.

4. Enter the IP address to be assigned or excluded, select the assignment type, then 
click Create.

If you choose Manual Assignment Type, you must provide information for either 
the Client Identifier or the MAC Address fields. You can also specify the MAC Type 
by clicking in the field; the default is FF Any.

Starting the DHCP server
After you create and set up a DHCP server and configure the NDSTM objectsrequired 
for DHCP, type the following command at the DHCP server console: 

LOAD DHCPSRVR

After you install DHCPSRVR.NLM, the DHCP server can respond to client requests 
and assign IP addresses.

Note: For additional information about setting up, configuring, or using Novell 
DNS/DHCP Services, refer to the NetWare 5.1 documentation, located on the 
Novell Documentation CD or at http://www.novell.com/documentation.

Using Microsoft DHCP as a BOOTP-compatible server
You must use a version of DHCP that supports BOOTP static addressing. To use a 
DHCP server, you must have a DHCP Manager installed. If a DHCP Manager is 
installed on the system, go to “Setting up a DHCP server” on page 22. If a DHCP 
Manager is not installed, use the following installation procedure.
 Chapter 2.  Preparing for installation  21



 

Installing the DHCP manager
Use the following procedure to install the DHCP Manager:

1. Click Start → Settings → Control Panel.

2. Double-click the Network icon.

3. In the Network window that opens, click the Services tab.

4. Click DHCP Server Network Services → Add.

5. Reinstall Windows NT Service Pack 5 or later to get the new DHCP settings or 
information that is associated with the service pack.

6. Continue with “Setting up a DHCP server”.

Setting up a DHCP server
Use the following procedure, along with Table 13 on page 47, to set up the DHCP 
server. 

Note: The following steps and window examples assume that you are configuring a 
Windows NT DHCP server using its DHCP Manager.

1. Click Start → Programs → Administrative Tools → DHCP Manager.

The DHCP Manager window opens.

2. Create a scope. A scope defines a group of controllers that you want to configure 
using the DHCP server:

a. Click Local Machine.

b. Click Scope g Create.

The Create Scope window opens.

Figure 10. Create scope - (Local) window

c. Type the starting and ending IP addresses of the controllers that you are 
configuring on the network.

For example, if you are configuring 50 controllers on a 153.79.144.0 subnet, 
set the starting address to 153.79.144.1, and set the ending address to 
153.79.144.50. 
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Note: If each field does not contain at least three characters, press the 
period (.) key to advance to the next field. If you have only one 
controller, type its address for both the starting and ending addresses.

d. Type the subnet mask (obtained from your network administrator).

e. Set the Lease Duration to Unlimited. This makes the DHCP connection 
permanent.

f. Type a scope name and comment.

g. Click OK.

h. When the scope is successfully completed, click Yes to activate it.

You return to the DHCP Manager window.

3. Use the following procedure to configure global scope options. You can use the 
scope options to configure settings that are applicable to all controllers. To 
determine which parameters to apply to the entire group, see Table 8 on page 14.

Note: You can apply options to specific controllers later using step 5 on page 24.

a. Click DHCP Options → Global.

The DHCP Options: Global window opens.

Note: The Remote Management Station (RMS) and Network Management 
Station (NMS) entries used in previous versions of storage-
management software version 6.22, are not required when using 
Storage Manager 7.02 to manage storage subsystems with controllers 
running firmware version 4.00.0x.

Figure 11. DCHP Options window

b. Select an item in the Unused Options list, and click Add to move it to the 
Active Options list. Each option is preceded by its tag number.

c. Click Value to assign a value to the active option.

If Value is not selectable, the Edit Array option window opens in the lower part 
of the window.

d. If you need to add an IP address, click Edit Array.

The IP Address Array Editor window opens.
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Figure 12. IP Address Array Editor window

Figure 12 shows an example of adding the IP address for a management 
station.

If you do not need to add an IP address, go to step 4..

e. Type the unique IP address for the option that you added.

f. Click Add to move the New IP Address to the IP Addresses list.

g. Click OK.

You return to the DHCP Options: Global window.

h. Repeat step 3d through step 3g until all global options are added.

When you finish adding the Global Scope Options, click OK at the DHCP 
Options: Global window.

You return to the DHCP Manager window. 

4. Use the following procedure to create a reservation for each controller. Use the 
data sheet that you created from Table 13 on page 47 to make sure that you 
include all of the controllers for every storage subsystem on the network.

a. Click Scope → Add Reservations.

b. In the IP Address field, type the IP address for the first controller on your data 
sheet.

c. In the Unique Identifier field, type the controller hardware Ethernet address.

d. In the Client Name field, type the eight-character controller name.

e. Click Add.

f. Repeat step 4b through step 4e for each controller that is listed in your data 
sheet. See Table 13 on page 47.

g. When you finish typing the information for all of the controllers, click Close. 

You return to the DHCP Manager window.

5. Use the following procedure to configure controller-specific options. By creating a 
controller-specific option, you can associate a controller configuration entry with a 
specific controller that you added in step 4.

Note: If you set an option as Global Scope, it applies to every controller in this 
group and does not need to be added again.

a. Click Scope → Active Leases.
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The Active Leases window opens.

Figure 13. Active Leases window

b. Select a controller in the list.

c. Click Properties.

The Unique Identifier is the hardware Ethernet address that you added in step 
4c.

Figure 14. Add Option Type window

d. Click Options.

The DHCP Options: Reservations window opens.

e. Select an entry in the Unused Options list, and click Add to move it to the 
Active Options list.

f. Click Value to assign a value to the active option.

g. Type the information for the value of the option.

For example, for the host name, type the host name for the controller (from 
your data sheet, see Table 13 on page 47) in the string field. Click Edit if the 
value that you need to add is an IP address for a router.

h. Repeat step 5e through step 5g until you finish adding specific options for this 
controller.
 Chapter 2.  Preparing for installation  25



 

i. Click OK.

You return to the Add Option Type window.

j. Click OK.

You return to the Active Leases window.

k. Repeat step 5b through step 5j until you finish adding controller-specific 
options for every controller.

When you finish adding specific options for all controllers, click OK at the 
Active Leases window.

You return to the DHCP Manager window.

6. Continue with “Verifying the TCP/IP software and setting up the host or DNS 
table” on page 27.
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Using a UNIX BOOTP server
Table 10 and Table 13 on page 47 provide information for setting up the BOOTP table 
and making the required entries to support the controllers in the storage subsystems. 
Use a text editor to edit the bootptab file in the /etc directory.

The following example of a BOOTP table assumes that you are configuring a UNIX 
BOOTP server, such as a server on Network A, as shown in Figure 5 on page 14. The 
s4.default:\ entry denotes settings that are common to all controllers. The 
tc=s4.default:\ entry associates this common setting group to a specific controller.

s4.default:\ (common settings)
ht=ether:\
sm=255.255.248.0:\
gw=153.79.144.2:\
hn:
denver_a:\
tc=s4.default:\ (refers to common settings)
ip=153.79.144.13:\
ha=00a0b8020420:
denver_b:\
tc=s4.default:\
ip=153.79.144.14:\
ha=00a0b80000d8"

When you finish setting up the BOOTP table, use the following procedure:

1. Turn on power to the storage subsystems so that the parameters in the BOOTP 
table take effect.

2. After you finish setting up the BOOTP table, go to “Verifying the TCP/IP software 
and setting up the host or DNS table”.

Verifying the TCP/IP software and setting up the host or DNS table
Make sure that the host names for the controllers correspond to the appropriate IP 
addresses for the controllers. Use the following procedure to verify that the TCP/IP 

Table 10. Required entries for setting up the UNIX BOOTP server 

Entry Description
Sample format 

in BOOTP 
server

Subnet mask Mask that is used to route packets to defined 
subnets

dot notation 
(sm=255.255.24
8.0)

Router IP address of the host computer that routes 
packets to networks

dot notation 
(gw=153.79.144.
2)

Host name for the 
controller

Host name that is associated with the controller 
(see Table 13 on page 47)

host name
(Denver_a)

IP address IP address of the controller (see Table 13 on page 
47)

dot notation 
(ip=153.79.144.
13)

Ethernet address The Ethernet address of the controller hardware
 (see Table 13 on page 47)

hexadecimal 
notation 
(ha=00a0b8020
420)
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software is installed on the management station and to set up the host or Domain 
Name System (DNS) table.

Note: You can use the Windows Internet Name Service (WINS) rather than DNS.

1. Click Start → Settings → Control Panel → Network → Protocols to verify that 
the TCP/IP software is installed and configured property.

Note: If the TCP/IP software was not installed properly, install it from the 
Windows NT 4.0 installation CD. Click Start → Settings → 
Control Panel → Network → Protocols → Add → Have Disk.

2. Update either the host or DNS table to specify a host name to associate with an 
IP address. If you do not have a DNS, edit the two host tables that are found in the 
following directories:

c:\winnt\system32\drivers\etc\hosts

c:\winnt\system32\drivers\etc\imhosts

For example, to set up the host tables for the controllers that are connected to 
Network A (Figure 5 on page 14), use a text editor to create the following IP 
address and controller-name entries. 

3. If you want to manage storage subsystems through a packet-filtering firewall, 
configure the firewall to open port 2463 to TCP data. Otherwise, go to Chapter 3, 
“Installing software in a standard configuration,” on page 27.

IP Address Host name for the controller

127.0.0.01 localhost

153.79.144.13 denver_a

153.79.144.14 denver_b
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Chapter 3.  Installing software in a standard configuration

This chapter describes how to install the storage-management software in a standard 
configuration.

Important: Always check for a README file on any installation media. This README 
file might contain important information that was not available when this Installation 
and Support Guide was prepared.

There are two configurations in which you can install the storage-management 
software:

• You do not have existing storage subsystems. In this situation, you are installing 
new storage subsystems with machine type 3526, 3542, or 3552 controllers using 
firmware version 4.00.0x and will manage these new storage subsystems using 
Storage Manager 7.02. If this is your situation, go to “Installation process” on page 
28.

• You do have existing storage subsystems with machine type 3526, 3542, or 3552 
controllers. In this situation, you can do one of the following:

— Upgrade the controller firmware on the existing storage subsystems to 
version 4.00.0x and manage them with Storage Manager 7.02.

— Continue to manage the storage subsystems with version 6.22 of the storage-
management software. You might manage these storage subsystems in 
coexistence with new storage subsystems that you are managing with 
Storage Manager 7.02. To determine if you have coexisting storage 
subsystems, see “Installation types” on page 5.

Use Table 11 to determine your installation process. 

Table 11. Determining your installation process in a standard configuration 

Current environment Planned environment Action

Existing storage subsystems 
with controllers using 
firmware version 3.x

Upgrade to firmware version 4.00.0x. Refer to the README file located in the 
\Netware51\ directory on the installation 
CD for more information.

No existing storage 
subsystems

New storage subsystems with controllers 
that will use version 4.00.0x firmware and 
will be managed with Storage Manager 
7.02.

Go to “Installation process” on page 28.

Existing storage subsystems 
with controllers that have 
firmware versions 4.00.00 
through 4.00.01

Upgrade storage subsystems with 
controllers that will use version 4.00.0x 
firmware and will be managed with Storage 
Manager 7.02.

1. Go to “Installation process” on page 
28.

2. Update the NVSRAM and firmware 
to version 4.00.0x using the storage-
management software online help. 

Continue to use your existing versions 
4.00.00 through 4.00.01 controller firmware 
and will be managed with Storage Manager 
7.02. Refer to the README file located in 
the \Netware51\ directory on the installation 
CD for more information.

Go to “Installation process” on page 28. 
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Installation process
The following installation process applies to:

• New installations

• When installing with existing storage subsystems

Begin the installation of the storage-management software with “Installing the 
SM7client package”. Continue the process until you have completed “Installing the 
host-agent package” on page 30.

Figure 15 shows a flowchart of the installation process. 

Figure 15. Installation process

Installing the SM7client package
Use the following procedure to install the SM7client on a management station that is 
configured with Novell NetWare 5.1 with Service Pack 1.

To install the SM7client on a management station that is configured with one of the 
following operating systems, refer to the IBM FAStT Storage Manager Version 7.02 for 
Windows NT Installation and Support Guide or IBM FAStT STorage Manager Version 
7.02 for Windows 2000 Installation and Support Guide for installation instructions.

• Windows NT Server 4.0 with Service Pack 5 or later

• Windows NT 4.0 Enterprise Edition with Service Pack 5 or later

• Windows NT Workstation 4.0 with Service Pack 5 or later

• Windows 2000 Advanced Server

• Windows 2000 Professional

• Windows Advanced Server

Install the client package

Install the host agent package

Start the Enterprise Management window

Start the Subsystem Management window

Installation is complete.
Go to Chapter 4,
Operating System Support
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Notes: 

• If you are configuring only a network management station, you need to install only 
the SM7client.

• If you want to install SM7client on a stand-alone host and manage storage 
subsystems through the Fibre Channel I/O path rather than over the network, you 
must install the TCP/IP software on the host and assign a static IP address to the 
host.

Installation instructions for NetWare 5.1
Before you install the NetWare SM7client software, make sure that:

• The management station has at least 60 MB of available disk space.

• The monitor properties are set to a minimum screen resolution of 800 x 600 pixels 
and a palette of 256 colors or more.

• You close all other programs.

Perform the following steps if you are installing the SM7client package on a 
management station running NetWare 5.1 operating system software:

1. Insert the IBM FAStT Storage Manager installation CD into the CD-ROM drive 
and type: 

load cdrom

2. Mount the volume.

3. Click Novell → Install.

4. Click Add, and follow the instructions on the screen.

5. Click the Directory Tree button.

The Directory Tree window opens.

6.  Select the CD-ROM volume.

7. Select the \Netware51\SM7client directory.

8. Select the program.ni file, and then click OK.

9. Click OK.

After the files are copied, the License Agreement window opens.

10. Click Accept to continue. 

The copying files message window opens.

11. When the installation is complete, click Finish.

Use the following procedure to verify that the installation was successful:

1. Click Novell → Programs.

2. Verify that the Netfinity Fibre Channel Storage Manager client appears in the list 
of programs.

3. Go to “Installing the host-agent package” on page 30. 

Note: You must install the host-agent package even if you are installing SM7client 
only on a management station.
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Installing the host-agent package
Use the following procedure to install the host-agent package on each host computer 
that is connected to one or more storage subsystems. The SM7agent consists of the 
following components:

• The host-agent software that is necessary for host-agent management of the 
storage subsystems.

• The hot-add utility for dynamically adding logical drives to the operating system. 
See “Using the Hot Add utility” on page 45.

• The SM7devices utility that is used to display the relationship of logical drives to 
operating system device names. For more information, see “Using the 
SM7devices utility” on page 45.

Important: You must install the host-agent package even if you do not intend to 
manage storage subsystems through the host-agent software. The host-agent 
package contains utilities that are required to manage storage subsystems.

Before you install the software, make sure that:

• The host computer is configured with Novell NetWare 5.1 and Service Pack 1.

• The host computer has at least 20 MB of available disk space.

• The monitor properties are set to a minimum screen resolution of 640 x 480 pixels 
and a palette of 256 colors or more.

• You close all other programs

If you are using the host-agent management method for the storage subsystem, set 
the maximum LUN value to 32 for the host bus adapter. By default, the Universal 
Transport Module (UTM) LUNs are set to 31 and must be reported to the operating 
system so that the SM7agent can identify and link to the UTM. For more information, 
refer to the README in the Netware51/host_adapter directory of the IBM FAStT 
Storage Manager installation CD.

Perform the following steps to install the host-agent package:

1. Insert the IBM FAStT Storage Manager installation CD into the CD-ROM drive 
and type:

load cdrom

2. Mount the CD volume.

3. Click Novell → Install.

4. Click Add, and follow the instructions on the screen.

5. Click the Directory Tree button.

The Directory Tree window opens.

6. Select the CD-ROM volume.

7. Select the \Netware51\SM7agent directory.

8. Select the product.ni file, and then click OK.

9. Click OK.

After the files are copied, the License Agreement window opens.

10. Click Accept to continue. 

The files are copied.

11. When the installation is complete, click Finish.
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Note: To enable SM7agent at server startup, an autoexec.ncf entry can now be 
made. 

Use the following procedure to load SM7agent and verify that the installation was 
successful:

1. Toggle to the Server Console window and at the command prompt, type:

Load SM7agent

The agent will start and displays the following message when UTM LUNs are 
being scanned:

Activating

For additional information refer to “Starting the host-agent automatically” on page 33.
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Chapter 4.  Completing the installation

This chapter contains procedures for starting Enterprise Management and Subsystem 
Management and for completing the installation tasks.

Stopping and starting the host-agent
Perform the procedures in the folowing sections to stop and start the host-agent 
software that is installed on the host computer.

Note: If an access volume is not detected, the host-agent software will automatically 
stop running. If you download an NVSRAM file that enables an access volume 
or changes the LUN that is used for the access volume, you must stop and 
restart the host-agent software or restart the host computer to enable the 
discovery of host-agent managed storage subsystems.

Stopping the host-agent
You must stop the host-agent software if you want to add storage subsystems. When 
you restart the service, the host-agent discovers the new storage subsystems and 
adds them to the management domain.

Use the following procedure to stop the host-agent software: 

1. From the system console, press Ctrl+Esc and then, select System Console.

2. At the prompt, type:

unload sm7agent

3. Press Enter.

4. Return to ConsoleOne. Press Ctrl+Esc and then, select Xserver °° Graphical 
Console.

Starting the host-agent manually
The host-agent software must be started manually when the system is started or if it is 
stopped to add storage subsystems.

Use the following procedure to start the host-agent manually:

1. From the system console, press Ctrl+Esc and then, select System Console.

2. At the Prompt type:

sm7agent

3. Press Enter.

4. The window will go blank when the define (NLM) space has been created.

5. Return to ConsoleOne. Press Ctrl+Esc and then, select Xserver °° Graphical 
Console.

Starting the host-agent automatically
To configure the host-agent software automatically at startup, use the following 
procedure:

1. Open the autoexec.ncf file in a file editing program.

2. Locate the section that describes loading the Java Runtime Environment. Type 
the following line after the string:

sys:system/sm7agent
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3. Save and close the edited autoexec.ncf file.

Starting the Enterprise Management window
The Enterprise Management window is the first window that opens when you start the 
software. Use the Enterprise Management window to:

• Add and discover the storage subsystems that you want to manage.

• Provide a comprehensive view of all storage subsystems in your management 
domain.

• Perform batch storage-subsystem management tasks using the Script Editor.

Use the following procedure to start the Enterprise Management window:

1. If you are using the SM7agent, start the SM7agent at the Server Console window.

At the Server Console, type:

Load SM7agent

2. From the Xserver Graphical Console, click Novell → Programs.

3. Click Netfinity Fibre Channel Storage Manager 7 client.

The client software starts, and the Enterprise Management window and the 
Confirm Initial Automatic Discovery window open, as shown in Figure 16.

Figure 16. Confirm Initial Automatic Discovery window

Note: The Enterprise Management window can take several minutes to open. 
No wait cursor (such as an hourglass) is displayed.

If you do not want to perform the initial automatic discovery, click No. You 
can use the Edit → Add Device menu option to add hosts and storage 
subsystems. For more information, see “Adding devices” on page 36. 

4. Click Yes to begin an initial automatic discovery of hosts and storage subsystems 
that are attached to the local subnetwork on which the management station is 
installed.

The software sends a broadcast message across the local subnetwork where the 
management station is installed. It discovers host-agent managed storage 
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subsystems if the hosts that provide network management connections to the 
storage subsystems respond to the broadcast. The software discovers directly 
managed storage subsystems if the controllers in those storage subsystems 
respond to the broadcast message.

Note: It can take up to a minute for the Enterprise Management window to refresh 
after an initial automatic discovery. 

If you need to stop the automatic discovery operation, close the Enterprise 
Management window.

When the initial automatic discovery is complete, you can see all hosts and storage 
subsystems that are attached to the local subnetwork, as shown in Figure 17. 

Figure 17. Enterprise Management window

If you do not see all hosts and storage subsystems: 

• Check the hardware and connections for possible problems (refer to the hardware 
documentation for specific procedures).

• Refer to the Enterprise Management Help topic about discovering storage 
subsystems.

• Make sure that the device is on the local subnetwork. If it is not, you must use the 
Add Device option.

Note: If any device shows a status of Unresponsive, use the software to remove the 
device from the management domain and then add it again. Refer to the 
Enterprise Management online Help for instructions on removing and adding 
devices.

A storage subsystem might be duplicated in the device tree after an automatic 
discovery, if the storage subsystem is directly managed but is attached to a host with 
the host-agent software installed and running. In this case, you can remove the 
duplicate storage-management icon from the device tree using the Remove Device 
option in the Enterprise Management window.

Continue with “Adding devices” on page 36.
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Adding devices
You can add more hosts or storage subsystems outside the local subnetwork. For 
more information about this option, refer to the Enterprise Management window online 
Help.

Important:   If you are managing storage subsystems through the host-agent 
software and you physically add new storage subsystems, you must stop and restart 
the host-agent service so that it can recognize the new storage subsystems. Then, go 
to the Enterprise Management window and click Tools → Rescan to add the new 
storage subsystems to the management domain.

Continue with “Monitoring storage subsystems”.

Monitoring storage subsystems
To monitor the condition of storage subsystems in your management domain, you 
must start Enterprise Management. For more information about monitoring storage 
subsystems, refer to the Enterprise Management online Help.

Setting up alert notifications
After you add devices to the management domain, set up alert notification options to 
report critical events on the storage subsystems. The following options are available 
for alert notification:

• Notification to a designated network management station (NMS) using Simple 
Network Management Protocol (SNMP) traps (see “Setting up the NMS for SNMP 
notification” for more information)

• Notification to designated e-mail addresses

• Notification to designated alphanumeric pagers (when a third-party software 
package is used to convert e-mail messages)

Note: The Enterprise Management window must remain open if you want to monitor 
the condition of storage subsystems that are included in your management 
domain. You might want to minimize the window. If you close this window, you 
will not receive alert notifications. Refer to the Enterprise Management online 
Help for more information on alert notification options.

Setting up the NMS for SNMP notification
If you choose to set up alert notification using SNMP traps, you must first copy a 
management information base (MIB) file to the designated network management 
station. Use this procedure to set up the MIB file on the network management station.

Important: You need to set up your designated NMS only one time.

1. From the \Netware51\SM7mib directory on the IBM FAStT Storage Manager 
installation CD, copy the Arrayman.mib file to the network management station.

2. Follow the steps that are required by your specific network management station to 
compile the MIB file.

Note: For details on the required steps, see your network administrator or the 
documentation that is specific to the NMS product that you are using.
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Configuring alert destinations
Configure SNMP trap destinations and e-mail destinations for alert notifications using 
Enterprise Management. Refer to the Enterprise Management online Help for specific 
procedures.

Starting Subsystem Management
The Subsystem Management window enables you to manage selected subsystems.

Use the following procedure to open a Subsystem Management window for a selected 
storage subsystem:

1. In the Enterprise Management window, select a storage subsystem.

2. Click Tools → Manage Device.

The software displays the Subsystem Management window for the selected 
storage subsystem, as shown in Figure 18.

Note: Using the open Subsystem Management window, you can manage only 
the selected storage subsystem. However, you can open multiple 
Subsystem Management windows to manage other storage subsystems.

Figure 18. Subsystem Management window (models 3526 and 3552)
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Figure 19. Subsystem Management window (model 3542)

Renaming storage subsystems
When starting Storage Manager 7.02 for the first time, the storage subsystems are 
unnamed. You must use the Subsystem Management window to rename each 
storage subsystem from <unnamed> to the name that you want. Refer to the names 
that you entered in the information record that you created using Table 13 on page 47. 
Then, refer to the topic about renaming storage subsystems in the Subsystem 
Management online Help. The Help topic provides detailed instructions for renaming 
storage subsystems.

Performing other storage-subsystem management tasks
You can perform the following storage-subsystem management tasks:

• Downloading controller firmware

• Downloading controller NVSRAM

• Locating a storage subsystem

• Viewing a storage subsystem profile

• Typing or changing a storage subsystem password

• Creating and managing logical drives and arrays

• Using the Performance Monitor

• Creating storage partitions (if applicable)

Note: To create storage partitions, you must obtain the worldwide name or port name 
of each host adapter in each host that is connected to the storage subsystem.

For more information about these and other storage-subsystem management tasks, 
refer to the appropriate topics in the Subsystem Management online Help.

Continue with “Modifying configuration settings in NVSRAM” on page 39.
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Modifying configuration settings in NVSRAM
Run the NVSRAM configuration scripts to configure the storage subsystem for use 
with NetWare hosts in a standard noncluster environment. Use the following 
procedure to apply these scripts:

1. Insert the IBM FAStT Storage Manager installation CD into the CD-ROM drive.

2. From the Xserver Graphical Console, type:

load cdrom

3. Mount the CD volume.

4. From the Xserver Graphical Console, click Novell → Netfinity Fibre Channel 
Storage Manager 7.

5. From the Confirm Initial Automatic Discovery window, click Yes.

If you click No, you can still add devices manually using the Edit → Add Device 
option.

The storage subsystems that are at firmware level 4.x are automatically 
discovered.

6. In the right pane of the Netfinity Fibre Channel Storage Manager 7 (Enterprise 
Management) window, right-click on a storage subsystem, and click Execute 
Script from the menu.

The Script Editor window opens.

7. From the Script Editor window menu, click File → Load Script.

If you are prompted to save changes to newscript.scr, click No.

8. From the Load Script window, select the <CD-ROM volume>  
\Netware51\scripts\Netware5.scr file and select Open.

9. From the Script Editor window menu, click Tools → Verify and Execute.

The message:

Script execution complete

is displayed in the lower pane of the Script Editor window.

10. From the Script Editor window, click File → Load Script.

If you are prompted to save changes to newscript.scr, click No.

11. From the Load Script window, select the <CD-ROM volume> 
\Netware51\scripts\NW_mpio.scr file and then, select Open.

12. From the Script Editor window, select Tools → Verify and Execute.

Script execution complete

will be displayed in the lower pane of the Script Editor window.

13. Restart the controller for changes to take effect.
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Chapter 5.  Operating system support

This chapter contains information about operating the storage-management software 
with Novell NetWare.

Novell NetWare limitations
Important: Always check for a README file on any installation media. This README 
file might contain important information that was not available when this Installation 
and Support Guide was prepared.

Table 12 explains the limitations that apply when you use the FAStT Storage Manager 
Version 7.02 with Novell NetWare.

Table 12. Novell NetWare limitations and workarounds. 

Limitation Workaround

Clicking a vertical scroll arrow (either up or 
down) causes the scroll box to move all the 
way to the opposite end of the scroll bar.

This is a known defect in the Java Runtime 
Environment.

Click the scroll box and slide it until you reach 
the desired position in the Help window.

Logical drive migration (removing a set of 
drives that are configured with logical drives 
from one storage subsystem to insert in 
another storage subsystem) is not supported 
because it could cause loss of configuration.

Call for service.

If you manage storage subsystems through 
the host-agent software and use the storage-
management software to download controller 
firmware, the download process can take up 
to 10 minutes to complete.

None.

If you configure a new storage subsystem 
with a single controller, you must place the 
controller in slot A. The controller firmware 
cannot recognize or communicate with a 
single controller until slot A is populated. This 
restriction does not apply to storage 
subsystems that were originally configured 
with two controllers.

None.

A public loop configuration (managed hubs 
that are attached to switches) is not 
supported.

None.

If you remove a fan or power supply customer 
replaceable unit (CRU) from a storage 
subsystem while the system is running, the 
storage-management software does not 
report an error message, and the component 
is not reported as missing.

Note: Fan and power-supply CRU failures 
are reported.

Replace the missing fan or power-supply 
CRUs immediately to ensure redundancy. 
Make sure that the fan or power-supply CRU 
is properly seated in the controller unit.
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Number of supported logical drives
The supported logical drive limits are as follows:

• When using Novell Storage Management Services (SMS) you can configure up to 
256 LUNs, or the maximum available for the model of the host adapter that you 
have in your system.

• Host adapters support a maximum number of logical drives. Refer to the host-
adapter documentation for specific information.

• The host-agent management method uses a special logical drive, called an 
access volume, to communicate with the controllers on the storage subsystem. 
The access volume uses one of the allowable logical drives. Therefore, managing 
storage subsystems with the host-agent software limits you to one fewer LUN 
than the maximum number that is supported by Novell NetWare and the host 
adapter.

Creating logical drives
A logical drive is a logical object that is the basic structure that you create to store 
data on the storage subsystem. A logical drive is configured for an array with a 
specific RAID level to meet application needs for data availability and Fibre Channel 
I/O performance. A logical drive is recognized by the operating system as one drive. 

You can add or delete logical drives in a standard configuration.

When you create new logical drives with the storage-management software, you must 
add the new logical drives to Novell NetWare. Refer to the Novell NetWare 
documentation for details about adding a drive. Remember that each logical drive (not 
array) is recognized by Novell NetWare as one drive. After creating logical drives, run 
the Hot Add and SM7devices utilities that are provided with the storage-management 
software. The Hot Add utility adds newly created logical drives to the operating 
system, and the SM7devices utility identifies logical drives by their associated 
operating system device names. For information about using these utilities, see 
“Using the Hot Add utility” on page 45 and “Using the SM7devices utility” on page 45.

Before either deleting logical drives with the storage-management software or using 
Configure → Reset Configuration, stop all input and output activity to the affected 
storage subsystem. Then dismount any NetWare volumes that are associated with 
the logical drives.
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Installing QLogic Management Suite Java 
The QLogic Management Suite Java (QMSJ) software includes the QLogic GUI 
device driver that is required for failover support. You can use the GUI to configure 
LUNs, storage, and failover.

Note: For additional information, refer to the online Help.

Perform the following steps to install QLogic Management Suite Java:

1. Insert the IBM FAStT Storage Manager installation CD into the CD-ROM Drive.

2. Map a drive to the SYS volume of the NetWare server.

3. Select the Netware51\qlremote directory.

4. Click install.exe.

The Introduction window opens.

5. Click Next.

The Important Information window opens. Read the QMSJ application notes. 

6. Click Next.

The Choose Install Folder window opens.

7. Click Next.

The Choose Install Set window opens. 

8. To install the QMSJ Java GUI only, select QMSJ GUI.

9. To install the QMSJ Novell NetWare 5.x Agent, select QMSJ Novell NetWare 5.

10. To install the Java GUI and Novell NetWare Agent, click Customize.

11. Click Next.

If you choose to select customize, the Customize Install window opens.

12. Set the Current Install Sets to Custom Set.

13. Select QMSJ GUI, QMSJ Novell NetWare 5.x Agent, and Help check boxes.

14. Click Install.

The Novell NetWare Disk Selection window opens.

15. Select or type the drive letter that is mapped to the SYS volume of your NetWare 
server.

The Install Complete window opens.

16. Click Done.

17. Restart your NetWare server to start the QMSJ agent.

Configuration example for QLogic Management Suite Java
Refer to the following example when configuring device and LUN mapping.

1. Open QLogic Management Suite Java. The Host Bus Adapter View window 
opens.

2. Click Connect.

The Connect to Host window opens.

3. Type the host name or IP address.

Note: If a connection is not established by typing the host name, an entry in the 
host file or DNS table is required. 

4. Click Configure.
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The Fibre Channel Port Configuration window opens.

5. Click Tools g Auto Configure.

6. Click Tools g Load Balance g All LUNs.

7. Right click on Device Node Name.

The device Information and Configure LUN mask options display.

8. Select Configure LUN Mask.

Note: The default configuration maps all LUNs to the first FAStT host adapter. 
You can use the Fibre Channel Port Configuration window to configure 
your host bus adapter for failover and load balancing. 

The Fibre Channel LUN Configuration window opens. You can configure your 
preferred paths, alternate paths, and make changes to the LUN configuration 
from the Fibre Channel LUN Configuration window.

 

9. Click on any path and the available configuration options display. For specific 
configuration information, refer to the online Help.
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Note: Your LUNs might need to have their preferred paths changed to match the 
configuration of the FAStT storage subsystem.

10. Click OK.

The Fibre Channel Port Configuration window opens.

11. The configuration is complete. Click Apply.

The Security Check window opens.

12. Click OK.

The Apply Configuration window opens.

13. Click OK.

Using the Hot Add utility
The host-agent software includes a utility called Hot Add that you can use to add new 
logical drives dynamically without restarting the system. The utility registers the new 
logical drives with the operating system so that you can use Disk Administrator to 
create partitions, add device names, and so on. The Hot Add utility is installed as part 
of the host-agent package.

After you finish creating the logical drives on a particular storage subsystem, go to the 
host that is attached to that storage subsystem and perform the following steps to use 
the Hot Add utility:

1. From the Xserver Graphical Console, type:

hot_add

2. Press Enter.

The new logical drives are available through the Disk Administrator.

Using the SM7devices utility
The SM7agent software includes a utility called SM7devices that you can use to view 
the storage subsystem logical drive that is associated with a particular operating 
system device name. This capability is helpful when you want to create drives, 
volumes, or a combination of both for the logical drive using nwconfig.

After you finish creating the logical drives on a particular storage subsystem, go to the 
host that is attached to that storage subsystem and perform the following steps to use 
SM7devices:

1. From the Server Console type:

SM7devices

2. Press Enter.

The software displays device identification information. For example, you might 
see:

V596-A3-D0:0[Storage Subsystem MARKETING, Logical Drive DEBIT, LUN 0, 
WWN <600a0b800007545c0000008d3a308b6e>] 

V596-A3-D0:1 [Storage Subsystem MARKETING, Logical Drive DEBIT, LUN 1, 
WWN <600a0b80000756ec000000a93a307d2a>]

V596-A3-D0:1F [Storage Subsystem MARKETING, Logical Drive Access volume, 
LUN 31, WWN <600a0b800007545c0000009000000000>]

Where V596-A3-D0:0;
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The numbers at the beginning of each line comprise the device name. The device 
name identifies the adapter or device as follows:

Vendor number [V596]. A unique number specific to the device vendor.

Adapter number [A3]. The instance number of an adapter registered with 
NWPA. In the example, A3 identifies the first instance of an adapter 
installed in the server.

Device number [D0]. The number of the disk or other device.

Logical unit number [0,1,1F]. The LUN identifies individual devices when 
more than one device is attached to one bus.

Storage Subsystem x = the storage subsystem name

Logical Drive x = the logical drive name

LUN x = the logical unit number associated with the logical drive

WWN x = the worldwide name for the logical drive

Uninstalling storage-management software components
Use the following procedure if you need to uninstall one or more of the components of 
Storage Manager 7.02.

1. From the Xserver Graphical Console, click Novell → Install.

The Add/Remove Programs Properties window opens.

2. From the list of programs, select the component that you want to uninstall.

For example, select Fibre Channel Storage Manager 7 Client.

3. Click Add/Remove.

The Confirm File Deletion window opens.

4. Click Yes to start the uninstallation process.

5. When the uninstallation is completed, click OK.
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Appendix A.   Storage subsystem/controller information record

Table 13 provides a data sheet on which you can record storage subsystem names, 
management types, hardware Ethernet addresses, and IP addresses. Make a copy of 
this table and complete the information for your storage subsystems and controllers. 
Use the information that is recorded in Table 13 to set up the BOOTP table for the 
network server and the host or Domain Name System (DNS) table. The information in 
Table 13 helps you add storage subsystems after initial installation. The column 
headings show a page reference for detailed instructions about obtaining the 
information. For a sample information record, see Figure 5 on page 14.

Table 13. Storage subsystem and controller information record 

Storage subsystem 
name

(see page 16)

Management type 
(see page 13)

Controllers—Ethernet and IP addresses, 
and host name

(see pages 17 and 18)

Host—IP address 
and host name
(see page 18)

Storage subsystem name:

Storage subsystem name:

Storage subsystem name:

Storage subsystem name:

Storage subsystem name:

Storage subsystem name:

Storage subsystem name:

Storage subsystem name:
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Appendix B.   Notices

This publication was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in 
other countries. Consult your local IBM representative for information on the products 
and services currently available in your area. Any reference to an IBM product, 
program, or service is not intended to state or imply that only that IBM product, 
program, or service may be used. Any functionally equivalent product, program, or 
service that does not infringe any IBM intellectual property right may be used instead. 
However, it is the user’s responsibility to evaluate and verify the operation of any non-
IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter 
described in this document. The furnishing of this document does not give you any 
license to these patents. You can send license inquiries, in writing, to: 

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY  10504-1785
U.S.A.

The following paragraph does not apply to the United Kingdom or any country 
where such provisions are inconsistent with local law: INTERNATIONAL 
BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS" 
WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, 
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-
INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR 
PURPOSE. Some states do not allow disclaimer of express or implied warranties in 
certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. 
Changes are periodically made to the information herein; these changes will be 
incorporated in new editions of the publication. IBM may make improvements and/or 
changes in the product(s) and/or the program(s) described in this publication at any 
time without notice.

Any references in this publication to non-IBM Web sites are provided for convenience 
only and do not in any manner serve as an endorsement of those Web sites. The 
materials at those Web sites are not part of the materials for this IBM product, and use 
of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes 
appropriate without incurring any obligation to you.

Some software may differ from its retail version (if available), and may not include user 
manuals or all program functionality.

Edition notice
© COPYRIGHT INTERNATIONAL BUSINESS MACHINES CORPORATION, 2001.  
All rights reserved.  

Note to U.S. Government Users — Documentation related to restricted rights — Use, 
duplication or disclosure is subject to restrictions set forth in GSA ADP Schedule 
Contract with IBM Corp.
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Processing date data
This IBM hardware product and IBM software products that might be packaged with it 
have been designed, when used in accordance with their associated documentation, 
to process date data correctly within and between the 20th and 21st centuries, 
provided all other products (for example, software, hardware, and firmware) used with 
these products properly exchange accurate date data with them.

IBM cannot take responsibility for the date data processing capabilities of non-IBM 
products, even if those products are preinstalled or otherwise distributed by IBM. You 
should contact the vendors responsible for those products directly to determine the 
capabilities of their products and update them if needed. This IBM hardware product 
cannot prevent errors that might occur if software, upgrades, or peripheral devices you 
use or exchange data with do not process date data correctly. 

The foregoing is a Year 2000 Readiness Disclosure.

Trademarks

The following terms are trademarks of the IBM Corporation in the United States, other 
countries, or both:

IBM

Netfinity

Intel, and Pentium are trademarks or registered trademarks of Intel Corporation in the 
United States, other countries, or both.

Microsoft, Windows, and Windows NT are trademarks or registered trademarks of 
Microsoft Corporation.

UNIX is a registered trademark of The Open Group in the United States and other 
countries.

Java and all Java-based trademarks and logos are trademarks or registered 
trademarks of Sun Microsystems, Inc. in the United States, other countries, or both.

Other company, product, and service names may be trademarks or service marks of 
others.
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