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About this book

This book provides information about setting up, installing, configuring, and working 
with IBM® Fibre Array Storage Technology (FAStT) Storage Manager Version 7.10 in  
Novell NetWare and Red Hat Linux operating-system environments. This Installation 
and Support Guide is for system administrators. Use this guide to:

• Determine the hardware and software that are required to install the storage-
management software.

• Integrate the necessary hardware components into your network.

• Install the storage-management software.

• Upgrade controller firmware, if necessary.

• Identify storage-management features that are unique to your specific installation.

How this book is organized
Chapter 1, “Introduction,” on page 1 provides an overview of IBM FAStT Storage 
Manager Version 7.10 and describes storage-subsystem management methods, 
configuration types, types of installations, and installation requirements.

Chapter 2, “Preparing for installation,” on page 17 discusses preparing for a network 
installation including setting up a Microsoft® DHCP server, UNIX® BOOTP server, or a 
NetWare server, and describes other setup tasks.

Chapter 3, “Installing software in standard and cluster configurations (Novell 
NetWare),” on page 33 gives the procedure for installing the software in a standard 
and noncluster server environments.

Chapter 4, “Completing the installation (Novell NetWare),” on page 39 discusses 
starting the Enterprise Management window, applying NVSRAM configuration scripts, 
adding devices, and subsystem management tasks.

Chapter 5, “Novell NetWare operating system support,” on page 49 discusses Novell 
NetWare operating system limitations.

Chapter 6, “Installing software in a standard configuration (Red Hat Linux),” on page 
55 gives the procedure for installing the software in a standard (noncluster) 
environment.

Chapter 7, “Completing the software installation (Red Hat Linux),” on page 59 
discusses starting the Enterprise Management window, applying NVSRAM 
configuration scripts, adding devices, and subsystem management tasks.

Chapter 8, “Red Hat Linux operating-system support,” on page 67 discusses Red Hat 
Linux operating system limitations.

Appendix A, “Storage subsystem/controller information record,” on page 71 provides a 
data sheet template that you can use to create a controller information record.

Appendix B, “Getting information, help, and service,” on page 73 provides information 
about how to obtain help, service, or technical assistance.

Appendix C, “Notices,” on page 77 provides product notices and trademark 
information.
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Notices used in this book
This book contains notices to highlight information as follows:

• Notes

These notices provide important tips, guidance, or advice.

• Important

These notices provide information that might help you avoid inconvenient or 
problem situations.

• Attention

These notices indicate possible damage to programs, devices, or data. An 
attention notice is placed just before the instruction or situation in which damage 
could occur.

Related publications
The following publications are available in Adobe Acrobat Portable Document Format 
(PDF) on the IBM FAStT Storage Manager CD and http://www.ibm.com/pc/support/ 
IBM Web page.

• IBM FAStT Storage Manager Version 7.10 for Novell NetWare and Red Hat Linux 
Installation and Support Guide (this book)

• IBM FAStT Storage Manager Version 7.10 for Microsoft® Windows NT® and 
Windows® 2000 Installation and Support Guide

• IBM FAStT Host Adapter Installation and User’s Guide

• IBM FAStT200 and FAStT200 HA Storage Servers Installation and User’s Guide1

• IBM Netfinity FAStT500 RAID Controller Enclosure Unit Installation Guide

• IBM Netfinity FAStT500 RAID Controller Enclosure Unit User’s Reference

• IBM FAStT Storage Manager Concepts Guide

• IBM FAStT MSJ User’s Guide

• IBM Netfinity Fibre Channel RAID Controller Unit User’s Handbook

1. Printed publications that are shipped with the IBM FAStT200 and FAStT200 High Availability (HA) Storage Servers.
 xii IBM® FAStT Storage Manager Version 7.10 for Novell NetWare and Red Hat Linux: Installation and Support Guide



Chapter 1.  Introduction

This installation and support guide provides information on preparing, installing, 
configuring, and starting the IBM FAStT Storage Manager Version 7.10 in the Novell 
NetWare and Red Hat Linux operating-system environments. Before you begin the 
installation of this product, consult the following documentation:

• README.TXT file - Read this text file first. The README file is located in the root 
directory of the installation CD, or refer to the http://www.ibm.com/pc/support IBM 
Web page for the latest installation and user information about the storage-
management software and hardware components.

• IBM FAStT Storage Manager Concepts Guide - Use this reference document to 
become familiar with terminology and features of the IBM FAStT Storage Manager 
Version 7.10 software. This book is located on the installation CD, or from the 
http://www.ibm.com/pc/support IBM Web page.

When you finish the entire installation process, refer to the following online Help 
systems, which contain information common to all operating system environments. 
For installation information specific to Novell NetWare or Red Hat Linux, refer to this 
book.

• You can access the help systems from the Enterprise Management and 
Subsystem Management windows in IBM FAStT Storage Manager Version 7.10. 
Click Help on the toolbar, or press F1.

• Enterprise Management window Help - Use this online Help system to learn more 
about working with the entire management domain.

• Subsystem Management window Help - Use this online Help system to learn 
more about managing individual storage subsystems.

IBM FAStT Storage Manager Version 7.10 for Novell NetWare and Red Hat Linux are 
Java™-based tools that simplify the management of the IBM Fibre Array Storage 
Technology (FAStT)200 and FAStT200 HA Storage Servers, Netfinity FAStT500 RAID 
Controller Enclosure Unit, and Netfinity Fibre Channel RAID Controller Unit. Previous 
versions of IBM FAStT Storage Manager Version 7.10 were known as Netfinity Fibre 
Channel Storage Manager 7.

The FAStT Storage Manager Version 7.10 software presents an interface for storage 
management that is based on information that is supplied by the storage subsystem 
controllers. You can install the storage-management software on a management 
station, which is the system that is responsible for managing all, or a portion of, a 
network. The management station communicates with network management agents 
that reside in the managed node by means of a network management protocol, such 
as Simple Network Management Protocol (SNMP). When you manage a storage 
subsystem that uses the client software that is installed on a management station, 
commands are sent to the storage subsystem controllers. The controller firmware 
contains the necessary information to carry out the storage-management commands. 
The controller is responsible for validating and running the commands and providing 
status and configuration information back to the client software.

Throughout this book, the terms storage-management software and Storage Manager 
7.10 refer to the IBM FAStT Storage Manager Version 7.10 for Novell NetWare and 
Red Hat Linux software. Individual components of the storage-management software 
are identified by name.
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Terms to know
If you are upgrading from a previous version of the IBM FAStT Storage Manager 
software, you might find that some of the terms you are familiar with have changed. It 
is important that you familiarize yourself with the new terminology. Table 1 provides a 
list of machine type and supported storage-management software. Table 2 provides a 
list of some of the old and new terms. For more information, refer to the IBM FAStT 
Storage Manager Concepts Guide.

Note: Product firmware must be at version 04.xx to be compatible with Storage 
Manager Version 7.10. 

It is important to understand the distinction between the following two terms when 
reading this document:

Management station
A management station is a system that is used to manage the storage 
subsystem. This system does not need to be attached to the storage 
subsystem through the Fibre Channel I/O path.

Host and host computer
The terms host and host computer are used interchangeably throughout this 
book. Both terms refer to a system that is directly attached to the storage 
subsystem through a Fibre Channel I/O path. This system is used to serve 
data (typically in the form of files) from the storage subsystem.

Note: A system can be both a management station and a host computer at the same 
time.

Table 1. Machine type and supported storage-management software. 

Product name Machine 
type Model

Product 
release 

and 
firmware 
version

Supported 
storage-

management 
software 
version

IBM FAStT200 3542 1RU 4.x 7.02, 7.10

IBM FAStT200 HA 3542 2RU 4.x 7.02, 7.10

Netfinity Fibre Channel RAID Controller 
Unit

3526 1RU 3.x, 4.x 6.22, 7.0, 7.01, 
7.02, 7.10

Netfinity FAStT500 RAID Controller 
Enclosure Unit

3552 1RU 4.x 7.0, 7.01, 7.02, 
7.10

Table 2. Old and new terminology. 

Term used in previous versions New term

RAID module Storage subsystem

Drive group Array

Logical unit number (LUN)1 Logical drive

1 In Storage Manager 7.10, the term logical unit number (LUN) refers to a logical address that 
is used by the host to access a particular logical drive.
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Software packages
Storage Manager 7.10 contains the following software packages for a Novell NetWare 
environment:

• Storage Manager 7 client software (SM7client)

• Storage Manager 7 agent (SM7agent)

• Storage Manager 7 Utility package (SM7util)

• IBM Storage Area Network (IBMSAN) driver

• IBM Host Adapter (HA) device driver (QL2x00)1

• IBM FAStT Management Suite Java (FAStT MSJagent)2

Storage Manager 7.10 contains the following software packages for a Red Hat Linux 
environment:

• Storage Manager 7 client software (SM7client)

• IBM FAStT Management Suite Java (FAStT MSJ)3

• IBM Host Adapter (HA) device driver (QLa2x00)4

Storage Manager 7 client software package
The Storage Manager 7.10 client (SM7client) component provides the graphical user 
interface (GUI) for managing storage subsystems through the Ethernet network or 
from the host. The SM7client contains two main components:

• Enterprise Management. You can use the Enterprise Management component 
for adding, removing, and monitoring storage subsystems within the management 
domain.

• Subsystem Management. You can use the Subsystem Management component 
for managing the components of an individual storage subsystem.

Storage Manager 7 agent software package
The Storage Manager 7.10 agent (SM7agent) package contains the host-agent 
software. You can use the host-agent software to manage storage subsystems 
through the host Fibre Channel connection. The host-agent software takes requests 
from a management station that is connected to the host through a network 
connection and passes the requests to the storage subsystem controllers through the 
Fibre Channel I/O path. For more information about managing storage subsystems 
through the host agent, see “Host-agent (in-band) management method” on page 4.

Storage Manager 7 Utility software package
Use the Storage Manager 7 Utility (SM7util) software package to register and map 
new logical drives to the operating system. The Storage Manager 7 Utility is installed 
on all host computers running a Novell NetWare operating system. The host 
computers are attached to the storage subsystem through the Fibre Channel 

1. The IBM HA driver is not included on the IBM FAStT Storage Manager installation CD. Refer to the IBM FAStT Host Adapter 
Installation and User’s Guide or refer to the http://www.ibm.com/pc/support/ IBM Web page.

2. Refer to the IBM FAStT MSJ User’s Guide for installation instructions.

3. This software package can be installed on a management station and a host. Refer to the IBM FAStT MSJ User’s Guide for 
installation instructions.

4. The IBM HA driver is not included on the IBM FAStT Storage Manager installation CD. Refer to the IBM FAStT Host Adapter 
Installation and User’s Guide or refer to the IBM Web page at http://www.ibm.com/pc/support/.
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connection. The Storage Manager 7 Utility software package contains the following 
two components:

• Hot Add utility. The Hot Add utility enables you to register newly created logical 
drives with the operating system. For information on using the Hot Add utility, see 
“Using the Hot Add utility” on page 51 in a Novell NetWare environment.

• SM7devices utility. You can use the SM7devices utility to associate storage 
subsystem logical drives with operating system device names. For more 
information about using SM7devices, see “Using the Storage Manager 7 devices 
utility” on page 52 for a Novell NetWare environment.

IBMSAN driver
The IBM Storage Area Network (IBMSAN) driver is used in a Novell NetWare  
environment to provide multipath I/O support to the storage controller. The IBMSAN 
driver is a custom device module (CDM) that is installed with the IBM FAStT Host 
Adapter device driver. In case of a failure along the I/O path, the driver will send the 
I/O requests through the alternate path and Auto-Volume Transfer (AVT) will move the 
logical drive within the FAStT Storage Server.

IBM FAStT Host Adapter (HA) device driver
The IBM FAStT Host Adapter device drivers, (QL2x00 for NetWare and QLa2X00 for 
Red Hat Linux) will enable your operating system to communicate with the host 
adapter. The IBM FAStT Host Adapter is a high-performance, direct memory access 
(DMA), bus-master, host adapter designed for high-end systems. The IBM FAStT 
Host Adapter supports all Fibre Channel (FC) peripheral devices that support private-
loop direct attach (PLDA) and fabric-loop attach (FLA). Refer to the IBM FAStT Host 
Adapter Installation and User’s Guide and the http://www.ibm.com/pc/support IBM 
Web page for the current README file and latest multipath I/O device drivers.

IBM FAStT Management Suite Java
The IBM FAStT Management Suite Java (FAStT MSJ) is part of the IBM FAStT 
Storage Manager software package. It provides multipath I/O device drivers for Linux. 
Based on a driver which resides on top of the hardware driver, the IBM FAStT 
Management Suite Java can be configured with a preferred and an alternate path for 
every logical drive. In case of a failure along the I/O path, the driver will send the I/O 
requests through the alternate path and Auto-Volume Transfer (AVT) will move the 
logical drive within the FAStT Storage Server. The IBM FAStT Management Suite 
Java agent (FAStT MSJagent) is installed on the NetWare system, which then can be 
configured from a management station running the IBM FAStT Management Suite 
Java.

Refer to the IBM FAStT MSJ User’s Guide for the diagnostics installation procedure 
for Linux and NetWare.

Storage subsystem management methods
The storage-management software provides two methods for managing storage 
subsystems: the host-agent (in-band) management method and the direct (out-of-
band) management method. Depending on your specific storage subsystem 
configurations, you can use either or both methods.

Host-agent (in-band) management method
When you use the host-agent (in-band) management method, you manage the 
storage subsystems through the Fibre Channel I/O path to the host. The management 
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information can be processed in the host or passed to the management station 
through the network connection. See Figure 1 on page 6.

Note: The host-agent (in-band) management method is not applicable if you are 
using a Linux platform.

Managing storage subsystems using the host-agent management method has the 
following advantages:

• You do not have to run Ethernet cables to the controllers.

• You do not need a Dynamic Host Configuration Protocol (DHCP) BOOTP server 
to connect the storage subsystems to the network.

• You do not need to perform the controller network configuration tasks that are 
described in Chapter 2, “Preparing for installation,” on page 17.

• When adding devices, you only have to specify a host name or IP address only 
for the host instead of for the individual controllers in a storage subsystem. 
Storage subsystems that are attached to the host are automatically discovered.

Managing storage subsystems using the host-agent management method has the 
following disadvantages: 

• You are limited to configuring one fewer logical unit number (LUN) than the 
maximum number that is allowed by the operating system and the host adapter 
that you are using.

• The host agent requires a special logical drive, called an access volume, to 
communicate with the controllers in the storage subsystem.

• If you are upgrading controllers from firmware version 3.x to version 4.x and your 
host system has already configured its maximum number of LUNs, you must give 
up a LUN to be used as an access volume.

Important: The access volume uses one of the logical unit numbers (LUNs). The 
Novell NetWare operating system will allow a maximum number of LUNs, depending 
on which Support Pack is installed and which host adapter you are using. If your host 
already has the maximum number of LUNs configured, either use the direct 
management method or give up a LUN for use as the access volume. For information 
on your specific configuration, see “Operating system requirements” on page 16. 
Contact an IBM technical-support representative for additional assistance.
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Figure 1. Host-agent (in-band) managed storage subsystems

Direct (out-of-band) management method
When you use the direct (out-of-band) management method, you manage storage 
subsystems directly over the network through the Ethernet connection to each 
controller. To manage the storage subsystem through the Ethernet connections, you 
must define the IP address and host name for each controller and attach a cable to 
the Ethernet connectors on each of the storage subsystem controllers. See Figure 2 
on page 7.

Note: The direct (out-of-band) management method is applicable if you are running 
Novell NetWare or Red Hat Linux operating systems.

Managing storage subsystems using the direct (out-of-band) management method 
has the following advantages:

• The Ethernet connections to the controllers enable a management station running 
SM7client to manage storage subsystems that are connected to a host running 
Novell NetWare, Linux, or other operating systems that are supported by Storage 
Manager 7.10.

• You do not need to use an access volume to communicate with the controllers as 
you do if you are running the host-agent software. You can configure the 
maximum number of LUNs that are supported by the operating system and the 
host adapter that you are using.

Managing storage subsystems using the direct (out-of-band) management method 
has the following disadvantages:

• It requires two Ethernet cables to connect both storage subsystem controllers to a 
network.

Network

Host computer

Controller

Controller

Controller

Controller

Fibre Channel
I/O path

Management station
(one or more)

Running the
host-agent software

Storage subsystems

Note: The host can act as a
management station also.

Storage subsystems
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• When adding devices, you must specify an IP address or host name for each 
controller.

• A DHCP BOOTP server and network preparation tasks are required. For a 
summary of the preparation tasks, see Table 10 on page 19.

Figure 2 shows a system in which storage subsystems are managed directly.

Figure 2. Direct (out-of-band) managed storage subsystems

Installation types
To install Storage Manager 7.10, choose the installation type in the following list that 
represents the setup of your enterprise.

• New storage subsystem environment. You do not have existing storage 
subsystems. In this case, you are installing new storage subsystems with 
machine type 3526, 3542, or 3552 controllers using firmware version 04.01.xx 
and intend to manage these new storage subsystems using Storage Manager 
7.10. To proceed with this installation, go to “Configuration types” on page 9.

• Existing storage subsystem environment. You have existing storage 
subsystems. Table 3 on page 8 explains your options for managing these existing 
storage subsystems.

Ethernet

Host computer

Fibre Channel
I/O path

Management station
(one or more)

Controller

Controller

Controller

Controller

Storage subsystems

Storage subsystems
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Managing new and existing storage subsystems attached to the same 
host

When installing Storage Manager 7.10, you must determine how you will use any 
existing storage subsystems. Existing storage subsystems are coexisting storage 
subsystems when they are attached to the same host as storage subsystems 
managed with Storage Manager 7.10, and when the conditions in Table 4 are met.

Figure 3 on page 9 shows an example of an environment that includes coexisting 
storage subsystems.

Table 3. Configurations for existing storage subsystems. 

Existing storage 
subsystems with: Options

Machine type 3526 
controllers running firmware 
version 3.x

Option 1 —Upgrade the controller firmware to version 
04.01.xx and manage the storage subsystems with Storage 
Manager 7.10. Refer to the http://www.ibm.com/pc/support 
IBM Web page for the Migrate utility in the README file; then, 
go to “Configuration types” on page 9. 

Option 2 —Install new storage subsystems and attach them 
to the same host as the existing storage subsystems. These 
existing and new storage subsystems are referred to as 
coexisting storage subsystems. See “Managing new and 
existing storage subsystems attached to the same host” for 
more information.

Option 3 —Continue to use version 6.22 of the storage-
management software to manage these storage subsystems, 
if they are attached to separate hosts from those that are 
attached to storage subsystems managed with Storage 
Manager 7.10.

Table 4. Coexisting storage subsystems requirements. 

Existing storage subsystems New or upgraded storage 
subsystems

• Use 3.01.x firmware

• Are managed with version 6.22 of the storage-
management software

Note: Firmware and software levels are the 
minimum levels required for machine type 
3526 controllers to coexist with new or 
upgraded storage subsystems.

• Use 04.01.xx firmware

• Are managed with Storage 
Manager 7.10
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Figure 3. Sample coexistence installation

Configuration types
You can install Storage Manager 7.10 in one of two configurations:

• Standard (noncluster) configuration. See “Standard (noncluster) configuration”.

• Cluster server configuration. See “Cluster server configuration” on page 11.

Standard (noncluster) configuration
Table 5 on page 10 describes where the storage-management software components 
are installed in a standard (noncluster) configuration. Figure 4 on page 11 shows a 
sample standard (noncluster) configuration.

Ethernet

Host computer

Controller

Controller

Controller

Controller

Fibre Channel
I/O path

Management station
(one or more)

Management station
(one or more)

Host-agent

Client software
Storage subsystems

Firmware version
3.01.x (minimum)

Firmware version 4.x

Version 7.10 of the
storage-management client
software must be installed on either
a management station or host.

Storage subsystems
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Table 5. Where to install software components in a standard (noncluster) configuration. 

Software 
component Where installed Notes

Storage Manager 
7.10 client 
(SM7client)

Install the client 
package on either of 
the following:

• Linux and NetWare 
Management 
station (for direct or 
host-agent 
management)

• Linux and NetWare 
Host computer (for 
direct or host-agent 
management)

Note: NetWare 
supports host-
agent and 
direct 
management. 
Linux supports 
direct 
management 
only.

• Management stations 
If you install the SM7client software on 
one or more management stations, you 
can choose to manage storage 
subsystems directly through Ethernet 
connections to the controllers, over the 
network to the host computer through 
the host agent, or a combination of both 
methods.

• Host computer in a direct-managed 
controller configuration
If you choose to manage storage 
subsystems directly through Ethernet 
connections to the controllers over the 
network, you install the SM7client 
software on the host computer, the host 
computer does not need to be 
connected to a network as long as the 
host-agent software is installed. The 
host computer must have the TCP/IP 
software installed and you must assign 
a static IP address to the host.

• Host computer in a host-agent 
managed controller configuration
If you install the SM7client software in 
an alternative, non-network controller 
configuration, you can manage the 
storage subsystems that are connected 
to the host computer through the Fibre 
Channel I/O path.

Note: You must assign an IP address for 
host agent and direct management.

Storage Manager 
7.10 Agent 
(SM7agent)

NetWare host Install the SM7agent software to manage 
storage subsystems with the host computer 
running NetWare through the Fibre Channel 
connections.

Storage Manager 
7.10 Utility
(SM7util)

NetWare host The Storage Manager 7 Utility software 
contains two important components, the Hot 
Add and Storage Manager 7 devices utility.

IBM FAStT 
Management Suite 
Java (FAStT MSJ) 

Linux host and 
management station

NetWare management 
station

The IBM FAStT Management Suite Java is a 
required component for managing the 
multipath driver. Refer to the IBM FAStT 
MSJ User’s Guide for more information.

IBM FAStT Host 
Adapter (HA) device 
driver

Linux host

NetWare host

Refer to the IBM FAStT Host Adapter 
Installation and User’s Guide.

IBMSAN driver NetWare host Provides automatic Fibre Channel multipath 
capability to storage subsystems for 
NetWare.
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The following figure shows an example of a standard (noncluster) configuration.

Figure 4. Sample standard (noncluster) configuration

Cluster server configuration
The following table describes the storage-management software components that are 
installed in a cluster server environment if you are running a Novell NetWare 
operating system. See Figure 5 on page 13 for a sample cluster configuration.

Important: Be sure to install all storage-management software components on each 
server in your cluster.

IBM FAStT 
Management Suite 
Java agent 
(QLRemote)

Linux host
NetWare host

Provides the interface between the FAStT 
MSJ application and host operating system. 
Refer to the IBM FAStT MSJ User’s Guide 
for more information.

Table 5. Where to install software components in a standard (noncluster) configuration. 

Software 
component Where installed Notes

Ethernet

Host computer

Controller

Controller

Controller

Controller

Fibre Channel
I/O path

Management station
FAStT MSJ (NetWare and Linux)

FAStT MSJ, FAStT HA
device driver,
SM7util, and host-agent
IBM SAN driver (NetWare)

The client software is
installed on one or more

management stations,
or on the host computer.

Storage subsystems

Storage subsystems
 Chapter 1.  Introduction  11



 

Table 6. Where to install software components in a cluster configuration (Novell NetWare). 

Software component Where installed Notes

Storage Manager 7.10 
client (SM7client)

Install the SM7client 
package on either of 
the following:

• Management 
station 
(for direct or host-
agent 
management)

• Nodes 01 and 02 
(for direct or host-
agent 
management)

• Management stations 
When you install the SM7client 
software on one or more management 
stations, you can choose to manage 
storage subsystems directly through 
Ethernet connections to the 
controllers, over the network to the 
host computer through the host agent, 
or a combination of both management 
methods.

• Nodes 01 and 02
When you install the SM7client on the 
cluster servers (nodes 01 and 02), the 
server does not need to be connected 
to a network as long as the host-agent 
software is installed. However, the 
host computer must have the TCP/IP 
software installed, and you must 
assign a static IP address to the 
cluster server.

Storage Manager 7.10 
agent (SM7agent)

Nodes 01 and 02 Install the SM7agent software to manage 
storage subsystems with the host 
computer through the Fibre Channel 
connections. 

Storage Manager 7.10 
Utility (SM7util)

Nodes 01 and 02 The Storage Manager 7 Utility software 
package contains important utilities that 
are necessary for operating the storage-
management software.
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Figure 5 shows an example of a cluster server configuration.

Figure 5. Sample NetWare cluster server configuration

System requirements
This section provides detailed information about the hardware, software, and 
operating system requirements for Storage Manager 7.10.

Hardware requirements
Table 7 on page 14 lists the hardware that is required for installing Storage Manager 
7.10 in Novell NetWare and Red Hat Linux environments. For the latest information 
about host adapters and host adapter device drivers, see the README file on the IBM 
FAStT Storage Manager Version 7.10 installation CD or on the 
http://www.ibm.com/pc/support IBM web page.

Ethernet

Fibre Channel
I/O path

Management station
(one or more)

Cluster server
node 01

Cluster server
node 02

FAStT MSJ agent, FAStT HA device driver,
SM7util, IBM SAN driver, and SM7agent

Controller

Controller

Storage subsystems

Managed hub or
switch

The SM7client software
is installed on one or more
management stations, or
on the cluster servers.
 Chapter 1.  Introduction  13



 

Table 7. Storage Manager 7.10 hardware requirements for Novell NetWare and Red Hat Linux 
environments. 

Hardware component Requirements

A BOOTP server 
(only for directly managed 
storage subsystems)

• UNIX® BOOTP server

• Novell DNS/DHCP services for NetWare 5 or later

• Microsoft BOOTP-compatible DHCP2 server for 
Windows NT® Server 4.0 with Service Pack 5 or later

Storage subsystems 
(one or more)

Storage subsystems with controllers running firmware version 
04.01.xx.

Note: Before you begin, make sure that you read “Storage 
subsystem management methods” on page 4 for 
information on managing these storage subsystems 
when existing storage subsystems are physically 
connected to the same host that you will connect to the 
new storage subsystems.

Fibre Channel host 
adapters

The IBM FAStT Host Adapter (part number: 00N6881) has 
been tested with the storage-management software.

For information on specific host adapter requirements:

• Refer to the README file in the \redhat71\Host_Adapter 
or NetWare51\Host_Adapter directory on the installation 
CD. Refer to the README for your specific operating 
system.

• Read the documentation that comes with your host 
adapter.

• Refer to the http://www.ibm.com/pc/support IBM Web 
page 

Fibre Channel fabric 
switches (if needed for the 
desired configuration)

The following Fibre Channel fabric switches were tested with 
the storage-management software:

• IBM 8-port Fibre Channel switch 
(machine type 2109-S08)

• IBM 16-port Fibre Channel switch 
(machine type 2109-S16)

For specific Fibre Channel switch setup requirements:

• Read the documentation that comes with your switch.

• Refer to the http://www.ibm.com/products IBM Web page

Fibre Channel managed 
hub (if needed for the 
desired configuration)

The IBM Fibre Channel managed hub (machine type: 3534) 
has been tested with the storage-management software.

For specific Fibre Channel managed hub setup requirements:

• Read the documentation that comes with your managed 
hub.

• Refer to the http://www.ibm.com/products IBM Web page
 14 IBM® FAStT Storage Manager Version 7.10 for Novell NetWare and Red Hat Linux: Installation and Support Guide  



Firmware requirements
Storage Manager 7.10 operates only with controller machine types 3526, 3542, or 
3552, and firmware version 04.00.xx through 04.01.xx. If you want to manage 
controllers with Storage Manager 7.10, you must upgrade the firmware to version 
04.00 through 4.01, refer to the http://www.ibm.com/pc/support IBM Web page for 
migration instructions. You must use version 6.22 of the storage-management 
software to manage storage subsystems with controllers using firmware version 3.x.

Software requirements
Table 8 lists the disk space and administrator privilege required for installing version 
7.10 of the storage-management software in Novell NetWare and Red Hat Linux 
environments.

Management station (for 
client software)

Your management station computer will require:

• Intel® Pentium® or Pentium-equivalent microprocessor 
(133 MHz or faster)

• CD-ROM drive

• Mouse or similar pointing device

• A minimum of 180 MB system memory for Linux and a 
minimum of 60 MB for NetWare

• AGP or PCI video adapter (AGP preferred), ISA adapters 
are not supported.

• Monitor setting of 1024 x 768 pixels with 64 000 colors. 
The minimum display setting that is allowed is 800 x 600 
pixels with 256 colors.

• Hardware-based Windows® acceleration

• 60 MB of free hard disk space

• Ethernet network interface card

Note: Desktop computers that use system memory for 
video memory are not preferred for use with the 
storage-management software.

Important: Many PC-based servers are not designed to 
run graphic-intensive software. If your server has difficulty 
running the storage-management software smoothly 
without video artifacts, you might need to upgrade the 
server video adapter.

Note: The required basic system memory is based on your 
configuration.

Table 7. Storage Manager 7.10 hardware requirements for Novell NetWare and Red Hat Linux 
environments. 

Hardware component Requirements

Table 8. Installation requirements by software package. 

Package
Disk space 

requirement 
(Novell NetWare)

Disk space 
requirement 

(Red Hat Linux)

Client (SM7client) 35 MB 40 MB on /opt
80 MB on /tmp

IBMSAN driver 1 MB Not required

Host agent (SM7agent) 1 MB Not required
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Operating system requirements
For Windows management stations, install one of the following operating systems:

• Windows NT Server 4.0 with Service Pack 5 or later

• Windows NT Workstation 4.0 with Service Pack 5 or later

• Windows NT 4.0 Enterprise Edition with Service Pack 5 or later

• Windows 2000 Server

• Windows 2000 Professional

• Windows 2000 Advanced Server

Install the Novell NetWare version 5.1 operating system with Support Pack 2 or later 
on one of the hosts.

If you are running Red Hat version 7.1, kernel 2.4.x, install Linux on the management 
station and hosts.

There are limits on how many logical unit numbers (LUNs) you can use to access the 
logical drives on a single storage subsystem. Supported logical drive limits for 
Microsoft Windows, Novell NetWare, and Red Hat Linux version 7.1 are 128 
maximum with 32 LUNs per storage partition.

IBM FAStT Management Suite Java 
(FAStT MSJ)

35 MB 35 MB

Storage Manager 7 Utility (SM7util) 25 MB Not required

IBM HA device driver 1 MB 1 MB

Table 8. Installation requirements by software package. 

Package
Disk space 

requirement 
(Novell NetWare)

Disk space 
requirement 

(Red Hat Linux)
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Chapter 2.  Preparing for installation

This chapter provides information to help you plan and prepare for installing the 
storage-management software in NetWare and Linux operating-system environments.

Refer to Table 9 for the software component installation based on the operating 
system of the attached management station, host computer, or cluster server.

Deciding how to manage storage subsystems
If you have not already done so, refer to “Storage subsystem management methods” 
on page 4 for information about the following two methods for managing storage 
subsystems:

• Use the direct (out-of-band) management method to manage the storage 
subsystems through an Ethernet connection to each controller on the storage 
subsystem.

Table 9. Software component installation in Novell Netware and Red Hat Linux environments. 

Operating 
system

Required software 
installation sequence Where to install

Novell NetWare Storage Manager 7 client 
(SM7client)

One or more:

• Management stations

• Attached host computers

• Cluster servers (cluster 
configuration)

1. Storage Manager 7 agent 
package (SM7agent)

2. IBM FAStT Management 
Suite Java (FAStT 
MSJagent)

3. Storage Manager 7 Utility 
(SM7util)

4. IBM Storage Area 
Network driver (SAN)

5. IBM Host Adapter (HA) 
device driver (QL2x00)

Each attached host computer

IBM FAStT Management Suite 
Java (FAStT MSJ)

Management station (Administrative 
client)
Refer to IBM FAStT MSJ User’s Guide for 
installation instructions.

Linux Storage Manager 7 client 
(SM7client)

One or more:

• Management stations

• Attached host computers

• Cluster servers (cluster 
configuration)

1. IBM FAStT Management 
Suite Java and agent

2. IBM Host Adapter (HA) 
device driver (QLa2x00)

Each attached host computer
Refer to IBM FAStT MSJ User’s Guide for 
installation instructions.
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• Use the host-agent (in-band) management method to manage the storage 
subsystems through host-agent software installed on the host computer that is 
connected to the storage subsystem.

In a Linux environment, you can use only the direct (out-of-band) management 
method. You can use either or both methods in a NetWare environment. However, 
because many of the preparation tasks for installation depend on which method you 
use, decide how you want to manage the storage subsystems on your network before 
you begin.

Reviewing a sample network
The example in Figure 6 shows a direct-managed storage subsystem network setup. 
Network A contains the following components:

• DHCP BOOTP server

• Network Management Station (NMS) for Simple Network Management Protocol 
(SNMP) traps

• Host that is connected to a storage subsystem through a Fibre Channel I/O path

• Management station connected by Ethernet cable to the storage subsystem 
controllers

Figure 6 shows an example of a host-agent managed storage subsystem network 
setup. Network B contains the following components:

• Host that is connected to a storage subsystem through a Fibre Channel I/O path

• Management station connected by Ethernet cable to the host

Figure 6. Sample network using direct and host-agent managed storage subsystems

Controller

Controller

Controller

Controller

Storage
subsystem

finance

Storage
subsystem
engineering

Fibre Channel
I/O path

Fibre Channel
I/O path

Network A
TCP/IP

Network B
TCP/IP

Ethernet

Router

Network
management

station
(for SNMP traps)

Management
station

(one or more)

Management
station

(one or more)

Host computer
Denver

(IP address
192.168.1.12)

Host computer
Atlanta

(IP address
)192.168.2.22

DHCP BOOTP server

Host name: Denver_a
(IP address )

hardware address 00.a0.b8.02.04.20
192.168.1.13

Host name: Denver_b
(IP address )

hardware address 00.a0.b8.00.00.d8
192.168.1.14

Ethernet
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Continue with “Preparing for a network installation”.

Preparing for a network installation 
Before you install the storage-management software, make sure that the network 
components are set up and operating properly, and that you have all the host and 
controller information needed for the software to operate correctly. To prepare for a 
network installation, perform the tasks summarized in Table 10. Be sure to refer to the 
appropriate procedures. Use Table 17 on page 71 to record storage subsystem and 
controller information. An example of a completed information record is shown in 
Table 11 on page 20.

Table 10. Network preparation task summary. 

Task to perform Management 
method Result For instructions, 

refer to

Step 1 - Install all 
hardware components 
(host computers, storage 
subsystems, cables, and 
so on) that you want to 
connect to the network.

Direct and 
host agent

To ensure that the 
network hardware is 
present.

The installation guide 
specific to the hardware 
components.

Step 2 - Establish and 
record a naming 
convention for the 
storage subsystems 
connected to the 
network.

Direct and 
host agent

To add the storage 
subsystems to the 
management domain 
after installing the 
software.

“Deciding how to name 
the storage subsystems” 
on page 21.

Step 3 - Determine the 
hardware Ethernet 
address for each 
controller in all storage 
subsystems connected 
to the network.

Direct To set up the DHCP 
BOOTP server to 
provide network 
configuration 
information to the 
controllers.

“Identifying the 
hardware Ethernet MAC 
address for each 
controller” on page 21.

Step 4 - Obtain IP 
addresses and host 
computer names from 
the network 
administrator.

Direct and 
host agent

For host-agent 
management, you 
need the IP addresses 
and host names of the 
host on which the 
host-agent software 
will run.

For direct 
management, you 
need the IP addresses 
of each controller in 
the storage 
subsystems to 
configure the DHCP 
BOOTP server. The 
DHCP BOOTP server 
can then provide 
network configuration 
information to the 
controllers. Also, you 
use the IP addresses 
of the controllers to set 
up the host or DNS 
table.

“Obtaining IP addresses 
for hosts and controllers” 
on page 23.
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Table 11 shows a sample information record for a direct-managed storage subsystem 
and a host-agent managed storage subsystem.

For information about the entries in Table 11, see the following: 

• “Deciding how to name the storage subsystems” on page 21.

• “Deciding how to manage storage subsystems” on page 17.

• “Identifying the hardware Ethernet MAC address for each controller” on page 21.

• “Obtaining IP addresses for hosts and controllers” on page 23.

Table 17 on page 71 provides a data sheet on which you can record storage 
subsystem names, management types, hardware Ethernet addresses, and IP 
addresses. Make a copy of this table and complete the information for your storage 
subsystems and controllers. Use the information recorded in Table 17 on page 71 to 
set up the DHCP BOOTP table for the network server and the host or DNS (Domain 
Name System) table.

Step 5 - Set up the 
DHCP BOOTP server to 
provide network 
configuration information 
for a specific controller.

Direct To provide network 
configuration 
information to the 
controllers using the 
DHCP BOOTP server.

“Setting up the DHCP 
BOOTP server” on page 
23.

Step 6 - Verify that the 
TCP/IP software is 
installed, and set up the 
host or DNS table.

Direct Installing the client 
software on a 
management station 
ensures that the 
management station is 
configured to reach 
the controllers over 
the network. 

“Verifying the TCP/IP 
protocol and setting up 
the host or DNS table” 
on page 30.

Step 7 - Power on the 
devices connected to the 
network.

Direct and 
host agent

To ensure that all 
devices and links are 
operational.

The installation guide 
specific to the hardware 
components.

Table 11. Sample information record. 

Storage 
subsystem name

Management 
type 

Controllers—Ethernet and IP 
addresses, and host name

Host—IP 
address 
and host name

Controller A Controller B

Finance Direct Hardware 
Ethernet 
address = 
00a0b8020420

Hardware 
Ethernet 
address = 
00a0b80000d8

IP address = 
192.168.1.13

IP address = 
192.168.1.14

Host = Denver_a Host = Denver_b

 Engineering Host agent IP address = 
192.168.2.22

Host = Atlanta

Table 10. Network preparation task summary. 

Task to perform Management 
method Result For instructions, 

refer to
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Deciding how to name the storage subsystems
As you set up your network, determine the naming convention for the storage 
subsystems. After you install the storage-management software and start it for the 
first time, all storage subsystems in the management domain are displayed as 
<unnamed>. Use the Subsystem Management window to rename the individual storage 
subsystems.

The following list provides tips for naming storage subsystems:

• There is a 30-character limit. All leading and trailing spaces are deleted from the 
name.

• Use a unique, meaningful naming convention that is easy to understand and 
remember.

• Avoid arbitrary names or names that would quickly lose their meanings in the 
future.

• The software displays storage-subsystem names with the prefix Storage 
Subsystem. Therefore, if you rename a storage subsystem to Engineering, it is 
displayed as: 

Storage Subsystem Engineering

After you decide on a naming scheme, record the storage subsystem names in the 
information record (Table 17 on page 71).

If you are directly managing your storage subsystem, go to “Identifying the hardware 
Ethernet MAC address for each controller”. If you are going to manage your storage 
subsystem through the host agent, go to “Obtaining IP addresses for hosts and 
controllers” on page 23.

Identifying the hardware Ethernet MAC address for each controller
Use the following procedure if you plan to directly manage storage subsystems 
through Ethernet connections to each controller. If you plan to manage storage 
subsystems using the host-agent software, skip this procedure and go to “Obtaining 
IP addresses for hosts and controllers” on page 23.

For machine type 3542, the media-access control (MAC) address is at the back of the 
unit under the controller Gigabit Interface Converter (GBIC) slots (see Figure 7).

Record each Ethernet address in the information record (Table 17 on page 71); then 
go to “Obtaining IP addresses for hosts and controllers” on page 23.

Figure 7. Location of the hardware Ethernet address labels (machine type 3542)

Hardware Ethernet
address label
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For machine types 3526 and 3552, use the following instructions:

1. Remove the front bezel from the controller unit (machine types 3526 and 3552), 
as shown in Figure 8. Carefully pull the bottom of the bezel out �1�to release the 
pins; then slide the bezel down �2�.

Figure 8. Removing the controller-unit bezel (machine types 3526 and 3552)

2. Unlock and open the levers on the RAID controllers (models 3526 and 3552).

Figure 9. Location of the hardware Ethernet address labels (machine types 3526 and 3552)

3. On the front of each controller, look for a label with the controller hardware 
Ethernet address, as shown in Figure 9.

The number will be in the form xx.xx.xx.xx.xx.xx (for example, 00.a0.b8.00.00.d8).

4. Record each Ethernet address in the information record (Table 17 on page 71).

5. Lock the RAID controllers by simultaneously pushing the levers until they are 
latched in.

6. To replace the bezel on machine types 3526 and 3552, slide the top edge under 
the lip on the chassis �1�; then push the bezel bottom until the pins snap into the 
mounting holes �2�, as shown in Figure 10 on page 23. 

Hardware Ethernet
address label
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Figure 10. Replacing the controller-unit bezel (models 3526 and 3552)

7. Continue with “Obtaining IP addresses for hosts and controllers”.

Obtaining IP addresses for hosts and controllers
If you intend to manage some storage systems directly and others with the host-agent 
software or if you intend to manage subsystems directly, assign (or obtain from your 
network administrator) a unique IP address and the associated host name for each 
controller in every storage subsystem on the network. Record the IP address and host 
name for each controller in the information record (Table 17 on page 71). Then, go to 
“Setting up the DHCP BOOTP server”.

If you intend to manage storage subsystems with the host agent, contact your network 
administrator to obtain the IP address and host name for each host on which you plan 
to install the host-agent software for managing storage subsystems. Record the IP 
address and host name for the host in the information record (Table 17 on page 71). 
Then, go to “Verifying the TCP/IP protocol and setting up the host or DNS table” on 
page 30.

Setting up the DHCP BOOTP server
If you plan to directly manage storage subsystems through the Ethernet connection to 
each controller, select the procedure you plan to use for setting up the DHCP BOOTP 
server: 

• When using NetWare DHCP as a BOOTP-compatible server, go to “Using 
NetWare DHCP as a BOOTP-compatible server”.

• When using Microsoft BOOTP-compatible DHCP, go to “Using Microsoft Windows 
2000 DHCP as a BOOTP-compatible server” on page 27.

• When using UNIX BOOTP, go to “Using a UNIX BOOTP server” on page 29.

If you plan to manage storage subsystems using the host-agent software, go to 
“Verifying the TCP/IP protocol and setting up the host or DNS table” on page 30.

Using NetWare DHCP as a BOOTP-compatible server
The Dynamic Host Configuration Protocol (DHCP) enables TCP/IP-based client 
workstations to receive local and network configuration information automatically 
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when the TCP/IP transport is loaded. When a DHCP client workstation starts, it 
broadcasts a DHCP request for its IP address and network configuration. When the 
DHCP server receives the message, it checks its database and replies by sending a 
DHCP reply message that includes all TCP/IP configuration information required by 
the specific client that sent the request.

This section provides procedures for setting up the NetWare DHCP service. Prior to 
the installation of the DNS DHCP service, you must complete the following tasks:

• Extend the NDS schema and create the default DNS DHCP objects.

• Install the Novell Client on the computer that is going to run the DNS DHCP 
Management Console.

• Install the DNS DHCP Management Console and NetWare Administrator snap-in 
files.

To use a DHCP server, you must have a DHCP Manager installed.

Before you begin
Complete the following steps before setting up DHCP:

1. Install NetWare version 5.1 on the selected server or servers.

2. Install the Novell Client software delivered with NetWare version 5.1 on client 
computers that you will use to administer DNS and DHCP.

3. Install the DNS/DHCP Management Console on client computers that you will use 
to administer DNS and DHCP.

Installing DHCP services during the NetWare 5.1 installation
Use the following procedure to install DHCP services:

1. From the Installation Options window, select Custom.

2. From the Components window, select the Novell DNS/DHCP Services check box.

3. Follow the on-screen instructions to complete the NetWare version 5.1 
installation.

4. Continue with “Launching the DHCP Management Console”.

Launching the DHCP Management Console
To launch the DNS/DHCP Management Console, double-click its icon. You can install 
the DNS/DHCP Management Console on a client workstation, or you can access it 
from the Tools menu of the NetWare Administrator utility.

After the DNS/DHCP Management Console is installed, you are prompted to enter the 
DNS Tree Name where you want to set up DHCP. Continue with “Creating a DHCP 
server object” on page 25.
 24 IBM® FAStT Storage Manager Version 7.10 for Novell NetWare and Red Hat Linux: Installation and Support Guide  



Creating a DHCP server object
Use the DHCP Management Console to create and set up a DHCP server object. A 
DHCP server object is created or located under any of the following objects: 

Organization (O) 
Organization Unit (OU) 
Country (C) 
Locality (L)

Complete the following steps to create and set up a DHCP server object:

1. Click the DHCP Service tab on the DHCP Management Console.

The Our Network object is the only object displayed on the DHCP Management 
Console left pane.

2. Click Create on the tool bar. 

The Create New DHCP Object window opens, enabling you to create a DHCP 
server object, a subnet object, or a subnet pool object. 

3. Select DHCP Server and click OK.

The Create DHCP Server window opens, prompting you to select a server object. 

4. Use the browse button to select a server, then click Create.

This creates the DHCP server object in NDS, called DHCP_servername.

In the DHCP Management Console, locate the icon for the DHCP server at the 
bottom of the DHCP Service tab. The server object will display with a red line 
through it. The red line indicates that DHCP server NetWare Loadable Module 
(NLM) and related NLMs have not been installed.

5. Continue with “Creating a subnet object”.

Creating a subnet object
Use the DNS/DHCP Management Console to create and set up a DHCP subnet 
object for each of the subnets to which you will assign addresses.

Complete the following steps to create and set up a subnet object:

1. Click the DHCP Service tab on the DNS/DHCP Management Console.

The Our Network object is the only object displayed on the DNS/DHCP 
Management Console left pane.

2. Click Create on the tool bar.

The Create New DHCP Object window opens enabling you to create a DHCP 
server, a subnet, or a subnet pool object.

3. Select Subnet and click OK.

The Create Subnet window opens. For each subnet you create, enter the 
following information in the fields provided: subnet name, NDS context, subnet 
address, and subnet mask. If you have set up a default DHCP server, the server 
name is displayed and can be changed.

Click the Define Additional Properties check box to provide more detailed 
configuration, including DHCP options specific to each subnet. 

4. Enter the required information, then click Create.

The DHCP subnet object is created and displayed in the left pane of the 
DNS/DHCP Management Console.

5. Continue with “Creating subnet address ranges” on page 26.
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Creating subnet address ranges
Use the DNS/DHCP Management Console to create and set up subnet address 
range objects for each pool of addresses you want to be dynamically assigned by 
DHCP.

To create and set up a subnet address range object, complete the following steps: 

1. Click the DHCP Service tab on the DNS/DHCP Management Console.

2. Select the subnet object under which you want to create the subnet address 
range object, then click Create.

The Create New DHCP Record window opens.

3.  Select Subnet Address Range and click OK.

The Create New Subnet Address Range window opens.

4. Enter a name for the subnet address range, specify the range's starting and 
ending address, then click Create. 

If you click the Define Additional Properties check box, the range's detailed 
information window is displayed, enabling you to provide more detailed 
configuration information.

5. Continue with “Creating IP address objects”.

Creating IP address objects
Use the DNS/DHCP Management Console to create and set up IP address objects to 
be assigned to specific devices or to be excluded from dynamic assignment. Create 
an IP address object for each such device or address. Assigning a specific address to 
a client requires you to specify the client's media-access control (MAC) address or 
Client ID. 

If you have set up subnets and subnet address ranges, you are not required to set up 
individual IP addresses, unless you want to perform manual address assignment or 
exclude addresses from assignment.

To create and set up an IP address object, complete the following steps:

1. Click the DHCP Service tab on the DNS/DHCP Management Console.

2. Select the subnet object of the target IP address, then click Create on the tool bar. 

The Create New DHCP Object window opens.

3. Select IP Address and click OK. 

The Create IP Address window opens.

4. Enter the IP address to be assigned or excluded, select the assignment type, then 
click Create.

If you choose Manual Assignment Type, you must provide information for either 
the Client Identifier or the MAC Address fields. You can also specify the MAC Type 
by clicking in the field; the default is FF Any.

5. Continue with “Starting the DHCP server” on page 27.
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Starting the DHCP server
After you create and set up a DHCP server and configure the NDSTM objects 
required for DHCP, type the following command at the DHCP server console: 

LOAD DHCPSRVR

After you install DHCPSRVR.NLM, the DHCP server can respond to client requests 
and assign IP addresses.

Note: For additional information about setting up, configuring, or using Novell 
DNS/DHCP Services, refer to the NetWare 5.1 documentation, located on the 
Novell Documentation CD or at http://www.novell.com/documentation.

Using Microsoft Windows 2000 DHCP as a BOOTP-compatible server
You must use a version of Dynamic Host Configuration Protocol (DHCP) that supports 
BOOTP static addressing. To use a DHCP server, you must have a DHCP Manager 
installed. If a DHCP Manager is installed on the system, go to “Setting up a DHCP 
server”. If a DHCP Manager is not installed, go to “Installation instructions”.

Installation instructions
Complete the following steps to install the DHCP Manager:

1. Click Start → Settings → Control Panel → Add/Remove Programs.

The Add/Remove window opens.

2. Click the Add/Remove Component button.

The Component window opens. 

3. Scroll to, highlight, and click Networking Services.

4. Click the Details button.

5. Under Subcomponents of Networking Services, select the Dynamic Host 
Configuration Protocol check box, and click OK.

6. If prompted, type the full path to the Windows distribution files and click Continue.

The required files are copied to your hard disk. The server software can be used 
after you restart the system.

7. Continue with “Setting up a DHCP server”.

Note: After installing the DHCP Manager, you can refer to its online help for 
additional information.

Setting up a DHCP server
Use the following procedure to create a scope and to set up the DHCP server. A 
scope defines a group of controllers by their IP addresses. You must create and 
configure a scope so that dynamic IP addresses can be assigned to controllers on 
your network. Refer to the information that you provided in Table 17 on page 71. 
Before you begin, read through the instructions to determine what information is 
required, and then, request the information from your network administrator.

Note: The following steps and window example assume that you are configuring a 
Windows DHCP server using its DHCP Manager.

1. Click Start → Programs → Administrative Tools → DHCP.

The DHCP Manager window opens.

2. Highlight the server you want to configure.
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The Create Scope window opens. Use the following instructions:

a. Type a scope name and description.

Figure 11. Create scope - (Local) window

b. Type the starting and ending IP addresses of the controllers that you are 
configuring on the network.

For example, if you are configuring 50 controllers on a 192.168.1.0 subnet, 
set the starting address to 192.168.1.1, and set the ending address to 
192.168.1.50. 

Note: If each field does not contain at least three characters, press the 
period (.) key to advance to the next field. If you have only one 
controller, type its address for both the starting and ending addresses.

c. Type the subnet mask (obtained from your network administrator).

d. Using the Add Exclusions window, enter IP addresses that need to be 
excluded from the beginning and ending addresses that you just entered in 
step 2b, and then click Add.

e. Set the Lease Duration (obtained from your network administrator).

f. To configure the DHCP options, do the following:

Note: Be sure that you configure the DHCP options now. If you want to 
configure the options later, go to the DHCP window, and open the 
directory structure for the scope that you created in step 2 on page 27. 
Right-click Scope Options → Configure Options and follow the 
instructions. 

1) Add an IP address for a router.

2) Add the domain name and DNS servers.

3) Enter the server name and IP address in the WINS Servers 
window.

4) When the scope has successfully completed, click Yes to activate 
it.

You return to the DHCP Manager window.

3. Open the directory structure below the scope you created.

a. Right-click Reservation, click New Reservation, and follow the instructions.
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Important: At the bottom of the New Reservations window, make a selection 
under Supported Type.

The New Reservation window opens.

b. Enter a Reservation name, IP address, MAC address, and description.

c. In the support type box, select both options (DHCP and BOOTP).

d. Click Add.

e. Repeat step 3b through step 3d until you have added the reservations for all 
of the controllers.

f. When you enter the information for all of the controllers, click Close.

4. After you finish setting up the DHCP server, you must restart the DHCP server 
and then restart the storage subsystem before any modifications in the DHCP will 
take effect. 

5. Go to “Verifying the TCP/IP protocol and setting up the host or DNS table” on 
page 30.

Using a UNIX BOOTP server
Table 12 and Table 17 on page 71 provide information for setting up the BOOTP table 
and making the required entries to support the controllers in the storage subsystems. 
Use a text editor to edit the bootptab file in the /etc directory.

Note: The RMS and NMS entries used in previous versions of the storage 
management software are not required when using Storage Manager 7.10 
with controllers running firmware version 4.x.

Example for editing a UNIX BOOTP table
The following example of a BOOTP table assumes that you are configuring a UNIX 
BOOTP server, such as a server on Network A, of Figure 6 on page 18. The 
s4.default:\ entry denotes settings that are common to all controllers. The 
tc=s4.default:\ entry associates this common setting group to a specific controller.

Table 12. Required entries for setting up the UNIX BOOTP server. 

Entry Description Sample format in 
BOOTP server

Subnet mask Mask that is used to route packets to defined 
subnets.

dot notation
(sm=255.255.255.0)

Router IP address of the host computer that routes 
packets to networks.

dot notation
(gw=192.168.1.1)

Host name for 
the controller

Host name that is associated with the controller 
(refer to Table 17 on page 71).

host name
(Denver_a)

IP address IP address of the controller (refer to Table 17 on 
page 71).

dot notation
(ip=192.168.1.13)

Ethernet 
address

The Ethernet address of the controller hardware 
(refer to Table 17 on page 71).

hexadecimal notation
(ha=00a0b8020420)
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s4.default:\ (common settings)
ht=ether:\
sm=255.255.248.0:\
gw=153.79.144.2:\
hn:
denver_a:\
tc=s4.default:\ (refers to common settings)
ip=153.79.144.13:\
ha=00a0b8020420:
denver_b:\
tc=s4.default:\
ip=153.79.144.14:\
ha=00a0b80000d8"

When you finish setting up the BOOTP table you must restart the storage subsystems 
for the parameters in the BOOTP table to take effect then, continue with “Verifying the 
TCP/IP protocol and setting up the host or DNS table”

Verifying the TCP/IP protocol and setting up the host or DNS table
Make sure that the host names for the controller correspond to the appropriate IP 
addresses for the controllers. Use the following procedure to verify that the TCP/IP-
protocol software is installed on the management station and to set up the host or 
DNS (Domain Name System) table.

Note: You can use the Windows Internet Naming Service (WINS) rather than DNS.

For Novell NetWare:

1. Click Start → Settings → Control Panel → Network → Protocols to verify that 
the TCP/IP software is installed and configured properly.

Note: If the TC/PIP software is not installed properly, install it from the 
appropriate installation CD. Click Start → Settings → Control Panel → 
Network → Protocols → Add → Have Disk.

2. Update either the host table or DNS table to specify a host name to associate with 
an IP address. If you do not have a DNS (or WINS), edit the two host tables found 
in the following directories (your directory will be different if the operating system 
is not installed on the root).

For NetWare:

c:\NetWare\system32\drivers\etc\hosts

c:\NetWare\system32\drivers\etc\imhosts

For Linux:

c:\Linux\system32\drivers\etc\hosts

c:\Linux\system32\drivers\etc\imhosts

Important: Opening ports to your network poses potential security risks.

To set up the host tables for the controllers connected to Network A (Figure 6 on 
page 18). Open the hosts file that is located in the \etc\ directory (refer to the 
example below) and use a text editor to update the hosts file to create the 
following IP address and controller name entries. See the following hosts file 
example:

Copyright (c) 1993-2001 Microsoft Corp. 

This is a sample HOSTS file used by Microsoft TC/PIP for Windows.
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3. To manage storage subsystems through a firewall, configure the firewall to open 
port 2463 to TCP data. Otherwise, go to “Determining your storage-management 
software installation process”.

Determining your storage-management software installation process
The installation process you follow depends on your operating system and how you 
plan to configure the system. If you plan to install the software in a standard (non-
cluster) configuration do one of the following:

• Go to Chapter 3, “Installing software in standard and cluster configurations 
(Novell NetWare),” on page 33.

• Go to Chapter 6, “Installing software in a standard configuration (Red Hat Linux),” 
on page 55. 

If you plan to install the software in a cluster server configuration go to Chapter 3, 
“Installing software in standard and cluster configurations (Novell NetWare),” on page 
33.

This file contains the mappings of IP addresses to host names. Each entry should be 
kept on an individual line. The IP address should be placed in the first column 
followed by the corresponding host name. The IP address and the host name should be 
separated by at least one space.

Additionally, comments (such as these) might be inserted on individual lines or 
following the machine name denoted by a ’#’ symbol.

For example:

102.54.94.97
38.25.63.10

rhino.acme.com
x.acme.com

# source server
# x client host

127.0.0.1
192.168.1.13
192.168.1.14

local host
denver_a
denver_b
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Chapter 3.  Installing software in standard and cluster 
configurations (Novell NetWare)

This chapter describes how to install the storage-management software in standard 
and cluster configurations.

Important: Always check for a README file on any installation media. This README 
file might contain important information that was not available when this Installation 
and Support Guide was written.

There are two configurations in which you can install the storage-management 
software:

• You do not have existing storage subsystems. In this situation, you are installing 
new storage subsystems with machine type 3526, 3542, or 3552 controllers using 
firmware version 04.01.xx and will manage these new storage subsystems using 
Storage Manager 7.10. If this is your situation, go to “Installation process” on page 
34.

• You have existing storage subsystems with machine type 3526, 3542, or 3552 
controllers. In this situation, you can do one of the following:

— Upgrade the controller firmware on the existing storage subsystems to 
version 04.01.xx and manage them with Storage Manager 7.10.

— Continue to manage the existing storage subsystems with version 6.22 of the 
storage-management software and manage new storage subsystems with 
Storage Manager 7.10. To determine if you have coexisting storage 
subsystems, see “Installation types” on page 7.

Use Table 13 to determine your installation process. 

Table 13. Determining your installation process in standard and cluster configurations. 

Current environment Planned environment Action

Existing storage 
subsystems with 
controllers using 
firmware version 3.x

Upgrade to firmware version 
04.01.xx.

Refer to the README file 
located in the \Netware51\ 
directory on the installation CD 
for more information.

No existing storage 
subsystems

New storage subsystems with 
controllers that use version 
04.01.xx firmware managed with 
Storage Manager 7.10.

Go to “Installation process” on 
page 34.

Existing storage 
subsystems with 
controllers that have 
firmware versions 
4.00.00 through 
4.00.01

Upgrade storage subsystems with 
controllers that use version 
04.01.xx firmware managed with 
Storage Manager 7.10.

1. Go to “Installation process” 
on page 34.

2. Update the NVSRAM and 
firmware to version 
04.01.xx using the storage-
management software 
online help. 

Continue to use your existing 
versions 4.00.00 through 4.00.01 
controller firmware managed with 
Storage Manager 7.10. Refer to 
the README file for more 
information.

Go to “Installation process” on 
page 34. 
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Installation process
The following installation process applies to:

• New installations

• Additions to existing storage subsystems

Begin the installation of the storage-management software with “Installing the Storage 
Manager 7 client package”. Continue the process until you have completed “Installing 
IBM FAStT Management Suite Java” on page 38.

Figure 12 shows a flowchart of the installation process. 

Figure 12. Installation process

Installing the Storage Manager 7 client package
Use the following instructions to install the SM7client on a management station that is 
configured with Novell NetWare 5.1 with Service Pack 2.

To install the SM7client on a management station that is configured with one of the 
following operating systems, refer to this installation guide or the IBM FAStT Storage 
Manager Version 7.10 for Microsoft Windows NT and Windows 2000 Installation and 
Support Guide for installation instructions.

• Windows NT Server 4.0 with Service Pack 5 or later

• Windows NT 4.0 Enterprise Edition with Service Pack 5 or later

• Windows NT Workstation 4.0 with Service Pack 5 or later

• Windows 2000 Advanced Server

• Windows 2000 Professional

Install the Storage Manager 7 client
(SM7client) software package

Install the Storage Manager 7 agent
(SM7agent) software package

Install the Storage Manager 7 utility
(SM7util) software package

Install the IBM Storage Area Network
(SAN) driver

Go to  Chapter 5, completing the installation

Install the IBM Host Adapter (HA) device
driver ( QL2x00)

Install the IBM Management Suite Java
(FAStT MSJ)
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• Windows Advanced Server

Notes: 

• If you are configuring only a network management station, you need to install only 
the SM7client.

• If you want to install SM7client on a stand-alone host and manage storage 
subsystems through the Fibre Channel I/O path rather than through the network, 
you must install the TCP/IP software on the host and assign a static IP address to 
the host.

Installation instructions for Storage Manager 7 client
Before you install the SM7client software, make sure that:

• The management station has at least 60 MB of available disk space.

• The monitor properties are set to a minimum screen resolution of 800 x 600 pixels 
and a palette of 256 colors or more.

• You close all other programs.

Perform the following steps if you are installing the SM7client package on a 
management station running NetWare 5.1 operating system software:

1. Insert the IBM FAStT Storage Manager installation CD into the CD-ROM drive 
and type: 

load cdrom

2. Mount the volume.

3. Click Novell → Install.

4. Click Add, and follow the instructions on the screen.

5. Click the Directory Tree button.

The Directory Tree window opens.

6. Select the CD-ROM volume.

7. Select the \Netware51\SM7client directory.

8. Select the program.ni file, and then click OK.

9. Click OK.

After the files are copied, the License Agreement window opens.

10. Click Accept to continue. 

The copying files message window opens.

11. When the installation is complete, click Finish.

Use the following procedure to verify that the installation was successful:

1. Click Novell → Programs.

2. Verify that the IBM FAStT Fibre Channel Storage Manager client appears in the 
list of programs.

3. Continue with “Installing the Storage Manager 7 agent software package” on page 
36. 
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Installing the Storage Manager 7 agent software package
Use the following procedure to install the host-agent software package on each host 
computer that is connected to one or more storage subsystems. The host-agent 
software is necessary for host-agent management of the storage subsystems.

Important: You must install the host-agent software package even if you do not intend 
to manage storage subsystems through the host-agent software. The host agent 
package contains utilities that are required to manage storage subsystems.

Note: You must install the host agent package even if you are installing SM7client 
only on a management station.

Before you install the software, make sure that:

• The host computer is configured with Novell NetWare 5.1 and Service Pack 2.

• The host computer has at least 20 MB of available disk space.

• The monitor properties are set to a minimum screen resolution of 640 x 480 pixels 
and a palette of 256 colors or more.

• You close all other programs.

If you are using the host-agent management method for the storage subsystem, set 
the maximum LUN value to 32 for the host bus adapter. By default, the Universal 
Transport Module (UTM) LUNs are set to 31 and must be reported to the operating 
system so that the SM7agent can identify and link to the UTM. For more information, 
refer to the README in the Netware51/host_adapter directory of the IBM FAStT 
Storage Manager installation CD.

Installation instructions
Perform the following steps to install the host agent package:

1. Insert the IBM FAStT Storage Manager installation CD into the CD-ROM drive 
and type:

load cdrom

2. Mount the CD volume.

3. Click Novell → Install.

4. Click Add, and follow the instructions on the screen.

5. Click the Directory Tree button.

The Directory Tree window opens.

6. Select the CD-ROM volume.

7. Select the \Netware51\SM7agent directory.

8. Select the product.ni file, and then click OK.

9. Click OK.

After the files are copied, the License Agreement window opens.

10. Click Accept to continue. 

The files are copied.

11. When the installation is complete, click Finish.

Note: To enable SM7agent at server startup, an autoexec.ncf entry can now be 
made. 
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Use the following procedure to load SM7agent and verify that the installation was 
successful:

1. Toggle to the Server Console window and at the command prompt, type:

Load SM7agent

The agent will start and display the following message when UTM LUNs are being 
scanned:

Activating

2. Continue with “Installing the Storage Manager 7 Utility software”.

Installing the Storage Manager 7 Utility software
This section provides instructions for installing the Storage Manager 7 Utility software 
on attached hosts that are running NetWare. The Storage Manager 7 Utility software 
contains utilities that will register and map new logical drives to the operating systems. 
The Storage Manager 7 Utility software must be installed on host computers that are 
attached to the storage subsystem through a Fibre Channel connection.

Important: Make sure you have installed the FAStT MSJ software on the same host 
where you are installing the Storage Manager 7 Utility software. For more information, 
refer to “Installing IBM FAStT Management Suite Java” on page 38.

Installation instructions
Use the following procedure to install the Storage Manager 7 Utility software on each 
attached Windows host computer.

1. Insert the IBM FAStT Storage Manager installation CD into the CD-ROM drive 
and type:

load cdrom

2. Mount the CD volume.

3. Click Novell → Install.

4. Click Add, and follow the instructions on the screen.

5. Click the Directory Tree button.

The Directory Tree window opens.

6. Select the CD-ROM drive.

7. Select the \NetWare51\SM7util folder, and then, click Open.

8. Select the setup.exe file, and then, click Open.

The Welcome window opens.

9. Click Next to begin the installation.

After installing the Storage Manager 7 Utility software, the Operation Complete 
window opens. If the system detects the installation of another version of Storage 
Manager 7 Utility, a window opens indicating that the installation will be updated 
and your personal configuration files will be saved. Click Yes to continue.

10. Click Finish.

11. Go to “Installing the IBMSAN driver” on page 38.
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Installing the IBMSAN driver
The IBM Storage Area Network (SAN) driver is used in a Novell NetWare environment 
to provide multipath I/O support to the storage controller. The IBMSAN driver is a 
custom driver module (CDM) that is installed with the IBM FAStT Host Adapter driver. 
In case of a failure along the I/O path, the driver will send the I/O requests through the 
alternate path and Auto-Volume Transfer (AVT) will move the logical drive within the 
FAStT Storage Server. Refer to the http://www.ibm.com/pc/support IBM Web page for 
the current README file, SAN driver, and installation instructions.

Continue with “Installing the IBM Host Adapter device driver (QL2x00)”.

Installing the IBM Host Adapter device driver (QL2x00)
The IBM Host Adapter device driver enables the operating system to communicate 
with the host adapter. The IBM FAStT Host Adapter is a high-performance, direct 
memory access (DMA), bus-master, host adapter designed for high-end systems. The 
IBM FAStT Host Adapter supports all Fibre Channel (FC) peripheral devices that 
support private-loop direct attach (PLDA) and fabric-loop attach (FLA). Refer to the 
IBM FAStT Host Adapter Installation and User’s Guide and the 
http://www.ibm.com/pc/support IBM Web page for the current README file and latest 
multipath I/O device driver.

Continue with “Installing IBM FAStT Management Suite Java”.

Installing IBM FAStT Management Suite Java 
The IBM FAStT Management Suite Java (FAStT MSJ) software includes the FAStT 
MSJ agent and FAStT MSJ application. The FAStT MSJ is for only diagnostics.

Note: For additional information, refer to the IBM FAStT MSJ User’s Guide or online 
Help.

Perform the following steps to install IBM FAStT Management Suite Java:

1. Insert the IBM FAStT Storage Manager installation CD into the CD-ROM Drive.

2. Map a drive to the SYS volume of the NetWare server.

3. Select the NetWare51 directory.

4. Click install.exe.

The Introduction window opens.

5. Click Next.

The Important Information window opens. Read the FAStT MSJ application notes. 

6. Click Next.

The Choose Install Folder window opens.

7. Restart your NetWare server to start the FAStT MSJ agent.

For additional information, refer to the IBM FAStT MSJ User’s Guide or online Help.
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Chapter 4.  Completing the installation (Novell NetWare)

This chapter contains procedures for starting Enterprise Management and Subsystem 
Management and for completing the installation tasks.

Starting the Enterprise Management window
The Enterprise Management window is the first window that opens when you start the 
software. Use the Enterprise Management window to:

• Add and discover the storage subsystems that you want to manage.

• Provide a comprehensive view of all storage subsystems in your management 
domain.

• Perform batch storage-subsystem management tasks using the Script Editor.

Use the following procedure to start the Enterprise Management window:

1. If you are using the SM7agent, start the SM7agent at the Server Console window.

At the Server Console, type:

Load SM7agent

2. From the Xserver Graphical Console, click Novell → Programs.

3. Click IBM FAStT Storage Manager 7.

The client software starts, and the Enterprise Management window and the Initial 
Automatic Discovery dialog box opens, as shown in Figure 13.

Figure 13. Confirm Initial Automatic Discovery dialog box

Note: The Enterprise Management window can take several minutes to open. 
No wait cursor (such as an hourglass) is displayed.

If you do not want to perform the initial automatic discovery, click No. You 
can use the Edit → Add Device menu option to add hosts and storage 
subsystems. For more information, see “Adding devices” on page 40. 

4. Click Yes to begin an initial automatic discovery of hosts and storage subsystems 
that are attached to the local subnetwork where the management station is 
installed.
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The software sends a broadcast message across the local subnetwork where the 
management station is installed. It discovers host-agent managed storage 
subsystems when the hosts that provide network management connections to the 
storage subsystems respond to the broadcast. The software discovers storage 
subsystems (that are using the direct management method) when the controllers 
in those storage subsystems respond to the broadcast message.

Adding devices
You can add more hosts or storage subsystems outside the local subnetwork. For 
more information about this option, refer to the Enterprise Management window online 
Help.

Important: If you are managing storage subsystems through the host-agent software 
and you physically add new storage subsystems, you must stop and restart the host-
agent service so that it can recognize the new storage subsystems. Then, go to the 
Enterprise Management window and click Tools → Rescan to add the new storage 
subsystems to the management domain.

Continue with “Setting up alert notifications”.

Setting up alert notifications
After you add devices to the management domain, set up alert notification options to 
report critical events on the storage subsystems. The following options are available 
for alert notification:

• Notification to a designated network management station (NMS) using Simple 
Network Management Protocol (SNMP) traps (see “Setting up the NMS for SNMP 
notification” for more information)

• Notification to designated e-mail addresses

• Notification to designated alphanumeric pagers (when a vendor software package 
is used to convert e-mail messages)

Note: If you do not install Event Monitor, you must monitor storage subsystems 
within the management domain. The Enterprise Management window must 
remain open (you can minimize the window). If you close the window, you will 
not receive alert notifications. Refer to the Enterprise Management window 
Help for information on alert notification options.

Setting up the NMS for SNMP notification
If you choose to set up alert notification using SNMP traps, you must first copy a 
management information base (MIB) file to the designated network management 
station. Use this procedure to set up the MIB file on the network management station.

Important: You need to designate your NMS only once.

1. From the \SM7mib directory on the IBM FAStT Storage Manager Installation CD, 
copy the Arrayman.mib file to the network management station.

2. Follow the steps that are required by your specific network management station to 
compile the MIB file.

Note: For details on the required steps, see your network administrator or the 
documentation that is specific to the NMS product that you are using.
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Configuring alert destinations
Configure SNMP trap destinations and e-mail destinations for alert notifications using 
Enterprise Management. Refer to the Enterprise Management online Help for specific 
procedures.

Starting Subsystem Management
The Subsystem Management window enables you to manage selected subsystems.

Use the following procedure to open a Subsystem Management window for a selected 
storage subsystem:

1. In the Enterprise Management window, select a storage subsystem.

2. Click Tools → Manage Device.

The software displays the Subsystem Management window for the selected 
storage subsystem, as shown in Figure 14 and Figure 15 on page 42.

Note: Using the open Subsystem Management window, you can manage only 
the selected storage subsystem. However, you can open multiple 
subsystem-management windows to manage other storage subsystems.

Figure 14. Subsystem Management window (models 3526 and 3552)
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Figure 15. Subsystem Management window (model 3542)

Renaming storage subsystems
When starting Storage Manager 7.10 for the first time, the storage subsystems are 
unnamed. You must use the Subsystem Management window to rename each 
storage subsystem to the name that you want. Refer to the names that you entered in 
the information record using Table 17 on page 71. Then, refer to the renaming storage 
subsystems topic in the Subsystem Management online Help, which provides detailed 
instructions for renaming storage subsystems.

Downloading firmware and NVSRAM
Important: You must download firmware version 04.01.xx before you download 
NVSRAM.

To download firmware version 04.01.xx, do the following:

1. Open the Subsystem Management window. 

2. Click Storage Subsystem → Download → Firmware.

Follow the online instructions.

To download NVSRAM, do the following:

1. Open the Subsystem Management window. 

2. Click Storage Subsystem → Download → NVSRAM.

Follow the online instructions.

3. Continue with “Creating arrays and logical drives”.

Creating arrays and logical drives
To create an array or logical drive, perform the following procedure:

1. Create all of your planned arrays and logical drives on this storage subsystem by 
clicking the Configure → Create Array/Logical Drive.
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2. Repeat the arrays/logical drive configuration for each storage subsystem 
connected to your cluster.

Note: If you make any other logical drive additions or deletions, you must make 
them known to node 02 in a cluster configuration.

3. Continue with “Changing host type”.

Changing host type
If you have partitioning enabled, do the following to check or change your host type:

1. From the Subsystem Management window left pane, select your host.

2. From the Subsystem Management window, select Configure → View Logical 
LUN Mapping.

3. From the Subsystem Management window left pane, select the host port you 
want to configure, and from the tool bar, click Configure → Topology → Change 
Host Type.

If you do not have partitioning enabled, do the following to check or change your host 
type:

Note: Partitioning is a premium feature. If you disable partitioning, you will have to 
contact your IBM technical-support representative to obtain a key to enable 
partitioning.

1. From the Subsystem Management window, select your host in the left pane.

2. Click Configure → Change Host Type.

3. Continue with “Heterogeneous hosts overview”.

Heterogeneous hosts overview
The heterogeneous hosts feature enables hosts running different operating systems 
to access a single storage subsystem. Previous releases of IBM FAStT Storage 
Manager did not have this featrure.

Host computers accessing a single storage subsystem can now run completely 
different operating systems (for example, NetWare and Linux). When a host type is 
specified in the Define New Host Port window, the heterogeneous hosts feature 
enables the controllers in the storage subsystem to tailor their behavior (such as LUN 
reporting and error conditions) to the needs of the host operating system of the host 
sending the information.

Important: The heterogeneous hosts feature is available only with storage 
partitioning enabled.

In a heterogeneous environment, you must set each host type to the appropriate 
operating system during host-port definition so that the firmware on each controller 
can respond correctly for the operating system for that host.

To start the heterogeneous host configuration, do the following:

1. From the Subsystem Management window, click Configure → Storage 
Partition.

2. Refer to the Subsystem Management window online help.

3. Continue with “Stopping and starting the host agent” on page 44.
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Stopping and starting the host agent
Perform the procedures in the following sections to stop and start the host-agent 
software that is installed on the host computer.

Note: If an access volume is not detected, the host-agent software will automatically 
stop running. If you download an NVSRAM file that enables an access volume 
or changes the LUN that is used for the access volume, you must stop and 
restart the host-agent software or restart the host computer to enable the 
discovery of host-agent managed storage subsystems.

Stopping the host agent
You must stop the host-agent software if you want to add storage subsystems. When 
you restart the service, the host agent discovers the new storage subsystems and 
adds them to the management domain.

Use the following procedure to stop the host-agent software: 

1. From the system console, press Ctrl+Esc, and then select System Console.

2. At the prompt, type:

unload sm7agent

3. Press Enter.

4. Return to ConsoleOne. Press Ctrl+Esc, and then select Xserver −− Graphical 
Console.

Starting the host agent manually
The host-agent software must be started manually when the system is started or if it is 
stopped to add storage subsystems.

Use the following procedure to start the host agent manually:

1. From the system console, press Ctrl+Esc, and then select System Console.

2. At the prompt, type:

sm7agent

3. Press Enter.

The window will go blank when the define (NLM) space has been created.

4. Return to ConsoleOne. Press Ctrl+Esc, and then select Xserver −− Graphical 
Console.

Starting the host agent automatically
To configure the host-agent software automatically at startup, use the following 
procedure:

1. Open the autoexec.ncf file in a file editing program.

2. Locate the section that describes loading the Java Runtime Environment. Type 
the following line after the string:

sys:system/sm7agent

3. Save and close the edited autoexec.ncf file.

Note: It can take up to a minute for the Enterprise Management window to refresh 
after an initial automatic discovery. 

If you need to stop the automatic discovery operation, close the Enterprise 
Management window.
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When the initial automatic discovery is complete, the system displays all hosts and 
storage subsystems that are attached to the local subnetwork, as shown in Figure 16. 

Figure 16. Enterprise Management window

The system does not display all hosts and storage subsystems: 

• Check the hardware and connections for possible problems (refer to the hardware 
documentation for specific procedures).

• Refer to the discovering storage subsystems Enterprise Management Help topic.

• Make sure that the device is on the local subnetwork. If it is not, you must use the 
Add Device option.

Note: If any device shows a status of Unresponsive, use the software to remove the 
device from the management domain and then add it again. Refer to the 
Enterprise Management online Help for instructions on removing and adding 
devices.

A storage subsystem might be duplicated in the device tree after an automatic 
discovery. In this case, you can remove the duplicate storage-management icon from 
the device tree using the Remove Device option in the Enterprise Management 
window.

Continue with “Monitoring storage subsystems”.

Monitoring storage subsystems
To monitor the condition of storage subsystems in your management domain, you 
must start Enterprise Management. For more information about monitoring storage 
subsystems, refer to the Enterprise Management online Help.

Performing other storage-subsystem management tasks
You can perform the following storage-subsystem management tasks:

• Download controller firmware

• Download controller NVSRAM

• Locate a storage subsystem
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• View a storage subsystem profile

• Type or change a storage subsystem password

• Create and manage logical drives and arrays

• Use the Performance Monitor

• Create storage partitions (if applicable)

Note: To create storage partitions, you must obtain the worldwide name or port name 
of each host adapter in each host that is connected to the storage subsystem.

For more information about these and other storage-subsystem management tasks, 
refer to the appropriate topics in the Subsystem Management online Help.

Continue with “Applying NVSRAM configuration scripts”.

Applying NVSRAM configuration scripts
When you manage with Storage Manager 7.10, you might need to run the NVSRAM 
configuration scripts on each storage subsystem to modify configuration settings that 
are stored in NVSRAM.  Use the following procedure to modify the scripts:

1. Insert the IBM FAStT Storage Manager Installation CD into the CD-ROM drive.

2. From the Xserver Graphical Console, type:

load cdrom

3. Mount the CD volume.

4. From the Xserver Graphical Console, click Novell → IBM FAStT 
Storage Manager 7.

5. From the Initial Automatic Discovery dialog box, click Yes.

If you click No, you can still add devices manually using the Edit → Add Device 
option.

Storage subsystems at firmware level 4.x are automatically discovered.

6. In the right pane of the IBM FAStT Storage Manager 7 (Enterprise Management) 
window, right-click a storage subsystem, and click Execute Script from the menu.

The Script Editor window opens.

7. From the Script Editor window menu, click File → Load Script.

If you are prompted to save changes to newscript.scr, click No.

8. From the Load Script window, select the <CD-ROM volume> 
\Netware51\scripts\Netware5.scr file and select Open.

9. From the Script Editor window menu, click Tools → Verify and Execute.

The message Script execution complete is displayed in the lower pane of the 
Script Editor window.

10. From the Script Editor window, click File → Load Script.

If you are prompted to save changes to newscript.scr, click No.

11. From the Load Script window, select the <CD-ROM volume> 
\Netware51\scripts\NW_mpio.scr file and then, select Open.

12. From the Script Editor window, select Tools → Verify → Execute.

The message Script execution complete is displayed in the lower pane of the 
Script Editor window.

13. Restart the controller.
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Chapter 5.  Novell NetWare operating-system support 

This chapter contains information about operating the storage-management software 
with Novell NetWare.

Novell NetWare limitations
Important: Always check for a README file on any installation media. This README 
file might contain important information that was not available when this Installation 
and Support Guide was prepared.

Table 14 explains the limitations that apply when you use the FAStT Storage Manager 
Version 7.10 with Novell NetWare.

Table 14. Novell NetWare limitations and workarounds. 

Limitation Workaround

Clicking a vertical scroll arrow (either up or 
down) causes the scroll box to move all the 
way to the opposite end of the scroll bar.

This is a known defect in the Java Runtime 
Environment.

Click the scroll box and slide it until you reach 
the desired position in the Help window.

Logical drive migration (removing a set of 
drives that are configured with logical drives 
from one storage subsystem for insertion into 
another storage subsystem) is not supported 
because it could cause loss of configuration.

Call for service.

When you manage storage subsystems 
through the host-agent software and use the 
storage-management software to download 
controller firmware, the download process 
can take up to 10 minutes to complete.

None.

The controller firmware does not recognize or 
communicate with a single controller until slot 
A is populated. This limitation does not apply 
to storage subsystems that were originally 
configured with two controllers.

When you configure a new storage 
subsystem with a single controller, you must 
place the controller in slot A.

Public loop configurations (managed hubs 
that are attached to switches) are not 
supported.

None.

Multipath failover will only work if the storage 
controllers are in active/active mode.

When you configure the storage subsystem, 
change both controllers to active status.

When you remove a fan or power supply 
customer replaceable unit (CRU) from a 
storage subsystem while the system is 
running, the storage-management software 
does not report an error message, and the 
component is not reported as missing.

Note: Fan and power-supply CRU failures 
are reported.

Replace the missing fan or power-supply 
CRUs immediately to ensure redundancy. 
Make sure that the fan or power-supply CRU 
is properly seated in the controller unit.
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Automatic redistribution of LUNs/arrays is not 
supported. If a controller fails over the 
storage subsystems to the alternate 
controller and the failed controller is replaced 
and brought back online, then the storage 
subsystems do not automatically transfer to 
the preferred controller.

This must be done manually by redistributing 
storage arrays.

Your windows and online Help will display a 
brownish hash pattern when you run in 256 
color mode.

Run the SM7 application in a higher display 
mode

When performing a redundancy check (parity 
scan) from the storage management 
application, machine type 3542 can take 
several minutes longer than machine type 
3526 and 3552 controller platforms.

None.

When attempting to manage a storage 
subsystem where the RAID controller unit 
does not have access to logical drives 
Storage Manager will prompt you for a 
password. This will occur even if no password 
has been setup. The automatic discovery will 
locate and identify each storage subsystem 
as two separate storage subsystems.

Ensure that at least one IBM FAStT EXP500 
Expansion Unit with at least one logical drive 
is properly attached to the IBM FAStT500 
RAID Controller Unit in each storage 
subsystem being managed. Since the RAID 
controller unit should not be powered on until 
the expansion units are attached and 
powered on, this should be done by powering 
off the RAID controller unit, properly attaching 
all expansion units, with the drives installed, 
to the RAID controller unit and powering them 
on, and then powering the RAID controller 
unit back on. At this point the storage 
subsystems can be re-discovered and 
managed using the FAStT Storage Manager 
software.

You might not see the maximum number of 
drives during Automatic Configuration if you 
are using drives of different capacities.

Use Manual Configuration to select individual 
drives and select the maximum number of 
drives allowed.

Table 14. Novell NetWare limitations and workarounds. 

Limitation Workaround
 50 IBM® FAStT Storage Manager Version 7.10 for Novell NetWare and Red Hat Linux: Installation and Support Guide  



Number of supported logical drives
The supported logical drive limits are as follows:

• When using Novell Storage Management Services (SMS) you can configure up to 
128 LUNs, or the maximum for the host adapter model in your system.

• Host adapters support a specific number of logical drives. Refer to the host-
adapter documentation for specific information.

• The host-agent management method uses a special logical drive, called an 
access volume, to communicate with the controllers on the storage subsystem. 
The access volume uses one of the allowable logical drives. Therefore, managing 
storage subsystems with the host-agent software limits you to one fewer LUN 
than the maximum number that is supported by Novell NetWare and the host 
adapter.

Creating logical drives
A logical drive is a logical object that is the basic structure that you create to store 
data on the storage subsystem. A logical drive is configured for an array with a 
specific RAID level to meet application needs for data availability and Fibre Channel 
I/O performance. A logical drive is recognized by the operating system as one drive. 

You can add or delete logical drives in a standard configuration.

When you create new logical drives with the storage-management software, you must 
add the new logical drives to Novell NetWare. Refer to the Novell NetWare 
documentation for details about adding a drive. Remember that each logical drive (not 
array) is recognized by Novell NetWare as one drive. After creating logical drives, run 
the Hot Add and SM7devices utilities that are provided with the storage-management 
software. The Hot Add utility adds newly created logical drives to the operating 
system, and the SM7devices utility identifies logical drives by their associated 
operating system device names. For information about using these utilities, see 
“Using the Hot Add utility” and “Using the Storage Manager 7 devices utility” on page 
52.

Before deleting logical drives with the storage-management software or using 
Configure → Reset Configuration, stop all input and output activity to the affected 
storage subsystem. Then dismount any NetWare volumes that are associated with 
the logical drives.

Using the Hot Add utility
The Storage Manager 7 utility software package includes the Hot Add utility that you 
can use to add new logical drives dynamically without restarting the system. This 
utility registers the new logical drives with the operating system so that you can use 
Disk Administrator to create partitions, add device names, and so on. The Hot Add 
utility is part of the SM7util package.

After you finish creating the logical drives on a particular storage subsystem, go to the 
host that is attached to that storage subsystem and perform the following steps to use 
the Hot Add utility:

1. From the Server Console, type:

hot_add

2. Press Enter.
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The new logical drives are available through the Disk Administrator.

Using the Storage Manager 7 devices utility
The Storage Manager 7 utility software package includes the utility called Storage 
Manager 7 devices (SM7devices) that you can use to view the storage subsystem 
logical drive that is associated with a particular operating system device name. This 
capability is helpful when you want to create drives, volumes, or a combination of both 
for the logical drive using the nwconfig program.

After you finish creating the logical drives on a particular storage subsystem, go to the 
host that is attached to that storage subsystem and perform the following steps to use 
SM7devices:

1. From the Server Console type:

SM7devices

2. Press Enter.

The software displays device identification information. For example, you might 
see:

V596-A3-D0:0[Storage Subsystem MARKETING, Logical Drive DEBIT,
LUN 0, WWN <600a0b800007545c0000008d3a308b6e>] 

V596-A3-D0:1 [Storage Subsystem MARKETING, Logical Drive DEBIT, LUN 1,
WWN <600a0b80000756ec000000a93a307d2a>]

V596-A3-D0:1F [Storage Subsystem MARKETING, Logical Drive Access volume,
LUN 31, WWN <600a0b800007545c0000009000000000>]

Where V596-A3-D0:0;

The numbers at the beginning of each line comprise the device name. The device 
name identifies the adapter or device as follows:

Vendor number [V596]. A unique number specific to the device vendor.

Adapter number [A3]. The instance number of an adapter registered with
NWPA. In the example, A3 identifies the first instance of an adapter
installed in the server.

Device number [D0]. The number of the disk or other device.

Logical unit number [0,1,1F]. The LUN identifies individual devices when
more than one device is attached to one bus.

Storage Subsystem x = the storage subsystem name

Logical Drive x = the logical drive name

LUN x = the logical unit number associated with the logical drive

WWN x = the worldwide name for the logical drive

Uninstalling storage-management software components
Use the following procedure to uninstall one or more of the components of Storage 
Manager 7.10.

1. From the Xserver Graphical Console, click Novell → Install.

The Add/Remove Programs Properties window opens.

2. From the list of programs, select the component that you want to uninstall.

For example, select IBM FAStT Storage Manager 7.
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3. Click Add/Remove.

The Confirm File Deletion window opens.

4. Click Yes to start the uninstall process.

5. When the uninstall is completed, click OK.
 Chapter 5.  Novell NetWare operating system support  53



 

 54 IBM® FAStT Storage Manager Version 7.10 for Novell NetWare and Red Hat Linux: Installation and Support Guide  



Chapter 6.  Installing software in a standard configuration
(Red Hat Linux)

This chapter describes how to install the storage-management software in a standard 
(noncluster) configuration in a Red Hat Linux operating-system environment.

Important: Always check for a README file on any installation media. This README 
file might contain important information that was not available when this Installation 
and Support Guide was written. 

To ensure proper installation, make sure you have read the entire contents of Chapter 
1, “Introduction,” on page 1, including all supporting documentation. In addition, you 
must complete all preparation tasks described in Chapter 2, “Preparing for 
installation,” on page 17.

Pre-installation process
There are two configurations in which you can install the storage-management 
software:

• You do not have existing storage subsystems. In this situation, you are installing 
new storage subsystems with machine type 3526, 3542, or 3552 controllers using 
firmware version 04.01.xx and will manage these new storage subsystems using 
Storage Manager 7.10. For this configuration, go to “New-installation process” on 
page 56.

• You have existing storage subsystems with machine type 3526, 3542, or 3552 
controllers. In this situation, you can do one of the following:

— Upgrade the controller firmware on the existing storage subsystems to 
version 04.01.xx and manage them with Storage Manager 7.10.

— If you have firmware version 3.01.x, continue to manage the existing storage 
subsystems with version 6.22 of the storage-management software and 
manage with new storage subsystems with Storage Manager 7.10.

— Manage the storage subsystem with the Storage Manager 7.10 at controller 
firmware version 4.00.x. 

Use Table 15 to determine an installation process.

Table 15. Determining your installation process in a standard configuration. 

Current environment Planned environment Action

No existing storage 
subsystems

New storage subsystems with 
controllers that use version 
4.00.02 firmware managed with 
Storage Manager 7.10.

Go to “New-installation 
process” on page 56.

Manage existing storage 
subsystems attached to separate 
host computers (not in a 
coexistence environment).

Continue to use existing 
storage-management software 
to manage existing storage 
subsystems.

Note: You cannot manage 
storage subsystems 
running version 3.x 
firmware with Storage 
Manager 7.10.
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New-installation process
Begin the installation of the storage-management software with “Installing the Storage 
Manager 7 client package on a Linux platform” on page 57. Continue the process until 
you have completed “Installing the IBM Host Adapter (HA) device driver (QLa2x00)” 
on page 58. 

Figure 17 on page 57 shows a flowchart of the installation process. 

Existing storage 
subsystems with 
controllers that have 
firmware versions 
4.00.00 through 
4.00.01 and storage- 
management software 
version 7.00 or 7.01 
(machine types 3526 
and 3552)

Upgrade storage subsystems with 
controllers that will use version 
4.00.02 firmware managed with 
Storage Manager 7.10.

1. Uninstall storage-
management software 
version 7.0 or 7.01 using 
the procedures in the 
Installation Guide for the 
previous version of the 
storage-management 
software.

2. Go to “New-installation 
process”.

3. Update the NVSRAM and 
firmware to version 4.00.02 
using the storage-
management software 
online help. 

Continue to use controller 
firmware versions 4.00.00 through 
4.00.01. (Be sure to uninstall 
previous versions of the storage-
management software before 
installing version 7.10.) 

You can manage these existing 
storage subsystems with Storage 
Manager 7.10, which includes 
components that are compatible 
with firmware versions 4.00.00 
through 4.00.01. The functional 
differences between the existing 
controller firmware and controller 
firmware 4.00.02 is provided on 
the installation CD. Refer to the 
README file located in the \linux\ 
directory on the installation CD for 
more information.

1. Uninstall storage-
management software 
version 7.0 or 7.01 using 
the procedures in the 
Installation Guide for the 
previous version of the 
storage-management 
software.

2. Go to “New-installation 
process”.

Table 15. Determining your installation process in a standard configuration. 

Current environment Planned environment Action
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Figure 17. Installation process

Installing with existing storage subsystems
Begin this installation with “Installing the Storage Manager 7 client package on a Linux 
platform”. Continue the process until you have completed “Installing the IBM Host 
Adapter (HA) device driver (QLa2x00)” on page 58.

Installing the Storage Manager 7 client package on a Linux platform
Use the procedure in this section to install the client software on a Linux management 
station, host, or cluster server attached to the storage subsystem.

Installation instructions
Before you install the software, make sure that:

• The management station has at least 80 MB of available disk space on /tmp and 
40 MB of available disk space on /opt.

• The display properties are set to a minimum screen resolution of 800 x 600 pixels 
and a palette of 256 colors or more.

• You close all other programs.

Attention: To avoid system problems, do not install any of the storage-
management components on a second Linux management station until instructed 
to do so in the installation procedures.

To install the SM7client package:

1. Insert the IBM FAStT Storage Manager version 7.10 installation CD into the CD-
ROM drive.

2. Mount the CD-ROM by typing:

mount /mnt/cdrom

and press Enter.

3. Type:

cd /mnt/cdrom

Install the Storage Manager 7 client
(SM7client) software package

Go to  Chapter 7, completing the installation

Install the IBM Host Adapter (HA) device
driver ( QLa2x00)

Install the IBM Management Suite Java
agent (FAStT MSJ)
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and press Enter.

4. Go to /Redhat71/SM7client folder.

5. Type:

rpm -ivh SM7client-Linux-0710G506.rpm

and press Enter.

Verifying the Storage Manager 7 client installation
Use the following procedure to verify that the installation was successful:

1. At the system prompt, type the following and press Enter:

rpm -qi SM7client

The verification process displays a message that describes the SM7client 
software, including version numbers, copyright license, installation time, and 
general software package description.

If no failure is reported, go to step 2. If the verification reports a failure, repeat 
steps 1 through 5 of the installation procedure.

2. Continue the installation with “Installing IBM FAStT Management Suite Java”. 

Installing IBM FAStT Management Suite Java 
The IBM FAStT Management Suite Java (FAStT MSJ) software includes the FAStT 
GUI device driver that is required for failover support. You can use the GUI to 
configure LUNs, storage, and failover.

Note: For additional information, refer to the online Help.

Perform the following steps to install IBM FAStT Management Suite Java:

1. Insert the IBM FAStT Storage Manager installation CD into the CD-ROM Drive.

2. From the X-windows GUI, open a command window.

3. Select the \Redhat71 directory.

4. Run the installer for FAStT MSJ, At the prompt, type:

sh FAStTMSJ_installation.bin

The Introduction window opens.

5. Click Next.

6. Restart your Linux server.

For configuration information, refer to the IBM FAStT MSJ User’s Guide. Continue with 
“Installing the IBM Host Adapter (HA) device driver (QLa2x00)”.

Installing the IBM Host Adapter (HA) device driver (QLa2x00)
The IBM Host Adapter device driver enables the operating system to communicate 
with the host adapter. The IBM FAStT Host Adapter is a high-performance, direct 
memory access (DMA), bus-master, host adapter designed for high-end systems. The 
IBM FAStT host adapter supports all Fibre Channel (FC) peripheral devices that 
support private-loop direct attach (PLDA) and fabric-loop attach (FLA). Refer to the 
IBM FAStT Host Adapter Installation and User’s Guide and the 
http://www.ibm.com/pc/support IBM Web page for the current README file and latest 
multipath I/O device driver installation and configuration information.
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Chapter 7.  Completing the software installation
(Red Hat Linux)

This chapter contains procedures for starting Enterprise Management and Subsystem 
Management and for completing the installation tasks.

Starting the Enterprise Management window
The Enterprise Management window is the first window that opens when you start the 
software. Use the Enterprise Management window to do the following:

• Add and discover the storage subsystems that you want to manage.

• Provide a comprehensive view of all storage subsystems in your management 
domain.

• Perform batch storage-subsystem management tasks using the Script Editor.

Use the following procedure to start the Enterprise Management window:

1. At the command prompt, Type:

SM7client

Note: If /opt/SM7client is not contained in the path environment, the full path 
name is required on the command line: 

/opt/SM7client/SM7client

 

The client software starts and the Enterprise Management window and the 
Confirm Initial Automatic Discovery dialog box displays, as shown in Figure 18.

Figure 18. Confirm Initial Automatic Discovery dialog box

Note: Open the Enterprise Management window. The Enterprise Management 
window can take several minutes to open. No wait cursor (such as an 
hourglass) is displayed.

If you do not want to perform the initial automatic discovery, click No. You 
can use the Edit → Add Device menu option to add hosts and storage 
subsystems. For more information, see “Adding devices” on page 62.
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2. Click Yes to begin an initial automatic discovery of hosts and storage subsystems 
that are attached to the local subnetwork where the management station is 
installed.

The software sends a broadcast message across the local subnetwork where the 
management station is installed. It discovers host-agent managed storage 
subsystems when the hosts that provide network management connections to the 
storage subsystems respond to the broadcast. The software discovers directly 
managed storage subsystems when the controllers in those storage subsystems 
respond to the broadcast message.

Note: It can take up to a minute for the Enterprise Management window to refresh 
after an initial automatic discovery. 

To stop the automatic discovery operation, close the Enterprise Management window.

When the initial automatic discovery is complete, all hosts and storage subsystems 
that are attached to the local subnetwork are displayed, as shown in Figure 19. 

Figure 19. Enterprise Management window

If all hosts and storage subsystems are not displayed: 

• Check the hardware and connections for possible problems (refer to the hardware 
documentation for specific procedures).

• Refer to the discovering storage subsystems Enterprise Management Help topic.

• Make sure that the missing device is on the local subnetwork. If it is not, you must 
use the Add Device option.

Note: If any device shows a status of Unresponsive, use the software to remove the 
device from the management domain and then add it again. Refer to the 
Enterprise Management online Help for instructions on removing and adding 
devices.

A storage subsystem might be duplicated in the device tree after an automatic 
discovery. In this case, you can remove the duplicate storage management icon from 
the device tree using the Remove Device option in the Enterprise Management 
window.

Continue with “Renaming storage subsystems” on page 61.
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Renaming storage subsystems
When starting Storage Manager 7.10 for the first time, the storage subsystems are 
unnamed. You must use the Subsystem Management window to rename each 
storage subsystem to the name that you want. Refer to the names that you entered in 
the information record using Table 17 on page 71. Then, refer to the renaming storage 
subsystems topic in the Subsystem Management online Help, which provides detailed 
instructions for renaming storage subsystems.

Downloading firmware and NVSRAM
Important: You must download firmware version 04.01.xx before you download 
NVSRAM.

To download firmware version 04.01.xx, do the following:

1. Open the Subsystem Management window. 

2. Click Storage Subsystem → Download → Firmware.

Follow the online instructions.

To download NVSRAM, do the following:

1. Open the Subsystem Management window. 

2. Click Storage Subsystem → Download → NVSRAM.

Follow the online instructions.

3. Continue with “Creating arrays and logical drives”.

Creating arrays and logical drives
To create an array or logical drive, perform the following procedure:

1. Create all of your planned arrays and logical drives on this storage subsystem by 
clicking the Configure → Create Array/Logical Drive.

2. Repeat the arrays/logical drive configuration for each storage subsystem 
connected to your cluster.

Note: If you make any other logical drive additions or deletions, you must make 
them known to node 02 in a cluster configuration.

3. Continue with “Changing host type”.

Changing host type
The access logical drive must be deleted from the Linux storage partition in order for 
the multipath I/O driver to be configured properly. The LUNs must also be numbered 
consecutively starting with 0-31. If you have partitioning enabled, do the following to 
check or change your host type:

1. From the Subsystem Management window left pane, select your host.

2. From the Subsystem Management window, select Configure → View Logical 
LUN Mapping.

3. From the Subsystem Management window left pane, select the host port you 
want to configure, and from the tool bar, click Configure → Topology → Change 
Host Type.
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If you do not have partitioning enabled, do the following to check or change your host 
type:

Note: Partitioning is a premium feature. If you disable partitioning, you will have to 
contact your IBM technical-support representative to obtain a key to enable 
partitioning.

1. From the Subsystem Management window, select your host in the left pane.

2. Click Configure → Change Host Type.

3. Continue with “Heterogeneous hosts overview”.

Heterogeneous hosts overview
The heterogeneous hosts feature enables hosts running different operating systems 
to access a single storage subsystem. Previous releases of IBM FAStT Storage 
Manager did not have this feature. 

Host computers accessing a single storage subsystem can now run completely 
different operating systems (for example, NetWare and Linux). When a host type is 
specified in the Define New Host Port window, the heterogeneous hosts feature 
enables the controllers in the storage subsystem to tailor their behavior (such as LUN 
reporting and error conditions) to the needs of the host operating system of the host 
sending the information. 

Important: The heterogeneous hosts feature is available only with storage 
partitioning enabled.

In a heterogeneous environment, you must set each host type to the appropriate 
operating system during host-port definition so that the firmware on each controller 
can respond correctly for the operating system for that host.

To start the heterogeneous host configuration, do the following:

1. From the Subsystem Management window, click Configure → Storage 
Partition.

2. Refer to the Subsystem Management window online help.

3. Continue with “Adding devices”.

Adding devices
You can add more hosts or storage subsystems outside the local subnetwork. For 
more information about this option, refer to the Enterprise Management window online 
Help.

To monitor the condition of storage subsystems in your management domain, you 
must start Enterprise Management. For more information about monitoring storage 
subsystems, refer to the Enterprise Management online Help. 

Continue with “Setting up alert notifications”.

Setting up alert notifications
After you add devices to the management domain, set up alert notification options to 
report critical events on the storage subsystems. The following options are available 
for alert notification:
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• Notification to a designated network management station (NMS) using Simple 
Network Management Protocol (SNMP) traps. (See “Setting up the NMS for 
SNMP notification” for more information.)

• Notification to designated e-mail addresses

• Notification to designated alphanumeric pagers (when a vendor software package 
is used to convert e-mail messages)

Note: The Enterprise Management Window must remain open to monitor the 
condition of storage subsystems that are included in your management 
domain. If you close this window, you will not receive alert notifications. Refer 
to the Enterprise Management online Help or Understanding Storage Manager 
Concepts Guide for Version 7.10 for more information on alert notification 
options.

 Continue with “Setting up the NMS for SNMP notification”.

Setting up the NMS for SNMP notification
If you choose to set up alert notification using SNMP traps, you must first copy a 
management information base (MIB) file to the designated network management 
station. Use this procedure to set up the MIB file on the network management station.

Important: You need to designate NMS only once.

1. From the \SM7mib directory on the FAStT Storage Manager Installation CD, copy 
the Arrayman.mib file to the network management station.

2. Follow the steps that are required by your specific network management station to 
compile the MIB file.

Note: For details on the required steps, see your network administrator or the 
documentation that is specific to the NMS product that you are using.

3. Continue with “Configuring alert destinations”.

Configuring alert destinations
Configure SNMP trap destinations and e-mail destinations for alert notifications using 
Enterprise Management. Refer to the Enterprise Management online Help for specific 
procedures.

Starting Subsystem Management
The Subsystem Management window enables you to manage selected subsystems.

Use the following procedure to open a subsystem management window for a selected 
storage subsystem:

1. In the Enterprise Management window, select a storage subsystem.

2. Click Tools → Manage Device.

The software displays the Subsystem Management window for the selected 
storage subsystem, as shown in Figure 20 and Figure 21 on page 64.

Note: Using the open Subsystem Management window, you can manage only 
the selected storage subsystem. However, you can open multiple 
subsystem-management windows to manage other storage subsystems.
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Figure 20. Subsystem Management window (machine types 3526 and 3552)

Figure 21. Subsystem Management window (machine type 3542)

Continue with “Performing other storage-subsystem management tasks”.

Performing other storage-subsystem management tasks
You can perform the following storage-subsystem management tasks:

• Download controller firmware

• Download controller NVSRAM

• Locate a storage subsystem

• View a storage subsystem profile

• Type or change a storage subsystem password

• Create and manage logical drives and arrays

• Use the Performance Monitor

• Create storage partitions (if applicable)

Note: To create storage partitions, you must obtain the worldwide name or port name 
of each host adapter in each host that is connected to the storage subsystem.
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For more information about these and other storage-subsystem management tasks, 
refer to the appropriate topics in the Subsystem Management online Help.

Continue with “Applying NVSRAM configuration scripts”.

Applying NVSRAM configuration scripts
You might need to run scripts to modify configuration settings that are stored in 
NVSRAM on each storage subsystem managed with Storage Manager 7.10.

Use the following procedure to modify the configuration settings:

1. Insert the FAStT Storage Management Installation CD into the CD-ROM drive on 
the management station.

2. Go to the \SM7scripts directory and read the README file in that directory.

3. In the Enterprise Management window, select a storage subsystem; then click 
Tools → Execute Script. 

Use the following procedure to run the scripts for your configuration:

1. To run a script file, click File → Load Script.

The Load Script window opens.

2. Select the appropriate script from the SM7scripts directory on the 
installation CD.

3. Click Open to load the script.

4. Click Tools → Execute. Wait until the Script Execution Complete message is 
displayed.

5. Repeat the procedures in steps 2 through 4 for each storage subsystem that you 
are managing with the storage-management software.

Note: For more information refer to the README file.
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Chapter 8.  Red Hat Linux operating-system support

This chapter contains information that is related to operating the storage-management 
software in a Red Hat Linux environment.

Number of supported logical drives
The supported logical drive limits are as follows:

• When using Linux Storage Management Services (SMS) you can configure up to 
128 LUNs, or the maximum for the host adapter model.

• Host adapters support a specific number of logical drives. Refer to the host-
adapter documentation for specific information.

Red Hat Linux limitations
Important: Always check for a README file on any installation media. This README 
file might contain important information that was not available when this Installation 
and Support Guide was prepared.

Table 16 explains the limitations that apply when you use the FAStT Storage Manager 
Version 7.10 in a Red Hat Linux operating system environment.

Table 16. Red Hat Linux limitations and workarounds. 

Limitation Workaround

Vixel Rapport 2000 Fibre Channel hubs using 
controllers with firmware version 4.00.02 
cause problems, including data corruption, 
system instability, and disrupted loop activity.

Do not use Vixel Rapport 2000 Fibre Channel 
hubs when your system is operating in a 
controller or an I/O path fault-tolerant 
environment. 

The drive space capacity for a single logical 
drive group is limited. For example, if 
configuring seventy-three, 4 GB drives, the 
maximum number of drives that can be 
configured in a single logical drive group is 
29. 

None.

After removing all drives from a storage 
subsystem, you will be prompted for a 
password at software startup or when you 
perform protected operations, all passwords 
you enter will fail.

Password information is stored on a reserved 
sector of each storage subsystem logical 
drive. Each drive stores a mirrored copy of 
the password data. When the storage-
management software does not detect 
password data when you attempt password-
protected operations, add one of the drives to 
the storage subsystem and reattempt the 
operation. 

Removing a set of drives that are configured 
with logical drives from one storage 
subsystem for insertion into another storage 
subsystem, is not supported because it could 
cause loss of configuration.

Call for service.

A standard non-network configuration is not 
supported when the Linux host does not have 
the TCP/IP software installed.

Install the TCP/IP software on the Linux host 
computer and assign the host a static IP 
address.

Multipath failover will work if the storage 
controllers are in only active/active mode.

When you configure the storage subsystem, 
change both controllers to active status.
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Creating logical drives
A logical drive is a logical object that is the basic structure that you create to store 
data on the storage subsystem. A logical drive is configured for an array with a 
specific RAID level to meet application needs for data availability and Fibre Channel 
I/O performance. A logical drive is recognized by the operating system as one drive. 

Important: Before mounting a logical drive, make sure that you have the correct 
hardware path.

When you create new logical drives with the storage-management software, you must 
add the new logical drives to Linux. Refer to the Linux documentation for details about 
adding a drive. Remember that each logical drive (not array) is recognized by Linux as 
one drive. 

When you configure a new storage 
subsystem with a single controller, you must 
place the controller in slot A.

The controller firmware does not recognize or 
communicate with a single controller until slot 
A is populated. This restriction does not apply 
to storage subsystems that were originally 
configured with two controllers.

Automatic redistribution of LUNs/arrays is not 
supported. If a controller fails over the 
storage subsystems to the alternate 
controller and the failed controller is replaced 
and brought back online, then the storage 
subsystems do not automatically transfer to 
the preferred controller.

This must be done manually by redistributing 
storage arrays.

Your windows and online Help will display a 
brownish hash pattern when you run in 256 
color mode.

Run the Storage Manager 7.10 application in 
a higher display mode.

When performing a redundancy check (parity 
scan) from the storage-management 
application, machine type 3542 can take 
several minutes longer than machine type 
3526 and 3552 controller platforms.

None.

When attempting to manage a storage 
subsystem where the RAID controller unit 
does not have access to logical drives, 
Storage Manager 7.10 will prompt you for a 
password. This will occur even if no password 
has been set up. The automatic discovery will 
locate and identify each storage subsystem 
as two separate storage subsystems.

Ensure that at least one IBM FAStT EXP500 
Expansion Unit with at least one logical drive 
is properly attached to the IBM FAStT500 
RAID Controller Unit in each storage 
subsystem being managed. Since the RAID 
controller unit should not be powered on until 
the expansion units are attached and 
powered on, this should be done by powering 
off the RAID controller unit, properly attaching 
all expansion units with the drives installed, to 
the RAID controller unit and powering them 
on, and then powering the RAID controller 
unit back on. At this point the storage 
subsystems can be re-discovered and 
managed using the FAStT Storage Manager 
software.

You might not see the maximum number of 
drives during Automatic Configuration if you 
are using drives of different capacities.

Use Manual Configuration to select individual 
drives and select the maximum number of 
drives allowed.

Table 16. Red Hat Linux limitations and workarounds. 

Limitation Workaround
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Uninstalling storage-management software components
Use the following procedure if you need to uninstall the Storage Manager 7 client 
component of Storage Manager 7.10. You must have root or equivalent privileges to 
remove this component. 

Note: The uninstall process will not remove the emwdata.bin or emwback.bin 
configuration files that are created by the SM7client. Reinstalling the SM7client 
will not overwrite these files.

Use the following procedure to uninstall the SM7client:

1. At the command prompt, type:

rpm -e SM7client

2. Press Enter.

To uninstall the FAStT MSJ, refer to the IBM FAStT MSJ User’s Guide.
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Appendix A.   Storage subsystem/controller information record

Table 17 provides a data sheet on which you can record storage subsystem names, 
management types, hardware Ethernet addresses, and IP addresses. Make a copy of 
this table and complete the information for your storage subsystems and controllers. 
Use the information that is recorded in Table 17 to set up the BOOTP table for the 
network server and the host or Domain Name System (DNS) table. The information in 
Table 17 will help you add storage subsystems after your initial installation. The 
column headings show a page reference for detailed instructions about obtaining the 
information. For a sample information record, refer to “Reviewing a sample network” 
on page 18.

Table 17. Storage subsystem information record and controller information record. 

Storage 
subsystem name
(refer to page 21)

Management 
type (refer to 

page 17)

Controllers—Ethernet and IP 
addresses, and host name
(refer to pages 21 and 23)

Host—IP 
address and 
host name

(refer to page 
23)
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Appendix B.   Getting information, help, and service

If you need help, service, or technical assistance or just want more information about 
IBM products, you will find a wide variety of sources available from IBM to assist you. 
This section contains information about where to go for additional information about 
IBM and IBM products, what to do if you experience a problem with your computer, 
and whom to call for service should it be necessary.

Getting information
Information about your IBM server product and preinstalled software, if any, is 
available in the documentation that comes with your server. That documentation 
includes printed books, online books, README files, and help files. In addition, 
information about IBM products is available on the World Wide Web and through the 
IBM Automated Fax System.

Using the World Wide Web
On the World Wide Web, the IBM Web page has up-to-date information about IBM 
products and support. The address for the IBM Personal Computing home page is 
http://www.ibm.com/pc/.

You can find support information for your IBM products at 
http://www.ibm.com/pc/support/.

If you click Profile from the support page, you can create a customized support page 
that is specific to your hardware, complete with Frequently Asked Questions, Parts 
Information, Technical Hints and Tips, and Downloadable Files. In addition, you can 
choose to receive e-mail notifications whenever new information becomes available 
about your registered products.

You also can order publications through the IBM Publications Ordering System at 
http://www.elink.ibmlink.ibm.com/public/applications/publications/cgibin/pbi.cgi.

Getting information by fax
If you have a touch-tone telephone and access to a fax machine, in the U.S. and 
Canada, you can receive, by fax, marketing and technical information on many topics, 
including hardware, operating systems, and local area networks (LANs).

You can call the IBM Automated Fax System 24 hours a day, 7 days a week. Follow 
the recorded instructions, and the requested information will be sent to your fax 
machine. In the U.S. and Canada, to access the IBM Automated Fax System, call 1-
800-426-3395.

Getting help and service

If you have a problem with your server product you will find a wide variety of sources 
available to help you.

Using the documentation and diagnostic programs
Many problems can be solved without outside assistance. If you experience a problem 
with your server product, the first place to start is the troubleshooting information in 
your IBM documentation. If you suspect a software problem, see the documentation, 
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including README files and online help, that comes with the operating system or 
application program.

Most IBM server products come with a set of diagnostic programs that you can use to 
help you identify hardware problems. See the troubleshooting information in your IBM 
documentation for instructions on using the diagnostic programs.

The troubleshooting information or the diagnostic programs might tell you that you 
need additional or updated device drivers or other software. IBM maintains pages on 
the World Wide Web where you can get the latest technical information and download 
device drivers and updates. To access these pages, go to 
http://www.ibm.com/pc/support/ and follow the instructions.

Calling for service
If you have tried to correct the problem yourself and still need help, during the 
warranty period, you can get help and information by telephone through the IBM 
HelpCenter®. The following services are available during the warranty period:

• Problem determination - Trained personnel are available to assist you with 
determining if you have a hardware problem and deciding what action is 
necessary to fix the problem.

• IBM hardware repair - If the problem is determined to be caused by IBM 
hardware under warranty, trained service personnel are available to provide the 
applicable level of service.

• Engineering Change management - Occasionally, there might be changes that 
are required after a product has been sold. IBM or your reseller, if authorized by 
IBM, will make selected Engineering Changes (ECs) available that apply to your 
hardware.

The following items are not covered:

• Replacement or use of non-IBM parts or nonwarranted IBM parts. All warranted 
parts contain a 7-character identification in the format IBM FRU XXXXXXX.

• Identification of software problem sources.
• Configuration of BIOS as part of an installation or upgrade.
• Changes, modifications, or upgrades to device drivers.
• Installation and maintenance of network operating systems (NOS).
• Installation and maintenance of application programs.

Refer to your IBM hardware warranty for a full explanation of IBM warranty terms. Be 
sure to retain your proof of purchase to obtain warranty service.

In the U.S. and Canada, these services are available 24 hours a day, 7 days a week. 
In the U.K., these services are available Monday through Friday, from 9:00 a.m. to 
6:00 p.m. 

Note: Response time will vary depending on the number and complexity of incoming 
calls.

Please have the following information ready when you call: 

• Machine type and model
• Serial numbers of your IBM hardware products
• Description of the problem
• Exact wording of any error messages
• Hardware and software configuration information

Phone numbers are subject to change without notice. For the most up-to-date phone 
numbers, go to http://www.ibm.com/pc/support/ and click Support Phone List.
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In all other countries, contact your IBM reseller or IBM marketing representative.

Purchasing additional services
During and after the warranty period, you can purchase additional services, such as 
support for IBM and non-IBM hardware, operating systems, and application programs; 
network setup and configuration; upgraded or extended hardware repair services; and 
custom installations. Service availability and service name might vary by country.

For more information about these services, contact your IBM marketing 
representative.

Country Telephone number

Austria Österreich 01-24 592 5901

Belgium - Dutch Belgie 02-210 9820

Belgium - French Belgique 02-210 9800

Canada Toronto only 416-383-3344

Canada Canada - all other 1-800-565-3344

Denmark Danmark 45 20 82 00

Finland Suomi 09-22 931 840

France France 02 38 55 74 50

Germany Deutschland 07032-1549 201

Ireland Ireland 01-815 9202

Italy Italia 02-482 9202

Luxembourg Luxembourg 298-977 5063

Netherlands Nederland 020-514 5770

Norway Norge 23 05 32 40

Portugal Portugal 21-791 51 47

Spain España 91-662 49 16

Sweden Sverige 08-477 4420

Switzerland Schweiz/Suisse/Svizzera 0848-80 52 52

United Kingdom United Kingdom 01475-555 055

U.S.A. and Puerto Rico U.S.A. and Puerto Rico 1-800-772-2227
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Appendix C.   Notices

This publication was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in 
other countries. Consult your local IBM representative for information on the products 
and services currently available in your area. Any reference to an IBM product, 
program, or service is not intended to state or imply that only that IBM product, 
program, or service may be used. Any functionally equivalent product, program, or 
service that does not infringe any IBM intellectual property right may be used instead. 
However, it is the user’s responsibility to evaluate and verify the operation of any non-
IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter 
described in this document. The furnishing of this document does not give you any 
license to these patents. You can send license inquiries, in writing, to: 

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY  10504-1785
U.S.A.

The following paragraph does not apply to the United Kingdom or any country 
where such provisions are inconsistent with local law: INTERNATIONAL 
BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS" 
WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, 
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-
INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR 
PURPOSE. Some states do not allow disclaimer of express or implied warranties in 
certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. 
Changes are periodically made to the information herein; these changes will be 
incorporated in new editions of the publication. IBM may make improvements and/or 
changes in the product(s) and/or the program(s) described in this publication at any 
time without notice.

Any references in this publication to non-IBM Web sites are provided for convenience 
only and do not in any manner serve as an endorsement of those Web sites. The 
materials at those Web sites are not part of the materials for this IBM product, and use 
of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes 
appropriate without incurring any obligation to you.

Some software may differ from its retail version (if available), and may not include 
user manuals or all program functionality.

Edition notice
© COPYRIGHT INTERNATIONAL BUSINESS MACHINES CORPORATION, 2000, 
2001.  All rights reserved.  

Note to U.S. Government Users — Documentation related to restricted rights — Use, 
duplication or disclosure is subject to restrictions set forth in GSA ADP Schedule 
Contract with IBM Corp.
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Processing date data
This IBM hardware product and IBM software products that might be packaged with it 
have been designed, when used in accordance with their associated documentation, 
to process date data correctly within and between the 20th and 21st centuries, 
provided all other products (for example, software, hardware, and firmware) used with 
these products properly exchange accurate date data with them.

IBM cannot take responsibility for the date data processing capabilities of non-IBM 
products, even if those products are preinstalled or otherwise distributed by IBM. You 
should contact the vendors responsible for those products directly to determine the 
capabilities of their products and update them if needed. This IBM hardware product 
cannot prevent errors that might occur if software, upgrades, or peripheral devices 
you use or exchange data with do not process date data correctly. 

The foregoing is a Year 2000 Readiness Disclosure.

Trademarks

The following terms are trademarks of the IBM Corporation in the United States, other 
countries, or both:

HelpCenter

IBM

Netfinity

Intel and Pentium are trademarks of Intel Corporation in the United States, other 
countries, or both.

Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation in the 
United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other 
countries.

Java and all Java-based trademarks and logos are trademarks or registered 
trademarks of Sun Microsystems, Inc. in the United States, other countries, or both.

Other company, product, and service names may be trademarks or service marks of 
others.
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