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Chapter  1.  Installing  and  running  ServeRAID  Manager  

This chapter provides installation instructions for the IBM® ServeRAID™ Manager 

program, and provides an overview of the software features and navigation tools. 

For detailed instructions about how to use the ServeRAID Manager program to 

manage the storage subsystem, see the online help. 

System Requirements 

This section lists the system requirements for the management station and the 

client computer. 

Management station system requirements 

To successfully install and run the ServeRAID Manager program on a management 

station, you need: 

v   A computer with an Intel™-compatible 500 MHz processor (IA32, AMD32, or 

AMD64) 

v   256 MB RAM 

v   35 MB hard disk drive space 

v   Microsoft® Windows® Advanced Server 2003, Windows XP, or Windows 2000

Client computer system requirements 

To successfully install and run the ServeRAID Manager program on a client 

computer, you need: 

v   A computer with an Intel-compatible 500 MHz processor (IA32, AMD32, or 

AMD64) 

v   256 MB RAM 

v   35 MB hard disk drive space 

v   256 color video mode

On client computers, the ServeRAID Manager program is supported on operating 

systems, including Microsoft Windows, Linux, Novell Netware, UnixWare, or 

OpenServer. 

Note: When installing the ServeRAID Manager program on client computers, see 

the operating-system-specific readme files on the IBM ServeRAID Manager 

Application CD for a list of supported operating systems and other 

operating-system-specific information. 
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Updating the registry information for the host computer 

If the DS300 storage subsystem configuration supports dual controllers, you must 

perform the following procedure on each host computer if the host computer is 

connected to one of the DS300 data ports, and is running Microsoft Windows 2000 

or Microsoft Windows 2003. You must perform this procedure after each time you 

load or update the Microsoft iSCSI software initiator onto a host computer. 

To update the registry information, complete the following steps: 

 1.   Create an Emergency Repair diskette for the system using the instructions in 

the operating system online help. 

 2.   Click Start → Run. 

 3.   In the Run window, type regedt32 and click OK. 

 4.   In the Registry Editor window, double-click HKEY_LOCAL_MACHINE to 

expand the tree. 

 5.   Expand the SYSTEM tree. 

 6.   Expand the ControlSet001 tree. 

 7.   Expand the Control tree. 

 8.   Expand the Class tree. 

 9.   Double-click the Globally Unique Identifier (GUID) that contains the legacy 

information option of SCSI. GUIDs are in the form {4D36E97B-E325-11CE-
BFC1-08002BE10318}. 

10.   Click the Parameters key 0000. 

11.   Change the value for the MAXRequestHoldTime from 60 to120: 

a.   In the right pane, double-click MaxRequestHoldTime. 

b.   In the String Editor window, change the value from 3c in hex to 78 in hex. 

c.   Click OK.

12.   Close the Registry Editor window.

Installing the ServeRAID Manager program 

This section provides instructions for installing the ServeRAID Manager program on 

systems running a Microsoft Windows operating system. To install the ServeRAID 

Manager program on client computers running operating systems other than 

Windows, see the operating-system-specific readme files on the IBM ServeRAID 

Manager Application CD for installation instructions. 

Note: You need administrator privileges to install the ServeRAID Manager program. 

To install the ServeRAID Manager program, complete the following steps: 

1.   Insert the installation CD and wait for the Autorun executable to start the 

installation. If this does not occur, browse the CD and click Autorun. 

2.   When the installation wizard opens, click Next. 

3.   Read and accept the terms of the license agreement; then, click Next. 

4.   Click Next to accept the default installation setup. Alternatively, use the menus 

to select the ServeRAID components that you want to install, then click Next. 

5.   Create a user name and a password for the management station. 

This is the user name and password that you will use to log into the 

management station. 

6.   Click Add User; then, click Next. 
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7.   Click Install. 

The installation wizard installs the software. This might take a few minutes to 

complete. 

8.   When the installation is complete, click Finish.

Getting started 

This section explains how to begin using the ServeRAID Manager program. 

Running ServeRAID Manager 

Note: You need administrator privileges to run ServeRAID Manager. 

To run ServeRAID Manager as a standalone application, click Start → Programs → 

ServeRAID Manager → ServeRAID Manager. 

For an introduction to ServeRAID Manager features, see “Navigating ServeRAID 

Manager” on page 4. 

Adding a management station agent 

When you log in for the first time, you must add the management station before you 

can begin to set up your network storage. 

The management station agent is a monitoring agent for network storage. After you 

add an agent to a management station, you can monitor and configure the attached 

storage enclosures from a ServeRAID Manager console. 

To add a management station agent, complete the following steps: 

1.   In the Enterprise view, right-click the icon for the Networked storage and select 

Add management station, as shown in the following illustration. 

 

The Add management station window opens. 

2.   In the Type field, select Management station. 

3.   Enter the host name or TCP/IP address of the management station computer. 

4.   Enter the management station user name and password, as they were defined 

during the ServeRAID Manager installation. (In “Installing the ServeRAID 

Manager program” on page 2, see step 5 on page 2.) 

5.   Select Save user name/password. 

6.   Click Connect. 

The management station agent is added.

  

Figure 1. Adding a management station
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Removing a management station agent 

To remove a management station agent, complete the following steps: 

1.   In the Enterprise view, right-click Networked storage, select Remove 

management station; then, select the management station to be removed. 

2.   Click Yes. 

The management station agent is removed.

Adding the storage subsystem to the management station 

To add the storage subsystem to the management station, complete the following 

steps: 

1.   In the Enterprise view, right-click the management station in the Networked 

storage tree and select Add agent. 

2.   Type the host name or TCP/IP address for one of the storage subsystem 

management ports. 

3.   Enter the administrator password for the storage subsystem. 

Note: The administrator password is created when the storage subsystem is 

installed on the network. It is not the same as the management station 

password. 

4.   Click Add. 

The storage subsystem is added to the management station in the Enterprise 

view Networked storage tree.

For more information about configuring the storage subsystem and building the 

network storage, see the ServeRAID Manager help. 

Navigating ServeRAID Manager 

ServeRAID Manager provides an expandable tree view, or Enterprise view (shown 

in Figure 2) that shows the systems and controllers you are managing. The 

Networked storage section of the tree is for management stations with 

network-attached storage enclosures. 

 

 You can perform most configuration and management tasks by selecting a controller 

or enclosure from the tree and working with related objects in the Physical and 

Logical device views (shown in Figure 3 on page 5). 

  

Figure 2. Enterprise view
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Figure 3 shows how ServeRAID Manager displays the Physical and Logical device 

views, which show the physical devices and logical devices that are connected to 

the controller or enclosure. 

 

 The Physical devices view (on the left in Figure 3) displays information about the 

drives, enclosures, and other devices attached to the controller. The devices are 

shown organized by the channel or port they are connected to and shown in 

numerical order. The information for each channel or port includes the maximum 

speed capability, the number of the channel on the controller, and the number of 

devices attached to the controller. 

The Logical devices view (on the right in Figure 3) displays information about the 

arrays and logical drives created using the physical devices. This information 

includes the number of arrays and logical drives, the RAID level of each device, 

and whether a logical drive is protected by a hot spare drive. 

In the Physical devices and Logical devices views, you can: 

v   Collapse or expand a view to see more information about arrays, logical devices, 

and physical devices. 

v   Change how drives are displayed (see “Changing how drives are displayed” on 

page 6). 

v   Identify components of a logical device (see “Viewing related components” on 

page 6).

Physical devices view 

The Physical Devices view displays physical device information in enclosure view 

format, as shown in Figure 4. Drives in the enclosure are shown in the physical 

slots they occupy with the proper vertical or horizontal orientation. Empty slots are 

shown as drive outlines. 

 

  

Figure 3. Physical and logical devices view

  

Figure 4. Physical devices view
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The indicator icons (
  

) report the status of the fan and temperature 

modules on SAF-TE (enclosure management) devices and other devices that 

monitor these conditions. 

The indicator colors are: 

v   Blue—Normal 

v   Yellow—Warning 

v   Red—Error 

v   Gray—Not applicable to the devices.

For example, the fan indicator changes to yellow when one fan fails; it changes to 

red when a second fan fails and cooling is no longer adequate. 

Logical devices view 

The Logical devices view displays information about the logical devices created 

using the physical devices, including the number of arrays and logical devices, the 

RAID level of each device, and whether a logical device is protected by a hot spare 

drive. 

You can create and delete logical devices in the Logical devices view by selecting 

the Create option and using the Create wizard. 

Changing how drives are displayed 

You can choose how information is displayed in the Physical devices view by 

clicking one of the following icons in the Logical devices view. 

 

 

 

Displays the enclosure view. This is the default view. 

 

 

Displays physical device information in text format. 

 

 

Displays physical device information in full size capacity format. A full-length bar 

is displayed for each drive, regardless of capacity. A small segment on each 

drive is reserved for the RAID signature; this area is indicated by a gray cap at 

the end of each bar. 

Note: A drive shaded in light blue is not part of any disk group. 

 

 

Displays physical device information in relative size capacity format. A 

full-length bar is displayed for the largest drive; proportionally shorter bars are 

displayed for other drives.
  

Viewing  related components 

When you click a physical or logical device in the device views, the related 

components are highlighted. 

For example, when you click an array, the associated logical drives are highlighted 

in the Logical devices view and the physical drives that are members of the array 

are highlighted in the Physical devices view, as shown in Figure 5 on page 7 and 

Figure 6 on page 7. 
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For another example, when you click a hot spare, the logical devices protected by 

that spare are highlighted, as shown in Figure 7. 

   

Finding more information 

For detailed instructions about how to use the ServeRAID Manager program to 

manage the storage subsystem, see the ServeRAID Manager help. 

  

Figure 5. Displaying the logical and physical drives of an array (single controller)

  

Figure 6. Displaying the logical and physical drives of an array (dual controllers)

  

Figure 7. Displaying logical devices protected by a spare
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Chapter  2.  Installing  firmware  

This chapter provides instructions for downloading and installing firmware on the 

storage subsystem. 

Downloading firmware 

To download a new firmware image, go to http://www.ibm.com/pc/support/; then, go 

to the page for your storage subsystem model and configuration. Follow the online 

instructions to download the file. 

Keep the default file name, and save the file to a system that is accessible by IBM 

ServeRAID Manager. 

Updating the firmware 

To update the firmware, complete the following steps: 

1.   In the Enterprise view, click the enclosure that you want to update. 

2.   Right-click Update controller images. The Software Update wizard opens. 

3.   Click Next. 

The “Select a software image” window opens. 

4.   Click Browse, select the firmware file; then, click Next. 

The “Update summary” window opens. 

5.   Review the update summary, then click Apply. 

ServeRAID Manager applies the firmware update. The progress meter shows 

the update status. When the update is complete, the progress meter 

automatically closes. 

6.   Restart the controller. (See “Restarting the controller.”)

Restarting the controller 

To restart a controller, complete the following steps: 

1.   In the Physical devices view, right-click the controller and select Restart 

enclosure. 

2.   Click Yes to confirm that you want to restart the controller. 

Note: Restarting the controller can take several minutes. Data on the controller 

is unavailable during that time.
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Chapter  3.  Configuring  a new  controller  

This chapter provides detailed instructions for configuring a new or replacement 

controller as part of the storage subsystem. 

Note: For detailed instructions about installing a RAID controller, see the IBM 

TotalStorage DS300 and DS400 Dual Controller Hardware Installation and User’s 

Guide on the IBM Documentation CD or on the IBM Support Web site. 

Getting started 

To configure a new or replacement controller, complete the following steps: 

1.   For a single-controller configuration only: If you are installing a replacement 

controller, remove (or un-cam but leave in place) the hard disk drives until you 

are told to replace them later in “Completing the controller configuration” on 

page 13. 

2.   Turn on the storage subsystem and connect to controller A through a Telnet 

session, using the default IP address 192.168.70.123. 

3.   To log in as the administrator, type ad. 

4.   Type the administrator password. By default, the password is passw0rd (all 

lowercase letters with a zero, not O, in passw0rd). 

5.   On the command line, type setup to open the Setup wizard. The Setup wizard 

helps you enter the information that is required to connect the storage 

subsystem to a local network. 

Note: After you connect to the storage subsystem for the first time, the Setup 

wizard opens automatically. 

6.   Using the Setup wizard, change the storage subsystem default configuration 

settings as required for your network. The default settings are shown in Table 1 

and Table 2. 

 Table 1. Controller A default configuration settings 

Controller A settings Default 

Hostname DS300 / DS400 

Domain Name ibm.com 

Timezone [GMT] GMT-5 

New Administrator Password passw0rd (All lowercase letters with a zero, 

not O, in passw0rd) 

Default Gateway 0.0.0.0 

DNS Servers NO 

User DHCP NO 

Management i/f IP Address 192.168.70.123 

Management i/f IP Netmask 255.255.0.0 

Management i/f Broadcast Address 192.168.255.255
  

 Table 2. Controller B default configuration settings 

Controller B settings Default 

Hostname DS300 / DS400 
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Table 2. Controller B default configuration settings (continued) 

Controller B settings Default 

Domain Name ibm.com 

Management i/f IP Address 192.168.70.124 

Management i/f IP Netmask 255.255.0.0 

Management i/f Broadcast Address 192.168.255.255
  

The Setup wizard steps you through a set of prompts. You can type the 

answers to the prompts and use the three commands that are shown in the 

following table. 

 Command Function 

Abort Quit the Setup wizard without making changes 

Back Go to the previous prompt 

Help Describe the current options
  

If a prompt has a default value, the default is displayed in square brackets [ ]. 

Some options take an arbitrary string, in which case the commands back and 

abort cannot be used. In those cases, you must enclose the response in 

double-quotation marks (“xxx”) so that your response is accepted, even if it is 

the same as a command. 

The Setup wizard prompts are described in the following list: 

hostname 

Type the name for which the system is to be known. 

 Use the special back command to repeat this prompt. 

domain name 

Type the domain in which the system belongs. 

SAN name 

Type the Storage Area Network in which the system belongs. 

timezone 

Type the system time zone. 

system Date 

Type the system date. 

define administrator password 

Define whether an administrator password is required. If a password is 

required, you are prompted for that password, which must be typed 

twice. 

 Press Ctrl to not change the password. 

 Press Enter twice to require no administrator password. 

define operator password 

Define whether an operator password is required. (For more 

information, see define administrator password.) 

dhcp Type yes or no to determine whether to use DHCP to discover the 

system network values. 

 If you type yes, the wizard takes you to the Save new configuration 

prompt (see page 13). If you type no, the wizard continues with prompts 

about the system main Ethernet interface. 
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IP address 

Type the IP address, for example, 192.193.194.195 

netmask 

Define the size of the netmask. 

 A netmask can be represented in several ways. The following examples 

all refer to the same netmask: 

 /23 The number of bits set in the network part 

255.255.254.0 The set bits displayed in the same way as an IP 

address 

0xfffffe00 The mask shown as a hexadecimal number
  

broadcast address 

Type the address to be used for broadcasts. You can use any of the 

formats described for the interface manage [interface] broadcast 

command, where [interface] is eth0, eth2, or eth3. 

default gateway 

Type the name or IP address of a router to which packets, for 

destinations that do not have routes defined for them in the system, are 

sent. Type no to clear the default gateway. 

DNS servers 

Type the IP addresses of up to three systems that will act as DNS 

servers. Type no to clear the list of DNS servers. 

save new configuration 

After the Setup wizard is finished, the system is configured but the new 

configuration is not saved immediately in nonvolatile memory. Type yes 

to save the configuration immediately, or no to defer saving the 

configuration. 

 The save command saves the configuration. 

finish? 

Type yes to apply the values you have entered, or no to return to the 

first prompt and change the values you entered. 

Note: If you changed the IP address, you must Telnet to the new IP 

address to reestablish the Telnet session.

Completing the controller configuration 

To finish the controller configuration using ServeRAID Manager, complete the 

following steps: 

1.   Start ServeRAID Manager. (For more information, see “Running ServeRAID 

Manager” on page 3.) 

2.   Add the management station agent. (For more information, see “Adding a 

management station agent” on page 3.) 

3.   Add the enclosure to the management station. (For more information, see 

“Adding the storage subsystem to the management station” on page 4.) 

4.   For a single-controller configuration only: If you have installed a 

replacement RAID controller, reinsert the hard disk drives. Wait approximately 

two minutes, then use ServeRAID Manager to scan for new or removed RDY 

drives. (For detailed instructions, see the ServeRAID Manager help.) 
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5.   For a dual-controller configuration only: See the Technical Update about 

replacing a controller that comes with the replacement controller and is available 

on the IBM Support Web site. 

6.   Configure the storage subsystem using the Configuration wizard. (For detailed 

instructions, see the ServeRAID Manager help.) 

Note: After the storage subsystem is configured, logical drives are displayed as 

physical drives to the initiator operating system. To set up the initiators, see the 

initiator documentation. 

7.   If existing arrays were associated with the RAID controller that you replaced, 

they are displayed as foreign arrays and can be imported. (For detailed 

instructions, see the ServeRAID Manager help.)
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Chapter  4.  Installing  a DS300  or  DS400  storage  subsystem  in 

a Windows  cluster  server  environment  

This chapter describes how to install a DS300 or DS400 storage subsystem in a 

Windows cluster server environment. Before you install the software, make sure 

that you have read the following information: 

v   IBM TotalStorage DS300 and DS400 Dual Controller Hardware Installation and 

User’s Guide 

v   Chapter 1, “Installing and running ServeRAID Manager,” on page 1

Important: Always check for a readme file on any installation media. A readme file 

contains important information that was not available when this document was 

written. 

For the latest storage management software and readme files for your operating 

system, go to http://www.ibm.com/servers/storage/support/disk/. 

Preinstallation tasks for an iSCSI (DS300) environment 

The procedure for installing a DS300 storage subsystem in a cluster server 

environment includes the following tasks: 

1.   Installing the Microsoft iSCSI Software Initiator software 

2.   Installing the ServeRAID Manager software 

3.   Installing the Microsoft Cluster Server software

ISCSI configuration considerations 

You can connect the DS300 storage subsystem to the cluster only using a gigabit 

Ethernet switch. Figure 8 shows an iSCSI environment using multiple switches. 

 

Gigabit
Ethernet
switch

Gigabit
Ethernet
switch

DS300

Node A Node B

Controller
B

Controller
A

NIC NICNIC NIC

Interlink
  

Figure 8. iSCSI cluster configuration
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Before connecting the DS300 to the cluster, read the following Microsoft 

requirements for iSCSI cluster support. For more information about Microsoft iSCSI 

support, see the Microsoft Web site 

http://www.microsoft.com/windowsserver2003/technologies/storage/ 

iscsi/default.mspx 

v   The iSCSI traffic must be on a private network (not shared), both for security 

reasons and for performance reasons. Any “networking standard practice” 

method for achieving this end is acceptable, and includes any of the following: 

–   Physically separate, dedicated iSCSI traffic network. 

–   Physically shared network with the iSCSI traffic running on a private VLAN. 

The switch hardware must provide CoS (or QoS) guarantees for the private 

VLAN.

v   If multiple clusters or systems are connected to the same iSCSI network, proper 

segregation must be provided. 

v   The use of session Authentication (CHAP minimum) is mandatory. This provides 

both a degree of security as well as segregation.

Installing the Microsoft iSCSI Software Initiator 

The Microsoft iSCSI Software Initiator is an iSCSI device driver that is used to 

connect to iSCSI devices using the Windows TCP/IP stack using NICs. 

To download the iSCSI software initiator from the Microsoft Download Center, go to 

http://www.microsoft.com/windowsserver2003/technologies/storage/ 

iscsi/default.mspx. For detailed information about the installing and configuring the 

iSCSI software initiator, see the Microsoft iSCSI Software Initiator Users Guide, 

which is available from the Microsoft Download Center. 

Preinstallation tasks for a Fibre Channel (DS400) environment 

The procedure for installing a storage subsystem in a cluster server environment 

includes the following tasks: 

1.   Installing the Fibre Channel host adapters 

2.   Installing the multi-path I/O device specific module (MPIO DSM) software 

3.   Installing the ServeRAID Manager software 

4.   Installing the Microsoft Cluster Server software

Fibre Channel configuration considerations 

You can connect the storage subsystem to the cluster node either directly or 

through Fibre Channel switches. Figure 9 on page 17 shows a typical 

directly-attached configuration. Figure 10 on page 17 shows a typical Fibre Channel 

switch connection configuration. Both configurations are fully redundant. 
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Installing the Fibre Channel host adapters 

To install the Fibre Channel host adapters, see the specific installation requirements 

and procedures in the documentation that comes with the host adapter. After you 

install the host adapter, install the correct host adapter device driver. 

To use the dual path configuration, complete the following steps: 

1.   Install two host adapters in each node. 

2.   Connect two Fibre Channel cables from each node to the storage subsystem. 

3.   Install the multi-path I/O (MPIO) DSM software as described in “Installing the 

multi-path I/O DSM software” on page 18.

Fibre
Channel
switch

Fibre
Channel
switch

DS400

Node A Node B

Controller
B

Controller
A

Interlink
  

Figure 9. Fibre Channel direct-attached cluster solution

DS400
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Controller
B
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Figure 10. Fibre Channel switch cluster solution
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Installing the multi-path I/O DSM software 

To install the MPIO DSM software on a host system using multiple connections to 

the external storage enclosure, complete the following steps: 

1.   To download the latest MPIO DSM from the IBM Support Web site, go to 

http://www.ibm.com/pc/support/. 

2.   On a command prompt or using Windows, run the installation program. 

3.   After the software is installed, restart the host system. 

4.   To be sure the software is installed correctly, on the desktop, right-click My 

computer, and click Manage. In the Computer Management window, a disk 

device is displayed as a Multi-Path Disk Device.

Installing a DS300 or DS400 storage subsystem in a cluster 

environment 

The following procedures describe how to install the storage management software 

in a cluster environment. 

Note: The storage management software consists of host bus adapter device 

drivers, iSCSI software initiator software, MPIO DSM software, and the ServeRAID 

Manager software. 

Windows 2000 

Note: Microsoft does not support an iSCSI cluster in a Windows 2000 operating 

system environment. 

Before you begin, make sure that the host bus adapters, device drivers, and MPIO 

DSM software are installed on each cluster node. 

To install the storage management software and the cluster service software on a 

server running the Microsoft Windows 2000 operating system, complete the 

following steps: 

1.   Shut down node B. Turn on node A. 

2.   Install the ServeRAID Manager software on node A. For more information, see 

“Installing the ServeRAID Manager program” on page 2. 

3.    Use the ServeRAID Manager software to define and map the shared logical 

drives to the cluster nodes. 

Note: You might need to restart the first node of the cluster to see the logical 

drives (LUNs) that are added. 

4.   Format all shared logical drives as NT File System (NTFS), assign volume 

labels, and specify a drive letter for each. 

Important: You must assign a permanent (sticky) drive letter to the shared 

logical drive on both cluster nodes. The two nodes must have the same drive 

letters on each shared drive. If you do not assign permanent drive letters, 

Windows might assign different drive letters on each node. 

5.   Shut down node A. Start node B. 

6.   To be sure that the drive letters for the cluster configuration are defined 

correctly, complete the following steps: 

a.   Click Start → Programs → Administrative Tools → Computer Management. 

The Computer Management window opens. 
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b.   Click Storage Disk Management.

7.   Make sure that the following conditions are met: 

v   The same logical drives are displayed on each cluster node. 

v   Each cluster node has the same number of partitions defined on the logical 

drives. 

v   Drive letters are assigned to the configured logical drives. 

v   The drive letters on the partitions are the same on both cluster nodes.

8.   Shut down node B. Start node A. 

9.   Install the cluster server software. For more information, see “Installing the 

cluster server software” on page 20.

Windows Server 2003 

To install the storage management software and the cluster services software on a 

server running the Microsoft Windows Server 2003 operating system, complete the 

following steps. 

Notes: 

v   For DS300 iSCSI configurations: Before you begin, make sure that the 

Microsoft iSCSI Software Initiator software is installed on each cluster node. For 

more information, see “Installing the Microsoft iSCSI Software Initiator” on page 

16. 

v   For DS400 Fibre Channel configurations: Before you begin, make sure that 

the host bus adapters, device drivers, and MPIO DSM software are installed on 

each cluster node.

1.   Shut down node B. Turn on node A. 

2.   Install the ServeRAID Manager software on node A. For more information, see 

“Installing the ServeRAID Manager program” on page 2. 

3.   Use the ServeRAID Manager software to define and map the shared logical 

drives to the cluster nodes. 

Note: You might need to restart the first node of the cluster to see the logical 

drives (LUNs) that are added. 

4.   Format all shared logical drives as NT File System (NTFS), assign volume 

labels, and specify a drive letter for each. 

Important: You must assign a permanent (sticky) drive letter to the shared 

logical drive on both cluster nodes. The two nodes must have the same drive 

letters on each shared drive. If you do not assign permanent drive letters, 

Windows might assign different drive letters on each node. 

5.   Shut down node A. Turn on node B. 

6.   To be sure that the drive letters for the cluster configuration are defined 

correctly, complete the following steps: 

a.   Click Start → Programs → Administrative Tools → Computer Management. 

The Computer Management window opens. 

b.   Click Storage Disk Management.

7.   Make sure that the following conditions are met: 

v   The same logical drives are displayed on each cluster node. 

v   Each cluster node has the same number of partitions defined on the logical 

drives. 

v   Drive letters are assigned to the configured logical drives. 

v   The drive letters on the partitions are the same on both cluster nodes.
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8.   Shut down node B. Start node A. 

9.   Install the cluster server software. For more information, see “Installing the 

cluster server software.”

Installing the cluster server software 

The following sections describe how to install the cluster server software on 

Windows operating systems. 

Windows 2000 

Important: Do not perform this procedure unless you installed the necessary 

storage management software components on both cluster nodes. 

To install the cluster server software on node A and node B, complete the following 

steps: 

1.   Install the cluster server software on node A: 

a.   See the Microsoft Cluster Server (MSCS) documentation for the correct 

procedure to install the cluster server software. 

Note: During installation, specify that you want to form a new cluster. 

b.   After the system restarts, leave node A running.

2.   Install the cluster server software on node B, as follows: 

a.   See the MSCS documentation for the correct procedure to install the Cluster 

Server software. 

Note: During installation, specify that you want to join the existing cluster. 

b.   After the system restarts, leave node B running.

3.   After you install MSCS, reinstall Service Pack 4. 

Note: For more information about installing the service pack in a cluster 

environment, see the Microsoft Knowledge Base article Q174799. 

4.   Check the software installation as follows: 

a.   On either node A or node B, click Start → Programs → Administrative Tools 

→ Cluster Administration. 

b.   In the Cluster or Server Name field, type either the name of the cluster or 

the name or IP address of one of the nodes. 

If the installation is successful, the computer names of both nodes are 

displayed on the left side of the Cluster Administrator window. 

c.   Make sure that the cluster disk groups can be moved between cluster 

nodes.

5.   If both node names are not displayed on the left side of the Cluster 

Administrator window, reinstall the cluster server software. If the problem 

persists, contact your IBM technical support representative.
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Windows Server 2003 

Important: Do not perform this procedure unless the necessary storage 

management software components are installed on all cluster nodes. 

To install the cluster server software on cluster nodes, complete the following steps: 

1.   Install the cluster server software on the first node of the cluster. See the 

Microsoft Cluster Server (MSCS) documentation for the correct procedure to 

install the cluster server software. 

Note: During installation, specify that you want to form a new cluster. 

2.   In the Cluster Administrator window, make sure that all of the cluster disk 

groups can be varied online and offline with no problems. 

3.   Install the cluster server software on the second node of the cluster. See the 

Microsoft Cluster Server (MSCS) documentation for the correct procedure to 

install the cluster server software. 

Note: During installation, specify that you want to join the existing cluster. Make 

sure that you add the cluster nodes one at a time. 

4.   If all node names are not displayed on the left side of the Cluster Administrator 

window, reinstall the cluster server software. If the problem persists, contact 

your IBM technical support representative.

Upgrading from a previous version of the storage management 

software 

Be sure that you are familiar with the steps required in a new installation before you 

continue with the following upgrade procedure. 

Choose one of the following two procedures: 

v   Performing a scheduled upgrade: A scheduled upgrade requires scheduling 

downtime on your cluster server to upgrade the controller firmware and storage 

management software. The services and resources offered by the cluster are not 

available during the upgrade. If you choose this upgrade method, it is important 

that you perform the upgrade during off-peak workload time. 

Note: The scheduled upgrade is the preferred procedure for upgrading a cluster 

server configuration. 

v   Performing a rolling upgrade: A rolling upgrade requires upgrading the storage 

management software first in one of the cluster nodes and then in each of the 

remaining cluster nodes, one cluster node a time, so that the services and 

resources offered by the cluster are always available. 

Important: Do not upgrade your storage subsystem firmware until you have 

upgraded the storage management software on all cluster nodes and management 

stations. 

Performing a scheduled upgrade 

The following sections describe how to perform a scheduled upgrade on Windows 

operating systems. 

Windows 2000 

To perform a scheduled upgrade on computers that are running the Windows 2000 

operating system, complete the following steps: 
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1.   Click Start → Programs → Administrative Tools → Services. The Services 

window opens. 

 2.   Shut down node B. 

 3.   From node A, uninstall the components from the previous version of the 

storage management software in the following order (as applicable): 

a.   MPIO DSM 

b.   Microsoft iSCSI Software Initiator 

c.   ServeRAID Manager

 4.   Make sure that the latest IBM host adapter device drivers are installed on node 

A. Go to http://www.ibm.com/servers/storage/support/disk/ to download the 

latest device drivers. 

 5.   Installation the latest version of the storage management software on node A. 

For more information, see “Installing the ServeRAID Manager program” on 

page 2, “Installing the Microsoft iSCSI Software Initiator” on page 16, and 

“Installing the Fibre Channel host adapters” on page 17. 

 6.   Shut down node A. 

 7.   Restart node B. 

 8.   From node B, uninstall the components from the previous version of the 

storage management software. 

 9.   Make sure that the latest IBM host adapter device drivers are installed on node 

B. Go to http://www.ibm.com/servers/storage/support/disk/ to download the 

latest device drivers. 

10.   Install the latest version of the storage management software on node B. For 

more information, see “Installing the ServeRAID Manager program” on page 2, 

“Installing the Microsoft iSCSI Software Initiator” on page 16, and “Installing the 

Fibre Channel host adapters” on page 17. 

11.   Shut down node B. 

12.   Start up one node at a time and complete the following procedure: 

a.   Click Start → Programs → Administrative Tools → Services. The Services 

window opens. 

b.   From the list of displayed services, right-click the cluster server. Click 

Automatic to change the cluster server startup option. 

c.   Start the cluster server service on node B.

Windows Server 2003 

To perform a scheduled upgrade on computers that are running the Windows 

Server 2003 operating system, complete the following steps: 

1.   Before you install the storage management software, perform the following 

steps in each of the cluster nodes in the cluster: 

a.   Click Start → Programs → Administrative Tools → Services. The Services 

window opens. 

b.   From the list of displayed services, right-click the cluster server. Then click 

Manual. 

c.   Stop the cluster server on all nodes in the cluster configuration.

2.   From each cluster node, uninstall the components from the previous version of 

the storage management software in the following order (as applicable): 

a.   MPIO DSM 

b.   Microsoft iSCSI Software Initiator 

c.   ServeRAID Manager
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3.   Make sure that the latest IBM host adapter device drivers are installed in each 

cluster node. Go to http://www.ibm.com/servers/storage/support/disk/ to 

download the latest device drivers. 

4.   Install the latest version of the storage management software in each cluster 

node. For more information, see “Installing the ServeRAID Manager program” 

on page 2, “Installing the Microsoft iSCSI Software Initiator” on page 16, and 

“Installing the Fibre Channel host adapters” on page 17. 

5.   Start up one node at a time and complete the following steps for each node: 

a.   Click Start → Programs → Administrative Tools → Services. The Services 

window opens. 

b.   From the list of displayed services, right-click the cluster server. Click 

Automatic to change the cluster server startup option. 

c.   Manually start the cluster server service.

6.   Open Cluster Administrator windows and verify that the cluster groups can be 

brought online. If not, contact your IBM service representative for support.

Performing a rolling upgrade 

This section describes how to perform a rolling upgrade on Windows operating 

systems. 

Important: If you have applications installed in the cluster server environment that 

do not support a rolling upgrade, perform one of the following tasks: 

v   Put those resources offline before the upgrade; then, put them back online after 

the upgrade. 

v   Perform a scheduled upgrade. A scheduled upgrade requires scheduling 

downtime on your cluster server to upgrade the controller firmware and storage 

management software.

Windows 2000 

To perform a rolling upgrade on computers that are running the Windows 2000 

operating system, complete the following steps: 

 1.   From node A, open Cluster Administrator. 

 2.   Double-click the Active Groups folder in the right pane of the Cluster 

Administrator window. 

 3.   Select each group listed and move them to node B. 

 4.   Select note A. Then click File → Pause Node to pause cluster service in node 

A. 

 5.   From node A, uninstall the components from the previous version of the 

storage management software in the following order (as applicable): 

a.   MPIO DSM 

b.   Microsoft iSCSI Software Initiator 

c.   ServeRAID Manager

 6.   Make sure that the latest IBM host adapter device drivers are installed on node 

A. Go to http://www.ibm.com/servers/storage/support/disk/ to download the 

latest device drivers. 

 7.   Install the latest version of the storage management software on node A. For 

more information, see “Installing the ServeRAID Manager program” on page 2, 

“Installing the Microsoft iSCSI Software Initiator” on page 16, and “Installing the 

Fibre Channel host adapters” on page 17. 
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8.   Run Cluster Administrator. Then click File → Resume Node to resume cluster 

service in node A. 

 9.   From node B, open Cluster Administrator. 

10.   Double-click the Active Groups folder in the right pane of the Cluster 

Administrator window. 

11.   Select each group listed and move them to node A. 

12.   Select node B. Then click File → Pause Node to pause cluster service in node 

B. 

13.   From node B, uninstall the components from the previous version of the 

software. 

14.   Make sure that the latest IBM host adapter device drivers are installed on node 

B. Go to http://www.ibm.com/servers/storage/support/disk/ to download the 

latest device drivers. 

15.   Install the latest version of the storage management software on node B. For 

more information, see Chapter 1, “Installing and running ServeRAID Manager,” 

on page 1. 

16.   Run Cluster Administrator. Then click File → Resume Node to resume cluster 

service in node B.

Windows Server 2003 

To perform a rolling upgrade on computers that are running the Windows Server 

2003 operating system, complete the following steps: 

 1.   In the first node of the cluster, open the Cluster Administrator window. 

 2.   Double-click the Active Groups folder in the right pane of the Cluster 

Administrator window. 

 3.   Select each of the active groups listed in the first cluster node and move them 

to other nodes in the cluster configuration. Make sure that the cluster groups 

come online successfully. 

 4.   Select the first node of the cluster in the Cluster Node Tree view and click File 

→ Pause Node to pause cluster service in that node. 

 5.   From node A, uninstall the components from the previous version of the 

storage management software in the following order (as applicable): 

a.   MPIO DSM 

b.   Microsoft iSCSI Software Initiator 

c.   ServeRAID Manager

 6.   Make sure that the latest IBM host adapter device drivers are installed in each 

cluster node. Go to http://www.ibm.com/servers/storage/support/disk/ to 

download the latest device drivers. 

 7.   Install the latest version of the storage management software in the first cluster 

node. For more information, see “Installing the ServeRAID Manager program” 

on page 2, “Installing the Microsoft iSCSI Software Initiator” on page 16, and 

“Installing the Fibre Channel host adapters” on page 17. 

 8.   In the Cluster Administrator window, select the first node of the cluster and 

click File → Resume Node to resume cluster services in the first cluster node. 

 9.   Move all cluster groups that were active in the first cluster node back to it. 

Make sure that the cluster groups can be brought online in the first cluster 

node with no problems. 

10.   Repeat steps 1 through 9 for each of the other nodes in the cluster 

configuration. Perform all steps for each cluster node, one cluster node at a 

time.
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Upgrading from Windows 2000 Advanced Server to Windows Server 

2003 in a cluster configuration 

Note: Always perform a full system backup before you perform any upgrade 

procedure. 

Important: If you have applications that are installed in the cluster server 

environment that do not support a rolling upgrade, perform one of the following 

tasks: 

v   Put those applications offline before the upgrade. Then put them back online 

after the upgrade. 

v   Perform a scheduled upgrade. A scheduled upgrade requires scheduling 

downtime on your cluster server to upgrade the controller firmware and storage 

management software.

To upgrade from Windows 2000 Advanced Server to Windows Server 2003 

Enterprise Edition, perform the following steps: 

 1.   On node A, open the Cluster Administrator window. 

 2.   Double-click the Active Groups folder in the right pane of Cluster Administrator. 

 3.   Move all active cluster groups in node A to node B. Make sure that the cluster 

groups come online successfully in node B. 

 4.   Select node A. Click File → Pause Node to pause cluster service in node A. 

 5.   Follow the instructions from Microsoft to upgrade node A from Windows 2000 

Advanced Server to Windows Server 2003 Enterprise Edition. 

Note: During the upgrade, the existing cluster server installation is detected 

and clustering for Windows 2000 Advanced Server is installed. When the 

upgrade is complete, node A rejoins the cluster and remains paused. 

 6.   Make sure that the latest IBM host adapter device drivers are installed on node 

A. Go to http://www.ibm.com/servers/storage/support/disk/ to download the 

latest device drivers. 

 7.   Make sure that node A was successfully upgraded to Windows Server 2003 

Enterprise Edition. 

 8.   Install the latest version of the storage management software on node A. For 

more information, see “Installing the ServeRAID Manager program” on page 2, 

“Installing the Microsoft iSCSI Software Initiator” on page 16, and “Installing the 

Fibre Channel host adapters” on page 17. 

 9.   In the Cluster Administrator window, select node A and click File → Resume 

Node to resume cluster service in node A. 

10.   Move the cluster groups that were active in node A back to node A. 

11.   On node B, open the Cluster Administrator window. 

12.   Double-click the Active Groups folder in the right pane of Cluster Administrator. 

13.   Make sure that all cluster groups failover to node A successfully. 

14.   Select node B. Click File → Pause Node to pause cluster service in node B. 

15.   Follow the instructions from Microsoft to upgrade node B from Windows 2000 

Advanced Server to Windows Server 2003 Enterprise Edition. 

Note: During the upgrade, the existing cluster server installation is detected 

and clustering for Windows 2000 Advanced Server is installed. When the 

upgrade is complete, node B rejoins the cluster and remains paused.
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16.   Make sure that the latest IBM host adapter device drivers are installed on node 

A. Go to http://www.ibm.com/servers/storage/support/disk/ to download the 

latest device drivers. 

17.   Make sure that node B was successfully upgraded to Windows Server 2003 

Enterprise Edition. 

18.   Install the latest version of the storage management software in node B. For 

more information, see “Installing the ServeRAID Manager program” on page 2, 

“Installing the Microsoft iSCSI Software Initiator” on page 16, and “Installing the 

Fibre Channel host adapters” on page 17. 

19.   In the Cluster Administrator window, select node B and click File → Resume 

Node to resume cluster service in node B. 

20.   In the Cluster Administrator window, move the cluster groups that were active 

in node B back to node B. Make sure that they come online with no problems. 

21.   If there are more than two nodes in a cluster, repeat step 11 on page 25 

through step 20 for each of the remaining nodes in a cluster, one cluster node 

at a time.
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Appendix  A.  Using  the  FlashCopy  Management  Command  

Line  Tool  

This appendix provides detailed instructions for using the Flashcopy Management 

Command Line Tool. This tool enables you to take flashcopies (also known as 

snapshots) of application databases. 

Introduction 

You can use the Flashcopy Management Command Line Tool to create and 

manage flashcopies of application databases. 

A flashcopy is a frozen image of an application database at a particular point in 

time. You can use a flashcopy to back up an application database, and use it as a 

rollback point in case of a future problem with the application. 

Using the Flashcopy Management Command Line Tool, you can: 

v   List Mini Snap Agents available on the IPSAN 

v   List available databases 

v   Take a flashcopy of the database 

v   Schedule a flashcopy of the database 

v   Rollback to a flashcopy 

v   Delete a flashcopy and its associated metadata 

v   Print usage information

Flashcopy Management Command Line Tool  glossary 

This section provides definitions for terms used in the rest of this appendix to 

describe the commands and options of the Flashcopy Management Command Line 

Tool. 

Agent A machine on the network running at least one instance of a database 

server application that holds information on network storage volumes and 

disks. 

Application 

A database server application type that can be used to store network 

storage information. 

Appointment 

An entry in the diary. 

Database 

The name of the database of the given instance running on the Agent. 

Diary A scheduling service available on the host that enables you to schedule 

jobs. 

Host The machine on the network that runs the IBM ServeRAID Manager 

network storage management station. 

Initiator 

A device that begins a SCSI transaction by issuing a command to another 

device (a target). Typically a SCSI host is the initiator, but a target can also 

become an initiator. 
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Instance 

A specific instance of a database server application. 

Snapshot 

A collection of data representing the state of a network storage device at a 

specific moment in time.

Command line syntax and output 

The Flashcopy Management Command Line Tool uses this syntax: 

sstool host host_username host_password command [options] 

where: 

v   host is a name or IP address of the management service. A host can optionally 

have a port number specified. Otherwise, the Flashcopy Management Command 

Line Tool uses 8003 by default. 

For example: 

   samplehost:8000 

   192.168.0.2:8000 

   192.168.0.2

v   host_username and host_password are the user name and password used to log 

in to a management station. 

v   command [options] describes the action to be performed by the Flashcopy 

Management Command Line Tool. A command can have options associated with 

it. (See “Commands.”)

Return values 

The return values are: 

v   0 - Success 

v   1 - Invalid parameters 

v   2 - Subsystem error

Output 

The Flashcopy Management Command Line Tool prints results to a standard output 

in tabular comma-delimited format. The order and meaning of the column are 

specific to each command. For more information, see “Commands.” 

Note: The Flashcopy Management Command Line Tool handles handle ’/’ as an 

option prefix instead of ’-’ or ’--’ for DOS and Microsoft Windows users. 

Commands 

This section provides detailed descriptions of the Flashcopy Management 

Command Line Tool commands and their options. 

list_agents 

Command: list_agents 

Options: None 

Description: Returns a list of flashcopy agents on the IPSAN (that is, a list of hosts 

with flashcopy agents on them) 
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list_server_instances 

Command: list_server_instances 

Options: 

 -a The name of the machine on the network that runs storage volume/disk 

database servers 

--d The network domain 

--au The agent user login name 

--ap The agent user password 

--app The database server application type
  

Description: Returns a list of server instances available on a flashcopy agent. 

list_instance_databases 

Command: list_instance_databases 

Options: 

 -a The name of the machine on the network that runs storage volume/disk 

database servers 

--d The network domain 

--au The agent user login name 

--ap The agent user password 

--app The database server application type 

-i The server instance name (the name of the instance of the database server of 

a given application type running on the mini snap agent) 

--iu The instance user login name 

--ip The instance user password
  

Description: Returns a list of databases available on a server instance. 

take_snapshot 

Command: take_snapshot 

Options: 

 -a The name of the machine on the network that runs storage volume/disk 

database servers 

--d The network domain 

--au The agent user login name 

--ap The agent user password 

--app The database server application type 

-i The server instance name (the name of the instance of the database server 

of a given application type running on the mini snap agent) 

--iu The instance user login name 

--ip The instance user password 
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--db The database (the name of the database of a given instance running on the 

mini snap agent) 

--ini Initiator 

--dbu The database user login name 

--dbp The database user password 

--NAME The flashcopy (snapshot) name
  

Description: Takes a flashcopy of the database. 

schedule_snapshot 

Command: schedule_snapshot 

Options: 

 -a The name of the machine on the network that runs storage volume/disk 

database servers 

--d The network domain 

--au The agent user login name 

--ap The agent user password 

--app The database server application type 

-i The server instance name (the name of the instance of the database server 

of a given application type running on the mini snap agent) 

--iu The instance user login name 

--ip The instance user password 

--db The database (the name of the database of a given instance running on the 

mini snap agent) 

--ini Initiator 

--dbu The database user login name 

--dbp The database user password 

--NAME The flashcopy (snapshot) name
  

Scheduling options: 

 Option Value Description 

--MINUTE 0-59 The minute within the hour 

--HOUR 0-23 The hour within the 24 hour period 

--DAY 1-31 The day of the month 

--WEEKDAY 0-6 The weekday 

--MONTH 1-12 The month of the year 

--YEAR valid year The year
  

In the scheduling options, value means that the task will run every unit of time. 

Values can also be given as a list values, separated by commas. For example: 

   --MINUTE 10,20,30 

   --DAY 5,25
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Description: Schedules the flashcopy. The time pattern of the flashcopy is defined 

using the scheduling options as shown in “Scheduling options”. 

list_scheduled 

Command: list_scheduled 

Options: None 

Description: Returns a list of scheduled jobs on the management station. 

unschedule_snapshot 

Command: unschedule_snapshot 

Options: 

   --NAME The flashcopy (snapshot) name

Description: Removes a flashcopy job from the host diary. 

roll_back 

Command: roll_back 

Options: 

 -a The name of the machine on the network that runs storage volume/disk 

database servers 

--d The network domain 

--au The agent user login name 

--ap The agent user password 

--app The database server application type 

-i The server instance name (the name of the instance of the database server 

of a given application type running on the mini snap agent) 

--iu The instance user login name 

--ip The instance user password 

--db The database (the name of the database of a given instance running on the 

mini snap agent) 

--dbu The database user login name 

--dbp The database user password 

--NAME The flashcopy (snapshot) name
  

Description: Rolls back the database to a specific flashcopy. 

delete_snapshot 

Command: delete_snapshot 

Options: 

 -a The name of the machine on the network that runs storage volume/disk 

database servers 

--d The network domain 
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--au The agent user login name 

--ap The agent user password 

--app The database server application type 

-i server instance name (the name of the instance of the database server of a 

given application type running on the mini snap agent) 

--iu The instance user login name 

--ip The instance user password 

--db Database (the name of the database of a given instance running on the mini 

snap agent) 

--dbu The database user login name 

--dbp The database user password 

--NAME The flashcopy (snapshot) name
  

Description: Deletes a flashcopy and its associated metadata. 

list_snapshots 

Command: list_snapshots 

Options: None 

Description: Lists all flashcopies. 

help 

Command: help 

Options: None 

Description: Prints this document to standard output. 
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Appendix  B.  Notices  

This information was developed for products and services offered in the U.S.A. 

IBM may not offer the products, services, or features discussed in this document in 

other countries. Consult your local IBM representative for information on the 

products and services currently available in your area. Any reference to an IBM 

product, program, or service is not intended to state or imply that only that IBM 

product, program, or service may be used. Any functionally equivalent product, 

program, or service that does not infringe any IBM intellectual property right may be 

used instead. However, it is the user’s responsibility to evaluate and verify the 

operation of any non-IBM product, program, or service. 

IBM may have patents or pending patent applications covering subject matter 

described in this document. The furnishing of this document does not give you any 

license to these patents. You can send license inquiries, in writing, to: 

   IBM Director of Licensing 

   IBM Corporation 

   North Castle Drive 

   Armonk, NY 10504-1785 

   U.S.A.

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS 

PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS 

OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES 

OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A 

PARTICULAR PURPOSE. Some states do not allow disclaimer of express or 

implied warranties in certain transactions, therefore, this statement may not apply to 

you. 

This information could include technical inaccuracies or typographical errors. 

Changes are periodically made to the information herein; these changes will be 

incorporated in new editions of the publication. IBM may make improvements and/or 

changes in the product(s) and/or the program(s) described in this publication at any 

time without notice. 

Any references in this information to non-IBM Web sites are provided for 

convenience only and do not in any manner serve as an endorsement of those 

Web sites. The materials at those Web sites are not part of the materials for this 

IBM product, and use of those Web sites is at your own risk. 

 IBM may use or distribute any of the information you supply in any way it believes 

appropriate without incurring any obligation to you. 

Some software may differ from its retail version (if available) and may not include all 

user manuals or all program functionality. 

IBM makes no representations or warranties regarding third-party products or 

services. 

Edition notice 

© COPYRIGHT INTERNATIONAL BUSINESS MACHINES CORPORATION, 2004, 

2005. All rights reserved. 
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U.S. Government Users Restricted Rights — Use, duplication or disclosure 

restricted by GSA ADP Schedule Contract with IBM Corp. 

Trademarks 

The following terms are trademarks of International Business Machines Corporation 

in the United States, other countries, or both: 

 Active Memory Predictive Failure 

Analysis 

Active PCI PS/2 

Active PCI-X ServeRAID 

Alert on LAN ServerGuide 

BladeCenter ServerProven 

C2T Interconnect TechConnect 

Chipkill Tivoli 

EtherJet TotalStorage 

e-business logo Update Connector 

FlashCopy Wake on LAN 

IBM XA-32 

IBM (logo) XA-64 

IntelliStation X-Architecture 

NetBAY XceL4 

Netfinity XpandOnDemand 

NetView xSeries 

OS/2 WARP 

  

Intel, MMX, and Pentium are trademarks of Intel Corporation in the United States, 

other countries, or both. 

Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation in 

the United States, other countries, or both. 

Adaptec and HostRAID are trademarks of Adaptec, Inc., in the United States, other 

countries, or both. 

Linux is a trademark of Linus Torvalds in the United States, other countries, or both. 

Red Hat, the Red Hat “Shadow Man” logo, and all Red Hat-based trademarks and 

logos are trademarks or registered trademarks of Red Hat, Inc., in the United States 

and other countries. 

Other company, product, or service names may be trademarks or service marks of 

others. 
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