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Chapter 1. Installing and running ServeRAID Manager

This chapter provides installation instructions for the IBM® ServeRAID™ Manager
program and provides an overview of the software features and navigation tools.
For detailed instructions for using the ServeRAID Manager program to manage the
storage subsystem, see the online help.

System requirements

This section lists the system requirements for the management station and the
client computer.

Management station system requirements

To install and run the ServeRAID Manager program on a management station, the
following minimum hardware and software are required:

+ A computer with an Intel®-compatible 500 MHz processor (IA32 or AMD32)
+ 256 MB RAM

* 35 MB hard disk space

+ Microsoft® Windows® Server 2003 or Windows 2000 Server

Client computer system requirements

To install and run the ServeRAID Manager program on a client computer, the
following minimum hardware and software are required:

* A computer with an Intel-compatible 500 MHz processor (IA32, AMD32, or
AMDG64)

256 MB RAM
* 35 MB hard disk space
» 256 color video mode

On client computers, the ServeRAID Manager program is supported Microsoft
Windows, Linux, Novell Netware, UnixWare, and OpenServer on operating systems.

Note: When installing the ServeRAID Manager program on client computers, see
the operating-system-specific readme files on the IBM ServeRAID Manager
Application CD for a list of operating systems that support ServeRAID Manager and
other operating-system-specific information.

Installing the ServeRAID Manager and Management Station programs

This section provides instructions for installing the ServeRAID Manager and
Management Station programs on systems running a Microsoft Windows operating
system. To install the ServeRAID Manager program on a client computer running an
operating system other than Windows, see the operating-system-specific readme
files on the IBM ServeRAID Manager Application CD for installation instructions. To
install the Management Station program on a client computer running an operating
system other than Windows, see the operating-system-specific readme files on the
IBM Support Web site for installation instructions.

Note: You must have administrator privileges to install the ServeRAID Manager
and Management Station programs.

© Copyright IBM Corp. 2004, 2006 1



Installing the ServeRAID Manager program
To install the ServeRAID Manager program, complete the following steps:

1.

6.

Insert the installation CD and wait for the Autorun executable file to start the
installation. If this does not occur, browse the CD and click Autorun.

When the installation wizard opens, click Next.
Read and accept the terms of the license agreement; then, click Next.

Click Next to accept the default installation setup. You can also use the menus
to select the ServeRAID components that you want to install, and then click
Next.

Click Install.
The installation wizard installs the software. This might take a few minutes.
When the installation is completed, click Finish.

Installing the Management Station program
To install the Management Station program, complete the following steps:

1.

Download the Management Station program executable file:
a. Go to |http://www.ibm.com/servers/storage/support/|
b. Go to the page for your storage subsystem model and configuration.

c. Follow the online instructions to download the program executable file
(setup.exe).

Double-click setup.exe to start the installation wizard.
Read and accept the terms of the license agreement; then, click Next.

Create a user name and a password for the management station. This is the
user name and password that you will use to log in to the management station.
When completed, click Next.

Click Install. The installation wizard installs the software. This might take a few
minutes.

When the installation is completed, click Finish.

Getting started

This section explains how to begin using the ServeRAID Manager program.

Running ServeRAID Manager

Note: You must have administrator privileges to run ServeRAID Manager.

To run ServeRAID Manager as a stand-alone application, click Start + Programs »
ServeRAID Manager » ServeRAID Manager. The ServeRAID Manager window
opens, as shown in [Figure 1 on page 3,
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http://www.ibm.com/servers/storage/support/

The ServeRAID Manager window is divided into four panes:
» Enterprise view (1)

* Physical devices (2)

* Logical devices (3)

» Event monitoring (4)

£ ServeRAID Manager N =10] x|
File View Remote Actions Help
@ add  Afcreate A sionce Properties [ vonts & Configure, &8 Help %
Enterpﬂsam(l) ] nysicalueﬁnes(Z) H Lngh:aldmﬁces('.’n)
© 3 Direct attached storage Epsi0tENAsT0zR2m009 @ )Y (T
R ¢ BOER &
= DS400 S320 Arrays (3)
€2 DS400-2 (SN 1S17002RD23B0037) EHED EEERDODDDD % © ' Amay-1(304.8 GB), Synchronizing: 22%.
23 DS400-3 (SN 1S17002RD23B0033) f—1 BB 'E S-array-1 (203.18 GB), Synchronizing: 61%
&2 DS400-Single (SN 1517002RD2380| ' S-array-2 (228.6 GB), Synchronizing: 40%
=1 [ X345-1 (Management station) Lz ¥ LS008, N GRS
€22 DS300 (SN 1517011RS23A5032) EXP400 5320 Bl
f ogical drives
EBEepeopPDDDOD # B
- @ R10-1 - 40 GB, Synchronizing: 61%.
@ R10-2 - 60 GB, Synchronizing: 61%.
EXP400 S320 > - R R
@ RS0-1 - 90 GB, Synchronizing: 40%.
@ R50-2 - 100 GB, Synchronizing: 40%.
' T ]| Connection status: Connected -]
< Date - Time _— Source h R ; Description
(@ 0910112005 03:38:45PMEDT  DS400-1 logical drive R50-1 has been created
@ 09/01/2005 03:38:32 PMEDT DS400-1 Created array S-array-2 (203.20Gh (426147840 blocks))
@ 0910172005 03:34:31 PMEDT  DS400-1 @ logical drive R5-2 has been created
@ 02/01/2005 03:3418 PMEDT DS400-1 logical drive R5-1 has been created
@ 09/01/2005 03:34:.09 PMEDT DS400-1 Created array Array-1 (270.94Gh (568197120 blocks))
@ 09/01/2005 03:33:25PMEDT DS400-1 Priority change: controller A, Array 0
@ 09/01/2005 03:33:25PMEDT DS400-1 Logical drive added: controller A, Array 0
@ 09/01/2005 031252 PMEDT DS400-1 Logical drive deleted: controller A, Array 61
@ 09/01/2005 03:12:52 PMEDT DS400-1 Logical drive deleted: controller A, Array 60
@ 09/01/2005 03:12:52 PMEDT DS400-1 Logical drive deleted: controller A, Array S-array-2
@ 08/01/2005 031252 PMEDT DS40041 Logical drive deleted: controller A, Array S-array-2
@ 09/01/2005 03:38:32PMEDT DS400-1 Created array S-array-2 (203.20Gk (426147840 blocks))
(D 08/01/2005 03:38116 PMEDT DS400-1 Adapter /O resumed: controller A
i@ ]x305 (Management station)/DS400-1 (SN 1517002RD23B0038yCantroller in slot Af... [

Figure 1. ServeRAID Manager window

For additional information about ServeRAID Manager features, see[‘Navigating
[ServeRAID Manager” on page 5.|

Adding a management-station agent

The management-station agent is a monitoring agent for network-managed storage.
After you add an agent to a management station, you can monitor and configure
the attached storage enclosures from a ServeRAID Manager console.

When you log in for the first time, you must add and configure the

management-station agent before you can set up network-managed storage, such
as the IBM TotalStorage DS300 and DS400.

Chapter 1. Installing and running ServeRAID Manager 3



To add a management-station agent, complete the following steps:

1.

In the “Enterprise view” pane, right-click the Networked storage icon and select

Add management station, as shown in the following illustration. The “Add
management station” window opens.

File Wiew Remote Actions Help
[ age A8 ¥ Y Properties =
|_ Enterprise view | E Hetworked sturaga
= @ Direct attached storage Host nan
28! hou2287c (Local system

[ Metworked storage

@ Add management station [%
Remove management station »

Properties

Figure 2. Adding a management station

5.
6.

In the Type field, select Management Station.
Enter the host name or TCP/IP address of the management-station computer.

Enter the management-station user name and password created during the
ServeRAID Manager installation. (See step .)

Select Save user name/password.
Click Connect. The management-station agent is added.

Removing a management-station agent
To remove a management-station agent, complete the following steps:

1.

In the “Enterprise view” pane, right-click Networked storage, and select
Remove management station; then, select the management-station agent to
be removed.

Click Yes.

The management-station agent and all the network-managed storage devices
that are associated with the management-station agent are removed.

Adding the storage subsystem to the management station

To add the storage subsystem to the management station, complete the following
steps:

1.

In the “Enterprise view” pane, right-click the management station in the
Networked storage tree and select Add agent.

Type the host name or TCP/IP address for one of the storage subsystem
management ports.

Enter the administrator password for the storage subsystem.

Note: The administrator password is created when the storage subsystem is
installed on the network. It is not the same as the management-station
password.

Click Add.

The storage subsystem is added to the management station in the Networked
storage tree in the “Enterprise view” pane.

For more information about configuring the storage subsystem and building the
network-managed storage, see the ServeRAID Manager help.

4  Software Installation Guide



Navigating ServeRAID Manager

The “Enterprise view” pane (shown in contains an expandable tree that
shows the systems and controllers that you are managing. The Networked storage
tree lists management stations that have network-attached storage enclosures.

Enterprise view |
Direct attached storage
Iz] Networked storage
= (1% %305 (Management station)
22 DS400-1 (SN 1517002RD23B0038)
£25 DS400-2 (SN 1517002RD23B0037)
£25 DS400-3 (SN 1517002RD23B0033)
£25 DS400-Single (SH 1517002RD23B0036)
= @l ¥345-1 (Management station)
£25 DS300 (SN 1517011RS23A5032)

Figure 3. “Enterprise view” pane

You can perform most configuration and management tasks by selecting a controller
or enclosure from the tree and working with related objects in the “Physical devices”
and “Logical device” panes (shown in|Figure 4).

shows how ServeRAID Manager displays the “Physical devices” and
“Logical devices” panes, which show the physical devices and logical devices that
are connected to the controller or enclosure.

| Physical devices || Logical devices
EDsI00 SNAsT002r02sB0058 @1 ¢ E|(T)[=2)(=)
03400 5320 Arrays (3)
| : = [ Aray-1 (3048 GB), Synchronizing: 42%.

EEEssreene

88 carray-1 (20318 GE)
B s-array-2 (2286 GE), Synchronizing: 83%.

EXP400 5320

pEERBROBRDE

Logical drives (E)

v R10-1 - Okay (40 GB)
R10-2 - Okay (61.59 GE)

B o amo oo (@ Re-1-25 68, Synchronizing. 42%.

EEEsspoRRDDDDD D

@ R&0-1 - 90 GEB, Synchranizing: 83%.

@ R&0-2 - 100 GE, Synchronizing: 83%.

Figure 4. “Physical devices” and “Logical devices” panes

Chapter 1. Installing and running ServeRAID Manager 5



The “Physical devices” pane (on the left in [Figure 4 on page 5) displays information
about the drives, enclosures, and other devices that are attached to the controller.
The devices are grouped by the channel or port they are connected to and shown
in numerical order. The information for each channel or port includes the maximum
speed capability, the number of the channel on the controller, and the nhumber of
devices that are attached to the controller.

The “Logical devices” pane (on the right in |Figure 4 on page 5|) displays information
about the arrays and logical drives that are created using the physical devices. This
information includes the number of arrays and logical drives, the RAID level of each
device, and whether a logical drive is protected by a hot spare drive.

In the “Physical devices” and “Logical devices” panes, you can perform the
following tasks:

» Collapse or expand a view to see more information about arrays, logical devices,
and physical devices.

+ Change how drives are displayed (see [‘Changing how drives are displayed” on
page 9
. Identifi components of a logical device (seel“Viewing related components” on|

page 8§).

“Physical devices” pane

The “Physical devices” pane displays device information in enclosure view format or
in text format.

Figure 5| shows the enclosure view format. Drives in the enclosure view format are
shown in the physical slots that they occupy with the correct vertical or horizontal
orientation. Empty slots are shown as drive outlines.

| Physical devices |
&3 DSA00-1 (SN 1517002RD23B0038) @& ] Y

DE400 5320

EXP400 5320

CECEBREORBREDEED #
EXP400 5320

pRbespopPRODODD 2

Figure 5. “Physical devices” pane showing the enclosure view format
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Figure 6/ shows physical device information displayed in text format. Drives in text
format are shown by SCSI channel and SCSI ID.

| Physical devices || Logical devices
&3D8400-1 (SN 1s17002R02380038 @1V ([T (5[]
Controller {23 Arrays (3
bW g v B2 Aray-1(304.8 GE), Synchronizing: 45%.
88 coarray-1 (20318 GE)
Channel 2 320 MBJs (8 devices found) 62 S-aray-2 (228.6 GE), Synchronizing: 89%.
¥ @ ID0- Online (33.87 GB)
& 1D - Online (33.87 GBE) Logical drives (E)

é 1D 2- Online (33.87 GB) e R10-1- Okay (40 GB)

& 1D 3- Online (33.87 GB) R10-2 - Okay (61.59 GB)

@8 |D4- Online (33.87 GB) R&-1- 25 GB, Synchronizing: 45%.
@ 1D 5- Online (33.87 GE) R&-2 - 50 GB, Synchronizing: 45%.
@ 1D 8- Online (33.87 GBE) R&0-1 - 90 GEB, Synchranizing: 89%.
# Enclozure management device R&0-2 - 100 GB, Synchronizing: 89%.

2eeea

Channel 1 320 MEfis {8 devices found)
P e e e R

Channel 3 320 MBis {14 devices faund)

P

Channel 4 320 MBis {14 devices faund)

Figure 6. Displaying the physical and logical drives in text format

= 1
The indicator icons ( I@ ﬂ ﬁ ) report the status of the fan and temperature
modules on SAF-TE (enclosure management) devices and other devices that
monitor these conditions.

The indicator colors are as follows:

* Blue — Normal

* Yellow — Warning

* Red — Error

» Gray — Not applicable to the devices

For example, the fan indicator changes to yellow when one fan fails; it changes to
red when a second fan fails and cooling is no longer adequate.

“Logical devices” pane

The “Logical devices” pane displays information about the logical devices that were
created using the physical devices, including the number of arrays and logical
devices, the RAID level of each device, and whether a logical device is protected by
a hot spare drive.

You can create and delete logical devices in the “Logical devices” pane by clicking
Create and using the Create wizard.

Chapter 1. Installing and running ServeRAID Manager 7



Changing how drives are displayed

You can change how information is displayed in the “Physical devices” pane by

clicking one

of the following icons in the “Logical devices” pane.

Displays the enclosure view. This is the default view.
Displays physical device information in text format.

Displays physical device information in full-size capacity format. A full-length bar
is displayed for each hard disk drive, regardless of capacity. A small segment
on each hard disk is reserved for the RAID signature; this area is indicated by a
gray cap at the end of each bar.

Note: A hard disk drive that is shaded in light blue is not part of any hard disk
drive group.

Displays physical device information in relative-size capacity format. A
full-length bar is displayed for the largest hard disk drive; proportionally shorter
bars are displayed for other hard disk drives.

Viewing related components

When you click a physical or logical device in either device pane, the related

components

are highlighted.

For example, when you click an array, the associated logical drives are highlighted
in the “Logical devices” pane and the physical drives that are members of the array

are highlight

ed in the “Physical devices” pane, as shown in [Figure 4 on page 5

Selecting a global or dedicated hot spare highlights the logical drives that are
protected by that hot spare. shows an example of the logical drives that
are protected by a global hot spare.

Physical devices

| | Logical devices

G DS400-1 (SN 1517002RD23B0038) (2] V'

DE400 5320 Arrays (3)

= B Array-1(301.04 GB), Synchronizing: 50%.

88 coarray-1 (20318 GE)

2 Sarray-2 (2286 GE)

EXP400 5320

pepesD

EXP400 5320

pepesD

P P E;\E E;\E E;\E E;\E £ ' Logical drives (6)

@ [ R10-1- Okay (40 GB)
Ji) R10-2- Okay (51.58 GB)
458 R&-1- 25 GB, Synchronizing: 80%.
49 R&-2 - 50 GB, Synchronizing: 80%.
5 RA0-1- Okay (90 GE)
5 RA0-2- Okay (100 GE)

2 Y ]

Figure 7. Displaying a global hot spare
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Figure 8/ shows an example of a dedicated hot spare.

G DS400-1 (SN 1517002RD23B0038) (2] V'

DS400 5320 Arrays (3)
EEERRBRERD i < 82 Array-1 (301.04 GE), Synchranizing: 51%.
: ) . ) 88 carray-1 (20318 GE)

£ samray2(2205 6B

EXP400 5320

pepesRoRBDbn

Logical drives {6)

@ @ R10-1- Okay (40 GB)
S8 R10-2- Okay (51.58 GB)
+@ R&-1- 25 GB, Synchronizing: 81%.
‘E? R&-2 - 50 GB, Synchronizing: 81%.
J5) RA0-1- Okay (90 GE)
J5) RA0-2- Okay (100 GE)

EXP400 5320

pepese

Figure 8. Displaying logical devices that are protected by a hot spare

Finding more information

For detailed instructions for using the ServeRAID Manager program to manage the
storage subsystem, see the ServeRAID Manager help.

Chapter 1. Installing and running ServeRAID Manager 9



10 Software Installation Guide



Chapter 2. Installing firmware

This chapter provides instructions for downloading and installing firmware on the
storage subsystem.

Downloading firmware

To download a new firmware image, go to |http://www.ibm.com/servers/storage/|
then, go to the page for your storage subsystem model and configuration.
Follow the online instructions to download the file.

Keep the default file name, and save the file to a system that is accessible by IBM
ServeRAID Manager.

Updating the firmware

To update the firmware, complete the following steps:

1. In the “Enterprise view” pane, right-click the Networked storage icon and select
Update controller images. The IBM ROM Update wizard starts.

2. Click Next. The ROM Update Image selection window opens.
3. Click Add and select the firmware update image file. Then, click Next.

4. Select the check box for the enclosure controllers that you want to update, and
then click Next.

Note: To force an update, hold down the Cirl key while selecting the enclosure
that is to be updated.

5. Review the update summary, and then click Apply.

ServeRAID Manager applies the firmware update to the selected enclosure
controllers. The progress meter shows the update status. When the update is
completed, the progress meter automatically closes.

6. Restart the controller. (See [‘Restarting the controller.”)

Restarting the controller

To restart the controller, complete the following steps:

1. In the “Enterprise view” pane, right-click the enclosure that you want to restart,
and select Restart enclosure.

2. Click Yes to confirm that you want to restart the enclosure.

Note: Restarting the enclosure can take up to 10 minutes; during this time,
data on the controller will be unavailable.

© Copyright IBM Corp. 2004, 2006 11
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Chapter 3. Configuring a new controller

This chapter provides detailed instructions for configuring a new or replacement
controller as part of the storage subsystem.

Note: For detailed instructions for installing a RAID controller, see the IBM
TotalStorage DS300 and DS400 Hardware Installation and User’s Guide.

Getting started

To configure a new or replacement controller, complete the following steps:

1. For a single-controller configuration only: If you are installing a replacement
controller, see the Replacing a controller in a single-controller or dual-controller
IBM TotalStorage DS300 or DS400 storage subsystem document that comes
with the replacement controller, for more detailed installation and setup
instructions.

2. Turn on the storage subsystem and wait until the green controller ready LED is
lit. For the location and a description of the LED, see the storage subsystem
rear view section in Chapter 4 (for DS300) or Chapter 8 (for DS400) of the
Hardware Installation and User’s Guide.

3. From a management station, open a Telnet session to IP address
192.168.70.123.

4. Change to administrator mode by typing administrator, admin, or ad and
pressing Enter.

5. When prompted for a password, enter passwOrd (all lowercase letters with a
zero, not O, in passwOrd).

6. For controller A only: At the DS300 or DS400 prompt, enter setup.

7. Using the Setup wizard, change the storage subsystem default configuration

settings as required for your network. The default settings are shown in(Table 1
and [Table 2 on page 14}

Table 1. Controller A default configuration settings

Controller A settings Default

Hostname DS300 / DS400

Domain Name ibm.com

Timezone [GMT] GMT-5

New Administrator Password passwOrd (all lowercase letters with a zero,
not O, in passwOrd)

Default Gateway 0.0.0.0

DNS Servers NO

User DHCP NO

Management i/f IP Address 192.168.70.123

Management i/f IP Netmask 255.255.0.0

Management i/f Broadcast Address 192.168.255.255

© Copyright IBM Corp. 2004, 2006 13



Table 2. Controller B default configuration settings

Controller B settings Default
Hostname DS300 / DS400
Domain Name ibm.com
Management i/f IP Address 192.168.70.124
Management i/f IP Netmask 255.255.0.0
Management i/f Broadcast Address 192.168.255.255

The Setup wizard gives you a series of prompts. You can type the answers to
the prompts and use the three commands that are shown in the following table.

Command Function

Abort Quit the Setup wizard without making changes
Back Go to the previous prompt

Help Describe the current options

If a parameter has a default value, the prompt displays the value in square
brackets ([ ] ). Some parameters require an arbitrary string, in which case the
commands back and abort cannot be used. In these cases, enclose the string
in quotation marks ("").

Use the following information to assign values for the parameters:

hostname
Enter the name that you want to use for the system. Enter back to
repeat this prompt.

domain name
Enter the domain to which the system belongs.

SAN name
Enter the Storage Area Network (SAN) to which the system belongs.

timezone
Enter the system time zone.

system date
Enter the system date in the format hh:mm@ dd/mml/yy.

define administrator password
Define whether an administrator password is required. If a password is
required, you are prompted for that password, which you must enter
twice. Press Ctrl to leave the password unchanged. Press Enter twice to
not require an administrator password.

define operator password
Define whether an operator password is required.

default gateway
Enter the name or IP address of a router to which packets are sent if
their destinations do not have routes that are defined in the system.
Enter no to clear the default gateway.

DNS servers
Enter the IP addresses of up to three systems that will act as DNS
servers. Enter no to clear the list of DNS servers.
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dhcp Enter yes if a DHCP server will be used to discover the system network
values. Enter no if a DHCP server will not be used.

If you enter yes, the wizard takes you to the finish parameter. If you
enter no, the wizard continues to prompt you for information about the
main Ethernet interface of the system.

IP address

Enter the IP address, in x.x.x.x format. You can also define the netmask
by typing its width after the IP address.

Note: For the DS300 storage subsystem, the management interface
must be in a separate network segment from your iSCSI ports.

netmask

Define the size of the netmask. Any of the common formats are
accepted.

Note: If you entered the netmask as part of the IP address in the
previous prompt, this parameter is skipped.

broadcast address

Enter the address to be used for broadcasts. Any of the common
formats are accepted.

peer IP address
Enter the IP address for the peer controller, in x.x.x format.

Note: For the DS300 storage subsystem, the management interface
must be in a separate network segment from your iSCSI ports.

peer netmask

Define the size of the netmask for the peer controller. Any of the
common formats are accepted.

peer broadcast address

Enter the address to use by the peer controller for broadcasts. Any of
the common formats are accepted.

finish Enter yes to apply the values that you have entered, or enter no to
return to the first parameter and change the values that you have
entered.

Completing the controller configuration

To finish the controller configuration by using ServeRAID Manager, complete the
following steps:

1.

Start ServeRAID Manager. (For more information, see [‘Running ServeRAID|
[Manager” on page 2))
Add the management-station agent. (For more information, see|‘Adding a
[management-station agent” on page 3))

Add the enclosure to the management station. (For more information, see
|“Adding the storage subsystem to the management station” on page 4.[)

Configure the storage subsystem using the Configuration wizard. (For detailed
instructions, see the ServeRAID Manager help.)

Note: After the storage subsystem is configured, logical drives are displayed as
physical drives to the initiator operating system. To set up the initiators, see the
initiator documentation.

Chapter 3. Configuring a new controller 15



If you replaced a RAID controller and the existing arrays were associated with
the RAID controller that you replaced, they are displayed as foreign arrays and
can be imported. (For detailed instructions, see the ServeRAID Manager help.)
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Chapter 4. Installing a DS300 or DS400 storage subsystem in
a Windows cluster server environment

This chapter describes how to install a DS300 or DS400 storage subsystem in a
Windows cluster server environment. Before you install the software, make sure
that you have read the following information:

* IBM TotalStorage DS300 and DS400 Hardware Installation and User’s Guide

« [Chapter 1, “Installing and running ServeRAID Manager,” on page 1|

Important: Always check for a readme file on any installation media. A readme file
contains important information that was not available when this document was
written.

For the latest storage management software and readme files for your operating
system, see |ttp://www.ibm.com/servers/storage/support].

Preinstallation tasks for an iSCSI (DS300) environment
The procedure for installing a DS300 storage subsystem in a cluster server
environment includes the following tasks:
1. lInstalling the Microsoft iISCSI Software Initiator software
2. Installing the ServeRAID Manager software
3. Installing the Microsoft Cluster Server software

ISCSI configuration considerations

You can connect the DS300 storage subsystem to the cluster only by using a
gigabit Ethernet switch. shows an iSCSI environment that uses multiple
switches.

li Interlink—l

Node A Node B

"""""" Gigabit
{ Ethernet
switch

Ethernet
switch

Figure 9. iSCSI cluster configuration
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Before connecting the DS300 to the cluster, read the following Microsoft
requirements for iISCSI cluster support. For more information about Microsoft iISCSI
support, see http://www.microsoft.com/windowsserver2003/technologies/storage/
iscsi/default.mspx

» The iSCSI traffic must be on a private network (not shared), for security and
performance. Any “networking standard practice” method for achieving this end is
acceptable and includes any of the following configurations:

— Physically separate, dedicated iSCSI traffic network.

— Physically shared network with the iSCSI traffic running on a private VLAN.
The switch hardware must provide CoS (or QoS) guarantees for the private
VLAN.

 If multiple clusters or systems are connected to the same iSCSI network, they
must be segregated.

* The use of session authentication (CHAP minimum) is mandatory. This provides
security and segregation.

Installing the Microsoft iSCSI Software Initiator

The Microsoft iSCSI Software Initiator is a device driver on the server that
encapsulates SCSI commands and routes them through the server NIC and the IP
network to the DS300 storage subsystem.

To download the iSCSI software initiator from the Microsoft Download Center, go to
http://www.microsoft.com/windowsserver2003/technologies/storage/
iscsi/default.mspx. For detailed information about installing and configuring the
iISCSI software initiator, see the Microsoft iISCSI Software Initiator Users Guide,
which is available from the Microsoft Download Center.

Preinstallation tasks for a Fibre Channel (DS400) environment
The procedure for installing a storage subsystem in a cluster server environment
includes the following tasks:
1. Installing the Fibre Channel host adapters
2. Installing the multi-path 1/0 device specific module (MPIO DSM) software
3. Installing the ServeRAID Manager software
4. Installing the Microsoft Cluster Server software

Types of Fibre Channel configurations

You can connect the storage subsystem to the cluster node either directly or
through Fibre Channel switches. [Figure 10 on page 19| shows a typical directly
attached configuration.|Figure 11 on page 19 shows a typical Fibre Channel switch
connection configuration. Both configurations are fully redundant.
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Interlink

Node A Node B

Fibre
Channel
switch

Fibre
Channel
switch
Controller| |Controller

Figure 10. Fibre Channel directly attached cluster solution

Interlink

Node A Node B

Controller| |Controller

Figure 11. Fibre Channel switch cluster solution

Installing the Fibre Channel host adapters

To install the Fibre Channel host adapters, see the specific installation requirements
and procedures in the documentation that comes with the host adapter. After you
install the host adapter, install the correct host adapter device driver.

To use the dual path configuration, complete the following steps:
1. Install two host adapters in each node.
2. Connect two Fibre Channel cables from each node to the storage subsystem.

3. Install the multi-path 1/0 (MPIO) DSM software as described in|‘Installing the

|mu|ti-path I/0 DSM software” on page 20.|
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Installing the multi-path /O DSM software

To install the MPIO DSM software on a host system that uses multiple connections
to the external storage enclosure, complete the following steps:

1. To download the latest MPIO DSM, go to |http://www.ibm.com/support/
2. At a command prompt or using Windows, run the installation program.
3. After the software is installed, restart the host system.
4

To be sure that the software is installed correctly, on the desktop, right-click My
computer, and click Manage. In the Computer Management window, a disk
device is displayed as a Multi-Path Disk Device.

Installing a DS300 or DS400 storage subsystem in a cluster
environment

The following procedures describe how to install the storage management software
in a cluster environment.

Note: The storage management software consists of host bus adapter device
drivers, iSCSI software initiator software, MPIO DSM software, and the ServeRAID
Manager software.

Windows 2000

Note: Microsoft does not support an iSCSI cluster in a Windows 2000
operating-system environment.

Before you begin, make sure that the host bus adapters, device drivers, and MPIO
DSM software are installed on each cluster node.

To install the storage management software and the cluster service software on a
server running the Microsoft Windows 2000 operating system, complete the
following steps:

1. Shut down node B. Turn on node A.

2. |Install the ServeRAID Manager software on node A. For more information, see
“Installing the ServeRAID Manager and Management Station programs” on page|
1.

3. Use the ServeRAID Manager software to define and map the shared logical
drives to the cluster nodes.

Note: You might have to restart the first node of the cluster to see the logical
drives (LUNSs) that are added.

4. Format all shared logical drives as NT File System (NTFS), assign volume
labels, and specify a drive letter for each.

Important: You must assign a permanent (sticky) drive letter to each shared
logical drive on both cluster nodes. The two nodes must have the same drive
letter for each shared drive. If you do not assign permanent drive letters,
Windows might assign different drive letters on the nodes.

5. Shut down node A. Start node B.
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To make sure that the drive letters for the cluster configuration are defined
correctly, complete the following steps:

a. Click Start » Programs » Administrative Tools + Computer Management.
The Computer Management window opens.

b. Click Storage Disk Management.
Make sure that the following conditions are met:
* The same logical drives are displayed on each cluster node.

» Each cluster node has the same number of partitions defined on the logical
drives.

» Drive letters are assigned to the configured logical drives.
* The drive letters on the partitions are the same on both cluster nodes.
Shut down node B. Start node A.

Install the cluster server software. For more information, see|‘Installing the

cluster server software” on page 22

Windows Server 2003

To install the storage management software and the cluster services software on a
server running the Microsoft Windows Server 2003 operating system, complete the
following steps.

Notes:

For DS300 iSCSI configurations: Before you begin, make sure that the
Microsoft iISCSI Software Initiator software is installed on each cluster node. For
more information, see [‘Installing the Microsoft iSCSI Software Initiator” on page|

For DS400 Fibre Channel configurations: Before you begin, make sure that
the host bus adapters, device drivers, and MPIO DSM software are installed on
each cluster node.

Shut down node B. Turn on node A.
Install the ServeRAID Manager software on node A. For more information, see

“Installing the ServeRAID Manager and Management Station programs” on page|

1

Use the ServeRAID Manager software to define and map the shared logical
drives to the cluster nodes.

Note: You might have to restart the first node of the cluster to see the logical
drives (LUNSs) that are added.

Format all shared logical drives as NT File System (NTFS), assign volume
labels, and specify a drive letter for each.

Important: You must assign a permanent (sticky) drive letter to each shared
logical drive on both cluster nodes. The two nodes must have the same drive
letter for each shared drive. If you do not assign permanent drive letters,
Windows might assign different drive letters on the nodes.

Shut down node A. Turn on node B.

To be sure that the drive letters for the cluster configuration are defined
correctly, complete the following steps:

a. Click Start » Programs » Administrative Tools + Computer Management.
The Computer Management window opens.

b. Click Storage Disk Management.
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7. Make sure that the following conditions are met:
* The same logical drives are displayed on each cluster node.

» Each cluster node has the same number of partitions defined on the logical
drives.

» Drive letters are assigned to the configured logical drives.
* The drive letters on the partitions are the same on both cluster nodes.
8. Shut down node B. Start node A.

9. Install the cluster server software. For more information, see [Installing the

[cluster server software.’]

Installing the cluster server software

The following sections describe how to install the cluster server software on
Windows operating systems.

Windows 2000

Important: Do not perform this procedure unless you have installed the necessary
storage management software components on both cluster nodes.

To install the cluster server software on node A and node B, complete the following
steps:
1. Install the cluster server software on node A:

a. See the Microsoft Cluster Server (MSCS) documentation for the correct
procedure to install the cluster server software.

Note: During installation, specify that you want to form a new cluster.
b. After the system restarts, leave node A running.
2. |Install the cluster server software on node B, as follows:

a. See the MSCS documentation for the correct procedure to install the Cluster
Server software.

Note: During installation, specify that you want to join the existing cluster.
b. After the system restarts, leave node B running.
3. After you install MSCS, reinstall Service Pack 4.

Note: For more information about installing the service pack in a cluster
environment, see the Microsoft Knowledge Base article Q174799.

4. Check the software installation as follows:

a. On either node A or node B, click Start »+ Programs » Administrative Tools
» Cluster Administration.

b. In the Cluster or Server Name field, type either the name of the cluster or
the name or IP address of one of the nodes.
If the installation is successful, the computer names of both nodes are
displayed in the left pane of the Cluster Administrator window. If both node
names are not displayed in the left pane of the Cluster Administrator
window, reinstall the cluster server software. If the problem remains, contact
your IBM technical support representative.

c. Make sure that the cluster disk groups can be moved between cluster
nodes.
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Windows Server 2003

Important: Do not perform this procedure unless the necessary storage
management software components are installed on all cluster nodes.

To install the cluster server software on cluster nodes, complete the following steps:

1. Install the cluster server software on the first node of the cluster. See the
Microsoft Cluster Server (MSCS) documentation for the correct procedure to
install the cluster server software.

Note: During installation, specify that you want to form a new cluster.

2. In the Cluster Administrator window, make sure that all of the cluster disk
groups can be varied online and offline with no problems.

3. Install the cluster server software on the second node of the cluster. See the
MSCS documentation for the correct procedure to install the cluster server
software.

Note: During installation, specify that you want to join the existing cluster. Make
sure that you add the cluster nodes one at a time.
4. If all node names are not displayed in the left pane of the Cluster Administrator

window, reinstall the cluster server software. If the problem remains, contact
your IBM technical support representative.

Upgrading from a previous version of the storage management

software

Make sure that you are familiar with the steps that are required in a new installation
before you continue with the following upgrade procedure.

Use one of the following two procedures:

* Performing a scheduled upgrade: A scheduled upgrade requires scheduling
downtime on your cluster server to upgrade the controller firmware and storage
management software. The services and resources that are offered by the cluster
are not available during the upgrade. If you use this upgrade method, you must
perform the upgrade during off-peak workload time.

Note: The scheduled upgrade is the preferred procedure for upgrading a cluster
server configuration.

* Performing a rolling upgrade: A rolling upgrade requires upgrading the storage
management software first in one of the cluster nodes and then in each of the
remaining cluster nodes, one cluster node a time, so that the services and
resources that are offered by the cluster are always available.

Important: Do not upgrade the storage subsystem firmware until you have
upgraded the storage management software on all cluster nodes and management
stations.

Performing a scheduled upgrade

The following sections describe how to perform a scheduled upgrade on Windows
operating systems.

Windows 2000

To perform a scheduled upgrade on computers that are running the Windows 2000
operating system, complete the following steps:
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10.

11.
12.

Click Start » Programs » Administrative Tools » Services. The Services
window opens.

Shut down node B.

On node A, uninstall the components from the previous version of the storage
management software in the following order (as applicable):

a. MPIO DSM

b. Microsoft iSCSI Software Initiator

c. ServeRAID Manager

Make sure that the latest IBM host adapter device drivers are installed on

node A. Go to |http://www.ibm.com/servers/storage/support/l to download the
latest device drivers.

Install the latest version of the storage management software on node A. For
more information, see [Installing the ServeRAID Manager and Management|
Station programs” on page 1) ﬂgstalling the Microsoft iSCSI Software Initiator’1
on page 18,|and [‘Installing the Fibre Channel host adapters” on page 19,
Shut down node A.

Restart node B.

On node B, uninstall the components from the previous version of the storage
management software.

Make sure that the latest IBM host adapter device drivers are installed on
node B. Go to |http://www.ibm.com/servers/storage/support| to download the
latest device drivers.

Install the latest version of the storage management software on node B. For
more information, see ['Installing the ServeRAID Manager and Management|
Station programs” on page 1/[Installing the Microsoft iSCSI Software Initiator’]
on page 18,|and[‘Installing the Fibre Channel host adapters” on page 19
Shut down node B.

Start one node at a time and complete the following steps:

a. Click Start » Programs » Administrative Tools » Services. The Services
window opens.

b. From the list of services, right-click the cluster server. Click Automatic to
change the cluster server startup option.

c. Start the cluster server service on node B.

Windows Server 2003
To perform a scheduled upgrade on computers that are running the Windows
Server 2003 operating system, complete the following steps:

1.

Before you install the storage management software, complete the following
steps in each of the cluster nodes in the cluster:

a. Click Start » Programs » Administrative Tools » Services. The Services
window opens.

b. From the list of services, right-click the cluster server. Then, click Manual.
c. Stop the cluster server on all nodes in the cluster configuration.

On each cluster node, uninstall the components from the previous version of the
storage management software in the following order (as applicable):

a. MPIO DSM
b. Microsoft iISCSI Software Initiator
c. ServeRAID Manager
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Performing a roll

Make sure that the latest IBM host adapter device drivers are installed in each
cluster node. Go to |http://www.ibm.com/servers/storage/support| to download
the latest device drivers.

Install the latest version of the storage management software in each cluster
node. For more information, see ['Installing the ServeRAID Manager and
Management Station programs” on page 1J]“Insta|ling the Microsoft iSCSI|
Software Initiator” on page 18,[and[‘Installing the Fibre Channel host adapters’1

on page 19.
on page 19

Start one node at a time and complete the following steps for each node:

a. Click Start » Programs » Administrative Tools » Services. The Services
window opens.

b. From the list of services, right-click the cluster server. Click Automatic to
change the cluster server startup option.

c. Manually start the cluster server service.

Open Cluster Administrator windows and verify that the cluster groups can be

brought online. If they cannot, contact your IBM service representative for
support.

ing upgrade

This section describes how to perform a rolling upgrade on Windows operating
systems.
Important: If applications that do not support a rolling upgrade are installed in the

cluster server environment, perform one of the following tasks:

Windows 2000
To

Put those applications offline before the upgrade; then, put them back online
after the upgrade.

Perform a scheduled upgrade. A scheduled upgrade requires scheduling
downtime on your cluster server to upgrade the controller firmware and storage
management software.

perform a rolling upgrade on computers that are running the Windows 2000

operating system, complete the following steps:

1.
2.
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On node A, open the Cluster Administrator window.

Double-click the Active Groups folder in the right pane of the Cluster
Administrator window.

Select each listed group and move it to node B.

Select note A. Then, click File » Pause Node to pause cluster service in node
A.

On node A, uninstall the components from the previous version of the storage
management software in the following order (as applicable):

a. MPIO DSM
b. Microsoft iSCSI Software Initiator
c. ServeRAID Manager

Make sure that the latest IBM host adapter device drivers are installed on node
A. Go to |http://www.ibm.com/servers/storage/support/|to download the latest
device drivers.

Install the latest version of the storage management software on node A. For
more information, see [nstalling the ServeRAID Manager and Management|
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11.
12.

13.

14.

15.

16.

Station programs” on page 1fInstalling the Microsoft iISCSI Software Initiator]

on page 18,|and [‘Installing the Fibre Channel host adapters” on page 19

Start Cluster Administrator. Then, click File * Resume Node to resume cluster
service in node A.

On node B, start Cluster Administrator.

Double-click the Active Groups folder in the right pane of the Cluster
Administrator window.

Select each listed group and move it to node A.

Select node B. Then, click File » Pause Node to pause cluster service in node
B.

From node B, uninstall the components from the previous version of the
software.

Make sure that the latest IBM host adapter device drivers are installed on node
B. Go to |http://www.ibm.com/servers/storage/support/disk/ to download the
latest device drivers.

Install the latest version of the storage management software on node B. For
more information, see [Chapter 1, “Installing and running ServeRAID Manager,’|

Start Cluster Administrator. Then, click File * Resume Node to resume cluster
service in node B.

Windows Server 2003

To perform a rolling upgrade on computers that are running the Windows Server
2003 operating system, complete the following steps:

1.
2.
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On the first node of the cluster, open the Cluster Administrator window.

Double-click the Active Groups folder in the right pane of the Cluster
Administrator window.

Select each of the active groups that are listed in the first cluster node and
move them to other nodes in the cluster configuration. Make sure that the
cluster groups can be brought online successfully.

Select the first node of the cluster in the Cluster Node Tree view and click File
» Pause Node to pause cluster service in that node.

On node A, uninstall the components from the previous version of the storage
management software in the following order (as applicable):

a. MPIO DSM
b. Microsoft iSCSI Software Initiator
c. ServeRAID Manager

Make sure that the latest IBM host adapter device drivers are installed in each
cluster node. Go to |http://www.ibm.com/servers/storage/support/l to download
the latest device drivers.

Install the latest version of the storage management software in the first cluster
node. For more information, see |‘Installing the ServeRAID Manager and
Management Station programs” on page 1,||“Installing the Microsoft iSCSI
Software Initiator’” on page 18,/and [Installing the Fibre Channel host adapters’]

on page 19.|
In the Cluster Administrator window, select the first node of the cluster and
click File » Resume Node to resume cluster services in the first cluster node.

Move all cluster groups that were active in the first cluster node back to it.
Make sure that the cluster groups can be brought online in the first cluster
node successfully.
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10.

Repeat steps 1 through 9 for each of the other nodes in the cluster
configuration. Perform all steps for each cluster node, one cluster node at a
time.

Upgrading from Windows 2000 Advanced Server to Windows Server
2003 in a cluster configuration

Note: Always perform a full system backup before you perform any upgrade
procedure.

Important: If applications that do not support a rolling upgrade are installed in the
cluster server environment, perform one of the following tasks:

Put those applications offline before the upgrade; then, put them back online
after the upgrade.

Perform a scheduled upgrade. A scheduled upgrade requires scheduling
downtime on your cluster server to upgrade the controller firmware and storage
management software.

To upgrade from Windows 2000 Advanced Server to Windows Server 2003
Enterprise Edition, complete the following steps:

1.
2.

10.
11.
12.

13.
14.

On node A, open the Cluster Administrator window.

Double-click the Active Groups folder in the right pane of the Cluster
Administrator window.

Move all active cluster groups in node A to node B. Make sure that the cluster
groups can be brought online successfully in node B.

Select node A. Click File » Pause Node to pause cluster service in node A.

Follow the instructions from Microsoft to upgrade node A from Windows 2000
Advanced Server to Windows Server 2003 Enterprise Edition.

Note: During the upgrade, the existing cluster server installation is detected
and clustering for Windows 2000 Advanced Server is installed. When the
upgrade is complete, node A rejoins the cluster and remains paused.

Make sure that the latest IBM host adapter device drivers are installed on node
A. Go to |http://www.ibm.com/servers/storage/support/disk/ to download the
latest device drivers.

Make sure that node A was successfully upgraded to Windows Server 2003
Enterprise Edition.

Install the latest version of the storage management software on node A. For
more information, see [‘Installing the ServeRAID Manager and Management]

Station programs” on page 1[“Installing the Microsoft iISCSI Software Initiator’|

on page 18,/and [Installing the Fibre Channel host adapters” on page 19|

In the Cluster Administrator window, select node A and click File » Resume
Node to resume cluster service in node A.

Move the cluster groups that were active in node A back to node A.
On node B, open the Cluster Administrator window.

Double-click the Active Groups folder in the right pane of the Cluster
Administrator window.

Make sure that all cluster groups failover to node A successfully.
Select node B. Click File » Pause Node to pause cluster service in node B.
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15.

16.

17.

18.

19.

20.

21.
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Follow the instructions from Microsoft to upgrade node B from Windows 2000
Advanced Server to Windows Server 2003 Enterprise Edition.

Note: During the upgrade, the existing cluster server installation is detected
and clustering for Windows 2000 Advanced Server is installed. When the
upgrade is complete, node B rejoins the cluster and remains paused.

Make sure that the latest IBM host adapter device drivers are installed on node
A. Go to |http://www.ibm.com/servers/storage/support/disk/ to download the
latest device drivers.

Make sure that node B was successfully upgraded to Windows Server 2003
Enterprise Edition.

Install the latest version of the storage management software in node B. For
more information, see [Installing the ServeRAID Manager and Management|

Station programs” on page 1) ﬂgstalling the Microsoft iSCSI Software Initiator’1

on page 18,/and [‘Installing the Fibre Channel host adapters” on page 19

In the Cluster Administrator window, select node B and click File » Resume
Node to resume cluster service in node B.

In the Cluster Administrator window, move the cluster groups that were active
in node B back to node B. Make sure that they can be brought online
successfully.

If there are more than two nodes in a cluster, repeat step|11 on page 27
through step for each of the remaining nodes in a cluster, one cluster node
at a time.
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Appendix A. Configuring an iSCSI software initiator for use
with a DS300 storage subsystem

The following sections describe how to configure an iISCSI software initiator for use
with a DS300 storage subsystem.

Updating the registry information for the host computer

If the DS300 storage subsystem configuration supports dual controllers, you must
perform the following procedure on each host computer if the host computer is
connected to one of the DS300 data ports, and is running the Microsoft Windows
2000 or Microsoft Windows 2003 operating system. You must perform this
procedure after each time that you install or update the Microsoft iISCSI Software
Initiator onto a host computer.

To update the registry information, complete the following steps:

1. Create an Emergency Repair diskette for the system, using the instructions in
the operating-system online help.

2. Click Start » Run.
In the Run window, type regedt32 and click OK.

In the Registry Editor window, double-click HKEY_LOCAL_MACHINE to
expand the tree.

Expand the SYSTEM tree.
Expand the ControlSet001 tree.
Expand the Control tree.
Expand the Class tree.

Double-click the Globally Unique Identifier (GUID) that contains the legacy
information option of SCSI. An example of a GUID is {4D36E97B-E325-11CE-
BFC1-08002BE10318}.

10. Select value 0000x (where x is the Microsoft iSCSI Initiator device driver), and
then click Parameters.

11. Change the value for the MAXRequestHoldTime from 60 to120:
a. In the right pane, double-click MaxRequestHoldTime.
b. In the String Editor window, change the value from hex 3C in hex 78.
c. Click OK.

12. Close the Registry Editor window.

>
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Microsoft iSCSI Software Initiator version 2.0 target configuration

During a failover event, the software initiator might attempt to reconnect to a target
portal that is not accessible. Use the procedure in this section to make the
necessary changes to the target portal to be sure that the software initiator is
associated with the correct target portal.

To make sure that the initiator is associated with the correct target portal, complete
the following steps:

1. On the desktop, double-click the iSCSI Initiator icon. The iSCSI Initiator
Properties window opens.

2. Click the Target Portals tab and click Add to define a target portal. The Target
Portals window opens.
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10.

Type the IP address of the target portal and then click Advanced. The
Advanced Settings window opens.

Select the Local adapter, and then select the source IP address that is bound
to the local adapter.

Click OK to finish adding the target portal information.

Click the Available Targets tab and click Refresh to make sure that the
current valid targets are listed.

Select a target, and then click Log On.
Click Advanced.

Change the target portal to correspond to the same target portal that you
specified in step [3,

Repeat step[2 on page 29| through step |§|f0r each target.

Note: To change the target portal after it is defined, you must log off the target and
then log on again and redefine the target portal in the Advanced Settings window.
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Appendix B. Using the FlashCopy Management Command
Line Tool

This appendix provides detailed instructions for using the FlashCopy Management
Command Line Tool.

Introduction

You can use the FlashCopy Management Command Line Tool to create and
manage FlashCopy images of application databases.

You can back up an application database to a FlashCopy image and use it later as
a rollback point in case of a problem with the application.

You can use the FlashCopy Management Command Line Tool to perform the
following tasks:

« List Mini Snap Agents that are available on the IPSAN
 List available databases

» Create a FlashCopy image of the database

» Schedule a FlashCopy image of a database

* Roll back to a FlashCopy image

» Delete a FlashCopy image and its associated metadata
* Print usage information

FlashCopy Management Command Line Tool glossary

This section defines terms that are used in this appendix to describe the commands
and options of the FlashCopy Management Command Line Tool.

agent A system on the network that is running at least one instance of a database
server application that holds information on network storage volumes and
disks.

appointment
An entry in the diary.

diary A scheduling service on the host that you can use to schedule jobs.

host The system on the network that runs the IBM ServeRAID Manager network
storage management station.

initiator
A device that starts a SCSI transaction by issuing a command to another

device (a target). Typically, a SCSI host is the initiator, but a target can also
become an initiator.

instance
A specific occurrence of a database server application.

shapshot
A collection of data that represents the state of a network storage device at
a specific point in time.
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Command line syntax and output

The FlashCopy Management Command Line Tool uses this syntax:

sstool host host_username host_password command [options]

where:

* host is the name or IP address of the management service. A host can optionally
have a specified port number. Otherwise, the FlashCopy Management Command
Line Tool uses 8003 by default.

For example:
samplehost:8000
192.168.0.2:8000
192.168.0.2

» host_username and host_password are the user name and password that are
used to log in to a management station.

* command [options] describes the action that is to be performed by the FlashCopy
Management Command Line Tool. A command can have options associated with

it. (See ['Commands.’)

Return values
The following values can be returned:
e 0 - Success
* 1 - Invalid parameters
e 2 - Subsystem error

Output

The FlashCopy Management Command Line Tool prints results to a standard output
in tabular comma-delimited format. The order and meaning of the column are
specific to each command. For more information, see

Note: In DOS and Windows, the FlashCopy Management Command Line Tool

uses a forward slash (/) as an option prefix instead of a hyphen (- ) or double
hyphen ( --).

Commands

This section describes the FlashCopy Management Command Line Tool commands
and their options.

list_agents

Description: Returns a list of FlashCopy agents on the IPSAN (that is, a list of
hosts with FlashCopy agents on them)

Command: list_agents

Options: None
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list_server_instances

Description: Returns a list of server instances that are available on a FlashCopy

agent.

Command: list_server_instances

Options:

-a

The name of the system on the network that runs storage volume/disk
database servers

-~d

The network domain

--au

The agent user login name

--ap

The agent user password

—-app

The database server application type

list_instance_databases
Description: Returns a list of databases that are available on a server instance.

Command: list_instance_databases

Options:

-a

The name of the system on the network that runs storage volume/disk database
servers

-~d

The network domain

--au

The agent user login name

--ap

The agent user password

--app

The database server application type

The server instance name (the name of the instance of the database server of
a given application type that is running on the mini snap agent)

--iu

The instance user login name

__ip

The instance user password

take_snapshot

Description: Creates a FlashCopy image of the database.

Command: take_snapshot

Options:

-a

The name of the system on the network that runs storage volume/disk
database servers

-~d

The network domain

--au

The agent user login name

--ap

The agent user password

--app

The database server application type

The server instance name (the name of the instance of the database server
of a given application type running on the mini snap agent)
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--iu

The instance user login name

--ip

The instance user password

--db

The database (the name of the database of a given instance that is running
on the mini snap agent)

--ini

Initiator

--dbu

The database user login name

--dbp

The database user password

--NAME

The FlashCopy image name

schedule_snapshot

Description: Schedules creation of a FlashCopy image. The time pattern of the
FlashCopy is defined using the scheduling options as shown in “Scheduling

options”.

Command: schedule_snapshot

Options:

-a

The name of the system on the network that runs storage volume/disk
database servers

-d

The network domain

--au

The agent user login name

__ap

The agent user password

--app

The database server application type

The server instance name (the name of the instance of the database server
of a given application type that is running on the mini snap agent)

--iu

The instance user login name

__ip

The instance user password

--db

The database (the name of the database of a given instance that is running
on the mini snap agent)

--ini

Initiator

--dbu

The database user login name

--dbp

The database user password

--NAME

The FlashCopy image name

Scheduling options:

Option Value Description

--MINUTE 0-59 The minute within the hour
--HOUR 0-23 The hour within the 24 hour period
--DAY 1-31 The day of the month
--WEEKDAY 0-6 The weekday

--MONTH 1-12 The month of the year

--YEAR valid year The year
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list_scheduled

In the scheduling options, value means that the task will run every unit of time.
Values can also be given as a list of values, separated by commas. For example:

--MINUTE 10,20,30
--DAY 5,25

Description: Returns a list of scheduled jobs on the management station.
Command: list_scheduled

Options: None

unschedule_snapshot

roll_back

Description: Removes a scheduled job from the host diary.
Command: unschedule_snapshot

Options:

--NAME The snapshot name

Description: Rolls back the database to a specific FlashCopy image.

Command: roll_back

Options:

-a The name of the system on the network that runs storage volume/disk
database servers

--d The network domain

--au The agent user login name

--ap The agent user password

--app The database server application type

-i The server instance name (the name of the instance of the database server
of a given application type that is running on the mini snap agent)

--iu The instance user login name

--ip The instance user password

--db The database (the name of the database of a given instance that is running
on the mini snap agent)

--dbu The database user login name

--dbp The database user password

--NAME The FlashCopy image name
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delete_snapshot

Description: Deletes a FlashCopy image and its associated metadata.

Command: delete_snapshot

Options:

-a

The name of the system on the network that runs storage volume/disk
database servers

-~d

The network domain

--au

The agent user login name

--ap

The agent user password

--app

The database server application type

The server instance name (the name of the instance of the database server of
a given application type that is running on the mini snap agent)

--iu

The instance user login name

--ip

The instance user password

--db

Database (the name of the database of a given instance that is running on the
mini snap agent)

--dbu

The database user login name

--dbp

The database user password

--NAME

The FlashCopy image name

list_snapshots

Description: Lists all FlashCopy images.

Command: list_snapshots

Options: None

help

Description: Prints this document to standard output.

Command: help

Options: None
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Appendix C. Getting help and technical assistance

If you need help, service, or technical assistance or just want more information
about IBM products, you will find a wide variety of sources available from IBM to
assist you. This appendix contains information about where to go for additional
information about IBM and IBM products, what to do if you experience a problem
with your system or optional device, and whom to call for service, if it is necessary.

Before you call

Before you call, make sure that you have taken these steps to try to solve the
problem yourself:

» Check all cables to make sure that they are connected.

* Check the power switches to make sure that the system and any optional
devices are turned on.

» Use the troubleshooting information in your system documentation, and use the
diagnostic tools that come with your system. Information about diagnostic tools is
in the Hardware Maintenance Manual and Troubleshooting Guide or Problem
Determination and Service Guide on the IBM Documentation CD that comes with
your system.

Note: For some IntelliStation models, the Hardware Maintenance Manual and
Troubleshooting Guide is available only from the IBM support Web site.

* Go to the IBM support Web site at http://www.ibm.com/servers/eserver/support/
xseries/index.html to check for technical information, hints, tips, and new device
drivers or to submit a request for information.

You can solve many problems without outside assistance by following the
troubleshooting procedures that IBM provides in the online help or in the
documentation that is provided with your IBM product. The documentation that
comes with IBM systems also describes the diagnostic tests that you can perform.
Most systems, operating systems, and programs come with documentation that
contains troubleshooting procedures and explanations of error messages and error
codes. If you suspect a software problem, see the documentation for the operating
system or program.

Using the documentation

Information about your IBM system and preinstalled software, if any, or optional
device is available in the documentation that comes with the product. That
documentation can include printed documents, online documents, readme files, and
help files. See the troubleshooting information in your system documentation for
instructions for using the diagnostic programs. The troubleshooting information or
the diagnostic programs might tell you that you need additional or updated device
drivers or other software. IBM maintains pages on the World Wide Web where you
can get the latest technical information and download device drivers and updates.
To access these pages, go to http://www.ibm.com/servers/eserver/support/xseries/
index.html and follow the instructions. Also, some documents are available through
the IBM Publications Center at http://www.ibm.com/shop/publications/order/.
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Getting help and information from the World Wide Web

On the World Wide Web, the IBM Web site has up-to-date information about IBM
systems, optional devices, services, and support. The address for IBM System x
and xSeries information is http://www.ibm.com/systems/x/. The address for IBM
IntelliStation information is http://www.ibm.com/intellistation/.

You can find service information for IBM systems and optional devices at
http://www.ibm.com/servers/eserver/support/xseries/index.html.

Software service and support

Through IBM Support Line, you can get telephone assistance, for a fee, with usage,
configuration, and software problems with System x and xSeries servers,
BladeCenter products, IntelliStation workstations, and appliances. For information
about which products are supported by Support Line in your country or region, see
http://www.ibm.com/services/sl/products/.

For more information about Support Line and other IBM services, see
http://www.ibm.com/services/, or see http://www.ibm.com/planetwide/ for support
telephone numbers. In the U.S. and Canada, call 1-800-IBM-SERV
(1-800-426-7378).

Hardware service and support

You can receive hardware service through IBM Services or through your IBM
reseller, if your reseller is authorized by IBM to provide warranty service. See
http://www.ibm.com/planetwide/ for support telephone numbers, or in the U.S. and
Canada, call 1-800-IBM-SERV (1-800-426-7378).

In the U.S. and Canada, hardware service and support is available 24 hours a day,

7 days a week. In the U.K., these services are available Monday through Friday,
from 9 a.m. to 6 p.m.
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Appendix D. Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may be
used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give you any
license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing

IBM Corporation

North Castle Drive

Armonk, NY 10504-1785

U.S.A.

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A
PARTICULAR PURPOSE. Some states do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply to
you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements and/or
changes in the product(s) and/or the program(s) described in this publication at any
time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those
Web sites. The materials at those Web sites are not part of the materials for this
IBM product, and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes
appropriate without incurring any obligation to you.

Trademarks

The following terms are trademarks of International Business Machines Corporation
in the United States, other countries, or both:

Active Memory IBM (logo) Tivoli

Active PCI IntelliStation Tivoli Enterprise
Active PCI-X NetBAY TotalStorage
Alert on LAN Netfinity Wake on LAN
BladeCenter Predictive Failure Analysis XA-32
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Chipkill ServeRAID XA-64

e-business logo ServerGuide X-Architecture
@server ServerProven XpandOnDemand
FlashCopy System x xSeries

IBM

Intel, Intel Xeon, Itanium, and Pentium are trademarks or registered trademarks of
Intel Corporation or its subsidiaries in the United States and other countries.

Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation in
the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Java and all Java-based trademarks and logos are trademarks of Sun
Microsystems, Inc. in the United States, other countries, or both.

Adaptec and HostRAID are trademarks of Adaptec, Inc., in the United States, other
countries, or both.

Linux is a trademark of Linus Torvalds in the United States, other countries, or both.
Red Hat, the Red Hat “Shadow Man” logo, and all Red Hat-based trademarks and
logos are trademarks or registered trademarks of Red Hat, Inc., in the United States

and other countries.

Other company, product, or service names may be trademarks or service marks of
others.

Important notes

IBM makes no representation or warranties regarding non-IBM products and
services that are ServerProven®, including but not limited to the implied warranties
of merchantability and fitness for a particular purpose. These products are offered
and warranted solely by third parties.

IBM makes no representations or warranties with respect to non-IBM products.
Support (if any) for the non-IBM products is provided by the third party, not IBM.

Some software may differ from its retail version (if available), and may not include
user manuals or all program functionality.
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