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About this book

This book provides information about setting up, installing, configuring, and working
with IBM® Fibre Array Storage Technology (FAStT) Storage Manager in a Novell
NetWare operating-system environment. This Installation and Support Guide is for
system administrators. Use this guide to:

v Determine the hardware and software that are required to install the
storage-management software.

v Integrate the necessary hardware components into your network.

v Install the FAStT Storage Manager software.

v Upgrade controller firmware, if necessary.

v Identify storage-management features that are unique to your specific installation.

How this book is organized
Chapter 1, “Introduction” on page 1 provides an overview of IBM FAStT Storage
Manager Version 8.2 and describes storage-subsystem management methods,
configuration types, types of installations, and installation requirements.

Chapter 2, “Preparing for installation” on page 19 discusses preparing for a network
installation including setting up a Microsoft® Dynamic Host Configuration Protocol
(DHCP) server, UNIX® Boot Protocol (BOOTP) server, or a NetWare server, and
describes other setup tasks.

Chapter 3, “Installing software” on page 37 gives the procedure for installing the
software in a standard and noncluster server environments.

Chapter 4, “Completing the installation” on page 43 discusses starting the Enterprise
Management window, applying NVSRAM configuration scripts, adding devices, and
subsystem management tasks.

Chapter 5, “Using the storage-management software” on page 49 provides
information about adding ad deleting logical drives, using the Hot Add and
SMdevices utilities, starting and stopping the host-agent software, and uninstalling
Storage Manager components.

Chapter 6, “Novell NetWare operating-system support” on page 53 discusses Novell
NetWare operating system limitations.

Appendix A, “Storage subsystem/controller information record” on page 55 provides
a data sheet template that you can use to create a controller information record.

Appendix B, “Getting information, help, and service” on page 57 provides
information about how to obtain help, service, or technical assistance.

Appendix C, “Notices” on page 61 provides product notices and trademark
information.
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Notices used in this book
This book contains the following notices designed to highlight key information:

v Note: These notices provide important tips, guidance, or advice.

v Important: These notices provide information or advice that might help you avoid
inconvenient or problem situations.

v Attention: These notices indicate possible damage to programs, devices, or
data. An attention notice is placed just before the instruction or situation in which
damage could occur.

Related publications
The following publications are available in Adobe Acrobat Portable Document
Format (PDF) on the IBM FAStT Storage Manager CD and at
http://www.ibm.com/pc/support/.

v IBM FAStT Storage Manager Version 8.2 Installation and Support Guide for
Novell NetWare (this book)

v IBM FAStT Storage Manager Version 8.2 Installation and Support Guide for
Microsoft® Windows NT® and Windows® 2000

v IBM FAStT Storage Manager Version 8.2 Installation and Support Guide for
Linux®

v IBM FAStT Remote Mirror Option Installation and User’s Guide

v IBM TotalStorage™ FAStT700 Fibre Channel Storage Server Installation Guide

v IBM TotalStorage FAStT700 Fibre Channel Storage Server User’s Guide

v IBM FAStT700 Fibre Channel Cabling Instructions

v IBM FAStT FC-2 Host Bus Adapter Installation and User’s Guide

v IBM Netfinity FAStT500 RAID Controller Enclosure Unit Installation Guide

v IBM Netfinity FAStT500 RAID Controller Enclosure Unit User’s Guide

v IBM Netfinity Fibre Channel Cabling Instructions

v IBM FAStT200 and FAStT200 HA Storage Servers Installation and User’s Guide

v IBM FAStT200 Fibre Channel Cabling Instructions

The following diagnostic publications might be of interest:

v IBM FAStT MSJ User’s Guide

v IBM Fibre Channel Hardware Maintenance Manual

v IBM Fibre Channel Problem Determination Guide

v IBM Fibre Channel Basic SAN Configuration Setup Guide

In addition, the following IBM Redbooks™ might be of interest:

v Fibre Array Storage Technology, A FAStT Introduction

v Implementing Netfinity Disk Subsystems: ServeRAID SCSI, Fibre Channel, and
SSA

v Tuning Netfinity Servers for Performance: Getting the most out of Windows 2000
and Windows NT 4.0

v Netfinity Director: Integration and Tools

v Netfinity Clustering Planning Guide

You can download these Redbooks from http://www.ibm.com/redbooks/.
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Chapter 1. Introduction

This installation and support guide provides information for preparing, installing,
configuring, and starting the IBM FAStT Storage Manager Version 8.2 in a Novell
NetWare operating system environment.

Before you begin the installation of this product, consult the README.TXT first.
Refer to the http://www.ibm.com/pc/support IBM Web site for the latest installation
and user information about the storage-management software and hardware
components.

When you finish the installation process, refer to the following online help systems:

v Enterprise Management window help - Use this online help system to learn more
about working with the entire management domain.

v Subsystem Management window help - Use this online help system to learn
more about managing individual storage subsystems.

You can access these help systems from within Storage Manager 8.2 Client. From
either a Enterprise Management or Subsystem Management window, click Help or
press F1.

After installing IBM FAStT Storage Manager Version 8.2, consider installing the
FAStT Management Suite Java¬ (FAStT-MSJ) diagnostic program. You can use this
program to verify the status of the Fiber Channel connections before using the
storage subsystem. The program and the IBM FAStT MSJ User’s Guide are located
on the IBM FAStT Storage Manager Version 8.2 CD.

New features
This section describes the new premium features and standard features that are
part of the IBM FAStT Storage Manager Version 8.2 software. Your storage
subsystem firmware must be at version 5.20.xx if you want to use any of the
features listed in this section. If your controller firmware is at version 04.x or earlier,
you must purchase a firmware upgrade option.

There are two premium features that can be enabled by purchasing a premium
feature key. Descriptions of these premium features are as follows:

v FlashCopy - FlashCopy is a premium feature that is part of the IBM FAStT
Storage Manager 8.2 software and is enabled by purchasing a premium feature
key. This feature supports the creation and management of FlashCopy logical
drives. A FlashCopy logical drive is a logical point-in-time image of another
logical drive, called a base logical drive, in the storage subsystem. A FlashCopy
is the logical equivalent of a complete physical copy, but you create it much more
quickly and it requires less disk space. Because a FlashCopy is a host
addressable logical drive, you can perform backups using the FlashCopy while
the base logical drive remains online and user-accessible. In addition, you can
write to the FlashCopy logical drive to perform application testing or scenario
development and analysis. The maximum FlashCopy logical drives allowed is
one half of the total logical drives supported by your controller model.

v Remote Mirror Option - The Remote Mirror Option is a premium feature that is
part of the IBM FAStT Storage Manager 8.2 software and is enabled by
purchasing a premium feature key. The Remote Mirror Option is used for online,
real-time replication of data between storage subsystems over a remote distance.
In the event of a disaster or unrecoverable error on one storage subsystem, the

© Copyright IBM Corp. 2001, 2002 1



Remote Mirror Option enables you to promote a second storage subsystem to
take over responsibility for normal input/output (I/O) operations. When the
Remote Mirror option is enabled, the maximum number of logical drives per
storage subsystem is reduced. For more information, refer to “Number of
supported logical drives” on page 18.

In addition to the new premium features, the storage-management software
includes the following new standard features:

v Dynamic logical-drive expansion - this feature enables you to increase the
capacity of an existing logical drive. You can use the free capacity of a logical
drive on an existing array, or add unconfigured capacity (new or unassigned
drives) to that array. You can expand a logical drive dynamically without losing
access to it, or to any other logical drives.

v 2048 logical drive support - this feature enables you to increase the number of
defined logical drives up to 2048 for each storage subsystem. The number of
logical drives will depend on your controller model. For more information refer to
“Number of supported logical drives” on page 18.

v Storage Partitioning - this feature gives you support for up to 64 storage
partitions. Specifically, there is support for up to two host ports in each host and
up to eight ports in each host group (supporting a four-way host group of
dual-adapter hosts).

v Script Engine and Command Line Interface (CLI) Language - this feature
expands previous version support to include: creating and deleting a FlashCopy
logical drive, setting FlashCopy logical drive attributes, supporting dynamic logical
drive expansion for standard or repository logical drives, disabling or recreating a
FlashCopy, creating or deleting logical drive-to-LUN mappings, uploading Read
Link Status data from a storage subsystem to a comma delimited file on a
management station, and downloading a feature key file to a storage subsystem
to enable a premium feature.

v Read Link Status Diagnostic (RLS) - this feature enhances controller diagnostics
enabling you to isolate the source of link problems on a Fibre Channel loop.
During communication between devices, RLS error counts are detected within
the traffic flow of the loop. Error count information is accumulated over a period
of time for every component and device on the loop. The baseline is
automatically set by the controller; however, a new baseline is set manually
through the Read Link Status Diagnostics window.

v Redesigned user interface - this feature supports a more integrated process of
creating logical drives and then mapping them to hosts or host groups and logical
unit numbers to create storage partitions. The previous Storage Partitions window
is now a Mappings View that you can switch to from the Logical/Physical View.

In the Subsystem Management window, the Mappings View displays storage
partition topology such as the default and defined host groups, hosts, host ports
in a tree, and FlashCopy logical drives.

v Controller default IP address - Unless a static IP address is assigned to the
controller by the administrator, controllers A and B will automatically be assigned
the following IP addresses:

– Controller A (192.168.128.101)

– Controller B (192.168.128.102)

The subnet mask for the default IP address is 255.255.255.0.
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Supported machine types
Table 1 provides a list of machine type and supported storage-management
software.

Table 1. Machine type and supported storage-management software

Product name Machine
type

Model Firmware
version

Supported
storage-management
software version

Netfinity® Fibre Channel RAID
Controller Unit

3526 1RU
1RX

4.x 7.02, 7.10, 8.0, 8.2

IBM FAStT200 3542 1RU
1RX

4.x, 5.20.x 7.02, 7.10, 8.0, 8.2

IBM FAStT200 HA 3542 2RU
2RX

4.x, 5.20.x 7.02, 7.10, 8.0, 8.2

Netfinity FAStT500 RAID
Controller Enclosure Unit

3552 1RU
1RX

4.x, 5.00.x,
5.20.x

7.02, 7.10, 8.0, 8.2

IBM TotalStorage™ FAStT700
Fibre Channel Storage Server

1742 1RU
1RX

5.00.x,
5.20.x

8.0, 8.2

Note: Storage subsystem firmware must be at version 04.00.02.00 or higher to be
managed with Storage Manager 8.2.

Terms to know
If you are upgrading from a previous version of the storage-management software,
you will find that some of the terms you are familiar with have changed. It is
important that you familiarize yourself with the new terminology. Table 2 provides a
list of some of the new terminology.

Table 2. New terminology

Term used in previous versions New term

RAID module Storage subsystem

Drive group Array

Volume Logical drive

It is important to understand the distinction between the following two terms when
reading this document:

Management station
A management station is a system that is used to manage the storage
subsystem. It can be attached to the storage subsystem in the following
ways:

v Through a TCP/IP Ethernet connection to the controllers in the storage
subsystem

v Through a TCP/IP connection to the host-agent software that is installed
on a host computer, which in turn is directly attached to the storage
subsystem through the Fibre Channel input/output (I/O) path

Host computer
A host computer is a system that is directly attached to the storage
subsystem through a Fibre Channel I/O path. This system is used to do the
following:

Chapter 1. Introduction 3



v Serve data (typically in the form of files) from the storage subsystem

v Function as a connection point to the storage subsystem for a
remote-management station

Notes:

1. The terms host and host computer are used interchangeably throughout
this book.

2. A host computer can also function as a management station.

IBM FAStT Storage Manager Version 8.2 software
Storage Manager Version 8.2 contains the following software components for a
Novell NetWare environment:

v Java Virtual Machine (JVM) for NetWare

v Storage Manager 8.2 Client (SMclient)

v Storage Manager 8.2 Agent (SMagent)

v Storage Manager 8.2 Utility (SMutil)

v IBM Storage Area Network (IBMSAN) driver

v IBM Host Adapter device driver (QL2x00)

v IBM FAStT Management Suite Java (FAStT MSJagent)1

Storage Manager 8.2 Client
The Storage Manager 8.0 Client (SMclient) component provides the graphical user
interface (GUI) for managing storage subsystems. The SMclient contains two main
components:

v Enterprise Management. You can use the Enterprise Management component
to add, remove, and monitor storage subsystems within the management
domain.

v Subsystem Management. You can use the Subsystem Management component
to manage the components of an individual storage subsystem.

The Event Monitor is a separate program that is bundled with the SMclient. If
installed, it monitors storage subsystems whenever the Enterprise Management
window is closed. It runs continuously in the background and can send alert
notifications in the event of a critical problem.

Storage Manager 8.2 Agent
The Storage Manager Agent (SMagent) provides a management conduit for the
storage manager client to configure and monitor the subsystem through the Fibre
Channel I/O path. The agent also provides local or remote access to the client
depending on whether the client is installed on the host computer or on a
management station over the TCP/IP network.

Storage Manager 8.2 Utility
The Storage Manager 8.2 Utility (SMutil) registers and maps new logical drives to
the operating system. This software package contains the following two
components:

1. Refer to the IBM FAStT MSJ User’s Guide for installation instructions.
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v Hot Add utility. The Hot Add utility enables you to register newly created logical
drives with the operating system. For information on using the Hot Add utility, see
“Using the Hot Add utility” on page 50.

v SMdevices utility. You can use the SMdevices utility to associate storage
subsystem logical drives with operating system device names. For more
information about using SMdevices, see “Using the SMdevices utility” on
page 50.

IBMSAN driver
The IBM Storage Area Network (IBMSAN) driver is used in a Novell NetWare
environment to provide multipath I/O support to the storage controller. The IBMSAN
driver is a custom device module (CDM) that is installed with the IBM FAStT Host
Adapter device driver. In case of a failure along the I/O path, the driver sends the
I/O requests through the alternate path and Auto-Volume Transfer (AVT) moves the
logical drive within the FAStT Storage Server.

IBM FAStT Host Adapter device driver
The IBM FAStT Host Adapter device drivers, (QL2x00) will enable your operating
system to communicate with the host adapter. The IBM FAStT Host Adapter is a
high-performance, direct memory access (DMA), bus-master, host adapter designed
for high-end systems. The IBM FAStT Host Adapter supports all Fibre Channel (FC)
peripheral devices that support private-loop direct attach (PLDA) and fabric-loop
attach (FLA). Refer to the IBM FAStT Host Adapter Installation and User’s Guide
and the http://www.ibm.com/pc/support IBM Web page for the current README file
and latest multipath I/O device drivers.

Storage subsystem management methods
The storage-management software provides two methods for managing storage
subsystems: the host-agent managed method and the directly managed method.
Depending on your specific storage-subsystem configurations, you can use either or
both methods. The management methods you select will determine where you will
need to install the software components.

Host-agent (in-band) management method
When you use the host-agent (in-band) management method, you manage the
storage subsystems through the Fibre Channel I/O path to the host. The
management information can either be processed in the host or passed to the
management station through the network connection, as shown in Figure 1 on
page 6.

Managing storage subsystems through the host-agent has the following
advantages:

v Ethernet cables do not have to be connected to the controllers.

v A Dynamic Host Configuration Protocol (DHCP)/BOOTP server is not needed to
connect the storage subsystems to the network.

v The controller network configuration tasks that are described in Chapter 2,
“Preparing for installation” on page 19, do not need to be performed.

v A host name or IP address must only be specified for the host instead of for the
individual controllers in a storage subsystem. Storage subsystems that are
attached to the host are automatically discovered.

v If the Fibre Channel connection is broken between the host and the subsystem,
the subsystem cannot be managed or monitored.
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The disadvantage of managing storage subsystems through the host-agent is that
the host-agent requires a special logical drive, called an access logical drive, to
communicate with the controllers in the storage subsystem. Therefore, you are
limited to configuring one fewer logical drive than the maximum number that is
allowed by the operating system and the host adapter that you are using.

Note: The access logical drive is also referred to as the Universal Xport Device.

Important: If your host already has the maximum number of logical drives
configured, either use the direct-management method or give up a logical drive for
use as the access logical drive. For more information, see “Number of supported
logical drives” on page 18.

Network

Host computer

Controller

Controller

Controller

Controller

Fibre Channel
I/O path

Management station
(one or more)

Running the
host-agent software

Storage subsystems

Note: The host can act as a
management station also.

Storage subsystems

Direct (out-of-band) management method
When you use the direct (out-of-band) management method, you manage storage
subsystems directly over the network through an Ethernet connection to each
controller. To manage the storage subsystem through the Ethernet connections, you
must define the static IP address and host name for each controller and attach a
cable to the Ethernet connectors on each of the storage subsystem controllers, as
shown in Figure 2 on page 8.

Note: For more information on setting a static IP address, contact an IBM
technical-support representative for tip HP17389.

Managing storage subsystems using the direct (out-of-band) management method
has the following advantages:

Figure 1. Host-agent (in-band) managed storage subsystems
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v The Ethernet connections to the controllers enable a management station with
the SMclient software installed to manage storage subsystems that are
connected to a host that has any of the operating systems that are supported by
Storage Manager 8.2 installed.

v An access logical drive is not needed to communicate with the controllers. You
can configure the maximum number of logical drives that are supported by the
operating system and the host adapter that you are using.

v There is a constant management station connection to the subsystem that is not
dependent on the host agent enabled hosts.

Managing storage subsystems using the direct (out-of-band) management method
has the following disadvantages:

v Two Ethernet cables are required to connect the storage subsystem controllers to
a network.

v When adding devices, you must specify an IP address or host name for each
controller.

v A DHCP/BOOTP server and network preparation tasks are required. For a
summary of the preparation tasks, see “Preparing a network installation” on
page 20.

Note: If the storage subsystem controllers have firmware version 05.xx.xx, they
have the following default settings:

Controller IP address Subnet mask

A 192.168.128.101 255.255.255.0

B 192.168.128.102 255.255.255.0

v Static IP addresses can also be assigned to the controllers. Refer to the IBM
support Web site for Retain Tip #H171389 ″Unable To Setup Networking Without
DHCP/BOOTP″.

If you opt to use the default IP addresses or static TCP/IP address, a
DHCP/BOOTP server is not necessary and you do not have to perform the “Setting
up the DHCP or BOOTP-compatible server” on page 24 procedure.
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Figure 2 shows a system in which storage subsystems are managed using the
direct (out-of-band) management method.

Ethernet

Host computer

Fibre Channel
I/O path

Management station
(one or more)

Controller

Controller

Controller

Controller

Storage subsystems

Storage subsystems

Where to install software components
How you have decided to manage the storage subsystems will determine where
you will need to install the various software components.

Management stations
You must install the following software components on each management station:

v Storage Manager 8.2 Client (SMclient)

v FAStT MSJ

Host computers
You must install the following software components on each host computer:

v Java Virtual Machine for NetWare

v Storage Manager 8.2 Utility (SMutil)

v IBM SAN driver

v IBM Host Adapter device driver (QL2x00)

Depending on how you intend to manage the storage subsystems, you might need
to install the following software components:

v Storage Manager 8.2 Agent (SMagent)

Figure 2. Directly (out-of-band) managed storage subsystems
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v Storage Manager 8.2 Client (SMclient)

The SMagent must be installed on a host computer if you intend to manage the
storage subsystems using the host-agent management method.

The SMclient must be installed on a host computer if you intend the host computer
to act as a management station. If the host computer is not connected to a network,
it must have TCP/IP software installed, and you must assign an IP address to the
host.

Configuration types
You can install Storage Manager 8.2 in one of two configurations:

v Standard (noncluster) configuration.

v Cluster server configuration.

Standard (noncluster) configuration
Figure 3 shows a sample standard (noncluster) configuration.

Ethernet

Host computer

Controller

Controller

Controller

Controller

Fibre Channel
I/O path

Management station
FAStT MSJ, SMclient

QLRemote agent,
FAStT device driver,
SMutil, and host-agent
IBM SAN driver, and
SMclient

The client software is
installed on one or more

management stations,
or on the host computer.

Storage subsystems

Storage subsystems

Figure 3. Sample standard (noncluster) configuration
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Cluster server configuration
Figure 4 shows an example of a cluster server configuration.

Ethernet

Fibre Channel
I/O path

Management station
(one or more)

Cluster server
node 01

Cluster server
node 02

QLRemote agent, FAStT device driver, SMclient,
SMutil, IBM SAN driver, and SMagent

Controller

Controller

Storage subsystems

Managed hub or
switch

The SMclient software
is installed on one or more
management stations, or
on the cluster servers.

Installation types
You can install the storage-management software in two types of hardware
environments:

v New storage subsystem environment. You are installing the IBM TotalStorage
FAStT Fibre Channel Storage Server using firmware 05.20.xx.xx and you will
manage storage subsystems using Storage Manager 8.2.

v Existing storage subsystem environment. You are installing the
storage-management software in an environment with existing storage
subsystems. See Table 3 on page 11 for your installation options in an
environment with existing storage subsystems.

Figure 4. Sample cluster server configuration
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Table 3. Configurations for existing storage subsystems

Current environment Planned environment Action

(Machine type 3552)
Existing storage
subsystems with
controllers that have
firmware versions
04.00.02.xx through
04.01.xx.xx

Upgrade firmware to
version 05.20.xx.xx

Manage all storage
subsystems using
Storage Manager 8.2

1. Purchase upgrade option. Contact
your IBM service representative for
more information.

2. Uninstall Storage Manager version
7.x. Refer to “Uninstalling
storage-management software
components” on page 52 for more
information.

3. Install Storage Manager 8.2. Refer to
“New installation process” on page 37
for more information.

4. Discover the storage subsystems.
Refer to “Performing an initial
automatic discovery of storage
subsystems” on page 43 for more
information.

5. Download firmware and NVSRAM
version 5.20.xx.xx. Refer to
“Downloading firmware and
NVSRAM” on page 46 for more
information.

(Machine types 3526,
3542, 3552) Existing
storage subsystems
with controllers that
have firmware versions
04.00.02.xx through
04.01.xx.xx

Retain existing firmware
versions.

Manage all storage
subsystems using
Storage Manager 8.2.

1. Uninstall Storage Manager version
7.x. Refer to “Uninstalling
storage-management software
components” on page 52 for more
information.

2. Install Storage Manager 8.2. Refer to
“New installation process” on page 37
for more information.

3. Discover the storage subsystems.
Refer to “Performing an initial
automatic discovery of storage
subsystems” on page 43 for more
information.

(Machine types 3526,
3552) Existing storage
subsystems with
controllers that have
firmware versions
04.00.xx.xx through
04.00.01.xx

Upgrade firmware to
version 04.00.02.xx or
higher.

Manage all storage
subsystems using
Storage Manager 8.2.

1. Uninstall Storage Manager version
7.x. Refer to “Uninstalling
storage-management software
components” on page 52 for more
information.

2. Install Storage Manager 8.2. Refer to
“New installation process” on page 37
for more information.

3. Discover the storage subsystems.
Refer to “Performing an initial
automatic discovery of storage
subsystems” on page 43 for more
information.

4. Upgrade the firmware to version
4.00.02.xx or higher. Go to the IBM
Web site; download the firmware and
matching NVSRAM.
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Table 3. Configurations for existing storage subsystems (continued)

Current environment Planned environment Action

(Machine types 3526,
3552) Existing storage
subsystems with
controllers that have
firmware versions
04.00.xx.xx through
4.00.01.xx

Retain existing firmware
versions.

Manage existing
storage subsystems
using Storage Manager
7.01.

Set up a separate management station
with Storage Manager 7.01 installed to
manage the storage subsystems with
controllers that have back-level firmware.

(Machine type 1742)
Existing storage
subsystems with
controllers that have
firmware versions
05.00.xx.xx

Upgrade firmware to
version 5.20.xx.xx.
Manage all storage
subsystems using
Storage Manager 8.2.

1. Uninstall Storage Manager 8.0. See
“Uninstalling storage-management
software components” on page 52 for
more information.

2. Install Storage Manager 8.2. See
“Storage Manager 8.2 Client” on
page 38 for more information.

3. Discover the storage subsystems.
See “Performing an initial automatic
discovery of storage subsystems” on
page 43for more information.

4. Download firmware and NVSRAM
version 5.20.xx.xx. See “Downloading
firmware and NVSRAM” on
page 46for more information.

(Machine type 3542)
Existing storage
subsystems with
controllers that have
firmware versions
04.00.02.xx through
04.01.xx.xx

Upgrade the firmware to
version 5.20.xx.xx.
Manage all storage
subsystems using
Storage Manager 8.2.

1. Purchase the upgrade option.
Contact your IBM service
representative for more information.

2. Uninstall Storage Manager 7.0. See
“Uninstalling storage-management
software components” on page 52 for
more information.

3. Install Storage Manager 8.2. See
“Storage Manager 8.2 Client” on
page 38 for more information.

4. Discover the storage subsystems.
See “Performing an initial automatic
discovery of storage subsystems” on
page 43 for more information. Go to
the IBM Web site to download the
04.01.02.26 or higher firmware and
matching NVSRAM.
Note: The storage subsystem
controllers must be at firmware level
04.01.02.26 or higher before
downloading firmware level 05.20.xx
and NVSRAM to the controllers.

5. Download firmware level 04.01.02.26
or higher and its associated
NVSRAM. See “Downloading
firmware and NVSRAM” on page 46
for more information.

6. Download firmware and NVSRAM
version 5.20.xx.xx. See “Downloading
firmware and NVSRAM” on page 46
for more information.
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Managing coexisting storage subsystems
Storage subsystems are coexisting storage subsystems when the following
conditions are met:

v There are multiple storage subsystems with controllers that have different
versions of firmware.

v These storage subsystems are attached to the same host.

For example, a coexisting situation exists when you have a new storage subsystem
with controllers that have firmware version 05.20.xx.xx, and it is attached to the
same host in one or more of the following configurations:

v A storage subsystem with controllers that have firmware versions 04.00.xx.xx
through 04.00.01.xx, which is managed by a separate management station with
Storage Manager 7.01.

v A storage subsystem with controllers that have firmware versions 04.00.02.xx
through 04.01.xx.xx, which is managed with Storage Manager 8.2.

Important: The common host must have the latest level (8.2) of Storage Manager
Agent installed.
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Figure 5 shows an example of an environment that includes coexisting storage
subsystems.

Ethernet

Host computer

Controller

Controller

Controller

Controller

Fibre Channel
I/O path

Management station
(one or more)

Management station
(one or more)

Host-agent

Client software
Storage subsystems

Firmware version
4.01.x (minimum)

Firmware version 5.x

Version 8.2 of the
storage-management client
software must be installed on either
a management station or host.

Storage subsystems

System requirements
This section provides detailed information about the hardware, software, and
operating system requirements for Storage Manager 8.2.

Figure 5. Sample coexistence installation
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Hardware requirements
Table 4 lists the hardware required for installing Storage Manager 8.2.

Table 4. Hardware requirements for Storage Manager 8.2 software

Hardware component Requirements

A DHCP/BOOTP server (only
for directly managed storage
subsystems)
Note: If the controllers static
address or default IP
addresses are used, you do
not need to setup the
DHCP/BOOTP server.

One of the following BOOTP or BOOTP-compatible servers:

v Microsoft BOOTP-compatible DHCP server for Windows NT

v Microsoft BOOTP-compatible DHCP server for Windows
2000

v UNIX® BOOTP server

v NetWare DHCP server

Storage subsystems (one or
more)

Storage subsystems with controllers running firmware version
04.00.02.xx through 05.20.xx.xx.
Note: Read “Installation types” on page 10 for information on
managing these storage subsystems when existing storage
subsystems are physically connected to the same host that
you will connect to the new storage subsystems.

Fibre Channel (FC) host
adapters

The following Fibre Channel host adapters were tested with
the storage-management software:

v IBM Netfinity FAStT host adapter (part number: 00N6881)

v IBM FAStT FC-2 host bus adapter (part number: 19K1246)

For information on specific host adapter requirements:

v Refer to the README file in the \Host_Adapter directory on
the installation CD.

v Read the host adapter documentation.

v Refer to the http://www.ibm.com/pc/support Web site

Fibre Channel (FC) fabric
switches (if needed for the
desired configuration)

The following Fibre Channel fabric switches were tested with
the storage management software:

v IBM 8-port Fibre Channel switch (machine type: 2109-S08)

v IBM 16-port Fibre Channel switch (machine type:
2109-S16)

v IBM 16-port 2 Gbps Fibre Channel switch (machine type:
2019-F16)

v IBM 8-port 2 Gbps Fibre Channel switch (machine type:
3534-F08)

For specific Fibre Channel switch setup requirements:

v Read the switch documentation.

v Refer to the http://www.ibm.com/storage/fcswitch Web site

Fibre Channel (FC) managed
hub (if needed for the
desired configuration)

The following managed hub was tested with the storage
management software:

v IBM Fibre Channel managed hub (machine type: 3534)

For specific Fibre Channel managed hub setup requirements:

v Read the managed hub documentation.

v Refer to the http://www.ibm.com/storage/fchub Web site
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Table 4. Hardware requirements for Storage Manager 8.2 software (continued)

Hardware component Requirements

Management station (for
client software)

Your management station computer will require:

v Intel® Pentium® or Pentium-equivalent microprocessor (133
MHz or faster)

v CD-ROM drive

v Mouse or similar pointing device

v System memory:

– For Windows NT 4.0: A minimum of 64 MB (128 MB
recommended)

– For Windows 2000: A minimum of 128 MB (256 MB
recommended)

v Ethernet network interface adapter

v AGP or PCI video adapter (AGP preferred), ISA adapters
are not supported

v Monitor setting of 1024 x 768 pixels with 64,000 colors. The
minimum display setting that is allowed is 800 x 600 pixels
with 256 colors.

v Hardware-based Windows acceleration: Desktop computers
that use system memory for video memory are not
preferred for use with the storage-management software.

Important: Many PC-based servers are not designed to run
graphic-intensive software. If your server has difficulty running
the storage-management software smoothly without video
artifacts, you might need to upgrade the server video adapter.

Note: For more information about host adapters, fabric switches, and managed
hubs, consult the ServerProven™ Web site at
http://www.ibm.com/pc/us/compat/.

Firmware requirements
To utilize all of the standard and premium features of Storage Manager 8.2, your
storage subsystem must contain controllers with firmware version 05.20.xx.xx. To
manage storage subsystems with Storage Manager 8.2, your existing storage
subsystems must contain controllers with firmware versions 04.00.02.xx or higher.

If you want to utilize the Storage Manager 8.2 standard features on machine types
3542 and 3552, you must purchase an optional firmware upgrade. The optional
firmware upgrade will bring your firmware versions from 04.00.xx.xx (or higher) to
05.20.xx.xx. In addition, the Storage Manager 8.2 also supports two premium
features that must be purchased; FlashCopy and the Remote Mirror Option.

For more information about the firmware upgrade option or FlashCopy and Remote
Mirror premium feature options, contact your IBM technical-support representative.

Software requirements
Table 5 lists the disk space and administrator privileges required for installing the
Storage Manager 8.2 software.

Table 5. Installation requirements by software package

Package Disk space requirement

Storage Manager 8.2 Client (SMclient) 35 MB
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Table 5. Installation requirements by software package (continued)

Package Disk space requirement

Storage Manager 8.2 Agent (SMagent) 1 MB

Storage Manager 8.2 Utility (SMutil) 22 MB

IBM SAN driver 1 MB

IBM FAStT Management Suite Java (FAStT MSJ) 1 MB

IBM HA device driver 1 MB

Java Virtual Machine for NetWare 37MB

Operating system requirements
Each management station, host computer, or cluster node requires one of the
following operating systems:

Management stations. Install one of the following operating systems:

v Windows NT 4.0 Server with Service Pack 6a

v Windows NT 4.0 Enterprise Edition with Service Pack 6a

v Windows NT 4.0 Workstation with Service Pack 6a

v Windows 2000 Server with Service Pack 2

v Windows 2000 Professional with Service Pack 2

v Windows 2000 Advanced Server with Service Pack 2

Host computers. Install Novell NetWare 5.1 with Service Pack 2a or later.

Cluster nodes. Novell NetWare 5.1 with Service Pack 2 or later.

Chapter 1. Introduction 17



Number of supported logical drives
There is a limit to how many logical unit numbers (LUNs) can access the logical
drives on a single storage subsystem. The maximum number of logical drive that a
FAStT storage subsystem supported with firmware version 05.20.xx.xx depends on
the model of the FAStT storage subsystem.

Table 6. Logical drives without the remote mirror option enabled

Model
Type

Maximum logical drives Maximum logical drives
per storage unit partition

Maximum flashCopy
logical drives

3542 5121 325 2562

3552 5121 325 2562

1742 20481 325 10242

Table 7. Logical drives using the remote mirror option

Model Type Maximum logical
drives

Maximum logical drives
per storage unit
partition

Maximum flashCopy
logical drives

3542 N / A N / A N / A

3552 1283,6 325 642

1742 2561,4,6 325 1282

Note: The access logical drive is also referred to as the Universal Xport Device.

1.When using firmware version 5.xx.xx, the firmware reserves one logical drive for
use by the system.

2. Maximum of four FlashCopy logical drives for each standard logical drive

3. Maximum of eight remote mirror pairs

4. Maximum of 16 remote mirror pairs

5.The host-agent management method uses a special logical drive, called an access
logical drive, to communicate with the controllers on the storage subsystem. The
access logical drive uses one of the available LUNs. Therefore, managing storage
subsystems with the host-agent software limits you to one fewer LUN than the
maximum number supported by the operating system and the host adapter.

6.For firmware version 05.20.xx.xx, the maximum number of logical drives includes
the flash Copy repository logical drives and the remote mirror logical drives, in
addition to the standard data logical drives. If the remote mirror option is enabled,
two logical drives are reserved for use by the system.
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Chapter 2. Preparing for installation

This chapter provides information to help you plan for the installation of the
storage-management software.

Table 8 contains information about where the Storage Manager software
components will need to be installed.

Table 8. Software component installation in a Novell NetWare environment

System type Software installation sequence

Management station 1. Java Virtual Machine (JVM) for NetWare version 1.3.1

2. Storage Manager 8.2 Client (SMclient)

Host computer /
cluster node

1. Storage Manager 8.2 Client (SMclient)

v Optional component

v Necessary if you intend to manage the storage subsystem from
the host computer

2. Storage Manager 8.2 Agent (SMagent)

v Optional component

v Necessary if you intend to use the host-agent management
method.

3. Storage Manager 8.2 Utility (SMutil)

v Required component

v Contains the Hot Add, SMdevices, and SMflashcopyassist
utilities

4. IBM Storage Area Network (SAN) driver

5. IBM Host Adapter device driver (QL2x00)

Storage subsystem management methods
If you have not already done so, see Chapter 1, “Introduction” on page 1 for
information about the following two methods for managing storage subsystems:

v Direct (out-of-band) management: The storage subsystems are managed
through a TCP/IP Ethernet connection to each controller on the storage
subsystem.

v Host-agent (in-band) management: The storage subsystems are managed
through host-agent software that is installed on a host computer connected to the
storage subsystem.

You can use one or both methods. However, because many of the preparation
tasks for installation depend on which method you use, decide how you want to
manage the storage subsystems on your network before you begin.

Reviewing a sample network
Figure 6 on page 20 shows an example of a network containing both a
directly-managed storage subsystem (Network A) and a host-agent-managed
storage subsystem (Network B).

Direct-managed storage subsystem: Network A is a direct-managed storage
subsystem. Network A contains the following components:
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v DHCP/BOOTP server

v Network Management Station (NMS) for Simple Network Management Protocol
(SNMP) traps

v Host that is connected to a storage subsystem through a Fibre Channel I/O path

v Management station connected by Ethernet cable to the storage subsystem
controllers

Host-agent-managed storage subsystem: Network B is a a host-agent-managed
storage subsystem. Network B contains the following components:

v Host that is connected to a storage subsystem through a Fibre Channel I/O path

v Management station connected by Ethernet cable to the host computer

Controller

Controller

Controller

Controller

Storage
subsystem

finance

Storage
subsystem
engineering

Fibre Channel
I/O path

Fibre Channel
I/O path

Network A
TCP/IP

Network B
TCP/IP

Ethernet

Router

Network
management

station
(for SNMP traps)

Management
station

(one or more)

Management
station

(one or more)

Host computer
Denver

(IP address
192.168.1.12)

Host computer
Atlanta

(IP address
)192.168.2.22

DHCP/BOOTP server

Host name: Denver_a
(IP address )

hardware address 00.a0.b8.02.04.20
192.168.128.101

Host name: Denver_b
(IP address )

hardware address 00.a0.b8.00.00.d8
192.168.128.102

Ethernet

Preparing a network installation
To begin installing the storage-management software, ensure that the network
components are set up and operating properly, and that you have all the host and
controller information needed for the software to operate correctly.

The following list provides a high-level overview of the steps involved in setting up a
network installation.

Step 1. Install all hardware components (host computers, storage subsystems, and
cables) that you want to connect to the network. You might need to refer to
the installation guides specific to the hardware components.

Figure 6. Sample network using direct-managed and host-agent-managed storage
subsystems
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Step 2. Establish a naming convention for the storage subsystems connected to
the network. Refer to “Naming the storage subsystems” on page 22 for
more information.

Step 3. Record the storage subsystem names and management types in Table 13
on page 55. An example of a completed information record is shown in
Table 9.

Note: Throughout the remaining steps, you will need to return to Table 13
on page 55 to record information such as hardware Ethernet
addresses and IP addresses.

Step 4. (For a direct-managed system only) Determine the hardware Ethernet
address for each controller in storage subsystems connected to the
network. Refer to “Identifying the hardware Ethernet MAC address for each
controller” on page 22 for more information.

Step 5. Obtain the following information from the network administrator.

For a direct-managed system The IP addresses of each controller in the storage
subsystems

For a host-managed system The IP address and host name of the host computer on
which the host-agent software will run

Refer to “Assigning IP addresses for hosts and controllers” on page 24 for
more information. For a direct managed system only, if you are using a
default controller IP address, go to step 7.

Step 6. (For a direct-managed system only) Set up the DHCP/BOOTP server to
provide network configuration information for a specific controller, however,
if you are using a controller static IP address, skip this step.

Step 7. Verify that the TCP/IP software is installed. For more information, see
“Verifying the TCP/IP protocol and setting up the host or DNS table” on
page 34.

Step 8. (For a direct-managed system only) Verify that the TCP/IP software is
installed, and set up the host or Domain Name Server (DNS) table. For
more information, see “Verifying the TCP/IP protocol and setting up the
host or DNS table” on page 34.

Step 9. Power on the devices connected to the network.

Table 9 shows a sample information record for the network shown in Figure 6 on
page 20. This network contains storage subsystems managed using both the
direct-management and host-agent-management method.

Table 9. Sample information record

Storage
subsystem name

Management
type

Controllers—Ethernet and IP
addresses, and host name

Host—IP
address and

host nameController A Controller B

Finance Direct Hardware
Ethernet address
= 00a0b8020420

Hardware
Ethernet address
= 00a0b80000d8

IP address =
192.168.128.101

IP address =
192.168.128.102

Host = Denver_a Host = Denver_b

Engineering Host agent IP address =
192.168.2.22

Host = Atlanta
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Naming the storage subsystems
As you set up your network, decide on a naming convention for the storage
subsystems. When you install the storage-management software and start it for the
first time, all storage subsystems in the management domain are displayed as
<unnamed>. Use the Subsystem Management window to rename the individual
storage subsystems.

Consider the following when naming storage subsystems:

v There is a 30-character limit. All leading and trailing spaces are deleted from the
name.

v Use a unique, meaningful naming scheme that is easy to understand and
remember.

v Avoid arbitrary names or names that might quickly lose their meanings.

v The software displays storage-subsystem names with the prefix Storage
Subsystem. Therefore, if you rename a storage subsystem to Engineering, it is
displayed as:
Storage Subsystem Engineering

After you decide on a naming scheme, record the storage subsystem names in the
information record (Table 13 on page 55).

If you plan to manage your storage subsystem using the direct-management
method, go to “Identifying the hardware Ethernet MAC address for each controller”.
If you plan to manage your storage subsystem using the host-agent management
method, go to “Assigning IP addresses for hosts and controllers” on page 24.

Identifying the hardware Ethernet MAC address for each controller
To manage your storage subsystem using the direct-management method, you
need to identify the hardware Ethernet MAC address for each controller.

To identify the hardware Ethernet MAC address for machine type 3542, do the
following:

1. Locate the Ethernet MAC address at the back of the unit, under the controller
Gigabit Interface Converter (GBIC) ports, as shown in Figure 7 on page 23. The
number will be in the form xx.xx.xx.xx.xx.xx (for example, 00.a0.b8.20.00.d8).

2. Record each Ethernet address in the information record (Table 13 on page 55).
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To identify the hardware Ethernet MAC address for machine types 3552 and 1742,
do the following:

1. Remove the front bezel from the storage subsystem, as shown in Figure 8.
Carefully pull the bottom of the bezel out �1�to release the pins; then, slide the
bezel down �2�.

2. On the front of each controller, look for a label with the hardware Ethernet MAC
address. The number will be in the form xx.xx.xx.xx.xx.xx (for example,
00.a0.b8.20.00.d8).

3. Record each Ethernet address in the information record (Table 13 on page 55).

4. To replace the bezel, slide the top edge under the lip on the chassis �1�; then,
push the bezel bottom until the pins snap into the mounting holes �2�, as shown
in Figure 9 on page 24.

Hardware Ethernet
address label

Figure 7. Locating the Ethernet MAC address for machine type 3542

Figure 8. Removing the controller-unit bezel (machine types 3552 and 1742)
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5. Continue with “Assigning IP addresses for hosts and controllers”.

Assigning IP addresses for hosts and controllers
If you plan to manage your storage subsystem using the direct-management
method, assign a unique IP address for every controller in all storage subsystems
on the network. Record the IP address for each controller in the information record
(Table 13 on page 55). Then, go to “Setting up the DHCP or BOOTP-compatible
server”.

Note: If you want to assign static IP addresses for the controllers, refer to the IBM
support Web site for Retain Tip #H171389 ″Unable To Setup Networking
Without DHCP/BOOTP″. Then, go to “Verifying the TCP/IP protocol and
setting up the host or DNS table” on page 34.

If you plan to manage your storage subsystem using the host-agent management
method, assign an IP address for each host on which you will instal the host-agent
software. Record the IP address for each host in the information record (Table 10
on page 45). Then, go to “Verifying the TCP/IP protocol and setting up the host or
DNS table” on page 34.

Setting up the DHCP or BOOTP-compatible server
To directly manage storage subsystems through the Ethernet connection to each
controller, you will need to set up a DHCP or BOOTP-compatible server and
configure the following options:

v Router/Gateway

v DNS Server

v Hostname

v DNS Domain Name

This section provides instructions for setting up a DHCP server on Windows NT,
Windows 2000, and Novell NetWare, as well as instructions for setting up a UNIX
BOOT server.

Note: The remote management station (RMS) and network management station
(NMS) entries used in previous versions of the storage-management
software are not required when using Storage Manager 8.2.

Figure 9. Replacing the controller-unit bezel (machine types 3552 and 1742)
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Setting up a Windows NT DHCP server
You must use a version of DHCP that supports BOOTP static addressing. To use a
DHCP server, you must have a DHCP Manager installed. If a DHCP Manager is
installed on the system, go to “Setting up a DHCP server”. If a DHCP Manager is
not installed, use the following installation procedure to install one.

Installing the DHCP Manager
Use the following procedure to install the DHCP Manager:

1. Click Start → Settings → Control Panel.

2. Click Network. The Network window opens.

3. Click Services.

4. From the Services tab, click Add.

5. Click Microsoft DHCP Server; then, click OK.

6. Specify the path to the Windows NT Install file; then, click Continue. A
dialogue windows opens, stating that a static IP address is required.

7. Click OK. The Network window opens.

8. Click Protocols.

9. Click TCP/IP Protocol; then, click Properties.

10. Verify that the IP address information is correct; then, click OK.

11. Continue to “Setting up a DHCP server”.

Note: After installing the DHCP Manager, you can refer to its online help for
additional information.

Setting up a DHCP server
Use the following procedure, along with the information you recorded in Table 13 on
page 55, to set up a DHCP server.

1. Click Start → Programs → Administrative Tools → DHCP Manager. The DHCP
Manager window opens.

2. Create a scope. A scope defines a group of controllers that you want to
configure using the DHCP server.

a. Click Local Machine.

b. Click Scope → Create. The Create Scope - (Local) window opens.
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c. Type the starting and ending IP addresses of the controllers that you are
configuring for the network.

For example, if you are configuring 50 controllers on a 153.79.144.0 subnet,
set the starting address to 153.79.144.1 and the ending address to
153.79.144.50.

Note: If each field does not contain at least three characters, press the
period (.) key to advance to the next field. If you have only one
controller, type its address for both the starting and ending address.

d. Type the subnet mask (obtained from your network administrator).

e. Set the Lease Duration to Unlimited. This makes the DHCP connection
permanent.

f. Type a scope name and comment.

g. Click OK.

h. When the scope successfully completes, click Yes to activate it. This returns
you to the DHCP Manager window.

3. Configure global scope options. Table X shows the global options that need to
be set.

Table 10. Global options for a Windows NT DHCP server

Number Description Notes

003 Router/Gateway

006 DNS Server

012 Host name Unique for each controller

015 DNS domain name For example, ibm.com

You can apply options to specific controllers later using step 5 on page 27.

a. Click DHCP Options → Global. The DHCP Options: Global window opens.

b. To make a global option active, select an item in the Unused Options list;
then, click Add to move it to the Active options list.

c. Click Value to assign a value to the active option.

If the Value field is not available, click Edit Array; the Edit Array Editor
window opens. Do one of the following:

v If you need to add an IP address, complete the following procedure:

Figure 10. Create Scope - (Local) window

Figure 11. DCHP Options: Global window
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1) Click Edit Array. The IP Address Array Editor window opens.

2) Type a unique IP address for the option that you added.

3) Click Add to move the New IP Address to the IP Addresses list.

4) Click OK. This returns you to the DHCP Options: Global window.

v If you do not need to add an IP address, click Cancel. This returns you to
the DHCP Options: Global window.

d. Repeat step 3b through step 3c until all global options are added.

e. When you finish adding the Global Scope Options, click OK at the DHCP
Options: Global window.

4. Create a reservation for each controller. Use the information record (Table 13 on
page 55) to make sure that you include all of the controllers on the network.

a. Click Scope → Add Reservations.

b. In the IP Address field, type the IP address for the first controller on your
data sheet.

c. In the Unique Identifier field, type the controller hardware Ethernet address.
Do not type decimal points or spaces.

d. In the Client Name field, type the controller eight-character name.

e. Click Add.

f. Repeat step 4b through step 4e for each controller that is listed on
information record (Table 13 on page 55).

g. When you finish adding the information for all of the controllers, click Close.
This returns you to the DHCP Manager window.

5. Configure controller-specific options. By creating a controller-specific option, you
can associate a controller configuration entry with a specific controller.

Note: If you set an option as Global Scope, it applies to every controller in this
group and does not need to be added again.

Figure 12. IP Address Array Editor window
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a. Click Scope → Active Leases. The Active Leases window opens.

b. Select a controller in the list.

c. Click Properties. The Add Option Type window opens. The Unique Identifier
is the hardware Ethernet address from step 4c.

d. Click Options. The DHCP Options: Reservations window opens.

e. Select an option from the Unused Options list, and click Add to move it to
the Active Options list.

f. Click Value to assign a value to the active option.

g. Type the information for the value of the option. For example, type the host
name for the controller from your information record (Table 13 on page 55) in
the String field. Click Edit if the value that you need to add is an IP address
for a router.

h. Repeat step 5e through step 5g until you finish adding specific options for
this controller.

i. Click OK. This returns you to the Add Option Type window.

j. Click OK. This returns you to the Active Leases window.

k. Repeat step 5b through step 5j until you finish adding controller-specific
options for every controller.

Figure 13. Active Leases window

Figure 14. Add Option Type window
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l. Click OK on the Active Leases window. This returns you to the DHCP
Manager window.

6. Do the following to add a network management custom option:

a. From the DHCP Manager window, select a scope; then, select DHCP
Options: Defaults. The DHCP Option: Defaults window opens.

b. In the Name field, type Network Management Station.

c. In the Data Type field, select IP Address; then, select the Array check box.

d. In the Identifier field, type 165.

e. In the Description field, type a description of the SNMP servers to which
the controllers will send alerts.

f. Click OK.

7. Continue with “Verifying the TCP/IP protocol and setting up the host or DNS
table” on page 34.

Setting up a Windows 2000 DHCP server
You must use a version of DHCP that supports BOOTP static addressing. To use a
DHCP server, you must have a DHCP Manager installed. If a DHCP Manager is
installed on the system, go to “Setting up a DHCP server”.

Installing the DHCP Manager
To install the DHCP Manager, do the following:

1. Click Start → Administrative Tools → Configure Your Server. The Configure
Your Server window opens.

2. In the left pane, double-click Networking; then, click DHCP

3. In the right pane, click Start. The Windows Components Wizard starts.

4. In the Components field, select Networking Services; then, click Details.

Note: Do not select the check box; you do not want to install all of the
Networking Services subcomponents.

The Networking Services window opens

5. In the Subcomponents of Networking Services field, select Dynamic Host
Configuration Protocol (DHCP).

6. Click OK; the Windows Components Wizard window opens.

7. Click Next to start the installation process.

8. If prompted, type the full path to the Windows 2000 distribution files and click
Continue.

9. When the installation has successfully completed, the Configure Your Server
Window opens.

10. Click Next.

11. Click Open the DHCP Manager. The DHCP window opens.

12. Continue with step 2 of “Setting up a DHCP server”.

Note: After installing the DHCP Manager, you can refer to its online help for
additional information.

Setting up a DHCP server
Use the following procedure to create a scope and to set up a DHCP server. A
scope defines a group of controllers by their IP addresses. You must create and
configure a scope so that dynamic IP addresses can be assigned to controllers on
your network. Refer to the information record (Table 13 on page 55). Before you
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begin, read through the instructions to determine what information is required; then,
request the information from your network administrator.

1. Click Start → Programs → Administrative Tools → DHCP. The DHCP window
opens.

2. In the Console tree, right-click the server you want to configure; click New
Scope. The New Scope Wizard starts.

3. Follow the on-screen instructions to define the scope of IP addresses for
TCP/IP clients. You will define the following:

a. Scope name and description

b. IP address range for the controllers you are configuring and the subnet
mask

c. IP addresses that you want to exclude from the IP address range

d. IP address lease duration

e. Common DHCP options:

v IP address for a router

v Domain name and DNS servers

4. When you have defined the scope, click Yes, I want to activate this scope
now. The wizard ends, and the DHCP window appears.

5. In the Console tree, open the scope folder.

6. Right-click Reservations; then, select New Reservations. The New
Reservations window opens.

7. To define the IP address reservation, type the following information:

a. Reservation name

b. IP address

c. Ethernet hardware MAC address

d. Description

8. In the Supported Type field, select Both (DHCP and BOOTP).

9. Click Add.

10. Repeat steps 5 through 9 for each controller in the network.

Figure 15. New Scope Wizard: IP Address Range window
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11. Restart the DHCP server and then restart the storage subsystem so that all
modifications are applied.

12. Go to “Verifying the TCP/IP protocol and setting up the host or DNS table” on
page 34.

Setting up a NetWare DHCP server
A NetWare DHCP server automatically assigns IP addresses and other
configuration information to clients upon request or when the clients are restarted.

To set up a NetWare DHCP server, you must complete the following tasks:

1. Install DNS/DHCP Services, either during or after installing NetWare 5.

2. Install the DNS/DHCP Management Console.

3. Create the DHCP server object.

4. Create the subnet address.

5. Create the subnet address range.

6. Create the IP address object.

7. Start the DHCP server.

Installing NetWare 5.1 with DNS/DHCP Services
This section contains instructions for adding Novell DNS/DHCP services during and
after the NetWare 5.1 installation.

Adding Novell DNS/DHCP Services during the NetWare 5.1 installation: Do
the following to add Novell DNS/DHCP Services during the Netware 5.1 installation:

1. From the Installation Options window, select Custom.

2. From the Components window, select the Novell DNS/DHCP Services check
box.

3. Follow the on-screen instructions to complete the NetWare 5.1 installation.

Adding Novell DNS/DHCP Services after the NetWare 5.1 installation: Do the
following to add Novell DNS/DHCP Services after the Netware 5.1 installation:

1. Insert the NetWare 5.1 Installation CD into the CD-ROM drive; then, mount the
CD as a volume.

2. Load NWCONFIG and select Product Options.

3. Select Install a Product not Listed.

4. Press F3 and specify the volume name of the CD. The X Server-Graphical
Console window opens.

5. In the Additional Products and Services dialog box, select the Novell
DNS/DHCP Services check box.

6. Follow the on-screen instructions to complete installation.

Note: Installing the DNS/DHCP Service will extend the Novell Directory
Services (NDS) schema and create the following NDS objects:

v DNSDHCP-GROUP Group object

v DNS/DHCP Locator object

v RootServerInfo Zone object

Installing the DNS/DHCP Management Console
Do the following to install the DNS/DHCP Management Console and NetWare
Administrator snap-in files on the client workstation you will use to administer DNS
and DHCP:
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1. If you have not done so, install the latest version of Novell Client 32 on your
workstation.

2. From the workstation, run the SYS:PUBLIC\DNSDHCP\SETUP.EXE program.

3. Install the DNS/DHCP Management Console on the local hard-disk drive.

4. Install the NetWare Administrator snap-in files in the SYS:PUBLIC\WIN32
directory.

5. Restart the workstation.

6. To start the DNS/DHCP Management Console, double-click the shortcut icon on
the desktop, enter the NDS Tree NAME, and click Launch.

Note: You can install the DNS/DHCP Management Console on a workstation, or
you can access it from the Tools menu of the NetWare Administrator utility.

Creating the DHCP server object
Use the DHCP Management Console to create a DHCP server object. A DHCP
server object can be created under any of the following objects:

v Organization (O)

v Organization Unit (OU)

v Country (C)

v Locality (L)

Do the following to create a DHCP server object:

1. From the DHCP Management Console, click the DHCP Service tab.

2. In the left pane, select Our Network.

3. Click Create. The Create New DHCP Object window opens.

4. Select DHCP Server; then, click OK. The Create DHCP Server window opens.

5. Select a server; then, click Create. This creates the DHCP server object in
NDS, called DHCP_servername.

6. In the DHCP Management Console, locate the icon for the DHCP server object
at the bottom of the DHCP Service tab. The server object is displayed with a
red line through it. The red line indicates that DHCP server has not been
started.

7. Continue with “Creating a subnet object”.

Creating a subnet object
You must do the following to create a DHCP subnet object for each of the subnets
for which you want to assign addresses:

1. In the DNS/DHCP Management Console, click the DHCP Service tab.

2. Select Our Network or the DHCP Server Object.

3. Click Create. The Create New DHCP Object window opens.

4. Select Subnet; then, click OK. The Create Subnet window opens.

5. For each subnet, type the following information:

v Subnet name

v NDS context

v Subnet address

v Subnet mask

v Default DHCP Server

6. Click Create. The DHCP subnet object is created and displayed in the
DNS/DHCP Management Console.
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Creating subnet address ranges
Do the following to create a subnet address range object:

1. From the DNS/DHCP Management Console, click the DHCP Service tab.

2. Select the subnet object under which you want to create the subnet address
range object; then, click Create. The Create New DHCP Record window opens.

3. Select Subnet Address Range; then, click OK. The Create New Subnet
Address Range window opens.

4. Type the following information for the subnet address range:

v Subnet address range name

v Starting address

v Ending address

5. Click Create.

6. Select the Define Additional Properties check box; then, set the Range Type
to Dynamic BOOTP and DHCP.

Creating IP address objects
Use the DNS/DHCP Management Console to create IP address objects. IP address
objects are used for the following purposes:

v To exclude an IP address from assignment

v To assign an IP address manually to a specific host

v To record dynamic IP address leases

Do the following to create an IP address object:

1. From the DNS/DHCP Management Console, click the DHCP Service tab.

2. Select the subnet object of the target IP address; then, click Create.

3. Select IP Address; then, click OK. The Create IP Address window opens.

4. In the IP Address field, type the IP address for the first controller.

5. In the Assignment field, select Manual.

6. In the Client Identifier field, specify the MAC address.

7. In the MAC Address field, enter the hardware Ethernet MAC address for the
controller.

8. Select the Define Additional Properties check box.

9. In the Hostname field, type the eight-character name for the controller.

10. In the Usage field, select Permanent.

11. Repeat step 3 through step 10 for each controller.

Starting the DHCP server
To start the DHCP server, type the following at the DHCP server console:
LOAD DHCPSRVR

The DHCP server can now respond to client requests and assign IP addresses.

Notes:

1. To load the DHCP server automatically each time the server starts, place the
DHCPSRVR command in the SYS:\SYSTEM\AUTOEXEC.NCF directory.

2. For additional information about setting up, configuring, or using Novell
DNS/DHCP Services, refer to the NetWare 5.1 documentation, located on the
Novell Documentation CD or at http://www.novell.com/documentation Web site.
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Setting up a UNIX BOOTP server
To use a UNIX BOOTP server, you must set up a BOOTP table. Table 11 and the
information record (Table 13 on page 55) provide the information needed.

Table 11. Required entries for setting up the UNIX BOOTP server

Entry Description Sample format in
BOOTP server

Subnet mask Mask that is used to route packets to defined
subnets

dot notation
(sm=255.255.255.0)

Router IP address of the host computer that routes
packets to networks

dot notation
(gw=192.168.1.1)

Host name for the
controller

Host name that is associated with the controller
(refer to Table 13 on page 55)

host name (Denver_a)

IP address IP address of the controller (refer to Table 13 on
page 55)

dot notation
(ip=192.168.128.101)

Ethernet address The Ethernet address of the controller
hardware (refer to Table 13 on page 55)

hexadecimal notation
(ha=00a0b8020420)

To set up a UNIX BOOTP server, do the following:

1. Use a text editor to edit the bootptab file in the /etc directory.

The following is an example of the BOOTP table used to configure the Network
A server shown in Figure 6 on page 20:
s4.default:\ (common settings)

ht=ether:\

sm=255.255.248.0:\

gw=192.168.1.1:\

hn:

denver_a:\

tc=s4.default:\ (common settings)

ip=192.168.128.101:\

ha=00a0b8020420:

denver_b:\

tc=s4.default:\

ip=192.168.128.102:\

ha=00a0b80000d8:

where the s4.default:\ entry denotes settings that are common to all controllers,
and the tc=s4.default:\ entry associates this common setting group to a specific
controller.

2. If the storage subsystem is running, shut down and then restart the subsystem.
This will ensure that the parameters in the BOOTP table take effect.

3. Continue with “Verifying the TCP/IP protocol and setting up the host or DNS
table”.

Verifying the TCP/IP protocol and setting up the host or DNS table
Use the following procedure to verify that the TCP/IP protocol software is installed
on the management station and to set up the host or DNS table. Make sure that the
host names for the controller match the IP addresses for the controllers.
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1. Click Start → Settings → Control Panel → Network → Protocols to verify that the
TCP/IP software is installed and configured properly.

Note: If the TC/PIP software is not installed properly, install it from the
installation CD. Click Start → Settings → Control Panel → Network →
Protocols → Add → Have Disk.

2. Update either the host table or DNS table to specify a host name to associate
with an IP address. If you do not have a DNS, edit the two host tables found in
the following directories (your directory will be different if the operating system is
not installed on the root).
sys:etc\hosts

To set up the host tables for the controllers connected to Network A (Figure 6 on
page 20). Open the hosts file that is located in the \etc\ directory (refer to the
example below) and use a text editor to update the host file to create the
following IP address and controller name entries. Sample host file:

Mappings of host names and host aliases to IP addresses
127.0.0.1 loopback lb local host loopback address

Examples from a fictitious network
129.47.4.2 ta tahiti ta.some.com loghost

129.47.6.40 osd-frog

129.47.6.144 sj-in5 in5

197.67.172.71 sj-in1 in1

3. To manage storage subsystems through a firewall, configure the firewall to open
port 2463 to TCP data.
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Chapter 3. Installing software

This chapter describes how to install the storage-management software in standard
(noncluster) and cluster server configurations.

Important: Always check for a README file on any installation media. A README
file might contain important information that was not available when the Installation
and Support Guide was prepared.

New installation process
The Storage Manager 8.2 software components must be installed on both
management stations and host computers.

Management station: A management station is a system that is used to manage
the storage subsystem. It can be attached to the storage subsystem in the following
ways:

v Through a TCP/IP Ethernet connection to the controllers in the storage
subsystem

v Through a TCP/IP network connection to a host computer with the host-agent
soft-ware installed, that is directly attached to the storage subsystem through the
Fibre Channel input/output (I/O) path

You must install the following Storage Manager 8.2 components:

1. Storage Manager 8.2 Client

2. Client from IBM FAStT_MSJ.

Host computer: A host computer (or host) is a system that is directly attached to
the storage subsystem through a Fibre Channel I/O path.

You must install storage management software on each host computer in the
following order:

1. Novell Java Virtual Machine for NetWare version 1.3.1

2. Storage Manager 8.2 Client

3. Storage Manager 8.2 Agent

4. Storage Manager 8.2 Utility

5. IBM Storage Area Network (SAN) driver

6. IBM Host Adapter (HA) device driver

7. Netware Agent component of IBM FAStT Management Suite Java (FAStT MSJ)

To begin the installation, continue with “Java Virtual Machine for NetWare Version
1.3.1”.

Java Virtual Machine for NetWare Version 1.3.1
To install Java Virtual Machine (JVM) on management stations, servers, and host
computers running NetWare 5.1, do the following:

1. Be sure you are running NetWare operating system version 5.1 and Support
Pack 4.

2. View the Novell Technical Information Document (TID) 2961564. For more
information, go to the Novell Web site at http:\\support.novell.com.
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Storage Manager 8.2 Client
This section provides instructions for installing Storage Manager 8.2 Client on a
management stations and host computers.

Before you install the software, make sure that:

v The management station or host computer has at least 60 MB of available disk
space.

v All programs are closed.

Important: When you install Storage Manager 8.2 Client on a stand-alone host and
manage storage subsystems through the Fibre Channel I/O path rather than
through the network, you must install the TCP/IP software on the host and assign
an IP address to the host.

Installing Storage Manager 8.2 Client
To install Storage Manager 8.2 Client software package, do the following:

1. Insert the IBM FAStT Storage Manager installation CD into the CD-ROM drive
and type:
load cdrom

2. Mount the volume.

3. Click Novell → Install.

4. Click Add, and follow the instructions on the screen.

5. Click the Directory Tree button.

The Directory Tree window opens.

6. Select the CD-ROM volume.

7. Select the \Netware\SMclient folder.

8. Select the program.ni file, and then click OK.

9. Click OK.

After the files are copied, the License Agreement window opens.

10. Click Accept to continue.

The copying files message window opens.

11. When the installation is complete, click Finish.

Verifying the Storage Manager 8.2 Client installation
This section provides instructions for verifying that the Storage Manager 8.2 Client
software has been installed correctly.

To verify that the Storage Manager 8.2 Client software is installed correctly, do the
following:

1. Click Novell → Programs.

2. Verify that the IBM FAStT Fibre Channel Storage Manager Client appears in the
list of programs.

Otherwise, repeat “Installing Storage Manager 8.2 Client”. If the IBM FAStT
Storage Manager Client still does not appear, a failure has occurred. Contact
your IBM technical-support representative.

3. If you are installing Storage Manager 8.2 Client on a host computer, go to
“Storage Manager 8.2 Agent” on page 39. Otherwise, go to Chapter 4,
“Completing the installation” on page 43.
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Storage Manager 8.2 Agent
The Storage Manager 8.2 Agent software must be installed if you want to manage
the storage subsystem using the host-agent management method.

Before you install the software, ensure that the following conditions are met:

v The host computer is configured with Novell NetWare 5.1 and Service Pack 4.

v You have Administrator privileges on the host computer.

v The host computer has at least 20 MB of available disk space.

Installing Storage Manager 8.2 Agent
To install the Storage Manager 8.2 Agent, do the following:

1. Close all other programs.

2. Insert the IBM FAStT Storage Manager installation CD into the CD-ROM drive
and type:
load cdrom

3. Mount the CD volume.

4. Click Novell → Install.

5. Click Add, and follow the instructions on the screen.

6. Click the Directory Tree button.

The Directory Tree window opens.

7. Select the CD-ROM volume.

8. Select the \Netware\SMagent directory.

9. Select the product.ni file, and then click OK.

10. Click OK.

After the files are copied, the License Agreement window opens.

11. Click Accept to continue.

The files are copied.

12. When the installation is complete, click Finish.

Note: To enable SMagent at server startup, an autoexec.ncf entry can now be
made.

Verifying the Storage Manager 8.2 Agent installation
To verify that the Storage Manager 8.2 Agent software was installed correctly, do
the following:

1. Toggle to the Server Console window and at the command prompt, type:
SMagent

The agent will start and display the following message when UTM LUNs are
being scanned:
Activating

2. Continue with “Storage Manager 8.2 Utility”.

Storage Manager 8.2 Utility
This section provides instructions for installing Storage Manager 8.2 Utility software
on host computers. This component contains utilities that will register and map new
logical drives to the operating systems.
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Important: Make sure you have installed the IBM FAStT MSJ QLRemote agent on
the same host where you are installing the Storage Manager 8.2 Utility software.
For more information, refer to “Installing IBM FAStT Management Suite Java” on
page 41.

Installing Storage Manager 8.2 Utility
To install the Storage Manager 8.2 Utility software on each attached Windows host
computer, do the following:

1. Close all programs.

2. Insert the IBM FAStT Storage Manager installation CD into the CD-ROM drive
and type:
load cdrom

3. Mount the CD volume.

4. Click Novell → Install.

5. Click Add, and follow the instructions on the screen.

6. Click the Directory Tree button.

The Directory Tree window opens.

7. Select the CD-ROM drive.

8. Select the \NetWare51\SMutil folder, and then, click Open.

9. Select the product.ni file, and then, click Open.

The Welcome window opens.

10. Click Next to begin the installation.

After installing the Storage Manager 8.2 Utility software, the Operation
Complete window opens. If the system detects the installation of another
version of Storage Manager 8.2 Utility, a window opens indicating that the
installation will be updated and your personal configuration files will be saved.
Click Yes to continue.

11. Click Finish.

12. Go to “Installing the IBMSAN driver” on page 41.

Verifying the Storage Manager 8.2 Utility installation
To verify that Storage Manager 8.2 Utility has been installed correctly, do the
following:

1. Go to the following directory:

sys:system

where installation_directory is the directory where you installed the Storage
Manager 8.2 Utility.

2. Verify that the directory contains the following files:

v hot_add.ncf

v SMdevices.ncf

If it does not, reinstall the Storage Manager 8.2 Utility using the procedure
outlined in “Installing Storage Manager 8.2 Utility”.

3. Continue with “Installing the IBMSAN driver” on page 41.
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Installing the IBMSAN driver
The IBM Storage Area Network (SAN) driver is used in a Novell NetWare
environment to provide multipath I/O support to the storage server. The IBMSAN
driver is a custom driver module (CDM) that is installed with the IBM FAStT Host
Adapter driver. In case of a failure along the I/O path, the driver will send the I/O
requests through the alternate path and Auto-Volume Transfer (AVT) will move the
logical drive within the FAStT Storage Server. Refer to the
http://www.ibm.com/pc/support IBM Web page for the current README file, SAN
driver, and installation instructions.

Continue with “Installing the IBM Host Adapter device driver (QL2x00)”.

Installing the IBM Host Adapter device driver (QL2x00)
The IBM Host Adapter device driver enables the operating system to communicate
with the host adapter. The IBM FAStT FC-2 Host Bus Adapter is a
high-performance, direct memory access (DMA), bus-master, host adapter designed
for high-end systems. The IBM FAStT FC-2 Host Bus Adapter supports all Fibre
Channel (FC) peripheral devices that support private-loop direct attach (PLDA) and
fabric-loop attach (FLA). Refer to the IBM Netfinity FAStT Host Adapter Installation
and User’s Guide or the IBM FAStT FC-2 Host Bus Adapter Installation and User’s
Guide and the http://www.ibm.com/pc/support IBM Web page for the current
README file and latest multipath I/O device driver.

Continue with “Installing IBM FAStT Management Suite Java”.

Installing IBM FAStT Management Suite Java
For additional information on installing and using this software, refer to the IBM
FAStT MSJ User’s Guide or online Help.
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Chapter 4. Completing the installation

This chapter contains procedures for using Enterprise Management and Subsystem
Management to complete the following installation tasks:

1. Perform an initial automatic discovery of storage subsystems.

2. Add devices, if necessary.

3. Set up alert notifications, if you want.

4. Name the storage subsystems.

5. Download firmware and NVSRAM.

6. Create arrays and logical drives.

7. Define the default host type.

8. Configuring heterogeneous hosts

9. Perform other storage subsystem tasks.

The Enterprise Management window opens when you start Storage Manager. Use
the Enterprise Management window to:

v Add and discover the storage subsystems

v View of all storage subsystems in your management domain

v Perform batch storage subsystem management tasks using the Script Editor

Performing an initial automatic discovery of storage subsystems
To perform an initial automatic discovery of storage subsystems, do the following:

1. If you are using the SMagent, start the SMagent at the Server Console window.

At the Server Console, type:
smagent

2. From the Xserver Graphical Console, click Novell → Programs.

3. Click IBM FAStT Storage Manager.

The client software starts, displaying the Enterprise Management window.

Note: The Enterprise Management window might take several minutes to open.
No wait cursor (such as an hourglass) is displayed.
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4. Click Yes to begin an initial automatic discovery of hosts and storage
subsystems that are attached to the local subnetwork.

After the initial automatic discovery is complete, the Enterprise Management
window displays all hosts and storage subsystems attached to the local
subnetwork.

Note: The Enterprise Management window might take up to a minute to refresh
after an initial automatic discovery.

5. Verify that each host and storage subsystem is displayed in the Enterprise
Manager window.

If a hosts or storage subsystem is not displayed, do the following:

v Check the hardware and connections for possible problems (refer to the
hardware documentation for specific procedures).

v Refer to the Enterprise Management online help for additional information
about discovering storage subsystems.

v Verify that all hosts and storage subsystems are on the local subnetwork. If
they are not, use the Add Device option.

Note: In certain situations, a storage subsystem might be duplicated in the
device tree after an automatic discovery. You can remove a duplicate
storage-management icon from the device tree using the Remove Device
option in the Enterprise Management window.

6. Verify that the status of each storage subsystem is Optimal. If a device shows a
status of Unresponsive, use the software to remove the device from the
management domain and then add it again. Refer to the Enterprise
Management window online help for instructions on removing and adding
devices.

7. Continue with “Adding devices” on page 45.

Figure 16. Enterprise Management window
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Adding devices
You can manually add more hosts or storage subsystems. You can use this option
to selectively manage a group of storage subsystems from a Storage Manager 8.2
client. You can also use this option to add additional devices to be managed that
were not identified during the Storage Manager 8.2 client initial discovery.For more
information about this option, refer to the Enterprise Management window online
help.

Important:

v When you add new storage subsystems to existing storage subsystems in a
Storage Area Network (SAN) that are managed through the host-agent software,
you must stop and restart the host-agent service. When the host-agent service
restarts, the new storage subsystem is detected. For more information, refer to
“Stopping and starting the host-agent software” on page 51. Then, go to the
Enterprise Management window and click Tools → Rescan to add the new
storage subsystems to the management domain.

v When you add new storage subsystems to existing storage subsystems that are
managed using the direct-management method, be sure and specify the IP
addresses for both controllers.

Continue with “Setting up alert notifications”.

Setting up alert notifications
After you add devices to the management domain, you can set up alert notification
to report critical events on the storage subsystems. The following alert-notification
options are available:

v Notification to a designated network management station (NMS) using Simple
Network Management Protocol (SNMP) traps

v Notification to designated e-mail addresses

v Notification to designated alphanumeric pagers (requires additional software to
convert e-mail messages)

Note: You can only monitor storage subsystems within the management domain. If
you no not install Event Monitor service, the Enterprise Management window
must remain open. If you close the window, you will not receive alert
notifications from the managed storage subsystems. Refer to the Enterprise
Management window online help for additional information.

To set up alert notification to a NMS using SNMP traps, do the following:

1. Insert the IBM FAStT Storage Manager Version 8.2 CD into the CD-ROM drive
on a network management station (NMS). You need to set up the designated
management station only once.

2. Copy the SM820.MIB file from the SM8mib directory to the NMS.

3. Follow the steps required by your NMS to compile the management information
base (MIB) file. (For details, contact your network administrator or see the
documentation specific to the storage management product you are using.)

4. Continue with “Naming storage subsystems” on page 46.
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Naming storage subsystems
To name your storage subsystem, do the following:

1. In the Enterprise Management window, select a storage subsystem.

2. Click Tools → Manage Device. The Subsystem Management window opens, as
shown in Figure 17.

3. Click Storage Subsystem → Rename. The Rename Storage Subsystem
window opens.

4. Type the name of the storage subsystem (refer to Table 13 on page 55); then,
click OK.

5. Repeat for each unnamed storage subsystem. For more information, refer to the
topic on renaming storage subsystems in the Subsystem Management window
online help.

6. Continue with “Downloading firmware and NVSRAM”.

Downloading firmware and NVSRAM
This section provides instructions for downloading firmware and NVSRAM. You
must download firmware version 5.20.00.00 before you download NVSRAM.

Downloading firmware
To download firmware version 5.20.xx, do the following:

1. From the Enterprise Management window, select a storage subsystem.

2. Click Tools → Manage Device. The Subsystem Management window opens.

3. Click Storage Subsystem → Download → Firmware. Follow the instructions that
display.

4. Continue with “Downloading NVSRAM”.

Downloading NVSRAM
To download NVSRAM, do the following:

1. From the Enterprise Management window, select a storage subsystem.

Figure 17. Subsystem Management window
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2. Click Tools → Manage Device. The Subsystem Management window opens.

3. Click Storage Subsystem→ Download → NVSRAM. Follow the on-screen
instructions.

4. Continue with “Creating arrays and logical drives”.

Creating arrays and logical drives
A logical drive is the basic structure you create to store data on the storage
subsystem. The operating system recognizes a logical drive as a single drive.
Choose a RAID level to meet application needs for data availability and maximize
Fibre Channel I/O performance.

To create arrays and logical drives, do the following:

1. From the Enterprise Management window, select a storage subsystem.

2. Click Tools → Manage Device. The Subsystem Management window opens.

3. Click the Logical/Physical View tab.

4. Click Logical Drive → Create. The Logical Drive Create wizard starts. Follow
the online instructions to create arrays and logical drives.

5. Continue with “Defining the default host type”.

Note: (For cluster configurations) If you add or delete logical drives, you must
make them known to both node A and node B.

Defining the default host type
Before using the logical drives in a host computer, you must specify the host type.
The host type determine how the storage subsystem controllers will work with each
particular operating system on the hosts to which it is connected. If all of the host
computers connected to the same storage subsystem have the same operating
system installed and you do not want to define partitioning, you can define a default
host type.

To define a default host type, do the following:

1. Click Storage subsystem → Change → Default host-type. The Default
Host-type window opens.

2. From the pull-down list, select the host type.

3. Click OK.

If you have hosts with different operating systems or if you want to define partitions
for the hosts, continue with “Configuring heterogeneous hosts”.

Configuring heterogeneous hosts
The heterogeneous hosts feature enables hosts running different operating systems
to access a single storage subsystem. Previous releases of IBM FAStT Storage
Manager (versions 7.02 or earlier) required that hosts run the same operating
system in order to access a single storage subsystem.

Host computers can run completely different operating systems (for example,
Solaris and Windows NT) or variants of the same operating system (for example,
Windows NT operating in a cluster environment or Windows NT running in a
noncluster environment). When a host type is specified in the Define New Host Port
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window, the heterogeneous hosts feature enables the controllers in the storage
subsystem to tailor their behavior (such as LUN reporting) to the needs of the host.

Important: To use the heterogeneous host feature, the following conditions must be
met:

v Storage partitioning is enabled.

v During host-port definition, you must set each host type to the appropriate
operating system so that the firmware on each controller can respond correctly to
the host.

To start the heterogeneous host configuration, do the following:

1. From the Subsystem Management window, click Configure → Storage
Partition.

2. Follow the on-screen instructions.

3. Continue with “Performing other storage-subsystem management tasks”.

Note: Partitioning is a premium feature. If you disable partitioning, you must
contact your IBM technical-support representative to obtain a key to reenable
partitioning.

Performing other storage-subsystem management tasks
Other storage-subsystem management tasks you can perform include the following:

v Locating a storage subsystem

v Viewing a storage subsystem profile

v Entering or changing a storage subsystem password

v Creating and managing logical drives and subsystems

v Using the Performance Monitor

v Create storage partitions (if applicable)

Note: To create storage partitions, you must obtain the worldwide name or port
name of each host adapter in every host connected to the storage
subsystem.

For more information about these and other storage-subsystem management tasks,
refer to the appropriate topics in the Subsystem Management online help.

After installing IBM FAStT Storage Manager Version 8.2, consider installing the
FAStT Management Suite Java (FAStT-MSJ) diagnostic program. You can use this
program to verify the status of the fiber channel connections before using the
storage subsystem. The program and the IBM FAStT MSJ User’s Guide are located
on the IBM FAStT Storage Manager Version 8.2 CD.

48 IBM FAStT Storage Manager Version 8.2: Installation and Support Guide for Novell NetWare



Chapter 5. Using the storage-management software

This chapter provides information about adding or deleting logical drives, using the
Hot Add and SMdevices utilities, starting and stopping the host-agent software, and
uninstalling Storage Manager components.

Adding or deleting logical drives
Use the following instructions to add or delete logical drives in a standard
(noncluster) configuration.

Creating logical drives
When you create new logical drives with the storage-management software, you
must add the new logical drives to Novell NetWare. Refer to the Novell NetWare
documentation for details about adding a drive. Each logical drive (not array) is
recognized by Novell NetWare as a single drive.

After creating logical drives, run the Hot Add and SMdevices utilities that are
provided with the storage-management software. The Hot Add utility adds newly
created logical drives to the operating system, and the SMdevices utility identifies
logical drives by their associated operating system device names. For information
about using these utilities, see “Using the Hot Add utility” on page 50 and “Using the
SMdevices utility” on page 50.

Deleting logical drives

Important: If you have data or logical drives that you want to keep, do not click Configure
→ Reset Configure. This will reset the controller unit and delete all previously-configured
logical drives.

Before deleting logical drives with the storage-management software or using
Configure → Reset Configuration.

Before deleting logical drives with the storage-management software or using
Configure → Reset Configuration, stop all input and output activity to the affected
storage subsystem. Then dismount any NetWare volumes that are associated with
the logical drives.

Creating a FlashCopy logical drive
A FlashCopy logical drive is a logical point-in-time image of a logical drive, called a
base logical drive. A FlashCopy logical drive has the following features:

v It is created quickly and requires less disk space than an actual logical drive.

v It can be assigned a host address, so that you can perform backups using the
FlashCopy logical drive while the base logical drive is online and accessible.

v You can use the FlashCopy logical drive to perform application testing or
scenario development and analysis. This does not effect the actual production
environment.

v The maximum number of FlashCopy logical drives allowed is one half of the total
logical drives supported by your controller model.

For additional information about the FlashCopy feature and how to manage Flash
Copy logical drives, refer to the Storage Manager Subsystem Management online
help.
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Note: FlashCopy is a premium feature. Contact your IBM reseller or IBM marketing
representative for more information.

To create a FlashCopy logical drive, do the following:

1. To ensure that you have the accurate point-in-time image of the base logical
drive, stop applications and flush cache I/O to the base logical drive.

2. Open the Subsystem Management window. From the Logical View, right-click
the base logical drive.

3. Select Create FlashCopy Logical Drive. The Create FlashCopy Logical Drive
Wizard starts.

4. Follow the on-screen instructions.

5. Refer to the Subsystem Management online help for instructions on how to add
the FlashCopy logical drive to the host.

Using the Remote Mirror Option
The Remote Mirror Option is a premium feature. The Remote Mirror Option is used
for online, real-time replication of data between storage subsystems over a remote
distance. In the event of a disaster or unrecoverable error at one storage
subsystem, the Remote Mirror Option enables you to promote a second storage
subsystem to take over responsibility for normal input/output (I/O) operations. For
more information about this feature, consult the IBM FAStT Remote Mirror Option
Installation and User’s Guide, or contact your IBM reseller or marketing
representative.

Using the Hot Add utility
The Hot Add utility enables you to add new logical drives without restarting the
system. The utility registers the new logical drives with the operating system so that
you can use nwconfig to create partitions, add device names, and so on. The Hot
Add utility is part of the Storage Manager 8.2 Utility package.

When you finish creating logical drives on a particular storage subsystem, go to the
host that is attached to that storage subsystem, and perform the following steps to
use the hot add utility:

1. From the Server Console, type:
hot_add

2. Press Enter.

The new logical drives are available through the Disk Administrator.

Using the SMdevices utility
The Storage Manager 8.2 Utility software package includes a utility called
SMdevices that you can use to view the storage subsystem logical drive that is
associated with a particular operating-system device name. This utility is helpful
when you want to create drives, volumes, or a combination of both for the logical
drive using the nwconfig program.

When you finish creating the logical drives on a particular storage subsystem, go to
the host that is attached to that storage subsystem, and perform the following steps
to use SMdevices:

1. From the Server Console type:
SMdevices
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2. Press Enter.

The software displays device identification information. For example, you might
see:
V596-A3-D0:0[Storage Subsystem MARKETING, Logical Drive DEBIT,
LUN 0, WWN <600a0b800007545c0000008d3a308b6e>]

V596-A3-D0:1 [Storage Subsystem MARKETING, Logical Drive DEBIT, LUN 1,
WWN <600a0b80000756ec000000a93a307d2a>]

V596-A3-D0:1F [Storage Subsystem MARKETING, Logical Drive Access volume,
LUN 31, WWN <600a0b800007545c0000009000000000>]

Where V596-A3-D0:0;

The numbers at the beginning of each line comprise the device name. The
device name identifies the adapter or device as follows:
Vendor number [V596]. A unique number specific to the device vendor.

Adapter number [A3]. The instance number of an adapter registered with
NWPA. In the example, A3 identifies the first instance of an adapter
installed in the server.

Device number [D0]. The number of the disk or other device.

Logical unit number [0,1,1F]. The LUN identifies individual devices when
more than one device is attached to one bus.

Storage Subsystem x = the storage subsystem name
Logical Drive x = the logical drive name
LUN x = the logical unit number associated with the logical drive
WWN x = the worldwide name for the logical drive

Stopping and starting the host-agent software
Use the procedures in the following sections to stop and start the host-agent
software installed on the host or cluster node.

Note: If an access logical drive is not detected after a restart, the host-agent
software will automatically stop running. Restart the host or cluster node so
that new host-agent-managed storage subsystems will be discovered.

Stopping the host-agent software
You must stop the host-agent software if you want to add storage subsystems.
When you restart the service, the host-agent software discovers the new storage
subsystems and adds them to the management domain.

To stop the host-agent software, do the following:

1. From the system console, press Ctrl+Esc, and then select System Console.

2. At the prompt, type:
java -show

Look for the following line:
"devmgr.versioned.agent.AgentServer.............QQQ"

Where QQQ is the process ID.

3. At the prompt type the following:
java -killQQQ

Where QQQ is the process ID from the java -show command.

4. Press Enter.
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Starting the host agent manually
The host-agent software must be started manually when the system is started or if
it is stopped to add storage subsystems.

Use the following procedure to start the host agent manually:

1. From the system console, press Ctrl+Esc, and then select System Console.

2. At the prompt, type:
smagent

3. Press Enter.

The agent will start and display the following message when UTM LUNs are
scanned:
Activating

4. Return to ConsoleOne. Press Ctrl+Esc, and then select Xserver -- Graphical
Console.

Uninstalling storage-management software components
Use the following procedure to uninstall one or more of the components of Storage
Manager 8.0. If you are uninstalling components released with an earlier version of
the storage-management software, use the procedure that came with the version of
the storage-management software that you are currently running.

1. From the Xserver Graphical Console, click Novell → Install.

The Add/Remove Programs Properties window opens.

Note: The Storage Manager components should be uninstalled in the following
order:

a. Storage Manager 8.0 Agent

b. Storage Manager 8.0 Utility

c. Storage Manager 8.0 Client

2. Select the component you want to uninstall from the list of programs (for
example, IBM FAStT Storage Manager 8.0 Client).

3. Click Add/Remove.

The Confirm File Deletion window opens.

4. Click Yes to start the uninstallation process.

5. When the uninstallation is completed, click OK.
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Chapter 6. Novell NetWare operating-system support

Important: Always check for a README file on any installation media. This
README file might contain important information that was not available when this
Installation and Support Guide was prepared.

Table 12 explains the limitations that apply when you use the IBM IBM FAStT
Storage Manager Version 8.2 with Novell NetWare.

Table 12. Novell NetWare limitations

Limitation Workaround

If the SMagent is running on the NetWare
server and a fibre cable is pulled or a path
failure occurs, the NetWare server might
abend.

Stop the SMagent and manage the FAStT
using the direct (out-of-band) method of
management. See “Stopping the host-agent
software” on page 51 and use the procedure
for uninstalling the SMagent software.

Clicking a vertical scroll arrow (either up or
down) causes the scroll box to move all the
way to the opposite end of the scroll bar.

This is a known defect in the Java Runtime
Environment. Click the scroll box and slide it
until you reach the desired position in the
Help window.

Logical drive migration (removing a set of
drives that are configured with logical drives
from one storage subsystem for insertion into
another storage subsystem) is not supported
because it could cause loss of configuration.

Call for service.

When you manage storage subsystems
through the host-agent software and use the
storage-management software to download
controller firmware, the download process
can take up to 10 minutes to complete.

None.

The controller firmware does not recognize or
communicate with a single controller until slot
A is populated. This limitation does not apply
to storage subsystems that were originally
configured with two controllers.

When you configure a new storage
subsystem with a single controller, you must
place the controller in slot A.

Public loop configurations (managed hubs
that are attached to switches) are not
supported.

None.

Multipath failover will only work if the storage
controllers are in active/active mode.

When you configure the storage subsystem,
change both controllers to active status.

When you remove a fan or power supply
customer replaceable unit (CRU) from a
storage subsystem while the system is
running, the storage-management software
does not report an error message, and the
component is not reported as missing.
Note: Fan and power-supply CRU failures
are reported.

Replace the missing fan or power-supply
CRUs immediately to ensure redundancy.
Make sure that the fan or power-supply CRU
is properly seated in the controller unit.

Your windows and online Help will display a
brownish hash pattern when you run in 256
color mode.

Run the Storage Manager 8.2 application in a
higher display mode
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Table 12. Novell NetWare limitations (continued)

Limitation Workaround

When performing a redundancy check (parity
scan) from the storage management
application, machine type 3542 can take
several minutes longer than machine type
3526 and 3552 controller platforms.

None.

When attempting to manage a storage
subsystem where the RAID controller unit
does not have access to logical drives
Storage Manager will prompt you for a
password. This will occur even if no password
has been setup. The automatic discovery will
locate and identify each storage subsystem
as two separate storage subsystems.

Ensure that at least one IBM FAStT EXP500
Expansion Unit with at least one logical drive
is properly attached to the IBM FAStT500
RAID Controller Unit in each storage
subsystem being managed. Since the RAID
controller unit should not be powered on until
the expansion units are attached and
powered on, this should be done by powering
off the RAID controller unit, properly attaching
all expansion units, with the drives installed,
to the RAID controller unit and powering them
on, and then powering the RAID controller
unit back on. At this point the storage
subsystems can be re-discovered and
managed using the FAStT Storage Manager
software.

You might not see the maximum number of
drives during Automatic Configuration if you
are using drives of different capacities.

Use Manual Configuration to select individual
drives and select the maximum number of
drives allowed.
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Appendix A. Storage subsystem/controller information record

Table 13 provides a data sheet for recording storage subsystem names,
management types, hardware Ethernet addresses, and IP addresses. Make a copy
of this table and complete the information for your storage subsystems and
controllers. Use the information to set up the BOOTP table for the network server
and the host or Domain Name System (DNS) table. The information will also be
helpful if you add storage subsystems after your initial installation. The column
headings show a page reference for detailed instructions about obtaining the
information. For a sample information record, refer to Table 9 on page 21.

Table 13. Storage subsystem information record and controller information record

Storage
subsystem name
(refer to page 22)

Management
type

Controllers—Ethernet and IP
addresses, and host name (refer
to pages 21 and 24)

Host—IP
address and
host name
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Appendix B. Getting information, help, and service

If you need help, service, or technical assistance or just want more information
about IBM products, you will find a wide variety of sources available from IBM to
assist you. This section contains information about where to go for additional
information about IBM and IBM products, what to do if you experience a problem
with your computer, and whom to call for service should it be necessary.

Getting information
Information about your IBM server product and preinstalled software, if any, is
available in the documentation that comes with your server. That documentation
includes printed books, online books, README files, and help files. In addition,
information about IBM products is available on the World Wide Web.

On the World Wide Web, the IBM Web site has up-to-date information about IBM
products and support. The address for the IBM Personal Computing home page is
http://www.ibm.com/pc/.

You can find support information for your IBM products at
http://www.ibm.com/pc/support/.

If you click Profile from the support page, you can create a customized support
page that is specific to your hardware, complete with Frequently Asked Questions,
Parts Information, Technical Hints and Tips, and Downloadable Files. In addition,
you can choose to receive e-mail notifications whenever new information becomes
available about your registered products.

You also can order publications through the IBM Publications Ordering System at
http://www.elink.ibmlink.ibm.com/public/applications/publications/cgibin/pbi.cgi.

Getting help and service
If you have a problem with your server product, you will find a wide variety of
sources available to help you.

Using the documentation and diagnostic programs
Many problems can be solved without outside assistance. If you experience a
problem with your server product, the first place to start is the troubleshooting
information in your IBM documentation. If you suspect a software problem, see the
documentation, including README files and online help, that comes with the
operating system or application program.

Most IBM server products come with a set of diagnostic programs that you can use
to help you identify hardware problems. See the troubleshooting information in your
IBM documentation for instructions on using the diagnostic programs.

The troubleshooting information or the diagnostic programs might tell you that you
need additional or updated device drivers or other software. IBM maintains pages
on the World Wide Web where you can get the latest technical information and
download device drivers and updates. To access these pages, go to
http://www.ibm.com/pc/support/ and follow the instructions.
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Calling for service
If you have tried to correct the problem yourself and still need help, during the
warranty period, you can get help and information by telephone through the IBM
HelpCenter®. The following services are available during the warranty period:

v Problem determination - Trained personnel are available to assist you with
determining if you have a hardware problem and deciding what action is
necessary to fix the problem.

v IBM hardware repair - If the problem is determined to be caused by IBM
hardware under warranty, trained service personnel are available to provide the
applicable level of service.

v Engineering Change management - Occasionally, there might be changes that
are required after a product has been sold. IBM or your reseller, if authorized by
IBM, will make selected Engineering Changes (ECs) available that apply to your
hardware.

The following items are not covered:
v Replacement or use of non-IBM parts or nonwarranted IBM parts. All warranted

parts contain a 7-character identification in the format IBM FRU XXXXXXX.
v Identification of software problem sources.
v Configuration of BIOS as part of an installation or upgrade.
v Changes, modifications, or upgrades to device drivers.
v Installation and maintenance of network operating systems (NOS).
v Installation and maintenance of application programs.

Refer to your IBM Statement of Limited Warranty for a full explanation of IBM
warranty terms. Be sure to retain your proof of purchase to obtain warranty service.

In the U.S. and Canada, these services are available 24 hours a day, 7 days a
week. In the U.K., these services are available Monday through Friday, from 9:00
a.m. to 6:00 p.m.

Note: Response times vary; may exclude some holidays.

Please have the following information ready when you call:
v Machine type and model
v Serial numbers of your IBM hardware products
v Description of the problem
v Exact wording of any error messages
v Hardware and software configuration information

Telephone numbers
Telephone numbers are subject to change without notice. For the most up-to-date
phone numbers, go to http://www.ibm.com/pc/support/ and click Support Phone
List.
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Country Telephone number

Austria Österreich 01-24 592 5901

Belgium - Dutch Belgie 02-210 9820

Belgium - French Belgique 02-210 9800

Canada Toronto only 416-383-3344

Canada Canada - all other 1-800-565-3344

Denmark Danmark 45 20 82 00

Finland Suomi 09-459 6960

France France 02 38 55 74 50

Germany Deutschland 07032-1549 201

Ireland Ireland 01-815 9202

Italy Italia 02-7031 6101

Luxembourg Luxembourg 298-977 5063

Netherlands Nederland 020-514 5770

Norway Norge 66 81 11 00

Portugal Portugal 21-791 51 47

Spain España 91-662 49 16

Sweden Sverige 08-477 4420

Switzerland Schweiz/Suisse/Svizzera 058-333 0900

United Kingdom United Kingdom 01475-555 055

U.S.A. and Puerto Rico U.S.A. and Puerto Rico 1-800-772-2227

In all other countries or regions, contact your IBM reseller or IBM marketing
representative.

International Warranty Service
If you travel with your server product or relocate it to a country where your server
machine type is sold, your server product might be eligible for International
Warranty Service, which automatically entitles you to obtain warranty service
throughout the warranty period. Service will be performed by IBM or by IBM
resellers who are authorized to perform warranty service.

Service methods and procedures vary by country, and some services might not be
available in all countries. International Warranty Service is delivered through the
method of service (such as depot, carry-in, or on-site service) that is provided in the
servicing country. Service centers in certain countries might not be able to service
all models of a particular machine type. In some countries, fees and restrictions
might apply at the time of service.

To determine whether your server product is eligible for International Warranty
Service and to view a list of the countries where service is available, go to
http://www.ibm.com/pc/support/, and click Warranty Lookup. Eligible IBM server
products are identified by their four-digit machine types. For more information about
International Warranty Service, see Service Announcement 601-034 at
http://www.ibm.com/. Click Support & downloads, click Announcement letters,
and click Announcements search. In the Search by letter number only field,
type 601-034, and click Search.
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Purchasing additional services
During and after the warranty period, you can purchase additional services, such as
support for IBM and non-IBM hardware, operating systems, and application
programs; network setup and configuration; upgraded or extended hardware repair
services; and custom installations. Service availability and service name might vary
by country or region.

For more information about these services, contact your IBM marketing
representative.
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Appendix C. Notices

This publication was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may be
used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give you any
license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A
PARTICULAR PURPOSE. Some jurisdictions do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply to
you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements and/or
changes in the product(s) and/or the program(s) described in this publication at any
time without notice.

Any references in this publication to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those
Web sites. The materials at those Web sites are not part of the materials for this
IBM product, and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes
appropriate without incurring any obligation to you.

Edition notice
© COPYRIGHT INTERNATIONAL BUSINESS MACHINES CORPORATION, 2001,
2002. All rights reserved.

Note to U.S. Government Users — Documentation related to restricted rights —
Use, duplication or disclosure is subject to restrictions set forth in GSA ADP
Schedule Contract with IBM Corp.
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Trademarks
The following terms are trademarks of International Business Machines Corporation
in the United States, other countries, or both:

e-business logo Predictive Failure
Analysis

FlashCopy Redbooks
HelpCenter ServeRAID
IBM ServerProven

TotalStorage

Lotus, Lotus Notes, and Domino are trademarks of Lotus Development Corporation
and/or IBM Corporation in the United States, other countries, or both.

Intel, Celeron, MMX, LANDesk, Pentium, Pentium II Xeon, Pentium III Xeon, and
Xeon are trademarks of Intel Corporation in the United States, other countries, or
both.

Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation in
the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Java and all Java-based trademarks and logos are trademarks or registered
trademarks of Sun Microsystems, Inc. in the United States, other countries, or both.

Linux is a registered trademark of Linus Torvalds.

Other company, product, or service names may be the trademarks or service marks
of others.

Important notes
Processor speeds indicate the internal clock speed of the microprocessor; other
factors also affect application performance.

CD-ROM drive speeds list the variable read rate. Actual speeds vary and are often
less than the maximum possible.

When referring to processor storage, real and virtual storage, or channel volume,
KB stands for approximately 1000 bytes, MB stands for approximately 1 000 000
bytes, and GB stands for approximately 1 000 000 000 bytes.

When referring to hard disk drive capacity or communications volume, MB stands
for 1 000 000 bytes, and GB stands for 1 000 000 000 bytes. Total user-accessible
capacity may vary depending on operating environments.

Maximum internal hard disk drive capacities assume the replacement of any
standard hard disk drives and population of all hard disk drive bays with the largest
currently supported drives available from IBM.

Maximum memory may require replacement of the standard memory with an
optional memory module.
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IBM makes no representation or warranties regarding non-IBM products and
services that are ServerProven®, including but not limited to the implied warranties
of merchantability and fitness for a particular purpose. These products are offered
and warranted solely by third parties.

IBM makes no representations or warranties with respect to non-IBM products.
Support (if any) for the non-IBM products is provided by the third party, not IBM.

Some software may differ from its retail version (if available), and may not include
user manuals or all program functionality.
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