<|lI!

IBM TotalStorage FAStT Storage Manager Version 84x

Installation and Support Guide for
Intel-based Operating System
Environments

GC26-7621-02






<|lI!

IBM TotalStorage FAStT Storage Manager Version 84x

Installation and Support Guide for
Intel-based Operating System
Environments

GC26-7621-02



Note:
FBefore using this information and the product it supports, be sure to read the general information in ['Notices” on page 147

Third Edition (May 2004)

This edition replaces GC26-7621-01 and applies to FAStT Storage Manager version 8.4 software release levels and
to all subsequent releases and modifications until otherwise indicated in new editions.

© Copyright International Business Machines Corporation 2004. All rights reserved.
US Government Users Restricted Rights — Use, duplication or disclosure restricted by GSA ADP Schedule Contract
with IBM Corp.



Contents

Figures.
Tables .

About this document .
Who should read this document
FASHT installation process overview . .
FAStT Storage Manager Version 8.4 library
How this document is organized
Notices that this document uses .
Getting information, help, and service .
Before you call.
Using the documentation.
Web sites .
Software service and support
Hardware service and support .
How to send your comments .

Chapter 1. Introduction.
New features .
Premium features .
Storage Manager 8.4 I|m|tat|ons .
Supported machine types
Terms to know
IBM FAStT Storage Manager Versron 8 4 software for Wmdows
Microsoft Virtual Machine .
Storage Manager 8.4 Client.
Redundant disk array controller .
Storage Manager 8.4 Agent.
Storage Manager 8.4 Utility .
IBM FAStT Storage Manager Version 8.4 software for NetWare
IBM FAStT Storage Manager Version 8.4 software for Linux.
Storage subsystem management methods . .o
Host-agent (in-band) management method .
Direct-management (out-of-band) method
Reviewing a sample network . .
Where to install software components
Management stations
Host computers.
Configuration types
Standard (noncluster) conf|gurat|on .
Cluster server configuration for Windows and NetWare .
Installation types . .
Managing coexisting storage subsystems .
System requirements
Hardware requirements.
Firmware requirements .
Windows software requirements
Windows operating system requirements
NetWare software requirements.
NetWare operating system requirements
Linux software requirements .
Linux operating system requirements.

© Copyright IBM Corp. 2004

.oXi

. Xiii
. Xiv
. Xiv
. XV
. Xvi
. Xvii
. Xvii
. Xvii
. Xviii
. Xviii
. XiX
. XiX
. XX

©COoOUoOWONNNNOOOOO P~ DOWN=



Number of supported logical drives . . . . . . . . . . . . . . . . .28

Chapter 2. Preparing for installation . . . . . . . . . . . . . . . .31
Planning and preparing for Windows installation. . . . . . . . . . . . . 31
Planning and preparing for NetWare installaton. . . . . . . . . . . . .32
Planning and preparing for Linux installation . . . . . . . . . . . . . .32
Preparing a network installaton. . . . . . . . . . . . . . . . . . .33
Step 1: Naming the storage subsystems . . . . . . . . . . . . . . .34
Step 2: Recording the subsystem names . . . . .34
Step 3: Identifying the hardware Ethernet MAC address for each controller . .35
Step 4: Assigning IP addresses to hosts and controllers. . . . . . . . . .37
Step 5: Setting up the DHCP or BOOTP-compatible server . . . . . . . . 38
Setting up a Windows NT 4.0 DHCP server . . . . . . . . . . . . .38
Setting up a Windows 2000 DHCP server . . . . . . . . . . . . . .42
Setting up a Windows Server 2003 DHCP server . . . . . . . . . . .45
Setting up a Novell NetWare DHCP server. . . . . . . . . . . . . .46
Setting up a UNIX BOOTP server . . . . 49
Step 6 (Windows): Verifying the TCP/IP protocol and setting up the host or DNS
table. . . . . . Coe . .. . . . . . .50
WindowsNT40 P 510
Windows 2000 . . . . . . . . . . . . . . . . . . . . . .. .5
Windows Server 2003 . . . . . 52
Step 6 (NetWare): Verifying the TCP/IP protocol and setting up the host or DNS
table. . . . . .53
Step 6 (Linux): Verifying the TCP/IP protocol and setting up the host or DNS
table. . . . . . . . ... . ... ... ... .b4

Chapter 3. Installing Storage Manager software in a standard Windows

configuration . . . . . . . . . . . . . . . . . . . . . . . .5bb
New installation process . . . . . . . . . .55
Installing the IBM fibre-channel host bus adapter dewce driver . . . . . . .56
Storage Manager 8.4 Client . . . . . . . . . . . . . . . . . . . .b6
Installing SMclient. . . . e e e e . . .. . . . . . . . . .56
Verifying the SMclient mstallation - Y 4
Verifying the Event Monitor installaton . . . . . . . . . . . . . . .57
RDAC . . . . . o1
Assigning static drive Ietters e e e ... ... ... . . . .©58
Installing the RDAC . . . . . . . . . . . . . . . . . . . . . .h9
Verifying the RDAC installation . . . . . . . . . . . . . . . . . .60
Storage Manager 84 Agent . . . . . . . . . . . . . . . . . .. .61
Installing SMagent . . . e 2
Verifying the SMagent mstallation O ¢ 724
Storage Manager 8.4 Utility . . . . . . . . . . . . . . . . . . . .63
Installing SMutil. . . . . P
Verifying the SMutil |nstaIIat|on N o 7
Additional information . . . . . . . . . . . . . . . . . . . . . .64

Chapter 4. Installing Storage Manager software in a Windows cluster

server environment. . . . . . . . . . . . . . . . . . . . . .65
Preinstallation considerations. . . . . . . . . . . . . . . . . . . .65
Configuration options . . . . . . . . . . . . . . . . . . . . .65
Hostadapters . . . . . . . . . . . . . . . . . . . . . . . .66
Storage subsystems . . . . ... .67
Installing the storage management software in a cIuster enwronment .. . .67
Windows NT 4.0 and Windows 2000. . . . . . . . . . . . . . . .67
Windows Server2003 . . . . . . . . . . . . . . . . . . . . .68

iv BM TotalStorage FAStT Storage Manager Version 8.4x Installation and Support Guide for Intel-based Operating System

Environments



Installing the IBM fibre-channel host bus adapter device driver .
Installing the storage management software .
Installing the SMclient
RDAC . .
SMagent .
SMutil software . .
Installing the cluster server software .
Windows NT 4.0 and Windows 2000 .
Windows Server 2003 .
Upgrading from a previous version of the storage management software
Performing a scheduled upgrade .
Performing a rolling upgrade .
Upgrading Windows operating systems . .
Upgrading from Windows NT 4.0 to Wlndows 2000 in a standard
configuration .

Upgrading from Windows NT 4 0 to Wlndows 2000 in a Cluster conf|gurat|on
Upgrading from Windows NT 4.0 or Windows 2000 to Windows Server 2003

in a standard configuration. .
Upgrading from Windows 2000 to Wlndows Server 2003 ina cluster
configuration . e e e
Additional information

Chapter 5. Installing Storage Manager software in a standard NetWare

configuration .o
Installation overview . .

Storage Manager 8.4 Client .

Installing Storage Manager 8.4 Cllent (SMcllent)

Verifying the Storage Manager 8.4 Client installation .
Storage Manager 8.4 Agent .

Installing Storage Manager 8.4 Agent (SMagent)

Verifying the Storage Manager 8.4 Agent installation .
Storage Manager 8.4 Utility . .

Installing Storage Manager 8.4 Utlllty (SMutrI)

Verifying the Storage Manager 8.4 Utility installation .
Installing the LSIMPE driver . .
Installing the IBM fibre-channel host bus adapter dewce drlver .
Installing IBM FAStT Management Suite Java
Additional information Coe

Chapter 6. Installing Storage Manager software in a Linux configuration
Installation overview . .
Linux software requrrements
Linux operating system requirements.
Uninstalling Storage Manager
Installing the 8.4 software .
Installing Storage Manager 8.4 Runt|me (SMruntlme)
Verifying the Storage Manager 8.4 Runtime installation .
Installing the Storage Manager 8.4 Client (SMclient) .
Verifying the Storage Manager 8.4 Client installation .
Disabling and enabling the Event Monitor . .
Installing the Storage Manager 8.4 Utility (SMutil) .
Verifying the Storage Manager 8.4 Utility installation .
Uninstalling IBM FAStT Management Suite Java
Installing IBM FAStT Management Suite Java .
Installing the IBM fibre-channel host bus adapter device drlver .
Additional information .

Contents

. 69
. 69
. 70
.72
. 75
.77
. 78
. 78
.79
.79
. 80
. 81
. 84

. 84

84

. 86

. 86
. 88

. 89
. 89
. 90
. 90
. 90
. 91
. 91
.9
.9
. 92
.92
.92
. 93
. 93
. 93

95

. 95
. 95
. 95
. 96
.97
.97
.97
. 97
. 97
. 98
. 98
. 98
. 99
. 99

. 99

. 100

\'}



Chapter 7. Installing Storage Manager software in a VMware ESX Server

configuration. . . . . . . . . . . . . . . . . .. .. .. 101
Software requirements . . . . . . . . . . . . . . . . . . . . 101
Management staton . . . . . . . . . . . . . . . . . . . . .101
Host (ESX Server) . . . . . . . . . . . . . . . . . . . .. .102
Hardware requirements . . . . . . . . . . . . . . . . . . . . .102
Additional information . . . . . . . . . . . . . . . . . . . . . .102
Chapter 8. Completing Storage Manager 8.4 installation. . . . . . . . 103
Completing the installation . . . . e e . . . . . . . . . . .108
Introduction to SANavigator. . . . . . . . .103
Performing an initial automatic dlscovery of storage subsystems .. . . .104
Adding devices . . . e 04
Setting up alert notlfloatlons T (04
Naming storage subsystems . . .. . . . . . . .108
Downloading controller and NVSRAM ESM f|rmware e [0
Creating arrays and logical drives . . . . . . . . . . . . . . . . 109
Verifying and defining the default hosttype . . . . . . . . . . . . . 110
Configuring heterogeneous hosts. . . . . . . . . . . . . . . . .11
Creating a FlashCopy logical drive . . . . . . . . . . . . . . . .12
Using VolumeCopy . . . . . . . . . . . . . . . . . . . .. .12
Using the Remote Mirror option . . . R R K
Performing other storage-subsystem management tasks . . . . . . . .18

Chapter 9. Using the storage management software for Windows and

NetWare . . . . e . . . . . . . 115
Using the storage management software for Wrndows B R B
Adding or deleting logical drives . . . . . . . . . . . . . . . . . 115
Using the hot_add utility . . . . . . . . . . . . . . . . . . . .120
Using the SMdevices utility . . . . . . . . . . . . . . . . . . .120
Using the SMrepassist utility . . . . T P2
Stopping and restarting the host-agent software P P2
Uninstalling storage management software components . . . . . . . . 122
Using the storage management software for NetWare . . . . . . . . . . 123
Adding or deleting logical drives . . . . . . . . . . . . . . . . .123
Using the hot_add utility . . . . . . . . . . . . . . . . . . . .123
Using the SMdevices utility . . . . T o
Stopping and starting the host-agent software T o2
Uninstalling storage-management software components . . . . . . . . 125
Appendix A. Windows operating system limitations . . . . . . . . . 127
Limitations of Windows operating systems . . . . . . . . . . . . . .127
Direct-management method workaround . . . Lo 13
SMagent workaround for defining additional access LUN mapprng .. o132
SMagent workaround for changing existing access LUN mapping. . . . . 132
Appendix B. NetWare operating system limitations. . . . . . . . . . 133
Appendix C. Linux operating system limitations . . . . . . . . . . . 135
Appendix D. VMware ESX Server operating system limitations . . . . . 137
Appendix E. Storage subsystem and controller information record . . . 139
Appendix F. Additional FAStT documentation . . . . . . . . . . . . 141
FAStTO00 Fibre Channel Storage Server library . . . . . . . . . . . . 141

Vi 1BM TotalStorage FAStT Storage Manager Version 8.4x Installation and Support Guide for Intel-based Operating System
Environments



FAStT700 Fibre Channel Storage Server library
FAStT600 Fibre Channel Storage Server library
FAStT-related documents G

Notices .
Trademarks.
Important notes .

Glossary

Index .

. 143
. 144
. 145

. 147
. 147
. 148

. 149

. 157

Contents

Vii



Viii  1BM TotalStorage FASIT Storage Manager Version 8.4x Installation and Support Guide for Intel-based Operating System

Environments



Figures

CONOO AWM~

[ )0 T ' I N W R U W G U U Q-
mPOLONOGB AN SO

Installation process flow by current publications
Host-agent (in-band) managed storage subsystems
Direct-management (out-of-band) storage subsystems .

Sample network using directly-managed and host-agent managed storage subsystems .

Sample standard (noncluster) configuration .

Sample cluster server configuration .

Sample coexisting storage subsystems. . .

Locating the Ethernet MAC address (machine types 3542 and 1722)
Removing the controller-unit bezel (machine types 3552 and 1742) .
Replacing the controller-unit bezel (machine types 3552 and 1742)
Create Scope - (Local) window e e

DHCP Options: Global window.

IP Address Array Editor window

Active Leases window .

Add Option Type window . .

New Scope Wizard: IP Address Range wmdow

Installing the storage subsystem on a fibre-channel network

Sample VMware ESX Server configuration .

Confirm Initial Automatic Discovery window.

Enterprise Management window .

Subsystem Management window

© Copyright IBM Corp. 2004

. Xiv
.1
.12
. 14
. 15
. 22
. 36
. 36
. 37
. 39
. 40
. 40
.41
. 42
. 44
. .66
. 101
. 105
. 106
. 108



X IBM TotalStorage FAStT Storage Manager Version 8.4x Installation and Support Guide for Intel-based Operating System

Environments



Tables

PDMNODMNDODMNODMNDDMNDODMNODNODND 2 A
SNSARSBNES0o®I0rdN=2D

CONOO AWM~

TotalStorage FAStT Storage Manager Version 8.4 titles by user tasks
Machine types and supported storage management software .

New terminology

Configurations for existing storage subsystems

Hardware requirements for Storage Manager 8.4 software
Installation requirements for Windows by software package .
Installation requirements for NetWare by software package
Installation requirements for Linux by software package

Management station or host computer by minimum operating system and kernel Ievels .

Maximum number of logical drives per storage server .

Software component installation in a Windows environment .

Software component installation sequence in a Novell NetWare 6.0 enwronment
Software component installation sequence in a Linux environment

Sample information record .o .

Global options for a Windows NT 4. 0 DHCP server . .

Required entries for setting up the UNIX BOOTP server

Software component installation sequence in a Novell NetWare 6. 0 enwronment
Installation requirements for Linux by software package

Management station or host computer by minimum operating system and kernel Ievel
Windows operating system limitations and workarounds .

Novell NetWare limitations and workarounds .

Linux limitations and workarounds .

VMware ESX Server limitations and workarounds

Storage subsystem and controller information record .

. TotalStorage FAStT900 Fibre Channel Storage Server document tltles by user tasks
. TotalStorage FAStT700 Fibre Channel Storage Server document titles by user tasks
. TotalStorage FAStT600 Fibre Channel Storage Server document titles by user tasks
. TotalStorage FASHT related document titles by user tasks e e

© Copyright IBM Corp. 2004

. XV

. 16
. 23
. 26
.27
. 28
. 28
. 29
. 31
. 32
. 32
. 35
. 39
. 49
. 89
. 95
. . 9
. 127
. 133
. 135
. 137
. 139
141
. 143
. 144
. 145

Xi



xii 1BM TotalStorage FAStT Storage Manager Version 8.4x Installation and Support Guide for Intel-based Operating System

Environments



About this document

Throughout this document, Storage Manager Version 8.4 refers to all version 8.4
software release levels. References to Storage Manager Version 8.41 refer
exclusively to that release.

This document provides information about how to plan, install, configure, and work
with IBM® TotalStorage® Fibre Array Storage Technology (FAStT) Storage Manager
Version 8.4 in each of the following Intel® processor-based operating systems:

+ Microsoft® Windows NT®4.0
+ Windows® 2000

* Windows Server 2003

* Novell NetWare 6.0 and 6.5

* Red Hat Enterprise Linux Advanced Server 2.1 (formerly Red Hat Linux
Advanced Server 2.1)

* United Linux 1.0 1A-64
* United Linux 1.0
— SuSE Linux Enterprise Server 8 (SLES 8)
— Turbolinux Enterprise Server 8 (TLES 8)
— Conectiva Linux Enterprise Edition Powered by United Linux
* VMware ESX Server 2.0
This document also provides information about how to plan, install, configure, and

work with IBM TotalStorage FASIT Storage Manager Version 8.41 in each of the
following Intel processor-based operating systems:

* Windows 2000

* Red Hat Enterprise Linux Advanced Server 2.1 (formerly Red Hat Linux
Advanced Server 2.1)

* United Linux 1.0
— SuSE Linux Enterprise Server 8 (SLES 8)
Turbolinux Enterprise Server 8 (TLES 8)
Conectiva Linux Enterprise Edition Powered by United Linux
IA-64

Use this document to perform the following tasks:

» Determine the hardware and software that you will require to install the storage
management software.

* Integrate the necessary hardware components into your network.
 Install the FASIT Storage Manager software.

» Upgrade controller firmware, if necessary.

» |dentify storage management features that are unique to your installation.

Notes:

1. The controller firmware and NVSRAM that ship with the IBM FAStT Storage
Manager Version 8.4 support only the following FAStT storage servers:

* FAStT600; Machine Type 1722; Model Number 60U
* FAStT600; Machine Type 1722; Model Number 60X
* FAStT700; Machine Type 1742; Model Number 1RU
* FAStT700; Machine Type 1742; Model Number 1RX

© Copyright IBM Corp. 2004 xiii



* FAStT900; Machine Type 1742; Model Number 90U
* FAStT900; Machine Type 1742; Model Number 90X

2. The controller firmware and NVSRAM that ship with the IBM FAStT Storage
Manager Version 8.41 support only the following FAStT storage servers:

* FAStT600; Machine Type 1722; Model Number 60U
* FAStT600; Machine Type 1722; Model Number 60X
* FAStT900; Machine Type 1742; Model Number 90U
* FAStT900; Machine Type 1742; Model Number 90X

Who should read this document

This document is intended for system and storage administrators who are
responsible for installing software. Readers should have knowledge of Redundant

Array of Independent Disks (RAID), Small Computer System Interface (SCSI), and

Fibre Channel technology, They should also have working knowledge of the
applicable operating systems that are used with the management software.

FASLT installation process overview

Xiv

Environments

gives an overview of the FAStT hardware and the FAStT Storage Manager

software installation process. Lined arrows in the flow chart indicate consecutive

hardware and software installation process steps. Labeled arrows indicate which
document provides detailed information about a step.

Install Process Documentation
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Figure 1. Installation process flow by current publications
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FAStT Storage Manager Version 8.4 library

presents an overview of FAStT Storage Manager product library documents
by the common tasks that they address. Click on active links in the tables to access
those documents currently available on the Internet. You can access documentation
for the other FASLIT products at the following Web site:

www-1.ibm.com/servers/storage/support/fastt/index.html|

Table 1. TotalStorage FAStT Storage Manager Version 8.4 titles by user tasks

Title

User tasks

Planning

Hardware
installation

Software
installation

Configuration

Operation and
administration

Diagnosis and
maintenance

Support Guide for|
Intel-based
Operating Systen

Environments,
GC26-762

IBM TotalStorage
FASLtT Storage
Manager 8.4x
Installation and
Support Guide for
AlX, UNIX, and
Solaris, GC26-7622

IBM TotalStora a

FASIT Storage
Manager Copy/
Services User’s|

Guide, GC26-7561

IBM FAStT Storage
Manager Script
Commands (see
product CD)

IBM TotalStorag
FASIT Storagé
Manager Concepts
Guide, GC26-7560
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How this document is organized

[Chapter 1, “Introduction,” on page 1|provides an overview of IBM FAStT Storage
Manager Version 8.4 and describes storage subsystem management methods,
configuration types, types of installations, and installation requirements.

|Chapter 2, “Preparing for installation,” on page 31|discusses preparing for a network
installation, including setting up a Dynamic Host Configuration Protocol/Boot
Protocol (DHCP/BOQOTP) server on Windows NT 4.0, Windows 2000, Windows
Server 2003, NetWare, Linux, and UNIX® platforms. It also describes other setup
tasks.

Chapter 3, “Installing Storage Manager software in a standard Windowsl
configuration,” on page 55| provides installation instructions for Windows NT,
Windows 2000, and Windows 2000 Server software components in a standard
(noncluster) environment.

Chapter 4, “Installing Storage Manager software in a Windows cluster server|
environment,” on page 65| provides installation instructions for Windows NT,
Windows 2000, and Windows 2000 Server software in a cluster server environment.

Chapter 5, “Installing Storage Manager software in a standard NetWare|
configuration,” on page 89 provides installation instructions for the storage
management software in standard (noncluster) and cluster server configurations in
the NetWare 6.0 operating system environment.

Chapter 6, “Installing Storage Manager software in a Linux configuration,” on page]
95| provides installation instructions for the storage management software in a Linux
operating system environment.

Chapter 7, “Installing Storage Manager software in a VMware ESX Server
configuration,” on page 101|provides installation instructions for the storage
management software in a VMware ESX Server operating system environment.

[Chapter 8, “Completing Storage Manager 8.4 installation,” on page 103| discusses
completion of Storage Manager software on Windows NT, Windows 2000, Windows
2000 Server, NetWare, and Linux platforms. It provides details on starting the
Enterprise Management window, performing an automatic discovery of storage
subsystems, adding devices, setting up alert notifications, downloading firmware
and nonvolatile storage random access memory (NVSRAM), creating arrays and
logical drives, and other storage subsystem management tasks.

Chapter 9, “Using the storage management software for Windows and NetWare,” on|
page 115| provides information about adding and deleting logical drives, using the
hot_add and SMdevices utilities, starting and stopping the host-agent software, and
uninstalling Storage Manager components in Windows NT, Windows 2000,
Windows 2000 Server, and NetWare operating system environments.

IAppendix A, “Windows operating system limitations,” on page 127| discusses
Windows NT, Windows 2000, and Windows Server 2003 operating system
limitations and other operating system issues.

IAppendix B, “NetWare operating system limitations,” on page 133 discusses
NetWare operating system limitations and other related operating system issues.
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l[Appendix C, “Linux operating system limitations,” on page 135|discusses Linux
operating system limitations and other related operating system issues.

lAppendix D, “VMware ESX Server operating system limitations,” on page 137|
discusses VMware ESX Server operating system limitations and other related
operating system issues.

|Appendix E, “Storage subsystem and controller information record,” on page 1351
provides a data sheet template that you can use to create a controller information
record.

IAppendix F, “Additional FAStT documentation,” on page 141|provides an overview
of the FAStT900, FAStT700, and FAStT600 Fibre Channel Storage Server product
libraries, as well as other related documents.

Notices that this document uses

This document contains the following notices designed to highlight key information:
* Notes: These notices provide important tips, guidance, or advice.

* Important: These notices provide information that might help you avoid
inconvenient or problem situations.

» Attention: These notices indicate possible damage to programs, devices, or
data. An attention notice is placed just before the instruction or situation in which
damage could occur.

Getting information, help, and service

If you need help, service, or technical assistance or just want more information
about IBM and IBM products, you will find a wide variety of sources available from
IBM to assist you. This section contains information about where to go for additional
information, what to do if you experience a problem with your IBM @server
xSeries® or IntelliStation® system, and whom to call for service, if it is necessary.

Before you call

Before you call, make sure that you take these steps to try to solve the problem
yourself:

* Check all cables to make sure that they are connected.
» Check the power switches to make sure that the system is turned on.

» Use the troubleshooting information in your system documentation, and use the
diagnostic tools that come with your system.

Go to the IBM Support Web site at:

[www.ibm.com/pc/support/]

to check for technical information, hints, tips, and new device drivers.
* Use an IBM discussion forum on the IBM Web site to ask questions.

You can solve many problems without outside assistance by following the
troubleshooting procedures that IBM provides in the online help or in the
publications that are provided with your system and software. The information that
comes with your system also describes the diagnostic tests that you can perform.
Most xSeries and IntelliStation systems, operating systems, and programs come
with information that contains troubleshooting procedures and explanations of error
messages and error codes. If you suspect a software problem, see the information
for the operating system or program.

About this document  XVii
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Using the documentation

Information about your IBM @server xSeries or IntelliStation system and
preinstalled software, if any, is available in the documentation that comes with your
system. That documentation includes printed documents, online documents, readme
files, and help files. See the troubleshooting information in your system
documentation for instructions for using the diagnostic programs. The
troubleshooting information or the diagnostic programs might tell you that you need
additional or updated device drivers or other software. IBM® maintains pages on the
World Wide Web where you can get the latest technical information and download
device drivers and updates. To access these pages, go to the Web site at:

www.ibm.com/pc/support/

and follow the instructions. Also, to order publications through the IBM Publications
Ordering System, go to the Web site at:

www.elink.ibmlink.ibm.com/public/applications/publications/cgibin/pbi.cgil

Web sites

Locate up-to-date information about FAStT Fibre Channel Storage Servers and

FASIT Storage Manager 8.4, including documentation and the most recent software,

firmware, and NVSRAM downloads at the following Web sites.

IBM xSeries servers
For IBM xSeries information, go to the Web site at:
www.ibm.com/eserver/xseries/

IBM IntelliStation
For IBM IntelliStation information, go to the Web site at:
www.ibm.com/pc/intellistation/]

FAStT Fibre Channel Storage Servers
Find the latest information about all of the IBM FAStT Fibre Channel
Storage Servers at:
www.ibm.com/storage/disk/fastt/

IBM TotalStorage products
Find information about all IBM TotalStorage products at:
www.ibm.com/storage]

TotalStorage FAStT interoperability matrix
Find the latest information about operating system and host bus adapter
(HBA) support, clustering support, storage area network (SAN) fabric
support, and Storage Manager feature support at:
|www.ibm.com/storage/disk/fastt/supserver.htm/1

IBM Service
For service information for your IBM products, including supported options,
go to the Web site at:
www.ibm.com/pc/support/
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FASIT technical support
Find FASIT software downloads, hints and tips, documentation, parts
information, HBA and fibre channel support at:

www-1.ibm.com/servers/storage/support/fastt/index.html|

If you click Profile from the support page, you can create a customized
support page. The support page has many sources of information and ways
for you to solve problems, including how to:

» Diagnose problems, using the IBM Online Assistant.

* Download the latest device drivers and updates for your products.

* View Frequently Asked Questions (FAQ).

* View hints and tips to help you solve problems.

» Participate in IBM discussion forums.

» Set up e-mail notification of technical updates about your products.
Premium feature activation

Enable a premium feature on a FAStT600 or FAStT900 by using the online
tool at:

www.storage.ibm.com/pfeatures.html|

IBM Publications Center
Order IBM publications at:

www.ibm.com/shop/publications/order/|

Software service and support

Through the IBM Support Line, for a fee, you can get telephone assistance with
usage, configuration, and software problems with xSeries servers, IntelliStation
workstations and appliances. For information about which products are supported
by Support Line in your country or region, go to the Web site at:

www.ibm.com/services/sl/products/|

For more information about Support Line and other IBM services, go to the Web
site at:

www.ibm.com/services/

or, for support telephone numbers, go to the Web site at:

www.ibm.com/planetwide]

Hardware service and support

You can receive hardware service through IBM Integrated Technology Services or
through your IBM reseller, if your reseller is authorized by IBM to provide warranty
service. For support telephone numbers, go to the Web site at:

www.ibm.com/planetwide/|

In the U.S. and Canada, hardware service and support are available 24 hours a
day, 7 days a week. In the U.K., service and support are available Monday through
Friday, from 9 a.m. to 6 p.m.
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How to send your comments

Your feedback is important to help us provide the highest quality of information. If
you have any comments about this document, please either fill out the Readers’
comments form (RCF) at the back of this document and give it to an IBM
representative, or submit it in one of the following ways:

e E-mail

Submit your comments over the Internet to:

[starpubs @ us.ibm.com|
— Submit your comments over IBMLink™ from the U.S.A. to:

STARPUBS at SUIEVM5
— Submit your comments over IBMLink from Canada to:

STARPUBS at TORIBM
— Submit your comments over IBM Mail Exchange to:

USIB3WD at IBMMAIL

Be sure to include the name and order number of the document and, if
applicable, the specific location of the text that you are commenting on, such as
a page or table number.

*  Mail
Complete the readers’ comments form (RCF) at the back of this document and

return it by mail. If the RCF Business Reply Mailer has been removed, you may
address your comments to:

International Business Machines Corporation
Information Development

Dept. GZW

9000 South Rita Road

Tucson, Arizona 85744-0001

U.S.A.
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Chapter 1. Introduction

IBM FAStT Storage Manager version 8.4x host software supports new features
incorporated into the latest release of controller firmware version 05.4x.xx.xx. This
version of FAStT Storage Manager also manages FAStT storage servers with all
general released firmware versions from 04.00.02.xx through 05.3x.xx.xx. The latest
controller firmware versions supporting FAStT600 storage servers available
free-of-charge are of the 05.34.xx.xx code thread. The latest controller firmware
versions supporting FAStT200, FAStT500, FAStT700 and FAStT900 storage servers
available free-of-charge are of the 05.30.xx.xx code thread. You can upgrade
FAStT600, FAStT700 and FAStT900 storage servers to the 5.4x.xx.xx controller
firmware version only by purchase option. New features associated with the
05.4x.xx.xx controller firmware are listed in[‘New features” on page 2.|

This document provides information on how to prepare, install, configure, and start
IBM TotalStorage FASIT Storage Manager Version 8.4 in the following operating
system environments:

* Windows NT 4.0

*  Windows 2000

* Windows Server 2003
* Novell NetWare

e Linux

* VMware ESX Server

This document also provides information on how to prepare, install, configure, and
start IBM TotalStorage FAStT Storage Manager Version 8.41 in the following
operating system environments:

* Windows 2000
e Linux

Consult your IBM service representative for any future support of additional
operating system environments.

Before you begin the installation of this product, consult the following
documentation:

¢ readme.txt file

Read this document first. It supplies information associated with operating
systems on which you can install Storage Manager software. A readme file is
located in the root directory of each of four installation CDs associated with
supported operating systems. For the latest installation and user information,
refer to the following IBM Web site:

[www-1.ibm.com/servers/storage/support/fastt/index.html|
» IBM TotalStorage FAStT Storage Manager Concepts Guide

Use this document to become familiar with terminology and features of the IBM
FAStT Storage Manager software. To download this book, go to the Web site at:

[www-1.ibm.com/servers/storage/support/fastt/index.html|

When you finish the installation process, refer to the following online help systems:
* Enterprise Management window help

Use this online help system to learn more about working with the entire
management domain.
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» Subsystem Management window help

Use this online help system to learn more about managing individual storage
subsystems.

You can access these help systems from within the Storage Manager 8.4 Client.
From either an Enterprise Management or Subsystem Management window, click
Help or press F1.

After you install IBM FAStT Storage Manager Version 8.4, consider installing the
FAStT Management Suite Java (FAStT MSJ) and SANavigator diagnostic programs.
You can use these programs to verify the status of the fibre channel connections
before you use the storage subsystem.

The SANavigator program (Windows and Linux), the IBM FAStT MSJ User’s Guide,
and the FAStT MSJ program are located on the IBM FAStT Storage Manager
Version 8.4 CD where associated with your particular operating system. For
information about how to install and run SANavigator, see the FAStT Hardware
Maintenance Manual and Problem Determination Guide.

New features

This section describes the standard features that are part of the Storage Manager
Version 8.4 software. Your storage subsystem firmware must be version 5.4x.xx.xx
if you want to use any of the features listed in this section. If your controller
firmware is version 05.3x.xx.xx or earlier, you must purchase a firmware upgrade
option.

The following new features and support have been added to the Storage Manager
version 8.40 software:

» Support for IBM TotalStorage FAStT600 Turbo Option Fibre Channel Storage
Server

» Support for up to 256 logical unit number (LUN) mappings per host server
(depending on the operating system)

* Persistent Reservations feature
* VolumeCopy feature

Storage Manager 8.41 supports:

» FASIT EXP100 storage expansion enclosure attachment to FAStT600 and
FAStT900 storage servers.

» Serial ATA (SATA) hard drives instead of fibre-channel hard drives

* Firmware version 5.41.xx.xx, which ships as part of the EXP100 expansion
enclosure without additional charge.

Restrictions to Storage Manager software Version 8.41 and firmware version level
5.41.xx.xx include:

+ No copy services support (Remote Mirroring Option, FlashCopy®, VolumeCopy)

* No support for the simultaneous attachment of the EXP100 expansion enclosure
to controllers that are attached to EXP700 or EXP500 expansion enclosures
(those using fibre-channel hard drives)

» FASIT storage servers require that you install firmware version 5.41.xx.xx and its
associated NVSRAM file for SATA hard drives to be recognized in EXP100
expansion enclosures.
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You can either order FAStT storage servers factory-equipped with firmware
version 5.41.xx.xx or upgrade your firmware and NVSRAM files using the
procedure documented in the IBM TotalStorage FAStT EXP100 Storage
Expansion Unit Installation and User’s Guide, GC26-7601.

» After the upgrade is complete, you cannot downgrade a controller firmware from
version 5.41.xx.xx to any previous version.

Premium features

FAStT600

* The Remote Mirror feature is not currently supported on either the
FAStT600 or FAStT600 Turbo Option Fibre Channel storage servers.

« Storage Partitioning is not a standard feature on the FAStT600.

Four premium features can be enabled on all FAStT subsystems by purchasing a
premium feature key. These include FlashCopy, Remote Mirror option, VolumeCopy,
and Storage Partitioning (standard on all but the FAStT600 and FAStT600 Turbo
Option). Each of these features is described in the following section.

FlashCopy
This feature supports the creation and management of FlashCopy logical
drives. A FlashCopy logical drive is a logical point-in-time image of another
logical drive, called a base logical drive, that is in the storage subsystem. A
FlashCopy is the logical equivalent of a complete physical copy, but you
create it much more quickly and it requires less disk space. Because a
FlashCopy is a host addressable logical drive, you can perform backups
using the FlashCopy while the base logical drive remains online and
user-accessible. In addition, you can write to the FlashCopy logical drive to
perform application testing or scenario development and analysis. The
maximum number of FlashCopy logical drives allowed is one half of the
total number of logical drives supported by your controller model.

Remote Mirror Option
The Remote Mirror option is used for online, real-time replication of data
between storage subsystems over a remote distance. In the event of a
disaster or unrecoverable error on one storage subsystem, the Remote
Mirror Option enables you to promote a second storage subsystem to take
over responsibility for normal input/output (I/O) operations.

VolumeCopy
The VolumeCopy feature is a firmware-based mechanism for replicating
logical drive data within a storage array. This feature is designed as a
system management tool for tasks such as relocating data to other drives
for hardware upgrades or performance management, data backup, or
restoring FlashCopy logical drive data. Users submit VolumeCopy requests
by specifying two compatible drives. One drive is designated as the Source
and the other as the Target. The VolumeCopy request is persistent so that
any relevant result of the copy process can be communicated to the user.

Storage Partitioning

Storage Partitioning allows the user to present all storage volumes to a
SAN through several different partitions by mapping storage volumes to a
LUN number, each partition presenting LUNs 0 - 255. This volume/LUN
mapping applies only to the host port or ports that have been configured to
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access that LUN. A given storage volume can have only one Host/LUN
mapping. This feature allows the total number of configurable storage
volumes supported by the array to be much greater than the number of
addressable storage devices.

This feature also allows the support of multiple hosts using different
operating systems and their own unique disk storage subsystem settings to
be connected to the same FASIT Storage Serverat the same time
(heterogeneous host environment).

Storage Manager 8.4 limitations

Because there is no Storage Manager 8.4-level firmware and NVSRAM for
FAStT200 (3542-1RU) and FAStT500 (3552-1RU), Storage Manager 8.4 features
are unavailable for these products. However, IBM recommends that you use
Storage Manager 8.4 host software to manage these FAStT Storage Servers.

Supported machine types

provides a list of machine types and supported storage management
software.

Table 2. Machine types and supported storage management software

Supported storage
Machine Firmware |management software
Product name type Model |version version
IBM Netfinity® Fibre Channel 3526 1RU 4.x 7.0,7.01,7.02, 7.10,
RAID Controller Unit 1RX 8.0, 8.2, 8.21, 8.3, 8.41
IBM FAStT200 Storage Server 3542 1RU 4.x, 7.02, 7.10, 8.0, 8.2,
1RX 5.20.xx.xx [8.21, 8.3, 8.41
5.30.xx.xX
IBM FAStT200 High Availability 3542 2RU 4.x, 7.02, 7.10, 8.0, 8.2,
Storage Server 2RX 5.20.xx.xx |8.21, 8.3, 8.41
5.30.xx.XX
IBM Netfinity FAStT500 RAID 3552 1RU 4.x, 7.0,7.01,7.02, 7.10,
Controller Enclosure Unit 1RX 5.00.xx.xx |[8.0, 8.2, 8.21, 8.3, 8.41
5.20.xX.XX
5.21.xXx.Xx
5.30.xx.xx
IBM TotalStorage FAStT700 Fibre | 1742 1RU 5.00.xx.xx |8.0, 8.2, 8.21, 8.3, 8.41
Channel Storage Server 1RX 5.20.xx.XX
5.21.xx.xXx
5.30.xx.XX
5.40.xx.Xx
IBM TotalStorage FAStT900 Fibre | 1742 90X 5.30.xx.xx |8.3, 8.4, 8.41
Channel Storage Server 90U 5.40.xx.xx
5.41.xx.xX
(supports
EXP100
only)
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Table 2. Machine types and supported storage management software (continued)

Supported storage

Machine Firmware |management software
Product name type Model |version version
IBM TotalStorage FAStT600 Fibre | 1722 6LU 5.34.xx.xx |8.41.xx.03 or later
Channel Storage Server 6LX

60U 5.33.xx.xx |8.3, 8.4, 8.41
60X 5.34.xx.xx
5.40.xx.xx

5.41.xx.xX
(supports
EXP100
only)

Notes:
1. Firmware level 5.41.xx.xx provides EXP100 expansion enclosure support only.

2. Firmware level 5.40.xx.xx and earlier provide support for EXP500 and EXP700
expansion enclosures only.

3. Controller firmware versions regulate the function of any given Storage Manager
client code version release. You might need to purchase the appropriate
firmware upgrade option to enable the function of your particular Storage
Manager client code version release. Storage subsystem firmware must be at
version 04.00.02.xx or higher to be managed with Storage Manager 8.0, 8.2,
8.21, 8.3, 8.4 or 8.41.

4. This table associates all compatible controller firmware and management
software versions for the various FAStT Storage Server products. To ensure the
highest level of compatibility and error-free operation, the controller firmware for
all FAStT Storage Server products should be 05.3x.xx.xx-level (except for
machine type 3526, for which the latest available firmware level is 04.01.xx.xx.)
and the management software version should be 08.4x.xx.xx-level or higher.

Terms to know

If you are upgrading from a previous version of the storage management software,
some of the terms you are familiar with have changed. It is important that you
familiarize yourself with the new terminology. provides a list of some of the
changed terms. For further information on terminology, see the Help section of the
Storage Manager Enterprise Management window, the Storage Subsystem
Management window, or the glossary on page .

Table 3. New terminology

Term used in previous versions New term

RAID module Storage subsystem
Drive group Array

Volume Logical drive

It is important to understand the distinction between the following two terms when
you read this document.
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Management station
A management station is a system that is used to manage the storage
subsystem. You can attach it to the storage subsystem in either of the
following ways:

* Through a TCP/IP Ethernet connection to the controllers in the storage
subsystem

» Through a TCP/IP connection to the host-agent software that is installed
on a host computer, which in turn is directly attached to the storage
subsystem through the fibre-channel input/output (1/O) path

Host computer
A host computer is a system that is directly attached to the storage
subsystem through a fibre-channel 1/O path. This system is used to perform
the following tasks:

« Serve data (typically in the form of files) from the storage subsystem

» Function as a connection point to the storage subsystem for a
remote-management station

Notes:

1. The terms host and host computer are used interchangeably throughout
this document.

2. A host computer can also function as a management station.

IBM FAStT Storage Manager Version 8.4 software for Windows

Storage Manager Version 8.4 contains the following software components for
Windows NT 4.0, Windows 2000, and Windows Server 2003:

* The following component installs on both the host and management station:
— Storage Manager 8.4 Client (SMclient)
* The following components install only on the host:
— Redundant Disk Array Controller (RDAC)
— Storage Manager 8.4 Agent (SMagent)
— Storage Manager 8.4 Utility (SMutil)

Microsoft Virtual Machine

Systems running Windows NT 4.0 and Storage Manager 8.4 do not require the
Microsoft Virtual Machine to support the following components or options:

* SMagent
« Event Monitor option of the SMclient

Storage Manager 8.4 Client

The Storage Manager 8.4 Client (SMclient) component provides the graphical user
interface (GUI) for managing storage subsystems. The SMclient contains two main
components:

* Enterprise Management. You can use the Enterprise Management component
to add, remove, and monitor storage subsystems within the management
domain.

* Subsystem Management. You can use the Subsystem Management component
to manage the components of an individual storage subsystem.

The Event Monitor is a separate program that is bundled with the SMclient. If
installed, it monitors storage subsystems whenever the Enterprise Management
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window is closed. It runs continuously in the background and can send alert
notifications in the event of a critical problem.

Redundant disk array controller

The redundant disk array controller (RDAC) contains the multi-path device driver
that is necessary to provide controller failover support when a component on the
fibre-channel I/O path fails. For RDAC in Storage Manager 8 and higher, a
maximum of four end-to-end fibre-channel paths from the host to the storage
subsystems are supported.

Storage Manager 8.4 Agent

The Storage Manager Agent (SMagent) provides a management conduit for the
SMclient to configure and monitor the subsystem through the fibre-channel I/O path.
The agent also provides local or remote access to the SMclient depending on
whether the client is installed on the host or in a network management station over
the TCP/IP network.

Storage Manager 8.4 Utility

The Storage Manager 8.4 Utility (SMutil) dynamically defines and maps new logical
drives to the operating system. This software package contains the following
components:

» hot_add utility. The hot_add utility enables you to register newly created logical
drives with the operating system. For more information, see [‘Using the hot_add|
[utility” on page 120

» SMdevices utility. The SMdevices utility enables you to associate storage
subsystem logical drives with operating-system device names. For more
information, see [‘Using the SMdevices utility” on page 120 |

* SMrepassist utility. The SMrepassist utility enables you to perform the following
tasks:

— Flush cached data before creating a FlashCopy or VolumeCopy.

— Resolve duplicate logical drive signatures between the base logical drives and
a FlashCopy logical drive or between target and source logical drives in a
VolumeCopy logical drive pair (Windows NT 4.0 only).

For more information, see|“Using the SMrepassist utility” on page 121

IBM FAStT Storage Manager Version 8.4 software for NetWare
Storage Manager Version 8.4 contains the following software components for
NetWare:

* The following components install on both the host and management station:
— Storage Manager 8.4 Client (SMclient)
» The following components install only on the host:
— Storage Manager 8.4 Agent (SMagent)
— Storage Manager 8.4 Utility (SMutil)
- hot_add
- SMdevices
— LSIMPE.CDM
Download this software component from the following Web site:
[support.novell.com|
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IBM FAStT Storage Manager Version 8.4 software for Linux

Storage Manager Version 8.4 contains the following software components for Linux:
* The following components install on both the host and management station:

— Storage Manager 8.4 Client (SMclient)

— Storage Manager 8.4 Runtime (SMruntime)
* The following components install only on the host:

— Storage Manager 8.4 Utility (SMutil)

— IBM FAStT MSJ QLremote agent

— FAStT Management Suite Java™ (FAStT MSJ)

Storage subsystem management methods

The storage management software provides the following two methods for
managing storage subsystems:

* The host-agent management method
* The direct management method

Unless you are using Windows NT, you must make direct (out-of-band) connection
to the FASLT Storage Server in order to obtain the correct host type. The correct
host type will allow the FASIT Storage Server to configure itself properly for the
operating system of the host server. After you do so, and depending on your
particular site requirements, you can use either or both management methods. The
management methods you select will determine where you will need to install the
software components.

Note: Storage Manager 8.4 supports only the out-of-band management method for
use with the Linux operating system.

Host-agent (in-band) management method

When you use the host-agent (in-band) management method, you manage the
storage subsystems through the fibre-channel 1/0 path to the host. The
management information can either be processed in the host or passed to the
management station through the network connection, as shown in [Figure 2 on page|

Managing storage subsystems through the host-agent has the following
advantages:

» Ethernet cables do not need to be run to the controllers.

* A Dynamic Host Configuration Protocol/Bootstrap Protocol (DHCP/BOOTP)
server is not needed to connect the storage subsystems to the network.

* The controller network configuration tasks that are described in
|“Preparing for installation,” on page 31 | do not need to be performed.

* A host name or IP address must only be specified for the host instead of for the
individual controllers in a storage subsystem. Storage subsystems that are
attached to the host are automatically discovered.

Managing storage subsystems through the host-agent has the following
disadvantages:

* The host-agent requires a special logical drive, called an access logical drive, to
communicate with the controllers in the storage subsystem. Therefore, you are
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limited to configuring one less logical drive than the maximum number that is
allowed by the operating system and the host adapter that you are using.

* If the connection through the fibre channel is lost between the host and the
subsystem, the subsystem cannot be managed or monitored.

Note: The access logical drive is also referred to as the Universal Xport Device.

Important: If your host already has the maximum number of logical drives
configured, either use the direct-management method or give up a logical drive for
use as the access logical drive. For more information, see ['Number of supported|
logical drives” on page 28

Running the
host-agent software
’ Controller ‘ ***** !
’ Controller ‘
Host computer
Fibre Channel
I/O path
’ Controller ‘ Network—
’ Controller ‘

Storage subsystems

Note: The host can
act as a management
station also.

Management station
(one or more) $J000879

Figure 2. Host-agent (in-band) managed storage subsystems

Direct-management (out-of-band) method

When you use the direct-management (out-of-band) method, you manage storage
subsystems directly over the network through a TCP/IP Ethernet connection to each
controller. To manage the storage subsystem through the Ethernet connections, you
must define the IP address and host name for each controller. Each of the storage
subsystem controllers must be connected, through a cable connected to the RJ-45
connector, to an Ethernet network, as shown in [Figure 3 on page 11

Managing storage subsystems using the direct-management (out-of-band) method
has the following advantages:
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* The Ethernet connections to the controllers enable a management station
running SMclient to manage storage subsystems that are connected to a host
running any of the operating systems that Storage Manager 8.4 supports.

* An access logical drive is not needed to communicate with the controllers. You
can configure the maximum number of logical drives that are supported by the
operating system and the host adapter that you are using.

* You can manage and troubleshoot the storage subsystem when there are
problems with the fibre-channel links.

Managing storage subsystems using the direct-management (out-of-band) method

has the following disadvantages:

* You need two Ethernet cables to connect the storage subsystem controllers to a
network.

* When adding devices, you must specify an IP address or host name for each
controller.

* Network preparation tasks are required and you might need a DHCP/BOOTP
server. For a summary of the preparation tasks, see|Chapter 2, “Preparing for|
[installation,” on page 31

You can avoid DHCP/BOOTP server and network tasks by assigning static IP
addresses to the controller, or by using a default IP address.

» To assign a static IP address, see the IBM support Web site at:
[www.ibm.com/pc/support/]

Refer to Retain Tip “H171389 Unable To Setup Networking Without
DHCP/BOOTP.

» Storage subsystem controllers with firmware version 05.00.xx. or higher have the
following default settings.

Controller IP address Subnet mask

A 192.168.128.101 255.255.255.0

B 192.168.128.102 255.255.255.0
Notes:

1. If the storage subsystem controllers have firmware version 05.4x.xx.xx or
higher, use the Storage Manager Client Program to change the default IP
address.

2. You must make a direct management connection to the storage server using
the default IP addresses before you can change them.

|Figure 3 on page 11|shows a system in which storage subsystems are managed by
using the direct-management (out-of-band) method.
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’ Controller ‘ ***** !

’ Controller ‘
Host computer
Fibre Channel
I/0 path

’ Controller ‘

’ Controller ‘

Storage subsystems

<+— Ethernet

Management station
(one or more) ;000864

Figure 3. Direct-management (out-of-band) storage subsystems

Reviewing a sample network

[Figure 4 on page 12[shows an example of a network that contains both a
directly-managed storage subsystem (Network A) and a host-agent-managed
storage subsystem (Network B).

Directly-managed storage subsystem: Network A is a directly-managed storage
subsystem. Network A contains the following components:

- A DHCP/BOOTP server

* A network management station (NMS) for Simple Network Management Protocol
(SNMP) traps

* A host that is connected to a storage subsystem through a fibre-channel I/O path

* A management station that is connected by an Ethernet cable to the storage
subsystem controllers

Note: If the controllers, static IP addresses, or default IP addresses are used, you
do not need to setup the DHCP/BOOTP server.

Host-agent-managed storage subsystem: Network B is a host-agent-managed
storage subsystem. Network B contains the following components:

* A host that is connected to a storage subsystem through a fibre-channel I/O path

Chapter 1. Introduction 11



* A management station that is connected by an Ethernet cable to the host

computer
Network A Fibre Channel
TCP/IP I/O path Ethernet
Storage
subsystem
‘ ’ ‘ . finance ’—‘
Network Host computer ', Controller || Management DHCP/BOOTP server
management Denver | Control station

station (IP address ] | (one or more)

(for SNMP traps)192.168.128.112) Host name: Denver._a
(IP address 192.168.128.101)

hardware address 00.a0.b8.02.04.20
Host name: Denver_b

Router (IP address 192.168.128.102)
hardware address 00.a0.b8.00.00.d8
Network B Fibre Channel
TCP/IP I/0 path Ethernet

Storage
subsystem

|:| Yo engineering |:|
ot Management
Atlanta ! Controller

‘ station
182P $ggr2es2$2) """ (one or more)

$J000882

Figure 4. Sample network using directly-managed and host-agent managed storage
subsystems

Where to install software components

How you manage the storage subsystems determines where you must install the
various software components.

Management stations

You must install the following software components on each management station:
» SMclient

¢ SMruntime (for Linux only)

Host computers

You must install the following software components on each host computer:

* RDAC (for Linux, Windows NT, Windows 2000, and Windows Server 2003 only)
e SMutil

* LSIMPE.com (for NetWare only)

* |IBM FASIT MSJ and QLRemote agent (for Linux only if Linux RDAC is not
installed)
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Note: See the Linux RDAC README in the IBM FAStT Storage Manager for x86
Linux software package for detailed Linux RDAC installation instructions.

Depending on how you intend to manage the storage subsystems, you might need
to install the following software components:

» SMagent (for Windows NT, Windows 2000, Windows Server 2003, and NetWare
only)

* SMclient

*  SMruntime (for Linux only)

Install the SMagent on a host computer if you intend to manage the storage
subsystems using the host-agent management method.

You must install the SMclient on a host computer if you intend the host computer to
act as a management station. If the host computer is not connected to a network,
you must install TCP/IP software and assign an IP address.

Configuration types

You can install Storage Manager 8.4 in either of the two following configurations:
» Standard (noncluster) configuration
» Cluster server configuration

— Although there is currently no support for Linux cluster server configurations,
you can contact IBM for updates regarding availability of such support in the
future.

— lllustrations of cluster server configurations that follow do not pertain to
NetWare.
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Standard (noncluster) configuration
shows a sample standard (noncluster) configuration.

Controller ‘
‘ | RDAC, SMutil,
1 Controller SMagent
| 1
Host computer
“«———Fibre Channel
| I/O path
’ Controller ‘ ****** i
The SMclient software
’ Controller ‘ fffffff can also be installed
on the host computer.
Storage subsystems
SMclient
<+— Ethernet
Management station $J000869

Figure 5. Sample standard (noncluster) configuration
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Cluster server configuration for Windows and NetWare

Figure 6[ shows a sample cluster server configuration.

RDAC, SMutil,
SMagent

Ethernet —»

SMclient

Management station
(one or more)

| &

|

Cluster server
node A

The SMclient software
can also be installed on
the cluster nodes.

Storage subsystem

Figure 6. Sample cluster server configuration

/" Cluster server
‘ node B

N
3
\

1
'

Managed hub or
switch

’ Controller ‘

’ Controller ‘

$J000870

Installation types

You can install the storage management software in either of the following types of

hardware environments:

New storage subsystem environment. Use this hardware environment if you
are installing the IBM TotalStorage FASIT Fibre Channel Storage Server using
firmware 05.4x.xx.xx and you will manage storage subsystems using Storage

Manager 8.4.

Existing storage subsystem environment. If you are installing the storage

management software in an environment with existing storage subsystems, see

[Table 4 on page 16| for your installation options.

Notes:

1.

Where you are instructed in the following table to uninstall Storage Manager

software (for Windows operating systems only), be sure to uninstall the
management software on all management systems or hosts that have access to
the storage subsystem that has firmware 5.4x.xx.xx. The Storage Manager 8.4
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RDAC has new functionality and features and it is compatible with older
versions of firmware. To ensure the highest level of compatibility and error-free
operation, install the Storage Manager 8.4 RDAC on all host computers that
have disks defined on storage subsystems that have firmware level 5.4x.xx.xx

2. Because uninstallation and installation of RDAC require a system reboot, it is
possible to install all other components of Storage Manager 8.4, except RDAC,
so that you can download the new firmware version (05.4x.xx.xx) to the storage
subsystem and manage it. Schedule an RDAC installation as soon as possible
to ensure error-free operation and the highest level of compatibility.

Table 4. Configurations for existing storage subsystems

Environments

Current environment |Planned environment |Action
(Machine type 1742) Firmware version 1. Purchase option.
Existing storage 5.40.x0xx 2. Uninstall Storage Manager 8.3x. See

subsystems with
controllers that have
firmware versions
05.00.xx.xx, 05.2X.XX.XX
or 05.3x.xx.xx

(Machine type 1722)
Existing storage
subsystems with
controllers that have
firmware version
05.3X.XX.XX

Storage Manager 8.4x.
Note: Firmware version
05.40.xx.xx supports
EXP500 and EXP700
expansion enclosures
only.

3.

‘Uninstalling storage management|
software components” on page 122
for more information.

Install Storage Manager 8.4. See
['New installation process” on page 55
for more information.

Discover the storage subsystems.
See [‘Performing an initial automatic|
discovery of storage subsystems” onl
page 104|for more information.

Download firmware and NVSRAM

version 5.4x.xx.xx. See |“Down|oading|
controller and NVSRAM ESM|
firmware” on page 109|for more
information.

Note: Upgrade the controller firmware
using the version supplied on the FASIT
Storage Manager 8.40 Upgrade CD
before downloading controller firmware
from the Web.

Only after you have done so, access the
Web to download controller firmware
version 5.40.xx.xXx.
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Table 4. Configurations for existing storage subsystems (continued)

Current environment

Planned environment

Action

(Machine type 1742)
Existing storage
subsystems with
controllers that have
firmware versions
05.00.xx.xx, 05.2X.XX.XX
or 05.3x.xXx.xXx

(Machine type 1722)
Existing storage
subsystems with
controllers that have
firmware version
05.3%x.XX.XX

Firmware version
5.41.xXX.XX

Storage Manager 8.4x.

Notes:

Perform upgrade of
machine types 1742
and 1722 to
firmware level
05.41.xx.xx only
when you no longer
plan to use these
storage servers to
manage EXP500
and EXP700
storage expansion
enclosures equipped
with fibre-channel
drives. Perform this
upgrade only when
you plan to use
these FASLT storage
servers only to
manage EXP100
expansion
enclosures.

2. Firmware version
05.41.xx.xx supports
EXP100 expansion
enclosures only.

1. This firmware ships as part of the
FAStT Storage Manager 8.41 Support
for FAStT EXP100 SATA Storage
Expansion Unit CD.

2. Uninstall Storage Manager 8.3x. See
‘Uninstalling storage management|
software components” on page 122|
for more information.

3. Install Storage Manager 8.4. See
fNew installation process” on page 55
for more information. Follow the
instructions to upgrade the controller
firmware in the IBM TotalStorage
FASIT EXP100 Installation and
User’s Guide.

Note: Upgrade the controller firmware
using the version supplied on the FASIT
Storage Manager 8.41 Support for FASTT
EXP100 SATA Storage Expansion Unit
CD before downloading controller
firmware from the Web.

Only after you have done so, access the
Web to download controller firmware
version 5.41.xx.xx.
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Table 4. Configurations for existing storage subsystems (continued)

Current environment

Planned environment

Action

(Machine type 3552)
Existing storage
subsystems with
controllers that have
firmware version levels
04.00.xx.xx through
05.3X.XX.XX

Firmware version level
05.3X.XX.XX

Storage Manager 8.4x.
Note: Firmware version
level 05.4x.xx.xx does
not support machine
type 3552.

1.

Uninstall previous Storage Manager
version. See [‘Uninstalling storage
management software components’|

on page 122|for more information.

Install Storage Manager 8.4. See
FNew installation process” on page 55
for more information.

Discover the storage subsystems.
See fPerforming an initial automatid
discovery of storage subsystems” on|
page 104|for more information. If the
current controller firmware version
number starts with “4.”, go to the
FAStT technical support Web site
listed on page to download
firmware level 04.01.02.30 or higher
and its matching NVSRAM.

Important: The storage subsystem
controllers must be at firmware level
04.01.02.30 or higher before you
download firmware level 05.3x.xX.xx
and NVSRAM to the controllers.

If the current controller firmware
version number starts with "4.”,
download firmware level 04.01.02.30
or higher and its associated
NVSRAM. See f‘DownIoadina
controller and NVSRAM ESM
firmware” on page 109|for more
information.

Download the latest firmware and
NVSRAM version 5.3x.xx.xx from the
IBM Web site. See |“Down|oadina
controller and NVSRAM ESM|
firmware” on page 109 for more
information.
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Table 4. Configurations for existing storage subsystems (continued)

Current environment

Planned environment

Action

(Machine type 3542)
Existing storage
subsystems with
controllers that have
firmware versions
04.00.02.xx through
05.3X.XX.XX

Firmware version
5.3X.XX. XX

Storage Manager 8.4x.
Note: Firmware version
05.4x.xx.xx does not
support machine type
3542.

1.

Uninstall the previous Storage
Manager software. See f‘UninstaIIingl
storage management software|
components” on page 122 for more
information.

Install Storage Manager 8.4. See
FNew installation process” on page|

5
Discover storage subsystems. See
fPerforming an initial automatid]
discovery of storage subsystems” o
age 104|for more information. If the
current controller firmware version
number starts with “4.” , go to the
FASLT technical support Web site
listed on page to download the
level 04.01.02.30 or higher firmware
and matching NVSRAM.

Important: The storage subsystem
controllers must be at firmware level
04.01.02.30 or higher before you
download firmware level 05.3x.xx.xx
and NVSRAM to the controllers.

Download firmware level 04.01.02.30
or higher and its associated
NVSRAM. See [‘Downloadin
controller and NVSRAM ESM
firmware” on page 109 for more
information.

Download firmware and NVSRAM

version 5.3x.xx.xx. See |“Down|oadin§]

controller and NVSRAM ESM|
firmware” on page 109 for more
information.
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Table 4. Configurations for existing storage subsystems (continued)

Current environment

Planned environment

Action

(Machine types 3526,
3552) Existing storage
subsystems with
controllers that have
firmware versions
04.00.xx.xx through
04.00.01.xx

Firmware version
04.01.xx.xx for machine
type 3526

Firmware version
05.3x.xx.xx for machine
type 3552

Storage Manager 8.4
Note: Firmware version
05.3x.xx.xx does not
support machine type
3526. Firmware version
05.4x.xx.xx does not
support machine type
3552.

1.

Uninstall Storage Manager Version
7.x. See [‘Uninstalling storage]
management software components’|

on page 122|for more information.

Install Storage Manager 8.4. See
FNew installation process” on page 55
for more information.

Discover the storage subsystems.
See fPerforming an initial automatid
discovery of storage subsystems” on|
page 104|for more information. If the
current controller firmware version
number starts with "4.”, go to the
FAStT technical support Web site
listed on page to download the
level 04.01.02.30 or higher firmware
and matching NVSRAM.

Important: The storage subsystem
controllers must be at firmware level
04.01.02.30 or higher before you
download firmware level 05.3x.xX.xx
and NVSRAM to the controllers.

If the current controller firmware
version number starts with "4.”,
download firmware level 04.01.02.30
or higher and its associated
NVSRAM. See f‘DownIoadina
controller and NVSRAM ESM
firmware” on page 109|for more
information.

(Machine types 3526,
3542, 3552) Existing
storage subsystems
with controllers that
have firmware versions
04.00.02.xx through
04.01.xx.xx

Existing firmware
versions

Storage Manager 8.4

Uninstall Storage Manager Version
7.x. See [‘Uninstalling storage]
management software components’|

on page 122|for more information.

Install Storage Manager 8.4. See
['New installation process” on page 55
for more information.

Discover the storage subsystems.
See [‘Performing an initial automatic|
discovery of storage subsystems” on|
page 104|for more information.

(Machine types 3526,
3552) Existing storage
subsystems with
controllers that have
firmware versions
04.00.xx.xx through
4.00.01.xx

Existing firmware
versions

Storage Manager 7.10

Set up a separate management station
with Storage Manager 7.10 installed to
manage the storage subsystems with
controllers that have back-level firmware.

Environments

Managing coexisting storage subsystems

Storage subsystems are coexisting storage subsystems when the following

conditions are met:
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* Multiple storage subsystems with controllers are running different versions of
firmware.

* These storage subsystems are attached to the same host.

For example, a coexisting situation exists when you have a new storage subsystem
with controllers running firmware version level 05.4x.xx.xx, and it is attached to the
same host as one or more of the following configurations:

» A storage subsystem with controllers running firmware version levels 04.00.xx.xx
through 04.00.01.xx, which is managed by a separate management station with
Storage Manager 7.10

* A storage subsystem with controllers running firmware version levels 04.00.02.xx
through 05.3x.xx.xx, which is managed with Storage Manager 8.4

Important: The common host must have the latest level (8.4) of RDAC and
SMagent installed. Upgrade all storage subsystems running firmware at or below
level 05.2x.xx.xx to the current code level. The latest 05.3x.xx.xx firmware is
available free of charge for download with all fixes and software patches from the
following IBM support Web site:

www-1.ibm.com/servers/storage/support/fastt/index.html|
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shows an example of a Windows environment that includes coexisting
storage subsystems.

Version 8.4 of the Important: In a

storage-management co-existing situation,

software must be installed on either the common host

a management station or host. must have Storage Manager
Version 8.4 RDAC and SMagent
installed.

/

Management station

Firmware version
4. x (minimum) Host-agent
’ Controller ‘
’ Controller ‘
Host computer
Firmware !
version 5.x 4— Fibre Channel
; 1/O path
’ Controller ‘ ffffff i P Ethernet ——»
Controller | f--—--- '1
’ ‘ Client software

Storage subsystems

Version 7.10 of the storage-management
software must be installed on a
management station.*

*Only to manage existing
storage subsystems with firmware
version 4.00.xx.xx to 4.00.01.xx. Management station $J001058

Figure 7. Sample coexisting storage subsystems

System requirements

This section provides detailed information about the hardware, software, and
operating system requirements for Storage Manager 8.4.
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Hardware requirements
lists the hardware required for installing Storage Manager 8.4.

Table 5. Hardware requirements for Storage Manager 8.4 software

Hardware
component Requirements Software tested

A DHCP/BOOTP | One of the following BOOTP or
server (only for | BOOTP-compatible servers:

directly managed |. Microsoft BOOTP-compatible
storage DHCP server for Windows NT

;ﬁ?sﬁe?;? Microsoft BOOTP-compatible
) DHCP server for Windows 2000

controllers static
IP addresses or |*® Microsoft BOOTP-compatible

default IP DHCP server for Windows Server
addresses are 2003
used, you do not [« UNIX BOOTP server

?heeed tosetup |, Netware DHCP server

DHCP/BOOTP
server.

Storage Storage subsystems with controllers
subsystems (one | running firmware version levels
or more) 04.00.02.xx through 05.4x.XX.XX

Fibre Channel The following fibre-channel host
(FC) host adapters were tested with the
adapters storage management software:

* IBM FAStT host adapter (part
number: OON6881)

* An IBM FAStT FC2 Host Bus
Adapter (part number 19K1246)
or IBM FASLT single port
FC2-133 Host Bus Adapter (part
number 24P0960)

For information about specific host
adapter requirements:

* Refer to the readme file in the
\Host_Adapter directory on the
installation CD.

* Read the host adapter
documentation.

* Go to the Web site at:
[www.ibm.com/pc/support]
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Table 5. Hardware requirements for Storage Manager 8.4 software (continued)

Hardware

component Requirements Software tested

Fibre-channel The following fibre-channel fabric
(FC) fabric switches were tested with the
switches (if storage management software:
needed for the « IBM 8-port fibre-channel switch
desired (machine type 2109 S08)
configuration)

* IBM 16-port fibre-channel switch
(machine type 2109 S16)

* IBM 16-port 2 Gbps fibre-channel
switch (machine type 2019 F16)

* IBM 8-port 2 Gbps fibre-channel
switch (machine type 3534 F08)

* IBM 32-port 2 Gbps fibre-channel
switch (machine type 2109 F32)

* INRANGE IN-VSN FC/9000 2
Gbps fibre-channel directors
(machine types 2042-01 and
2042-128)

* MCcDATA 4500 Sphereon 2 Gbps
16-, 24-, and 32-port
fibre-channel switch (machine
types 2031-216, 2031-224, and
2032-232)

* MCcDATA Intrepid 6140 2 Gbps
directors (machine type
2032-140)

+ CISCO MDS 9209 2 Gbps
multilayer director (machine types
2062-D07 and 2062-T07)

+ CISCO MDS 9216 2 Gbps
multilayer fabric switch (machine
type 2062-D01)

For specific fibre-channel switch
setup requirements:

* Read the switch documentation.
* Go to the Web site at:
[www.ibm.com/storage/fcswitch/|
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Table 5. Hardware requirements for Storage Manager 8.4 software (continued)

Hardware

component Requirements Software tested
Management Your management station computer

station (for client |requires:

software) * Intel Pentium® or

Pentium-equivalent
microprocessor (450 MHz or
faster)

» CD-ROM drive
* Mouse or similar pointing device
* System memory:

— For Windows NT 4.0: A
minimum of 64 MB (128 MB
recommended)

— For Windows 2000: A
minimum of 128 MB (256 MB
recommended)

— For Windows Server 2003,
NetWare, and Linux: A
minimum of 256 MB (512 MB
recommended)

* Ethernet network interface
adapter

* AGP or PCI video adapter (AGP
preferred); ISA adapters are not
supported

* Monitor setting of 1024 x 768
pixels with 64 000 colors. The
minimum display setting that is
allowed is 800 x 600 pixels with
256 colors.

* Hardware-based Windows
acceleration. Desktop computers
that use system memory for video
memory are not preferred for use
with the storage management
software.

Important: Many PC-based servers
are not designed to run
graphic-intensive software. If your
server has difficulty running the
storage management software
smoothly without video artifacts, you
might need to upgrade the server
video adapter.

Note: For more information about host adapters, fabric switches, and managed

hubs, go to the following ServerProven™ Web sites at:

www.ibm.com/pc/us/compat/|

www.ibm.com/storage/disk/fastt/supserver.htm|
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Firmware requirements

To use all of the features of Storage Manager 8.4, your storage subsystem must
contain controllers with firmware version 5.4x.xx.xx for machine types 1722 and
1742. To manage storage subsystems with Storage Manager 8.4, your storage
subsystems must contain controllers with firmware versions 04.00.02.xx or higher.

You cannot upgrade your firmware from versions 04.xx.xx.xx through 05.3x.xx.xx to
5.4x.xx.xx for machine types 3552 and 3542. For more information about this
subject, contact your IBM reseller or IBM marketing representative.

Storage Manager 8.4 also supports four premium feature options:
» Storage Partitioning

* FlashCopy

* VolumeCopy

* Remote Mirroring

Windows software requirements

lists the disk space and administrator privileges that are required to install
version 8.4 of the storage management software in a Windows environment.

Note: The disk space listed in Table 5 is for the packages after the installation.
During the installation of each software package, you might need up to 120
MB of free disk space.

Table 6. Installation requirements for Windows by software package

Disk space requirement Administrator privilege
Package (Windows NT / Windows 2000) |(Windows NT / Windows 2000)
SMclient 80 MB Not required / Not required
RDAC 2MB/2 MB Required
SMagent 1 MB /1 MB if SMclient is Required

installed.

40 MB / 40 MB if SMclient is not
installed.

SMutil 2MB/2 MB Required

Windows operating system requirements

Each management station, host computer, or cluster node requires one of the
following operating systems:

Management stations

* Windows NT 4.0 Server with Service Pack 6a

* Windows NT 4.0 Enterprise Edition with Service Pack 6a
* Windows NT 4.0 Workstation with Service Pack 6a

* Windows 2000 Server with Service Pack 4

* Windows 2000 Professional with Service Pack 4

* Windows 2000 Advanced Server with Service Pack 4

* Windows XP, Professional Edition

* Windows Server 2003, Web Edition
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* Windows Server 2003, Standard Edition
* Windows Server 2003, Enterprise Edition

Host computers

* Windows NT 4.0 Server with Service Pack 6a

* Windows NT 4.0 Enterprise Edition with Service Pack 6a
* Windows NT 4.0 Workstation with Service Pack 6a

* Windows 2000 Server with Service Pack 4

* Windows 2000 Professional with Service Pack 4

* Windows 2000 Advanced Server with Service Pack 4

* Windows Server 2003, Web Edition

* Windows Server 2003, Standard Edition

* Windows Server 2003, Enterprise Edition

Cluster nodes

* Windows NT 4.0 Enterprise Edition with Service Pack 6a
* Windows 2000 Advanced Server with Service Pack 4

* Windows 2000 Datacenter

* Windows Server 2003, Enterprise Edition

NetWare software requirements
lists the disk space that is required for installing the Storage Manager 8.4

software in a NetWare environment.

Table 7. Installation requirements for NetWare by software package

Package Disk space requirement
Storage Manager 8.4 Client (SMclient) 35 MB

Storage Manager 8.4 Agent (SMagent) 1 MB

Storage Manager 8.4 Utility (SMutil) 22 MB

LSIMPE.CDM driver 1 MB

IBM FAStT Management Suite Java (FAStT MSJ) |1 MB

IBM HA device driver 1 MB

Java Virtual Machine 37 MB

NetWare operating system requirements

Each management station, host computer, or cluster node requires one of the
following operating systems:

Management stations

* Windows NT 4.0 Server with Service Pack 6a

* Windows NT 4.0 Enterprise Edition with Service Pack 6a
* Windows NT 4.0 Workstation with Service Pack 6a

* Windows 2000 Server with Service Pack 4

* Windows 2000 Professional with Service Pack 4

* Windows 2000 Advanced Server with Service Pack 4
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* Red Hat Enterprise Linux AS 2.1
* United Linux 1.0
— SuSE Linux Enterprise Server 8 (SLES 8)
— Turbolinux Enterprise Server 8 (TLES 8) -
— Conectiva Linux Enterprise Edition Powered by United Linux

Host computers
* Novell NetWare 6.0 with Service Pack 3

Cluster nodes
* Novell NetWare 6.0 with Service Pack 3

Linux software requirements

lists the disk space that is required for installing Storage Manager 8.4 in a
Linux environment.

Table 8. Installation requirements for Linux by software package

Package Disk space requirement
Storage Manager 8.4 Client (SMclient) 15 MB on /opt, 2 MB on /tmp
IBM FAStT Management Suite Java (FAStT MSJ) 35 MB

Storage Manager 8.4 Utility (SMutil) 7 MB on /opt

IBM Host Adapter device driver 1 MB

Storage Manager 8.4 run time (SMruntime) 42 MB on /opt, 1 MB on /var

Linux operating system requirements

lists the minimum operating system and kernel levels required by each
management station or host computer.

Table 9. Management station or host computer by minimum operating system and kernel
levels

Operating system Kernel

Red Hat Advanced Server 2.1 2.4.9-e.27 or higher
SuSE Linux Enterprise Server Version 8 (SLES 8) 2.4.21 or higher
Notes:

1. Red Hat Enterprise Linux Advanced Server 2.1 supports a maximum of 128
logical drives per storage partition.

2. SuSE Linux Enterprise Server 8 supports a maximum of 256 logical drives with
32 LUNSs per storage partition.

Number of supported logical drives

With controller firmware 05.40.xx.xx and higher, the supported logical drive limits for
NetWare 6.0, Linux, Windows NT 4.0, Windows 2000, and Windows Server 2003
are as follows:

* NetWare 6.0 with SP3 or higher supports up to 256 logical drives per storage

subsystem (LUNs 0-255) when you use IBM-approved FASIT adapters and their
supported device drivers.

28 1BM TotalStorage FAStT Storage Manager Version 8.4x Installation and Support Guide for Intel-based Operating System

Environments



Linux supports up to 256 logical drives per storage subsystem (LUNs 0 through
255) when you use IBM-approved FASIT adapters and their supported device
drivers.

Check your Linux kernel documentation for the maximum total number of logical
drives supported in the host sever and the maximum number of logical drives
that can be mapped from a storage subsystem.

Windows NT 4.0 with Service Pack 6a supports up to 32 logical drives per
storage subsystem (LUNs 0 through 31) when you use IBM-approved FAStT
adapters and their supported device drivers.

Windows 2000 supports up to 64 logical drives per storage subsystem (LUNs 0
through 63) when you use IBM-approved FASIT adapters and their supported
device drivers.

Windows Server 2003 supports a maximum of 255 LUNs (LUNs 0 through 254)
when you use IBM-approved FAStT adapters and their supported device drivers.

The maximum number of logical drives that a FASIT storage subsystem supports
with firmware version 05.4x.xx.xx depends on the model of the FAStT storage
subsystem. See [Table 10

Table 10. Maximum number of logical drives per storage server

Model Maximum logical Maximum logical drives | Maximum FlashCopy
Type drives per storage unit partition | logical drives

1742 2048 (See notes@ and |256 (See notesElandEb 1024 (See note@)
1722 1024 (See notes and |256 (See notesElandEb 512 (See note@)

The access logical drive is also referred to as the Universal Xport Device.

Notes:

1.

When you use firmware version 5.xx.xx.xx, the firmware reserves one logical
drive for use by the system.

Maximum of four FlashCopy logical drives for each standard logical drive.
Maximum of 32 remote mirror pairs.

The host-agent management method uses a special logical drive, called an
access logical drive, to communicate with the controllers on the storage
subsystem. The access logical drive uses one of the available LUNs. Therefore,
managing storage subsystems with the host-agent software limits you to one
fewer LUN than the maximum number supported by the operating system and
the host adapter.

For firmware version levels 05.2x.xx.xx and higher, the maximum number of
logical drives includes the FlashCopy repository logical drives and the remote
mirror logical drives in addition to the standard data logical drives. If the Remote
Mirror option is enabled, two logical drives are reserved for use by the system.

For firmware version level 05.4x.xx.xx, the default host type limit is the
maximum LUN value allowed in the default partition. If the default host type has
the restriction option enabled, the default partition allows only 32 LUNSs;
otherwise, it allows 256 LUNSs.

Important:

The FlashCopy drive can not be added or mapped to the same server that has
the base logical drive of the FlashCopy logical drive in a Windows 2000,
Windows Server 2003, or NetWare environment. You must map the FlashCopy
logical drive to another server.
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» For firmware version 05.3x.xx.xx and earlier, the maximum number of logical
drives that can be mapped to a host server from each storage subsystem is 32.
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Chapter 2. Preparing for installation

This chapter provides information to help you plan the installation of the storage
management software.

The installation procedure for Storage Manager 8.41 components is identical to the
Storage Manager 8.4 installation procedure. See the appropriate sections of this
document to install either Storage Manager 8.4 or 8.41 host software for a particular
operating system. When you have completed Storage Manager 8.4 or 8.41 software
component installation procedures, perform the procedures in |Chapter 8,|
‘Completing Storage Manager 8.4 installation,” on page 103|and[Chapter 9, “Using|
the storage management software for Windows and NetWare,” on page 115

See the FASIT Storage Manager 8.41 Support for FAStT EXP100 SATA Storage
Expansion Unit CD for additional information as well as firmware associated with
FAStT EXP100 Storage Expansion Unit.

Planning and preparing for Windows installation

able 11|contains information about where you need to install the Storage Manager
software components.

Table 11. Software component installation in a Windows environment

System type Software installation sequence

Management station | SMclient

Host computer and 1. SMclient

cluster node .
* Optional component

» Necessary if you intend to manage the storage subsystem from
the host computer.

« See[‘Storage Manager 8.4 Client” on page 56.
2. RDAC
* Required component

* On Windows NT 4.0, you must assign static drive letters to
existing local drives before you install RDAC. This process
requires a minimum of two disk partitions (the BOOT partition
and one other partition).

+ See[‘RDAC” on page 58
3. SMagent
* Optional component

* Necessary if you intend to use the host-agent management
method.

+ See|[‘Storage Manager 8.4 Agent” on page 61|
4. SMutil
» Required component
» Contains the hot_add, SMdevices, and SMrepassist utilities
+ See [‘Storage Manager 8.4 Utility” on page 63.|
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Planning and preparing for NetWare installation

shows the installation sequence for Storage Manager software
components and provides information to help you plan for the installation of the
storage management software.

Table 12. Software component installation sequence in a Novell NetWare 6.0 environment

System type

Software installation sequence

Management station

Storage Manager 8.4 Client (SMclient).

Host computer and
cluster node

1.

Storage Manager 8.4 Client (SMclient)

This optional component is necessary if you intend to manage the
storage subsystem from a host computer.

See [‘Storage Manager 8.4 Client” on page 90.|
Storage Manager 8.4 Agent (SMagent)

This optional component is necessary if you intend to use the
host-agent management method.

See [‘Storage Manager 8.4 Agent” on page 91.|
Storage Manager 8.4 Utility (SMutil)

This required component contains the hot_add, SMdevices, and
SMrepassist utilities.

See [‘Storage Manager 8.4 Utility” on page 91
LSIMPE.CDM driver

See [‘Installing the LSIMPE driver” on page 92.|
IBM Host Adapter device driver (QL2x00)

See ['Installing the IBM fibre-channel host bus adapter device|
|driver” on page 93|

Planning and preparing for Linux installation

shows the installation sequence for Storage Manager software
components and provides information to help you plan for the installation of the
storage management software for Linux.

Table 13. Software component installation sequence in a Linux environment

System type

Software installation sequence

Management station

Storage Manager 8.4 Client (SMclient)

See[Installing the Storage Manager 8.4 Client (SMclient)” on page 97
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Table 13. Software component installation sequence in a Linux environment (continued)

System type Software installation sequence

Host computer and | 1.

cluster node

Storage Manager 8.4 Client (SMclient)

This optional component is necessary if you intend to manage the
storage subsystem from a host computer.

See ﬁnstalling the Storage Manager 8.4 Client (SMclient)” on pagﬂ

Storage Manager 8.4 Runtime (SMruntime)

This required component contains the software Java Runtime for
the SMclient and SMutil packages.

See [‘Installing Storage Manager 8.4 Runtime (SMruntime)” on|

|page 97|

Storage Manager 8.4 Utility (SMutil)

This required component contains the hot_add, SMdevices, and
SMrepassist utilities.

See [‘Installing the Storage Manager 8.4 Utility (SMutil)” on page|

IBM FAStT Management Suite Java (FAStT MSJ)

This required component configures the path information for the
Linux Host Adapter failover device drivers.

See [Installing IBM FASIT Management Suite Java” on page 99

IBM Host Adapter failover device drivers (QLA2200.0 and
QLA2300.0)

These required components enable your computer to communicate
with the host adapter and to provide logical drive failover/failback
support.

See [Installing the IBM fibre-channel host bus adapter device]
[driver” on page 99|

Preparing a network installation

To begin installing the storage management software, ensure that the network
components are set up and operating properly, and that you have all the host and
controller information needed for the software to operate correctly.

The following steps provide an overview of the tasks involved in setting up a

network installation:

1. Install all hardware components (host computers, storage subsystems, and
cables) that you want to connect to the network. You might need to refer to the
installation guides specific to the hardware components.

2. Establish a naming convention for the storage subsystems connected to the

network. See[‘Step 1: Naming the storage subsystems” on page 34| for more

information.

3. Record the storage subsystem names and management types in|Appendix E,|

[‘Storage subsystem and controller information record,” on page 139./An

example of a completed information record is shown in[Table 14 on page 35|

Note: Throughout the remaining steps, you will need to return to|Appendix E,|

[‘Storage subsystem and controller information record,” on page 139 to

record information such as hardware Ethernet addresses and IP

addresses.
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4. (For a directly-managed system only) Determine the hardware Ethernet address
for each controller in storage subsystems connected to the network. See |“Step
3: ldentifying the hardware Ethernet MAC address for each controller” on page;
35| for more information.

5. (For a directly-managed system only) If you are using a default controller IP
address, go to step[7] Otherwise, obtain the TCP/IP address and host name for
each of the controllers in the storage subsystems on the network from the
network administrator. See r‘Step 4: Assigning IP addresses to hosts and|
[controllers” on page 37|

(For a host-managed system only) Obtain the IP address and host name of the
host computer on which the host-agent software will run from the network
administrator. See r‘Step 4: Assigning IP addresses to hosts and controllers” on|
page 37.

6. (For a directly-managed system only) Set up the DHCP/BOOTP server to
provide network configuration information for a specific controller. If you are
using a controller static IP addresses, skip this step.

7. Verify that the TCP/IP software is installed. For more information, see |“Step 6|

(Windows): Verifying the TCP/IP protocol and setting up the host or DNS table’]

on page 50.|

8. (For a directly-managed system only) Set up the host or domain name server
(DNS) table. For more information, see[‘Step 6 (Windows): Verifying the TCP/IP)|
[protocol and setting up the host or DNS table” on page 50/

9. Power on the devices that are connected to the network.

Step 1: Naming the storage subsystems

As you set up your network, decide on a naming convention for the storage
subsystems. When you install the storage management software and start it for the
first time, all storage subsystems in the management domain display as <unnamed>.
Use the Subsystem Management window to rename the individual storage
subsystems.

Consider the following factors when you name storage subsystems:

* There is a 30-character limit. All leading and trailing spaces are deleted from the
name.

» Use a unique, meaningful naming scheme that is easy to understand and
remember.

* Avoid arbitrary names or names that might quickly lose their meaning.

* The software displays storage-subsystem names with the prefix Storage
Subsystem. Therefore, if you rename a storage subsystem to Engineering, it is
displayed as:

Storage Subsystem Engineering

Step 2: Recording the subsystem names

After you decide on a naming scheme, record the storage subsystem names in the
blank information record form provided in|Appendix E, “Storage subsystem and|
icontroller information record,” on page 139).

Table 14 on page 35|shows a sample information record for the network shown in
Figure 4 on page 12| This network contains storage subsystems that are managed
by using both the direct-management and host-agent-management method.
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Table 14. Sample information record

Storage Management |Controllers-Ethernet and IP Host-IP address
subsystem name | method addresses, and host name and host name
Controller A Controller B
Finance Direct Hardware Hardware
Ethernet address | Ethernet address
= 00a0b8020420 |= 00a0b80000d8
IP address = IP address =
192.168.128.101 |192.168.128.102
Host = Denver_a | Host = Denver_b
Engineering Host-agent IP address =
192.168.2.22

Host = Atlanta

If you plan to manage your storage subsystem using the direct-management

method, go to [‘Step 3: Identifying the hardware Ethernet MAC address for each|

controller.”| If you plan to manage your storage subsystem using the host-agent
management method, go to [‘Step 4: Assigning IP addresses to hosts and|

icontrollers” on page 37/

Step 3: Identifying the hardware Ethernet MAC address for each

controller

To manage your storage subsystem using the direct-management method, you
need to identify the hardware Ethernet medium access control (MAC) address for

each controller.

To identify the hardware Ethernet MAC address for machine types 3542 and 1722,
perform the following steps:

1. Locate the Ethernet MAC address at the back of the unit, under the controller
fibre-channel host ports, as shown in |Figure 8 on page 36l The number will be
in the form xx.xx.xx.xx.xx.xx (for example, 00.a0.b8.20.00.d8).

2. Record each Ethernet address in the information record (Appendix E, “Storage]

[subsystem and controller information record,” on page 139).
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Hardware Ethernet
address label $J000866

Figure 8. Locating the Ethernet MAC address (machine types 3542 and 1722)

To identify the hardware Ethernet MAC address for machine types 3552 and 1742,
perform the following steps:

1. Remove the front bezel from the storage subsystem, as shown in|Figure 9
Carefully pull the bottom of the bezel out [ to release the pins. Then slide the
bezel down H .

$J000865

Figure 9. Removing the controller-unit bezel (machine types 3552 and 1742)

2. On the front of each controller, look for a label with the hardware Ethernet MAC
address. The number will be in the form xx.xx.xx.xx.xx.xx (for example,
00.20.b8.20.00.d8).

3. Record each Ethernet address in the information record dAppendix E, “Storagel
[subsystem and controller information record,” on page 139).

36 IBM TotalStorage FASIT Storage Manager Version 8.4x Installation and Support Guide for Intel-based Operating System
Environments



4. To replace the bezel, slide the top edge under the lip on the chassis . Then
push the bezel bottom until the pins snap into the mounting holes H, as shown

in|Figure 10,

NNNNNN
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NNNNNNANN
NNSENNAE

$J000867

Figure 10. Replacing the controller-unit bezel (machine types 3552 and 1742)

5. Continue with f‘Step 4: Assigning IP addresses to hosts and controllers.’1

Step 4: Assigning IP addresses to hosts and controllers

If you plan to manage your storage subsystem using the direct-management

method, assign a unique IP address for every controller in all storage subsystems
on the network. Record the IP address for each controller in the information record
(Appendix E, “Storage subsystem and controller information record,” on page 139).
Then, go to|“Step 5: Setting up the DHCP or BOOTP-compatible server” on page|

Note: If you want to assign static IP addresses for the controllers, refer to Retain
Tip #H171389 Unable to setup networking without DHCP/BOOTP at the IBM
support Web site at:

www.ibm.com/support|

Then go to [‘Step 6 (Windows): Verifying the TCP/IP protocol and setting up|
the host or DNS table” on page 50.|

If you plan to manage your storage subsystem using the host-agent management
method, assign an IP address for each host on which you will install the host-agent
software. Record the IP address for each host in the information record

(Appendix E, “Storage subsystem and controller information record,” on page 139).
Then, go to[“Step 6 (Windows): Verifying the TCP/IP protocol and setting up the]
lhost or DNS table” on page 50|
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Step 5: Setting up the DHCP or BOOTP-compatible server

To directly manage storage subsystems through the Ethernet connection to each
controller, you will need to set up a DHCP or BOOTP-compatible server and
configure the following options:

* Router/Gateway
* DNS Server

* Hostname
 DNS

This section provides instructions to set up a DHCP server on Windows NT 4.0,
Windows 2000, Windows Server 2003, and Novell NetWare, as well as instructions
to set up a UNIX BOOT server.

Note: The remote management station (RMS) and network management station
(NMS) entries used in previous versions of the storage management
software are not required for Storage Manager 8.4.

Setting up a Windows NT 4.0 DHCP server

You must use a version of DHCP that supports BOOTP static addressing. To use a
DHCP server, you must have a DHCP Manager installed. If a DHCP Manager is
installed on the system, go to [‘Setting up a DHCP server.] If a DHCP Manager is
not installed, use the following installation procedure to install one.

Installing the DHCP Manager
Perform the following steps to install the DHCP Manager:

1. Click Start » Settings » Control Panel. A Control Panel window opens.
Double-click Network. The Network window opens.

Click Services.

From the Services tab, click Add.

Click Microsoft DHCP Server. Click OK.

Specify the path to the Windows NT Install file. Click Continue. A dialogue
window opens stating that a static IP address is required.

7. Click OK. The Network window opens.

8. Click Protocols.

9. Click TCP/IP Protocol. Click Properties.
10. Verify that the IP address information is correct. Then click OK.
11. Proceed to[‘Setting up a DHCP server.’]

SICRE NN

Note: After you install the DHCP Manager, you can refer to its online help for
additional information.

Setting up a DHCP server

Perform the following steps and use the information you recorded in|Appendix E,

|“Storage subsystem and controller information record,” on page 139,to set up a

DHCP server:

1. Click Start » Programs » Administrative Tools + DHCP Manager. The DHCP
Manager window opens.

2. Create a scope. A scope defines a group of TCP/IP addresses that you want the
DHCP server to use to assign to the controllers.

a. Click Local Machine.
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b. Click Scope » Create. The Create Scope - (Local) window opens as shown

in [Figure 11

Create Scope - (Local)

— IP Address Pool

Start Address:
End Address:

Subnet Mask |255.255.248.0
Exclusion Range:

Add -
StartAddress: [ . . . | dd >
End Address: |:| <- Remove

Excluded Addresses:

— Lease Duration

O Limited To: Day(s) HDU[(S) Minute(s)

Name:

Comment: |

OK Cancel

Help

Figure 11. Create Scope - (Local) window

c. Type the starting and ending IP addresses of the controllers that you are

configuring for the network.

For example, if you are configuring 50 controllers on a 153.79.144.0 subnet,
set the starting address to 153.79.144.1 and the ending address to
153.79.144.50.

SJ000859

Note: If each field does not contain at least three characters, press the
period (.) key to advance to the next field. If you have only one
controller, type its address for both the starting and ending address.

Type the subnet mask (obtained from your network administrator).

Set the Lease Duration to Unlimited. This makes the DHCP connection

permanent.

—

> @

Type a scope name and comment.
Click OK.
When the scope successfully completes, click Yes to activate it. This returns

you to the DHCP Manager window.

3. Configure global scope options. shows the global options that you
need to set.

Table 15. Global options for a Windows NT 4.0 DHCP server

Number |Description Notes

003 Router/Gateway

006 DNS Server

012 Host name Unique for each controller
015 DNS domain name For example, ibm.com
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Table 15. Global options for a Windows NT 4.0 DHCP server (continued)

Number

Description

Notes

165

Network Management Station

Defines where the controller should send

SNMP alerts

You can apply options to specific controllers later by using step |5 on page 41

a. Click DHCP Options » Global. The DHCP Options: Global window opens,
as shown in

DHCP Options: Global

Options for: Server 127.0.0.1 OK

Unused Options: Active options:

Cancel

003 Router

M 164 Remote Management S

165 Network Management §

; <- Remove
CC8 Cookie Servers v v

CC2 Time Offset A
CC4 Time Server
CC5 Name Servers
CC6 DNS Servers
CC7 Log Servers

Value > > >

Help

el

Comment: Array of router addresses ordered by preference

$J000860

Figure 12. DHCP Options: Global window

b. To make a global option active, select an item in the Unused Options list.
Click Add to move it to the Active options list.

Click Value to assign a value to the active option.

If the Value field is not available, click Edit Array. The Edit Array Editor
window opens. Perform one of the following actions:

* If you need to add an IP address, complete the following procedure:

1) Click Edit Array. The IP Address Array Editor window opens, as
shown in

o

IP Address Array Editor
— General Information
Application: DHCP Options: Global OK
Option: Remote Management Station Cancel
— Data Entry Help
1P Addresses:

New IP Address:

153.79.144.6 Add > 153.79.144.6

<- Remove ﬂ
Resolve - ﬂ

Server Name:

SJ000861
Figure 13. IP Address Array Editor window
2) Type a unique IP address for the option that you added.

3) Click Add to move the New IP Address to the IP Addresses list.
4) Click OK. This returns you to the DHCP Options: Global window.
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* If you do not need to add an IP address, click Cancel. This returns you to
the DHCP Options: Global window.

Repeat steps @through 3c on page 40| until all global options are added.
When you finish adding the Global Scope Options, click OK at the DHCP
Options: Global window.

4. Create a reservation for each controller. Use the information record

(Appendix E, “Storage subsystem and controller information record,” on page|

|139D to make sure that you include all of the controllers on the network.

a.
b.

f.

g.

Click Scope » Add Reservations.

In the IP Address field, type the IP address for the first controller on your
data sheet.

In the Unique Identifier field, type the controller hardware Ethernet address.
Do not type decimal points or spaces.

In the Client Name field, type the controller eight-character name.
Click Add.

e.
Repeat steps |4_1b on page 41| through |4_1e on page 41| for each controller that

is listed on the information record (Appendix E, “Storage subsystem and|
[controller information record,” on page 139).

When you finish adding the information for all of the controllers, click Close
to return to the DHCP Manager window.

5. Configure controller-specific options. By creating a controller-specific option, you
can associate a controller configuration entry with a specific controller.

Note: When you set an option to Global Scope, it will apply to every controller

in the group. You will not need to add it again.

a. Click Scope » Active Leases. The Active Leases window opens, as shown
in

Active Leases - [153.79.144.0]

Total Addresses in Scope: 50 OK

Active/Excluded: 6 (12%)

Cancel

Available: 44 (88%) e

Client

159.79.144.13 denver_a Reservation

159.79.144.14 denver_b Reservation
Properties Delete Reconcile Refresh
— Sort Order
Sort leases by IP Addresses
O‘ ,,,,,,,,,,,,,,,,,, y ,,,,,,,, [ ] Show Reservations Only
® Sort leases by Name:

$J000862

Figure 14. Active Leases window
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b. Select a controller in the list.

c. Click Properties. The Add Option Type window opens, as shown in
Figure 15. The Unique Identifier is the hardware Ethernet address from step

4c
Add Option Type
IP Address: 153.79.144.13 |

Unique Identifier: | 00a0b8020420 |

Client Name: ‘ denver_a ‘

Client Comment: ‘ ‘

Lease Expires: N/A

oK | Cancel Help Options .. . |

$J000863

Figure 15. Add Option Type window

d. Click Options. The DHCP Options: Reservations window opens.

e. Select an option from the Unused Options list and click Add to move it to
the Active options list.

f. Click Value to assign a value to the active option.

g. Type the information for the value of the option. For example, type the host
name for the controller from your information record {Appendix E, “Storagel
lsubsystem and controller information record,” on page 139) in the String
field. Click Edit if the value that you need to add is an IP address for a

router.
h. Repeat steps @through until you finish adding specific options for this
controller.

i. Click OK. This returns you to the Add Option Type window.
j- Click OK. This returns you to the Active Leases window.

k. Repeat stepsthrough El until you finish adding controller-specific options
for every controller.

[. Click OK on the Active Leases window. This returns you to the DHCP
Manager window.

6. Continue with [‘Step 6 (Windows): Verifying the TCP/IP protocol and setting up|
[the host or DNS table” on page 50|

Setting up a Windows 2000 DHCP server

You must use a version of DHCP that supports BOOTP static addressing. To use a
DHCP server, you must have a DHCP Manager installed. If a DHCP Manager is
installed on the system, go to [‘Creating a scope and setting up a DHCP server” on|

Installing the DHCP Manager
To install the DHCP Manager, perform the following steps:

1. Click Start » Administrative Tools » Configure Your Server. The Configure
Your Server window opens.
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2. In the left pane, double-click Networking. Click DHCP.
3. In the right pane, click Start. The Windows Components Wizard starts.

4. In the Components field, select Networking Services. Then click Details.
The Networking Services window opens.

Note: Do not select the check box; you do not want to install all of the
Networking Services subcomponents.

5. In the Subcomponents of Networking Services field, select Dynamic Host
Configuration Protocol (DHCP).

6. Click OK. The Windows Components Wizard window opens.
7. Click Next to start the installation process.

8. If prompted, type the full path to the Windows 2000 distribution files and click
Continue.

9. When the installation has successfully completed, the Windows Components
Wizard window closes and the Configure Your Server Window opens.

10. Click Next.
11. Click Open the DHCP Manager. The DHCP window opens.
12. Continue with stepof [‘Creating a scope and setting up a DHCP server.]

Note: After you install the DHCP Manager, you can refer to the DHCP Manager
online help for additional information.

Creating a scope and setting up a DHCP server
Use the following procedure to create a scope and to set up a DHCP server. A
scope defines a group of controllers by their IP addresses. You must create and
configure a scope so that dynamic IP addresses can be assigned to controllers on
your network. Refer to the information record {Appendix E, “Storage subsystem and|
icontroller information record,” on page 139). Before you begin, read through the
instructions to determine what information is required. Then request the information
from your network administrator.

1. Click Start » Programs » Administrative Tools » DHCP. The DHCP window

opens.

2. In the Console tree, right-click the server you want to configure; click New
Scope. The New Scope Wizard starts, as shown in [Figure 16 on page 44,
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MNew Scope Wizard x|

IP Addrezs Range —r
“'ou define the scope address range by identifying a set of consecutive 1P

addreszes.

Enter the range of addrezzes that the zcope diztibutes.

Start IP address: |192.1EE. 1.1

End IP address: |192 1B 1 . D

A zubnet mazk defines how many bitz of an IP address to use far the network /subnet
|02 and how mary bitz bo uge for the host [D. You can zpecify the subnet mazk by
length or as an [P address.

Lenigth: 24 _:I

Subnet mask: | 255,255 255 0

< Back I Mest » I Cancel

$J000868

Figure 16. New Scope Wizard: IP Address Range window

3. Follow the on-screen instructions to define the scope of IP addresses for
TCP/IP clients. You will define the following fields:

a. Scope name and description

b. IP address range for the subnet mask, and the controllers you are
configuring

c. |IP addresses that you want to exclude from the IP address range
IP address lease duration
Common DHCP options:
* |P address for a router
* Domain name and DNS servers

4. When you have defined the scope, click Yes, | want to activate this scope
now. The wizard ends, and the DHCP window opens.

5. In the Console tree, open the scope folder.

6. Right-click Reservations. Then select New Reservations. The New
Reservations window opens.

7. To define the IP address reservation, type the following information:
a. Reservation name
b. IP address
c. Ethernet hardware MAC address
d. Description

8. In the Supported Type field, select Both (DHCP and BOOTP).

9. Click Add.

10. Repeat stepsthrough|§|for each controller in the network.
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11. Restart the DHCP server and then restart the storage subsystem so that all
modifications are applied.

12. Proceed to [‘Step 6 (Windows): Verifying the TCP/IP protocol and setting up the|
[host or DNS table” on page 50.|

Setting up a Windows Server 2003 DHCP server

You must use a version of DHCP that supports BOOTP static addressing. To use a
DHCP server, you must have a DHCP Manager installed. If a DHCP Manager is

already installed on the system, see |“Creating a scope and setting up a DHCP|
i

Installing the DHCP Manager
To install the DHCP Manager, perform the following steps:

1. Click Start » Control Panel »+ Add or Remove Programs. The Add or Remove
Programs window opens.

2. In the left pane, click Add/Remove Windows Components. The Windows
Components Wizard window opens.

3. In the Components field, select Networking Services. Then click Details. The
Networking Services window opens.

Note: Do not select the check box; you do not want to install all of the
Networking Services subcomponents.

4. In the Subcomponents of Networking Services field, select Dynamic Host
Configuration Protocol (DHCP). Click OK. The Networking Services window
closes.

5. In the Windows Components Wizard window, click Next to start the installation
process.

6. If prompted, type the full path to the Windows Server 2003 distribution files and
click Continue.

7. When the installation has successfully completed, the Windows Components
Wizard window opens. Click Finish to close the Windows Components Wizard
window.

8. Close the Add or Remove Programs window. You are now ready to perform the
tasks in [‘Creating a scope and setting up a DHCP server.’]

After you install the DHCP Manager, you can refer to the DHCP Manager online
help for additional information.

Creating a scope and setting up a DHCP server

Perform the following steps to create a scope and to set up a DHCP server. A
scope defines a group of controllers by their IP addresses. You must create and
configure a scope so that dynamic IP addresses can be assigned to controllers on
your network. See [Appendix E, “Storage subsystem and controller information|
|record,” on page 139.|Before you begin, read through the instructions to determine
what information is required. Then request the information from your network
administrator.

1. Click Start » Administrative Tools * DHCP. The DHCP window opens.

2. In the Console tree, right-click the server you want to configure, then click New
Scope. The New Scope Wizard starts.

3. Follow the on-screen instructions to define the scope of IP addresses for
TCP/IP clients. You will define the following fields:

* Scope name and description
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9.
10.
11.
12.

13.

» |P address range for the subnet mask, and the controllers that you are
configuring

» |P addresses that you want to exclude from the IP address range
* |P address lease duration
+ Common DHCP options:

— IP address for a router

— Domain name and DNS servers or Windows Internet Naming Service
(WINS) servers

When you have defined the scope, click Yes, | want to activate this scope
now. The New Scope Wizard window opens.

Click Finish. The New Scope Wizard window closes and the DHCP window
opens.

In the Console tree, expand the Scope folder.

Right-click Reservations. Then select New Reservations. The New
Reservations window opens.

To define the IP address reservation, type the following information:
* Reservation name

* |P address

» Ethernet hardware MAC address

» Description

In the Supported Type field, select Both (DHCP and BOOTP).
Click Add.

Repeat steps E through for each controller in the network.

Restart the DHCP server and then restart the storage subsystem so that all
the modifications are applied.

Proceed to [‘Step 6 (Windows): Verifying the TCP/IP protocol and setting up thel
[host or DNS table” on page 50.|

Setting up a Novell NetWare DHCP server

A Novell NetWare DHCP server automatically assigns IP addresses and other
configuration information to clients upon request or when the clients are restarted.

Perform the following steps to set up a Novell NetWare DHCP server:

No ok~ owDd =

Install DNS/DHCP Services, either during or after installing NetWare 6.
Install the DNS/DHCP Management Console.

Create the DHCP server object.

Create the DHCP subnet address.

Create the subnet address range.

Create the IP address object.

Start the DHCP server.

Each of these tasks is described in detail in the sections that follow.

Adding Novell DNS/DHCP Services during the NetWare 6.0
installation

Perform the following steps to add Novell DNS/DHCP Services during the NetWare
installation:

1.

From the Installation Options window, select Custom.
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2. From the Components window, select the Novell DNS/DHCP Services check
box.

3. Follow the on-screen instructions to complete the NetWare installation.

Adding Novell DNS/DHCP Services after the NetWare 6.0
installation

Perform the following steps to add Novell DNS/DHCP Services after the NetWare
installation:

1. Insert the NetWare 6.0 Installation CD into the CD-ROM drive. Then mount the
CD as a volume.

2. Load NWCONFIG and select Product Options.
3. Select Install a Product not Listed.

4. Press F3 and specify the volume name of the CD. The X Server-Graphical
Console window opens.

5. In the Additional Products and Services dialog box, select the Novell
DNS/DHCP Services check box.

6. Follow the on-screen instructions to complete installation.

Note: Installing the DNS/DHCP Service will extend the Novell Directory Services
(NDS) schema and create the following NDS objects:

*« DNSDHCP-GROUP Group object
* DNS/DHCP Locator object
* RootServerinfo Zone object

Installing the DNS/DHCP Management Console

Perform the following steps to install the DNS/DHCP Management Console and
NetWare Administrator snap-in files on the client workstation you will use to
administer DNS and DHCP:

1. If you have not done so, install the latest version of Novell Client 32 on your
workstation.

From the workstation, run the SYS:PUBLIC\DNSDHCP\SETUP.EXE program.

Install the DNS/DHCP Management Console on the local hard-disk drive.

Install the NetWare Administrator snap-in files in the SYS:PUBLIC\WIN32 directory.
Restart the workstation.

To start the DNS/DHCP Management Console, double-click the shortcut icon on
the desktop, type the NDS tree name, and click Launch.

IS S o < A

Note: You can install the DNS/DHCP Management Console on a workstation, or
you can access it from the Tools menu of the NetWare Administrator utility.

Creating the DHCP server object
Use the DHCP Management Console to create a DHCP server object. You can
create a DHCP server object under any of the following objects:

* Organization (O)

* Organization Unit (OU)
* Country (C)

* Locality (L)

Perform the following steps to create a DHCP server object:
1. From the DHCP Management Console, click the DHCP Service tab.
2. In the left pane, select Our Network.

Chapter 2. Preparing for installation 47



3. Click Create. The Create New DHCP Object window opens.
4. Select DHCP Server. Click OK. The Create DHCP Server window opens.

5. Select a server. Click Create. This creates the DHCP server object, called
DHCP_servername, in NDS.

6. In the DHCP Management Console, locate the icon for the DHCP server object
at the bottom of the DHCP Service tab. The server object displays with a red
line through it, indicating that the DHCP server has not been started.

7. Continue with [Creating the DHCP subnet object.]

Creating the DHCP subnet object
Perform the following steps to create a DHCP subnet object for each of the subnets
for which you want to assign addresses:

1. In the DNS/DHCP Management Console, click the DHCP Service tab.
Select Our Network or the DHCP Server Object.

Click Create. The Create New DHCP Object window opens.

Select Subnet. Then click OK. The Create Subnet window opens.

For each subnet, type the following information:

* Subnet name

* NDS context

* Subnet address

* Subnet mask

» Default DHCP Server

6. Click Create. The DHCP subnet object is created and displayed in the
DNS/DHCP Management Console.

Al A

Creating the subnet address range
Perform the following steps to create a subnet address range object:

1. From the DNS/DHCP Management Console, click the DHCP Service tab.

2. Select the subnet object under which you want to create the subnet address
range object. Then click Create. The Create New DHCP Record window opens.

3. Select Subnet Address Range. Then click OK. The Create New Subnet
Address Range window opens.

4. Type the following information for the subnet address range:
* Subnet address range name
e Starting address
* Ending address

5. Click Create.

6. Select the Define Additional Properties check box. Then set the Range Type
to Dynamic BOOTP and DHCP.

Creating the IP address object
Use the DNS/DHCP Management Console to create IP address objects. You use IP
address objects for the following purposes:

* To exclude an IP address from assignment
» To assign an IP address manually to a specific host
* To record dynamic IP address leases

Perform the following steps to create an IP address object:
1. From the DNS/DHCP Management Console, click the DHCP Service tab.
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controller.

8. Select the Define Additional Properties check box.
9. In the Hostname field, type the eight-character name for the controller.

10.
11.

In the Usage field, select Permanent.
Repeat steps @ through for each controller.

Starting the DHCP server

To start the DHCP server, at the DHCP server console, type:

LOAD DHCPSRVR

Select the subnet object of the target IP address. Then click Create.
Select IP Address. Click OK. The Create IP Address window opens.
In the IP Address field, type the IP address for the first controller.

In the Assignment field, select Manual.

In the Client Identifier field, specify the MAC address.
In the MAC Address field, enter the hardware Ethernet MAC address for the

The DHCP server can now respond to client requests and assign IP addresses.

Notes:

1. To load the DHCP server automatically each time the server starts, place the
DHCPSRVR command in the SYS:\SYSTEM\AUTOEXEC.NCF directory.

2. For additional information about setting up, configuring, or using Novell
DNS/DHCP Services, refer either to the Novell Documentation CD or to the
following Web site:

[www.novell.com/documentation/|

Setting up a UNIX BOOTP server

To use a UNIX BOOTP server, you must set up a BOOTP table. |Tab|e 16| and the
information record (Appendix E, “Storage subsystem and controller information

[record,” on page 139) provide the necessary information.

Table 16. Required entries for setting up the UNIX BOOTP server

Entry

Description

Sample format in
BOOTP server

Subnet mask

Mask that is used to route packets to defined
subnets

dot notation
(sm=255.255.0.0)

Router

IP address of the host computer that routes
packets to networks

dot notation
(gw=192.168.128.1)

Host name for the
controller

Host name that is associated with the controller
(see[Table 24 on page 139)

host name (Denver_a)

IP address

IP address of the controller (see [Table 24 on

dot notation
(ip=192.168.128.101)

Ethernet address

The Ethernet address of the controller
hardware (see|[Table 24 on page 139)

hexadecimal notation
(ha=00a0b8020420)

Perform the following steps to set up a UNIX BOOTP server:

1. Use a text editor to edit the bootptab file in the /etc directory.

Use the following example of the BOOTP table to configure the Network A
server shown in [Figure 4 on page 12| where the s4.default:\ entry denotes
settings that are common to all controllers, and the tc=s4.default:\ entry
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associates this common setting group to a specific controller.

s4.default:\ (common settings)
ht=ether:\

sm=255.255.255.0:\
gw=192.168.128.1:\

hn:

denver_a:\

tc=s4.default:\ (common settings)
ip=192.168.128.101:\
ha=00a0b8020420:

denver_b:\

tc=s4.default:\
ip=192.168.128.102:\
ha=00a0b80000d8:

2. If the storage subsystem is running, shut down and then restart the subsystem.
This ensures that the parameters in the BOOTP table take effect.

3. Continue with ['Step 6 (Windows): Verifying the TCP/IP protocol and setting up|
[the host or DNS table.”|

Step 6 (Windows): Verifying the TCP/IP protocol and setting up the
host or DNS table

Install the TCP/IP networking stack to enable SMclient functions. Perform the
following two tasks by using the procedure that follows them:

» Verify that the TCP/IP protocol software is installed on the management station or
the host server on which you will install and from which will run SMclient.

» Set up the host or DNS table.

Note: Make sure that the host names for the controllers match the IP addresses for
the controllers.

Windows NT 4.0
Perform the following steps for Windows NT 4.0:
1. Right-click Network Neighborhood.
2. Select Properties. The Network window opens.

3. Click the Protocols tab. If the TCP/IP protocol entry does not appear in the
Network Products box, click Add. The Select Network Protocol window opens.

4. In the Network Protocol field, select TCP/IP Protocol.
5. Click OK. Then follow the on-screen instructions to install the TCP/IP protocol.
6. Update the DNS table to specify a host name to associate with an IP address.

If you do not have a DNS server, use a text editor to update the hosts file to link
the IP address and controller name entries. The following example shows the
host tables for the controllers that are connected to Network A as shown in
[Figure 4 on page 12

50 IBM TotalStorage FASIT Storage Manager Version 8.4x Installation and Support Guide for Intel-based Operating System

Environments



Windows 2000

#

Copyright (c) 1993-1999 Microsoft Corp.

This is a sample HOSTS file used by Microsoft TCP/IP for Windows.

This file contains the mappings of IP addresses to host names. Each

entry should be kept on an individual Tine. The IP address should be placed
in the first column followed by the corresponding host name. The IP address
and the host name should be separated by at least one space.

Additionally, comments (such as these) might be inserted on individual

lines or following the machine name denoted by a '#' symbol.

For example:
102.54.94.97  rhino.acme.com # source server
38.25.63.10  x.acme.com # x client host

127.0.0.1 local host
192.168.128.101  denver_a

192.168.128.102 denver_b

7.

If you want to manage storage subsystems through a firewall, configure the

firewall to open port 2463 to TCP data.

Perform the following steps for Windows 2000:

1.

2.
3.
4

Right-click My Network Places.
Select Properties. The Network and Dial-up Connections window opens.
Right-click a defined network connection.

Select Properties. Make sure that the Internet Protocol TCP/IP box under the
Components checked that are used by this connection is marked. If not, mark it,

click Install, and follow the instructions that display.

Update the DNS table to specify a host name to associate with an IP address.
If you do not have a DNS server, use a text editor to update the hosts file to link

the IP address and controller name entries. The following example shows the

host tables for the controllers that are connected to Network A as shown in
[Figure 4 on page 12
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#

Copyright (c) 1993-1999 Microsoft Corp.

This is a sample HOSTS file used by Microsoft TCP/IP for Windows.

This file contains the mappings of IP addresses to host names. Each

entry should be kept on an individual Tine. The IP address should be placed
in the first column followed by the corresponding host name. The IP address
and the host name should be separated by at least one space.

Additionally, comments (such as these) might be inserted on individual
lines or following the machine name denoted by a'#' symbol.

For example:

102.54.94.97  rhino.acme.com # source server

38.25.63.10  x.acme.com # x client host

127.0.0.1 local host
192.168.128.101  denver_a

192.168.128.102  denver_b

6.

Windows Server

To manage storage subsystems through a firewall, configure the firewall to open
port 2463 to TCP data.

2003

Perform the following steps for Windows Server 2003:

1.
2.

Open the Windows Explorer window.

Right-click the My Network Places folder and select Properties from the
pull-down menu. The Network Connections window opens.

Right-click a defined network connection and select Properties from the
pull-down menu.

A network_name Properties window opens. Make sure that the Internet Protocol
TCP/IP box under “The Connection Uses The Following ltems” window pane is
selected. If not, select it and click OK to close the network_name Properties
window.

Update the DNS table to specify a host name to associate with an IP address. If
you do not have a DNS server, use a text editor to update the hosts file to link
the IP address and controller name entries. The following example shows the
host tables for the controllers that are connected to Network A, as shown in
[Figure 4 on page 12
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#

Copyright (c) 1993-1999 Microsoft Corp.

This is a sample HOSTS file used by Microsoft TCP/IP for Windows.

This file contains the mappings of IP addresses to host names. Each
entry should be kept on an individual Tine. The IP address should

be placed in the first column followed by the corresponding host name.
The IP address and the host name should be separated by at Teast one
space.

Additionally, comments (such as these) may be inserted on individual
lines or following the machine name denoted by a '#' symbol.

For example:

102.54.94.97 rhino.acme.com # source server

38.25.63.10 X.acme.com # x client host

127.0.0.1 Tocalhost
192.168.128.101 denver_a

192.168.128.102 denver_b

6.

To manage storage subsystems through a firewall, configure the firewall to open
port 2463 to TCP data.

Step 6 (NetWare): Verifying the TCP/IP protocol and setting up the host

or DNS table

The normal default installation process will install the TCP/IP software package.

Perform the following steps to set up the host or DNS table. Make sure that the
host names for the controller match the IP addresses for the controllers.

1.

Update either the host table or the DNS table to specify a host name to
associate with an IP address. If you do not have a DNS table, edit the two host
tables that are found in the sys:etc\hosts directories. (Your directory will be
different if the operating system is not installed on the root.)

To set up the host tables for the controllers, open the hosts file that is located in
the \etc\ directory. Use a text editor to update the host file to create the
following IP address and controller name entries. For example:

Mappings of host names and host aliases to IP addresses

127.0.0.1  Toopback 1b Tocal host loopback address

Examples from a fictitious network:

129.47.4.2 ta tahiti ta.some.com Toghost
129.47.6.40 osd-frog

129.47.6.144 sj-in5 inb

197.67.172.71 sj-inl inl

2.

To manage storage subsystems through a firewall, configure the firewall to open
port 2463 to TCP data.
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Step 6 (Linux): Verifying the TCP/IP protocol and setting up the host or
DNS table

The normal default installation process will install the TCP/IP software package.

Perform the following steps to set up the host or DNS table. Make sure that the

host names for the controller match the IP addresses for the controllers.

1. Update either the host table or the DNS table to specify a host name to
associate with an IP address. If you do not have a DNS table, edit the host
table that is found in the /etc/hosts directory. Your directory might be different if
the operating system is not installed on the root.

2. To manage storage subsystems through a firewall, configure the firewall to open
port 2463 to TCP data.

The following sample shows a Linux host file. Do not remove the following line, or
various programs that require network functionality will fail.

127.0.0.1 rh71_8500 localhost.localdomain
localhost 102.54.94.97 rhino.acme.com Xx.acme.com
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Chapter 3. Installing Storage Manager software in a standard
Windows configuration

This chapter describes how to install the storage management software for

Windows NT, Windows 2000, and Windows Server 2003 in a standard (noncluster)

configuration. Before you install the software, make sure that you have read the

following information:

- If you intend to configure your system for clustering, see [Chapter 4, “Installing

Storage Manager software in a Windows cluster server environment,” on page|

65.

« If you have existing storage systems, see [‘Installation types” on page 15/and
[‘Managing coexisting storage subsystems” on page 20.

» To ensure proper installation, make sure that you have completed all preparation
tasks described in|Chapter 2, “Preparing for installation,” on page 31 |

Important: Always check for a readme file on any installation media. The readme
file contains important information that was not available when the guide was
prepared.

New installation process

You can install the Storage Manager 8.4 software components on host computers
only or on both host computers and management stations.

Management station: A management station is a system that you use to manage

the storage subsystem. You can attach it to the storage subsystem in the following

ways:

« Through a TCP/IP Ethernet connection to the controllers in the storage
subsystem

* Through a TCP/IP network connection to a host computer with host-agent
software installed on it, which in turn is directly attached to the storage
subsystem through the fibre-channel input/output (1/0) path

You must install the following storage management software on a management
station:

e SMclient

Host computer: A host computer (or host) is a system that is directly attached to
the storage subsystem through a fibre-channel 1/0 path.

Important: Be sure you install the host-bus adapter and driver before you install the
storage management software.

You must install storage management software on each host computer in the
following order:

1. SMclient
2. RDAC
3. SMagent
4. SMutil

To begin the installation on your management station, see [‘Storage Manager 8.4
[Client” on page 56.|
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To begin installation on a host, see [‘Installing the IBM fibre-channel host bus|
ladapter device driver.”|

Installing the IBM fibre-channel host bus adapter device driver

An IBM fibre-channel host bus adapter (HBA) provides the interface between a host
server and an FASLT storage server. IBM FASIT fibre-channel HBAs are
high-performance, direct memory access, bus-master, host adapters that are
designed for high-end systems. These HBAs support all fibre-channel peripheral
devices that support private-loop direct-attach and fabric-loop attachment. The IBM
Host Adapter device driver enables your operating system to communicate with the
fibre-channel HBA. See the readme file included in the driver package for
installation instructions associated with your operating system. For more
information, see the Installation and User’'s Guide for your particular fibre-channel
HBA model. The current readme file and latest multipath 1/O device driver are
available at the following Web site:

www-1.ibm.com/servers/storage/support/fastt/index.html|

Storage Manager 8.4 Client

This section describes how to install SMclient on management stations and host
computers that run Windows operating systems.

Before you install the software, make sure that the management station or host
computer has at least 80 MB of available disk space.

Important: When you install SMclient on a stand-alone host and manage storage
subsystems through the fibre-channel 1/0O path rather than through the network, you
must install the TCP/IP software on the host and assign an IP address to the host.

Installing SMclient

To install SMclient on Windows operating systems, perform the following steps:

1. Insert the IBM FASIT Storage Manager Version 8.4 CD into the CD-ROM drive.
2. Click Start » Run. The Run window opens.

3. Click Browse. The Browse window opens.

4. Select the CD-ROM drive.

5. Select the folder that is associated with your operating system.

Operating System Folder

Windows NT 4.0 or Windows 2000 \Win32\SMclient

Windows Server 2003 \WS03_32bit\SMClient

Click Open.

6. Select the displayed .exe file. Click Open. The InstallShield Wizard window
opens; then, the Welcome window opens.

7. Click Next. The End User License Agreement window opens.
8. Perform the following procedures depending on your operating system:
For Windows NT 4.0 and Windows 2000:

a. Read the license agreement and click Yes. The Event monitor window
opens.
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b. At the prompt, click Yes if you want to install the Event Monitor. The Choose
Destination Location window opens.

c. Click Browse to change the destination location.

d. Click Next to start the installation. When the installation is complete, the
Operation Complete window opens.

e. Click Finish.
f. Continue with [‘Verifying the SMclient installation” on page 71.|
For Windows Server 2003:

a. Read the license agreement and click Yes. The Choose Destination
Location window opens.

b. Click Browse to change the destination location. Click Next to continue with
the installation.

c. The Event monitor window opens. Click Yes if you want to install the Event
Monitor. Otherwise, click No.

d. The Setup Status window opens showing the installation progress. When
the installation is complete, the Operation Complete window opens.

e. Click Finish.
f. Continue with [“Verifying the SMclient installation.’]

Verifying the SMclient installation

To verify that you installed SMclient correctly on Windows operating systems,
perform the following steps:

1.

2.

4.

Perform one of the following steps depending on your operating system:
* For Windows NT 4.0 and Windows 2000, click Start » Programs.
* For Windows Server 2003, click Start » All Programs.

Verify that IBM FAStT Storage Manager 8 Client displays in the Program list. If
the appropriate software version displays, go to step

Otherwise, repeat [‘Installing SMclient” on page 56 If the appropriate software
version associated with your operating system still does not display, a failure
has occurred. Contact your IBM technical support representative.

If you installed the optional Event Monitor service, go to [‘Verifying the Event|
[Monitor installation.”] Otherwise, continue to step [4}
If you are installing SMclient on a host computer, go to [RDAC” on page 58|
Otherwise, go to|Chapter 8, “Completing Storage Manager 8.4 installation,” on|

page 103.

Verifying the Event Monitor installation

This section describes how to verify that you installed the Event Monitor service
correctly on Windows operating systems.

Windows NT 4.0
To verify that you installed the Event Monitor service correctly, perform the following
steps:

1.
2.
3.

Click Start » Settings » Control Panel. The Control Panel window opens.
Double-click Services. The Services window opens.

Verify that the IBM FAStT Storage Manager 8 Event Monitor service displays
with the status Started. If it does not display, click Start. If the service does not
start, reinstall the SMclient. If the failure persists, call your IBM technical support
representative.
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4. If you are installing the storage management software on a host computer, go to
“RDAC.] Otherwise, go to[Chapter 8, “Completing Storage Manager 8.4]
installation,” on page 103

Windows 2000

To verify that you installed the Event Monitor service correctly, perform the following
steps:

1. Click Start » Programs » Administrative Tools » Services. The Services
window opens.

2. Verify that the IBM FAStT Storage Manager 8 Event Monitor service displays
with the startup type Automatic and status Started. If it does not display, click
Start. If it does not start, reinstall the SMclient. If the failure persists, call your
IBM technical support representative.

3. If you are installing the storage management software on a host computer, go to
“RDAC.] Otherwise, go to [Chapter 8, “Completing Storage Manager 8.4
installation,” on page 103

Windows Server 2003

To verify that you installed the Event Monitor service correctly, perform the following
steps:

1. Click Start » Administrative Tools » Services. The Services window opens.

2. Verify that the IBM FAStT Storage Manager 8 Event Monitor service displays
with the startup type Automatic and status Started. If it does not display, click
Start. If it displays but does not start, reinstall the SMclient. If the failure
persists, call your IBM technical support representative.

3. If you are installing the storage management software on a host computer, go to
“RDAC.”| Otherwise, go to[Chapter 8, “Completing Storage Manager 8.4|
installation,” on page 103,

RDAC

This section describes how to install RDAC on Windows operating systems. You
must install RDAC on each host computer. RDAC contains the multipath device
driver that is necessary for controller failover support.

Before you install the software, ensure that the following conditions are met:
* You have Administrator privileges on the host computer.

* The host computer has at least 2 MB of available disk space.

» All programs are closed.

* You have installed the host bus adapter and driver.

If iou are installing RDAC on Windows NT 4.0, continue with |“Assigning static drive|

If you are installing RDAC on Windows 2000 or Windows Server 2003, continue
with ['Installing the RDAC” on page 59.|

Assigning static drive letters

Important: Before you install RDAC, you must assign static drive letters to existing
local drives. Otherwise, problems might occur during new installations and
upgrades. When RDAC is installed, the RDAC utility installs the RDAC device driver
before the Windows NT 4.0 class driver. If static drive letters have not previously
been assigned to local drives, the system will detect storage subsystem arrays and
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assign them drive letters before detecting and assigning drive letters to local drives.
If you have software applications using non-permanent drive letters that are
assigned to local drives, and this occurs, application errors will result.

Perform the following steps to manually assign static drive letters on host
computers that run Windows NT 4.0:

1.

4.

Determine how many partitions are on the system. Click Start + Programs -

Administrative Tools » Disk Administrator to view the disk configuration and

check the number of partitions.
Check that the following conditions are met:
* A boot partition exists.

* The last partition has been created with Disk Administrator or Disk
Management.

* The partition has an assigned drive letter with either an unknown status or a

status other than Unformatted.

If all conditions are met, go to[“Installing the RDAC.”| Otherwise, continue to step

Create a new partition on your local system or on a storage subsystem by using

the following procedure:
a. Select a drive with free space. Click Partition » Create. The partition is

created with a status of Unformatted and a drive letter is assigned. You can

delete or change the logical drive at a later time without causing
reassignment of the boot partition.

b. Click Partition » Commit Changes Now. The partition status changes to
Unknown, and static drive letters are assigned to all existing partitions.

Continue with [Installing the RDAC.]

Installing the RDAC

To install RDAC on Windows operating systems, perform the following steps:

1.

Insert the IBM FAStT Storage Manager Version 8.4 CD into the CD-ROM
drive.

2. Click Start » Run. The Run window opens.

3. Click Browse. The Browse window opens.

4. Select the CD-ROM drive.

5. Select the directory that is associated with your operating system.
Operating System Directory
Windows NT 4.0 \Win32\SMrdac\NT
Windows 2000 Server or Professional \Win32\SMrdac\W2K

Windows Server 2003 for 32-bit processors \WS03_32bit\SMrdac

Windows Server 2003 for 64-bit processors \WS03_64bit\SMrdac

6.

Select the displayed .exe file. Click Open. The InstallShield Wizard window
opens; then, the Welcome window opens.
Click Next. The End User License Agreement window opens.

Click Yes to start the installation. Perform the following steps depending on

your operating system:

* For Windows NT 4.0 and Windows 2000, after you install RDAC, the
InstallShield Wizard Complete window opens. Continue with step
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* For Windows Server 2003, the Installation/Removal status window opens
displaying the RDAC installation progress. Continue with step Q

9. After the installation is complete, the Operation Complete window opens.
10. Select Yes | want to restart my computer now. Click Finish.
11. Continue with [*Verifying the RDAC installation.]

Verifying the RDAC installation

This section describes how to verify that you installed RDAC correctly on Windows
operating systems.

Windows NT 4.0
To verify that you installed RDAC correctly, perform the following steps.

Note: Make sure that all storage subsystems are connected to the host computer
and are powered on.

1. Click Start » Settings » Control Panel. The Control Panel window opens.
2. Double-click Devices. The Devices window opens.
3. Scroll to symarray.

» If symarray displays with a device status of Started, go to step

* If symarray does not display, an error might have occurred. Repeat the
procedure in [‘Installing the RDAC” on page 59/ If the failure persists, call
your IBM technical support representative. Otherwise, go to step

4. Perform one of the following tasks:

« If you are managing the storage subsystems using the host-agent method,
continue with [‘Storage Manager 8.4 Agent” on page 61)

* If you are managing your storage subsystems directly, go to
[Manager 8.4 Utility” on page 63

Windows 2000
To verify that you installed RDAC correctly, perform the following steps:

1. Click Start » Programs » Administrative Tools + Computer Management.
The Computer Management window opens. Go to the \System Tools\System
Information\Software environment\drivers directory.

2. Scroll through the list and select one of the following device drivers:

» rdacbus

¢ rdacdisk

The rdacbus option always displays. The rdacdisk option displays only when
you have disks.

3. Verify that either rdacbus or rdacdisk displays with the state type Running and
status OK. If neither does, repeat the procedure in ['Installing the RDAC” on page]
If the failure persists, call your IBM technical support representative.
Otherwise, continue as follows:

* If you are managing the storage subsystems using the host-agent method,
continue with [‘Storage Manager 8.4 Agent” on page 61|

» If you are managing your storage subsystems using the direct-management
method, go to[‘Storage Manager 8.4 Utility” on page 63|

Windows Server 2003
To verify that you installed RDAC correctly, perform the following steps:
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1. Click Start » All Programs » Accessories » System Tools » System
information. The System Information window opens. Go to the \System
Summary\Software Environment\System Drivers list.

2. Scroll through the list and select one of the following device drivers:

* rdacbus

e rdacdisk

rdacbus is always shown. rdacdisk displays only when you have disks.

3. \Verify that either rdacbus or rdacdisk displays with the state type Running and
status OK. If it does not display, repeat the procedure in |“Instal|ing the RDAC” on|
If the failure persists, call your IBM technical support representative.
Otherwise, continue as follows:

» If you are managing the storage subsystems using the host-agent method,
continue with [‘Storage Manager 8.4 Agent.’|

» If you are managing your storage subsystems using the direct-management
method, go to[‘Storage Manager 8.4 Utility” on page 63.|

Storage Manager 8.4 Agent

This section describes how to install SMagent software on Windows operating
systems. You must install the SMagent software if you want to manage the storage
subsystem using the host-agent management method.

Before you install the software, ensure that the following conditions are met:
* You have Administrator privileges on the host computer.

* The host computer has at least 1 MB of available disk space if the SMclient is
installed with the Event Monitoring service.

* The host computer has at least 40 MB of available disk space if the SMclient
program is not installed with the Event Monitoring service.

+ RDAC is installed on each host computer. If not, see [‘RDAC” on page 58
» All storage subsystems are connected to the host computer and are powered on.

Installing SMagent
To install SMagent on Windows operating systems, perform the following steps:
1. Close all programs.

2. Insert the IBM FASIT Storage Manager Version 8.4 CD in the CD-ROM drive.
3. Click Start » Run. The Run window opens.
4. Click Browse. The Browse window opens.
5. Select the CD-ROM drive
6. Select the folder that is associated with your operating system.
Operating System Folder
Windows NT 4.0 and Windows 2000 \Win32\SMagent
Windows Server 2003 \WS03_32bit\SMAgent

Then, click Open.

7. Select the displayed .exe file. Click Open. The InstallShield window opens,
showing the status of the file unpacking. The Welcome window opens.

8. Click Next. The End User License Agreement window opens.
9. Read the license and click Yes to begin the installation. The software
installation ends, and the Operation Complete window opens.
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10. Click Finish.
11. Continue with [“Verifying the SMagent installation.”|

Verifying the SMagent installation

This section provides instructions on how to verify that you installed SMagent
correctly on Windows operating systems.

Windows NT 4.0
To verify that you installed the SMagent correctly, perform the following steps:

1. Click Start » Settings » Control Panel. The Control Panel window opens.
2. Double-click Services. The Services window opens.

3. Scroll through the list of services until you find IBM FAStT Storage Manager 8

Agent.

» |f IBM FASLT Storage Manager 8 Agent displays with a startup type of
Started, close the Services window and continue to step EI

« If IBM FASIT Storage Manager 8 Agent does not display with a startup type
of Started, click Start. If the status changes to Started, go to step If not,
see[Table 21 on page 133|for a possible cause. Otherwise, reinstall IBM
FASIT Storage Manager 8.4 Agent. If the problem persists, contact your IBM
technical support representative.

4. Perform one of the following procedures:

» If you plan to use the host-agent software to manage one or more storage
subsystems, go to [‘Storage Manager 8.4 Utility” on page 63,

* If you do not plan to use the host-agent software to manage one or more
storage subsystems, perform the following steps to disable the host-agent
service:

a. Click Start » Settings » Control Panel. The Control Panel window opens.
Double-click Services. The Services window opens.
From the list of displayed services, right-click IBM FAStT Storage Manager

8 Agent.
d. Click Properties » Startup Type » Manual.
e. Click OK.

5. Continue with [‘Storage Manager 8.4 Utility” on page 63.|

Windows 2000
To verify that you installed the SMagent correctly, perform the following steps:

Note: Make sure that all storage subsystems are connected to the host computer
and are powered on.

1. Click Start » Programs » Administrative Tools » Services. The Services
window opens.

2. Scroll through the list of services until you find IBM FASIT Storage Manager 8
Agent.

3. If IBM FASIT Storage Manager 8 Agent does not display with a startup type of
Started, click Start. If the status changes to Started, go to step EI If not, see
[Table 21 on page 133|for a possible cause. Otherwise, reinstall IBM FAStT
Storage Manager 8.4 Agent. If the problem persists, contact your IBM technical
support representative.

4. Perform one of the following steps:

» If you plan to use the host-agent software to manage one or more storage
subsystems, go to [‘Storage Manager 8.4 Utility” on page 63.
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5.

* If you do not plan to use the host-agent software to manage one or more
storage subsystems, perform the following procedure to disable the
host-agent service:

a. Click Start » Programs » Administrative Tools »+ Computer
Management. The Computer Management window opens.

Click Services.

From the list of displayed services, right-click IBM FAStT Storage
Manager 8 Agent.

d. Click Properties » Startup Type » Manual.
e. Click OK.
Continue with [‘Storage Manager 8.4 Utility.]

Windows Server 2003
To verify that you installed the SMagent correctly, perform the following steps.

Note: Make sure that all storage subsystems are connected to the host computer

1.
2.

5.

and are powered on.
Click Start » Administrative Tools » Services. The Services window opens.

Scroll through the list of services until you find IBM FAStT Storage Manager 8
Agent.

If IBM FASTIT Storage Manager 8 Agent does not display with a startup type of
Started, click Start. If the status changes to Started, go to step EI If not, see
[Table 21 on page 133|for a possible cause. Otherwise, reinstall IBM FAStT
Storage Manager 8.3 Agent. If the problem persists, contact your IBM technical
support representative.

Perform one of the following steps:

* If you plan to use the host-agent software to manage one or more storage
subsystems, see [‘'Storage Manager 8.4 Utility."|

* If you do not plan to use the host-agent software to manage one or more
storage subsystems, perform the following steps to disable the host-agent
service:

a. Click Start » Administrative Tools »* Computer Management. The
Computer Management window opens.

Click Services.

From the list of displayed services, right-click IBM FAStT Storage
Manager 8 Agent.

d. Click Properties from the pull-down menu. The IBM FAStT Storage
Manager 8 Agent Properties window opens.

e. In the Startup Type list, select Manual. Click OK.
f. The IBM FASIT Storage Manager 8 Agent Properties window closes.
Continue with [‘Storage Manager 8.4 Utility.’]

Storage Manager 8.4 Utility

This section describes how to install SMutil on host computers that run both
Windows operating systems. This component contains utilities that will register and
map new logical drives to the operating systems.

Installing SMutil

To install SMutil on Windows operating systems, perform the following steps:
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1. Close all programs and insert the IBM FAStT Storage Manager Version 8.4
installation CD in the CD-ROM drive.

2. Click Start » Run. The Run window opens.

3. Click Browse. The Browse window opens.

4. Select the CD-ROM drive.

5. Select the folder that is associated with your operating system.
Operating System Folder
Windows NT 4.0, Enterprise Edition \Win32\SMutil
Windows 2000 Advanced Server \Win32\SMutil
Windows Server 2003 for 32-bit \WS03_32bit\SMUTil
processors
Windows Server 2003 for 64-bit \WS03_64bit\SMUHil
processors

Then click Open.

6. Select the displayed .exe file. Click Open. The InstallShield Wizard window
opens, displaying the status of the files unpacking. The Welcome window
opens.

7. Click Next. The End User License Agreement window opens.

8. Click Yes to begin the installation. After the installation is complete, the
Operation Complete window opens.

9. Click Finish.
10. Continue with [‘Verifying the SMutil installation.]

Verifying the SMutil installation

To verify that you installed the SMutil correctly on Windows operating systems,
perform the following steps:

1. Go to the following directory:
installation_directonA\IBM_FAStT\Util

where installation_directory is the directory where you installed the SMutil.
2. Verify that the directory contains the following files:

* hot_add.exe

» SMdevices.bat

* SMrepassist.exe

I it does not, reinstall the SMutil by using the procedure in ['Installing SMutil” on|
page 63.|If the problem persists, contact your IBM technical support
representative.

3. Go to [Chapter 8, “Completing Storage Manager 8.4 installation,” on page 103]

Additional information

For additional information about installing and using Storage Manager 8.4 for
Windows NT, Windows 2000, and Windows Server 2003 in a standard (noncluster)
configuration, see IAppendix A, “Windows operating system limitations,” on page|
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Chapter 4. Installing Storage Manager software in a Windows
cluster server environment

This chapter describes how to install the storage management software in a
Windows cluster server environment. Before you install the software, make sure
that you have read the following information:

« If you have existing storage systems, read [Installation types” on page 15/and
[‘Managing coexisting storage subsystems” on page 20|

 If you are upgrading from a previous version of Storage Manager on an existing
cluster, go to[‘Upgrading from a previous version of the storage management]
[software” on page 79

* To ensure proper installation, complete all preparation tasks described in
[Chapter 2, “Preparing for installation,” on page 31

Important: Always check for a readme file on any installation media. A readme file
contains important information that was not available when this guide was prepared.

Preinstallation considerations

The hardware installation involves installing host adapters and storage subsystems.
Before you begin the installation of the software, make sure that all hardware
components are installed correctly for the cluster server configuration.

Configuration options

You can connect the storage subsystem to the cluster nodes either directly or
through fibre-channel switches. [Figure 17 on page 66|shows typical direct-attached
or fibre-channel switch connection configurations. Both configurations offer full
redundancy.
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Figure 17. Installing the storage subsystem on a fibre-channel network

Host adapters

Refer to the appropriate host-adapter documentation for specific installation
requirements and procedures. The following considerations apply:

* To use the dual-path configuration, perform the following tasks:
— Install two host adapters in each node.
— Run two fibre-channel cables from each node to the storage subsystem.
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» If you connect the storage subsystem through a Fibre Channel-Arbitrated Loop

(FC-AL), ensure that every adapter on the loop is assigned a unique hard ID. For
instructions about changing hard IDs, see the documentation provided with your
host adapters.

» The correct device driver is installed for the host adapter. See the readme file in
the \Host_Adapter directory on the IBM FASIT Storage Manager Version 8.4 CD
for information about supported host adapters and device drivers.

Storage subsystems

Refer to the appropriate hardware documentation for specific installation
requirements and procedures. If you are managing storage subsystems directly, you
must connect Ethernet cables to both controllers in each storage subsystem.

Installing the storage management software in a cluster environment

The following procedures describe how to install the storage management software
in a cluster environment.

Windows NT 4.0 and Windows 2000

Perform the following steps to install the storage management and cluster service
software on Windows NT 4.0 and Windows 2000:

1.

Be sure that the HBA and device driver are installed in each cluster node. For
information about HBA and device driver installation, see [‘Installing the IBM|
ffibre-channel host bus adapter device driver’ on page 69.

Power down node B. Start node A.

Install the storage management software on node A. See [‘Installing the

lstorage management software” on page 69 for instructions.

Complete the procedures in|Chapter 8, “Completing Storage Manager 8.4]
[installation,” on page 103.|

Run the hot_add utility on node A. See [‘Using the hot_add utility” on page 120|
for instructions.

Note: You might have to restart node A in order to see the newly-added
logical drives.

Format all shared logical drives as NT File System (NTFS), assign volume
labels, and specify a drive letter for each.

Important: You must assign a permanent (sticky) drive letter to the shared
logical drive on both cluster nodes. The two nodes must have the same drive
letters on each shared drive. If you do not assign permanent drive letters,
Windows might assign different drive letters on each node. Assigning a
permanent drive letter ensures that Windows assigns the same drive letter to
the partition on both cluster nodes.

Shut down node A. Start node B.

Install the storage management software on node B. See[‘Installing the

lstorage management software” on page 69 for instructions.

To verify the drive letters for the cluster configuration, perform one of the
following procedures:

* For Windows NT 4.0, click Start » Programs » Administrative Tools »
Disk Administrator.

* For Windows 2000, perform the following steps:
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a. Click Start » Programs » Administrative Tools »+ Computer
Management. The Computer Management window opens.

b. Click Storage » Disk Management.
10. Verify that the following conditions are met:
* The same logical drives display on each cluster node.
» Each cluster node has the same number of partitions defined on the logical
drives.
» Drive letters are assigned to the configured logical drives.
* The drive letters on the partitions are the same on both cluster nodes.
11. Shut down node B.
12. Install the cluster server software. See [‘Installing the cluster server software’|

on page 78| for instructions.

13. Go to|Chapter 8, “Completing Storage Manager 8.4 installation,” on page 103

Windows Server 2003

Perform the following steps to install the storage management and cluster service
software on Windows Server 2003:

1. Make sure that the HBA and device driver are installed in each cluster node.
For information about HBA and device driver installation, see |“Insta|ling tha
[[BM fibre-channel host bus adapter device driver’ on page 69

2. Install the storage management software on the host server that will be the
first node of the cluster. See [Installing the storage management software” on|

for instructions.

3. Complete the procedures in|Chapter 8, “Completing Storage Manager 8.4|
installation,” on page 103,|specifically to create LUNSs that will be used as
cluster disks and to make sure that the host type of the host group or host
ports that these LUNs are mapped to were set to “Windows 2000/Server
2003..clustered” or “Windows 2000 clustered”.

4. Run the hot_add utility on the first node of the cluster. See[‘Using the hot_add|
[utility” on page 120|for instructions.

Note: You might have to restart the first node of the cluster in order to see the
newly-added logical drives (LUNSs).

5. Format all shared logical drives as NT File System (NTFS), assign volume
labels, and specify a drive letter for each.

Important: You must make sure that the permanent (sticky) drive letters that
are assigned to LUNs in the first cluster node are available (not used) in the
rest of the cluster nodes. In another words, all of the nodes in the cluster must
have the same drive letters on each shared drive. If you do not assign
permanent drive letters, Windows might assign different drive letters on each
node, which will prevent the cluster disks from operating correctly. Assigning a
permanent drive letter ensures that Windows assigns the same drive letter to
the partition on all cluster nodes.

6. Install the storage management software on the second node of the cluster.

Note: You must install the RDAC and SMutil software packages. You do not
have to install all of the storage management software packages unless
you want to manage the storage subsystem from this cluster node.

7. Run the hot_add utility on the second node of the cluster.
8. Repeat step|§| and stepﬁlfor each additional node of the cluster.
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9. Install the cluster server software. See [Installing the cluster server software’]
for instructions.

10. Manually move the cluster disk groups from the first cluster node to each of
the nodes in the cluster, making sure that they can be brought online. If they
can be brought online with no problems, you are ready to continue with your
application software installation. If you experience any problems, call IBM
support for assistance.

Installing the IBM fibre-channel host bus adapter device driver

An IBM fibre-channel host bus adapter (HBA) provides the interface between a host
server and a FASLT storage server. IBM FASLT fibre-channel HBAs are
high-performance, direct memory access, bus-master, host adapters that are
designed for high-end systems. These HBAs support all fibre-channel peripheral
devices that support private-loop direct-attach and fabric-loop attachment. The IBM
Host Adapter device driver enables your operating system to communicate with the
fibre-channel HBA. See the readme file included in the driver package for
installation instructions associated with your operating system. For more
information, see the Installation and User’'s Guide for your particular fibre-channel
HBA model. The current readme file and latest multipath 1/O device driver are
available at the following Web site:

www-1.ibm.com/servers/storage/support/fastt/index.html|

Installing the storage management software

This section describes how to install the storage management software on Windows
operating systems. Before you begin an installation with existing storage
subsystems, refer to your hardware installation documentation for the specific
configuration. A specific configuration might be required for your hardware to
support the storage management software in a cluster configuration.

You can install the Storage Manager 8.4 software components on cluster nodes
only or cluster nodes and management stations.

Management station: A management station is a system that is used to manage

the storage subsystem. You can attach it to the storage subsystem in either of the

following ways:

» Through a TCP/IP Ethernet connection to the controllers in the storage
subsystem

« Through a TCP/IP network connection to a cluster node with the host-agent
software installed

You must install the following storage management software on a management
station:

* SMclient

Cluster node: The cluster nodes are directly attached to the storage subsystem
through a fibre-channel 1/O path.

You must install storage management software on each cluster node in the
following order:

1. SMclient
2. RDAC
3. SMagent
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4. SMutil

See [Installing the SMclient’] to begin the installation.

Installing the SMclient

This section provides instructions on how to install SMclient on management
stations and cluster nodes that run on Windows operating systems.

Before you install the software, make sure that the following conditions are met:

* The management station or host computer has at least 80 MB of available disk
space.

» All programs are closed.

Important: When you install SMclient on a stand-alone host and manage storage
subsystems through the fibre-channel 1/0 path rather than through the network, you
must install the TCP/IP software on the host and assign an IP address to the host.

Installing SMclient
To install SMclient on Windows operating systems, perform the following steps:

1. Insert the IBM FASIT Storage Manager Version 8.4 CD into the CD-ROM drive.
2. Click Start » Run. The Run window opens.

3. Click Browse. The Browse window opens.

4. Select the CD-ROM drive.

5. Select the folder that is associated with your operating system.

Operating System Folder

Windows NT 4.0 or Windows 2000 \Win32\SMclient

Windows Server 2003 \WS03_32bit\SMClient

Click Open.

6. Select the displayed .exe file. Click Open. The InstallShield Wizard window
opens then the Welcome window opens.

7. Click Next. The End User License Agreement window opens.
8. Perform the procedure that is associated with your operating system:
For Windows NT 4.0 and Windows 2000:

a. Read the license agreement and click Yes. The Event monitor window
opens.

b. At the prompt, click Yes if you want to install the Event Monitor. The Choose
Destination Location window opens.

c. Click Browse to change the destination location.

d. Click Next to start the installation. When the installation is complete, the
Operation Complete window opens.

e. Click Finish.
f. Continue with |“Verifying the SMclient installation” on page 71 |
For Windows Server 2003:

a. Read the license agreement and click Yes. The Choose Destination
Location window opens.

b. Click Browse to change the destination location. Click Next to continue with
the installation.
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c. The Event monitor window opens. Click Yes if you want to install the Event
Monitor. Otherwise, click No.

d. The Setup Status window opens showing the installation progress. When
the installation is complete, the Operation Complete window opens.

e. Click Finish.
f. Continue with [Verifying the SMclient installation.]

Verifying the SMclient installation
Perform the following steps to verify that the SMclient software is installed correctly
on Windows operating systems:
1. Perform one of the following steps, depending on your operating system:
* For Windows NT 4.0 and Windows 2000, click Start + Programs.
* For Windows Server 2003, click Start » All Programs.
2. Verify that IBM FAStT Storage Manager 8 Client displays in the Program list. If
the appropriate software version displays, go to step

Otherwise, repeat [‘Installing SMclient” on page 70/ If the appropriate software
version associated with your operating system still does not display, a failure
occurred. Contact your IBM technical support representative.

3. If you installed the optional Event Monitor service, go to [Verifying the Event|
[Monitor installation.] Otherwise, continue with step

4. If you are installing SMclient on a host computer, go to fRDAC” on page 72.|
Otherwise, go to[Chapter 8, “Completing Storage Manager 8.4 installation,” on|

Verifying the Event Monitor installation
This section describes how to verify that you installed the Event Monitor correctly
on Windows operating systems.

Windows NT 4.0: To verify that you installed the Event Monitor service correctly
on Windows NT 4.0, perform the following steps:

1. Click Start » Settings » Control Panel. The Control Panel window opens.

2. Double-click Services. The Services window opens.

3. Verify that IBM FAStT Storage Manager 8 Event Monitor service displays with
the status Started. If it is not, click Start. If the service does not start, reinstall

the SMclient. If the failure persists, call your IBM technical support
representative.

4. If you are installing the storage management software on a cluster node, go to
“RDAC” on page 72| Otherwise, go to [Chapter 8, “Completing Storage Manager|
8.4 installation,” on page 103

Windows 2000: To verify that you installed the Event Monitor service correctly on
Windows 2000, perform the following steps:

1. Click Start » Programs » Administrative Tools » Services. The Services
window opens.

2. Verify that the IBM FAStT Storage Manager 8 Event Monitor service displays
with the startup type Automatic and status Started. If it is not, click Start. If the
service does not start, reinstall the SMclient. If the failure persists, call your IBM
technical support representative.

3. If you are installing the storage management software on a host computer, go to
“RDAC” on page 72| Otherwise, go to [Chapter 8, “Completing Storage Manager|
8.4 installation,” on page 103
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RDAC

Windows Server 2003: To verify that you installed the Event Monitor service
correctly on Windows Server 2003, perform the following steps:

1. Click Start » Administrative Tools » Services. The Services window opens.

2. Verify that the IBM FAStT Storage Manager 8 Event Monitor service displays
with the startup type Automatic and status Started. If it is not, click Start. If it
does not start, reinstall the SMclient. If the failure persists, call your IBM
technical support representative.

3. If you are installing the storage management software on a host computer, see
“RDAC.”| Otherwise, go to|Chapter 8, “Completing Storage Manager 8.4{
installation,” on page 103

This section describes how to install RDAC on Windows operating systems. You
must install RDAC on each cluster node. RDAC contains the multipath device driver
that is necessary for controller failover support.

Before you install the software, ensure that the following conditions are met:
* You have Administrator privileges on the cluster nodes.

» Each cluster node has at least 2 MB of available disk space.

* You close all programs.

* The appropriate HBA device driver is installed.

If you are installing RDAC on Windows NT 4.0, continue with [‘Assigning static drivel

If you are installing RDAC on Windows 2000 or Windows Server 2003, continue
with [Installing the RDAC” on page 73.|

Assigning static drive letters

Important: Before you install RDAC, you must assign static drive letters to existing
local drives. Otherwise, problems might occur during new installations and
upgrades. When RDAC is installed, the RDAC utility installs the RDAC device driver
before the Windows NT 4.0 class driver. If static drive letters have not previously
been assigned to local drives, the system will detect storage subsystem arrays and
assign them drive letters before detecting and assigning drive letters to local drives.
If this occurs and you have software applications that use non-permanent drive
letters that are assigned to local drives, application errors will result.

Use the following procedure to manually assign drive letters on cluster nodes
running Windows NT 4.0:

1. Click Start » Programs » Administrative Tools » Disk Administrator to view
the disk configuration and check the number of partitions.

2. Check that the following conditions are met:
* A boot partition exists.

* The last partition has been created with Disk Administrator or Disk
Management.

* The partition has an assigned drive letter and either an Unknown status or a
status other than Unformatted.

If all conditions are met, go to |“Instal|ing the RDAC” on page 73.| Otherwise,
continue to step

3. Create a new partition on your local system or on a storage subsystem using
the following procedure:
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a. Select a drive with free space; then, click Partition » Create. The partition is
created with a status of Unformatted and a drive letter is assigned. You can
delete or change the logical drive at a later time without causing
reassignment of the boot partition.

b. Click Partition » Commit Changes Now. The partition status changes to
Unknown, and static drive letters are assigned to all existing partitions.

4. Continue with [Installing the RDAC."|

Installing the RDAC
To install RDAC on Windows operating systems, perform the following steps:

1. Insert the IBM FASIT Storage Manager Version 8.4 CD into the CD-ROM drive.
2. Click Start » Run. The Run window opens.

3. Click Browse. The Browse window opens.

4. Select the CD-ROM drive.

5. Select the directory that is associated with your operating system.
Operating System Directory

Windows NT 4.0 \Win32\SMrdac\NT

Windows 2000 \Win32\SMrdac\W2K

Windows Server 2003 for 32-bit \WS03_32bit\SMrdac

processors

Windows Server 2003 for 64-bit \WS03_64bit\SMrdac

processors

6. Select the displayed .exe file; then, click Open. The InstallShield window opens,
showing the file unpacking. The Welcome window opens.

7. Click Yes to start the installation. Perform the following steps, depending on
your operating system:
* For Windows NT 4.0 and Windows 2000, after you install RDAC, the
InstallShield Wizard Complete window opens.

* For Windows Server 2003, the Installation/Removal Status window opens
displaying the RDAC installation progress. After the installation is complete,
the Operation Complete window opens.

8. Select Yes, | want to restart my computer now. Click Finish.
9. Continue with ['Verifying the RDAC."|

Verifying the RDAC
The following section describes how to verify that you installed RDAC correctly on
Windows operating systems.

Windows NT 4.0: To verify that you installed RDAC correctly on Windows NT 4.0,
perform the following steps.

Note: Make sure that all storage subsystems are connected to the host computer
and are powered on.

1. Click Start » Settings » Control Panel. A Control Panel window opens,
double-click Devices.

2. When the Devices window opens, scroll to symarray.
o |f simarray displays with a device status of Started, continue with step

page 74
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» If symarray does not display, an error might have occurred. Repeat the
procedure in [‘Installing the RDAC” on page 73 If the failure persists, call
your IBM technical support representative. Otherwise, continue with step

3. Perform one of the following procedures:

« If you are managing the storage subsystems using the host-agent method,
continue with ['SMagent” on page 75.|

« If you are managing your storage subsystems directly, continue with [*SMutil
lsoftware” on page 77

Windows 2000: To verify that you installed RDAC correctly on Windows 2000,
perform the following steps.

Note: Make sure that all storage subsystems are connected to the host computer
and are powered on.

1. Click Start » Programs » Administrative Tools »+ Computer Management.
The Computer Management window opens. Go to the \System Tools\System
Information\Software environment\Drivers directory.

2. Scroll through the list and select one of the following device drivers:
* rdacbus
* rdacdisk
The rdacbus option always displays. The rdacdisk option displays only when
you have disks.

3. Verify that either rdacbus or rdacdisk displays with the state type Running and
status OK. If neither does, repeat the procedure in [‘Installing the RDAC” on page]
If the failure persists, call your IBM technical support representative.
Otherwise, proceed to step
4. Perform one of the following procedures:
« If you are managing the storage subsystems using the host-agent method,
continue with ['SMagent” on page 75.|

o If iou are managing your storage subsystems directly, go to[‘SMutil software”|

Windows Server 2003: To verify that you have installed RDAC correctly, perform
the following steps:

1. Click Start » All Programs » Accessories » System Tools » System
information. The System Information window opens. Go to the \System
Summary\Software Environment\System Drivers list.

2. Scroll through the list and select one of the following device drivers:
* rdacbus
* rdacdisk

rdacbus is always shown. rdacdisk displays only when you have disks.

3. Verify that either rdacbus or rdacdisk displays with the state type Running and
status OK. If it does not, repeat the procedure in|“|nsta||ing the RDAC” on page|
If the failure persists, call your IBM technical support representative.
Otherwise, continue as follows:

« If you are managing the storage subsystems using the host-agent method,
continue with |“SMagent” on page 75.|

« If you are managing your storage subsystems using the direct-management
method, go to |“SMutiI software” on page 77.|
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SMagent

The following section describes how to install the SMagent software on Windows
operating systems. You must install the SMagent software if you want to manage
the storage subsystem using the host-agent method.

Before you install the software on Windows operating systems, ensure that the
following conditions are met:

* You have Administrator privileges on the cluster nodes.

» Each cluster node will have at least 1 MB of available disk space if you install
SMclient with the Event Monitoring service.

* The host computer will have at least 40 MB of available disk space if you do not
install the SMclient program with the Event Monitoring service.

* You installed RDAC on each cluster node. If you have not done so, refer to
[‘RDAC” on page 72|

Installing SMagent
To install SMagent on Windows operating systems, perform the following steps:

1. Close all programs.

2. Insert the IBM FASIT Storage Manager Version 8.4 CD in the CD-ROM drive.
3. Click Start » Run. The Run window opens.
4. Click Browse. The Browse window opens.
5. Select the CD-ROM drive.
6. Select the folder that is associated with your operating system.
Operating System Folder
Windows NT 4.0 \Win32\SMagent
Windows 2000 \Win32\SMagent
Windows Server 2003 for 32-bit \WS03_32bit\SMAgent
processors

Click Open.

7. Select the displayed .exe file. Then click Open. The InstallShield window
opens, showing the status of the file unpacking. The Welcome window opens.

8. Click Next. The End User License Agreement window opens.

9. Read the license and click Yes to begin the installation. The software
installation ends, and the Operation Complete window opens.

10. Click Finish.
11. Continue with [Verifying the SMagent.’]

Verifying the SMagent
The following section describes how to verify that you installed the SMagent
correctly on Windows operating systems.

Windows NT 4.0: To verify that you installed the SMagent correctly on Windows
NT 4.0, perform the following steps:

1. Click Start » Settings » Control Panel. The Control Panel window opens.
2. Double-click Services. The Services window opens.
3. Scroll through the list of services until you find Storage Manager 8 Agent.

« |If Storage Manager 8 Agent displays with a startup type of Started, close the
Services window, and continue to step
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» |If Storage Manager 8 Agent does not display with a startup type of Started,

click Start. If the status changes to Started, go to step|4 on page 62| If not,

refer to[Table 21 on page 133|for a possible cause. Otherwise, reinstall
SMagent. If the problem persists, contact your IBM technical support
representative.

4. Perform one of the following procedures:

» If you plan to use the host-agent software to manage one or more storage
subsystems, go to [‘SMutil software” on page 77|

» If you do not plan to use the host-agent software to manage one or more
storage subsystems, perform the following steps to disable the host-agent
service:

a. Click Start » Programs » Administrative Tools » Manage. The
Computer Management window opens.

Click Services.
From the list of displayed services, right-click Storage Manager 8 Agent.
Click Properties » Startup Type » Manual.
e. Click OK.
5. Continue with [SMutil software” on page 77|

a oo

Windows 2000: To verify that you installed the SMagent correctly on Windows
2000, perform the following steps:

1. Click Start » Programs » Administrative Tools » Services. The Services
window opens.

2. Scroll through the list of services until you find Storage Manager 8 Agent.

3. Verify that Storage Manager 8 Agent is displayed with the startup type
Automatic and status Started. If Storage Manager 8 Agent does not display

with a startup type of Started, click Start. If the status changes to Started, go
to step If not, see(Table 21 on page 133 for a possible cause.
Otherwise, reinstall SMagent. If the problem persists, contact your IBM technical
support representative.

4. Perform one of the following procedures:

» If you plan to use the host-agent software to manage one or more storage
subsystems, go to [‘SMutil software” on page 77

* If you do not plan to use the host-agent software to manage one or more
storage subsystems, perform the following procedure to disable the
host-agent service:

a. Click Start » Programs » Administrative Tools »+ Computer
Management. The Computer Management window opens.

Click Services.
From the list of displayed services, right-click Storage Manager 8 Agent.
Click Properties » Startup Type » Manual.
e. Click OK.
5. Continue with 'SMutil software” on page 77/

a oo

Windows Server 2003: To verify that you installed the SMagent correctly, perform
the following steps:

1. Click Start » Administrative Tools » Services. The Services window opens.

2. Scroll through the list of services until you find IBM FAStT Storage Manager 8
Agent.
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3. If IBM FASIT Storage Manager 8 Agent does not display with a startup type of
Started, click Start. If the status changes to Started, go to @, If not, see
[Table 21 on page 133|for a possible cause. Otherwise, reinstall SMagent. If the
problem persists, contact your IBM technical support representative.

4. Perform one of the following steps:

» If you plan to use the host-agent software to manage one or more storage
subsystems, see [‘SMutil software.’]

» If you do not plan to use the host-agent software to manage one or more
storage subsystems, perform the following steps to disable the host-agent
service:

a. Click Start »+ Administrative Tools »+ Computer Management. The
Computer Management window opens.

Click Services.

From the list of displayed services, right-click IBM FAStT Storage
Manager 8 Agent.

d. Select Properties from the pull-down menu. The IBM FAStT Storage
Manager 8 Agent Properties window opens.

e. In the Startup Type list, select Manual. Click OK.
f. The IBM FASLIT Storage Manager 8 Agent Properties window closes.
5. Continue with [*SMutil software.’]

SMutil software

This section provides instructions regarding SMutil software installation on cluster
nodes that run Windows operating systems. This component contains utilities that
will register and map new logical drives to the operating systems.

Installing SMutil
To install SMutil on Windows operating systems, perform the following steps:

1. Close all programs and insert the IBM Storage Manager Version 8.4
installation CD in the CD-ROM drive.

2. Click Start » Run. The Run window opens.

3. Click Browse. The Browse window opens.

4. Select the CD-ROM drive.

5. Select the folder that is associated with your operating system.
Operating System Folder
Windows NT 4.0 Enterprise Edition \Win32\SMuti1
Windows 2000 Advanced Server \Win32\SMuti1
Windows Server 2003 for 32-bit \WS03_32bit\SMUti1
processors
Windows Server 2003 for 64-bit \WS03_64bit\SMUti1
processors

Click Open.

6. Select the setup.exe file, then click Open. The InstallShield Wizard window
opens, displaying the status of the files unpacking. The Welcome window
opens.

7. Click Next. The End User License Agreement window opens.

8. Click Yes to begin the installation. After the installation is complete, the
Operation Complete window opens.
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9. Click Finish.
10. Continue with [‘Verifying the SMutil installation.’]

Verifying the SMutil installation
To verify that you installed the SMutil correctly on Windows operating systems,
perform the following steps:

1. Go to the following directory:
installation_directory\1BM_FAStT\Uti1

where installation_directory is the directory where you installed the SMutil.
2. Verify that the directory contains the following files:

* hot_add.exe

* SMdevices.bat

e SMrepassist.exe

If it does not, reinstall the SMutil using the procedure in [“Installing SMutil” on|

If the problem persists, contact your IBM technical support
representative.

3. Go to [Installing the storage management software in a cluster environment” on|

lpage 67|

Installing the cluster server software

The following sections describe how to install the cluster server software on
Windows operating systems.

Windows NT 4.0 and Windows 2000

Important: Do not perform this procedure unless you installed the necessary
storage management software components on both cluster nodes.

To install the cluster server software on node A and node B, perform the following
steps:
1. Install the cluster server software on node A, as follows:

a. Refer to the appropriate Microsoft Cluster Server (MSCS) documentation for
the correct procedure to install the cluster server software.

Note: During installation, specify that you want to form a new cluster.
b. After the system restarts, leave node A running.
2. Install the cluster server software on node B, as follows:

a. Refer to the appropriate MSCS documentation for the correct procedure to
install the Cluster Server software.

Note: During installation, specify that you want to join the existing cluster.
b. After the system restarts, leave node B running.
3. After you install MSCS, perform one of the following tasks:
* For systems running Windows NT 4.0, reinstall Service Pack 6a.
* For systems running Windows 2000, reinstall Service Pack 4.

Note: Refer to Microsoft Knowledge Base article Q174799 for more information
regarding service pack installation in a cluster environment.

4. Verify the software installation as follows:
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a. On either node A or node B, click Start + Programs » Administrative Tools
» Cluster Administration.

b. In the Cluster or Server Name field, type either the name of the cluster or
the name or IP address of one of the nodes.

If the installation is successful, the computer names of both nodes appear
on the left side of the Cluster Administrator window.

c. Make sure that the cluster disk groups can be moved between cluster
nodes.
5. If both node names do not display on the left side of the Cluster Administrator
window, reinstall the cluster server software. If the problem persists, contact
your IBM technical support representative.

Windows Server 2003

Important: Do not perform this procedure unless the necessary storage
management software components are installed on all cluster nodes.

Perform the following steps to install the cluster server software on cluster nodes:

1. Install the cluster server software on the first node of the cluster. Refer to the
appropriate Microsoft Cluster Server (MSCS) documentation for the correct
procedure to install the cluster server software.

Note: During installation, specify that you want to form a new cluster.

2. In the Cluster Administrator window, make sure that all of the cluster disk
groups can be varied online and offline with no problems.

3. Install the cluster server software on the second node of the cluster. Refer to
the appropriate MSCS documentation for the correct procedure to install
additional nodes in the cluster server.

Note: During installation, specify that you want to join the existing cluster. You
can add one cluster node at a time or all of the remaining cluster nodes
at the same time. You should add cluster nodes one at a time.

4. If all node names do not display on the left side of the Cluster Administrator
window, reinstall the cluster server software. If the problem persists, contact
your IBM technical support representative.

Upgrading from a previous version of the storage management

software

Be sure that you are familiar with the steps required in a new installation before you
continue with the following upgrade procedure.

Choose one of the following two procedures:

* Performing a scheduled upgrade: A scheduled upgrade requires scheduling
downtime on your cluster server to upgrade the controller firmware and storage
management software. The services and resources offered by the cluster are not
available during the upgrade. If you choose this upgrade method, it is important
that you perform the upgrade during off-peak workload time.

Note: The scheduled upgrade is the preferred procedure for upgrading a cluster
server configuration.

+ Performing a rolling upgrade: A rolling upgrade requires upgrading the storage
management software first in one of the cluster nodes and then in each of the
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remaining cluster nodes, one cluster node a time, so that the services and
resources offered by the cluster are always available.

Important: Do not upgrade your storage subsystem firmware until you have
upgraded the storage management software on all cluster nodes and management
stations. If you upgrade your storage subsystem controller firmware level to version
05.4x.xx.xx, you will not be able to communicate with the controller until you have
upgraded to Storage Manager 8.4 software on your management station and cluster
nodes. Previously installed versions of Storage Manager will not recognize
controllers running version 05.4x.xx.xx firmware.

Performing a scheduled upgrade

The following sections describe how to perform a scheduled upgrade on Windows
operating systems.

Windows NT 4.0 and Windows 2000

To perform a scheduled upgrade from Storage Manager Version 7.xx, 8.0, or 8.2x to
Storage Manager 8.4 on machines that are running Windows NT 4.0 and Windows
2000, perform the following procedure:

1. Click Start » Programs » Administrative Tools » Services. The Services
window opens.

2. Shut down node B.

3. From node A, uninstall the components from the previous version of the
storage management software. To uninstall the storage management software
for Storage Manager Version 7.x, 8.0, or 8.2x see [‘Uninstalling storagel
[management software components” on page 122

Note: Uninstall the storage management components in the following order:

a. SMagent
b. SMutil
c. RDAC
d. SMclient

4. Verify that the IBM host adapter device driver versions are current. If they are
not current, refer to the readme file located in the \Host_Adapter directory on
the installation CD and upgrade the device drivers.

5. Install the SMclient on node A. See [‘Installing the SMclient” on page 70| for
instructions.

Install the RDAC on node A. See [‘{RDAC” on page 72 for instructions.
Install the SMagent on node A. See |“SMagent” on page 75| for instructions.

Install the SMutil on node A. See f‘SMutiI software” on page 7§| for instructions.

Shut down node A.
Restart node B.

From node B, uninstall the components from the previous version of the
storage management software. To uninstall the storage management software
for Storage Manager Version 7.x, 8.0 or 8.2x, see r‘UninstaIIing storage|
[management software components” on page 122

12. Verify that the IBM host adapter device driver versions are current. If they are
not current, refer to the readme file located in the \Host Adapter directory on
the installation CD and upgrade the device driver versions before you continue.

13. Install the SMclient on node B. See [Installing the SMclient” on page 70| for
instructions.

oo 0N o
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14. Install the RDAC on node B. See ['RDAC” on page 72| for instructions.

15. Install the SMagent on node B. See[‘SMagent” on page 75 for instructions.

16. Install the SMutil on node B. See [‘SMutil software” on page 77| for instructions.
17. Shut down node B.

18. Start up one node at a time and complete the following procedure:

a. Click Start » Programs » Administrative Tools » Services. The Services
window opens.

b. From the list of displayed services, right-click the cluster server. Click
Automatic to change the cluster server startup option.

c. Start the cluster server service on node B.
19. Go to|Chapter 8, “Completing Storage Manager 8.4 installation,” on page 103

Windows Server 2003

To perform a scheduled upgrade from Storage Manager Version 7.xx, 8.0, or 8.2x to
Storage Manager 8.4 on machines that are running Windows Server 2003, perform
the following procedure:

1. Before you install the storage management software, perform the following
steps in each of the cluster nodes in the cluster:
a. Click Start » Administrative Tools » Services. The Services window
opens.
b. From the list of displayed services, right-click the cluster server. Then click
Manual.
c. Stop the cluster server on all nodes in the cluster configuration.

2. From each cluster node, uninstall the components from the previous version of
the storage management software. See [‘Uninstalling storage management
[software components” on page 122|for instructions.

Note: Uninstall the storage management components in the following order:

a. SMagent
b. SMutil
c. RDAC
d. SMclient

3. Verify that the IBM host adapter device driver version in each cluster node is
current. If they are not current, refer to the readme file located in the
\Host_Adapter directory on the installation CD and upgrade the device drivers.

4. Install the new version of the Storage Manager software in each cluster node.
See [‘Installing the storage management software” on page 69| for instructions.

5. Start up one node at a time and complete the following steps for each node:

a. Click Start » Administrative Tools » Services. The Services window
opens.

b. From the list of displayed services, right-click the cluster server. Click
Automatic to change the cluster server startup option.

c. Manually start the cluster server service.

6. Open Cluster Administrator windows and verify that the cluster groups can be
brought online. If not, contact your IBM service representative for support.

Performing a rolling upgrade

This section describes how to perform a rolling upgrade on Windows operating
systems.
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Important: If you have applications installed in the cluster server environment that
do not support a rolling upgrade, perform one of the following tasks:

» Put those resources offline before the upgrade; then, put them back online after
the upgrade.

» Perform a scheduled upgrade. A scheduled upgrade requires scheduling
downtime on your cluster server to upgrade the controller firmware and storage
management software.

Windows NT 4.0 and Windows 2000

To perform a rolling upgrade from Storage Manager Version 7.xx, 8.0, or 8.2x to
Storage Manager 8.4 on machines that are running Windows NT 4.0 and Windows
2000, perform the following steps:

1. From node A, open Cluster Administrator.

2. Double-click the Active Groups folder in the right pane of the Cluster
Administrator window.

3. Select each group listed and move them to node B.

4. Select node A. Then click File » Pause Node to pause cluster service in node
A

5. From node A, uninstall the components from the previous version of the
software. To uninstall the software for Storage Manager Version 7.x, 8.0, or
8.2, see [‘Uninstalling storage management software components” on page|

|1 22.|

Note: Uninstall the components in the following order:

a. SMagent
b. SMutil
c. RDAC
d. SMclient

6. Verify that the IBM host adapter device driver versions are current. If they are
not current, refer to the readme file located in the \Host_Adapter directory on
the installation CD and upgrade the device drivers.

7. Install the SMclient on node A. See [‘Installing the SMclient” on page 70| for
instructions.

8. Install the RDAC on node A. See [‘RDAC” on page 72 for instructions.
9. Install the SMagent on node A. See ['SMagent” on page 75| for instructions.
10. Install the SMutil on node A. See [‘'SMutil software” on page 77| for instructions.
11. Run Cluster Administrator. Then click File * Resume Node to resume cluster
service in node A.
12. From node B, open Cluster Administrator.

13. Double-click the Active Groups folder in the right pane of the Cluster
Administrator window.

14. Select each group listed and move them to node A.

15. Select node B. Then click File » Pause Node to pause cluster service in node
B.

16. From node B, uninstall the components from the previous version of the
software. To uninstall the storage management software for Storage Manager
Version 7.x, 8.0, or 8.2x, see|“UninstaIIing storage management software|
fcomponents” on page 122
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17. Verify that the IBM HBA device driver versions are current. If they are not
current, see the readme file located in the \Host_Adapter directory on the
installation CD and upgrade the device drivers.

18. Install the SMclient on node B. See [Installing the SMclient” on page 70| for
instructions.

19. Install the RDAC on node B. See 'RDAC” on page 72| for instructions.
20. Install the SMagent on node B. See |“SMagent” on page 7§| for instructions.

21. Install the SMutil on node B. See |“SMutiI software” on page 77| for instructions.

22. Run Cluster Administrator. Then click File » Resume Node to resume cluster
service in node B.

23. Goto |Chapter 8, “Completing Storage Manager 8.4 installation,” on page 103.|

Windows Server 2003

To perform a rolling upgrade from Storage Manager Version 7.xx, 8.0, or 8.2x to
Storage Manager 8.4 on machines that are running Windows Server 2003, perform
the following steps:

1. In the first node of the cluster, open the Cluster Administrator window.

2. Double-click the Active Groups folder in the right pane of the Cluster
Administrator window.

3. Select each of the active groups listed in the first cluster node and move them
to other nodes in the cluster configuration. Make sure that the cluster groups
come online successfully.

4. Select the first node of the cluster in the Cluster Node Tree view and click File
+» Pause Node to pause cluster service in that node.

5. From node A, uninstall the components from the previous version of the
software. To uninstall the previous version of Storage Manager software, see
[‘Uninstalling storage management software components” on page 122

Note: Uninstall the components in the following order:

a. SMagent
b. SMutil
c. RDAC
d. SMclient

6. Verify that the IBM HBA device driver versions in the cluster node are current.
If they are not current, refer to the readme file located in the \Host_Adapter
directory on the installation CD and upgrade the device drivers.

7. Install the new version of the Storage Manager software in the first cluster
node. See [‘Installing the storage management software” on page 69| for
instructions.

8. In the Cluster Administrator window, select the first node of the cluster and
click File » Resume Node to resume cluster service in first cluster node.

9. Move all cluster groups that were active in the first cluster node back to it.
Make sure that the cluster groups can be brought online in the first cluster
node with no problems.

10. Repeat stepsthrough|§|f0r each of the other nodes in the cluster
configuration. Perform all steps for each cluster node, one cluster node at a
time.
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Upgrading Windows operating systems

The following sections describe how to upgrade from one Windows operating
systems to another.

Note: Upgrading from Windows NT 4.0 to Windows Server 2003 in a cluster
configuration is not supported. You have to either perform a new installation
of the Windows Server 2003 or upgrade to Windows 2000 first and then
upgrade to Windows Server 2003. Always perform a full system backup
before you perform any upgrade procedure.

Upgrading from Windows NT 4.0 to Windows 2000 in a standard
configuration

If you have an existing storage subsystem running Windows NT 4.0, you can
upgrade to Windows 2000 if the following conditions apply:

* Your storage subsystem is not the startup (boot) device.
* Your controllers are running firmware versions 04.00.00.00 or higher.

Attention: To avoid possible data loss, you must uninstall any previous versions of
the storage management software (see [‘Uninstalling storage management software]
fcomponents” on page 122) before you upgrade your operating system. All storage
management configuration information is deleted during the uninstallation process.
A complete reinstallation of the storage management software is required.

To upgrade from Windows NT 4.0 to Windows 2000, perform the following steps:

1. Verify that the storage subsystem contains no system-dependent files or
directories, such as paging files.

2. Uninstall Storage Manager. See [‘Uninstalling storage management software]
[components” on page 122

3. Use the instructions from Microsoft to upgrade to Windows 2000.

4. Reinstall Storage Manager. Either see the instructions in [‘Installing SMclient” on|

or the procedure that came with the version of the storage
management software you are currently running.

Upgrading from Windows NT 4.0 to Windows 2000 in a cluster
configuration
To ensure that the services and resources offered by the cluster are always
available, you must perform a rolling upgrade. A rolling upgrade requires upgrading

the controller firmware, storage management software, and operating system first in
node A and then in node B.

Important: If you have applications installed in the cluster server environment that
do not support a rolling upgrade, perform one of the following tasks:

» Put those resources offline before the upgrade; then, put them back online after
the upgrade.

» Perform a scheduled upgrade. A scheduled upgrade requires scheduling
downtime on your cluster server to upgrade the controller firmware and storage
management software.

To upgrade from Windows NT 4.0 Enterprise Edition to Windows 2000 Advanced
Server, perform the following steps:

1. On node A, open Cluster Administrator.
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10.
11.
12.
13.

14.
15.
16.
17.

18.

19.

Double-click the Active Groups folder in the right pane of Cluster Administrator.
Make sure that all of the groups failover to node B successfully.

Select node A. Then click File » Pause Node to pause cluster service in node
A.

From node A, uninstall all software components. To uninstall the software, see
[‘Uninstalling storage management software components” on page 122]
Uninstall the components in the following order:

a. SMagent
b. SMutil
c. RDAC
d. SMclient

Follow the instructions from Microsoft to upgrade node A from Windows NT 4.0
Enterprise Edition to Windows 2000 Advanced Server.

Note: During the upgrade, the existing cluster server installation is detected
and clustering for Windows 2000 Advanced Server is installed. When
the upgrade is complete, node A will rejoin the cluster and remain
paused.

Verify that the host bus adapter (HBA) device driver versions are correct. If
they are not the certified versions, refer to the readme file in the \Host_Adapter
directory on the installation CD and upgrade the device driver versions before
you continue.

Verify that node A was successfully upgraded to Windows 2000 Advanced
Server.

Install the SMclient on node A. See [‘Installing the SMclient” on page 70| for
instructions.

Install the RDAC on node A. See['RDAC” on page 72| for instructions.
Install the SMagent on node A. See [‘SMagent” on page 75| for instructions.
Install the SMutil on node A. See ['SMutil software” on page 77| for instructions.

Run Cluster Administrator. Then click File » Resume Node to resume cluster
service in node A.

On node B, open Cluster Administrator.
Double-click the Active Groups folder in the right pane of Cluster Administrator.
Make sure that all of the groups failover to node A successfully.

Select node B. Then click File » Pause Node to pause cluster service in node
B.

From node B, uninstall all software components. To uninstall the software, see
[‘Uninstalling storage management software components” on page 122
Uninstall the components in the following order:

a. SMagent
b. SMutil
c. RDAC
d. SMclient

Follow the instructions from Microsoft to upgrade node B from Windows NT 4.0
Enterprise Edition to Windows 2000 Advanced Server.

Note: During the upgrade, the existing cluster server installation is detected
and clustering for Windows 2000 Advanced Server is installed. When
the upgrade is complete, node B will rejoin the cluster and remain
paused.
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20. Verify that the HBA device driver versions are correct. If they are not the
certified versions, see the readme file in the \Host_Adapter directory on the
installation CD and upgrade the device driver versions before you continue.

21. Verify that node B was successfully upgraded to Windows 2000 Advanced
Server.

22. Install the SMclient on node B. See ['Installing the SMclient” on page 70|for
instructions.

23. Install the RDAC on node B. See |“RDAC” on page 72| for instructions.
24. Install the SMagent on node B. See |“SMagent” on page 7§| for instructions.
25. Install the SMutil on node B. See [‘SMutil software” on page 77| for instructions.

26. Run Cluster Administrator. Then click File » Resume Node to resume cluster
service in node B.

27. Go to|Chapter 8, “Completing Storage Manager 8.4 installation,” on page 103

Upgrading from Windows NT 4.0 or Windows 2000 to Windows Server
2003 in a standard configuration

If you have an existing storage subsystem running Windows NT 4.0 or Windows
2000, you can upgrade to Windows Server 20083 if the following conditions apply:

* Your storage subsystem is not the startup (boot) device.
* Your controllers are running firmware versions 04.00.00.00 or higher.

* Your other installed application software can be upgraded and the versions are at
the upgradable version.

Attention: To avoid possible data loss, you must uninstall any previous versions
of the storage management software (see [‘Uninstalling storage management]

lsoftware components” on page 122) before you upgrade your operating system. All
storage management configuration information is deleted during the un-installation
process. A complete reinstallation of the storage management software is required.

To upgrade from Windows NT 4.0 or Windows 2000 to Windows Server 2003 in a
standard (non-cluster) configuration, perform the following steps:

1. Verify that the storage subsystem contains no system-dependent files or
directories, such as paging files.

2. Uninstall the Storage Manager software. See [‘Uninstalling storage management|
[software components” on page 122.|

Use the instructions from Microsoft to upgrade to Windows Server 2003.

Reinstall Storage Manager. Either see the instructions in [‘Installing the storage
[management software” on page 69 or the procedure that came with the version
of the storage management software that you are currently running.

5. Go to [Chapter 8, “Completing Storage Manager 8.4 installation,” on page 103]
Make sure that the host type of the host or default host group is “Windows
2000/Server 2003 non-clustered”.

w

»

Upgrading from Windows 2000 to Windows Server 2003 in a cluster
configuration

Note: Upgrading from Windows NT 4.0 to Windows Server 2003 in a cluster
configuration is not supported. You have to either perform a new installation
of the Windows Server 2003 or upgrade to Windows 2000 first and then
upgrade to Windows Server 2003. Always perform a full system backup
before you perform any upgrade procedure.
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Important: If you have applications that are installed in the cluster server
environment that do not support a rolling upgrade, perform one of the following
tasks:

Put those applications offline before the upgrade. Then put them back online
after the upgrade.

Perform a scheduled upgrade. A scheduled upgrade requires scheduling
downtime on your cluster server to upgrade the controller firmware and storage
management software.

To upgrade from Windows 2000 Advanced Server to Windows Server 2003
Enterprise Edition, perform the following steps:

1.
2.
3.

10.

1.
12.
13.
14.
15.
16.

On node A, open the Cluster Administrator window.
Double-click the Active Groups folder in the right pane of Cluster Administrator.

Move all active cluster groups in node A to node B. Make sure that the cluster
groups come online successfully in node B.

Select node A. Click File » Pause Node to pause cluster service in node A.

From node A, uninstall all software components. To uninstall the software, see
[‘Uninstalling storage management software components” on page 122
Uninstall the components in the following order:

a. SMagent
b. SMutil
c. RDAC
d. SMclient

Follow the instructions from Microsoft to upgrade node A from Windows 2000
Advanced Server to Windows Server 2003 Enterprise Edition.

Note: During the upgrade, the existing cluster server installation is detected
and clustering for Windows 2000 Advanced Server is installed. When
the upgrade is complete, node A rejoins the cluster and remain paused.

Verify that the HBA device driver versions are correct. If they are not the
certified versions, refer to the readme file in the \Host Adapter directory on the
installation CD and upgrade the device driver versions before you continue.

Verify that node A was successfully upgraded to Windows Server 2003
Enterprise Edition.

Install the Storage Management software in node A. See [‘Installing the storage]
[management software” on page 69

In the Cluster Administrator window, select node A and click File » Resume
Node to resume cluster service in node A.

Move the cluster groups that were active in node A back to node A.

On node B, open the Cluster Administrator window.

Double-click the Active Groups folder in the right pane of Cluster Administrator.
Make sure that all cluster groups failover to node A successfully.

Select node B. Click File » Pause Node to pause cluster service in node B.

From node B, uninstall all software components. To uninstall the software, see
|“Uninstal|ing storage management software components” on page 122.|
Uninstall the components in the following order:

a. SMagent
b. SMutil
c. RDAC
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17.

18.

19.

20.

21.

22.

23.

d. SMclient

Follow the instructions from Microsoft to upgrade node B from Windows 2000
Advanced Server to Windows Server 2003 Enterprise Edition.

Note: During the upgrade, the existing cluster server installation is detected
and clustering for Windows 2000 Advanced Server is installed. When
the upgrade is complete, node B rejoins the cluster and remain paused.

Verify that the HBA device driver versions are correct. If they are not the
certified versions, refer to the readme file in the \Host Adapter directory on the
installation CD and upgrade the device driver versions before you continue.

Verify that node B was successfully upgraded to Windows Server 2003
Enterprise Edition.

Install the Storage Management software in node B. See [‘Installing the storage]
|management software” on page 69| for instructions.
In the Cluster Administrator window, select node B and click File » Resume
Node to resume cluster service in node B.

In the Cluster Administrator window, move the cluster groups that were active
in node B back to node B. Make sure that they come online with no problems.

If there are more than two nodes in a cluster, repeat steps|{12 on page 87
through for each of the remaining nodes in a cluster, one cluster node at a
time.

Additional information

For additional information about installing and using Storage Manager 8.4 in a
Windows cluster server configuration, see|Appendix A, “Windows operating system|

limitations,” on page 127.]
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Chapter 5. Installing Storage Manager software in a standard
NetWare configuration

This chapter describes how to install the storage management software in standard
(noncluster) and cluster server configurations in the NetWare 6.0 operating system
environment.

If you have existing storage systems, read [‘Installation types” on page 15 and
[‘Storage subsystem management methods” on page 8.

To ensure proper installation, complete all preparation tasks described in
fand preparing for NetWare installation” on page 32|

Important: Always check for a readme file on any installation media. A readme file
might contain important information that was not available when this document was
prepared.

Installation overview

You must install Storage Manager 8.4 software components on both management
stations and host computers.

shows the installation sequence for Storage Manager software
components.

Table 17. Software component installation sequence in a Novell NetWare 6.0 environment

System type Software installation sequence

Management station | Storage Manager 8.4 Client (SMclient)

Host computer and |1 gtorage Manager 8.4 Client (SMclient)
cluster node . . . . .
This optional component is necessary if you intend to manage the

storage subsystem from a host computer.
2. Storage Manager 8.4 Agent (SMagent)

This optional component is necessary if you intend to use the
host-agent management method.

3. Storage Manager 8.4 Utility (SMutil)

This required component contains the hot_add, SMdevices, and
SMflashcopyassist utilities.

4. LSIMPE.cdm driver
5. IBM Host Adapter device driver (QL2x00)

Important: Be sure that you install the host bus adapter before you install the
storage management software.

To install the storage management software in a NetWare 6.0 operating system
environment, you must install the software on each host computer in the following
order:

1. Storage Manager 8.4 Client
2. Storage Manager 8.4 Agent
3. Storage Manager 8.4 Utility
4. LSIMPE.cdm driver
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5. IBM Host Adapter (HA) device driver
6. NetWare Agent component of IBM FAStT Management Suite Java (FAStT MSJ)

Storage Manager 8.4 Client

This section provides instructions for installing Storage Manager 8.4 Client on
management stations and host computers.

Before you install the software, make sure that:

* The management station or host computer has at least 60 MB of available disk
space.

» All programs are closed.

* The HBA is installed.

Important: When you install Storage Manager 8.4 Client on a stand-alone host and
manage storage subsystems through the fibre-channel I/O path rather than through
the network, you must install the TCP/IP software on the host and assign an IP
address to the host.

Installing Storage Manager 8.4 Client (SMclient)

Perform the following steps to install SMclient:

1. Insert the IBM FASIT Storage Manager installation CD into the CD-ROM drive
and type the following command:

load cdrom
Mount the volume.
Click Novell » Install.
Click Add and follow the instructions on the screen.
Click the Directory Tree button.
The Directory Tree window opens.
Select the CD-ROM volume.
Select the \NetWare\SMcTient folder.
Select the program.ni file, and then click OK.
Click OK.
After the files are copied, the License Agreement window opens.
10. Click Accept to continue.
The Copying Files message window opens.
11. When the installation is complete, click Finish.

ok~ wDpd
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Verifying the Storage Manager 8.4 Client installation

Perform the following steps to verify that SMclient 8.4 installed correcily:
1. Click Novell » Programs.

2. Verify that the IBM FAStT Fibre Channel Storage Manager Client displays in the
list of programs.
If the program is not listed, repeat [‘Installing Storage Manager 8.4 Client
(SMclient).] If the IBM FAStT Storage Manager Client still does not display, a
failure has occurred. Contact your IBM technical support representative.

3. If you are installing Storage Manager 8.4 Client on a host computer, go to
“Storage Manager 8.4 Agent” on page 91.|Otherwise, go to |Chapter 8,|

“Completing Storage Manager 8.4 installation,” on page 103/
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Storage Manager 8.4 Agent

Install the Storage Manager 8.4 Agent software if you want to manage the storage
subsystem using the host-agent management method.

Before you install the software, ensure that the following conditions are met:

» The host computer is configured with Novell NetWare 6.0 and Service Pack 2.
* You have Administrator privileges on the host computer.

* The host computer has at least 20 MB of available disk space.

Installing Storage Manager 8.4 Agent (SMagent)
Perform the following steps to install SMagent:
1. Close all other programs.

2. Insert the IBM FASLT Storage Manager installation CD into the CD-ROM drive
and type the following command:

load cdrom
Mount the CD volume.
Click Novell ~» Install.
Click Add, and follow the instructions on the screen.
Click the Directory Tree button.
The Directory Tree window opens.
Select the CD-ROM volume.
Select the \NetWare\SMagent directory.
9. Select the product.ini file, and then click OK.
10. Click OK.
After the files are copied, the License Agreement window opens.
11. Click Accept to continue.
The files are copied.
12. When the installation is complete, click Finish.

ook w
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Note: Make an autoexec.ncf entry to enable SMagent when you start the
server.

Verifying the Storage Manager 8.4 Agent installation
Perform the following steps to verify that the SMagent installed correctly:
1. Toggle to the Server Console window and at the command prompt, type:
SMagent

The agent starts and displays the following message when UTM LUNs are
being scanned:

Activating
2. Continue with ['Storage Manager 8.4 Utility.]

Storage Manager 8.4 Utility

This section provides instruction for installing Storage Manager 8.4 Utility software
on host computers. This component contains utilities that register and map new
logical drives to the operating systems.
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Important: Make sure that you have installed the IBM FAStT MSJ QLRemote agent
on the same host where you are installing the Storage Manager 8.4 Utility software.
For more information, see [‘Installing IBM FAStT Management Suite Java” on page|

Installing Storage Manager 8.4 Utility (SMutil)

Perform the following steps to install SMutil:
1. Close all programs.

2. Insert the IBM FASLT Storage Manager installation CD into the CD-ROM drive
and type the following command:

load cdrom

3. Mount the CD volume.
4. Click Novell » Install.
5. Click Add and follow the instructions on the screen.
6. Click the Directory Tree button.
The Directory Tree window opens.
7. Select the CD-ROM drive.
8. Click the \NetWare\SMutil folder, and then, click Open.

9. Select the product.ni file, and then, click Open.
The Welcome window opens.
10. Click Next to begin the installation.

After you install the Storage Manager 8.4 Utility software, the Operation
Complete window opens. If the system detects the installation of another
version of Storage Manager 8.4 Utility, a window opens indicating that the
installation will be updated and your personal configuration files will be saved.
Click Yes to continue.

11. Click Finish.

Verifying the Storage Manager 8.4 Utility installation
Perform the following steps to verify that SMutil installed correctly:
1. Go to the following directory:

sys:system

2. Verify that the directory contains the following files:
* hot_add.ncf
* SMdevices.ncf

If it does not, reinstall the Storage Manager 8.4 Utility using the procedure in
[“Installing Storage Manager 8.4 Utility (SMutil).”|

Installing the LSIMPE driver

The LSIMPE.CDM driver is used in a Novell NetWare environment to provide multipath
I/0O support to the storage server. The LSIMPE.CDM driver is a custom driver module
that is installed with the IBM FAStT Host Adapter driver. In case of a failure along
the 1/0 path, the driver sends the I/O requests through the alternate path and
Auto-Volume Transfer (AVT) moves the logical drive within the FAStT Storage
Server.

For the current readme file, LSIMPE.CDM driver, and installation instructions, go to the
following Web site:
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www-1.ibm.com/servers/storage/support/fastt/index.html|

Continue with [Installing the IBM fibre-channel host bus adapter device driver.’]

Installing the IBM fibre-channel host bus adapter device driver

An IBM fibre-channel host bus adapter (HBA) provides the interface between a host
server and a FAStT storage server. IBM FASHT fibre-channel HBAs are
high-performance, direct memory access, bus-master, host adapters that are
designed for high-end systems. These HBAs support all fibre-channel peripheral
devices that support private-loop direct-attach and fabric-loop attachment. The IBM
Host Adapter device driver enables your operating system to communicate with the
fibre-channel HBA. See the readme file included in the driver package for
installation instructions associated with your operating system. For more
information, see the Installation and User’'s Guide for your particular fibre-channel
HBA model. The current readme file and latest multipath 1/O device driver are
available at the following Web site:

www-1.ibm.com/servers/storage/support/fastt/index.html|

Continue with [‘Installing IBM FAStT Management Suite Java.”|

Installing IBM FAStT Management Suite Java

For information about installing and using this software, see the IBM FAStT MSJ
User’s Guide or online Help.

Additional information

For additional information about installing and using Storage Manager 8.4 in a
NetWare configuration, see|Appendix B, “NetWare operating system limitations,” on|
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Chapter 6. Installing Storage Manager software in a Linux
configuration

This chapter describes how to install the storage management software in a Linux
operating system environment.

If you have existing storage systems, make sure that you have read [Installation]
types” on page 15| and[‘Managing coexisting storage subsystems” on page 20

To ensure proper installation, make sure you have completed all preparation tasks
described in|Chapter 2, “Preparing for installation,” on page 31|

Important: Always check for a readme file on any installation media. This readme
file might contain important information made available only after completion of this
document.

Installation overview
Important: Be sure that you install the HBA and device driver before you install the
storage management software.

Linux software requirements
lists the disk space that is required for installing Storage Manager 8.4 in a
Linux environment.
Note: The SMclient and SMagent software packages are not available for all 64-bit
Linux kernels.

Table 18. Installation requirements for Linux by software package

Package Disk space requirement
Storage Manager 8.4 Client (SMclient) 15 MB on /opt, 2 MB on /tmp
IBM FAStT Management Suite Java (FAStT MSJ) 35 MB

Storage Manager 8.4 Utility (SMutil) 7 MB on /opt

IBM Host Adapter device driver 1 MB

Storage Manager 8.4 runtime (SMruntime) 42 MB on /opt, 1 MB on /var

Linux operating system requirements

describes the minimum operating system and kernel level requirements for
each management station or host computer. See the readme file for the latest
information regarding supported kernel versions.

Table 19. Management station or host computer by minimum operating system and kernel

level

Operating system Kernel
Red Hat Enterprise Linux AS 2.1 2.4.9-e.27
SuSE Linux Enterprise Server Version 8 (SLES 8) 2.4.21

To begin installing the storage management software, ensure that the network
components are set up and operating properly, and that you have all the host and
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controller information that you need for the software to operate. Be sure to install
the software on the management stations as well as the attached host computers.

You must install the software on each host computer in the following order:
Uninstall the earlier version Storage Manager.

Install Storage Manager 8.4 Runtime.

Install Storage Manager Client 8.4 Client.

Disable and enable the Event Monitor.

Install Storage Manager 8.4 Utility.

Uninstall existing IBM FAStT Management Suite Java (use this procedure when
installing Storage Manager 8.4 on an existing storage subsystem).

Install IBM FAStT Management Suite Java.
Install the IBM Host Adapter (HA) device driver (q1a2200.0 or g1a2300.0).

ook wn =
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Uninstalling Storage Manager

Perform the following steps to uninstall an earlier version of Storage Manager.

Note: You do not need to restart your host computer after removing a software
component. During the software removal process, the host keeps existing
storage subsystem mappings and storage partition configurations, which the
new client software will recognize.

1. Be sure that you have root privileges, which are required to uninstall Storage
Manager.

2. To begin uninstalling Storage Manager, type the following command:
rpm -qa|grep SM

3. Press Enter. The SM packages are listed.

4. At the prompt, type the following command and press Enter:
rpm -e component-name

where component-name is the name of the storage management software
package that you want to uninstall. The system prompt displays when the
software removal completes.

5. Verify that the removal was successful. At the system prompt, type the following
command and press Enter:
rpm -qi component-name
where component-name is the name of the storage management software
package that you want to uninstall. If the uninstallation process was successful,
the host displays a message indicating that the software is not installed.

6. Repeat step@ through stepto remove each Storage Manager component and
associated directory.

7. Click Completed in the Installation Activity panel.
8. Select one of the following options:

* If you are installing IBM FAStT Storage Manager Version 8.4 on a
management station or a host computer, proceed to|“Installing the 8.4|
[software” on page 97

« If you remove the storage management software and do not plan to reinstall

the software on a management station or host computer, you have
successfully completed all procedures.
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Installing the 8.4 software

Use the procedures in this section to install the Storage Manager on a management
station or host computer.

Installing Storage Manager 8.4 Runtime (SMruntime)

Perform the following steps to install SMruntime:

1. Close all open programs.

2. Insert the IBM FASLT Storage Manager Version 8.4 CD into the CD-ROM drive.

3. To mount the CD-ROM, type the following command and press Enter:
mount /mnt/cdrom

4. Type the following command and press Enter:
cd /mnt/cdrom/1inux

5. Type the following command:
rpm -ivh SMruntime

6. Press Tab; then, press Enter.

Verifying the Storage Manager 8.4 Runtime installation
Perform the following steps to verify that the installation was successful:
1. At the system prompt, type the following command and press Enter:
rpm -qi SMRuntime
The verification process displays a message that describes the SMruntime

software, including version numbers, copyright license, installation time, and
general software package description.

If no failure is reported, go to step If the verification reports a failure, repeat
steps through |}§2| of the installation procedure.

2. Continue with [Installing the Storage Manager 8.4 Client (SMclient).”|

Installing the Storage Manager 8.4 Client (SMclient)

Perform the following steps to install the SMclient:

1. Close all open programs.

2. Insert the IBM FASLT Storage Manager Version 8.4 CD into the CD-ROM drive.

3. To mount the CD-ROM, type the following command and press Enter:
mount /mnt/cdrom

4. Type the following command and press Enter:
cd /mnt/cdrom/1inux

5. Type the following command:
rpm -ivh SMclient

6. Press Tab; then, press Enter.

Verifying the Storage Manager 8.4 Client installation
Perform the following steps to verify that the installation was successful:
1. At the system prompt, type the following command and press Enter:
rpm -qi SMclient

The verification process displays a message that describes the SMclient
software, including version numbers, copyright license, installation time, and
general software package description.
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If no failure is reported, go to step If the verification reports a failure, repeat
step 1 through step 6 of the installation procedure.

2. Continue the installation with [‘Installing IBM FAStT Management Suite Java” on|
if you are installing a new storage subsystem. If you are installing the
storage management software on an existing storage subsystem, continue with
[Disabling and enabling the Event Monitor.]

Disabling and enabling the Event Monitor

The Event Monitor, which comes with the client software, installs automatically
during the client software installation. The Event Monitor handles storage
subsystem error notification through e-mail or SNMP traps when the storage
management software is not actively running on the management station or host
computer.

Important: If you installed the client software on multiple hosts, you might receive
duplicate error messages from the same storage subsystem. To avoid receiving
duplicate error messages, disable the Event Monitor on all but one system. You
must run the Event Monitor on one host that will run continually.

To disable the Event Monitor, type the following command and press Enter:
/etc/rc.d/init.d/SMmonitor stop

To enable the Event Monitor, type the following command and press Enter:

/etc/rc.d/init.d/SMmonitor start

Installing the Storage Manager 8.4 Utility (SMutil)

Perform the following steps to install the SMutil:
1. Close all open programs.
2. Insert the IBM FASLT Storage Manager Version 8.4 CD into the CD-ROM drive.
3. To mount the CD-ROM, type the following command and press Enter:
mount /mnt/cdrom
4. Type the following command and press Enter:
cd /mnt/cdrom/1inux
5. Type the following command:
rpm -ivh SMutil
6. Press Tab; then, press Enter.

Verifying the Storage Manager 8.4 Utility installation

Perform the following steps to verify that the installation was successful:
1. At the system prompt, type the following command and press Enter:
rpm -qi SMutility

The verification process displays a message that describes the SMutility
software.

If no failure is reported, go to step If the verification reports a failure, repeat
steps 1 through 6 of the installation procedure.

2. Continue with r‘UninstaIIing IBM FASIT Management Suite Java” on page 99.|
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Uninstalling IBM FAStT Management Suite Java

If you are installing Storage Manager 8.4 in an environment with existing storage
subsystems, you need to uninstall older versions of IBM FAStT Management Suite
Java (MSJ) and then install the version of IBM FAStT MSJ that came on the IBM
FASIT Storage Manager Version 8.4 CD.

Perform the following steps to uninstall FAStT MSJ:

1. From a system prompt, type the following command:
/usr/FAStT_MSJ Uninstaller

2. Press Tab; then, press Enter.

Installing IBM FAStT Management Suite Java

The IBM FASIT MSJ software includes the FASTT GUI device driver that is required
for failover support. You can use the GUI to configure logical drives, storage, and
failover.

Note: For additional information, see the online help.

Perform the following steps to install IBM FAStT MSJ:
1. Insert the IBM FAStT Storage Manager Version 8.4 CD into the CD-ROM drive.
2. From the X-windows GUI, open a command window.
3. Type the following command and press Enter:
cd /mnt/cdrom/FAStT_MSJ/1inux
4. To run the installer for FAStT MSJ, type the following command at a system
prompt:
sh FAStT
Press Tab; then, press Enter. The Introduction window opens.
Click Next.
Restart your Linux server.
Continue with [Installing the IBM fibre-channel host bus adapter device driver.”|
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For additional configuration information, see the IBM FAStT MSJ User’s Guide.

Installing the IBM fibre-channel host bus adapter device driver

An IBM fibre-channel host bus adapter (HBA) provides the interface between a host
server and a FASLT storage server. IBM FASLT fibre-channel HBAs are
high-performance, direct memory access, bus-master, host adapters designed for
high-end systems. These HBAs support all fibre-channel peripheral devices that
support private-loop direct-attach and fabric-loop attachment. The IBM Host Adapter
device driver enables your operating system to communicate with the fibre-channel
HBA. See the readme file included in the driver package for installation instructions
associated with your operating system. For more information, see the Installation
and User’s Guide for your particular fibre-channel HBA model. The current readme
file and latest multipath I/O device driver are available for download at the following
Web site:

www-1.ibm.com/servers/storage/support/fastt/index.html|
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Additional information

For additional information about installing and using Storage Manager 8.4 in a Linux
configuration, see |Appendix C, “Linux operating system limitations,” on page 135.|
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Chapter 7. Installing Storage Manager software in a VMware
ESX Server configuration

Install Storage Manager 8.4 on a management workstation separate from that
running VMware ESX Server 2.0, preferably on the workstation from which you
manage the VMware ESX Server 2.0 . Do not install Storage Manager 8.4 on a
server running VMware ESX Server 2.0. Your management station should be using
either a Windows or Linux operating system. For instructions associated with your
particular platform, see [Chapter 3, “Installing Storage Manager software in al
standard Windows configuration,” on page 55| or [Chapter 6, “Installing Storage|
Manager software in a Linux configuration,” on page 95.|

shows a sample VMware ESX Server configuration.

Ethernet

Management station ESX server

<4——Fibre-channel
1/0 path

Ethernet —»

Controller

‘ Controller ‘

Storage subsystems

$J001150

Figure 18. Sample VMware ESX Server configuration

Software requirements
Software requirements for FAStT Storage Manager 8.4 running VMware ESX
Server 2.0 are detailed in this section.

Management station
The following software is required for the management station:
1. SM Runtime (Linux only)
2. SMclient

Note: The mapping storage partition host type for VMware is Linux.
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Host (ESX Server)

The following software is required for the ESX Server:

1. No Storage Manager software

2. VMware-supplied driver for the fibre-channel HBAs

3. QLogic driver failover setup (in VMware ESX Server 2.0)

Note: For the VMware ESX Server 2.0 Administration Guide and additional
related information, see the |VMware support Web site| at:

[www.vmware.com/support/esx2/

For more information about installing VMware ESX Server 2.0 on an IBM server,
see the IBM support Web site at:

www.ibm.com/pc/us/compat/nos/matrix.shtml|

Hardware requirements

For information about the hardware that is supported with VMware ESX Server 2.0,
see the IBM support Web site at:

www.ibm.com/storage/disk/fastt/supserver.htm|

Additional information

For additional information about installing and using Storage Manager 8.4 in a
VMware configuration, see |[Appendix D, “VMware ESX Server operating system|
limitations,” on page 137.]
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Chapter 8. Completing Storage Manager 8.4 installation

This chapter contains procedures on how to use Enterprise Management and
Subsystem Management to complete Storage Manager 8.4 installation tasks for
Windows, NetWare, and Linux operating system environments.

Completing the installation

To complete a Storage Manager 8.4 installation, perform the following tasks:
1. Install SANavigator, if you choose.

Perform an initial automatic discovery of storage subsystems.

Add devices, if necessary.

Set up alert notifications, if you want.

Name the storage subsystems.

Download firmware and NVSRAM.

Create arrays and logical drives.

Verify and define the default host type.
9. Configure the heterogeneous hosts.

10. Perform other storage subsystem tasks.
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Each of these steps is discussed in detail in the sections that follow.

The Enterprise Management window opens when you start the FAStT Storage
Manager. Use the Enterprise Management window to:

» Add and discover the storage subsystems.
* View all storage subsystems in your management domain.
» Perform batch storage subsystem management tasks using the Script Editor.

Introduction to SANavigator

This section provides an overview of the functions of SANavigator. SANavigator is
an application that enables you to easily monitor and manage your storage area
network (SAN). It is a powerful diagnostic tool that detects SAN failures and
displays them in a graphical manner. When you use SANavigator with the problem
determination maps found in the FAStT Hardware Maintenance Manual and
Problem Determination Guide, you can detect and diagnose SAN malfunctions
easily. Install SANavigator after you install the IBM FAStT Storage Manager and the
FAStT Management Suite Java (FAStT MSJ).

SANavigator features

SANavigator enables you to easily monitor and manage your SAN through the
following features:

* Discovery

SANavigator uses TCP/IP (out-of-band) and Fibre Channel (in-band) to establish
contact with a large number of SAN devices, gather embedded information, and
then depict it graphically. SANavigator discovers the devices that are attached to
your SAN. It then presents a visual map of devices and their interconnections to
enable you to identify any problem components in the map.

* Monitoring

© Copyright IBM Corp. 2004 103



SANavigator generates events and messages about the status of devices and
their respective properties. The self-monitoring event logging and messaging
feature enables you to stay informed about the current state of the SAN.

* Launching device applications and utilities

You can launch applications and utilities such as IBM FAStT Storage Manager
and IBM FAStT MSJ from SANavigator by right-clicking the respective devices. A
pop-up menu displays that allows you to select the applications and link to the
IBM Fibre Channel Solution Support Web site at:

www.ibm.com/pc/support/
* Reporting
SANavigator enables you to generate, view, and print reports.

To learn more about the features of SANavigator, see the FAStT Hardware
Maintenance Manual and Problem Determination Guide.

System requirements
The following list outlines the minimum requirements for SANavigator:

* Microsoft Windows operating systems (Windows NT 4.0 service pack 6a and
Windows 2000 Professional, Enterprise Server, and Advanced Server)

— 700-MHz Intel™ Pentium® Ill processor and up
— CD-ROM
- 512-MB RAM
— Disk space: 150 MB
— VGA: 256 colors or greater
* Linux operating systems (Red Hat 7.2 and above)
700-MHz Intel Pentium 11l and up
512-MB RAM
Disk space: 150 MB
VGA: 256 colors or greater

Installing SANavigator

SANavigator installation is easy and fast. After you install IBM FAStT Storage
Manager Version 8.4, consider installing the FAStT MSJ and SANavigator
diagnostic programs. You can use these programs to verify the status of the
fibre-channel connections before you use the storage subsystem.

The SANavigator program, the IBM FAStT MSJ User’s Guide, and FAStT MSJ
program are located on the IBM FAStT Storage Manager 8.4 CD. For information
about how to install and run SANavigator, see the FAS!T Hardware Maintenance
Manual and Problem Determination Guide.

Performing an initial automatic discovery of storage subsystems

To perform an initial automatic discovery of storage subsystems, perform the

following steps:

1. Click Start » Programs.

2. Click IBM FAStT Storage Manager 8 Client. The client software starts and
displays the Enterprise Management window and the Confirm Initial Automatic
Discovery window as illustrated in [Figure 19 on page 105]
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i} IBM FASIT Storage Manager 8 [Enterprize Management]
Edit “iew Tools Help

Mame Status Metwork Management Type | Commentl

i) Initial Automatic Discovery

The Enterprise Management Window is not configured to
manitar any devices.

Select Yes to begin an automatic discovery an the local
sub-netwark; this may take several minutes. Select Mo to
bypass the automatic discovery process.

Ifyou select Mo, you can still use the Edit==Add Device
option to manually add the devices.

Mo Help

' @]

Figure 19. Confirm Initial Automatic Discovery window

$§J000872

Note: The Enterprise Management window can take several minutes to open.
No wait cursor (such as an hourglass) displays.

Click Yes to begin an initial automatic discovery of hosts and storage

subsystems attached to the local subnetwork.

After the initial automatic discovery is complete, the Enterprise Management
window displays all hosts and storage subsystems attached to the local

subnetwork.

Note: The Enterprise Management window can take up to a minute to refresh
after an initial automatic discovery.
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Figure 20. Enterprise Management window

4. Verify that each host and storage subsystem displays in the Enterprise Manager
window.

If a host or storage subsystem is not displayed, perform the following tasks:

» Check the hardware and hardware connections for possible problems (refer
to the hardware documentation for specific procedures).

* Refer to the Enterprise Management online help for additional information
about discovering storage subsystems.

» If you are using the direct-management method, verify that all hosts and
storage subsystems are connected to the same subnet network. If you are
using the host-agent method, ensure that the fibre-channel connection
between the host and storage subsystems is made.

* Make sure that all of the preparation steps for setting up the storage
subsystem for a directly-managed system in [Chapter 2, “Preparing for
installation,” on page 31| are completed. If they are, use the Add Device
option to add the IP addresses of the Storage subsystem. Add both IP
addresses of the controller. Otherwise, you will get a "partially-managed
device” error message when you try to manage the storage subsystem.

» If you are using the host-agent management method, perform the following
steps:
a. Make sure that the SMagent is installed in the host.

b. Verify that you have a fibre-channel connection from the storage
subsystems to the host that has the SMagent installed.

c. Verify that all of the preparation steps outlined in [Chapter 2, “Preparing fot
installation,” on page 31|are complete. If they are, perform the following
steps:

1) Run the hot_add utility.

106 1BM TotalStorage FAST Storage Manager Version 8.4x Installation and Support Guide for Intel-based Operating System
Environments



2) Restart the SMagent using the information in [‘Stopping and restarting|
[the host-agent software” on page 121

3) Click Tools » Rescan in the Enterprise management window.

Note: In certain situations, a storage subsystem might be duplicated in the
device tree after an automatic discovery. You can remove a duplicate
storage management icon from the device tree by using the Remove
Device option in the Enterprise Management window.

5. Verify that the status of each storage subsystem is Optimal. If a device shows a
status of Unresponsive, right-click the device and select Remove Device to
delete it from the management domain. Then use the Add Device option to add
it to the management domain again. Refer to the Enterprise Management
window online help for instructions on removing and adding devices.

6. Continue with ['Adding devices.’]

Adding devices

You can manually add more hosts or storage subsystems. You can use this option
to selectively manage a group of storage subsystems from an SMclient. You can
also use this option to add additional devices to be managed that were not
discovered during the SMclient initial discovery. For more information about this
option, see the Enterprise Management window online help.

Important:

* When you add new storage subsystems to the existing storage subsystems in a
SAN that are managed through the host-agent software, you must stop and
restart the host-agent service. When the host-agent service restarts, the new
storage subsystem is detected. For more information, see ['Stopping and
[restarting the host-agent software” on page 121 Then, go to the Enterprise
Management window and click Tools + Rescan to add the new storage
subsystems to the management domain.

* When you add new storage subsystems to existing storage subsystems that are
managed using the direct-management method, be sure to specify the IP
addresses for both controllers.

Continue with [‘Setting up alert notifications.’]

Setting up alert notifications

After you add devices to the management domain, you can set up alert notifications
to report critical events on the storage subsystems. The following alert-notification
options are available:

* Notification to a designated network management station (NMS) using Simple
Network Management Protocol (SNMP) traps

* Notification to designated e-mail addresses

* Notification to designated alphanumeric pagers (requires separately supplied
software to convert e-mail messages)

Note: You can only monitor storage subsystems within the management domain. If
you do not install the Event Monitor service, the Enterprise Management
window must remain open. If you close the window, you will not receive any
alert notifications from the managed storage subsystems. Refer to the
Enterprise Management window online help for additional information.
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To set up alert notification to an NMS using SNMP traps, perform the following
steps:

1.

4.

Insert the IBM FAStT Storage Manager Version 8.4 CD into the CD-ROM drive
on an NMS. You need to set up the designated management station only once.

Copy the SM820.MIB file from the SM820.mib directory to the NMS.

Follow the steps required by your NMS to compile the management information
base (MIB) file. (For details, contact your network administrator or see the
documentation specific to your particular storage management product.)

Continue with 'Naming storage subsystems.”|

Naming storage subsystems
To name your storage subsystem, perform the following steps:

1.
2.

<Unnamed> - IBM FASLT Storage Manager 8 [Subsystem Management) = [O] x|

Storage Subsystern  Wiew  Mappings  Array  Looical Drive  Controller  Drive  Advanced Help

In the Enterprise Management window, select a storage subsystem.

Click Tools » Manage Device. The Subsystem Management window opens, as
shown in [Figure 21

NG T e

i LogicalPhysical View | [ Mappings View |
Logical FPhysical

I i i iﬁ 5 E Partitions AllowediUsed: 64/0

==r Storage Subsystem Unnamed rController Enclosure
@ Unconfigured Capacity (467.621G8) A E 1= E E El
e [E =E 1]

rDrive Enclosure 0
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4| I bl
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Figure 21. Subsystem Management window

3.

Click Storage Subsystem » Rename. The Rename Storage Subsystem
window opens.

Type the name of the storage subsystem (see [Table 24 on page 139). Then
click OK.

Repeat this procedure for each unnamed storage subsystem. For more
information, see the topic on renaming storage subsystems in the Subsystem
Management window online help.

Proceed to[‘Downloading controller and NVSRAM ESM firmware” on page 109
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Downloading controller and NVSRAM ESM firmware

Note: Access the latest versions of FAStT storage server controller firmware and
NVSRAM and FASIT Storage Expansion Enclosure ESM firmware at the IBM
Web site:

www-1.ibm.com/servers/storage/support/fastt/index.html|

Important: Suspend all I/0 activity while downloading firmware and NVSRAM to a
FASIT Storage Server with a single controller or you will not have redundant
controller connections between the host server and the FASIT Storage Server.

This section provides instructions for downloading FASLT storage server controller
firmware and NVSRAM and FASIT Storage Expansion Enclosure ESM firmware.
You must download FASLT storage server controller firmware version 05.4x.xx
before you download FAStT Storage Expansion Enclosure ESM firmware.

Downloading firmware
To download firmware version 05.4x.xx, perform the following steps:

1. From the Enterprise Management window, select a storage subsystem.
2. Click Tools » Manage Device. The Subsystem Management window opens.

3. Click Storage Subsystem » Download » Firmware. Follow the instructions that
display.
4. Continue with [Downloading NVSRAM.”|

Downloading NVSRAM
To download NVSRAM, perform the following steps:

1. From the Enterprise Management window, select a storage subsystem.
2. Click Tools » Manage Device. The Subsystem Management window opens.

3. Click Storage Subsystem » Download + NVSRAM. Follow the instructions that
display.

4. Continue with [‘Creating arrays and logical drives.”|

Downloading ESM firmware
Perform the following steps to download the ESM firmware:

1. In the FASLT Storage Server Subsystem Management window, select
Advanced » Download » Environmental (ESM) card firmware. A download
Environmental card firmware window opens.

2. In the window, select the enclosure, provide the filename of the ESM firmware
file and click Start to begin the ESM firmware download.

3. Click Cancel to close the window when the ESM firmware download is
complete.

Note: Suspend all I/O activity while ESM firmware downloads if you select
multiple enclosures for downloading ESM firmware. If you select only one
enclosure for download at a time, you can download ESM firmware while
the server conducts I/O activity. However, IBM recommends that you
suspend all I/0O activity to perform firmware upgrades.

Creating arrays and logical drives

Important: You should create a storage subsystem profile and save it in a safe
place whenever you modify the arrays and logical drives in your storage server.
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This profile contains detailed controller information including logical and physical
disk configuration information that you can use to help recover the configuration in
the event of a catastrophic failure.

To create a storage subsystem profile, select View » Storage Subsystem Profile
in the Storage Subsystem Management window and click the Save As button when
the Storage Subsystem Profile window opens.

If you have a storage server with firmware level 04.01.xx.xx or earlier, you must
also perform a controller state capture in addition to saving the storage subsystem
profile. To use the Capture State Information feature, you must upgrade the
controller to firmware level 04.01.02.34 or higher and install the FAStT Storage
Manager Field Tool Version 5.21 program. This program is available at the following
Web site:

www-1.ibm.com/servers/storage/support/fastt/index.html|

To create a storage subsystem profile using the Capture State Information feature,
perform the following steps:

1. Click Tools » Capture State Information. A State Capture window opens.

2. Click the Browse button to specify the file name for the state capture
information.

3. Click the Start button to start the capture process.

4. Click the Cancel button to close the State Capture window when the capturing
is completed.

An array is a set of fibre-channel hard drives that are logically grouped together to
form a RAID set. For firmware levels 05.3x.xx.xx and lower, the maximum number
of hard drives supported for each array is 30 if the hard drive capacities are 73.4
GB or less and 14 if the hard drive capacities are 146 GB. For firmware levels
5.4x.xx.xx and higher, however, the maximum number of drives supported in an
array is 30, regardless of the hard drive capacity. Each array can be divided into
from 1 to 256 logical drives. A logical drive is a logical structure, which is the basic
structure that you create to store data on the storage subsystem. The operating
system recognizes a logical drive as a single drive. Choose a RAID level to meet
application needs for data availability and maximize fibre-channel 1/0 performance.

To create arrays and logical drives, perform the following steps:

1. From the Enterprise Management window, select a storage subsystem.

2. Click Tools » Manage Device. The Subsystem Management window opens.
3. Click the Logical/Physical View tab.
4

Click Logical Drive » Create. The Logical Drive Create wizard starts. Follow
the online instructions to create arrays and logical drives.

5. Proceed to |“Verifying and defining the default host type.’1

Note: For cluster configurations, if you add or delete logical drives, you must make
them known to both nodes A and B.

Verifying and defining the default host type

Before you use the logical drives in a host computer, you must specify the host
type. The host type determines how the storage subsystem controllers will work
with each particular operating system on the hosts to which it is connected. If all of
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the host computers connected to the same storage subsystem are running the
same operating system, and you do not want to define partitioning, you can define
a default host type.

Note: Windows 2000 and Windows Server 2003 share the following host type
options:
* Windows 2000/Server 2003 non-clustered
* Windows 2000/Server 2003 clustered

If these host type entries do not display as options in your host type
pull-down menu, use either of the following host types instead:

¢ Windows 2000 non-clustered
¢ Windows 2000 clustered

To verify the current default host type, perform the following steps:

1. In the Subsystem Management window, click View » Storage subsystem
profile. A Storage Subsystem Profile window opens.

2. Click the Mappings folder tab and scroll down to NVSRAM Host Type Internal
Definitions. The host type name of the index that has the word DEFAULT next
to it is the default host type.

3. Click Close.

To define a default host type, perform the following steps:

1. Click Storage subsystem » Change » Default host-type. The Default
Host-type window opens.

2. From the pull-down list, select the host type.
3. Click OK.

If you have hosts with different operating systems or if you want to define partitions
for the hosts, continue with [‘Configuring heterogeneous hosts.]

Configuring heterogeneous hosts

The heterogeneous hosts feature enables hosts running different operating systems
to access a single storage subsystem. Previous releases of FASIT Storage
Manager (versions 7.02 or earlier) required that hosts run the same operating
system in order to access a single storage subsystem.

Host computers can run completely different operating systems (for example,
Solaris and Windows NT 4.0) or variants of the same operating system (for
example, Windows NT 4.0 running in a cluster environment or Windows NT 4.0
running in a noncluster environment). When a host type is specified in the Define
New Host Port window, the heterogeneous hosts feature enables the controllers in
the storage subsystem to tailor their behavior (such as LUN reporting) to the needs
of the host.

Important: To use the heterogeneous host feature, you must meet the following
conditions:

* You must enable storage partitioning.

» During host-port definition, you must set each host type to the appropriate
operating system so that the firmware on each controller can respond correctly to
the host.
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To start the heterogeneous host configuration, perform the following steps:
1. From the Subsystem Management window, click Mappings View.
2. Follow the on-screen instructions.

3. Continue with ['Performing other storage-subsystem management tasks” on|
|page 113.|

Note: Partitioning is a premium feature. If you disable partitioning, you must
contact your IBM technical support representative to obtain a key to enable
partitioning again. This is not a standard feature with the FAStT600.

Creating a FlashCopy logical drive

A FlashCopy logical drive is a logical point-in-time image of a logical drive, called a
base logical drive. A FlashCopy logical drive has the following features:

* |t is created quickly and requires less disk space than an actual logical drive.

* |t can be assigned a host address, so that you can perform backups by using the
FlashCopy logical drive while the base logical drive is online and accessible.

* You can use the FlashCopy logical drive to perform application testing or both
scenario development and analysis. This does not effect the actual production
environment.

* The maximum number of FlashCopy logical drives allowed is one half of the total
logical drives supported by your controller model.

For additional information about the FlashCopy feature and how to manage Flash
Copy logical drives, refer to the Storage Manager Subsystem Management online
help.

Note: FlashCopy is a premium feature. Contact your IBM reseller or IBM marketing
representative for more information.

Important: The FlashCopy drive cannot be added or mapped to the same server
that has the base logical drive of the Flashcopy logical drive in a Windows 2000,
Windows Server 2003, or NetWare environment. You must map the Flashcopy
logical drive to another server.

Perform the following steps to create a FlashCopy logical drive:

1. To ensure that you have the accurate point-in-time image of the base logical
drive, stop applications and flush cache 1/O to the base logical drive.

2. Open the Subsystem Management window. From the Logical View, right-click
the base logical drive.

3. Select Create FlashCopy Logical Drive. The Create FlashCopy Logical Drive
Wizard starts.

4. Follow the on-screen instructions.

5. Refer to the Subsystem Management online help for instructions on how to add
the FlashCopy logical drive to the host.

Using VolumeCopy

The VolumeCopy feature is a firmware-based mechanism for replicating logical
drive data within a storage array. This feature is designed as a system management
tool for tasks such as relocating data to other drives for hardware upgrades or
performance management, data backup, or restoring snapshot volume data. Users
submit VolumeCopy requests by specifying two compatible drives. One drive is
designated as the Source and the other as the Target. The VolumeCopy request is
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persistent so that any relevant result of the copy process can be communicated to
the user. For more information about this feature, see the IBM TotalStorage FAStT
Storage Manager Copy Services User’s Guide, or contact your IBM reseller or
marketing representative.

Using the Remote Mirror option

The Remote Mirror option is a premium feature. The Remote Mirror option is used
for online, real-time replication of data between storage subsystems over a remote
distance. In the event of a disaster or unrecoverable error at one storage
subsystem, the Remote Mirror option enables you to promote a second storage
subsystem to take over responsibility for normal input/output (1/O) operations. For
more information about this feature, see the IBM FAStT Remote Mirror Option
Installation and User’s Guide, or contact your IBM reseller or marketing
representative.

Performing other storage-subsystem management tasks

The following list includes other storage subsystem management tasks that you can
perform:

* Locating a storage subsystem

* Viewing a storage subsystem profile or event log

* Entering or changing a storage subsystem password

» Creating and managing logical drives and arrays

» Using the Performance Monitor

» Creating storage partitions (if applicable) and heterogeneous hosts
* Viewing or changing media scan settings

* Increasing capacity of an array or logical drive

* Changing RAID level for an array

* Monitoring read-link-status error counts

* Downloading ESM firmware or fibre-channel drive firmware

Note: To create storage partitions, you must obtain the worldwide name or port of
each host adapter in every host connected to the storage subsystem.

For more information about these and other storage subsystem management tasks,
refer to the appropriate topics in the Subsystem Management online help.

Chapter 8. Completing Storage Manager 8.4 installation 113



114 IBM TotalStorage FASIT Storage Manager Version 8.4x Installation and Support Guide for Intel-based Operating System

Environments



Chapter 9. Using the storage management software for
Windows and NetWare

This chapter provides information about how to add or delete logical drives, create
FlashCopy logical drives, use the hot_add and SMdevices utilities, start and stop
the host-agent software, and uninstall Storage Manager components in Windows
and NetWare operating system environments. Information regarding the Windows
operating system follows. See [‘Using the storage management software for
NetWare” on page 123]|for analogous information about the NetWare operating
system environment.

Using the storage management software for Windows

This section provides information about how to add or delete logical drives, create
FlashCopy logical drives, use the hot_add and SMdevices utilities, start and stop
the host-agent software, and uninstall Storage Manager components in a Windows
operating system environment.

Adding or deleting logical drives

Use the following procedures to add or delete logical drives in a standard
(noncluster) and a cluster configuration.

Standard (noncluster) configuration for Windows NT 4.0

Creating logical drives: When you create logical drives with the storage
management software, you must add the new logical drives to Windows NT 4.0.
Refer to the Windows NT 4.0 documentation for details about how to add a drive.
Each logical drive (not array) is recognized by Windows NT 4.0 as a single drive.

After you create logical drives, run the hot_add and SMdevices utilities that are
provided with the storage management software. The hot_add utility adds newly
created logical drives to the operating system. The SMdevices utility identifies
logical drives by their associated operating system device names. For more
information, see[‘Using the hot_add utility” on page 120| and[‘Using the SMdevices
[utility” on page 120

Deleting logical drives:

Important: If you have data or logical drives that you want to keep, do not click
Configuration » Reset. This action resets the controller unit and deletes all
previously-configured logical drives.

Before you delete logical drives with the storage management software or by using
Configuration » Reset, perform the following steps:

1. Use the Disk Administrator to delete any partitions and to unassign drive letters
that are associated with the logical drives.

2. Restart the system to remove the configuration information.
Attention: You must use the Disk Administrator to delete OS partitions and

unassigned drive letters before you delete logical drives or reset the configuration in
Storage Manager. Take this action to avoid damage to your registry information.
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Cluster server configuration for Windows NT 4.0
Use the following procedures to create or delete logical drives in a cluster server
environment for Windows NT 4.0.

Creating logical drives: To add logical drives in a Windows NT 4.0 cluster server
environment, perform the following steps:

1. Using the IBM FAStT Storage Manager Client, create arrays and assign them
to the appropriate host group by using storage partitioning.

2. Stop the cluster server service in node A. Make sure that all of the cluster
groups and resources failover to node B.

3. Perform the following steps to disable the cluster server service and the cluster
disk device in node A:

a. Click Start » Settings » Control Panel. The Control Panel window opens.
b. Click Services. The Services window opens.
c. Select Cluster Server, and click Startup. The Service window opens.
d. Change the Startup Type Setting to Disabled; then, click OK.
e. Close the Services window.
f. Click Start » Settings » Control Panel. The Control Panel window opens
g. Click Devices. The Device window opens.
h. Select Cluster Disk; then, click Startup. The Devices window opens.
i. Select Disabled; then, click OK.
j- Close the Devices window.
4. Restart node A.
5. Use Disk Administrator to create and format your operating system partitions.

6. Enable cluster server service and the cluster disk device in node A. Make sure
that the start-up type is set to System for cluster disk device and Automatic for
cluster server service.

7. Restart node A. Then make sure that the cluster server service started and
that the cluster groups and resources failed back correcily.

8. Stop the cluster server service in node B.

9. Using the procedure outlined in step 3} disable cluster server service and the
cluster disk device in node B.

10. Restart node B.

11. Use Disk Administrator to reassign the drive letters to match the ones that
were assigned to a given disk in node A.

12. Enable cluster server service and the cluster disk device in node B. Make sure
that the start-up type is set to System for cluster disk device and Automatic for
cluster server service.

13. Restart node B. Then make sure that the cluster server service started and the
cluster groups and resources failed back correctly.

14. Stop the cluster server service in node A.
15. Restart node A.

16. After cluster server service starts, use Cluster Administrator to create your
physical disk resources.

17. Verify that the physical disk resources can be brought online in both nodes.

Deleting logical drives:
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Attention: Do not click Configuration » Reset in the Storage Manager Client
Storage Subsystem management window if you have data or logical drives that you
want to keep. This action resets the controller unit and deletes all previously
configured logical drives.

Before you delete logical drives with the storage management software or use
Configuration » Reset in the Storage Manager Client Storage Subsystem
management window, perform the following steps®

1. Use Cluster Administrator to delete the cluster physical disk resources that own
the logical drives that will be deleted.

2. Use Disk Administrator to delete any partitions and to unassign drive letters that
are associated with the logical drives.

3. Restart the system to remove the configuration information.

Attention: You must use the Cluster Administrator and Disk Administrator to
delete the cluster physical disk resources, delete OS partitions, and unassigned
drive letters before you delete logical drives or reset the configuration in Storage
Manager. Take this action to avoid damage to your registry information.

Standard (noncluster) configuration for Windows 2000
Use the following procedures to create or delete logical drives in a standard server
environment for Windows 2000.

Creating logical drives: When you create logical drives with the storage
management software, you must add the new logical drives to Windows 2000. Each
logical drive (not array) is recognized by Windows 2000 as a single drive.

After creating logical drives, run the hot_add and SMdevices utilities that are
provided with the storage management software. The hot_add utility adds newly
created logical drives to the operating system without requiring a system restart.
The SMdevices utility identifies the logical drives by their associated operating
system device names. For more information, see [‘Using the hot_add utility” on page]
ﬁéﬂ or ['Using the SMdevices utility” on page 120.|

Deleting logical drives:

Attention: Do not click Configuration » Reset if you have data or logical drives
that you want to keep. This action resets the controller unit and deletes all
previously-configured logical drives.

Before you delete logical drives with the storage management software or use
Configuration » Reset, perform the following steps:

1. Use the Disk Administrator to delete any partitions and to unassign drive letters
that are associated with the logical drives.

2. Restart the system to remove the configuration information.

Attention: You must use the Disk Administrator to delete OS partitions and
unassigned drive letters before you delete logical drives or reset the configuration in
Storage Manager. Take this action to avoid damage to your registry information.

Cluster server configuration for Windows 2000
Use the following procedures to create or delete logical drives in a cluster server
environment for Windows 2000.
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Creating logical drives: To add logical drives in a Windows 2000 cluster server
environment, perform the following steps:

1. Using the IBM FASLT Storage Manager Client, create arrays and assign them to
the appropriate host group by using storage partitioning.
2. Use the hot_add utility to add the new logical drives to node A.

3. Using the Disk Administrator, create, format, and assign drive letters to the disk
partitions on the new logical drives.

4. Use the hot_add utility to add the new logical drives to node B.

5. Using the Disk Administrator, ensure that the drive letters assigned to the disk
partitions on the logical drives are the same on both node A and node B.

6. Restart node A. Then use the Cluster Administrator to create cluster physical
disk resources using the new disk partitions on the new logical drives.

7. Bring the cluster resources online in node A.
8. Use cluster administrator to move the cluster physical disk resources to node B.
9. Verify that the resources come online in node B.

Deleting logical drives:

Attention: Do not click Configuration » Reset in the Storage Manager Client
Storage Subsystem management window if you have data or logical drives that you
want to keep. This action resets the controller unit and deletes all
previously-configured logical drives.

Before you delete logical drives with the storage management software or use
Configuration » Reset in the Storage Manager Client Storage Subsystem
management window, perform the following steps:

1. Use the Cluster Administrator to delete the cluster physical disk resources that
own the logical drives that will be deleted.

2. Use the Disk Administrator to delete any partitions and to unassign drive letters
that are associated with the logical drives.

3. Restart the system to remove the configuration information.

Attention: You must use the Cluster Administrator and Disk Administrator to
delete the cluster physical disk resources, delete OS partitions, and unassigned
drive letters before deleting logical drives or resetting the configuration in Storage
Manager. This avoids damage to your registry information.

Standard (non-clustered) configuration for Windows Server 2003
Use the following procedures to create or delete logical drives in a standard
environment.

Creating logical drives: When you create logical drives with the storage
management software, you must add the new logical drives to the Windows Server
2003 operating system. Each logical drive (not array) is recognized by Windows
Server 2003 as a single disk drive.

After creating logical drives, run the hot_add and SMdevices utilities that are
provided with the storage management software. The hot_add utility adds newly
created logical drives to the operating system without requiring a system restart.
The SMdevices utility identifies logical drives by their associated operating system
device names. For more information, see [‘Using the hot_add utility” on page 120| or
FUsing the SMdevices utility” on page 120
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Deleting logical drives:

Attention: Do not click Configuration » Reset in the Storage Manager Client
Storage Subsystem management window if you have data or logical drives that you
want to keep. This action resets the controller unit and deletes all
previously-configured logical drives.

Before you delete logical drives with the storage management software or use
Configuration » Reset in the Storage Manager Client Storage Subsystem
management window, perform the following steps:

1. Use the Disk Administrator to delete any partitions and to unassign drive letters
that are associated with the logical drives.

2. If possible, restart the system to remove the configuration information.

Attention: You must use the Disk Administrator to delete the cluster physical disk
resources, delete OS partitions, and unassigned drive letters before you delete
logical drives or reset the configuration in Storage Manager. This action avoids
damage to your registry information.

Cluster server configuration for Windows Server 2003
Use the following procedures to create or delete logical drives in a cluster server
environment.

Creating logical drives: To add logical drives in a Windows Server 2003 cluster
server environment, perform the following steps:

1. Use the IBM FASIT Storage Manager Client program to create arrays and
logical drives and use storage partitioning to assign them to the appropriate
cluster host group.

2. Use the hot_add utility to add the new logical drives to the cluster node that is
currently owned by the cluster quorum resource.

3. Use the Disk Administrator program to create, format, and assign drive letters to
the disk partitions on the new logical drives.

4. In each of the rest of the cluster nodes in the cluster configuration, use the
hot_add utility to add the new logical drives to the cluster node.

5. In the first cluster node, use the Cluster Administrator program to create cluster
physical disk resources using the new disk partitions on the new logical drives.

Note: If the new disk does not show up in the available disk pull-down list when
you go through the Cluster Administrator program, you might have to
reboot the server.

6. Bring the cluster resources online in the first cluster node.

7. Use the Cluster Administrator to move the newly-created cluster physical disk
resources to other nodes in the cluster configuration.

8. Verify that the resources come online in other nodes in the cluster configuration.
Deleting logical drives:

Attention: Do not click Configuration » Reset in the Storage Manager Client
Storage Subsystem management window if you have data or logical drives that you

want to keep. This action resets the controller unit and deletes all
previously-configured logical drives.
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Before you delete logical drives with the storage management software or use

Configuration » Reset in the Storage Manager Client Storage Subsystem

management window, perform the following steps:

1. Use the Cluster Administrator to delete the cluster physical disk resources that
own the logical drives that will be deleted.

2. Use the Disk Administrator to delete any partitions and to unassign drive letters
that are associated with the logical drives.

3. If possible, restart the cluster nodes to remove the configuration information.

Attention: You must use the Cluster Administrator and Disk Administrator to
delete the cluster physical disk resources, delete OS partitions, and unassigned
drive letters before you delete logical drives or reset the configuration in Storage
Manager. This action avoids damage to your registry information.

Using the hot_add utility

The hot_add utility enables you to add new logical drives without restarting the
system. The utility registers the new logical drives with the operating system so that
you can use Disk Administrator to create partitions, add device names, and so on.
The hot_add utility is part of the SMutil software package. If you run the program
twice and the new logical drives are not displayed in the Disk Administrator window,
you must either run fibre-channel diagnostics or restart (reboot) the host.

When you finish creating logical drives on a particular storage subsystem, go to the
host that is attached to that storage subsystem and perform the following steps to
use the hot_add utility:

1. From a DOS or command prompt, change to the
installation_directory\1BM_FAStT\Uti1

where installation_directory is the directory where you installed the SMutil.
2. From a DOS or command prompt, type the following command:
hot_add

3. Press Enter. The new logical drives are available through the Disk
Administrator.

Using the SMdevices utility

The SMutil software includes a utility called SMdevices that you can use to view the
storage subsystem logical drive that is associated with a particular operating system
device name. This utility is helpful when you want to create drive letters or partitions
by using Disk Administrator.

When you finish creating the logical drives on a particular storage subsystem, go to
the host that is attached to that storage subsystem, and perform the following steps
to use SMdevices:

1. From a DOS or command prompt, change to the
installation_directory\1BM_FAStT\Uti1

where installation_directory is the directory where you installed the SMutil.
2. Type:
SMdevices

3. Press Enter. The software displays device identification information. For
example, you might see the following information.
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\\.\PHYSICALDRIVEx [Storage Subsystem Finance, Logical Drive DEBIT, LUN xx,

WWN <worldwide _name>]

where:

* xis the Disk number that displays in Disk Administrator

* Finance is the name of the storage subsystem

« DEBIT is the name of the logical drive

» xx is the LUN associated with the logical drive

* worldwide_name is the worldwide name for the logical drive

Using the SMrepassist utility
You can use the SMrepassist utility to perform the following tasks:
* Flush cached data for a logical drive.

» Resolve duplicate logical drive signatures between the base logical drives and
the FlashCopy logical drives. (Windows NT 4.0 only)

Important: The FlashCopy drive can not be added or mapped to the same server
that has the base logical drive of the FlashCopy logical drive in a Windows 2000,
Windows Server 2003, or NetWare environment. You must map the FlashCopy
logical drive to another server.

To flush cached data in a logical drive, perform the following steps:

1. From a DOS or command prompt, change to the
installation_directory\1BM_FAStT\Uti1

where installation_directory is the directory where you installed the SMutil.
2. Type the following command:
smrepassist -f logical drive letter:

where logical_drive_letter is the operating system drive letter that was assigned
to the disk partition created on the logical drive.

3. Press Enter.

After you create a FlashCopy logical drive and map it to the same host as the base
logical drive, (for Windows NT 4.0 only) to resolve duplicate logical drive signatures:

1. Type:
smrepassist -r
2. Press Enter.

Stopping and restarting the host-agent software

You must stop and restart the host-agent software if you add additional storage
subsystems to the management domain of the host-agent software. When you
restart the service, the host-agent software discovers the new storage subsystems
and adds them to the management domain.

Note: If none of the access logical drives are detected after a restart, the
host-agent software automatically stops running. Make sure that there is a
good fibre-channel connection from the host to the SAN to which the storage
subsystem is connected. Then restart the host or cluster node so that new
host-agent-managed storage subsystems can be discovered.

Chapter 9. Using the storage management software for Windows and Netware 121



Windows NT 4.0
To stop and restart the host-agent software, perform the following steps:

1. Click Start » Settings » Control Panel. The Control Panel window opens.
2. Double-click Services. The Services window opens.

3. Click IBM FAStT Storage Manager 8 Agent; then, click Stop. The Confirmation
window opens.

4. Click Yes.
5. Click Start. The Storage Agent Manager starts.
6. Close the Services window.

Windows 2000
To stop and restart the host-agent software, perform the following steps:

1. Click Start » Programs » Administrative Tools » Services. The Services
window opens.

2. Right-click IBM FAStT Storage Manager 8 Agent.

3. Click Restart. The IBM FASIT Storage Manager 8 Agent stops and then starts
again.

4. Close the Services window.

Windows Server 2003

To stop and restart the host-agent software, perform the following steps:

1. Click Start »+ Administrative Tools » Services. The Services window opens.

2. Right-click IBM FAStT Storage Manager 8 Agent.

3. Click Restart. The IBM FAStT Storage Manager 8 Agent stops and then starts
again.

4. Close the Services window.

Uninstalling storage management software components

Use the following procedure to uninstall one or more of the components of Storage
Manager 8.4. If you are uninstalling components released with an earlier version of
the storage management software, use the uninstall procedure that came with the
version of the storage management software that you are currently running.

Important: Do not uninstall the RDAC unless instructed by an IBM technical
support representative. The host-agent package requires RDAC to function properly.
If you uninstall RDAC in a coexistence environment, you will lose fibre-channel 1/0
path failover support for both the version 7.xx and version 8.xx of Storage Manager.

1. Click Start » Settings » Control Panel. The Control Panel window opens.
Select Add/Remove programs. The Add/Remove Programs Properties window
opens.

Note: Uninstall the Storage Manager components in the following order:

a. SMagent
b. SMutil
c. RDAC
d. SMclient

2. Select the component you want to uninstall from the list of programs (for
example, IBM FAStT Storage Manager Client).

3. Click Add/Remove. The Confirm File Deletion window opens.
4. Click Yes to start the uninstallation process.
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5. When the uninstallation is complete, click OK.

Using the storage management software for NetWare

This section provides information on how to add or delete logical drives using the
hot_add and SMdevices utilities, start and stop the host-agent software, and
uninstall Storage Manager components in a NetWare operating system
environment.

Adding or deleting logical drives

Use the following instructions to add or delete logical drives in a standard
(noncluster) configuration.

Creating logical drives

When you create new logical drives with the storage management software, you
must add the new logical drives to Novell NetWare. Refer to the Novell NetWare
documentation for details about adding a drive. Novell NetWare recognizes each
logical drive (not array) as a single drive.

After creating logical drives, run the hot_add and SMdevices utilities that are
provided with the storage management software. The Hot Add utility adds newly
created logical drives to the operating system, and the SMdevices utility identifies
logical drives by their associated operating system device names. For information
about how to use these utilities, see [‘Using the hot_add utility’| and [‘Using the|
[SMdevices utility.”|

Deleting logical drives

Important: If you have data or logical drives that you want to keep, do not click
Configure » Reset Configure. This will reset the controller unit and delete all
previously-configured logical drives.

Before you delete logical drives with the storage management software or use
Configure » Reset Configuration, stop all input and output activity to the affected
storage subsystem. Then dismount any Novell NetWare volumes that are
associated with the logical drives.

Using the hot_add utility

The hot_add utility enables you to add new logical drives without restarting the
system. The utility registers the new logical drives with the operating system so that
you can use nwconfig to create partitions, add device names, and so on. The
hot_add utility is part of the Storage Manager 8.4 Utility package.

When you finish creating logical drives on a particular storage subsystem, go to the
host that is attached to that storage subsystem, and perform the following steps to
use the hot_add utility:

1. From the Server Console, type:
hot_add
2. Press Enter.
The new logical drives are available through the Disk Administrator.

Using the SMdevices utility

The Storage Manager 8.4 Utility software package includes a utility called
SMdevices that you can use to view the storage subsystem logical drive that is
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associated with a particular operating-system device name. This utility is helpful
when you want to create drives, volumes, or a combination of both for the logical
drive using the nwconfig program.

When you finish creating the logical drives on a particular storage subsystem, go to
the host that is attached to that storage subsystem, and perform the following steps
to use SMdevices:

1. From the Server Console type:
SMdevices
2. Press Enter.

The software displays device identification information. For example, you might
see:

V596-A3-DO:0[Storage Subsystem MARKETING, Logical Drive DEBIT,
LUN 0, WWN <600a0b800007545c0000008d3a308b6e>]

V596-A3-D0:1 [Storage Subsystem MARKETING, Logical Drive DEBIT, LUN 1,
WWN <600a0b80000756ec000000a93a307d2a>]

V596-A3-D0:1F [Storage Subsystem MARKETING, Logical Drive Access volume,
LUN 31, WWN <600a0b800007545c0000009000000000>]

Where V596-A3-D0:0;

The numbers at the beginning of each line constitute the device name. The
device name identifies the adapter or device as follows:

Vendor number [V596]. A unique number specific to the device vendor.

Adapter number [A3]. The instance number of an adapter registered with
NWPA. In the example, A3 identifies the first instance of an adapter installed in
the server.

Device number [DO]. The number of the disk or other device.

Logical unit number [0,1,1F]. The LUN identifies individual devices when more
than one device is attached to one bus.

Storage Subsystem [x]. The storage subsystem name.

Logical Drive [x]. The logical drive name.

LUN [x]. The logical unit number associated with the logical drive.
WWN [x]. The worldwide name for the logical drive.

Stopping and starting the host-agent software

Use the procedures in the following sections to stop and start the host-agent
software installed on the host or cluster node.

Note: If an access logical drive is not detected after a restart, the host-agent
software will automatically stop running. Restart the host or cluster node so
that new host-agent-managed storage subsystems will be discovered.

Stopping the host-agent software

You must stop the host-agent software if you want to add storage subsystems.
When you restart the service, the host-agent software discovers the new storage
subsystems and adds them to the management domain.

Perform the following steps to stop the host-agent software:
1. From the system console, press Ctrl+Esc, and then select System Console.
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2.

4.

At the prompt, type:

java -show

Look for the following line:
"devmgr.versioned.agent.AgentServer............. QQQ"
where QQQ is the process ID.

At the prompt type the following:

java -ki11QQQ

where QQQ is the process ID from the java -show command.
Press Enter.

Starting the host agent manually
To add storage subsystems, start the host-agent software manually either when you
start the system or if it is already stopped.

Perform the following steps to start the host agent manually:

1.
2.

From the system console, press Ctrl+Esc, and then select System Console.
At the prompt, type:

smagent

Press Enter.

The agent will start and display the following message when UTM LUNSs are
scanned:

Activating

Return to ConsoleOne. Press Ctrl+Esc, and then click Xserver » Graphical
Console.

Uninstalling storage-management software components

Use the following procedure to uninstall one or more of the components of Storage
Manager 8.4. If you are uninstalling components released with an earlier version of
the storage management software, use the procedure that came with the version of
the storage management software that you are currently running.

1.

From the Xserver Graphical Console, click Novell » Install.
The Installed Products window opens.

In the list of currently installed products, select and click Remove to uninstall
the product/software package.

The name of the Storage Manager packages are:
a. Storage Manager 8.4 Agent
b. Storage Manager 8.4 Utility
c. Storage Manager 8.4 Client

Click OK in the Confirm Product Deletion window to proceed with the
uninstallation.

A Please Wait pop-up window displays while the package uninstalls.

The Installed Products window will display again when the uninstallation is
complete.
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Appendix A. Windows operating system limitations

This appendix contains information about how to operate the storage management
software in a Windows NT 4.0, Windows 2000, or Windows Server 2003

environment.

Important: Always check for a readme file on any installation media. This readme
file might contain important information that was not available when this document

was prepared.

Limitations of Windows operating systems

explains limitations that apply when you use the IBM FAStT Storage
Manager Version 8.4 with Windows NT 4.0, Windows 2000, and Windows Server

2003.

Table 20. Windows operating system limitations and workarounds

Limitation

Workaround

If you click a vertical scroll arrow either up
or down, the scroll box will move all the
way to the opposite end of the scroll bar.

This is a known defect in the Java Runtime
Environment. Click the scroll box and slide it until
you reach the position that you want in the Help
window.

Data or configuration loss might occur
during a logical drive migration. Logical
drive migration consists of removing
configured physical drives from one
storage subsystem and inserting them
into another storage subsystem.

Contact an IBM technical support representative
for assistance in performing this procedure.

Array migration is not supported because
it could cause loss of configuration and
data. Array migration consists of removing
a set of drives configured with arrays from
one storage subsystem and inserting
them into another storage subsystem.

Contact an IBM technical support representative.

If you manage storage subsystems
through the host-agent software and use
the storage management software to
download controller firmware, the
download process can take up to 10
minutes to complete.

None.

When you configure a new storage
subsystem with a single controller, you
must place the controller in slot A. The
controller firmware cannot recognize or
communicate with a single controller until
slot A is populated. This restriction does
not apply to storage subsystems that
were originally configured with two
controllers.

None.

© Copyright IBM Corp. 2004
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Table 20. Windows operating system limitations and workarounds (continued)

Limitation

Workaround

The following loop configuration is not
supported: IBM Fibre Channel Hub
(machine type 3523) in conjunction with
the IBM Fibre Channel Switch (machine
types 2109 S16 and 2109 S08) or the
IBM Fibre Channel Switch (machine types
3534 F08 and 2109 F16).

None.

A controller failover occurs in an
active/active controller pair, and
ownership of arrays transfers from the
failed preferred owner to the other
controller of the repair. The failed
controller is replaced and brought online.
The array ownership is not automatically
transferred back to the preferred controller
owner.

Immediately after you replace the controller, click
Storage subsystem » Redistribute Arrays in
the Subsystem Management window to
redistribute arrays back to their preferred
controller owners. For more information, refer to
the Enterprise Management online help.

After adding a host device to the
management domain of more than five
clients, the host-agent-managed storage
subsystems attached to that host become
unresponsive.

Make sure that a single instance of the
host-agent software communicates with no more
than five clients.

When you connect a FAStT EXP700
Storage Expansion Unit to a FAStT200,
you must set the drive speed to 1 Gbps.

None.
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Table 20. Windows operating system limitations and workarounds (continued)

Limitation

Workaround

After you install the host-agent software,
the host displays the error message
Service Error 100.

The cause includes:

» The host-agent software does not find any
controllers with firmware version 04.00.02.00
or higher. Upgrade the firmware to the latest
firmware level from the IBM support Web site
at:

www.ibm.com/support/|

For more information, see [‘Direct-management|
[method workaround” on page 131

» The access logical drive has been removed
from NVSRAM or the storage partition defined
for the host. Perform one of the following
tasks:

— Manage the storage subsystem by using
the direct-management method. See
“Direct-management method workaround’]

on page 131.|

— Define the access logical drive for the host
and restart SMagent. Sed“SMagenﬂ
workaround for defining additional access]
LUN mapping” on page 132

* The NVSRAM on the controllers in a storage
subsystem that you want to manage contains
an access logical drive LUN that is in use by
another logical drive, or is not supported by
the operating system or installed patches. For
example, the access logical drive is configured
at LUN 31, and the operating system and
service packs support only eight LUNSs.
Perform one of the following tasks:

— Manage the storage subsystem by using
the direct-management method. See
“Direct-management method workaround’|

on page 131.|

— Change the LUN mapping for the
host-access logical drive to a LUN that is
not in use and is supported by the
operating system either from a different
computer that has management access to
the storage subsystem, or establish a direct
management connection to the storage
subsystem from the current host. For more
information, see [‘SMagent workaround for|
changing existing access LUN mapping” on|

page 132.|

Auto LUN/Array Transfer is not enabled. If
a controller fails over arrays to the
alternate controller and the failed
controller is replaced and brought back
online, the arrays will not automatically
transfer to the preferred controller.

Manually select the Redistribute Logical Drives
menu option in the IBM FASIT Storage Manager
client GUI.

A brownish hash pattern displays in the
dialog windows and in online help when
operating in 256-color mode.

Run the FAStT Storage Manager 8.4 application
in a higher display mode.
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Table 20. Windows operating system limitations and workarounds (continued)

Limitation

Workaround

The system might display the FAStT
Storage Manager dialog windows as
cropped without the vertical and horizontal
scroll bars.

Move the mouse pointer over the edge of the
window until the mouse pointer changes to a
window resize pointer. Left-click your mouse;
hold to grip the window’s edge and resize the
window.

The controller in the IBM FAStT Storage
Server with firmware 05.3x.xx.xx is
connected to a SAN with more than 64
host connections per controller port that
can log into the controllers, exceeding the
maximum number of host connections
that can be seen and log into the
controller.

Either use the switch zoning function or

rearrange the SAN connections so that only the

following maximum number of host connections

can be seen and log into the controller as

follows:

* The following FAStT storage subsystems have
two ports per controller — one per minihub slot.

— FAStT900, Machine Type 1742
— FAStT700, Machine Type 1742
— FAStT500, Machine Type 3552

» The FAStT600 (IBM machine type 1722) has
two ports per controller.

* The FAStT200 (IBM machine type 3542) has
only one port per controller.

It is possible to circumvent IBM FAStT
Storage Server hardware and software
designs for redundant pathways from the
host system. This is accomplished by
connecting a single host adapter from the
host system to one of the controller
minihubs, and then connecting this
minihub to the minihub of the other
controller, creating a Fibre
Channel-Arbitrated Loop (FC-AL) between
the host adapter and the two IBM FAStT
Storage Server controllers. This
configuration leaves no redundant path to
the host system.

When connecting two minihubs together, always
connect the IN port of one minihub to the OUT
port of the other minihub or vice versa. Do not
connect the IN port of one to the IN port of the
other minihub or the OUT port of one minihub to
the OUT port of the other minihub.

Nevertheless, this configuration is not supported
by IBM.

If the IBM FASLT Storage Server is
connected to a SAN with many other IBM
FAStT Storage Servers, there may be
ghost LUNSs displayed in the Windows NT,
Version 4 Disk Administrator.

Use switch zoning to either limit the number of
storage servers that the HBAs in the Windows
NT Version 4 host server can log into (single or
dual HBAs per host server configuration) or
create two separate paths from the Windows NT,
Version 4 host server to the storage server
controllers A and B (dual HBAs per host server
configuration.)

When you issue a Subsystem
Management command from the IBM
FASIT Storage Manager client, the
command may be cached. If so, the
system will issue the error: Error 21 -
The Operation cannot complete because
a... is in progress. The IBM FAStT
Storage Manager client will run such
cached commands as soon as the
controller resources become available.

Wait for at least ten minutes; then, check to see
if the IBM FAStT Storage Manager client has run
the command. If it has not, reissue the
command.
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Table 20. Windows operating system limitations and workarounds (continued)

Limitation

Workaround

You must always uninstall IBM FAStT
Storage Manager RDAC before you
uninstall the host bus adapter driver.
Failure to do so may result in a hung
system or blue screen.

None.

When you upgrade the FAStT Storage
Subsystem controller firmware from any
version 05.00.xx.xx (or earlier) to version
05.2x.xx.xx (or later), the controller
returns the first four bytes of the firmware
revision to the Product Revision Field of
the SCSI LUN inquiry data. Windows
2000 uses this Product Revision data as
part of its LUN identification method. In
doing so, Windows 2000 incorrectly
interpretes your upgrade of the firmware
revision level and subsequent Product
Revision data change to mean that you
have also removed LUNs with the original
Product Revision data from the server.

When the FASIT Storage Manager
hot_add utility later executes the scan for
hardware changes task, or when you
select the Scan For Hardware Changes
menu option of the Devices folder in the
Computer Management window, Windows
2000 displays the Unsafe Removal of
Devices dialogs for the original LUNs. The
devices cited in these dialogs are RDAC
Virtual Disks and xxxx SCSI devices,
where xxxx represents either 1722, 1742,
3552 or 3542, depending on the machine
type of the FAStT Storage Server from
which Windows 2000 had mapped the
original LUNs. Under these
circumstances, the Windows 2000 server
will lose connectivity to the LUNSs in the
FASIT Storage Subsystem whose
controller firmware you updated.

This problem will not occur when you
upgrade the FAStT Storage Subsystem
controller firmware from version
05.20.xx.xx to version 05.3x.xx.xx or later
because the Product Revision data field
was fixed at 0520.

After you apply the new FASIT Storage
Subsystem controller firmware and NVSRAM,
you must perform one of the following
procedures reconnect FAStT Storage Servers to
their logical drives:

* Re-scan the server for hardware changes.
* Add the logical drives back to the server.

* Reboot all of the Windows 2000 servers that
originally had LUNs mapped in the affected
FAStT Storage Subsystem.

Direct-management method workaround

Perform the following steps for the direct-management method workaround:
1. Connect the two controller Ethernet ports to the network.

2. Follow the direct-management setup instructions in|Chapter 2, “Preparing for|
[installation,” on page 31|to manage the subsystem directly.

3. Open the Storage Manager 8 Enterprise Management window. Click Edit »+ Add

device.
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Type the IP address for the first controller and click Add.
Repeat to add the IP address of the additional controllers.
Click Close.

Right-click the newly added storage subsystem and select Manage Device. The
Subsystem Management window for the storage subsystem opens. Proceed
with the storage subsystem management tasks.

N o ok

SMagent workaround for defining additional access LUN mapping
Perform the following steps to define additional access LUN mapping for SMagent:

1. Go to a different computer that has management access to the storage
subsystem, or establish a direct management connection to the storage
subsystem from the current host.

2. Start the IBM FASET Storage Manager 8.4 Client and open the Subsystem
Management window for the storage subsystem.

Click the Mappings View tab.

Right-click the Default Group and select Define Additional mappings.
Select Access.

From the LUN drop-down menu, select Logical Unit Number (LUN) 31.
Click Add to define the access LUN.

Click Close. In the Define Mapping pane, a LUN with the Access name
displays.

9. Close the window and restart the host. When the host restarts, the SMagent
service starts.

© N oA~

SMagent workaround for changing existing access LUN mapping
Perform the following steps to change existing access LUN mapping:

1. Go to a different computer that has management access to the storage
subsystem, or establish a direct management connection to the storage
subsystem from the current host.

2. Start the IBM FAStT Storage Manager 8.4 Client and open the Subsystem
Management window for the storage subsystem.

3. Click the Mappings View tab.

4. From the topology pane, select the Default Group or the corresponding host
partition.

5. Right-click Access and select Change Mapping. A Change Mapping window
opens.

6. From the LUN drop-down menu, select the LUN that your operating system
supports. If it is not available, you must remove one of the existing storage
partitioning mappings.

7. Click OK.

8. Close the window and restart the host. When the host restarts, the SMagent
service starts.
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Appendix B. NetWare operating system limitations

This appendix contains information about how to operate the storage management

software in a NetWare environment.

Important: Always check for a readme file on any installation media. This readme
file might contain important information that was not available when this document

was prepared.

able 21| lists the limitations that apply when you use the IBM FAStT Storage

Manager Version 8.4 with Novell NetWare.

Table 21. Novell NetWare limitations and workarounds

Limitation

Workaround

If the SMagent is running on the NetWare
server and a fiber-optic cable is pulled or a
path failure occurs, the NetWare server might
end.

Stop the SMagent and manage the FAStT
using the direct (out-of-band) method of
management. See [‘Stopping the host-agent]
|software” on page 124{and use the procedure
for uninstalling the SMagent software.

Clicking a vertical scroll arrow (either up or
down) causes the scroll box to move all the
way to the opposite end of the scroll bar.

This is a known defect in the Java Runtime
Environment. Click the scroll box and slide it
until you reach the desired position in the
Help window.

Logical drive migration (removing a set of
drives that are configured with logical drives
from one storage subsystem for insertion into
another storage subsystem) is not supported
because it could cause loss of configuration.

Call for service.

When you manage storage subsystems
through the host-agent software and use the
storage management software to download
controller firmware, the download process
can take up to 10 minutes to complete.

None.

The controller firmware does not recognize or
communicate with a single controller until slot
A is populated. This limitation does not apply
to storage subsystems that were originally
configured with two controllers.

When you configure a new storage
subsystem with a single controller, you must
place the controller in slot A.

Public loop configurations (managed hubs
that are attached to switches) are not
supported.

None.

Multipath failover will work only if the storage
controllers are in active/active mode.

When you configure the storage subsystem,
change both controllers to active status.

When you remove a fan or power supply field
replaceable unit (FRU) from a storage
subsystem while the system is running, the
storage management software does not
report an error message, and the component
is not reported as missing.

Note: Fan and power supply FRU failures
are reported.

Replace the missing fan or power supply
FRUs immediately to ensure redundancy.
Make sure that the fan or power supply FRU
is properly seated in the controller unit.

Your windows and online Help displays a
brownish hash pattern when you run in
256-color mode.

Run the Storage Manager 8.4 application in a
higher display mode.
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Table 21. Novell NetWare limitations and workarounds (continued)

Limitation

Workaround

When performing a redundancy check (parity
scan) from the storage management
application, machine type 3542 can take
several minutes longer than machine type
3526 and 3552 controller platforms.

None.

When attempting to manage a storage
subsystem where the RAID controller unit
does not have access to logical drives,
Storage Manager prompts you for a
password. This occurs even if no password
has been set up. The automatic discovery
locates and identifies each storage
subsystem as two separate storage
subsystems.

Ensure that at least one IBM FAStT EXP700
Storage Expansion Unit with at least one
logical drive is properly attached to the IBM
FAStT700 RAID controller unit in each
storage subsystem being managed. The
RAID controller unit should not be powered
on until the expansion units are attached and
powered on. Power off the RAID controller
unit, properly attach all expansion units with
the drives installed to the RAID controller
unit, and power them on; then, power on the
RAID controller unit. At this point, the storage
subsystems can be rediscovered and
managed by using the FASIT Storage
Manager software.

You might not see the maximum number of
drives during Automatic Configuration if you
are using drives of different capacities.

Use Manual Configuration to select individual
drives and select the maximum number of
drives allowed.

When you connect an IBM TotalStorage
FAStT EXP700 Storage Expansion Unit to a
FAStT200, the drive speed must be set to 1
Gbps.

None.

When you issue a Subsystem Management
command from the IBM FAStT Storage
Manager client, the command may be
cached. If so, the system issues the error:
Error 21 - The Operation cannot complete
because a... is in progress. The IBM
FASIT Storage Manager client will run such
cached commands as soon as the controller
resources become available.

Wait for at least ten minutes; then, check to
see if the IBM FAStT Storage Manager client
has run the command. If it has not, reissue
the command.

134 1BM TotalStorage FASIT Storage Manager Version 8.4x Installation and Support Guide for Intel-based Operating System

Environments



Appendix C. Linux operating system limitations

This appendix contains information that is specific to operating the storage
management software in a Linux environment.

Important: Always check for a readme file on any installation media. This readme
file contains information that was not available when this document was prepared.

lists the limitations that apply when you use the IBM FAStT Storage

Manager Version 8.4 with Linux.

Table 22. Linux limitations and workarounds

Limitations

Workaround

Vixel Rapport 2000 fibre-channel hubs using
controllers with firmware version 04.01.02
cause problems, including damage to data,
system instability, and disrupted loop activity.

Do not use Vixel Rapport 2000 fibre-channel
hubs when your system is operating in a
controller or an 1/O path fault-tolerant
environment.

The maximum number of physical drives
allowed in a single RAID 5 logical drive is 29.
The maximum number of physical drives
allowed in a single RAID 1 logical drive is 28.

None.

After removing all drives from a storage
subsystem, you are prompted for a password
at software startup or when you perform
protected operations, all passwords you enter
fail.

Add one of the drives to the storage
subsystem and attempt the operation again.

Removing a set of drives that are configured
with logical drives from one storage
subsystem for insertion into another storage
subsystem is not supported because it might
cause loss of configuration.

Contact an IBM technical support
representative for assistance.

A standard non-network configuration is not
supported when the Linux host does not have
the TCP/IP software installed.

Install the TCP/IP software on the Linux host
computer and assign the host a static IP
address.

Multipath failover will work only if the storage
controllers are in active/active mode.

When you configure the storage subsystem,
change both controllers to active status.

The controller firmware does not recognize or
communicate with a single controller until slot
A is populated. This restriction does not apply
to storage subsystems that were originally
configured with two controllers.

When you configure a new storage
subsystem with a single controller, you must
place the controller in slot A.

Your windows and online help display a
brownish hash pattern when you run in
256-color mode.

Run the Storage Manager 8.4 application in a
higher display mode.

When you perform a redundancy check
(parity scan) from the storage management
application, machine type 3542 can take
several minutes longer than machine type
1742 and 3552 controller platforms.

None.

You might not see the maximum number of
drives during Automatic Configuration if you
are using drives of different capacities.

Use Manual Configuration to select individual
drives and select the maximum number of
drives allowed.
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Table 22. Linux limitations and workarounds (continued)

Limitations

Workaround

When you connect an IBM TotalStorage
FASIT EXP700 Storage Expansion Unit to a
FAStT200, the drive speed must be set to 1
Gbps.

None.

When you issue a Subsystem Management
command from the IBM FAStT Storage
Manager client, the command may be

cached. If so, the system will issue the error:

Error 21 - The Operation cannot complete
because a... is in progress. The IBM
FASIT Storage Manager client will run such
cached commands as soon as the controller
resources become available.

Wait for at least ten minutes; then, check to
see if the IBM FAStT Storage Manager client
has run the command. If it has not, re-issue
the command.
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Appendix D. VMware ESX Server operating system limitations

This appendix contains information about how to operate the storage management
software in a VMware ESX Server environment.

Important: Always check for a readme file on any installation media. This readme
file might contain important information that was not available when this document

was prepared.

lists the limitations that apply when you use IBM FASLtT Storage Manager

Version 8.4 with VMware ESX Server.

Table 23. VMware ESX Server limitations and workarounds

Limitations

Workaround

VMware ESX 2.0 clustering function is not
supported. Clustering between guest
operating systems is not supported.

None.

For information about possible support in
future releases, contact your IBM service
representative or submit an RPQ.

The maximum number of guest operating
systems that are supported on each VMware
ESX 2.0 server is 16.

None.

For information about possible support in
future releases, contact your IBM service
representative or submit an RPQ.

New logical volumes cannot be successfully
created and assigned to a guest operating
system.

Although a guest operating system can scan
for new disk volumes dynamically, the guest
operating system must be powered off before
new logical volumes can be created within
VMware ESX Server and assigned to that
guest.

When you issue a Subsystem Management
command from the IBM FAStT Storage
Manager client, the command may be
cached. If so, the system will issue the error:
Error 21 - The Operation cannot complete
because a... is in progress. The IBM
FASIT Storage Manager client will run such
cached commands as soon as the controller
resources become available.

Wait for at least ten minutes; then, check to
see if the IBM FAStT Storage Manager client
has run the command. If it has not, reissue
the command.
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Appendix E. Storage subsystem and controller information

record

provides a data sheet for recording storage subsystem names,
management types, Ethernet hardware addresses, and IP addresses. Make a copy
of this table and complete the information for your storage subsystems and
controllers. Use the information to set up the BOOTP table for the network server
and the host or Domain Name System (DNS) table. The information is also helpful
if you add storage subsystems after initial installation. The column headings show a
page reference for detailed instructions about how to obtain the information. For a
sample information record, refer to[Table 14 on page 35

Table 24. Storage subsystem and controller information record

Storage
subsystem
name (page

Management
method (page

Controllers-Ethernet and IP
addresses, and host name (pages

B4]and B7)

Host-IP address
and host name

(page
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Appendix F. Additional FASIT documentation

The following tables present an overview of the FAStT900, FAStT700, and
FAStT600 Fibre Channel Storage Server product libraries, as well as other related
documents. Each table lists documents that are included in the libraries and what
common tasks they address. Click on active links in the tables to access those
documents currently available on the Internet. You can access documentation for

the other FASIT products at the following Web site:

issddom02.storage.ibm.com/techsup/webnav.nsf/support/fastt/|

FAStT900 Fibre Channel Storage Server library

associates each document in the FAStT900 Fibre Channel Storage Server
library with its related common user tasks.

Table 25. TotalStorage FAStT900 Fibre Channel Storage Server document titles by user tasks

Title

User Tasks

Planning

Hardware
Installation

Software
Installation

Configuration

Operation and
Administration

Diagnosis and
Maintenance

IBM TotaIStorage|
FAStT900

Installation and
Support Guide,

GC26-7530]

IBM TotalStorage
FAStT900 Fibre
Channel Cablin
Instructions,
24P8135

IBM TotaIStorage|

FAStT900 Storage]
Server User's|
Guide, GC26-7534

IBM TotaIStorage|

FAStT FC2-133 Dual|
Port Host Bus|
Adapter Installation|
and User’s Guide,|

GC26-7532f

IBM FAStT FC2-133
Host Bus Adaptet|
Installation and
User's Guide,
48P9823

IBM TotalStorag
FAStT900 Rack
Mountin
Instructions,
19K0900

0]
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http://ssddom02.storage.ibm.com/techsup/webnav.nsf/support/fastt
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/24p8136.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/24p8136.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/24p8136.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/24p8136.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/24p8136.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/24p8135.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/24p8135.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/24p8135.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/24p8135.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/24p8135.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/gc26-7534.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/gc26-7534.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/gc26-7534.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/gc26-7534.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/48p9823.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/48p9823.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/48p9823.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/48p9823.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/48p9823.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/19k0900.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/19k0900.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/19k0900.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/19k0900.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/19k0900.pdf

Table 25. TotalStorage FAStT900 Fibre Channel Storage Server document titles by user tasks (continued)

Title

User Tasks

Planning

Hardware
Installation

Software
Installation

Configuration

Operation and
Administration

Diagnosis and
Maintenance

IBM Fibre Channel|
Planning and
Integration: User’s|
Guide and Service|

Information,
SC23-432

IBM FAStT|

Management Suite
Java User’s Guide,
32P0081

IBM TotaIStora§e|
FAStT Fibre)

Channel Hardware|
Maintenance Manual

and Problem
Determination

Guide, GC26-7528|
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http://www-1.ibm.com/servers/eserver/pseries/library/hardware_docs/a4a/234329.pdf
http://www-1.ibm.com/servers/eserver/pseries/library/hardware_docs/a4a/234329.pdf
http://www-1.ibm.com/servers/eserver/pseries/library/hardware_docs/a4a/234329.pdf
http://www-1.ibm.com/servers/eserver/pseries/library/hardware_docs/a4a/234329.pdf
http://www-1.ibm.com/servers/eserver/pseries/library/hardware_docs/a4a/234329.pdf
http://www-1.ibm.com/servers/eserver/pseries/library/hardware_docs/a4a/234329.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/32p0081.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/32p0081.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/32p0081.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/32p0081.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/hmpd4.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/hmpd4.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/hmpd4.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/hmpd4.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/hmpd4.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/hmpd4.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/hmpd4.pdf

FAStT700 Fibre Channel Storage Server library

associates each document in the FAStT700 Fibre Channel Storage Server
library with its related common user tasks.

Table 26. TotalStorage FAStT700 Fibre Channel Storage Server document titles by user tasks

Title

User Tasks

Planning

Hardware
Installation

Software
Installation

Configuration

Operation and
Administration

Diagnosis and
Maintenance

IBM FAStT700
Installation and
Support Guide,
32P0171

IBM FAStT700 Fibrel
Channel Cablin
Instructions,|
32P0343

IBM FAStT700 Fibre|
Channel Storage
Server User’'s
Guide, 32P0341

IBM FAStT FC2-133
Dual Port Host Bus|
Adapter Installation|
and User’s Guide,|

GC26-7532f

IBM TotaIStorage|

FAStT FC2-133 Host|
Bus Adapte

IBM FASHT]

Management Suite
Java User’s Guide,
32P0081

IBM Fibre Channel|

Hardware
Maintenanc

Manual, 19K6130|

IBM Fibre Channel
Problem
Determination
Guide, 48P980
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ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/32p0171.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/32p0171.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/32p0171.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/32p0171.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/32p0343.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/32p0343.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/32p0343.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/32p0343.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/32p0341.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/32p0341.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/32p0341.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/32p0341.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/48p9823.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/48p9823.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/48p9823.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/48p9823.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/48p9823.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/48p9823.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/32p0081.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/32p0081.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/32p0081.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/32p0081.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/19k6130.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/19k6130.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/19k6130.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/19k6130.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/48p9804r.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/48p9804r.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/48p9804r.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/48p9804r.pdf

FAStT600 Fibre Channel Storage Server library

associates each document in the FAStT600 Fibre Channel Storage Server
library with its related common user tasks.

Table 27. TotalStorage FAStT600 Fibre Channel Storage Server document titles by user tasks

Title

User Tasks

Planning

Hardware
Installation

Software
Installation

Configuration

Operation and
Administration

Diagnosis and
Maintenance

IBM TotalStorage
FAStT600 Fibre
Channel Storage|

Server Installation]|
land User’s Guide,|

GC26-7531]

IBM TotalStorage)
FAStT Fibre)

Channel Hardware|
Maintenance Manual
and Problem|
Determination

Guide, GC26-7528)

IBM TotaIStorage|

FAStT FC2-133 Dual|
Port Host Bus|
[Adapter Installation|
and User’s Guide,|

GC26-7532f

IBM TotalStorage
FAStT600 Rack
Mounting
Instructions,
24P8125

IBM TotalStorage
FAStT600 Cabling
Instructions,
24P8126
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ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/f602iug.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/f602iug.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/f602iug.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/f602iug.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/f602iug.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/f602iug.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/hmpd4.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/hmpd4.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/hmpd4.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/hmpd4.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/hmpd4.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/hmpd4.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/hmpd4.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/gc26-7532.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/gc26-7532.pdf

FAStT-related documents
associates each of the following documents related to FAST operations

with its related common user tasks.

Table 28. TotalStorage FAStT related document titles by user tasks

Title

User Tasks

Planning

Hardware
Installation

Software
Installation

Configuration

Operation and
Administration

Diagnosis and
Maintenance

IBM Safety
Information,
P48P9741

’/

IBM TotaIStora?e|
FAStT EXP100
Storage Expansion|
Unit Release Notes,|

GC26-7619

IBM TotaIStora?el
FAStT EXP100
Storage Expansion|
Unit Installation and|

Users Guide,
GC26-7601

U

Fibre Channel
Solutions - IBM
FAStT EXP500
Installation and

User's Guide,
59p5637|

IBM EXP700
Storage Expansion|
Unit Installation and|
User's Guide,
32P0178

IBM Netfinity® Fibre]
Channel Cabling
Instructions,
19K0906,

IBM Fibre Channell
SAN Configuration|
Setup Guide,
25P2509
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ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/24p8851.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/24p8851.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/24p8851.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/24p8851.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/24p8851.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/exp1uig0.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/exp1uig0.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/exp1uig0.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/exp1uig0.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/exp1uig0.pdf
ftp://ftp.pc.ibm.com/pub/pccbbs/pc_servers_pdf/exp1uig0.pdf
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Notices

This publication was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may be
used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give you any
license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing

IBM Corporation

North Castle Drive

Armonk, NY 10504-1785

U.S.A.

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A
PARTICULAR PURPOSE. Some jurisdictions do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply to
you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements and/or
changes in the product(s) and/or the program(s) described in this publication at any
time without notice.

Any references in this publication to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those
Web sites. The materials at those Web sites are not part of the materials for this
IBM product, and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes
appropriate without incurring any obligation to you.

Trademarks

The following are trademarks of International Business Machines Corporation in the
United States, other countries, or both:

AIX IntelliStation
e-business logo Netfinity

the eServer logo ServerProven
FlashCopy TotalStorage
IBM xSeries
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IBMLink
Intel and Pentium are trademarks of Intel Corporation in the United States, other
countries, or both.

Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation in
the United States, other countries, or both.

Java and all Java-based trademarks and logos are trademarks or registered
trademarks of Sun Microsystems, Inc. in the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Other company, product, or service names may be the trademarks or service marks
of others.

Important notes

Processor speeds indicate the internal clock speed of the microprocessor; other
factors also affect application performance.

CD-ROM drive speeds list the variable read rate. Actual speeds vary and are often
less than the maximum possible.

When referring to processor storage, real and virtual storage, or channel volume,
KB stands for approximately 1000 bytes, MB stands for approximately 1 000 000
bytes, and GB stands for approximately 1 000 000 000 bytes.

When referring to hard disk drive capacity or communications volume, MB stands
for 1 000 000 bytes, and GB stands for 1 000 000 000 bytes. Total user-accessible
capacity may vary depending on operating environments.

Maximum internal hard disk drive capacities assume the replacement of any
standard hard disk drives and population of all hard disk drive bays with the largest
currently supported drives available from IBM.

Maximum memory may require replacement of the standard memory with an
optional memory module.

IBM makes no representation or warranties regarding non-IBM products and
services that are ServerProven®, including but not limited to the implied warranties
of merchantability and fitness for a particular purpose. These products are offered
and warranted solely by third parties.

IBM makes no representations or warranties with respect to non-IBM products.
Support (if any) for the non-IBM products is provided by the third party, not IBM.

Some software may differ from its retail version (if available), and may not include
user manuals or all program functionality.
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Glossary

This glossary provides definitions for the
terminology used for the IBM TotalStorage FAStT.
This glossary also provides definitions for the
terminology used for the IBM TotalStorage FAStT
Storage Manager.

This glossary defines technical terms and
abbreviations used in this document. If you do not
find the term you are looking for, see the IBM
Glossary of Computing Terms located at
www.ibm.com/networking/nsg/nsgmain.htm

This glossary also includes terms and definitions
from:

» Information Technology Vocabulary by
Subcommittee 1, Joint Technical Committee 1,
of the International Organization for
Standardization and the International
Electrotechnical Commission (ISO/IEC
JTC1/SCH1). Definitions are identified by the
symbol (l) after the definition; definitions taken
from draft international standards, committee
drafts, and working papers by ISO/IEC
JTC1/SC1 are identified by the symbol (T) after
the definition, indicating that final agreement
has not yet been reached among the
participating National Bodies of SC1.

* IBM Glossary of Computing Terms. New York:
McGraw-Hill, 1994.

The following cross-reference conventions are
used in this glossary:

See Refers you to (a) a term that is the
expanded form of an abbreviation or
acronym, or (b) a synonym or more
preferred term.

See also
Refers you to a related term.

Abstract Windowing Toolkit (AWT). A Java graphical
user interface (GUI).

accelerated graphics port (AGP). A bus specification
that gives low-cost 3D graphics cards faster access to
main memory on personal computers than the usual
peripheral component interconnect (PCI) bus. AGP
reduces the overall cost of creating high-end graphics
subsystems by using existing system memory.

access volume. A special logical drive that allows the
host-agent to communicate with the controllers in the
storage subsystem.

© Copyright IBM Corp. 2004

adapter. A printed circuit assembly that transmits user
data input/output (I/0O) between the internal bus of the
host system and the external fibre-channel (FC) link and
vice versa. Also called an I/O adapter, host adapter, or
FC adapter.

advanced technology (AT) bus architecture. A bus
standard for IBM compatibles. It extends the XT bus
architecture to 16 bits and also allows for bus
mastering, although only the first 16 MB of main
memory are available for direct access.

agent. A server program that receives virtual
connections from the network manager (the client
program) in a Simple Network Management
Protocol-Transmission Control Protocol/Internet Protocol
(SNMP-TCP/IP) network-managing environment.

AGP. See accelerated graphics port.
AL_PA. See arbitrated loop physical address.

arbitrated loop. One of three existing fibre-channel
topologies, in which 2 - 126 ports are interconnected
serially in a single loop circuit. Access to the Fibre
Channel-Arbitrated Loop (FC-AL) is controlled by an
arbitration scheme. The FC-AL topology supports all
classes of service and guarantees in-order delivery of
FC frames when the originator and responder are on
the same FC-AL. The default topology for the disk array
is arbitrated loop. An arbitrated loop is sometimes
referred to as a Stealth Mode.

arbitrated loop physical address (AL_PA). An 8-bit
value that is used to uniquely identify an individual port
within a loop. A loop can have one or more AL_PAs.

array. A set of fibre-channel hard drives that are
logically grouped together to form a redundant array of
independent disks (RAID) set.

AT. See advanced technology (AT) bus architecture.
ATA. See AT-attached.

AT-attached. Peripheral devices that are compatible
with the original IBM AT computer standard in which
signals on a 40-pin AT-attached (ATA) ribbon cable
followed the timings and constraints of the Industry
Standard Architecture (ISA) system bus on the IBM PC
AT computer. Equivalent to integrated drive electronics
(IDE).

auto-volume transfer/auto-disk transfer (AVT/ADT).
A function that provides automatic failover in case of
controller failure on a storage subsystem.

AVT/ADT. See auto-volume transfer/auto-disk transfer.

AWT. See Abstract Windowing Toolkit.

149



basic input/output system (BIOS). The personal
computer code that controls basic hardware operations,
such as interactions with diskette drives, hard disk
drives, and the keyboard.

BIOS. See basic input/output system.
BOOTP. See bootstrap protocol.

bootstrap protocol (BOOTP). In Transmission Control
Protocol/Internet Protocol (TCP/IP) networking, an
alternative protocol by which a diskless machine can
obtain its Internet Protocol (IP) address and such
configuration information as IP addresses of various
servers from a BOOTP server.

bridge. A storage area network (SAN) device that
provides physical and transport conversion, such as
fibre channel to small computer system interface (SCSI)
bridge.

bridge group. A bridge and the collection of devices
connected to it.

broadcast. The simultaneous transmission of data to
more than one destination.

cathode ray tube (CRT). A display device in which
controlled electron beams are used to display
alphanumeric or graphical data on an
electroluminescent screen.

client. A computer system or process that requests a
service of another computer system or process that is
typically referred to as a server. Multiple clients can
share access to a common server.

command. A statement used to initiate an action or
start a service. A command consists of the command
name abbreviation, and its parameters and flags if
applicable. A command can be issued by typing it on a
command line or selecting it from a menu.

community string. The name of a community
contained in each Simple Network Management
Protocol (SNMP) message.

CRC. See cyclic redundancy check.
CRT. See cathode ray tube.
CRU. See customer replaceable unit.

customer replaceable unit (CRU). An assembly or
part that a customer can replace in its entirety when any
of its components fail. Contrast with field replaceable
unit (FRU).

cyclic redundancy check (CRC). (1) A redundancy
check in which the check key is generated by a cyclic
algorithm. (2) An error detection technique performed at
both the sending and receiving stations.

dac. See disk array controller.

dar. See disk array router.
DASD. See direct access storage device.

default host group. A logical collection of discovered
host ports, defined host computers, and defined host
groups in the storage-partition topology that fulfill the
following requirements:

= Are not involved in specific logical drive-to-LUN
mappings

+ Share access to logical drives with default logical
drive-to-LUN mappings

device type. Identifier used to place devices in the
physical map, such as the switch, hub, or storage.

DHCP. See Dynamic Host Configuration Protocol.

direct access storage device (DASD). A device in
which access time is effectively independent of the
location of the data. Information is entered and retrieved
without reference to previously accessed data. (For
example, a disk drive is a DASD, in contrast with a tape
drive, which stores data as a linear sequence.) DASDs
include both fixed and removable storage devices.

direct memory access (DMA). The transfer of data
between memory and an input/output (I/O) device
without processor intervention.

disk array controller (dac). A disk array controller
device that represents the two controllers of an array.
See also disk array router.

disk array router (dar). A disk array router that
represents an entire array, including current and
deferred paths to all logical unit numbers (LUNSs) (hdisks
on AIX). See also disk array controller.

DMA. See direct memory access.

domain. The most significant byte in the node port
(N_port) identifier for the fibre-channel (FC) device. It is
not used in the fibre channel-small computer system
interface (FC-SCSI) hardware path ID. It is required to
be the same for all SCSI targets logically connected to
an FC adapter.

DRAM. See dynamic random access memory.

Dynamic Host Configuration Protocol (DHCP). A
protocol defined by the Internet Engineering Task Force
that is used for dynamically assigning Internet Protocol
(IP) addresses to computers in a network.

dynamic random access memory (DRAM). A
storage in which the cells require repetitive application
of control signals to retain stored data.

ECC. See error correction coding.

EEPROM. See electrically erasable programmable
read-only memory.
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EISA. See Extended Industry Standard Architecture.

electrically erasable programmable read-only
memory (EEPROM). A type of memory chip which can
retain its contents without consistent electrical power.
Unlike the PROM which can be programmed only once,
the EEPROM can be erased electrically. Because it can
only be reprogrammed a limited number of times before
it wears out, it is appropriate for storing small amounts
of data that are changed infrequently.

electrostatic discharge (ESD). The flow of current
that results when objects that have a static charge
come into close enough proximity to discharge.

environmental services monitor (ESM) canister. A
component in a drive enclosure that monitors the
environmental condition of the components in that
enclosure. Not all storage subsystems have ESM
canisters.

E_port. See expansion port.

error correction coding (ECC). A method for
encoding data so that transmission errors can be
detected and corrected by examining the data on the
receiving end. Most ECCs are characterized by the
maximum number of errors they can detect and correct.

ESD. See electrostatic discharge.

ESM canister. See environmental services monitor
canister.

EXP. See expansion unit.

expansion port (E_port). A port that connects the
switches for two fabrics.

expansion unit (EXP). A feature that can be
connected to a system unit to provide additional storage
and processing capacity.

Extended Industry Standard Architecture (EISA). A
bus standard for IBM compatibles that extends the
Industry Standard Architecture (ISA) bus architecture to
32 bits and allows more than one central processing
unit (CPU) to share the bus. See also Industry Standard
Architecture.

fabric. A Fibre Channel entity which interconnects and
facilitates logins of N_ports attached to it. The fabric is
responsible for routing frames between source and
destination N_ports using address information in the
frame header. A fabric can be as simple as a
point-to-point channel between two N-ports, or as
complex as a frame-routing switch that provides multiple
and redundant internal pathways within the fabric
between F_ports.

fabric port (F_port). In a fabric, an access point for
connecting a user's N_port. An F_port facilitates N_port

logins to the fabric from nodes connected to the fabric.
An F_port is addressable by the N_port connected to it.
See also fabric.

FAStT MSJ. See FAS!T Management Suite Java.

FAStT Management Suite Java (FAStT MSJ). A
diagnostic and configuration utility that can be used on
Linux, Microsoft Windows, and Novell NetWare host
systems. In Linux, it is also used with the QLRemote
agent to define preferred and non-preferred paths for
logical drives.

FC. See fibre channel.
FC-AL. See arbitrated loop.

feature enable identifier. A unique identifier for the
storage subsystem, which is used in the process of
generating a premium feature key. See also premium
feature key.

fibre channel (FC). A set of standards for a serial
input/output (1/0) bus capable of transferring data
between two ports at up to 100 Mbps, with standards
proposals to go to higher speeds. FC supports
point-to-point, arbitrated loop, and switched topologies.

Fibre Channel-Arbitrated Loop (FC-AL). See
arbitrated loop.

Fibre Channel Protocol (FCP) for small computer
system interface (SCSI). A high-level fibre-channel
mapping layer (FC-4) that uses lower-level fibre-channel
(FC-PH) services to transmit SCSI commands, data,
and status information between a SCSI initiator and a
SCSI target across the FC link by using FC frame and
sequence formats.

field replaceable unit (FRU). An assembly that is
replaced in its entirety when any one of its components
fails. In some cases, a field replaceable unit might
contain other field replaceable units. Contrast with
customer replaceable unit (CRU).

FlashCopy. A premium feature for FASIT that can
make an instantaneous copy of the data in a volume.

F_port. See fabric port.
FRU. See field replaceable unit.
GBIC. See gigabit interface converter

gigabit interface converter (GBIC). A transceiver that
performs serial, optical-to-electrical, and
electrical-to-optical signal conversions for high-speed
networking. A GBIC can be hot swapped. See also
small form-factor pluggable.

graphical user interface (GUI). A type of computer
interface that presents a visual metaphor of a real-world
scene, often of a desktop, by combining high-resolution
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graphics, pointing devices, menu bars and other menus,
overlapping windows, icons, and the object-action
relationship.

GUI. See graphical user interface.
HBA. See host bus adapter.

hdisk. An AIX term representing a logical unit number
(LUN) on an array.

host. A system that is directly attached to the storage
subsystem through a fibre-channel input/output (1/O)
path. This system is used to serve data (typically in the
form of files) from the storage subsystem. A system can
be both a storage management station and a host
simultaneously.

host bus adapter (HBA). An interface between the
fibre-channel network and a workstation or server.

host computer. See host.

host group. An entity in the storage partition topology
that defines a logical collection of host computers that
require shared access to one or more logical drives.

host port. Ports that physically reside on the host
adapters and are automatically discovered by the FAStT
Storage Manager software. To give a host computer
access to a partition, its associated host ports must be
defined.

hot swap. To replace a hardware component without
turning off the system.

hub. In a network, a point at which circuits are either
connected or switched. For example, in a star network,
the hub is the central node; in a star/ring network, it is
the location of wiring concentrators.

IBMSAN driver. The device driver that is used in a
Novell NetWare environment to provide multipath
input/output (1/0) support to the storage controller.

IC. See integrated circuit.
IDE. See integrated drive electronics.

in-band. Transmission of management protocol over
the fibre-channel transport.

Industry Standard Architecture (ISA). Unofficial
name for the bus architecture of the IBM PC/XT
personal computer. This bus design included expansion
slots for plugging in various adapter boards. Early
versions had an 8-bit data path, later expanded to 16
bits. The "Extended Industry Standard Architecture”
(EISA) further expanded the data path to 32 bits. See
also Extended Industry Standard Architecture.

initial program load (IPL). The initialization procedure
that causes an operating system to commence
operation. Also referred to as a system restart, system
startup, and boot.

integrated circuit (IC). A microelectronic
semiconductor device that consists of many
interconnected transistors and other components. ICs
are constructed on a small rectangle cut from a silicon
crystal or other semiconductor material. The small size
of these circuits allows high speed, low power
dissipation, and reduced manufacturing cost compared
with board-level integration. Also known as a chip.

integrated drive electronics (IDE). A disk drive
interface based on the 16-bit IBM personal computer
Industry Standard Architecture (ISA) in which the
controller electronics reside on the drive itself,
eliminating the need for a separate adapter card. Also
known as an Advanced Technology Attachment
Interface (ATA).

Internet Protocol (IP). A protocol that routes data
through a network or interconnected networks. IP acts
as an intermediary between the higher protocol layers
and the physical network.

Internet Protocol (IP) address. The unique 32-bit
address that specifies the location of each device or
workstation on the Internet. For example, 9.67.97.103 is
an IP address.

interrupt request (IRQ). A type of input found on
many processors that causes the processor to suspend
normal processing temporarily and start running an
interrupt handler routine. Some processors have several
interrupt request inputs that allow different priority
interrupts.

IP. See Internet Protocol.

IPL. See initial program load.

IRQ. See interrupt request.

ISA. See Industry Standard Architecture.

isolated group. A collection of isolated devices not
connected to the storage area network (SAN) but
discovered by the SANavigator tool. The isolated group
displays with a gray background near the bottom of the
Physical and Data Path maps.

Java Runtime Environment (JRE). A subset of the
Java Development Kit (JDK) for end users and
developers who want to redistribute the Java Runtime
Environment (JRE). The JRE consists of the Java virtual
machine, the Java Core Classes, and supporting files.

JRE. See Java Runtime Environment.
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label. A discovered or user entered property value that
is displayed underneath each device in the Physical and
Data Path maps.

LAN. See local area network.
LBA. See logical block address.

local area network (LAN). A computer network
located on a user’s premises within a limited geographic
area.

logical block address (LBA). The address of a logical
block. Logical block addresses are typically used in
hosts’ /0 commands. The SCSI disk command
protocol, for example, uses logical block addresses.

logical unit number (LUN). An identifier used on a
small computer system interface (SCSI) bus to
distinguish among up to eight devices (logical units) with
the same SCSI ID.

loop address. The unique ID of a node in
fibre-channel loop topology sometimes referred to as a
loop ID.

loop group. A collection of storage area network
(SAN) devices that are interconnected serially in a
single loop circuit. Loop groups are discovered by the
SANavigator tool and displayed with a gray background
on the Physical and Data Path maps.

loop port. A node port (N_port) or fabric port (F_port)
that supports arbitrated loop functions associated with
an arbitrated loop topology.

LUN. See logical unit number.
MAC. See medium access control.

management information base (MIB). The
information that is on an agent. It is an abstraction of
configuration and status information.

man pages. In UNIX-based operating systems, online
documentation for operating system commands,
subroutines, system calls, file formats, special files,
stand-alone utilities, and miscellaneous facilities.
Invoked by the man command.

MCA. See micro channel architecture.

medium access control (MAC). In local area
networks (LANSs), the sublayer of the data link control
layer that supports medium-dependent functions and
uses the services of the physical layer to provide
services to the logical link control sublayer. The MAC
sublayer includes the method of determining when a
device has access to the transmission medium.

MIB. See management information base.

micro channel architecture (MCA). Hardware that is
used for PS/2 Model 50 computers and above to

provide better growth potential and performance
characteristics when compared with the original
personal computer design.

Microsoft Cluster Server (MSCS). MSCS, a feature
of Windows NT Server (Enterprise Edition), supports the
connection of two servers into a cluster for higher
availability and easier manageability. MSCS can
automatically detect and recover from server or
application failures. It can also be used to balance
server workload and provide for planned maintenance.

model. The model identification that is assigned to a
device by its manufacturer.

MSCS. See Microsoft Cluster Server.

network management station (NMS). In the Simple
Network Management Protocol (SNMP), a station that
runs management application programs that monitor
and control network elements.

NMI. See non-maskable interrupt.
NMS. See network management station.

non-maskable interrupt (NMI). A hardware interrupt
that another service request cannot overrule (mask). An
NMI bypasses and takes priority over interrupt requests
generated by software, the keyboard, and other such
devices and is issued to the microprocessor only in
disastrous circumstances, such as severe memory
errors or impending power failures.

node. A physical device that allows for the
transmission of data within a network.

node port (N_port). A fibre-channel defined hardware
entity that performs data communications over the
fibre-channel link. It is identifiable by a unique worldwide
name. It can act as an originator or a responder.

nonvolatile storage (NVS). A storage device whose
contents are not lost when power is cut off.

N_port. See node port.
NVS. See nonvolatile storage.

NVSRAM. Nonvolatile storage random access
memory. See nonvolatile storage.

Object Data Manager (ODM). An AIX proprietary
storage mechanism for ASCII stanza files that are
edited as part of configuring a drive into the kernel.

ODM. See Object Data Manager.

out-of-band. Transmission of management protocols
outside of the fibre-channel network, typically over
Ethernet.

PCI local bus. See peripheral component interconnect
local bus.

Glossary 153



PDF. See portable document format.

performance events. Events related to thresholds set
on storage area network (SAN) performance.

peripheral component interconnect local bus (PCI
local bus). A local bus for PCs, from Intel, that
provides a high-speed data path between the CPU and
up to 10 peripherals (video, disk, network, and so on).
The PCI bus coexists in the PC with the Industry
Standard Architecture (ISA) or Extended Industry
Standard Architecture (EISA) bus. ISA and EISA boards
plug into an IA or EISA slot, while high-speed PCI
controllers plug into a PCI slot. See also Industry
Standard Architecture, Extended Industry Standard
Architecture.

polling delay. The time in seconds between
successive discovery processes during which discovery
is inactive.

port. A part of the system unit or remote controller to
which cables for external devices (such as display
stations, terminals, printers, switches, or external
storage units) are attached. The port is an access point
for data entry or exit. A device can contain one or more
ports.

portable document format (PDF). A standard
specified by Adobe Systems, Incorporated, for the
electronic distribution of documents. PDF files are
compact; can be distributed globally by e-mail, the Web,
intranets, or CD-ROM; and can be viewed with the
Acrobat Reader, which is software from Adobe Systems
that can be downloaded at no cost from the Adobe
Systems home page.

premium feature key. A file that the storage
subsystem controller uses to enable an authorized
premium feature. The file contains the feature enable
identifier of the storage subsystem for which the
premium feature is authorized, and data about the
premium feature. See also feature enable identifier.

private loop. A freestanding arbitrated loop with no
fabric attachment. See also arbitrated loop.

program temporary fix (PTF). A temporary solution or
bypass of a problem diagnosed by IBM in a current
unaltered release of the program.

PTF. See program temporary fix.
RAID. See redundant array of independent disks.
RAM. See random-access memory.

random-access memory (RAM). A temporary storage
location in which the central processing unit (CPU)
stores and executes its processes. Contrast with DASD.

RDAC. See redundant disk array controller.

read-only memory (ROM). Memory in which stored
data cannot be changed by the user except under
special conditions.

recoverable virtual shared disk (RVSD). A virtual
shared disk on a server node configured to provide
continuous access to data and file systems in a cluster.

redundant array of independent disks (RAID). A
collection of disk drives that appears as a single volume
to the server and are fault tolerant through mirroring or
parity checking.

redundant disk array controller (RDAC). (1) In
hardware, a redundant set of controllers (either
active/passive or active/active). (2) In software, a layer
that manages the input/output (1/O) through the active
controller during normal operation and transparently
reroutes 1/Os to the other controller in the redundant set
if a controller or 1/0 path fails.

ROM. See read-only memory.

router. A computer that determines the path of
network traffic flow. The path selection is made from
several paths based on information obtained from
specific protocols, algorithms that attempt to identify the
shortest or best path, and other criteria such as metrics
or protocol-specific destination addresses.

RVSD. See recoverable virtual shared disk.
SAl. See Storage Array Identifier.

SA Identifier. See Storage Array Identifier.
SAN. See storage area network.

SATA. See serial ATA.

scope. Defines a group of controllers by their Internet
Protocol (IP) addresses. A scope must be created and
defined so that dynamic IP addresses can be assigned
to controllers on the network.

SCSI. See small computer system interface.

segmented loop port (SL_port). A port that allows
division of a fibre-channel private loop into multiple
segments. Each segment can pass frames around as
an independent loop and can connect through the fabric
to other segments of the same loop.

sense data. (1) Data sent with a negative response,
indicating the reason for the response. (2) Data
describing an I/O error. Sense data is presented to a
host system in response to a sense request command.

serial ATA. The standard for a high-speed alternative
to small computer system interface (SCSI) hard drives.
The SATA-1 standard is equivalent in performance to a
10 000 RPM SCSI drive.
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serial storage architecture (SSA). An interface
specification from IBM in which devices are arranged in
a ring topology. SSA, which is compatible with small
computer system interface (SCSI) devices, allows
full-duplex packet multiplexed serial data transfers at
rates of 20 Mbps in each direction.

server. A functional hardware and software unit that
delivers shared resources to workstation client units on
a computer network.

server/device events. Events that occur on the server
or a designated device that meet criteria that the user
sets.

SFP. See small form-factor pluggable.

Simple Network Management Protocol (SNMP). In
the Internet suite of protocols, a network management
protocol that is used to monitor routers and attached
networks. SNMP is an application layer protocol.
Information on devices managed is defined and stored
in the application’s Management Information Base
(MIB).

SL_port. See segmented loop port.

SMagent. The FASIT Storage Manager optional
Java-based host-agent software, which can be used on
Microsoft Windows, Novell NetWare, HP-UX, and
Solaris host systems to manage storage subsystems
through the host fibre-channel connection.

SMclient. The FAStT Storage Manager client software,
which is a Java-based graphical user interface (GUI)
that is used to configure, manage, and troubleshoot
storage servers and expansion units in a FAStT storage
subsystem. SMclient can be used on a host system or
on a storage management station.

SMruntime. A Java compiler for the SMclient.

SMutil. The FASIT Storage Manager utility software
that is used on Microsoft Windows, HP-UX, and Solaris
host systems to register and map new logical drives to
the operating system. In Microsoft Windows, it also
contains a utility to flush the cached data of the
operating system for a particular drive before creating a
FlashCopy.

small computer system interface (SCSI). A standard
hardware interface that enables a variety of peripheral
devices to communicate with one another.

small form-factor pluggable (SFP). An optical
transceiver that is used to convert signals between
optical fiber cables and switches. An SFP is smaller
than a gigabit interface converter (GBIC). See also
gigabit interface converter.

SNMP. See Simple Network Management Protocol and
SNMPv1.

SNMP time-out. The maximum amount of time the
SANavigator tool will wait for a device to respond to a
request. The specified time applies to one retry only.

SNMP trap event. (1) (2) An event notification sent by
the SNMP agent that identifies conditions, such as
thresholds, that exceed a predetermined value. See
also Simple Network Management Protocol.

SNMPv1. The original standard for SNMP is now
referred to as SNMPv1, as opposed to SNMPVv2, a
revision of SNMP. See also Simple Network
Management Protocol.

SRAM. See static random access memory.
SSA. See serial storage architecture.

static random access memory (SRAM). Random
access memory based on the logic circuit know as
flip-flop. It is called static because it retains a value as
long as power is supplied, unlike dynamic random
access memory (DRAM), which must be regularly
refreshed. It is however, still volatile, meaning that it can
lose its contents when the power is turned off.

storage area network (SAN). A dedicated storage
network tailored to a specific environment, combining
servers, storage products, networking products,
software, and services. See also fabric.

Storage Array ldentifier (SAl or SA Identifier). The
Storage Array Identifier is the identification value used
by the FASIT Storage Manager host software
(SMClient) to uniquely identify each managed storage
server. The FAStT Storage Manager SMClient program
maintains Storage Array Identifier records of
previously-discovered storage servers in the host
resident file, which allows it to retain discovery
information in a persistent fashion.

storage management station. A system that is used
to manage the storage subsystem. A storage
management station does not need to be attached to
the storage subsystem through the fibre-channel
input/output (I/O) path.

storage partition. Storage subsystem logical drives
that are visible to a host computer or are shared among
host computers that are part of a host group.

storage partition topology. In the FASIT Storage
Manager client, the Topology view of the Mappings
window displays the default host group, the defined host
group, the host computer, and host-port nodes. The
host port, host computer, and host group topological
elements must be defined to grant access to host
computers and host groups using logical drive-to-LUN
mappings.

subnet. An interconnected but independent segment
of a network that is identified by its Internet Protocol (IP)
address.
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sweep method. A method of sending Simple Network
Management Protocol (SNMP) requests for information
to all the devices on a subnet by sending the request to
every device in the network.

switch. A fibre-channel device that provides full
bandwidth per port and high-speed routing of data by
using link-level addressing.

switch group. A switch and the collection of devices
connected to it that are not in other groups. Switch
groups are discovered by the SANavigator tool and
displayed with a gray background on the Physical and
Data Path maps.

system name. Device name assigned by the vendor’s
third-party software.

TCP. See Transmission Control Protocol.

TCP/IP. See Transmission Control Protocol/Internet
Protocol.

terminate and stay resident program (TSR
program). A program that installs part of itself as an
extension of DOS when it is executed.

topology. The physical or logical arrangement of
devices on a network. The three fibre-channel
topologies are fabric, arbitrated loop, and point-to-point.
The default topology for the disk array is arbitrated loop.

TL_port. See translated loop port.

transceiver. A device that is used to transmit and
receive data. Transceiver is an abbreviation of
transmitter-receiver.

translated loop port (TL_port). A port that connects
to a private loop and allows connectivity between the
private loop devices and off loop devices (devices not
connected to that particular TL_port).

Transmission Control Protocol (TCP). A
communication protocol used in the Internet and in any
network that follows the Internet Engineering Task Force
(IETF) standards for internetwork protocol. TCP
provides a reliable host-to-host protocol between hosts
in packed-switched communication networks and in
interconnected systems of such networks. It uses the
Internet Protocol (IP) as the underlying protocol.

Transmission Control Protocol/Internet Protocol
(TCP/IP). A set of communication protocols that
provide peer-to-peer connectivity functions for both local
and wide-area networks.

trap. In the Simple Network Management Protocol
(SNMP), a message sent by a managed node (agent
function) to a management station to report an
exception condition.

trap recipient. Receiver of a forwarded Simple
Network Management Protocol (SNMP) trap.

Specifically, a trap receiver is defined by an Internet
Protocol (IP) address and port to which traps are sent.
Presumably, the actual recipient is a software
application running at the IP address and listening to
the port.

TSR program. See terminate and stay resident
program.

uninterruptible power supply. A source of power
from a battery that is installed between a computer
system and its power source. The uninterruptible power
supply keeps the system running if a commercial power
failure occurs, until an orderly shutdown of the system
can be performed.

user action events. Actions that the user takes, such
as changes in the storage area network (SAN), changed
settings, and so on.

vendor. Property value that the SANavigator tool uses
to launch third-party software. Vendor property might be
discovered, but will always remain editable.

worldwide name (WWN). A unique identifier for a
switch on local and global networks.

WORM. See write-once read-many.

write-once read many (WORM). Any type of storage
medium to which data can be written only a single time,
but can be read from any number of times. After the
data is recorded, it cannot be altered.

WWN. See worldwide name.

zoning. A function that allows segmentation of nodes
by address, name, or physical port and is provided by
fabric switches or hubs.
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