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About this document

This document provides information about how to plan, install, configure, and work
with IBM® Fibre Array Storage Technology (FAStT) Storage Manager version 8.3 in
a Microsoft® Windows NT® 4.0 or Windows® 2000 operating system environment.
This guide is for system administrators. Use this guide to:

* Determine the hardware and software that you will require to install the
storage-management software.

» Integrate the necessary hardware components into your network.
 Install the FAStT Storage Manager software.

* Upgrade controller firmware, if necessary.

» Identify storage-management features that are unique to your installation.

Note: Throughout this document, Storage Manager version 8.3 refers to software
levels 8.30 or higher.

Who should read this document

This document is intended for system administrators and storage administrators
who are responsible for installing software. Readers should have knowledge of
RAID, SCSI, and fibre-channel technology, and should also have working
knowledge of the applicable operating systems that are used with the management
software.

© Copyright IBM Corp. 2000, 2003 Xi



FASLT installation process overview

The following flow chart gives an overview of the installation process for the FAStT
hardware and the FAStT Storage Manager. The arrows in the flow chart indicate the
current publications that cover, in detail, each step in the installation process.
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Figure 1. Process flow by current publications
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FASiIT documentation

The following tables present an overview of the FASIT Storage Manager and the
FAStT900, FAStT700, the FAStT500, and the FAStT200 Fibre Channel Storage
Server document libraries, as well as related documents. Each table lists
documents that are included in the libraries and where to locate the information that
you need to accomplish common tasks.
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FAStT Storage Manager Version 8.3 library

associates each document in the FASIT Storage Manager library with its
related common user tasks.

Table 1. TotalStorage FAStT Storage Manager Version 8.3 titles by user tasks

Title

User Tasks

Planning

Hardware
Installation

Software
Installation

Configuration

Operation and
Administration

Diagnosis and
Maintenance

Installation and
Support Guide for
Windows® NT and
Windows 2000,
GC26-7522

Installation and
Support Guide for
Linux, GC26-7519

Installation and
Support Guide for
Novell NetWare,
GC26-7520

Installation and
Support Guide for
UNIX and AIX
Environments,
GC26-7521

FAStT Remote
Mirror Option
Installation and
User's Guide,
48P9821

IBM FASET Storage
Manager Script
Commands (see
product CD)

IBM FAStT Storage
Manager Version
7.10 Concepts
Guide, 25P1661

About this document  Xili



FAStT900 Fibre Channel Storage Server library

associates each document in the FAStT900 Fibre Channel Storage Server
library with its related common user tasks.

Table 2. TotalStorage FAStT900 Fibre Channel Storage Server document titles by user tasks

Title User Tasks

Planning |Hardware Software Configuration |Operation and |Diagnosis and
Installation Installation Administration | Maintenance

FAStT900
Installation and
Support Guide,
GC26-7530

FAStT900 Fibre
Channel Cabling
Instructions,
24P8135

FAStT900 User’s
Guide, GC26-7534

FAStT Host Adapter
Installation and
User's Guide,
59P5712

FAStT FC2-133 Dual
Port Host Bus
Adapter Installation [ e
and User’'s Guide,
GC26-7532

FAStT FC2-133 Host
Bus Adapter
Installation and I e
User's Guide,
48P9823

Fibre Channel
Planning and
Integration: User’s
Guide and Service
Information,
SC23-4329

FAStT Management
Suite Java User’s - I
Guide, 32P0081

Fibre Channel
Hardware
Maintenance Manual
and Problem
Determination
Guide, GC26-7528
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FAStT700 Fibre Channel Storage Server library

associates each document in the FAStT700 Fibre Channel Storage Server
library with its related common user tasks.

Table 3. TotalStorage FAStT700 Fibre Channel Storage Server document titles by user tasks

Title

User Tasks

Planning

Hardware
Installation

Software
Installation

Configuration

Operation and | Diagnosis and
Administration | Maintenance

FAStT700
Installation and
Support Guide,
32P0171

FAStT700 Fibre
Channel Cabling
Instructions,
32P0343

FAStT700 Fibre
Channel Storage
Server User’'s Guide,
32P0341

EXP700 Storage
Expansion Unit
Installation and
User's Guide,
32P0178

FAStT Host Adapter
Installation and
User’'s Guide,
59P5712

FAStT FC2-133 Dual
Port Host Bus
Adapter Installation
and User’s Guide,
GC26-7532

TotalStorage FAStT
FC2-133 Host Bus
Adapter Installation
and User’s Guide,
48P9823

FASIT Management
Suite Java User’s
Guide, 32P0081

Fibre Channel
Hardware
Maintenance
Manual, 19K6130

Fibre Channel
Problem
Determination
Guide, 48P9804

About this document
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FAStT500 Fibre Channel Storage Server library

associates each document in the FAStT500 Fibre Channel Storage Server
library with its related common user tasks.

Table 4. TotalStorage FAStT500 and FAStT High Availablity Storage Server document titles by user tasks

Title User Tasks

Planning |Hardware Software Configuration |Operation and |Diagnosis and
Installation Installation Administration | Maintenance

FAStT500 RAID
Controller Enclosure
Unit User's Guide,
48P9847

FAStT EXP500
Storage Expansion
Unit Installation and 4 4 . e P
User’s Guide,
59P5637

FAStT Host Adapter
Installation and
User's Guide,
59P5712

FAStT FC2-133 Dual
Port Host Bus
Adapter Installation I e
and User’s Guide,
GC26-7532

TotalStorage FAStT
FC2-133 Host Bus
Adapter Installation [ e
and User’s Guide,
48P9823

FAStT Management
Suite Java User’s I I
Guide, 32P0081

Fibre Channel
Hardware
Maintenance
Manual, 19K6130

Fibre Channel
Problem
Determination
Guide, 48P9804
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FAStT200 Fibre Channel Storage Server library

associates each document in the FAStT200 Fibre Channel Storage Server
library with its related common user tasks.

Table 5. TotalStorage FAStT200 and FAStT High Availablity Storage Server document titles by user tasks

Title

User Tasks

Planning

Hardware
Installation

Software
Installation

Configuration

Operation and | Diagnosis and
Administration | Maintenance

FAStT200 and
FAStT200 HA
Storage Servers
Installation and
User’'s Guide,
59P6243

FAStT200 Fibre
Channel Cabling
Instructions,
21P9094

FAStT Host Adapter
Installation and
User’'s Guide,
59P5712

FAStT FC2-133 Dual
Port Host Bus
Adapter Installation
and User’s Guide,
GC26-7532

FAStT FC2-133 Host
Bus Adapter
Installation and
User's Guide,
48P9823

FAStT Management
Suite Java User’s
Guide, 32P0081

Fibre Channel
Hardware
Maintenance
Manual, 19K6130

Fibre Channel
Problem
Determination
Guide, 48P9804

About this document
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FASIT related documents

associates each of the following documents related to FAStT operations
with its related common user tasks.

Table 6. TotalStorage FAStT related document titles by user tasks

Title User Tasks

Planning |Hardware Software Configuration |Operation and |Diagnosis and
Installation Installation Administration | Maintenance

IBM Safety
Information, I
P48P9741

IBM FAStT500 RAID
Controller Enclosure
Unit Installation
Guide, 59P6244

IBM FAStT500 RAID
Controller Enclosure
Unit User’'s

Reference, 48P9847

IBM Netfinity® Fibre
Channel Cabling
Instructions,
19K0906

IBM FAStT200 and
FAStT200 HA
Storage Servers
Installation and
User's Guide,
59P6243

IBM FAStT200 Fibre
Channel Cabling
Instructions,
21P9094

IBM TotalStorage
FAStT EXP700
Storage Expansion
Unit Installation and
User’s Guide,
32P0178

IBM FAStT EXP500
Installation and
User’s Guide,
59P5637

IBM Fibre Channel
SAN Configuration
Setup Guide,
25P2509
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How this document is organized

[Chapter 1, “Introduction”, on page 1|provides an overview of IBM FASIT Storage
Manager version 8.3 and describes storage-subsystem management methods,
configuration types, types of installations, and installation requirements.

|Chapter 2, “Preparing for installation”, on page 21|discusses preparing for a network
installation, including setting up a Dynamic Host Configuration Protocol/Boot
Protocol (DHCP/BOQOTP) server on Windows NT 4.0, Windows 2000, Novell
NetWare, and UNIX® platforms.

[Chapter 3, “Installing software in a standard configuration”, on page 39| provides
instructions for installing the software components in a standard (noncluster)
environment.

|Chapter 4, “Installing software in a cluster server environment”, on page 47| provides
instructions for installing the software in a cluster server environment.

[Chapter 5, “Completing the installation”, on page 65| discusses starting the
Enterprise Management window, performing an automatic discovery of storage
subsystems, adding devices, setting up alert notifications, downloading firmware
and NVSRAM, creating arrays and logical drives, and other storage subsystem
management tasks.

[Chapter 6, “Using the storage-management software”, on page 75| provides
information about adding and deleting logical drives, using the Hot Add and
SMdevices utilities, starting and stopping the host-agent software, and uninstalling
Storage Manager components.

[Chapter 7, “Operating system support”, on page 81| discusses Windows NT and
Windows 2000 operating system limitations and other operating-system issues.

[‘Storage subsystem and controller information record”, on page 87| provides a data
sheet template that you can use to create a controller information record.

[‘Getting information, help, and service” on page xx| provides information about how
to obtain help, service, or technical assistance.

[‘Notices” on page 89| provides product notices and trademark information.

Notices used in this document

This document contains the following notices designed to highlight key information:
* Notes: These notices provide important tips, guidance, or advice.

* Important: These notices provide information that might help you avoid
inconvenient or problem situations.

» Attention: These notices indicate possible damage to programs, devices, or
data. An attention notice is placed just before the instruction or situation in which
damage could occur.

About this document  XiX



Getting information, help, and service

Before you call

If you need help, service, or technical assistance or just want more information
about IBM and IBM products, you will find a wide variety of sources available from
IBM to assist you. This section contains information about where to go for additional
information, what to do if you experience a problem with your xSeries™ or
IntelliStation® system, and whom to call for service, if it is necessary.

Before you call, make sure that you have taken these steps to try to solve the
problem yourself:

» Check all cables to make sure that they are connected.
» Check the power switches to make sure that the system is turned on.

» Use the troubleshooting information in your system documentation, and use the
diagnostic tools that come with your system.

* Go to the IBM Support Web site at http://www.ibm.com/pc/support/ to check for
technical information, hints, tips, and new device drivers.

» Use an IBM discussion forum on the IBM Web site to ask questions.

You can solve many problems without outside assistance by following the
troubleshooting procedures that IBM provides in the online help or in the
publications that are provided with your system and software. The information that
comes with your system also describes the diagnostic tests that you can perform.
Most xSeries and IntelliStation systems, operating systems, and programs come
with information that contains troubleshooting procedures and explanations of error
messages and error codes. If you suspect a software problem, see the information
for the operating system or program.

Using the documentation

Web sites

Information about your IBM® xSeries or IntelliStation system and preinstalled
software, if any, is available in the documentation that comes with your system.
That documentation includes printed documents, online documents, readme files,
and help files. See the troubleshooting information in your system documentation
for instructions for using the diagnostic programs. The troubleshooting information
or the diagnostic programs might tell you that you need additional or updated
device drivers or other software. IBM maintains pages on the World Wide Web
where you can get the latest technical information and download device drivers and
updates. To access these pages, go to hitp://www.ibm.com/pc/support and follow
the instructions. Also, you can order publications through the IBM Publications
Ordering System at
http://www.elink.ibmlink.ibm.com/public/applications/publications/cgibin/pbi.cgi/

On the World Wide Web, the IBM Web site has up-to-date information about IBM
xSeries and IntelliStation products, services, and support. The address for IBM
xSeries information is http://www.ibm.com/eserver/xseries/ The address for IBM
IntelliStation information is http://www.ibm.com/pc/intellistation.

You can find service information for your IBM products, including supported options,
at http://www.ibm.com/pc/support/ If you click Profile from the support page, you
can create a customized support page. The support page has many sources of
information and ways for you to solve problems, including how to:

» Diagnose problems, using the IBM Online Assistant

XX IBM TotalStorage FASIT Storage Manager Version 8.3: Installation and Support Guide for Microsoft Windows NT and
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» Download the latest device drivers and updates for your products
* View Frequently Asked Questions (FAQ)

* View hints and tips to help you solve problems

» Participate in IBM discussion forums

+ Set up e-mail notification of technical updates about your products

Software service and support

Through the IBM Support Line, for a fee, you can get telephone assistance with
usage, configuration, and software problems with xSeries servers, IntelliStation
workstations and appliances. For information about which products are supported
by Support Line in your country or region, go to
http://www.ibm.com/services/sl/products/

For more information about Support Line and other IBM services, go to
http://www.ibm.com/services/ or go to http://www.ibm.com/planetwide/ for support
telephone numbers.

Hardware service and support

You can receive hardware service through IBM Integrated Technology Services or
through your IBM reseller, if your reseller is authorized by IBM to provide warranty
service. Go to http://www.ibm.com/planetwide/ for support telephone numbers.

In the U.S. and Canada, hardware service and support is available 24 hours a day,
7 days a week. In the U.K,, these services are available Monday through Friday,
from 9 a.m. to 6 p.m.

How to send your comments

Your feedback is important to help us provide the highest quality of information. If
you have any comments about this document, you can submit them in one of the
following ways:

* E-mail
Submit your comments electronically to:
starpubs @us.ibm.com
Be sure to include the name and order number of the document and, if

applicable, the specific location of the text that you are commenting on, such as
a page number or table number.

* Mail or fax

Fill out the Readers’ Comments form (RCF) at the back of this document and
return it by mail or fax (1-800-426-6209) or give it to an IBM representative. If the
RCF has been removed, you may address your comments to:

International Business Machines Corporation
RCF Processing Department

Dept. M86/BIdg. 050-3

5600 Cottle Road

San Jose, CA 95193-0001

U.S.A.

About this document  XXI
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Chapter 1. Introduction

This document provides information on how to prepare, install, configure, and start
IBM FAStT Storage Manager version 8.3 in a Windows NT 4.0 or Windows 2000
environment. All references to the Storage Manager refer to the IBM FASIT Storage
Manager version 8.3.

Before you begin the installation of this product, consult the following
documentation:

* readme.txt file

Read this first. The readme file is located in the root directory of the installation
CD. Refer to the IBM Web site at http://www.ibm.com/pc/support/ for the latest
installation and user information.

* IBM FASLT Storage Manager Version 7.10 Concepts Guide

Use this document to become familiar with terminology and features of the IBM
FASIT Storage Manager software. This book can be downloaded from the
http://www.ibm.com/pc/support Web site.

When you finish the installation process, refer to the following online help systems:
» Enterprise Management window help

Use this online help system to learn more about working with the entire
management domain.

* Subsystem Management window help

Use this online help system to learn more about managing individual storage
subsystems.

You can access these help systems from within the Storage Manager 8.3 Client.
From either an Enterprise Management or Subsystem Management window, click
Help or press F1.

After installing IBM FAStT Storage Manager Version 8.3, consider installing the
FASIT MSJ and SANavigator diagnostic programs. You can use these programs to
verify the status of the fibre-channel connections before using the storage
subsystem.

The SANavigator program, the IBM FAStT MSJ User’s Guide and FAStT MSJ
program are located on the IBM FAStT Storage Manager Version 8.3 CD. For
information about how to install and run SANavigator, see the FAStT Hardware
Maintenance Manual and Problem Determination Guide

New features

This section describes the standard features that are part of the Storage Manager
Version 8.3 software. Your storage subsystem firmware must be version 5.3x.xx if

you want to use any of the features listed in this section. If your controller firmware
is version 04.x or earlier, you must purchase a firmware upgrade option.

The following list includes new standard features that have been added to the
storage-management software:

» Support for IBM TotalStorage FAStT900 Fibre Channel Storage Server

» Support for online Environmental Services Monitor (ESM) card firmware
downloads
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The ESM cards are customer replaceable unit (CRU) components in the IBM
FASLT storage expansion units. The ESM firmware can be updated while the
storage subsystem receives I/Os from the servers.

» Support for offline Fibre Channel hard drive firmware and mode page downloads

The 1/O from the servers must be suspended during the duration of the hard
drive firmware and mode page download.

» Support for Media Scan without Parity repairs
» Support for forcibly disabling Fibre Channel drive-level write caching
» Support the controller state dump function for diagnostics

Supported machine types

provides a list of machine types and supported storage-management
software.

Table 7. Machine types and supported storage-management software

Product name Machine |Model |Firmware |Supported
type version storage-management
software version
Netfinity Fibre Channel RAID 3526 1RU 4.x 7.0,7.01,7.02, 7.10,
Controller Unit 1RX 8.0, 8.2, 8.21, 8.3
IBM FAStT200 Storage Server 3542 1RU 4.x, 7.02, 7.10, 8.0, 8.2,
1RX 5.20.xx.xx, |8.21, 8.3

5.30.xx.xx
IBM FAStT200 High Availability 3542 2RU 4.x, 7.02, 7.10, 8.0, 8.2,
Storage Server 2RX 5.20.xx.xx, |8.21, 8.3

5.30.xx.xx
Netfinity FAStT500 RAID 3552 1RU 4.x, 7.0, 7.01,7.02, 7.10,
Controller Enclosure Unit 1RX 5.00.xx.xx |8.0, 8.2, 8.21, 8.3

5.20.xx.XX

5.21.XX.XX,

5.30.xx.xx
IBM TotalStorage FAStT700 Fibre | 1742 1RU 5.00.xx.xx |[8.0, 8.2, 8.21, 8.3
Channel Storage Server 1RX 5.20.xx.XX

5.21.xx.XX,

5.30.xx.xx
IBM TotalStorage FAStT900 Fibre | 1742 90X, 5.30.xx.xx |8.3
Channel Storage Server 90U

Note: Storage subsystem firmware must be at version 04.00.02.xx or higher to be
managed with Storage Manager 8.0, 8.2, 8.21, or 8.3.

Terms to know

If you are upgrading from a previous version of the storage-management software,
some of the terms you are familiar with have changed. It is important that you
familiarize yourself with the new terminology. [Table 8 on page 3| provides a list of
some of the changed terms. Also a glossary is located in the Help section of the
Storage Manager Enterprise Management window and the Storage Subsystem
Management window.
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Table 8. New terminology

Term used in previous versions New term

RAID module Storage subsystem
Drive group Array

Volume Logical drive

It is important to understand the distinction between the following two terms when
you read this document:

Management station

A management station is a system that is used to manage the storage

subsystem. It can be attached to the storage subsystem in the following

ways:

» Through a TCP/IP Ethernet connection to the controllers in the storage
subsystem

» Through a TCP/IP connection to the host-agent software that is installed
on a host computer, which in turn is directly attached to the storage
subsystem through the Fibre Channel input/output (I/O) path

Host computer

A host computer is a system that is directly attached to the storage
subsystem through a Fibre Channel 1/O path. This system is used to
perform the following tasks.:

+ Serve data (typically in the form of files) from the storage subsystem

* Function as a connection point to the storage subsystem for a
remote-management station

Notes:
1. The terms host and host computer are used interchangeably throughout
this book.

2. A host computer can also function as a management station.

IBM FAStT Storage Manager version 8.3 software

Storage Manager version 8.3 contains the following software components for
Windows NT 4.0 and Windows 2000:

Microsoft Virtual Machine (for Windows NT 4.0 only)
Storage Manager 8.3 Client (SMclient)

Redundant Disk Array Controller (RDAC)

Storage Manager 8.3 Agent (SMagent)

Storage Manager 8.3 Utility (SMutil)

Microsoft Virtual Machine

For systems running Windows NT 4.0, the Microsoft Virtual Machine is required to
support the following Storage Manager 8.3 components or options:

Storage Manager 8.3 Agent
Event Monitor option of the Storage Manager 8.3 Client
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Storage Manager 8.3 Client

The Storage Manager 8.3 Client (SMclient) component provides the graphical user
interface (GUI) for managing storage subsystems. The SMclient contains two main
components:

» Enterprise Management. You can use the Enterprise Management component
to add, remove, and monitor storage subsystems within the management
domain.

* Subsystem Management. You can use the Subsystem Management component
to manage the components of an individual storage subsystem.

The Event Monitor is a separate program that is bundled with the SMclient. If
installed, it monitors storage subsystems whenever the Enterprise Management
window is closed. It runs continuously in the background and can send alert
notifications in the event of a critical problem.

Redundant Disk Array Controller

The Redundant Disk Array Controller (RDAC) contains the multi-path device driver
that is necessary to provide controller failover support when a component on the
Fibre Channel I/O path fails. For RDAC in Storage Manager 8 and higher, a
maximum of four end-to-end fibre channel paths from the host to the storage
subsystems are supported.

Storage Manager 8.3 Agent

The Storage Manager Agent (SMAgent) provides a management conduit for the
Storage Manager Client to configure and monitor the subsystem through the Fibre
Channel I/0O path. The agent also provides local or remote access to the Storage
Manager 8.3 client depending on whether the client is installed on the host or in a
network management station over the TCP/IP network.

Storage Manager 8.3 Utility

The Storage Manager 8.3 Utility (SMutil) dynamically defines and maps new logical
drives to the operating system. This software package contains the following
components:

* Hot Add utility. The Hot Add utility enables you to register newly created logical
drives with the operating system. For more information, see [‘Using the Hot Add|
[utility” on page 78}

» SMdevices utility. The SMdevices utility enables you to associate storage
subsystem logical drives with operating-system device nhames. For more
information, see [‘Using the SMdevices utility” on page 78}

» SMflashcopyassist utility. The SMflashcopyassist utility enables you to perform
the following tasks:

— Flush cached data before creating a FlashCopy™ logical drive

— Resolve duplicate logical drive signatures between the base logical drives and
the FlashCopy logical drives (Windows NT only)

For more information, see[“Using the SMflashcopyassist utility” on page 79|

Note: FlashCopy is a premium feature that you must purchase. Contact your
IBM service representative for more information.
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Storage-subsystem management methods

The storage-management software provides the following two methods for
managing storage subsystems:
» the host-agent management method

» the direct management method

Depending on your specific storage-subsystem configurations, you can use either or
both methods. The management methods you select will determine where you will
need to install the software components.

Host-agent (in-band) management method

When you use the host-agent (in-band) management method, you manage the
storage subsystems through the Fibre Channel I/O path to the host. The
management information can either be processed in the host or passed to the

management station through the network connection, as shown in
i

Managing storage subsystems through the host-agent has the following
advantages:

» Ethernet cables do not need to be run to the controllers.
+ A DHCP/BOOTP server is not needed to connect the storage subsystems to the
network.

+ The controller network configuration tasks that are described in
[‘Preparing for installation”, on page 21| do not need to be performed.

* A host name or IP address must only be specified for the host instead of for the
individual controllers in a storage subsystem. Storage subsystems that are
attached to the host are automatically discovered.

Managing storage subsystems through the host-agent has the following
disadvantages:

* The host-agent requires a special logical drive, called an access logical drive, to
communicate with the controllers in the storage subsystem. Therefore, you are
limited to configuring one less logical drive than the maximum number that is
allowed by the operating system and the host adapter that you are using.

+ If the connection through the Fibre Channel is lost between the host and the
subsystem, the subsystem cannot be managed or monitored.

Note: The access logical drive is also referred to as the Universal Xport Device.

Important: If your host already has the maximum number of logical drives
configured, either use the direct management method or give up a logical drive for
use as the access logical drive. For more information, see |“Number of supported|
logical drives” on page 18
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Running the
host-agent software

’ Controller ‘ ffffff ;
’ Controller ‘
% Host computer
Fibre Channel
47 /0 path
’ Controller ‘ Network—p
’ Controller ‘
Storage subsystems
Note: The host can
act as a management
station also.
Management station
(one or more) $J000879

Figure 2. Host-agent (in-band) managed storage subsystems

Direct-management (out-of-band) method

When you use the direct-management (out-of-band) method, you manage storage
subsystems directly over the network through a TCP/IP Ethernet connection to each
controller. To manage the storage subsystem through the Ethernet connections, you
must define the IP address and host nhame for each controller. Each of the storage
subsystem controllers must be connected, through a cable connected to the RJ-45
connector, to an Ethernet network, as shown in|Figure 3 on page 8|

Managing storage subsystems using the direct-management (out-of-band) method
has the following advantages:

* The Ethernet connections to the controllers enable a management station
running SMclient to manage storage subsystems that are connected to a host
running any of the operating systems that are supported by Storage Manager

8.3.

An access logical drive is not needed to communicate with the controllers. You
can configure the maximum number of logical drives that are supported by the
operating system and the host adapter that you are using.

The user can manage and troubleshoot the storage subsystem when there are
problems with the Fibre Channel links.
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Managing storage subsystems using the direct-management (out-of-band) method

has the following disadvantages:

* You need two Ethernet cables to connect the storage subsystem controllers to a
network.

* When adding devices, you must specify an IP address or host name for each
controller.

* Network preparation tasks are required and you might need a DHCP/BOOTP
server. For a summary of the preparation tasks, see[‘Preparing a network|
linstallation” on page 21}

You can avoid DHCP/BOOTP server and network tasks by assigning static IP
addresses to the controller, or by using a default IP address.

» To assign a static IP address, see the IBM support Web site at
www.ibm.com/support/ for Retain Tip *H171389 Unable To Setup Networking
Without DHCP/BOOTP.

* If the storage subsystem controllers have firmware version 05.00.xx. or later, they
have the following default settings.

Controller IP address Subnet mask
A 192.168.128.101 255.255.255.0
B 192.168.128.102 255.255.255.0

[Figure 3 on page 8| shows a system in which storage subsystems are managed by
using the direct-management (out-of-band) method.

’ Controller ‘

’ Controller ‘
Host computer
Fibre Channel
| /O path

’ Controller ‘ 777777 ,:

’ Controller ‘

Storage subsystems

<+—— Ethernet

Management station
(one or more) s oo0864
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Figure 3. Direct-management (out-of-band) storage subsystems

Reviewing a sample network

[Figure 4 on page 9|shows an example of a network that contains both a
directly-managed storage subsystem (Network A) and a host-agent-managed
storage subsystem (Network B).

Directly-managed storage subsystem: Network A is a directly-managed storage
subsystem. Network A contains the following components:

« DHCP/BOOTP server

* Network Management Station (NMS) for Simple Network Management Protocol
(SNMP) traps

* Host that is connected to a storage subsystem through a Fibre Channel I/O path

* Management station connected by Ethernet cable to the storage subsystem
controllers

 If the controllers, static IP addresses or default IP addresses are used, you do
not need to setup the DHCP/BOOTP server.

Host-agent-managed storage subsystem: Network B is a host-agent-managed
storage subsystem. Network B contains the following components:

* Host that is connected to a storage subsystem through a Fibre Channel 1/O path
* Management station connected by Ethernet cable to the host computer
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Network A Fibre Channel
TCP/IP I/O path Ethernet

l

Storage
subsystem
’ " ‘ 77777 finance

Network Host computer |___{[" Controller | — Management DHCP/BOOTP server
management Denver ! station
station (IPaddress ] |~ (one or more)
(for SNMP traps)192.168.128.112) Host name: Denver_a

(IP address 192.168.128.101)

hardware address 00.a0.b8.02.04.20
Host name: Denver_b

Router (IP address 192.168.128.102)
hardware address 00.a0.b8.00.00.d8

Network B Fibre Channel
TCP/IP I/0 path Ethernet
Storage
subsystem

Host computer | __| T Management
Atlanta 3 station
(IP address Controller (one or more)
192.168.2.22) $J000882

Figure 4. Sample network using direct-management and host-agent management storage
subsystems

Where to install the software components

How you manage the storage subsystems determines where you must install the
various software components.

Management stations
You must install the following software components on each management station:
+ Storage Manager 8.3 Client (SMclient)
* Microsoft Virtual Machine (for Windows NT only)

Host computers
You must install the following software components on each host computer:
* Redundant Disk Array Controller (RDAC)
» Storage Manager 8.3 Utility (SMutil)

Depending on how you intend to manage the storage subsystems, you might need
to install the following software components:

» Storage Manager 8.3 Agent (SMagent)
+ Storage Manager 8.3 Client (SMclient)
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You must install the SMagent on a host computer if you intend to manage the
storage subsystems using the host-agent management method.

You must install the SMclient on a host computer if you intend the host computer to
act as a management station. If the host computer is not connected to a network,
you must install TCP/IP software and assign an IP address.

Configuration types

You can install Storage Manager 8.3 in one of two configurations:
+ Standard (noncluster) configuration
» Cluster server configuration

Standard (noncluster) configuration
shows a sample standard (noncluster) configuration.

Controller ‘
3 RDAC, SMutil,
Controller ‘ SMagent
| § ?
Host computer
‘«——— Fibre Channel
| I/0 path
’ Controller ‘ ****** i
The SMclient software
’ Controller ‘ ******* can also be installed
on the host computer.
Storage subsystems
SMclient
<+— Ethernet
Management station $J000869

Figure 5. Sample standard (noncluster) configuration
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Cluster server configuration
shows a sample cluster configuration.

RDAC, SMutil,
SMagent
[ & S|
Ethernet —»
SMclient _ _
Cluster server ™./ Cluster server
node A node B
The SMclient software
can also be installed on .
the cluster nodes. |
Management station Manageld hub or
(one or more) switch
«——Fibre Channel
| I/O path
’ Controller ‘
’ Controller ‘
Storage subsystem $J000870

Figure 6. Sample cluster server configuration

Installation types

You can install the storage-management software in two types of hardware
environments:

* New storage subsystem environment. You are installing the IBM TotalStorage
FASLT Fibre Channel Storage Server using firmware 05.3x.xx.xx and you will
manage storage subsystems using Storage Manager 8.3.

» Existing storage subsystem environment. You are installing the
storage-management software in an environment with existing storage
subsystems. See [Table 9 on page 12| for your installation options in an
environment with existing storage subsystems.

Note: When instructed to uninstall Storage Manager software in the following table,
be sure to uninstall the management software on all management systems
or hosts that have access to the storage subsystem that has firmware
5.3x.xx.xx The Storage Manager 8.3 RDAC has new functionality and
features and it is compatible with older versions of firmware. To ensure the
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highest level of compatibility and error-free operation, the Storage Manager
8.3 RDAC must be installed on all host computers that have disks defined on
storage subsystems that have firmware level 5.3x.xx.xx.

Table 9. Configurations for existing storage subsystems

Current environment

Planned environment

Action

(Machine types 1742,
3552) Existing storage
subsystems with
controllers that have
firmware versions
05.00.xx.xx or
05.2X.XX.XX

(Machine type 3542)
Existing storage
subsystems with
controllers that have
firmware versions
05.20.xx.XX

Upgrade firmware to
version 5.3X.XX.XX

Manage all storage
subsystems by using
Storage Manager 8.3.

Uninstall Storage Manager 8.2x. See
‘Uninstalling storage-management|
software components” on page 80| for
more information.

Install Storage Manager 8.3. See
I“_New installation process” on page 39
for more information.

Discover the storage subsystems.
See [‘Performing an initial automatic|
discovery of storage subsystems” on|
page 6§| for more information.

Download firmware and NVSRAM

version 5.3x.xx.xx. See |“Down|oading|
ffirmware and NVSRAM’ on page 70|
for more information.

(Machine type 3552)
Existing storage
subsystems with
controllers that have
firmware versions
04.00.xx.xx through
04.01.xx.xx

Upgrade firmware to
version 05.3X.XX.XX

Manage all storage
subsystems by using
Storage Manager 8.3

Purchase an upgrade option. Contact
your IBM service representative for
more information.

Uninstall Storage Manager version
7.x. Refer to f‘UninstaIIing|
storage-management software]

components” on page 80|for more
information.

Install Storage Manager 8.3. Refer to
['New installation process” on page 39
for more information.

Discover the storage subsystems.
Refer to [‘Performing an initial
lautomatic discovery of storage|
subsystems” on page 66| for more
information.

Download firmware and NVSRAM
version 5.3x.xx.xx. Refer to
‘Downloading firmware and|
NVSRAM” on page 70| for more
information.
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Table 9. Configurations for existing storage subsystems (continued)

Current environment

Planned environment

Action

(Machine type 3542)
Existing storage
subsystems with
controllers that have
firmware versions
04.00.02.xx through
04.01.xx.xx

Upgrade the firmware to
version 5.3X.XX.XX.

Manage all storage
subsystems by using
Storage Manager 8.3.

Purchase the upgrade option.
Contact IBM for more information.

Uninstall Storage Manager 7.0. See
‘Uninstalling storage-management|
software components” on page 80 for
more information.

Install Storage Manager 8.3. See
FNew installation process” on page 39
for more information.

Discover the storage subsystems.
See [Performing an initial automatic]
discovery of storage subsystems” on|
page 6§| for more information. Go to
the IBM Web site to download the
04.01.02.30 or higher firmware and
matching NVSRAM. Important: The
storage subsystem controllers must
be at firmware level 04.01.02.30 or
higher before downloading firmware
level 05.3x.xx.xx and NVSRAM to the
controllers.

Download firmware level 04.01.02.30
or higher and its associated
NVSRAM. See f‘DownIoadina
ffirmware and NVSRAM” on page 70|
for more information.

Download firmware and NVSRAM
version 5.3x.xx.xx. See |“Down|oadin§]
firmware and NVSRAM” on page 70|
for more information.

(Machine types 3526,
3552) Existing storage
subsystems with
controllers that have
firmware versions
04.00.xx.xx through
04.00.01.xx

Upgrade firmware to
version 04.00.02.xx or
higher. The latest
firmware version for the
4.xx.xx.xx firmware
thread is 04.10.xXx.xX.

Manage all storage
subsystems by using
Storage Manager 8.3.

Uninstall Storage Manager version
7.x. Refer to f‘UninstaIIin’Q]
storage-management software]

components” on page 80|for more
information.

Install Storage Manager 8.3. Refer to
['New installation process” on page 39
for more information.

Discover the storage subsystems.
Refer to [‘Performing an initial
automatic discovery of storage]
subsystems” on page 66 for more
information.

Upgrade the firmware to version
4.00.02.xx or higher. Go to the IBM
Web site; download the firmware and
matching NVSRAM.
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Table 9. Configurations for existing storage subsystems (continued)

Current environment

Planned environment

Action

(Machine types 3526,
3542, 3552) Existing
storage subsystems
with controllers that
have firmware versions
04.00.02.xx through
04.01.xx.xx

Retain existing firmware
versions.

Manage all storage
subsystems using
Storage Manager 8.3.

—_

Uninstall Storage Manager version
7.x. Refer to f‘UninstaIIing|
storage-management software|
components” on page 80[for more
information.

2. Install Storage Manager 8.3. Refer to

FNew installation process” on page 39
for more information.

3. Discover the storage subsystems.
Refer to [Performing an initial

automatic discoverx of storage|
subsystems” on page 66| for more

information.

(Machine types 3526,
3552) Existing storage
subsystems with
controllers that have
firmware versions
04.00.xx.xx through
4.00.01.xx

Retain existing firmware
versions.

Manage existing
storage subsystems
using Storage Manager
7.01.

Set up a separate management station
with Storage Manager 7.01 installed to
manage the storage subsystems with
controllers that have back-level firmware.

Managing coexisting storage subsystems

Storage subsystems are coexisting storage subsystems when the following

conditions are met:

» Multiple storage subsystems with controllers are running different versions of

firmware.

* These storage subsystems are attached to the same host.

For example, a coexisting situation exists when you have a new storage subsystem
with controllers running firmware version 05.3x.xx.xx, and it is attached to the same
host as one or more of the following configurations:

» A storage subsystem with controllers running firmware versions 04.00.xx.xx
through 04.00.01.xx, which is managed by a separate management station with
Storage Manager 7.01

» A storage subsystem with controllers running firmware versions 04.00.02.xx
through 04.01.xx.xx, which is managed with Storage Manager 8.3

Important: The common host must have the latest level (8.3) of RDAC and Storage
Manager Agent installed.
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Figure 7| shows an example of an environment that includes coexisting storage

subsystems.

Version 8.3 of the Important: In a

storage-management co-existing situation,

software must be installed on either the common host

a management station or host. must have Storage Manager
Version 8.3 RDAC and SMagent
installed.

/

Management station

Firmware version
4.x (minimum)

Controller
Controller

Host-agent

Host computer

Firmware
version 5.x <+—  Fibre Channel

1/0 path
Controller |- : P Ethernet——»|
Controller | p-----

Storage subsystems

Client software

Version 7.01 of the storage-management
software must be installed on a
management station.*

*Only to manage existing
storage subsystems with firmware
version 4.00.xx.xx to 4.00.01.xx . Management station $J000875

Figure 7. Sample coexistence installation

System requirements

This section provides detailed information about the hardware, software, and
operating system requirements for Storage Manager 8.3.
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Hardware requirements
lists the hardware required for installing Storage Manager 8.3.

Table 10. Hardware requirements for Storage Manager 8.3 software

Hardware component

Requirements

A DHCP/BOOQOTP server (only
for directly managed storage
subsystems)

Note: If the controllers static
IP addresses or default IP
addresses are used, you do
not need to setup the
DHCP/BOQOTP server.

One of the following BOOTP or BOOTP-compatible servers:
* Microsoft BOOTP-compatible DHCP server for Windows NT

* Microsoft BOOTP-compatible DHCP server for Windows
2000

* UNIX BOOTP server
NetWare DHCP server

Storage subsystems (one or
more)

Storage subsystems with controllers running firmware version
04.00.02.xx through 05.3X.XX.XX.

Fibre Channel (FC) host
adapters

The following Fibre Channel host adapters were tested with
the storage-management software:

* IBM FAStT host adapter (part number: 0OON6881)

» Optical interface connector on an IBM FAStT FC2 Host Bus
Adapter (part number 19K1246), IBM FAStT single port
FC2-133 Host Bus Adapter (part number 24P0960), or dual
port FC2-133 Host Bus Adapter (part number 24P8053)

For information on specific host adapter requirements:

* Refer to the README file in the \Host_Adapter directory on
the installation CD.

* Read the host adapter documentation.
* Go to the http://www.ibm.com/pc/support/ Web site.

Fibre Channel (FC) fabric
switches (if needed for the
desired configuration)

The following Fibre Channel fabric switches were tested with
the storage-management software:

* IBM 8-port Fibre Channel switch (machine type: 2109-S08)

* IBM 16-port Fibre Channel switch (machine type:
2109-S16)

* IBM 16-port 2 Gbps Fibre Channel switch (machine type:
2019-F16)

* |IBM 8-port 2 Gbps Fibre Channel switch (machine type:
3534-F08)

For specific Fibre Channel switch setup requirements:
* Read the switch documentation.
* Go to the http://www.ibm.com/storage/fcswitch/ Web site.

Fibre Channel (FC) managed
hub (if needed for the
desired configuration)

The Fibre Channel managed hub (machine type: 3534) was
tested with the storage management software.

For specific Fibre Channel managed hub setup requirements:
* Read the managed hub documentation.
* Go to the http://www.ibm.com/storage/fchub/ Web site.
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Table 10. Hardware requirements for Storage Manager 8.3 software (continued)

Hardware component

Requirements

Management station (for
client software)

Your management station computer will require:

Intel® Pentium® or Pentium-equivalent microprocessor (450
MHz or faster)

CD-ROM drive

Mouse or similar pointing device

System memory:

— For Windows NT 4.0: A minimum of 64 MB (128 MB
recommended)

— For Windows 2000: A minimum of 128 MB (256 MB
recommended)

Ethernet network interface adapter

AGP or PCI video adapter (AGP preferred), ISA adapters

are not supported

Monitor setting of 1024 x 768 pixels with 64,000 colors. The
minimum display setting that is allowed is 800 x 600 pixels
with 256 colors.

Hardware-based Windows acceleration: Desktop computers

that use system memory for video memory are not
preferred for use with the storage-management software.

Important: Many PC-based servers are not designed to run
graphic-intensive software. If your server has difficulty running
the storage-management software smoothly without video
artifacts, you might need to upgrade the server video adapter.

Note: For more information about host adapters, fabric switches, and managed
hubs, go to the ServerProven™ Web site at
http://www.ibm.com/pc/us/compat/.

Firmware requirements

To utilize all of the features of Storage Manager 8.3, your storage subsystem must
contain controllers with firmware version 5.3x.xx.xx for machine types 1742, 3552,
and 3542. To manage storage subsystems with Storage Manager 8.3, your storage
subsystems must contain controllers with firmware versions 04.00.02.xx or higher.

To upgrade your firmware from version 04.xx.xx.xx to 05.3x.xx.xx for machine types
3552 and 3542, you must purchase a firmware option. For more information,
contact your IBM reseller or IBM marketing representative.

Storage Manager 8.3 also supports two premium feature options: FlashCopy and
Remote Mirroring. For more information about these premium features, see

‘Creating a FlashCopy logical drive” on page 77|and [‘Using the Remote Mirrox

Software requirements

feature” on page 78| or contact your IBM reseller or IBM marketing representative.

[Table 11 on page 18|lists the disk space and administrator privileges required to
install version 8.3 of the storage-management software.

Note: The disk space listed in table 5 is for the packages after the installation.
During the installation of each software package, you might need up to 120M

of free disk space.
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Table 11. Installation requirements by software package

Package Disk space requirement Administrator privilege

(Windows NT / Windows 2000) | (Windows NT / Windows 2000)

Microsoft Virtual 1 MB/NA Required / NA
Machine

Storage Manager 8.3 40 MB Not required / Not Required
Client (SMclient)

Redundant Disk Array 1MB/1MB Required
Controller (RDAC)

Storage Manager 8.3 1MB/1MB Required
Agent (SMagent)

Storage Manager 8.3 4 MB /4 MB Required
Utility (SMutil)

Operating system requirements

Each management station, host computer, or cluster node requires one of the
following operating systems:

Management stations. Install one of the following operating systems:
* Windows NT 4.0 Server with Service Pack 6a

* Windows NT 4.0 Enterprise Edition with Service Pack 6a

* Windows NT 4.0 Workstation with Service Pack 6a

* Windows 2000 Server with Service Pack 3

* Windows 2000 Professional with Service Pack 3

* Windows 2000 Advanced Server with Service Pack 3

Host computers. Install one of the following operating systems:
* Windows NT 4.0 Server with Service Pack 6a

* Windows NT 4.0 Enterprise Edition with Service Pack 6a

* Windows NT 4.0 Workstation with Service Pack 6a

* Windows 2000 Server with Service Pack 3

* Windows 2000 Professional with Service Pack 3

* Windows 2000 Advanced Server with Service Pack 3

Cluster nodes. Install one of the following operating systems:
* Windows NT 4.0 Enterprise Edition with Service Pack 6a
* Windows 2000 Advanced Server with Service Pack 3

Number of supported logical drives

Supported logical drive limits for Windows NT 4.0 and Windows 2000 are as
follows:

* Windows NT 4.0 with Service Pack 6a supports up to 32 logical drives per
storage subsystem (LUNs 0-31) when you use IBM-approved FAStT adapters
and their supported device drivers.

* Windows 2000 supports up to 32 logical drives per storage subsystem (LUNs
0-31) when you use IBM-approved FASIT adapters and their supported device
drivers.
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» The maximum number of logical drives that a FASIT storage subsystem supports
with firmware version 05.3x.xx.xx depends on the model of the FASIT storage
subsystem.

Table 12. Logical drives without the remote mirror option enabled

Model Maximum logical drives | Maximum logical drives Maximum flashcopy
Type per storage unit partition |logical drives

3542 512" 32° 2562

3552 512" 32° 2567

1742 2048" 32° 10242

Table 13. Logical drives using the remote mirror option

Model Type | Maximum logical Maximum logical drives | Maximum flashcopy
drives per storage unit logical drives
partition
3542 N/A N/A N/A
3552 128°%6 32° 642
1742 256146 32° 1282

Note: The access logical drive is also referred to as the Universal Xport Device.

"When using firmware version 5.xx.xx.xx, the firmware reserves one logical drive
for use by the system.

2- Maximum of four Flashcopy logical drives for each standard logical drive

8- Maximum of eight remote mirror pairs

4 Maximum of 16 remote mirror pairs

5The host-agent management method uses a special logical drive, called an access
logical drive, to communicate with the controllers on the storage subsystem. The
access logical drive uses one of the available LUNs. Therefore, managing storage
subsystems with the host-agent software limits you to one fewer LUN than the
maximum number supported by the operating system and the host adapter.

5-For firmware version 05.2x.xx.xx and higher, the maximum number of logical
drives includes the flashcopy repository logical drives and the remote mirror logical
drives in addition to the standard data logical drives. If the remote mirror option is
enabled, two logical drives are reserved for use by the system.

19
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Chapter 2. Preparing for installation

This chapter provides information to help you plan the installation of the
storage-management software.

contains information about where you need to install the Storage Manager
software components.

Table 14. Software component installation in a Windows environment

System type Software installation sequence

Management station | 1 Microsoft Virtual Machine (for Windows NT only)
» Optional package

* Necessary if you plan to install the Event Monitor option of the
SMclient

2. Storage Manager 8.3 Client (SMclient)

Host computer / 1. Microsoft Virtual Machine (for Windows NT only)
cluster node .
» Optional package

* Necessary if you plan to install the Event Monitor option of the
SMclient.

2. Storage Manager 8.3 Client (SMclient)
* Optional component

* Necessary if you intend to manage the storage subsystem from
the host computer

3. Redundant Disk Array Controller (RDAC)
* Required component

* On Windows NT, you must assign static drive letters to existing
local drives before installing RDAC. This process requires a
minimum of two disk partitions (the BOOT partition and one
other partition).

4. Storage Manager 8.3 Agent (SMagent)
* Optional component

* Necessary if you intend to use the host-agent management
method.

5. Storage Manager 8.3 Utility (SMutil)
* Required component

» Contains the Hot Add, SMdevices, and SMflashcopyassist
utilities

Preparing a network installation

To begin installing the storage-management software, ensure that the network
components are set up and operating properly, and that you have all the host and
controller information needed for the software to operate correctly.

The following steps provide an overview of the tasks involved in setting up a
network installation:
1. Install all hardware components (host computers, storage subsystems, and

cables) that you want to connect to the network. You might need to refer to the
installation guides specific to the hardware components.
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9.

Table 15| shows a sample information record for the network shown in
page 9} This network contains storage subsystems that are managed by using both

Establish a naming convention for the storage subsystems connected to the
network. Refer to ['Naming the storage subsystems” on page 23| for more
information.

Record the storage subsystem names and management types in|Table 19 on
page 87, An example of a completed information record is shown in[Table 15

to record information such as hardware Ethernet addresses and
IP addresses.

(For a directly-managed system only) Determine the hardware Ethernet address
for each controller in storage subsystems connected to the network. Refer to
[‘ldentifying the hardware Ethernet MAC address for each controller” on page 23
for more information.

(For a directly-managed system only) If you are using a default controller IP
address, go to step|7|Otherwise, Obtain the TCP/IP address and host name for
each of the controllers in the storage subsystems on the network from the
network administrator. Refer to [‘Assigning IP addresses to hosts and|
[controllers” on page 25}

(For a host-managed system only) Obtain the IP address and host name of the
host computer on which the host-agent software will run from the network
administrator. Refer to [‘Assigning IP addresses to hosts and controllers” on|
lpage 29

(For a directly-managed system only) Set up the DHCP/BOOTP server to
provide network configuration information for a specific controller, however, if
you are using a controller static IP addresses, skip this step.

Verify that the TCP/IP software is installed. For more information, see “Verifying|
[the TCP/IP protocol and setting up the host or DNS table” on page 36

(For a directly-managed system only) Set up the host or Domain Name Server
(DNS) table. For more information, see [Verifying the TCP/IP protocol and|
[setting up the host or DNS table” on page 36

Power on the devices connected to the network.

Note: Throughout the remaining steps, you will need to return to|Table 19 on
i

the direct-management and host-agent-management method.

Table 15. Sample information record

Storage Management |Controllers-Ethernet and IP Host-IP address

subsystem name | method addresses, and host name and host name
Controller A Controller B

Finance Direct Hardware Hardware

Ethernet address | Ethernet address
= 00a0b8020420 |= 00a0b80000d8

IP address = IP address =
192.168.128.101 |192.168.128.102

Host = Denver_a |Host = Denver_b

Engineering Host-agent IP address =

192.168.2.22
Host = Atlanta
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Naming the storage subsystems

As you set up your network, decide on a naming convention for the storage
subsystems. When you install the storage-management software and start it for the
first time, all storage subsystems in the management domain are displayed as
<unnamed>. Use the Subsystem Management window to rename the individual
storage subsystems.

Consider the following factors when naming storage subsystems:

» There is a 30-character limit. All leading and trailing spaces are deleted from the
name.

» Use a unique, meaningful naming scheme that is easy to understand and
remember.

* Avoid arbitrary names or names that might quickly lose their meaning.

* The software displays storage-subsystem names with the prefix Storage
Subsystem. Therefore, if you rename a storage subsystem to Engineering, it is
displayed as:

Storage Subsystem Engineering

After you decide on a naming scheme, record the storage-subsystem names in the
information record (Table 19 on page 87).

If you plan to manage your storage subsystem using the direct-management
method, go to [‘ldentifying the hardware Ethernet MAC address for each controller’|
If you plan to manage your storage subsystem using the host-agent management
method, go to [‘Assigning IP addresses to hosts and controllers” on page 25|

Identifying the

hardware Ethernet MAC address for each controller

To manage your storage subsystem using the direct-management method, you
need to identify the hardware Ethernet Medium Access (MAC) address for each
controller.

To identify the hardware Ethernet MAC address for machine type 3542, perform the

following steps:

1. Locate the Ethernet MAC address at the back of the unit, under the controller
Gigabit Interface Converter (GBIC) ports, as shown in|Figure 8 on page 24| The
number will be in the form xx.xx.xx.xx.xx.xx (for example, 00.20.b8.20.00.d8).

2. Record each Ethernet address in the information record (Table 19 on page 87).
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Hardware Ethernet
address label $J000866

Figure 8. Locating the Ethernet MAC address for machine type 3542

To identify the hardware Ethernet MAC address for machine types 3552 and 1742,
perform the following steps:
1. Remove the front bezel from the storage subsystem, as shown in|Figure 9

Carefully pull the bottom of the bezel out [ to release the pins; then, slide the
bezel down H .

$§J000865

Figure 9. Removing the controller-unit bezel (machine types 3552 and 1742)

2. On the front of each controller, look for a label with the hardware Ethernet MAC
address. The number will be in the form xx.xx.xx.xx.xx.xx (for example,
00.20.b8.20.00.d8).

3. Record each Ethernet address in the information record (Table 19 on page 87).
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4. To replace the bezel, slide the top edge under the lip on the chassis [}; then,
push the bezel bottom until the pins snap into the mounting holes B, as shown

in|Figure 10,

NNNNNN
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NNNNNNANN
NNSENNAE

$J000867

Figure 10. Replacing the controller-unit bezel (machine types 3552 and 1742)

5. Continue with r‘Assigning IP addresses to hosts and controllers’1.

Assigning IP addresses to hosts and controllers

If you plan to manage your storage subsystem using the direct-management
method, assign a unique IP address for every controller in all storage subsystems
on the network. Record the IP address for each controller in the information record
(Table 19 on page 87). Then, go to [‘Setting up the DHCP or BOOTP-compatiblel

|§erver”|

Note: If you want to assign static IP addresses for the controllers, refer to the IBM
support Web site at www.ibm.com/support/ for Retain Tip #H171389 Unable
to setup networking without DHCP/BOOTP. Then go to[“Verifying the TCP/IP|
protocol and setting up the host or DNS table” on page 36|

If you plan to manage your storage subsystem using the host-agent management
method, assign an IP address for each host on which you will install the host-agent
software. Record the IP address for each host in the information record dTabIe 1§|
|on page 87[). Then, go to [‘Verifying the TCP/IP protocol and setting up the host o1
[DNS table” on page 36}

Setting up the DHCP or BOOTP-compatible server

To directly manage storage subsystems through the Ethernet connection to each
controller, you will need to set up a DHCP or BOOTP-compatible server and
configure the following options:

* Router/Gateway
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* DNS Server
¢ Hostname
« DNS

This section provides instructions for setting up a DHCP server on Windows NT,
Windows 2000 , and Novell NetWare, as well as instructions for setting up a UNIX
BOOQOT server.

Note: The remote management station (RMS) and network management station
(NMS) entries used in previous versions of the storage-management
software are not required when using Storage Manager 8.3.

Setting up a Windows NT DHCP server

You must use a version of DHCP that supports BOOTP static addressing. To use a
DHCP server, you must have a DHCP Manager installed. If a DHCP Manager is
installed on the system, go to [‘Setting up a DHCP server} If a DHCP Manager is
not installed, use the following installation procedure to install one.

Installing the DHCP Manager
Use the following procedure to install the DHCP Manager:

1. Click Start » Settings » Control Panel. A Control Panel window opens.
Double-click Network. The Network window opens.

Click Services.

From the Services tab, click Add.

Click Microsoft DHCP Server; then, click OK.

Specify the path to the Windows NT Install file; then, click Continue. A
dialogue window opens, stating that a static IP address is required.

7. Click OK. The Network window opens.

8. Click Protocols.

9. Click TCP/IP Protocol; then, click Properties.
10. Verify that the IP address information is correct. Then click OK.
11. Continue to [‘Setting up a DHCP server]

ook w0

Note: After you install the DHCP Manager, you can refer to its online help for
additional information.

Setting up a DHCP server
Use the following procedure, along with the information you recorded in [Table 19 on

to set up a DHCP server.

1. Click Start » Programs » Administrative Tools + DHCP Manager. The DHCP
Manager window opens.

2. Create a scope. A scope defines a group of TCP/IP addresses that you want the
DHCP server to use to assign to the controllers.

a. Click Local Machine.
b. Click Scope » Create. The Create Scope - (Local) window opens.
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Create Scope - (Local)

IP Address Pool

Excluded Addresses:

End Address:  [153.79.144.50

SubnetMask: |255.255.248.0

Exclusion Range:

Add ->
Start Address: |:|
End Address: |:| <~ Remove

Lease Duration

O Limited To: Dgy(s) Hou;(s) Mingte(s)

Name: ‘

Comment: ‘

OK Cancel

Help

Figure 11. Create Scope - (Local) window

c. Type the starting and ending IP addresses of the controllers that you are

configuring for the network.

$J000859

For example, if you are configuring 50 controllers on a 153.79.144.0 subnet,
set the starting address to 153.79.144.1 and the ending address to

153.79.144.50.

Note: If each field does not contain at least three characters, press the

period (.) key to advance to the next field. If you have only one
controller, type its address for both the starting and ending address.

Type the subnet mask (obtained from your network administrator).

e. Set the Lease Duration to Unlimited. This makes the DHCP connection

permanent.

—h

g. Click OK.

Type a scope name and comment.

h. When the scope successfully completes, click Yes to activate it. This returns
you to the DHCP Manager window.

Configure global scope options. shows the global options that you

need to set.

Table 16. Global options for a Windows NT DHCP server

Number |Description Notes

003 Router/Gateway

006 DNS Server

012 Host name Unique for each controller

015 DNS domain name For example, ibm.com

165 Network Management Station | Defines where the controller should send

SNMP alerts

You can apply options to specific controllers later using step
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a. Click DHCP Options » Global. The DHCP Options: Global window opens.

DHCP Options: Global

Optionsfor: Server 127.0.0.1 OK
Unused Options: Active options:
002 Time Offset A 003 Router Cancel

004 Time Server 164 Remote Management St

Add >
005 Name Servers 165 Network Management S

006 DNS Servers
007 Log Servers
008 Cookie Servers v

Value >>>

.

Help

Comment: Array of router addresses ordered by preference

SJ000860

Figure 12. DHCP Options: Global window

b. To make a global option active, select an item in the Unused Options list;
then, click Add to move it to the Active options list.

Click Value to assign a value to the active option.

If the Value field is not available, click Edit Array. The Edit Array Editor
window opens. Perform one of the following actions:

* If you need to add an IP address, complete the following procedure:
1) Click Edit Array. The IP Address Array Editor window opens.

o

IP Address Array Editor
— General Information
Application: DHCP Options: Global OK
Option: Remote Management Station Canoel
— Data Entry Help
IP Addresses:

New IP Address:

. 153.79.144.6
153.79.144.6 Add >

< Remove ﬂ
Resolve ﬂ

Server Name:

SJ000861

Figure 13. IP Address Array Editor window

2) Type a unique IP address for the option that you added.
3) Click Add to move the New IP Address to the IP Addresses list.
4) Click OK. This returns you to the DHCP Options: Global window.

* If you do not need to add an IP address, click Cancel. This returns you to
the DHCP Options: Global window.

d. Repeat step @through step until all global options are added.
e. When you finish adding the Global Scope Options, click OK at the DHCP

Options: Global window.

4. Create a reservation for each controller. Use the information record (Table 19 on
page 87) to make sure that you include all of the controllers on the network.

a. Click Scope » Add Reservations.
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o

data sheet.

In the IP Address field, type the IP address for the first controller on your

c. In the Unique Identifier field, type the controller hardware Ethernet address.

Do not type decimal p

oints or spaces.

d. In the Client Name field, type the controller eight-character name.

Click Add.

e.
f. Repeat step 4b on page 29| through step |4e on page 2§| for each controller

that is listed on the information record (Table 19 on page 87).

g. When you finish adding the information for all of the controllers, click Close.
This returns you to the DHCP Manager window.

can associate a controller

configuration entry with a specific controller.

Configure controller-specific options. By creating a controller-specific option, you

Note: If you set an option as Global Scope, it applies to every controller in this
group and you do not need to add it again.

a. Click Scope » Active

Active Leases - [153.79.144.0] X

Total Addresses in Scope:

Active/Excluded:

Available:

Client

Leases. The Active Leases window opens.

50 OK
6 (12%) Cancel
44 (88%) e

M 159.79.144.13 denver_a Reservation
159.79.144.14 denver b Reservation
Properties ‘ Delete Reconcile ‘ Refresh
— Sort Order
() Sortleases by IP Addresses )
o [ ] Show Reservations Only
(® Sort leases by Name:

$J000862

Figure 14. Active Leases window

b. Select a controller in the list.

c. Click Properties. The Add Option Type window opens. The Unique Identifier
is the hardware Ethernet address from step

Chapter 2. Preparing for installation
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Add Option Type

IP Address: 1153.79.144.13 |

Unique Identifier: | 00a0b8020420 |

ClientName: ‘ denver_a ‘

ClientComment: ‘ ‘

Lease Expires: N/A

OK ‘ Cancel Help Options... ‘

$J000863

Figure 15. Add Option Type window

d. Click Options. The DHCP Options: Reservations window opens.

e. Select an option from the Unused Options list, and click Add to move it to
the Active Options list.

f. Click Value to assign a value to the active option.

g. Type the information for the value of the option. For example, type the host
name for the controller from your information record (Table 19 on page 87) in
the String field. Click Edit if the value that you need to add is an IP address
for a router.

h. Repeat step @through step until you finish adding specific options for
this controller.

i. Click OK. This returns you to the Add Option Type window.
j- Click OK. This returns you to the Active Leases window.

k. Repeat step [5b on page 29 through step until you finish adding

controller-specific options for every controller.

I. Click OK on the Active Leases window. This returns you to the DHCP
Manager window.

Continue with [Verifying the TCP/IP protocol and setting up the host or DNS|

table” on page 36|

Setting up a Windows 2000 DHCP server

You must use a version of DHCP that supports BOOTP static addressing. To use a
DHCP server, you must have a DHCP Manager installed. If a DHCP Manager is
installed on the system, go to [‘Creating a scope and setting up a DHCP server” on|

Installing the DHCP Manager
To install the DHCP Manager, perform the following steps:

1.

Click Start »+ Administrative Tools + Configure Your Server. The Configure
Your Server window opens.

In the left pane, double-click Networking; then, click DHCP
In the right pane, click Start. The Windows Components Wizard starts.

In the Components field, select Networking Services. Then click Details.
The Networking Services window opens.
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10.
11.
12.

Note: Do not select the check box; you do not want to install all of the
Networking Services subcomponents.

In the Subcomponents of Networking Services field, select Dynamic Host
Configuration Protocol (DHCP).

Click OK. The Windows Components Wizard window opens.
Click Next to start the installation process.

If prompted, type the full path to the Windows 2000 distribution files and click
Continue.

When the installation has successfully completed, the Windows Components
Wizard window closes and the Configure Your Server Window opens.

Click Next.
Click Open the DHCP Manager. The DHCP window opens.
Continue with stepof [‘Creating a scope and setting up a DHCP server’]

Note: After you install the DHCP Manager, you can refer to the DHCP Manager

online help for additional information.

Creating a scope and setting up a DHCP server
Use the following procedure to create a scope and to set up a DHCP server. A

scope defines a group of controllers by their IP addresses. You must create and
configure a scope so that dynamic IP addresses can be assigned to controllers on
your network. Refer to the information record (Table 19 on page 87). Before you
begin, read through the instructions to determine what information is required. Then
request the information from your network administrator.

1.

Click Start » Programs » Administrative Tools * DHCP. The DHCP window
opens.

In the Console tree, right-click the server you want to configure; click New
Scope. The New Scope Wizard starts.

Follow the on-screen instructions to define the scope of IP addresses for
TCP/IP clients. You will define the following:

a. Scope name and description

b. IP address range for the subnet mask, and the controllers you are
configuring.
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MNew Scope Wizard x|

IP Addrezs Range —r
“'ou define the scope address range by identifying a set of consecutive 1P

addreszes.

Enter the range of addrezzes that the zcope diztibutes.

Start IP address: |192.1EE. 1.1

End IP address: |192 1B 1 . D

A zubnet mazk defines how many bitz of an IP address to use far the network /subnet
|02 and how mary bitz bo uge for the host [D. You can zpecify the subnet mazk by
length or as an [P address.

Lenigth: 24 _:I

Subnet mask: | 255,255 255 0

< Back I Mest » I Cancel

$J000868

Figure 16. New Scope Wizard: IP Address Range window

c. |IP addresses that you want to exclude from the IP address range
IP address lease duration
Common DHCP options:
» |P address for a router
* Domain name and DNS servers

4. When you have defined the scope, click Yes, | want to activate this scope
now. The wizard ends, and the DHCP window appears.

5. In the Console tree, open the scope folder.

6. Right-click Reservations. Then select New Reservations. The New
Reservations window opens.

7. To define the IP address reservation, type the following information:
a. Reservation name
b. IP address
c. Ethernet hardware MAC address
d. Description

8. In the Supported Type field, select Both (DHCP and BOOTP).

9. Click Add.

10. Repeat stepthrough step E)I for each controller in the network.

11. Restart the DHCP server and then restart the storage subsystem so that all
modifications are applied.

12. Go to[*Verifying the TCP/IP protocol and setting up the host or DNS table” on|

|Eage 36|

32 IBM TotalStorage FAStT Storage Manager Version 8.3: Installation and Support Guide for Microsoft Windows NT and
Windows 2000



Setting up a Novell NetWare DHCP server

A Novell NetWare DHCP server automatically assigns IP addresses and other
configuration information to clients upon request or when the clients are restarted.

To set up a Novell NetWare DHCP server, you must complete the following tasks:
Install DNS/DHCP Services, either during or after installing NetWare 6.

Install the DNS/DHCP Management Console.

Create the DHCP server object.

Create the subnet address.

Create the subnet address range.

Create the IP address object.

Start the DHCP server.

N o oo s~ -~

Each of these tasks is described in detail in the sections that follow.

Adding Novell DNS/DHCP Services during the NetWare 6.0
installation:

Perform the following to add Novell DNS/DHCP Services during the Netware
installation:

1. From the Installation Options window, select Custom.

2. From the Components window, select the Novell DNS/DHCP Services check
box.

3. Follow the on-screen instructions to complete the NetWare installation.

Adding Novell DNS/DHCP Services after the NetWare 6.0
installation:

Perform the folllowing to add Novell DNS/DHCP Services after the Netware
installation:

1. Insert the NetWare 6.0 Installation CD into the CD-ROM drive; then, mount the
CD as a volume.

2. Load NWCONFIG and select Product Options.
3. Select Install a Product not Listed.

4. Press F3 and specify the volume name of the CD. The X Server-Graphical
Console window opens.

5. In the Additional Products and Services dialog box, select the Novell
DNS/DHCP Services check box.

6. Follow the on-screen instructions to complete installation.

Note: Installing the DNS/DHCP Service will extend the Novell Directory Services
(NDS) schema and create the following NDS objects:

* DNSDHCP-GROUP Group object
* DNS/DHCP Locator object
* RootServerinfo Zone object

Installing the DNS/DHCP Management Console

Perform the following steps to install the DNS/DHCP Management Console and

NetWare Administrator snap-in files on the client workstation you will use to

administer DNS and DHCP:

1. If you have not done so, install the latest version of Novell Client 32 on your
workstation.

2. From the workstation, run the SYS:PUBLIC\DNSDHCP\SETUP.EXE program.
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3. Install the DNS/DHCP Management Console on the local hard-disk drive.

4. Install the NetWare Administrator snap-in files in the SYS:PUBLIC\WIN32
directory.

5. Restart the workstation.

6. To start the DNS/DHCP Management Console, double-click the shortcut icon on
the desktop, enter the NDS Tree NAME, and click Launch.

Note: You can install the DNS/DHCP Management Console on a workstation, or
you can access it from the Tools menu of the NetWare Administrator utility.

Creating the DHCP server object
Use the DHCP Management Console to create a DHCP server object. You can
create a DHCP server object under any of the following objects:

» Organization (O)

* Organization Unit (OU)
« Country (C)

* Locality (L)

Perform the following steps to create a DHCP server object:

1. From the DHCP Management Console, click the DHCP Service tab.

In the left pane, select Our Network.

Click Create. The Create New DHCP Object window opens.

Select DHCP Server; then, click OK. The Create DHCP Server window opens.

Select a server; then, click Create. This creates the DHCP server object, called
DHCP_servername, in NDS.

6. In the DHCP Management Console, locate the icon for the DHCP server object
at the bottom of the DHCP Service tab. The server object is displayed with a
red line through it. The red line indicates that DHCP server has not been
started.

7. Continue with [‘Creating the DHCP subnet object’|

Creating the DHCP subnet object
Perform the following steps to create a DHCP subnet object for each of the subnets
for which you want to assign addresses:

1. In the DNS/DHCP Management Console, click the DHCP Service tab.
Select Our Network or the DHCP Server Obiject.

Click Create. The Create New DHCP Object window opens.

Select Subnet. Then click OK. The Create Subnet window opens.

For each subnet, type the following information:

* Subnet name

* NDS context

* Subnet address

* Subnet mask

* Default DHCP Server

6. Click Create. The DHCP subnet object is created and displayed in the
DNS/DHCP Management Console.

ok 0N

A

Creating the subnet address range
Perform the following steps to create a subnet address range object:

1. From the DNS/DHCP Management Console, click the DHCP Service tab.
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2. Select the subnet object under which you want to create the subnet address
range object. Then click Create. The Create New DHCP Record window opens.

3. Select Subnet Address Range. Then click OK. The Create New Subnet
Address Range window opens.

4. Type the following information for the subnet address range:
* Subnet address range name
+ Starting address
* Ending address

5. Click Create.

6. Select the Define Additional Properties check box. Then set the Range Type
to Dynamic BOOTP and DHCP.

Creating the IP address object
Use the DNS/DHCP Management Console to create IP address objects. You use IP
address objects for the following purposes:

» To exclude an IP address from assignment
» To assign an IP address manually to a specific host
* To record dynamic IP address leases

Perform the following steps to create an IP address object:

1. From the DNS/DHCP Management Console, click the DHCP Service tab.
Select the subnet object of the target IP address. Then click Create.
Select IP Address; then, click OK. The Create IP Address window opens.
In the IP Address field, type the IP address for the first controller.

In the Assignment field, select Manual.
In the Client Identifier field, specify the MAC address.

In the MAC Address field, enter the hardware Ethernet MAC address for the
controller.

8. Select the Define Additional Properties check box.

9. In the Hostname field, type the eight-character name for the controller.
10. In the Usage field, select Permanent.
11. Repeat step [3] through step [10] for each controller.

Starting the DHCP server
To start the DHCP server, at the DHCP server console, type:

LOAD DHCPSRVR

No o koD

The DHCP server can now respond to client requests and assign IP addresses.

Notes:

1. To load the DHCP server automatically each time the server starts, place the
DHCPSRVR command in the SYS:\SYSTEM\AUTOEXEC.NCF directory.

2. For additional information about setting up, configuring, or using Novell
DNS/DHCP Services, refer to the Novell Documentation CD or go to
http://www.novell.com/documentation/.

Setting up a UNIX BOOTP server

To use a UNIX BOOTP server, you must set up a BOOTP table. [Table 17 on
|page 36/and the information record (Table 19 on page 87) provide the necessary
information.
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Table 17. Required entries for setting up the UNIX BOOTP server

Entry

Description

Sample format in
BOOTP server

Subnet mask

Mask that is used to route packets to defined
subnets

dot notation
(sm=255.255.0.0)

Router

IP address of the host computer that routes
packets to networks

dot notation
(gw=192.168.128.1)

Host name for the
controller

Host name that is associated with the controller
(refer to|Table 19 on page 87)

host name (Denver_a)

IP address

IP address of the controller (refer to|Table 19 on

dot notation
(ip=192.168.128.101)

Ethernet address

The Ethernet address of the controller
hardware (refer to [Table 19 on page 87)

hexadecimal notation
(ha=00a0b8020420)

To set up a UNIX BOOTP server, perform the following steps:
1. Use a text editor to edit the bootptab file in the /etc directory.

Use the following example of the BOOTP table to configure the Network A
server shown in [Figure 4 on page 9}

s4.default:\ (common settings)
ht=ether:\

sm=255.255.255.0:\
gw=192.168.128.1:\

hn:

denver_a:\

tc=s4.default:\ (common settings)
ip=192.168.128.101:\
ha=00a0b8020420:

denver_b:\

tc=s4.default:\
ip=192.168.128.102:\
ha=00a0b80000d8:

where the s4.default:\ entry denotes settings that are common to all controllers,
and the tc=s4.default:\ entry associates this common setting group to a specific
controller.

2. If the storage subsystem is running, shut down and then restart the subsystem.
This will ensure that the parameters in the BOOTP table take effect.

3. Continue with [‘Verifying the TCP/IP protocol and setting up the host or DNS|

Verifying the TCP/IP protocol and setting up the host or DNS table
Use the following procedure to verify that the TCP/IP protocol software is installed
on the management station and to set up the host or DNS table.

Note: Make sure that the host names for the controller match the IP addresses for
the controllers.

For Windows NT, perform the following steps:
1. Right-click Network Neighborhood.
2. Select Properties. The Network window opens.
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Click the Protocols tab. If the TCP/IP protocol entry does not appear in the
Network Products box, click Add. The Select Network Protocol window opens.
In the Network Protocol field, select TCP/IP Protocol.

Click OK.Then follow the on-screen instructions to install the TCP/IP protocol.
Update the DNS table to specify a host name to associate with an IP address.
If you do not have a DNS server, use a text editor to update the hosts file to link
the IP address and controller name entries. The following example shows the
host tables for the controllers that are connected to Network A as shown in
[Figure 4 on page 9|

# Copyright (c) 1993-1999 Microsoft Corp.

# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.

This file contains the mappings of IP addresses to host names. Each

entry should be kept on an individual Tine. The IP address should be placed
in the first column followed by the corresponding host name. The IP address
and the host name should be separated by at least one space.

Additionally, comments (such as these) might be inserted on individual
lines or following the machine name denoted by a '#' symbol.

For example:

102.54.94.97 rhino.acme.com # source server

38.25.63.10  x.acme.com # x client host

127.0.0.1 local host

192.168.128.101  denver_a

192.168.128.102  denver_b

If you want to manage storage subsystems through a firewall, configure the
firewall to open port 2463 to TCP data.

H= H H H W T I I e

For Windows 2000, perform the following steps:

1.

2.
3.
4

Right-click My Network Places.

Select Properties. The Network and Dial-up Connections window opens.
Right-click on a defined network connection.

Select Properties. Make sure that the Internet Protocol TCP/IP box under the

Components checked that are used by this connection is marked. If not, mark it,
click Install and follow the instructions that display.

Update the DNS table to specify a host name to associate with an IP address.

If you do not have a DNS server, use a text editor to update the hosts file to link
the IP address and controller name entries. The following example shows the
host tables for the controllers that are connected to Network A as shown in
[Figure 4 on page 9|

# Copyright (c) 1993-1999 Microsoft Corp.

# This is a sample HOSTS file used by Microsoft TCP/IP for Windows.

This file contains the mappings of IP addresses to host names. Each

entry should be kept on an individual Tine. The IP address should be placed
in the first column followed by the corresponding host name. The IP address
and the host name should be separated by at least one space.

Additionally, comments (such as these) might be inserted on individual
lines or following the machine name denoted by a'#' symbol.

For example:

102.54.94.97 rhino.acme.com # source server

38.25.63.10  x.acme.com # x client host

127.0.0.1 local host

192.168.128.101  denver_a

H FH FH FH I I I FE K
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192.168.128.102  denver_b

6. To manage storage subsystems through a firewall, configure the firewall to open
port 2463 to TCP data.
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Chapter 3. Installing software in a standard configuration

This chapter describes how to install the storage-management software in a
standard (noncluster) configuration. If you intend to configure your system for
clustering, go to[Chapter 4, “Installing software in a cluster server environment”, on|

If you have existing storage systems, make sure you have read |“Installation types’|
[on page 11| and [‘Managing coexisting storage subsystems” on page 14|

To ensure proper installation, make sure you have completed all preparation tasks
described in|Chapter 2, “Preparing for installation”, on page 21|

Important: Always check for a readme file on any installation media. The readme
file might contain important information that was not available when the guide was
prepared.

New installation process

You must install the Storage Manager 8.3 software components on both host
computers and management stations.

Management station: A management station is a system that you use to manage
the storage subsystem. You can attach it to the storage subsystem in the following
ways:

» Through a TCP/IP Ethernet connection to the controllers in the storage
subsystem

» Through a TCP/IP network connection to a host computer with host-agent
software installed on it, which in turn is directly attached to the storage
subsystem through the Fibre Channel input/output (I/O) path

You must install storage-management software on a management station in the
following order:

1. Microsoft Virtual Machine (Windows NT 4.0 only)

2. Storage Manager 8.3 Client

Host computer: A host computer (or host) is a system that is directly attached to
the storage subsystem through a Fibre Channel 1/O path.

Important: Be sure you install the host-bus adapter and driver before you install the
storage-manager software.

You must install storage management software on each host computer in the
following order:

1. Microsoft Virtual Machine (Windows NT 4.0 only)

2. Storage Manager 8.3 Client
3. Redundant Disk Array Controller
4. Storage Manager 8.3 Agent
5. Storage Manager 8.3 Utility

If you are installing the Storage Manager software on a Windows NT platform, see
|“Microsoft Virtual Machine” on page 40 to begin the installation.
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If you are installing the Storage Manager software on a Windows 2000 platform,
see [‘Storage Manager 8.3 Client’] to begin the installation.

Microsoft Virtual Machine
On Windows NT, Microsoft Virtual Machine is required to support the following
components:
» Event Monitor option of Storage Manager 8.3 Client
« Storage Manager 8.3 Agent

To install Microsoft Virtual Machine on management stations and host computers
running Windows NT 4.0, perform the following steps:

1. Close all programs.

2. Insert the IBM FASIT Storage Manager Version 8.3 CD into the CD-ROM drive.

3. Click Start » Run. The Run window opens.

4. Click Browse. The Browse window opens.

5. Select the CD-ROM drive.

6. Select the \Win32\MSVM\NT folder; then, click Open.

7. Select the MSJavx86-3805.exe file; then, click Open, and follow the instructions
on the screen. The Setup Complete window opens.

8. Click No, do not restart the system at this time. Click Finish.

9. Continue with [‘Storage Manager 8.3 Client’}

Storage Manager 8.3 Client

This section provides instructions on how to install Storage Manager 8.3 Client on
management stations and host computers.

Before you install the software, make sure that:

» The management station or host computer has at least 40 MB of available disk
space.

* (Windows NT only) Microsoft Virtual Machine software has been installed on the
device.

Important: When you install Storage Manager 8.3 Client on a stand-alone host and
manage storage subsystems through the Fibre Channel I/O path rather than
through the network, you must install the TCP/IP software on the host and assign
an |IP address to the host.

Installing Storage Manager 8.3 Client
To install Storage Manager 8.3 Client, perform the following steps:

1. Insert the IBM FAStT Storage Manager Version 8.3 CD into the CD-ROM
drive.

Click Start » Run. The Run window opens.

Click Browse. The Browse window opens.

Select the CD-ROM drive.

Select the \Win32\SMclient folder; then, click Open.

Select the setup.exe file; then, click Open. The InstallShield Wizard window
opens. The Welcome window opens.

7. Click Next. The End User License Agreement window opens.

R e
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10.
11.

12.
13.

Note: For Windows NT 4.0, ensure that the Microsoft Virtual Machine is
installed before you install the Event Monitor.

Read the license agreement and click Yes. The Event monitor window opens.

At the prompt, click Yes if you want to install the Event Monitor. The Choose
Destination Location window opens.

Click Browse to change the destination location.

Click Next to start the installation. When the installation is complete, the
Operation Complete window opens.

Click Finish.
Continue with [‘Verifying the Storage Manager 8.3 Client installation”}

Verifying the Storage Manager 8.3 Client installation

To verify that Storage Manager 8 Client v08.33.G5.xx is installed correctly, perform
the following steps:

1.
2.

Click Start » Programs.

Verify that IBM FAStT Storage Manager 8 Client v08.33.G5.xx appears in the
Program list. If the IBM FASIT Storage Manager 8 Client v08.33.G5.xx appears,
go to step

Otherwise, repeat [‘Installing Storage Manager 8.3 Client” on page 40| If the IBM
FAStT Storage Manager 8 Client v08.33.G5.xx still does not appear, a failure
has occurred. Contact your IBM technical support representative.

If you installed the optional Event Monitor service, go to [‘Verifying the Event|
[Monitor installation’]. Otherwise, continue to step [4}

If you are installing Storage Manager 8.3 Client on a host computer, go to
Chapter 5,

“Redundant Disk Array Controller” on page 42} Otherwise, go to
“Completing the installation”, on page 65|

Verifying the Event Monitor installation

This section provides instructions for verifying that the Event Monitor service has
been installed correctly on Windows NT and Windows 2000.

Windows NT 4.0
To verify that the Event Monitor service is installed correctly, perform the following

steps:

1.
2.
3.

Click Start » Settings » Control Panel. The Control Panel window opens.
Double-click Services. The Services window opens.

Verify that the IBM FAStT Storage Manager 8 Event Monitor service is displayed
with the status Started. If it is not, click Start. If the service does not start,
reinstall the Storage Manager 8.3 Client. If the failure persists, call your IBM
technical support representative.

If you are installing the storage-management software on a host computer, go to
“Redundant Disk Array Controller” on page 42l Otherwise, go to [Chapter 5,

“Completing the installation”, on page 65

Windows 2000

To verify that the Event Monitor service is installed correctly, perform the following
steps:

1.

Click Start » Programs » Administrative Tools » Services. The Services
window opens.
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2. Verify that the Storage Manager 8 Event Monitor service is displayed with the
startup type Automatic and status Started. If it is not, click Start. If it does not
start, reinstall the Storage Manager 8.3 Client. If the failure persists, call your
IBM technical support representative.

3. If you are installing the storage-management software on a host computer, go to

“Redundant Disk Array Controller’} Otherwise, go to [Chapter 5, “Completing the|

installation”, on page 65|

Redundant Disk Array Controller

RDAC must be installed on each host computer. RDAC contains the multipath
device driver that is necessary for controller failover support.

Before you install the software, ensure that the following conditions are met:
* You have Administrator privileges on the host computer.

» The host computer has at least 1 MB of available disk space.

» All programs are closed.

* You have installed the host bus adapter and driver.

If you are installing RDAC on Windows NT 4.0, continue with [‘Assigning static drive|

If you are installing RDAC on Windows 2000, continue with |“Installing the
[Redundant Disk Array Controller” on page 43|

Assigning static drive letters

Important:

Before installing RDAC, you must assign static drive letters to existing local drives.
Otherwise, problems might occur during new installations and upgrades. When RDAC is
installed, the RDAC utility installs the RDAC device driver before the Windows NT class
driver. If static drive letters have not previously been assigned to local drives, the system
will detect storage subsystem arrays and assign them drive letters before detecting and
assigning drive letters to local drives. If you have software applications using
non-permanent drive letters that are assigned to local drives, and this occurs, application
errors will result.

Use the following procedure to manually assign static drive letters on host
computers running Windows NT 4.0:

1. Determine how many partitions are on the system. Click Start + Programs »
Administrative Tools » Disk Administrator to view the disk configuration and
check the number of partitions.

2. Check that the following conditions are met:

* A boot partition exists.
* The last partition has been created with Disk Administrator or Disk
Management.

» The partition has an assigned drive letter with either an unknown status or a
status other than Unformatted.

If all conditions are met, go to |“Insta||ing the Redundant Disk Array Controller’1
on page 43 Otherwise, continue to step|3]

3. Create a new partition on your local system or on a storage subsystem using
the following procedure:
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a. Select a drive with free space; then, click Partition » Create. The partition is
created with a status of Unformatted and a drive letter is assigned. You can
delete or change the logical drive at a later time without causing
reassignment of the boot partition.

b. Click Partition » Commit Changes Now. The partition status changes to
Unknown, and static drive letters are assigned to all existing partitions.

4. Continue with [Installing the Redundant Disk Array Controller’]

Installing the Redundant Disk Array Controller
To install RDAC, perform the following steps:
1. Insert the IBM FASIT Storage Manager Version 8.3 CD into the CD-ROM drive.
2. Click Start » Run. The Run window opens.
3. Click Browse. The Browse window opens.
4. Select the CD-ROM drive.
5. Select one of the following directories.

For Windows NT 4.0 \Win32\SMrdac\NT
For Windows 2000 Server or Professional \Win32\SMrdac\W2K

6. Select the setup.exe file; then, click Open. The InstallShield Wizard window
opens. The Welcome window opens. Click Next. The End User License
Agreement window opens.

7. Click Yes to start the installation. After installing RDAC, the InstallShield Wizard
Complete window opens.

8. Select Yes | want to restart my computer now; then, click Finish.
9. Continue with “Verifying the RDAC installation”.

Verifying the Redundant Disk Array Controller installation

This section provides instructions for verifying that RDAC has been installed
correctly on a Windows NT 4.0 and a Windows 2000 operating system.

Windows NT 4.0
To verify that RDAC has been installed correctly, perform the following steps:

Note: Make sure that all storage subsystems are connected to the host computer
and are powered on.

1. Click Start » Settings » Control Panel. The Control Panel window opens.
2. Double-click Devices. The Devices window opens.
3. Scroll to symarray.

» |If symarray appears with a device status of Started, go to step E

» |If symarray does not appear, an error might have occurred. Repeat the
procedure outlined in[“Installing the Redundant Disk Array Controller’} If the
failure pEersists, call your IBM technical support representative. Otherwise, go
to step @{

4. Perform one of the following tasks:
« If you are managing the storage subsystems using the host-agent method,
continue with |“Storage Manager 8.3 Agent” on page 44|.

« If you are managing your storage subsystems directly, go to
[Manager 8.3 Utility” on page 46}
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Windows 2000
To verify that RDAC has been installed correctly, perform the following steps:

1. Right-click My Computer.

2. Click Start » Programs > Administrative Tools > Computer Management.
The Computer Management window opens. Go to the \System Tools\Software
Information\Software environment\drivers directory.

3. Scroll through the list of device drivers until you find rdacfltr.

4. Verify that rdacfltr is displayed with the state type Running and status OK. If it is
not, repeat the procedure outlined in r‘lnstalling the Redundant Disk Array|
[Controller” on page 43| If the failure persists, call your IBM technical support
representative. Otherwise,

» If you are managing the storage subsystems using the host-agent method,
continue with [‘Storage Manager 8.3 Agent’}

» If you are managing your storage subsystems using the direct-management
method, go to[‘Storage Manager 8.3 Utility” on page 46}

Storage Manager 8.3 Agent

The Storage Manager 8.3 Agent software must be installed if you want to manage
the storage subsystem using the host-agent management method.

Before you install the software, ensure that the following conditions are met:
* You have Administrator privileges on the host computer.
* The host computer has at least 1 MB of available disk space.

+ RDAC is installed on each host computer. If not, refer to [‘Redundant Disk Array|
[Controller’ on page 42|

* (For Windows NT 4.0) Microsoft Virtual Machine is installed (refer tow
[Virtual Machine” on page 40).

» All storage subsystems are connected to the host computer and are powered on.

Installing Storage Manager 8.3 Agent
To install Storage Management 8.3 Agent, perform the following steps:
1. Close all programs.

2. Insert the IBM FAStT Storage Manager Version 8.3 CD in the CD-ROM drive.

3. Click Start » Run. The Run window opens.

4. Click Browse. The Browse window opens.

5. Select the CD-ROM drive.

6. Select the \Win32\SMagent folder; then, click Open.

7. Select the setup.exe file; then, click Open. The InstallShield window opens,
showing the status the file unpacking. The Welcome window opens.

8. Click Next. The End User License Agreement window opens.

9. Read the license and click Yes to begin the installation. The software

installation ends, and the Operation Complete window opens.
10. Click Finish.
11. Continue witH“Verifying the Storage Manager 8.3 Agent installation”|

Verifying the Storage Manager 8.3 Agent installation

This section provides instructions for verifying that Storage Manager 8 Agent has
been installed correctly on Windows NT 4.0 and Windows 2000.
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Windows NT 4.0
To verify that Storage Manager 8.3 Agent has been installed correctly, perform the

following steps:
1. Click Start » Settings » Control Panel. The Control Panel window opens.
2. Double-click Services. The Services window opens.

3. Scroll through the list of services until you find IBM FASIT Storage Manager 8
Agent.
« |If IBM FASLIT Storage Manager 8 Agent appears with a startup type of
Started, close the Services window and continue to step EI

« If IBM FASIT Storage Manager 8 Agent does not appear with a startup type
of Started, click Start. If the status changes to Started, go to step If not,
refer to[Table 18 on page 81| for a possible cause. Otherwise, reinstall IBM
FASIT Storage Manager 8.3 Agent. If the problem persists, contact your IBM
technical support representative.

4. Perform one of the following procedures:

» If you plan to use the host-agent software to manage one or more storage
subsystems, go to [‘Storage Manager 8.3 Utility” on page 46|

* If you do not plan to use the host-agent software to manage one or more
storage subsystems, do the following procedures to disable the host-agent
service:

a. Click Start » Settings » Control Panel. The Control Panel window opens.
b. Double-click Services. The Services window opens.
c. From the list of displayed services, right-click IBM FAStT Storage Manager

8 Agent.
d. Click Properties » Startup Type » Manual.
e. Click OK.

5. Continue with [‘Storage Manager 8.3 Utility” on page 46}

Windows 2000
To verify that Storage Manager 8 Agent has been installed correctly, perform the

following steps:

Note: Make sure that all storage subsystems are connected to the host computer
and are powered on.

1. Click Start » Programs » Administrative Tools » Services. The Services
window opens.

2. Scroll through the list of services until you find IBM FASIT Storage Manager 8
Agent.

3. If IBM FAStT Storage Manager 8 Agent does not appear with a startup type of
Started, click Start. If the status changes to Started, go to step If not, refer to
[Table 18 on page 81| for a possible cause. Otherwise, reinstall IBM FAStT
Storage Manager 8 Agent. If the problem persists, contact your IBM technical
support representative.

4. Perform one of the following steps:

» If you plan to use the host-agent software to manage one or more storage
subsystems, go to |“Storage Manager 8.3 Utility” on page 46L

* If you do not plan to use the host-agent software to manage one or more
storage subsystems, do the following procedure to disable the host-agent
service:

a. Click Start » Programs » Administrative Tools »+ Computer
Management. The Computer Management window opens.
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Click Services.

From the list of displayed services, right-click IBM FAStT Storage
Manager 8 Agent.

d. Click Properties » Startup Type » Manual.
e. Click OK.
5. Continue with ['Storage Manager 8.3 Utility’|

Storage Manager 8.3 Utility

This section provides instructions for installing Storage Manager 8.3 Utility on host
computers. This component contains utilities that will register and map new logical
drives to the operating systems.

Installing Storage Manager 8.3 Utility
To install Storage Manager 8.3 Utility, perform the following steps:

1. Close all programs and insert the IBM FAStT Storage Manager Version 8.3
installation CD in the CD-ROM drive.

Click Start » Run. The Run window opens.

Click Browse. The Browse window opens.
Select the CD-ROM drive.

Select the \Win32\SMuitil folder; then, click Open.

Select the setup.exe file; then, click Open. The InstallShield Wizard window
opens, displaying the status of the files unpacking. The Welcome window
opens.

7. Click Next.

8. The End User License Agreement window opens. Click Yes to begin the
installation. After the installation is complete, the Operation Complete window
opens.

9. Click Finish.
10. Continue with [‘Verifying the Storage Manager 8.3 Utility installation’]

ook~

Verifying the Storage Manager 8.3 Utility installation

To verify that Storage Manager 8.3 Utility has been installed correctly, perform the
following steps:

1. Go to the following directory:
installation_directonA\IBM_FAStT\Util

where installation_directory is the directory where you installed the Storage
Manager 8.3 Utility.

2. Verify that the directory contains the following files:
* hot_add.exe
* SMdevices.bat
* SMflashcopyassist.exe

If it does not, reinstall the Storage Manager 8.3 Utility by using the procedure
outlined in ['Installing Storage Manager 8.3 Utility’]. If the problem persists,
contact your IBM technical support representative.

3. Go to [Chapter 5, “Completing the installation”, on page 65|
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Chapter 4. Installing software in a cluster server environment

This chapter describes how to install the storage-management software in a cluster
server environment.

The installation process you will use depends on your storage subsystem
environment. If you have existing storage systems, read [“Installation types” on|
page 11|and|[‘Managing coexisting storage subsystems” on page 14|

To ensure proper installation, complete all preparation tasks described in [Chapter 2,
[‘Preparing for installation”, on page 21}

If you are upgrading from a previous version of Storage Manager on an existing
cluster, go to ['Upgrading from a previous version of the storage-managemenll
lsoftware” on page 58]

Important: Always check for a readme file on any installation media. A readme file
might contain important information that was not available when this guide was
prepared.

Preinstallation considerations

The hardware installation involves installing host adapters and storage subsystems.
Before you begin the installation of the software, make sure that all hardware
components are installed correctly for the cluster server configuration.

Configuration options

You can connect the storage subsystem to the cluster nodes either directly or
through Fibre Channel switches. Both configurations offer full redundancy. The
following figure illustrates both configurations.
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Figure 17. Installing the storage subsystem on a Fibre Channel network

Host adapters

Refer to the appropriate host-adapter documentation for specific installation
requirements and procedures. The following considerations apply:

* To use the dual-path configuration, perform the following tasks:
— Install two host adapters in each node.
— Run two Fibre Channel cables from each node to the storage subsystem.
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» If you connect the storage subsystem through a Fibre Channel Arbitrated Loop
(FC-AL), ensure that every adapter on the loop has been assigned a unique hard
ID. For instructions about changing hard IDs, refer to the documentation provided
with your host adapters.

» The correct device driver is installed for the host adapter. Refer to the readme file
in the \Host_Adapter directory on the IBM FAStT Storage Manager version 8.3
CD for information on supported host adapters and device drivers.

Storage subsystems

Refer to the appropriate hardware documentation for specific installation
requirements and procedures. If you are managing storage subsystems directly, you
must connect Ethernet cables to both controllers in each storage subsystem.

Overview: Installing Storage Manager in a cluster environment

Perform the following steps to install the storage-management and cluster service
software:

1. Be sure that the host bus adapter and driver are installed in each cluster node.
2. Power down node B. Start node A.

3. Install the storage-management software on node A. Refer to [‘Installing the

lstorage-management software” on page 50| for instructions.

4. Complete the procedures detailed in [Chapter 5, “Completing the installation” |
5. Run the Hot Add utility on node A. Refer to[‘Using the Hot Add utility” on|
for instructions.

Note: You might have to restart node A in order to see the newly-added
logical drives.

6. Format all shared logical drives as NTFS (NT File System), assign volume
labels, and specify a drive letter for each.

Important: You must assign a permanent (sticky) drive letter to the shared
logical drive on both cluster nodes. The two nodes must have the same drive
letters on each shared drive. If you do not assign permanent drive letters,
Windows might assign different drive letters on each node. Assigning a
permanent drive letter ensures that Windows assigns the same drive letter to
the partition on both cluster nodes.

7. Shut down node A. Start node B.

8. Install the storage-management software on node B. Refer to|“Installing the

Istorage-management software” on page 50| for instructions.

9. To verify the drive letters for the cluster configuration, perform one of the
following procedures:

* For Windows NT, click Start »+ Programs » Administrative Tools » Disk
Administrator.

* For Windows 2000, perform the following steps:

a. Click Start » Programs » Administrative Tools »+ Computer
Management. The Computer Management window opens.

b. Click Storage » Disk Management.
10. Verify that the following conditions are met:
* The same logical drives appear on each cluster node.

* Each cluster node has the same number of partitions defined on the logical
drives.
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» Drive letters are assigned to the configured logical drives.
* The drive letters on the partitions are the same on both cluster nodes.
11. Shut down node B.

12. |Install the cluster server software. Refer to[“Installing the cluster server|
lsoftware” on page 57| for instructions.

13. Go to|Chapter 5, “Completing the installation”, on page 65|

Installing the storage-management software

Before you begin an installation with existing storage subsystems, refer to your
hardware installation documentation for the specific configuration. A specific
configuration might be required for your hardware to support the
storage-management software in a cluster configuration.

You must install the Storage Manager 8.3 software components on both
management stations and cluster nodes.

Management station: A management station is a system that is used to manage
the storage subsystem. It can be attached to the storage subsystem in the following
ways:

» Through a TCP/IP Ethernet connection to the controllers in the storage
subsystem

» Through a TCP/IP network connection to a cluster node with the host-agent
software installed

You must install storage-management software on a management station in the

following order:

1. Microsoft Virtual Machine (Windows NT 4.0 only)

2. Storage Manager 8.3 Client

Cluster node: The cluster nodes are directly attached to the storage subsystem
through a Fibre Channel I/O path.

You must install storage management software on each cluster node in the
following order:

1. Microsoft Virtual Machine (Windows NT 4.0 only)
Storage Manager 8.3 Client

Redundant Disk Array Controller

Storage Manager 8.3 Agent

Storage Manager 8.3 Utility

A

If you are installing the Storage Manager software on a Windows NT platform, see
FInstalling the Microsoft Virtual Machine’| to begin the installation.

If you are installing the Storage Manager software on a Windows 2000 platform,
see [‘Storage Manager 8.3 Client” on page 51|to begin the installation.

Installing the Microsoft Virtual Machine

On Windows NT, Microsoft Virtual Machine is required to support the following
components:

« Event Monitor option of Storage Manager 8.3 Client
+ Storage Manager 8.3 Agent
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To install Microsoft Virtual Machine on management stations or cluster nodes,
perform the following steps:

1.

© N Ok~ ODND

©

10.

Close all programs.

Insert the IBM FAStT Storage Manager version 8.3 CD into the CD-ROM drive.
Click Start » Run. The Run window opens.

Click Browse. The Browse window opens.

Select the CD-ROM drive.

Select the \Win32\MSVM\NT folder; then, click Open.

Select the MSJavx86-3805.exe file; then, click Open.

Click Finish and follow the instructions on the screen. When the software is
installed, the Setup Complete window opens.

Click No, do not restart the system at this time.
Continue with [‘Storage Manager 8.3 Client]

Storage Manager 8.3 Client

This section provides instructions for installing Storage Manager 8.3 Client on
management stations and cluster nodes.

Before you install the software, make sure that:

The management station or host computer has at least 40 MB of available disk
space.
All programs are closed.

For Windows NT systems, that the Microsoft Virtual Machine software has been
installed on the device. Refer to [Installing the Microsoft Virtual Machine” on|

page 50

Important: When you install Storage Manager Client on a stand-alone host and
manage storage subsystems through the Fibre Channel I/O path rather than
through the network, you must install the TCP/IP software on the host and assign
an IP address to the host.

Installing Storage Manager 8.3 Client
To install Storage Manager 8.3 Client, perform the following steps:

1.

oo~ 0D

10.
11.

Insert the IBM FASIT Storage Manager version 8.3 CD into the CD-ROM drive.
Click Start » Run. The Run window opens.

Click Browse. The Browse window opens.

Select the CD-ROM drive.

Select the \Win32\SMclient folder; then, click Open.

Select the setup.exe file; then, click Open. The InstallShield Wizard window
opens. The Welcome window opens.

Click Next. The End User License Agreement window opens.

Note: For Windows NT 4.0, ensure that the Microsoft Virtual Machine is
installed before you install the Event Monitor.

Read the license agreement and click Yes. The Event monitor window opens.

At the prompt, click Yes if you want to install the Event Monitor. The Choose
Destination Location window opens.

Click Browse to change the destination location.

Click Next to start the installation. When the installation is complete, the
Operation Complete window opens.
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12. Click Finish.
13. Continue with [‘Verifying the Storage Manager 8.3 Client installation’}

Verifying the Storage Manager 8.3 Client installation
Perform the following steps to verify that the Storage Manager 8.3 Client
v08.33.G5.xx software is installed correctly:

1. Click Start » Programs.

2. Verify that the Storage Manager 8 Client v08.33.G5.xx appears in the Program
list. If the Storage Manager 8 Client appears, go to step

Otherwise, repeat [‘Installing Storage Manager 8.3 Client’ on page 51| If the
Storage Manager 8 Client still does not appear, a failure occurred. Contact your
IBM technical support representative.

3. If you installed the optional Event Monitor service, go to |“Verifying the Event|
[Monitor installation on Windows NT and Windows 2000’} Otherwise, continue to
step|4]

4. If you are installing Storage Manager 8.3 Client on a host computer, go to

“Redundant Disk Array Controller’| Otherwise, go to [Chapter 5, “Completing the|

installation”, on page 65|

Verifying the Event Monitor installation on Windows NT and
Windows 2000

To verify that the Event Monitor service has been installed correctly on Windows
NT, perform the following steps:

1. Click Start » Settings » Control Panel. The Control Panel window opens.
2. Double-click Services. The Services window opens.

3. Verify that Storage Manager 8 Event Monitor service is displayed with the status
Started. If it is not, click Start. If the service does not start, reinstall the Storage
Manager 8.3 Client. If the failure persists, call your IBM technical support
representative.

4. If you are installing the storage-management software on a cluster node, go to
“Redundant Disk Array Controller’} Otherwise, go to [Chapter 5, “Completing the|
installation”, on page 65|

To verify that the Storage Manager 8 Event Monitor service has been installed
correctly on Windows 2000, perform the following steps:

1. Click Start » Programs » Administrative Tools » Services. The Services
window opens.

2. Verify that the Storage Manager 8 Event Monitor service is displayed with the
startup type Automatic and status Started. If it is not, click Start. If the service
does not start, reinstall the Storage Manager 8.3 Client. If the failure persists,
call your IBM technical support representative.

3. If you are installing the storage-management software on a host computer, go to
“Redundant Disk Array Controller’] Otherwise, go to [Chapter 5, “Completing the|
installation”, on page 65

Redundant Disk Array Controller

RDAC must be installed on each cluster node. RDAC contains the multipath device
driver that is necessary for controller failover support.

Before you install the software, ensure that the following conditions are met:
* You have Administrator privileges on the cluster nodes.
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» Each cluster node has at least 1 MB of available disk space.
* You close all programs.
» The appropriate host bus adapter driver is installed.

If you are installing RDAC on Windows NT 4.0, continue with [‘Assigning static drive|

If you are installing RDAC on Windows 2000, continue with [‘Installing the

[Redundant Disk Array Controller’}

Assigning static drive letters

Important:

Before installing RDAC, you must assign static drive letters to existing local drives.
Otherwise, problems might occur during new installations and upgrades. When RDAC is
installed, the RDAC uitility installs the RDAC device driver before the Windows NT class
driver. If static drive letters have not previously been assigned to local drives, the system
will detect storage subsystem arrays and assign them drive letters before detecting and
assigning drive letters to local drives. If this occurs and you have software applications
using non-permanent drive letters that are assigned to local drives, application errors will
result.

Use the following procedure to manually assign drive letters on cluster nodes
running Windows NT 4.0:

1. Click Start » Programs » Administrative Tools » Disk Administrator to view
the disk configuration and check the number of partitions.

2. Check that the following conditions are met:
* A boot partition exists.

* The last partition has been created with Disk Administrator or Disk
Management.

» The partition has an assigned drive letter and either an unknown status or a
status other than Unformatted.

If all conditions are met, go to [‘Installing the Redundant Disk Array Controller}
Otherwise, continue to step

3. Create a new partition on your local system or on a storage subsystem using
the following procedure:

a. Select a drive with free space; then, click Partition » Create. The partition is
created with a status of Unformatted and a drive letter is assigned. You can
delete or change the logical drive at a later time without causing
reassignment of the boot partition.

b. Click Partition » Commit Changes Now. The partition status changes to
Unknown, and static drive letters are assigned to all existing partitions.

4. Continue with ['Installing the Redundant Disk Array Controller’}

Installing the Redundant Disk Array Controller
To install RDAC, perform the following steps:

1. Insert the IBM FAStT Storage Manager version 8.3 CD into the CD-ROM drive.
2. Click Start » Run. The Run window opens.

3. Click Browse. The Browse window opens.

4. Select the CD-ROM drive.
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5. Select one of the following directories:

For Windows NT 4.0 Enterprise Edition [\Win32\SMrdac\NT
Windows 2000 Advanced Server \Win32\SMrdac\W2K

6. Select the setup.exe file; then, click Open. The InstallShield window opens,
showing the file unpacking. The Welcome window opens.

7. Click Next to begin the installation. After installing RDAC, the InstallShield
Wizard window opens.

8. Click Yes to restart your computer.

9. Continue with “Verifying the RDAC installation”.

Verifying the Redundant Disk Array Controller installation on

Windows NT and Windows 2000
To verify that RDAC has been installed correctly on Windows NT, perform the

following steps:

Note: Make sure that all storage subsystems are connected to the host computer
and are powered on.

1. Click Start » Settings » Control Panel. A Control Panel window opens,
double-click Devices.

2. When the Devices window opens, scroll to symarray.
« If symarray appears with a device status of Started, go to step @
« If symarray does not appear, an error might have occurred. Repeat the

procedure outlined in|“Installing the Redundant Disk Array Controller” on|
If the failure persists, call your IBM technical support representative.

Otherwise, go to step
3. Perform one of the following procedures:

* If you are managing the storage subsystems using the host-agent method,
continue with [‘Storage Manager 8.3 Agent” on page 55

» If you are managing your storage subsystems directly, go to
[Manager 8.3 Utility” on page 56|

To verify that the Redundant Disk Array Controller has been installed correctly on
Windows 2000, perform the following steps:

Note: Make sure that all storage subsystems are connected to the host computer
and are powered on.

1. Right-click My Computer.

2. Click Start » Programs » Administrative Tools + Computer Management.
The Computer Management window opens. Go to the \System Tools\System
Information\Software environment\Drivers directory.

3. Scroll through the list of device drivers until you find rdacfltr.

4. Verify that rdacfltr is displayed with the state type Running and status OK. If it is
not, repeat the procedure outlined in r‘lnstalling the Redundant Disk Array|
|Contro||er” on page 53L If the failure persists, call your IBM technical support
representative. Otherwise, go to step [5

5. Perform one of the following procedures:

» If you are managing the storage subsystems using the host-agent method,
continue with [‘Storage Manager 8.3 Agent” on page 55,

* If you are managing your storage subsystems directly, go to
[Manager 8.3 Utility” on page 56}
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Storage Manager 8.3 Agent

You must install the Storage Manager 8.3 Agent software if you want to manage the
storage subsystem using the host-agent method.

Before you install the software on Windows NT or Windows 2000, ensure that the
following conditions are met:

* You have Administrator privileges on the cluster nodes.
» Each cluster node has at least 1 MB of available disk space.

* You have installed RDAC on each cluster node. If you have not done so, refer to
[‘Redundant Disk Array Controller” on page 52|

» (For Windows NT 4.0) You have installed Microsoft Virtual Machine (refer to
|“Insta||ing the Microsoft Virtual Machine” on page 50[).

Installing Storage Manager 8.3 Agent on Windows NT and

Windows 2000
To install Storage Management 8.3 Agent, perform the following steps:

1. Close all programs.

2. Insert the IBM FAStT Storage Manager version 8.3 CD in the CD-ROM drive.

3. Click Start » Run. The Run window opens.

4. Click Browse. The Browse window opens.

5. Select the CD-ROM drive.

6. Select the \Win32\SMagent folder; then, click Open.

7. Select the setup.exe file; then, click Open. The InstallShield window opens,
showing the status the file unpacking. The Welcome window opens.

8. Click Next. The End User License Agreement window opens.

9. Read the license and click Yes to begin the installation. The software

installation ends, and the Operation Complete window opens.
10. Click Finish.
11. Continue with*Verifying the Storage Manager 8.3 Agent on Windows NT and

|Windows 2000’].

Verifying the Storage Manager 8.3 Agent on Windows NT and

Windows 2000
To verify that Storage Manager 8.3 Agent has been installed correctly on Windows

NT, perform the following steps:

1. Click Start » Settings » Control Panel. The Control Panel window opens.
2. Double-click Services. The Services window opens.

3. Scroll through the list of services until you find Storage Manager 8 Agent.

» If Storage Manager 8 Agent appears with a startup type of Started, close the
Services window, and continue to step

» |If Storage Manager 8 Agent does not appear with a startup type of Started,
click Start. If the status changes to Started, go to step 4 on page 485, If not,
refer to |Tab|e 18 on page 81|for a possible cause. Otherwise, reinstall
Storage Manager 8.3 Agent. If the problem persists, contact your IBM
technical support representative.

4. Perform one of the following procedures:

* If you plan to use the host-agent software to manage one or more storage

subsystems, go to f‘Storage Manager 8.3 Utility” on page 56L
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* If you do not plan to use the host-agent software to manage one or more
storage subsystems, perform the following steps to disable the host-agent
service:

a. Click Start » Programs » Administrative Tools » Manage. The
Computer Management window opens.

Click Services.
From the list of displayed services, right-click Storage Manager 8 Agent.
Click Properties » Startup Type » Manual.
e. Click OK.
5. Continue with ['Storage Manager 8.3 Utility’|

a oo

To verify that Storage Manager 8.3 Agent has been installed correctly on Windows
2000, perform the following steps:

1. Click Start » Programs » Administrative Tools » Services. The Services
window opens.

2. Scroll through the list of services until you find Storage Manager 8 Agent.

3. Verify that Storage Manager 8 Agent is displayed with the startup type
Automatic and status Started. If Storage Manager 8 Agent does not appear with

a startup type of Started, click Start. If the status changes to Started, go to step
If not, refer to[Table 18 on page 81| for a possible cause.
Otherwise, reinstall Storage Manager 8.3 Agent. If the problem persists, contact
your IBM technical support representative.

4. Perform one of the following procedures:

» If you plan to use the host-agent software to manage one or more storage
subsystems, go to [‘Storage Manager 8.3 Utility’|

* If you do not plan to use the host-agent software to manage one or more
storage subsystems, perform the following procedure to disable the
host-agent service:

a. Click Start » Programs » Administrative Tools »+ Computer
Management. The Computer Management window opens.

Click Services.
From the list of displayed services, right-click Storage Manager 8 Agent.
Click Properties » Startup Type » Manual.
e. Click OK.
5. Continue with [‘'Storage Manager 8.3 Utility”}

a oo

Storage Manager 8.3 Utility

This section provides instructions for installing the Storage Manager 8.3 Utility
software on cluster nodes. This component contains utilities that will register and
map new logical drives to the operating systems.

Installing Storage Manager 8.3 Utility on Windows NT and

Windows 2000
To install Storage Manager 8.3 Utility, perform the following steps:

1. Close all programs and insert the IBM Storage Manager version 8.3 installation
CD in the CD-ROM drive.

Click Start » Run. The Run window opens.

Click Browse. The Browse window opens.
Select the CD-ROM drive.

Select the \Win32\SMutil folder. Then click Open.

ok~ wDd
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6. Select the setup.exe file. Then click Open. The InstallShield Wizard window
opens, displaying the status of the files unpacking. The Welcome window
opens.

7. Click Next.

8. The End User License Agreement window opens. Click Yes to begin the
installation. After the installation is complete, the Operation Complete window
opens.

9. Click Finish.

10. Continue with [‘Verifying the Storage Manager 8.3 Utility installation” on|

|page 46|

Verifying the Storage Manager 8.3 Utility installation
To verify that Storage Manager 8.3 Utility has been installed correctly, perform the

following steps:
1. Go to the following directory:

installation_directonAIBM_FAStT\Util

where installation_directory is the directory where you installed the Storage
Manager 8.3 Utility.

2. Verify that the directory contains the following files:
* hot_add.exe
* SMdevices.bat
« SMflashcopyassist.exe

If it does not, reinstall the Storage Manager 8.3 Utility using the procedure
outlined in [Installing Storage Manager 8.3 Utility” on page 46! If the problem
persists, contact your IBM technical support representative.

3. Go to [‘Overview: Installing Storage Manager in a cluster environment” on|

|Eage 49].

Installing the cluster server software

Important:

Do not perform this procedure unless you have installed the necessary
storage-management software components on both cluster nodes.

To install the cluster server software on Nodes A and B, perform the following steps:
1. Install the cluster server software on Node A, as follows:

a. Refer to the appropriate Microsoft Cluster Server (MSCS) documentation for
the correct procedure to install the cluster server software.

Note: During installation, specify that you want to form a new cluster.
b. After the system restarts, leave Node A running.
2. Install the cluster server software on Node B, as follows:

a. Refer to the appropriate MSCS documentation for the correct procedure to
install the Cluster Server software.

Note: During installation, specify that you want to join the existing cluster.
b. After the system restarts, leave Node B running.
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After installing MSCS, perform one of the following tasks:
* For systems running Windows NT, reinstall Service Pack 6a.
* For systems running Windows 2000, reinstall Service Pack 3.

Note: Refer to Microsoft knowledge base article Q174799 for more information
about installing a service pack in a cluster environment.
Verify the software installation, as follows:
a. On either node A or node B, click Start + Programs » Administrative Tools
» Cluster Administration.

b. In the Cluster or Server Name field, type either the name of the cluster or
the name or IP address of one of the nodes.

If the installation is successful, the computer names of both nodes appear
on the left side of the Cluster Administrator window.

c. Make sure that the cluster disk groups can be moved between cluster
nodes.

If both node names do not appear on the left side of the Cluster Administrator
window, reinstall the cluster server software. If the problem persists, contact
your IBM technical support representative.

Upgrading from a previous version of the storage-management

software

Be sure that you are familiar with the steps required in a new installation before you
continue with the following upgrade procedure.

Choose one of the following two procedures:

Performing a scheduled upgrade: A scheduled upgrade requires scheduling
downtime on your cluster server to upgrade the controller firmware and
storage-management software. The services and resources offered by the cluster
are not available during the upgrade.

Note: The scheduled upgrade is the preferred procedure for upgrading a cluster
server configuration.

Performing a rolling upgrade: A rolling upgrade requires upgrading the
storage-management software first in node A and then in node B, so that the
services and resources offered by the cluster are always available.

Important: Do not upgrade your storage subsystem firmware until you have
upgraded the storage-management software on all cluster nodes and management
stations. If you upgrade your storage subsystem controller firmware to version
05.3x.xx.xx, you will not be able to communicate with the controller until you have
upgraded to Storage Manager 8.3 software on your management station and cluster
nodes. Previously installed versions of Storage Manager will not recognize
controllers running version 05.3x.xx.xx firmware.

Performing a scheduled upgrade for Windows NT and Windows 2000

To perform a scheduled upgrade from Storage Manager version 7.xx, 8.0 and 8.2x
to Storage Manager 8.3, perform the following procedures:

Before installing the storage-management software, perform the following

steps:

a. Click Start » Programs » Administrative Tools » Services. The Services
window opens.
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10.
11.

12.

13.

14.

15.

16.

17.
18.

b. From the list of displayed services, right-click the cluster server. Then, click
Manual.

c. Stop the cluster server on all nodes in the cluster configuration.
Shut down node B.

From node A, uninstall the components from the previous version of the
storage-management software. To uninstall the storage-management software
for Storage Manager version 7.x, 8.0 or 8.2x see f‘UninstaIIina(
|storage-management software components” on page 80|

Note: Uninstall the storage-management components in the following order:
a. Storage Manager Agent

b. Storage Manager Utility

c. Redundant Disk Array Controller

d. Storage Manager Client

Verify that the IBM host adapter device driver versions are current. If they are
not current, refer to the readme file located in the \Host_Adapter directory on
the installation CD and upgrade the device drivers.

Install the Storage Manager 8.3 Client on node A. Refer to [‘Storage Manager|
[8.3 Client” on page 51| for instructions.

Install the Redundant Disk Array Controller on node A. Refer to ['Redundant
[Disk Array Controller” on page 52| for instructions.

Install the Storage Manager 8.3 Agent on node A. Refer to [‘Storage Manager|
[8.3 Agent” on page 55| for instructions.

Install the Storage Manager 8.3 Utility on node A. Refer to [‘Storage Manager|
[8.3 Utility” on page 56| for instructions.

Shut down node A.

Restart node B.

From node B, uninstall the components from the previous version of the
storage-management software. To uninstall the storage-management software
for Storage Manager version 7.x, 8.0 or 8.2x, refer to FUninstallind
[storage-management software components” on page 80|

Verify that the IBM host adapter device driver versions are current. If they are
not current, refer to the readme file located in the \Host_Adapter directory on
the installation CD and upgrade the device driver versions before continuing.

Install the Storage Manager 8.3 Client on node B. Refer to[“Storage Manager
[8.3 Client” on page 51| for instructions.

Install the Redundant Disk Array Controller on node B. Refer to
[Disk Array Controller” on page 52| for instructions.

Install the Storage Manager 8.3 Agent on node B. Refer to |“Storage Managed
(8.3 Agent” on page 55| for instructions.

Install the Storage Manager 8.3 Utility on node B. Refer to[*Storage Manager|
(8.3 Utility” on page 56| for instructions.

Shut down node B.
Start up one node at a time and complete the following procedure:

a. Click Start » Programs» Administrative Tools » Services. The Services
window opens.

b. From the list of displayed services, right-click the cluster server. Click
Automatic to change the cluster server startup option.

c. Start the cluster server service on node B.
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19. Go to|Chapter 5, “Completing the installation”, on page 65|

Performing a rolling upgrade for Windows NT and Windows 2000

Important:

If you have applications installed in the cluster server environment that do not support a

rolling upgrade, perform one of the following tasks:

« Put those resources offline before the upgrade; then, put them back online after the
upgrade.

« Perform a scheduled upgrade. A scheduled upgrade requires scheduling downtime on
your cluster server to upgrade the controller firmware and storage-management software.

To perform a rolling upgrade from Storage Manager version 7.xx, 8.0 or 8.2x to
Storage Manager 8.3, perform the following steps:

1. From node A, open Cluster Administrator.

2. Double-click the Active Groups folder in the right pane of the Cluster
Administrator window.

3. Select each group listed, and move them to node B.

4. Select node A. Then click File » Pause Node to pause cluster service in node
A

5. From node A, uninstall the components from the previous version of the
software. To uninstall the software for Storage Manager version 7.x, 8.0 or
8.2x, refer to[‘Uninstalling storage-management software components” on|

|Qage 80|

Note: Uninstall the components in the following order:
a. Storage Manager Agent

b. Storage Manager Utility

c. Redundant Disk Array Controller

d. Storage Manager Client

6. Verify that the IBM host adapter device driver versions are current. If they are
not current, refer to the readme file located in the \Host_Adapter directory on
the installation CD and upgrade the device drivers.

7. Install the Storage Manager 8.3 Client on node A. Refer to [‘Storage Manager|
[8.3 Client” on page 51| for instructions.

8. Install the Redundant Disk Array Controller on node A. Refer to
[Disk Array Controller” on page 52| for instructions.

9. Install the Storage Manager 8.3 Agent on node A. Refer to [‘Storage Manager|
18.3 Agent” on page 55| for instructions.

10. Install the Storage Manager 8.3 Utility on node A. Refer to [‘Storage Manager|
(8.3 Utility” on page 56| for instructions.

11. Run Cluster Administrator. Then click File » Resume Node to resume cluster
service in node A.

12. From node B, open Cluster Administrator.

13. Double-click the Active Groups folder in the right pane of the Cluster
Administrator window.

14. Select each group listed, and move them to node A.

15. Select node B. Then click File » Pause Node to pause cluster service in node
B.
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16.

17.

18.

19.

20.

21.

22.

23.

From node B, uninstall the components from the previous version of the
software. To uninstall the storage-management software for Storage Manager
version 7.x, 8.0 or 8.2x, refer to[“Uninstalling storage-management software
fcomponents” on page 80|

Verify that the IBM host adapter device driver versions are current. If they are
not current, refer to the readme file located in the \Host_Adapter directory on
the installation CD and upgrade the device drivers.

Install the Storage Manager 8.3 Client on node B. Refer to[“Storage Manager|
8.3 Client” on page 51|for instructions.

Install the Redundant Disk Array Controller on node B. Refer to
[Disk Array Controller” on page 52| for instructions.

Install the Storage Manager 8.3 Agent on node B. Refer to[“Storage Managet|
8.3 Agent” on page 55| for instructions.

Install the Storage Manager 8.3 Utility on node B. Refer to [‘Storage Manager|
8.3 Utility” on page 56] for instructions.

Run Cluster Administrator. Then click File » Resume Node to resume cluster
service in node B.

Go to|Chapter 5, “Completing the installation”, on page 65|

Upgrading from Windows NT 4.0 to Windows 2000 in a cluster

configuration

To

ensure that the services and resources offered by the cluster are always

available, you must perform a rolling upgrade. A rolling upgrade requires upgrading
the controller firmware, storage-management software, and operating system first in
node A and then in node B.

Important:

If you have applications installed in the cluster server environment that do not support a
rolling upgrade, perform one of the following tasks:

Put those resources offline before the upgrade; then, put them back online after the
upgrade.

Perform a scheduled upgrade. A scheduled upgrade requires scheduling downtime on
your cluster server to upgrade the controller firmware and storage-management software.

To

upgrade from Windows NT 4.0 Enterprise Edition to Windows 2000 Advanced

Server, perform the following steps:

1.

2.
3.
4

On node A, open Cluster Administrator.
Double-click the Active Groups folder in the right pane of Cluster Administrator.
Make sure that all of the groups failover to node B successfully.

Select node A. Then click File » Pause Node to pause cluster service in node
A

From node A, uninstall all software components. To uninstall the software, refer
to[‘Uninstalling storage-management software components” on page 80|
Uninstall the components in the following order:

a. Storage Manager 8.3 Agent
b. Storage Manager 8.3 Utility
c. Storage Manager 8.3 Redundant Disk Array Controller
d. Storage Manager 8.3 Client
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10.

11.

12.

13.

14.
15.
16.
17.

18.

19.

20.

21.

22.

Follow the instructions from Microsoft to upgrade node A from Windows NT
Enterprise Edition to Windows 2000 Advanced Server.

Note: During the upgrade, the existing cluster server installation is detected
and clustering for Windows 2000 Advanced Server is installed. When
the upgrade is complete, node A will rejoin the cluster and remain
paused.

Verify that the host bus adapter (HBA) device driver versions are correct. If
they are not the certified versions, refer to the readme file in the \Host_Adapter
directory on the installation CD and upgrade the device driver versions before
you continue.

Verify that node A was successfully upgraded to Windows 2000 Advanced
Server.

Install the Storage Manager 8.3 Client on node A. Refer to [‘Storage Manager|
8.3 Client” on page 51| for instructions.

Install the Redundant Disk Array Controller on node A. Refer to
[Disk Array Controller” on page 52| for instructions.

Install the Storage Manager 8.3 Agent on node A. Refer to[“Storage Manager|
[8.3 Agent” on page 55| for instructions.

Install the Storage Manager 8.3 Utility on node A. Refer to [‘Storage Manager|
[8.3 Utility” on page 56| for instructions.

Run Cluster Administrator. Then click File * Resume Node to resume cluster
service in node A.

On node B, open Cluster Administrator.
Double-click the Active Groups folder in the right pane of Cluster Administrator.
Make sure that all of the groups failover to node A successfully.

Select node B. Then click File » Pause Node to pause cluster service in node
B.

From node B, uninstall all software components. To uninstall the software, refer
to[“Uninstalling storage-management software components” on page 80}
Uninstall the components in the following order:

a. Storage Manager Agent
b. Storage Manager Utility
c. Redundant Disk Array Controller
d. Storage Manager Client

Follow the instructions from Microsoft to upgrade node B from Windows NT
Enterprise Edition to Windows 2000 Advanced Server.

Note: During the upgrade, the existing cluster server installation is detected
and clustering for Windows 2000 Advanced Server is installed. When
the upgrade is complete, node B will rejoin the cluster and remain
paused.

Verify that the host bus adapter (HBA) device driver versions are correct. If
they are not the certified versions, refer to the readme file in the \Host_Adapter
directory on the installation CD and upgrade the device driver versions before
you continue.

Verify that node B was successfully upgraded to Windows 2000 Advanced
Server.

Install the Storage Manager 8.3 Client on node B. Refer to[“Storage Manager|
[8.3 Client” on page 51|for instructions.
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23.

24.

25.

26.

27.

Install the Redundant Disk Array Controller on node B. Refer to
[Disk Array Controller” on page 52| for instructions.

Install the Storage Manager 8.3 Agent on node B. Refer to|“Storage Manager|
[8.3 Agent” on page 55| for instructions.

Install the Storage Manager 8.3 Utility on node B. Refer to[“Storage Manager
(8.3 Utility” on page 56| for instructions.

Run Cluster Administrator. Then click File » Resume Node to resume cluster
service in node B.

Go to [Chapter 5, “Completing the installation”, on page 65|
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Chapter 5. Completing the installation

This chapter contains procedures on how to use Enterprise Management and
Subsystem Management to complete the following installation tasks:

1. Install SANavigator, if you want.
Perform an initial automatic discovery of storage subsystems.
Add devices, if necessary.
Set up alert notifications, if you want.
Name the storage subsystems.
Download firmware and NVSRAM.
Create arrays and logical drives.
Verify and define the default host type.
9. Configure the heterogeneous hosts.
10. Perform other storage subsystem tasks.

© N oA OD

Each of these steps is discussed in detail in the sections that follow.

The Enterprise Management window opens when you start the FASIT Storage
Manager. Use the Enterprise Management window to:

» Add and discover the storage subsystems.
* View all storage subsystems in your management domain.
» Perform batch storage subsystem management tasks using the Script Editor.

Introduction to SANavigator

This section provides an overview of the functions of SANavigator. SANavigator is
an application that enables you to easily monitor and manage your storage area
network (SAN). It is a powerful diagnostic tool that detects SAN failures and
displays them in a graphical manner. When you use SANavigator with the problem
determination maps found in the FAStT Hardware Maintenance Manual and
Problem Determination Guide, you can detect and diagnose SAN malfunctions
easily. Install SANavigator after you have installed the IBM FAStT Storage Manager
and the FAStT Management Suite Java (FAStT MSJ).

SANavigator features

SANavigator enables you to easily monitor and manage your SAN through the

following features:

» Discovery
SANavigator uses TCP/IP (out-of-band) and Fibre Channel (in-band) to establish
contact with a large number of SAN devices, gather embedded information, and
then depict it graphically. SANavigator discovers the devices that are attached to
your SAN. It then presents a visual map of devices and their interconnections to
enable you to identify any problem components in the map.

* Monitoring
SANavigator generates events and messages about the status of devices and
their respective properties. The self-monitoring event logging and messaging
feature enables you to stay informed about the current state of the SAN.

» Launching device applications and utilities

You can launch applications and utilities such as IBM FAStT Storage Manager
and IBM FAStT MSJ from SANavigator by right-clicking on the respective
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devices. A pop-up menu displays that allows you to select the applications as
well as link to the IBM Fibre Channel Solution Support web site.

* Reporting
SANavigator enables you to generate, view, and print reports.

To learn more about the features of SANavigator, see the IBM Hardware
Maintenance Manual and Problem Determination Guide.

System requirements
The following are the minimum requirements for SANavigator:

* Microsoft Windows operating systems (Windows NT SP 6a and Windows 2000
Professional, Enterprise Server, and Advanced Server)

— 700 MHz Intel® Pentium IIl and up
— CD-ROM
- 512 MB RAM
— Disk space: 150 MB
— VGA - 256 colors or greater
+ Linux operating systems (Red Hat 7.2 and above)
— 700 MHz Intel Pentium Il and up
- 512 MB RAM
— Disk Space: 150 MB
— VGA - 256 colors or greater

Installing SANavigator

SANavigator installation is easy and fast. After installing IBM FASIT Storage
Manager Version 8.3, consider installing the FAStT MSJ and SANavigator
diagnostic programs. You can use these programs to verify the status of the
fibre-channel connections before using the storage subsystem.

The SANavigator program, the IBM FAStT MSJ User’s Guide and FAStT MSJ
program are located on the IBM FAStT Storage Manager Version 8.3 CD. For
information about how to install and run SANavigator, see the FAStT Hardware
Maintenance Manual and Problem Determination Guide

Performing an initial automatic discovery of storage subsystems

To perform an initial automatic discovery of storage subsystems, perform the
following steps:
1. Click Start » Programs.

2. Click IBM FASIT Storage Manager 8 Client v08.33.G5.xx. The client software
starts and displays the Enterprise Management window and the Confirm Initial
Automatic Discovery window.
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Figure 18. Confirm Initial Automatic Discovery window
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Note: The Enterprise Management window might take several minutes to open.

No wait cursor (such as an hourglass) is displayed.
Click Yes to begin an initial automatic discovery of hosts and storage

subsystems attached to the local subnetwork.

After the initial automatic discovery is complete, the Enterprise Management
window displays all hosts and storage subsystems attached to the local

subnetwork.

Note: The Enterprise Management window might take up to a minute to refresh
after an initial automatic discovery.
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Figure 19. Enterprise Management window

4.

Verify that each host and storage subsystem is displayed in the Enterprise
Manager window.

If a host or storage subsystem is not displayed, perform the following tasks:

Check the hardware and connections for possible problems (refer to the
hardware documentation for specific procedures).

Refer to the Enterprise Management online help for additional information
about discovering storage subsystems.

If you are using the direct-management method, verify that all hosts and
storage subsystems are connected to the same subnet network. If you are
using the host-agent method, ensure that the Fibre Channel connection
between the host and storage subsystems is made.

Make sure that all of the preparation steps for setting up the storage
subsystem for a directly-managed system in Chapter 2 are completed. If they
are, use the Add Device option to add the IP addresses of the Storage
subsystem. Add both IP addresses of the controller. Otherwise, you will get a
"partially-managed device” error message when you try to manage the
storage subsystem.

If you are using the host-agent management method, perform the following
steps:
a. Make sure that the Storage Manager 8.3 Agent is installed in the host.

b. Verify that you have a Fibre Channel connection from the storage
subsystems to the host that has the Storage Manager 8.3 Agent installed.

c. Verify that all of the preparation steps outlined in [Chapter 2, “Preparing for
installation”, on page 21| have been completed. If they have, perform the
following steps:

1) Run the Hot Add Utility.
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2) Restart the Storage Manager 8.3 Agent using the information in
[‘Stopping and restarting the host-agent software” on page 79|

3) Click Tools —> Rescan in the Enterprise management window.

Note: In certain situations, a storage subsystem might be duplicated in the
device tree after an automatic discovery. You can remove a duplicate
storage-management icon from the device tree by using the Remove
Device option in the Enterprise Management window.

5. Verify that the status of each storage subsystem is Optimal. If a device shows a
status of Unresponsive, right-click the device and select Remove Device to
delete it from the management domain. Then use the Add Device option to add
it to the management domain again. Refer to the Enterprise Management
window online help for instructions on removing and adding devices.

6. Continue with ['‘Adding devices’}.

Adding devices

You can manually add more hosts or storage subsystems. You can use this option
to selectively manage a group of storage subsystems from a Storage Manager 8
Client. You can also use this option to add additional devices to be managed that
were not discovered during the Storage Manager 8 Client initial discovery. For more
information about this option, refer to the Enterprise Management window online
help.

Important:

* When you add new storage subsystems to the existing storage subsystems in a
Storage Area Network (SAN) that are managed through the host-agent software,
you must stop and restart the host-agent service. When the host-agent service
restarts, the new storage subsystem is detected. For more information, refer to
[‘Stopping and restarting the host-agent software” on page 79| Then, go to the
Enterprise Management window and click Tools » Rescan to add the new
storage subsystems to the management domain.

* When you add new storage subsystems to existing storage subsystems that are
managed using the direct-management method, be sure to specify the IP
addresses for both controllers.

Continue with [‘Setting up alert notifications’|

Setting up alert notifications

After you add devices to the management domain, you can set up alert notification
to report critical events on the storage subsystems. The following alert-notification
options are available:

* Notification to a designated network management station (NMS) using Simple
Network Management Protocol (SNMP) traps

* Notification to designated e-mail addresses

* Notification to designated alphanumeric pagers (requires separately supplied
software to convert e-mail messages)

Note: You can only monitor storage subsystems within the management domain. If
you do not install Event Monitor service, the Enterprise Management window
must remain open. If you close the window, you will not receive any alert
notifications from the managed storage subsystems. Refer to the Enterprise
Management window online help for additional information.
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To set up alert notification to an NMS using SNMP traps, perform the following

steps:

1. Insert the IBM FASIT Storage Manager version 8.3 CD into the CD-ROM drive
on a NMS. You need to set up the designated management station only once.

2. Copy the SM820.MIB file from the SM820.mib directory to the NMS.

3. Follow the steps required by your NMS to compile the management information
base (MIB) file. (For details, contact your network administrator or see the
documentation specific to the storage management product you are using.)

4. Continue with ['Naming storage subsystems’]

Naming storage subsystems

To name your storage subsystem, perform the following steps:
1. In the Enterprise Management window, select a storage subsystem.
2. Click Tools » Manage Device. The Subsystem Management window opens, as

shown in
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Figure 20. Subsystem Management window

3. Click Storage Subsystem » Rename. The Rename Storage Subsystem
window opens.

4. Type the name of the storage subsystem (refer to [Table 19 on page 87). Then
click OK.

5. Repeat for each unnamed storage subsystem. For more information, refer to the
topic on renaming storage subsystems in the Subsystem Management window
online help.

6. Continue with ['Downloading firmware and NVSRAM|

Downloading firmware and NVSRAM

This section provides instructions for downloading firmware and NVSRAM. You
must download firmware version 05.3x.xx before you download NVSRAM.
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Downloading firmware
To download firmware version 05.3x.xx, perform the following steps:
1. From the Enterprise Management window, select a storage subsystem.
2. Click Tools » Manage Device. The Subsystem Management window opens.

3. Click Storage Subsystem » Download » Firmware. Follow the instructions that
display.

4. Continue with 'Downloading NVSRAM’|

Downloading NVSRAM

To download NVSRAM, perform the following steps:
1. From the Enterprise Management window, select a storage subsystem.
2. Click Tools » Manage Device. The Subsystem Management window opens.

3. Click Storage Subsystem» Download »+ NVSRAM. Follow the instructions that
display.

4. Continue with [‘Creating arrays and logical drives’].

Creating arrays and logical drives

An array is a set of Fibre Channel hard drives that are logically grouped together to
form a RAID set. The maximum number of hard drives for each array is 30 if the
hard drive capacities are 73.4GB or less and 14 if the hard drive capacities are
146GB. Each array can be divided into 1 to 256 logical drives. A logical drive is a
logical structure, which is the basic structure that you create to store data on the
storage subsystem. The operating system recognizes a logical drive as a single
drive. Choose a RAID level to meet application needs for data availability and
maximize Fibre Channel I/O performance.

To create arrays and logical drives, perform the following steps:

1. From the Enterprise Management window, select a storage subsystem.

2. Click Tools » Manage Device. The Subsystem Management window opens.
3. Click the Logical/Physical View tab.
4

Click Logical Drive » Create. The Logical Drive Create wizard starts. Follow
the online instructions to create arrays and logical drives.

5. Continue with ['Verifying and defining the default host type’l

Note: (For cluster configurations) If you add or delete logical drives, you must
make them known to both node A and node B.

Verifying and defining the default host type

Before you use the logical drives in a host computer, you must specify the host
type. The host type determines how the storage subsystem controllers will work
with each particular operating system on the hosts to which it is connected. If all of
the host computers connected to the same storage subsystem are running the
same operating system, and you do not want to define partitioning, you can define
a default host type.

To verify the current default host type, perform the following steps:

1. In the Subsystem Management window, click View > Storage subsystem
profile. A Storage Subsystem Profile window opens.
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2. Click the Mappings folder tab and scroll down to NVSRAM Host Type Internal
Definitions. The host type name of the index that has the word DEFAULT next
to it is the default host type.

3. Click Close.

To define a default host type, perform the following steps:

1. Click Storage subsystem » Change » Default host-type. The Default
Host-type window opens.

2. From the pull-down list, select the host type.
3. Click OK.

If you have hosts with different operating systems or if you want to define partitions
for the hosts, continue with [‘Configuring heterogeneous hosts’|.

Configuring heterogeneous hosts

The heterogeneous hosts feature enables hosts running different operating systems
to access a single storage subsystem. Previous releases of FASIT Storage
Manager (versions 7.02 or earlier) required that hosts run the same operating
system in order to access a single storage subsystem.

Host computers can run completely different operating systems (for example,
Solaris and Windows NT) or variants of the same operating system (for example,
Windows NT running in a cluster environment or Windows NT running in a
noncluster environment). When a host type is specified in the Define New Host Port
window, the heterogeneous hosts feature enables the controllers in the storage
subsystem to tailor their behavior (such as LUN reporting) to the needs of the host.

Important: To use the heterogeneous host feature, you must meet the following
conditions:

* You must enable storage partitioning.

» During host-port definition, you must set each host type to the appropriate
operating system so that the firmware on each controller can respond correctly to
the host.

To start the heterogeneous host configuration, perform the following steps:
1. From the Subsystem Management window, click Mappings View.
2. Follow the on-screen instructions.

3. Continue with ['Performing other storage-subsystem management tasks’|

Note: Partitioning is a premium feature. If you disable partitioning, you must
contact your IBM technical support representative to obtain a key to reenable
partitioning.

Performing other storage-subsystem management tasks
The following list includes other storage subsystem management tasks that you can
perform:
» Locating a storage subsystem
* Viewing a storage subsystem profile or event log
» Entering or changing a storage subsystem password
» Creating and managing logical drives and arrays
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» Using the Performance Monitor

» Creating storage patrtitions (if applicable) and heterogeneous hosts
» Viewing or changing media scan settings

* Increasing capacity of an array or logical drive

» Changing RAID level for an array

» Monitoring read-link-status error counts

» Downloading ESM firmware or Fibre Channel drive firmware

Note: To create storage partitions, you must obtain the worldwide name or port of
each host adapter in every host connected to the storage subsystem.

For more information about these and other storage subsystem management tasks,
refer to the appropriate topics in the Subsystem Management online help.
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Chapter 6. Using the storage-management software

This chapter provides information about how to add or delete logical drives, create
FlashCopy logical drives, use the Hot Add and SMdevices utilities, start and stop
the host-agent software, and uninstall Storage Manager components.

Adding or deleting logical drives

Use the following instructions to add or delete logical drives in a standard
(noncluster) configuration.

Standard (noncluster) configuration for Windows NT

Creating logical drives

When you create logical drives with the storage-management software, you must
add the new logical drives to Windows NT. Refer to the Windows NT documentation
for details about how to add a drive. Each logical drive (not array) is recognized by
Windows NT as a single drive.

After you create logical drives, run the Hot Add and SMdevices utilities that are
provided with the storage-management software. The Hot Add utility adds newly
created logical drives to the operating system, and the SMdevices utility identifies
logical drives by their associated operating system device names. For more
information, see|[“Using the Hot Add utility” on page 78 and [‘Using the SMdevices|
lutility” on page 78]

Deleting logical drives

Important: If you have data or logical drives that you want to keep, do not click Configure
> Reset Configure. This action resets the controller unit and deletes all
previously-configured logical drives.

Before deleting logical drives with the storage-management software or using
Configure » Reset Configuration, use Cluster Administrator to delete the cluster
physical disk resources that own the logical drives that will be deleted. Then, use
Disk Administrator to delete any partitions and to unassign drive letters that are
associated with the logical drives. Restart the system to remove the configuration
information.

Attention: You must use Cluster Administrator and Disk Administrator to delete
the cluster physical disk resources, OS partitions, and unassigned drive letters
before deleting logical drives or resetting the configuration in Storage Manager. This
will avoid damage to your registry information.

Cluster server configuration for Windows NT

To add logical drives in a Windows NT 4.0 cluster server environment, perform the
following steps:

1. Using the IBM FASLT Storage Manager 8 Client, create arrays and assign
them to the appropriate host group by using storage partitioning.

2. Stop the cluster server service in node A. Make sure that all of the cluster
groups and resources failover to node B.

3. Perform the following steps to disable the cluster server service and the cluster
disk device in node A:

a. Click Start » Settings » Control Panel. The Control Panel window opens.
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b. Click Services. The Services window opens.
c. Select Cluster Server, and click Startup. The Service window opens.
d. Change the Startup Type Setting to Disabled; then, click OK.
e. Close the Services window.
f. Click Start » Settings » Control Panel. The Control Panel window opens
g. Click Devices. The Device window opens.
h. Select Cluster Disk; then, click Startup. The Devices window opens.
i. Select Disabled; then, click OK.
j- Close the Devices window.
4. Restart node A.
5. Use Disk Administrator to create and format your operating system partitions.

6. Enable cluster server service and the cluster disk device in node A. Make sure
that the start-up type is set to System for cluster disk device and Automatic for
cluster server service.

7. Restart node A. Then make sure that the cluster server service has started
and that the cluster groups and resources have failed back correctly.

8. Stop the cluster server service in node B.

9. Using the procedure outlined in step , disable cluster server

service and the cluster disk device in node B.
10. Restart node B.

11. Use Disk Administrator to reassign the drive letters to match the ones that
were assigned to a given disk in node A.

12. Enable cluster server service and the cluster disk device in node B. Make sure
that the start-up type is set to System for cluster disk device and Automatic for
cluster server service.

13. Restart node B. Then make sure that the cluster server service started and the
cluster groups and resources failed back correctly.

14. Stop the cluster server service in node A.
15. Restart node A.

16. After cluster server service has started, use Cluster Administrator to create
your physical disk resources.

17. Verify that the physical disk resources can be brought online in both nodes.

Standard (noncluster) configuration for Windows 2000

Use the following instructions to create or delete logical drives in a cluster server
environment.

Creating logical drives

When you create logical drives with the storage-management software, you must
add the new logical drives to the Windows 2000 operating system. Each logical
drive (not array) is recognized by Windows 2000 as a single drive.

After creating logical drives, run the HotAdd and SMdevices utilities that are
provided with the storage-management software. The Hot Add utility adds newly
created logical drives to the operating system, and the SMdevices utility identifies
logical drives by their associated operating system device names. For more
information, see|“Using the Hot Add utility” on page 78 or [‘Using the SMdevices|
lutility” on page 78]
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Deleting logical drives

Important: If you have data or logical drives that you want to keep, do not click Configure
+ Reset Configure. This action resets the controller unit and deletes all
previously-configured logical drives.

Before you delete logical drives with the storage-management software or use
Configure » Reset Configuration, use Cluster Administrator to delete the cluster
physical disk resources that own the logical drives that will be deleted. Then, use
Disk Administrator to delete any partitions and to unassign drive letters that are
associated with the logical drives. Restart the system to remove the configuration
information.

Attention: You must use Cluster Administrator and Disk Administrator to delete
the cluster physical disk resources, OS partitions, and unassigned drive letters
before you delete logical drives or reset the configuration in Storage Manager. This
action will avoid damage to your registry information.

Cluster server configuration for Windows 2000

To add logical drives in a Windows 2000 cluster server environment, perform the
following steps:

1. Using the IBM FAStT Storage Manager 8 Client, create arrays and assign them
to the appropriate host group by using storage partitioning.

2. Use the Hot Add utility to add the new logical drives to node A.

3. Using the Disk Administrator, create, format, and assign drive letters to the disk
partitions on the new logical drives.

4. Use the Hot Add utility to add the new logical drives to node B.

5. Using the Disk Administrator, ensure that the drive letters assigned to the disk
partitions on the logical drives are the same on both node A and node B.

6. Restart node A. Then use the Cluster Administrator to create cluster physical
disk resources using the new disk partitions on the new logical drives.

7. Bring the cluster resources online in node A.
8. Use cluster administrator to move the cluster physical disk resources to node B.
9. Verify that the resources come online on node B.

Creating a FlashCopy logical drive
A FlashCopy logical drive is a logical point-in-time image of a logical drive, called a
base logical drive. A FlashCopy logical drive has the following features:
» |t is created quickly and requires less disk space than an actual logical drive.

* It can be assigned to a host address, so that you can perform backups using the
FlashCopy logical drive while the base logical drive is online and accessible.

* You can use the FlashCopy logical drive to perform application testing or
scenario development and analysis. This does not effect the actual production
environment.

» The maximum number of FlashCopy logical drives allowed is one half of the total
logical drives supported by your controller model.

For additional information about the FlashCopy feature and how to manage Flash
Copy logical drives, refer to the Storage Manager Subsystem Management online
help.

Note: FlashCopy is a purchased premium feature. Contact your IBM reseller or
IBM marketing representative for more information.
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To create a FlashCopy logical drive, perform the following steps:

1. To ensure that you have the accurate point-in-time image of the base logical
drive, stop applications and flush cache 1/O to the base logical drive. For
instructions, see [‘Using the SMflashcopyassist utility” on page 79}

2. Open the Subsystem Management window. From the Logical View, right-click
the base logical drive.

3. Select Create FlashCopy Logical Drive. The Create FlashCopy Logical Drive
Wizard starts.

4. Follow the on-screen instructions.

5. Refer to the Subsystem Management online help for instructions on how to add
the FlashCopy logical drive to the host.

Using the Remote Mirror feature

The Remote Mirror feature is a purchased premium feature. The Remote Mirror
Option is used for online, real-time replication of data between storage subsystems
over a remote distance. In the event of a disaster or unrecoverable error at one
storage subsystem, you can promote a second storage subsystem to take over
responsibility for normal 1/0 operations. Consult the IBM FAStT Remote Mirror
Option Installation and User’s Guide, or contact your IBM reseller or IBM marketing
representative for more information.

Using the Hot Add utility

The Hot Add utility enables you to add new logical drives without restarting the
system. The utility registers the new logical drives with the operating system so that
you can use Disk Administrator to create partitions, add device names, and so on.
The Hot Add utility is part of the Storage Manager 8.3 Utility software package. If
you run the program twice and the new logical drives are not displayed in the Disk
Administrator window, you must either run Fibre Channel diagnostics or restart
(reboot) the host.

When you finish creating logical drives on a particular storage subsystem, go to the
host that is attached to that storage subsystem and perform the following steps to
use the Hot Add utility:

1. From a DOS or command prompt, change to the
installation_directonAIBM_FAStT\Util where installation_directory is the directory
where you installed the Storage Manager 8.3 Utility.

2. From a DOS or command prompt, type the following command:
hot_add
3. Press Enter. The new logical drives are available through the Disk Administrator.

Using the SMdevices utility

The Storage Manager 8.3 Utility software includes a utility called SMdevices that
you can use to view the storage subsystem logical drive that is associated with a
particular operating system device name. This utility is helpful when you want to

create drive letters or partitions by using Disk Administrator.

When you finish creating the logical drives on a particular storage subsystem, go to
the host that is attached to that storage subsystem, and perform the following steps
to use SMdevices:
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1. From a DOS or command prompt, change to the
installation_directonAIBM_FAStT\Util where installation_directory is the directory
where you installed the Storage Manager 8.3 Utility.

2. Type:
SMdevices

3. Press Enter. The software displays device identification information. For
example, you might see the following information:

\\.\PHYSICALDRIVEx [Storage Subsystem Finance, Logical Drive DEBIT, LUN xx,
WWN <worldwide_name>]

where:

» xis the Disk number that displays in Disk Administrator

* Finance is the name of the storage subsystem

» DEBIT is the name of the logical drive

» xxis the LUN associated with the logical drive

* worldwide_name is the worldwide name for the logical drive

Using the SMflashcopyassist utility

Note: This utility requires that you enable the FlashCopy feature.

You can use SMflashcopyassist utility to perform the following tasks:
* Flush cached data for a logical drive.

* Resolve duplicate logical drive signatures between the base logical drives and
the FlashCopy logical drives.

To flush cached data in a logical drive, perform the following steps:

1. From a DOS or command prompt, change to the
installation_directonA\IBM_FAStT\Util where installation_directory is the directory
where you installed the Storage Manager 8.3 Utility.

2. Type the following command:

smflashcopyassist -f logical drive letter: where logical drive_letter is the
operating-system drive letter that was assigned to the disk partition created on
the logical drive

3. Press Enter.

After you create a FlashCopy logical drive and map it to the same host as the base
logical drive, (for Windows NT only) to resolve duplicate logical drive signatures:

1. Type:
smflashcopyassist -r
2. Press Enter.

Stopping and restarting the host-agent software

You must stop and restart the host-agent software if you add additional storage
subsystems to the management domain of the host-agent software. When you
restart the service, the host-agent software discovers the new storage subsystems
and adds them to the management domain.

Note: If none of the access logical drives are detected after a restart, the
host-agent software automatically stops running. Make sure that there is a
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Windows NT

Windows 2000

good fibre channel connection from the host to the Storage Area Network
that the storage subsystem is connected to; then, restart the host or cluster
node so that new host-agent-managed storage subsystems can be
discovered.

To stop and restart the host-agent software, perform the following steps:
1. Click Start » Settings » Control Panel. The Control Panel window opens.
2. Double-click Services. The Services window opens.

3. Click IBM FAStT Storage Manager 8 Agent; then, click Stop. The Confirmation
window opens.

4. Click Yes.
5. Click Start. The Storage Agent Manager starts.
6. Close the Services window.

To stop and restart the host-agent software, perform the following steps:

1. Click Start » Programs » Administrative Tools » Services. The Services
window opens.

2. Right-click IBM FAStT Storage Manager 8 Agent.

3. Click Restart. The IBM FAStT Storage Manager 8 Agent stops and then starts
again.
4. Close the Services window.

Uninstalling storage-management software components

Use the following procedure to uninstall one or more of the components of Storage
Manager 8.3. If you are uninstalling components released with an earlier version of
the storage-management software, use the procedure that came with the version of
the storage-management software that you are currently running.

Important: Do not uninstall the Redundant Disk Array Controller unless instructed
by an IBM technical support representative. The host-agent package requires
RDAC to function properly. If you uninstall RDAC in a coexistence environment, you
will lose Fibre Channel I/O path failover support for both the version 7.xx and
version 8.xx of Storage Manager.

1. Click Start » Settings » Control Panel. The Control Panel window opens.
Select Add/Remove programs. The Add/Remove Programs Properties window
opens.

Note: Uninstall the Storage Manager components in the following order:
a. Storage Manager 8.3 Agent
b. Storage Manager 8.3 Utility
c. Storage Manager 8.3 Redundant Disk Array Controller
d. Storage Manager 8.3 Client

2. Select the component you want to uninstall from the list of programs (for
example, IBM FAStT Storage Manager 8 Client).

3. Click Add/Remove. The Confirm File Deletion window opens.
4. Click Yes to start the uninstallation process.
5. When the uninstallation is complete, click OK.
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Chapter 7. Operating system support

This chapter contains information related to operating the storage-management
software in a Windows NT or Windows 2000 environment.

Windows NT and Windows 2000 limitations

Important: Always check for a readme file. A readme file might contain important
information that was not available when this Installation and Support Guide was
prepared.

explains limitations that apply when you use the IBM FASLT Storage
Manager Version 8.3 with Windows NT and Windows 2000.

Table 18. Windows NT and Windows 2000 limitations

Limitation Workaround

If you click a vertical scroll arrow (either | This is a known defect in the Java Runtime

up or down) causes the scroll box to Environment. Click the scroll box and slide it until
move all the way to the opposite end of you reach the position that you want in the Help

the scroll bar. window.

Data or configuration loss might occur Contact an IBM technical support representative

during a logical drive migration (removing |for assistance in performing this procedure.
configured physical drives from one
storage subsystem and inserting them
into another storage subsystem).

Array migration is not supported because |Contact an IBM technical support representative.
it could cause loss of configuration and
data. Array migration consists of removing
a set of drives configured with arrays from
one storage subsystem and inserting
them into another storage subsystem.

If you manage storage subsystems None.
through the host-agent software and use
the storage management software to
download controller firmware, the
download process can take up to 10
minutes to complete.

When you configure a new storage None.
subsystem with a single controller, you
must place the controller in slot A. The
controller firmware cannot recognize or
communicate with a single controller until
slot A is populated. This restriction does
not apply to storage subsystems that
were originally configured with two
controllers.

The following loop configuration is not None.
supported: IBM Fibre Channel Hub
(machine type 3523) in conjunction with
the IBM Fibre Channel Switch (machine
types 2109-S16 and 2109-S8) or the IBM
Fibre Channel Switch (machine types
3534-F08 and 2109-F16).
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Table 18. Windows NT and Windows 2000 limitations (continued)

Limitation Workaround

A controller failover occurs in an Immediately after you replace the controller, click
active/active controller pair, and Storage subsystem - Redistribute Arrays in
ownership of arrays transfers from the the Subsystem Management window to

failed preferred owner to the other redistribute arrays back to their preferred
controller of the repair. The failed controller owners. For more information, refer to

controller is replaced and brought online. |the online help.
The array ownership is not automatically
transferred back to the preferred controller
owner.

After adding a host device to the A single instance of the host-agent software can
management domain of more than five communicate with no more than five clients.
clients, the host-agent managed storage
subsystems attached to that host become
unresponsive.

When you connect an FAStT EXP700 None.
Storage Expansion Unit to a FAStT200,
you must set the drive speed to 1 GB per
second.
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Table 18. Windows NT and Windows 2000 limitations (continued)

Limitation

Workaround

After you install the host-agent software,
the error message:

Service Error 100

is displayed on the host.

The cause includes:

The host-agent software does not find any
controllers with firmware version 04.00.02.00
or later. Upgrade the firmware to the latest FW
level from the IBM support Web site. For more
information, see the section that follows on
fDirect-management method work around’}

The access logical drive has been removed
from NVSRAM or the storage partition defined
for the host. Perform one of the following
tasks:

— Manage the storage subsystem by using
the direct-management method. See the
section that follows onDirect-management]
|[method work around’}

— Define the access logical drive for the host
and restart SMagent. See the ['SMAgent
work around for defining additional Access|
LUN mapping” on page 84|

The NVSRAM on the controllers in a storage
subsystem that you want to manage contains
an access logical drive LUN that is in use by
another logical drive, or is not supported by
the operating system or installed patches. For
example, the access logical drive is configured
at LUN 31, and the operating system and
service packs support only eight LUNSs.
Perform one of the following tasks:

— Manage the storage subsystem by using
the direct-management method. See the
section that follows on[‘Direct-management|
[method work around’]

— Change the LUN mapping for the host
access logical drive to a LUN that is not in
use and is supported by the operating
system either from a different computer that
has management access to the storage
subsystem, or establish a direct
management connection to the storage
subsystem from the current host. For more
information, see the ['SMAgent work around
[for changing existing Access LUN mapping’

|9n page 84_4

Direct-management method work around

Use these instructions for the direct-management method work around:
1. Connect the two controller Ethernet ports to the network.

2. Follow the direct-management setup instructions in|Chapter 2, “Preparing for|
[installation”, on page 21|to manage the subsystem directly.

3. Open the Storage Manager 8 Enterprise Management window. Click Edit > Add

device.

4. Enter the IP address for the first controller and click Add.
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5. Repeat to add the IP address of the additional controllers.
6. Click Close.

7. Right-click the newly added storage subsystem and select Manage Device. The
Subsystem Management window for the storage subsystem opens. Proceed
with the storage subsystem management tasks.

SMAgent work around for defining additional Access LUN mapping

Perform the following steps to define additional Access LUN mapping for Storage
Manager 8.3 Agent:

1. Go to a different computer that has management access to the storage
subsystem, or establish a direct management connection to the storage
subsystem from the current host.

2. Start the IBM FAStT Storage Manager 8.3 Client and open the Subsystem
Management window for the storage subsystem.

Click the Mappings View tab.

Right-click the Default Group and select Define Additional mappings.
Select Access.

From the LUN drop-down menu, select Logical Unit Number (LUN) 31.

Click Add to define the access LUN.

Click Close. In the Define Mapping pane, a LUN with the Access name is
displayed.

9. Close the window and restart the host. When the host restarts, the SMagent
service starts.

© N O~

SMAgent work around for changing existing Access LUN mapping
Perform the following steps to change existing Access LUN mapping:
1. Go to a different computer that has management access to the storage

subsystem, or establish a direct management connection to the storage
subsystem from the current host.

2. Start the IBM FAStT Storage Manager 8.3 Client and open the Subsystem
Management window for the storage subsystem.

3. Click the Mappings View tab.

4. From the topology pane, select the Default Group or the corresponding host
partition.

5. Right-click Access and select Change Mapping. A Change Mapping window
opens.

6. From the LUN drop-down menu, select the LUN that your operating system
supports. If it is not available, you must remove one of the existing storage
partitioning mappings.

7. Click OK.

8. Close the window and restart the host. When the host restarts, the SMagent
service starts.

Upgrading from Windows NT 4.0 to Windows 2000

If you have an existing storage subsystem running Windows NT 4.0, you can
upgrade to Windows 2000 if the following conditions apply:

* Your storage subsystem is not the startup (boot) device.
* Your controllers are running firmware versions 04.00.00.00 or later.
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Attention: To avoid possible data loss, you must uninstall any previous versions of
the storage-management software (refer to [‘Uninstalling storage-management|
isoftware components” on page 80) before upgrading your operating system. All
storage-management configuration information is deleted during the uninstallation
process. A complete reinstallation of the storage-management software is required.

To upgrade from Windows NT 4.0 to Windows 2000, perform the following steps:

1. Verify that the storage subsystem contains no system-dependent files or
directories, such as paging files.

2. Uninstall Storage Manager. Refer to [‘Uninstalling storage-management software]
[components” on page 80}

3. Use the instructions from Microsoft to upgrade to Windows 2000.

4. Reinstall Storage Manager. Either refer to the instructions in [‘Installing Storage|

|Manager 8.3 Client” on page 40| or to the procedure that came with the version
of the storage-management software you are currently running.
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Appendix. Storage subsystem and controller information

record

provides a data sheet for recording storage subsystem names,
management types, hardware Ethernet addresses, and IP addresses. Make a copy
of this table and complete the information for your storage subsystems and
controllers. Use the information to set up the BOOTP table for the network server
and the host or Domain Name System (DNS) table. The information is also helpful
if you add storage subsystems after initial installation. The column headings show a
page reference for detailed instructions about how to obtain the information. For a
sample information record, refer to[Table 15 on page 22

Table 19. Storage subsystem information record and controller information record

Storage |Management
subsystem method

name (page (page [5)

Controllers-Ethernet and IP
addresses, and host name (pages

[23 and|[25)

Host-IP address and
host name (page
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Notices

This publication was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may be
used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give you any
license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing

IBM Corporation

North Castle Drive

Armonk, NY 10504-1785

U.S.A.

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS
PUBLICATION “AS IS” WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS
OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A
PARTICULAR PURPOSE. Some jurisdictions do not allow disclaimer of express or
implied warranties in certain transactions, therefore, this statement may not apply to
you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements and/or
changes in the product(s) and/or the program(s) described in this publication at any
time without notice.

Any references in this publication to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those
Web sites. The materials at those Web sites are not part of the materials for this
IBM product, and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it believes
appropriate without incurring any obligation to you.

Trademarks

The following terms are trademarks of International Business Machines Corporation
in the United States, other countries, or both:

Active PCI Predictive Failure
Analysis

e-business logo Redbooks

FlashCopy ServeRAID

IBM ServerProven
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IntelliStation TotalStorage
Netfinity xSeries

Lotus, Lotus Notes, and Domino are trademarks of Lotus Development Corporation
and/or IBM Corporation in the United States, other countries, or both.

Intel, Celeron, MMX, LANDesk, Pentium, Pentium Il Xeon, Pentium Ill Xeon, and
Xeon are trademarks of Intel Corporation in the United States, other countries, or
both.

Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation in
the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Java and all Java-based trademarks and logos are trademarks or registered
trademarks of Sun Microsystems, Inc. in the United States, other countries, or both.

Other company, product, or service names may be the trademarks or service marks
of others.

IBM agreement for licensed internal code

You accept the terms of this Agreement’ by your initial use of a machine that
contains IBM Licensed Internal Code (called “Code”). These terms apply to Code
used by certain Machines IBM or your reseller specifies (called “Specific
Machines”). International Business Machines Corporation or one of its subsidiaries
(“IBM”) owns copyrights in Code or has the right to license Code. IBM or a third
party owns all copies of Code, including all copies made from them.

If you are the rightful possessor of a Specific Machine, IBM grants you a license to
use the Code (or any replacement IBM provides) on, or in conjunction with, only the
Specific Machine for which the Code is provided. IBM licenses the Code to only one
rightful possessor at a time.

Under each license, IBM authorizes you to do only the following:

1. execute the Code to enable the Specific Machine to function according to its
Official Published Specifications (called “Specifications”);

2. make a backup or archival copy of the Code (unless IBM makes one available
for your use), provided you reproduce the copyright notice and any other legend
of ownership on the copy. You may use the copy only to replace the original,
when necessary; and

3. execute and display the Code as necessary to maintain the Specific Machine.

You agree to acquire any replacement for, or additional copy of, Code directly from
IBM in accordance with IBM’s standard policies and practices. You also agree to
use that Code under these terms.

You may transfer possession of the Code to another party only with the transfer of
the Specific Machine. If you do so, you must 1) destroy all your copies of the Code

1. Form Z125-4144
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that were not provided by IBM, 2) either give the other party all your IBM-provided
copies of the Code or destroy them, and 3) notify the other party of these terms.
IBM licenses the other party when it accepts these terms. These terms apply to all
Code you acquire from any source.

Your license terminates when you no longer rightfully possess the Specific Machine.

Actions you must not take

You agree to use the Code only as authorized above. You must not do, for
example, any of the following:

1. Otherwise copy, display, transfer, adapt, modify, or distribute the Code
(electronically or otherwise), except as IBM may authorize in the Specific
Machine’s Specifications or in writing to you;

2. Reverse assemble, reverse compile, or otherwise translate the Code unless
expressly permitted by applicable law without the possibility of contractual
waiver;

3. Sublicense or assign the license for the Code; or
4. Lease the Code or any copy of it.

Important notes

Processor speeds indicate the internal clock speed of the microprocessor; other
factors also affect application performance.

CD-ROM drive speeds list the variable read rate. Actual speeds vary and are often
less than the maximum possible.

When referring to processor storage, real and virtual storage, or channel volume,
KB stands for approximately 1000 bytes, MB stands for approximately 1 000 000
bytes, and GB stands for approximately 1 000 000 000 bytes.

When referring to hard disk drive capacity or communications volume, MB stands
for 1 000 000 bytes, and GB stands for 1 000 000 000 bytes. Total user-accessible
capacity may vary depending on operating environments.

Maximum internal hard disk drive capacities assume the replacement of any
standard hard disk drives and population of all hard disk drive bays with the largest
currently supported drives available from IBM.

Maximum memory may require replacement of the standard memory with an
optional memory module.

IBM makes no representation or warranties regarding non-IBM products and
services that are ServerProven®, including but not limited to the implied warranties
of merchantability and fitness for a particular purpose. These products are offered
and warranted solely by third parties.

IBM makes no representations or warranties with respect to non-IBM products.
Support (if any) for the non-IBM products is provided by the third party, not IBM.

Some software may differ from its retail version (if available), and may not include
user manuals or all program functionality.
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Glossary

This glossary provides definitions for the
terminology used for the IBM TotalStorage FASHT.
This glossary also provides definitions for the
terminology used for the IBM TotalStorage FAStT
Storage Manager.

This glossary defines technical terms and
abbreviations used in this document. If you do not
find the term you are looking for, see the IBM
Glossary of Computing Terms located at
www.ibm.com/networking/nsg/nsgmain.htm

This glossary also includes terms and definitions
from:

» Information Technology Vocabulary by
Subcommittee 1, Joint Technical Committee 1,
of the International Organization for
Standardization and the International
Electrotechnical Commission (ISO/IEC
JTC1/SCH1). Definitions are identified by the
symbol (l) after the definition; definitions taken
from draft international standards, committee
drafts, and working papers by ISO/IEC
JTC1/SC1 are identified by the symbol (T) after
the definition, indicating that final agreement
has not yet been reached among the
participating National Bodies of SC1.

» IBM Glossary of Computing Terms. New York:
McGraw-Hill, 1994.

The following cross-reference conventions are
used in this glossary:

See Refers you to (a) a term that is the
expanded form of an abbreviation or
acronym, or (b) a synonym or more
preferred term.

See also
Refers you to a related term.

Abstract Windowing Toolkit (AWT). A Java graphical
user interface (GUI).

accelerated graphics port (AGP). A bus specification
that gives low-cost 3D graphics cards faster access to
main memory on personal computers than the usual
PCI bus. AGP reduces the overall cost of creating
high-end graphics subsystems by using existing system
memory.

access volume. A special logical drive that allows the
host-agent to communicate with the controllers in the
storage subsystem.

© Copyright IBM Corp. 2000, 2003

adapter. A printed circuit assembly that transmits user
data (I/0Os) between the internal bus of the host system
and the external Fibre Channel link and vice versa. Also
called an I/0O adapter, host adapter, or FC adapter.

advanced technology (AT) bus architecture. A bus
standard for IBM compatibles. It extends the XT bus
architecture to 16 bits and also allows for bus
mastering, although only the first 16 MB of main
memory are available for direct access.

agent. A server program that receives virtual
connections from the network manager (the client
program) in an SNMP-TCP/IP network-managing
environment.

AGP. See accelerated graphics port.
AL_PA. See arbitrated loop physical address.

arbitrated loop. A shared 100 MBps Fibre Channel
transport structured as a loop and supporting up to 126
devices and one fabric attachment. A port must
successfully arbitrate before a circuit can be
established.

arbitrated loop physical address (AL_PA). One of
three existing Fibre Channel topologies, in which two to
126 ports are interconnected serially in a single loop
circuit. Access to the FC-AL is controlled by an
arbitration scheme. The FC-AL topology supports all
classes of service and guarantees in-order delivery of
FC frames when the originator and responder are on
the same FC-AL. The default topology for the disk array
is arbitrated loop. An arbitrated loop is sometimes
referred to as Stealth Mode.

auto volume transfer/auto disk transfer (AVT/ADT).
A function that provides automatic failover in case of
controller failure on a storage subsystem.

AVT/ADT. See auto volume transfer/auto disk transfer.
AWT. See Abstract Windowing Toolkit.

basic input/output system (BIOS). Code that controls
basic hardware operations, such as interactions with
diskette drives, hard disk drives, and the keyboard.

BIOS. See basic input/output system.
BOOTP. See bootstrap protocol.

bootstrap protocol (BOOTP). A Transmission Control
Protocol/Internet Protocol (TCP/IP) protocol that a
diskless workstation or network computer use to obtain
its IP address and other network information such as
server address and default gateway.
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bridge. A SAN device that provides physical and
transport conversion, such as Fibre Channel to SCSI
bridge.

bridge group. A bridge and the collection of devices
connected to it. Bridge Groups are discovered by the
SANavigator tool and displayed with a gray background
on the Physical and Data Path Maps.

broadcast. A method of sending an SNMP request for
information to all the devices on a subnet that use a
single special request. Because of its efficiency, the
SANavigator tool sets its default method of discovery to
broadcast. However, a network administrator might
disable this method on the network router.

cathode ray tube (CRT). An electrical device for
displaying images by exciting phosphor dots with a
scanned electron beam. CRTs are found in computer
VDUs and monitors, televisions, and oscilloscopes.

CDPD. See cellular digital packet data.

cellular digital packet data (CDPD). A wireless
standard that provides two-way, 19.2 kps packet data
transmission over existing cellular telephone channels.

CGA. See color graphics adapter.

client. A computer system or process that requests a
service of another computer system or process that is
typically referred to as a server. Multiple clients can
share access to a common server.

color graphics adapter (CGA). An early, now
obsolete, IBM video display standard for use on IBM
PCs. CGA displays 80 x 25 or 40 x 25 text in 16 colors,
640 x 200 pixel graphics in two colors or 320 x 200
pixel graphics in four colors.

command. Any selection on a dialog box or elsewhere
in the user interface that causes the SANavigator tool to
perform a task.

community strings. The name of a community
contained in each SNMP message. SNMP has no
standard mechanisms for verifying that a message was
sent by a member of the community, keeping the
contents of a message private, or for determining if a
message has been changed or replayed.

CRC. See cyclic redundancy check.
CRT. See cathode ray tube.

cyclic redundancy check (CRC). (1) 1) A redundancy
check in which the check key is generated by a cyclic
algorithm. (2) 2) An error detection technique performed
at both the sending and receiving stations.

dac. See disk array controller.

dar. See disk array router.

DASD. See Direct-Access Storage Device.

device type. Identifier used to place devices in the
physical map, such as the switch, hub, storage.

direct access storage device (DASD). I1BM
mainframe terminology for a data storage device by
which information can be accessed directly, instead of
by-passing sequentially through all storage areas. For
example, a disk drive is a DASD, in contrast with a tape
drive, which stores data as a linear sequence.

direct memory access (DMA). The transfer of data
between memory and an input/output (I/O) device
without processor intervention.

disk array controller (dac). A disk array controller
device that represents the two controllers of an array.
See also disk array controller.

disk array router (dar). A disk array router that
represents an entire array, including current and
deferred paths to all logical unit numbers (LUNs) (hdisks
on AlX). See also disk array controller.

DMA. See direct memory access.

domain. The most significant byte in the N_Port
Identifier for the FC device. It is not used in the
FC-SCSI hardware path ID. It is required to be the
same for all SCSI targets logically connected to an FC
adapter.

DRAM. See dynamic random access memory.

dynamic random access memory (DRAM). A
storage in which the cells require repetitive application
of control signals to retain stored data.

E_Port. An expansion port that connects the switches
for two fabrics (also used for McData ES-1000 B ports).

ECC. See error correction coding.

EEPROM. See Electrically Erasable Programmable
Read-Only Memory.

EGA. See enhanced graphics adapter.

electrically eErasable programmable read-only
memory (EEPROM). A type of non-volatile storage
device that can be erased with an electrical signal.
Writing to EEPROM takes much longer than reading. It
also can only be reprogrammed a limited number of
times before it wears out. Therefore, it is appropriate for
storing small amounts of data that are changed
infrequently.

electrostatic discharge (ESD). The flow of current
that results when objects that have a static charge
come into close enough proximity to discharge.

enhanced graphics adapter (EGA). An IBM video
display standard that provides text and graphics with a

94 |BM TotalStorage FASIT Storage Manager Version 8.3: Installation and Support Guide for Microsoft Windows NT and

Windows 2000



resolution of 640 x 350 pixels of 16 colors. It emulates
the Color/Graphics Adapter (CGA) and the Monochrome
Display Adapter (MDA) and was superseded by the
Video Graphics Display (VGA).

enhanced small disk interface (ESDI). A hard disk
controller standard that allows disks to communicate
with computers at high speeds. ESDI drives typically
transfer data at about 10 megabits per second, although
they are capable of doubling that speed.

error correction coding (ECC). A method for
encoding data so that transmission errors can be
detected and corrected by examination of the data on
the receiving end. Most ECCs are characterized by the
maximum number of errors they can detect and correct.

error detection coding. A method for encoding data
so that errors that occur during storage or transmission
can be detected. Most error detection codes are
characterized by the maximum number of errors they
can detect. The simplest form of error detection is by
using a single added parity bit or a cyclic redundancy
check. Adding multiple parity bits can detect not only
that an error has occurred, but also which bits have
been inverted, thereby indicating which bits should be
re-inverted to restore the original data.

ESD. See electrostatic discharge.
ESDI. See enhanced small disk interface.

eXtended graphics array (XGA). An IBM advanced
standard for graphics controller and display mode
design introduced in 1990. XGA, used mostly on
workstation-level systems, supports a resolution of 1024
X 768 pixels with a palette of 256 colors, or 640 x 480
with high color (16 bits per pixel). XGA-2 added 1024 x
768 support for high color and higher refresh rates,
improved performance, and supports 1360 x 1024 in 16
colors.

F_Port. A port that supports an N_Port on a Fibre
Channel switch.

fabric group. A collection of interconnected SAN
devices discovered by the SANavigator tool and
displayed with a blue background on the Physical and
Data Path Maps.

Fibre Channel. A bi-directional, full-duplex,
point-to-point, serial data channel structured for high
performance capability. Physically, Fibre Channel
interconnects devices, such as host systems and
servers, FC hubs and disk arrays, through ports, called
N_Ports, in one of three topologies: a point-to-point link,
an arbitrated loop, or a cross point switched network,
which is called a fabric. FC can interconnect two
devices in a point-to-point topology, from two to 126
devices in an arbitrated loop. FC is a generalized
transport mechanism that can transport any existing
protocol, such as SCSI, in FC frames.

Fibre Channel Protocol for SCSI (FCP). A high-level
Fibre Channel mapping layer (FC-4) that uses
lower-level Fibre Channel (FC-PH) services to transmit
SCSI command, data, and status information between a
SCSI initiator and a SCSI target across the FC link by
using FC frame and sequence formats.

field replaceable unit (FRU). An assembly that is
replaced in its entirety when any one of its components
fails. In some cases, a FRU might contain other field
replaceable units.

FRU. See field replaceable unit.

general purpose interface bus (GPIB). An 8-bit
parallel bus developed for the exchange of information
between computers and industrial automation
equipment.

GPIB. See general purpose interface bus..

graphical user interface (GUI). A type of computer
interface that presents a visual metaphor of a real-world
scene, often of a desktop, by combining high-resolution
graphics, pointing devices, menu bars and other menus,
overlapping windows, icons, and the object-action
relationship.

GUI. See graphical user interface.
HBA. See host bus adapter.

hdisk. An AIX term representing a logical unit number
(LUN) on an array.

host. A system that is directly attached to the storage
subsystem through a fibre-channel I/O path. This
system is used to serve data (typically in the form of
files) from the storage subsystem. A system can be both
a storage management station and a host
simultaneously.

host bus adapter (HBA). An interface between the
Fibre Channel network and a workstation or server.

host computer. See host.

host group. The collection of HBAs and NASs in a
fabric discovered by the SANavigator tool and displayed
with a yellow background on the Physical and Data
Path Maps.

hub. In a network, a point at which circuits are either
connected or switched. For example, in a star network,
the hub is the central node; in a star/ring network, it is
the location of wiring concentrators.

IC. See integrated circuit.
IDE. See integrated drive electronics.

In-band. Transmission of management protocol over
the Fibre Channel transport.
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Industry Standard Architecture (ISA). A bus
standard for IBM compatibles that allows components to
be added as cards plugged into standard expansion
slots. ISA was originally introduced in the IBM PC/XT
with an 8-bit data path. It was later expanded to permit
a 16-bit data path when IBM introduced the PC/AT.

initial program load (IPL). The part of the boot
sequence during which a computer system copies the
operating system kernel into main memory and runs it.

integrated circuit (IC). Also known as a chip. A
microelectronic semiconductor device that consists of
many interconnected transistors and other components.
ICs are constructed on a small rectangle cut from a
silicon crystal or other semiconductor material. The
small size of these circuits allows high speed, low
power dissipation, and reduced manufacturing cost
compared with board-level integration.

integrated drive electronics (IDE). Also known as an
Advanced Technology Attachment Interface (ATA). A
disk drive interface based on the 16-bit IBM PC ISA in
which the controller electronics reside on the drive itself,
eliminating the need for a separate adapter card.

integrated services digital network (ISDN). A digital
end-to-end telecommunication network that supports
multiple services including, but not limited to, voice and
data. ISDNs are used in public and private network
architectures.

interrupt request (IRQ). A type of input found on
many processors that causes the processor to suspend
normal instruction execution temporarily and start
executing an interrupt handler routine. Some processors
have several interrupt request inputs that allow different
priority interrupts.

Internet Protocol address. The unique 32-bit address
that specifies the location of each device or workstation
on the Internet. For example, 9.67.97.103 is an IP
address.

IP address. See Internet Protocol address.
IPL. See initial program Load.

IRQ. See interrupt request.

ISA. See Industry Standard Architecture.

ISDN. See Integrated Services Digital Network.

isolated group. A collection of isolated devices not
connected to the SAN but discovered by the
SANavigator tool. The Isolated Group displays with a
gray background near the bottom of the Physical and
Data Path Maps.

Java Runtime Environment (JRE). A subset of the
Java Development Kit (JDK) for end users and
developers who want to redistribute the Java Runtime

Environment (JRE). The JRE consists of the Java virtual
machine, the Java Core Classes, and supporting files.

JRE. See Java Runtime Environment.

label. A discovered or user entered property value that
is displayed underneath each device in the Physical and
Data Path Maps.

LAN. See local area network.
LBA. See logical block addressing.

local area network (LAN). A computer network
located on a user’s premises within a limited geographic
area.

logical block addressing (LBA). A hard disk sector
addressing scheme in which the addressing conversion
is performed by the hard disk firmware. LBA is used on
all SCSI hard disks and on ATA-2 conforming IDE hard
disks.

logical unit number (LUN). An identifier used on a
small computer systems interface (SCSI) bus to
distinguish among up to eight devices (logical units) with
the same SCSI ID.

loop address. The unique ID of a node in Fibre
Channel loop topology sometimes referred to as a Loop
ID.

loop group. A collection of SAN devices that are
interconnected serially in a single loop circuit. Loop
Groups are discovered by the SANavigator tool and
displayed with a gray background on the Physical and
Data Path Maps.

loop port (FL_Port). An N-Port or F-Port that supports
arbitrated loop functions associated with an arbitrated
loop topology.

LUN. See logical unit number.
MAC.. See medium access control.

medium access control (MAC).. In LANSs, the
sublayer of the data link control layer that supports
medium-dependent functions and uses the services of
the physical layer to provide services to the logical link
control sublayer. The MAC sublayer includes the
method of determining when a device has access to the
transmission medium.

man pages. In UNIX-based operating systems, online
documentation for operating-system commands,
subroutines, system calls, file formats, special files,
stand-alone utilities, and miscellaneous facilities.
Invoked by the man command.

management information base (MIB). The
information that is on an agent. It is an abstraction of
configuration and status information.
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MCA. See micro channel architecture.
MIB. See management information base.

micro channel architecture (MCA). IBM’s proprietary
bus that is used in high-end PS/2 personal computers.
Micro Channel is designed for multiprocessing and
functions as either a 16-bit or 32-bit bus. It eliminates
potential conflicts that arise when installing new
peripheral devices.

MIDI. See musical instrument digital interface.

model. The model identification assigned to a device
by its manufacturer.

musical instrument digital interface (MIDI). A
protocol that allows a synthesizer to send signals to
another synthesizer or to a computer, or a computer to
a musical instrument, or a computer to another
computer.

NDIS. See network device interface specification.

network device interface specification (NDIS). An
application programming interface (API) definition that
allows DOS or OS/2 systems to support one or more
network adapters and protocol stacks. NDIS is a 16-bit,
Ring O (for the OS/2 operating system) API that defines
a specific way for writing drivers for layers 1 and 2 of
the OSI model. NDIS also handles the configuration and
binding of these network drivers to multiple protocol
stacks.

network management station (NMS). In the Simple
Network Management Protocol (SNMP), a station that
executes management application programs that
monitor and control network elements.

NMI. See non-maskable interrupt.
NMS. See network management station.

non-maskable interrupt (NMI). A hardware interrupt
that another service request cannot overrule (mask). An
NMI bypasses and takes priority over interrupt requests
generated by software, the keyboard, and other such
devices and is issued to the microprocessor only in
disastrous circumstances, such as severe memory
errors or impending power failures.

N_Port. A node port. A Fibre Channel defined
hardware entity that performs data communications over
the Fibre Channel link. It is identifiable by a unique
Worldwide Name. It can act as an originator or a
responder.

node. A physical device that allows for the
transmission of data within a network.

nonvolatile storage (NVS). A storage device whose
contents are not lost when power is cut off.

NVS. See nonvolatile storage.

NVSRAM. Nonvolatile storage random access
memory. See nonvolatile storage.

Object Data Manager (ODM). An AIX proprietary
storage mechanism for ASCII stanza files that are
edited as part of configuring a drive into the kernel.

ODM. See Object Data Manager.

out-of-band. Transmission of management protocols
outside of the Fibre Channel network, typically over
Ethernet.

PCI local bus. See peripheral component interconnect
local bus.

PDF. See portable document format.

peripheral component interconnect local bus (PCI
local bus). A standard that Intel Corporation
introduced for connecting peripherals. The PCI local bus
allows up to 10 PCl-compliant expansion cards to be
installed in a computer at a time. Technically, PCl is not
a bus but a bridge or mezzanine. It runs at 20 - 33 MHz
and carries 32 bits at a time over a 124-pin connector
or 64 bits over a 188-pin connector. A PCI controller
card must be installed in one of the PCl-compliant slots.
The PCI local bus is processor independent and
includes buffers to decouple the CPU from relatively
slow peripherals, allowing them to operate
asynchronously. It also allows for multiplexing, a
technique that permits more than one electrical signal to
be present on the PCI local bus at a time.

performance events. Events related to thresholds set
on SAN performance.

polling delay. The time in seconds between
successive discovery processes during which Discovery
is inactive.

port. The hardware entity that connects a device to a
Fibre Channel topology. A device can contain one or
more ports.

portable document format (PDF). A standard
specified by Adobe Systems, Incorporated, for the
electronic distribution of documents. PDF files are
compact; can be distributed globally by e-mail, the Web,
intranets, or CD-ROM; and can be viewed with the
Acrobat Reader, which is software from Adobe Systems
that can be downloaded at no cost from the Adobe
Systems home page.

private loop. A freestanding Arbitrated Loop with no
fabric attachment.

program temporary fix (PTF). A temporary solution or
bypass of a problem diagnosed by IBM in a current
unaltered release of the program.

PTF. See program temporary fix.
RAM. See random-access memory.
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random-access memory (RAM). A temporary storage
location in which the central processing unit (CPU)
stores and executes its processes.

RDAC. See redundant disk array controller.

read-only memory (ROM). Memory in which the user
cannot changed stored data except under special
conditions.

red, green, blue (RGB). (1) Color coding in which the
brightness of the additive primary colors of light, red,
green, and blue are specified as three distinct values of
white light. (2) Pertaining to a color display that accepts
signals that represent red, green, and blue.

redundant disk array controller (RDAC). (1) In
hardware, a redundant set of controllers (either
active/passive or active/active). (2) In software, a layer
that manages the input/output (I/O) through the active
controller during normal operation and transparently
reroutes 1/Os to the other controller in the redundant set
if a controller or 1/0 path fails.

RGB. See red, green, blue.
ROM. See read-only memory.

router. A computer that determines the path of
network traffic flow. The path selection is made from
several paths based on information obtained from
specific protocols, algorithms that attempt to identify the
shortest or best path, and other criteria such as metrics
or protocol-specific destination addresses.

SAN. See storage area network.

scope. Defines a group of controllers by their IP
addresses. You must create and configure a scope so
that dynamic IP addresses can be assigned to
controllers on your network..

SCSIl. See small computer system interface.

segmented loop ports (SL_Ports). SL_Ports allow
you to divide a Fibre Channel Private Loop into multiple
segments. Each segment can pass frames around as
an independent loop and can connect through the fabric
to other segments of the same loop.

serial storage architecture (SSA). An interface
specification from IBM in which devices are arranged in
a ring topology. SSA, which is compatible with SCSI
devices, allows full-duplex packet multiplexed serial data
transfers at rates of 20Mb/sec in each direction.

server. A functional hardware and software unit that
delivers shared resources to workstation client units on
a computer network.

server/device events. Events that occur on the server
or a designated device that meet criteria that the user
sets.

Simple Network Management Protocol (SNMP). In
the Internet suite of protocols, a network management
protocol that is used to monitor routers and attached
networks. SNMP is an application layer protocol.
Information on devices managed is defined and stored
in the application’s Management Information Base
(MIB).

SL_Port. See segmented loop ports.

small computer system interface (SCSI). A standard
hardware interface that enables a variety of peripheral
devices to communicate with one another.

SNMP. See Simple Network Management Protocol.

SNMPv1. The original standard for SNMP is now
referred to as SNMPv1, as opposed to SNMPv2, a
revision of SNMP. See also Simple Network
Management Protocol.

SNMP time-out. The maximum amount of time the
SANavigator tool will wait for a device to respond to a
request. The specified time applies to one retry only.

SNMP trap events. SNMP is based on a
manager/agent model. SNMP includes a limited set of
management commands and responses. The
management system issues messages that tell an agent
to retrieve various object variables. The managed agent
sends a Response message to the management
system. That message is an event notification, called a
trap, that identifies conditions, such as thresholds, that
exceed a predetermined value.

SRAM. See static random access memory.
SSA. See serial storage architecture.

static random access memory (SRAM). Random
access memory based on the logic circuit known as
flip-flop. It is called static because it retains a value as
long as power is supplied, unlike dynamic random
access memory (DRAM), which must be regularly
refreshed. It is however, still volatile, meaning that it can
lose its contents when the power is switched off.

storage area network (SAN). A network that links
servers or workstations to disk arrays, tape backup
subsystems, and other devices, typically over Fibre
Channel.

storage management station. A system that is used
to manage the storage subsystem. A storage
management station does not need to be attached to
the storage subsystem through the fibre-channel I/O
path.

subnet. An interconnected but independent segment
of a network that is identified by its Internet Protocol (IP)
address.
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super video graphics array (SVGA). A video display
standard that Video Electronics Standards Association
(VESA) created to provide high resolution color display
on IBM PC compatible personal computers. The
resolution is 800 x 600 4-bit pixels. Each pixel can
therefore be one of 16 colors.

SVGA. See super video graphics array.

sweep method. A method of sending SNMP requests
for information to all the devices on a subnet by sending
the request to every device on the network. Sweeping
an entire network can take a half an hour or more. If
broadcast is disabled, the recommended method is to
enter the individual IP addresses of the SAN devices
into the SANavigator tool. This method produces good
results without unnecessarily using time to wait for
responses from every IP address in the subnet,
especially for IP addresses where no devices are
present. There might, however, be times when a full
subnet sweep will produce valuable diagnostic
information about the network or a device’s
configuration.

switch. A Fibre Channel device that provides full
bandwidth per port and high-speed routing of data by
using link-level addressing.

switch group. A switch and the collection of devices
connected to it that are not in other groups. Switch
Groups are discovered by the SANavigator tool and
displayed with a gray background on the Physical and
Data Path Maps.

system name. Device name assigned by the vendor’s
third-party software.

TCP. See Transmission Control Protocol.

TCP/IP. See Transmission Control Protocol/Internet
Protocol.

terminate and stay resident program (TSR
program). A program that installs part of itself as an
extension of DOS when it is executed.

TFT. See thin-film transistor.

thin-film transistor (TFT). A transistor created by
using thin film methodology.

topology. The physical or logical arrangement of
devices on a network. The three Fibre Channel
topologies are fabric, arbitrated loop, and point-to-point.
The default topology for the disk array is arbitrated loop.

TL_Ports. See translated loop port.

translated loop ports (TL_Ports). Each TL_Port
connects to a private loop and allows connectivity
between the private loop devices and off loop devices
(devices not connected to that particular TL_Port).

Transmission Control Protocol (TCP). A
communication protocol used in the Internet and in any
network that follows the Internet Engineering Task Force
(IETF) standards for internetwork protocol. TCP
provides a reliable host-to-host protocol between hosts
in packed-switched communication networks and in
interconnected systems of such networks. It uses the
Internet Protocol (IP) as the underlying protocol.

Transmission Control Protocol/Internet Protocol
(TCP/IP). A set of communication protocols that
provide peer-to-peer connectivity functions for both local
and wide-area networks.

trap. In the Simple Network Management Protocol
(SNMP), a message sent by a managed node (agent
function) to a management station to report an
exception condition.

trap recipient. Receiver of a forwarded SNMP trap.
Specifically, a trap receiver is defined by an IP address
and port to which traps are sent. Presumably, the actual
recipient is a software application running at the IP
address and listening to the port.

TSR program. See terminate and stay resident
program.

user action events. Actions that the user takes, such
as changes in the SAN, changed settings, and so on.
Each such action is considered a User Action Event.

vendor. Property value that the SANavigator tool uses
to launch third-party software. Vendor property might be
discovered but will always remain editable.

VGA. See video graphics adapter.

video graphics adapter (VGA). A computer adapter
that provides high-resolution graphics and a total of 256
colors.

video random access memory (VRAM). A special
type of dynamic RAM (DRAM) used in high-speed video
applications, designed for storing the image to be
displayed on a computer’'s monitor.

VRAM. See video random access memory.
WORM. See write-once read-many.

Worldwide Name (WWN). A registered, unique 64-bit
identifier assigned to nodes and ports.

write-once read-many (WORM). Any type of storage
medium to which data can be written only a single time,
but can be read from any number of times. After the
data is recorded, it cannot be altered. Typically the
storage medium is an optical disk whose surface is
permanently etched by using a laser in order to record
information. WORM media are high-capacity storage
devices and have a significantly longer shelf life than
magnetic media.
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WWN. See worldwide name.
XGA. See eXtended graphics array.

zoning. A function that allows segmentation of nodes
by address, name, or physical port and is provided by
fabric switches or hubs.
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