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Chapitre 1. Installation et démarrage de Software Delivery
Assistant

Cette section contient les instructions d’installation et de démarrage de Software
Delivery Assistant (SDA) version 1.3.

Configuration requise
SDA version 1.3 nécessite un des systèmes d’exploitation Microsoft suivants :
v Windows 95
v Windows 98
v Windows NT 4.0
v Windows 2000
v Windows Millennium Edition
v Windows XP

Installation de Software Delivery Assistant
Pour effectuer une installation sous surveillance de Software Delivery Assistant sur
un serveur, une console ou un poste client doté de Windows NT ou Windows 98,
procédez comme suit :
1. Pour télécharger le programme, allez sur la page Web IBM suivante et

recherchez SDA :
http://www.ibm.com/pc/.

2. A partir du menu Démarrer de Windows, cliquez sur Exécuter.
3. Dans la zone Ouvrir, tapez

ID_unité:\répertoire\sdav13.exe
où ID_unité et répertoire correspondent à l’unité et au répertoire où se trouve le
programme d’installation.

4. Cliquez sur OK pour lancer le programme d’installation.
5. Dans la fenêtre de bienvenue, cliquez sur Suivant pour continuer l’installation.
6. Cliquez sur Suivant.

Le programme d’installation de Software Delivery Assistant installe les fichiers
programme.

7. La fenêtre de fin d’installation s’affiche lorsque l’installation est terminée.
Cliquez sur Terminer pour confirmer.

Démarrage de Software Delivery Assistant
Vous pouvez lancer SDA en procédant de l’une des manières suivantes :
v Cliquez sur Démarrer → Programmes → IBM Software Delivery Assistant v1.3.
v Cliquez deux fois que le fichier SDAassist.exe, qui se trouve dans le répertoire

C:\Program Files\SDAv13\SDAssist.exe.
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Désinstallation de Software Delivery Assistant
Pour supprimer Software Delivery Assistant de votre système, procédez comme
suit :
1. Cliquez sur Démarrer → Paramètres → Panneau de configuration.
2. Cliquez deux fois sur Ajout/Suppression de programmes.
3. Sélectionnez le nom de programme IBM Software Delivery Assistant V1.3

dans la liste Installation/Désinstallation.
4. Cliquez sur Supprimer.
5. Dans la fenêtre de confirmation de suppression, cliquez sur Oui.
6. Cliquez sur OK.
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Chapitre 2. Utilisation de Software Delivery Assistant

IBM Software Delivery Assistant (SDA) facilite le déploiement d’un ensemble
d’applications unique que vous pouvez utiliser dans toute une entreprise. SDA
peut créer un ensemble unique d’applications communes que vous pouvez
déployer auprès de tous les utilisateurs, sans tenir compte de leur système
d’exploitation, de leur langue, de leur configuration matérielle ou de leur groupe
métier (marketing, développement, ou finance par exemple.)

Avec SDA, vous rassemblez tous les ensembles d’applications uniques, créés en
fonction des groupes métier de votre entreprise (tels que marketing ou fabrication),
dans une seule image SDA d’installation. Vous pouvez ensuite combiner cette
image SDA avec une image de base contenant un système d’exploitation, des
pilotes de périphériques et des applications de base, telles qu’un antivirus, afin de
former une superimage commune qui pourra être déployée auprès de tous les
utilisateurs de votre entreprise, quelle que soit leur groupe métier.

SDA se compose des deux parties suivantes :
v le module d’administration SDA,
v le module d’installation SDA.

En tant qu’administrateur, vous utilisez le module d’administration SDA pour créer
une image SDA. Les utilisateurs, quant à eux, utilisentle module d’installation SDA
pour installer leurs ensembles d’applications sur leurs ordinateurs à partir de
l’image SDA que vous avez créée. Vous pouvez également configurer le module
d’installation SDA pour qu’il s’exécute automatiquement sur les ordinateurs des
utilisateurs finaux.

Présentation générale
Les sections suivantes contiennent une présentation générale du processus IBM
SDA.

Collecte d’informations
Avant de commencer, rassemblez les informations suivantes :
v Les systèmes d’exploitation sur lesquels vous déployez des applications. Le

module d’administration SDA permet de créer des images SDA prenant en
charge Microsoft Windows 95, Windows 98, Windows NT 4.0, Windows 2000,
Windows Millennium Edition et Windows XP.

v Les langues dans lesquelles vous déployez des applications.
v Les groupes pour lesquels différentes séries d’applications sont nécessaires. Les

groupes peuvent par exemple inclure les responsables de votre entreprise, le
département Marketing ou le service de la paye.

v Les zones de profil utilisateur que vous voulez définir. Vous devez au moins
définir une zone de profil utilisateur Groupe, afin que l’utilisateur puisse
indiquer quelle série d’applications doit être installée.

© Copyright IBM Corp. 2002 3



Création d’un espace de travail
Un espace de travail (.SSW) contient toutes les informations requises pour créer
une image SDA. Vous pouvez créer un nouvel espace de travail, ou bien vous
pouvez importer un espace de travail existant à partir d’une image SDA
précédemment construite afin de créer un nouvel espace de travail. L’assistant de
création d’image SDA vous guide tout au long de la procédure de définition d’un
nouvel espace de travail. L’interface de l’espace de travail s’apparente à celle de
l’Explorateur Windows de Microsoft. Vous pouvez éditer cet espace de travail pour
y ajouter, copier, déplacer ou supprimer des langues, des groupes et des
applications.

Traduction du texte de l’image SDA
Vous pouvez traduire les noms des groupes et des zones de profil utilisateur dans
différentes langues. Le module d’administration SDA extrait le texte de l’espace de
travail dans des fichiers que vous pouvez faire traduire par différents traducteurs.
Lorsque vous recevez les traductions, il suffit de les réintégrer dans votre espace
de travail.

Les noms des zones de profil utilisateur et des groupes peuvent également être
présentés dans différentes langues.

Aperçu de l’image SDA
Pour vérifier que vous avez spécifié les informations correctes dans l’espace de
travail à partir duquel vous allez créer l’image SDA, vous pouvez demander un
aperçu de l’image SDA. L’aperçu de l’image n’installe pas réellement les
applications, mais simule leur installation en montrant quelles applications seront
installées pour un groupe métier donné.

Création de l’image SDA
Lorsque vous êtes certain d’avoir spécifié les informations correctes dans l’espace
de travail, créez l’image SDA. La création de l’image SDA consiste à copier sur
l’image SDA les programmes de toutes les applications devant être déployées vers
les ordinateurs des utilisateurs.

Téléchargement de l’image SDA sur les ordinateurs des
utilisateurs

Après avoir créé l’image SDA, téléchargez-la sur l’ordinateur de chaque utilisateur
(à l’aide d’un outil tel qu’IBM Remote Deployment Manager, PowerQuest Drive
Image ou Norton Ghost). Vous pouvez également copier l’image SDA sur un
CD-ROM pour la distribuer.

Les utilisateurs peuvent accéder à l’image SDA via le module d’installation SDA
afin d’installer leurs séries d’applications. Vous pouvez également configurer le
module d’installation SDA pour qu’il installe automatiquement les applications
requises.

Lancement de l’image SDA
L’utilisateur peut lancer le module d’installation SDA en exécutant le fichier
swselect.exe de l’image SDA après le redémarrage de l’ordinateur.
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Installation des logiciels sur les ordinateurs des utilisateurs
Lors de la première exécution du module d’installation SDA, le programme
demande à l’utilisateur de sélectionner un des groupes métier définis dans l’espace
de travail SDA. Une fois que l’utilisateur a sélectionné un groupe métier, le module
d’installation SDA installe les applications requises à partir du groupe Commun et
du groupe métier choisi par l’utilisateur.

Vous pouvez configurer l’image SDA pour effectuer une des tâches suivantes après
l’installation des applications requises :
v Laisser toutes les applications dans l’image SDA après l’installation des

applications requises.
v Supprimer l’image SDA pour libérer de l’espace sur le disque dur de l’utilisateur

(si l’image SDA se trouve sur le disque dur de l’utilisateur).
v Supprimer tous les programmes d’installation d’application de l’image SDA afin

de libérer de l’espace sur le disque dur et permettre à l’utilisateur d’installer des
applications supplémentaires à partir d’une autre image SDA située sur le
disque dur ou sur une unité réseau connectée.

v Autoriser l’utilisateur à sélectionner d’autres applications à installer à partir de
la même image SDA (applications en option pour le groupe Commun et le
groupe métier sélectionné par l’utilisateur dans l’espace de travail SDA).

Initiation
Après avoir compilé les informations concernant votre système et votre espace de
travail, vous pouvez créer (ou importer) l’espace de travail. Avant de commencer,
assurez-vous que vous disposez de toutes les informations requises concernant
votre espace de travail.

Pour masquer définitivement la fenêtre du module d’administration SDA, cochez
la case Do not show this window again (Ne plus afficher cette fenêtre) lorsque la
fenêtre s’affiche. Tant que vous n’aurez pas coché cette case, la fenêtre s’affichera à
chaque fois que vous lancerez le programme.

Présentation de l’espace de travail
Le module d’administration SDA crée l’espace de travail et l’affiche. L’interface de
l’espace de travail s’apparente à celle de l’Explorateur Windows de Microsoft. Le
panneau gauche de la fenêtre affiche la structure de l’espace de travail, avec
chaque groupe répertorié pour chaque langue. Chaque langue contient son propre
ensemble de zones de profil utilisateur que vous pouvez modifier. De plus, chaque
langue contient un groupe Commun, ainsi qu’un ou plusieurs autres groupes.
Enfin, chaque groupe peut contenir un ou plusieurs sous-groupes.

Le panneau droit de la fenêtre du module d’administration SDA affiche le contenu
de l’élément mis en surbrillance dans le panneau gauche.

Remarque : Vous devez enregistrer le fichier de l’espace de travail avant de quitter
le module d’administration SDA. Cliquez sur File → Save (Fichier →
Enregistrer) ou File → Save As (Fichier → Enregistrer sous) et
enregistrez le fichier comme n’importe quel autre fichier.

Affectation d’un nom à l’espace de travail
Affectez à l’espace de travail un nom descriptif dans la zone Workspace name
(Nom de l’espace de travail).
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Sélection des langues
Sélectionnez les langues que l’image SDA doit prendre en charge. Ces langues
doivent correspondre aux langues des systèmes d’exploitation que vous déployez.

Définition des groupes
Un groupe est un ensemble d’applications spécifiques destinées à un service, une
fonction ou une activité particulière de votre entreprise. (Par exemple, dans une
université, les groupes peuvent inclure les écoles de journalisme, l’odontologie et la
finance.) Répertoriez les groupes que l’image SDA doit prendre en charge. La liste
de groupes doit inclure le groupe Commun, qui contient les applications utilisées
par tous les groupes.

Définition des zones de profil utilisateur
Créez les zones de profil utilisateur que vous voulez que les utilisateurs
renseignent la première fois qu’ils installent l’image SDA. (Par exemple, une zone
de profil utilisateur peut être un ID employé ou un emplacement.)

Ouverture d’un espace de travail existant
Vous pouvez utiliser un espace de travail existant qui n’a pas encore servi à créer
une image SDA en cliquant sur File → Open (Fichier → Ouvrir) et en navigant
jusqu’à cet espace de travail. Vous pouvez ensuite renommer cet espace de travail
pour créer un nouvel espace et le modifier comme vous le souhaitez.

Importation d’un espace de travail à partir d’une image SDA
existante

Vous pouvez créer un nouvel espace de travail à partir d’une image SDA
existante ; pour ce faire, il vous suffit d’importer un espace de travail à partir de
l’image SDA existante. Vous pouvez ensuite modifier cet espace de travail pour
créer une nouvelle image SDA. Le module d’administration SDA utilisera les
fichiers d’installation de l’image SDA existante au lieu d’utiliser les emplacements
à partir desquels ces fichiers ont été initialement obtenus lors de la création de
l’image SDA existante.

Le module d’administration SDA importe le nouvel espace de travail en tant
qu’espace de travail actif. Vous pouvez modifier l’espace de travail pour ajouter
des applications aux groupes et pour ajouter, copier, déplacer et supprimer des
éléments de l’espace de travail. Les messages d’information et d’erreur relatifs au
processus d’importation s’affichent dans le panneau d’information.

Boutons de la barre d’outils
De gauche à droite, vous pouvez voir les boutons de barre d’outils suivants

New (Nouveau)
Cliquez sur ce bouton pour créer un nouvel espace de travail. Cette
opération revient à cliquer surFile → New (Fichier → Nouveau).

Open (Ouvrir)
Cliquez sur ce bouton pour ouvrir un espace de travail existant. Cette
opération revient à cliquer sur File → Open (Fichier → Ouvrir).

Save (Enregistrer)
Cliquez sur ce bouton pour enregistrer l’espace de travail actif. Cette
opération revient à cliquer sur File → Save (Fichier → Enregistrer) ou File →
Save As (Fichier → Enregistrer sous).
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Cut (Couper)
Cliquez sur ce bouton pour supprimer l’élément sélectionné de l’espace de
travail et le copier dans le presse-papiers. Cette opération revient à cliquer
sur Edit → Cut (Edition → Couper).

Copy (Copier)
Cliquez sur ce bouton pour copier l’élément sélectionné dans le
presse-papiers. Cette opération revient à cliquer sur Edit → Copy (Edition →
Copier).

Paste (Coller)
Cliquez sur ce bouton pour copier le contenu du presse-papiers dans
l’élément sélectionné. Cette opération revient à cliquer sur Edit → Paste
(Edition → Coller).

Information panel (Panneau d’information)
Cliquez sur ce bouton pour afficher ou masquer le panneau d’information,
qui contient les résultats des opérations de création, d’importation et de
traduction (extraction et intégration).

Help (Aide)
Cliquez sur ce bouton pour afficher l’aide relative au module
d’administration SDA.

Options de menu
Utilisez les options de menu suivantes pour manipuler les espaces de travail SDA.

File (Fichier)
Les options du menu File (Fichier) vous permettent de créer, ouvrir ou importer
des espaces de travail.

New (Nouveau)
Sélectionnez cette option pour créer un nouvel espace de travail. Cette
opération revient à cliquer sur le bouton New (Nouveau) de la barre
d’outils.

Open (Ouvrir)
Sélectionnez cette option pour ouvrir un espace de travail existant. Cette
opération revient à cliquer sur le bouton Open (Ouvrir) de la barre
d’outils.

Import (Importer)
Sélectionnez cette option pour importer un espace de travail à partir d’une
image SDA existante.

Edit (Edition)
Les options du menu Edition sont semblables aux options d’édition de la plupart
des applications Microsoft Windows.

Selected object (Objet sélectionné)
Sélectionnez cette option pour modifier le nom d’un espace de travail.

Delete (Supprimer)
Sélectionnez cette option pour supprimer la langue, le groupe ou
l’application sélectionné.
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Cut (Couper)
Sélectionnez cette option pour supprimer la langue, le groupe ou
l’application sélectionné et les copier dans le presse-papiers. Cette
opération revient à cliquer sur le bouton Cut (Couper) de la barre d’outils.

Copy (Copier)
Sélectionnez cette option pour copier l’élément sélectionné dans le
presse-papiers. Cette opération revient à cliquer sur le bouton Copy
(Copier) de la barre d’outils.

Paste (Coller)
Sélectionnez cette option pour copier le contenu du presse-papiers dans
l’élément sélectionné. Cette opération revient à cliquer sur le bouton Paste
(Coller) de la barre d’outils.

Find and update (Rechercher et mettre à jour)
Sélectionnez cette option pour propager une modification de propriété à
plusieurs applications. Par exemple, vous pouvez changer l’emplacement
des fichiers source d’installation d’une ou plusieurs applications dans
plusieurs groupes et langues.

Effectuez une recherche pour limiter la liste des applications à mettre à
jour. Vous pouvez effectuer la recherche sur n’importe quelle zone de
propriété d’application, telle que le nom de programme, la langue, le
groupe ou l’emplacement des fichiers d’installation. Cliquez sur Next
(Suivant).
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Dans le panneau des résultats de la recherche, sélectionnez les applications
à mettre à jour en cochant la case qui figure en regard de chaque entrée.
Choisissez ensuite la zone à mettre à jour et la nouvelle valeur à affecter.

Cliquez sur le bouton Update selection (Mettre à jour la sélection) pour
mettre à jour uniquement les applications sélectionnées, ou cliquez sur le
bouton Update all results (Mettre à jour tous les résultats) pour mettre à
jour toutes les applications répertoriées dans le panneau des résultats.
Cliquez sur Finish (Terminer).

View (Affichage)
Les options du menu Affichage vous permettent de modifier l’apparence de la
fenêtre du module d’administration SDA.

Toolbar (Barre d’outils)
Sélectionnez cette option pour afficher ou masquer la barre d’outils.

Status bar (Barre d’état)
Sélectionnez cette option pour afficher ou masquer la barre d’état dans la
partie inférieure de la fenêtre du module d’administration SDA. La barre
d’état affiche la description de la fonction d’une option de menu
sélectionnée.

Information panel (Panneau d’information)
Sélectionnez cette option pour afficher ou masquer le panneau
d’information dans la partie inférieure de la fenêtre du module
d’administration SDA. Le panneau d’information affiche les résultats des
opérations de création, d’importation et de traduction (extraction et
intégration).

Operating systems (Systèmes d’exploitation)
Sélectionnez cette option pour afficher les applications conçues pour un
système d’exploitation en particulier. Vous pouvez afficher les applications
conçues pour Microsoft Windows 95, Windows 98, Windows NT 4.0,
Windows 2000, Windows Millenium Edition ou Windows XP.
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Insert (Insérer)
Les options de menu suivantes vous permettent d’insérer une langue, un groupe,
un sous-groupe, une application ou une zone de profil dans une image SDA.

Language (Langue)
Sélectionnez cette option pour ajouter une ou plusieurs langues à un
espace de travail.

Dans le panneau gauche de la fenêtre du module d’administration SDA,
cliquez sur le nom de l’espace de travail, puis sur Insert → Language
(Insérer → Langue). Vous pouvez également cliquer avec le bouton droit de
la souris sur le nom de l’espace de travail, puis cliquer sur Insert language
(Insérer une langue).

Dans la fenêtre “Insert language” (Insérer une langue), cliquez sur les
langues à ajouter à l’espace de travail, puis cliquez sur OK.

Group (Groupe)
Sélectionnez cette option pour ajouter un groupe à une langue dans un
espace de travail.

Dans le panneau gauche de la fenêtre du module d’administration SDA,
cliquez sur la langue à laquelle vous voulez ajouter un groupe, puis sur
Insert → Group (Insérer → Groupe). Vous pouvez également cliquer avec le
bouton droit de la souris sur la langue, puis cliquer sur Insert group
(Insérer un groupe). Dans la fenêtre “Insert group” (Insérer un groupe),
tapez le nom du nouveau groupe, puis cliquez sur OK.

Vous pouvez également affecter un mot de passe à chaque groupe. Après
le déploiement d’une image, l’utilisateur doit alors saisir un mot de passe
pour que l’ensemble d’applications du groupe sélectionné soit installé.

Lors de l’ajout d’un groupe à un espace de travail SDA dans la fenêtre
“Insert group” (Insérer un groupe), saisissez le mot de passe dans la zone
Password (Mot de passe). Vous pouvez également modifier le mot de
passe affecté à un groupe en cliquant sur le groupe avec le bouton droit de
la souris, puis en cliquant sur l’option Edit (Modifier).

Subgroup (Sous-groupe)
Sélectionnez cette option pour créer des sous-groupes d’applications au
sein d’un groupe. Cela facilite la gestion complexe d’un grand nombre de
groupes, en vous permettant de structurer une hiérarchie au sein d’un
groupe. Par exemple, votre entreprise peut comprendre différents
départements. Au sein de chaque département, des groupes métier
spécifiques peuvent nécessiter des ensembles d’applications spécifiques.
SDA vous permet de créer un groupe pour chaque département et des
sous-groupes au sein de chaque groupe.
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La figure suivante montre comment SDA gère les groupes et les
sous-groupes :

Les règles suivantes s’appliquent à l’ajout de groupes et de sous-groupes :
v Les langues peuvent contenir des groupes et des zones de profil

utilisateur.
v Les groupes peuvent contenir des sous-groupes et des applications.
v Les sous-groupes ne peuvent contenir que des applications. Ils ne

peuvent pas contenir d’autres sous-groupes.
v Si vous copiez un sous-groupe dans une langue, ce sous-groupe est

converti en groupe.
v Si vous copiez un groupe dans un autre groupe, ce groupe est converti

en sous-groupe.

Application (Programme)
Sélectionnez cette option pour ajouter une application à un groupe ou à un
sous-groupe d’une langue.

Dans le panneau gauche de la fenêtre du module d’administration SDA,
cliquez sur le groupe ou le sous-groupe auquel vous voulez ajouter une
application, puis sur Insert → Application (Insérer → Programme). Vous
pouvez également cliquer avec le bouton droit de la souris sur le groupe,
puis cliquer sur Insert application (Insérer un programme). Dans la
fenêtre“Insert application” (Insérer un programme), indiquez les
informations relatives à l’application. Lorsque vous avez indiqué les
informations nécessaires sous chaque onglet, cliquez sur OK.

Profile field (Zone de profil)

Sélectionnez cette option pour ajouter une zone de profil utilisateur dans
une langue. Une zone de profil utilisateur permet d’identifier l’utilisateur
qui installe le logiciel depuis SDA. Dans la fenêtre “User profile” (Profil
utilisateur) qui s’affiche, vous pouvez indiquer que cette zone est
obligatoire, ce qui signifie que l’utilisateur est obligé de la remplir. Vous
pouvez également définir la taille de la zone en nombre de caractères et
faire une liste des valeurs correctes parmi lesquelles l’utilisateur peut faire
une sélection.
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Les réponses par zone de profil utilisateur sont sauvegardées dans un
fichier caché, c:\sdaprof.ini.

Propriétés d’insertion d’application
Vous pouvez ajouter des applications à l’espace de travail dans la fenêtre “Insert
application” (Insérer un programme).

General (Général) : Les zones de l’onglet General (Général) vous permettent
d’indiquer les informations de base relatives à une application.

Change icon (Changer d’icône)
Cette option permet d’utiliser une icône différente de l’icône par défaut.
Cliquez sur le bouton Change icon (Changer d’icône), puis sélectionnez le
fichier (généralement un fichier .EXE, .ICO ou .DLL) associé à l’icône que
vous voulez utiliser. Cliquez sur l’application, puis sur Open (Ouvrir).
Vous pouvez sélectionner une des icônes affichées. Le système associe
l’icône affichée sous l’onglet General (Général) à l’application dans l’image
SDA.

Des modèles d’icônes sont inclus dans le module d’installation SDA.

Application name (Nom du programme)
Vous devez taper dans cette zone obligatoire le nom de l’application tel
qu’il sera affiché dans l’image SDA.

Operating system (Système d’exploitation)
Vous devez sélectionner le système d’exploitation sur lequel l’application
sera déployée.

Remarque : Si des systèmes d’exploitation différents nécessitent des
versions différentes d’une application, vous devez les ajouter à
l’espace de travail séparément.

Language (Langue) et Group (Groupe)
Ces zones indiquent la langue et le groupe auxquels l’application
appartient. Vous ne pouvez pas modifier ces zones sous l’onglet General
(Général).
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Properties (Propriétés) : Toutes les zones de l’onglet Properties (Propriétés)
fournissent les données qui sont affichées dans la partie concernant l’installation
facultative du module d’installation SDA. Ces zones facultatives ne sont
applicables que si vous avez indiqué que l’intégralité de l’image SDA doit être
laissée sur le disque dur de l’utilisateur après l’installation des applications
requises.

Version
Indiquez le numéro de version de l’application, tel qu’il apparaîtra dans le
module d’installation SDA.

Disk space required (in MB) [Espace disque requis (en Mo)]
Indiquez la quantité approximative d’espace disque requis pour une
installation normale de l’application. Cette valeur s’affiche uniquement
dans le module d’installation SDA ; elle n’est pas destinée à être utilisée
par un autre programme.

Flyover text (Texte descriptif)
Saisissez une brève description de l’application, qui s’affichera dans le
module d’installation SDA lorsque l’utilisateur placera le pointeur de la
souris sur le nom de l’application.

Application name in Windows Add/Remove Programs (Nom du programme
dans l’option Ajout/Suppression de programmes de Windows)

Pour déterminer si une application a été installée et pour pouvoir
désinstaller cette application via le module d’installation SDA, saisissez le
nom de l’application exactement tel qu’il apparaîtra dans la fenêtre
Ajout/Suppression de programmes de Windows.

Path to a file or directory where the application is installed (Chemin d’accès
d’un fichier ou du répertoire où l’application est installée)

Si aucun nom ne s’affiche pour l’application dans la fenêtre
Ajout/Suppression de programmes et que vous voulez quand même que le
module d’installation SDA puisse déterminer où l’application est installée,
tapez le chemin d’accès qualifié complet de cette application. De cette
façon, SDA a un autre moyen de déterminer si une application est installée.
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Par exemple, le fichier d’application pourrait être :
C:\PROGRAM FILES\LOTUS\NOTES\NOTES.EXE.

Source : Les zones de l’onglet Source vous permettent d’indiquer l’emplacement
et le nom des fichiers d’installation. Vous devez indiquer un fichier de commandes
d’installation automatique ou un fichier de commandes d’installation
personnalisée. Vous pouvez indiquer les deux. Dans ce cas, le système exécute par
défaut le fichier de commandes d’installation automatique.

Location of installation files (Emplacement des fichiers d’installation)
Vous devez indiquer le chemin d’accès aux fichiers utilisés pour installer
l’application. Le chemin d’accès défini dans cette zone obligatoire s’affiche
automatiquement comme chemin d’accès dans la zone Silent Installation
Command (Commande d’installation automatique) de l’onglet Source.

Preinstallation command (Commande de préinstallation)
Vous avez la possibilité de configurer un programme pour qu’il s’exécute
juste avant un autre programme dans le cadre du processus d’installation
d’applications.

La commande de préinstallation vous permet de personnaliser
l’environnement, par exemple en définissant une clé de registre ou en
implémentant une commande par lots.

Silent installation command (Commande d’installation automatique)
Cette zone est obligatoire si vous n’indiquez aucun fichier de commandes
d’installation personnalisée. Indiquez le nom du fichier de commandes
d’installation automatique, sans oublier tout paramètre éventuellement
requis pour exécuter l’installation automatique (par exemple,
SETUP.EXE –S).

Une installation automatique s’effectue sans intervention de l’utilisateur.
Vous devez vous assurer que le programme que vous utilisez pour installer
les applications (InstallShield, Wise Installer ou Windows Installer, par
exemple) prend en charge l’installation automatique. La plupart des
programmes d’installation prennent en charge l’installation automatique.
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Custom installation command (Commande d’installation personnalisée)
Cette zone est obligatoire si vous n’indiquez aucun fichier de commandes
d’installation automatique. Indiquez le nom du fichier de commandes
d’installation personnalisée.

Une installation personnalisée nécessite l’intervention de l’utilisateur, pour
définir les options ou le répertoire d’installation, par exemple.

Post-installation command (Commande de post-installation)
Vous avez la possibilité de configurer un programme pour qu’il s’exécute
juste après un autre programme dans le cadre du processus d’installation
d’applications.

La commande de post-installation vous permet de personnaliser
l’application après l’installation. Vous pouvez également personnaliser la
configuration de l’application installée par le module d’installation SDA.

La mise à jour automatique d’un logiciel antivirus est un exemple de
commande de post-installation.

Recognizer command (Commande du dispositif de reconnaissance)
Cette commande permet d’associer à une application un programme de
reconnaissance, qui détermine si l’application peut être installée sur un
système particulier. En général, un programme de reconnaissance détecte
l’existence d’un périphérique matériel particulier.

Le programme de reconnaissance renvoie la valeur 0 si la condition est
fausse, ou la valeur 1 si la condition est vraie. Par exemple, un programme
de reconnaissance peut vérifier l’existence d’une unité de DVD et renvoyer
la valeur 1 si une telle unité est détectée. Dans cet exemple, une
application de lecture de DVD peut spécifier ce programme de
reconnaissance et elle ne sera installée que si le système est bien doté d’une
unité de DVD.

Remarque : Vous devez fournir les programmes de reconnaissance.

Installation : Les zones de l’onglet Installation vous permettent de définir les
propriétés d’installation de l’application.
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Installation type (Type d’installation)
Vous devez cliquer sur une des options suivantes dans le menu :
v Optional (En option) - L’installation de l’application est facultative.
v Recommended (Recommandée) - L’installation de l’application est

également facultative. Cependant, dans la fenêtre du module
d’installation SDA, l’application est sélectionnée par défaut lors de la
première exécution du module d’installation SDA. L’utilisateur doit
désélectionner l’application pour éviter de l’installer.

v Required (Requise) - L’application est impérativement installée pendant
la phase d’installation automatique du module d’installation SDA.

Les paramètres Optional (En option) et Recommended (Recommandée)
nécessitent que l’utilisateur sélectionne manuellement l’application à
installer.

Installation sequence (Séquence d’installation)
Ce menu permet d’affecter à l’application une priorité d’installation par
rapport aux autres applications qui sont installées. La séquence
d’installation démarre avec la priorité la plus élevée, 1, et continue jusqu’à
Don’t care (Quelconque). Les applications auxquelles vous affectez la
même priorité sont installées dans un ordre aléatoire.

Computer restart required (Redémarrage de l’ordinateur requis)
Cochez cette case si l’ordinateur doit être redémarré après l’installation de
l’application. Ce choix ne concerne que les applications installées pendant
la phase d’installation en option du module d’installation SDA. Lorsque
l’installation des applications en option est terminée, SDA invite
l’utilisateur à redémarrer l’ordinateur.

SDA version 1.3 installe les applications du groupe Commun et et des groupes
métier ensemble, dans une seule séquence (si une séquence a été définie).

Build (Intégration) : Les zones de l’onglet Build (Intégration) vous permettent de
personnaliser la création d’une arborescence pour les fichiers d’installation de
l’image SDA. Le répertoire indiqué sous cet onglet est ajouté à la fin du répertoire
d’intégration spécifié dans les propriétés de l’image, afin de créer le chemin d’accès
qualifié complet du répertoire dans lequel les fichiers source d’installation doivent
être copiés.
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Encrypt the installation (setup) files (Chiffrement des fichiers d’installation)
Ce paramètre facultatif vous permet de chiffrer une ou plusieurs
applications à l’aide du logiciel PKZIP en utilisant un mot de passe (défini
dans les propriétés de l’image) lors de la création d’une image SDA.

Le chiffrement empêche un utilisateur de naviguer manuellement dans le
répertoire de l’image SDA et d’installer des applications qui ne doivent pas
l’être (généralement pour des raisons de licence d’utilisation ou de droits
d’auteur).

Lorsqu’une application est désignée comme devant être chiffrée, le module
d’administration SDA compresse les fichiers d’installation, leur affecte un
mot de passe et copie le fichier .ZIP dans l’image SDA. Quand le module
d’installation SDA installe une application chiffrée, les fichiers source
d’installation se décompressent dans un répertoire temporaire sur le disque
dur de l’utilisateur. Le programme d’installation est exécuté depuis ce
répertoire temporaire, qui est ensuite supprimé.

Remarque : N’utilisez le chiffrement des applications que dans les cas où
cela s’avère nécessaire en raison de la licence d’utilisation. Le
chiffrement ralentit l’installation car il nécessite une
décompression de chaque application chiffrée avant
l’exécution du programme d’installation.

Image
Utilisez les options de menu suivantes pour manipuler l’image SDA que vous
intégrez à l’espace de travail.

Preview (Aperçu)
Sélectionnez cette option pour vous assurer que vous avez défini les informations
correctes dans l’espace de travail afin de créer l’image SDA voulue. L’aperçu de
l’image SDA simule l’installation des applications via le module d’installation SDA.
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L’aperçu de l’image n’installe pas réellement les applications, mais simule leur
installation en montrant quelles applications seront installées pour un groupe
métier donné.

Build (Intégration)
Sélectionnez cette option pour stocker les fichiers de l’image SDA dans un
répertoire d’intégration sur votre système.

Cochez la case Do not copy the installation files (Ne pas copier les fichiers
d’installation) pour autoriser les fichiers source de l’application à résider dans le
répertoire source d’origine au lieu de copier les fichiers source de chaque
application dans l’image SDA. Cela permet de limiter la taille de l’image SDA.
Cependant, vous devez disposer d’un accès réseau pour installer les applications et
la durée de l’installation sera plus longue en raison des temps d’accès au réseau.

Remarque : Pour vérifier que vous avez indiqué les informations correctes dans
l’espace de travail pour créer l’image SDA voulue, créez un aperçu de
l’image SDA avant de générer cette dernière.

Report (Rapport)
Sélectionnez cette option pour générer un rapport mis en page et imprimable
contenant la liste des ensembles d’applications au sein d’un espace de travail.

Le rapport classe les applications par langue. Il contient par défaut les colonnes
suivantes :
v Application name (Nom du programme)
v Group name (Nom du groupe)
v Subgroup name (Nom du sous-groupe)
v Operating system (Système d’exploitation)
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Vous pouvez personnaliser le rapport en sélectionnant les propriétés d’application
que vous voulez y inclure. Par exemple, vous pouvez ajouter l’emplacement des
fichiers d’installation, ainsi que la version de chaque application.

Après avoir sélectionné les zones supplémentaires à inclure au rapport, cliquez sur
OK pour générer un fichier de rapport au format ASCII standard.

Properties (Propriétés)
Sélectionnez cette option pour définir ce qu’il advient de l’image SDA une fois que
les applications requises sont installées sur le système d’un utilisateur.

Image contents (Contenus d’image) : Les options de l’onglet Image contents
(Contenus d’image) vous permettent de définir ce qu’il advient de l’image SDA
une fois que la phase d’installation automatique du module d’installation SDA a
installé les applications requises.
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Option de contenu de l’image SDA Résultat

Leave all applications (Laisser toutes
les applications)

Autorise d’administrateur à stipuler que TOUTES
les applications de l’image SDA doivent rester
dans l’image SDA. Rien ne sera supprimé de
l’image SDA après l’installation des applications
requises.

Leave only required and optional
applications in either the Common
group or the user’s selected business
group (Laisser les applications
requises et les applications
optionnelles dans le groupe Commun
ou dans l’activité sélectionnée par
l’utilisateur)

Permet aux utilisateurs de réinstaller une des
applications requises (en cas d’incident lié à
l’installation) ou d’installer une application en
option ou recommandée.

Leave only optional applications
included in either the Common group
or the user’s selected business group
(Laisser les applications optionnelles
dans le groupe Commun ou dans
l’activité sélectionnée par l’utilisateur)

Supprime toutes les applications requises déjà
installées. L’utilisateur peut installer uniquement
les applications en option ou recommandées
restant dans le groupe Commun ou dans le groupe
sélectionné par l’utilisateur.

Delete all applications and direct
SDA-Installer to another SDA image,
which can be on the user’s hard disk
or on a network drive (Supprimer
toutes les applications et diriger le
module d’installation SDA vers une
autre image SDA, laquelle peut se
trouver sur le disque dur de
l’utilisateur ou sur une unité réseau)

Spécifie une autre image SDA qui contient un
autre ensemble d’applications. Cet ensemble
d’applications doit contenir des applications en
option parmi lesquelles l’utilisateur peut faire une
sélection. Les applications requises de cet autre
ensemble d’applications ne sont pas
automatiquement installées.

La figure suivante illustre les options contenues dans la fenêtre Image.
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Si vous sélectionnez l’option Delete all applications and direct SDA-Installer to
another SDA image (Supprimer toutes les applications et diriger le module
d’installation SDA vers une autre image SDA), vous avez la possibilité d’entrer
un nom d’utilisateur et un mot de passe dans les zones Remote server username
(Nom d’utilisateur du serveur éloigné) et Remote server password (Mot de passe
du serveur éloigné).

Le nom d’utilisateur et le mot de passe que vous entrez ici permettent à
l’utilisateur d’installer les applications sans avoir à fournir ces informations. Si
vous ne renseignez pas ces zones, l’utilisateur devra entrer ces informations lors de
l’installation des programmes.

Image updates (Mises à jour d’image) : Vous pouvez fournir des versions mises à
jour des applications pour plusieurs images SDA sur un serveur de fichiers.
Lorsque le module d’installation SDA installe l’ensemble d’applications de
l’utilisateur, il peut rechercher une version plus récente de chaque application dans
une autre image SDA (généralement située sur un serveur de fichiers éloigné)
avant d’installer chaque application. Si une version plus récente d’une application
est localisée, le module d’installation SDA installe cette version au lieu de celle qui
est contenue dans l’image SDA située sur le disque dur de l’utilisateur. L’image
SDA située sur le disque dur de l’utilisateur détermine néanmoins toujours
l’ensemble d’applications à installer.

La figure suivante montre comment un administrateur peut désigner une image
SDA mise à jour :

Si vous indiquez un emplacement dans la zone Location of an updated SDA
image (on a file server)[Localisation d’une image SDA mise à jour (sur un
serveur de fichiers)], vous avez la possibilité d’entrer un nom d’utilisateur et un
mot de passe dans les zones Remote server username (Nom d’utilisateur du
serveur éloigné) et Remote server password (Mot de passe du serveur éloigné).
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Le nom d’utilisateur et le mot de passe que vous entrez ici permettent à
l’utilisateur d’installer les applications les plus récentes sans avoir à fournir ces
informations. Si vous ne renseignez pas ces zones, l’utilisateur devra entrer ces
informations lors de l’installation des programmes.

Pour chaque application installée, le module d’installation SDA compare le numéro
de version de l’application située sur le disque dur local avec celui de l’application
contenue dans l’image SDA mise à jour pour déterminer quelle version est
installée. Si la version de l’image SDA mise à jour est plus récente, l’utilisateur est
invité à vérifier si la nouvelle version doit être installée. Par exemple, la
version 2.01 est plus récente que la version 1.02.

Le numéro de version de chaque application est spécifié sous l’onglet Properties
(Propriétés) de l’application. Les numéros de version doivent se présenter sous la
forme d’une valeur numérique, telle que 1.0, 1.01 ou 4.62.

En outre, le contrôle de la version d’une application n’est effectué que dans le cas
où le module d’installation SDA trouve dans l’image SDA mise à jour une
application ayant exactement les mêmes nom, groupe, langue et système
d’exploitation.

SDA-Installer settings (Paramètres du module d’installation SDA) : Ces
paramètres vous permettent d’activer ou de désactiver les fonctions du module
d’installation SDA. Vous devez indiquer l’image SDA qui doit rester sur le disque
dur de l’utilisateur pour que ces paramètres soient applicables. Pour indiquer ce
que vous voulez faire de l’image SDA, cliquez sur Image → Properties (Propriétés),
puis sur l’onglet Image contents (Contenus d’image).

Change settings (Modification des paramètres)
Sélectionnez cette option pour modifier certains paramètres (emplacement
de l’image SDA, langue, affichage du texte descriptif et de la case à cocher
Custom installation (Installation personnalisée) pendant la phase
d’installation en option du module d’installation SDA.
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Display flyover text (Affichage du texte descriptif)
Sélectionnez cette option pour afficher une description de chaque
application lorsque l’utilisateur place le pointeur de la souris sur le nom de
l’application.

Si vous avez sélectionné l’option Change settings (Modification des
paramètres), l’utilisateur peut modifier ce paramètre dans la fenêtre du
module d’installation SDA pour contrôler le mode d’affichage de la
description. Pour créer un texte descriptif pour une application, cliquez sur
l’onglet Properties (Propriétés) de la fenêtre “Insert application” (Insérer
un programme).

Make the custom-installation option available (Activation de l’installation
personnalisée des programmes)

Sélectionnez cette option pour activer l’installation personnalisée des
programmes.

Si vous sélectionnez cette option, une case à cocher Custom installation
(Installation personnalisée) est affichée en regard de chaque application
pour laquelle un fichier de commandes d’installation personnalisée a été
défini. Si vous sélectionnez l’option Change settings (Modification des
paramètres), la valeur par défaut est définie et l’utilisateur peut modifier
ce paramètre dans la fenêtre du module d’installation SDA pour afficher
ou masquer la case à cocher Custom installation (Installation
personnalisée).

Display a full-screen window while required applications are installing
(Affichage d’une fenêtre plein-écran lors de l’installation des applications
requises)

Sélectionnez cette option pour afficher un bitmap plein écran en
arrière-plan afin de dissuader les utilisateurs d’accéder au bureau Windows
pendant l’installation des applications.

Specify a background bitmap (.bmp) to be displayed while applications are
installing (Indiquez un fichier bitmap (.bmp) en arrière-plan à afficher lors de
l’installation des applications.)

Indiquez le chemin d’accès qualifié complet d’un fichier bitmap à afficher
en arrière-plan. Si aucun fichier n’est indiqué, c’est la couleur par défaut
du bureau qui est utilisée.

Lock user out of the operating system (Interdire à l’utilisateur l’accès au système
d’exploitation)

Cette option interdit totalement l’accès à Windows à l’utilisateur et elle
masque toutes les fenêtres d’installation lors de l’installation des
applications.

Avertissement : Si une application nécessite une intervention de
l’utilisateur, vous ne devez PAS utiliser cette option car l’utilisateur ne
pourrait pas accéder au système et une condition d’erreur se produirait.
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SDA-Installer shortcut options (Options de raccourci du module d’installation
SDA)

Si vous choisissez de laisser le module d’installation SDA sur le disque dur
de l’utilisateur, vous pouvez sélectionner une ou plusieurs des options
suivantes :
v Run after required applications are installed (Exécuter une fois les

applications requises installées)
v Add a shortcut to the Windows Start menu (Ajout d’un raccourci dans le

menu Démarrer de Windows)
v Add a shortcut to the desktop (Ajout d’un raccourci sur le bureau)

Advanced options (Options avancées) : Les paramètres de cet onglet vous
permettent de définir le chiffrement de l’application, un graphique d’en-tête et les
propriétés du répertoire d’intégration.

Application encryption (Chiffrement de l’application)
Vous pouvez fournir un mot de passe à utiliser pour les applications que
vous choisissez de chiffrer (c’est-à-dire les applications pour lesquelles la
case Encrypt the installation files (Chiffrement des fichiers d’installation)
est cochée). Ces applications chiffrées ne peuvent pas être installées tant
que ce mot de passe n’est pas utilisé pour déchiffrer les fichiers
d’installation.
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Header graphic (Graphique d’en-tête)

Cette zone vous permet de changer le graphique qui figure en haut du
panneau gauche de la fenêtre du module d’installation SDA. Dans la zone
Header graphic (Graphique d’en-tête), sélectionnez le fichier graphique. Il
doit s’agir d’une image .GIF transparente, n’excédant pas 140 x 140 pixels.

La valeur de cette zone n’est applicable que si vous laisser l’image SDA sur
le disque dur de l’utilisateur à l’issue de l’installation automatique. Pour
indiquer ce que vous voulez faire de l’image SDA après l’installation
automatique, cliquez sur Image → Properties (Propriétés), puis sur l’onglet
Image contents (Contenus d’image).

Build directory (Répertoire d’intégration)

Cette zone vous permet d’indiquer le chemin d’accès qualifié complet du
répertoire dans lequel les fichiers source des applications doivent être
copiés pour les applications pour lesquelles un répertoire d’intégration
relatif personnalisé a été défini. Par exemple, si cette zone a pour valeur
C:\SDA\APPS et que le répertoire d’intégration relatif de l’application
Norton Antivirus est NORTON\1.0, le répertoire dans lequel les fichiers
source d’installation doivent être copiés lors d’une intégration est
C:\SDA\APPS\NORTON\1.0\<fichiers d’installation>.

Translation (Traduction)
Vous pouvez traduire les noms des groupes et des zones de profil utilisateur dans
d’autres langues. Le module d’administration SDA extrait ces éléments de texte
dans des fichiers (.INI) que vous pouvez faire traduire.

Send (Extraire)
Vous pouvez extraire le texte d’un fichier image SDA pour le sauvegarder dans un
répertoire de votre disque dur.

Receive (Intégrer)
Une fois les textes traduits, le module d’administration SDA les intègre dans
l’espace de travail.

Window (Fenêtre)
Ces options sont similaires aux options de fenêtre de nombreuses applications
Microsoft Windows :

Cascade
Dispose les fenêtres de sorte qu’elles se superposent.

Tile (Mosaïque)
Dispose les fenêtres sans qu’elles se superposent, verticalement ou
horizontalement.
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Lancement du module d’installation SDA sur l’ordinateur de
l’utilisateur

Vous pouvez utiliser une des méthodes suivantes pour lancer le module
d’installation SDA sur l’ordinateur d’un utilisateur après le déploiement de
l’image. Le module d’installation SDA s’exécute une fois que l’ordinateur a été
redémarré.

Création d’une entrée dans la clé de registre RunOnce
Pour exécuter automatiquement le module d’installation SDA au démarrage de
l’ordinateur, ajoutez ce module à la clé de registre RunOnce. Vous pouvez utiliser
les fichiers .REG comme dans les exemples suivants afin d’ajouter la bonne clé de
registre :
v

Pour Windows 95, Windows 98, Windows NT 4.0 et Windows Millennium
Edition :
REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
CurrentVersion\RunOnce]

"Run SDA-Installer"="d:\sdaimage\SWSELECT.EXE

v

Pour Windows 2000 :
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
CurrentVersion\RunOnce]

"Run SDA-Installer"="d:\sdaimage\SWSELECT.EXE"

Dans ces exemples, d:\sdaimage désigne l’unité de disque et le répertoire
contenant l’image SDA.

Création d’un raccourci dans le dossier Démarrage
Si vous créez un raccourci dans le dossier Démarrage, vous pouvez exécuter
automatiquement le module d’installation SDA au premier démarrage de
l’ordinateur. Sur l’ordinateur de l’utilisateur, dans le dossier Démarrage, créez un
raccourci vers un fichier de commandes ou un programme permettant de lancer le
module d’installation SDA. Supprimez ensuite ce raccourci du dossier Démarrage.

Autorisation de l’exécution du module d’installation SDA par
l’utilisateur

Vous pouvez autoriser l’utilisateur à exécuter le module d’installation SDA à la
demande. Pour ce faire, créez un raccourci vers le module d’installation SDA sur le
bureau Windows ou dans le menu Démarrer.

Exécution du module d’installation SDA sous Windows NT
Les procédures d’installation de nombreuses applications comprennent la mise à
jour des ressources Microsoft Windows, telles que le registre et les répertoires
système. Par conséquent, le compte utilisateur sur l’ordinateur de l’utilisateur doit
disposer des privilèges d’administrateur pour pouvoir activer les applications à
installer via le module d’installation SDA. Si vous ne voulez pas que le compte
utilisateur dispose de tels privilèges, vous devez utiliser une autre méthode pour
donner les droits d’accès nécessaires au module d’installation SDA.
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Le kit ZAK (Zero Administration Kit) de Windows NT contient les scripts et les
fichiers de commandes utilisés par Windows NT pour appeler d’autres
programmes, répercuter les modifications dans le registre et lancer des
programmes tels que le module d’installation SDA.

Pour plus d’informations sur ZAK et sur l’intégration des programmes pour qu’ils
s’exécutent automatiquement à l’issue de la configuration de Windows NT,
consultez le site Web de Microsoft (www.microsoft.com).

Tâches
Les procédures suivantes montrent comment utiliser Software Delivery Assistant.

Création d’un espace de travail
Pour créer un nouvel espace de travail, procédez comme suit :
1. Dans la fenêtre du module d’administration SDA, cliquez sur Create a new

workspace (Création d’un nouvel espace de travail), puis sur OK.

Si la fenêtre du module d’administration SDA est masquée, cliquez sur File →
New (Fichier → Nouveau). L’assistant de création d’espace de travail vous aide
à définir le nouvel espace de travail SDA.

2. Entrez le nom du nouvel espace de travail, puis cliquez sur Next (Suivant).
3. Sélectionnez les langues que l’image SDA doit prendre en charge, puis cliquez

sur Next (Suivant).
4. Cliquez sur le bouton Add (Ajouter) pour compiler les groupes que l’image

SDA doit prendre en charge, puis cliquez sur Next (Suivant).
Pour plus d’informations sur la définition des groupes, reportez-vous à la page
27.

5. Cliquez sur le bouton Add (Ajouter) pour compiler les zones de profil
utilisateur que vous voulez que les utilisateurs renseignent la première fois
qu’ils utilisent le module d’installation SDA, puis cliquez sur Finish (Terminer).

Vous pouvez maintenant modifier l’espace de travail et ajouter des applications à
chaque groupe.

Définition des groupes
Pour ajouter un groupe, procédez comme suit :
1. Cliquez sur la langue pour laquelle vous voulez ajouter un groupe.
2. Cliquez sur Insert → Group (Insérer → Groupe), ou cliquez avec le bouton droit

de la souris sur la langue, puis cliquez sur Insert group (Insérer un groupe).
3. Tapez le nom du groupe et appuyez sur Entrée.

Répétez cette étape pour chaque groupe.
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4. Lorsque vous avez dressé la liste de tous les groupes voulus, cliquez sur Next
(Suivant).

Pour supprimer un groupe de la liste, sélectionnez-le en cliquant dessus, puis
cliquez sur Remove (Supprimer). Pour modifier le nom d’un groupe de la liste,
cliquez sur ce groupe, puis sur Edit (Modifier). Tapez le nouveau nom et appuyez
sur Entrée.

Définition des zones de profil utilisateur
Pour ajouter une zone de profil utilisateur, procédez comme suit :
1. Cliquez sur le groupe de la langue dans laquelle vous voulez ajouter une zone

de profil utilisateur.
2. Cliquez sur Insert → Profile field (Insérer → Zone de profil), ou cliquez sur le

groupe avec le bouton droit de la souris et cliquez sur Insert profile field
(Insérer une zone de profil).
La fenêtre “User profile” (Profil utilisateur) s’affiche.

3. Dans la zone Name (Nom), tapez le nom de la zone de profil utilisateur à
ajouter.

4. Dans la zone Size (Taille), tapez le nombre maximal de caractères acceptés.
Le système tronque les entrées qui excèdent la taille indiquée.

5. Si vous voulez que l’utilisateur renseigne obligatoirement la zone, cochez la
case Required field (Zone obligatoire).
Si vous ne voulez pas limiter les entrées admises dans la zone, cliquez sur OK
et passez à l’étape 8.
Si vous voulez limiter les entrées de l’utilisateur à une liste d’entrées admises,
cliquez sur Add (Ajouter) pour créer une liste d’entrées admises qui sera
présentée à l’utilisateur.

6. Tapez une entrée dans la fenêtre Valid set (Valeurs admises) et appuyez sur
Entrée.
Pour chaque entrée supplémentaire, cliquez sur Add (Ajouter), tapez l’entrée et
appuyez sur Entrée. Une fois que vous avez défini toutes les entrées, cliquez
sur OK.

7. Pour supprimer une entrée de la liste, sélectionnez-la en cliquant dessus, puis
cliquez sur Remove (Supprimer). Pour modifier une entrée, sélectionnez-la en
cliquant dessus, puis cliquez sur Edit (Modifier). Tapez ensuite la nouvelle
entrée et appuyez sur Entrée.

8. Pour chaque zone de profil utilisateur supplémentaire, répétez les étapes 1 à 6.

Vous pouvez maintenant modifier l’espace de travail et ajouter des applications à
chaque groupe.
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Ouverture d’un espace de travail existant
Pour ouvrir un espace de travail existant, procédez comme suit :
1. Si vous venez de lancer SDA, cliquez sur Open an existing workspace (Ouvrir

un espace de travail existant) à partir de la fenêtre Software Delivery Assistant
– Administrator (IBM Software Delivery Assistant - Module d’administration),
puis cliquez sur OK.

Si la fenêtre

Software Delivery Assistant – Administrator (IBM Software Delivery Assistant -
Module d’administration) n’est pas ouverte, cliquez sur File → Open (Fichier →
Ouvrir).

2. Recherchez le fichier de l’espace de travail (.SSW) que vous voulez ouvrir.
3. Cliquez deux fois sur ce fichier, ou sélectionnez-le et cliquez sur Open (Ouvrir).

Importation d’un espace de travail à partir d’une image SDA
existante

Pour importer un espace de travail à partir d’une image SDA existante, procédez
comme suit :
1. A partir de la fenêtre Software Delivery Assistant – Administrator (IBM

Software Delivery Assistant - Module d’administration), cliquez sur Import a
workspace from an existing image (Importer un espace de travail à partir
d’une image existante), puis sur OK.
Si la fenêtre Software Delivery Assistant – Administrator (IBM Software
Delivery Assistant - Module d’administration) n’est pas ouverte, cliquez sur
File → Import (Fichier → Importer).

2. Tapez le nom descriptif (pas le nom du fichier) de l’espace de travail que vous
voulez créer à partir de celui que vous importez.

3. Tapez ou sélectionnez le chemin d’accès du répertoire dans lequel se trouve
l’image SDA (répertoire contenant le fichier SWSELECT.EXE et le
sous-répertoire DATA), puis cliquez sur OK.

Ajout de langues à un espace de travail
Pour ajouter des langues à l’espace de travail actif, procédez comme suit :
1. Dans le panneau gauche de la fenêtre du module d’administration SDA, cliquez

sur le nom de l’espace de travail.
2. Cliquez sur Insert (Insérer).
3. Cliquez sur Language (Langue). La fenêtre “Insert language” (Insérer une

langue) s’affiche.
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4. Sélectionnez chaque langue que vous voulez ajouter à l’espace de travail, puis
cliquez sur OK.
Chaque langue comprend le groupe Commun et un ensemble de zones de
profil utilisateur.

Ajout de groupes à une langue
Pour ajouter un groupe à une langue de l’espace de travail actif, procédez comme
suit :
1. Dans le panneau gauche de la fenêtre du module d’administration SDA, cliquez

sur la langue à laquelle vous voulez ajouter un groupe.
2. Cliquez sur Insert → Group (Insérer → Groupe). La fenêtre “Insert group”

(Insérer un groupe) s’affiche.
3. Tapez le nom du nouveau groupe, puis cliquez sur OK.

Ajout de sous-groupes à un groupe
Pour ajouter un sous-groupe à un groupe, procédez comme suit :
1. Dans le panneau gauche de la fenêtre du module d’administration SDA, cliquez

sur le groupe auquel vous voulez ajouter un sous-groupe.
2. Cliquez sur Insert → Subgroup (Insérer → Sous-groupe). La fenêtre “Insert

subgroup” (Insérer un sous-groupe) s’affiche.
3. Tapez le nom du nouveau groupe, puis cliquez sur OK.

Ajout d’applications à un groupe ou un sous-groupe
Pour ajouter une application à un groupe ou un sous-groupe de l’espace de travail
actif, procédez comme suit :
1. Dans le panneau gauche de la fenêtre du module d’administration SDA, dans

la langue concernée, sélectionnez le groupe auquel vous voulez ajouter une
application.

2. Cliquez sur Insert → Application (Insérer → Programme). La fenêtre “Insert
application” (Insérer un programme) s’affiche.

3. Fournissez les informations nécessaires sur l’application sous chacun des
onglets de la fenêtre “Insert application” (Insérer un programme).
Pour plus d’informations sur la fenêtre “Insert application” (Insérer un
programme), reportez-vous à la section «Propriétés d’insertion d’application» à
la page 12.

4. Lorsque vous avez indiqué les informations nécessaires sous chaque onglet,
cliquez sur OK.

Ajout de zones de profil utilisateur
Pour ajouter une zone de profil utilisateur, procédez comme suit :
1. Dans le panneau gauche de la fenêtre du module d’administration SDA, dans

la langue pour laquelle vous voulez ajouter une zone de profil utilisateur,
cliquez sur Profile (Profil). Les zones de profil utilisateur actuellement définies
s’affichent dans le panneau droit de la fenêtre du module d’administration
SDA.

2. Cliquez sur Insert → Profile (Insérer → Profil). La fenêtre “User profile” (Profil
utilisateur) s’affiche.
Vous pouvez également cliquer sur Profile (Profil) avec le bouton droit de la
souris, puis cliquer sur Insert profile field (Insérer une zone de profil).
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3. Dans la zone Name (Nom), tapez le nom de la zone de profil utilisateur à
ajouter.

4. Dans la zone Size (Taille), tapez le nombre maximal de caractères acceptés.
SDA tronque les entrées trop longues.

5. Si vous ne voulez pas limiter les entrées admises dans la zone, cliquez sur OK
pour ajouter la nouvelle zone de profil utilisateur, puis passez à l’étape 8.
Si vous voulez limiter les entrées admises dans la zone, cochez la case
Required field (Zone obligatoire) afin que l’utilisateur soit obligé de
renseigner la zone.

6. Pour créer une liste d’entrées admises, cliquez sur le bouton Add (Ajouter).
7. Tapez une entrée dans la fenêtre Valid set (Valeurs admises) et appuyez sur

Entrée. Répétez les étapes 6 et 7 pour chaque entrée supplémentaire.
Pour supprimer une entrée de la liste, sélectionnez-la en cliquant dessus, puis
cliquez sur Remove (Supprimer). Pour modifier une entrée, sélectionnez-la en
cliquant dessus, puis cliquez sur Edit (Modifier). Tapez ensuite la nouvelle
entrée et appuyez sur Entrée.

8. Une fois que vous avez défini toutes les entrées, cliquez sur OK.

Automatisation de la sélection de groupes
Vous devez au minimum définir une zone de profil utilisateur Groupe dans
l’image SDA, afin que l’utilisateur puisse indiquer quelle suite d’applications doit
être installée. Si vous préférez, vous pouvez configurer le module d’installation
SDA pour qu’il ne tienne pas compte des zones de profil utilisateur et qu’il
détermine automatiquement le groupe de l’utilisateur, ce qui évite le risque que ce
dernier se trompe de groupe.

Il y a deux façons de procéder : vous pouvez créer un programme 32 bits ou une
clé de registre.

Création d’un programme 32 bits
1. Créez un fichier programme 32 bits, nommé C:\SDAPROF.INI, sur le disque

dur de l’utilisateur. Ce fichier doit contenir le texte suivant :
Group=nom_groupe

où nom_groupe est le nom du groupe de l’utilisateur.
2. Exécutez le module d’installation SDA, qui lance le programme GROUPCHK et

crée la clé de registre et l’entrée.

Ajout d’une entrée à la clé de registre
1. Créez un programme 32 bits, nommé GROUPCHK.EXE, qui va déterminer le

groupe de l’utilisateur, créer la clé de registre HKEY_CURRENT_USER
\SOFTWARE\IBM\SS et créer l’entrée suivante dans cette clé de registre :
Group “nom_groupe”

où nom_groupe est le nom du groupe de l’utilisateur.
2. Sur le disque dur de l’utilisateur, placez le fichier programme dans le répertoire

principal qui contient le fichier SWSELECT.EXE et le sous-répertoire DATA de
l’image SDA.

3. Exécutez le module d’installation SDA, qui lance le programme GROUPCHK et
crée la clé de registre et l’entrée.
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Création d’un aperçu de l’image SDA
Pour créer un aperçu de l’image SDA à partir de l’espace de travail actif, procédez
comme suit :
1. Cliquez sur Image → Preview (Image → Aperçu).
2. Dans le menu Language (Langue), sélectionnez la langue qui vous intéresse.
3. Dans le menu “Operating system” (Système d’exploitation), sélectionnez le

système d’exploitation qui vous intéresse, puis cliquez sur OK.
Le module d’administration SDA génère l’aperçu de l’image et le module
d’installation SDA est lancé.

4. Dans le module d’installation SDA, renseignez les zones de profil utilisateur,
puis cliquez sur OK.
Le module d’installation SDA simule l’installation des applications dans le
groupe Commun et dans le groupe que vous avez sélectionné dans le profil
utilisateur.

Création d’une image SDA à partir d’une image SDA existante
Pour créer une nouvelle image SDA à partir d’une image SDA existante, procédez
comme suit :
1. Cliquez sur File → Import (Fichier → Importer) pour importer un espace de

travail à partir de l’image SDA existante.
2. Entrez le nom de la nouvelle image SDA dans la zone New workspace name

(Nouveau nom de l’espace de travail).
3. Entrez l’unité de disque et le répertoire dans la zone Image location

(Emplacement de l’image). Vous pouvez également cliquer sur le bouton
Browse (Parcourir) pour sélectionner manuellement le répertoire.

4. Cliquez sur OK.

Mise à jour de plusieurs applications
Pour mettre à jour plusieurs applications, procédez comme suit :
1. Cliquez sur Find → Update (Rechercher → Mettre à jour). La fenêtre “Find and

update application” (Rechercher et mettre à jour les applications) s’affiche.

2. Cliquez sur le type de zone à utiliser pour la recherche.
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La zone de recherche que vous sélectionnez affecte la valeur qui est utilisée par
le moteur de recherche. Dans certaines zones de recherche, vous pouvez
effectuer une recherche exacte en cochant la case Exact match only
(Occurrences exactes uniquement).

3. Saisissez le texte que vous voulez rechercher dans la zone Value to search for
(Valeur à rechercher).

4. Cliquez sur Next (Suivant).
La fenêtre “Find and update applications” (Rechercher et mettre à jour les
applications) affiche les résultats de la recherche dans la fenêtre Results
(Résultats).

5. Cliquez sur le résultat que vous voulez mettre à jour.
6. Sélectionnez le type de mise à jour que vous désirez effectuer dans le menu

“Field to be updated” (Zone à mettre à jour).
7. Saisissez ou cliquez sur l’information mise à jour dans la zone New Value

(Nouvelle valeur). Votre entrée dépend de la valeur que vous avez sélectionnée
dans le menu Field to be updated (Zone à mettre à jour).

8. Cliquez sur le bouton Update Selection (Mettre à jour la sélection) pour
mettre à jour uniquement les applications sélectionnées, ou cliquez sur le
bouton Update All Results (Mettre à jour tous les résultats) pour mettre à jour
toutes les applications répertoriées dans la liste des résultats.

9. Cliquez sur Finish (Terminer) pour terminer les mises à jour.

Désactivation de la phase d’installation en option du module
d’installation SDA

Pour supprimer l’image du module d’installation SDA du disque dur de
l’utilisateur, ce qui désactive la phase d’installation en option du module
d’installation SDA, procédez comme suit :
1. Cliquez sur Image → Properties (Image → Propriétés).

La fenêtre “Image properties” (Propriétés de l’image) s’affiche.
2. Cliquez sur l’onglet Image contents (Contenus d’image).
3. Cliquez sur Remove SDA-Installer from the user’s hard disk (Supprimer le

module d’installation SDA du disque dur de l’utilisateur), puis sur OK.

Pour plus d’informations sur la gestion des images SDA, reportez-vous à la section
«Properties (Propriétés)» à la page 19.

Extraction du texte pour traduction
Pour extraire du texte de l’espace de travail actif, procédez comme suit :
1. Cliquez sur Translation → Send (Traduction → Extraire).

La fenêtre Send (Extraire) s’affiche.
2. Tapez le chemin d’accès du répertoire dans lequel vous voulez stocker les

fichiers, puis cliquez sur OK. Vous pouvez également naviguer jusqu’à cet
emplacement en cliquant sur le bouton Browse (Parcourir).
Le panneau d’informations affiche les résultats de l’extraction de texte.
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Intégration du texte traduit
Pour intégrer le texte traduit dans l’espace de travail actif, procédez comme suit :
1. Cliquez sur Translation → Receive (Traduction → Intégrer).

La fenêtre Receive (Intégrer) s’affiche.
2. Tapez le chemin d’accès du répertoire dans lequel vous voulez stocker les

fichiers, puis cliquez sur OK. Vous pouvez également naviguer jusqu’à cet
emplacement en cliquant sur le bouton Browse (Parcourir).
Le panneau d’informations affiche les résultats de l’intégration de texte.
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Annexe. Remarques

Le présent document peut contenir des informations ou des références concernant
certains produits, logiciels ou services IBM non annoncés dans ce pays. Pour plus
de détails, référez-vous aux documents d’annonce disponibles dans votre pays, ou
adressez-vous à votre partenaire commercial IBM. Toute référence à un produit,
logiciel ou service IBM n’implique pas que seul ce produit, logiciel ou service
puisse être utilisé. Tout autre élément fonctionnellement équivalent peut être
utilisé, s’il n’enfreint aucun droit d’IBM. Il est de la responsabilité de l’utilisateur
d’évaluer et de vérifier lui-même les installations et applications réalisées avec des
produits, logiciels ou services non expressément référencés par IBM.

IBM peut détenir des brevets ou des demandes de brevet couvrant les produits
mentionnés dans le présent document. La remise de ce document ne vous donne
aucun droit de licence sur ces brevets ou demandes de brevet. Si vous désirez
recevoir des informations concernant l’acquisition de licences, veuillez en faire la
demande par écrit à l’adresse suivante :

IBM EMEA Director of Licensing
IBM Europe Middle-East Africa
Tour Descartes La Défense 5
2 avenue Gambetta
92066 Paris-La Défense CEDEX 50
France

Pour le Canada, veuillez adresser votre courrier à :
IBM Director of Commercial Relations
IBM Canada Ltd.
3600 Steeles Avenue East
Markham, Ontario
L3R 9Z7
Canada

LE PRESENT DOCUMENT EST LIVRE «EN L’ETAT». IBM DECLINE TOUTE
RESPONSABILITE, EXPLICITE OU IMPLICITE, RELATIVE AUX INFORMATIONS
QUI Y SONT CONTENUES, Y COMPRIS EN CE QUI CONCERNE LES
GARANTIES DE VALEUR MARCHANDE OU D’ADAPTATION A VOS BESOINS.
Certaines juridictions n’autorisent pas l’exclusion des garanties implicites, auquel
cas l’exclusion ci-dessus ne vous sera pas applicable.

Le présent document peut contenir des inexactitudes ou des coquilles. Il est mis à
jour périodiquement. Chaque nouvelle édition inclut les mises à jour. IBM peut
modifier sans préavis les produits et logiciels décrits dans ce document.

IBM pourra utiliser ou diffuser, de toute manière qu’elle jugera appropriée et sans
aucune obligation de sa part, tout ou partie des informations qui lui seront
fournies.

Les références à des sites Web non IBM sont fournies à titre d’information
uniquement et n’impliquent en aucun cas une adhésion aux données qu’ils
contiennent. Les éléments figurant sur ces sites Web ne font pas partie des
éléments du présent produit IBM et l’utilisation de ces sites relève de votre seule
responsabilité.
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Marques
IBM est une marque enregistrée d’International Business Machines Corporation
aux Etats-Unis et/ou dans certains autres pays.

Microsoft, Windows et Windows NT sont des marques de Microsoft Corporation
aux Etats-Unis et/ou dans certains autres pays.

D’autres sociétés sont propriétaires des autres marques, noms de produits ou logos
qui pourraient apparaître dans ce document.
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