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Chapter 1. Installing and Starting Software Delivery Assistant

This section contains instructions for installing and starting Software Delivery Assis-
tant (SDA) version 1.2.

System requirements
SDA version 1.2 requires one of the following Microsoft® operating systems:

• Windows® 95

• Windows® 98

• Windows NT® 4.0

• Windows 2000

• Windows Millennium Edition

Installing Software Delivery Assistant 
Do the following to perform an attended installation of Software Delivery Assistant on 
a server, console, or client runnings Windows NT or Windows 98: 

1. Download the program from the following IBM web page: http://www.ibm.com/pc/.

2. From the Windows Start menu, click Run.

3. In the Open field, type:

drive_letter:\directory\sda12.exe

where drive_letter and directory are the drive and directory where the installation 
program is located. 

4. Click OK to start the installation program.

5. In the Welcome window, click Next to continue the installation.

6. Click Next.

The Software Delivery Assistant Installer installs the program files.

7. The Setup Complete window opens when the installation is complete. Click Fin-
ish to confirm.

Starting Software Delivery Assistant
You can start SDA with one of these methods:   

• Click Start →�Programs → IBM Software Delivery Assistant v1.2.

• Double-click the SDAassist.exe file located within C:\Program 
Files\SDAv12\SDAssist.exe.

Uninstalling Software Delivery Assistant
To remove Software Delivery Assistant from your system, do the following:

1. Click Start → Settings → Control Panel.

2. Double-click Add/Remove Programs.

3. Select the Software Delivery Assistant program name from the Install/Uninstall 
list.
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4. Click Add/Remove.

5. In the Confirm File Deletion window, click Yes.

6. Click OK.
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Chapter 2. Using Software Delivery Assistant 

IBM Software Delivery Assistant (SDA) helps with the deployment of a single applica-
tion set that you can use across an entire organization. SDA can create a single com-
mon application set that you can deploy to all users, regardless of their operating 
system, language, hardware configuration or business group (for example, marketing, 
development, or finance).

With SDA, you package all of the unique application sets, based on business group-
ings within your enterprise into a single installation SDA image. You can then combine 
this image with a base SDA image, which contains an operating system, device driv-
ers, and core applications (such as antivirus tool), to form a common superimage that 
can be deployed to all users regardless of what business group they are in.

SDA consists of two parts:

• SDA-Administrator

• SDA-Installer

You, the administrator, use SDA-Administrator to create an SDA image. Users use 
SDA-Installer to install their application sets onto their computers from the SDA image 
that you create. You can also set up SDA-Installer to run automatically on the end 
users’ computers.

Overview
The following topics present an overview of the IBM SDA process.

Gathering information
Have the following information available before you begin:

• The operating systems that the SDA image will support.  The SDA-Administrator 
can be used to create SDA images that support Microsoft Windows 95, Windows 
98, Windows NT 4.0, Windows 2000, and Windows Millennium Edition.

• The languages that the SDA image will support, which includes what language 
version of Windows you will be deploying.

• The groups for which different suites of applications are needed. For example, 
groups could include your company’s managers, marketing department, or payroll 
division.

• The user-profile fields that you want to define.  At a minimum, you must have a 
group user-profile field, so that the user can indicate which suite of applications is 
to be installed.

Creating a workspace
A workspace (files with the .SSW extension) contains all the information that is 
required to build an SDA image.  You can create a new workspace, or you can import 
a workspace from an SDA image that was previously built to create a new workspace.  
The SDA image creation wizard guides you through the process of setting up a new 
workspace.  The workspace interface resembles the Microsoft Windows Explorer 
interface.  You can edit this workspace to add, copy, move, or delete languages, 
groups, and applications to the workspace.
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Translating the SDA image text
You can translate the group names and user-profile field names into the different lan-
guages for the SDA image.  The SDA-Administrator extracts the text from the work-
space into files that you can send to your translators.  When you receive the 
translations, reintegrate this translated text into your workspace.

The user-profile field names and group names can also be presented in different lan-
guages.

Previewing the SDA image
To verify that you have specified the correct information in the workspace to create the 
SDA image that you want, you can run a preview of the SDA image.

Previewing the image does not actually install any applications but instead simulates 
the installation by showing which applications will be installed for a selected business 
group.

Building the SDA image
When you are certain that you have specified the correct information in the work-
space, build the SDA image. Building the SDA image installs programs for all the 
applications for deployment onto users’ computers.

Downloading the SDA image to users’ computers
After you build the SDA image, download the SDA image to each user’s computer 
(through a tool such as IBM LANClient Control Manager™, PowerQuest Drive Image, 
or Norton Ghost). You can also copy the SDA image to a CD for distribution.  Users 
can access the SDA image through the SDA-Installer to install their application suites, 
or you can set the SDA-Installer to automatically install the required applications.  

Starting the SDA image on users’ computers
The user can start the SDA-Installer by running swselect.exe in the SDA image after 
the computer has been restarted.

Installing software onto users’ computers
The first time SDA-Installer runs, the program prompts the user to select one of the 
business groups that are defined in the SDA workspace. After the user selects a busi-
ness group, the SDA-Installer installs the required applications from the Common 
group and the user’s selected business group.

You can set up the SDA image to do one of the following after the required applica-
tions are installed:

• Remove the SDA image from the user's hard disk to free up space (if the SDA 
image is on the user's hard disk).

• Leave the install packages for required and optional applications in either the 
Common group or the user's selected business group. All other install packages 
will be removed from the user's hard disk to free up space.

• Leave the install packages for optional applications in either the Common group 
or the user's selected business group. All other install packages will be removed 
from the user's hard disk to free up space.

• Remove all of the install packages for all applications in the SDA-image to free up 
disk space, and enable the user to selectively install additional applications from 
another SDA image on an attached network drive (or can be a second SDA image 
on the user’s hard disk).
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Automating group selection
At a minimum, you must have a group user-profile field in the SDA image so that a 
user can indicate which suite of applications is to be installed.  If you prefer, you can 
enable the SDA-Installer to bypass the user-profile fields and automatically determine 
the user’s group, preventing the user from selecting the wrong group.  

Normally, when SDA-Installer runs the first time, the end-user is prompted to select 
their business group to allow the correct application set to be installed.  If you do not 
want the end-user to select their business group (to avoid the mistake of selecting the 
wrong business group), you can automate the group selection which bypasses the 
user profile prompt.

You can do this one of two ways:

1. Create a group entry in the C:\SDAPROF.INI. The entry must contain the follow-
ing:

[User Information]

Group=groupname  

where groupname is the name of the user’s group. 

For example:

[User Information]

Group=Finance  

2. Create a group entry in the following Registry key:

[HKEY_CURRENT_USER\SOFTWARE\IBM\SS]

"Group"="groupname" 

where groupname is the name of the user’s group. 

For example:

[HKEY_CURRENT_USER\SOFTWARE\IBM\SS]

"Group"="Finance" 

In both cases, you can manually create the Group entry or you can create a 32-bit 
program, called GROUPCHK.EXE, to create the Group entry for you.  SDA-Installer 
has a programmatic hook built in to look for the GROUPCHK.EXE program in the 
SDA-Image directory.  This allows you to create your own Group decision logic for 
determining an end user's business group. 

Note: GROUPCHK.EXE must be in the root directory of the SDA-Image, where 
SWSELECT.EXE exists.

Getting started
After you compile your system and workspace information, you can create (or import) 
the workspace. Before you begin, make sure that you have all the necessary informa-
tion for your workspace.

If you want to permanently hide the Software Delivery Assistant - Administrator win-
dow, select the Do not show this window again check box when the window opens. 
Until you do this, the window opens whenever you start the program.

Getting familiar with the workspace
The SDA-Administrator builds and displays the workspace.  The workspace interface 
resembles the Microsoft Windows Explorer interface.  The left pane of the window dis-
plays the structure of the workspace, with each group listed within each language.  
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Each language contains its own set of user-profile fields, which you can modify.  In 
addition, each language contains a Common group and one or more other groups. 
Furthermore, each group can contain one or more subgroups.

The right pane of the SDA-Administrator window displays the contents of the item that 
you highlight in the left pane of the window.

Note: You must save the workspace file before you exit from the SDA-Administrator.  
Click File → Save or File → Save As and save the file as you would any other 
file.

Naming the workspace
Give the workspace a descriptive name in the Workspace name field.

Selecting languages
Select each language that you want the SDA image to support.  These languages 
must correspond to the language versions of the operating systems that you are 
deploying.

Specifying groups
A group is a set of applications specific to a particular organization, job, or discipline in 
your enterprise.  (For example, in a university setting, groups might include the 
Schools of Journalism, Dentistry, and Business).  List the groups that you want the 
SDA image to support.  The list of groups must contain the Common group, which 
contains the applications that are used by all groups.

Specifying user-profile fields
Create the user-profile fields that you want the users to complete the first time they 
install the SDA image.  (For example, a user-profile field might be an employee ID, or 
a location.) 

Opening an existing workspace
You can use an existing workspace that has not yet been used to build an SDA image 
by clicking File → Open and navigating to the existing workspace.  You can then 
rename the workspace to create a new workspace and modify it as necessary. 

Importing a workspace from an existing SDA image
You can create a new workspace from an existing SDA image by importing a work-
space from the existing SDA image.  You can then modify the workspace to create a 
new SDA image.  The SDA-Administrator will use installation (setup) files from the 
existing SDA image rather than from the locations from which the files were originally 
obtained when the existing SDA image was built.

The SDA-Administrator imports the new workspace as the active workspace. You can 
edit the workspace to add applications to the groups and add, copy, move, and delete 
items in the workspace.  Information and error messages for the import process are 
displayed in the information panel.  

Toolbar buttons
From left to right, you find these toolbar buttons:

New
Click this button to create a new workspace.  Using this option is the same as 
clicking File → New.
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Open
Click this button to open an existing workspace.  Using this option is the same 
as clicking File → Open.

Save
Click this button to save the active workspace.  Using this option is the same 
as clicking File → Save or File → Save As.

Cut
Click this button to delete the selected item from the workspace and copy it to 
the Clipboard.  Using this option is the same as clicking Edit → Cut. 

Copy
Click this button to copy the selected item to the Clipboard.  Using this option 
is the same as clicking Edit → Copy.

Paste
Click this button to copy the contents of the Clipboard to the selected item.  
Using this option is the same as clicking Edit → Paste.

Information panel 
Click this button to show or hide the information panel, which displays the 
results of build, import, and translation send and receive processes.

Help
Click this button to display help for the SDA-Administrator.

Menu options
Use the following menu options to manipulate the SDA workspaces.

File
You can use the File menu options to create, open, or import workspaces.

New
Click this option to create a new workspace.  Using this option is the same as 
clicking the New button on the toolbar.

Open
Click this option to open an existing workspace.  Using this option is the same 
as clicking the Open button on the toolbar.

Import
Click this option to import a workspace from an existing SDA image.

Edit
The Edit menu options resemble the editing options in many Microsoft Windows appli-
cations.

Selected object
Click this option to change the name of a workspace.

Delete
Click this option to delete the selected language, group, or application.

Cut
Click this option to delete the selected language, group, or application and 
save it to the Clipboard.  Clicking this option is the same as clicking the Cut 
button on the toolbar.

Copy
Click this option to copy the selected item to the Clipboard.  Clicking this 
option is the same as clicking the Copy button on the toolbar.
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Paste
Click this option to copy the contents of the Clipboard to the selected item.  
Clicking this option is the same as clicking the Paste button on the toolbar.

Find and update
Click this option to propagate a property change to many applications. For 
example, you might want to change the location of the installation source files 
for one or more applications within multiple groups and languages.

For more information updating applications, refer to “Updating multiple appli-
cations” on page 25. 

View
You can use the View menu options to change the appearance of the SDA-Adminis-
trator window.

Toolbar
Click this option to show or hide the toolbar.

Status bar
Click this option to show or hide the status bar at the bottom of the SDA-
Administrator window.  The status bar displays the function of a highlighted 
menu item.

Information panel
Click this option to show or hide the information panel at the bottom of the 
SDA-Administrator window.  The information panel displays the results of 
build, import, and translation send and receive processes.

Operating systems
Click this option to display applications for one operating system only.  You 
can choose to display applications for Microsoft Windows 95, Windows 98, 
Windows NT 4.0, Windows 2000, or Windows Millennium Edition. 

Insert
Use the following menu options to insert a language, group, subgroup, application, or 
profile field into an SDA image.

Language
Click this option to add one or more languages to a workspace. 

In the left pane of the SDA-Administrator window, click the workspace name 
and then click the Insert → Language menu option.  Or you can right-click 
the workspace name and click Insert language.

In the Insert language window, click the languages that you want to add to the 
workspace, and click OK.

Group
Click this option to add a group to a language in a workspace. 

In the left pane of the SDA-Administrator window, click the language to which 
you want to add a group, and then click the Insert → Group menu option.  Or 
you can right-click the language, and click Insert group.  In the Insert group 
window, type the name of the new group, and click OK.

You can also assign a password to each group.  After an image is deployed, 
the user must type the password for the selected group to be installed. 

When adding a group to an SDA workspace in the Insert group window, type 
the password in the Password field.  You can also modify a group-assigned 
password by right-clicking the group and clicking the Edit option.
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Subgroup
Click this option to create application subgroups within a group.  This eases 
the complexity of managing large numbers of groups by enabling you to 
structure a hierarchy within a group.  

For example, you might have different divisions within your enterprise.  Within 
each division, unique business groups may require unique application sets.  
SDA enables you to create a group for each division and subgroups within 
each group.  

The following illustrates how SDA manages groups and subgroups:

The following rules apply to adding groups and subgroups:

• Languages can contain groups and user-profile fields.

• Groups can contain subgroups and applications.

• Subgroups can contain only applications.  Subgroups cannot contain 
other subgroups.

• If you copy a subgroup into a language, the subgroup is converted into a 
group.

• If you copy a group into another group, the group is converted into a sub-
group.

Application
Click this option to add an application to a group or subgroup within a lan-
guage.

In the left pane of the SDA-Administrator window, click the group or subgroup 
to which you want to add an application, and then click Insert → Application. 
Or you can right-click the group and click Insert application.  In the Insert 
application window, specify information about the application.  When you are 
finished specifying the necessary information on each tab, click OK.

Profile field
Click this option to add a user-profile field within a language. A user-profile 
field helps identify the user who installs the software from SDA.  In the User 
profile window that opens, you can designate the field as Required, meaning 
that the user must complete it. You can also define the field size in characters 
and list valid entries from which the user selects.
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Application insertion properties
You can add applications to the workspace in the Insert application window.

General:  Use the fields in the General tab to specify basic information about an 
application.

Change icon
This optional feature allows you to use an icon other than the default icon.  
Click the Change icon button and browse to the file (usually an .EXE, .ICO, 
or .DLL file) that is associated with the application you are adding.  Click the 
files, and click Open.  You can select one of the icons that are displayed.  The 
system associates the icon that is displayed in the General tab with the appli-
cation in the SDA image.

Sample icons are also included with SDA-Installer.

Application name
You must type the name of the application in this required field as you want it 
to be displayed in the SDA image.

Operating system
You must select the operating system in which the application will be 
deployed.

Note: If different operating systems require different versions of an applica-
tion, you must add them to the workspace separately.

Language and Group
These fields display the language and group to which the application belongs. 
You cannot change these fields in the General tab.

Properties:  All the items in the Properties tab provide the data that is displayed in 
the optional-installation portion of the SDA-Installer.  These optional items are applica-
ble only if you specify that the entire SDA image is to be left on the user’s hard disk 
after SDA installs the required applications.
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Application name in Windows Add/Remove Programs
If you want users to be able to uninstall the application through the SDA-
Installer, type the name of the application exactly as it will appear in the Win-
dows Add/Remove Programs window.

Version
Type the version number of the application as you want it to appear in the 
SDA-Installer.

Disk space required (in MB)
Type the approximate amount of disk space that a typical installation of the 
application requires.  This value is only displayed in the SDA-Installer; the 
information is not used by any program.

Flyover text
Type a brief description of the application to appear in the SDA-Installer when 
the user positions the cursor over the application name.

Source:  Use the fields in the Source tab to specify the location and names of instal-
lation files.  You must specify either a silent installation command file or a custom 
installation command file; you can specify both.  If you specify both, the system 
defaults to the silent installation command.
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Location of installation files
You must specify the path where the files that are used to install the applica-
tion are located.  The path that you specify in this required field is automati-
cally displayed as the path for the Silent Installation Command field on the 
Source tab.

Encrypt the installation (setup) files
This optional setting enables you to encrypt one or more applications with 
PKZIP software when building an SDA image.

Encryption prevents a user from manually navigating the SDA image direc-
tory and installing an application that must not be installed (typically for roy-
alty or licensing reasons).

When an application is marked for encryption, the SDA-Administrator zips the 
installation files with a password and copies the .ZIP file to the SDA image.  
When SDA-Installer installs an encrypted application, the installation source 
for the application unzips to a temporary directory on the user’s hard disk. 
The installation program runs from the temporary directory and is then 
deleted.

Note: Use application encryption only where license restrictions require it.  
Encryption lengthens the installation time by decompressing each of 
the encrypted applications before running the installation program.

Preinstallation command
You have the option to set a program to run immediately before a program as 
part of the application installation process.

The preinstallation command enables you to set up your system for the envi-
ronment, such as setting up a registry key or implementing a batch command.

Silent installation command
You must complete this field if you do not specify a custom installation com-
mand.  Type the name of the silent installation command, including any 
switches that are required to run the silent installation (for example, 
SETUP.EXE -S).

A silent installation occurs without input from the user. You must make sure 
that the program that you are using to install the applications (such as 
InstallShield, Wise Installer, or Windows Installer) supports silent installation.  
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Custom installation command
You must complete this field if you do not specify a silent installation com-
mand file.  Type the name of the custom installation command file (for exam-
ple, SETUP.EXE).

A custom installation occurs with input from the user, such as installation 
options and destination directories.

Post-installation command
You have the option to set a program to run immediately after a program as 
part of the application installation process.

The post-installation command enables you to customize the installed appli-
cation after the installation is complete. You can also custom configure the 
application that is installed by the SDA-Installer.

An example of a post-installation command would be setting the automatic 
update service for antivirus software.

Installation:  Use the fields in the Installation tab to specify installation properties of 
the application.

Installation type
You must click one of the following options from the menu:

• Optional - Installation of the application is optional.

• Recommended - Installation of the application is optional.  In the SDA-
Installer window, the application is selected by default the first time SDA-
Installer runs.  The user must deselect the application to avoid installing 
it.

• Required - The application is to be installed during the auto-installation 
portion of the SDA-Installer. The Required setting needs no user inter-
vention.

The Optional and Recommended settings require that the user manually 
select the application.

Installation sequence
Use this menu to assign the application an installation priority relative to other 
applications that are being installed.  The installation sequence begins with 1, 
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the highest priority and continues to Don’t care. Applications that you assign 
the same priority are installed in random order relative to each other. 

Computer restart required
Select this check box if the computer must restart to complete the installation 
of the application.  This selection applies only to applications that are installed 
during the optional-installation portion of the SDA-Installer.  When installation 
of the optional applications is complete, SDA prompts the user to restart the 
computer. 

SDA Version 1.2 installs both Common and business group applications together, fol-
lowing a single sequence (if a sequence is designated).

Image
Use the following menu options to manipulate the SDA image that you bundle into the 
workspace.

Preview
Click this option to ensure that you have the correct information in the workspace to 
create the SDA image that you want.  The preview SDA image simulates the installa-
tion of applications through the SDA-Installer.

Previewing the image does not actually install any applications but instead simulates 
the installation by showing which applications will be installed for a selected business 
group.

Build
Click this option to store the SDA image files in a build directory on your system.

Select the check box option Click here to not copy any of the installation (setup) 
files to extract only the SDA-Installer program to the SDA Image directory without 
copying any of the installation files.

Note: To ensure that you have the correct information in the workspace to create the 
SDA image that you want, create a preview SDA image before you build the 
SDA image.

Report
Click this option to generate a printable, formatted report containing a list of the appli-
cation sets within a workspace.  

The report categorizes the applications by language. The report contains the following 
default columns:

• Application name

• Group name

• Subgroup name

• Operating system

You can customize the report by selecting which application properties to include in 
the report.  For example, you can add the location of the installation files and the ver-
sion for each application.
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After you select the additional fields to include in the report, click OK to generate the 
report file in a standard ASCII format.

Image properties
Click this option to define what happens with the SDA image after the required appli-
cations are installed on a user’s system. 

Image:  Use the options in the Image tab to specify what happens to the SDA image 
after the auto-installation portion of the SDA-Installer installs required applications.

SDA-Installer
Use the settings in this section to specify what you want to happen to the 
SDA-Installer.
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If you choose to leave the SDA-Installer program on the user’s hard disk, you 
can select from the following options:

• Run the SDA-Installer program after the required applications are 
installed.

• Add a shortcut to the Windows Start Menu for the end user to start at 
another time.

• Add a shortcut to the desktop for the end user to start at another time.

Note: You can select one or more of these options.

SDA image
Use the settings in this section to specify what you want to happen to the SDA 
image after the auto-installation portion of the SDA-Installer installs the 
required applications. You can select only one setting.

The following diagram illustrates the options that the Image window contains.

If you select the Delete the entire SDA image and direct SDA-Installer to 
another SDA image option, you have the option to enter a username and 
password at the Remote server username and Remote server password 
fields. 

SDA-Installer option Result

Remove the SDA-Installer program 
from the user’s hard disk.

Disables the other options in this window.

Leave the SDA-Installer program on 
the user’s hard disk.

Enables the SDA image options in this 
window.

SDA image option Result

Leave only required and optional 
applications in either the Common 
group or the user’s selected 
business group.

Enables users to either reinstall one of their 
required applications (in case the installation 
ever becomes damaged) or install an optional 
or recommended application.

Leave only optional applications 
included in either  the Common 
group or the user’s selected 
business group.  

Deletes all the required applications already 
installed.  The user can install only the 
remaining optional or recommended 
applications in either the Common group or 
the user’s selected group. 

Delete the entire SDA image and 
direct SDA-Installer to another 
SDA image, which can be on the 
user’s hard disk or on a network 
drive. 

Specifies an alternative SDA image that 
contains another application set.  This 
application set should have optional 
applications that the user can choose from.  
Required applications in the alternative 
application set will not be automatically 
installed.
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The username and password you enter here allow the user to install the appli-
cations without having to enter such information. If you leave these fields 
blank, the user will have to enter that information when installing the pro-
grams.

Updates:  You can provide updated versions of applications for multiple SDA images 
on a file server.  When the SDA-Installer installs the user’s application set, it can look 
for a more recent version of each application in another SDA image (usually on a 
remote file server) before installing each application.  If a more recent version of an 
application is located, SDA-installer installs that version instead of the version that is 
in the SDA image on the user’s hard disk. The SDA image on the user’s hard disk still 
determines the application set that is installed.

The following illustrates how an administrator can designate an updated SDA image:
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If you enter a location in the Location of an updated SDA image (on a file server), you 
have the option to enter a username and password at the Remote server username 
and Remote server password fields. 

The username and password you enter here allow the user to install the latest appli-
cations without having to enter such information. If you leave these fields blank, the 
user will have to enter that information when installing the programs.

For each installed application, the SDA-Installer compares the version number of the 
application on the local hard disk with the version number of the application on the 
updated SDA image to determine which version is installed.  If the version on the 
updated SDA image is a more recent version, the user will be prompted to verify that 
the newer version should be installed.  For example, version 2.01 is more recent than 
version 1.02. 

The version number for each application is specified on the Properties tab for the 
application.  Version numbers must be in the form of a numeric value, such as 1.0, 
1.01, or 4.62.

In addition, the version check is performed on an application only if the SDA-Installer 
finds an application in the updated SDA image with the exact same name, group, lan-
guage, and operating system.

Graphics:  Use this field to change the graphic at the top of the left pane of the SDA-
Installer window.  In the Header graphic field, browse to the graphic file.  This file 
must be a transparent .GIF image and not more than 140 x 140 pixels.
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The field in this tab is applicable only if you leave the SDA image on the user’s hard 
disk after the auto-installation.  (To specify what you want to happen to the SDA image 
after the auto-installation, click Image → Properties and click the Image tab.)

Passwords:  You can provide a password to be used for applications that you choose 
to encrypt (applications with the Encrypt the installation files check box selected on 
the Source tab in the Insert application window).

You can specify one password per SDA image.  To set this password, click Image → 
Properties and click the Password tab.

SDA-Installer settings:  Use these settings to enable or disable functions in the 
SDA-Installer program.  You must specify the SDA image that is to be left on the 
user’s hard disk for these settings to be relevant. (To specify what you want to happen 
to the SDA image, click Image�→�Properties and click the Image tab.)

Change settings
Click this option to change settings (SDA image location, language, flyover 
text, and display of the Custom installation check box) in the optional-instal-
lation portion of the SDA-Installer.

Display flyover text
Click this option to display a description of each application when the user 
positions the cursor over the application name.

If you click the Change settings option, the user can change the setting in 
the SDA-Installer window to control the way the description is displayed.  (To 
create flyover text for an application, click the Properties tab in the Insert 
application window.)

Make the custom-installation option available
Click this option to make the custom-installation option available to users.

If you click this option, a Custom installation check box is displayed with 
each application for which a custom installation command file has been spec-
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ified.  If you click the Change settings option, this option sets the default and 
the user can change the setting in the SDA-Installer window to show or hide 
the Custom installation check box.

Translation
You can translate the group names and user-profile field names into other languages.  
The SDA-Administrator extracts these text items into files (.INI) that you can send to 
be translated.

Send
You can extract the text from the SDA image file and save it to a directory on your 
hard disk.

Receive
After you have translated the text, the SDA-Administrator integrates (receives) them 
back into the workspace.

Window
These options are similar to the window options in many Microsoft Windows applica-
tions:

Cascade
Arrange the windows so that they overlap.

Tile Arrange the windows as non-overlapping tiles either vertically or horizontally.

Starting the SDA-Installer on the user’s computer
You can use any of the following ways to run the SDA-Installer on a user’s computer 
after you deploy the image.  SDA-Installer runs after the computer is restarted.

Create an entry in the RunOnce registry key
To run SDA-Installer automatically when the computer is started, add SDA-Installer to 
the RunOnce registry key.  You can use .REG files like the following examples to add 
the appropriate registry key:

• For Windows 95, Windows 98, Windows NT 4.0, and Millennium Edition:

REGEDIT4

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
CurrentVersion\RunOnce]

"Run SDA-Installer"="d:\sdaimage\SWSELECT.EXE

• For Windows 2000:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\
CurrentVersion\RunOnce]

"Run SDA-Installer"="d:\sdaimage\SWSELECT.EXE"

In these examples, d:\sdaimage is the drive and directory where the SDA image is 
located.

Create a shortcut in the Startup folder
You can run the SDA-Installer automatically the first time the computer is started if you 
create a shortcut in the Startup folder.  In the Startup folder on the user’s computer, 
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create a shortcut to a batch file or program that starts the SDA-Installer and then 
deletes the shortcut from the folder. 

Allow the user to run SDA-Installer
You can allow the user to run the SDA-Installer on demand.  Create a shortcut to the 
SDA-Installer on the Windows desktop or in the Start menu that launches 
SWSELECT.EXE.

Running the SDA-Installer with Windows NT
The installation processes for many applications include updating Microsoft Windows 
resources, such as the registry and system directories; therefore, the user account on 
a user’s computer must have administrator privileges to enable applications to be 
installed on the computer through the SDA-Installer.  If you do not want the user 
account to have administrator privileges, you must use an alternative method of pro-
viding the necessary access privileges to the SDA-Installer.

The Windows NT Zero Administration Kit (ZAK) contains scripts and batch files that 
Windows NT can use to call other programs to apply registry changes and start pro-
grams such as the SDA-Installer.

See the Microsoft Web site (www.microsoft.com) for more information about ZAK and 
how to integrate programs to run automatically at the end of Windows NT Setup.  

Tasks
The following procedures demonstrate how to use the Software Delivery Assistant.

Creating a new workspace
To create a new workspace, complete the following steps:

1. From the Software Delivery Assistant – Administrator window, click Create a new 
workspace, and click OK. 

If the Software Delivery Assistant – Administrator window is hidden, click File →�
New.  The workspace-creation wizard assists you in setting up the new SDA 
workspace.

2. Type the name of the new workspace, and click Next.

3. Select the languages that you want the SDA image to support, and click Next.
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4. Click the Add button to compile the groups that you want the SDA image to sup-
port, and click Next.

5. Click the Add button to compile the user-profile fields that you want users to com-
plete the first time they use the SDA-Installer, and click Finish.  

You can now edit the workspace and add applications to each group.

Specifying groups
To add a group, complete the following steps:

1. Click the language that you want to add to the group.

2. Click Insert →�Group, or right-click the language and click Insert group.

3. Type the name of the group, and press Enter.

Repeat this step for each group.

4. When you have listed all the groups that you want, click Next.

To delete a group from the list, click the group, and click Remove.  To change the 
name of a group in the list, click the group and click Edit. Type the new name and 
press Enter.

Specifying user-profile fields
To add a user-profile field, complete the following steps:

1. Click the group from the language into which you want to add a user-profile field.  

2. Click Insert → Profile field, or right-click and click Insert profile field. 

The User profile window opens.

3. In the Name field, type the name of the user-profile field that you want to add.

4. In the Size field, type the maximum number of characters that the field can 
accommodate. 

The system truncates entries that exceed the specified size.

5. If you want to require the user to complete the field, select the Required field 
check box.

If you do not want to limit the valid entries for the field, click OK and go to step 8.

If you want to restrict user input to a list of valid entries, click Add to create a list of 
valid entries for the user.

6. Type an entry in the Valid set window, and press Enter.  

For each additional entry, click Add, type the entry, and press Enter.  When you 
have listed all the entries that you want, click OK.

7. To delete an entry from the list, click the entry and click Remove.  To change an 
entry, click the entry, and click Edit. Then type the new entry and press Enter.

8. For each additional user-profile field, repeat steps 1 through 6.

You can now edit the workspace and add applications to each group.

Opening an existing workspace
To open an existing workspace, complete the following steps:

1. If you are starting SDA, click Open an existing workspace from the Software 
Delivery Assistant – Administrator window and click OK.
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If the Software Delivery Assistant - Administrator window is not open, click File → 
Open.

2. Browse to the workspace file (.SSW) that you want to open.  

3. Double-click the file, or click the file and click Open.

Importing a workspace from an existing SDA image
To import a workspace from an existing SDA image, complete the following steps:

1. From the Software Delivery Assistant – Administrator window, click Import a 
workspace from an existing image and click OK.

If the Software Delivery Assistant – Administrator window is not open, click File →�
Import.

2. Type the descriptive name (not the file name) of the workspace that you want to 
create from the workspace that you are importing.

3. Type or browse to the drive and directory where the SDA image is located (where 
the SWSELECT.EXE file and the DATA subdirectory are located), and click OK.

Adding languages to a workspace
To add languages to the active workspace, complete the following steps:

1. In the left pane of the SDA-Administrator window, click the workspace name.

2. Click Insert.

3. Click Language.  The Insert language window opens.

4. Select each language that you want to add to the workspace, and click OK.  

Each language contains the Common group and a set of user-profile fields.

Adding groups to a language
To add a group to a language in the active workspace, complete the following steps:

1. In the left pane of the SDA-Administrator window, click the language to which you 
want to add a group.

2. Click Insert → Group.  The Insert group window opens.

3. Type the name of the new group and click OK.

Adding subgroups to a group
To add a subgroup to a group, complete the following steps:
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1. In the left pane of the SDA-Administrator window, click the group to which you 
want to add a subgroup.

2. Click Insert → Subgroup.  The Insert subgroup window opens.

3. Type the name of the new group and click OK.

Adding applications to a group or subgroup
To add an application to a group or a subgroup in the active workspace, complete the 
following steps:

1. In the left pane of the SDA-Administrator window, within the applicable language, 
select the group to which you want to add an application.

2. Click Insert → Application.  The Insert application window opens.

3. Specify the necessary information about the application in each of the tabs in the 
Insert application window. 

4. When you are finished specifying the necessary information on each tab, click 
OK.

Adding user-profile fields
To add a user-profile field, complete the following steps:

1. In the left pane of the SDA-Administrator window, under the language for which 
you want to add a user-profile field, click Profile. The current user-profile fields 
are displayed in the right pane of the SDA-Administrator window.

2. Click Insert →�Profile. The User profile window opens.

You can also right-click Profile and click Insert profile field.  

3. In the Name field, type the name of the user-profile field that you want to add.

4. In the Size field, type the maximum number of characters that the field accommo-
dates.  SDA truncates entries that are too long.

5. If you do not want to limit the valid entries for the field, click OK to add the new 
user-profile field and go to step 9.

If you want to limit the valid entries for the field, select the Required field check 
box if you want to require the user to complete the field.

6. To create a list of valid entries, click the Add button.

7. Type an entry in the Valid set window and press Enter.  

8. Repeat steps 6 and 7 for each additional entry.  

To delete an entry from the list, click the entry and click Remove.  To change an 
entry, click the entry and click Edit.  Then type the new entry and press Enter.  

9. When you have listed all the entries, click OK.

Creating a preview SDA image
To create a preview SDA image from the active workspace, complete the following 
steps:

1. Click Image →�Preview.

2. From the Language menu, click the language that you want to preview.

3. From the Operating system menu, click the operating system that you want to 
preview, and click OK.  

The SDA-Administrator builds the preview SDA image and starts the SDA-
Installer.

4. In the SDA-Installer, complete the user-profile fields, and click OK.  
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The SDA-Installer simulates installation of the applications in the Common group 
and the group that you selected in the user profile. 

Creating a new SDA image from an existing SDA image
To create a new SDA image from an existing SDA image, complete the following 
steps:

1. Click File →�Import to import a workspace from the existing SDA image. 

2. Type the name for the new SDA image in the New workspace name field.

3. Type the drive and directory in the Image location field. You can also click the 
Browse button and manually navigate to the directory.

4. Click OK.

Updating multiple applications
To update multiple applications, complete the following steps.

1. Click Find →�Update. The Find and update application window opens.

2. Click the field type to search. 

The search field you select affects the value on which the engine searches. In 
some search fields, you can perform an exact search by selecting the Exact 
match only check box.

3. Enter the text you want to search for in the Value to search for field.

4. Click the Next button. 

The Find and update applications window displays the search results in the 
Results window.

5. Click the search result that you want to update.

6. Select the type of update you are making in the Field to be updated menu.

7. Enter or click the updated information in the New Value field. What you selected 
in the Field to be updated menu determines your entry.

8. Click the Update Selection button to update only the applications that are 
selected, or click the Update All Results button to update all applications in the 
results list.  

9. Click Finish to complete the updates.
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Disabling the optional-installation portion of the SDA-Installer
To delete the SDA-Installer image from the user’s hard disk, which disables the 
optional-installation portion of the SDA-Installer, complete the following steps:

1. Click Image →�Properties. 

The Image properties window opens.

2. Click the Image tab.

3. Click Remove SDA-Installer from the user’s harddrive and click OK.

Translating group names and user-profile field names
Translation can be broken down into the following tasks:

• Extracting text for translation

• Integrating translated text

Extracting text for translation
To extract the text from the active workspace, complete the following steps:

1. Click Translation →�Send. 

The Send window opens.

2. Type the drive and directory where you want to store the files and click OK.  You 
can also navigate to this location by clicking the Browse button.

The information panel displays the results of the text extraction.

Integrating translated text
To integrate the translated text into the active workspace, complete the following 
steps:

1. Click Translation →�Receive. 

The Receive window opens.

2. Type the drive and directory where you want to store the files and click OK.  You 
can also navigate to this location by clicking the Browse button.

The information panel displays the results of the text extraction.
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